Basic Router Configuration

This chapter provides procedures for configuring the basic parameters of your Cisco router, including global parameter settings, routing protocols, interfaces, and command-line access. It also describes the default configuration on startup.


Note Individual router models may not support every feature described in this guide. Features that are not supported by a particular router are indicated whenever possible.



Note For instructions on how to configure the 4G LTE features on your Cisco 819 ISR, see the Cisco 4G LTE Software Installation Guide.


This chapter includes configuration examples and verification steps, as available.

For complete information on how to access global configuration mode, see the “Entering Global Configuration Mode” section.

Interface Ports

Table 5-1 lists the interfaces that are supported for each router and their associated port labels on the equipment.

 

Table 5-1 Supported Interfaces and Associated Port Labels by Cisco Router

Router
Interface
Port Label

Cisco 819 Router

4-port Fast Ethernet LAN

LAN, FE0–FE3

Gigabit Ethernet WAN

GE WAN 0

Serial

Serial

Mini USB for 3G port Provisioning

3G RSVD

Console/Aux port

CON/AUX


Note There are two labels for the associated antennas with the labels: Main and DIV/GPS.


Default Configuration

When you first boot up your Cisco router, some basic configuration has already been performed. All of the LAN and WAN interfaces have been created, console and vty ports are configured, and the inside interface for Network Address Translation (NAT) has been assigned. Use the show running-config command to view the initial configuration, as shown in the following example for a Cisco 819 ISR:

Router# show running
Building configuration...
 
Current configuration : 977 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
no aaa new-model
ip source-route
ip cef
 
no ipv6 cef
license udi pid CISCO819G-G-K9 sn FHK1429768Q
controller Cellular 0
interface Cellular0
no ip address
encapsulation ppp
interface Ethernet-wan0
no ip address
shutdown
duplex auto
speed auto
interface FastEthernet0
interface FastEthernet1
interface FastEthernet2
interface FastEthernet3
interface Serial0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Vlan1
no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
 
logging esm config
 
control-plane
line con 0
no modem enable
line aux 0
line 3
no exec
line 7
stopbits 1
speed 115200
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end
 

Information Needed for Configuration

You need to gather some or all of the following information, depending on your planned network scenario, before configuring your network:

  • If you are setting up an Internet connection, gather the following information:

PPP client name that is assigned as your login name

PPP authentication type: Challenge Handshake Authentication Protocol (CHAP) or Password Authentication Protocol (PAP)

PPP password to access your Internet service provider (ISP) account

DNS server IP address and default gateways

  • If you are setting up a connection to a corporate network, you and the network administrator must generate and share the following information for the WAN interfaces of the routers:

PPP authentication type: CHAP or PAP

PPP client name to access the router

PPP password to access the router

  • If you are setting up IP routing:

Generate the addressing scheme for your IP network.

  • If you are setting up the serial interface:

Mode of operation (sync, async, bisync)

Clock rate depending on the mode

IP address depending on the mode

  • If you are setting up 3G:

You must have service availability on the Cisco 819 ISR from a carrier, and you must have network coverage where your router will be physically placed. For a complete list of supported carriers, see the data sheet at Cisco 3G Wireless Connectivity Solutions.

You must subscribe to a service plan with a wireless service provider and obtain a SIM card.

You must install the SIM card before configuring the 3G Cisco 819 ISR. For instructions on how to install the SIM card, see Cisco 800 Series RoutersConfiguring Cisco EHWIC and 880G for 3.7G (HSPA+)/3.5G (HSPA).

  • You must install the required antennas before you configure the 3G for Cisco 819 ISR. See the following URLs for instructions on how to install the antennas:

3G-ANTM1919D—See Cisco Multiband Swivel-Mount Dipole Antenna (3G-ANTM1919D).

3G-ANTM1916-CM—See Cisco Multiband Omnidirectional Ceiling Mount Antenna (3G-ANTM1916-CM).

3G-AE015-R (Antenna Extension)—See Cisco Single-Port Antenna Stand for Multiband TNC Male-Terminated Portable Antenna (Cisco 3G-AE015-R).

3G-AE010-R (Antenna Extension)—See Cisco Single-Port Antenna Stand for Multiband TNC Male-Terminated Portable Antenna (Cisco 3G-AE015-R). This document applies to both 3G-AE015-R and 3G-AE010-R. The only difference between these two products is the length of the cable.

3G-ANTM-OUT-OM—See Cisco 3G Omnidirectional Outdoor Antenna (3G-ANTM-OUT-OM).

3G-ANTM-OUT-LP—See Cisco Multiband Omnidirectional Panel-Mount Antenna (3G-ANTM-OUT-LP).

3G-ACC-OUT-LA—See Cisco 3G Lightning Arrestor (3G-ACC-OUT-LA).

4G-ANTM-OM-CM—See Cisco 4G Indoor Ceiling-Mount Omnidirectional Antenna (4G-ANTM-OM-CM).

After you have collected the appropriate information, you can perform a full configuration on your router, beginning with the tasks in the “Configuring Command-Line Access” section.

To obtain or change software licenses:

Configuring Command-Line Access

To configure parameters to control access to the router, perform the following steps, beginning in global configuration mode:

SUMMARY STEPS

1. line [aux | console | tty | vty] line-number

2. password password

3. login

4. exec-timeout minutes [ seconds ]

5. line [aux | console | tty | vty] line-number

6. password password

7. login

8. end

DETAILED STEPS

Command
Purpose

Step 1

line [ aux | console | tty | vty ] line-number

Example:

Router(config)# line console 0
Router(config-line)#
 

Enters line configuration mode and specifies the type of line.

This example specifies a console terminal for access.

Step 2

password password

Example:

Router(config)# password 5dr4Hepw3
Router(config-line)#
 

Specifies a unique password for the console terminal line.

Step 3

login

Example:

Router(config-line)# login
Router(config-line)#
 

Enables password checking at terminal session login.

Step 4

exec-timeout minutes [seconds]

Example:

Router(config-line)# exec-timeout 5 30
Router(config-line)#
 

Sets the interval that the EXEC command interpreter waits until user input is detected. The default is 10 minutes. Optionally, add seconds to the interval value.

This example shows a timeout of 5 minutes and 30 seconds. Entering a timeout of 0 0 specifies never to time out.

Step 5

line [ aux | console | tty | vty ] line-number

Example:

Router(config-line)# line vty 0 4
Router(config-line)#
 

Specifies a virtual terminal for remote console access.

Step 6

password password

Example:

Router(config-line)# password aldf2ad1
Router(config-line)#
 

Specifies a unique password for the virtual terminal line.

Step 7

login

Example:

Router(config-line)# login
Router(config-line)#
 

Enables password checking at the virtual terminal session login.

Step 8

end

Example:

Router(config-line)# end
Router#
 

Exits line configuration mode and returns to privileged EXEC mode.

Example

The following configuration shows the command-line access commands.

You do not need to input the commands marked “default.” These commands appear automatically in the configuration file generated when you use the show running-config command.

!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
 

Configuring Global Parameters

To configure selected global parameters for your router, perform these steps:

SUMMARY STEPS

1. configure terminal

2. hostname name

3. enable secret password

4. no ip domain-lookup

DETAILED STEPS

Command
Purpose

Step 1

configure terminal

Example:

Router> enable

Router# configure terminal

Router(config)#

Enters global configuration mode when using the console port.

If you are connecting to the router using a remote terminal, use the following:

telnet router name or address

Login: login id

Password: *********

Router> enable

Step 2

hostname name

Example:

Router(config)# hostname Router

Router(config)#

Specifies the name for the router.

Step 3

enable secret password

Example:

Router(config)# enable secret cr1ny5ho

Router(config)#

Specifies an encrypted password to prevent unauthorized access to the router.

Step 4

no ip domain-lookup

Example:

Router(config)# no ip domain-lookup Router(config)#

Disables the router from translating unfamiliar words (typos) into IP addresses.

Configuring WAN Interfaces

Configure the WAN interface for your router using one of the following as appropriate:

Configuring a Gigabit Ethernet WAN Interface

To configure the Ethernet interface on a Cisco 819 ISR, perform these steps, beginning in global configuration mode:

SUMMARY STEPS

1. interface type number

2. ip address ip-address mask

3. no shutdown

4. exit

DETAILED STEPS

Command
Purpose

Step 1

interface type number

Example:

Router(config)# interface gigabitethernet 0
Router(config-if)#
 

Enters the configuration mode for a Gigabit Ethernet WAN interface on the router.

Step 2

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.12.2 255.255.255.0
Router(config-if)#
 

Sets the IP address and subnet mask for the specified Gigabit Ethernet interface.

Step 3

no shutdown

Example:

Router(config-if)# no shutdown
Router(config-if)#
 

Enables the Ethernet interface, changing its state from administratively down to administratively up.

Step 4

exit

Example:

Router(config-if)# exit
Router(config)#
 

Exits configuration mode for the Gigabit Ethernet interface and returns to global configuration mode.

Configuring the Cellular Wireless WAN Interface

The Cisco 819 ISRs provide a Third-Generation (3G) wireless interface for use over Global System for Mobile Communications (GSM) and code division multiple access (CDMA) networks. The interface is a 34-millimetre embedded mini express card.

Its primary application is WAN connectivity as a backup data link for critical data applications. However, the 3G wireless interface can also function as the router’s primary WAN connection.

To configure the 3G cellular wireless interface, follow these guidelines and procedures:

Prerequisites for Configuring the 3G Wireless Interface

The following are prerequisites to configuring the 3G wireless interface:

  • You must have wireless service from a carrier, and you must have network coverage where your router will be physically placed. For a complete list of supported carriers, see the data sheet at:

www.cisco.com/go/m2m

Username

Password

Access point name (APN)

  • To configure your CDMA (CDMA only) data profile for manual activation, you need the following information from your service provider:

Master Subsidy Lock (MSL) number

Mobile Directory number (MDN)

Mobile Station Identifier (MSID)

Electronic Serial Number (ESN)

  • Check the LED located on the front panel of the router for signal strength and other indications. Table 2-1 describes the 3G LEDs for the Cisco 819 ISR.

 

Restrictions for Configuring the Cellular Wireless Interface

The following restrictions apply to configuring the Cisco 3G wireless interface:

  • A data connection can be originated only by the 3G wireless interface. Remote dial-in is not supported.
  • Because of the shared nature of wireless communications, the experienced throughput varies depending on the number of active users or the amount of congestion in a given network.
  • Cellular networks have higher latency than wired networks. Latency rates depend on the technology and carrier. Latency may be higher when there is network congestion.
  • VoIP is currently not supported.
  • Any restrictions that are part of the terms of service from your carrier also apply to the Cisco 3G wireless interface.
  • Inserting a different type of modem from what was previously removed requires configuration changes and you must reload the system.

Data Account Provisioning


Note To provision your modem, you must have an active wireless account with a service provider. A SIM card must be installed in a GSM 3G wireless card.


To provision your data account, follow these procedures:

Verifying Signal Strength and Service Availability

To verify the signal strength and service availability on your modem, use the following commands in privileged EXEC mode.

SUMMARY STEPS

1. show cellular 0 network

2. show cellular 0 hardware

3. show cellular 0 connection

4. show cellular 0 gps

5. show cellular 0 radio

6. show cellular 0 profile

7. show cellular 0 security

8. show cellular 0 sms

9. show cellular 0 all

DETAILED STEPS

 

Command or Action
Purpose

Step 1

show cellular 0 network
 

Router# show cellular 0 network

Displays information about the carrier network, cell site, and available service.

Step 2

show cellular 0 hardware
 
Router# show cellular 0 hardware

Displays the cellular modem hardware information.

Step 3

show cellular 0 connection
 
Router# show cellular 0 connection

Displays the current active connection state and data statistics.

Step 4

show cellular 0 gps
 
Router# show cellular 0 gps

Displays the cellular gps information.

Step 5

show cellular 0 radio
 

Router# show cellular 0 radio

Shows the radio signal strength.

Note The RSSI should be better than –90 dBm for steady and reliable connection.

Step 6

show cellular 0 profile
 

Router# show cellular 0 profile

Shows information about the modem data profiles created.

Step 7

show cellular 0 security
 

Router# show cellular 0 security

Shows the security information for the modem, such as SIM and modem lock status.

Step 8

show cellular 0 sms
 
Router# show cellular 0 sms

Displays the cellular sms information.

Step 9

show cellular 0 all
 

Router# show cellular 0 all

Shows consolidated information about the modem, such as the profiles that were created, the radio signal strength, the network security, and so on.

Configuring a GSM Modem Data Profile

To configure or create a new modem data profile, enter the following command in privileged EXEC mode.

SUMMARY STEPS

1. cellular 0 gsm profile create <profile number> <apn> <authentication> <username> <password> ipv4

DETAILED STEPS

Command or Action
Purpose

Step 1

cellular 0 gsm profile create <profile number> <apn> <authentication> <username> <password> ipv4
 

Router# gsm profile create 2 <apn-name> chap username password ipv4

Creates a new modem data profile. See Table 5-2 for details about the command parameters.

 

Table 5-2 lists the modem data profile parameters.

 

Table 5-2 Modem Data Profile Parameters

profile number

Number for the profile that you are creating. You can create up to 16 profiles.

apn

Access point name. You must get this information from the service provider.

authentication

Type of authentication, for example, CHAP, PAP.

Username

Username provided by your service provider.

Password

Password provided by your service provider.

CDMA Modem Activation and Provisioning

Activation procedures may differ, depending upon your carrier. Consult your carrier and perform one of the following procedures as appropriate:

  • Manual activation
  • Activating using over-the-air service provisioning

The following table lists the activation and provisioning processes supported by different wireless carriers.

 

Table 5-3

Activation and Provisioning Process
Carrier

Manual Activation using MDN, MSID, MSL

Sprint

OTASP1 Activation

Verizon Wireless

IOTA2 for Data Profile refresh

Sprint

1.OTASP = Over the Air Service Provisioning.

2.IOTA = Internet Over the Air.

Manual Activation


Note You must have valid mobile directory number (MDN), mobile subsidy lock (MSL), and mobile station identifier (MSID) information from your carrier before you start this procedure.


To configure a modem profile manually, use the following command, beginning in EXEC mode:

cellular unit cdma activate manual mdn msid msl

Besides being activated, the modem data profile is provisioned through the Internet Over the Air (IOTA) process. The IOTA process is initiated automatically when you use the cellular unit cdma activate manual mdn msid msl command.

The following is a sample output from this command:

router# cellular 0 cdma activate manual 1234567890 1234567890 12345
NAM 0 will be configured and will become Active
Modem will be activated with following Parameters
MDN :1234567890; MSID :1234567890; SID :1234; NID 12:
Checking Current Activation Status
Modem activation status: Not Activated
Begin Activation
Account activation - Step 1 of 5
Account activation - Step 2 of 5
Account activation - Step 3 of 5
Account activation - Step 4 of 5
Account activation - Step 5 of 5
Secure Commit Result: Succeed
Done Configuring - Resetting the modem
The activation of the account is Complete
Waiting for modem to be ready to start IOTA
Beginning IOTA
router#
*Feb 6 23:29:08.459: IOTA Status Message Received. Event: IOTA Start, Result: SUCCESS
*Feb 6 23:29:08.459: Please wait till IOTA END message is received
*Feb 6 23:29:08.459: It can take up to 5 minutes
*Feb 6 23:29:27.951: OTA State = SPL unlock, Result = Success
*Feb 6 23:29:32.319: OTA State = Parameters committed to NVRAM, Result = Success
*Feb 6 23:29:40.999: Over the air provisioning complete; Result:Success
*Feb 6 23:29:41.679: IOTA Status Message Received. Event: IOTA End, Result: SUCCESS

 

The IOTA start and end must have “success” as the resulting output. If you receive an error message, you can run IOTA independently by using the cellular cdma activate iota command.

Your carrier may require periodic refreshes of the data profile. Use the following command to refresh the data profile:

cellular cdma activate iota

Activating with Over-the-Air Service Provisioning

To provision and activate your modem using Over-the-Air Service Provisioning (OTASP), use the following command, beginning in EXEC mode.

router # cellular 0 cdma activate otasp phone_number


Note You need to obtain the phone number for use with this command from your carrier. The standard OTASP calling number is *22899.


The following is a sample output from this command:

router# cellular 0 cdma activate otasp *22899
Beginning OTASP activation
OTASP number is *22899
819H#
OTA State = SPL unlock, Result = Success
router#
OTA State = PRL downloaded, Result = Success
OTA State = Profile downloaded, Result = Success
OTA State = MDN downloaded, Result = Success
OTA State = Parameters committed to NVRAM, Result = Success
Over the air provisioning complete; Result:Success

Configuring a Cellular Interface

To configure the cellular interface, enter the following commands, beginning in privileged EXEC mode.

SUMMARY STEPS

1. configure terminal

2. interface cellular 0

3. encapsulation ppp

4. ppp chap hostname hostname

5. ppp chap password 0 password

6. asynchronous mode interactiv e

7. ip address negotiated


Note The PPP Challenge Handshake Authentication Protocol (CHAP) authentication parameters that you use in this procedure must be the same as the username and password provided by your carrier and configured only under the GSM profile. CDMA does not require a username or password.


DETAILED STEPS

 

Command or Action
Purpose

Step 1

configure terminal
 

Router# configure terminal

Enters global configuration mode from the terminal.

Step 2

interface cellular 0
 

Router (config)# interface cellular 0

Specifies the cellular interface.

Step 3

encapsulation ppp
 

Router (config-if)# encapsulation ppp

Specifies PPP encapsulation for an interface configured for dedicated asynchronous mode or dial-on-demand routing (DDR).

Step 4

ppp chap hostname hostname
 

Router (config-if)# ppp chap hostname cisco@wwan.ccs

Defines an interface-specific Challenge Handshake Authentication Protocol (CHAP) hostname. This must match the username given by the carrier. Applies to GSM only.

Step 5

ppp chap password 0 password
 

Router (config-if)# ppp chap password 0 cisco

Defines an interface-specific CHAP password. This must match the password given by the carrier.

Step 6

asynchronous mode interactive
 

Router (config-if)# asynchronous mode interactive

Returns a line from dedicated asynchronous network mode to interactive mode, enabling the slip and ppp commands in privileged EXEC mode.

Step 7

ip address negotiated
 

Router (config-if)# ip address negotiated

Specifies that the IP address for a particular interface is obtained via PPP and IPCP address negotiation.


Note When the cellular interface requires a static IP address, the address may be configured as ip address negotiated. Through IP Control Protocol (IPCP), the network ensures that the correct static IP address is allocated to the device. If a tunnel interface is configured with the ip address unnumbered <cellular interface> command, the actual static IP address must be configured under the cellular interface, in place of ip address negotiated. For a sample cellular interface configuration, see the “Basic Cellular Interface Configuration” section.


Configuring DDR

Perform these steps to configure dial-on-demand routing (DDR) for the cellular interface.

SUMMARY STEPS

1. configure terminal

2. interface cellular 0

3. dialer in-band

4. dialer idle-timeout seconds

5. dialer string string

6. dialer group number

7. exit

8. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

9. ip access-list < access list number> permit < ip source address >

10. line 3

11. script dialer <regexp>

12. exit

13. chat-script <script name> ”” “ATDT*99*<profile number>#” TIMEOUT <timeout value> CONNECT
or
chat-script <script name> "" "ATDT*777*<profile number>#" TIMEOUT <timeout value> CONNECT

14. interface cellular 0

15. dialer string < string>

DETAILED STEPS

 

Command or Action
Purpose

Step 1

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 2

interface cellular 0

 

Router (config)# interface cellular 0

Specifies the cellular interface.

Step 3

dialer in-band

 

Router (config-if)# dialer in-band

Enables DDR and configures the specified serial interface for in-band dialing.

Step 4

dialer idle-timeout seconds

 

Router (config-if)# dialer idle-timeout 30

Specifies the duration of idle time, in seconds, after which a line is disconnected.

Step 5

dialer string string

 

Router (config-if)# dialer string gsm

Specifies the number or string to dial. Use the name of the chat script here.

Step 6

dialer-group number

 

Router (config-if)# dialer-group 1

Specifies the number of the dialer access group to which a specific interface belongs.

Step 7

exit

 

Router (config-if)# exit

Enters the global configuration mode.

Step 8

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

 

Router (config)# dialer-list 1 protocol ip list 1

Creates a dialer list for traffic of interest and permits access to an entire protocol.

Step 9

ip access-list <access list number> permit <ip source address>

 

Router (config)# ip access list 1 permit any

Defines traffic of interest.

Step 10

line 3

 

Router (config-line)# line 3

Specifies the line configuration mode. It is always 3.

Step 11

script dialer <regexp>

 

Router (config-line)# script-dialer gsm

Specifies a default modem chat script.

Step 12

exit

 

Router (config-line)# exit

Exits line configuration mode.

Step 13

For GSM:

chat-script <script name> ”” “ATDT*99*<profile number>#” TIMEOUT <timeout value> CONNECT

 

For CDMA:

chat-script <script name> "" "ATDT*777*<profile number>#" TIMEOUT <timeout value> CONNECT

 

Router (config)# chat-script gsm "" "ATDT*98*2#" TIMEOUT 60 "CONNECT“

 

Configures this line for GSM.

Configures this line for CDMA.

Defines the Attention Dial Tone (ATDT) commands when the dialer is initiated.

Step 14

interface cellular 0

 

Router (config)# interface cellular 0

Specifies the cellular interface.

Step 15

dialer string string

 

Router (config)# dialer string gsm

Specifies the dialer script (defined using the chat script command).

Examples for Configuring Cellular Wireless Interfaces

This section provides the following configuration examples:

Basic Cellular Interface Configuration

The following example shows how to configure a gsm cellular interface to be used as a primary WAN connection. It is configured as the default route.

chat-script gsm "" "ATDT*98*2#" TIMEOUT 60 "CONNECT“
 
!
interface Cellular0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string gsm
dialer-group 1
async mode interactive
ppp chap hostname cisco@wwan.ccs
ppp chap password 0 cisco
ppp ipcp dns request
!
 
ip route 0.0.0.0 0.0.0.0 Cellular0
!
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 3
exec-timeout 0 0
script dialer gsm
login
modem InOut
 

The following example shows how to configure a cdma cellular interface to be used as a primary WAN connection. It is configured as the default route.

chat-script cdma "" "ATDT#777" TIMEOUT 60 "CONNECT“
 
!
interface Cellular0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string cdma
dialer-group 1
async mode interactive
ppp chap password 0 cisco
!
 
ip route 0.0.0.0 0.0.0.0 Cellular0
!
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 3
exec-timeout 0 0
script dialer cdma
login
modem InOut

Tunnel over Cellular Interface Configuration

The following example shows how to configure the static IP address when a tunnel interface is configured with the ip address unnumbered < cellular interface > command:

interface Tunnel2
ip unnumbered Cellular0
tunnel source Cellular0
tunnel destination 128.107.248.254
 
interface Cellular0
bandwidth receive 1400000
ip address 23.23.0.1 255.255.0.0
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 0
dialer string dial<carrier>
dialer-group 1
async mode interactive
no ppp lcp fast-start
ppp chap hostname <hostname> *** gsm only ***
ppp chap password 0 <password>
ppp ipcp dns request
 
! traffic of interest through the tunnel/cellular interface
ip route 10.10.0.0 255.255.0.0 Tunnel2

Configuration for 8705 modem

The following shows how to configure an HSPA+ modem:

chat-script hspa "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
 
interface Cellular0
ip address negotiated
encapsulation slip
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive
 
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer pool 1
dialer string hspa
dialer-group 1
 
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
access-list 1 permit any
dialer-list 1 protocol ip permit
line 3
script dialer hspa+
modem InOut
no exec
transport input all

Configuring Dual SIM for Cellular Networks

The Dual SIM feature implements auto-switch and failover between two cellular networks on a Cisco 819 ISR. This feature is enabled by default with SIM slot 0 being the primary slot and slot 1 being the secondary (failover) slot.


Note For instructions on how to configure the Dual SIM feature for 4G LTE cellular networks, see the Cisco 4G LTE Software Installation Guide.


You can configure the Dual SIM feature using the following commands:

Command
Syntax
Description

gsm failovertimer

gsm failovertimer <1-7>

Sets the failover timer in minutes.

gsm sim authenticate

gsm sim authenticate <0,7> <pin> slot <0-1>

Verifies the SIM CHV1 code.

gsm sim max-retry

gsm sim max-retry <0-65535>

Specifies the maximum number of failover retries. The default value is 10.

gsm sim primary slot

gsm sim primary slot <0-1>

Modifies the primary slot assignment.

gsm sim profile

gsm sim profile <1-16> slot <0-1>

Configures the SIM profile.

Note the following:

  • For auto-switch and failover to work, configure the SIM profile for slots 0 and 1 using the gsm sim profile command.
  • For auto-switch and failover to work, configure the chat script without a specific profile number.
  • If no SIM profile is configured, profile #1 is used by default.
  • If no GSM failover timer is configured, the default failover timeout is 2 minutes.
  • If no GSM SIM primary slot is configured, the default primary SIM is slot 0.

The following example shows you how to set the SIM switchover timeout period to 3 minutes:

router(config-controller)# gsm failovertimer 3

 

The following example shows you how to authenticate using an unencrypted pin:

router(config-controller)# gsm sim authenticate 0 1234 slot 0

The following example shows you how to set the maximum number of SIM switchover retries to 20:

router(config-controller)# gsm sim max-retry 20

The following example shows you how to set SIM slot 1 as the primary slot:

router(config-controller)# gsm sim primary slot 1

 

The following example shows you how to configure the SIM card in slot 0 to use profile 10:

router(config-controller)# gsm sim profile 10 slot 0

 

Perform the following commands to manually switch the SIM:

Command
Syntax
Description

cellular GSM SIM

cellular GSM SIM {lock | unlock}

Locks or unlocks the SIM.

gsm sim

cellular <unit> gsm sim [lock | unlock] <pin>

Locks or unlocks the gsm SIM.

gsm sim unblock

cellular <unit> gsm sim unblock <puk> <newpin>

Unblocks the gsm SIM.

gsm sim change-pin

cellular <unit> gsm sim change-pin <oldpin> <newpin>

Changes the PIN of the SIM.

gsm sim activate slot

cellular <unit> gsm sim activate slot <slot_no>

Activates the GSM SIM.

The following command forces the modem to connect to SIM1:

Router# cellular 0 gsm sim activate slot 1

Configuring Router for Image and Config Recovery Using Push Button

A push button feature is available on the Cisco 819 ISR. The reset button on the front panel of the router enables this feature.

Perform the following steps to use this feature:


Step 1 Unplug power.

Step 2 Press the reset button on the front panel of the router.

Step 3 Power up the sytem while holding down the reset button.

The system LED blinks four times indicating that the router has accepted the button push.


 

Using this button takes effect only during ROMMON initialization. During a warm reboot, pressing this button has no impact on performance. Table 5-4 shows the high level functionality when the button is pushed during ROMMON initialization.

 

Table 5-4 Push Button Functionality during ROMMON Initialization

ROMMON Behavior
IOS Behavior
  • Boots using default baud rate.
  • Performs auto-boot.
  • Loads the *.default image if available on compact flash

Note If no *.default image is available, the ROMMON will boot up with the first Cisco IOS image on flash.

Examples of names for default images: c800-universalk9-mz.SPA.default, c-800-universalk9_npe-mz.151T.default, image.default

Note You can only have one configuration file with *.cfg option. Having more than one file will result in uncertain operational behavior.

If the configuration named *.cfg is available in nvram storage or flash storage, IOS will perform a backup of the original configuration and will boot up using this configuration.

Use the show platform command to display the current bootup mode for the router. The following sections show sample outputs when the button is not pushed and when the button is pushed.

Output When Button Is Not Pushed: Example

router# show platform boot-record
 
Platform Config Boot Record :
============================
Configuration Register at boot time : 0x0
Reset Button Status at Boot Time : Not Pressed
Startup-config Backup Status at Boot: No Status
Startup-config(backup file)location : No Backup
Golden config file at location : No Recovery Detected
Config Recovery Status : No Status

Output When Button Is Pushed: Example

router# show platform boot-record
Platform Config Boot Record :
============================
Configuration Register at boot time : 0x0
Reset Button Status at Boot Time : Pressed
Startup-config Backup Status at Boot: Ok
Startup-config(backup file)location : flash:/startup.backup.19000716-225840-UTC
Golden config file at location : flash:/golden.cfg
Config Recovery Status : Ok

Push Button in WLAN AP

When the push button on the front panel is pressed, WLAN AP will perform both image and configuration recovery.

To perform image recovery, WLAN will go into the boot loader so that the user can download the image from the bootloader prompt.

To perform configuration recovery, WLAN AP will overwrite the contents of flash:/config.txt with the contents of flash:/cpconfig-ap802.cfg file if available in flash drive. Otherwise, flash:/config.txt will be deleted.

Configuring the Fast Ethernet LAN Interfaces

The Fast Ethernet LAN interfaces on your router are automatically configured as part of the default VLAN and are not configured with individual addresses. Access is provided through the VLAN. You may assign the interfaces to other VLANs if you want. For more information about creating VLANs, see the “Configuring the Ethernet Switches” section.

Configuring a Loopback Interface

The loopback interface acts as a placeholder for the static IP address and provides default routing information.

Perform these steps to configure a loopback interface, beginning in global configuration mode:

SUMMARY STEPS

1. interface type number

2. ip address ip-address mask

3. exit

DETAILED STEPS

Command
Purpose

Step 1

interface type number

Example:

Router(config)# interface Loopback 0
Router(config-if)#
 

Enters configuration mode for the loopback interface.

Step 2

ip address ip-address mask

Example:

Router(config-if)# ip address 10.108.1.1 255.255.255.0
Router(config-if)#
 

Sets the IP address and subnet mask for the loopback interface.

Step 3

exit

Example:

Router(config-if)# exit
Router(config)#
 

Exits configuration mode for the loopback interface and returns to global configuration mode.

Example

The loopback interface in this sample configuration is used to support Network Address Translation (NAT) on the virtual-template interface. This configuration example shows the loopback interface configured on the Fast Ethernet interface with an IP address of 200.200.100.1/24, which acts as a static IP address. The loopback interface points back to virtual-template1, which has a negotiated IP address.

!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
 

Verifying Configuration

To verify that you have properly configured the loopback interface, enter the show interface loopback command. You should see a verification output similar to the following example:

Router# show interface loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 

Another way to verify the loopback interface is to ping it:

Router# ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 
 

Configuring Static Routes

Static routes provide fixed routing paths through the network. They are manually configured on the router. If the network topology changes, the static route must be updated with a new route. Static routes are private routes unless they are redistributed by a routing protocol.

Follow these steps to configure static routes, beginning in global configuration mode.

SUMMARY STEPS

1. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

2. end

DETAILED STEPS

Command
Purpose

Step 1

ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

Example:

Router(config)# ip route 192.168.1.0 255.255.0.0 10.10.10.2
Router(config)#
 

Specifies the static route for the IP packets.

For details about this command and about additional parameters that can be set, see Cisco IOS IP Routing: Protocol-Independent Command Reference.

Step 2

end

Example:

Router(config)# end
Router#
 

Exits router configuration mode and enters privileged EXEC mode.

For general information on static routing, see the “Floating Static Routes” section.

Example

In the following configuration example, the static route sends out all IP packets with a destination IP address of 192.168.1.0 and a subnet mask of 255.255.255.0 on the Fast Ethernet interface to another device with an IP address of 10.10.10.2. Specifically, the packets are sent to the configured PVC.

You do not need to enter the command marked “(default).” This command appears automatically in the configuration file generated when you use the show running-config command.

!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
 

Verifying Configuration

To verify that you have properly configured static routing, enter the show ip route command and look for static routes signified by the “S.”

You should see a verification output similar to the following:

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
 

Configuring Dynamic Routes

In dynamic routing, the network protocol adjusts the path automatically, based on network traffic or topology. Changes in dynamic routes are shared with other routers in the network.

The Cisco routers can use IP routing protocols, such as Routing Information Protocol (RIP) or Enhanced Interior Gateway Routing Protocol (EIGRP), to learn routes dynamically. You can configure either of these routing protocols on your router.

Configuring Routing Information Protocol

To configure the RIP routing protocol on the router, perform these steps, beginning in global configuration mode:

SUMMARY STEPS

1. router rip

2. version {1 | 2}

3. network ip-address

4. no auto-summary

5. end

DETAILED STEPS

Command
Task

Step 1

router rip

Example:

Router> configure terminal
Router(config)# router rip
Router(config-router)#

Enters router configuration mode and enables RIP on the router.

Step 2

version { 1 | 2 }

Example:

Router(config-router)# version 2
Router(config-router)#

Specifies use of RIP version 1 or 2.

Step 3

network ip-address

Example:

Router(config-router)# network 192.168.1.1
Router(config-router)# network 10.10.7.1
Router(config-router)#

Specifies a list of networks on which RIP is to be applied, using the address of the network of each directly connected network.

Step 4

no auto-summary

Example:

Router(config-router)# no auto-summary
Router(config-router)#

Disables automatic summarization of subnet routes into network-level routes. This allows subprefix routing information to pass across classfull network boundaries.

Step 5

end

Example:

Router(config-router)# end
Router#

Exits router configuration mode and enters privileged EXEC mode.

For general information on RIP, see the “RIP” section.

Example

The following configuration example shows RIP version 2 enabled in IP network 10.0.0.0 and 192.168.1.0.

To see this configuration, use the show running-config command from privileged EXEC mode.

!
Router# show running-config
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
 

Verifying Configuration

To verify that you have properly configured RIP, enter the show ip route command and look for RIP routes signified by “R.” You should see a verification output like the following example:

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0
 

Configuring Enhanced Interior Gateway Routing Protocol

To configure Enhanced Interior Gateway Routing Protocol (EIGRP), perform these steps, beginning in global configuration mode:

SUMMARY STEPS

1. router eigrp as-number

2. network ip-address

3. end

DETAILED STEPS

Command
Purpose

Step 1

router eigrp as-number

Example:

Router(config)# router eigrp 109
Router(config)#
 

Enters router configuration mode and enables EIGRP on the router. The autonomous-system number identifies the route to other EIGRP routers and is used to tag the EIGRP information.

Step 2

network ip-address

Example:

Router(config)# network 192.145.1.0
Router(config)# network 10.10.12.115
Router(config)#
 

Specifies a list of networks on which EIGRP is to be applied, using the IP address of the network of directly connected networks.

Step 3

end

Example:

Router(config-router)# end
Router#
 

Exits router configuration mode and enters privileged EXEC mode.

For general information on EIGRP concept, see the “Enhanced IGRP” section.

Example

The following configuration example shows the EIGRP routing protocol enabled in IP networks 192.145.1.0 and 10.10.12.115. The EIGRP autonomous system number is 109.

To see this configuration, use the show running-config command, beginning in privileged EXEC mode.

!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!
 

Verifying Configuration

To verify that you have properly configured IP EIGRP, enter the show ip route command and look for EIGRP routes indicated by “D.” You should see a verification output similar to the following:

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0