Show Commands

This chapter describes the Cisco NX-OS quality of service (QoS) show commands.

show class-map type control-plane

To display control plane class map information, use the show class-map type control-plane command.

show class-map type control-plane [ class-map-name ]

 
Syntax Description

class-map-name

(Optional) Name of the control plane class map. The name is alphanumeric and case sensitive. The maximum length is 64 characters.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modification

5.1(3)N1(1)

This command was introduced.

 
Usage Guidelines

This command does not require a license.

Examples

This example shows how to display control plane class map information:

switch# show class-map type control-plane
 
class-map type control-plane match-any copp-system-class-arp
match protocol arp
 
class-map type control-plane match-any copp-system-class-bgp
match protocol bgp
 
class-map type control-plane match-any copp-system-class-bridging
match protocol bridging
 
class-map type control-plane match-any copp-system-class-cdp
match protocol cdp
 
class-map type control-plane match-any copp-system-class-default
match protocol default
 
<--Output truncated-->
switch#
 

 
Related Commands

Command
Description

class-map type control-plane

Creates or configures a control plane class map.

 

show class-map type network-qos

To display type network-qos class maps, use the show class-map type network-qos command.

show class-map type network-qos [ class-map-name ]

 
Syntax Description

class-map-name

Name of the class map. The name can be a maximum of 40 alphanumeric characters.

 
Command Default

Displays all type network-qos class maps if no class map name is specified.

 
Command Modes

Any command mode

 
Command History

Release
Modification

4.1(3)N1(1)

This command was introduced.

 
Usage Guidelines

If you do not specify the type, the command displays all the class maps configured in the system.

Examples

This example shows how to display all type network-qos class maps:

switch(config)# show class-map type network-qos
 
 
Type network-qos class-maps
==============================
 
class-map type network-qos s1
match qos-group 2
 
class-map type network-qos s2
match qos-group 3
 
class-map type network-qos s3
match qos-group 4
 
class-map type network-qos s4
match qos-group 5
 
class-map type network-qos cu1
match qos-group 2
 
class-map type network-qos cu2
match qos-group 3
 
class-map type network-qos cu3
match qos-group 4
 
class-map type network-qos cu4
match qos-group 5
 
class-map type network-qos new
match qos-group 2
 
class-map type network-qos class7
match qos-group 5
 
class-map type network-qos class-0
match qos-group 2
 
class-map type network-qos ip-based
match qos-group 5
 
class-map type network-qos class-1-2
match qos-group 3
 
class-map type network-qos class-4-7
match qos-group 4
 
class-map type network-qos cos-based
match qos-group 2
 
class-map type network-qos class-fcoe
match qos-group 1
 
class-map type network-qos class-flood
match qos-group 2
 
class-map type network-qos cos-based-3
match qos-group 3
 
class-map type network-qos cos-based-4
match qos-group 4
 
class-map type network-qos class-default
match qos-group 0
 
class-map type network-qos class-multicast
 
class-map type network-qos class-ip-multicast
match qos-group 5
 
 
switch(config)#
 

 
Related Commands

Command
Description

class-map

Creates or modifies a class map.

show class-map type qos

To display type qos class maps, use the show class-map type qos command.

show class-map type qos [ class-map-name ]

 
Syntax Description

class-map-name

Named class map. The name class-default is reserved. The name can be a maximum of 40 alphanumeric characters.

 
Command Default

Displays all type qos class maps if no class map name is specified.

 
Command Modes

Any command mode

 
Command History

Release
Modification

4.1(3)N1(1)

This command was introduced.

Examples

This example shows how to display all type qos class maps on a switch that runs Cisco NX-OS Release 4.1(3)N1(1):

switch(config)# show class-map type qos
 
 
Type qos class-maps
===================
 
class-map type qos s1
match cos 0
 
class-map type qos s2
match protocol ldp
match ip rtp 2000
match protocol dhcp
match protocol arp
 
class-map type qos s3
match access-group name mac
 
class-map type qos s4
match access-group name ipv4
 
class-map type qos cp1
match precedence 4-5
match cos 0,4
match dscp 4
match protocol ldp
match protocol arp
 
class-map type qos cp2
match ip rtp 2000
match cos 0
 
class-map type qos cp3
match access-group name mac
 
class-map type qos cp5
 
class-map type qos cq1
match protocol ldp
match precedence 7
match cos 0
 
class-map type qos cq2
match protocol ldp
match cos 1-2
 
class-map type qos cq3
match access-group name mac
 
class-map type qos cq4
match access-group name ipv4-1
 
class-map type qos cq5
match access-group name ipv6-based
 
class-map type qos p1.1
match cos 7
 
class-map type qos p1.2
match protocol ldp
match ip rtp 2000-6001,10000-20000,60000-65535
match dscp 1
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p1.3
match access-group name mac
 
class-map type qos p1.4
match access-group name ipv4
 
class-map type qos p2.1
match cos 0,7
 
class-map type qos p2.2
match protocol ldp
match ip rtp 2000-6000,6002,10000-20000,60000-65535
match dscp 2
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p2.3
match access-group name mac
 
class-map type qos p2.4
match access-group name ipv4
 
class-map type qos p3.1
match cos 0,7
 
class-map type qos p3.2
match protocol ldp
match ip rtp 2000-6000,6003,10000-20000,60000-65535
match dscp 3
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p3.3
match access-group name mac
 
class-map type qos p3.4
match access-group name ipv4
 
class-map type qos p4.1
match cos 0,7
 
class-map type qos p4.2
match protocol ldp
match ip rtp 2000-6000,6004,10000-20000,60000-65535
match dscp 4
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p4.3
match access-group name mac
 
class-map type qos p4.4
match access-group name ipv4
 
class-map type qos p5.1
match cos 0,7
 
class-map type qos p5.2
match protocol ldp
match ip rtp 2000-6000,6005,10000-20000,60000-65535
match dscp 5
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p5.3
match access-group name mac
 
class-map type qos p5.4
match access-group name ipv4
 
class-map type qos p6.1
match cos 0,7
 
class-map type qos p6.2
match protocol ldp
match ip rtp 2000-6000,6006,10000-20000,60000-65535
match dscp 6
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p6.3
match access-group name mac
 
class-map type qos p6.4
match access-group name ipv4
 
class-map type qos p7.1
match cos 0,7
 
class-map type qos p7.2
match protocol ldp
match ip rtp 2000-6000,6007,10000-20000,60000-65535
match dscp 7
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p7.3
match access-group name mac
 
class-map type qos p7.4
match access-group name ipv4
 
class-map type qos p8.1
match cos 0,7
 
class-map type qos p8.2
match protocol ldp
match ip rtp 2000-6000,6008,10000-20000,60000-65535
match dscp 8
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p8.3
match access-group name mac
 
class-map type qos p8.4
match access-group name ipv4
 
class-map type qos p9.1
match cos 0,7
 
class-map type qos p9.2
match protocol ldp
match ip rtp 2000-6000,6009,10000-20000,60000-65535
match dscp 9
match protocol dhcp
match protocol arp
match precedence 0-7
 
class-map type qos p9.3
match access-group name mac
 
class-map type qos p9.4
match access-group name ipv4
 
class-map type qos class-0
match cos 0
 
class-map type qos class-6
match cos 6
 
class-map type qos class-7
match cos 7
 
class-map type qos clsas-0
 
class-map type qos cos-6-7
match cos 7
 
class-map type qos ip-based
match access-group name ip-based
 
class-map type qos acl-based
match access-group name ipPacl
 
class-map type qos class-1-2
match cos 1-2
 
class-map type qos class-4-5
match cos 4-5
 
class-map type qos class-4-6
match cos 5
 
class-map type qos class-4-7
match cos 5,7
 
class-map type qos class-405
 
class-map type qos cos-based
 
class-map type qos mac-based
match access-group name foo
 
class-map type qos udp-based
match access-group name ip-based
 
class-map type qos class-fcoe
match cos 3
 
class-map type qos class-flood
 
class-map type qos class-default
match any
 
class-map type qos class-all-flood
match all flood
 
class-map type qos class-ip-multicast
match ip multicast
 
switch(config)#
 

This example shows how to display a specific class map:

switch# show class-map type qos class-4-6
 
 
Type qos class-maps
===================
 
class-map type qos class-4-6
match cos 5
 
switch#
 

This example shows how to display all type qos class maps on a switch that runs Cisco NX-OS Release 5.0(3)N1(1):

switch# show class-map type qos
 
 
Type qos class-maps
===================
 
class-map type qos match-any class-fcoe
match cos 3
 
class-map type qos match-any class-default
match any
 
class-map type qos match-any class-all-flood
match all flood
 
class-map type qos match-any class-ip-multicast
match ip multicast
 
switch#
 

 
Related Commands

Command
Description

class-map

Creates or modifies a class map.

show class-map type queuing

To display type queuing class maps, use the show class-map type queuing command.

show class-map type queuing [ class-map-name ]

 
Syntax Description

class-map-name

Named class map. The name can be a maximum of 40 alphanumeric characters.

 
Command Default

Displays all type queuing class maps if no class map name is specified.

 
Command Modes

Any command mode

 
Command History

Release
Modification

4.1(3)N1(1)

This command was introduced.

Examples

This example shows how to display all type queuing class maps on a switch that runs Cisco NX-OS Release 4.1(3)N1(1):

switch(config)# show class-map type queuing
 
 
Type queuing class-maps
=======================
 
class-map type queuing s1
match qos-group 2
 
class-map type queuing s2
match qos-group 3
 
class-map type queuing s3
match qos-group 4
 
class-map type queuing s4
match qos-group 5
 
class-map type queuing cq1
match qos-group 2
 
class-map type queuing cq2
match qos-group 3
 
class-map type queuing cq3
match qos-group 4
 
class-map type queuing cq4
match qos-group 5
 
class-map type queuing pq1
 
class-map type queuing cqe1
match qos-group 2
 
class-map type queuing cqe2
match qos-group 3
 
class-map type queuing cqe3
match qos-group 4
 
class-map type queuing cqe4
match qos-group 5
 
class-map type queuing p1.1
match qos-group 2
 
class-map type queuing p1.2
match qos-group 3
 
class-map type queuing p1.3
match qos-group 4
 
class-map type queuing p1.4
match qos-group 5
 
class-map type queuing p2.1
match qos-group 2
 
class-map type queuing p2.2
match qos-group 3
 
class-map type queuing p2.3
match qos-group 4
 
class-map type queuing p2.4
match qos-group 5
 
class-map type queuing p3.1
match qos-group 2
 
class-map type queuing p3.2
match qos-group 3
 
<--Output truncated-->
switch(config)#
 

This example shows how to display all type queuing class maps on a switch that runs Cisco NX-OS Release 5.0(3)N1(1):

switch# show class-map type queuing
 
 
Type queuing class-maps
=======================
 
class-map type queuing class-fcoe
match qos-group 1
 
class-map type queuing class-default
match qos-group 0
 
class-map type queuing class-all-flood
match qos-group 2
 
class-map type queuing class-ip-multicast
match qos-group 2
 
switch#
 

 
Related Commands

Command
Description

class-map

Creates or modifies a class map.

 

show copp status

To display the Control Plane Policing (CoPP) configuration status, use the show copp status command.

show copp status

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

Any configuration mode

 
Command History

Release
Modification

5.1(3)N1(1)

This command was introduced.

 
Usage Guidelines

This command does not require a license.

Examples

This example shows how to display the CoPP configuration status information:

switch# show copp status
Last Config Operation: class class-default
Last Config Operation Timestamp: 05:06:14 UTC Jan 1 2009
Last Config Operation Status: Success
Policy-map attached to the control-plane: copp-system-policy-default
 
switch#
 

 
Related Commands

Command
Description

clear copp statistics

Clears the CoPP statistics.

show running-config copp

Displays CoPP configuration information in the running configuration.

 

show interface flowcontrol

To display the detailed listing of the flow control settings on all interfaces, use the show interface flowcontrol command.

show interface flowcontrol [ module number ]

 
Syntax Description

module number

(Optional) Displays flow control settings on all interfaces on a specified module. The module number range is from 1 to 3.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.

5.0(3)N1(1)

Support for Layer 3 interfaces was added.

 
Usage Guidelines

You can use this command to display the flow control information for the following interfaces:

  • Layer 2 interface
  • Layer 3 interface

Note Use the no switchport command to configure an interface as a Layer 3 interface, and then use the flowcontrol command to configure flow control for the interface.


Examples

This example shows how to display the flow control settings on all interfaces on a switch:

switch# show interface flowcontrol
 
--------------------------------------------------------------------------------
Port Send FlowControl Receive FlowControl RxPause TxPause
admin oper admin oper
--------------------------------------------------------------------------------
Eth1/1 off off off off 0 0
 
Eth1/2 off off off off 0 0
 
Eth1/3 off off off off 0 0
 
Eth1/4 off off off off 0 0
 
Eth1/5 off off off off 0 0
 
Eth1/6 off off off off 0 0
 
Eth1/7 off off off off 0 0
 
Eth1/8 off off off off 0 0
 
Eth1/9 off off off off 0 0
 
Eth1/10 off off off off 0 0
 
Eth1/11 off off off off 0 0
 
--More--
switch#

show hardware profile tcam feature qos

To display the the limits of the QoS TCAMs, use the show hardware profile tcam feature-qos command.

show hardware profile tcam feature qos tcam-size

 
Syntax Description

tcam-size

Interface QoS TCAM limit. The tcam-size can be from 7- 446 entries.

 
Command Default

None

 
Command Modes

Global configuration mode

 
Command History

Release
Modification

5.1(3)N2(1)

This command was introduced.

 
Usage Guidelines

No interface policy entry should be present after the interface_qos limit in the QoS region of any TCAM.

Examples

This example shows how to set the interface QoS TCAM limit to 20 entries:

switch(config)# configue terminal
switch(config)# hardware profile tcam feature interface-qos limit 20
switch(config)# show hardware profile tcam feature qos
Feature Limit
--------------------------------------------------------------------------------
Interface 20
vlan-qos + global-qos 428
 
switch(config)# copy running-config startup-config

 
Related Commands

Command
Description

hardware profile tcam feature interface-qos limit

Configures the QoS TCAM limit

show interface priority-flow-control

To display the priority flow control details for a specified interface, use the show interface priority-flow-control command.

show interface [ ethernet slot / port ] priority-flow-control

 
Syntax Description

ethernet slot / port

(Optional) Specifies the Ethernet interface and its slot number and port number. The slot number is from 1 to 255, and the port number is from 1 to 128.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.

5.0(3)N1(1)

Support for Layer 3 interfaces was added.

 
Usage Guidelines

You can use this command to display the priority flow control information for the following interfaces:

  • Layer 2 interface
  • Layer 3 interface

Note Use the no switchport command to configure an interface as a Layer 3 interface, and then use the flowcontrol command to configure flow control for the interface.


If you do not specify an interface, the show interface priority-flow-control command will display the priority flow control information for all interfaces (Layer 2, Layer 3).

Examples

This example shows how to display the priority flow control details for a specified interface:

switch# show interface ethernet 1/2 priority-flow-control
============================================================
Port Mode Oper(VL bmap) RxPPP TxPPP
============================================================
 
Ethernet1/2 Auto On (9) 4088353 1890
switch#
 

The interface specified is Ethernet 1/2, the PFC mode is set to negotiate PFC capability, the operation is on, and packets transmitted is 1890.

This example shows how to display the priority flow control information for a specified Layer 3 interface:

switch# show interface ethernet 1/5 priority-flow-control
============================================================
Port Mode Oper(VL bmap) RxPPP TxPPP
============================================================
 
Ethernet1/5 On On (0) 0 0
switch#
 

This example shows how to display the priority flow control information for all interfaces:

switch# show interface priority-flow-control
============================================================
Port Mode Oper(VL bmap) RxPPP TxPPP
============================================================
 
Ethernet1/1 Auto Off 0 0
Ethernet1/2 Auto Off 0 0
Ethernet1/3 Auto Off 0 0
Ethernet1/4 Auto Off 0 0
Ethernet1/5 On On (0) 0 0
Ethernet1/6 Auto Off 0 0
Ethernet1/7 Auto Off 0 0
Ethernet1/8 Auto Off 0 0
Ethernet1/9 Auto Off 0 0
Ethernet1/10 Auto Off 0 0
Ethernet1/11 Auto Off 0 0
Ethernet1/12 Auto Off 0 0
Ethernet1/13 Auto Off 0 0
Ethernet1/14 Auto Off 0 0
Ethernet1/15 Auto Off 0 0
Ethernet1/16 Auto Off 0 0
Ethernet1/17 Auto Off 0 0
Ethernet1/18 Auto Off 0 0
Ethernet1/19 Auto Off 0 0
Ethernet1/20 Auto Off 0 0
Ethernet1/21 Auto Off 0 0
Ethernet1/22 Auto Off 0 0
Ethernet1/23 Auto Off 0 0
Ethernet1/24 Auto Off 0 0
Ethernet1/25 Auto Off 0 0
Ethernet1/26 Auto Off 0 0
Ethernet1/27 Auto Off 0 0
Ethernet1/28 Auto Off 0 0
Ethernet1/29 Auto Off 0 0
Ethernet1/30 Auto Off 0 0
Ethernet1/31 Auto Off 0 0
Ethernet1/32 Auto Off 0 0
Ethernet3/1 Auto Off 0 0
Ethernet3/2 Auto Off 0 0
Ethernet3/3 Auto Off 0 0
Ethernet3/4 Auto Off 0 0
Ethernet3/5 Auto Off 0 0
Ethernet3/6 Auto Off 0 0
Ethernet3/7 Auto Off 0 0
Ethernet3/8 Auto Off 0 0
Ethernet3/9 Auto Off 0 0
Ethernet3/10 Auto Off 0 0
Ethernet3/11 Auto Off 0 0
Ethernet3/12 Auto Off 0 0
Ethernet3/13 Auto Off 0 0
Ethernet3/14 Auto Off 0 0
Ethernet3/15 Auto Off 0 0
Ethernet3/16 Auto Off 0 0
Ethernet3/17 Auto Off 0 0
Ethernet3/18 Auto Off 0 0
Ethernet3/19 Auto Off 0 0
Ethernet3/20 Auto Off 0 0
Ethernet3/21 Auto Off 0 0
Ethernet3/22 Auto Off 0 0
Ethernet3/23 Auto Off 0 0
Ethernet3/24 Auto Off 0 0
Ethernet3/25 Auto Off 0 0
Ethernet3/26 Auto Off 0 0
Ethernet3/27 Auto Off 0 0
Ethernet3/28 Auto Off 0 0
Ethernet3/29 Auto Off 0 0
Ethernet3/30 Auto Off 0 0
Ethernet3/31 Auto Off 0 0
Ethernet3/32 Auto Off 0 0
Ethernet100/1/1 Auto Off 0 0
Ethernet100/1/2 Auto Off 0 0
Ethernet100/1/3 Auto Off 0 0
Ethernet100/1/4 Auto Off 0 0
Ethernet100/1/5 Auto Off 0 0
Ethernet100/1/6 Auto Off 0 0
Ethernet100/1/7 Auto Off 0 0
Ethernet100/1/8 Auto Off 0 0
Ethernet100/1/9 Auto Off 0 0
Ethernet100/1/10 Auto Off 0 0
Ethernet100/1/11 Auto Off 0 0
Ethernet100/1/12 Auto Off 0 0
Ethernet100/1/13 Auto Off 0 0
Ethernet100/1/14 Auto Off 0 0
Ethernet100/1/15 Auto Off 0 0
Ethernet100/1/16 Auto Off 0 0
switch#
 

 
Related Commands

Command
Description

no switchport

Configures a Layer 3 routed interface.

priority-flow-control

Sets the PFC mode for the selected interface.

show interface untagged-cos

To display the untagged class of service (CoS) values for a specified interface, use the show interface untagged-cos command.

show interface untagged-cos [ module module_no ]

 
Syntax Description

module

(Optional) Displays the interfaces on this module of the switch chassis.

module_no

Module number in the switch chassis. The range is from 1 to 18.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modification

4.1(3)N1(1)

This command was introduced.

5.0(3)N1(1)

Support to display Layer 3 interfaces was added.

Examples

This example shows how to display the untagged CoS values for interfaces:

switch# show interface untagged-cos
=================================
 
Interface Untagged-CoS
=================================
 
port-channel1
port-channel3 2
port-channel5 5
port-channel6
port-channel12
port-channel15
port-channel20
port-channel24
port-channel25
port-channel33
port-channel41
port-channel44
--More--
switch#
 

This example shows how to display the untagged CoS values for all interfaces (Layer 2, Layer 3) on a switch that runs Cisco NX-OS Release 5.0(3)N1(1):

switch# show interface untagged-cos
S3(config-if)# show int untagged-cos
=================================
 
Interface Untagged-CoS
=================================
 
port-channel100
port-channel127
port-channel128
Ethernet1/1
Ethernet1/2
Ethernet1/3
Ethernet1/4
Ethernet1/5 3
Ethernet1/6
Ethernet1/7
Ethernet1/8
Ethernet1/9
Ethernet1/10
Ethernet1/11
Ethernet1/12
:
<--snip-->
Ethernet3/31
Ethernet3/32
Ethernet100/1/1
Ethernet100/1/2
<--Output truncated-->
switch#
 

 
Related Commands

Command
Description

untagged cos

Sets a CoS value for untagged Ethernet frames.

show policy-map

To display policy maps, use the show policy-map command.

show policy-map [ type { network-qos | qos | queuing }] [ policy-map-name ]

 
Syntax Description

type

(Optional) Specifies the component type to display.

network-qos

Displays policy maps of type network-qos.

qos

Displays policy maps of type qos only.

queuing

Displays policy maps of type queuing only.

policy-map-name

(Optional) Named policy map. The name can be a maximum of 40 alphanumeric characters.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modification

4.1(3)N1(1)

This command was introduced.

 
Usage Guidelines

When you enter the show policy-map command with no arguments or keywords, the system also displays the Control Plane Policing (CoPP) information.

Examples

This example shows how to display a named network-qos policy map:

switch# show policy-map type network-qos my_pnq
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos my_pnq
class type network-qos cl_nq
multicast-optimize
queue-limit 20480 bytes
mtu 1500
class type network-qos class-fcoe
pause no-drop
mtu 2158
class type network-qos class-default
mtu 1500
switch#
 

 
Related Commands

Command
Description

policy-map

Creates or modifies a policy map.

show policy-map interface

To display the service policy maps configured on the interfaces, use the show policy-map interface command.

show policy-map interface [ ethernet slot / port | port-channel channel-number ] [ input | output ] [ type { qos | queuing }]

 
Syntax Description

ethernet

(Optional) Displays policy maps assigned to Ethernet interfaces.

slot/port

Ethernet interface slot number and port number. The slot number is from 1 to 255, and the port number is from 1 to 128.

port-channel

(Optional) Displays policy maps assigned to EtherChannels.

channel-number

EtherChannel number. The number is from 1 to 4096.

input

(Optional) Displays policy maps assigned to input traffic only.

output

(Optional) Displays policy maps assigned to output traffic only.

type

(Optional) Specifies the component type to display.

qos

Displays policy maps of type qos only.

queuing

Displays policy maps of type queuing only.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modification

4.0(0)N1(1a)

This command was introduced.

5.0(3)N1(1)

Support for Layer 3 subinterfaces was added.

 
Usage Guidelines

Statistics are on by default.

Examples

This example shows how to display policy maps assigned to a specified interface:

switch(config)# show policy-map interface ethernet 2/10
 

This example shows how to display QoS policy maps assigned to a specified interface:

switch# show policy-map interface ethernet 3/1 type qos
 
 
Global statistics status : disabled
 
Ethernet3/1
 
Service-policy (qos) input: s
policy statistics status: disabled
 
Class-map (qos): s1 (match-any)
Match: cos 0
set qos-group 2
 
Class-map (qos): class-1-2 (match-any)
Match: cos 1-2
set qos-group 3
 
Class-map (qos): class-4-5 (match-any)
Match: cos 4-5
set qos-group 4
 
Class-map (qos): class-6 (match-any)
Match: cos 6
set qos-group 5
 
Class-map (qos): class-fcoe (match-any)
Match: cos 3
set qos-group 1
 
Class-map (qos): class-default (match-any)
Match: any
set qos-group 0
 
switch#
 

This example shows how to display the policy maps assigned to the output traffic of a specified interface:

switch# show policy-map interface ethernet 3/1 output
 
 
Global statistics status : disabled
 
Ethernet3/1
 
Service-policy (queuing) output: pqe1
policy statistics status: disabled
 
Class-map (queuing): cqe1 (match-any)
Match: qos-group 2
bandwidth percent 20
 
Class-map (queuing): cqe2 (match-any)
Match: qos-group 3
priority
 
Class-map (queuing): cqe3 (match-any)
Match: qos-group 4
bandwidth percent 20
 
Class-map (queuing): cqe4 (match-any)
Match: qos-group 5
bandwidth percent 40
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 10
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 5
 
switch#
 

This example shows how to display the policy maps assigned to the input traffic of a virtual Ethernet interface:

switch# show policy-map interface vethernet 10 input type queuing
 
 
Global statistics status : disabled
 
Vethernet10
 
Service-policy (queuing) input: p2
policy statistics status: disabled
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 50
shape 30 kbps
 
switch#
 

 
Related Commands

Command
Description

policy-map

Creates or modifies a policy map.

service-policy (virtual Ethernet interface)

Attaches a policy map to a virtual Ethernet interface.

show policy-map interface brief

To display policy maps applied to interfaces in a brief format, use the show policy-map interface brief command.

show policy-map interface brief

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modification

4.1(3)N1(1)

This command was introduced.

5.0(3)N1(1)

Support to display Layer 3 interfaces was added.

Examples

This example shows how to display assigned policy maps in a brief format:

switch(config)# show policy-map interface brief
 
 
Interface [Status]:INP QOS INP QUE OUT QUE
===================================================================
port-channel1 [Active]:p1 pqe1 pqe1
port-channel3 [Active]:s pqe1 pqe1
port-channel5 [Active]:s pqe1 pqe1
port-channel6 [Active]:s pqe1 pqe1
port-channel12 [Active]:p12 p12-in p12-out
port-channel15 [Active]:s pqe1 pqe1
port-channel20 [Active]:s pqe1 pqe1
port-channel24 [Active]:p4 pqe1 pqe1
port-channel25 [Active]:p4 pqe1 pqe1
port-channel33 [Active]:s pqe1 pqe1
port-channel41 [Active]:s pqe1 pqe1
port-channel44 [Active]:s pqe1 pqe1
port-channel48 [Active]:s pqe1 pqe1
port-channel101 [Active]:s pqe1 pqe1
port-channel102 [Active]:p4
port-channel103 [Active]:p4
port-channel104 [Active]:p4
port-channel105 [Active]:p4
port-channel106 [Active]:p4
port-channel107 [Active]:p4
--More--
switch(config)#
 

This example shows how to display assigned policy maps in a brief format on a switch that runs Cisco NX-OS Release 5.0(3)N1(1):

switch# show policy-map interface brief
S3(config-if)# show policy-map interface brief
 
 
Interface/VLAN [Status]:INP QOS OUT QOS INP QUE OUT QUE
================================================================================
port-channel100 [Active]:default-in-po default-in-po default-out-p
 
port-channel127 [Active]:default-in-po default-in-po default-out-p
 
port-channel128 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/1 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/2 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/3 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/4 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/5 [Active]:default-in-po default-in-po default-out-p
 
Ethernet1/6 [Active]:default-in-po default-in-po default-out-p
 
:
<Snip>
:
Ethernet3/31 [Active]:default-in-po default-in-po default-out-p
 
Ethernet3/32 [Active]:default-in-po default-in-po default-out-p
 
Ethernet100/1/1 [Active]:default-in-po default-in-po default-out-p
 
Ethernet100/1/2 [Active]:default-in-po default-in-po default-out-p
 
Ethernet100/1/3 [Active]:default-in-po default-in-po default-out-p
<--Output truncated-->
switch#
 

 
Related Commands

Command
Description

policy-map

Creates or modifies a policy map.

show policy-map

Displays policy maps.

 

show policy-map interface control-plane

To display the control-plane policy maps applied to interfaces, use the show policy-map interface control-plane command.

show policy-map interface control-plane

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modification

5.1(3)N1(1)

This command was introduced.

Examples

This example shows how to display assigned control-plane policy maps:

switch# show policy-map interface control-plane
control Plane
 
service-policy input: copp-system-policy-default
 
class-map copp-system-class-igmp (match-any)
match protocol igmp
police cir 1024 kbps, bc 65535 bytes
conformed 0 bytes; action: transmit
violated 0 bytes; action: drop
 
class-map copp-system-class-pim-hello (match-any)
match protocol pim
police cir 1024 kbps, bc 4800000 bytes
conformed 0 bytes; action: transmit
violated 0 bytes; action: drop
 
class-map copp-system-class-bridging (match-any)
match protocol bridging
police cir 20000 kbps, bc 4800000 bytes
conformed 0 bytes; action: transmit
violated 0 bytes; action: drop
 
class-map copp-system-class-arp (match-any)
match protocol arp
<--Output truncated-->
switch(config)#
 

 
Related Commands

Command
Description

policy-map

Creates or modifies a policy map.

show policy-map

Displays policy maps.

 

show policy-map system

To display all active policy maps in the system, use the show policy-map system command.

show policy-map system [ type { network-qos | qos [ input ] | queuing [ input | output ]}]

 
Syntax Description

type

(Optional) Specifies the component type to display.

network-qos

Displays policy maps of type network-qos only.

qos

Displays policy maps of type qos only.

input

(Optional) Displays policy maps assigned to input traffic.

queuing

Displays policy maps of type queuing only.

output

(Optional) Displays policy maps assigned to output traffic.

 
Command Default

All policy maps

 
Command Modes

EXEC mode

 
Command History

Release
Modification

4.1(3)N1(1)

This command was introduced.

 
Usage Guidelines

If you do not specify a policy map type and name, the system displays all the active policy maps in the system.

Examples

This example shows how to display all active policy maps in the system:

switch# show policy-map system
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos s
class type network-qos s2 match qos-group 3
 
mtu 4000
class type network-qos s1 match qos-group 2
 
mtu 5000
set cos 0
multicast-optimize
pause no-drop
class type network-qos s3 match qos-group 4
 
mtu 9216
class type network-qos s4 match qos-group 5
 
mtu 9216
class type network-qos class-fcoe match qos-group 1
 
pause no-drop
mtu 2158
class type network-qos class-default match qos-group 0
 
mtu 1500
 
 
Service-policy (qos) input: s
policy statistics status: disabled
 
Class-map (qos): s1 (match-any)
Match: cos 0
set qos-group 2
 
Class-map (qos): class-1-2 (match-any)
Match: cos 1-2
set qos-group 3
 
Class-map (qos): class-4-5 (match-any)
Match: cos 4-5
set qos-group 4
 
Class-map (qos): class-6 (match-any)
Match: cos 6
set qos-group 5
 
Class-map (qos): class-fcoe (match-any)
Match: cos 3
set qos-group 1
 
Class-map (qos): class-default (match-any)
Match: any
set qos-group 0
 
Service-policy (queuing) input: pqe1
policy statistics status: disabled
 
Class-map (queuing): cqe1 (match-any)
Match: qos-group 2
bandwidth percent 20
 
Class-map (queuing): cqe2 (match-any)
Match: qos-group 3
priority
 
Class-map (queuing): cqe3 (match-any)
Match: qos-group 4
bandwidth percent 20
 
Class-map (queuing): cqe4 (match-any)
Match: qos-group 5
bandwidth percent 40
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 10
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 5
 
Service-policy (queuing) output: pqe1
policy statistics status: disabled
 
Class-map (queuing): cqe1 (match-any)
Match: qos-group 2
bandwidth percent 20
 
Class-map (queuing): cqe2 (match-any)
Match: qos-group 3
priority
 
Class-map (queuing): cqe3 (match-any)
Match: qos-group 4
bandwidth percent 20
 
Class-map (queuing): cqe4 (match-any)
Match: qos-group 5
bandwidth percent 40
 
Class-map (queuing): class-fcoe (match-any)
Match: qos-group 1
bandwidth percent 10
 
Class-map (queuing): class-default (match-any)
Match: qos-group 0
bandwidth percent 5
 
switch#
 

This example shows how to display active network-qos policy maps in the system:

switch# show policy-map system type network-qos
 
 
Type network-qos policy-maps
===============================
 
policy-map type network-qos s
class type network-qos s2 match qos-group 3
 
mtu 4000
class type network-qos s1 match qos-group 2
 
mtu 5000
set cos 0
multicast-optimize
pause no-drop
class type network-qos s3 match qos-group 4
 
mtu 9216
class type network-qos s4 match qos-group 5
 
mtu 9216
class type network-qos class-fcoe match qos-group 1
 
pause no-drop
mtu 2158
class type network-qos class-default match qos-group 0
 
mtu 1500
switch#
 

 
Related Commands

Command
Description

show policy-map

Displays all policy maps.

show policy-map type control-plane

To display control plane policy map information, use the show policy-map type control-plane command.

show policy-map type control-plane [ expand ] [ name policy-map-name ]

 
Syntax Description

expand

(Optional) Displays expanded control plane policy map information.

name policy-map-name

(Optional) Specifies the name of the control plane policy map. The name is case sensitive and can be a maximum of 64 alphanumeric characters.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modification

5.1(3)N1(1)

This command was introduced.

 
Usage Guidelines

This command does not require a license.

Examples

This example shows how to display control plane policy map information:

switch# show policy-map type control-plane
 
policy-map type control-plane copp-system-policy-customized
class copp-system-class-igmp
police cir 1024 kbps bc 65535 bytes
class copp-system-class-pim-hello
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-bridging
police cir 20000 kbps bc 4800000 bytes
class copp-system-class-arp
police cir 1024 kbps bc 3600000 bytes
class copp-system-class-dhcp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-mgmt
police cir 12000 kbps bc 4800000 bytes
class copp-system-class-lacp
police cir 1024 kbps bc 4800000 bytes
class copp-system-class-lldp
police cir 2048 kbps bc 4800000 bytes
class copp-system-class-udld
police cir 2048 kbps bc 4800000 bytes
<--Output truncated-->
switch#
 

This example shows how to display control plane policy map information in expanded format:

switch# show policy-map type control-plane expand
 

 
Related Commands

Command
Description

policy-map type control-plane

Creates or configures a control plane policy map.

 

show policy-map vlan

To display VLAN policy maps, use the show policy-map vlan command.

show policy-map vlan [vlan-number]

 
Syntax Description

vlan-number

Displays the QoS policies configured on the specified VLAN.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modification

5.1(3)N2(1)

This command was introduced.

 
Usage Guidelines

You must configure the interface QoS limit and policy map before using the show policy-map vlan command. The TCAM must have enough free entries to configure the service policy on the VLAN.

Examples

This example shows how to display the QoS policies configured on the specified VLAN:

switch# show policy-map vlan 101
 
 
Service-policy (qos) input: vpq1
===============================
 
policy status statistics: disabled
class-map (qos): vcq2 (match-any)
match: cos 2
match: precedence 1
set cos-group 2
set prec 2
 
class-map (qos): vcq4 (match-any)
match: access-group ipacl1-vq
match: prec 7
set cos-group 4
 
class-map (qos): vcq4 (match-any)
match: cos 1
set cos-group 3
 
class-map (qos): vcq4 (match-any)
match: any
set cos-group 0
switch#
 

 
Related Commands

Command
Description

policy-map

Creates or modifies a policy map.

show queuing interface

To display the queuing information on interfaces, use the show queuing interface command.

show queuing interface [ ethernet slot-no / port-no ]

 
Syntax Description

ethernet

(Optional) Specifies that queuing information to be displayed for an Ethernet interface.

slot-no

Slot number of the Ethernet interface. The range is from 1 to 255.

port-no

Port number of the Ethernet interface. The range is from 1 to 128.

 
Command Default

Displays the queuing information for all interfaces.

 
Command Modes

EXEC mode

 
Command History

Release
Modification

4.1(3)N1(1)

This command was introduced.

Examples

This example shows how to display the queuing information for all interfaces:

switch# show queuing interface
Ethernet1/1 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 73
1 WRR 0
2 WRR 1
3 WRR 6
4 WRR 20
5 priority 0
 
RX Queuing
qos-group 0
q-size: 25600, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 160
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 1
q-size: 76800, HW MTU: 2240 (2158 configured)
drop-type: no-drop, xon: 128, xoff: 240
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 2
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 3
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 4
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 5
q-size: 81920, HW MTU: 9280 (9216 configured)
drop-type: no-drop, xon: 128, xoff: 230
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
Total Multicast crossbar statistics:
Mcast pkts received from the cross-bar : 0
 
Ethernet1/2 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 73
1 WRR 0
2 WRR 1
3 WRR 6
4 WRR 20
5 priority 0
<---output truncated--->
switch#
 

This example shows how to display the queuing information on Ethernet interface 1/2:

switch# show queuing interface ethernet 1/2
Ethernet1/2 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 73
1 WRR 0
2 WRR 1
3 WRR 6
4 WRR 20
5 priority 0
 
RX Queuing
qos-group 0
q-size: 25600, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 160
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 1851526994
Pkts sent to the port : 1851527000
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 1
q-size: 76800, HW MTU: 2240 (2158 configured)
drop-type: no-drop, xon: 128, xoff: 240
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
qos-group 2
q-size: 20480, HW MTU: 9280 (9216 configured)
drop-type: drop, xon: 0, xoff: 128
Statistics:
Pkts received over the port : 0
Ucast pkts sent to the cross-bar : 0
Mcast pkts sent to the cross-bar : 0
Ucast pkts received from the cross-bar : 0
Pkts sent to the port : 0
Pkts discarded on ingress : 0
Per-priority-pause status : Rx (Inactive), Tx (Inactive)
 
--More--
switch#
 

Table 1 describes the significant fields shown in the display.

 

Table 1 show queuing interface Field Descriptions

Field
Description

Ethernet...

Ethernet interface information.

qoS-group

Information about QoS groups configured on the switch.

sched-type

Type of schedule.

WRR

Weighted round robin(WRR). Queue eight for scheduling.

Priority

Priority of the queue.

q-size

Queue size.

drop-type

Queue drop type can be either drop or no-drop.

MTU

Maximum transmit unit (MTU) for the queue.

Xon

Transmission on at this threshold.

Xoff

Transmission off at this threshold.

 
Related Commands

Command
Description

hardware buffer-threshold

Configures the hardware buffer threshold.

hardware queue-limit

Configures the hardware queue limit.

show fex

Displays all configured Fabric Extender chassis connected to the switch.

 

show running-config copp

To display Control Plane Policing (CoPP) configuration information in the running configuration, use the show running-config copp command.

show running-config copp [ all ]

 
Syntax Description

all

(Optional) Displays configured and default information.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modification

5.1(3)N1(1)

This command was introduced.

 
Usage Guidelines

This command does not require a license.

Examples

This example shows how to display the configured CoPP information in the running configuration on a switch that runs Cisco NX-OS Release 5.1(3)N1(1):

switch# show running-config copp
 

This example shows how to display the configured and default CoPP information in the running configuration:

switch# show running-config copp all
 

 
Related Commands

Command
Description

control-plane

Enters the control-plane configuration mode.

copy running-config startup-config

Copies the running configuration to the startup configuration file.

show startup-config aclmgr

Displays the ACL startup configuration.

show startup-config copp

Displays the CoPP configuration information in the startup configuration file.

 

show running-config ipqos

To display information about the running-system configuration for quality of service (QoS), use the show running-config ipqos command.

show running-config ipqos [ all ]

 
Syntax Description

all

(Optional) Displays configured and default information.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modification

5.0(2)N1(1)

This command was introduced.

5.0(3)N1(1)

Support to display Layer 3 interfaces was added.

 
Usage Guidelines

Use this command to view a list of default and configured class maps and policy maps and the policies attached to interfaces.

Examples

This example shows how to display QoS information on a switch that runs Cisco NX-OS Release 5.0(2)N1(1):

switch# show running-config ipqos
 
 
!Command: show running-config ipqos
!Time: Thu Sep 9 06:26:49 2010
 
version 5.0(2)N1(1)
class-map type qos class-fcoe
match cos 4
class-map type qos match-all 1
match cos 1
class-map type qos match-all 2
match cos 2
class-map type qos match-all 3
match cos 3
class-map type qos match-all 4
class-map type qos match-any 5
match cos 5,7
class-map type qos match-all arp
match protocol dhcp
match protocol arp
match cos 3
class-map type qos match-all cos
match cos 5
class-map type qos match-all dot
match access-group name dot
class-map type qos match-all my_class
match dscp 3
match precedence 0
match protocol dhcp
class-map type qos match-all new
match protocol netbios
:
<snip>
class-map type queuing my_qclass
match qos-group 3
class-map type queuing Video-Signalling
match qos-group 4
class-map type queuing class-ip-multicast
match qos-group 4
policy-map type qos 5
class 5
set qos-group 2
class Video
set qos-group 3
policy-map type qos my_policy
class my_class
set precedence 5
set dscp 5
class myQAll
set precedence 3
set dscp 48
:
<snip>
policy-map type network-qos my_policy1
class type network-qos my_class1
pause no-drop buffer-size 143680 pause-threshold 58860 resume-threshold 3840
class type network-qos class-fcoe
pause no-drop
mtu 2158
class type network-qos class-default
:
<snip>
system qos
service-policy type qos input voice
service-policy type network-qos Network
service-policy type queuing output Queu
service-policy type queuing input Queue
 
<--output truncated-->
switch#
 

This example shows how to display QoS information on a switch that runs Cisco NX-OS Release 5.0(3)N1(1):

switch# show running-config ipqos
 
!Command: show running-config ipqos
!Time: Sun Apr 20 07:22:36 2008
 
version 5.0(3)N1(1)
class-map type qos class-fcoe
class-map type qos match-all c1
match cos 3-5
class-map type queuing class-fcoe
match qos-group 1
class-map type queuing class-all-flood
match qos-group 2
class-map type queuing class-ip-multicast
match qos-group 2
policy-map type qos p1
class c1
set qos-group 3
class-map type network-qos n1
match qos-group 1
class-map type network-qos class-fcoe
match qos-group 1
class-map type network-qos class-all-flood
match qos-group 2
class-map type network-qos class-ip-multicast
match qos-group 2
policy-map type network-qos n2
class type network-qos n1
class type network-qos class-default
multicast-optimize
 
 
interface Ethernet1/5
priority-flow-control mode on
untagged cos 3
 
switch#
 

The above display shows the QoS information for Layer 3 interfaces (Ethernet 1/5 configured as a Layer 3 interface).

 
Related Commands

Command
Description

copy running-config startup-config

Copies the running configuration to the startup configuration file.

show class-map

Displays information about class maps.

show policy-map

Displays information about policy maps.

 

show startup-config copp

To display the Control Plane Policing (CoPP) configuration information in the startup configuration, use the show startup-config copp command.

show startup-config copp

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modification

5.1(3)N1(1)

This command was introduced.

 
Usage Guidelines

This command does not require a license.

Examples

This example shows how to display the CoPP information in the startup configuration:

switch# show startup-config copp
 

 
Related Commands

Command
Description

control-plane

Enters the control-plane configuration mode.

copy running-config startup-config

Copies the running configuration to the startup configuration file.

show running-config copp

Displays the CoPP configuration information in the running configuration.

 

show startup-config ipqos

To display quality of service (QoS) configuration information in the startup configuration, use the show startup-config ipqos command.

show startup-config ipqos [ all ]

 
Syntax Description

all

(Optional) Displays configured and default information.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modification

5.0(2)N1(1)

This command was introduced.

5.0(3)N1(1)

Support to display Layer 3 interfaces was added.

Examples

This example shows how to display the QoS information in the startup configuration file:

switch# show startup-config ipqos
 
!Command: show startup-config ipqos
!Time: Thu Sep 9 07:42:33 2010
!Startup config saved at: Tue Sep 7 08:45:03 2010
 
version 5.0(2)N1(1)
class-map type qos class-fcoe
match cos 4
class-map type qos match-all 1
match cos 1
class-map type qos match-all 2
match cos 2
class-map type qos match-all 3
match cos 3
class-map type qos match-all 4
class-map type qos match-any 5
match cos 5,7
class-map type qos match-all arp
match protocol dhcp
match protocol arp
match cos 3
class-map type qos match-all cos
match cos 5
class-map type qos match-all dot
match access-group name dot
class-map type qos match-all new
match protocol netbios
class-map type qos match-all rtp
match ip rtp 2000-40000
class-map type qos match-all dscp
match dscp 46
match precedence 7
match protocol arp
class-map type qos match-all Video
match dscp 34
class-map type qos match-all Voice
match dscp 40,46
class-map type qos match-all class1
match ip rtp 2000
class-map type qos match-all class2
match cos 1
class-map type qos match-all class3
match protocol arp
class-map type qos match-all class4
match protocol dhcp
class-map type qos match-all class5
match protocol ldp
:
:
<--output truncated--
 
switch#
 

 
Related Commands

Command
Description

copy running-config startup-config

Copies the running configuration to the startup configuration file.

show class-map

Displays information about class maps.

show policy-map

Displays information about policy maps.

show wrr-queue cos-map

To display the mapped class of service (CoS) values to egress queues, use the show wrr-queue cos-map command.

show wrr-queue cos-map

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modification

5.0(3)N1(1)

This command was introduced.

Examples

This example shows how to display the CoS values that are mapped to the egress queue:

switch# show wrr-queue cos-map
MCAST Queue ID Cos Map
0 0 1
1 2
2 3 4 5
3 6 7
switch#
 

 
Related Commands

Command
Description

wrr-queue cos-map

Maps class of service (CoS) values to select one of the egress queues.