المقدمة
يصف هذا وثيقة كيف أن يشكل إعادة توزيع متبادل بين EIGRP و BGP.
المتطلبات الأساسية
المتطلبات
توصي Cisco بأن تكون لديك معرفة بالمواضيع التالية:
المكونات المستخدمة
تستند المعلومات الواردة في هذا المستند إلى موجه السلسلة Cisco 7200 Series مع برنامج Cisco IOS®الإصدار 15.0(1).
تم إنشاء المعلومات الواردة في هذا المستند من الأجهزة الموجودة في بيئة معملية خاصة. بدأت جميع الأجهزة المُستخدمة في هذا المستند بتكوين ممسوح (افتراضي). إذا كانت شبكتك قيد التشغيل، فتأكد من فهمك للتأثير المحتمل لأي أمر.
الاصطلاحات
راجع اصطلاحات تلميحات Cisco التقنية للحصول على مزيد من المعلومات حول اصطلاحات المستندات.
التكوين
في هذا المثال، تتواصل الموجهات R1 و R2 مع بعضها البعض باستخدام EIGRP. تستخدم الموجهات R2 و R3 بروتوكول eBGP. من أجل إعادة توزيع مسارات eBGP بشكل متبادل إلى EIGRP، أستخدم الأمر redistribute bgpمع مقاييس EIGRP. بالمثل، لإعادة توزيع مسارات EIGRP إلى BGP، أستخدم redistribute eigrp AS number الأمر.
الرسم التخطيطي للشبكة
يستخدم هذا المستند إعداد الشبكة التالي:
الرسم التخطيطي للشبكة
التكوينات
يستخدم هذا المستند التكوينات التالية:
الموجه R1 |
!
hostname R1
!
ip cef
!
!
interface Loopback0
ip address 10.30.30.30 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.101 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
network 10.30.0.0
network 192.168.1.0
no auto-summary
!
end
|
الموجه R2 |
!
hostname R2
!
ip cef
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
ip address 10.20.20.20 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.100 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.100.50 255.255.255.0
serial restart-delay 0
clock rate 2000000
!
router eigrp 100
redistribute static
redistribute bgp 1000 metric 100 1 255 1 1500
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
router bgp 1000
no synchronization
bgp log-neighbor-changes
network 10.20.20.20 mask 255.255.255.255
redistribute connected
redistribute static
redistribute eigrp 100
neighbor 172.16.100.51 remote-as 2000
neighbor 172.16.100.51 next-hop-self
no auto-summary
!
end
|
الموجه R3 |
!
hostname R3
!
ip cef
!
interface Loopback0
ip address 10.22.22.22 255.255.255.255
!
interface Serial0/0
ip address 172.16.100.51 255.255.255.0
serial restart-delay 0
clock rate 2000000
!
router bgp 2000
no synchronization
bgp log-neighbor-changes
network 10.22.22.22 mask 255.255.255.255
network 172.16.100.0 mask 255.255.255.0
neighbor 172.16.100.50 remote-as 1000
neighbor 172.16.100.50 default-originate
default-information originate
!--- Default route is configured!
no auto-summary
!
end
|
التحقق من الصحة
استخدم هذا القسم لتأكيد عمل التكوين بشكل صحيح.
يتم إستخدام محلل واجهة سطر الأوامر (CLI) لعرض تحليل مخرج show الأمر.
ملاحظة: يمكن فقط لمستخدمي Cisco المسجلين الوصول إلى أدوات Cisco ومعلومات داخلية.
إظهار الأوامر
للتحقق من أن EIGRP يستلم المسارات المعاد توزيعها، أستخدم show ip route eigrp الأمر.
show ip route eigrp |
في الموجه R1 R1#show ip route eigrp
10.20.0.0/32 is subnetted, 1 subnets
D EX 10.20.20.20
[170/25625856] via 192.168.1.100, 01:00:33, FastEthernet0/0
10.22.0.0/32 is subnetted, 1 subnets
D EX 10.22.22.22
[170/25625856] via 192.168.1.100, 00:59:49, FastEthernet0/0
10.0.0.0/32 is subnetted, 1 subnets
D 10.10.10.10 [90/409600] via 192.168.1.100, 00:55:17, FastEthernet0/0
D*EX 0.0.0.0/0 [170/25625856] via 192.168.1.100, 00:46:24, FastEthernet0/0
!--- Shows the default route from router R3.
!--- EX indicates that the routes are EIGRP external routes.
|
للتحقق من إعادة توزيع مسارات EIGRP في BGP بشكل صحيح، أستخدم show ip route bgpالأمر في الموجه R3.
show ip route bgp |
في الموجه R3 R3#show ip route bgp
show ip route bgp
10.20.0.0/32 is subnetted, 1 subnets
B 10.20.20.20 [20/0] via 172.16.100.50, 01:03:02
10.0.0.0/32 is subnetted, 1 subnets
B 10.10.10.10 [20/0] via 172.16.100.50, 01:03:02
B 192.168.1.0/24 [20/0] via 172.16.100.50, 01:03:02
10.30.0.0/32 is subnetted, 1 subnets
B 10.30.30.30 [20/409600] via 172.16.100.50, 00:59:06
!--- The output indicates that the EIGRP routes are !--- redistributed in BGP.
|
معلومات ذات صلة