Einleitung
In diesem Dokument wird beschrieben, wie Sie das Problem mit Customer Voice Portal (CVP) Call Studio beheben, wenn Sie keine Projekte aus Call Studio 10.5 in Call Studio 11.0 oder Call Studio 11.5 importieren können.
Voraussetzungen
Anforderungen
Cisco empfiehlt, dass Sie über Kenntnisse in folgenden Bereichen verfügen:
- CVP Call Studio
- CVP-Anrufserver
Die Informationen in diesem Dokument basieren auf folgenden Software-Versionen:
- CVP-Server 11.5
- CVP Call Studio 11.5
Problem
Call Studio-Skripte wurden in Call Studio Version 10.5 entwickelt. Wenn es in CallStudio Version 11.0/11.5 importiert wird, ist bei einigen Skripten der Import fehlgeschlagen und es wurde eine Fehlermeldung angezeigt.
Fehlermeldung
Diese Fehlermeldung wird angezeigt, wenn das Call Studio-Skript importiert wird "Call Studio Project import Failed: Project enthält das Start of Call-Element mit demselben Namen wie ein anderes Element im Hauptfluss. Ab Call Studio 10.5(1) muss der Name des Start-Elements eindeutig sein. Benennen Sie die alte Version von Call Studio um, und wiederholen Sie den Vorgang."
Mögliche Ursachen
Wenn Sie Studio 11.0 aufrufen, darf kein Element den gleichen Namen wie das Element "Beginn des Anrufs" haben.
Dies ist die Ursache der Fehlermeldung, die Sie für den Import der älteren Apps sehen können, die verwendet, um die gleiche zu ermöglichen.
Lösung
Empfohlen
Schritt 1: Importieren Sie das problematische Projekt als reguläres Projekt in Call Studio 11.5 (kein Call Studio Projekt). Das Projekt wurde erfolgreich importiert.
Schritt 2: Suchen Sie nach dem Namen des start-of-call-Elements der Anwendung.
Schritt 3. Wenn Sie mehr als ein Auftreten auf einer Seite der Anwendung finden, dann ist das die Ursache des Importfehlers.
Schritt 4: Erstellen Sie auf der Hauptseite ein neues Page Entry-Element neben dem Start-of-Call-Element.
Schritt 5: Zeigen Sie den Ausgangszustand dieses neuen Elements auf das gleiche Element, auf das das start-of-call-Element zeigt.
Schritt 6: Stellen Sie sicher, dass die Verbindungselemente für Seiteneinträge, die denselben Namen wie das Aufruffeld-Element haben, auf das neue Seiteneintrags-Element zeigen, das auf der Hauptseite erstellt wurde.
Schritt 7. Die Anwendung ist nun kompatibel mit Call Studio 11.0 / 11.5, speichern und exportieren.
Schritt 8: Löschen Sie das importierte Projekt, und importieren Sie es erneut als vorhandenes Call Studio-Projekt.
Hinweis: Dieser Defekt CSCvb95979 wurde für die Ausgabe geöffnet.