In diesem Dokument wird beschrieben, wie jedes Multicast VPN (mVPN)-Profil innerhalb von Cisco IOS® nur für IPv6 konfiguriert wird.
Bevor Sie mit der in diesem Dokument beschriebenen Konfiguration fortfahren, prüfen Sie, ob auf der jeweiligen Plattform, auf der Cisco IOS ausgeführt wird, Unterstützung für ein mVPN-Profil vorhanden ist.
Die Informationen in diesem Dokument basieren auf allen Versionen von Cisco IOS.
Die Informationen in diesem Dokument wurden von den Geräten in einer bestimmten Laborumgebung erstellt. Alle in diesem Dokument verwendeten Geräte haben mit einer leeren (Standard-)Konfiguration begonnen. Wenn Ihr Netzwerk in Betrieb ist, stellen Sie sicher, dass Sie die potenziellen Auswirkungen eines Befehls verstehen.
Ein mVPN-Profil wird für den globalen Kontext oder pro VRF (Virtual Routing/Forwarding) konfiguriert. Nur die neuere Methode zur Definition einer VRF-Instanz (VRF-Definition) kann verwendet werden, um IPv6 für mVPN-Profile zu aktivieren. Hier ein Beispiel:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
!
address-family ipv6
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
Multicast-Routing für IPv6 muss für die Profile im globalen Kontext aktiviert werden. Darüber hinaus muss die Protocol Independent Multicast Version 6 (PIMv6) auf der globalen Loopback-Schnittstelle aktiviert werden. Dies gilt, wenn der Befehl ipv6-Multicast-Routing aktiviert ist und die Loopback-Schnittstelle über eine IPv6-Adresse verfügt oder der Befehl ipv6 enable auf der Loopback-Schnittstelle konfiguriert ist.
ipv6 multicast-routing
Multicast-Routing für IPv6 muss auf der VRF-Instanz für die Profile im VRF-Kontext aktiviert werden.
ipv6 multicast-routing vrf one
Es empfiehlt sich, die Protokollierung von MLDP (Multipoint Label Distribution Protocol) mit diesem globalen Befehl für die Profile mit MLDP zu aktivieren:
mpls mldp logging notifications
PIM für IPv6 ist standardmäßig auf den Schnittstellen im globalen oder VRF-Kontext aktiviert, wenn der entsprechende Befehl ipv6-Multicast-Routing oder ipv6-Multicast-Routing vrf one konfiguriert wurde.
interface Ethernet0/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
ipv6 address 2001:DB8:1::1/64
Dies bedeutet, dass der Befehl ipv6 pim auf den Schnittstellen standardmäßig aktiviert ist. Für die Profile mit VRF müssen 6 Virtual Provider Edge (6VPE) für den Unicast-Datenverkehr vollständig betriebsbereit sein. Für das Profil 7 muss der 6 Provider Edge (6PE) für den Unicast-Datenverkehr voll betriebsbereit sein.
In diesem Abschnitt wird beschrieben, wie Sie die mVPN-Profile innerhalb des Cisco IOS konfigurieren.
Die für die VRF-Instanz konfigurierte VPN-ID ist nur für Profile erforderlich, die MLDP als Core Tree Protocol und Standard Multicast Distribution Tree (MDT) verwenden.
vrf definition one
rd 1:1
vpn id 1000:2000
â¦
Wenn für die Profile mit Standard-MDT und Generic Routing Encapsulation (GRE) mVPN für IPv4 und IPv6 aktiviert ist, muss für beide Adressfamilien (AFs) derselbe Standard-MDT verwendet werden.
Für die verschiedenen AFs können keine Profile gemischt werden.
Wenn für die Profile mit partitioniertem MDT mit MLDP mVPN für IPv4 und IPv6 aktiviert ist, wird für jeden AF für denselben Root-PE-Router ein anderer partitionierter MDT signalisiert. Der Opak-Wert im MLDP-Tree enthält eine andere globale ID (GID). Für beide AFs wird dieselbe LSPVIF-Schnittstelle (Label Switched Path Virtual Interface) verwendet.
Im folgenden Beispiel wird das Profil 14 für die IPv4- und IPv6-Ports der AF verwendet:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
mdt auto-discovery mldp
mdt partitioned mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
address-family ipv6
mdt auto-discovery mldp
mdt partitioned mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
Die Quellen 10.100.1.6 und 2001:DB8:2:6 liegen hinter demselben Quell-PE-Router PE2. Der MRIB-Eintrag (Multicast Routing Information Database) für die IPv4-Multicast-Gruppe und die IPv6-Multicast-Gruppe verwendet einen anderen LSM-Eintrag (Label Switched Multicast) oder MLDP-Eintrag in der Datenbank des Eingangs-PE-Routers, sodass beide Gruppen auf unterschiedlichen MLDP-Trees weitergeleitet werden.
PE2#show mpls mldp database opaque_type gid
LSM ID : 5 Type: P2MP Uptime : 02:18:54
FEC Root : 10.100.1.2 (we are the root)
Opaque decoded : [gid 65536 (0x00010000)]
Opaque length : 4 bytes
Opaque value : 01 0004 00010000
Upstream client(s) :
None
Expires : N/A Path Set ID : 5
Replication client(s):
MDT (VRF one)
Uptime : 02:18:54 Path Set ID : None
Interface : Lspvif1
10.100.1.4:0
Uptime : 00:32:50 Path Set ID : None
Out label (D) : 20 Interface : Ethernet2/0*
Local label (U): None Next Hop : 10.1.2.4
LSM ID : 6 Type: P2MP Uptime : 00:37:06
FEC Root : 10.100.1.2 (we are the root)
Opaque decoded : [gid 131072 (0x00020000)]
Opaque length : 4 bytes
Opaque value : 01 0004 00020000
Upstream client(s) :
None
Expires : N/A Path Set ID : 6
Replication client(s):
MDT (VRF one)
Uptime : 00:37:06 Path Set ID : None
Interface : Lspvif1
10.100.1.4:0
Uptime : 00:18:38 Path Set ID : None
Out label (D) : 22 Interface : Ethernet2/0*
Local label (U): None Next Hop : 10.1.2.4
PE2#show ip mfib vrf one 232.1.1.1
Entry Flags: C - Directly Connected, S - Signal, IA - Inherit A flag,
ET - Data Rate Exceeds Threshold, K - Keepalive
DDE - Data Driven Event, HW - Hardware Installed
ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
MS - MoFRR Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
NS - Negate Signalling, SP - Signal Present,
A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
MA - MFIB Accept, A2 - Accept backup,
RA2 - MRIB Accept backup, MA2 - MFIB Accept backup
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts: Total/RPF failed/Other drops
I/O Item Counts: FS Pkt Count/PS Pkt Count
VRF one
(10.100.1.6,232.1.1.1) Flags:
SW Forwarding: 374/0/100/0, Other: 122/0/122
Ethernet0/0 Flags: A
Lspvif1, LSM/6 Flags: F
Pkts: 374/0
PE2#show ipv6 mfib vrf one route FF3E::4000:1
Entry Flags: C - Directly Connected, S - Signal, IA - Inherit A flag,
ET - Data Rate Exceeds Threshold, K - Keepalive
DDE - Data Driven Event, HW - Hardware Installed
ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
MS - MoFRR Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
NS - Negate Signalling, SP - Signal Present,
A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
MA - MFIB Accept, A2 - Accept backup,
RA2 - MRIB Accept backup, MA2 - MFIB Accept backup
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts: Total/RPF failed/Other drops
I/O Item Counts: FS Pkt Count/PS Pkt Count
VRF one
(2001:DB8:2::6,FF3E::4000:1)
Ethernet0/0 A
Lspvif1, LSM/5 F
In diesem Abschnitt werden die erforderlichen Konfigurationen für jedes Profil beschrieben.
Verwenden Sie diese Konfiguration für Profil 0:
interface Loopback0
ipv6 address 2001:DB8:100::2/128
!
vrf definition one
rd 1:1
!
address-family ipv6
mdt default 232.1.1.1
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
!
address-family ipv4 mdt
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Verwenden Sie diese Konfiguration für Profil 1:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
ipv6 multicast-routing vrf one
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Profil 2 wird derzeit im Cisco IOS nicht unterstützt, und das MLDP unterstützt keinen Partitionierten MDT mit Multipoint-to-Multipoint (MP2MP).
Verwenden Sie diese Konfiguration für Profil 3:
interface Loopback0
ipv6 address 2001:DB8:100::2/128
!
vrf definition one
rd 1:1
!
address-family ipv6
mdt auto-discovery pim
mdt default 232.1.1.1
route-target export 123:456
route-target import 123:456
exit-address-family
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Profil 4 wird derzeit von Cisco IOS nicht unterstützt, und MLDP unterstützt keinen partitionierten MDT mit MP2MP.
Profil 5 wird derzeit im Cisco IOS nicht unterstützt, und die PIM-Signalisierung wird nicht über einen partitionierten MDT unterstützt.
Verwenden Sie diese Konfiguration für Profil 6:
vrf definition one
rd 1:1
!
address-family ipv6
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
ipv6 multicast-routing vrf one
ipv6 multicast vrf one mpls source Loopback0
ipv6 multicast vrf one mpls mldp
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Verwenden Sie diese Konfiguration für Profil 7:
ipv6 multicast-routing
ipv6 multicast mpls source Loopback0
ipv6 multicast mpls mldp
interface Ethernet0/0
ip address 10.2.2.2 255.255.255.0
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 2001:DB8:2::6 remote-as 65002
!
!
address-family ipv6
redistribute connected
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-label
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Profil 8 wird derzeit im Cisco IOS nicht unterstützt.
Verwenden Sie diese Konfiguration für Profil 9:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
ipv6 multicast-routing vrf one
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Profile 10 wird derzeit im Cisco IOS nicht unterstützt, und BGP-AD wird für Point-to-Multipoint Traffic Engineering (P2MP TE) nicht unterstützt.
Verwenden Sie diese Konfiguration für Profil 11:
interface Loopback0
ipv6 address 2001:DB8:100::2/128
!
vrf definition one
rd 1:1
!
address-family ipv6
mdt auto-discovery pim
mdt default 232.1.1.1
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Verwenden Sie diese Konfiguration für Profil 12:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
Verwenden Sie diese Konfiguration für Profil 13:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
ipv6 multicast-routing vrf one
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Verwenden Sie diese Konfiguration für Profil 14:
vrf definition one
rd 1:1
!
address-family ipv6
mdt auto-discovery mldp
mdt strict-rpf interface
mdt partitioned mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 2001:DB8:2::6 remote-as 65002
!
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate exit-address-family
Profil 15 wird derzeit von Cisco IOS nicht unterstützt, und MLDP unterstützt keinen partitionierten MDT mit MP2MP.
Profil 16 wird derzeit im Cisco IOS nicht unterstützt.
Verwenden Sie diese Konfiguration für Profil 17:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp p2mp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
Profil 18 wird derzeit im Cisco IOS nicht unterstützt.
Profile 19 und Ingress Replication (IR) werden im Cisco IOS derzeit nicht unterstützt.
Profile 20 und P2MP Auto-Tunnels TE werden derzeit im Cisco IOS nicht unterstützt.
Profile 21 und IR werden derzeit im Cisco IOS nicht unterstützt.
Profile 22 und P2MP Auto-Tunnels TE werden derzeit im Cisco IOS nicht unterstützt.
Profile 23 und IR werden derzeit im Cisco IOS nicht unterstützt.
Profile 24 und P2MP Auto-Tunnels TE werden im Cisco IOS derzeit nicht unterstützt.
Profile 25 und IR werden derzeit im Cisco IOS nicht unterstützt.
Profile 26 und P2MP Auto-Tunnels TE werden derzeit im Cisco IOS nicht unterstützt.
Für diese Konfigurationen ist derzeit kein Überprüfungsverfahren verfügbar.
Für diese Konfigurationen sind derzeit keine spezifischen Informationen zur Fehlerbehebung verfügbar.
Überarbeitung | Veröffentlichungsdatum | Kommentare |
---|---|---|
1.0 |
15-Jun-2015 |
Erstveröffentlichung |