The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
This document describes Connectivity Fault Management (CFM) technology, configuration, post-checks, and troubleshooting. The basic concepts of CFM, CFM's building blocks, a configuration guide, show commands, and Wireshark analysis of CFM messages is provided. This document does not explain hardware limitations or the supported interface for CFM to work.
Cisco recommends that you have knowledge of these topics:
This document is not restricted to specific software and hardware versions.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, ensure that you understand the potential impact of any command.
Ethernet CFM is an end-to-end per-service-instance Ethernet layer operation, administration, and management (OAM) protocol. It includes proactive connectivity monitoring, fault verification, and fault isolation for large Ethernet metropolitan-area networks (MANs) and WANs.
The advent of Ethernet as a MAN and WAN technology imposes a new set of OAM requirements on Ethernet's traditional operations, which were centered on enterprise networks only. The expansion of Ethernet technology into the domain of service providers, where networks are substantially larger and more complex than enterprise networks and the user base is wider, makes operational management of link uptime crucial. More importantly, the timeliness to isolate and respond to a failure becomes mandatory for normal day-to-day operations, and OAM translates directly to the competitiveness of the service provider.
There are three (3) protocols defined by CFM:
multicast "heart-beat"
messages are transmitted at a configurable periodic interval by MEPs (3.3ms, 10ms, 100ms, 1s, 10s, 1min, 10min) - Uni-directional (no response required)Ethernet Ping
Ethernet Traceroute
In order to put all three protocols together and implement them in the network, complete these steps:
In order to explore the configuration, a small topology was built for demonstration. The names used for Domain, Service name, and EVC Name are shown here:
Domain: ISPdomain
Domain level: 5
Service Name: XCONN_EVC
EVC Name: EVC_CE1
PE1:
---------------------------Enabling CFM globally-------------------------------------
ethernet cfm ieee
ethernet cfm distribution enable
ethernet cfm global
ethernet cfm traceroute cache
ethernet cfm alarm notification all
ethernet cfm domain ISPdomain level 5
service XCONN_EVC evc EVC_CE1
continuity-check
---------------------------Enabling CFM MEP under EVC----------------------------
int gig4/2
service instance 2100 ethernet EVC_CE1
encapsulation dot1q 2100
xconnect 192.168.3.3 2100 encapsulation mpls
cfm mep domain ISPdomain mpid 102
monitor loss counter
PE3:
---------------------------Enabling CFM globally-------------------------------------
ethernet cfm ieee
ethernet cfm distribution enable
ethernet cfm global
ethernet cfm traceroute cache
ethernet cfm alarm notification all
ethernet cfm domain ISPdomain level 5
service XCONN_EVC evc EVC_CE1
continuity-check
---------------------------Enabling CFM MEP under EVC----------------------------
int gig4/2
service instance 2100 ethernet EVC_CE1
encapsulation dot1q 2100
xconnect 192.168.1.1 2100 encapsulation mpls
cfm mep domain ISPdomain mpid 201
monitor loss counter
PE1#show ethernet cfm maintenance-points local
Local MEPs:
--------------------------------------------------------------------------------
MPID Domain Name Lvl MacAddress Type CC
Ofld Domain Id Dir Port Id
MA Name SrvcInst Source
EVC name
--------------------------------------------------------------------------------
102 ISPdomain 5 ccef.48d0.64b0 XCON Y
No ISPdomain Up Gi4/2 N/A
XCONN_EVC 2100 Static
EVC_CE1
Total Local MEPs: 1
PE1#show ethernet cfm maintenance-points remote
--------------------------------------------------------------------------------
MPID Domain Name MacAddress IfSt PtSt
Lvl Domain ID Ingress
RDI MA Name Type Id SrvcInst
EVC Name Age
Local MEP Info
--------------------------------------------------------------------------------
201 ISPdomain 8843.e1df.00b0 Up Up
5 ISPdomain Gi4/2:(192.168.3.3, 2100)
- XCONN_EVC XCON N/A 2100
EVC_CE1 5s
MPID: 102 Domain: ISPdomain MA: XCONN_EVC
In this output you can see the remote mpid and remote MAC address. CFM status shows up/up.
PE1#ping ethernet mpid 201 domain ISPdomain service XCONN_EVC
Type escape sequence to abort.
Sending 5 Ethernet CFM loopback messages to 8843.e1df.00b0, timeout is 5 seconds:!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
PE1#traceroute ethernet mpid 201 domain ISPdomain service XCON$
Type escape sequence to abort. TTL 64. Linktrace Timeout is 5 seconds
Tracing the route to 8843.e1df.00b0 on Domain ISPdomain, Level 5,
service XCONN_EVC, evc EVC_CE1
Traceroute sent via Gi4/2:(192.168.3.3, 2100), path found via MPDB
B = Intermediary Bridge
! = Target Destination
* = Per hop Timeout
--------------------------------------------------------------------------------
MAC Ingress Ingr Action Relay Action
Hops Host Forwarded Egress Egr Action Previous Hop
--------------------------------------------------------------------------------
B 1 ccef.48d0.64b0 Gi4/2 IngOk RlyMPDB
Forwarded
! 2 8843.e1df.00b0 RlyHit:MEP
Not Forwarded ccef.48d0.64b0
A sniffer device was placed on PE1, which captures all CFM packets that come remotely. An example is shown here:
In the screen shot:
In the previous example, the EVC can used by CE1 which is located behind the PE1 and PE3. You can enable down MEP on the CE1 device, but with a higher level of MD. MD level 7 is shown in this example.
Domain: CEdomain
Domain level: 7
CE1_A
--------------------Enabling CFM globally---------------------------
ethernet cfm ieee
ethernet cfm global
ethernet cfm domain CEdomain level 7
service CUST vlan 2100 direction down (down Mep)
continuity-check
------------------Enabling CFM MEP under interface--------------------
interface GigabitEthernet1/0/1
switchport access vlan 2100
switchport trunk encapsulation dot1q
switchport mode trunk
ethernet cfm mep domain CEdomain mpid 1002 service CUST
CE1_B
--------------------Enabling CFM globally---------------------------
ethernet cfm ieee
ethernet cfm global
ethernet cfm domain CEdomain level 7
service CUST vlan 2100 direction down
continuity-check
------------------Enabling CFM MEP under interface--------------------
interface GigabitEthernet1/0/1
switchport access vlan 2100
switchport trunk encapsulation dot1q
switchport mode trunk
ethernet cfm mep domain CEdomain mpid 2001 service CUST
CE1#show ethernet cfm maintenance-points remote
--------------------------------------------------------------------------------
MPID Domain Name MacAddress IfSt PtSt
Lvl Domain ID Ingress
RDI MA Name Type Id SrvcInst
EVC Name Age
Local MEP Info
--------------------------------------------------------------------------------
2001 CEdomain 5835.d970.9381 Up Up
7 CEdomain Gi1/0/1
- CUST Vlan 2100 N/A
N/A 3s
MPID: 1002 Domain: CEdomain MA: CUST
Total Remote MEPs: 1
CE1#show ethernet cfm maintenance-points local
Local MEPs:
--------------------------------------------------------------------------------
MPID Domain Name Lvl MacAddress Type CC
Ofld Domain Id Dir Port Id
MA Name SrvcInst Source
EVC name
--------------------------------------------------------------------------------
1002 CEdomain 7 0023.eac6.8d01 Vlan Y
No CEdomain Down Gi1/0/1 2100
CUST N/A Static
N/A
CE1#ping ethernet mpid 2001 domain CEdomain service CUST
Type escape sequence to abort.
Sending 5 Ethernet CFM loopback messages to 5835.d970.9381, timeout is 5 seconds:!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Total Local MEPs: 1
Till now MIP is not configured on PE1 and PE3 hence output of show command and
traceroute command will be as per below.
CE1#tracer ethernet mpid 2001 domain CEdomain service CUST
Type escape sequence to abort. TTL 64. Linktrace Timeout is 5 seconds
Tracing the route to 5835.d970.9381 on Domain CEdomain, Level 7, vlan 2100
Traceroute sent via Gi1/0/1
B = Intermediary Bridge
! = Target Destination
* = Per hop Timeout
--------------------------------------------------------------------------------
MAC Ingress Ingr Action Relay Action
Hops Host Forwarded Egress Egr Action Previous Hop
--------------------------------------------------------------------------------
! 1 5835.d970.9381 Gi1/0/1 IngOk RlyHit:MEP
Not Forwarded 0023.eac6.8d01
CE1_A can see CE1_B via traceroute.
Now, configure MIP on PE1 and PE2.
PE1:
interface GigabitEthernet 4/2
service instance 2100 ethernet EVC_CE1
cfm mip level 7
PE2:
interface GigabitEthernet 4/2
service instance 2100 ethernet EVC_CE1
cfm mip level 7
Now, check the traceroute results from CE1.
CE1#traceroute ethernet mpid 2001 domain CEdomain service CUST
Type escape sequence to abort. TTL 64. Linktrace Timeout is 5 seconds
Tracing the route to 5835.d970.9381 on Domain CEdomain, Level 7, vlan 2100
Traceroute sent via Gi1/0/1
B = Intermediary Bridge
! = Target Destination
* = Per hop Timeout
--------------------------------------------------------------------------------
MAC Ingress Ingr Action Relay Action
Hops Host Forwarded Egress Egr Action Previous Hop
--------------------------------------------------------------------------------
B 1 ccef.48d0.64b0 Gi4/2 IngOk RlyMPDB
Forwarded 0023.eac6.8d01
B 2 8843.e1df.00b0 RlyMPDB
Forwarded Gi4/2 EgrOK ccef.48d0.64b0
! 3 5835.d970.9381 Gi1/0/1 IngOk RlyHit:MEP
Not Forwarded 8843.e1df.00b0
You can see the difference in the traceroute output. Iintermediate hops are seen after MIPs on PE1 and PE2 are configured.
debug ethernet cfm diagnostic packets
debug ethernet cfm packets
IP SLA for Metro Ethernet
ethernet cfm distribution enable
platform time-source
monitor loss counter
The previous commands have already been enabled in Fault Management, therefore just IP SLA is enabled to start with Performance Management.
Ip sla 10
Ethernet y1731 loss LMM domain SPdomain evc EVC_CE1 mpid 201 cos 8 source mpid 102
Frame interval 100
Aggregate interval 180
Ip sla schedule 10 start-time after 00:00:30 life forever.
PE1#show ip sla stat 10
IPSLAs Latest Operation Statistics
IPSLA operation id: 10
Loss Statistics for Y1731 Operation 10
Type of operation: Y1731 Loss Measurement
Latest operation start time: 09:30:11.332 UTC Fri Dec 20 2013
Latest operation return code: OK
Distribution Statistics:
Interval
Start time: 09:30:11.332 UTC Fri Dec 20 2013
Elapsed time: 56 seconds
Number of measurements initiated: 120
Number of measurements completed: 120
Flag: OK
PE1#show ethernet cfm pm session active
Display of Active Session
----------------------------------------------------------------------------
EPM-ID SLA-ID Lvl/Type/ID/Cos/Dir Src-Mac-address Dst-Mac-address
----------------------------------------------------------------------------
0 10 5/XCON/N/A/7/Up ccef.48d0.64b0 8843.e1df.00b0
Total number of Active Session: 1
--> Src-Mac-address: SRC MAC of MEP,check 'show ethernet cfm maintenance-points local'
--> Dst-Mac-address: MAC of dest MEP,check 'show ethernet cfm maintenance-points remote'
PE1#show ethernet cfm pm session detail 0
Session ID: 0
Sla Session ID: 10
Level: 5
Service Type: XCO
Service Id: N/A
Direction: Up
Source Mac: ccef.48d0.64b0
Destination Mac: 8843.e1df.00b0
Session Status: Active
MPID: 102
Tx active: yes
Rx active: yes
Timeout timer: stopped
Last clearing of counters: 08:54:20.079 UTC Sat Dec 20 2013
DMMs:
Transmitted: 0
DMRs:
Rcvd: 0
1DMs:
Transmitted: 0
Rcvd: 0
LMMs:
Transmitted: 3143161
LMRs
Rcvd: 515720
VSMs: Transmitted: 0
VSRs: Rcvd: 0
debug ip sla trace <oper_id>
debug ip sla error <oper_id
Revision | Publish Date | Comments |
---|---|---|
1.0 |
09-Apr-2014 |
Initial Release |