Introduction
This document describes how to troubleshoot Customer Voice Portal (CVP) Call Studio issue when unable to import projects from Call Studio 10.5 into Call Studio 11.0, or Call Studio 11.5.
Prerequisites
Requirements
Cisco recommends that you have knowledge of these topics:
- CVP Call Studio
- CVP Call Server
The information in this document is based on these software versions:
- CVP Server 11.5
- CVP Call Studio 11.5
Problem
Call Studio scripts have been developed in Call Studio version 10.5. When it is imported in CallStudio version 11.0/11.5, for few scripts, import failed and showed an error message.
Error Message
This error message shows when the Call Studio Script is imported "Call Studio Project import Failed: Project contains Start of Call element with same name as another element in main flow. From Call Studio 10.5(1) onwards, Start of Call element name must be unique. Please rename using previous version of Call Studio and retry".
Possible Causes
Call Studio 11.0 onwards, no element is allowed to have the same name as the ‘start of call’ element.
This is the root cause of the error message which you can see for import of the older apps, which used to allow the same.
Solution
Recomended Action
Step 1. Import the problematic project into Call Studio 11.5 as a regular project (not a call studio project). The project is imported successfully.
Step 2. Search for the name of the start-of-call element of the application.
Step 3. If you find more than one occurrence of it on any page of the application, then that is the root cause of the import error.
Step 4. On the main page, create a new Page Entry element alongside the start-of-call element.
Step 5. Point the exit state of this new element to the same element that the start-of-call element points to.
Step 6. Make the occurrences of the page entry connectors, having the same name as the start-of-call element, to point to the new Page Entry element created on the main page.
Step 7. The application is now compatible with Call Studio 11.0 / 11.5, save and export it.
Step 8. Delete the imported project and reimport as existing Call Studio project.
Note: This defect CSCvb95979 was opened for the issue.