Introduction
This document describes the named Enhanced Interior Gateway Routing Protocol (EIGRP) mode feature and discusses differences between traditional and named mode with the help of a relevant configuration.
Prerequisites
Requirements
Cisco recommends that you have basic knowledge of IP Routing and the EIGRP protocol.
Components Used
This document is not restricted to specific software and hardware versions.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.
Background Information
The traditional way to configure EIGRP requires various parameters to be configured under the interface and EIGRP configuration mode. In order to configure EIGRP IPV4 and IPv6, it is required to configure separate EIGRP instances. Traditional EIGRP does not support Virtual Routing and Forwarding (VRF) in IPv6 EIGRP implementations.
With Named mode EIGRP, everything is configured at a single place under the EIGRP configuration and there are no restrictions as mentioned previously.
Configure
Network Diagram
This image is a sample topology for the rest of the document.
Unlike the traditional method, the EIGRP instance is neither created nor started when this is configured on the router:
R1(config)#router eigrp TEST
The instance will be created when address-family and autonomous system number is configured, for example:
R1(config-router)#address-family ipv4 unicast autonomous-system 1
With this named mode, only a single instance of EIGRP needs to be created. It can be used for all address family types. It also supports multiple VRFs limited only by available system resources. One thing to be aware of in regards to the named mode is that configuration of the address-family does not enable IPv4 routing as a traditional configuration of IPv4 EIGRP. A 'no shut' is required in order to start the process:
router eigrp [virtual-instance-name | asystem]
[no] shutdown
Named EIGRP has three modes under which the bulk of the configuration is completed. These are:
- address-family configuration mode - (config-router-af)#
- address-family interface configuration mode - (config-router-af-interface)#
- address-family topology configuration mode - (config-router-af-topology)#
Address-family Configuration Mode
You enter this mode with this command:
R1(config-router)#address-family ipv4 unicast autonomous-system 1
R1(config-router-af)#?
Address Family configuration commands:
af-interface Enter Address Family interface configuration
default Set a command to its defaults
eigrp EIGRP Address Family specific commands
exit-address-family Exit Address Family configuration mode
help Description of the interactive help system
maximum-prefix Maximum number of prefixes acceptable in aggregate
metric Modify metrics and parameters for advertisement
neighbor Specify an IPv4 neighbor router
network Enable routing on an IP network
no Negate a command or set its defaults
shutdown Shutdown address family
timers Adjust peering based timers
topology Topology configuration mode
In this mode, these parameters can be configured: Networks, EIGRP neighbor, and EIGRP Router-id. The other two configuration modes of named EIGRP are accessed from this mode.
Traditional Configuration
Interface GigabitEthernet 0/0
ip bandwidth-percent eigrp 1 75
ipv6 enable
ipv6 eigrp 1
ip bandwidth-percent eigrp 1 75
no shut
!
router eigrp 1
eigrp router-id 10.10.10.1
network 0.0.0.0 0.0.0.0
ipv6 router eigrp 1
eigrp router-id 10.10.10.1
no shut
Named Configuration
router eigrp TEST
!
address-family ipv4 unicast autonomous-system 1
!
network 0.0.0.0
eigrp router-id 10.10.10.1
no shutdown
exit-address-family
!
address-family ipv6 unicast autonomous-system 1
!
eigrp router-id 10.10.10.1
no shutdown
exit-address-family
Address-family Interface Configuration Mode
This mode takes all the interface specific commands that were previously configured on an actual interface (logical or physical). EIGRP authentication, split-horizon, and summary-address configuration are some of the options that are now configured here instead of on the actual interface:
R1(config-router-af)#af-interface g0/0
R1(config-router-af-interface)#?
Address Family Interfaces configuration commands:
authentication authentication subcommands
bandwidth-percent Set percentage of bandwidth percentage limit
bfd Enable Bidirectional Forwarding Detection
dampening-change Percent interface metric must change to cause update
dampening-interval Time in seconds to check interface metrics
default Set a command to its defaults
exit-af-interface Exit from Address Family Interface configuration
hello-interval Configures hello interval
hold-time Configures hold time
next-hop-self Configures EIGRP next-hop-self
no Negate a command or set its defaults
passive-interface Suppress address updates on an interface
shutdown Disable Address-Family on interface
split-horizon Perform split horizon
summary-address Perform address summarization
Note: You can use the af-interface default command in order to apply the configuration to all the interfaces at once.
Address-family Topology Configuration Mode
This mode provides several configuration options which operate on the EIGRP topology table. Things like redistribution, distance, offset list, variance and so on can be configured under this mode. You can enter this mode from the address-family configuration mode.
R1(config-router-af)#topology base
R1(config-router-af-topology)#?
Address Family Topology configuration commands:
auto-summary Enable automatic network number summarization
default Set a command to its defaults
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter entries in eigrp updates
eigrp EIGRP specific commands
exit-af-topology Exit from Address Family Topology configuration
maximum-paths Forward packets over multiple paths
metric Modify metrics and parameters for advertisement
no Negate a command or set its defaults
offset-list Add or subtract offset from EIGRP metrics
redistribute Redistribute IPv4 routes from another routing proto
summary-metric Specify summary to apply metric/filtering
timers Adjust topology specific timers
traffic-share How to compute traffic share over alternate paths
variance Control load balancing variance
Comparison
A comparison between the two configuration modes that were discussed is shown here:
Availability
The EIGRP named configuration is available from these Cisco IOS® releases:
- 15.0(1)M
- 12.2(33)SRE
- 12.2(33)XNE
- Cisco IOS XE Release 2.5
Automatic Conversion to Named EIGRP
There is an automatic method to convert the configuration from the traditional way to the new method. Inside the EIGRP process, the command
eigrp upgrade-cli <EIGRP Virtual-Instance Name> needs to be entered. This automatically converts the configuration to the named mode without an impact to the established EIGRP peering:
Traditional Configuration
router eigrp 1
network 10.10.10.1 0.0.0.0
!
interface Ethernet0/0
ip address 10.10.10.1 255.255.255.0
ip hello-interval eigrp 1 100
Configuration
R1(config)#router eigrp 1
R1(config-router)#eigrp upgrade-cli TEST
Configuration will be converted from router eigrp 1 to router eigrp TEST.
Are you sure you want to proceed? ? [yes/no]: yes
*Oct 10 14:14:40.684: EIGRP: Conversion of router eigrp 1 to router eigrp TEST -
Completed.
Converted Named Configuration
router eigrp TEST
!
address-family ipv4 unicast autonomous-system 1
!
af-interface Ethernet0/0
hello-interval 100
exit-af-interface
!
topology base
exit-af-topology
network 10.10.10.1 0.0.0.0
exit-address-family
Verify
There is currently no verification procedure available for this configuration.
Troubleshoot
There is currently no specific troubleshooting information available for this configuration.