The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
This document describes the behavior of Intermediate System to Intermediate System (ISIS) attach bit.
Cisco recommends that you have knowledge of these topics:
This document is not restricted to specific software and hardware versions.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.
Here are the few things to remember and the behavior of attach bit with respect to ISIS.
1. In ISIS network, there are 3 type of routers, Level1 (L1) router, Level 2 (L2) router and Level1Level2 (L1L2) router .
2. Like OSPF, ISIS has L2 area as backbone area.
3. Router which is connected to both the areas i.e. Level 1 and Level 2 is called L1L2 route.
4. OSPF has a concept of multiple areas to limit the Shortest Path First (SPF) calculation scope and same is the reason to have different areas in ISIS.
5. Level 1 and Level 2 ISIS router generates Level 1 and Level 2 Link-State PDUs (LSPs) respectively. L1L2 router generates both the LSP (i.e Level1 and Level2).
6. In case, Level 1 router needs to reach L2 network, then Level 1 router would send the packet to L1L2 router in order to reach the backbone area.
7. By default, Level 2 routers are not leaked into Level 1 areas by L1L2 router, although Level 1 routers always propagate to Level 2 area.
8. In order to reach Level 2 area, L1L2 router sets the Attach bit in Level1 LSP. Level1 router installs the default route in routing table, this route would point towards L1L2 router.
9. In case the network has more than one L1L2 router which connects the same L1 area, then it may lead to suboptimal routing as level2 route does not flow into level1 area. Level 1 area only installs the default route which points towards the L1L2 router which is the nearest. Leaking of level2 route into level1 can be done to overcome these limitation.
Consider this network topology in order to understand the loop-prevention techniques.
R1#sh run int lo 0
Building configuration...
Current configuration : 82 bytes
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
ip router isis 1
end
R1#sh run int ethernet 0/0
Building configuration...
Current configuration : 127 bytes
!
interface Ethernet0/0
ip address 10.10.12.1 255.255.255.0
ip router isis 1
isis circuit-type level-1
end
R1#sh run int ethernet 0/1
Building configuration...
Current configuration : 111 bytes
!
interface Ethernet0/1
ip address 10.10.13.1 255.255.255.0
ip router isis 1
isis circuit-type level-1
end
!
router isis 1
net 49.0001.0000.0000.0001.00 >>>>> Area is 49.0001
is-type level-1 >>>>>>>>>> Globally this router belongs to Level1
R2#sh run int lo 0
Building configuration...
Current configuration : 82 bytes
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
ip router isis 1
end
R2#sh run int eth0/0
Building configuration...
Current configuration : 111 bytes
!
interface Ethernet0/0
ip address 10.10.12.2 255.255.255.0
ip router isis 1
isis circuit-type level-1 >>>>>> Circuit type is L1 towards R1
end
R2#sh run int eth0/1
Building configuration...
Current configuration : 84 bytes
!
interface Ethernet0/1
ip address 10.10.24.2 255.255.255.0
ip router isis 1
end
!
router isis 1
net 49.0001.0000.0000.0002.00
R3#sh run int lo 0
Building configuration...
Current configuration : 82 bytes
!
interface Loopback0
ip address 10.3.3.3 255.255.255.255
ip router isis 1
end
R3#sh run int eth0/0
Building configuration...
Current configuration : 84 bytes
!
interface Ethernet0/0
ip address 10.10.13.3 255.255.255.0
ip router isis 1
end
R3#sh run int eth0/1
Building configuration...
Current configuration : 84 bytes
!
interface Ethernet0/1
ip address 10.10.34.3 255.255.255.0
ip router isis 1
end
!
router isis 1
net 49.0001.0000.0000.0003.00
R4#sh run int lo 0
Building configuration...
Current configuration : 82 bytes
!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
ip router isis 1
end
R4#sh run int ethernet 0/0
Building configuration...
Current configuration : 84 bytes
!
interface Ethernet0/0
ip address 10.10.24.4 255.255.255.0
ip router isis 1
end
R4#sh run int ethernet 0/1
Building configuration...
Current configuration : 84 bytes
!
interface Ethernet0/1
ip address 10.10.34.4 255.255.255.0
ip router isis 1
end
!
router isis 1
net 49.0002.0000.0000.0004.00 >>>> Area on R4 is 49.0002.
Note: Router between two different areas are always from Level 2 neighbor relationship. In our case, R4 area is 49.0002 and R2 and R3 area is 49.0001. So, R4 must have L2 adjacency with R2 and R3.
Use this section in order to confirm that your configuration works properly.
R1#show clns neighbors
Tag 1:
System Id Interface SNPA State Holdtime Type Protocol
R2 Et0/0 aabb.cc01.f600 Up 6 L1 IS-IS
R3 Et0/1 aabb.cc01.f700 Up 9 L1 IS-IS
R1#
R1 neighbor relationship with R2 and R3 is only L1
R2#sh clns neighbors
Tag 1:
System Id Interface SNPA State Holdtime Type Protocol
R1 Et0/0 aabb.cc01.f500 Up 24 L1 IS-IS
R4 Et0/1 aabb.cc01.f800 Up 9 L2 IS-IS
R2 neighbor relationship with R1 is L1
R2 neighbor relationship with R4 is L2
So R2 is L1L2 router as it is building both adjanceny i.e. L1 and L2 neighbor
R3#sh clns neighbors
Tag 1:
System Id Interface SNPA State Holdtime Type Protocol
R1 Et0/0 aabb.cc01.f510 Up 25 L1 IS-IS
R4 Et0/1 aabb.cc01.f810 Up 7 L2 IS-IS
R3 neighbor relatioship with R1 is L1
R3 neighbor relationship with R4 is L2
So R3 is L1L2 router as it is building both adjanceny i.e. L1 and L2 neighbor
R4#sh clns neighbors
Tag 1:
System Id Interface SNPA State Holdtime Type Protocol
R2 Et0/0 aabb.cc01.f610 Up 29 L2 IS-IS
R3 Et0/1 aabb.cc01.f710 Up 23 L2 IS-IS
R4 neighbor relationship with R2 and R3 is L2 only .
In this topology, R2 and R3 are L1L2 router so they must set attach bit and as a result R1 must have the two default route.
R1#show isis database
Tag 1:
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 * 0x0000002B 0x4269 576 0/0/0
R2.00-00 0x00000033 0xB1CA 997 1/0/0
R2.01-00 0x0000001F 0x42F0 1018 0/0/0
R3.00-00 0x0000002B 0xCA5E 857 1/0/0
R3.01-00 0x0000001B 0x50E4 964 0/0/0
ATT ( which is marked in Bold ) represents attach bit and is set to 1 for both R2 and R3
router in Level 1 LSP . ATT bit is only set in Level1 LSP .
R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is 10.10.13.3 to network 0.0.0.0
i*L1 0.0.0.0/0 [115/10] via 10.10.13.3, 00:00:26, Ethernet0/1
[115/10] via 10.10.12.2, 00:00:26, Ethernet0/0
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
C 10.1.1.1/32 is directly connected, Loopback0
i L1 10.2.2.2/32 [115/20] via 10.10.12.2, 00:00:26, Ethernet0/0
i L1 10.3.3.3/32 [115/20] via 10.10.13.3, 00:46:55, Ethernet0/1
C 10.10.12.0/24 is directly connected, Ethernet0/0
L 10.10.12.1/32 is directly connected, Ethernet0/0
C 10.10.13.0/24 is directly connected, Ethernet0/1
L 10.10.13.1/32 is directly connected, Ethernet0/1
i L1 10.10.24.0/24 [115/20] via 10.10.12.2, 00:00:26, Ethernet0/0
i L1 10.10.34.0/24 [115/20] via 10.10.13.3, 00:46:55, Ethernet0/1
In route table R1 is installing default route towards R2 and R3 .
Routing table here does not have any specific route for R4 because by default Level2 routes are not leaked into Level1 areas. It relies on default table for forwarding traffic and this may lead to suboptimal routing. In above case, both default route got installed because both are of same metric. If metric gets increased between the R1 and R2, then the router must only install default route towards R2.
R1(config)#int eth0/0
R1(config-if)#isis metric 20 >>>>> Metric is increased by 20
R1#sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
Known via "isis", distance 115, metric 10, candidate default path, type level-1
Redistributing via isis 1
Last update from 10.10.13.3 on Ethernet0/1, 00:00:05 ago
Routing Descriptor Blocks:
* 10.10.13.3, from 10.3.3.3, 00:00:05 ago, via Ethernet0/1
Route metric is 10, traffic share count is 1
Now only 1 default route in routing table i.e. towards R3 .
In above case, all traffic for R4 would be forwarded towards R3 and link towards R2 is not used. In order to utilize link towards R2, redistribution need to be done on R2. In order to depict this, loopback 0 on R4 is leaked into R2 through redistribution .
R4#sh run int lo 1
Building configuration...
Current configuration : 85 bytes
!
interface Loopback1
ip address 10.44.44.44 255.255.255.255
ip router isis 1
end
R2#
router isis 1
net 49.0001.0000.0000.0002.00
redistribute isis ip level-2 into level-1 route-map LEVEL2_into_Level1
R2#show route-map
route-map LEVEL2_into_Level1, permit, sequence 10
Match clauses:
ip address (access-lists): 10
Set clauses:
Policy routing matches: 0 packets, 0 bytes
!
R2#sh access-lists 10
Standard IP access list 10
10 permit 10.4.4.4 (22 matches)
R1 database and routing table after redistribution:
R1#show isis database R2.00-00 detail
Tag 1:
IS-IS Level-1 LSP R2.00-00
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R2.00-00 0x00000036 0xABCD 859 1/0/0
Area Address: 49.0001
NLPID: 0xCC
Hostname: R2
IP Address: 10.2.2.2
Metric: 10 IP 10.10.12.0 255.255.255.0
Metric: 10 IP 10.2.2.2 255.255.255.255
Metric: 10 IP 10.10.24.0 255.255.255.0
Metric: 10 IS R2.01
Metric: 148 IP-Interarea 10.4.4.4 255.255.255.255
After redistribution 10.4.4.4/32 route is being seen into R1 database .
R1#sh ip route 10.4.4.4
Routing entry for 10.4.4.4/32
Known via "isis", distance 115, metric 168, type inter area
Redistributing via isis 1
Last update from 10.10.12.2 on Ethernet0/0, 00:06:32 ago
Routing Descriptor Blocks:
* 10.10.12.2, from 10.2.2.2, 00:06:32 ago, via Ethernet0/0
Route metric is 168, traffic share count is 1
After redistribution 10.4.4.4/32 is also present in routing table as well .
Note: In this case, R2 advertises specific route in routing table but it does not advertise default route. R1 sees attach bit in Level1 LSP and it installs default route in routing table.
There is currently no specific troubleshooting information available for this configuration.