The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
This document describes how to configure each Multicast VPN (mVPN) profile within the Cisco IOS®.
Note: The configurations that are described in this document apply to the Provider Edge (PE) routers.
Before you proceed with the configuration that is described in this document, verify whether there is support for an mVPN profile on the specific platform that runs Cisco IOS.
The information in this document is based on all versions of the Cisco IOS.
The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.
This section describes how to configure the mVPN profiles within the Cisco IOS.
Note: Use the Command Lookup Tool (registered customers only) in order to obtain more information on the commands used in this section.
Note: Not all profiles are currently supported in the Cisco IOS.
Note: The Virtual Routing/Forwarding (VRF) that is used throughout this document is VRF one. The Rosen MLDP has been renamed to Default MDT.
An mVPN profile is configured for the global context or per VRF. You can use either the old or new method in order to define a VRF when you configure mVPN profiles in the Cisco IOS.
Here is an example of the old method:
ip vrf one
rd 1:1
route-target export 1:1
route-target import 1:1
Here is an example of the new method:
vrf definition one
rd 1:1
!
address-family ipv4
route-target export 1:1
route-target import 1:1
exit-address-family
For the profiles in the global context, multicast-routing must be enabled:
ip multicast-routing
For the profiles in the VRF context, multicast-routing must be enabled for the VRF:
ip multicast-routing vrf one
You can enable the logging of Multipoint Label Distribution Protocol (MLDP) with this global command for the profiles with MLDP:
mpls mldp logging notifications
The Protocol Independent Multicast (PIM) must be enabled for the Provider Edge (PE) router on the Provider Edge-Customer Edge (PE-CE) link for both the cases (global or VRF context):
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
Fast Re-Route (FRR) for MLDP is available in the Cisco IOS. The multicast traffic for which MLDP is the control plane protocol must use a primary Traffic Engineering (TE) tunnel in order to have the traffic protected by FRR. The primary TE tunnel can be a manual TE tunnel or a primary auto-tunnel. The link must be protected by TE FRR, either by a manual backup tunnel or a backup auto-tunnel.
This example uses a manual primary and manual backup tunnel.
This global command must be configured in order for MLDP to use Multiprotocol Label Switching (MPLS) TE tunnels:
mpls mldp path traffic-eng
This configuration is used for the protected interface that is used by the primary one-hop tunnel:
interface Ethernet3/0
ip address 10.1.6.6 255.255.255.0
load-interval 30
mpls ip
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel0
ip rsvp bandwidth 10000
end
This configuration is used for the backup tunnel:
interface Tunnel0
ip unnumbered Loopback0
load-interval 30
tunnel source Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.100.1.3
tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3
This configuration is used for the primary one-hop tunnel:
interface Tunnel1
ip unnumbered Loopback0
load-interval 30
mpls ip
tunnel source Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.100.1.3
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3-direct
tunnel mpls traffic-eng fast-reroute
Note : The mpls ip configuration is required on the primary tunnel because MLDP must be enabled on the protected tunnel. The autoroute announce configuration is required in order to ensure that the TE tunnel is used to forward traffic.
The Make Before Break (MBB) feature is supported in the Cisco IOS, but only the method that uses a fixed delay after the new path is available. There is no Query/Acknowledge mechanism in the Cisco IOS.
This is the global command that is used in order to configure the MBB fixed delay:
P1(config)#mpls mldp make-before-break delay ?
<0-60000> Delay in milliseconds
The default value is 0, so there is no MBB by default.
This section describes the required configurations for each mVPN profile.
Use this configuration for profile 0:
vrf definition one
rd 1:1
!
address-family ipv4
mdt default 232.1.1.1
route-target export 1:1
route-target import 1:1
exit-address-family
!
ip multicast-routing
ip multicast-routing vrf one
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
neighbor 10.100.1.7 route-reflector-client
exit-address-family
!
address-family ipv4 mdt
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.1.8 remote-as 65001
neighbor 10.2.1.8 activate
exit-address-family
!
Note: For this profile, PIM must be enabled on the global loopback interface. The Address Family (AF) IPv4 Multicast Distribution Tree (MDT) must be used for all types of PIM signaling in the core (not only for PIM Source Specific Multicast (SSM)).
Use this configuration for profile 1:
vrf definition one
rd 1:2
vpn id 1000:2000
!
address-family ipv4
mdt default mpls mldp 10.100.1.1
route-target export 1:1
route-target import 1:1
exit-address-family
!
ip multicast-routing vrf one
mpls mldp logging notifications
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.2.9 remote-as 65002
neighbor 10.2.2.9 activate
exit-address-family
Profile 2 is not currently supported in the Cisco IOS, and MLDP does not support Partitioned MDT with Multipoint-to-Multipoint (MP2MP).
Use this configuration for profile 3:
vrf definition one
rd 1:1
!
address-family ipv4
mdt auto-discovery pim
mdt default 232.1.1.1
route-target export 1:1
route-target import 1:1
exit-address-family
!
ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.1.8 remote-as 65001
neighbor 10.2.1.8 activate
exit-address-family
Note: For this profile, PIM must be enabled on the global loopback interface. Because Border Gateway Protocol-Auto Discovery (BGP-AD) for PIM is used, there is no longer a need for AF IPv4 MDT, which was needed for profile 0.
Profile 4 is not currently supported in the Cisco IOS, and MLDP does not support Partitioned MDT with MP2MP.
Profile 5 is not currently supported in the Cisco IOS, and PIM signaling is not supported over Partitioned MDT.
Use this configuration for profile 6:
vrf definition one
rd 1:1
!
address-family ipv4
route-target export 1:1
route-target import 1:1
exit-address-family
!
ip multicast-routing vrf one
ip multicast vrf one mpls mldp
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.1.8 remote-as 65001
neighbor 10.2.1.8 activate
exit-address-family
!
ip pim vrf one mpls source Loopback0
Use this configuration for profile 7:
ip multicast-routing
ip multicast mpls mldp
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
redistribute connected
neighbor 10.2.1.8 activate
neighbor 10.100.1.7 activate
exit-address-family
ip pim ssm default
ip pim mpls source Loopback0
This section describes the required configurations for profile 8 on the TE head-end and TE tail-end routers.
Use this configuration for profile 8 on the TE head-end router:
ip multicast-routing
ip multicast mpls traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng destination list name from-PE3
ip 10.100.1.1 path-option 1 dynamic
ip 10.100.1.2 path-option 1 dynamic
ip 10.100.1.4 path-option 1 explicit name to-PE4
interface Tunnel0
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.1.1.1 source 10.2.3.10
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name from-PE3
!
interface Ethernet1/0
ip address 10.1.10.3 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000
!
router ospf 1
network 10.1.7.0 0.0.0.255 area 0
network 10.1.10.0 0.0.0.255 area 0
network 10.100.0.0 0.0.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
redistribute connected
neighbor 10.100.1.7 activate
exit-address-family
ip pim ssm default
Note: A destination list is required for the tail-end routers of the Point-to-Multipoint (P2MP) TE tunnel. The path-option towards the tail-end router can be explicit or dynamic.
Use this configuration for profile 8 on the TE tail-end router:
ip multicast-routing
ip multicast mpls traffic-eng
mpls traffic-eng tunnels
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
redistribute connected
neighbor 10.2.1.8 activate
neighbor 10.100.1.7 activate
exit-address-family
ip pim ssm default
ip mroute 10.2.3.0 255.255.255.0 10.100.1.3
Note: The static mroute is required for the source towards the TE head-end router in the global context.
Use this configuration for profile 9:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
route-target export 1:1
route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
Profile 10 is not currently supported in the Cisco IOS, and BGP-AD is not supported for P2MP TE.
Use this configuration for profile 11:
vrf definition one
rd 1:1
!
address-family ipv4
mdt auto-discovery pim
mdt default 232.1.1.1
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family
!
ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.1.8 remote-as 65001
neighbor 10.2.1.8 activate
exit-address-family
Note: For this profile, PIM must be enabled on the global loopback interface. Because BGP-AD for PIM is used, there is no longer a need for AF IPv4 MDT, which was needed for profile 0.
Use this configuration for profile 12:
vrf definition one
rd 1:1
!
address-family ipv4
mdt auto-discovery mldp
mdt default mpls mldp p2mp
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.1.8 remote-as 65001
neighbor 10.2.1.8 activate
exit-address-family
!
Use this configuration for profile 13:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
Use this configuration for profile 14:
vrf definition one
rd 1:1
!
address-family ipv4
mdt auto-discovery mldp
mdt strict-rpf interface
mdt partitioned mldp p2mp
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.1.8 remote-as 65001
neighbor 10.2.1.8 activate
exit-address-family
!
Profile 15 is not currently supported in the Cisco IOS, and MLDP does not support Partitioned MDT with MP2MP.
Profile 16 is not currently supported in the Cisco IOS.
Use this configuration for profile 17:
vrf definition one
rd 1:1
!
address-family ipv4
mdt auto-discovery mldp
mdt default mpls mldp p2mp
route-target export 1:1
route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.1.8 remote-as 65001
neighbor 10.2.1.8 activate
exit-address-family
!
Profile 18 is not currently supported in the Cisco IOS.
vrf definition one
rd 1:1
!
address-family ipv4
mdt auto-discovery ingress-replication
mdt default ingress-replication
route-target export 1:1
route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.1.8 remote-as 65001
neighbor 10.2.1.8 activate
exit-address-family
!
Profile 20 and P2MP Auto-Tunnels TE are not currently supported in the Cisco IOS.
vrf definition one
rd 1:1
!
address-family ipv4
mdt auto-discovery ingress-replication
mdt default ingress-replication
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.1.8 remote-as 65001
neighbor 10.2.1.8 activate
exit-address-family
!
Profile 22 and P2MP Auto-Tunnels TE are not currently supported in the Cisco IOS.
Profile 23 and IR are not currently supported in the Cisco IOS.
Profile 24 and P2MP Auto-Tunnels TE are not currently supported in the Cisco IOS.
vrf definition one
rd 1:1
!
address-family ipv4
mdt auto-discovery ingress-replication
mdt default ingress-replication
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family
!
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.7 activate
neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
redistribute connected
neighbor 10.2.1.8 remote-as 65001
neighbor 10.2.1.8 activate
exit-address-family
!
Profile 26 and P2MP Auto-Tunnels TE are not currently supported in the Cisco IOS.
The information in this section is provided under the assumption that the proper configuration is implemented on the routers in order to make inter-AS MPLS VPN operational for unicast.
Option D is not supported for mVPN.
The regular mVPN configuration is required for Option A. You can have any profile in the autonomous systems, and the profiles do not have to match in the different autonomous systems.
For Options B and C, if the loopback interface IP addresses are redistributed from the Border Gateway Protocol (BGP) into the Interior Gateway Protocol (IGP) of the other Autonomous Systems (AS), then the PIM vector is not required.
Only inter-Autonomous System (inter-AS) mVPN is supported with profile 0 (with non-segmented tunnels).
The regular mVPN configuration is required for Option B. Only AF IPv4 MDT can be used; AF IPv4 MVPN is not supported.
The PIM vector origination with Route Distinguisher (RD) is required on the PE routers, with this additional configuration:
ip multicast vrf one rpf proxy rd vector
The Autonomous System Border Routers (ASBRs) must have PIM enabled on the ASBR-to-ASBR link. The ASBRs must also have AF IPv4 MDT configured for the internal Border Gateway Protocol (iBGP) neighbors and the ASBR external Border Gateway Protocol (eBGP) neighbor.
This additional configuration is required on the ASBR:
interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding
router bgp 1
bgp log-neighbor-changes
no bgp default route-target filter
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family vpnv4
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
Only inter-Autonomous System (inter-AS) mVPN is supported with profile 0 (with non-segmented tunnels).
The regular mVPN configuration is required for Option C. The PE loopback prefixes of the other ASs are advertised by the BGP in AF IPv4.
The PIM vector origination without RD is required on the PE routers also, with this additional configuration:
ip multicast rpf proxy vector
The ASBRs must have PIM enabled on the ASBR-to-ASBR link. The ASBRs must also have AF IPv4 MDT configured for the iBGP neighbors and the ASBR eBGP neighbor.
This additional configuration is required on the ASBR:
interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding
router bgp 1
bgp log-neighbor-changes
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family ipv4
redistribute ospf 1 metric 100 route-map loopbacks-into-BGP
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.3.1.4 send-label
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
neighbor 10.100.1.6 send-label
exit-address-family
!
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!
Note: The AF IPv4 MDT between the Autonomous Systems can also be configured on the Route Reflectors (RRs) on an eBGP multihop session instead of on the ASBRs.
Option B is not currently supported.
There is no support for Recursive Forwarding Equivalence Class (FEC) in the Cisco IOS. Hence, redistribution of the PE loopbacks by iBGP into the other AS is not sufficient, as the P (Provider) routers lack the knowledge of the PE routers in the other AS.
There is support if the PE loopbacks are redistributed by the IGP into the other AS. In this case, the profiles with Partitioned MDT and full mesh P2MP MLDP are supported. The AF IPv4 MDT cannot be used here; AF IPv4 MVPN must be used. The BGP mVPN session can run between the PEs and RRs. Between the RRs, there is already an eBGP multihop session that runs for the AF VPNv4/6.
The MLDP BGP-AD must be enabled. The inter-as keyword is required on the PE routers in order to ensure that the BGP-AD Type 1 routes do not have the no-export community.
This section describes the configurations for profiles 12 and 17.
Here is the configuration on the PE routers for profile 17:
vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
route-target export 1:1
route-target import 1:1
exit-address-family
Here is the configuration on the ASBRs for profile 17:
interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding
end
Note: The mpls ip configuration is required on the link between the ASBRs in order to have an MLDP neighborship between them.
Here is the configuration on the RRs for profile 17:
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!
This configuration is the same as that used for profile 17, but there is the additional C-multicast signaling by BGP.
Here is the configuration on the PE routers for profile 12:
vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family
This section describes the configuration for profile 14.
Here is the configuration on the PE routers for profile 14:
vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family
Here is the configuration on the ASBRs for profile 14:
interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding
Note: The mpls ip is required on the link between the ASBRs in order to have an MLDP neighborship between them.
Here is the configuration on the RRs for profile 14:
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!
This information is provided under the assumption that the proper configuration is implemented on the routers in order to have Carrier’s Carrier (CsC) MPLS VPN operational for unicast.
Only profile 0 is supported for CsC. This means that there can be hierarchical CsC with multicast-enabled VPNs. The VPN of the CsC has mVPN profile 0 configured. The Carrier’s network has mVPN profile 0 configured as well. This means that there is the regular mVPN configuration, on the CsC-PE routers of the CsC and on the PE routers of the Carrier, and then there is no additional configuration needed for multicast.
There is currently no verification procedure available for this configuration.
There is currently no specific troubleshooting information available for this configuration.