The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
This document describes the procedure to configure Point to Point Protocol over Ethernet (PPPoE) on Cisco ASR 920 Aggregation Service Router acting as Client.
Cisco recommends that you have knowledge of End-to-End Layer 1 connectivity.
The information in this document is based on Cisco ASR 920 hardware.
The information in this document was created from the devices in a specific lab environment, All of the devices used in this document started with a cleared(default) configuration.
Note: If your network is live, ensure that you understand the potential impact of any command.
Note: Use the Command Lookup Tool (registered customers only) in order to obtain more information on the commands used in this section.
Configuration on the Routers are from a back to back setup (Client and Server).
It is specific to the ASR 920 Platform.
interface GigabitEthernet0/0/1
no ip address
no ip redirects
no ip proxy-arp
ip tcp adjust-mss 1452
speed 1000
no negotiation auto
cdp enable
ip virtual-reassembly
service instance 10 ethernet
encapsulation untagged etype pppoe-all
bridge-domain 10
!
interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname cisco
ppp chap password 0 cisco123
ppp pap sent-username cisco password 0 cisco123
end
!
interface BDI10
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1
!
ip route 0.0.0.0 0.0.0.0 Dialer1
This remains the same in all scenarios, irrespective of the platform used on client side.
username cisco password 0 cisco123
!
bba-group pppoe global
virtual-template 1
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip rip advertise 4
load-interval 30
duplex auto
speed auto
pppoe enable group global
!
interface Virtual-Template1
mtu 1492
ip unnumbered GigabitEthernet0/0
peer default ip address pool PPPoE_Pool
ppp authentication pap chap
!
ip local pool PPPoE_Pool 10.1.1.1 10.1.1.100
Use this section to confirm that your configuration works properly.
These debugs are enabled on both Client and Server:
Client Logs:
*Jul 14 20:23:09.486: ppp13 PPP: Phase is ESTABLISHING
*Jul 14 20:23:09.486: Vi2 PPP: Using dialer call direction
*Jul 14 20:23:09.486: Vi2 PPP: Treating connection as a callout
*Jul 14 20:23:09.486: Vi2 PPP: Session handle[6300000D] Session id[13]
*Jul 14 20:23:09.486: Vi2 LCP: Event[OPEN] State[Initial to Starting]
*Jul 14 20:23:09.486: Vi2 PPP: No remote authentication for call-out
*Jul 14 20:23:09.486: Vi2 LCP: O CONFREQ [Starting] id 1 len 10
*Jul 14 20:23:09.486: Vi2 LCP: MagicNumber 0xB07C8578 (0x0506B07C8578)
*Jul 14 20:23:09.486: Vi2 LCP: Event[UP] State[Starting to REQsent]
*Jul 14 20:23:09.488: Vi2 LCP: I CONFREQ [REQsent] id 1 len 18
*Jul 14 20:23:09.488: Vi2 LCP: MRU 1492 (0x010405D4)
*Jul 14 20:23:09.488: Vi2 LCP: AuthProto PAP (0x0304C023)
*Jul 14 20:23:09.488: Vi2 LCP: MagicNumber 0xED0582E9 (0x0506ED0582E9)
*Jul 14 20:23:09.488: Vi2 LCP: O CONFNAK [REQsent] id 1 len 8
*Jul 14 20:23:09.488: Vi2 LCP: MRU 1500 (0x010405DC)
*Jul 14 20:23:09.489: Vi2 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
*Jul 14 20:23:09.489: Vi2 LCP: I CONFACK [REQsent] id 1 len 10
*Jul 14 20:23:09.489: Vi2 LCP: MagicNumber 0xB07C8578 (0x0506B07C8578)
*Jul 14 20:23:09.489: Vi2 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
*Jul 14 20:23:09.490: Vi2 LCP: I CONFREQ [ACKrcvd] id 2 len 18
*Jul 14 20:23:09.490: Vi2 LCP: MRU 1500 (0x010405DC)
*Jul 14 20:23:09.490: Vi2 LCP: AuthProto PAP (0x0304C023)
*Jul 14 20:23:09.490: Vi2 LCP: MagicNumber 0xED0582E9 (0x0506ED0582E9)
*Jul 14 20:23:09.490: Vi2 LCP: O CONFACK [ACKrcvd] id 2 len 18
*Jul 14 20:23:09.490: Vi2 LCP: MRU 1500 (0x010405DC)
*Jul 14 20:23:09.490: Vi2 LCP: AuthProto PAP (0x0304C023)
*Jul 14 20:23:09.490: Vi2 LCP: MagicNumber 0xED0582E9 (0x0506ED0582E9)
*Jul 14 20:23:09.490: Vi2 LCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
*Jul 14 20:23:09.499: Vi2 PPP: No authorization without authentication
*Jul 14 20:23:09.499: Vi2 PPP: Phase is AUTHENTICATING, by the peer
*Jul 14 20:23:09.499: Vi2 PAP: Using hostname from interface PAP
*Jul 14 20:23:09.499: Vi2 PAP: Using password from interface PAP
*Jul 14 20:23:09.499: Vi2 PAP: O AUTH-REQ id 1 len 19 from "cisco"
*Jul 14 20:23:09.499: Vi2 LCP: State is Open
*Jul 14 20:23:09.530: Vi2 PAP: I AUTH-ACK id 1 len 5
*Jul 14 20:23:09.530: Vi2 PPP: Phase is FORWARDING, Attempting Forward
*Jul 14 20:23:09.530: Vi2 PPP: Queue IPCP code[1] id[1]
*Jul 14 20:23:09.532: Vi2 PPP: Phase is ESTABLISHING, Finish LCP
*Jul 14 20:23:09.532: Vi2 PPP: Phase is UP
*Jul 14 20:23:09.532: Vi2 IPCP: Protocol configured, start CP. state[Initial]
*Jul 14 20:23:09.532: Vi2 IPCP: Event[OPEN] State[Initial to Starting]
*Jul 14 20:23:09.532: Vi2 IPCP: O CONFREQ [Starting] id 1 len 10
*Jul 14 20:23:09.532: Vi2 IPCP: Address 0.0.0.0 (0x030600000000)
*Jul 14 20:23:09.532: Vi2 IPCP: Event[UP] State[Starting to REQsent]
*Jul 14 20:23:09.532: Vi2 PPP: Process pending ncp packets
*Jul 14 20:23:09.532: Vi2 IPCP: Redirect packet to Vi2
*Jul 14 20:23:09.532: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10
*Jul 14 20:23:09.532: Vi2 IPCP: Address 192.168.1.1 (0x0306C0A80101)
*Jul 14 20:23:09.533: Vi2 IPCP: O CONFACK [REQsent] id 1 len 10
*Jul 14 20:23:09.533: Vi2 IPCP: Address 192.168.1.1 (0x0306C0A80101)
*Jul 14 20:23:09.533: Vi2 IPCP: Event[Receive ConfReq+] State[REQsent to ACKsent]
*Jul 14 20:23:09.535: Vi2 IPCP: I CONFNAK [ACKsent] id 1 len 10
*Jul 14 20:23:09.535: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Jul 14 20:23:09.535: Vi2 IPCP: O CONFREQ [ACKsent] id 2 len 10
*Jul 14 20:23:09.535: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Jul 14 20:23:09.536: Vi2 IPCP: Event[Receive ConfNak/Rej] State[ACKsent to ACKsent]
*Jul 14 20:23:09.537: Vi2 IPCP: I CONFACK [ACKsent] id 2 len 10
*Jul 14 20:23:09.537: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Jul 14 20:23:09.537: Vi2 IPCP: Event[Receive ConfAck] State[ACKsent to Open]
*Jul 14 20:23:09.562: Vi2 IPCP: State is Open
*Jul 14 20:23:09.562: Di1 IPCP: Install negotiated IP interface address 10.1.1.1
*Jul 14 20:23:09.565: PPPoE : ipfib_encapstr prepared
*Jul 14 20:23:09.566: Di1 Added to neighbor route AVL tree: topoid 0, address 192.168.1.1
*Jul 14 20:23:09.566: Di1 IPCP: Install route to 192.168.1.1
*Jul 14 20:23:09.567: Vi2 DDR: dialer protocol up
*Jul 14 20:23:09.567: PPPoE : ipfib_encapstr prepared
*Jul 14 20:23:09.567: Di1 DDR: dialer protocol up
*Jul 14 20:23:10.235: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
Client#sh pppoe session
1 client session
Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st Type
N/A 1 a0ec.f9d8.9dd0 BD10 Di1 Vi2 UP
64f6.9d6e.dd3f UP
Server Logs:
* Jul 15 04:41:18.727: ppp1 PPP: Phase is ESTABLISHING
*Jul 15 04:41:18.727: ppp1 PPP: Using vpn set call direction
*Jul 15 04:41:18.727: ppp1 PPP: Treating connection as a callin
*Jul 15 04:41:18.727: ppp1 PPP: Session handle[BF000001] Session id[1]
*Jul 15 04:41:18.727: ppp1 LCP: Event[OPEN] State[Initial to Starting]
*Jul 15 04:41:18.727: ppp1 PPP LCP: Enter passive mode, state[Stopped]
*Jul 15 04:41:18.735: ppp1 LCP: I CONFREQ [Stopped] id 1 len 10
*Jul 15 04:41:18.735: ppp1 LCP: MagicNumber 0xB07C8578 (0x0506B07C8578)
*Jul 15 04:41:18.735: ppp1 LCP: O CONFREQ [Stopped] id 1 len 18
*Jul 15 04:41:18.735: ppp1 LCP: MRU 1492 (0x010405D4)
*Jul 15 04:41:18.735: ppp1 LCP: AuthProto PAP (0x0304C023)
*Jul 15 04:41:18.735: ppp1 LCP: MagicNumber 0xED0582E9 (0x0506ED0582E9)
*Jul 15 04:41:18.735: ppp1 LCP: O CONFACK [Stopped] id 1 len 10
*Jul 15 04:41:18.735: ppp1 LCP: MagicNumber 0xB07C8578 (0x0506B07C8578)
*Jul 15 04:41:18.735: ppp1 LCP: Event[Receive ConfReq+] State[Stopped to ACKsent]
*Jul 15 04:41:18.735: ppp1 LCP: I CONFNAK [ACKsent] id 1 len 8
*Jul 15 04:41:18.735: ppp1 LCP: MRU 1500 (0x010405DC)
*Jul 15 04:41:18.735: ppp1 LCP: O CONFREQ [ACKsent] id 2 len 18
*Jul 15 04:41:18.735: ppp1 LCP: MRU 1500 (0x010405DC)
*Jul 15 04:41:18.735: ppp1 LCP: AuthProto PAP (0x0304C023)
*Jul 15 04:41:18.735: ppp1 LCP: MagicNumber 0xED0582E9 (0x0506ED0582E9)
*Jul 15 04:41:18.735: ppp1 LCP: Event[Receive ConfNak/Rej] State[ACKsent to ACKsent]
*Jul 15 04:41:18.739: ppp1 LCP: I CONFACK [ACKsent] id 2 len 18
*Jul 15 04:41:18.739: ppp1 LCP: MRU 1500 (0x010405DC)
*Jul 15 04:41:18.739: ppp1 LCP: AuthProto PAP (0x0304C023)
*Jul 15 04:41:18.739: ppp1 LCP: MagicNumber 0xED0582E9 (0x0506ED0582E9)
*Jul 15 04:41:18.739: ppp1 LCP: Event[Receive ConfAck] State[ACKsent to Open]
*Jul 15 04:41:18.747: ppp1 PPP: Queue PAP code[1] id[1]
*Jul 15 04:41:18.763: ppp1 PPP: Phase is AUTHENTICATING, by this end
*Jul 15 04:41:18.763: ppp1 PAP: Redirect packet to ppp1
*Jul 15 04:41:18.763: ppp1 PAP: I AUTH-REQ id 1 len 19 from "cisco"
*Jul 15 04:41:18.763: ppp1 PAP: Authenticating peer cisco
*Jul 15 04:41:18.763: ppp1 PPP: Phase is FORWARDING, Attempting Forward
*Jul 15 04:41:18.763: ppp1 LCP: State is Open
*Jul 15 04:41:18.763: ppp1 PPP: Phase is AUTHENTICATING, Unauthenticated User
*Jul 15 04:41:18.763: ppp1 PPP: Sent PAP LOGIN Request
*Jul 15 04:41:18.763: ppp1 PPP: Received LOGIN Response PASS
*Jul 15 04:41:18.763: ppp1 IPCP: Authorizing CP
*Jul 15 04:41:18.763: ppp1 IPCP: CP stalled on event[Authorize CP]
*Jul 15 04:41:18.763: ppp1 IPCP: CP unstall
*Jul 15 04:41:18.763: ppp1 PPP: Phase is FORWARDING, Attempting Forward
*Jul 15 04:41:18.775: Vi1.1 PPP: Phase is AUTHENTICATING, Authenticated User
*Jul 15 04:41:18.775: Vi1.1 PAP: O AUTH-ACK id 1 len 5
*Jul 15 04:41:18.775: Vi1.1 PPP: Phase is UP
*Jul 15 04:41:18.775: Vi1.1 IPCP: Protocol configured, start CP. state[Initial]
*Jul 15 04:41:18.775: Vi1.1 IPCP: Event[OPEN] State[Initial to Starting]
*Jul 15 04:41:18.775: Vi1.1 IPCP: O CONFREQ [Starting] id 1 len 10
*Jul 15 04:41:18.775: Vi1.1 IPCP: Address 192.168.1.1 (0x0306C0A80101)
*Jul 15 04:41:18.779: Vi1.1 IPCP: Event[UP] State[Starting to REQsent]
*Jul 15 04:41:18.779: Vi1.1 IPCP: I CONFREQ [REQsent] id 1 len 10
*Jul 15 04:41:18.779: Vi1.1 IPCP: Address 0.0.0.0 (0x030600000000)
*Jul 15 04:41:18.783: Vi1.1 IPCP AUTHOR: Start. Her address 0.0.0.0, we want 0.0.0.0
*Jul 15 04:41:18.783: Vi1.1 IPCP AUTHOR: Done. Her address 0.0.0.0, we want 0.0.0.0
*Jul 15 04:41:18.783: Vi1.1 IPCP: Pool returned 10.1.1.1
*Jul 15 04:41:18.783: Vi1.1 IPCP: O CONFNAK [REQsent] id 1 len 10
*Jul 15 04:41:18.783: Vi1.1 IPCP: Address 10.1.1.1 (0x03060A010101)
*Jul 15 04:41:18.783: Vi1.1 IPCP: Event[Receive ConfReq-] State[REQsent to REQsent]
*Jul 15 04:41:18.783: Vi1.1 IPCP: I CONFACK [REQsent] id 1 len 10
*Jul 15 04:41:18.783: Vi1.1 IPCP: Address 192.168.1.1 (0x0306C0A80101)
*Jul 15 04:41:18.783: Vi1.1 IPCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
*Jul 15 04:41:18.783: Vi1.1 IPCP: I CONFREQ [ACKrcvd] id 2 len 10
*Jul 15 04:41:18.783: Vi1.1 IPCP: Address 10.1.1.1 (0x03060A010101)
*Jul 15 04:41:18.783: Vi1.1 IPCP: O CONFACK [ACKrcvd] id 2 len 10
*Jul 15 04:41:18.783: Vi1.1 IPCP: Address 10.1.1.1 (0x03060A010101)
*Jul 15 04:41:18.783: Vi1.1 IPCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
*Jul 15 04:41:18.795: Vi1.1 IPCP: State is Open
*Jul 15 04:41:18.795: Vi1.1 Added to neighbor route AVL tree: topoid 0, address 10.1.1.1
*Jul 15 04:41:18.795: Vi1.1 IPCP: Install route to 10.1.1.1
Server#show pppoe session
1 session in LOCALLY_TERMINATED (PTA) State
1 session total
Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st Type
1 1 64f6.9d6e.dd3f Gi0/0 1 Vi1.1 PTA
a0ec.f9d8.9dd0 UP
This section provides information you can use to troubleshoot your configuration.
Follow the standard PPP troubleshooting steps.
Note: If the BDI interface is not configured and the PPPoE Client Configuration is applied on Gigabit Ethernet interface, you will see that the PPPoE session does not get established and displays this error message.
padi timer expired
Sending PADI: Interface = GigabitEthernet0/0/1