Introduction
This document describes how to troubleshoot error "Client Data Not Updated" on Cisco Secure Email Encryption Admin Portal.
Prerequisites
Understanding of Cisco Email Encryption Service (formerly known as Cisco Registered Envelope Service) and Microsoft 365 (Azure AD, Entra ID).
Problem
Error "Client Data Not Updated" occurs when attempting to save Office 365 Mailbox/Azure AD settings under Addin Config
on the Email Encryption Service Admin Portal as shown in this image.
Error: Client Data not Updated
Cause
Incorrect Tenant, Client ID, or Invalid Client Secret.
1. Verify the Sign-in Logs
of the Registered Application on Entra ID (Azure AD) by navigating to Applications > Enterprise Applications
. Click Email Encryption Service Application.
2. Under Activity > Sign-in logs
, click Service principal sign-in
. Verify the latest failure attempts.
Entra ID Sign-in Logs
Resolution
Step 1. Log in to Microsoft Entra ID as an Administrator. Navigate to Applications > App Registrations > All Applications
. Click Registered Email Encryption Service Application.
Step 2. From the Overview page of the Registered Application, copy the Application (client) ID
and Directory (tenant) ID
. Copy the Client secret
from Certificates &
Secrets.
Microsoft Entra Application Overview
Copy Client Secret
Note: Please generate a new client secret if you are unaware of the previously created value by clicking New Client Secret
.
Step 3. Click Add-in Config
tab on the CRES Admin Portal. Enter the Tenant, Client ID, and Secret obtained from Entra ID under Azure AD Details, and click Save Details
.
Related Information