Introduction
This document describes Unified Computing System-E series (UCS-E) network setup by BVI and BDI.
BVI is a Layer-3 routable logical interface that groups physical interfaces into one logical group. BVIs are used on ISR G2 series routers.
BDI is a logical interface that allows bidirectional flow of traffic between a Layer-2 bridged network and a Layer-3 routed network. BDI interface is used on ISR 4000 series routers.
Contributed by Usman Mahmud, Sanaz Tayyar Cisco TAC Engineers.
Prerequisites
Knowledge of routed (L3) and bridged (L2) traffic.
Requirements
Basic knowledge of IP networking and routing. Also, it is expected that the audience has basic knowledge of virtual machines and hypervisors.
Components Used
UCS-E series server modules, Integrated Services Routers (ISR) G2 (3900) and ISR 4K (4451).
Configure
This article covers two configuration examples. One example is based on ISR4K and BDI. The other example covers ISR G2 and BVI.
Network Image
This image is a simple set up that uses ISR4k and BDI:
This image is a simple set up that uses ISR G2 (3900) and BVI:
Configurations
Configuration example for ISR4K and BDI:
########################################################
Router(config)# vlan 20
!
Router(config)#interface BDI20
Router (config-if)# ip address 192.168.7.1 255.255.255.0
Router(config-if)# encapsulation dot1Q 20
Router(config-if)# end
!
Router(config)# ucse subslot 0/1
Router(config-ucse)# imc access-port shared-lom console
Router(config-ucse)# imc ip address 192.168.254.3 255.255.255.0 default-gateway 192.168.254.1
!
Router(config)# interface ucse0/1/0
Router(config-if)# ip unnumbered Loopback1
Router(config-if)# carrier-delay 60
Router(config-if)# no negotiation auto
Router(config-if)# switchport mode trunk
Router(config-if)# no mop enabled
Router(config-if)# no mop sysid
!
Router(config)#interface ucse0/1/1
Router(config-if)# no ip address
Router(config-if)# no negotiation auto
Router(config-if)# switchport mode trunk
Router(config-if)# no mop enabled
Router(config-if)# no mop sysid
Router(config-if)# service instance 20 ethernet
Router(config-if-srv)#encapsulation dot1q 20
Router(config-if-srv)#bridge-domain 20
#########################################################
Configuration example for ISR G2 and BVI:
#########################################################
Router(config)#interface ucse2/0
Router(config-if)# ip unnumbered BVI1
Router(config-if)#service-module heartbeat-reset disable
Router(config-if)# imc ip address 192.168.13.2 255.255.255.0 default-gateway 192.168.13.1
Router(config-if)# imc access-port shared-lom console
Router(config-if)#bridge-group 1
!
Router(config)# interface ucse2/1
Router(config-if)# switchport mode trunk
Router(config-if)#no ip address
!
Router(config)# interface BVI1
Router(config-if)#ip address 192.168.13.1 255.255.255.0
Router(config-if)#end
##########################################################
Verify
Verify BDI state by this command:
Router# show bridge-domain 20
Bridge-domain 20 (2 ports in all)
State: UP Mac learning: Enabled
Aging-Timer: 300 second(s)
BDI20 (up)
ucse0/1/1 service instance 20
AED MAC address Policy Tag Age Pseudoport
- 00C1.64AF.7CF3 to_bdi static 0 BDI20 >>
0 000C.29DC.297B forward dynamic 299 ucse0/1/1.EFP20
Verify BVI interface state by this command:
Router# show ip interface brief
Interface IP-Address OK? Method Status Protocol
ucse2/0 192.168.13.1 YES unset up up
ucse2/1 unassigned YES unset up up
BVI1 192.168.13.1 YES NVRAM up up
Troubleshoot
Run these commands to check UCS-E module status:
Router# ucse subslot 2/0 status
Service Module is Cisco ucse2/0
Service Module supports session via TTY line 67
Service Module is in Steady state
Service Module reset on error is disabled
Service Module heartbeat-reset is disabled
Router# ucse subslot 2/0 statistics
Module Reset Statistics:
CLI reset count = 0
CLI reload count = 1
Registration request timeout reset count = 0
Error recovery timeout reset count = 0
Module registration count = 2
Run this command to check the router inventory:
Router# show inventory
NAME: "CISCO3925-CHASSIS", DESCR: "CISCO3925-CHASSIS"
PID: CISCO3925-CHASSIS , VID: V01 , SN: FTX1425A55N
………………………………………
NAME: "Cisco UCS E-Series Double Wide Intel Performance level 4 Generation with PCIe support on Slot 2", DESCR: "Cisco UCS E-Series Double Wide Intel Performance level 4 Generation with PCIe support"
PID: UCS-E140DP-M1/K9 , VID: V01 , SN: FOC16270UHN
Run this command to check interface status:
Router# show ip interface brief
Interface IP-Address OK? Method Status Protocol
ucse2/0 192.168.13.1 YES unset up up
ucse2/1 unassigned YES unset up up
BVI1 192.168.13.1 YES NVRAM administratively down down
Related Information