
Anonymous Group Manager GUI Tool

This chapter provides details on the Anonymous Group Manager GUI tool and how to manager Anonymous
Groups using the Cisco SCABB. This chapter describes how to use the Anonymous GroupManager graphical
user interface (GUI) tool to configure anonymous groups in a Cisco SCE. This chapter consists of these
sections:

• Using the Anonymous Group Manager GUI Tool, page 1

• Introduction to Managing Anonymous Groups, page 2

• Working with Anonymous Groups CSV Files , page 12

Using the Anonymous Group Manager GUI Tool
You can use the Anonymous Group Manager GUI tool to import and export subscriber files, and to perform
these operations on anonymous groups:

• Add and delete an anonymous group

• View the subscribers in a specific anonymous group

• Delete all anonymous groups

• View the configuration of a specific anonymous group

• Filter subscribers

• View online status of the subscriber

• View OS information of the subscribers in anonymous group

• Edit subscriber properties

• Import anonymous groups from a CSV file

• Export anonymous groups to a CSV file

• Export subscribers of a certain group to CSV file

Software-based support for IPv6 subscribers is available on Cisco SCE 10000 devices.

For details on Anonymous Groups, Subscriber templates, and CSV file formats, see the Cisco SCE 10000
Software Configuration Guide .
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For more information about the Cisco Service Control Subscriber Manager, see the Cisco Service Control
Management Suite Subscriber Manager User Guide.

Introduction to Managing Anonymous Groups
After importing subscribers into the system, you can maintain and update the database.

You can perform these tasks:

• Add and delete an anonymous group

• View the subscribers in a specific anonymous group

• View the configuration of a specific anonymous group

• Delete all anonymous groups in the Cisco SCE

• Filter subscribers

• View online status of the subscriber

• Edit subscriber properties

This section contains information on:

Anonymous Group Manager Information
In the Anonymous Group Manager GUI, you can see a list of anonymous groups configured in a Cisco SCE.
Use this list to manage individual anonymous group or multiple groups of subscriber tables stacked together,
and the subscribers in each anonymous group.

The Anonymous Group Manager GUI is composed of a console view at the bottom and a device view at the
top. The console shows the logmessages. The anonymous group viewwithin the group folder has the following
columns in a subscriber table:

• Subscriber Name—Name of the subscriber in the system.

• Mappings—IP address, range of IP addresses, or VLAN tag mapped to the subscriber.

• Package ID

• Monitor State

• Up VLINK ID

• Down VLINK ID
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• Owner—Owner of the subscriber (For example, Subscriber Manager Device)

Figure 1: Anonymous Group Manager GUI - Group List

Right-click on the specific subscriber to perform various actions including the following:

• Edit subscriber data.

• View the online status of the subscriber

Finding and Selecting Subscribers Overview
The Anonymous Group Manager GUI tool retrieves subscribers in bulks of 1000 subscribers. Subscriber
information is displayed in a standard view. If there are more subscribers than that can be displayed in the
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standard view, then the information is displayed in pages. You can use the various pagination buttons to
navigate between the pages.

Figure 2: Anonymous Group Manager GUI - Pagination Buttons

1. Get previous bulk.

2. Get first page.

3. Get previous page.

4. Enter page number.

5. Get next page.

6. Get last page.

7. Get next bulk.

For ease of use, the Anonymous Group Manager GUI tool incorporates two standard features:

• Filter—You can filter the subscriber list based on the packageID, downVlinkId, monitor, and upVlinkId.
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• Multiple Select—Select a range of subscribers or a number of individual subscribers.

Figure 3: Filter Anonymous Subscriber

Selecting Subscribers Overview
You can edit, export, or delete a group of subscribers at one time by selecting subscribers displayed in the
subscriber list. The group may be either of the following:

• A range of contiguous subscribers

• A number of noncontiguous subscribers

Selecting a Range of Subscribers

Procedure

Step 1 Select the first subscriber in the range.
Step 2 Press the Shift key while clicking the last subscriber in the range.

All subscribers within the range are selected. You can combine this function with the search function; search
for specific subscribers and then select the entire range.

Selecting a Number of Noncontiguous Subscribers

Procedure

Press the Ctrl key while selecting multiple subscribers.
You can combine this function with selecting a range of subscribers; first, select the range of subscribers, and
then select additional subscribers.
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Adding a Cisco SCE to the Anonymous Group Manager GUI Tool
All SCEs added to Cisco SCABBNetwork Navigator appears in the site list of the Anonymous GroupManager
GUI Tool.
For details on adding SCEs through Network Navigator, see the Adding Devices to a Site section.

Adding a New Anonymous Group in a Cisco SCE Device

Procedure

Step 1 From the Console main menu, choose Tools > Anonymous Group Manager.
The Anonymous Group Manager tool opens.

Step 2 If the device is not listed in the Site list, add the device using the Network Navigator.
Step 3 Right-click the corresponding Cisco SCE device, and select Add a New Group.

A Password Management window appears with the Device, Device Type, and Service information.
Step 4 Enter the User Name and Password. For details on password management, see the Password Management

section.
The Add Anonymous Group page appears.

Figure 4: Add Anonymous Group

Step 5 Enter the Group Name, IP Range, Template Index, and Manager Name.
Step 6 Select the Aging option from the drop-down list.
Step 7 Click Ok.

The new anonymous group is added to the specific Cisco SCE.
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Adding a New IPv6 Anonymous Group in a Cisco SCE Device

Procedure

Step 1 From the Console main menu, choose Tools > Anonymous Group Manager .
The Anonymous Group Manager tool opens.

Step 2 If the device is not listed in the Site list, add the device using the Network Navigator.
Step 3 Right-click on the Cisco SCE, and select Add a New Group .

A Password Management window appears with the Device, Device Type, and Service information.
Step 4 Enter the User Name and Password. For details on password management, see the Password Management

section.
The Add Anonymous Group page appears.

Figure 5: Add IPv6 Anonymous Group

Step 5 Enter the following details:

• Group Name

• IPv6 Range with a prefix value of 0 to 64

• Template Index

• Manager Name

Step 6 Select the Aging option from the drop-down list.
Step 7 Click Ok .

The new anonymous group is added to the specific Cisco SCE device.
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Viewing the Configuration of a Specific Anonymous Group

Procedure

Step 1 From the Console main menu, chooseTools > Anonymous Group Manager .
The Anonymous Group Manager tool opens.

Figure 6: Anonymous Group Manager Tool

Figure 7: IPv6 Anonymous Group Manager Tool

Step 2 In the Site list, right-click the corresponding Anonymous Group, and select View Group Definition.
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Deleting An Anonymous Groups in a Cisco SCE

Procedure

Step 1 From the Console main menu, choose Tools > Anonymous Group Manager .
The Anonymous Group Manager tool opens.

Step 2 From the Site list, click on the Cisco SCE from which you plan to delete the Anonymous Group.
The Anonymous Groups in the Cisco SCE appears.

Step 3 Right-click on the Anonymous group to delete, and select Delete.
A confirmation dialog box appears.

Figure 8: Confirmation Dialog Box

Step 4 Click Yes.

Deleting All Anonymous Groups in a Cisco SCE

Procedure

Step 1 From the Console main menu, choose Tools > Anonymous Group Manager .
The Anonymous Group Manager tool opens.

Step 2 From the Site list, right-click on the Cisco SCE from which you plan to delete the Anonymous Groups and
select Delete Groups.
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A confirmation dialog box appears.

Figure 9: Confirmation Dialog Box

Step 3 Click Yes.

Viewing Subscribers in a Specific Anonymous Group

Procedure

Step 1 From the Console main menu, choose Tools > Anonymous Group Manager.
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The Anonymous Group Manager tool opens.

Figure 10: Anonymous Group Manager Tool

Step 2 In the Site list, right-click the Anonymous Group, and select View Subscribers.
The list of subscribers appears in the Anonymous Group tab near the Console tab.

Viewing the Online Status of a Subscriber

Procedure

Step 1 From the Console main menu, choose Tools > Anonymous Group Manager.
The Anonymous Group Manager tool opens.

Step 2 In the Site list, right-click the Anonymous Group, and select View Subscribers.
The list of subscribers appears in the Anonymous Group pane.

Step 3 Right-click in the subscriber row, and select View Online Status.
The online status appears.
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Editing the Subscriber Properties

Procedure

Step 1 From the Console main menu, choose Tools > Anonymous Group Manager .
The Anonymous Group Manager tool opens.

Step 2 In the Site list, right-click the Anonymous Group, and select View Subscribers.
The list of subscribers appears in the Anonymous Group pane.

Step 3 Right-click in the subscriber row, and select Edit Subscriber .
The Edit Subscriber dialog box appears.

Step 4 Modify the required fields from the following:

• Package ID

• Monitor State

• UpVlinkId

• DownVlinkId

Step 5 Click OK .

Removing Subscribers from an Anonymous Group in a Cisco SCE

Procedure

Step 1 From the Console main menu, choose Tools > Anonymous Group Manager.
The Anonymous Group Manager tool opens.

Step 2 In the Site list, click the Anonymous Group, and select View Subscribers.
The list of subscribers appears in the Anonymous Group pane.

Step 3 Right-click in the subscriber row, and select Remove the Subscriber.
A confirmation dialog box appears.

Step 4 Click OK .

Working with Anonymous Groups CSV Files
With Anonymous Group GUI tool, you can:

• Import anonymous groups from a CSV file

• Export anonymous groups to a CSV file
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• Export subscribers of a certain anonymous group to CSV file

The format of subscriber CSV files is described in the “CSV File Formats” chapter of Cisco Service Control
Application for Broadband Reference Guide.

This section explains the following procedures:

• Importing Anonymous Groups from a CSV File

• Exporting Anonymous Groups to a CSV File

You can import subscriber data that was exported to a CSV file using the Anonymous Group Manager GUI
tool. This feature supports only one Cisco SCE at a time.

Importing Anonymous Groups from a CSV File

Procedure

Step 1 From the Console main menu, chooseTools > Anonymous Group Manager.
Step 2 In the Site list in Anonymous Group Manager tool, click the Cisco SCE for which you want to import the

Anonymous Groups.
Step 3 Select File > Import .
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Figure 11: Import Dialog Box

Step 4 Click Next.
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Figure 12: Import Anonymous Groups from File Dialog Box

Step 5 In the Import Anonymous Groups from File dialog box, browse to the file that is to be imported and click
Finish .
The selected file is imported into the Anonymous Group Manager GUI tool; the imported subscribers are
listed in the subscriber list.

Exporting Anonymous Groups to a CSV File
You can export anonymous group information to a CSV file.

Procedure

Step 1 From the Console main menu, choose Tools > Anonymous Group Manager .
The Anonymous Group Manager tool opens.

Step 2 In the Site list, click the Cisco SCE for which you want to export the Anonymous Groups.
Step 3 Select File > Export .
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The Export dialog box appears.

Figure 13: Export Dialog Box

Step 4 Click Next.
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The Export Anonymous Groups from File dialog box appears.

Figure 14: Export Anonymous Groups from File Dialog Box

Step 5 Select the Cisco SCE Device and the Anonymous Groups to be exported.
Step 6 Select the Export destination and click Finish .

The Export from File dialog box closes. The Anonymous Group Information is exported to the CSV file.

Exporting Information on Subscribers of an Anonymous Group to CSV File
To export information of all subscribers of an anonymous group to a CSV file, complete these steps:

Procedure

Step 1 From the Console main menu, choose Tools > Anonymous Group Manager.
The Anonymous Group Manager tool opens.

Step 2 In the Site list, click the Cisco SCE for which you want to export the Anonymous Groups.
Step 3 Select File > Export.
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The Export dialog box appears.

Figure 15: Export Dialog Box

Step 4 Select the subscribers to be exported.
Step 5 Select the Export destination and click Finish .

The Export from File dialog box closes. The selected subscriber information is saved to the CSV file.
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