
Monitor

This chapter contains the following topics:

• Inventory, on page 1
• Monitoring Switch, on page 20
• Monitoring LAN, on page 23
• Endpoint Locator, on page 27
• Alarms, on page 27

Inventory
This chapter contains the following topics:

Viewing Inventory Information for Switches
To view the inventory information for switches from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Inventory > Switches.

The Switches window with a list of all the switches for a selected Scope is displayed.

Step 2 You can also view the following information.

• Group column displays the switch group to which the switch belongs.

• In the Device Name column, select a switch to display the Switch Dashboard.

• IP Address column displays the IP address of the switch.

• WWN/Chassis ID displays the Worldwide Name (WWN) if available or chassis ID.

• Health displays the health situation of the switch.

To refresh and recalculate the latest health data for all the switches on Cisco DCNM, click
the Recalculate Health button above the switches table.

Note
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• Mode column displays the current mode of the switch. The switch can be in Normal, Maintenance, or
Migration mode.

• Status column displays the status of the switch.

• # Ports column displays the number of ports.

• Model column displays the model name of the switch.

• Serial No. column displays the serial number of the switch.

• Release column displays the switch version.

• Up Time column displays the time period for which the switch is active.

Step 3 Click Health to access the Health score window for a device. The Health score window includes health score
calculation and health trend. The Overview tab displays the overall health score. All the modules, switch ports
and alarms are taken into consideration while calculating the health score. Hover over the graph under Health
Trend for detailed information on specific dates. Hover over the info icon next to Alarms to display the number
of Critical, Major, Minor, and Warning alarms that have been generated.
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Click the Modules tab to display information about the various modules in the device. This tab displays
information such as Name, Model name, Serial number, Status, Type, Slot, Hardware revision and Software
revision.

Click the Switch Ports tab to display information about the device ports. This tab displays information such
as Name, Description, Status, Speed, and the device to which a port is connected .
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Click the Alarms tab to display information about the alarms that have been generated. This tab displays
information such as alarm Severity, Message, Category, and the Policy that has been activated due to which
the alarm is generated.

In the Health column, the switch health is calculated by the capacity manager based on the following
parameters:

• Total number of modules

• Total number of modules impacted by the warning

• Total number of switch ports

• Total number of switch ports impacted by the warning
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• Total number of critical severity alarms

• Total number of warning severity alarms

• Total number of major severity alarms

• Total number of minor severity alarms

Step 4 The value in the Health column is calculated based on the following:

• Percentage of modules impacted by warnings (Contributes 20% of the total health).

• Percentage of ports impacted by warnings (Contributes 20% of the total health).

• Percentage of alarms (Contributes 60% of the total health). The critical alarms contribute the highest
value to this percentage followed by major alarms, minor alarms and warning alarms.

You may also have your own health calculation formula by implementing the common interface class:
com.cisco.dcbu.sm.common.rif.HealthCalculatorRif.

The default Java class is defined as: health.calculator=com.cisco.dcbu.sm.common.util.HealthCalculatorAlarms.

• Capacity Manager calculates health only for the license switches. If the health column does not display
a value, the switch either does not have a license or it has missed the capacity manager daily cycle.

• If the switch is unlicensed, click Unlicensed in the DCNM License column. The Administration >
License window appears which allows you to assign a license to the user.

• The capacity manager runs two hours after the DCNM server starts. So, if you discover a device after
two hours of the DCNM start time, the health will be calculated 24 hours after this DCNM start time

Starting from Cisco DCNM 11.3(1) Release, you can view information about switch health along with the
switch summary by clicking on a switch in the Topology window or by choosing Control>Fabrics>Fabric
Builder, selecting a fabric and clicking on a switch in the Fabric Builder window.
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Viewing System Information
The switch dashboard displays the details of the selected switch.

Procedure

Step 1 From the Cisco DCNM home page, choose Monitor > Inventory > Switches.

An inventory of all the switches that are discovered by Cisco DCNMWeb UI is displayed.

Step 2 Click a switch in the Device Name column.

The Switch dashboard that corresponds to that switch is displayed along with the following information:

Step 3 Click the System Information tab. This tab displays detailed system information such as group name, health,
module, time when system is up, serial number, the version number, contact, location, DCNM license, status,
system log sending status, CPU and memory utilization, and VTEP IP address are displayed. Click Health
to access the Health score screen, which includes health score calculation and health trend. The popup contains
Overview, Modules, Switch Ports, and Events tabs.

• (Optional) Click SSH to access the switch through Secure Shell (SSH).

• (Optional) Click Show Commands to display the device show commands. TheDevice ShowCommands
page helps you to view commands and execute them.

Hosts
You can view host details of switch.

Monitor
6

Monitor
Viewing System Information



To view the Hosts tab, choose Monitor > Inventory > Switches, click a switch name in the Device Name
column, and navigate to the Hosts tab.

The following table describes the fields that are displayed:

Table 1: The Hosts Tab

DescriptionField

Displays VRF details of switch.VRF

Displays host IP address of switch.Host IP

Displays host MAC address of switch.Host MAC Address

Displays configured VLAN on switch.VLAN

Port

Displays layer 2 VXLAN network identifier (L2VNI)
configured on switch.

L2 VNI

Displays layer 3 VXLAN network identifier (L3VNI)
configured on switch.

L3 VNI

Capacity
You can view the physical capacity of switch.

Capacity tab shows information about the physical ports that are present on the switch.

To view theCapacity tab, chooseMonitor > Inventory > Switches, click a switch name in theDevice Name
column, and navigate to the Capacity tab.

The following table describes the fields that are displayed:

Table 2: The Capacity Tab

DescriptionField

Displays physical ports available on the switch.Tier

Displays number of used ports on switch.Used Ports

Displays total number of ports on switch.Total Ports

Displays total days left.Days Left

Features
You can view features enabled on the switch.

To view the Features tab, chooseMonitor > Inventory > Switches, click a switch name in theDevice Name
column, and navigate to the Features tab.
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VXLAN
You can view VXLANs and their details under the VXLAN tab.

To view VXLANs, choose Monitor > Inventory > View > Switches, and then click a switch name in the
Device Name column.

The following table describes the fields that are displayed:

Table 3: The VXLAN Tab

DescriptionField

Displays the Layer 2 (network) or Layer 3 (VRF)
VXLAN VNI that is configured on a switch.

VNI

Displays the multicast address that is associated with
the Layer 2 VNI, if applicable.

Multicast address

Displays the status of the VNI.VNI Status

Displays the VNImodes: Control Plane or Data Plane.Mode

Displays whether the VXLANVNI is associatedwith
a network (Layer 2) or a VRF (Layer 3).

Type

Displays the VRF name that is associated with the
VXLAN VNI if it is a Layer 3 VNI.

VRF

Displays the VLAN or Bridge domain that is mapped
to VNI.

Mapped VLAN

VLAN
You can view VLANs and their details under the VLAN tab.

To view VLANs, choose Monitor > Inventory > View > Switches, and then click a switch name in the
Device Name column.

The following table describes the fields that are displayed:

Table 4: The VLAN Tab

DescriptionField

Displays the VLAN configured on the switch.VLAN

Displays the name of VLAN.Name

Displays whether the VLAN is associated with a
network.

Type

Displays the name of associated policy. If a policy is
not associated, by default it is Undefined.

Policy

Displays the VLAN modes.Mode
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DescriptionField

Displays the status of VLAN.Status

Specifies the port number to which the VLAN is
physically connected to the Switch.

Ports

Switch Modules
You can view the switch modules and their details under the Modules tab.

To view theModules tab, chooseMonitor > Inventory > Switches, click a switch name in theDevice Name
column, and navigate to the Modules tab.

The following table describes the fields that are displayed:

Table 5: The Modules Tab

DescriptionField

Specifies the name of the module.Name

Specifies the model name of the module.ModelName

Specifies the serial number of the module.SerialNum

Specifies the module type. Valid values are chassis,module, fan, and powerSupply.Type

Specifies the operational status of the module.OperStatus

Specifies the slot number of the module.Slot

Specifies the NX-OS hardware version.H/W
Revision

Specifies the NX-OS software version.S/W
Revision

Specifies the asset ID of the module.AssetID

Specifies the IO field programmable gate arrays (FPGA) version.IO FPGA

Specifies the MI field programmable gate arrays (FPGA) version.MI FPGA

FEX
The Fabric Extender feature allows you to manage a Cisco Nexus 2000 Series Fabric Extender and its
association with the Cisco NX-OS switch that it is attached to. A Fabric Extender is connected to the switch
through physical Ethernet interfaces or a Port Channel. By default, the switch does not allow the attached
Fabric Extender to connect until it has been assigned a chassis ID and is associated with the connected interface.
You can configure a Fabric Extender host interface port as a routed or Layer 3 port. However, no routing
protocols can be tied to this routed interface.

FEX feature is available on LAN devices only. Therefore, you will see FEX on Cisco DCNM Inventory
Switches. FEX is also not supported on Cisco Nexus 1000V devices.

Note

Monitor
9

Monitor
Switch Modules



4x10G breakout for FEX connectivity is not supported on Cisco Nexus 9500 Switches.Note

The Fabric Extender may connect to the switch through several separate physical Ethernet interfaces or at
most one port channel interface.

Note

This section describes how tomanage Fabric Extender (FEX) on Cisco Nexus Switches through Cisco DCNM.

You can create and manage FEX from Cisco DCNM Inventory > Switches.

FEX tab is visible only if you choose a LAN device.Note

The following table describes the fields that appear on this page.

Table 6: FEX Operations

DescriptionField

Allows you to view various configuration details for the selected FEX
ID. You can select the following from the drop-down list.

• show_diagnostic

• show_fex

• show_fex_detail

• show_fex_fabric

• show_fex_inventory

• show_fex_module

The variables for respective show commands are displayed in the
Variables area. Review the Variables and click Execute. The output
appears in the Output area.

You can create a show template for FEX. Select template type as SHOW
and sub type as FEX.

Show

Table 7: FEX Field and Description

DescriptionField

Uniquely identifies a Fabric Extender that is connected to a Cisco NX-OS
device.

Fex Id

Description that is configured for the Fabric Extender.Fex Description

Specifies the version of the FEX that is associated with the switch.Fex Version
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DescriptionField

An integer value that denotes the maximum pinning uplinks of the Fabric
Extender that is active at a time.

Pinning

Specifies the status of the FEX as associated with the Cisco Nexus Switch.State

Specifies the model of the FEX.Model

Specifies the configured serial number.

If this configured serial number and the serial number of
the Fabric Extender are not the same, the Fabric Extender
will not be active.

Note

Serial No.

Specifies the port channel number to which the FEX is physically
connected to the Switch.

Port Channel

Refers to the physical interfaces to which the FEX is connected.Ethernet

Specifies the vPC ID configured for FEX.vPC ID

VDCs
This section describes how tomanage Virtual Device Contexts (VDCs) on Cisco Nexus 7000 Switches through
Cisco DCNM.

Users with the network administrator (network-admin) role can create Virtual Device Contexts (VDCs). VDC
resource templates limit the amount of physical device resources available to the VDC. The Cisco NX-OS
software provides a default resource template, or you can create resource templates.

You can create and manage VDCs from Cisco DCNM Inventory > Switches > VDCs. As Cisco DCNM
supports DCNM on Cisco Nexus 7000 Series only, click an active Cisco Nexus 7000 Switch. After you create
a VDC, you can change the interface allocation, VDC resource limits, and the high availability (HA) policies.

The following table describes the fields that appear on this page.

Table 8: VDC Operations

DescriptionField

Click to add a new VDC.Add

Select any active VDC radio button and click Edit to edit the VDC
configuration.

Edit

Allows you to delete the VDC. Select any active VDC radio button
and click Delete to remove the VDC associated with the device.

Delete

Allows you to resume a suspended VDC.Resume
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DescriptionField

Allows you to suspend an active non-default VDC.

Save the VDC running configuration to the startup configuration
before suspending the VDC. Otherwise, you will lose the changes
to the running configuration.

You cannot suspend the default VDC.Note

Suspending a VDC disrupts all traffic on the VDC.Caution

Suspend

Allows you to resume a non-default VDC from the suspended
state. The VDC resumes with the configuration that is saved in
the startup configuration.

Rediscover

Allows you to view the Interfaces and Resources that are allocated
to the selected VDC.

In the Interface tab, you can view the mode, admin-status, and
operational status for each interface associated with the VDC.

In the Resource tab, you can view the allocation of resources and
current usage of these resources.

Show

Table 9: Vdc Table Field and Description

DescriptionField

Displays the unique name for the VDCName

Species the type of VDC. The two types of VDCs are:

• Ethernet

• Storage

Type

Specifies the status of the VDC.Status

Displays the allocated resource limit andmodule type.Resource Limit-Module Type
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DescriptionField

Specifies the action that the Cisco NX-OS software
takes when an unrecoverable VDC fault occurs.

You can specify the HA policies for single supervisor
module and dual supervisor module configurations
when you create the VDC. The HA policy options are
as follows:

Single supervisor module configuration:

• Bringdown—Puts the VDC in the failed state.
To recover from the failed state, you must reload
the physical device.

• Reload—Reloads the supervisor module.

• Restart—Takes down the VDC processes and
interfaces and restarts it using the startup
configuration.

Dual supervisor module configuration:

• Bringdown—Puts the VDC in the failed state.
To recover from the failed state, you must reload
the physical device.

• Restart—Takes down the VDC processes and
interfaces and restarts it using the startup
configuration.

• Switchover—Initiates a supervisor module
switchover.

The default HA policies for a non-default VDC that
you create is restart for a single supervisor module
configuration and switchover for a dual supervisor
module configuration. The default HA policy for the
default VDC is reload for a single supervisor module
configuration and switchover for a dual supervisor
module configuration.

HA-Policy

• Single Supervisor

• Dual Supervisor

Specifies the default VDCmanagementMAC address.Mac Address

Species the IP Address of the VDC Management
interface. The status shows if the interface if up or
down.

Management Interface

• IP Address Prefix

• Status

Specifies the SSH statusSSH
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If you change the VDC hostname of a neighbor device after initial configuration, the link to the old VDC
hostname is not replaced with the new hostname automatically. As a workaround, we recommend manually
deleting the link to the old VDC hostname.

Note

This chapter includes the following sections:

Add VDCs

To add VDC from the Cisco DCNMWeb UI, perform the following steps:

Before you begin

Ensure that you have discovered the physical device using a username that has the network-admin role.

Obtain an IPv4 or IPv6 address for the management interface (mgmt 0) if you want to use out-of-band
management for the VDC.

Create a storage VDC to run FCoE. The storage VDC cannot be the default VDC and you can have one storage
VDC on the device.

Procedure

Step 1 Choose Inventory > Switches > VDC.

The VDC window is displayed.

Step 2 Click the Add VDC icon.
Step 3 From the drop-down list, select the VDC type.

You can configure the VDC in two modes.

• Configuring Ethernet VDCs

• Configuring Storage VDCs

The default VDC type is Ethernet.

Step 4 Click OK.

Configuring Ethernet VDCs

To configure VDC in Ethernet mode from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 In the General Parameter tab, specify the VDC Name, Single supervisor HA-policy, Dual supervisor
HA-policy, and Resource Limit - Module Type.

Step 2 In the Allocate Interface tab, select the network interfaces (dedicated interfaces membership) to be allocated
to the VDC.
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Click Next.

Step 3 In the Allocate Resource tab, specify the resource limits for the VDC.

Select the radio button and choose Select a Template from existing Templates or Create a New Resource
Template. VDC resource templates describe the minimum and maximum resources that the VDC can use.
If you do not specify a VDC resource template when you create a VDC, the Cisco NX-OS software uses the
default template, vdc-default.

• If you choose Select a Template from existing Templates, from the Template Name drop-down list, you
can select None, global-default, or vdc-default.

The template resource limits are detailed in the following below:

Table 10: Template Resource Limits

MaximumMinimumResource

Global Default VDC Template Resource Limits

Anycast Bundled

8

Route memory is in megabytes.

8IPv6 multicast route memory

4848IPv4 multicast route memory

3232IPv6 unicast route memory

IPv4 unicast route memory

VDC Default Template Resource Limits

Monitor session extended

Monitor session mx exception

Monitor SRC INBAND

Port Channels

Monitor DST ERSPAN

SPAN Sessions

VLAN

Anycast Bundled

IPv6 multicast route memory

IPv4 multicast route memory

IPv6 unicast route memory

IPv4 unicast route memory
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MaximumMinimumResource

VRF

• If you choose Create New Resource Template, enter a unique Template Name. In the Resource Limits
area, enter the minimum and maximum limits, as required for the resources.

You can edit individual resource limits for a single VDC through the Cisco DCNM Web Client > Inventory
> Switches > VDC.

Click Next.

Step 4 In the Authenticate tab, you can allow the Admin to configure the password and also authenticate users using
AAA Server Groups.

In the Admin User Area:

• Check the Enable Password Strength Check checkbox, if necessary.

• In the Password field, enter the admin user password.

• In the Confirm Password field, reenter the admin user password.

• In the Expiry Date field, click the down arrow and choose an expiry date for the admin user from the
Expiry Date dialog box. You can also select Never radio button not to expire the password.

In the AAA Server Groups area:

• In the Group Name field, enter an AAA server group name.

• In the Servers field, enter one or more host server IPv4 or IPv6 addresses or names, which are separated
by commas.

• In the Type field, choose the type of server group from the drop-down list.

Click Next.

Step 5 In the Management Ip tab, enter IPv4 or IPv6 Address information.

Click Next.

Step 6 In the Summary tab, review the VDC configuration.

Click Previous to edit any parameters.

Click Deploy to configure VDC on the device.

Step 7 In the Deploy tab, the status of the VDC deployment is displayed.

A confirmation message appears. Click Know More to view the commands that are executed to deploy the
VDC.

Click Finish to close the VDC configuration wizard and revert to view the list of VDCs configured on the
device.
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Configuring Storage VDCs

To configure VDCs in storage mode from the Cisco DCNMWeb UI, perform the following steps:

Before you begin

Create a separate storage VDC when you run FCoE on the device. Only one of the VDCs can be a storage
VDC, and the default VDC cannot be configured as a storage VDC.

You can configure shared interfaces that carry both Ethernet and Fibre Channel traffic. In this specific case,
the same interface belongs to more than one VDC. The shared interface is allocated to both an Ethernet and
a storage VDC.

Procedure

Step 1 In the General Parameter tab, specify the VDC Name, Single supervisor HA-policy, Dual supervisor
HA-policy, and Resource Limit - Module Type.

Step 2 In the Allocate FCoE Vlan tab, select the available Ethernet Vdc from the drop-down list.

The existing Ethernet VLANs range is displayed. Select None not to choose any available Ethernet VDCs.

You can allocate specified FCoE VLANs to the storage VDC and specified interfaces.

Click Next.

Step 3 In the Allocate Interface tab, add the dedicated and shared interfaces to the FCoE VDC.

The dedicated interface carries only FCoE traffic and the shared interface carries both the Ethernet
and the FCoE traffic.

Note

You can configure shared interfaces that carry both Ethernet and Fibre Channel traffic. In this specific case,
the same interface belongs to more than one VDC. FCoE VLAN and shared interface can be allocated from
same Ethernet VDC.

Click Next.

Step 4 In the Authenticate tab, you can allow the Admin to configure the password and also authenticate users using
AAA Server Groups.

In the Admin User Area:

• Check the Enable Password Strength Check checkbox, if necessary.

• In the Password field, enter the admin user password.

• In the Confirm Password field, reenter the admin user password.

• In the Expiry Date field, click the down arrow and choose an expiry date for the admin user from the
Expiry Date dialog box. You can also select Never radio button not to expire the password.

In the AAA Server Groups area:

• In the Group Name field, enter an AAA server group name.

• In the Servers field, enter one or more host server IPv4 or IPv6 addresses or names, which are separated
by commas.
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• In the Type field, choose the type of server group from the drop-down list.

Click Next.

Step 5 In the Management Ip tab, enter IPv4 or IPv6 Address information.

Click Next.

Step 6 In the Summary tab, review the VDC configuration.

Click Previous to edit any parameters.

Click Deploy to configure VDC on the device.

Step 7 In the Deploy tab, the status of the VDC deployment is displayed.

A confirmation message appears. Click Know More to view the commands that are executed to deploy the
VDC.

Click Finish to close the VDC configuration wizard and revert to view the list of VDCs configured on the
device.

Edit VDC

To edit VDC from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Inventory > Switches > VDC.

The VDC window is displayed.

Step 2 Select the VDC radio button that you must edit. Click the Edit VDC icon.
Step 3 Modify the parameters as required.
Step 4 After you review the configuration summary on the Summary tab, click Deploy the VDC with the new

configuration.

Viewing Inventory Information for Modules
To view the inventory information for modules from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Modules.

The Modules window is displayed with a list of all the switches and its details for a selected Scope.

Step 2 You can view the following information.

• Group column displays the group name of the module.

Monitor
18

Monitor
Edit VDC



• Switch column displays the switch name on which the module is discovered.

• Name displays the module name.

• ModelName displays the model name.

• SerialNum column displays the serial number.

• 2nd SerialNum column displays the second serial number.

• Type column displays the type of the module.

• Slot column displays the slot number.

• Hardware Revision column displays the hardware version of the module.

• Software Revision column displays the software version of the module.

• Asset ID column displays the asset id of the module.

• OperStatus column displays the operation status of the module.

• IO FPGA column displays the IO field programmable gate arrays (FPGA) version.

• MI FPGA column displays the MI field programmable gate arrays (FPGA) version.

Viewing Inventory Information for Licenses
To view the inventory information for licenses from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Inventory > View > Licenses.

The Licenses window is displayed based on the selected Scope.

Step 2 You can view the following information.

• Group column displays the group name of switches.

• Switch column displays the switch name on which the feature is enabled.

• Feature displays the installed feature.

• Status displays the usage status of the license.

• Type column displays the type of the license.

• Warnings column displays the warning message.
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Monitoring Switch
The Switch menu includes the following submenus:

Viewing Switch CPU Information
To view the switch CPU information from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Switch > CPU.

The CPU window is displayed. This window displays the CPU information for the switches in that scope.

Step 2 You can use the drop-down to filter the view by Last 10 Minutes, Last Hour, Last Day, Last Week, Last
Month, and Last Year.

Step 3 In the Switch column, click the switch name to view the Switch Dashboard.
Step 4 Click the chart icon in the Switch column to view the CPU utilization.

You can also change the chart timeline to Last 10 Minutes, Last Hour, Last Day, Last Week, Last Month, and
Last Year. You can choose the chart type and chart options to show as well.

Viewing Switch Memory Information
To view the switch memory information from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Switch > Memory.

The memory panel is displayed. This panel displays the memory information for the switches in that scope.

Step 2 Use the drop-down to filter the view by Last 10 Minutes, Last Hour, Last Day, Last Week, Last Month, and
Last Year.

Step 3 Click the chart icon in the Switch column to see a graph of the memory usage of the switch.
Step 4 In the Switch column, click the switch name to view the Switch Dashboard.
Step 5 You can use the drop-down to view the chart in different time lines. Use the chart icons to view the memory

utilization chart in varied views.

Viewing Switch Traffic and Errors Information
To view the switch traffic and errors information from the Cisco DCNMWeb UI, perform the following steps:
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Procedure

Step 1 Choose Monitor > Switch > Traffic.

The Switch Traffic panel is displayed. This panel displays the traffic on that device for the past 24 hours.

Step 2 Use the drop-down to filter the view by 24 hours, Week, Month, and Year.
Step 3 Click the Export icon in the upper-right corner to export the data into a spreadsheet.
Step 4 Click Save.
Step 5 Click the switch name to view the Switch Dashboard section.

Viewing Switch Temperature
Cisco DCNM includes the module temperature sensor monitoring feature, using which you can view the
sensor temperature of a switch. You can choose an interval by which to filter the sensor list. The default
interval is Last Day. Only sensors that have historical temperature data is shown in the list. You can choose
between Last ten Minutes, Last Hour, Last Day, Last Week, and Last Month.

It is not necessary to configure the LAN credentials under the Configure > Credentials Management >
LAN Credentials screen to fetch the temperature monitoring data from the switches.

Note

To view the switch temperature information from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Switch > Temperature.

The Switch Temperature window is displayed with the following columns.

• Scope: The sensor belongs to a switch, which is part of a fabric. The fabric that it belongs to is shown
as its scope. When the scope selector at the top of Cisco DCNM is used, the sensor list is filtered by that
scope.

• Switch: Name of the switch the sensor belongs to.
• IP Address: IP Address of the switch.
• Temperature Module: The name of the sensor module.
• Avg/Range: The first number is the average temperature over the interval that is specified at the top of
the table. The second set of numbers is the range of the temperature over that interval.

• Peak: The maximum temperature over the interval

Step 2 From this list, each row has a chart icon, which you can click.
A chart is displayed, which shows historical data for the sensor. The interval for this chart can be changed as
well, between 24 hours, 1 week, and 1 month.
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Enabling Temperature Monitoring
You can enable the temperature monitoring feature for LAN switches from the LAN Collections screen, and
for the SAN switches by setting a few properties under Administration > DCNM Server > Server Properties
screens.

Enabling Temperature Monitoring for LAN Switches

1. From the menu bar, choose Administration > Performance Setup > LAN Collections.

2. Select the Temperature Sensor check box.

3. Select the type of LAN switches for which you want to collect performance data.

4. Click Apply to save the configuration.

Viewing Accounting Information
To view the accounting information from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Switch > Accounting.

The fabric name or the group name along with the accounting information is displayed.

Step 2 SelectAdvanced Filter beside the filter icon to search the accounting information by Source,Username,Time,
and Description. Or select Quick Filter to search under each column.

Step 3 You can also select a row and click the Delete icon to delete accounting information from the list.
Step 4 You can use the Print icon to print the accounting details and use the Export icon to export the data to a

Microsoft Excel spreadsheet.

Viewing Events Information
To view the events and syslog from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Monitor > Switch > Events.

The fabrics along with the switch name and the events details are displayed.

TheCount column displays the number of times the same event has occurred during the time period as shown
in the Last Seen and First Seen columns.

Click a switch name in the Switch column to view the switch dashboard.

Step 2 Select an event in the table and click the Add Suppressor icon to open the shortcut of adding an event
suppressor rule.
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Step 3 Select one or more events from the table and click theAcknowledge icon to acknowledge the event information
for the fabric.

• After you acknowledge the event for a fabric, the acknowledge icon is displayed in the Ack column next
to the fabric.

Step 4 Select the fabric and click the Unacknowledge icon to cancel an acknowledgment for a fabric.
Step 5 SelectAdvanced Filter beside the filter icon to search the accounting information by Source,Username,Time,

and Description. Or select Quick Filter to search under each column.
Step 6 Select a fabric and use the Delete icon to delete the fabric and event information from the list.
Step 7 Click the Print icon to print the event details.
Step 8 Click the Export to Excel icon to export the data.

Monitoring LAN
The LAN menu includes the following submenus:

Monitoring Performance Information for Ethernet
To monitor the performance information for ethernet from the Cisco DCNMWeb UI, perform the following
steps:

Procedure

Step 1 Choose Monitor > LAN > Ethernet.

The Ethernet window is displayed.

Step 2 You can use the drop-down to filter the view by Last 10 Minutes, Last Hour, Last Day, Last Week, Last
Month, and Last Year.

There are variations to this procedure. In addition to these basic steps, you can also perform the following
steps:

• Select the name of an Ethernet port from theName column to see a graph of the traffic across that Ethernet
port for the past 24 hours. You can change the time range for this graph by selecting it from the drop-down
list in the upper-right corner.

• To export the data into a spreadsheet, click the Export icon in the upper-right corner and click Save.

• Use the chart icons to view the traffic chart in varied views. You can also use the icons to Append,
Predict, and Do not interpolate data.

Set the pmchart.doInterpolate property in the Server Properties window to false to use
the Do not interpolate data option.

Note

• For the Rx/Tx calculation, see the following Rx/Tx calculation.
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The conversion for Fabrics is 10 bit = 1 byte and for LAN traffic, the conversion is 8 bit =
1 byte.

• Average Rx/Tx % = Average Rx/Tx divided by Speed * 100

• Peak Rx/Tx % = Peak Rx/Tx divided by Speed * 100

Note

If the performance tables do not contain any data, see the Thresholds section to turn on performance
data collection.

Note

To change traffic display unit from bytes to bits, From Cisco DCNMWeb UI, choose
Administration > DCNM Server > Server Properties, enter value as true for
pm.showTrafficUnitAsbit property, and click Apply Changes.

Note

Monitoring ISL Traffic and Errors
To monitor the ISL traffic and errors from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Monitor > LAN > Link.

The ISL Traffic and Errorswindow is displayed. This panel displays the ISL information for the end devices
in that scope. You can reduce or expand the scope of what is displayed by using the scope menu.

Step 2 You can use the drop-down to filter the view by Last 10 Minutes, Last Hour, Last Day, Last Week, Last
Month, and Last Year.

NaN (Not a Number) in the data grid means that the data is not available.Note

There are variations to this procedure. In addition to these basic steps, you can perform the following steps
to view detailed information for ISLs:

• To change the time range for this graph, select it from the drop-down list in the upper-right corner.

• To view the detailed information for a specific period, drag the slider control to choose the time interval
for which you need the information.

• Use the chart icons to view the traffic chart in varied views. You can also use the icons to Append,
Predict, and Do not interpolate data.

Set the pmchart.doInterpolate property in the Server Properties window to false to use
the Do not interpolate data option.

Note

• To export the data into a spreadsheet, choose Export from the drop-down list in the Chart menu and
then click Save.

• For the Rx/Tx calculation, see the following Rx/Tx calculation.
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The conversion for Fabrics is 10 bit = 1 byte and for LAN traffic, the conversion is 8 bit =
1 byte.

• Average Rx/Tx % = Average Rx/Tx divided by Speed * 100

• Peak Rx/Tx % = Peak Rx/Tx divided by Speed * 100

Note

If the performance tables do not contain any data, see the Performance Setup Thresholds section
to turn on performance.

Note

Monitoring a vPC
The virtual port channel (vPC) feature enables you to view the links that are physically connected to different
devices as a single port channel. A vPC is an extended form of a port channel which allows you to create
redundancy and increase bisectional bandwidth by enablingmultiple parallel paths between nodes and allowing
load balancing traffic. Traffic is distributed among two single device vPC endpoints. If there is an inconsistency
in the vPC configurations, the vPC does not function correctly.

To view the vPC in vPC Performance, both primary and secondary device should be designated to the user.
If either one kind of switch is not designated, vPC information is isplayed.

Note

Cisco DCNM Web Client > Monitor> vPC displays only consistent vPCs displays both the consistent and
inconsistent vPCs.

You can identify the inconsistent vPCs and resolve the inconsistencies in each vPC by using the Cisco DCNM
Web UI > Configure > Deploy > vPC Peer and Web Client > Configure > Deploy > vPC.

Table 11: vPC Performance, on page 25 displays the following vPC configuration details in the data grid
view.

Table 11: vPC Performance

DescriptionColumn

Enter any string to filter the entries in their respective column.Search box

Displays vPC ID's configured device.vPC ID

Displays the domain ID of the vPC peer switches.Domain ID

Displays the multi-chassis vPC endpoints for each vPC ID
under a vPC domain.

Multi Chassis vPC EndPoints

Displays the vPC Primary device name.Primary vPC Peer - Device Name

Displays the primary vPC interface.Primary vPC Peer - Primary vPC Interface

Displays the capacity for the primary vPC peer.Primary vPC Peer - Capacity

Displays the average receiving speed of primary vPC peer.Primary vPC Peer - Avg. Rx/sec
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DescriptionColumn

Displays the average sending speed of primary vPC peer.Primary vPC Peer - Avg. Tx/sec

Displays the peak utilization percentage of primary vPC peer.Primary vPC Peer - Peak Util%

Displays the vPC secondary device name.Secondary vPC Peer - Device Name

Displays the secondary vPC interface.Secondary vPC Interface

Displays the capacity for the secondary vPC peer.Secondary vPC Peer - Capacity

Displays the average receiving speed of secondary vPC peer.Secondary vPC Peer - Avg. Rx/sec

Displays the average sending speed of secondary vPC peer.Secondary vPC Peer - Avg. Tx/sec

Displays the peak utilization percentage of secondary vPC
peer.

Secondary vPC Peer - Peak Util%

You can use this feature as following:

Monitoring vPC Performance
You can view the relationship among consistent virtual port channels (vPCs). You can view the statistics of
all member interfaces and the aggregate of the statistics at the port-channel level.

This tab only displays consistent vPCs.Note

To view the VPC performance information from the Cisco DCNMWeb UI, perform the following steps:

Procedure

Step 1 Choose Monitor > LAN > vPC.

The vPC Performance statistics is displayed. The aggregated statistics of all vPCs are displayed in a tabular
manner.

Step 2 Click the vPC ID.

The vPC topology, vPC Details, Peer-link Details, and Peer-link Status are displayed.

The vPC Consistency, Peer-link Consistency, and vPC Type2 Consistency for the vPC are displayed.

• Click the vPC Details tab, you can view the parameter details of vPCBasic Setting andLayer 2 Settings
for both Primary and Secondary vPC devices.

• Click the Peer-link Details tab, to view the parameter details of peer-link vPC Global Setting and STP
Global Settings for both Primary and Secondary vPC devices.

• Click the Peer-link Status tab, the vPC Consistency, and Peer-Link Consistency status is displayed.
The parameter details of Role Status and vPC Peer keep-alive Status for both Primary and Secondary
vPC devices is also displayed.
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Step 3 Click the peer-link icon in front of the Device Name in the Primary vPC peer or Secondary vPC peer
column to view its member interface.

Step 4 Click the Show Chart icon of the corresponding interface to view its historical statistics.

The traffic distribution statistics appear at the bottom of the vPC window. By default, the Cisco DCNMWeb
Client displays the historical statistics for 24 hours.

There are variations to this procedure. In addition to these basic steps, you can also perform the following
steps to view detailed information for flows:

• To change the time range for this graph, select it from the drop-down list in the upper right corner.

• To view the detailed information for a specific period, drag the slider control to choose the time interval
for which you need the information.

• Use the chart icons to view the traffic chart in varied views.

• You can also use the icons to Append, Predict, and Do not interpolate data.

Set the pmchart.doInterpolate property in the Server Properties window to false to use
the Do not interpolate data option.

Note

• To print the vPC Utilization data, click the Print icon in the upper-right corner. The vPC Utilization
page appears.

• To export the data into a spreadsheet, click the Export icon in the upper-right corner and click Save File.

If the performance tables do not contain any data, see the Thresholds section to turn on performance
data collection.

Note

Endpoint Locator
The Endpoint Locator (EPL) feature allows real-time tracking of endpoints within a data center. The tracking
includes tracing the network life history of an endpoint and getting insights into the trends that are associated
with endpoint additions, removals, moves, and so on.

Information about the Endpoint Locator is displayed on a single landing page or dashboard . The dashboard
displays an almost real-time view of data (refreshed every 30 seconds) pertaining to all the active endpoints
on a single pane. The data that is displayed on this landing page is dependent on the scope selected by you
from the SCOPE drop-down list.

• Endpoint Locator

• Monitoring Endpoint Locator

Alarms
The Alarms menu includes the following submenus:
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Viewing Alarms and Events
You can view the alarms, cleared alarms, and events.

Procedure

Step 1 Choose Monitor > Alarms > View.
Step 2 Choose any of the following tabs.

• Alarms: This tab displays the alarms that are generated for various categories. This tab displays
information such as ID (optional), Severity, Failure Source, Name, Category, Acknowledged, Creation
Time, Last Updated (optional), Policy, and Message. You can specify the Refresh Interval in this tab.
You can select one or more alarms and then acknowledge or unacknowledge their status using theChange
Status drop-down list. In addition, you can select one or more alarms and then click the Delete button
to delete them.

• Cleared Alarms: This tab displays the cleared alarms. This tab displays information such as ID (optional),
Severity, Failure Source, Name, Category, Acknowledged, Creation Time, Cleared At (optional), Cleared
By, Policy, and Message. You can select one or more alarms and then click the Delete button to delete
them.

• Events: This tab displays the events that are generated for the switches. This tab displays information
such as Ack, Acknowledged user, Group, Switch, Severity, Facility, Type, Count, Last Seen, and
Description. You can select one or more events and then acknowledge or unacknowledge their status
using the Change Status drop-down list. In addition, you can select one or more alarms and then click
the Delete button to delete them. If you want to delete all events, click the Delete All button.

Monitoring and Adding Alarm Policies

• Alarm policies are stored in compute nodes. Therefore, run the appmgr backup command on each
compute node in addition to taking a backup of DCNM.

Note

You can forward alarms to registered SNMP listeners in DCNM. From Cisco DCNM web UI, choose
Administration > DCNM Server > Server Properties, enter an external port address in
alarm.trap.listener.address field, click Apply Changes, and restart DCNM services.

Ensure that you select Forwarding check box inAlarm Policy creation dialog window to enable forwarding
alarms to external SNMP listener.

Note

You can add alarm policies for the following:

• Device Health: Device health policies enable you to create alarms when Device ICMP Unreachable,
Device SNMP Unreachable, or Device SSH Unreachable. Also, these policies enable you to monitor
chassis temperature, CPU, and memory usage.
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• Interface Health: Interface health policies enable you to monitor Up or Down, Packet Discard, Error,
Bandwidth details of the interfaces. By default all interfaces are selected for monitoring.

• Syslog Alarm: Syslog Alarm Policy defines a pair of Syslog messages formats; one which raises the
alarm, and one which clears the alarm.

Procedure

Step 1 Choose Monitor > Alarms > Alarm Policies.
Step 2 Select the Enable Alarms check box to enable alarm policies.
Step 3 From the Add drop-down list, choose any of the following:

• Device Health Policy: Select the devices for which you want to create policies. Specify the policy name,
description, CPU Utilization parameters, Memory Utilization parameters, Environment Temperature
parameters, device availability, and device features. Under Device Features, you can select the BFD,
BGP, and HSRP protocols. When these check boxes are selected, alarms are triggered for the following
traps: BFD- ciscoBfdSessDown, ciscoBfdSessUp, BGP- bgpEstablishedNotification,
bgpBackwardTransNotification, cbgpPeer2BackwardTransition (), cbgpPeer2EstablishedNotification,
and HSRP- cHsrpStateChange. Please refer
https://snmp.cloudapps.cisco.com/Support/SNMP/do/BrowseOID.do?local=en for detailed trap OID
definition.

• Interface Health Policy: Select the devices for which you want to create policies. Specify the policy
name, description, link-state, Bandwidth (In/Out), Inbound errors, Outbound errors, Inbound Discards,
and Outbound Discards.

• Syslog Alarm Policy: Select the devices for which you want to create policies and then specify the
following parameters.

• Devices: Define the scope of this policy. Select individual devices or all devices to apply this policy.

• Policy Name: Specify the name for this policy. It must be unique.

• Description: Specify a brief description for this policy.

• Severity: Define the severity level for this syslog alarm policy. Choices are: Critical, Major, Minor,
and Warning.

• Identifier: Specify the identifier portions of the raise & clear messages.

• Raise Regex: Define the format of a syslog raise message. The syntax is as follows:
Facility-Severity-Type: Message

• Clear Regex: Define the format of a syslog clear message. The syntax is as follows:
Facility-Severity-Type: Message

The Regex definitions are simple expressions but not a complete regex. Variable regions of text are noted
using $(LABEL) syntax. Each label represents a regex capture group (.+), which corresponds to one or
more characters. The variable texts found in both raise and clear messages are used to associate the two
messages. An Identifier is a sequence of one or more labels that appear in both messages. An Identifier
is used to match a clear syslog message to the syslog message that raised the alarm. If the text appears
only in one of the messages, it can be noted with a label and exclude it from the identifier.

Example: A policy with "Value": "ID1-ID2",
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"syslogRaise": "SVC-5-DOWN: $(ID1) module $(ID2) is down $(REASON)"

"syslogClear": "SVC-5-UP: $(ID1) module $(ID2) is up."

In the example, ID1 and ID2 labels can be marked as an identifier to find the alarm. This identifier will
be found in corresponding syslog messages. Label “REASON” is in the raise but not in the clear message.
This label can be excluded from the identifier, as it has no impact on the syslog message to clear the
alarm.

Table 12: Example 1

ID1-ID2Identifier

ETHPORT-5-IF_ADMIN_UP: Interface
Ethernet15/1 is admin up .

Raise Regex

ETHPORT-5-IF_DOWN_NONE: Interface
Ethernet15/1 is down (Transceiver Absent)

Clear Regex

In the above example, the regex expressions are part of the syslog messages that appear in the terminal
monitor.

Table 13: Example 2

ID1-ID2Identifier

ETH_PORT_CHANNEL-5-PORT_DOWN:
$(ID1): $(ID2) is down

Raise Regex

ETH_PORT_CHANNEL-5-PORT_UP: $(ID1):
$(ID2) is up

Clear Regex

Table 14: Example 3

ID1-ID2Identifier

ETHPORT-5-IF_SFP_WARNING: Interface
$(ID1), High Rx Power Warning

Raise Regex

ETHPORT-5-IF_SFP_WARNING: Interface
$(ID1), High Rx Power Warning cleared

Clear Regex

Step 4 Click OK to add the policy.

Syslog Messages in Terminal Monitor and Console

The following examples show how the syslog messages appear in the terminal monitor and the
console. The regex expression is matched with the part of the syslog messages after the % sign.
leaf-9516# terminal monitor
leaf-9516# conf t
leaf-9516(config)# int e15/1-32
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leaf-9516(config-if-range)# no shut
2019 Aug 2 04:41:27 leaf-9516 %ETHPORT-5-IF_ADMIN_UP: Interface
Ethernet15/1 is admin up .
2019 Aug 2 04:41:27 leaf-9516 %ETHPORT-5-IF_DOWN_NONE: Interface
Ethernet15/1 is down (Transceiver Absent)
2019 Aug 2 04:41:27 leaf-9516 %ETHPORT-5-IF_ADMIN_UP: Interface
Ethernet15/2 is admin up .
2019 Aug 2 04:41:27 leaf-9516 %ETHPORT-5-IF_DOWN_NONE: Interface
Ethernet15/2 is down (Transceiver Absent)
2019 Aug 2 04:41:28 leaf-9516 %ETHPORT-5-IF_ADMIN_UP: Interface
Ethernet15/3 is admin up .

The syslog messages in the console have a similar format as they would appear in the terminal
monitor, except for the additional port information enclosed in the %$ signs. However, the regex
expression is matched with the part of the syslog messages after the last % sign.
SR-leaf1# 2019 Aug 26 23:55:45 SR-leaf1 %$ VDC-1 %$ %PLATFORM-1-
PFM_ALERT: FAN_BAD: fan6
2019 Aug 26 23:56:15 SR-leaf1 %$ VDC-1 %$ %PLATFORM-1-PFM_ALERT:
FAN_BAD: fan6
2019 Aug 26 23:56:18 SR-leaf1 %$ VDC-1 %$ %ASCII-CFG-2-CONF_CONTROL:
System ready
2019 Aug 26 23:56:25 SR-leaf1 %$ VDC-1 %$ %PLATFORM-1-PFM_ALERT:
FAN_BAD: fan6
2019 Aug 26 23:56:35 SR-leaf1 %$ VDC-1 %$ %PLATFORM-1-PFM_ALERT:
FAN_BAD: fan6
2019 Aug 26 23:56:39 SR-leaf1 %$ VDC-1 %$ %VMAN-2-ACTIVATION_STATE:
Successfully activated virtual service 'guestshell+'
2019 Aug 26 23:56:39 SR-leaf1 %$ VDC-1 %$ %VMAN-2-GUESTSHELL_ENABLED:
The guest shell has been enabled. The command 'guestshell' may be used
to access it, 'guestshell destroy' to remove it.
2019 Aug 26 23:56:45 SR-leaf1 %$ VDC-1 %$ %PLATFORM-2-FAN_REMOVED: Fan
module 5 (Serial number ) Fan5(sys_fan5) removed
2019 Aug 26 23:56:45 SR-leaf1 %$ VDC-1 %$ %PLATFORM-1-PFM_ALERT:
System will shutdown in 2 minutes 0 seconds due to fan policy
__pfm_fanabsent_any_singlefan.
2019 Aug 26 23:56:45 SR-leaf1 %$ VDC-1 %$ %PLATFORM-1-PFM_ALERT:
FAN_BAD: fan6
2019 Aug 26 23:56:54 SR-leaf1 %$ VDC-1 %$ %PLATFORM-1-PFM_ALERT:
System will shutdown in 1 minutes 40 seconds due to fan policy
__pfm_fanabsent_any_singlefan.
2019 Aug 26 23:56:54 SR-leaf1 %$ VDC-1 %$ %PLATFORM-1-PFM_ALERT:
FAN_BAD: fan6
2019 Aug 26 23:57:03 SR-leaf1 %$ VDC-1 %$ %PLATFORM-2-FANMOD_FAN_OK:
Fan module 5 (Fan5(sys_fan5) fan) ok
2019 Aug 26 23:57:03 SR-leaf1 %$ VDC-1 %$ %PLATFORM-1-PFM_ALERT:
FAN_BAD: fan6

Activating Policies
After you create new alarm policies, activate them.

Procedure

Step 1 Choose Monitor > Alarms > Policies.
Step 2 Select the policies that you want to activate and then click the Activate button.
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Deactivating Policies
You can deactivate the active alarm policies.

Procedure

Step 1 Choose Monitor > Alarms > Policies.
Step 2 Select the policies that you want to deactivate and then click the Deactivate button.

Importing Policies
You can create alarm policies using the import functionality.

Procedure

Step 1 Choose Monitor > Alarms > Policies and then click the Import button.
Step 2 Browse and select the policy file saved on your computer.

You can only import policies in text format.

Exporting Policies
You can export the alarm policies into a text file.

Procedure

Step 1 From the menu bar, choose Monitor > Alarms > Policies.
Step 2 Click the Export button and then select a location on your computer to store the exported file.

Editing Policies

Procedure

Step 1 From the menu bar, choose Monitor > Alarms > Policies.
Step 2 Select the policy that you want to edit.
Step 3 Click the Edit button and then make necessary changes.
Step 4 Click the OK button.
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Deleting Policies

Procedure

Step 1 From the menu bar, choose Monitor > Alarms > Policies.
Step 2 Select the policy that you want to delete.
Step 3 Click the Delete button. The policy is deleted.

Enabling External Alarms
You can enable external alarms using one of the following methods:

• Using Cisco DCNMWeb UI

1. From Cisco DCNMWeb UI, choose Administration > DCNM Server > Server Properties.

2. Locate the alarm.enable.external property.

3. Enter the value in the field as true.

• Using REST APIs

1. Go the API documentation URL from your DCNM setup: https://<DCNM-ip>/api-docs

2. Navigate to the Alarms section.

3. Click POST > rest/alarms/enabledisableextalarm.

4. Choose the body parameter value as true from the Value drop-down list.

5. Click Try it out!.

• Using CLI

1. Log into the DCNM server using SSH.

2. Set the alarm.enable.external property to true in the server.properties file.

The filepath is /usr/local/cisco/dcm/fm/config/server.properties.

Configuration Compliance Alarms
Starting from Cisco DCNM Release 11.3(1), the alarm policies and alarms under the External category are
created by the applications running on DCNM. These External alarm policies are created by the applications
and cannot be created or added via the DCNMWeb UI.

Config-Compliance(CC) is a core application running on DCNM. CC registers and creates Alarms under the
External Alarm category.
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Config-Compliance : Alarm Policy

This External alarm category policy is activated on creation of the fabric and is enabled on all the devices in
that fabric. The severity level of the policy is CRITICAL. If any device in the fabric moves from In-Sync to
Out-of-Sync and the Enable Alarms checkbox is selected, a critical severity alarm is generated.

Choose Monitor>Alarms>Policies to display the default alarm policies. This alarm policy is not editable on
the web UI. Click Activate or Deactivate to activate or deactivate the selected policy.

In case an alarm policy is deactivated using the DCNMWeb UI, any alarms created or cleared for that policy
will not be displayed in the Monitor>Alarms>View tab. To delete a policy, select the checkbox next to the
policy and click Delete. However, we recommend not deleting a policy from the DCNMWeb UI. If a policy
is deleted, CC regenerates the policy on the next periodic run or when a Re-sync is triggered at the device
level or fabric level under that fabric.

Click the arrow icon next to Critical to display detailed information about the alarm.
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An Out-of-Sync status indicates that there is a difference between the intent defined for the device on DCNM
and the running configuration on the device. An In-Sync status indicates that the intent defined for the device
on DCNM matches the running configuration and CC found no differences between the configurations. For
more details on computation of diff, refer Configuration Compliance in DCNM.

When a fabric is deleted, the alarm policy along with all the active alarms for the devices in that fabric are
deleted.

Config-Compliance : Active Alarms

Consider a scenario in which CC is running on a fabric and a device in that fabric moves to Out-of-Sync
status. This leads to the generation of a Critical severity alarm. Choose Monitor->Alarms->View to display
the alarms. These alarms are active until the device moves from Out-of-Sync to In-Sync.

To clear active alarms, select the checkbox next to the alarm, click Change Status and select Clear. In case
the same device moves to Out-of-Sync status again, the active alarm is re-created.
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To delete active alarms, select the checkbox next to the alarm and clickDelete. In case the same device moves
to Out-of-Sync status again, a new active alarm is created.

Config-Compliance : Cleared Alarms

When the device that is in Out-of-Sync status moves to In-Sync status, the active alarm is cleared. To view
the cleared alarms, select Monitor>Alarms>View>Cleared Alarms. The cleared alarms do not contribute
to the overall device health score.

To delete a cleared alarm from the list of cleared alarms, choose Monitor>Alarms>View>Cleared Alarms,
select the checkbox next to the alarm, and click Delete. This will delete the selected cleared alarms from the
list.

Alarms are cleared when a switch moves fromOut-of-Sync to In-Sync. Configuration compliance alarms also
contribute to the overall Health score of a device.

For more information on Alarms and Policies, refer Alarms.

Endpoint Locator Alarms
Starting from Cisco DCNM Release 11.4(1), alarms are registered and created under the External alarm
category by the Endpoint Locator (EPL).
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Endpoint Locator: Alarm Policy

The EPL external alarm category policy is activated when EPL is enabled on a fabric. Alarms are raised for
issues such as Duplicate IP addresses, DuplicateMAC addresses, Endpoints appearing on a VRF and Endpoints
disappearing from a VRF, Endpoints moving within a fabric, loss of Route Reflector connectivity, and
restoration of Route Reflector connectivity. Depending on the issue, the severity level of the alarm policy can
be CRITICAL or MINOR.

Alarms are raised and categorized as CRITICAL for the following events:

• Route Reflector disconnection

• Detection of a duplicate IP address

• Detection of a duplicate MAC address

Alarms are raised and categorized as MINOR for the following events:

• Movement of an endpoint

• Appearance of a new VRF in a fabric

• Number of endpoints in a fabric goes down to 0

• Number of endpoints in a VRF goes down to 0

• Disappearance of all endpoints from a switch

• Connection of a Route Reflector (RR)

CRITICAL alarms are cleared automatically when the condition is corrected. For example, when the
connectivity between DCNM and RR is lost, a CRITICAL alarm is generated. This alarm is automatically
cleared when the connectivity between DCNM and RR is restored. Other MINOR alarms are automatically
cleared after 30 minutes have passed since the alarm was generated.

Choose Monitor>Alarms>Policies to display the EPL alarm policies. These alarm policies are not editable
on the web UI. Click Activate or Deactivate to activate or deactivate the selected policy.

In case an alarm policy is deactivated using the DCNMWeb UI, any alarms created or cleared for that policy
will not be displayed in the Monitor>Alarms>View tab. To delete a policy, select the checkbox next to the
policy and click Delete. However, we recommend not deleting a policy from the DCNMWeb UI. When a
fabric is deleted, the alarm policy along with all the active alarms for the devices in that fabric are deleted.
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Endpoint Locator: Active Alarms

Choose Monitor>Alarms>View to display the active alarms.

To clear active alarms, select the checkbox next to the alarm, click Change Status and select Clear.

To delete active alarms, select the checkbox next to the alarm and click Delete.

Endpoint Locator: Cleared Alarms

To view the cleared alarms, select Monitor>Alarms>View>Cleared Alarms.
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Click the arrow icon to display detailed information about the required alarm.

To delete a cleared alarm from the list of cleared alarms, select the checkbox next to the alarm and click
Delete.

For more information on Alarms and Policies, refer Alarms.

Health Monitor Alarms
Starting from Cisco DCNM Release 11.4(1), alarms are registered and created under the External alarm
category by the Health Monitor.

Health Monitor: Alarm Policy

The Health Monitor external alarm category policy is automatically activated and enabled on all the devices
in a fabric. The severity level of this alarm policy can be MINOR, MAJOR, or CRITICAL.

Alarms are raised and categorized as CRITICAL for the following events:
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• Elasticsearch (ES) Cluster Status is Red: Critical (For Cluster/HA mode only)

• CPU/Memory/Disk Utilization/ES JVM Heap Used Percentage >= 90%

Alarms are raised and categorized as MAJOR for the following events:

• ES Cluster Status is Yellow (For Cluster/HA mode only)

• ES has unassigned shards (For Cluster/HA mode only)

• CPU/Memory/Disk Utilization/ES JVM Heap Used Percentage >= 80% and <90%

Alarms are raised and categorized as MINOR for the following events:

• CPU/Memory/Disk Utilization/ES JVM Heap Used Percentage >= 65% and <80%

• Kafka: Number of partitions without active leader > 0

• Kafka: Qualified partition leader not found. Unclear leaders > 0

Choose Monitor>Alarms>Policies to display the Health Monitor alarm policies. These alarm policies are
not editable on the web UI. Click Activate or Deactivate to activate or deactivate the selected policy.

In case an alarm policy is deactivated using the GUI, any alarms created or cleared for that policy will not be
displayed in the Monitor>Alarms>View tab. To delete a policy, select the checkbox next to the policy and
clickDelete. However, we recommend not deleting a policy from the GUI.When a fabric is deleted, the alarm
policy along with all the active alarms for the devices in that fabric are deleted.

Health Monitor: Active Alarms

Choose Monitor>Alarms>View to display the active alarms.

To clear active alarms, select the checkbox next to the alarm, click Change Status and select Clear.

To delete active alarms, select the checkbox next to the alarm and click Delete.

Health Monitor: Cleared Alarms

To view the cleared alarms, select Monitor>Alarms>View>Cleared Alarms.

Click the arrow icon to display detailed information about the required alarm.
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To delete a cleared alarm from the list of cleared alarms, select the checkbox next to the alarm and click
Delete.

For more information on Alarms and Policies, refer Alarms.
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