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C H A P T E R 3

Managing Chassis

The Chassis Management chapter covers the following information:

• Management Information

• Chassis Configuration 

• SNMP Management 

• Chassis Inventory 

• Chassis Fault Management 

• Command Log 

• System Log 

• Configuration Editor 

• Configuration Backup/Restore 

• IOS Image Download 

• Initiating a Telnet Service

• Launching the Web Console

• APS Status

Management Information
The Management Information window allows you to perform the following functions:

• Configure the chassis IP address fields

• Set or change usernames and passwords

Caution It is strongly recommended that only a system administrator user should have access to the 
Management Information window, because access passwords can be configured and 
modified in this window.

The Management Information section covers the following areas;

• Viewing the Management Information Window

• System Configuration

• Entering or Changing Username and Passwords
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• Management Information Window—Detailed Description

Viewing the Management Information Window

Step 1 Right-click a chassis object, then choose CGM Management>Physical>Chassis>Management 
Information. The Management Information window appears, with the Configuration tab displayed.

Figure 3-1 Management Information Window—Configuration Tab

Step 2 Make sure the chassis you selected is highlighted in the list box at left. 

System Configuration
To configure the fields within the Configuration tab, proceed as follows: 

Step 1 Choose the relevant chassis from the list box at left.

Step 2 Configure the fields in the Configuration tab. For detailed information on the fields in this tab, refer to 
“Management Information Window—Detailed Description” section on page 3-3.
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Entering or Changing Username and Passwords
To enter or change the username or passwords, proceed as follows:

Step 1 Click the IOS/Command Line Security tab.

Figure 3-2 Management Information Window—IOS Command Line Security Tab

Step 2 Enter the login password (mandatory). You can also enter a username and/or exec password, if desired. 

Step 3 If you know the passwords that are set on the device:

• Click Save Locally. This changes the passwords stored within CGM only. 

If you do not know the passwords on the device, or if you want to change the passwords currently on the 
device:

• Click Save to Device. This changes passwords both on the device and locally in CGM.

Management Information Window—Detailed Description
The Management Information window displays two tabs: Configuration and IOS/Command Line 
Security.
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Configuration Tab

The Configuration tab displays a single System Configuration area.

System Configuration

The System Configuration area displays the following fields:

IP Address—Allows you to enter the IP address of the system.

System Name—Allows you to enter the name of the system.

System Contact—Allows you to enter the name and contact details for the person administering the 
node.

System Location—Allows you to specify the physical location of the system.

Extra Location Information (optional)—Allows you to specify additional information describing the 
location of the system.

IOS/Command Line Security Tab

The IOS/Command Line Security tab displays a single area, IOS Username and Passwords. 

IOS Username and Passwords

The IOS Username and Passwords area contains the following fields: 

User Name—Allows you to enter a unique user name password, enabling you to access and configure 
objects in CGM. 

Exec Password—Allows you to set the access password for the chassis, enabling you to perform specific 
operations on the Cisco 12000 GSR chassis.

Login Password—Allows you to set a telnet access password to protect CGM from access by 
unauthorized personnel.

Save Locally—Click Save Locally to save your passwords locally in CGM for a selected chassis.

Save to Device—Click Save to Device when you wish to reconfigure both the local CGM password and 
the password on the device, or when you want to change the current passwords for the selected chassis.

Chassis Configuration
The Chassis Configuration section covers the following areas:

• Viewing the Chassis Configuration Window

• Commissioning or Decommissioning a Chassis

• Starting or Stopping Global Performance Logging

• Chassis Configuration Window—Detailed Description
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Viewing the Chassis Configuration Window

Step 1 Right-click a chassis object, then choose CGM Management>Physical>Chassis>Configuration. The 
Chassis Configuration window appears, with the Configuration tab displayed.

Figure 3-3 Chassis Configuration Window—Configuration Tab

Step 2 Make sure the chassis you selected is highlighted in the list box at left. 

Commissioning or Decommissioning a Chassis
• Choose the chassis you want to commission or decommission from the list at left.

• Click the corresponding Commission or Decommission button.

Not applicable for CGM
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Commissioning a chassis starts the following activities:

– Subchassis discovery begins, which detects all objects and interfaces within the chassis and 
creates representative objects in CGM

– Chassis state changes to normal

– Objects within the chassis that are present change to the normal state

– Any interfaces that are pre-deployed but not active change to the errored state

– Heartbeat polling begins on the chassis, modules, and interfaces

Decommissioning a chassis starts the following activities:

– Chassis state changes to decommissioned

– Objects within the chassis change to the decommissioned state

– Heartbeat polling stops on the chassis, modules, and interfaces

– Performance polling stops on the chassis, modules, and interfaces (if enabled)

Starting or Stopping Global Performance Logging
• Choose the relevant chassis from the list displayed at left.

• Click the Start or Stop button in the Global Performance Logging area. 

Global performance logging collects performance information on GRPs and interfaces within a specified 
chassis. Performance data can then be viewed through performance menus or through the Performance 
Manager. 

If you start global performance logging on a chassis, all subchassis objects are placed into the 
performance logging on state. However, performance data is only collected for GRPs and interfaces, so 
any other modules will not collect performance data, despite having a state of performance logging on.

Note that Global Performance Logging can use a lot of bandwidth, so use discretion. 

Tips Performance logging can also be started or stopped on a per module (GRP) or physical 
interface basis. For details on how to start performance logging for a selected module 
(GRP), refer to “Module Performance.” For details on how to start performance logging for 
a selected physical interface (such as Ethernet, ATM, or DS-3), refer to “Stopping or 
Starting Performance Logging.”

Chassis Configuration Window—Detailed Description
The Chassis Configuration window (Figure 3-3) contains two tabs: Configuration and Additional 
Descriptions.

Configuration Tab

The Configuration tab displays five areas:

• Validation Parameters

• Action (not applicable to CGM)
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• Clock (not applicable to CGM)

• Power Supply (not applicable to CGM)

• Action

• Commission Status

Validation Parameters

The Validation Parameters area contains attributes that describe the population characteristics of a 
chassis and are used to validate module deployment.

Number of Slots—Displays the number of slots in the chassis for plug-in modules.

Unavailable Slots—Displays a comma separated list of slots that modules cannot be deployed into.

Max Number of Sub-Modules per Slot—Defines the maximum number of submodules that can be 
deployed into each slot for the selected chassis.

Action

This area is not applicable to CGM.

Clock

This area is not applicable to CGM.

Power Supply

This area is not applicable to CGM.

Action

Management

The Management area allows you to commission or decommission the selected chassis.

Commission—Click Commission to commission the selected chassis.

Decommission—Click Decommission to commission the selected chassis.

Global Performance Logging

The Global Performance Logging area allows you to start or stop global performance logging.

Start—Click Start to begin global performance logging.

Stop—Click Stop to stop global performance logging.

Commission Status

The Commission Status area displays the result of the last commission, either succeeded or failed.

Additional Descriptions Tab

The Additional Descriptions tab displays a single Additional Descriptions area.
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Figure 3-4 Chassis Configuration Window—Additional Descriptions Tab

Additional Descriptions

The Additional Descriptions tab optionally allows you to specify description information for a selected 
chassis. Any additional text descriptions can be entered in the description 1 and description 2 data entry 
fields. For example, you might want to record additional text descriptions for identification purposes, 
such as CLLI codes.

SNMP Management
The SNMP Management section covers the following areas:

• Viewing the SNMP Management Window

• Selecting or Modifying SNMP Community Names or Version

• Enabling or Disabling Trap Generation
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• SNMP Management Window—Detailed Description

Viewing the SNMP Management Window

Step 1 Right-click a chassis object, then choose CGM Management>Physical>Chassis>SNMP 
Management.

Figure 3-5 SNMP Management Window—SNMP Management Tab

Step 2 Make sure the chassis you selected is highlighted in the list box at left. 

Selecting or Modifying SNMP Community Names or Version
To choose or modify SNMP community names:

• Type in the version 1 or version 2 Read and Write names as desired. 

To choose or modify the SNMP Version:

• Click on the arrow in the list box. A drop-down list appears. Choose the desired version from the list. 

Not applicable for CGM
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Enabling or Disabling Trap Generation
Traps generate alarms and send them to the IP address of the chassis specified when trap generation is 
enabled (on a selected chassis). When trap generation is enabled, you can see alarms when they arise in 
the appropriate CGM view. Trap generation can also be disabled so that traps and alarms are not 
generated for the selected chassis.

To enable or disable trap generation on a selected chassis, follow these steps:

Step 1 Choose the relevant chassis from the IOS host list displayed at left.

Step 2 Choose the SNMP version to be used. When using version 1 of SNMP, complete the community names 
in the Community Names area for V1 read and V1 write (note that CGM release 2.0.1 does not support 
SNMPv1), and when using version 2 of SNMP, complete the community names for V2 read and V2 
write.

Step 3 Click Enable to allow trap generation, or click Disable to avoid trap generation.

Step 4 Save the changes by clicking the Save icon.

SNMP Management Window—Detailed Description
The SNMP Management window displays a single SNMP Management tab. The SNMP Management tab 
contains three areas: 

• Community Names

• Version

• Trap Generation

Community Names

Community names provide a security mechanism for SNMP communications. The device holds its own 
community names, so the correct community names must be used in order to get or set attributes from 
the device.

V1 Read—Community string used when retrieving attributes from a device using the SNMPv1 protocol. 
Note that CGM release 2.0.1 does not support SNMPv1.

V1 Write—Community string used when setting attributes on a device using the SNMPv1 protocol. Not 
applicable for CGM. Note that CGM release 2.0.1 does not support SNMPv1.

V2 Read—Community string used when retrieving attributes from a device using the SNMPv2c 
protocol.

V2 Write—Community string used when setting attributes on a device using the SNMPv2c protocol.

Version

Displays the SNMP version.

SNMP Version—Allows you to choose the SNMP version.
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Trap Generation

Enable—Click Enable to enable trap generation for the selected chassis. Traps generated by selected 
chassis are sent to the IP addresses listed in the Trap Destination and Community pane.

Disable—Click Disable to disable trap generation for the selected chassis. No traps generated by 
selected chassis are sent to the IP addresses listed in the Trap Destination and Community pane.

Chassis Inventory
The Chassis Inventory section covers the following areas:

• Viewing the Chassis Inventory Window

• Chassis Inventory Window—Detailed Description 

Viewing the Chassis Inventory Window

Step 1 Right-click on a chassis object, then choose CGM Management>Physical>Chassis>Inventory. The 
Chassis Inventory window appears.
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Figure 3-6 Chassis Inventory Window—General Tab

Step 2 Make sure the chassis you selected is highlighted in the list box at left. The chassis details appear in the 
General tab at right.

The PCMCIA Slot Details area and the Power Supply Details area are not applicable to CGM. The Asset 
Tracking tab also is not applicable to CGM.

Not applicable for CGM
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Figure 3-7 Chassis Inventory Window—Asset Tracking Tab

Chassis Inventory Window—Detailed Description
The Chassis Inventory window contains two tabs: General and Asset Tracking. Note that the Asset 
Tracking tab is not applicable for CGM. 

General Tab

The General tab (see Figure 3-6) displays five areas: 

• Chassis Details 

• System Details 

• Version Details 

• PCMCIA Slot Details 

• Power Supply Details

Not applicable for CGM
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Chassis Details

The Chassis Details area displays the following details:

Serial Number—Not applicable to CGM.

Number of Slots—Displays the number of slots in the chassis.

Backplane Type—Not applicable to CGM.

Type—Displays the chassis type.

Environmental Monitor Type—Displays the type of environmental monitor located in the chassis.

System Details

The System Details area displays the following details:

Host Name—Displays the host name for the selected chassis.

Boot Image Host—Displays the IP address of the host, which supplies the software currently running.

Description—Displays the system’s hardware type, software operating system, and networking software 
of the selected chassis.

ROM ID—Displays the system boot trap description and version identifier.

Domain Name—Displays the domain portion of the domain name of the host.

Services—Displays the set of services potentially offered by the selected chassis.

Version Details

The Version Details area of the General tab displays the versions of the different components in the 
chassis, as follows:

IOS—Displays the version of the IOS commands in the selected chassis.

Software—Not applicable to CGM.

Hardware—Displays the version of the selected chassis. 

Firmware—Not applicable to CGM.

PCMCIA Slot Details

The PCMCIA Slot Details area is not applicable to CGM.

Power Supply Details

The Power Supply Details area is not applicable to CGM.

Asset Tracking Tab

The Asset Tracking tab is not applicable to CGM.
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Chassis Fault Management
The Chassis Fault Management section covers the following areas:

• Viewing the Chassis Fault Management Window

• Chassis Fault Management Window—Detailed Description

Viewing the Chassis Fault Management Window
To view the Chassis Fault Management window, follow these steps:

Step 1 Right-click on a chassis object, then choose CGM Management>Physical>Chassis>Fault 
Management. The Chassis Fault Management window appears.

Figure 3-8 Chassis Fault Management Window—General Tab

Step 2 Make sure the chassis you selected is highlighted in the list box at left. General fault management details 
are displayed.

The LED Status area is not applicable to CGM.

Not applicable for CGM
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For further information on the fields displayed in this window, refer to “Chassis Fault Management 
Window—Detailed Description” section on page 3-18.

Figure 3-9 Chassis Fault Management Window—Power Supply Tab

Step 3 Click the Power Supply tab. The power supply details for the selected chassis appear. For further 
information on the fields displayed in this window, refer to “Chassis Fault Management 
Window—Detailed Description” section on page 3-18.
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Figure 3-10 Chassis Fault Management Window—Temperature Tab

Step 4 Click the Temperature tab. The temperature details for the selected chassis appear in the tab. For further 
information on the fields displayed in this window, refer to “Chassis Fault Management 
Window—Detailed Description.”
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Figure 3-11 Chassis Fault Management Window—Fan Tab

Step 5 Click the Fan tab. The fan details for the selected chassis appear in the tab. For further information on 
the fields displayed in this window, refer to “Chassis Fault Management Window—Detailed 
Description” section on page 3-18.

Chassis Fault Management Window—Detailed Description
The Chassis Fault Management window displays four tabs:

• General 

• Power Supply 

• Temperature

• Fan

General Tab

The General tab (see Figure 3-8) displays three areas: Chassis Availability, LED Status, and 
Cisco Contact Details.
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Chassis Availability

The Chassis Availability area contains attributes that reflect the availability of the chassis, as follows:

Up Time—Displays the up time after the last reset.

Last Changed Time—Displays the time the chassis was last modified. 

Last Restart Reason—Displays the reason for the last restart.

Last Authentication Failure Address—Displays the last authorization failure IP address for the selected 
chassis.

Clock Source Status—Not applicable to CGM.

LED Status

The LED Status area is not applicable to CGM.

Cisco Contact Details

The Cisco Contact Details area displays any provided Cisco contact details. 

Power Supply Tab

The Power Supply tab (see Figure 3-9) displays two areas: Power Supply and Voltage.

Power Supply

The Power Supply area displays the following information for each power supply (in tabular format):

Description—Textual information for the power supply.

State—Current status of the power supply.

Source—Power supply source.

Voltage

The Voltage area displays the following details for the 12 volt power supply:

Description—Textual information on voltage.

Status Value—Current status of the voltage for the selected chassis.

Minimum Threshold—Lowest status value assigned before a shutdown was initiated.

Maximum Threshold—Highest status value assigned before a shutdown was initiated.

Last Shutdown—Last shutdown initiated.

State—Current status value of the voltage.

Note The min and max threshold values specify the range that can be associated with the object 
before an emergency shutdown is initiated.

Temperature Tab

The Temperature tab (see Figure 3-11) displays a single Temperature area.
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Temperature

The Temperature area displays the following details for the core temperature status and the inlet 
temperature status:

Description—Textual information on temperature for the selected chassis.

Status Value—Current status value of the temperature of the selected chassis.

Threshold—Highest value associated with the object before a shutdown was initiated.

Last Shutdown—Status value of the object when shutdown was last initiated.

State—Current status of the temperature for the selected chassis.

Fan Tab

The Fan tab (see Figure 3-11) displays a single Fan area.

Fan

The Fan area displays a description and the current state of the fan status in a tabular format.

Description—Textual information for the fan.

State—Current status of the fan in the selected chassis.

Command Log
The Command Log section covers the following areas:

• Viewing the Command Log Window

• Command Log Window—Detailed Description

Viewing the Command Log Window
To view the Command Log window, follow these steps:

Step 1 Right-click on a chassis object, then choose CGM Management>Physical>Chassis>View>Command 
Log. The Command Log window appears.
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Figure 3-12 Command Log Window

Step 2 Make sure the desired chassis is highlighted in the list box at left.

The Command Log Details pane for the selected chassis is displayed. For further information, refer to 
“Command Log Window—Detailed Description” section on page 3-22.

Step 3 Scroll through the list of event commands, using the arrow bars, until the relevant event command 
appears. Use the horizontal scroll bar to view all the entries. Drag the scroll bar until the relevant 
information appears. You can change the width of each column if necessary to view fault strings clearly 
(refer to “Changing Column Width.”)

Changing Column Width

To change the width of a column:

Step 1 Open the relevant window displaying a pane.

Step 2 Place the cursor to the left of a column heading and move the cursor until it changes to a double arrow.

Step 3 Click and hold the left mouse button when the cursor changes.

Step 4 Drag the cursor until the column is at the required width.

Step 5 Release the mouse button.
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Any text wider than the column is truncated. The column widths return to the default widths when you 
close this window.

Command Log Window—Detailed Description
The Command Log window displays a single Command Log Details tab.

Command Log Details Tab

The Command Log Details tab displays an Command Log pane and Event History area.

Command Log Details Pane

The Command Log Details pane displays the following information:

Index—Arbitrary integer value to uniquely identify the listed events. When it reaches the maximum 
value, the agent wraps the value back to 1 and can flush existing entries

Event Time—Value of system up time when the event occurred.

Command Source—Source of the command that instigated the event. You will see either command Line 
or SNMP.

Config Source—Configuration data source for the event.

Config Destination—Configuration data destination for the event.

Terminal Type—When the command source field is set to command line, the terminal type appears 
(unknown, console, terminal, virtual or auxiliary). Otherwise, not applicable appears.

Terminal Number—When the command source field is set to command line, the terminal number 
appears. When the terminal is not available or not applicable, -1 appears.

Terminal User—When the command source is set to command line, the name of the logged in user 
appears. When the terminal type is not available or not applicable, the field appears empty.

Terminal Location—When the command source is set to command line, the hard-wired location of the 
terminal or the remote host for an incoming connection appears. When the terminal type is not available 
or not applicable, the field appears empty.

Command Source Address—When the terminal type field is set to virtual, the internet address of the 
connected system appears. When the command source is set to SNMP, the internet address of the 
requester appears.

Virtual Host Name—When the terminal type field is set to virtual, the host name of the connected system 
appears. When the terminal type is not available or not applicable, the field appears empty.

Config Filename—When the config source field or the config destination field is set to network tftp or 
network rcp, the configuration filename at the storage file server appears.

RCP User—When the config source field or the config destination field is set to network rcp, the remote 
user name appears.

Event History Details

The Event History Details area (see Figure 3-12) displays the following information:
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Uptime at Last Save—Displays the amount of time the system had been up for, when the running 
configuration was last saved (written).

Uptime at Last Change—Displays the amount of time the system had been up from when the running 
configuration was last changed.

Note When the value of the uptime at last change field is greater than the uptime at last save field, 
the configuration has been changed, but not saved.

Uptime at Last Startup Change—Displays the amount of time the system had been up for, when the 
startup configuration was last written to. In general the uptime at last startup change field is the default 
configuration used when cold starting the system. It might have been changed by a save of the running 
configuration or by a copy from elsewhere.

Maximum Table Entries—Maximum number of entries that can be held in the pane.

Entries Deleted from Table—Number of times the oldest entry was deleted to make room for a new entry.

System Log
The System Log Messages window provides a table of all activity carried out by users logged into CLI 
or SNMP on a device. You can opt to be notified of all user activities through alarm notification, if 
desired. 

The System Log section covers the following areas:

• Viewing the System Log Window

• System Log Window—Detailed Description

Viewing the System Log Window

Step 1 Right-click on a selected chassis and choose CGM Management>Physical>Chassis>View>Sys Log 
Messages. The Sys Log Messages window appears. 
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Figure 3-13 Sys Log Messages Window

Step 2 Choose a relevant chassis from the list box at left. The Sys Log Message pane appears for the selected 
chassis. For further information, refer to “System Log Window—Detailed Description.”

Step 3 Scroll through the list of system messages, using the arrow keys, until you find the information you want. 
You can view all the entries by using the horizontal scroll bar. Click and drag the scroll bar until you see 
the information you want. You can change the width of each column if necessary (refer to “Changing 
Column Width” section on page 3-21).

System Log Window—Detailed Description
The Sys Log Messages window (see Figure 3-13) displays a single Sys Log Messages tab.

SysLog Message Tab

The Sys Log Message tab displays a SysLog Messages pane, and Sys Log Message Details area.

SysLog Messages Pane

The Sys Log Messages pane displays the following information:

Index—Arbitrary integer value to uniquely identify the listed messages. When it reaches the maximum 
value the agent flushes the pane and wraps the value back to 1.

Facility—Name of the facility that generated the facility message.
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Severity—Displays the severity of the message.

Message Name—Textual identification for the message type. A facility name in conjunction with a 
message name uniquely identifies a message type.

Message Text—Displays the text of the message. When the text of the message exceeds 255 bytes, the 
message is truncated to 254 bytes and a '*' character is appended, indicating that the message has been 
truncated.

Time Stamp—Displays the time the system has been running (when the message was generated).

Sys Log Message Details

The Sys Log Message Details area displays the following information:

Messages Not Recorded—Displays the number of syslog messages that were ignored.

Messages Not Processed—Displays the number of messages which could not be processed due to lack 
of system resources.

Messages Deleted From Table—Number of entries that have been removed to make room for new 
entries.

Notifications Sent—Displays the number of notifications sent.

Maximum Table Entries—Displays the upper limit on the number of entries that the pane can contain.

Maximum SysLog Severity—Any message with a severity less than this one will be ignored by the agent. 
This field can be set to emergency, alert, critical, error, warning, notice, info, or debug.

Notifications Enabled—Displays whether notifications are enabled or not enabled.

Configuration Editor 
The Configuration Editor allows you to perform the following:

• Upload the running configuration from a selected chassis and edit using a text editor

• Download the edited configuration file to a selected chassis

The Configuration Editor section covers the following areas:

• Viewing the Configuration Editor Window

• Configuration Editor Window—Detailed Description

Caution If you wish to delete a line, you must type “no” at the beginning of the line. If order is a 
concern, deleting a line might cause problems, so use extreme discretion when deleting a 
line.

Note You should be a superuser to access this feature.

Viewing the Configuration Editor Window
Right-click on a selected chassis, then choose Technology Specific Tools>Open Configuration Editor. 
The Configuration Editor window appears.
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Figure 3-14 Configuration Editor Window 

For further information on the fields displayed in this window, refer to “Configuration Editor 
Window—Detailed Description” section on page 3-27.

Uploading, Opening, or Editing the Running Configuration from a Selected Chassis

Step 1 Make sure the chassis which contains the configuration you want to upload is selected in the list box at 
left. 

Step 2 Click Upload. A text editor window appears, with the running configuration for the selected chassis 
displayed.

Step 3 Edit the running configuration as desired. To search for specific text within the running configuration 
file, refer to the section below. 

Caution If you wish to delete a line, you must type “no” at the beginning of the line. If order is a 
concern, deleting a line might cause problems, so use extreme discretion when deleting a 
line.

Note If you receive an error message after clicking Upload, you might need to make sure 
the tftpboot server is running. The tftpboot server must be running before you can 
upload the running configuration. 
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Searching in the Configuration Editor

Step 1 In the search criteria field, type in the text you wish to search for. 

Step 2 Now, click Add. The text you specified appears in the criteria name box under the Selection area.

Step 3 Click Upload. A text editor window appears, with the running configuration displayed. The first instance 
of the specified search criteria is displayed.

Step 4 If you want to delete your text from the criteria name box, simply click on the text you want to delete in 
the box, then click Delete.

Downloading the Edited Configuration File to a Selected Chassis

After you have edited the running configuration, click Download to download the modified running 
configuration to the selected chassis. This new configuration is reflected onto the startup configuration, 
the running configuration, and the NVRAM memory.

Configuration Editor Window—Detailed Description
The Configuration Editor window (see Figure 3-14) displays a single Configuration Editor tab.

Configuration Editor Tab

The Configuration Editor tab displays two areas: Selection and Operations on Device.

Selection

Criteria Name—Any text strings you have searched for appear in this list.

Search Criteria—Enter search text into the search criteria data entry box. Click Add to move the text 
string into the configuration criteria list.

Operations Done Locally

Add—Click Add to move the text string (displayed in the criteria data entry box) into the configuration 
criteria list. Then click Upload to commence your search.

Delete—Click Delete to remove any selected text string from the configuration criteria list.

Operations on Device

Upload—Click Upload to upload the running configuration files from the selected chassis and 
automatically open the running configuration file in a text editor (allowing you to edit the configuration 
file).

Download—Click Download to save the configuration file and download the edited running 
configuration file to the selected chassis.
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Configuration Backup/Restore

Caution Configuration Backup/Restore fails if the user name and passwords are not identical (refer 
to “Entering or Changing Username and Passwords” section on page 3-3).

The Configuration Backup/Restore window allows you to upload the current running configuration from 
a specified Cisco 12000 GSR and save it as a file to any Trivial File Transfer Program (TFTP) server. 
This file can later be downloaded from the specified TFTP server to a user specified Cisco 12000 GSR.

Regular configuration backups allow recovery in the unlikely event of a hardware failure. For example, 
if a module were to fail, a replacement module could be inserted into the chassis and the configuration 
data would be restored. Changes in configuration data between the last backup and the time of the failure 
would be lost.

Note The backup/restore mechanism is not intended as a “configuration upload and 
manipulation” facility permitting configuration of the Cisco hardware (for example, 
through Cisco IOS, followed by subsequent management by CGM).

The Configuration Backup/Restore section covers the following areas:

• Viewing the Configuration Backup/Restore Window

• Initiating a Backup

• Initiating a Restore

• Scheduling a Backup

• Configuration Backup/Restore Window—Detailed Description

Viewing the Configuration Backup/Restore Window
Right-click on a chassis object, then choose CGM Management>Physical>Chassis>Configuration 
Backup/Restore. The Configuration Backup/Restore window appears.
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Figure 3-15 Configuration Backup/Restore Window — Backup/Restore Tab

For further information on the fields displayed in this window, refer to “Configuration Backup/Restore 
Window—Detailed Description” section on page 3-31.

Note The Backup After Every Action field is not available for CGM.

Initiating a Backup
To initiate a backup, follow these steps:

Step 1 Open the Configuration Backup/Restore window. For further details, refer to “Viewing the Configuration 
Backup/Restore Window.” 

Step 2 Make sure the chassis you wish to backup or restore is highlighted in the IOS Host list at left.

Step 3 Click Backup to begin the backup. An Action Report window appears. The Action Report window 
details the Cisco IOS commands executed when the service is commissioned. Invalid Cisco IOS 
commands result in a failure to commission the service.

Step 4 Check the details in the Action Report window to ensure that the backup was successfully.

Step 5 Click Save to save the action report, if required.

Step 6 Click Close to close the Action Report window and return to the Configuration Backup/Restore window.

Step 7 Choose Close from the File menu to close the Configuration Backup/Restore window.
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Initiating a Restore
To initiate a restore, follow these steps:

Step 1 Open the Configuration Backup/Restore window. For further details, refer to “Viewing the Configuration 
Backup/Restore Window.” 

Step 2 Make sure the chassis you wish to backup or restore is highlighted in the IOS Host list at left.

Step 3 Click Restore to begin the restoration. An Action Report window appears. The Action Report window 
details the Cisco IOS commands executed when the service is commissioned. Invalid Cisco IOS 
commands result in a failure to commission the service.

Step 4 Check the details in the Action Report window to ensure that the restore was successful.

Step 5 Click Save to save the action report, if required.

Step 6 Click Close to close the Action Report window and return to the Configuration Backup/Restore window.

Step 7 Choose Close from the File menu to close the Configuration Backup/Restore window.

Scheduling a Backup
To schedule a backup, follow these steps:

Step 1 Open the Configuration Backup/Restore window. For further details, refer to “Viewing the Configuration 
Backup/Restore Window.” 

Step 2 Make sure the chassis you wish to backup or restore is highlighted in the IOS Host list at left.

Step 3 Click Schedule Backup to schedule a date and time for the backup to take place. The Schedule dialog 
box appears:

Figure 3-16 Schedule Dialog Box

Step 4 Enter a date (mm/dd/yyyy) and time (hh:mm) for the scheduled backup to take place automatically. Click 
Ok to save the new date and time. An Action Report window appears. The Action Report window details 
the Cisco IOS commands executed when the service is commissioned. Invalid Cisco IOS commands 
result in a failure to commission the service.

Step 5 Check the details in the Action Report window to ensure that the scheduled backup was setup 
successfully.

Step 6 Click Save to save the action report, if required.
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Step 7 Click Close to close the Action Report window and return to the Configuration Backup/Restore window.

Step 8 Choose Close from the File menu to close the Configuration Backup/Restore window.

Configuration Backup/Restore Window—Detailed Description
The Configuration Backup/Restore window displays a single Backup/Restore tab.

Backup/Restore Tab

The Backup/Restore tab (see Figure 3-15) displays three areas: Configuration, Status and Actions.

Configuration

The Configuration area allows you to view and configure the following fields:

Backup Server—Allows you to set the TFTP IP address.

Backup after every Action—Field not available for CGM.

Status

The Status area displays the following fields:

Time Stamp of Last Backup—Time of the last backup.

Backup File Name—Name of the backup file.

Actions

The Actions area allows you to:

Backup—Click Backup to initiate the action of backing up the running configuration of the selected 
Cisco 12000 GSR.

Restore—Click Restore to initiate the action of restoring the running configuration to the selected Cisco 
12000 GSR.

Schedule Backup—Click Schedule Backup to schedule a date and time for the backup to take place.

IOS Image Download
The IOS Image Download window allows you to:

• Download a current version of the IOS image software onto your device manually by pressing the 
Download button

• Download a current version of the IOS image software onto your device automatically at a scheduled 
time by pressing the Schedule Download button.

Caution Ensure that you download the correct IOS version or image. 

The IOS Image Download section covers the following areas:
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• Viewing the IOS Image Download Window

• Initiating a Download

• Scheduling a Download

• IOS Image Download Window—Detailed Description

Viewing the IOS Image Download Window

Step 1 Right-click on a selected chassis, then choose CGM Management>Physical>Chassis>IOS Image 
Download. The IOS Image Download window appears.

Figure 3-17 IOS Image Download Window

Step 2 Make sure that the desired chassis is highlighted in the list box at left.

For further information on the fields displayed in this window, refer to “IOS Image Download 
Window—Detailed Description” section on page 3-33.

Initiating a Download

Caution IOS image download fails if the user name and passwords are not identical (refer to 
“Entering or Changing Username and Passwords” section on page 3-3).
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To initiate a download, follow these steps:

Step 1 Choose an IOS host. The download information appears. 

Step 2 Configure the fields displayed in the configuration area.

Step 3 Click Download to download the Cisco IOS image (specified by the source filename in the configuration 
area) from the specified TFTP server to the file system of the Cisco 12000 GSR (specified in the 
destination filename in the configuration area).

Scheduling a Download
To schedule a Cisco IOS image download, follow these steps:

Step 1 Choose an IOS host. The download information appears. 

Step 2 Configure the fields displayed in the configuration area.

Step 3 Click Schedule Download. The Schedule dialog box appears (see Figure 3-18). The Schedule dialog 
box allows you to enter a date (in <mm><dd><yyyy> format) and time (hour and minute format) for 
the download to be performed.

Figure 3-18 Schedule Dialog Box

Step 4 Enter a date (mm/dd/yyyy) and time (hh:mm) for the download to take place automatically. Click Ok to 
save the new date and time. An Action Report window appears. The Action Report window details the 
Cisco IOS commands executed. Invalid Cisco IOS commands result in a failure to download.

Step 5 Check the details in the Action Report window to ensure that the scheduled download was setup 
successfully.

Step 6 Click Save to save the action report, when required.

Step 7 Click Close to close the Action Report window and return to the Cisco IOS Image Download window.

Step 8 Choose Close from the File menu to close the Cisco IOS Image Download window.

IOS Image Download Window—Detailed Description
The IOS Image Download window (see Figure 3-17) displays a single Download tab.
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Download Tab

The Download tab (see Figure 3-17) displays three areas: Configuration, Status, and Actions.

Configuration

The Configuration area allows you to view and configure the following fields:

TFTP Server IP Address—Allows you to set the TFTP IP address.

Destination File System—Allows you to specify any file system name supported by the module. File 
system names supported are, boot flash, flash, disk 0, and disk 1.

Source File Name—Allows you to specify the source filename (Cisco IOS image name).

Destination File Name—Allows you to specify the name for the file as it is stored in the file system of 
CGM.

Format the destination device before copying?—Allows you to format the destination device before 
copying. You can set the Format the destination device before copying? option to:

Yes—Enables formatting of the destination device.

No—Disables formatting of the destination device.

Reboot device using new image?—Allows you to reboot the device after a successful download. You can 
set the Reboot device using new image? option to:

Yes—Enables rebooting of the device.

No—Disables rebooting of the device.

Status

The Status area (see Figure 3-17) displays the last download operation (this displays the date and time 
of the last download).

Actions

The Actions area (see Figure 3-17) allows you to initiate the following actions:

Download—Click Download to download the Cisco IOS image (specified by the source filename in the 
configuration area) from the specified TFTP server to the file system of the Cisco 12000 GSR (specified 
in the destination filename in the configuration area).

Scheduled Download—Click Schedule Download to open the Schedule Dialog window. The Schedule 
Dialog window allows you to enter a date (in <mm><dd><yyyy> format) and time (hour and minute 
format) for the download to be performed automatically.

Initiating a Telnet Service
The Initiate Telnet Service application allows you to log onto the device, in order to perform some 
configuration or to retrieve information from the device. To launch a telnet window, follow these steps:

Step 1 Right-click on a chassis object in the chassis map, then choose Technology Specific Tools>Initiate 
Telnet Service. A telnet window appears.
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Step 2 Enter the required password.

Launching the Web Console
Another way to retrieve information from a device is through a web browser. To launch the Web Console 
application, follow these steps:

Step 1 Right-click on a chassis object in the chassis map, then choose Technology Specific Tools>Launch 
Web Console.

Step 2 A security window appears. Enter the required user ID and password. Access to the Cisco web console 
is now provided.

APS Status
The APS status window provides a single read only view which displays all APS circuits configured on 
a selected GSR.

Note You can also view APS circuits that are configured on another router.

The APS Status window displays the APS redundancy configuration for a selected chassis.

The APS Status section contains the following areas:

• Viewing the APS Status Window

• APS Status Window—Detailed Description

Viewing the APS Status Window

Step 1 Right-click on a selected chassis, then choose CGM Management>Physical>Chassis>POS>
APS Status. The APS Status window appears.
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Figure 3-19 APS Status Window

Step 2 Make sure that the desired chassis is highlighted in the list box at left. 

A list of all APS circuits set up on the selected chassis appear in the APS Circuits area.

When the GSR being managed is configured with an APS circuit that connects to another GSR, then either 
the Working or Protect field (whichever is appropriate) in the Table will indicate "Remote" .

APS Status Window—Detailed Description
The APS Status window has one area, APS Circuits.

APS Circuits

The APS Circuits area contains one table with the following headings:

Group—Group number of the APS circuit or interface.

Working Slot/Port—Slot/port number of the working interface. For a circuit, if the working interface is 
part of another chassis, “remote” is displayed instead of the slot/port number.

Protect Slot/Port—Slot/port number of the protected interface. For a circuit, if the protected interface is 
part of another chassis, “remote” is displayed instead of the slot/port number.
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