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Access the Software Upgrade Workflow
Table 1: Feature History

DescriptionRelease InformationFeature Name

You can now upgrade software
images on edge devices using the
Workflows menu in Cisco
SD-WAN Manager.

Cisco IOS XE Catalyst SD-WAN
Release 17.8.1a

Cisco vManage Release 20.8.1

Cisco SD-WAN Release 20.8.1

Software Upgrade Workflow

Upgrade the software of Cisco edge
devices using a scheduler which
helps in scheduling the upgrade
process at your convenience.

Cisco IOS XE Catalyst SD-WAN
Release 17.9.1a

Cisco vManage Release 20.9.1

Cisco SD-WAN Release 20.9.1

Schedule the Software Upgrade
Workflow

Added support for Cisco Enterprise
NFV Infrastructure Software
(NFVIS) and Cisco Catalyst
Cellular Gateways.

Cisco vManage Release 20.9.1Software Upgrade Workflow
Support for Additional Platforms

Added support for software upgrade
scheduling for Cisco Catalyst
Cellular Gateways.

Cisco vManage Release 20.10.1Software Upgrade Scheduling
Support for Additional Platforms

Before You Begin

To check if there is an in-progress software upgrade workflow:
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From the Cisco SD-WAN Manager toolbar, click the Task-list icon. Cisco SD-WAN Manager displays a list
of all running tasks along with the total number of successes and failures.

Access the Software Upgrade Workflow

1. In the Cisco SD-WAN Manager menu, click Workflows > Workflow Library.

In the Cisco vManage Release 20.8.1, the Workflow Library is titled Launch Workflows.Note

2. Start a new software upgrade workflow: Library > Software Upgrade.

OR

Alternatively, resume an in-progress software upgrade workflow: In-progress > Software Upgrade.

3. Follow the on-screen instructions to start a new software upgrade workflow.

Click Exit to exit from an in-progress software upgrade workflow. You can resume the in-progress workflow
at your convenience.

Note

In a multi-node cluster setup, if the control connection switches to a different node during a device upgrade
from Cisco SD-WAN Manager, the upgrade may be impacted due to NetConf session timeout. The device
then establishes control connection to a different node. You need to re-trigger the upgrade activity.

Note

Verify the Status of the Software Upgrade Workflow

To check the software upgrade workflow status:

1. From the Cisco SD-WAN Manager toolbar, click the Task-list icon.

Cisco SD-WANManager displays a list of all running tasks along with the total number of successes and
failures.

2. Click the + icon to view the details of a task.

Cisco SD-WANManager opens a pane displaying the status of the task and details of the device on which
the task was performed.

ACL Log
Use the ACL Log screen to view logs for access lists (ACLs) configured on a router. Routers collect ACL
logs every 10 minutes.

Set ACL Log Filters

1. From the Cisco SD-WAN Manager menu, choose Monitor > Logs > ACL Log.
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Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
ACL Log.

2. Click the Filter.

3. In the VPN field, choose the entity, for which you are collecting ACL logs, from the drop-down list. You
can choose only one VPN.

4. Click Search to search for logs that match the filter criteria.

Cisco SD-WAN Manager displays a log of activities in table format.

Application Performance and Site Monitoring

To achieve simplification and consistency, the Cisco SD-WAN solution has been rebranded as Cisco Catalyst
SD-WAN. In addition, from Cisco IOS XE SD-WAN Release 17.12.1a and Cisco Catalyst SD-WAN Release
20.12.1, the following component changes are applicable: Cisco vManage to Cisco Catalyst SD-WAN
Manager,Cisco vAnalytics toCisco Catalyst SD-WAN Analytics,Cisco vBond toCisco Catalyst SD-WAN
Validator, and Cisco vSmart to Cisco Catalyst SD-WAN Controller. See the latest Release Notes for a
comprehensive list of all the component brand name changes. While we transition to the new names, some
inconsistencies might be present in the documentation set because of a phased approach to the user interface
updates of the software product.

Note

Table 2: Feature History

DescriptionRelease InformationFeature Name

You can monitor and optimize the
application health and performance
on all sites or a single site using
Cisco SD-WAN Manager.

Cisco IOS XE Catalyst SD-WAN
Release 17.10.1a

Cisco vManage Release 20.10.1

Application Performance and Site
Monitoring

Overview of Application Performance and Site Monitoring
The Application Health window displays the following:

• All applications running in all sites: table view and heat map view.

• All applications running at a specific site: table view and heat map view.

• Single application running in all sites: table view and heat map view.

• Single application running at a specific site: aggregated line chart and per path table view.

Applications Health Metrics

The applications health is calculated as follows:
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Table 3:

QoEHealth

QoE >= 8Good

QoE 5~8Fair

QoE < 5Poor

View Application Health in Table View
The Application Health window displays the following in table view:

• All applications for all sites: A selected list of applications that are enabled using the performance
monitoring feature or the CLI add-on template from all the sites.

• All applications for a single site: A selected list of applications that are enabled using the performance
monitoring feature or the CLI add-on template from a single site.

• All the sites of a single application: All the sites of a selected application that is enabled using the
performance monitoring feature or the CLI add-on template, sorted by the status in the health column.

In the table, the Health column shows the application health. Place the cursor over the icon in the column to
display Good, Fair, or Poor health status. The health of the application is measured by QoE.

Click the application name to view further application specific details. For a single application on all sites,
click a specific Site ID to navigate to single site monitoring.

Click the toggle button to switch to application heatmap view.

View Application Health in Heatmap View
The Application Health window displays the following in heatmap view:

• All applications for all sites: A list of all applications health for different time selections.

• All applications for a single site: A selected list of applications that are enabled using the performance
monitoring feature or the CLI add-on template from a single site.

• All the sites of a single application: A list of sites and health of each site at different time intervals for a
single application.

In the heatmap view, the grid of colored squares displays the application health as Good, Fair, or Poor. You
can hover over a square or click it to display the additional details of an application at a specific time and
click View details to view specific application details. Click the time interval drop-down list to change the
time interval.

Click the Toggle button to switch to the application table view.

Configure Application Performance and Site Monitoring Using Cisco Catalyst SD-WAN Manager
You can enable application performance and site monitoring using Cisco SD-WAN Manager by configuring
Performance Monitoring under System Profile in a configuration group. Configure the parameters in
Application Performance Monitoring tab to enable monitoring. For more information see, Performance
Monitoring Feature Configuration.
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The application performance and site monitoring feature needs NBAR to be enabled on all LAN interfaces
for application recognition.

If Application-Aware Routing (AAR) policy is configured then NBAR is automatically enabled. If AAR
policy is not configured, then NBAR must be enabled on all LAN interfaces using a CLI add-on template.
Use the ip nbar protocol-discovery configuration to enable NBAR on all LAN interfaces.

All Sites and Single Site View

All Applications All Sites View

The default setting for the applications window is the all sites view. You can view information for all sites
by clicking the All Sites button on the top of the page, and clicking the radio button next to All Sites.

The all sites view displays information for all applications of all sites for the last one hour.

In the table, the Health column shows the application health. Place the cursor over the icon in the column to
displayGood, Fair, or Poor health status. The health of the application is measured by Quality of Experience
(QoE).

Click the toggle button to switch to the application heatmap view.

In the heatmap view, the grid of colored squares displays the application health as Good, Fair, or Poor. You
can hover over a square or click it to display additional details of an application at a specific time and click
View details to view specific application details. Click the time interval drop-down list to change the time
interval.

All Applications Single Site View

You can also view the health of all the applications on a single site. To enter single site view, click the All
Sites button on the top of the page, and click the radio button next to Single Site to select the site of interest.

Single Application All Site View

For a single application on all sites, click a specific Site ID to navigate to single site monitoring. Click the
application name to view further application specific details.

Single Application Single Site View

For a single application on a single site, a line graph shows the application health over a period of time. Select
the time from the drop-down list to select 1, 3, 6, 12, or 24 hours. The table displays a list of paths that has
processed application traffic over a time period. Select individual paths and view the individual QoE lines on
the line graph. At a time five paths can be selected, and five line charts are displayed. You can also drag the
top handles to focus on a particular point in time. When you change the time, the table automatically refreshes
to show the health information for that time interval.

Change the Device Rollback Timer
By default, when you attach a Cisco IOS XE Catalyst SD-WAN device to a configuration template, if the
router is unable to successfully start after 5 minutes, it returns to, or rolls back to, the previous configuration.
For a configuration that you have created from the CLI, you can change the device's rollback timer:

1. From the Cisco SD-WAN Manager menu, choose Configuration > Templates.

2. Click Device Templates, and choose a device template.
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In Cisco vManage Release 20.7.x and earlier releases, Device Templates is titled Device.Note

3. Click …, and click Change Device Values.

The right pane displays the device's configuration, and the Config Preview tab is selected.

4. In the left pane, click the name of a device.

5. Click Configure Device Rollback Timer. The Configure Device Rollback Time pop up page is
displayed.

6. From the Devices drop-down list, select a device.

7. To enable the rollback timer, in the Set Rollback slider drag the slider to the left to enable the rollback
timer. When you do this, the slider changes in color from gray to green.

8. To disable the rollback timer, click Enable Rollback slider. When you disable the timer, the Password
field dialog box appears. Enter the password that you used to log in to Cisco SD-WAN Manager.

9. In the Device Rollback Time slider, drag the slider to the desired value. The default time is 5 minutes.
You can configure a time from 6 to 15 minutes.

10. To exclude a device from the rollback timer setting, click Add Exception and select the devices to
exclude.

11. The table of the Configure Device Rollback Time dialog box lists all the devices to which you are
attaching the template and their rollback time. To delete a configured rollback time, click the Trash
icon of the device name.

12. Click Save.

13. ClickConfigure Devices to push the configuration to the devices. The Status column displays whether
the configuration was successfully pushed. Click (+) to display details of the push operation.

Run Site-to-Site Speed Test

Before You Begin

Ensure that Data Stream is enabled under Administration > Settings in Cisco SD-WAN Manager.

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.1 and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. To choose a device, click the device name in the Hostname column.

3. Click Troubleshooting in the left pane.

4. In the Connectivity area, click Speed Test.

5. Specify the following:

• Source Circuit: From the drop-down list, choose the color of the tunnel interface on the local device.
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• Destination Device: From the drop-down list, choose the remote device by its device name and
system IP address.

• Destination Circuit: From the drop-down list, choose the color of the tunnel interface on the remote
device.

6. Click Start Test.

The speed test sends a single packet from the source to the destination and receives the acknowledgment
from the destination.

The right pane shows the results of the speed test—circuit speed, download speed, and upload speed between
the source and destination. The download speed shows the speed from the destination to the source, and the
upload speed shows the speed from the source to the destination in Mbps. The configured downstream and
upstream bandwidths for the circuit are also displayed.

When a speed test completes, the test results are added to the table in the lower part of the right pane.

From Cisco vManage Release 20.10.1, the Speed Test option is also accessible as follows:

• On the Monitor > Devices page, click … adjacent to the device name and choose Speed Test.

• On the Monitor > Applications page, click … adjacent to the application name and choose Speed Test.

• On the Site Topology page, click a device name, and then click Speed Test in the right navigation pane.

Cluster Management

To achieve simplification and consistency, the Cisco SD-WAN solution has been rebranded as Cisco Catalyst
SD-WAN. In addition, from Cisco IOS XE SD-WAN Release 17.12.1a and Cisco Catalyst SD-WAN Release
20.12.1, the following component changes are applicable: Cisco vManage to Cisco Catalyst SD-WAN
Manager,Cisco vAnalytics toCisco Catalyst SD-WAN Analytics,Cisco vBond toCisco Catalyst SD-WAN
Validator, and Cisco vSmart to Cisco Catalyst SD-WAN Controller. See the latest Release Notes for a
comprehensive list of all the component brand name changes. While we transition to the new names, some
inconsistencies might be present in the documentation set because of a phased approach to the user interface
updates of the software product.

Note

Table 4: Feature History

DescriptionRelease InformationFeature Name

You can add Cisco SD-WAN Manager
servers to a cluster by identifying servers
based on personas. A persona defines what
services run on a server.

Cisco IOS XE Catalyst
SD-WAN Release 17.6.1a

Cisco SD-WANRelease 20.6.1

Cisco vManage Release 20.6.1

Cisco SD-WAN Manager
Persona-based Cluster
Configuration

A Cisco SD-WANManager cluster consists of at least three Cisco SD-WANManager servers. These servers
manage the Cisco Catalyst SD-WAN edge devices in a network. Cisco SD-WANManager servers in a cluster
perform specific functions based on the services that are running on them. In this way, a cluster distributes
the workload among Cisco SD-WAN Manager servers while sharing information between these servers. For
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scaling recommendations, see Server Recommendations for your release in Cisco Catalyst SD-WANController
Compatibility Matrix and Server Recommendations.

Use the Administration > Cluster Management window to create a Cisco SD-WAN Manager cluster and
perform related tasks.

From Cisco vManage Release 20.6.1, each Cisco SD-WAN Manager server has a persona. The persona is
determined when the Cisco SD-WANManager server first boots up after Cisco SD-WANManager is installed
and defines which services run on the server. The persona of a server lasts for the lifetime of the server and
cannot be changed. A server must have a persona before it can be added to a cluster. For more information
on personas, see Cisco Catalyst SD-WAN Manager Persona and Storage Device.

The role that a server has in a cluster depends on its persona. A Cisco SD-WAN Manager server can have
any of the following personas:

• Compute+Data: Includes all services that are required for Cisco SD-WAN Manager, including services
that are used for the application, statistics, configuration, messaging, and coordination

• Compute: Includes services that are used for the application, configuration, messaging, and coordination

• Data: Includes services that are used for the application and statistics

Collect Device Statistics
Enable or disable the collection of statistics for devices in the overlay network. By default, the collection of
statistics is enabled for all the devices in the overlay network.

1. From the Cisco SD-WAN Manager menu, choose Administration > Settings.

2. To modify the settings for collecting device statistics, click Statistics Setting, and click Edit.

To view the configured settings, click View.Tip

By default, for every group of statistics (such asAggregated DPI andAppHosting), collection of statistics
is enabled for all devices.

3. To enable the collection of a group of statistics for all devices, click Enable All for the particular group.

4. To disable the collection of a group of statistics for all devices, click Disable All for the particular group.

5. To enable the collection of a group of statistics for all devices only for consumption by Cisco SD-WAN
Analytics, click vAnalytics only for the particular group.

6. To enable or disable the collection of a group of statistics for specific devices in the overlay network,
click Custom for the particular group.

In the Select Devices dialog box, depending on whether statistics collection is enabled or disabled for a
device, the device is listed among Enabled Devices or Disabled Devices respectively.

a. To enable statistics collection for one or more devices, choose the devices from Disabled Devices
and move them to Enabled Devices.

To choose all Disabled Devices, click Select All.Tip
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b. To disable statistics collection for one or more devices, choose the devices from Enabled Devices
and move them to Disabled Devices.

To choose all Enabled Devices, click Select All.Tip

c. To save your selections, click Done.

To discard your selections, click Cancel.

7. To apply the modified settings, click Save.

To discard your changes, click Cancel.

To revert to the default settings, click Restore Factory Default.

Configure the Time Interval to Collect Device Statistics

1. From the Cisco SD-WAN Manager menu, choose Administration > Settings.

2. To modify the time interval at which device statistics are collected, find Statistics Configuration and
click Edit.

To view the configured time interval, click View.Tip

3. Enter the desired Collection Interval in minutes.

• Default value: 30 minutes

• Minimum value: 5 minutes

• Maximum value: 180 minutes

4. To apply the modified settings, click Save.

To discard your changes, click Cancel.

To revert to the default settings, click Restore Factory Default.

Create a Custom Banner
To create a custom banner that is displayed after you log in to the Cisco SD-WAN Manager:

1. From Banner, click Edit.

2. In Enable Banner, click Enabled.

3. In Banner Info, enter the text string for the login banner or click Select a File to download a file that
contains the text string.

4. Click Save.
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Create Customized VNF Image

Before you begin

You can upload one or more qcow2 images in addition to a root disk image as an input file along with
VM-specific properties, bootstrap configuration files (if any), and generate a compressed TAR file. Through
custom packaging, you can:

• Create a custom VM package along with image properties and bootstrap files (if needed) into a TAR
archive file.

• Tokenize custom variables and apply system variables that are passed with the bootstrap configuration
files.

Ensure that the following custom packaging requirements are met:

• Root disk image for a VNF–qcow2

• Day-0 configuration files–system and tokenized custom variables

• VM configuration–CPU, memory, disk, NICs

• HA mode–If a VNF supports HA, specify Day-0 primary and secondary files, NICs for a HA link.

• Additional Storage–If more storage is required, specify predefined disks (qcow2), storage volumes
(NFVIS layer)

Step 1 From the Cisco SD-WAN Manager menu, choose Maintenance > Software Repository .
Step 2 Click Virtual Images > Add Custom VNF Package.
Step 3 Configure the VNF with the following VNF package properties and click Save.

Table 5: VNF Package Properties

DescriptionMandatory or OptionalField

The filename of the target VNF package.
It’s the Cisco NFVIS image name with
.tar or .gz extensions.

MandatoryPackage Name

Cisco VNFs or third-party VNFs.MandatoryApp Vendor

Name of the VNF image.MandatoryName

Version number of a program.OptionalVersion

Type of VNF to choose.

Supported VNF types are: Router,
Firewall, Load Balancer, and Other.

MandatoryType

Step 4 To package a VM qcow2 image, click File Upload, and browse to choose a qcow2 image file.
Step 5 To choose a bootstrap configuration file for VNF, if any, click Day 0 Configuration and click File Upload to browse

and choose the file.
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Include the following Day-0 configuration properties:

Table 6: Day-0 Configuration

DescriptionMandatory or OptionalField

The path where the bootstrap file gets
mounted.

MandatoryMount

A Day-0 configuration file can be
parsed or not.

Options are: Enable or Disable. By
default, Enable is chosen.

MandatoryParseable

High availability for a Day-0
configuration file to choose.

Supported values are: Standalone, HA
Primary, HA Secondary.

MandatoryHigh Availability

If any bootstrap configuration is required for a VNF, create a bootstrap-config or a day0-config file.Note

Step 6 To add a Day-0 configuration, click Add, and then click Save. The Day-0 configuration appears in the Day 0 Config
File table. You can tokenize the bootstrap configuration variables with system and custom variables. To tokenize
variables of a Day-0 configuration file, click View Configuration File next to the desired Day-0 configuration file. In
the Day 0 configuration file dialog box, perform the following tasks:

The bootstrap configuration file is an XML or a text file, and contains properties specific to a VNF and
the environment. For a shared VNF, see the topic and additional references in Cisco SD-WAN Cloud
OnRamp for Colocation Solution Guide for the list of system variables that must be added for different
VNF types..

Note

a) To add a system variable, in theCLI configuration dialog box, select, and highlight a property from the text fields.
Click System Variable. The Create System Variable dialog box appears.

b) Choose a system variable from the Variable Name drop-down list, and click Done. The highlighted property is
replaced by the system variable name.

c) To add a custom variable, in the CLI configuration dialog box, choose and highlight a custom variable attribute
from the text fields. Click Custom Variable. The Create Custom Variable dialog box appears.

d) Enter the custom variable name and choose a type from Type drop-down list.
e) To set the custom variable attribute, do the following:

• To ensure that the custom variable is mandatory when creating a service chain, clickType next toMandatory.

• To ensure that a VNF includes both primary and secondary day-0 files, click Type next to Common.

f) ClickDone, and then click Save. The highlighted custom variable attribute is replaced by the custom variable name.

Step 7 To upload extra VM images, expand Advance Options, click Upload Image, and then browse to choose an extra
qcow2 image file. Choose the root disk, Ephemeral disk 1, or Ephemeral disk 2, and click Add. The newly added VM
image appears in the Upload Image table.

Ensure that you don’t combine ephemeral disks and storage volumes when uploading extra VM images.Note
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Step 8 To add the storage information, expandAdd Storage, and clickAdd volume. Provide the following storage information
and click Add. The added storage details appear in the Add Storage table.

Table 7: Storage Properties

DescriptionMandatory or OptionalField

The disk size that is required for the
VM operation. If the size unit is GiB,
the maximum disk size can be 256
GiB.

MandatorySize

Choose size unit.

The supported units are: MIB, GiB,
TiB.

MandatorySize Unit

Choose a disk or CD-ROM. By
default, disk is chosen.

OptionalDevice Type

The location of the disk or CD-ROM.
By default, it’s local.

OptionalLocation

Choose a disk image format.

The supported formats are: qcow2,
raw, and vmdk. By default, it’s raw.

OptionalFormat

Choose a value from the drop-down
list.

The supported values for a bus are:
virtio, scsi, and ide. By default, it’s
virtio.

OptionalBus

Step 9 To add VNF image properties, expand Image Properties and enter the following image information.

Table 8: VNF Image Properties

DescriptionMandatory or OptionalField

Enable or disable SR-IOV support. By
default, it’s enabled.

MandatorySR-IOV Mode

VM health monitoring for those VMs
that you can bootstrap.

The options are: enable or disable. By
default, it’s enabled.

MandatoryMonitored

The monitoring timeout period for a
monitored VM. By default, it’s 600
seconds.

MandatoryBootup Time
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DescriptionMandatory or OptionalField

The serial console that is supported or
not.

The options are: enable or disable. By
default, it’s disabled.

OptionalSerial Console

Allows special features like
promiscuous mode and snooping.

The options are: enable or disable. By
default, it’s disabled.

OptionalPrivileged Mode

Facilitates allocation of a dedicated
resource (CPU) to supplement a VM's
low latency (for example, router and
firewall). Otherwise, shared resources
are used.

The options are: enable or disable. By
default, it’s enabled.

MandatoryDedicate Cores

Step 10 To add VM resource requirements, expand Resource Requirements and enter the following information.

Table 9: VM Resource Requirements

DescriptionMandatory or OptionalField

The CPUs supported by a VM. The
maximumnumbers of CPUs supported
are 8.

MandatoryDefault CPU

The RAM supported by a VM. The
RAM can range 2–32.

MandatoryDefault RAM

The disk size in GB supported by a
VM. The disk size can range 4–256.

MandatoryDisk Size

The maximum number of VNICs
allowed for a VM. The number of
VNICs can from range 8–32 and by
default, the value is 8.

OptionalMax number of VNICs

The management VNIC ID
corresponding to the management
interface. The valid range is from 0 to
maximum number of VNICs.

MandatoryManagement VNIC ID

The number of VNICs.MandatoryNumber of Management VNICs ID
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DescriptionMandatory or OptionalField

TheVNIC IDswhere high availability
is enabled. The valid range is from
0–maximum number of VNICs. It
shouldn’t conflict with management
VNIC Id. By default, the value is 1.

MandatoryHigh Availability VNIC ID

The maximum number of VNIC IDs
where high availability is enabled. The
valid range is 0–(maximum number of
VNICs-number of management
VNICs-2) and by default, the value is
1.

MandatoryNumber of High Availability VNICs
ID

Step 11 To add day-0 configuration drive options, expand Day 0 Configuration Drive options and enter the following
information.

Table 10: Day-0 Configuration Drive Options

DescriptionMandatory or OptionalField

The volume label of the Day-0
configuration drive.

The options are: V1 or V2. By default,
the option is V2. V2 is the config-drive
label config-2. V1 is config-drive label
cidata.

MandatoryVolume Label

The Day-0 configuration file as a disk
when mounted. The default drive is
CD-ROM.

OptionalInit Drive

Choose an init bus.

The supported values for a bus are:
virtio, scsi, and ide. By default, it’s ide.

OptionalInit Bus

The Software Repository table displays the customized VNF image, and image is available for choosing when
creating a custom service chain.
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Customize the Monitor Overview Dashboard
Table 11: Feature History

DescriptionRelease InformationFeature Name

You can customize the Monitor Overview dashboard. You
can specify which dashlets to view and sort them based on
your personal preferences.

Cisco vManage
Release 20.9.1

Customizable Monitor
Overview Dashboard
in Cisco SD-WAN
Manager

You can filter the data on the Monitor Overview and
Monitor Security dashboards for a specified time range.

Cisco vManage
Release 20.10.1

Time Filter in Monitor
Overview andMonitor
Security Dashboards in
Cisco SD-WAN
Manager

You can view all sites or a single site in the global topology
view for geographical regions worldwide by clicking the
inverted-drop-shaped icon on the Monitor Overview
dashboard.

Cisco vManage
Release 20.11.1

View Sites in Global
Topology View

You can view alarm details for a single site on the Monitor
Overview dashboard. Click View Details to open the
Monitor > Logs > Alarms window and view the alarm
details.

Cisco vManage
Release 20.11.1

View Top Alarms

You can view the WAN Edge Management dashlet on the
Monitor Overview dashboard.

Cisco vManage
Release 20.11.1

View WAN Edge
Management

This feature enhances the security dashboard in Cisco
SD-WAN Manager.

The security dashboard introduces aActions drop-down list
that enables you to edit the security dashboard, reset the
security dashboard, and view the SecureX ribbon in the
security dashboard.

Additionally, you can access the Cisco Talos portal from
Cisco SD-WAN Manager. A hyperlink of the Cisco Talos
portal is added to the security dashboard.

Cisco IOSXECatalyst
SD-WAN Release
17.11.1a

Cisco vManage
Release 20.11.1

Security Dashboard
Enhancements

Network-Wide Path Insight is now integratedwith the global
network view. This feature also introduces enhancements
to the geomap view by providing real-time monitoring of
the health of each site.

Global Topology View is now called as Global Network
View in Cisco Catalyst SD-WAN Manager.

Cisco Catalyst
SD-WAN Manager
Release 20.12.1

Global Network View
with Network-Wide
Path Insight
Integration

This feature enhances the security dashboard to provide
greater flexibility while troubleshooting security threats
down to a device level in Cisco Catalyst SD-WAN.

Cisco Catalyst
SD-WAN Manager
Release 20.12.1

Security Dashboard
Enhancements
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Add a Dashlet
1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview.

2. From the Actions drop-down list, choose Edit Dashboard.

3. Click Add Dashlet.

The Add Dashlet option is available only if additional dashlets are available to be added. It is not available
on the default dashboard.

Note

4. Choose the dashlets that you want to add.

5. Click Add.

6. Click Save.

You can customize the following dashlets:

• Transport Health

• Site BFD Connectivity

• Transport Interface Distribution

• WAN Edge Inventory

• Application-Aware Routing

Delete a Dashlet
1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview.

2. From the Actions drop-down list, choose Edit Dashboard.

3. Click the Delete icon adjacent to the corresponding dashlet name.

4. To confirm the deletion of the dashlet, click Yes.

5. Click Save.

Rearrange Dashlets
1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview.

2. From the Actions drop-down list, choose Edit Dashboard.

3. Drag and drop the dashlets according to your requirements.

4. Click Save.

Filter the Dashboard Data
Minimum release: Cisco vManage Release 20.10.1
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You can view the data on the Monitor Overview and Monitor Security dashboards based on a specified
time range. A time filter option is available on these dashboards. On the Monitor Overview dashboard, the
time filter option is applicable to the following dashlets:

• Site Health

• Tunnel Health

• WAN Edge Health

• Application Health

• Transport Health

• Top Alarms

• Top Applications

This feature is available in both single-tenant and multitenant deployments. In multitenant deployments, this
feature is available only in the tenant dashboard.

Time filter values: 1 hour, 3 hours, 6 hours, 12 hours, 24 hours, 7 days.

Only in the Transport Health dashlet, the data is available up to 7 days. In the Site Health, Tunnel Health,
WAN Edge Health,Application Health, andTop Applications dashlets, the data is available up to 24 hours.

Default: 24 hours

To filter the data, do the following:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview or Monitor > Security.

2. From the time filter drop-down list, choose a value.

The dashlets display the data based on the chosen time.

You also can apply the time filter at the dashlet level. To do this, click View Details in the corresponding
dashlet, and choose a time filter value in the right navigation pane. The time filter value applied at the dashboard
level, and not at the dashlet level, is preserved after closing the navigation pane.

Restore Default Settings
1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview.

2. From the Actions drop-down list, choose Reset to Default View.

3. Click Apply.

Decommission a Cloud Router
Decommissioning a cloud router (such as a Cisco Cloud Services Router 1000V) removes the device's serial
number from Cisco SD-WAN Manager and generates a new token for the device. To do so:

1. From the Cisco SD-WAN Manager menu, choose Configuration > Devices.

2. Click WAN Edge List, and select a cloud router.

3. Click …, and click Decommission WAN Edge.
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4. To confirm the decommissioning of the router, click OK.

Delete a Software Image from the Repository
To delete a software image from the Cisco SD-WAN Manager software repository:

Step 1 From the Cisco SD-WAN Manager menu, choose Maintenance > Software Repository.
Step 2 For the desired software image, click ... and choose Delete.

If a software image is being downloaded to a router, you cannot delete the image until the download process
completes.

Determine the Status of Network Sites
A site is a particular physical location within the Cisco Catalyst SD-WAN overlay network, such as a branch
office, a data center, or a campus. Each site is identified by a unique integer, called a site ID. Each device at
a site is identified by the same site ID.

To determine the status of network sites:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, chooseDashboard >
Main Dashboard.

2. Locate the Site BFD Connectivity dashlet, which displays the state of data connections of a site. When
a site has multiple edge devices, this dashlet displays the state of the entire site and not for individual
devices. The Site BFD Connectivity dashlet displays three states:

• Full WAN Connectivity: Total number of sites where all BFD sessions on all devices are in the up
state.

• Partial WAN Connectivity: Total number of sites where a TLOC or a tunnel is in the down state.
These sites still have limited data plane connectivity.

• No WAN Connectivity: Total number of sites where all BFD sessions on all devices are in the down
state. These sites have no data plane connectivity.

Click any of these to view more details. The details are displayed in a pop-up window.
3. For the desired row, click ... and choose Device Dashboard, SSH Terminal, or Real Time. You will be

redirected to the appropriate window based on your selection.
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Enable Reverse Proxy
Table 12: Feature History

DescriptionRelease InformationFeature Name

With this feature, you can deploy a reverse proxy in
your overlay network between Cisco IOSXECatalyst
SD-WAN devices and Cisco SD-WAN Manager and
Cisco SD-WANControllers. Also, this feature enables
you to deploy a reverse proxy in both single-tenant
andmultitenant deployments that include Cisco vEdge
devices or Cisco IOS XE Catalyst SD-WAN devices.
In a multitenant deployment, the Service Provider
manages reverse proxy and the associated
configuration.

Cisco IOS XE Release
17.6.1a

Cisco SD-WAN Release
20.6.1

Cisco vManage Release
20.6.1

Support for Reverse Proxy
with Cisco IOS XE
Catalyst SD-WAN devices
and Cisco Catalyst
SD-WAN Multitenancy

In a standard overlay network, Cisco Catalyst SD-WAN edge devices initiate direct connections to the Cisco
SD-WAN Controllers (Cisco SD-WAN Manager and Cisco SD-WAN Controllers) and exchange control
plane information over these connections. The WAN edge devices are typically located in branch sites and
connect to the Cisco SD-WAN Controllers over the internet. As a result, Cisco SD-WANManager and Cisco
SD-WAN Controllers are also connected directly to the internet.

For security, or other reasons, you may not want the Cisco SD-WAN Controllers to have direct internet
connections. In such a scenario, you can deploy a reverse proxy between the Cisco SD-WAN Controllers and
the WAN edge devices. The reverse proxy acts as an intermediary to pass control traffic between the Cisco
SD-WAN Controllers and the WAN edge devices. Instead of communicating directly with Cisco SD-WAN
Manager and the Cisco SD-WAN Controllers, the WAN edge devices communicate with the reverse proxy,
and the reverse proxy relays the traffic to and fromCisco SD-WANManager and Cisco SD-WANControllers.

The following figure illustrates a reverse proxy deployed between a WAN edge device and Cisco SD-WAN
Manager and the Cisco SD-WAN Controllers.
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You can deploy a reverse proxy in both single-tenant and multi-tenant Cisco Catalyst SD-WAN deployments.

Restrictions for Enabling Reverse Proxy Support

• In a multitenant Cisco Catalyst SD-WAN overlay network, you can deploy a reverse proxy device with
only a three-node Cisco SD-WAN Manager cluster. Deployment of the reverse proxy is only supported
with a TLS-based control plane for Cisco SD-WAN Manager and Cisco SD-WAN Controllers.

• You cannot deploy a reverse proxy with a Cisco vEdge 5000 router.

• You cannot deploy a reverse proxy with IPv6 control connections.

Provision Certificates on the Reverse Proxy

Before exchanging traffic, the reverse proxy and the WAN edge devices must authenticate each other.

On the reverse proxy you must provision a certificate that is signed by the CA that has signed the certificate
of the Cisco SD-WAN Controllers. This certificate is used by the reverse proxy to verify the WAN edge
devices.

To generate a Certificate Signing Request (CSR) for the reverse proxy and have it signed by Cisco, do as
follows:

1. Run the following command on the reverse proxy:
proxy$ openssl req -new -days 365 -newkey rsa:2048 -nodes -keyout Proxy.key -out Proxy.csr

When prompted, enter values as suggested in the following table:

DescriptionProperty

Any country code.

Example: US

Country Name (2 letter
code)

Any state or province.

Example: CA

State or Province Name

Any locality.

Example: San Jose

Locality Name

Use either "vIPtela Inc" or "Viptela LLC".

Starting from Cisco IOS XE Catalyst SD-WANRelease 17.10.1a, you can
use "Cisco Systems" string as the Organization Name for enterprise
certificates.

Example: Viptela LLC

Organization Name

Use the “organization” name configured on the overlay.

Example: cisco-sdwan-12345

Organizational Unit Name

Host name ending with “.viptela.com”.

Example: proxy.viptela.com

Common Name
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DescriptionProperty

Use any valid email address.

Example: someone@example.com

Email Address

2. Get the CSR signed by Cisco.

• If you use Symantec/Digicert as the CA for the Cisco SD-WAN Controllers, open a case with Cisco
TAC to sign the CSR.

• If you use Cisco Public Key Infrastructure (PKI) as the CA for the Cisco SD-WAN Controllers,
submit the CSR on the Cisco Network Plug and Play (PnP) application and retrieve the signed
certificate.

Enable Reverse Proxy

1. From the Cisco SD-WAN Manager menu, choose Administration > Settings.

2. For the Reverse Proxy setting, click Edit.

3. For Enable Reverse Proxy, click Enabled.

4. Click Save.

Configure Reverse Proxy Settings on Cisco SD-WAN Controllers

1. From the Cisco SD-WAN Manager menu, choose Configure > Devices.

2. Click Controllers.

3. For the desired Cisco SD-WANManager instance or Cisco SD-WAN Controller, click … and click Add
Reverse Proxy.

The Add Reverse Proxy dialog box appears.

4. To map a private IP address and port number to a proxy IP address and port number, do as follows:

a. Click Add Reverse Proxy.

b. Enter the following details:

The private IP address is the IP address of the transport interface in VPN 0.Private IP

This is the port used to establish the connections that handle control and traffic
in the overlay network. The default port number is 12346.

Private Port

Proxy IP address to which private IP address must be mapped.Proxy IP

Proxy port to which the private port must be mapped.Proxy Port

c. If the Cisco SD-WAN Manager instance or Cisco SD-WAN Controller has multiple cores, repeat
Step 4 a and Step 4 b for each core.

5. To delete a private IP address-port number to proxy IP address-port number mapping, find the mapping
and click the trash icon.
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6. To save the reverse proxy settings, click Add.

To discard the settings, click Cancel.

7. In the Security feature template attached to the Cisco SD-WAN Manager instance or Cisco SD-WAN
Controller, choose TLS as the transport protocol.

After you configure reverse proxy settings on a Cisco SD-WAN Manager instance or a Cisco SD-WAN
Controller, WAN edge devices in the overlay network are provisioned with a certificate for authentication
with the reverse proxy.

1. When a reverse proxy is deployed, Cisco Catalyst SD-WAN Validator shares the details of the reverse
proxy with the WAN edge devices.

2. On learning about the reverse proxy, a WAN edge device initiates the installation of a signed certificate
from Cisco SD-WAN Manager.

3. After the certificate is installed, the WAN edge device uses the certificate for authentication with the
reverse proxy and connects to the reverse proxy.

Disable Reverse Proxy

Before you disable reverse proxy, delete any private IP address-port number to proxy IP address-port number
mappings that you have configured for Cisco SD-WAN Manager instances and Cisco SD-WAN Controller.
See Configure Reverse Proxy Settings on Cisco Catalyst SD-WAN Controllers for information about deleting
the mappings.

Note

1. From the Cisco SD-WAN Manager menu, choose Administration > Settings.

2. For the Reverse Proxy setting, click Edit.

3. For Enable Reverse Proxy, click Disabled.

4. Click Save.

Monitor Private and Proxy IP Addresses of Cisco SD-WAN Controllers and WAN Edge Devices

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Click on the hostname of a Cisco SD-WAN Manager instance, Cisco SD-WAN Controller, or a WAN
edge device.

3. In the left pane, click Real Time.

4. From the Device Options drop-down list, choose Control Connections.

In the table that appears, the entries in the Private IP and Private Port columns are the private IP address
and port number of the transport interface in VPN 0. The entries in the Public IP and Public Port columns
are the proxy IP address and port number.
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Monitor Reverse Proxy Using CLI

Example: Monitor Private and Proxy IP Address and Port Numbers of WAN Edge Devices on Cisco
SD-WAN Controllers

The following is a sample output from the execution of the show control connections command on a Cisco
SD-WAN Controller. In the command output, for a WAN edge device, the entries in the PEER PRIVATE IP
and PEER PRIV PORT columns are the configured TLOC IP address and port number of the WAN edge
interface. The entries in the PEER PUBLIC IP and PEER PUB PORT columns are the corresponding IP
address and port number of the reverse proxy interface. The same command can also be executed on a Cisco
SD-WAN Manager instance to obtain a similar output.
vsmart1# show control connections

PEER PEER

PEER PEER PEER SITE DOMAIN PEER PRIV PEER PUB

INDEX TYPE PROT SYSTEM IP ID ID PRIVATE IP PORT PUBLIC IP PORT
ORGANIZATION REMOTE COLOR STATE UPTIME

-------------------------------------------------------------------------------------------------------------------------------------------------
0 vbond dtls 172.16.1.2 0 0 10.1.1.2 12346 10.1.1.2
12346 EXAMPLE-ORG default up 53:08:18:50
0 vmanage tls 172.16.1.6 1 0 10.2.100.6 45689 10.2.100.6
45689 EXAMPLE-ORG default up 53:08:18:32
1 vedge tls 1.1.100.1 100 1 10.3.1.2 57853 10.2.100.1 53624

EXAMPLE-ORG biz-internet up 53:08:18:44
1 vedge tls 1.1.101.1 101 1 10.4.1.2 55411 10.2.100.1 53622

EXAMPLE-ORG biz-internet up 53:08:18:48
1 vbond dtls 172.16.1.2 0 0 10.1.1.2 12346 10.1.1.2
12346 EXAMPLE-ORG default up 53:08:18:51

vsmart1#

Example: View Mapping of SD-WAN Controller Private IP Address and Port Number to Proxy IP
Address and Port Number on Cisco Catalyst SD-WAN Validator

The following is a sample output from the execution of the show orchestrator reverse-proxy-mapping
command on a Cisco SD-WAN Validator. In the command output, the entries in the PROXY IP and PROXY
PORT columns are the proxy IP address and port number. The entries in the PRIVATE IP and PRIVATE
PORT columns are the private IP address and port number of the transport interface in VPN 0.
vbond# show orchestrator reverse-proxy-mapping

PRIVATE PROXY

UUID PRIVATE IP PORT PROXY IP PORT

-----------------------------------------------------------------------------

14c35ae4-69e3-41c5-a62f-725c839d25df 10.2.100.4 23456 10.2.1.10 23458

14c35ae4-69e3-41c5-a62f-725c839d25df 10.2.100.4 23556 10.2.1.10 23558

6c63e80a-8175-47de-a455-53a127ee70bd 10.2.100.6 23456 10.2.1.10 23457

6c63e80a-8175-47de-a455-53a127ee70bd 10.2.100.6 23556 10.2.1.10 23557

6c63e80a-8175-47de-a455-53a127ee70bd 10.2.100.6 23656 10.2.1.10 23657

6c63e80a-8175-47de-a455-53a127ee70bd 10.2.100.6 23756 10.2.1.10 23757
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6c63e80a-8175-47de-a455-53a127ee70bd 10.2.100.6 23856 10.2.1.10 23857

6c63e80a-8175-47de-a455-53a127ee70bd 10.2.100.6 23956 10.2.1.10 23957

6c63e80a-8175-47de-a455-53a127ee70bd 10.2.100.6 24056 10.2.1.10 24057

6c63e80a-8175-47de-a455-53a127ee70bd 10.2.100.6 24156 10.2.1.10 24157

vbond#

Example: View Mapping of SD-WAN Controller Private IP Address and Port Number to Proxy IP
Address and Port Number on a WAN Edge Device

The following is a sample output from the execution of the show sdwan control connections
command on a Cisco IOS XE Catalyst SD-WAN device. In the command output, check the entry in the
PROXY column for a Cisco SD-WAN Manager instance or a Cisco SD-WAN Controller. If the entry is Yes,
the entries in the PEER PUBLIC IP and PEER PUBLIC PORT are the proxy IP address and port number.
Device# show sdwan control connections

PEER PEER
CONTROLLER

PEER PEER PEER SITE DOMAIN PEER PRIV PEER PUB
GROUP

TYPE PROT SYSTEM IP ID ID PRIVATE IP PORT PUBLIC IP PORT
ORGANIZATION LOCAL COLOR PROXY STATE UPTIME ID

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

vsmart tls 172.16.1.4 1 1 10.2.100.4 23558 10.2.1.10 23558
EXAMPLE-ORG biz-internet Yes up 52:08:44:25 0

vbond dtls 0.0.0.0 0 0 10.1.1.2 12346 10.1.1.2 12346
EXAMPLE-ORG biz-internet - up 52:08:50:47 0

vmanage tls 172.16.1.6 1 0 10.2.100.6 23957 10.2.1.10 23957
EXAMPLE-ORG biz-internet Yes up 66:03:04:50 0

Device#

On aCisco vEdge device, you can obtain a similar output by executing the command show control connections.

Example: View Signed Certificate Installed on a WAN Edge Device for Authentication with Reverse
Proxy

The following is a sample output from the execution of the show sdwan certificate reverse-proxy command
on a Cisco IOS XE Catalyst SD-WAN device.
Device# show sdwan certificate reverse-proxy

Reverse proxy certificate

------------------
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Certificate:

Data:

Version: 1 (0x0)

Serial Number: 1 (0x1)

Signature Algorithm: sha256WithRSAEncryption

Issuer: C = US, CN = 6c63e80a-8175-47de-a455-53a127ee70bd, O = Viptela

Validity

Not Before: Jun 2 19:31:08 2021 GMT

Not After : May 27 19:31:08 2051 GMT

Subject: C = US, ST = California, CN = C8K-9AE4A5A8-4EB0-E6C1-1761-6E54E4985F78, O
= ViptelaClient

Subject Public Key Info:

Public Key Algorithm: rsaEncryption

RSA Public-Key: (2048 bit)

Modulus:

00:e2:45:49:53:3a:56:d4:b8:70:59:90:01:fb:b1:

44:e3:73:17:97:a3:e9:b7:55:44:d4:2d:dd:13:4a:

a8:ef:78:14:9d:bd:b5:69:de:c9:31:29:bd:8e:57:

09:f2:02:f8:3d:1d:1e:cb:a3:2e:94:c7:2e:61:ea:

e9:94:3b:28:8d:f7:06:12:56:f3:24:56:8c:4a:e7:

01:b1:2b:1b:cd:85:4f:8d:34:78:78:a1:26:17:2b:

a5:1b:2a:b6:dd:50:51:f8:2b:13:93:cd:a6:fd:f8:

71:95:c4:db:fc:a7:83:05:23:68:61:15:05:cc:aa:

60:af:09:ef:3e:ce:70:4d:dd:50:84:3c:9a:57:ce:

cb:15:84:3e:cd:b2:b6:30:ab:86:68:17:94:fa:9c:

1a:ab:28:96:68:8c:ef:c8:f7:00:8a:7a:01:ca:58:

84:b0:87:af:9a:f6:13:0f:aa:42:db:8b:cc:6e:ba:

c8:c1:48:d2:f4:d8:08:b1:b5:15:ca:36:80:98:47:

32:3a:df:54:35:fe:75:32:23:9f:b5:ed:65:41:99:

50:b9:0f:7a:a2:10:59:12:d8:3e:45:78:cb:dc:2a:

95:f2:72:02:1a:a6:75:06:87:52:4d:01:17:f2:62:

8c:40:ad:29:e4:75:17:04:65:a9:b9:6a:dd:30:95:

34:9b
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Exponent: 65537 (0x10001)

Signature Algorithm: sha256WithRSAEncryption

99:40:af:23:bb:cf:7d:59:e9:a5:83:78:37:02:76:83:79:02:

b3:5c:56:e8:c3:aa:fc:78:ef:07:23:f8:14:19:9c:a4:5d:88:

07:4d:6e:b8:0d:b5:af:fa:5c:f9:55:d0:60:94:d9:24:99:5e:
33:06:83:03:c3:73:c1:38:48:45:ba:6a:35:e6:e1:51:0e:92:

c3:a2:4a:a2:e1:2b:da:cd:0c:c3:17:ef:35:52:e1:6a:23:20:

af:99:95:a2:cb:99:a7:94:03:f3:78:99:bc:76:a3:0f:de:04:

7d:35:e1:dc:4d:47:79:f4:c8:4c:19:df:80:4c:4f:15:ab:f1:

61:a2:78:7a:2b:6e:98:f6:7b:8f:d6:55:44:16:79:e3:cd:51:

0e:27:fc:e6:4c:ff:bb:8f:2d:b0:ee:ed:98:63:e9:c9:cf:5f:

d7:b1:dd:7b:19:32:22:94:77:d5:bc:51:85:65:f3:e0:93:c7:

3c:79:fc:34:c7:9f:40:dc:b1:fc:6c:e5:3d:af:2d:77:b7:c3:

88:b3:89:7c:a6:1f:56:35:3b:35:66:0c:c8:05:b5:28:0b:98:

19:c7:b0:8e:dc:b7:3f:9d:c1:bb:69:f0:7d:20:95:b5:d1:f0:

06:35:b7:c4:64:ba:c4:95:31:4a:97:03:0f:04:54:6d:cb:50:

2f:31:02:59

Device#

On a Cisco vEdge device, you can obtain a similar output by executing the command show certificate
reverse-proxy.

Enterprise Certificates
In Cisco IOS XE SD-WAN Release 16.11.1 and Cisco SD-WAN Release 19.1, enterprise certificates were
introduced. Enterprise certificates replace the controller certificates authorization used previously.

When using enterprise certificates for Cisco SD-WAN Controllers, ensure that you use root certificates with
an RSA key that is at least 2048 bit.

Note

For purposes of certificate management, the term controller is used to collectively refer to Cisco SD-WAN
Manager, the Cisco Catalyst SD-WAN Controller, and the Cisco Catalyst SD-WAN Validator.

Note
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For more information about enterprise certificates, see the Cisco Catalyst SD-WAN Controller Certificates
and Authorized Serial Number File Prescriptive Deployment Guide.

Note

Use the Certificates page to manage certificates and authenticate WAN edge and controller devices in the
overlay network.

Two components of the Cisco Catalyst SD-WAN solution provide device authentication:

• Signed certificates are used to authenticate devices in the overlay network. Once authenticated, devices
can establish secure sessions between each other. It is from Cisco SD-WAN Manager that you generate
these certificates and install them on the controller devices—Cisco SD-WANManager, Cisco SD-WAN
Validators, and Cisco SD-WAN Controllers.

• The WAN edge authorized serial number file contains the serial numbers of all valid vEdge and WAN
routers in your network. You receive this file from Cisco Catalyst SD-WAN, mark each router as valid
or invalid, and then from Cisco SD-WANManager, send the file to the controller devices in the network.

Install the certificates and the WAN edge authorized serial number file on the controller devices to allow the
Cisco Catalyst SD-WAN overlay network components to validate and authenticate each other and thus to
allow the overlay network to become operational.

Generate Admin-Tech Files
Table 13: Feature History

DescriptionRelease InformationFeature Name

This feature enhances the admin-tech file to include show
tech-support memory, show policy-firewall stats
platform, and show sdwan confd-log netconf-trace
commands in the admin-tech logs. The admin-tech tar file
includes memory, platform, and operation details.

Cisco IOSXECatalyst
SD-WAN Release
17.2.1r

Admin-Tech
Enhancements

You can collect system status information for a Cisco
SD-WAN Manager cluster. Prior to this feature, Cisco
Catalyst SD-WANwas only able to generate an admin-tech
file for a single device.

Cisco IOSXECatalyst
SD-WAN Release
17.6.1a

Cisco vManage
Release 20.6.1

Generate System
Status Information for
a Cisco SD-WAN
Manager Cluster Using
Admin Tech

You can view a list of generated admin-tech files and
determine which files to copy from your device to Cisco
SD-WAN Manager. You can then download the selected
admin-tech files to your local device, or delete the
downloaded admin-tech files from Cisco SD-WAN
Manager, the device, or both.

Cisco IOSXECatalyst
SD-WAN Release
17.6.1a

Cisco vManage
Release 20.6.1

View Generated
Admin-Tech Files at
Any Time
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DescriptionRelease InformationFeature Name

You can access additional diagnostics information collected
from the application server, the configuration database, the
statistics database, and other internal services.

Cisco IOSXECatalyst
SD-WAN Release
17.7.1a

Cisco vManage
Release 20.7.1

Additional Diagnostics
Information Added to
Admin-Tech File

You can upload an admin-tech file to a TAC case fromCisco
SD-WAN Manager.

Cisco IOSXECatalyst
SD-WAN Release
17.7.1a

Cisco vManage
Release 20.7.1

Upload an
Admin-Tech File to a
TAC Case

Perform the following steps to generate admin-tech file.

1. From the Cisco SD-WAN Manager menu, choose Tools > Operational Commands.

2. Click Generate Admin Tech for vManage to generate an admin-tech file for all the nodes in a Cisco
SD-WAN Manager cluster.

3. For a single device, click . . . for the desired device and choose Generate Admin Tech.

4. In the Generate admin-tech File window, limit the contents of the admin-tech tar file if desired:

a. The Include Logs check box is checked by default. Uncheck this check box to omit any log files from
the compressed tar file.

The log files are stored in the /var/log/directory on the local device.Note

b. Check the Include Cores check box to include any core files.

The core files are stored in the /var/crash directory on the local device.Note

c. Check the Include Tech check box to include any files related to device processes (daemons), memory
details and operations.

5. Click Generate.

Cisco SD-WAN Manager creates the admin-tech file.

The file name has the format date-time-admin-tech.tar.gz.

Starting from Cisco vManage Release 20.7.1, the admin-tech file includes additional diagnostics information
collected from the application server, the configuration database, the statistics database, and other internal
services.

Note
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For more information on admin tech and technical support commands, see request admin-tech and show
tech-support.

View Admin-Tech Files
You can perform any of the following operations after the admin-tech file is generated:

• View the list of the generated admin-tech files.

• Copy the selected admin-tech files from your device to Cisco SD-WAN Manager.

• Download the selected admin-tech files to your local device.

• Delete the selected admin-tech files from Cisco SD-WAN Manager, the device, or both.

1. From the Cisco SD-WAN Manager menu, choose Tools > Operational Commands.

2. For the desired device, click . . . and choose View Admin Tech List.

A tar file appears that contains the admin-tech contents of the device that you selected earlier. This file
has a name similar to ip-address-hostname-20210602-032523-admin-tech.tar.gz,
where the numeric fields are the date and the time.

You can view the list of the generated admin-tech files and decide which files that you want to copy to
Cisco SD-WAN Manager.

3. Click the Copy icon to copy the admin-tech file from the device to Cisco SD-WAN Manager.

A hint appears letting you know that the file is being copied from the device to Cisco SD-WANManager.

4. After the file is copied from the device to Cisco SD-WANManager, you can click the Download icon to
download the file to your local device.

You can view the admin-tech file size after the file is copied to Cisco SD-WAN Manager.

5. After the admin-tech file is successfully copied to Cisco SD-WAN Manager, you can click the Delete
icon and choose which files to delete from Cisco SD-WAN Manager, the device, or both.

For more information on admin tech and technical support commands, see request admin-tech and show
tech-support.

Upload an Admin-Tech File to a TAC Case
From Cisco vManage Release 20.7.1, Cisco IOS XE Catalyst SD-WANRelease 17.7.1a, and Cisco SD-WAN
Release 20.7.1, you can upload an admin-tech file directly from Cisco SD-WAN Manager when opening a
TAC case.

Before You Begin

Ensure that you have generated admin-tech files from Cisco SD-WAN Manager.

Upload an Admin-Tech File to a TAC Case

Perform the following steps to upload an admin-tech file to a TAC case:

1. From the Cisco SD-WAN Manager menu, choose Tools > Operational Commands.

2. After you generate Admin-Tech files, click Show Admin Tech List.
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The List of Admin-techs window is displayed.

3. From the list of Admin-tech files, select the admin-tech file and click Upload.

4. In the SR Number and Token fields, enter the details.

5. Choose the VPN from the VPN options. The options are VPN 0 and VPN 512.

6. Click Upload.

The selected admin-tech file is uploaded to the relevant service request.

How to Load a Custom Cisco SD-WAN Manager Application Server Logo
To change the Cisco SD-WAN Manager web application server logo and load a new custom logo, use the
request nms application-server update-logo command.

The logo image is located in the upper left corner of all Cisco SD-WAN Manager web application server
screens. You can load two files, a larger version, which is displayed on wider browser screens, and a smaller
version, which is displayed when the screen size narrows. Both files must be PNG files located on the local
device, and both must be 1 MB or smaller in size. For best resolution, it is recommended that the image for
the large logo be 180 x 33 pixels, and for the small logo 30 x 33 pixels.

Log In to the Cisco Catalyst SD-WAN Manager Web Application Server
The Cisco SD-WAN Manager runs as a web application server through which you log in to a running Cisco
SD-WAN Manager.

In an overlay network with a single Cisco SD-WANManager, to log in to the server, use HTTPS, and specify
the IP address of the server. Enter a URL in the format https://ip-address:8443, where 8443 is the port number
used by Cisco SD-WAN Manager. On the login page, enter a valid username and password, and then click
Log In. You have five chances to enter the correct password. After the fifth incorrect attempt, you are locked
out of the device, and you must wait for 15 minutes before attempting to log in again.

In an overlay network that has a cluster of Cisco SD-WAN Managers, the cluster allows you to log in to one
of the Cisco SD-WAN Managers that is operating in the role of a web application server. Use HTTPS,
specifying the IP address of one of the Cisco SD-WANManagers, in the format https://ip-address:8443. The
cluster software load-balances login sessions among the individual Cisco SD-WANManagers that are acting
as web application servers. You cannot control which of the individual Cisco SD-WAN Managers you log in
to.

With a Cisco SD-WAN Manager cluster, if you enter invalid login credentials, it might take some time for
you to see an invalid login error message, and the amount of time increases as the size of the cluster increases.
This delay happens because each Cisco SD-WAN Manager attempts sequentially to validate the credentials.
If none of the Cisco SD-WAN Manager servers validate you, only then do you see an invalid login error
message.

To determine which Cisco SD-WAN Manager you are logged in to, look in the Cisco SD-WAN Manager
toolbar, which is located at the top of the screen. To view more information about this particular Cisco
SD-WAN Manager server, enter the name of the server in the Search filter of the Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: To determine which Cisco SD-WAN Manager you are logged in
to, look in the Cisco SD-WAN Manager toolbar, which is located at the top of the screen. To view more
information about this particular Cisco SD-WAN Manager server, enter the name of the server in the Search
filter of the Monitor > Network.
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Information about Monitoring Multicloud Services using Cisco vManage
Table 14: Feature History Table

Release InformationRelease InformationFeature Name

You now have four new views on
the Cisco SD-WAN Manager UI
that enable you to monitor your
multicloud network.

Cisco IOS XE Catalyst SD-WAN
Release 17.6.1a

Cisco vManage Release 20.6.1

Cisco SD-WAN Manager Support
forMonitoringMulticloud Services

This feature provides enhancements
to monitoring dashboard for all the
Cloud and Interconnect
connections. This feature also gives
you the flexibility to specify which
dashlets to view and sort them
based on your preferences.

Cisco IOS XE Catalyst SD-WAN
Release 17.10.1a

Cisco vManage Release 20.10.1

Monitoring MultiCloud Services
for Real Time Data in Cisco
SD-WAN Manager

This feature enables you to monitor Cisco SD-WAN connectivity to different cloud resources using the Cisco
vManage UI. This feature introduces the following views in the UI using which you can visually monitor the
approximate geographical locations of Edge devices, cloud types, and information about cloud sites and
accounts for different cloud providers:

• Geographical View

• Cloud and Interconnect Dashboard

• Cloud Gateway Summary View

• Interconnect Gateway Summary View

By default, the Monitor Overview dashboard displays all the available dashlets that help you monitor the
different components and services of a Cisco SD-WAN overlay network. The customizable dashboard feature
enables you to do the following:

• Add dashlets

• Delete dashlets

• Rearrange dashlets

• Restore default settings

Starting from Cisco vManage Release 20.10.1, the Multicloud dashlets on the Monitor Overview dashboard
are displayed as soon as the Cloud or Interconnect provider accounts are associated with Cisco vManage.

Note

Geographical View
The geographical view shows the approximate geographic locations of the Cisco Catalyst 8000V instances
in multicloud deployments. The approximate locations are based on the publicly available information from
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the cloud and interconnect types. The locations are provided for the Google Cloud, AWS, and Azure cloud
platforms as well as software-defined cloud interconnects.

To view the geographical locations of multicloud Cisco Catalyst 8000V instances:

1. From the Cisco vManage menu, choose Monitor > Geography.

2. On the map, click a Cisco Catalyst 8000V instance to see the cloud or interconnect type, site-id, and
system-ip of that instance.

Cloud and Interconnect Dashboard
The cloud and interconnect dashboard displays a separate panel for each cloud instance and software-defined
cloud interconnect. A pie chart shows the sites that are connected to the cloud or the software-defined cloud
interconnect and their reachability. The sites are Cisco Catalyst SD-WAN devices of a particular site-id that
have a BFD session to the cloud or interconnect Cisco Catalyst 8000V. Each cloud or interconnect panel also
displays the following information:

• Number of Cisco Catalyst SD-WAN edge devices

• Registered multicloud accounts

• Gateways

• Tags

• Host VPCs

• Tunnels

• VPN connections

To view information on the cloud and interconnect dashboard:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Multicloud.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, chooseDashboard >
Multicloud.

2. To view information about the Cisco Catalyst SD-WAN edge devices, click the number of WAN Edges
to see information about the Cisco Catalyst SD-WAN edge devices. The window that is displayed shows
the health (aggregate of the CPU, memory, and hardware state), BFD status, configuration status,
reachability, hostname, system IP, chassis number, cloud or interconnect gateway name, device model
and version of the device.

• FromMonitor >Multicloud, when you click on the non-zero number of Cloud or Interconnect Edge
devices, theMonitor >Devices page opens. The Filter criteria on the left pane of theDeviceswindow
allows you to choose the fields to be displayed from the available options.

• To view the cloud or software-defined cloud interconnect gateway name, region, account name,
health, and description of the all the gateways that are specific to a cloud type, click on the non-zero
number of Cloud or Interconnect Gateways.

• To view the details of Cloud or Interconnect Edge devices, click on the non-zero number of Cloud
or Interconnect Edge.

• To view the Connected Sites health, BFD status and site ID, click on the non-zero number of
Connected Sites.
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Cloud Gateway Summary View

Geographical locations and traffic statistics are not available when the solution is branch connect-AWS.Note

The cloud gateway summary view displays the following information:

• Cloud type

• Account name

• Region

• Cloud gateway devices

• Associated branch devices—branch devices that have a BFD session set up with the cloud gateway
devices.

• Associated VPCs and vNETs—VPCs and vNETs that are mapped to a VPN that belongs to the same
region as the cloud gateway.

• Traffic statistics—tunnel statistics from the cloud gateway devices to the workload VPCs.When a device
is selected, you can choose to view the following traffic statistics and also for the time duration listed:

• Kbps

• Packets

• Octets

• Errors

• Drops

• Pps

If no device is selected, an aggregation of statistics of all the devices in the cloud gateway is displayed.

To go to the cloud gateway summary view:

1. From the Cisco SD-WAN Manager menu, choose Configuration > Cloud OnRamp for Multicloud.

2. Choose Cloud.

3. In the cloud gateway summary table, click the cloud gateway name for which you want to view the details.
You can also view details about the connected sites on this page.

Interconnect Gateway Summary View
The interconnect gateway summary view displays the following information:

• Cisco Catalyst SD-WAN edge device type

• Account name

• Region

• Interconnect gateway devices
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• Associated branch devices

• Interconnect connectivity

To go to the interconnect gateway summary view:

1. From the Cisco SD-WAN Manager menu, choose Configuration > Cloud OnRamp for Multicloud.

2. Choose Interconnect.

3. Click the interconnect gateway name for which you want to view the details.

Manage Data Collection for Cisco Catalyst SD-WAN Telemetry
Table 15: Feature History

DescriptionRelease InformationFeature Name

This feature allows you to disable
data collection for Cisco Catalyst
SD-WAN telemetry using Cisco
SD-WAN Manager.

Data collection for telemetry is
enabled by default.

Cisco IOS XE Catalyst SD-WAN
Release 17.6.1a

Cisco SD-WAN Release 20.6.1

Cisco vManage Release 20.6.1

Manage Data Collection for Cisco
Catalyst SD-WAN Telemetry

From Cisco vManage Release 20.6.1, Cisco SD-WAN Manager has a new option to enable or disable data
collection for Cisco Catalyst SD-WAN telemetry fromAdministration > Settings >Data Collection. Before
this release, the Data Collection section only had the option to enable or disable data collection, and not data
collection for Cisco Catalyst SD-WAN telemetry. The two options are described below:

Data Collection: This option is used to establish a connection to Cisco Catalyst SD-WAN Data Collection
Service (DCS) hosted on the cloud. The connection from Cisco SD-WANManager to DCS is used to collect
required data from the controllers and the network, for different features such as Cisco SD-WAN Analytics
and Cisco Catalyst SD-WAN telemetry.

SD-WAN Telemetry Data Collection: This option is used to enable or disable telemetry data collection from
the controllers and the network. It is enabled by default when Data Collection is enabled for Cisco Catalyst
SD-WAN. For Cisco-provided cloud-hosted controllers, this option is enabled at the time of provisioning the
controllers. For an on-premises controller, establishing the connection to Cisco Catalyst SD-WAN Data
Collection Service (DCS) through the Data Collection setting is a mandatory prerequisite for enabling Cisco
Catalyst SD-WAN telemetry.
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Manage Service Groups
Table 16: Feature History

DescriptionRelease InformationFeature Name

You can now upload a virtual
machine image to Cisco SD-WAN
Manager in qcow2 format. Earlier,
you could upload only a
prepackaged image file in tar.gz
format.

Cisco IOS XE Catalyst SD-WAN
Release 17.7.1a

Cisco vManage Release 20.7.1

Support for Cisco VM Image
Upload in qcow2 Format

Create Service Chain in a Service Group
A service group consists of one or more service chains.

Table 17: Feature History

Feature DescriptionRelease
Information

Feature Name

This feature lets you configure periodic checks on the service chain
data path and reports the overall status. To enable service chain health
monitoring, NFVIS version 3.12.1 or later should be installed on all
CSP devices in a cluster.

Cisco IOS XE
Catalyst
SD-WAN
Release 16.12.1b

Monitor Service
Chain Health

From the Cisco SD-WAN Manager menu, choose Configuration > Cloud OnRamp for Colocation

a) Click Service Group and click Create Service Group. Enter the service group name, description, and colocation
group.

The service group name can contain 128 alphanumeric characters.

The service group description can contain 2048 alphanumeric characters.

For a multitenant cluster, choose a colocation group or a tenant from the drop-down list. For a single-tenant cluster,
the colocation group admin is chosen by default.

b) Click Add Service Chain.
c) In the Add Service Chain dialog box, enter the following information:

Table 18: Add Service Chain Information

DescriptionField

The service chain name can contain 128 alphanumeric characters.Name

The service chain description can contain alphanumeric 2048 characters.Description

The service chain bandwidth is in Mbps. The default bandwidth is 10 Mbps and
you can configure a maximum bandwidth of 5 Gbps.

Bandwidth
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DescriptionField

The Input VLAN handoff and output VLAN handoff can be comma-separated
values (10, 20), or a range from 10–20.

Input Handoff VLANS and
Output Handoff VLANS

A toggle button that allows you to enable or disable service chain health
monitoring. The service chain health monitoring is a periodic monitoring service
that checks health of a service chain data path and reports the overall service
chain health status. By default, the monitoring service is disabled.

A service chain with subinterfaces such as, SCHM (Service Chain Health
Monitoring Service) can only monitor the service chain including the first VLAN
from the subinterface VLAN list.

The service chain monitoring reports status based on end-to-end connectivity.
Therefore, ensure that you take care of the routing and return traffic path, with
attention to the Cisco Catalyst SD-WAN service chains for better results.

Note • Ensure that you provide input and output monitoring IP
addresses from input and output handoff subnets. However, if
the first and last VNF devices are VPN terminated, you don't
need to provide input and output monitoring IP addresses.

For example, if the network function isn’t VPN terminated, the
input monitoring IP can be 192.0.2.1/24 from the inbound
subnet, 192.0.2.0/24. The inbound subnet connects to the first
network function and the output monitoring IP can be,
203.0.113.11/24 that comes from outbound subnet,
203.0.113.0/24 of the last network function of a service chain.

• If the first or last VNF firewall in a service chain is in
transparent mode, you can't monitor these service chains.

Monitoring

A topology to choose from the service chain drop-down list. For a service chain
topology, you can choose any of the validated service chains such as, Router -
Firewall - Router, Firewall, Firewall - Router. See the Validated Service Chains
topic in Cisco Catalyst SD-WAN Cloud OnRamp Colocation Solution Guide.
You can also create a customized service chain. See Create Custom Service Chain,
on page 40.

Service Chain

d) In the Add Service Chain dialog box, click Add.
Based on the service chain configuration information, a graphical representation of the service group with all the
service chains and the VNFs automatically appear in the design view window. A VNF or PNF appears with a "V"
or "P" around the circumference for a virtual a physical network function. It shows all the configured service chains
within each service group. A check mark next to the service chain indicates that the service chain configuration is
complete.

After you activate a cluster, attach it with the service group and enable monitoring service for the service chain, when
you bring up the CSP device where CCM is running. Cisco SD-WANManager chooses the same CSP device to start
the monitoring service. The monitoring service monitors all service chains periodically in a round robin fashion by
setting the monitoring interval to 30 minutes. See Monitor Cloud OnRamp Colocation Clusters, on page 51.

e) In the design view window, to configure a VNF, click a VNF in the service chain.
The Configure VNF dialog box appears.
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f) Configure the VNF with the following information and perform the actions, as appropriate:

The following fields are available from Cisco vManage Release 20.7.1:

• Disk Image/Image Package (Select File)

• Disk Image/Image Package (Filter by Tag, Name and Version)

• Scaffold File (Select File)

• Scaffold File (Filter by Tag, Name and Version)

Note

Table 19: VNF Properties of Router and Firewall

DescriptionField

Choose a router, firewall package.Image Package

Choose a tar.gz package or a qcow2 image file.Disk Image/Image Package (Select File)

(Optional) Filter an image or a package file based on the
name, version, and tags that you specified when uploading
a VNF image.

Disk Image/Image Package (Filter by Tag, Name and
Version)

Choose a scaffold file.

Note • This field is mandatory if a qcow2
image file has been chosen. It is
optional if a tar.gz package has been
chosen.

• If you choose both a tar.gz package and
a scaffold file, then all image properties
and system properties from the scaffold
file override the image properties and
system properties, including the Day-0
configuration files, specified in the
tar.gz package.

Scaffold File (Select File)

(Optional) Filter a scaffold file based on the name,
version, and tags that you specified when uploading a
VNF image.

Scaffold File (Filter by Tag, Name and Version)

Click Fetch VNF Properties. The available information for the image is displayed in the Configure VNF dialog
box.

VNF image nameName

(Optional) Specifies the number of virtual CPUs that are
required for a VNF. The default value is 1 vCPU.

CPU

(Optional) Specifies the maximum primary memory in
MB that the VNF can use. The default value is 1024 MB.

Memory
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DescriptionField

(Optional) Specifies disk in GB required for the VM. The
default value is 8 GB.

Disk

A dialog box with any custom tokenized variables from Day-0 that requires your input appears. Provide the values.

In the following image, all IP addresses, VLAN, and autonomous system within the green box are system-specific
information that is generated from the VLAN, IP pools provided for the cluster. The information is automatically
added into the Day-0 configurations of VMs.

The following images are a sample configuration for VNF IP addresses and autonomous system numbers, in Cisco
SD-WAN Manager.
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If you're using a multitenant cluster and a comanged scenario, configure theCisco Catalyst SD-WANVM by entering
the values for the following fields and the remaining fields, as required for the service chain design:

To join the tenant overlay network, the provider should provide correct values for the following fields.Note

DescriptionField

The authorized serial number of a Cisco Catalyst SD-WAN device. The service provider
can get the device serial number from the tenant before creating the service chain.

Serial Number

The OTP of the Cisco Catalyst SD-WAN device that is available after authenticating it
with Cisco SD-WAN Control Components. The service provider can get the OTP for the
corresponding serial number from the tenant before creating the service chain.

OTP

The identifier of the site in the tenant Cisco Catalyst SD-WAN overlay network domain
in which the Cisco Catalyst SD-WAN device resides, such as a branch, campus, or data
center. The service provider can get the site Id from the tenant before creating the service
chain.

Site Id

The tenant organization name that is included in the Certificate Signing Request (CSR).
The service provider can get the organization name from the tenant before creating the
service chain.

Tenant ORG Name

The IP address to connect to the tenant overlay network. The service provider can get
the IP address from the tenant before creating the service chain.

System IP connect to
Tenant

The IP address of the tenant Cisco SD-WAN Validator. The service provider can get the
Cisco SD-WAN Validator IP address from the tenant before creating the service chain.

Tenant vBond IP
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For edge VMs such as first and last VM in a service chain, you must provide the following addresses as they peer
with a branch router and the provider router.

Table 20: VNF Options for First VM in Service Chain

DescriptionMandatory or
Optional

Field

Choose Routed or Transparent mode.

Firewall mode is applicable to firewall VMs only.Note

MandatoryFirewall Mode

Enable HA mode for the VNF.OptionalEnable HA

Choose one of the following modes:

• L3 mode selection with subinterfaces that are in trunk mode

<type>selection</type> <val help="L3 Mode With

Sub-interfaces(Trunked)" display="VNF-Tagged">vlan</val>

• L3 mode with IPSEC termination from a consumer-side and rerouted to
the provider gateway

<val help="L3 Mode With IPSEC Termination From Consumer and

Routed to Provider GW" display="Tunneled">vpn</val>

• L3 mode with access mode (nontrunk mode)

<val help="L3 Mode In Access Mode (Non-Trunked)"

display="Hypervisor-Tagged">routed</val>

MandatoryTermination

g) Click Configure. The service chain is configured with the VNF configuration.
h) To add another service chain, repeat the procedure from Steps b-g.
i) Click Save.

The new service group appears in a table under the Service Group. To view the status of the service chains
that are monitored, use the Task View window, which displays a list of all running tasks along with the total
number of successes and failures. To determine the service chain health status, use the show system:system
status command on the CSP device that has service chain health monitoring enabled.

Create Custom Service Chain
You can customize service chains,

• By including extra VNFs or add other VNF types.

• By creating new VNF sequence that isn’t part of the predefined service chains.

Step 1 Create a service group and service chains within the service group. See Create Service Chain in a Service Group, on page
35.
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Step 2 In theAdd Service Chain dialog box, enter the service chain name, description, bandwidth, input VLAN handoff, output
VLAN handoff, monitoring health information of a service chain, and service chain configuration. Click Add.

For the service chain configuration, choose Create Custom from the drop-down. An empty service chain in the design
view window is available.

Step 3 To add a VNF such as a router, load balancer, firewall, and others, click a VNF icon and drag the icon to its proper
location within the service group box. After adding all required VNFs and forming the VNF service chain, configure
each of the VNFs. Click a VNF in the service group box. The Configure VNF dialog box appears. Enter the following
parameters:
a) Choose the software image to load from the Disk Image/Image Package (Select File) drop-down list.

You can select a qcow2 image file from Cisco vManage Release 20.7.1.Note

b) Choose a scaffold file from the Scaffold File (Select File) drop-down list if you have chosen a qcow2 image file.

This option is available from Cisco vManage Release 20.7.1.Note

c) Optionally, filter an image, a package file, or a scaffold file based on the name, version, and tags that you specified
when uploading a VNF image.

This option is available from Cisco vManage Release 20.7.1.Note

d) Click Fetch VNF Properties.
e) In the Name field, enter a name of the VNF.
f) In the CPU field, enter the number of virtual CPUs required for the VNF.
g) In the Memory field, enter the amount of memory in megabytes to be allocated for the VNF.
h) In the Disk field, enter the amount of memory for storage in gigabytes to be allocated for the VNF.
i) Enter VNF-specific parameters, as required.

These VNF details are the custom variables that are required for Day-0 operations of the VNF.Note

j) Click Configure.
k) To delete the VNF or cancel the VNF configuration, click Delete or Cancel respectively.

The customized service chains are added to a service group.

You can customize a VNF sequence with only up to four VNFs in a service chain.Note
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Manage Software Repository
Table 21: Feature History

DescriptionRelease InformationFeature Name

This feature enables you to register
a remote server with Cisco
SD-WAN Manager, and add
locations of software images on the
remote server to the Cisco
SD-WAN Manager software
repository. When you upgrade
device or controller software, the
device or controller can download
the new software image from the
remote server.

Cisco IOS XE Catalyst SD-WAN
Release 17.7.1a

Cisco vManage Release 20.7.1

Software Upgrade Using a Remote
Server

Register Remote Server
Register a remote server with Cisco SD-WAN Manager so that you can add locations of software images on
the remote server to the Cisco SD-WAN Manager software repository and upgrade device or controller
software using these software images. In multitenant Cisco Catalyst SD-WAN deployment, only the provider
can register a remote server and perform software upgrade using images on the remote server.

1. From the Cisco SD-WAN Manager menu, choose Maintenance > Software Repository.

2. Click Add Remote Server.

3. In the Add Remote Server slide-in page, configure the following:

• Server Name: Enter a name for the server.

• Server IP or DNS Name: Enter the IP address or the DNS name of the server.

• Protocol: Choose HTTP or FTP.

• Port: Enter the access port number.

Server
Info

• User ID: Enter the user ID required to access the server. The username can contain
only the following characters: a-z, 0-9, ., _, and -.

• Password: Enter the password required to access the server. The password can contain
only the following characters: a-z, A-Z, 0-9, _, *, ., +, =, %, and -.

Special characters such as /, ?, :, @, and SPACE, which are used in URLs and
are needed for proper parsing of fields so files can be fetched properly with
the relevant protocol, are not supported in the username and the password.
The use of the valid characters is supported starting from Cisco vManage
Release 20.9.1.

Note

Credentials
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• Image Location Prefix: Enter the folder path where the uploaded images must be
stored

• VPN: Enter the VPN ID, either the transport VPN, management VPN, or service VPN

Image
Info

4. Click Add to add the remote server.

Manage Remote Server
1. From the Cisco SD-WAN Manager menu, choose Maintenance > Software Repository.

2. For the desired remote server, click …

3. To view the remote server settings, click View Details.

4. To edit the remote server settings, click Edit. Edit any of the following settings as necessary and click
Save.

You cannot edit the remote server settings if you have added locations of any software images on the remote
server to the Cisco SD-WAN Manager software repository. If you wish to edit the remote server settings,
remove the software image entries from the software repository and then edit the settings.

Note

• Server Name: Enter a name for the server.

• Server IP or DNS Name: Enter the IP address or the DNS name of the server.

• Protocol: Choose HTTP or FTP.

• Port: Enter the access port number.

Server
Info

• User ID: Enter the user ID required to access the server. The username can contain
only the following characters: a-z, 0-9, ., _, and -.

• Password: Enter the password required to access the server. The password can contain
only the following characters: a-z, A-Z, 0-9, _, *, ., +, =, %, and -.

Special characters such as /, ?, :, @, and SPACE, which are used in URLs and
are needed for proper parsing of fields so files can be fetched properly with
the relevant protocol, are not supported in the username and the password.
The use of the valid characters is supported starting from Cisco vManage
Release 20.9.1.

Note

Credentials

• Image Location Prefix: Enter the folder path where the uploaded images must be
stored.

• VPN: Enter the VPN ID, either the transport VPN, management VPN, or service VPN.

Image
Info

5. To delete the remote server, click Remove. Confirm that you wish to remove the remote server in the
dialog box.
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Before deleting a remote server, remove any entries for software images on the remote server that you have
added to the Cisco SD-WAN Manager software repository.

Note

Add Software Images to Repository

Before you begin

Before you can upgrade the software on an edge device, Cisco Catalyst SD-WANController, or Cisco SD-WAN
Manager to a new software version, you need to add the software image to the Cisco SD-WAN Manager
software repository. The repository allows you to store software images on the local Cisco SD-WANManager
server and on a remote file server.

The Cisco SD-WAN Manager software repository allows you to store images in three ways:

• On the local Cisco SD-WANManager server, to be downloaded over a control plane connection—Here,
the software images are stored on the local Cisco SD-WAN Manager server, and they are downloaded
to the Cisco Catalyst SD-WAN devices over a control plane connection. The receiving device generally
throttles the amount of data traffic it can receive over a control plane connection, so for large files, the
Cisco SD-WAN Manager server might not be able to monitor the software installation on the device
even though it is proceeding correctly.

• On the local Cisco SD-WANManager server, to be downloaded over an out-of-band connection—Here,
the software images are stored on the local Cisco SD-WAN Manager server, and they are downloaded
to the Cisco Catalyst SD-WAN devices over an out-of-band management connection. For this method
to work, you specify the IP address of the out-of-band management interface when you copy the images
to the software repository. This method is recommended when the software image files are large, because
it bypasses any throttling that the device might perform and so the Cisco SD-WAN Manager server is
able to monitor the software installation.

• On a remote server—Here, the software images remain on a remote file server that is reachable through
an FTP or HTTP URL. As part of the software upgrade process, the Cisco SD-WAN Manager server
sends this URL to the Cisco Catalyst SD-WAN device, which then establishes a connection to the file
server over which to download the software images.

Step 1 From the Cisco SD-WAN Manager menu, choose Maintenance > Software Repository.
Step 2 Click Add New Software.
Step 3 Choose the location to store the software image:

a) To store the software image or on the local Cisco SD-WAN Manager server and have it be downloaded to Cisco
Catalyst SD-WAN devices over a control plane connection, choose vManage. The Upload Software to vManage
dialog box opens.

1. Drag and drop the software image file to the dialog box, or click Browse to select the software image from a
directory on the local Cisco SD-WAN Manager server.

2. Click Upload to add the image to the software repository.

NFVIS upgrade images require the local Cisco SD-WAN Manager server.Note
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b) To store the software image on a remote server, choose Remote Server. The Location of Software on Remote
Server dialog box opens.

1. In the Controller Version field, enter the controller version.

2. In the Version field, enter the version number of the software image.

3. In the FTP/HTTP URL field, enter the FTP or HTTP URL of the software image.

4. Click Add to add the image to the software repository.

c) To store the image on a remote Cisco SD-WANManager server and have it be downloaded to Cisco Catalyst SD-WAN
devices over an out-of-band management connection, choose Remote Server - vManage . The Upload Software
to Remote Server - vManage dialog box opens.

1. In the vManage Hostnamr/IP Address field, enter the IP address of an interface on the Cisco SD-WANManager
server that is in a management VPN (typically, VPN 512).

2. Drag and drop the software image file to the dialog box, or click Browse to select the software image from a
directory on the local Cisco SD-WAN Manager server.

3. Click Upload.

View Software Images
From the Cisco SD-WAN Manager menu, choose Maintenance > Software Respository.

The Software Repository window displays the images avaialable in the repository.

The Software Version column lists the version of the software image, and the Controller Version column
lists the version of Cisco SD-WAN Control Components that is equivalent to the software version. The Cisco
SD-WAN Control Components version is the minimum supported version. The software image can operate
with the listed Cisco SD-WAN Control Components version or with a higher version.

The Software Location column indicates where the software images are stored, either in the repository on
the Cisco SD-WAN Manager server, or in a repository in a remote location.

The Available Files column lists the names of the software image files.

The Updated On column shows when the software image was added to the repository.

The ... option for a desired software version provides the option to delete the software image from the repository.

In Cisco vManage Release 20.6.1 and earlier releases, when two or more software images have the same
software version but are uploaded with different filenames, the images are listed in a single row. TheAvailable
Files column lists the different filenames. This listing scheme is disadvantageous when deleting software
images as the delete operation removes all the software images corresponding to a software version.

From Cisco vManage Release 20.7.1, when two or more software images have the same software version but
are uploaded with different filenames, each software image is listed in a separate row. This enables you to
choose and delete specific software images.
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Upload VNF Images
The VNF images are stored in the Cisco SD-WAN Manager software repository. These VNF images are
referenced during service chain deployment, and then they are pushed to Cisco NFVIS during service chain
attachment.

Step 1 From the Cisco SD-WAN Manager menu, choose Maintenance > Software Repository.
Step 2 To add a prepackaged VNF image, click Virtual Images, and then click Upload Virtual Image.
Step 3 Choose the location to store the virtual image.

• To store the virtual image on the local Cisco SD-WAN Manager server and download it to CSP devices over a
control plane connection, click vManage. The Upload VNF’s Package to vManage dialog box appears.

a. Drag and drop the virtual image file or the qcow2 image file to the dialog box or click Browse to choose the
virtual image from the local Cisco SD-WAN Manager server. For example, CSR.tar.gz, ASAv.tar.gz, or
ABC.qcow2

b. If you upload a file, specify the type of the uploaded file: Image Package or Scaffold. Optionally, specify a
description of the file and add custom tags to the file. The tags can be used to filter images and scaffold files
when creating a service chain.

c. If you upload a qcow2 image file, specify the service or VNF type: FIREWALL or ROUTER. Optionally,
specify the following:

• Description of the image

• Version number of the image

• Checksum

• Hash algorithm

You can also add custom tags to the file that can be used to filter images and scaffold files when creating a
service chain.

• It is mandatory to upload a scaffold file if you choose a qcow2 image file.

• The option to select a qcow2 image file is available from Cisco vManage Release 20.7.1. In
Cisco vManage Release 20.6.1 and earlier releases, you can select only a tar.gz file.

Note

d. Click Upload to add the image to the virtual image repository. The virtual image repository table displays the
added virtual image, and it available for installing on the CSP devices.

• To store the image on a remote Cisco SD-WANManager server and then download it to CSP devices, click Remote
Server - vManage. The Upload VNF’s Package to Remote Server-vManage dialog box appears.

a. In the vManage Hostname/IP Address field, enter the IP address of an interface on Cisco SD-WAN Manager
server that is in the management VPN (typically, VPN 512).

b. Drag and drop the virtual image file or the qcow2 image file to the dialog box, or click Browse to choose the
virtual image from the local Cisco SD-WAN Manager server.

c. If you upload a file, specify the type of the uploaded file: Image Package or Scaffold. Optionally, specify a
description of the file and add custom tags to the file. The tags can be used to filter images and scaffold files
when creating a service chain.
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d. If you upload a qcow2 image file, specify the service or VNF type: FIREWALL or ROUTER. Optionally,
specify the following:

• Description of the image

• Version number of the image

• Checksum

• Hash algorithm

You can also add custom tags to the file that can be used to filter images and scaffold files when creating a
service chain.

• It is mandatory to upload a scaffold file if you choose a qcow2 image file.

• The option to select a qcow2 image file is available from Cisco vManage Release 20.7.1. In
Cisco vManage Release 20.6.1 and earlier releases, you can select only a tar.gz file.

Note

e. Click Upload to add the image to the virtual image repository. The virtual image repository table displays the
added virtual image, and it is available for installing on the CSP devices.

You can have multiple VNF entries such as a firewall from same or from different vendors. Also, you can
add different versions of VNF that are based on the release of the same VNF. However, ensure that the VNF
name is unique.

View the Status of Network Devices
1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Locate the WAN edge router that you want to view the status for. You can either scroll through the list
of devices in the device table or enter a keyword in the search bar.

3. Click the relevant WAN edge router under the Hostname column. The System Status screen opens by
default.

View VNF Images

Step 1 From the Cisco SD-WAN Manager menu, choose Maintenance > Software Repository.
Step 2 Click Virtual Images.
Step 3 To filter the search results, use the filter option in the search bar.

The Software Version column provides the version of the software image.

The Software Location column indicates where the software images are stored. Software images can be stored either in
the repository on the Cisco SD-WAN Manager server or in a repository in a remote location.

The Version Type Name column provides the type of firewall.
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The Available Files column lists the names of the VNF image files.

The Update On column displays when the software image was added to the repository.

Step 4 For the desired VNF image, click ... and choose Show Info.

Delete VNF Images

Step 1 From the Cisco SD-WAN Manager menu, choose Maintenance > Software Repository.
Step 2 Click Virtual Images. The images in the repository are displayed in a table.
Step 3 For the desired image, click ... and choose Delete.

If you're downloading a VNF image to a device, you can’t delete the VNF image until the download process
completes.

Note

If the VNF image is referenced by a service chain, it can’t be deleted.Note

Software Upgrade
Use the Software Upgrade window to download new software images and to upgrade the software image
running on a Cisco Catalyst SD-WAN device.

From a centralized Cisco SD-WAN Manager, you can upgrade the software on Cisco Catalyst SD-WAN
devices in the overlay network and reboot them with the new software. You can do this for a single device or
for multiple devices simultaneously.

When you upgrade a group of Cisco Catalyst SD-WAN Validator, Cisco Catalyst SD-WAN Controllers, and
Cisco IOS XE Catalyst SD-WAN devices or Cisco vEdge devices in either a standalone or Cisco SD-WAN
Manager cluster deployment, the software upgrade and reboot is performed first on the Cisco Catalyst SD-WAN
Validator, next on the Cisco Catalyst SD-WANController, and finally on the Cisco IOSXECatalyst SD-WAN
devices or Cisco vEdge devices. Up to 40 Cisco IOS XE Catalyst SD-WAN devices or Cisco vEdge devices
can be upgraded and rebooted in parallel, depending on CPU resources.

Introduced in the Cisco vManage Release 20.8.1, the software upgrade workflow feature simplifies the software
upgrade process for the Cisco Catalyst SD-WAN edge devices through a guided workflow and displays the
various device and software upgrade statuses. For more information on creating a Software UpgradeWorkflow,
see Software Upgrade Workflow.
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• You cannot include Cisco SD-WANManager in a group software upgrade operation. You must upgrade
and reboot the Cisco SD-WAN Manager server by itself.

• You can create a software upgrade workflow only for upgrading the Cisco Catalyst SD-WAN edge
devices.

• It is recommended that you perform all software upgrades from Cisco SD-WAN Manager rather than
from the CLI.

• For software compatibility information, see Cisco SD-WANController Compatibility Matrix and Server
Recommendations.

Note

Monitor Cflowd and SAIE Flows for Cisco IOS XE Catalyst SD-WAN Devices
Table 22: Feature History

DescriptionRelease InformationFeature Name

Configure Cflowd traffic flow monitoring on Cisco
IOS XE Catalyst SD-WAN devices.

Cisco IOS XE Catalyst
SD-WANRelease 17.4.1a

Cisco vManage Release
20.4.1

Flexible NetFlow Support
for IPv6 and Cache Size
Modification

To enable logging of dropped packets, check the
Implicit ACL Logging check box and to configure
how often the packet flows are logged, enter the value
in the Log Frequency field.

Cisco IOS XE Catalyst
SD-WANRelease 17.5.1a

Cisco vManage Release
20.5.1

Log Packets Dropped by
Implicit ACL

Configure Cflowd traffic flow monitoring to collect
ToS, sampler ID, and remarked DSCP values in
netflow records.

Cisco IOS XE Catalyst
SD-WANRelease 17.6.1a

Cisco vManage Release
20.6.1

Flexible NetFlow
Enhancement

Configure this feature using the CLI template and also
add-on CLI template.

Cisco IOS XE Catalyst
SD-WANRelease 17.7.1a

Cisco vManage Release
20.7.1

Flexible NetFlow for
VPN0 Interface

This feature enables export spreading to prevent
export storms that occur when a burst of packets are
sent to external collector. The export of the previous
interval is spread during the current interval to prevent
export storms. When NetFlow packets are sent over
a low-bandwidth circuit, the export spreading
functionality is enabled to avoid packet drops.

Cisco IOS XE Catalyst
SD-WANRelease 17.9.1a

Cisco Catalyst SD-WAN
Control Components
Release 20.9.x

Cisco vManage Release
20.9.1

Flexible NetFlow Export
Spreading
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DescriptionRelease InformationFeature Name

With this feature, you can export Bidirectional
Forwarding Detection (BFD) metrics to an external
collector for generating BFD metrics of loss, latency,
and jitter. This feature provides enhanced monitoring
and faster collection of network state data.

Cisco IOS XE Catalyst
SD-WAN Release
17.10.1a

Cisco Catalyst SD-WAN
Control Components
Release 20.10.1

Flexible NetFlow Export
of BFD Metrics

With this feature, you can apply filters for monitoring
specific Cflowd and SD-WAN Application
Intelligence Engine (SAIE) applications or application
families running within a VPN on the selected Cisco
IOS XE Catalyst SD-WAN device.

This feature was already available on Cisco vEdge
devices and is being extended to Cisco IOS XE
Catalyst SD-WAN devices in this release.

Cisco IOS XE Catalyst
SD-WAN Release
17.10.1a

Cisco vManage Release
20.10.1

Real-Time Device
Options for Monitoring
Cflowd and SAIE Flows

Minimum releases: Cisco IOS XE Catalyst SD-WAN Release 17.10.1a and Cisco vManage Release 20.10.1

For more information on monitoring Cflowd traffic flows, see Traffic Flow Monitoring with Cflowd.

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

2. Click … adjacent to the Cisco IOS XE Catalyst SD-WAN device name and choose Real Time.

3. From the Device Options drop-down list, choose one of the following options:

• cFlowd Flows/DPI

• cFlowd ipv6 Flows/DPI

4. Click Show Filters.

You can search for Cflowd flow records based on the selected filters.

The filters are displayed only if you selected one of the Cflowd flows with the DPI device options.Note

Table 23: Filters for Cflowd with DPI Device Options

DescriptionField

Enter the VPN ID.VPN ID

Enter the source IPv4 or IPv6 address.Source IP

Enter the destination IPv4 or IPv6 address.Destination IP

Enter the name of the application for which you are
configuring Cflowd and SAIE monitoring.

Application
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DescriptionField

Enter the name of the application family for which
you are configuring Cflowd and SAIE monitoring.

Application Family

5. Click Search or Reset All to reset all the search filters.

Monitor Cloud OnRamp Colocation Clusters
Table 24: Feature History

DescriptionRelease
Information

Feature Name

You can now stop, start, or restart VNFs on Cisco CSP devices from
the Colocation Cluster tab.

Cisco IOS XE
Catalyst
SD-WAN
Release 17.3.1a

Cisco vManage
Release 20.3.1

Network
Assurance
–VNFs:
Stop/Start/Restart

You can view the cluster information and their health states. Reviewing this information can help you to
determine which Cisco CSP device is responsible for hosting each VNF in a service chain. To view information
about a cluster, perform the following steps:

Step 1 From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.1 and earlier: From the Cisco SD-WAN Manager menu, choose Monitor > Network.

Step 2 To monitor clusters, click Colocation Cluster.

Cisco vManage Release 20.6.1 and earlier: Click Colocation Clusters.

All clusters with relevant information are displayed in a tabular format. Click a cluster name. You can monitor cluster
by clicking Config. View and Port Level View.

• Config. View: The primary part of the window displays the CSP devices and switch devices that form the cluster.
In the right pane, you can view the cluster information such as the available and total CPU resources, available and
allocated memory, and so on, based on colocation size.

The detail part of the window contains:

• Search: To filter the search results, use the Filter option in the search bar.

• A table that lists information about all devices in a cluster (Cisco CSP devices, PNFs, and switches).

Click a Cisco CSP device. VNF information is displayed in a tabular format. The table includes information
such as VNF name, service chains, number of CPUs, memory consumption, and other core parameters that
define performance of a network service chain. See View Information About VNFs.

To start, stop, or reboot a VNF, for the desired VNF, click ... and choose one of the following operations:

• Start.
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• Stop.

• Restart.

Ensure that service chain provisioning is complete and VMs are deployed, before issuing start, stop,
restart operations on any of the VNFs in the service chain.

Note

After you choose an operation on a VNF, wait until the operation is complete before you issue another operation.
You can view the progress of an operation from the Task View window.

• Port Level View: After you activate the cluster, to view the port connectivity details, click Port Level View.

You can view detailed port connectivity information for the switches and CSP devices in a color coded format based
on the SR-IOV and OVS modes.

To view the mapping of ports between the Catalyst 9500 switches and CSP devices, click or hover over a CSP
device.

Figure 1: Monitor Port Connectivity Details of a Cluster

Step 3 Click Services.

Here, you can view the following:

• Complete information of a service chain. The first two columns display the name and description of the service
chain in the service group and the remaining columns mention about the VNF, PNF statuses, monitoring service
enablement, and the overall health of a service chain. You can also view the colocation user group associated with
a service chain. The various health statuses and their representations are:

• Healthy—An up arrow in green. A service chain is in 'Healthy' status when all the VNF, PNF devices are
running and are in healthy state. Ensure that you configure the routing and policy correctly.

• Unhealthy—A down arrow in red. If one of the VNFs or PNFs are in unhealthy state, the service chain is
reported to be in 'Unhealthy' status. For example, after deploying a service chain, if one of the network function
IP address changes on the WAN or LAN side, or the firewall policy isn’t configured to let the traffic pass
through, then unhealthy state is reported. This is because the network function or overall service chain is
Unhealthy or both are in Unhealthy state.
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• Undetermined—Down arrow in yellow. This state is reported when the health of the service chain can’t be
determined. This state is also reported when there’s no status such as healthy or unhealthy available for the
monitored service chain over a time period. You can’t query or search a service chain with undetermined status.

If a service chain consists of a single PNF and PNF is outside the reachability of Cisco SD-WAN Manager, it
can’t be monitored. If a service chain consists of a single network function, the firewall that has VPN termination
on both sides which can’t be monitored, then it’s reported as Undetermined.

If the status of a service chain is undetermined, you can’t choose the service chain to view the
detailed monitoring information.

Note

• If you had configured a service chain by enabling the monitoring field, then click a service group that is in Healthy
or Unhealthy state. The primary part of the service chain monitoring window contains the following elements:

Graphical display that plots the latency information of the service chain, VNFs, PNFs.

The detail part of the service chain monitoring window contains:

• Search: To filter the search results, use the Filter option in the search bar.

• A table that lists information about all service chains, VNFs, PNFs, their health status, and types.

• Check the service chain, VNF, PNF check boxes for the service chains, VNFs, PNFs you want to choose.

• To change the sort order of a column, click the column title.

The status details column indicates the monitored data path and it provides the per hop analysis.

• Click Diagram and view the service group with all the service chains and VNFs in the design view window.

• Click a VNF. You can view CPU, memory, and disk allocated to the VNF in a dialog box.

• Choose a service group from the Service Groups drop-down. The design view displays the selected service group
with all the service chains and VNFs.

Step 4 Click Network Functions.

Here, you can view the following:

• All the virtual or physical network functions in a tabular format. Use the Show button, and choose to display either
a VNF or PNF.

VNF information is displayed in a tabular format. The table includes information such as VNF name, service chains,
colocation user groups, CPU use, memory consumption, and other core parameters that define performance of
network service. To view more information about the VNF, click a VNF name. See View Information About VNFs.

• PNF information is displayed in tabular format. The table includes information such as the serial number and PNF
type. To view and note configuration of a specific PNF, click the desired PNF serial number. Ensure that youmanually
note all the configuration of the PNFs and then configure the PNF devices. For example, the following are some of
the PNF configuration where you position the PNF at various locations in the service chain. See Cloud OnRamp for
Colocation Solution Guide to configure the PNFs manually.
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Figure 2: PNF in the First Position with Service Chain Side Parameters

Figure 3: PNF in the First Position with Outside Neighbor Information

Figure 4: PNF Shared Across Two Service Chains

The ServiceGroup2_chain3 is a PNF-only service chain and therefore no configuration gets generated. The PNF is
in the last position of the ServiceGroup2_chain1, so only INSIDE variables gets generated.

Figure 5: PNF Shared Across Two Service Chains with Outside Neighbor Information

Monitor Network Performance
Use the Network screens to monitor the health of data tunnels and the availability of network devices and
circuits.

Screen Elements

• Title bar—Includes the title of the screen.

• Health—Displays latency, loss, and jitter performance.

• Availability—Displays downtime information for the Cisco Catalyst SD-WAN edge devices and circuits.
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Display Network Availability

To display downtime for Cisco Catalyst SD-WAN edge devices and circuit at each site:

1. Select an edge device or circuit view to see the respective downtime.

2. Adjust length of time: Day, Week, Month, or Custom Period.

3. Select Aggregated Downtime by Sites.

4. Click on individual data elements to see downtime information for a specific site.

5. Click a Cisco Catalyst SD-WAN edge device or circuit to display details about that downtime event.

Display Network Health

Use the Network Health screen to monitor the performance of tunnels over time in your overlay network over
time.

The tunnel statistics may be displayed in one of three views: by edge device, by tunnel, or by carrier.

To display performance through Cisco Catalyst SD-WAN edge device view:

1. Click vEdge.

2. Select an individual color to filter the view.

3. Select a Cisco vEdge device to display latency, loss, and jitter on all the tunnels on that device.

To display graphs for latency, loss, and jitter on each tunnel in your overlay network:

1. Click Tunnel. Select an individual carrier, color, or both to filter the view.

2. Hover over a point on a line to open a hover box with details for that point in time.

3. Click a local Cisco Catalyst SD-WAN device to display average latency, loss, or jitter on all the tunnels
on that device.
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4. Click a remote Cisco Catalyst SD-WAN device to display latency, loss, or jitter on the tunnels between
two Cisco Catalyst SD-WAN devices.

To display performance by carrier on a geographical map of the overlay network:

1. Click Carrier. Circles on the map represent each carrier. The legend to the right indicates the color of
each carrier.

2. Select Latency, Loss, or Jitter to change the data displayed.

3. Click on individual data elements to select specific carriers to view.

4. Hover over a carrier's circle to display a hover box with details for that location.

5. Click a circle on the map to display loss, latency, or jitter of all the tunnels terminating on that location.

6. Click a carrier on the graph to see performance by individual edge devices on that carrier.

Onboard Cisco Catalyst 8000V Edge Software Hosted by a Cloud Service, Using
PAYG Licensing

To onboard a Cisco Catalyst 8000V platform hosted by a cloud service, using pay as you go (PAYG) licensing,
perform these steps.

You can also use Cisco Cloud onRamp for Multi-Cloud to onboard a Cisco Catalyst 8000V platform using
PAYG licensing. For information to integrate public cloud infrastructure into the Cisco Catalyst SD-WAN
fabric, see Cloud OnRamp Configuration Guide, Cisco IOS XE Release 17.x.

This procedure is applicable to Cisco Catalyst 8000V hosted by Amazon Web Services (AWS).Note

1. From the Cisco SD-WANManager menu, choose Configuration > Devices, and click Add PAYG WAN
Edges.

2. In the Add PAYG WAN Edges dialog box, enter the number of PAYG devices to onboard into Cisco
Catalyst SD-WAN, select the Validate check box, and click Add.

The Task View page opens, showing the progress as Cisco SD-WAN Manager creates logical devices.

Validating causes Cisco SD-WAN Manager to publish the list of devices to the Cisco Catalyst SD-WAN
Validator and Cisco Catalyst SD-WAN Controller controllers in the network.

Note

3. After the Task View page shows the logical devices have been created successfully, choose
Configuration > Devices to view the new logical devices on the Devices page.

The Chassis Number column shows the unique identifier for each logical device.Note

4. For the logical devices that you have created, click … and choose Generate Bootstrap Configuration.
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5. (Optional) Attach a device template to the logical devices that you have created.

6. In the Generate Bootstrap Configuration dialog box, click Cloud-Init and then click OK.

The Generate Bootstrap Configuration dialog box shows the content of the bootstrap configuration,
which includes the UUID of the logical device, and includes the configuration details provided by the
device template if you have attached one.

The UUID corresponds to the identifier in the Chassis Number column in the Devices table.Note

7. There are different methods for loading the bootstrap configuration onto a C8000V instance on a cloud
service. The method you use depends on the cloud service. We recommend to click Download in the
Generate Bootstrap Configuration dialog box to save a copy of the bootstrap configuration.

8. In the cloud services portal, create a PAYG instance of the Cisco Catalyst 8000V. When configuring the
instance, use the bootstrap configuration that you created in Cisco SD-WANManager. The details of how
to load the Cisco Catalyst SD-WAN bootstrap configuration onto the instance are specific to the cloud
services provider.

On AWS, the workflow for bringing up an instance includes a user data step that enables loading the bootstrap
configuration.

Note

9. On the cloud service platform, start the Cisco Catalyst 8000V instance using the bootstrap configuration
from an earlier step.

When the Cisco Catalyst 8000V instance boots up, it joins the Cisco Catalyst SD-WAN overlay
automatically. In Cisco SD-WAN Manager, on the Devices page, this Cisco Catalyst 8000V instance
shows a green medal icon in the State column and In Sync in the Device Status column.

On the Devices page, for logical devices that have not joined the Cisco Catalyst SD-WAN overlay, the State
column shows a dotted-circle icon.

Note

Reboot a Device
Use the Device Reboot screen to reboot one or more Cisco Catalyst SD-WAN devices.

Reboot Devices

1. From the Cisco SD-WAN Manager menu, choose Maintenance > Device Reboot.

2. Click WAN Edge, Controller, or vManage depending on the device type that you want to reboot..

3. Check the check boxes next to the device or devices that you want to reboot.

4. Click Reboot.
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View Active Devices

To view a list of devices on which the reboot operation was performed:

1. From the Cisco SD-WAN Manager toolbar, click the Tasks icon. Cisco SD-WAN Manager displays a
list of all running tasks along with the total number of successes and failures.

2. Click a row to see details of a task. Cisco SD-WAN Manager opens a pane displaying the status of the
task and details of the device on which the task was performed.

Reload a Security Application

The Reload Services option in the Maintenance > Device Reboot window lets you to recover a security
application from an inoperative state. Ensure that you use this service as an initial recovery option. See
Determine Security Applications in Inoperative State, on page 59.

Ensure that a security application has already been installed on the device that you choose to reload services
for. To reload one or more security applications:

1. From the Cisco SD-WAN Manager menu, choose Maintenance > Device Reboot.

2. Under WAN Edge, check the check box for the Cisco Catalyst SD-WAN device you want to choose.

3. Click Reload Services.

The Reload Container dialog box appears.

4. If the security application version is correct, check the check box against the version of the security
application.

5. Click Reload.

The security application stops, is uninstalled, reinstalled, and restarted.

Reset a Security Application

The Reset Services option in the Maintenance > Device Reboot window enables you to recover a security
application from an inoperative state.

Use theReset Services option when the virtual network configuration of a security application changes, such
as, the virtual port group configuration on a device.

• Ensure that a security application is already been installed on the device that you choose to reset services
for.

• Ensure that the chosen security application is in a running state.

To reset one or more security applications:

1. Click WAN Edge and check against a Cisco Catalyst SD-WAN device to reload the security application.

2. Click Reset Services.

The Reset Container dialog box opens.

3. If the security application version is correct, check the check box against the version of the device.

4. Click Reset.

The security application is stopped, and then restarted.
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Determine Security Applications in Inoperative State

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device by clicking its name in the Hostname column.

3. In the left pane, click Real Time.

The real time device information appears in the right pane.

4. From the Device Options drop-down list, choose App Hosting Details.

A table appears with the device-specific application hosting information. In the table, if the state of the
device is ACTIVATED, DEPLOYED, or STOPPED, perform a reload or reset operation on the security
application.

If the state of the device is RUNNING, the security application is in an operative state.

5. From the Device Options drop-down list, choose Security App Dataplane Global.

A table appears with the device-specific application data plane information. In the table, if the SN Health
of the device is yellow or red, perform a reload or reset operation on the security application.

If the SN Health of the device is green, the security application is in an operative state.

Rediscover Network
Use the Rediscover Network window to locate new devices in the overlay network and synchronize them
with Cisco SD-WAN Manager.

1. From the Cisco SD-WAN Manager menu, choose Tools > Rediscover Network.

2. Choose a device or devices by checking the check box next to the device model. To find the device you
are looking for scroll through the device table. Alternatively, choose a device group from the Device
Groups drop-down list to see devices that belong to a specific device group.

3. To confirm resynchronization of the device data, click Rediscover.

4. In the Rediscover Network dialog box, click Rediscover.

Replace a Cisco IOS XE Catalyst SD-WAN Device
You might replace a Cisco IOS XE Catalyst SD-WAN device if the device has failed completely or when a
component of the device, such as one of the power supplies, has failed.

In general terms, to replace one Cisco IOS XE Catalyst SD-WAN device with another, copy the configuration
from the device that you are removing to the new device and then add the new device into the network.

A. Copy the configuration from the device that you are replacing

1. From the Cisco SD-WAN Manager menu, choose Configuration > Devices.

2. In the list of devices, locate the device to be replaced. In the row of the device, click … and choose
Running Configuration.

Operations
59

Operations
Rediscover Network



If Cisco SD-WANManager cannot reach the device, skip to step 4 for instructions on logging in to the device
directly to copy the configuration information.

Note

3. Copy the text of the configuration and paste it into a text editor.

The configuration information is useful especially if you choose the manual deployment method for
onboarding the new replacement device.

4. If the device is not reachable by Cisco SD-WAN Manager, log in to the device directly and use the
following commands on the device to display the configuration information. Copy the configuration
information from the output.

• Display the running configuration and save the output to a text file.
show running-config | redirect bootflash:sdwan/ios.cli

• Display the SD-WAN running configuration and save the output to a text file.
show sdwan running-config | redirect bootflash:sdwan/sdwan.cli

B. Remove the device from the overlay network

1. From the Cisco SD-WAN Manager menu, choose Configuration > Certificates.

2. In the list of devices, locate the device to be replaced. In the row of the device, in the Validate column,
click Invalid, then OK.

This step causes any control connections to the device to be lost.Note

3. Click Send to Controllers.

4. From the Cisco SD-WAN Manager menu, choose Configuration > Devices.

5. In the list of devices, locate the device to be replaced. In the row of the device, click… and chooseDelete
WAN Edge.

C. Add the replacement device to the Cisco SD-WAN Manager inventory

1. Obtain the chassis number and serial number of the replacement device.

You can use the show sdwan certificate serial command on the device to display this information.Note

2. Add the new device to the inventory using one of the methods described in the Cisco Catalyst SD-WAN
Getting Started Guide.
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The methods for adding a new device to the inventory are relevant to onboarding devices in general. They
are not unique to replacing a device.

Note

D. Apply a device template to the new device, using the same device template that was applied to the device
that is being replaced

1. From the Cisco SD-WAN Manager menu, choose Configuration > Templates.

2. In the row for the template that was used for the device being replaced, click… and choose Export CSV.
The CSV file shows the parameters for each device to which the template is attached.

3. Review the exported CSV file.

• If the new device is identical to the device being replaced, you do not need to update any of the
parameters in the CSV file.

• If the new device is not identical to the device being replaced, then optionally, you can update
parameter values in the CSV file to match the new device, as required. For example, if the replacement
device uses a different interface numbering, as compared with the device being replaced, you can
update the parameter that specifies interface numbering.

4. To attach the template to the replacement device, do the following:

a. From the Cisco SD-WAN Manager menu, choose Configuration > Templates.

b. Click Device Templates.

In Cisco vManage Release 20.7.x and earlier releases, Device Templates is called Device.Note

c. In the row for the template that was used for the device being replaced, click … and choose Attach
Devices.

d. In the Attach Devices window, move the replacement device to the Selected Devices pane and click
Attach.

e. Optionally, you can update parameters in the template before applying it to the device, using one of
the following methods:

• In the row of the replacement device, click … and choose Edit Device Template. Edit any
parameters, as needed.

• Upload the CSV file that you downloaded and edited to update the parameters for the replacement
device. To upload the CSV file, click Upload (up arrow button) and navigate to the CSV file.

E. Onboard the new device

Use one of the following methods to onboard the new device.
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The methods for onboarding a new device to the inventory are relevant to onboarding devices in general.
They are not unique to replacing a device.

Note

• Plug and Play (PnP)

For information, see the Plug and Play Onboarding Workflow section of the Cisco Catalyst SD-WAN
Getting Started Guide, and see the Cisco Catalyst SD-WAN: WAN Edge Onboarding guide.

• Bootstrap

For information, see the Non-PnP Onboarding section of the Cisco Catalyst SD-WAN Getting Started
Guide, and see the bootstrap deployment section of the Cisco Catalyst SD-WAN:WANEdge Onboarding
guide.

• Manual deployment

To configure the new device, you can use the configuration files that you saved
earlier in part A.

Note

The manual deployment method requires installing a root certificate authority
(CA) for the new device.

Note

For information, see the Cisco Catalyst SD-WAN: WAN Edge Onboarding guide.

For information about installing a root CA, see the Enterprise Certificates section of the Cisco Catalyst
SD-WAN Getting Started Guide.

Restore Cisco SD-WAN Manager
This article describes how to restore the vManage NMS in case the server on which the vManage NMS virtual
machine (VM) is running fails. This article provides procedures for restoring a vManage NMS using two
different VMware interfaces, vSphere Client and vSphere Web Client.

When you restore vManage, any vManage certificates are reset to their original state. Any changes to the
certificates are lost as a result of restoring vManage; and you would have to reconfigure any certificates that
you had customized earlier.

Caution

The vManage NMS database is the repository for the overlay network device configurations, events, alarms,
and monitoring information. The vManage NMS database is stored on a separate virtual hard disk on the
vManage NMS server; specifically, it is stored on hard disk 2. Hard disk 1 contains the Viptela operating
system software.

We recommend that you set up periodic crash-consistent backups of the vManage NMS database. (In a
crash-consistent backup, all the VM's data are captured at exactly the same time.) Then, if the vManage NMS
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server fails, you simply create a new vManage NMS instance and attach the vManage NMS database backup
to that instance.

The procedures in this article each encompass both of the following scenarios:

• If you have a backup of the vManage NMS database, you create a new vManage NMS and attach the
disk that contains your backup database.

• If you do not have a backup of the vManage database, you create a new vManage NMS and create a new
virtual hard disk for the database.

Restore vManage NMS Using vSphere Client

1. Create a vManage VM instance. See Launch vSphere Client and Create a vManage VM Instance, in Create
a vManage VM Instance .

2. In the left navigation bar of the vSphere Client screen, select the vManage VM instance you just created,
and click Edit virtual machine settings.

The vManage - Virtual Machine Properties screen is displayed.

3. Click Add to add a new virtual disk, and click OK.
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The Add Hardware window opens with the Select a Disk screen displayed. If you have a backup of the
vManage NMS database, complete Step 4. If you do not have a backup database, skip to Step 5.

1. If you have a backup of the vManage NMS database, complete the following steps:

a. In the Select a disk screen, select Use an existing virtual disk, and click Next.
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The Select Existing Disk screen is displayed.

b. Click Browse.

Operations
65

Operations
Restore Cisco SD-WAN Manager



The Browse Datastores window opens and displays the datastores on the server

c. Navigate to the location of your backup database, and click OK.
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d. In the Select Existing Disk screen, click Next.
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The Advanced Options screen is displayed. Skip Step 5 and proceed to Step 6.

2. If you do not have an existing vManage NMS database, you must create a new virtual disk for the vManage
database:

a. In the Select a Disk screen, select Create a new virtual disk and click Next.
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The Create a Disk screen is displayed.

a. Enter a disk capacity for the vManage database of 100 GB, and click Next.

Operations
69

Operations
Restore Cisco SD-WAN Manager



The Advanced Options screen is displayed.

3. In the Advanced Options screen, select IDE for the virtual device node, and click Next.

Operations
70

Operations
Restore Cisco SD-WAN Manager



The Ready to Complete screen is displayed.

4. Click Finish.
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The data volume is added to the vManage NMS.

5. To verify that the new disk has been created, in the vManage Virtual Machine Properties screen, select
the Hardware tab. Hard disk 2—the virtual disk that stores the vManage database—is shown in the
hardware list.
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6. In the left navigation bar of the vSphere Client, select the vManage VM instance you just created, and
click Power on the virtual machine.
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The vManage virtual machine is powered on.

7. Select the Console tab to connect to the vManage console. The vManage console is displayed.

8. At the vManage login prompt, log in with the default username, which is admin, and the default password,
which is admin. The system prompts you to select the storage device to use.
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1. Select the appropriate storage device.

2. In response to the question
Would you like to format x?

:

• If you attached an existing disk with a backup of the vManage database, type n.

• If you created a new virtual disk for the vManage database, type y.

3. Configure the vManage NMS. See vManage NMS Initial Configuration .

4. Generate a certificate for the new vManage NMS. See Generate vManage Certificate .

5. Add the serial number of the new vManage NMS to all the vBond orchestrators in the overlay network,
as described later in this article.

Restore vManage NMS Using vSphere Web Client

1. Create a vManage VM instance. See Launch vSphere Client and Create a vManage VM Instance, in Create
a vManage VM Instance .

2. Log in to the vSphere Web Client.

3. Select the VM instance for your vManage NMS.
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4. Click the Manage tab, and click Edit. The Edit Settings screen is displayed with the Virtual Hardware tab
selected.

5. If you have a backup of the vManage NMS database, attach it to the new vManage VM. If you do not
have a backup database, skip to step 6 and create a new virtual disk for the database.

a. In the New device field at the bottom of the screen, click Select. A pop-up menu opens.
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b. From the pop-up menu, select Existing Hard Disk. The Select File window is displayed.
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c. In the Select File window, under Datastores, navigate to and select the appropriate .vmdk file, and
click

OK.

6. If you do not have an existing vManage NMS database, create a new virtual disk for the vManage NMS
database:

a. In the New device field at the bottom of the screen, click Select. A pop-up menu opens.

b. From the pop-up menu, select New Hard Disk.
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c. In the New Hard Disk field, enter a size for the new virtual disk of 100 GB.

Operations
79

Operations
Restore Cisco SD-WAN Manager



d. Click OK.

7. From the New Hard Disk section, under Virtual Device Node, select IDE 1, and click OK.
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1. From the vSphereWeb Client Navigator, select the datacenter that is hosting the VM and then select Open
Console from the menu. The vManage console is displayed.

2. At the vManage login prompt, log in with the default username, which is admin, and the default password,
which is admin. The system prompts you to select the storage device to use.

3. Select the appropriate storage device:
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1. In response to the question
Would you like to format x?

:

• If you attached an existing disk with a backup of the vManage database, type n.

• If you created a new virtual disk for the vManage database, type yto reformat the disk.

2. Configure the vManage NMS. See vManage NMS Initial Configuration .

3. Generate a certificate for the new vManage NMS. See Generate vManage Certificate .

4. Add the serial number of the new vManage NMS to all the vBond orchestrators in the overlay network,
as described below.

Add vManage NMS Serial Number to vBond Orchestrators

When you generate a certificate for a new vManage NMS with a new database, the serial number from the
certificate is automatically sent to the vBond orchestrators. However, when you create a new vManage NMS
and attach an existing database, you must manually send the new serial number to each vBond orchestrator
to overwrite the serial number of the previous vManage NMS.

If you have the management IP address for the vBond orchestrator, you can use vManage NMS to send the
serial number to each vBond orchestrator. Otherwise, you must use the CLI.

If you have the management IP address for the vBond orchestrator:

1. From the Cisco vManage menu, choose Configuration > Devices.
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2. Click Controllers.

3. Choose the desired Cisco vBond orchestrator.

4. For the desired Cisco vBond orchestrator, click ... and choose Edit.

5. Enter the management IP address, username, and password for the vBond orchestrator.

6. Click Save.

7. From the Cisco vManage menu, choose Configuration > Certificates.

8. In the Certificates window, click Controllers.

9. Click Send to vBond to send the new Cisco vManage certificate to the Cisco vBond orchestrator.

If you do not have the management IP address for the vBond orchestrator:

1. Find the serial number for the new vManage NMS:

a. From the Cisco vManage menu, choose Configuration > Certificates.

b. In the Certificates window, click Controllers.

c. Choose the Cisco vManage instance and make a note of the serial number that is displayed in the
Certificate Serial column.

2. From the Cisco vManage menu, choose Tools > SSH Terminal.

3. Choose the desired Cisco vBond orchestrator instance in the left pane, and enter the user name and
password to log in to it.

4. Enter the following command to send the certificate serial number for the new Cisco vManage instance
to the Cisco vBond orchestrator, where number is the serial number that you noted in Step 1:

request vsmart add serial-num number

Restrict Network Access for a Device
Table 25: Feature History

DescriptionRelease InformationFeature Name

If the location of the device goes beyond its
geographical boundary, you can restrict network
access to the device using Cisco SD-WAN Manager
operational commands. For more information, see the
Cisco Catalyst SD-WAN Monitor and Maintain
Configuration Guide.

Cisco IOS XE Catalyst
SD-WANRelease 17.6.1a

Cisco vManage Release
20.6.1

Geofencing

You can configure the geographical boundary of a
device using a Cisco System feature template.

Cisco IOS XE Catalyst
SD-WANRelease 17.7.1a

Cisco vManage Release
20.7.1

Added Support for
Configuring Geofencing
Using a Cisco System
Feature Template
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DescriptionRelease InformationFeature Name

Added support for Long-Term Evolution (LTE)
Advanced Network Interface Modules (NIMs) for
Cisco ISR 4000 routers.

Cisco IOS XE Catalyst
SD-WANRelease 17.8.1a

Added Support for LTE
Advanced NIM Modules

Make Your Device Invalid
You can make your device invalid should your device go beyond its target location.

1. From the Cisco Catalyst SD-WAN menu, choose Tools > Operational Commands.

2. For the desired device, click … and choose Make Device Invalid.

3. Confirm that you want to make the device invalid and click OK.

Bring Your Device Back to Valid State
1. From the Cisco Catalyst SD-WAN menu, choose Configuration > Certificates.

2. Choose the invalid device and look for the Validate column.

3. Click Valid.

4. Click Send to Controllers to complete the action.

Stop Data Traffic
You can stop data traffic to your device should your device exceed its target location.

1. From the Cisco Catalyst SD-WAN menu, choose Tools > Operational Commands.

2. For the desired device, click … and choose Stop Traffic.

3. Confirm that you want to stop data traffic to your device and click OK.

Perform a Factory Reset
If your device is outside its target boundary, you may need to perform a factory reset of your device.

The Factory Reset operational command is supported only for Cisco ISR 1000 series and Catalyst 8K devices.Note

For more information on geofencing, see the Cisco IOS XE Catalyst SD-WAN Systems and Interfaces
Configuration Guide.

1. From the Cisco Catalyst SD-WAN menu, choose Tools > Operational Commands.

2. For the desired device, click … and choose Factory Reset.

3. Choose one of the following options:

• Retain License: Wipes all the device settings and partitions except for licenses. Retain License is
a sub option to the factory-reset option.
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• Full Wipe factory-reset: Wipes all the device settings and partitions.

After a full-wipe operation, the device can only be booted up using a USB or
TFTP.

Note

4. Click Reset.

Run a Report
Table 26: Feature History

DescriptionRelease InformationFeature Name

You can schedule a report, download it as a PDF document,
and receive it as an email. The Reports menu has been
added to Cisco SD-WAN Manager.

Cisco vManage
Release 20.10.1

Cisco IOSXECatalyst
SD-WAN Release
17.10.1a

Reports

Before You Begin

Ensure that the email settings are configured in Cisco SD-WANManager for scheduling reports. This step is
required only if you want to schedule the report to be emailed.

Configure Email Settings
1. From the Cisco SD-WAN Manager menu, choose Administration > Settings.

2. Click Edit adjacent to the Alarm Notifications option.

3. Click Enabled.

4. Check the Email Settings check box.

5. Choose the security level for sending the email notifications. The security level can be None, SSL, or
TLS.

6. In the SMTP Server field, enter the name or the IP address of the SMTP server to receive the email
notifications.

7. In the SMTP Port field, enter the SMTP port number. For no security, the default port is 25; for SSL
it is 465; and for TLS it is 587.

8. In the From address field, enter the full email address to include as the sender in email notifications.

9. In the Reply to address field, enter the full email address to include in the Reply-To field of the email.
This address can be a no-reply address, such as noreply@cisco.com.

10. Check the Use SMTP Authentication check box to enable SMTP authentication to the SMTP server.

Operations
85

Operations
Run a Report



Enter the username and password to use for SMTP authentication. The default user email suffix is
appended to the username. The password that you type is hidden.

11. Click Save.

Run a Report
1. From the Cisco SD-WAN Manager menu, choose Reports.

2. Click Report Templates.

In the Executive Summary Report section, click the header to view a sample report. Use the scroll bar to
review the entire report. The following data is presented:

• Data metrics and summaries

• Graphical representation of the data (including heat maps, pie charts, and bar charts)

Note

3. In the Executive Summary Report section, click Create Report to configure parameters to build a
report.

DescriptionField

Enter a name for the reportEnter Report Name

ClickEdit adjacent to this field, and choose the sites for which you want
to generate the report.

Site

Choose the time range for which you want to generate the report.

Values: 7 Days, 30 days

Default: 30 days

Time Frame

Check this check box if you want to schedule the report to be emailed.Email Report

Enter up to a maximum of five email addresses.Enter Email

Click one of the schedule options.

Values: Run Now, Run Later (One-Time), Run Recurring

• If you clickRun Later (One-Time), enter the Start Date and Start
Time.

• If you clickRun Recurring, choose the frequency from theRepeats
drop-down list, and enter the Start Date and Start Time.

Schedule

4. Click Create Report.
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Run a Traceroute
1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.1 and earlier: From the Cisco SD-WANManager menu, chooseMonitor >
Network.

2. To choose a device, click the device name in the Hostname column.

3. Click Troubleshooting in the left pane.

4. In the Connectivity area, click Trace Route.

5. In the Destination IP field, enter the IP address of the corresponding device in the network.

6. From the VPN drop-down list, choose a VPN to use to reach the device.

7. From the Source/Interface for VPN drop-down list, choose the interface to use to send the traceroute
probe packets.

8. Click Advanced Options.

9. In the Size field, enter the size of the traceroute probe packets, in bytes.

10. Click Start to trigger a traceroute to the requested destination.

The lower part of the right pane displays the following information:

• Raw output of the path the traceroute probe packets take to reach the destination.

• Graphical depiction of the path the traceroute probe packets take to reach the destination.

From Cisco vManage Release 20.10.1, the Trace Route option can be accessed using one of these methods:

• Choose Monitor > Devices, click … adjacent to the device name, and choose Trace Route.

• In the Site Topology page, click a device or tunnel name, and then click Trace Route in the right
navigation pane.

Security Monitoring
Table 27: Feature History

DescriptionRelease InformationFeature Name

You can view traffic, CPU,
memory usage, health and
reachability of UTD.

Cisco IOS XE Catalyst SD-WAN
Release 17.5.1a

Cisco vManage Release 20.5.1

Enhanced Security Monitoring on
Cisco Catalyst SD-WAN

View Traffic, CPU, and Memory Usage
1. From the Cisco SD-WAN Manager Monitor > Devices page, select the device.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManagerMonitor >Network page,
select the device.
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2. Under Security Monitoring in the left pane, select one of the UTD features Intrusion Prevention, URL
Filtering, and so on.

3. By default, the traffic counter graph is displayed.

You can also customize the time range to see traffic usage for specific time ranges such as Real Time,
1h, 3h or even specify a Custom time range. By default, a time range of 24h is displayed. The time range
cannot be more than 365 days.

4. To view CPU or memory usage, do the following:

• To view CPU usage, click UTD Stats: CPU Usage.

• To view memory usage, click UTD Stats: Memory Usage.

View the Health and Reachability of UTD
1. From the Cisco SD-WAN Manager Monitor > Devices page, select the device.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManagerMonitor >Network page,
select the device.

2. Under Security Monitoring in the left pane, select one of the UTD features such as Intrusion Prevention,
URL Filtering, and so on.

3. For all features, the health of UTD is displayed as one of the following:

• Down: For example: UTD is not configured.

• Green: UTD is healthy.

• Yellow: For example: High memory usage.

• Red: For example: One or more Snort instances are down.

If you configured UTD on the device and the status is not green, contact Cisco TAC for assistance.

4. Depending on the UTD feature that you choose, the following additional information is displayed:

StatusUTD Feature

Package Version

IPS Last Updated

Reason for last update status

Intrusion Prevention

Cloud ReachabilityURL Filtering

AMP Cloud Reachability Status

TG Cloud Reachability Status

Advanced Malware Protection

Umbrella Registered VPNs

DNSCrypt

Umbrella DNS Redirect
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SSH Terminal
Use the SSH Terminal screen to establish an SSH session to a router. From an SSH session, you can issue
CLI commands on a router.

Establish an SSH Session to a Device

To establish an SSH session to a device:

1. From the Cisco SD-WAN Manager menu, choose Tools > SSH Terminal.

2. Select the device on which you wish to collect statistics:

a. Select the device group to which the device belongs.

b. If needed, sort the device list by its status, hostname, system IP, site ID, or device type.

c. Click the device to select it.

3. Enter the username and password to log in to the device.

You can now issue CLI commands to monitor or configure the device.

Upgrade Cisco Catalyst SD-WAN Manager Cluster
Table 28: Feature History

DescriptionRelease InformationFeature Name

This feature outlines the upgrade
procedure for Cisco vManage
servers in a cluster to Cisco
vManage Release 20.3.1.

To upgrade Cisco vManage nodes
in a Cluster, use the Tools > SSH
Terminal screen.

Cisco IOS XE Catalyst SD-WAN
Release 17.3.1a

Cisco vManage Release 20.3.1

Cisco SD-WAN Manager Cluster
Upgrade

This section describes how to upgrade Cisco SD-WAN Manager in a cluster.

You can upgrade directly from Cisco vManage 20.3.1 or later releases to Cisco vManage Release 20.6.1. To
upgrade from earlier releases, first upgrade to Cisco vManage 20.4.2 or Cisco vManage Release 20.5.1.

If you are upgrading a Cisco SD-WAN Manager cluster deployment from Cisco vManage Release 20.3.1 or
later to Cisco vManage Release 20.5.1 or later, you must do it through the CLI.

Before You Begin

Before you upgrade Cisco SD-WANManager nodes to Cisco vManage Release 20.6.1 or later releases, verify
the following:

• Ensure that the internal user account vmanage-admin is not locked for any server that you are upgrading.

You can check the status of this admin account by pushing a template to the devices that are connected
to the server. The push fails if the account is locked. In such a scenario, you can unlock the account by
using the request aaa unlock-user vmanage-admin command.
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• Ensure that PKI keys have been exchanged between the servers that you are upgrading.

To do so, ensure that the control connections are in the UP state on the servers and restart the application
server.

• Ensure that the out-of-band IP address of each server is reachable.

• Ensure that the Cisco SD-WAN Manager UI is accessible on all servers in the cluster.

• Ensure that DCA is running on all nodes in the cluster.

To do so, use the request nms data-collection-agent status command and ensure that the status value
shows running for each node.

To start DCA, if needed, use the request nms data-collection-agent start command.

If these prerequisites are not met or if another error occurs during the upgrade, the activation of the image
fails and a file named upgrade-context.json is created in the /opt/data/extra-packages/image-version folder on
each node in the cluster. You can provide this file to your Cisco representative for assistance with resolving
the issue.

Note

If you are upgrading to Cisco vManage Release 20.6.1 or later releases from a six-node Cisco SD-WAN
Manager cluster deployment in which not all services are running on all nodes, contact your Cisco support
representative before performing the upgrade.

1. Take snapshots of all the Cisco SD-WAN Manager servers. Take a backup of the configuration database
and save it in a location outside of the Cisco SD-WAN Manager server using the following command:

request nms configuration-db backup path path_and_filename
2. Ensure that Cisco vManage Release 18.3 or later is installed.

3. For upgrades fromCisco vManage Release 20.3.1 or later, copy the current image to each Cisco SD-WAN
Manager server in the cluster and install the image on each Cisco SD-WANManager server by using the
following command. Do not activate the image at this time.

request software install path
4. For upgrades from Cisco vManage Release 20.3.1 or later, activate the current image on each Cisco

SD-WAN Manager server using the following command. All servers reboot simultaneously.

request software activate version
5. You must upgrade the configuration database when upgrading from one of the following:

• Cisco SD-WAN Manager Release 18.4.x or 19.2.x to Cisco SD-WAN Manager 20.3.x or 20.4.x

• Cisco SD-WAN Manager Release 20.3.x or 20.4.x to Cisco SD-WAN Manager Release 20.5.x or
20.6.x

• Any Cisco SD-WAN Manager release to Cisco vManage Release 20.10.1 or later
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• Starting from Cisco vManage Release 20.1.1, before upgrading the configuration database, ensure that
you verify the database size. We recommend that the database size is less than or equal to 5 GB. To
verify the database size, use the following diagnostic command:

request nms configuration-db diagnostics
• When you upgrade the configuration database, ensure that you have activated the current image on each
Cisco SD-WAN Manager server in the cluster as described in the previous step. In addition, ensure that
all services except the application server and configuration-db services are running on these servers by
entering the request nms all status command on each server.

Note

To upgrade the configuration database, do the following:

a. To determine which node to upgrade, enter the request nms configuration-db status command on
each node. In the output look for the following:
Enabled: true
Status: not running

After activating a new image on a Cisco SD-WAN Manager host server, the server reboots. After the reboot,
for approximately 30 minutes, the output of the request nms configuration-db status command shows
Enabled: false even on a node that has the configuration database enabled, while NMS services are being
migrated to a containerized form.

Note

b. On the node to upgrade, as determined in the previous step, enter the following:

request nms configuration-db upgrade

• Enter this command on one node only.

• Do not enter this command if you are upgrading from Cisco vManage Release 20.5.x to Cisco vManage
Release 20.6.1 or later.

Note

6. Enter your login credentials, if prompted. Login credentials are prompted in releases earlier than Cisco
vManage Release 20.3.1 if all the Cisco SD-WAN Manager servers establish control connection with
each other. After a successful upgrade, all the configuration database services are UP across the cluster,
and the application server is started.

You can check the database upgrade logs at the following location:
vmanage-server:/var/log/nms/neo4j-upgrade.log.

For information about how to upgrade Cisco SD-WANManager clusters by using the Cisco SD-WANManager
GUI, see the Upgrade the Software Image on a Device section in Cisco Catalyst SD-WAN Monitor and
Maintain Configuration Guide.
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View Application Health Dashlet
Minimum supported release: Cisco vManage Release 20.10.1

You can view a summary of the health of all applications on the Application Health dashlet on Monitor
Overview dashboard.

You can view the usage of applications across all sites in a graphical format. The graph indicates whether the
application performance is Good, Fair, or Poor based on the application Quality of Experience (QoE).

Starting fromCisco Catalyst SD-WANManager Release 20.12.1, a bar graph displays the application bandwidth
usage information and changes in bandwidth from the last time period for each application. You can filter the
applications based on the health status using the drop-down list for Good Performing Applications, Fair
Performing Applications, and Poor Performing Applications.

Click View Details to open the Monitor > Applications window.

View Admin-Tech Files
You can perform any of the following operations after the admin-tech file is generated:

• View the list of the generated admin-tech files.

• Copy the selected admin-tech files from your device to Cisco SD-WAN Manager.

• Download the selected admin-tech files to your local device.

• Delete the selected admin-tech files from Cisco SD-WAN Manager, the device, or both.

1. From the Cisco SD-WAN Manager menu, choose Tools > Operational Commands.

2. For the desired device, click . . . and choose View Admin Tech List.

A tar file appears that contains the admin-tech contents of the device that you selected earlier. This file
has a name similar to ip-address-hostname-20210602-032523-admin-tech.tar.gz,
where the numeric fields are the date and the time.

You can view the list of the generated admin-tech files and decide which files that you want to copy to
Cisco SD-WAN Manager.

3. Click the Copy icon to copy the admin-tech file from the device to Cisco SD-WAN Manager.

A hint appears letting you know that the file is being copied from the device to Cisco SD-WANManager.

4. After the file is copied from the device to Cisco SD-WANManager, you can click the Download icon to
download the file to your local device.

You can view the admin-tech file size after the file is copied to Cisco SD-WAN Manager.

5. After the admin-tech file is successfully copied to Cisco SD-WAN Manager, you can click the Delete
icon and choose which files to delete from Cisco SD-WAN Manager, the device, or both.

For more information on admin tech and technical support commands, see request admin-tech and show
tech-support.

Operations
92

Operations
View Application Health Dashlet

https://www.cisco.com/c/en/us/td/docs/routers/sdwan/command/sdwan-cr-book/operational-cmd.html#wp2938418477
https://www.cisco.com/c/en/us/td/docs/routers/sdwan/command/sdwan-cr-book/operational-cmd.html#wp2033577503
https://www.cisco.com/c/en/us/td/docs/routers/sdwan/command/sdwan-cr-book/operational-cmd.html#wp2033577503


View Device Interfaces
To view information about interfaces on a device:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device by clicking its name in the Hostname column.

3. Click Interface in the left pane. The right pane displays interface information for the device.

The upper part of the right pane contains:

• Chart Options bar—Located directly under the device name, this bar includes:

• Chart Options drop-down—Click Chart Options to choose how the data should be displayed.

• IPv4 & IPv6 drop-down—Click IPv4 & IPv6 to choose the type of interfaces to view. The
information is displayed in graphical format. By default, the graph is Combined, showing interfaces
on which both IPv4 and IPv6 addresses are configured. To view IPv4 and IPv6 interfaces in separate
graphs, select the Separated toggle button.

• Time periods—Click eitherReal Time, a predefined time period, or a custom time period for which
to view the data.

• Interface information in graphical format.

• Interface graph legend—Choose an interface to display information for just that interface.

The lower part of the right pane contains:

• Filter criteria.

• Interface table, which lists information about all interfaces. By default, the first six interfaces are displayed.
The graphical display in the upper part of the right pane plots information for the selected interfaces.

• Check the check box to the left to select and deselect interfaces. You can select and view information
for a maximum of 30 interfaces at a time.

• To rearrange the columns, drag the column title to the desired position.

• For cellular interfaces, click the interface name to view a detailed information about the cellular
interface.

To view interface status and interface statistics, see show interface and show interface statistics.

View Device Status in the Overlay Network
You have the following options to view the status of a device in the overlay network.

Use the Dashboard Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview.
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Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, chooseDashboard >
Main Dashboard.

2. For releases before Cisco vManage Release 20.6.1, click the upward or downward arrow next to WAN
Edge.

For Cisco vManage Release 20.6.1 and later, click the number representing the number of WAN Edge
devices.

3. To know the status of the WAN edge device, see the Reachability column in the dialog box that opens.

Use the Geography Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Geography.

2. Click Filter and choose WAN Edge under Types.

3. Click the router icon to check its status.

Use the Network Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Locate the WAN edge router that you want to view the status for. You can either scroll through the list
of devices in the device table or enter a keyword in the search bar.

3. Click the relevant WAN edge router under the Hostname column. The System Status screen opens by
default.

View the Geographic Location of Your Devices
Use the Geography window in Cisco SD-WAN Manager to view information about the Cisco Catalyst
SD-WAN devices and links in the overlay network. The Geography window provides a map displaying the
geographic location of the devices in the overlay network.

The browser on which you are running Cisco SD-WAN Manager must have internet access. If you do not
have internet access, ensure that the browser has access to "*.openstreetmaps.org."

Note

To view the geographic location of the devices in the overlay network:

1. From the VPN Group list, choose a VPN group.

2. From the VPN Segment list, choose a VPN segment.

3. Set filters.

Set Map Filters

To select the devices and links you want to display on the map:
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1. From the Cisco SD-WAN Manager menu, choose Monitor > Geography.

2. Click Filter.

3. From the options that display, choose the device group. By default, the group All is selected and displays
all devices in the overlay network. The group No Groups displays devices that are not part of a device
group. If all devices are in a group, the No Groups option is not displayed.

4. Choose the devices you want to view. By default, the map displays all device types including edge devices,
Cisco SD-WAN Validator, Cisco SD-WAN Controller, and Cisco SD-WAN Manager.

5. Choose the state of control and data links. By default, the map displays all control and data connections.

6. Close the Filter box by moving the cursor outside the box.

The map dynamically updates to display your selections.

View Device Information

To view basic information for a device, hover over the device icon. A pop-up box displays the system IP,
hostname, site ID, device type, and device status.

To view detailed information for a device, double-click the device icon. Click Device Dashboard, Device
Details, SSH Terminal, Site Topology, or Links to view more details for the device.

Note the following about links:

• A thin blue line displays an active control connection between two devices.

• A bold blue line displays multiple active connections between devices.

• A dotted red line displays a control connection that is down.

• A bold dotted red line displays multiple control connections that are down.

• A thin green line displays an active data connection between two devices.

• A bold green line displays multiple active data connections.

• A dotted red line displays a data connection that is down.

• A bold dotted red line displays multiple data connections that are down.

• A thick gray line displays an active consolidated control and data connection between two devices.

If you hover over the line, a hover box tells you if the connection is up or down.

Configure and View Geographic Coordinates for a Device

To configure the geographic coordinates for a device, use the System Feature template underConfiguration >
Templates.

If the Cisco Catalyst SD-WAN device is not attached to a configuration template, you can configure the
latitude and longitude directly on the device:

1. From the Cisco SD-WAN Manager menu, choose Tools > SSH Terminal.

2. Choose a device from the left pane. The SSH Terminal window opens in the right pane.

3. Enter the username and password to log in to the device.
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4. Use the show system status command to determine whether the device is attached to a configuration
template:
Device# show system status...

Personality: vedge
Model name: vedge-cloud
Services: None
vManaged: false
Commit pending: false
Configuration template: None

In the output, check the values in the vManaged and Configuration template output fields. If the vManaged
field is false, the device is not attached to a configuration template, and the Configuration template

field value is None. For such a device, you can configure the GPS coordinates directly from the CLI. If
the vManaged field is true, the Cisco SD-WANManager server has downloaded the device configuration,
and the Configuration template field value displays the name of the configuration template. For such
a device, you cannot configure the GPS coordinates directly from the CLI. If you attempt to do so, the
validate or commit commands fails with the following message:
Aborted: 'system is-vmanaged': This device is being managed by the vManage. Configuration
through the CLI is not allowed.

5. Enter configuration mode:

For Cisco vEdge devices:
Device# config

Device(config)#

For Cisco IOS XE Catalyst SD-WAN devices:
Device# configure-transaction

Device(config)#

6. Configure the latitude and longitude for the device.
Device(config)# system gps-location latitude

degrees.minutes.seconds
Device(config-system)# gps-location longitude

degrees.minutes.seconds

7. Save the configuration.
Device(config-system)# commit

Device(config-system)#

View Network Site Topology
Table 29: Feature History

DescriptionRelease InformationFeature Name

You can now view the topology diagram of a site in Cisco
SD-WAN Manager.

Cisco IOSXECatalyst
SD-WAN Release
17.8.1a

Cisco vManage
Release 20.8.1

Site Topology
Visualization in Cisco
SD-WAN Manager
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DescriptionRelease InformationFeature Name

You can view information about the health of devices and
tunnels in the topology.

Cisco IOSXECatalyst
SD-WAN Release
17.9.1a

Cisco vManage
Release 20.9.1

Site Topology
Visualization in Cisco
SD-WAN Manager
(Phase II)

You have the following options to view the topology of a site.

Use the Devices Window

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

2. Find the corresponding Cisco IOS XE Catalyst SD-WAN device in the table and click the value in the
Site ID column adjacent to this device name.

Alternatively, click the device name in the Hostname column, and then click the Site ID value in the
device dashboard.

Cisco SD-WAN Manager displays the topology of the site.

Use the Geography Window

1. From the Cisco SD-WAN Manager menu, choose Monitor > Geography.

2. Click the corresponding Cisco IOS XE Catalyst SD-WAN device in the map.

3. Click the Site ID value.

Cisco SD-WAN Manager displays the topology of the site.

View Network-Wide Path Insight
Table 30: Feature History

DescriptionRelease InformationFeature Name

This feature lets you view
network-wide path tracing
information using Cisco SD-WAN
Manager.

Cisco IOS XE Catalyst SD-WAN
Release 17.4.1a

Cisco vManage Release 20.4.1

Network-Wide Path Insight in
Cisco SD-WAN Manager

You can configure network-wide
path insight options to include
additional filters and parameters for
traces and DNS domain discovery,
and view new displays for
application flows, trace views, and
app trends.

Cisco IOS XE Catalyst SD-WAN
Release 17.6.1a

Cisco vManage Release 20.6.1

Network-Wide Path Insight in
Cisco SD-WAN Manager
Enhancements
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DescriptionRelease InformationFeature Name

This feature provides enhancements
to the Network-Wide Path Insight
feature to include the collection and
display of insight information,
trace-level insight information, path
insight information, and detailed
application trace information.

Cisco IOS XE Catalyst SD-WAN
Release 17.9.1a

Cisco vManage Release 20.9.1

Network-Wide Path Insight in
Cisco SD-WAN Manager
Enhancements

This feature provides enhancements
to the Network-Wide Path Insight
feature to include support for
multiple VPNs for traces, the ability
to generate synthetic traffic for
traces, options for grouping trace
information, support for auto-on
tasks, new information on insight
displays, and expanded insight
summaries.

Cisco IOS XE Catalyst SD-WAN
Release 17.12.1a

Cisco Catalyst SD-WAN Manager
Release 20.12.1

Network-Wide Path Insight in
Cisco SD-WAN Manager
Enhancements

Information About Network-Wide Path Insight

Network-wide path insight provides on-demand end-to-end application-tracing serviceability in the Cisco
Catalyst SD-WAN network. You can obtain and view detailed information at the packet level, application
level, domain level, flow level, and network level. This information provides comprehensive insights into the
operations of your network and can assist with performance analysis, planning, and troubleshooting.

Supported Devices

This feature is supported on Cisco IOS XE Catalyst SD-WAN devices.

Overview

With the Network-Wide Path Insight feature, Cisco SD-WAN Manager lets you initiate application tracing
and displays the trace results collected from multiple devices in a consolidated view.

Benefits of Network-Wide Path Insight

• End-to-end bidirectional network path visibility for applications over Cisco Catalyst SD-WAN fabric

• Real-time network performance measurement and visibility for applications

• Feature execution insight on Cisco Catalyst SD-WAN device. Example: QoS, SD-WAN Policy, SAIE
flow, and SD-WAN overlay tunneling

In Cisco vManage Release 20.7.x and earlier releases, the SD-WAN Application
Intelligence Engine (SAIE) flow is called the deep packet inspection (DPI) flow.

Note

• Validation of application policies
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Use Cases for Network-Wide Path Insight

• Verification of network and policy design when deploying a new site, VPN, or application

• Daily monitoring of network, application, and policy operations

• Collection of information for diagnosing operational issues

Restrictions for Network-Wide Path Insight

• Support for this feature on Cisco vEdge devices is limited to interoperation with Cisco IOS XE Catalyst
SD-WAN devices.

• Only UDP and TCP can be traced using the Network-Wide Path Insight feature.

• This feature is not supported on VPN 0 or the transport VPN.

• This feature is not supported when extranet VPNs or service chain policies are configured in your Cisco
Catalyst SD-WAN deployment.

• Not all packet traces are captured per flow. The system takes samples for the most typical packets
automatically.

• Flow records do not display the complete history of flow path and hop information for releases before
Cisco vManage Release 20.6.1.

• Mixed application and default policies are not supported for releases before Cisco vManage Release
20.6.1.

• You canmonitor a maximum of two traces per device, and 10 concurrent active traces per Cisco SD-WAN
Manager tenant.

• The following table shows the number of active flows that can be monitored, and the supported number
of completed flows. Tracing stops when the monitoring limit is reached.

Number of Supported Number of
Completed

Number of Supported Active
Flows

Release

1,00050 to 100 per device, depending
on the Cisco IOS XE Catalyst
SD-WAN device

Releases before Cisco vManage
Release 20.6.1

10,00050 to 100 per device, depending
on the Cisco IOS XE Catalyst
SD-WAN device

Cisco vManage Release 20.6.1
through Cisco vManage Release
20.8.x

60,00050 to 100 per device, depending
on the Cisco IOS XE Catalyst
SD-WAN device

Cisco vManage Release 20.9.1
and later releases

• In releases before Cisco vManage Release 20.6.1, flow trace does not show the complete network path
if the following optimizations are enabled:

• UTD

• TCP
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• SSL

• DRE

• In the Application Stats graphs that are available in the Insight Summary > Overview tab, you cannot
choose aWAN color for Cisco ASR 1000 Series Routers and Cisco Catalyst 8500 Series Edge Platforms.

Prerequisites for Network-Wide Path Insight

Ensure that the Data Stream option is enabled in Cisco SD-WAN Manager. To enable this option, follow
these steps:

1. From the Cisco SD-WAN Manager menu, choose Administration > Settings.

2. For the Data Stream option, click View.

3. Click Edit and choose Enable.

4. Click Save.

If you try to set up a trace path when Data Stream is not enabled, you are prompted to enable it.Note

View Network-Wide Path Insight for Releases Before Cisco vManage Release 20.6.1

This section describes how to perform network-wide path insight tracing in releases before Cisco vManage
Release 20.6.1. To start a trace, follow these steps:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Network Wide Path Insight.

2. In the Policy area, choose Site ID(*) from the drop-down list. Ensure that you only choose a site that
you have access to.

3. In the VPN(*) field, choose a VPN ID from the drop-down list. Only VPNs associated with the chosen
site are listed.

4. (Optional) Enter the Source/ Destination IP Addresses.

5. (Optional) Choose the Application from the drop-down list.

6. (Optional) Specify the required Trace Duration in minutes. The default trace duration is 60 minutes
and the maximum duration supported is 1440 minutes.

7. (Optional) Choose Device and Source Interface from the drop-down list.

8. (Optional) Choose Protocol from the drop-down list. TCP and UDP protocols are supported. The All
option indicates both UDP and TCP protocols.

9. (Optional) Choose DSCP from the drop-down list.

10. Click Start to initiate a path trace. A dialog box displays the Trace ID, Start time of the trace, and all
the details such as their IP addresses and trace status of the started devices.
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To stop an ongoing trace before the timer expired, click Stop. You can also stop a trace from theTrace section.Note

View Network-Wide Path Insight for Cisco vManage Release 20.6.1 and Later Releases

This section describes how to perform network-wide path insight tracing fromCisco vManage Release 20.6.1.

Tracing provides detailed information about application issues and can discover domains and applications
that run in domains. You can configure a variety of options to specify the tracing that you need and view
detailed information about trace flows.

To start a trace, follow these steps:

1. From the Cisco SD-WAN Manager menu, choose Tools > Network Wide Path Insight.

From Cisco Catalyst SD-WANManager Release 20.12.1, you can also start a trace by choosing Create
a Trace from the Monitor > Overview page.

In Cisco vManage Release 20.6.x and earlier releases, Network Wide Path Insight is part of the Monitor
menu.

Note

2. Perform one of the following actions:

• From Cisco vManage Release 20.6.1 through Cisco vManage 20.11.x:

a. (Optional) In the Trace area, check the Enable DNS Domain Discovery check box to enable
DNS domain discovery for network-wide path insight.

b. Click New Trace.

• From Cisco Catalyst SD-WAN Manager Release 20.12.1:

a. Click New Trace.

b. (Optional) In the Trace area, check the Enable DNS Domain Discovery check box to enable
DNS domain discovery for network-wide path insight, or continue to Step 3.

When Enable DNS Domain Discovery is enabled, DNS snooping is used to discover DNS domains and the
apps that are running in the discovered domains. You can then monitor the domains under the Application
option to obtain information about health, trends, and metrics.When this option is disabled, the trace monitors
the application flows based on the criteria and filters that you specify.

Enabling this option provides deep insight information for DNS domains, especially in Cisco Catalyst SD-WAN
Cloud OnRamp for SaaS and Direct Internet Access (DIA) deployments. You can check the discovered
domains for information about DNS domain queries that are running, and then start a trace to probe the traffic
in these domains.

Note

3. (Optional) In the Trace Name field, enter a name for the trace.
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If you do not enter a name, the system assigns the name trace_ID, where ID is the system-generated
identifier of the trace.

4. In the Trace Duration field, enter the number of minutes for which the trace lasts.

The minimum value is 1. The maximum value is 1440 (24 hours). The default value is 60.

5. In the Filters area, perform these actions:

a. In the Site ID field, enter the ID of the Cisco Catalyst SD-WAN network site in which to perform
the trace.

b. From theVPN drop-down list, choose the service VPN for the trace to monitor. From Cisco Catalyst
SD-WAN Manager Release 20.12.1, you can choose up to 64 VPNs.

c. (Optional. This option is applicable only if DNS domain discovery is disabled.) In the Source
Address/Prefix field, enter the source IPv4 or IPv6 IP address and the prefix of flows for the trace
to monitor. If you leave this field blank, the trace monitors flows with any source address or prefix.

d. (Optional. This option is applicable only if DNS domain discovery is disabled.) In the Destination
Address/Prefix field, enter the destination IPv4 or IPv6 IP address and prefix of flows for the trace
to monitor. If you leave this field blank, the trace monitors flows with any destination address or
prefix.

e. (Optional. This option is applicable only if DNS domain discovery is enabled.) In the Client
Address/Prefix field, enter the source IPv4 or IPv6 IP address or prefix of flows for the trace to
monitor. If you leave this field blank, the trace monitors flows with any source address or prefix.

f. (Optional. The Application option applies only if DNS domain discovery is disabled.) Click one
of the following options, then click the field under the option and use the check boxes that appear
to choose the applications or application groups for the trace to monitor:

• Application: Choose this option to designate specific applications for the trace to monitor.

• Application Group: Choose this option to designate specific application groups for the trace
to monitor. The trace then monitors all the applications that an application group includes.

For example, if you choose the application group ms-cloud-group, all the applications that this
group includes are monitored. These applications are ms-office-365, ms-services, ms-teams,
and more.

If you do not choose an option, the trace monitors all the applications.

To remove an application or application group from this field, clickX adjacent to the corresponding
application or application group name.

6. (Optional) If DNS domain discovery is not enabled, click the Expand icon to expand the Advanced
Filters area and perform the following actions, as needed, to configure specific items for the trace to
monitor.

a. From the Device drop-down list, choose one or more devices for the trace to monitor by checking
the check box for each device.

If you do not choose a device, the trace monitors all devices for the site that you specified in Step
5, on page 102.

b. From the Source Interface drop-down list, choose the source interface of traffic for the trace to
monitor.
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If you do not choose a source interface, the trace monitors traffic from all source interfaces in the
VPN that you specified in Step 5, on page 102.

c. In the Source Port field, enter the source port number of traffic that the trace should monitor. The
trace monitors traffic that flows from this port number.

If you do not choose a source port, the trace monitors traffic for all source ports.

d. In the Destination Port field, enter the destination port number of traffic for the trace to monitor.
The trace monitors traffic that flows to this port number.

If you do not choose a destination port, the trace monitors traffic for all destination ports.

e. From the Protocol drop-down list, choose the traffic protocol type for the trace to monitor.

If you do not choose a protocol, the trace monitors traffic for all supported protocols.

f. From the DSCP drop-down list, choose the DSCP type for the trace to monitor. The DEFAULT
selection indicates DSCP0.

If you do not choose a DSCP type, the trace monitors traffic for all DSCP types.

7. (Optional) Click the Expand icon to expand the Monitor Settings area and perform these actions:

a. (From Cisco vManage Release 20.9.1) Click QoS Insight to have the trace include application,
VPN, interface, and queue-level throughput and drop-rate metrics for all traffic.

This option is enabled by default.

b. Click ART Visibility to have the trace include the application response time (ART) metrics for
TCP traffic. These metrics include client network delay (CND) and server network delay (SND)
information.

This option is enabled by default.

c. Click App Visibility to have the trace use the SD-WAN Application Intelligence Engine (SAIE)
flow to discover applications and application groups.

In Cisco vManage Release 20.7.x and earlier releases, the SAIE flow is called the deep packet inspection
(DPI) flow.

Note

If you chose applications or application groups in Step 5, on page 102, this option is enabled
automatically.

If DPI is not enabled, we recommend that you enableApp Visibility to ensure that flows are mapped
to the correct applications. Enabling this option authorizes Network-Wide Path Insight to enable
DPI in the first hop router of the trace for the duration of the trace.

d. Click DIA Visibility to enable the viewing of downstream information from direct internet access
flows, beginning with the first flow.

This option is enabled by default if DNS domain discovery is enabled.

This option does not affect the applications that are transported over a Cisco Catalyst SD-WAN
tunnel.
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If you do not enable this option, the device discovers direct internet access traffic automatically,
but it can take some time for this discovery to begin.

e. ClickHub WAN Visibility (orWANVisibility for releases from Cisco Catalyst SD-WANManager
Release 20.12.1.) when starting a trace to have the trace includes flows that are initiated in theWAN
to LAN direction.

By default, a trace monitors flows that are initiated in the LAN to WAN direction.

For releases before Cisco Catalyst SD-WAN Manager Release 20.12.1, if DNS domain discovery
is enabled, this option is enabled by default and cannot be disabled. For releases from Cisco Catalyst
SD-WANManager Release 20.12.1, this option is disabled by default in all cases and can be enabled
as needed.

~~

Because traffic typically flows from a spoke to a hub, we recommend that you start a trace from a spoke site.Note

f. Click Sampling to enable sampling when tracing, which causes the trace to capture flows at the
specified interval.

In the Sampling Interval field that appears, enter the time interval, in seconds, between samples.
For example, if you enter 100, one flow will be traced every 100 seconds even if there are multiple
other flows.

Theminimum sampling interval value is 1 second. Themaximum value is 86400 seconds (24 hours).
The default value is 60.

The sampling options can help extend the monitoring period of a trace by increasing the time that
it takes it to reach the maximum number of flows in a trace.

8. (Optional) FromCisco Catalyst SD-WANManager Release 20.12.1, click theExpand icon and perform
the following actions in the Synthetic Traffic area to enable synthetic traffic.

Synthetic traffic helps verify network design. When a new site is onboarded or an existing site
configuration is changed, it is important to validate whether applications work as designed and as
intended. Enabling synthetic traffic generates sample user traffic that you can evaluate with other
network-wide path insight features to check whether applications are working as expected.

Synthetic traffic starts when the trace starts and stops when the trace stops. After the trace stops, you
can see the information about synthetic traffic flows in theCompleted Flows tab, and filter information
on that tab to see information that only relates to synthetic traffic.

a. In the URL field, enter the URL to which a router should send synthetic traffic, for example,
https://www.cisco.com.

b. In the VPN field, choose a service VPN on which to start synthetic traffic. The VPNs that are
available are based on the VPNs that you chose in the Filters area.

c. In the DNS Server field, enter the IP address of the DNS server for translating the URL.

We recommend that you enter the IP address of your organization’s DNS server so that that the
synthetic traffic flows to the same destination as the actual user traffic.

d. From the DSCP drop-down list, choose the DSCP to use for the synthetic traffic.
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e. In the Interval field, enter how often, in minutes, the synthetic traffic is sent to the URL during the
duration of the trace. For example, if you enter an interval of 2, synthetic traffic is sent every 2
minutes. The minimum values is 1.

f. (Optional) Click the plus sign icon and repeat these steps to add another synthetic traffic instance.

g. Click Save.

9. (Optional) From Cisco Catalyst SD-WAN Manager Release 20.12.1, click the Expand icon to expand
the Grouping Fields area and configure the following options.

By default, information on the App Performance Insight tab on the Insight Summary display is
grouped by application. Additional options area let you group information into smaller groups so that
you can refine the display of information to meet your needs.

• Check the Client Prefix check box to additionally group information by client prefix.

• Check the Server Prefix check box to additionally group information by server prefix.

• Check the Source SGT check box to additionally group information by source security group tag
(SGT).

10. Click Start to initiate the trace.

The Start Trace window displays information about the trace, including the trace ID, the start time of
the trace, and related details such as the IP addresses and trace status of the started devices.

11. Close the Start Trace window.

The trace is displayed in the list of traces in the Tools > Network Wide Path Insight window.

In Cisco vManage Release 20.6.x and earlier releases, the list of traces is available in theMonitor >Network
Wide Path Insight page.

Note

Create Auto-On Task

The auto-on task feature is available from Cisco Catalyst SD-WAN Manager Release 20.12.1.Note

An auto-on task monitors your network for events that you choose and automatically runs a trace if an event
is detected.

An auto-on task monitors the network for a period that you specify. Each trace that a task runs lasts for 5
minutes. To avoid congestion from multiple traces running simultaneously, for each site that is monitored,
there is a ½ hour interval after a trace starts before the next one begins.

Options for traces that an auto-on task generates are preconfigured and cannot be changed.

An auto-on task is useful if you have identified or suspect a potential or intermittent issue in your network.
For example, if you have identified intermittent SLA violations, instead of manually monitoring the network
and manually starting a trace when you see an SLA violation, you can create a task that automatically starts
traces when SLA violations are detected.
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1. From the Cisco SD-WAN Manager menu, choose Tools > Network Wide Path Insight.

2. Click New Auto-on Task.

3. In the Task Name field, enter a name for the task.

4. From the Select Event drop-down list, choose either or both of the following events that, when detected,
start a trace:

• QoS Congestion: Congestion on the nondefault QoS queue of an interface.

• SLA Violation: Traffic outside of the parameters that are defined by a service level agreement (SLA),
for example, traffic latency exceeding predefined criteria.

5. (Optional) From the Select Site drop-down list, choose the name of one or more Cisco Catalyst SD-WAN
network sites in which to perform the trace.

If you do not choose a network site, the task monitors all the sites.

6. In the Select Duration field, enter the number of hours the task lasts for.

The task monitors your network for the selected events during this duration.

Enter a number from 1 through 168.

7. Click Start.

The task appears in the table of auto-on tasks. This table provides the following information and options
for each task and each trace that the task starts:

• Task name: Task trace name. This field also includes the Insight Summary link, which lets you
see more information about the traces that the task started. See Insight Summary, on page 116.

• Task ID: System-generated identifier of the task or trace.

• Event(s): The event or events that you configured to start a trace, or the events that triggered a trace.

• Site(s): The name of each site that the task monitors, or the name of the site in which a trace ran.

• State: Active means that the task is live or a trace is running. Finished means that the task or trace
has completed.

• Start Time: Date and time at which you started the task or that a trace started.

• Duration: Number of hours that a task or trace is live or ran.

• Stop Time: Date and time at which the task or trace ended.

• Actions:

• Click Delete to remove a task or trace from the table.

• Click Stop to stop an active task. Note that a stopped task cannot be restarted.

Trace

The path trace instances appear with unique trace IDs in the Trace History area (in releases before Cisco
vManage Release 20.6.1) or in theTrace area (in Cisco vManage Release 20.6.1 and later releases). Information
about each instance is also displayed, including its state and the actions that you can perform.
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From Cisco Catalyst SD-WAN Manager Release 20.12.1, the Trace area includes the following tabs:

• All Trace: Provides information about the traces that you start manually.

• Auto-On Task: Provides information about the traces that are generated by an auto-on task.

You can perform the following actions in the Trace History area or Trace area:

• In releases before Cisco vManage Release 20.6.1:

• To stop an active trace, click Stop. If you have specified the trace duration, the trace stops
automatically when the timer expires.

• To navigate to the Flow Path and Metrics section, click Detail.

• From Cisco vManage Release 20.6.1:

Tab (from Cisco Catalyst SD-WAN
Manager Release 20.12.1)

ProcedureAction

All Trace and Auto-On TaskClick Stop in the Action column
for the trace, and then click
Confirm in the Stop Trace
dialog box.

Stop a trace that is in progress.

All Trace and Auto-On TaskClick Delete in the Action
column for the trace, and then
click Confirm in the Delete
Trace dialog box.

Delete a trace that is completed.

All Trace and Auto-On TaskSee Insight Summary, on page
116.

Display trace-level insight
summary information (fromCisco
vManage Release 20.9.1).

All TraceClick Insight Summary for the
trace in theTrace Name column.

Display detailed information
about the flows in a trace in the
Insight area.

All TraceClick the name of the trace in the
Trace Name column.

View the filters and settings for a
trace.

All TraceClick the corresponding value in
the Src Site column.

View information about the
source of a trace.

All TraceClick the corresponding value in
the Application/App Group
column.

View information about the
applications or application groups
that a trace monitors.

All TraceClick the corresponding value in
the Trace State column.

View the status of a trace and
error messages, if any, that have
been generated.

Auto-On TaskClick the name of the
corresponding task.

View statistics for a task (from
Cisco Catalyst SD-WAN
Manager Release 20.12.1).
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Tab (from Cisco Catalyst SD-WAN
Manager Release 20.12.1)

ProcedureAction

Auto-On TaskExpand the task that you want,
and then click the name of the
trace in theTrace Name column.

View the filters and settings for a
trace in a task (from Cisco
Catalyst SD-WAN Manager
Release 20.12.1).

Flow Path and Metrics

This section applies to releases before Cisco vManage Release 20.6.1.

In the Flow Path and Metrics section, view bidirectional flow path table with hop-by-hop metrics. You can
expand any trace instance in the log to view the following details:

DescriptionColumn

The flow path instances in running state are refreshed
every 10 seconds and the time of the update is
displayed.

Last Update Time

Flow IDs differentiate two identical flow path
instances occurring at different times.

Flow ID

This state helps you visualize potential issues with
the flow. Only SLA state of the flow is supported.

State

Directions could be upstream or downstream. The
direction in which the first packet flow is identified
is considered as upstream.

Direction

Local edge (source) and the remote edge (destination)
colors indicate different WAN interfaces.

Local Color, Remote Color

Packet drop is measured at local and remote edge
routers. The packet drop is also measured on the
complete WAN network.

Local Drop(%), Remote Drop(%), WAN Drop(%)

Jitter and latency metrics of the flow. These metrics
help with evaluating the application performance in
real time.

Jitter(ms), Latency(ms)

For each direction of the flow, total number of packets
and total byte count are displayed.

Total Packets, Total Bytes

Insight

This section is applicable to Cisco vManage Release 20.6.1 and later.

Click View Insight in the Actions column in the list of traces to display detailed information about the flows
in the corresponding trace. This detailed information appears in the Insight area. The following information
is displayed in this area:
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• TheDNS Domains tab is available only when DNS domain discovery is enabled and displays information
about each domain that the trace discovers. You can expand any row in the list to display detailed
information about the application.

FromCisco vManage Release 20.9.1, clickDiscovered Domains to display information for every domain
that the trace discovered but that are not yet traced. Click Monitored Domains to display information
only for domains that the trace monitored.

In Cisco vManage Release 20.6.1 through Cisco vManage Release 20.8.x, the
DNS Domains tab is called the Applications tab.

Note

• (From Cisco vManage Release 20.9.1) The Applications tab displays information about applications
that were traced. You can expand any row in this list to display bidirectional path information with
hop-by-hop metrics for each application.

• TheActive Flows tab displays information about the flows that are in the Running state. You can expand
a flow instance to display bidirectional flow path information with hop-by-hop metrics.

• The Completed Flows tab shows information about the flows that are in the Stopped state. You can
expand a flow instance to display bidirectional flow path information with hop-by-hop metrics.

• In the DNS Domains tab, start or stop flow monitoring of the applications in the selected domain for an
active trace. Starting flow monitoring also deploys an HTTP probe (through Cisco vManage Release
20.8.x) or an HTTPS probe (from Cisco vManage Release 20.9.1) for the domain on the WAN. A dialog
box indicates that monitoring has started. Monitoring information is displayed in the Active Flows and
Completed Flows tabs.

• In Cisco vManage Release 20.6.1 through Cisco vManage Release 20.8.x, click Start Flow Monitor
and Stop Flow Monitor, as needed, to start or stop monitoring for the selected domains.

• From Cisco vManage Release 20.9.1, to start flow monitoring, click Discovered Domains, check
the corresponding check box for one or more domains to start monitoring, and click Start Flow
Monitor. In the confirmation dialog box that appears, click Confirm. You can change the domain
selections in this dialog box before you click Confirm.

From Cisco vManage Release 20.9.1, to stop flow monitoring, click Monitored Domains, check
the check box for each domain for which you want to stopmonitoring, and click Stop Flow Monitor.
In the confirmation dialog box that appears, click Confirm.

• Use the Search option to find specific flow instances.

From Cisco vManage 20.6.1, you also can cut and paste the following keywords to search for flows that
include corresponding the events:

• Local Drop

• WAN Loss

• TCP Reset

• NAT Translation

• DPI First Packet Unclassified

• SLA Violation
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• QoS Congestion

• WAN Color Inconsistency

• Flow Asymmetry

• Policy Bypass

• Server No Response

• AppQoE Diverted

• UTD Diverted

• For completed flows, use the Filter option to display only flow instances that meet specified criteria.

• For completed flows, you can limit the display to flows that occurred within a specified period.

In releases through Cisco vManage Release 20.8.x, you can choose a period of 1, 10, or 30 minutes, or
1, 2, or 5 hours. You also can click Custom and enter a date and time range.

From Cisco vManage Release 20.9.1, you can drag the ends of the time bar to designate the start and
end dates and times for a certain period.

The following tables describe the information that appears for each application and each instance in a flow,
and, if DNS domain discovery is enabled, for each domain.

The DNS domains tab (called Applications tab in Cisco vManage Release 20.6.1 through Cisco Manage
20.8.x) is available only when DNS Domain Discovery is enabled for a trace.

Note

Table 31: DNS Domains Tab (Called Applications Tab in Cisco vManage Release 20.6.1 Through Cisco Manage 20.8.x)

DescriptionColumn

Check the check box for the domains for which you
want monitoring to be enabled or disabled and click
Start Flow Monitor or Stop Flow Monitor.

Check box

Name of the domain that the trace discovered.Domain

Date and time at which the information was last
refreshed.

Instances are refreshed every 30 seconds by default.

Update Time

Name of the application that the trace discovered in
the domain.

Application

Name of the application group that the trace
discovered in the domain.

Application Group or App Group

Available from Cisco Catalyst SD-WAN Manager
Release 20.12.1. Identifier of the VPN in which the
application flow was traced.

VPN Id
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DescriptionColumn

Destination of DNS packets sent from clients.DNS Server

DNS resolver to which a device redirects DNS traffic
if a resolver is configured by a centralized policy or
by Cisco Umbrella.

DNS Redirect

DNS-resolved IP address for the application.Resolved IP

Transport type used by the domain.DNS Transport

Egress interface and type used by the domain.DNS Egress

DNS time to live, in seconds.TTL (sec)

Number of DNS packets sent.Request

Status of flow monitoring for the domain.Monitor State

Table 32: Applications Tabs (Available from Cisco vManage Release 20.9.1)

DescriptionColumn

Columns Displayed in Cisco vManage Release 20.9.1 through Cisco vManage Release 20.11.x

Date and time at which the information was last
refreshed.

Instances are refreshed every 10 seconds by default.

Last Update Time

Name of the application.App Name

Application group to which the application belongs.App Group

Number of upstream flows that were counted for the
application.

Upstream Flow Count

Number of downstream flows that were counted for
the application.

Downstream Flow Count

Number of KBs in the upstream traffic of this
application.

Upstream Bytes (K)

Number of KBs in the downstream traffic of this
application.

Downstream Bytes (K)

Columns Displayed From Cisco Catalyst SD-WAN Manager Release 20.12.1

Date and time at which the information was last
refreshed.

Instances are refreshed every 10 seconds by default.

Last Update Time

Name of the application.App Name
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DescriptionColumn

Application group to which the application belongs.App Group

Identifier of the VPN in which the application flow
was traced.

VPN Id

Number of KBs in the upstream and downstream
flows of this application.

Total Bytes (K)

Number of packets in the upstream and downstream
flows of this application.

Total packets

Number of KBs per second in the upstream and
downstream flows of this application during the past
minute.

KBPS

Number of packets per second in the upstream and
downstream flows of this application during the past
minute.

PPS

Number of flows that were counted for the application.Total Flows

Flows that had activity during the past 1 minute.Active Flows

Average number of new flows per second during the
past 1 minute.

Flow Setup Rate

Maximum, minimum, and average number of
milliseconds of detectable flow activity during the
duration of the trace.

Flow Live Time (ms) Max/Min/Avg

Number of flows that were sampled in the upstream
or downstream traffic of this application. Click the
up arrow icon next to the column name to display
information for upstream traffic. Click the down arrow
icon to display information for downstream traffic.

Sampled Flows

Number of KBs in the upstream or downstream traffic
of this application. Click the up arrow icon next to
the column name to display information for upstream
traffic. Click the down arrow icon to display
information for downstream traffic.

Sampled Bytes (K)
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Table 33: Active Flows and Completed Flows Tabs

DescriptionColumn

In releases through Cisco vManage 17.8.x: Date and
time at which the information was last refreshed.

In releases fromCisco vManage 20.9.1: Date and time
at which the flow started, and date and time at which
the information was last refreshed.

Instances are refreshed every 10 seconds by default.

Last Update Time or Start - Update Time

System-assigned identifier of the flow.Flow ID

Information that the flow contains (error, warning, or
information). Click an icon to display detailed
information about the flow in a dialog box (in releases
before Cisco vManage Release 20.9.1) or a slide-in
pane (in releases fromCisco vManage Release 20.9.1).
If the flow identifies an application issue, you can use
this information to assist with a root-cause analysis.

The dialog box or slide-in pane includes the following
information:

• Overview: Includes details about flow
asymmetry, bidirectional WAN color
inconsistency, QoS congestion, LAN or WAN
packet drops, SLA violation, path change, flow
reset, SAIE packet classification status, TCP
server response, and so on.

• Path Insight (available from Cisco vManage
Release 20.9.1): Provides information about how
a forwarding path was determined for a flow.
This information includes the edge router name;
destination IP address; IP address lookup and
matched route information; route-receiving
source protocol, preference, and metrics; flow
path-routing candidates; method for deciding the
flow path; NAT translation detail; and the flow
path used.

(You may have to scroll to the bottom of the
Path Insight tab to access the horizontal scroll
bar.)

In Cisco vManage Release 20.7.x and
earlier releases, the SD-WAN
Application Intelligence Engine (SAIE)
flow is called the deep packet inspection
(DPI) flow.

Note

Readout
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DescriptionColumn

From Cisco Catalyst SD-WAN Manager Release
20.12.1, identifier of the VPN in which the application
flow was traced.

VPN Id

Source IP address of the traffic that the trace monitors.Source IP

Source port of the traffic that the trace monitors.Source Port or Src Port

Destination IP address of the traffic that the trace
monitors.

Destination IP

Destination port of the traffic that the trace monitors.Destination Port or Dest Port

Protocol of the traffic that the trace monitors.Protocol

DSCP type that the trace monitors for upstream traffic
and downstream traffic.

DSCP Upstream/Downstream

Application that the flow monitors.Application

Application group that the flow monitors.Application Group

Domain that the flow belongs to.

Click a domain name to display the protocol from
which the domain was recognized.

This field shows information only for
DNS and HTTPS protocol flows. For
other flow types, this field displays
Unknown.

Note

Domain

Application response time, in milliseconds, for client
network delay (CND) and server network delay
(SND).

ART CND (ms)/SND (ms)

From Cisco Catalyst SD-WAN Manager Release
20.12.1, security group tag that is assigned to the flow.

Security Group Tag

Table 34: Expanded DNS Domains Information (Called Expanded Application Information in Cisco vManage Release 20.6.1 Through
Cisco Manage 20.8.x)

DescriptionColumn

Egress interface type used by the domain.Egress Interface

Names of the local edge (source) and the remote edge
(destination) of the flow.

Local Edge, Remote Edge

Color of the local edge (source) of the flow, which
indicates the egress WAN interface.

Local Color

Operations
114

Operations
View Network-Wide Path Insight



DescriptionColumn

Color of the remote edge (destination) of the flow,
which indicates the ingress WAN interface.

Remote Color

Application response time, in milliseconds, for client
network delay (CND) and server network delay
(SND).

App CND (ms)/App SND (ms)

Response time, in milliseconds, of an HTTP probe
ping from the device to the application server.

HTTP Probe Response Time (ms)

Packet loss percentage of an HTTP probe ping from
the device to the application server.

HTTP Probe Loss (%)

Path score of an HTTP probe ping from the device to
the application server.

Path Score

Table 35: Expanded Application Information (Available from Cisco vManage Release 20.9.1)

DescriptionColumn

Direction of the application flow (upstream or
downstream).

The first packet that the flow identifies is shown as a
flow in the upstream direction.

Direction

Hop index number for each direction of the
application.

HopIndex

Name of the local edge device (source) of the
application.

Local Edge

Name of the remote edge device (destination) of the
application.

Remote Edge

Color of the local edge device (source) of the
application, which indicates the egressWAN interface.

Local Color

Color of the remote edge device (destination) of the
application, which indicates the ingress WAN
interface.

Remote Color

Packet drop, as measured in the local and remote edge
routers. Packet drop is also measured in the complete
WAN network.

Local Drop (%), WAN Drop (%), Remote Drop
(%) or Local Drop (%), WAN Loss (%), Remote
Drop (%)

Jitter and latency metrics of the application during the
past minute. These values help with evaluating the
application performance in real time.

Jitter (ms), Latency (ms)

Operations
115

Operations
View Network-Wide Path Insight



DescriptionColumn

Application response time, in milliseconds, for client
network delay (CND) and server network delay (SND)
during the past minute.

ART CND (ms)/SND (ms)

For each direction of the application flow, the total
number of packets and the total byte count of packets.

Total Packets, Total Bytes, or Sampled Total
Packets and Sampled Total Bytes

Table 36: Expanded Flow Instance Information

DescriptionColumn

Direction of the flow (upstream or downstream).

The first packet that the flow identifies is considered
to flow in the upstream direction.

Direction

Hop index number for each direction of the flow.HopIndex

Name of the local edge (source) of the flow.Local Edge

Name of the remote edge (destination) of the flow.Remote Edge

Color of the local edge (source) of the flow, which
indicates the egress WAN interface.

Local Color

Color of the remote edge (destination) of the flow,
which indicates the ingress WAN interface.

Remote Color

Packet drop, as measured in the local and remote edge
routers. The packet drop is also measured in the
complete WAN network.

Local Drop (%), WAN Drop (%), Remote Drop
(%) or Local Drop (%), WAN Loss (%), Remote
Drop (%)

Jitter and latency metrics of the flow. These values
help with evaluating the application performance in
real time.

Jitter (ms), Latency (ms)

Application response time, in milliseconds, for client
network delay (CND) and server network delay
(SND).

ART CND (ms)/SND (ms)

For each direction of the flow, the total number of
packets and the total byte count of packets.

Total Packets, Total Bytes

Identifier of the QoS queue for the flow.Queue Id

Limit, maximum, minimum, and average values of
the QoS queue depth for the flow.

QDepthLimit/Max/Min/Avg

Insight Summary

Minimum release: Cisco vManage Release 20.9.1.
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An insight summary provides trace-level insight information for application traffic and flows. This information
appears in a slide-in pane. The following table describes how to display the various insight summaries that
are available.

Table 37: Display Insight Summary Information

ProcedureInsight Summary Information

For Manually Generated Traces

In the All Trace tab, click Insight Summary in the
Trace Name column for the trace that you want.

Insight summary for a single manually generated trace

In the All Trace tab, check the check box for each
trace that you want, and then click Insight Summary
above the Trace Name column.

Consolidated insight summary for selected manually
generated traces (from Cisco Catalyst SD-WAN
Manager Release 20.12.1)

For Auto-On Task Traces (from Cisco Catalyst SD-WAN Manager Release 20.12.1)

In the Auto-On Task tab, expand a task and click
Insight Summary next to the trace that you want.

Insight summary for a single trace generated by an
auto-on task

In the Auto-On Task tab, click Insight Summary
next to the name of the task.

Consolidated insight summary for all the traces
generated by an auto-on task

• Overview tab: Displays the following information.

From Cisco Catalyst SD-WAN Manager Release 20.12.1, click Sampled Flow Insight to see the
Applications graph, Events graph, and Hotspot Issues. Information for all the VPNs that the trace
detects is selected by default. You can remove a VPN by unchecking it in the corresponding drop-down
list, and add a VPN by choosing it in the corresponding drop-down list.

The information in this Sampled Flow Insight area is based on sampled data, which comes from a subset
of the total number of flows that were monitored. The number of flows that are sampled is determined
by an internal algorithm. For example, if the trace monitors 1,000 flows, this tab might show information
for only 10 of those flows.

• Applications graph: Displays the number of flows that the trace detects in each application in the
monitored traffic. Hover your cursor over the data points in the graph to display the percentage of
total flows that the corresponding application flow represents.

From Cisco Catalyst SD-WAN Manager Release 20.12.1, check the Application check box to
display information for all flows that include application traffic. Check theDNS check box to display
information for all the flows with DNS resolution.

• Events graph: Displays the events that the trace detects in the monitored traffic and the number of
application flows that each event affects. Hover your cursor over the data points in the graph to
display the percentage of total application flows that the corresponding event affected.

From Cisco Catalyst SD-WAN Manager Release 20.12.1, check one or more severity check boxes
(Critical,Warning, and Informational) to display information for events that have the corresponding
severity level.

• Hotspot Issues: For each event, provides information about each application flow that was affected,
including the traffic path in which the event occurred and the duration of the event.
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This information is displayed for each event that appears in the Events field. By default, all the
events that the trace detects appear in this field. You can remove an event by clicking X next to its
name and add an event by choosing the event from the Events drop-down list.

From Cisco Catalyst SD-WAN Manager Release 20.12.1, when viewing the Overview tab for a single
trace, click Application Stats to see the following graphs. These graphs provide information for the top
10 applications with the most flows. Hover your cursor over the data points in a graph to display more
detailed information for the corresponding item.

• Applications (top 10) - Total Flows: Total number of application flows for the duration of the
trace. The selected color is for the egress WAN interface on which flows were initialized.

• Applications (top 10) - Total Bytes: Overall application bidirectional bandwidth for the duration
of the trace. Upstream and downstream flow bandwidths are counted on the egress WAN on which
flows were initialized.

• Applications (top 10) – Flow Setup Rate: New incoming flows per second, calculated at 1-minute
intervals.

• Applications (top 10) – Active Flow: Number of active flows, calculated at 1-minute intervals.

• Applications (top 10) – Bandwidth: Number of KB per second, calculated at 1-minute intervals.

• Applications (top 10) – Flow Live Time: Overall lifetime of application flows, based on the flows
completed within the monitor interval and calculated at 1-minute intervals.

The Applications (top 10) - Total Flows and Applications (top 10) - Total Bytes graphs provide
information for each item that is selected in the VPN, Device, and WAN Color fields. All the items that
the trace detects are selected by default.

The other graphs provide information only when only one item is selected in theVPN,Device, andWAN
Color fields.

You can remove an item from these fields by unchecking it in the corresponding drop-down list, and add
an item by choosing the item from the corresponding drop-down list.

You can view detailed information about an event in the Event Insight tab.Note

• App Performance Insight tab (not available for consolidated insight summaries): Displays the following
performance information for the selected items.

From Cisco Catalyst SD-WAN Manager Release 20.12.11, the Score graph appears when you expand
Hop Metrics. The other graphs appear when you expand Detailed Metrics under the expanded Hop
Metrics.

• Score graph: Provides an evaluation of application performance.

• Loss graph: Provides information about packet loss.

• Delay graph: Provides information about delays in the traffic flows.

• Jitter graph: Provides information about the inconsistencies in latency in traffic flows.

• CND/SND graph: Provides information about client network delay (CND) and server network delay
(SND).
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• Applications Path & Performance Sankey chart: Provides a snapshot of bandwidth used and loss
information at a particular time. You can choose the time by clicking a dot on a timeline in a metrics
graph.

The graphs display information for each application that appears in the Application field and the hop
that is displayed in the Hop field. From Cisco Catalyst SD-WAN Manager Release 20.12.1, the
Application field appears when you expand Group Fields. The Sankey chart displays information for
each application that appears in the Application field and for all the hops, regardless of the hop that is
displayed in the Application field.

The five applications with the most hotspot issues appear in the Application field by default. You can
remove an application by clicking the X next to its name, and add an application by choosing the
application from the Application drop-down list. You can choose a hop from the Hop drop-down list.

From Cisco Catalyst SD-WAN Manager Release 20.12.1, information for all the VPNs that the trace
detects are selected by default. You can remove a VPN by unchecking it in the corresponding drop-down
list, and add a VPN by choosing the item from the corresponding drop-down list.

From Cisco Catalyst SD-WANManager Release 20.12.1, you can arrange the information that displays
into groups, according to the items that you choose in theGroup Fields area. The fields that are displayed
depend on the Grouping Fields options that you chose when you started the trace. You can remove a
grouping item by clicking X next to its name, and add an item by choosing it from the corresponding
drop-down list.

Click Upstream to display information for upstream traffic in the graphs and chart. Click Downstream
to display information for downstream traffic in the graphs and chart.

Hover your cursor over a data point in a graph to display more detailed information. Click a data point
in a graph to update the Sankey chart for that data point. Hover your cursor over a data point in the Sankey
chart to display more detailed information.

• Event Insight tab (not available for consolidated insight summaries): Displays the following information
about application flows that were affected during each minute of the duration of an event. You can use
this information to assist with a root-cause analysis.

• Flows graph: Provides information about the number of flows at a particular time.

• Applications Path & Event Sankey chart: Provides detailed information about the effect of
designated events at a particular time. Hover your cursor over a data point to see more information.

The graph displays information for each application that appears in the Application field and the hop
that is displayed in the Hop field. From Cisco Catalyst SD-WAN Manager Release 20.12.1, the
Application field appears when you expand Group Fields. The Sankey chart displays information for
each application that appears in the Application field, for all the hops regardless of the hop that is
displayed in the Hop field, and for the events that are displayed in the Events field.

The five applications with the most hotspot issues appear in the Application field by default. You can
remove an application by clickingX next to its name, and add an application by choosing the application
from the Application drop-down list. You can choose a hop from the Hop drop-down list.

Hotspot events that the trace detects appear in the Events field by default. You can remove an event by
clicking X next to its name and add an event by choosing the event from the Application drop-down
list.

From Cisco Catalyst SD-WAN Manager Release 20.12.1, information for all the VPNs that the trace
detects is selected by default. You can remove a VPN by unchecking it in the corresponding drop-down
list, and add a VPN by choosing the item from the corresponding drop-down list.
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From Cisco Catalyst SD-WAN Manager Release 20.12.1, you can use the fields in the Group Fields
area to group the information that displays by the selected items. The fields that are displayed depend
on the Grouping Fields options that you chose when you started the trace. You can remove a grouping
item by clicking X next to its name, and add an item by choosing it from a drop-down list.

Click Upstream to display information for upstream traffic in the graph and chart. Click Downstream
to display information for downstream traffic in the graph and chart.

Hover your cursor over a data point to display detailed information about the events that affect the flow
at that point. Click a data point to update the Sankey chart for that data point. Hover your cursor over a
data point in the Sankey chart to display more detailed information.

• QoS Insight tab (not available for consolidated insight summaries): Displays network-wide information
about which application traffic entered which QoS queues on the devices that the trace detects. This
information includes all the hops for the traffic.

To display information on this tab, enable the QoS Insight option when you start the trace.

• QoS Drop Rate graph: Provides information about the packet or byte drop rates for the selected
devices over the period of the trace.

• QoS - Applications Distribution Sankey chart: Provides detailed information about the traffic
spectrum and QoS processing at a particular time. The chart illustrates forwarded or dropped traffic
that occurs in a flow that goes from an application to a VPN to a physical interface to a queue.

To provide complete information about bandwidth consumers that cause dropped packets, this tab displays
information for all the applications on a device, regardless of the applications that you choose by using
the Application filter when you start a trace. It also displays information for VPN0 and all the service
VPNs, regardless of the service VPNs that you choose by using the VPN filter when you start the trace.

The graph and chart display information for each device that appears in the Devices field.

The chart displays information for each item that appears in theApplications,VPNs, Interfaces,Queues,
and Forward/Drop fields. All the items that the trace detects are displayed in these fields by default,
except items with a packet per second (PPS) rate of less than 0.05. You can remove an item by clicking
the X next to its name, and add an item by choosing the item from a corresponding drop-down list.

ClickPacket to display packet drop rate information in the graph and packets per second (PPS) information
in the Sankey chart. Click Byte to display byte drop rate information in the graph and kilobits per second
(Kbps) information in the Sankey chart.

Hover your cursor over a data point in the graph to display more detailed information. Click a data point
in the graph to update the Sankey chart for that data point. Hover your cursor over a data point in the
Sankey chart to display more detailed information.

Trace Views

In releases before Cisco vManage Release 20.6.1, you can view the trace flow from three sections—Geography
View, Feature View (Upstream), and Feature View (Downstream).

From Cisco vManage Release 20.6.1, you can view the trace flow information from these tabs in the Insight
- Advanced Views area after expanding a flow in the Insight area—Domain Trend, Flow Trend,Upstream
Feature, Downstream Feature, and Geography.
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In Cisco vManage Release 20.6.1 through Cisco vManage 20.8.x, Domain Trend is called App Trend.Note

Domain Trend

TheDomain Trend tab is available from Cisco vManage Release 20.6.1. It was calledApp Trend in In Cisco
vManage Release 20.6.1 through Cisco vManage 20.8.x. This tab appears only when DNS discovery is enabled
and displays trends for metrics and events in an application flow. Hover your cursor over the data points in
the tab to see detailed information.

The client network delay (CND) and server network delay (SND) information that appears on this tab are
measured by the applications' TCP traffic. DNS request frequency shows how often a SaaS application is
visited. HTTP probe response time and loss rate are measured by probes that are sent by a router to the SaaS
application server to detect a reachable direct internet access (DIA) network path and help evaluate the benefit
of deploying a DIA traffic policy.

From the Chart Metrics drop-down list, you can choose the metric types for which you want to view
information. From the Devices drop-down list, you can choose specific devices for which you want to view
data. By default, trend information appears for all metric types and all devices.

You can limit the display to trends that occurred within a specified time, or those that occurred within a
specified period. You can choose a period of 1, 10, or 30 minutes, or 1, 2, or 5 hours. You also can click
Custom and enter a date and time range, or click Real Time to display information as it is collected.

Flow Trend

The Flow Trend tab is available from Cisco vManage Release 20.6.1. This tab displays trends for metrics
and events in a trace flow. Hover your cursor over data points to see detailed information.

From the Chart Metrics drop-down list, you can choose specific metric types for viewing information. From
the Flow Direction drop-down list, you can choose the traffic flow direction for viewing data. By default,
trend information appears for latency, jitter, WAN loss, and average queue depth, and for all the flow directions.

Use the Navigate to Event drop-down list to choose information about a specific event.

You can limit the display to trends that occurred within a specified time, or those that occurred within a
specified period. You can choose a period of 1, 10, or 30 minutes, or 1, 2, or 5 hours. You also can click
Custom and enter a date and time range, or click Real Time to display information as it is collected.

Geography View

In the Geography View section for releases before Cisco vManage Release 20.6.1 or the Geography tab in
releases beginning with Cisco vManage Release 20.6.1, you can view the end-to-end trace flow and metrics
plotted on the map for a selected trace. The topology graph displays the geographic information about the
devices included in the flow.

• The geography view supports "Automatic Network Path Discovery," where you input only the Site and
VPN to trace the complete bidirectional, end-to-end real-traffic network flow path.

• Each node in the topology is connected with two lines. One line represents upstream direction and the
other represents downstream direction.

• Issues (example: SLA violation) detected in the flow metric are shown in different colored lines.

Feature View (Upstream and Downstream)
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In the Feature View section for releases before Cisco vManage Release 20.6.1 or the Upstream Feature and
Downstream Feature tabs in releases beginning with Cisco vManage Release 20.6.1, view the upstream and
downstream feature trace with associated policy details.

To view the upstream and downstream details of the flow, expand a flow record in the flow path and metrics
table.

• The feature view provides a list of ingress and egress features that are applied to the flow, and the
execution result of each feature.

• Typical ingress features include: SD-WANACL,NBAR, SD-WANdata policy, SD-WAN app-route
policy, SD-WAN forwarding, and so on.

• Typical egress features include: NBAR, IPsec, SDWAN QoS Output, QoS, Transmit report, and
so on.

• For releases before Cisco vManage Release 20.6.1, in the Ingress or Egress view, click a policy to view
detailed configuration in a pop-up window and validate policy behavior. For releases beginning with
Cisco vManage Release 20.6.1, click View Policy to view this information and validate behavior for the
corresponding policy. (View Policy does not apply to policies that are configured by using a CLI template.)

The downstream feature view shows similar information but organized from a downstream direction.Note

Troubleshooting Network-Wide Path Insight

Problem

No information is displayed when you view the results of a trace.

Solution

Check the following:

• Data stream collection might not be operating properly. To resolve this issue, choose Administration >
Settings > Data stream, click Disabled, then click Save. Click Data stream again, click Enabled,
choose System for the IP address type, then click Save.

• You may have enabled DNS domain discovery for the trace, and the monitored traffic may not be from
DNS domains. To resolve this issue, choose Tools > Network Wide Path Insight, uncheck the Enable
DNS Domain Discovery check box in the Trace area, and run the trace again.

Problem

The location of devices does not appear in the Geography View section for releases before Cisco vManage
Release 20.6.1 or the Geography tab in Cisco vManage Release 20.6.1.

Solution

Ensure that GPS is configured for the device.
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Monitor Performance of Cloud OnRamp for SaaS

View Application Performance

In vManage NMS, select the Configuration > Cloud OnRamp for SaaS screen. The Cloud OnRamp for
SaaS Dashboard displays the performance of each cloud application in a separate pane.

Each application pane displays the number of Cisco IOS XE Catalyst SD-WAN devices accessing the
application and the quality of the connection:

• The bottom status bar displays green for devices experiencing good quality.

• The middle status bar displays yellow for devices experiencing average quality.

• The top status bar displays red for devices experiencing bad quality.

The number to the right of each status bar indicates how many devices are experiencing that quality of
connection.

View Application Details

1. In vManage NMS, choose the Configuration > Cloud OnRamp for SaaS screen. The Cloud OnRamp
for SaaS Dashboard displays each cloud application in a separate pane.

2. Click in an application's pane. vManage NMS displays a list of sites accessing the application.

3. Click a graph icon in the vQoE Score column to display vQoE history for that site:

• Click a predefined or custom time period for which to display data.

• Hover over a point on the chart to display vQoE details for that point in time.

View ARP Table Entries
The Address Resolution Protocol (ARP) is used to resolve network layer addresses, such as IPv4 addresses)
into link layer addresses (such as Ethernet, or MAC, addresses). The mappings between network and physical
addresses are stored in an ARP table.

To view the entries in the ARP table:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that displays.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list in the right pane, choose ARP.

CLI equivalent: show arp
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View BFD Session Information
Bidirectional Forwarding Detection (BFD) sessions between routers start automatically when the devices
come up in the network. BFD which runs on secure IPsec connections between the routers, is used to detect
connection failures between the routers.

To view BFD information for a router:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that displays.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list, choose one of the following commands as relevant:

• BFD Sessions (to view real-time BFD sessions)

• BFD History (to view BFD session history)

View BGP Information
You can configure the Border Gateway Protocol (BGP) on routers to enable routing on the service side
(site-local side) of the device, thus providing reachability to networks at the devices' local sites.

To view BGP information on a router:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that displays.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list, choose one of the following commands as relevant:

DescriptionOption

View BGP connection status.BGP Summary (show bgp summary

View BGP neighbors.BGP Neigbors (show bgp neighbor)

View routes learned by BGP.BGP Routes (show bgp routes)
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View Cflowd Information
Table 38: Feature History

DescriptionRelease InformationFeature Name

Configure Cflowd traffic flow monitoring on Cisco
IOS XE Catalyst SD-WAN devices.

Cisco IOS XE Catalyst
SD-WANRelease 17.4.1a

Cisco vManage Release
20.4.1

Flexible NetFlow Support
for IPv6 and Cache Size
Modification

To enable logging of dropped packets, check the
Implicit ACL Logging check box and to configure
how often the packet flows are logged, enter the value
in the Log Frequency field.

Cisco IOS XE Catalyst
SD-WANRelease 17.5.1a

Cisco vManage Release
20.5.1

Log Packets Dropped by
Implicit ACL

Configure Cflowd traffic flow monitoring to collect
ToS, sampler ID, and remarked DSCP values in
netflow records.

Cisco IOS XE Catalyst
SD-WANRelease 17.6.1a

Cisco vManage Release
20.6.1

Flexible NetFlow
Enhancement

Configure this feature using the CLI template and also
add-on CLI template.

Cisco IOS XE Catalyst
SD-WANRelease 17.7.1a

Cisco vManage Release
20.7.1

Flexible NetFlow for
VPN0 Interface

This feature enables export spreading to prevent
export storms that occur when a burst of packets are
sent to external collector. The export of the previous
interval is spread during the current interval to prevent
export storms. When NetFlow packets are sent over
a low-bandwidth circuit, the export spreading
functionality is enabled to avoid packet drops.

Cisco IOS XE Catalyst
SD-WANRelease 17.9.1a

Cisco Catalyst SD-WAN
Control Components
Release 20.9.x

Cisco vManage Release
20.9.1

Flexible NetFlow Export
Spreading

With this feature, you can export Bidirectional
Forwarding Detection (BFD) metrics to an external
collector for generating BFD metrics of loss, latency,
and jitter. This feature provides enhanced monitoring
and faster collection of network state data.

Cisco IOS XE Catalyst
SD-WAN Release
17.10.1a

Cisco Catalyst SD-WAN
Control Components
Release 20.10.1

Flexible NetFlow Export
of BFD Metrics

Operations
125

Operations
View Cflowd Information



DescriptionRelease InformationFeature Name

With this feature, you can apply filters for monitoring
specific Cflowd and SD-WAN Application
Intelligence Engine (SAIE) applications or application
families running within a VPN on the selected Cisco
IOS XE Catalyst SD-WAN device.

This feature was already available on Cisco vEdge
devices and is being extended to Cisco IOS XE
Catalyst SD-WAN devices in this release.

Cisco IOS XE Catalyst
SD-WAN Release
17.10.1a

Cisco vManage Release
20.10.1

Real-Time Device
Options for Monitoring
Cflowd and SAIE Flows

Cflowd monitors traffic flowing through routers in the overlay network and exports flow information to a
collector, where it can be processed by an IPFIX analyzer. For a traffic flow, Cflowd periodically sends
template reports to a flow collector. These reports contain information about the flow and data extracted from
the IP headers of the packets in the flow.

To configure Cflowd in a router, use centralized data policy to define a Cflowd template that specifies the
location of a Cflowd collector and timers that control the flow collection.

To view Cflowd flow information for a router:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices displayed.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list, choose one of the following commands or options, as relevant:

DescriptionOption

View the Cflowd template.

Device option is displayed on Cisco vEdge devices.

Cflowd Template (show app cflowd template)

View Cflowd Collector information.

Device option is displayed on Cisco vEdge devices.

Cflowd Collector (show app cflowd collector)

View Cflowd flows.

Device option is displayed on Cisco vEdge devices.

Cflowd Flows (show app cflowd flows, show app
cflowd flow-count)

View Cflowd statistics.

Device option is displayed on Cisco vEdge devices.

Cflowd Statistics (show app cflowd statistics)
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DescriptionOption

View Cflowd traffic flow information and SAIE
flow information.

From Cisco IOS XE Catalyst SD-WAN Release
17.10.1a and Cisco vManage Release 20.10.1, the
cFlowd Flows/DPI field is added for applying
filters for monitoring specific SAIE applications or
application families running within a VPN on the
selected Cisco IOS XE Catalyst SD-WAN device.

Device option is displayed on Cisco IOS XE
Catalyst SD-WAN devices.

cFlowd Flows/DPI (show cflowd flows)

View Cflowd IPv6 traffic flow information and
SAIE flows.

From Cisco IOS XE Catalyst SD-WAN Release
17.10.1a and Cisco vManage Release 20.10.1, the
cFlowd ipv6 Flows/DPI field is added for applying
filters for monitoring specific SAIE applications or
application families running within a VPN on the
selected Cisco IOS XE Catalyst SD-WAN device.

Device option is displayed on Cisco IOS XE
Catalyst SD-WAN devices.

cFlowd ipv6 Flows/DPI (show cflowd flows)

View Device Templates

View a Template

1. From the Cisco SD-WAN Manager menu, choose Configuration > Templates.

2. Click Device Templates or Feature Templates, and select a template you wish to view.

In Cisco vManage Release 20.7.x and earlier releases, Device Templates is titled Device, and Feature
Templates is titled Feature.

Note

3. Click …, and then click View.

View Device Templates Attached to a Feature Template

1. From the Cisco SD-WAN Manager menu, choose Configuration > Templates.

2. Click Feature Templates, and select a template you wish to view.

In Cisco vManage Release 20.7.x and earlier releases, Feature Templates is titled Feature.Note
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3. Click …, and click Show Attached Device Templates.

Device Templates dailog box opens, displaying the names of the device templates to which the feature
template is attached.

View Devices Attached to a Device Template

For a device template that you created from feature templates:

1. From the Cisco SD-WAN Manager menu, choose Configuration > Templates.

2. Click Device Templates, and select a template you wish to view.

In Cisco vManage Release 20.7.x and earlier releases, Device Templates is titled Device.Note

3. Click …, and click Attach Devices.

4. From Attach Devices, click Attached Devices.

For a device template that you created from a CLI template:

1. From the Cisco SD-WAN Manager menu, choose Configuration > Templates.

2. Click Device Templates, and select a template you wish to view.

In Cisco vManage Release 20.7.x and earlier releases, Device Templates is titled Device.Note

3. Click …, and then click Show Attached Devices.

View and Monitor Cellular Interfaces
This topic describes how to monitor the status of cellular interfaces in Cisco Catalyst SD-WAN devices.

Monitor Cellular Interfaces

You can verify signal strength and service availability using either Cisco SD-WAN Manager or the LED on
the router. You can view the last-seen error message for cellular interfaces from Cisco SD-WAN Manager.

Verify Signal Strength

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. From the Device Groups drop-down list, choose a group that the device belongs to.

3. Choose a device by clicking its name in the Hostname column.

4. Click Real Time in the left pane.
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5. From the Device Options drop-down list in the right pane, choose Cellular Radio.

The values for the different cellular signals are displayed. If signal strength is poor, or there is no signal,
see Troubleshoot Common Cellular Interface Issues.

CLI equivalent: show cellular status

Verify Radio Signal Strength Using the Router LED

To check signal strength and service availability of a cellular connection from the router, look at the WWAN
Signal Strength LED. This LED is typically on the front of the routers, and is labeled with a wireless icon.

The following table explains the LED color and associated status:

Table 39:

DescriptionStateSignal
Strength

Color

LTE interface disabled (that is, admin status is down) or not configured——Off

LTE interface enabled and in dormant mode (no data being received or
transmitted)

SolidExcellentGreen

LTE interface enabled and in active mode (data being received and
transmitted)

Blinking

LTE interface enabled and in dormant mode (no data being received or
transmitted)

SolidGoodYellow

LTE interface enabled and in active mode (data being received and
transmitted)

Blinking

LTE interface enabled and in dormant mode (no data being received or
transmitted)

SolidPoorOrange

LTE interface enabled and in active mode (data are being received and
transmitted)

Blinking

LTE interface enabled but faulty; issues include no connectivity with the
base transceiver station (BTS) and no signal

SolidCritical IssueRed

View Error Messages for Cellular Interfaces

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device by clicking its name in the Hostname column.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list in the right pane, choose Cellular Status.

The output displayed includes a column for Last Seen Error
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CLI equivalent: show cellular status

View a Signed Certificate
Signed certificates are used to authenticate Cisco SD-WAN devices in the overlay network. To view the
contents of a signed certificate using Cisco SD-WAN Manager:

1. From the Cisco SD-WAN Manager menu, choose Configuration > Certificates.

2. Click Controllers.

3. For the desired device, click ... and choose View Certificate to view the installed certificate.

View Cisco Umbrella Information
To view Cisco Umbrella information on a device, perform the following steps:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

2. Choose a device from the list of devices that is displayed.

3. Click Real Time in the left pane.

4. Click Device Options, and choose the following.

DescriptionCommandDevice Option

Displays Cisco Umbrella
registration status for Cisco IOSXE
Catalyst SD-WAN devices.

show umbrella deviceidUmbrella Device Registration

View Cisco Catalyst SD-WAN Validator Information
1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that is displayed.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list, choose one of the following commands:

DescriptionCLI CommandDevice Option

Displays the proxy IP addresses and
port numbers that are configured
for use by reverse proxy.

show orchestrator
reverse-proxy-mapping

Orchestrator Reverse Proxy
Mapping
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DescriptionCLI CommandDevice Option

Displays statistics about the packets
that a Cisco Catalyst SD-WAN
Validator has transmitted and
received in the process of
establishing andmaintaining secure
DTLS connections to a Cisco IOS
XE Catalyst SD-WAN devices in
the overlay network.

show orchestrator statisticsOrchestrator Statistics

Lists the chassis numbers of the
valid Cisco SD-WAN Manager
instance in the overlay network.

show orchestrator valid-vmanage-idOrchestrator Valid vManage ID

View Cloud Express Information
To view Cloud Express information on a device, perform the following steps:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that is displayed.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list, choose one of the following commands:

DescriptionCommandDevice Option

Displays the best path that Cloud
onRamp for SaaS has selected for
each configured SaaS application
on Cisco IOS XE Catalyst
SD-WAN devices.

show sdwan cloudexpress
applications

Cloud Express Applications

Displays the Quality of Experience
(QoE)measurements received from
gateway sites, for Cloud onRamp
for SaaS on Cisco IOSXECatalyst
SD-WAN devices.

show sdwan cloudexpress
gateway-exits

Cloud Express Gateway Exits

Displays the list of applications
enabled for Cloud onRamp for
SaaS probing on Cisco IOS XE
Catalyst SD-WAN devices, and the
interfaces on which the probing
occurs.

show sdwan cloudexpress
local-exits

Cloud Express Local Exits
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View Control Connections
To view all control connections for a device:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Geography.

2. Choose a device to view its control connections.

If you select a controller device—a Cisco Catalyst SD-WAN Validator, Cisco SD-WAN Manager, or a
Cisco Catalyst SD-WAN Controller, the Control Connections screen opens by default.

3. If you choose an edge device, the System Status screen displays by default. To view control connections
for the device, click Control Connections in the left pane. The right pane displays information about all
control connections that the device has with other controller devices in the network.

The upper area of the right pane contains the following elements:

• Expected and actual number of connections.

• Control connection data in graphical format. If the device has multiple interfaces, Cisco SD-WAN
Manager displays a graphical topology of all control connections for each color.

The lower area of the right pane contains the following elements:

• Search bar—Includes the Search Options drop-down, for a Contains or Match.

• Control connections data in tabular format. By default, the first six control connections are selected. The
graphical display in the upper part of the right pane plots information for the selected control connections.

View Data Policies
A centralized data policy is configured and applied on Cisco SD-WAN Controllers, and is then carried in
OMP updates to the edge devices in the site-list that the policy is applied to. Centralized data policy examines
fields in the headers of data packets, looking at the source and destination addresses and ports, and the protocol
and DSCP values, and for matching packets, it modifies the next hop in a variety of ways or applies a policer
to the packets. The policy match operation and any resultant actions are performed on the router as it transmits
or receives data traffic.

Localized data policy, also called access lists (ACLs), is configured directly on a local router and affects data
traffic being transmitted between the routers on the Cisco Catalyst SD-WAN overlay network.

To view ACL information on a router, do the following:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that appears.

3. Click Real Time in the left pane.

4. Click Device Options, and choose one of the following commands:

DescriptionCommand

View names of configured ACLsshow policy access-list-names
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DescriptionCommand

View Interfaces to which ACLs are appliedshow policy access-list-associations

View count of packets affected by ACLsshow policy access-list-associations

View Cisco Catalyst SD-WAN Controller Policy

To view policy information from Cisco Catalyst SD-WAN Controller on a device, perform the following
steps:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that appears.

3. Click Real Time in the left pane.

4. Click Device Options, and choose one of the following commands:

DescriptionCommandDevice Option

Displays a centralized data policy,
an application-aware policy, or a
cflowd policy that a Cisco Catalyst
SD-WAN Controller has pushed to
the Edge devices.

show sdwan policy from-vsmartPolicy from vSmart

View Devices Connected to Cisco Catalyst SD-WAN Manager
1. From the Cisco SD-WAN Manager menu, choose Administration > Cluster Management.

2. Under Service Configuration, click the hostname of the desired Cisco SD-WAN Manager server. The
vManage Details screen appears.

3. Or alternatively:

Under Service Configuration, for the desired Cisco SD-WAN Manager instance, click ... and choose
Device Connected.

View Device Information
You can view basic or detailed information for a device in the overlay network.

To view basic information:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Geography.

2. Hover over the device icon.
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A pop-up box displays the system IP address, hostname, site ID, device type, and device status. To view
more information for a device, double-click the device icon to open the View More Details pop-up box.
Click Device Dashboard, Device Details, SSH Terminal, or Links to get further details for the device.

To view detailed information:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Locate the WAN edge router to view the status. You can either scroll through the list of devices in the
device table or enter a keyword in the search bar.

3. Click the relevant device under the Hostname column. The right pane displays System Status by default.
To view more detailed information for the device, choose one of the categories from the left pane.

Starting from Cisco vManage Release 20.9.2, theMonitor >Devices page displays the devices that are newly
added or synced to Cisco SD-WAN Manager using the options available on the Configuration > Devices
page.

Note

View Device Health in Table View
Minimum supported release: Cisco vManage Release 20.10.1

You can view details about the device health for the last one hour in the table view by default in the Monitor
Device window.

The table displays:

• Device model

• Site ID

• System IP address

• Device health

• Device reachability

• Memory utilization

• CPU load

You can also view the health of all the devices on a single site by clicking All Sites and selecting the site ID
to enter the single site view.

Devices Health Metrics

The devices health is calculated as follows:
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Evaluation LogicResourcesData PlaneControl PlaneReachabilityHealth State

All attributes
met

CPU usage <
75%

Memory usage <
75%

All BFD tunnels
up

All control
connections up

Device reachableGood

Any attributes
met

CPU usage >
75%

Memory usage >
75%

> = 1 BFD
tunnels up

> = 1 control
connections up

Device reachableFair

Any attributes
met

CPU usage >
90%

Memory usage >
90%

No BFD tunnels
up

No control
connections up

Device not
reachable

Poor

For a single device record the health is calculated as follows:

QoEHealth

10Good

5Fair

0Poor

The average health metric of devices is calculated as follows:

QoEHealth

QoE >= 6.67Good

3.34 <= QoE < 6.67Fair

0 < QoE < 3.34Poor

View Device Health in Heatmap View
Minimum supported release: Cisco vManage Release 20.10.1

In the heatmap view, the grid of colored squares displays the device health as Good, Fair, or Poor. You can
hover over a square or click it to display additional details of a device at a specific time. Click the time interval
drop-down list to change the time selection and filter the data for a specific interval.

You can view the health of all the devices on a single site by clicking All Sites and selecting the site ID to
enter the single site view.

View DHCP Server and Interface Information
When you configure a tunnel interface on a device, several services are enabled by default on that interface,
including DHCP. The device can act as a DHCP server for the service-side network to which it is connected,
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assigning IP addresses to hosts in the service-side network. It can also act as a DHCP helper, forwarding
requests for IP addresses from devices in the service-side network to a DHCP server that is in a different
subnet on the service side of the device.

To view DHCP server and interface information:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose the device by clicking its name in the Hostname column.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list in the right pane. choose one of the following to view specific
DHCP server and interface information:

DescriptionCommandDevice Option

View information about the DHCP
server functionality that is enabled
on the device

show dhcp serverDHCP Servers

View information about the
interfaces on which DHCP is
enabled on an edge device or a
Cisco SD-WAN Controller

show dhcp interfaceDHCP Interfaces

View SAIE Flows
1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.1 and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

Starting from Cisco vManage Release 20.6.1, to view the detailed SD-WAN Application Intelligence
Engine (SAIE) flow information such as source IP address, destination IP address, and port details, you
need to add the devices to the on-demand troubleshooting list. Add the device to the on-demand
troubleshooting list from Tools > On Demand Troubleshooting.

• In Cisco vManage Release 20.6.1 and earlier releases, On Demand Troubleshooting is part of the
Monitor menu.

• In Cisco vManage Release 20.7.1 and earlier releases, the SAIE flow is called the deep packet inspection
(DPI) flow.

• Ensure that no Cisco or third-party APIs that instruct on-demand troubleshooting to stop are called. These
APIs prevent on-demand troubleshooting from compiling information.

Note

To enhance the application visibility, the data collection process on the device generates aggregated
application statistics usage data, which in turn reduces the size of the statistics data files that are processed
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by default on the management plane. This enhancement allows Cisco SD-WANManager to collect SAIE
data efficiently and reduce the processing time of the management plane.

2. Under Applications in the left pane, click SAIE Applications. The right pane displays SAIE flow
information for the device.

• When displaying the SAIE flow usage, peak usage is shown to be higher from one time interval than for
another for the same time period. This situation occurs because the data is not yet available from the
statistics database to display in Cisco SD-WAN Manager. Cisco SD-WAN Manager displays only
available data and then plots that data in the appropriate axis.

• In Cisco vManage Release 20.7.1 and earlier releases, SAIE Applications is called DPI Applications.

Note

The upper part of the right pane contains:

• Filter option: Click the Filter option to view a drop-down menu to choose the desired VPN and Local
TLOC. Click Search. Click a predefined or custom time period for which to view the data.

Filtering Local TLOC : Dia is supported only for Cisco vEdge devices.Note

• SAIE flow information in graphical format.

• SAIE flow graph legend—Select an application family to display information for just that flow. Click
theTotal Network Traffic check box to display flow information as a proportion of total network traffic.

The lower part of the right pane contains:

• Filter criteria.

• SAIE flow information table that lists all application families sorted by usage. By default, the top six
application families are selected. The graphical display in the upper part of the right pane plots the flow
and usage of the selected application families.

• Click the check box on the left to select or deselect application families. You can choose to view
information for a maximum of six application families at one time.

• Click an application family to view applications within the family.

• Click an application to view the source IP addresses of the devices accessing the application. The
Traffic per TLOC pie chart next to the graph displays traffic distribution per TLOC (color).

• To re-arrange the columns, drag the column title to the desired position.

View Interface MTU Information
1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.
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2. Choose a device by clicking its name in the Hostname column.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list in the right pane, choose Interface Detail.

View Interfaces in Management VPN or VPN 512
VPN 512 is commonly used for out-of-band management traffic. To display information about the interfaces
in VPN 512 on a router:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Locate the device that you want to view the status for. You can either scroll through the list of devices in
the device table or enter a keyword in the search bar.

3. Choose the device by clicking its name in the Hostname column.

4. In the left pane, click Real Time.

5. From the Device Options drop-down list in the right pane, choose Interface Detail.

6. In the Select Filter dialog box, click Show Filters if you want to use filters. Otherwise click Do Not
Filter.

7. In the Search bar, enter 512, which is the management VPN.

CLI equivalent: show interface vpn 512.

View License Information
To view license information on a device, perform the following steps:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that is displayed.

3. Click Real Time in the left pane.

4. Click Device Options, and choose one of the following commands:

DescriptionCommandDevice Option

Display the licenses for the
software packages used by Cisco
Catalyst SD-WAN.

show licensesSmart License <info>
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View Logging Information
To view logging information on a device, perform the following steps:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that is displayed.

3. Click Real Time in the left pane.

4. Click Device Options and choose the following command:

DescriptionCommandDevice Option

Displays the settings for logging
syslog messages.

show loggingLogging

View Log of Certificate Activities
To view the status of certificate-related activities, use the Cisco SD-WAN Manager Configuration >
Certificates window.

1. From the Cisco SD-WAN Manager toolbar, click the tasks icon. Cisco SD-WAN Manager displays a list
of all running tasks along with the total number of successes and failures.

2. Click a row to see details of a task. Cisco SD-WANManager opens a status window displaying the status
of the task and details of the device on which the task was performed.

View Log of Configuration Template Activities
To view a log of activities related to creation of configuration templates and the status of attaching configuration
templates to devices:

1. From the Cisco SD-WAN Manager menu, choose Configuration > Devices.

2. Choose WAN Edge List or Controllers, and choose a device.

3. For the desired device, click ... and choose Template Log.

View Loss Percentage, Latency, Jitter, and Octet Information for Tunnels
View the loss percentage, latency, jitter, and octets for tunnels in a single chart option in Cisco SD-WAN
Manager.
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Table 40: Feature History

DescriptionRelease InformationFeature Name

You can view the loss percentage,
latency, jitter, and octet information
for tunnels in a single chart option
in Cisco SD-WAN Manager.

Cisco IOS XE Catalyst SD-WAN
Release 17.5.1a

Cisco SD-WAN Release 20.5.1

Cisco vManage Release 20.5.1

View Loss Percentage, Latency,
Jitter, and Octet Information for
Tunnels

View Loss Percentage, Latency, Jitter, and Octets for Tunnels

You can choose the Real Time option or other time frames to view tunnel information in the graph.

To view loss percentage, latency, jitter, and octets in Cisco SD-WAN Manager:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device.

3. In the left pane, click Tunnel under the WAN area. The right pane displays information about all tunnel
connections.

4. In the right pane, click Chart Options to choose the format in which you want to view the information.
Click Loss Percentage/Latency/Jitter/Octets for troubleshooting tunnel information.

The upper part of the right pane contains the following elements:

• Data for each tunnel is graphed based on time.

• Legend for the graph—Choose a tunnel to view information for just that tunnel. Lines and data points
for each tunnel are uniquely colored.

The lower part of the right pane contains the following elements:

• Search bar—Includes the Search Options filter to filter the table based on a Contains or a Match criteria.

• Tunnel Table—Lists the jitter, latency, loss percentage, and other data about all the tunnel end points.
By default, the first six tunnels are selected. The graphical display in the upper part of the right pane
plots information for the selected tunnels.

• Click the column drop-down lists to enable or disable all of the descriptions.

• Check the check box to the left to select and deselect tunnels. You can choose and view information
for a maximum of six tunnels at one time.

View Multicast Information
1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.
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2. Choose a device from the list of devices that displays.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list, choose one of the following commands as relevant:

DescriptionCommandDevice Option

View topology information about
the Multicast Domain

show multicast topologyMulticast Topology

View peers that support Multicastshow omp multicast
multicast-auto-discover

OMP Multicast Advertised
Autodiscover or OMP Multicast
Received Autodiscover

View information about IPsec
tunnels between Multicast peers

show multicast tunnelMulticast Tunnels

View Multicast reverse-path
forwarding information

show multicast rpfMulticast RPF

View Multicast replicatorsshow multicast replicatorMulticast Replicator

View Multicast routes that OMP
has learned from PIM join
messages

show omp multicast-routesOMPMulticast Advertised Routes
or OMPMulticast Received Routes

View NMS Server Status
1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a Cisco SD-WAN Manager device from the list of devices that is displayed.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list, choose NMS Server Running.

DescriptionCommandDevice Option

Displays whether a Cisco SD-WAN
Manager NMS server is
operational.

This device option is available from
Cisco vManage Release 20.6.1.

show nms-server runningNMS Server Running

View Device Configuration
1. From the Cisco SD-WAN Manager menu, choose Configuration > Devices .
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2. Click WAN Edge List or Controllers.

3. To view the running configuration, for the desired device, click … and choose Running Configuration.

To view the local configuration, for the desired device, click … and choose Local Configuration.

View Routing Information
1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that appears.

3. Click Real Time in the left pane.

4. Click Device Options, and choose one of the following commands as relevant:

DescriptionCommandDevice Options

Displays information about the IP
route table entries.

Displays the IPv6 entries in the
local route table.

show ip routes

show ipv6 routes

IP Routes

Displays information about
forwarding table entries.

Display the IPv6 entries in the local
forwarding table.

show ip fib

show ipv6 fib

IP FIB

Displays information about a
summary of active entries in the
multicast FIB.

show ip mfib summaryIP MFIB Summary

Displays information about
outgoing Interfaces from the
multicast FIB.

show ip mfib oilIP MFIB OIL

Displays information about
statistics for active entries in the
multicast FIB.

show ip mfib statsIP MFIB Statistics

Displays OMP peers and their
peering sessions.

show omp peersOMP Peers

Displays information about the
OMP sessions running between
Cisco SD-WAN Controller and the
routers.

show omp summaryOMP Summary
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DescriptionCommandDevice Options

Displays OMP routes.

From Cisco vManage Release
20.11.1, you can download OMP
route details in JSON or CSV
formats for Cisco IOS XE Catalyst
SD-WAN devices.

show omp routes

show sdwan omp routes

OMP Received Routes or OMP
Advertised Routes

Displays OMP TLOCs.show omp tlocsOMP Received TLOCs or OMP
Advertised TLOCs

Displays information about the
Interfaces running OSPF.

show ospf interfaceOSPF Interfaces

Displays information about the
OSPF neighbors.

show ospf neighborOSPF Neighbors

Displays routes learned fromOSPF.show ospf routesOSPF Routes

Displays a summary of the OSPF
link-state database entries.

show ospf database-summaryOSPF Database Summary

Displays information about the
OSPF link-state database entries.

show ospf databaseOSPF Database

Display OSPF external routes.
External routes are OSPF routes
that are not within the OSPF AS
(domain).

Not applicableOSPF External Database

Display the OSPF processes.show ospf processOSPF Processes

Displays information about
interfaces running PIM.

show pim interfacePIM Interfaces

Displays information about PIM
neighbors.

show pim neighborPIM Neighbors

Displays information about
PIM-related statistics.

show pim statisticsPIM Statistics

Displays information about IPv6
interfaces on Cisco Cisco IOS XE
Catalyst SD-WAN devices.

From Cisco vManage Release
20.6.1, this device option is
available on all Cisco IOS XE
Catalyst SD-WAN devices and
Cisco vEdge devices.

show ipv6 interfaceInterface Detail
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View Services Running on Cisco Catalyst SD-WAN Manager
1. From the Cisco SD-WAN Manager menu, choose Administration > Cluster Management.

2. Under Service Configuration, click the hostname of the desired Cisco SD-WAN Manager server. The
screen displays the process IDs of all the Cisco SD-WAN Manager services that are enabled on Cisco
SD-WAN Manager.

View SFP Information
To view SFP information on a router, perform the following steps:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that is displayed.

3. Click Real Time in the left pane.

4. Click Device Options, and choose one of the following commands:

DescriptionCommandDevice Option

Displays detailed SFP status and
digital diagnostic information.

show interface sfp detailSFP Detail

Displays SFP digital diagnostic
information.

show interface sfp detailSFP Diagnostic

Displays SFP measurement data.show interface sfp detailSFP Measurement Value

Displays SFP alarm information for
the measurements.

show interface sfp detailSFP Measurement Alarm

View Site Health Dashlet
Minimum supported release: Cisco vManage Release 20.10.1

You can view the overall health across all sites in the Site Health dashlet on theMonitor Overview dashboard.

The Site Health dashlet displays the health, which is calculated by the average Quality of Experience (QoE)
across all sites. The site health depends on the health metrics of devices, tunnels, and applications at that site.

Starting from Cisco Catalyst SD-WAN Manager Release 20.12.1, a bar graph displays the bandwidth usage
information for each site, and changes in bandwidth from the last time period. You can filter the view based
on health status using the drop-down list for Good Performing Sites, Fair Performing Sites, and Poor
Performing Sites.

Click View Details to open the site table view window.
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View Site Health in Table View
Minimum supported release: Cisco vManage Release 20.10.1

In the sites table view you can view the site health, tunnel health, device health, application health, and
application usage.

The sites table view displays all the sites by default and the overall health scores for sites, devices, tunnels,
and applications. The table also displays the application usage data for the last one hour.

Site Health Metrics

The average health metric of sites is calculated as follows:

ConditionHealth

All applications, WAN edge devices, and tunnels are
in good state.

Good

Any one application, WAN edge device, or tunnel in
fair state.

Fair

Any one application, WAN edge device, or tunnel in
poor state.

Poor

View Site Health in Heatmap View
Minimum supported release: Cisco vManage Release 20.10.1

In the heatmap view, the grid of colored squares displays the site health as Good, Fair, or Poor. You can
hover over a square or click to display additional details of a site at a specific time. The data shown here in
the aggregated dats for the last three hours. Click the time interval drop-down list to change the time selection
and filter the data for a specific interval.

View the Software Versions Installed on a Device
1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device by clicking its name in the Hostname column.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list in the right pane, choose Software Versions.
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View and Open TAC Cases
Table 41: Feature History

DescriptionRelease InformationFeature Name

This feature allows you to access
Support Case Manager (SCM)
wizard using Cisco SD-WAN
Manager. You can create, view, or
edit the support cases directly from
Cisco SD-WAN Manager without
having to go to a different Case
Manager portal.

Cisco IOS XE Catalyst SD-WAN
Release 17.9.1a

Cisco vManage Release 20.9.1

Cisco SD-WAN Release 20.9.1

Access TAC Cases from Cisco
SD-WAN Manager

This feature introduces various
enhancements to the Settings page
in Cisco SD-WAN Manager and
the Support Case Manager (SCM)
wizard.

Cisco IOS XE Catalyst SD-WAN
Release 17.11.1a

Cisco vManage Release 20.11.1

SCM Integration Improvements

Supported Devices

This feature is supported on both Cisco Catalyst SD-WAN and Cisco IOS XE Catalyst SD-WAN devices.

Overview

For any Cisco SD-WANManager troubleshooting issues, you raise a support case in the SCM portal. In Cisco
SD-WAN Manager, there is a provision to upload an Admin-Tech File to a specific Service Request (SR) on
the SCM server by providing the SR number and the token details.

Starting from Cisco vManage Release 20.9.1, you can access SCM portal from Cisco SD-WAN Manager. In
the SCM portal, you can create, view, or upload an admin-tech file. For more information on Admin-tech
files, see Admin-Tech File.

Prerequisites to Access TAC Cases

• You need active Cisco single sign-on (SSO) login credentials to access the SCMWizard and the cloud
server.

View TAC Cases

Perform the following steps to view TAC cases from Cisco SD-WAN Manager.

1. From the Cisco SD-WAN Manager menu, choose Tools > TAC Cases.

2. Login to the SCM portal using Cisco SSO login.

The TAC Support Cases portal displays a list of cases.

Open a TAC Case

Perform the following steps to open a TAC Case from Cisco SD-WAN Manager.
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1. From the Cisco SD-WAN Manager menu, choose Tools > TAC Cases.

2. In the TAC Support Cases page, click Open a Case.

3. Enter all the other relevant case details.

4. Click Create.

The TAC Support Cases portal now displays the updated list of cases.

For more information about using SCM portal, refer Cisco TAC Connect.

View Template Log and Device Bringup

View Log of Template Activities

A log of template activities contains information that relates to creating, editing, and deleting configuration
templates, and the status of attaching configuration templates to devices. This information can be useful for
troubleshooting.

To view a log of template activities:

1. From the Cisco SD-WAN Manager menu, choose Configuration > Devices.

2. Click WAN Edge List or Controllers, and select the device.

3. Click …, and click Template Log.

View Status of Device Bringup

You can view the status of the operations involved in bringing a router or controller up in the overlay network.
This information can help you monitor these operations.

To view the status of a device bringup:

1. From the Cisco SD-WAN Manager menu, choose Configuration > Devices.

2. Click WAN Edge List or Controllers, and select the device.

3. Click …, and click Device Bring Up.

View the Status of a Cisco Catalyst SD-WAN Validator
You have the following options to view the status of a Cisco Catalyst SD-WAN Validator.

Use the Dashboard Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview.

Cisco vManage Release 20.6.1 and earlier: From the Cisco SD-WANManager menu, chooseDashboard >
Main Dashboard.

2. For releases before Cisco vManage Release 20.6.1, click the upward or downward arrow next to Cisco
vBond.
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For Cisco vManage Release 20.6.1 and later, click the number representing the number of Cisco SD-WAN
Validator orchestrators in your overlay network.

3. To know the status of the Cisco Catalyst SD-WAN Validator, see the Reachability column in the dialog
box that opens.

Use the Geography Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Geography.

2. Click Filter and choose vBond under Types.

3. Click the Cisco SD-WAN Validator icon to check its status.

Use the Network Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.1 and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Locate the Cisco Catalyst SD-WAN Validator that you want to view the status for. You can either scroll
through the list of devices in the device table or enter vBond as the keyword in the search bar.

3. Click the relevant Cisco Catalyst SD-WAN Validator under the Hostname column. The Control
Connections screen opens by default and displays information about all control connections that the
device has with other controller devices in the network.

View Device Status in the Overlay Network
You have the following options to view the status of a device in the overlay network.

Use the Dashboard Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, chooseDashboard >
Main Dashboard.

2. For releases before Cisco vManage Release 20.6.1, click the upward or downward arrow next to WAN
Edge.

For Cisco vManage Release 20.6.1 and later, click the number representing the number of WAN Edge
devices.

3. To know the status of the WAN edge device, see the Reachability column in the dialog box that opens.

Use the Geography Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Geography.

2. Click Filter and choose WAN Edge under Types.

3. Click the router icon to check its status.
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Use the Network Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Locate the WAN edge router that you want to view the status for. You can either scroll through the list
of devices in the device table or enter a keyword in the search bar.

3. Click the relevant WAN edge router under the Hostname column. The System Status screen opens by
default.

View Top Applications Pane
TheTop Applications pane in the Cisco SD-WANManagerMonitor >Overview page displays the SD-WAN
Application Intelligence Engine (SAIE) flow information for traffic transiting WAN Edge routers in the
overlay network.

In Cisco vManage Release 20.7.1 and earlier releases, the SAIE flow is called the deep packet inspection
(DPI) flow.

Note

To list top applications by VPN, select a VPN from the drop-down list. To select a time period for which to
display data, click the Time drop-down list.

To list top applications in a sidebar:

1. Click View Details to open the Top Applications sidebar. It displays a more detailed view of the same
information.

2. In SAIE Application, from the VPN drop-down list, select the desired VPN, and then click Search.

In Cisco vManage Release 20.7.1 and earlier releases, SAIE Application is called DPI Application.Note

• Click Chart to list the applications.

• Click Details to display more information about the applications.

3. Click SSL Proxy, from the View by Policy Actions drop-down list, select the policy action. All Policy
Action, Encrypted, Un-Encrypted, Decrypted view are supported. From the VPN drop-down list, select
the desired VPN, and then click Search. TheHour option displays statistics for the selected hour duration.

• Click Chart to list the SSL applications.

• Click Details to display more information about the SSL applications.

4. Click X to close the window and return to the Monitor > Overview page.
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In Cisco vManage Release 20.6.1 and earlier releases, Cisco SD-WAN Manager has the following behavior:Note

• The Top Applications pane is part of the Dashboard > Main Dashboard page.

• A filter icon instead of a drop-down list lists the VPN options and indicates the time period for which to
display data.

• An expand icon instead of the View Details button opens the Top Applications pop-up window.

Flow DPI data is collected by Cisco SD-WAN Manager on schedule but processed on user requests. Flow
DPI based reports are available after data is processed.

Note

View the Status of a Cisco Catalyst SD-WAN Controller
You have the following options to view the status of a Cisco Catalyst SD-WAN Controller.

Use the Dashboard Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview.

Cisco vManage Release 20.6.1 and earlier: From the Cisco SD-WANManager menu, chooseDashboard >
Main Dashboard.

2. For releases before Cisco vManage Release 20.6.1, click the upward or downward arrow next to Cisco
vSmart.

For Cisco vManage Release 20.6.1 and later, click the number representing the number of Cisco SD-WAN
Controller in your overlay network.

3. To know the status of the Cisco Catalyst SD-WAN Controller, see the Reachability column in the dialog
box that opens.

Use the Geography Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Geography.

2. Click Filter and choose vSmart under Types.

3. Click the Cisco SD-WAN Controller icon to check its status.

Use the Network Screen

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.1 and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Locate the Cisco Catalyst SD-WAN Controller that you want to view the status for. You can either scroll
through the list of devices in the device table or enter vBond as the keyword in the search bar.
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3. Click the relevant Cisco Catalyst SD-WANController instance under theHostname column. TheControl
Connections screen opens by default and displays information about all control connections that the
device has with other controller devices in the network.

View Tunnel Connections
To view details about the top 100 data plane tunnels between Cisco Catalyst SD-WAN devices with the lowest
average latency, do the following:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Tunnels.

The Tunnels table lists the following information about all tunnel end points:

• Health

• State

• Quality of Experience (QoE) score. The QoE score rates the quality of experience of an application
that a network can deliver for a period of time.

• Local IP and remote IP

• Average latency, loss, and jitter data

The health of a tunnel is defined based on the following criteria:

• Good: If the QOE score is between 8 and 10, and the tunnel status is 1/1.

• Fair: If the QOE score is between 5 and 7, and the tunnel status is 1/1.

• Poor: If the QOE score is between 1 and 4, or the tunnel status is 0/1.

The tunnel information is available in Cisco SD-WAN Manager as a separate menu starting from Cisco
vManage Release 20.7.1.

Note

To view tunnel connections of a specific device, do the following:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that is displayed.

3. In the left pane, click TLOC under the WAN area. The right pane displays information about all tunnel
connections.

4. (Optional) Click the Chart Options drop-down list to choose the type of data to view.

You can also choose a predefined time period or a custom time period to sort the data.
5. (Optional) In the lower part of the right pane, use the filter option in the search bar to customize the table

fields you want to view.
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The tunnel table lists average latency, loss, and jitter data about all tunnel end points. By default, the first
six tunnels are selected. The graphical display in the upper part of the right pane plots information for the
selected tunnels.

6. (Optional) Click the check box to the left to select and deselect tunnels. You can select and view information
for a maximum of 30 tunnels at one time.

7. (Optional) Click Application Usage to the right to view the SD-WAN Application Intelligence Engine
(SAIE) flow information for that TLOC.

• Beginning with Cisco vManage Release 20.8.1, the Application Usage column and the Application
Usage links are removed from the Monitor > Devices > WAN – Tunnel window. After you have
configured on-demand troubleshooting for a device, you can view SAIE usage data based on the selected
filters or based on application families sorted by usage.

• In Cisco vManage Release 20.7.x and earlier releases, the SAIE flow is called the deep packet inspection
(DPI) flow.

For more information on configuring on-demand troubleshooting, see On-Demand Troubleshooting. For more
information on viewing SAIE flows, see View SAIE Flows.

Note

View Tunnel Health in Table View
Minimum supported release: Cisco vManage Release 20.10.1

In the Monitor Tunnels window the table shows information about the health of tunnels created in the last
hour, displaying a maximum of 10,000 tunnels.

The tunnel information includes the following:

• Tunnel health

• State

• Quality of Experience (QoE)

• Average latency

• Average loss

• Average jitter

• Local IP address

• Remote IP address

You can also view the tunnel health on a single site by clicking All Sites and selecting the site ID to enter the
single site view.

Tunnel Health Metrics

The average health metric of tunnels is calculated as follows:
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Evaluation LogicStatusQoEHealth

All attributes metUPQoE >= 8Good

All attributes metUP5 <= QoE < 8Fair

Any attributes metDOWN0 < QoE< 5Poor

View Tunnel Health in Heatmap View
Minimum supported release: Cisco vManage Release 20.10.1

In the heatmap view, a grid of colored squares displays the tunnel health as Good, Fair, or Poor. You can
hover over a square or click to display additional details of a tunnel at a specific time. Click the time interval
drop-down list to change the time selection and filter the data for a specific interval.

You can view the tunnel health on a single site by clicking All Sites and selecting the site ID to enter the
single site view.

View Tunnel Health Dashlet
Minimum supported release: Cisco vManage Release 20.10.1

You can view details about the tunnel health on Monitor Overview dashboard.

The Tunnel Health dashlet lists the following information about all tunnel end points:

• Health

• Average latency, loss, and jitter data

You can view the tunnel health across all sites in a graphical format. You can also filter the tunnel information
based on the health status using the drop-down list for Good Tunnels, Fair Tunnels, and Poor Tunnels, and
Latency, Loss, and Jitter.

Starting from Cisco Catalyst SD-WAN Manager Release 20.12.1, a bar graph displays current status of the
tunnel and the change in status from the last time period.

Click View Details to open the Monitor > Tunnels window to view the tunnel health in table view.

View Tunnel Loss Statistics

View Data Plane Tunnel Loss Statistics

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device from the list of devices that displays.

3. Click Real Time in the left pane.

4. From the Device Options drop-down list, choose Tunnel Statistics.
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View Traffic Loss for Application-Aware Routing

1. From the Cisco SD-WAN Manager menu, choose Monitor > Overview.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, chooseDashboard >
Main Dashboard.

2. Scroll down to the Application-Aware Routing pane.

You can also use the show app-route statistics command to view traffic loss for application-aware routing.

View WAN Interfaces
Transport interfaces in VPN 0 connect to a WAN network of some kind, such as the Internet, Metro Ethernet
network, or an MPLS network.

You can view information about WAN interfaces on a device using one of the following options:

Real Time Pane

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Locate the device that you want to view the status for. You can either scroll through the list of devices in
the device table or enter a keyword in the search bar.

3. Choose the device by clicking its name in the Hostname column.

4. In the window that opens, choose Real Time in the left pane.

5. From the Device Options drop-down in the right pane, choose Control WAN Interface Information.

Starting from Cisco Catalyst SD-WAN Manager Release 20.12.1, a new field Bind Interface is introduced
to display mapping relationship between the loopback interfaces and the physical interfaces.

Note

Interface Pane

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. From the Device Groups drop-down list, choose the device group to which the device belongs.

3. Choose the device by clicking its name in the Hostname column.

4. In the left pane, choose Interface.

View WAN Edge Health Dashlet
Minimum supported release: Cisco vManage Release 20.10.1
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You can view the state for each WAN edge device and the number of WAN edge devices in that state in the
WAN Edge Health dashlet on Monitor Overview dashboard.

You can view the state for each WAN edge device and the number of WAN edge devices in that state in the
WAN Edge Health dashlet on Monitor Overview dashboard.

Starting from Cisco Catalyst SD-WAN Manager Release 20.12.1, a bar chart displays the CPU utilization of
WAN edge devices at a site, and the changes in CPU utilization from the last time period.

You can filter the WAN Edge Health dashlet view based on the health status using the drop-down list for
Good Devices, Fair Devices, and Poor Devices and also for CPU Load and Memory Load.

Click View Details to open the Monitor > Devices window to view the device health in table view.

View VRRP Information
1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device.

3. Click Real Time from the left pane.

4. Click Device Options, and choose VRRP Information.

View Device Interfaces
To view information about interfaces on a device:

1. From the Cisco SD-WAN Manager menu, choose Monitor > Devices.

Cisco vManage Release 20.6.x and earlier: From the Cisco SD-WANManager menu, choose Monitor >
Network.

2. Choose a device by clicking its name in the Hostname column.

3. Click Interface in the left pane. The right pane displays interface information for the device.

The upper part of the right pane contains:

• Chart Options bar—Located directly under the device name, this bar includes:

• Chart Options drop-down—Click Chart Options to choose how the data should be displayed.

• IPv4 & IPv6 drop-down—Click IPv4 & IPv6 to choose the type of interfaces to view. The
information is displayed in graphical format. By default, the graph is Combined, showing interfaces
on which both IPv4 and IPv6 addresses are configured. To view IPv4 and IPv6 interfaces in separate
graphs, select the Separated toggle button.

• Time periods—Click eitherReal Time, a predefined time period, or a custom time period for which
to view the data.

• Interface information in graphical format.

• Interface graph legend—Choose an interface to display information for just that interface.
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The lower part of the right pane contains:

• Filter criteria.

• Interface table, which lists information about all interfaces. By default, the first six interfaces are displayed.
The graphical display in the upper part of the right pane plots information for the selected interfaces.

• Check the check box to the left to select and deselect interfaces. You can select and view information
for a maximum of 30 interfaces at a time.

• To rearrange the columns, drag the column title to the desired position.

• For cellular interfaces, click the interface name to view a detailed information about the cellular
interface.

To view interface status and interface statistics, see show interface and show interface statistics.
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