Managing Site-to-Site VPNs: The Basics

A virtual private network (VPN) consists of multiple remote peers transmitting private data securely to one
another over an unsecured network, such as the Internet. Site-to-site VPNs use tunnels to encapsulate data
packets within normal IP packets for forwarding over IP-based networks, using encryption to ensure privacy
and authentication to ensure integrity of data.

In Cisco Security Manager, site-to-site VPN are implemented based on IPsec policies that are assigned to
VPN topologies. An IPsec policy is a set of parameters that define the characteristics of the site-to-site VPN,
such as the security protocols and algorithms that will be used to secure traffic in an [Psec tunnel. Security
Manager translates [Psec policies into CLI commands that can be deployed to the devices in the VPN topology.
Several policy types might be required to define a full configuration image that can be assigned to a VPN
topology, depending on the IPsec technology type.

The Site-to-Site VPN Manager defines and configures site-to-site VPN topologies and policies on Cisco I0S
security routers, PIX Firewalls, Catalyst VPN Service Modules, and Adaptive Security Appliance (ASA)
firewall devices.

Je

Tip In ASA documentation, site-to-site VPNs are called LAN-to-LAN VPNSs. These phrases are equivalent, and
we use “site-to-site VPN” in this documentation.

You can access the Site-to-Site VPN Manager by selecting M anage > Site-To-Site VPNS or clicking the
Site-To-Site VPN Manager button on the toolbar.

You can also configure shared policies in Policy view and view and configure topologies in Device view. In
Policy View, you can assign IPsec policies to VPN topologies.

This chapter contains the following topics:

* Understanding VPN Topologies , on page 2

* Understanding IPsec Technologies and Policies , on page 5

* Accessing Site-to-Site VPN Topologies and Policies , on page 20
* Site-To-Site VPN Discovery , on page 23

* Creating or Editing VPN Topologies , on page 31

* Creating or Editing Extranet VPNs , on page 72

* Deleting a VPN Topology , on page 76
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Understanding VPN Topologies

A VPN topology specifies the peers and the networks that are part of the VPN and how they connect to one
another. After you create a VPN topology, the policies that can be applied to your VPN topology become
available for configuration, depending on the assigned IPsec technology.

Security Manager supports three main types of topologies—hub and spoke, point to point, and full mesh, with
which you can create a site-to-site VPN. Not all policies can be applied to all VPN topologies. The policies
that can be applied depend on the IPsec technology that is assigned to the VPN topology. In addition, the
IPsec technology that is assigned to a VPN depends on the topology type. For example, the DMVPN and
Easy VPN technologies can only be applied in a hub-and-spoke topology.

For more information, see Understanding IPsec Technologies and Policies , on page 5.
The following topics describe:

* Hub-and-Spoke VPN Topologies , on page 2

» Point-to-Point VPN Topologies , on page 3

* Full Mesh VPN Topologies , on page 4

* Implicitly Supported Topologies , on page 5

Hub-and-Spoke VPN Topologies

In a hub-and-spoke VPN topology, multiple remote devices (spokes) communicate securely with a central
device (hub). A separate, secured tunnel extends between the hub and each individual spoke.

The following illustration shows a typical hub-and-spoke VPN topology.
Figure 1: Hub-and-spoke VPN Topology
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This topology usually represents an intranet VPN that connects an enterprise’s main office with branch offices
using persistent connections to a third-party network or the Internet. VPNs in a hub-and-spoke topology
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provide all employees with full access to the enterprise network, regardless of the size, number, or location
of its remote operations.

A hub is generally located at an enterprise’s main office. Spoke devices are generally located at an enterprise’s
branch offices. In a hub-and-spoke topology, most traffic is initiated by hosts at the spoke site, but some traffic
might be initiated from the central site to the spokes.

If the hub in a hub-and-spoke configuration becomes unavailable for any reason, IPsec failover transfers
tunnel connections seamlessly to a failover (backup) hub, which is used by all spokes. You can configure
multiple failover hubs for a single primary hub.

In a hub-and-spoke VPN topology, all IPsec technology types can be assigned except GET VPN.

Related Topics
* Understanding [Psec Technologies and Policies , on page 5
» Implicitly Supported Topologies , on page 5

* Configuring IKE and IPsec Policies

Point-to-Point VPN Topologies

In a point-to-point VPN topology, two devices communicate directly with each other, without the option of
[Psec failover as in a hub-and-spoke configuration. To establish a point-to-point VPN topology, you specify
two endpoints as peer devices. Because either of the two devices can initiate the connection, the assigned
IPsec technology type can be only regular IPsec or [Psec/GRE.

In Security Manager, you can configure a special type of regular IPsec point-to-point VPN called an Extranet.
An Extranet VPN is a connection between a device in your managed network and an unmanaged device, such
as a router in your service provider’s network, a non-Cisco device, or simply a device in your network that
is being managed by a different group (that is, one that does not appear in the Security Manager inventory).

The following illustration shows a typical point-to-point VPN topology.
Figure 2: Point-to-Point VPN Topology
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Related Topics

* Understanding IPsec Technologies and Policies , on page 5
» Implicitly Supported Topologies , on page 5

* Creating or Editing VPN Topologies , on page 31

* Creating or Editing Extranet VPNs , on page 72

* Configuring IKE and IPsec Policies
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Full Mesh VPN Topologies

A full mesh topology works well in a complicated network where all peers need to communicate with each
other. In this topology type, every device in the network communicates with every other device through a
unique [Psec tunnel. All devices have direct peer relationships with one another, preventing a bottleneck at
the VPN gateway device, and saving the overhead of encryption and decryption on the device.

You can assign only Regular IPsec, IPsec/GRE, and GET VPN technologies to a full mesh VPN topology.

The following illustration shows a typical full mesh VPN topology.
Figure 3: Full Mesh VPN Topology

Internet

A full mesh network is reliable and offers redundancy. When the assigned technology is GRE and one device
(or node) can no longer operate, all the rest can still communicate with one another, directly or through one
or more intermediate nodes. With regular IPsec, if one device can no longer operate, a crypto access control
list (ACL) that specifies the protected networks, is created per two peers.

GET VPN is based on the group trust model. In this model, group members register with a key server. The
key server uses the Group Domain of Interpretation (GDOI) protocol for distributing the security policy and
keys for encrypting traffic between the group members. Because you can configure a primary key server and
secondary key servers that synchronize their policies with the primary one, if the primary key server becomes
unavailable, a secondary key server can take over.

\}

Note When the number of nodes in a full mesh topology increases, scalability may become an issue—the limiting

factor being the number of tunnels that the devices can support at a reasonable CPU utilization.
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Related Topics
* Understanding IPsec Technologies and Policies , on page 5
* Implicitly Supported Topologies , on page 5
* Creating or Editing VPN Topologies , on page 31

* Configuring IKE and IPsec Policies

Implicitly Supported Topologies
In addition to the three main VPN topologies, other more complex topologies can be created as combinations

of these topologies. They include:

* Partial mesh—A network in which some devices are organized in a full mesh topology, and other devices
form either a hub-and-spoke or a point-to-point connection to some of the fully meshed devices. A partial
mesh does not provide the level of redundancy of a full mesh topology, but it is less expensive to
implement. Partial mesh topologies are generally used in peripheral networks that connect to a fully
meshed backbone.

* Tiered hub-and-spoke—A network of hub-and-spoke topologies in which a device can behave as a hub
in one or more topologies and a spoke in other topologies. Traffic is permitted from spoke groups to their
most immediate hub.

* Joined hub-and-spoke—A combination of two topologies (hub-and-spoke, point-to-point, or full mesh)
that connect to form a point-to-point tunnel. For example, a joined hub-and-spoke topology could comprise
two hub-and-spoke topologies, with the hubs acting as peer devices in a point-to-point topology.

Related Topics
* Creating or Editing VPN Topologies , on page 31
* Hub-and-Spoke VPN Topologies , on page 2
* Point-to-Point VPN Topologies , on page 3

* Full Mesh VPN Topologies , on page 4

Understanding IPsec Technologies and Policies

Security Manager provides seven types of IPsec technologies that you can configure on the devices in your
site-to-site VPN topology—Regular IPsec, IPsec/GRE, GRE Dynamic IP, standard and large scale DMVPN,
Easy VPN, and GET VPN. The assigned technology determines which policies you can configure for the
VPN.

You assign an [Psec technology to a VPN topology during its creation. After an IPsec technology is assigned
to a VPN topology, you cannot change the technology, other than by deleting the VPN topology and creating
anew one. See Defining the Name and [Psec Technology of a VPN Topology , on page 34.

The following topics explain some basic concepts about [Psec technologies and site-to-site VPN policies:

* Understanding Mandatory and Optional Policies for Site-to-Site VPNs , on page 6
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* Overview of Site-to-Site VPN Policies , on page 8

» Understanding Devices Supported by Each IPsec Technology , on page 11
* Including Unmanaged or Non-Cisco Devices in a VPN , on page 13

* Understanding and Configuring VPN Default Policies , on page 14

* Using Device Overrides to Customize VPN Policies , on page 16

* Understanding VRF-Aware [Psec , on page 16

Understanding Mandatory and Optional Policies for Site-to-Site VPNs

Some site-to-site VPN policies are mandatory, which means that you must configure them to create a VPN
topology or to save your changes when editing them. Most mandatory policies have predefined defaults, which

you can use to complete the definition of a VPN topology, but you typically must edit the policies to ensure
their settings work for your network.

Optional policies, which you need to configure only if you desire the services defined by the policy, do not

come with predefined defaults.

Je

Tip

You can configure your own mandatory policy defaults by creating shared policies that specify the desired
settings, and then by selecting these shared policies when creating a VPN. You can even make the shared
policies the defaults for the Create VPN wizard. However, these default policies do not apply when you create
Extranet VPNs; with Extranet VPNs, you must always configure the settings for mandatory policies as part
of the normal wizard flow. In addition, you cannot create a default policy for IKEv2 Authentication. For more

information, see Understanding and Configuring VPN Default Policies , on page 14.

Some mandatory policies are mandatory only under certain conditions. For example, an IKEv1 preshared key
policy is mandatory only if the default (mandatory) IKEv1 proposal uses preshared key authentication. If the
selected IKE authentication method is Certificate (RSA Signature), an IKEv1 Public Key Infrastructure policy
is mandatory (see Deciding Which Authentication Method to Use). If you allow IKEv2 negotiations in the
topology, an IKEv2 Authentication policy is mandatory.

The following table lists the mandatory and optional policies for each predefined technology that you can
assign to the devices in your site-to-site VPN topology.

Table 1: Site-to-Site VPN IPsec Technologies and Policies

Technology Mandatory Policies Optional Policies
Regular IPsec * IKE Proposal * VPN Global
See Understanding IPsec « IPsec Proposal Settings

Proposals for Site-to-Site VPNs.
* When allowing IKEv1, one of: IKEv1

Preshared Key or IKEv1 Public Key
Infrastructure

* When allowing IKEv2, IKEv2
Authentication
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Technology Mandatory Policies Optional Policies
IPsec/GRE (Generic Routing * IKE Proposal * VPN Global
Encapsulation) Settings

* [Psec Proposal
See Understanding GRE.

* One of: IKEv1 Preshared Key or IKEv1

Public Key Infrastructure

* GRE Modes
GRE Dynamic IP * IKE Proposal * VPN Global
See Understanding GRE ¢ [Psec Proposal Settings

Configuration for Dynamically
Addressed Spokes.

* One of: IKEv1 Preshared Key or IKEv1
Public Key Infrastructure

* GRE Modes
Dynamic Multipoint VPN * IKE Proposal * VPN Global
(DMVPN). Settings

* [Psec Proposal
See Understanding DMVPN.

* One of: IKEv1 Preshared Key or IKEv1

Public Key Infrastructure

* GRE Modes

Large Scale DMVPN * IKE Proposal * VPN Global
Settings

See Configuring Large Scale
DMVPNs.

* [Psec Proposal

* One of: IKEv1 Preshared Key or IKEv1
Public Key Infrastructure

* GRE Modes

* Server Load Balance

Easy VPN
See Understanding Easy VPN.

* IKE Proposal
* Easy VPN IPsec Proposal
* Client Connection Characteristics

* If any servers are IOS or PIX 6.3 devices:
User Group

* If any servers are ASA or PIX 7.0+ devices:

Connection Profiles

* IKEv1 Public
Key
Infrastructure
(mandatory if
using certificates)

* VPN Global
Settings
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Technology Mandatory Policies Optional Policies
GET VPN * Group Encryption * Global Settings

. for GET VPN
See Understanding Group « IKE Proposal for GET VPN

Encrypted Transport (GET) VPNs.
* One of: IKEv1 Preshared Key or IKEv1

Public Key Infrastructure

Regular IPSec VTI * IKE Proposal

See Configuring Tunnel Interface. « Peers

* One of: IKEv1 Preshared Key or IKEv1
Public Key Infrastructure

* IKEv2 Authentication

 Tunnel Interface with IPSec Profile

Related Topics
* Creating or Editing VPN Topologies , on page 31
* Understanding Devices Supported by Each IPsec Technology , on page 11
* Understanding and Configuring VPN Default Policies , on page 14
* Configuring IKE and IPsec Policies

* Understanding Policies

Overview of Site-to-Site VPN Policies

You can access site-to-site VPN policies by selecting M anage > Site-To-Site VPNSs, or by clicking the
Site-To-Site VPN Manager button on the toolbar, and then selecting the required policy in the Policies
selector of the Site-to-Site VPN window. You can also access site-to-site VPN policies from Device view or
Policy view. For more information, see Accessing Site-to-Site VPN Topologies and Policies , on page 20.

From version 4.21 onwards, Cisco Security Manager supports multi-peer crypto maps in site-to-site VPNs
for IKEv2. However, you can set up a multi-peer crypto map only through Flex Config.

\}

Note  After you configure the multi-peer crypto map, deploy, and discover the VPN topology, the next crypto map
in the sequence will not be generated. For deployments thereafter, single-peer crypto map will be negated and
multi-peer crypto map will be generated.

The following is a summary of all of the site-to-site VPN policies, some of which you cannot create as shared
policies. Note that some of these policies are documented in the sections that explain remote access VPN,
because the policies are used for both remote access and site-to-site VPNs. However, you must configure
these policies separately for each type of VPN.

* Client Connection Characteristics. See Configuring Client Connection Characteristics for Easy VPN.
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* Connection Profiles. See Configuring Client Connection Characteristics for Easy VPN.
» Easy VPN IPsec Proposal. See Connection Profiles Page.

* GRE Modes. See Understanding the GRE Modes Page.

* Group Encryption Policy. See Defining GET VPN Peers , on page 66.

* Group Members. See Configuring GET VPN Group Members.

* IKE Proposal. See Configuring an IKE Proposal.

* IKE Proposal for GET VPN. See Configuring the IKE Proposal for GET VPN.
* IKEv2 Authentication. See Configuring IKEv2 Proposal Policy Objects.

* [Psec Proposal. See Configuring IPsec Proposals in Site-to-Site VPNs

» Key Servers. See Configuring GET VPN Key Servers.

* Peers. See Defining the Endpoints and Protected Networks , on page 37.

* IKEv1 Preshared Key. See Configuring IKEv1 Preshared Key Policies.

* IKEv1 Public Key Infrastructure. See Configuring IKEv1 Public Key Infrastructure Policies in Site-to-Site
VPNs.

* Server Load Balance. See Configuring Server Load Balancing in Large Scale DMVPN.
* User Group Policy. See Configuring a User Group Policy for Easy VPN.

* VPN Global Settings. See Configuring VPN Global Settings.

* Global Settings for GET VPN. See Configuring Global Settings for GET VPN.

Configuring Multi-Peer Crypto Maps in Site-to-Site VPNs for IKEv2

Step 1

Step 2
Step 3
Step 4

From version 4.21 onwards, Cisco Security Manager supports multi-peer crypto maps in site-to-site VPNs
for IKEv2. However, you can set up a multi-peer crypto map only through Flex Config. You can create
multi-peer crypto maps for P2P, Hub and Spoke, or Full Mesh topologies.

This procedure describes how to configure multi-peer crypto maps in site-to-site VPNs for P2P, Hub and
Spoke, and Full Mesh topologies. For more information on site-to-site VPN tolopologies and policies, see
Accessing Site-to-Site VPN Topologies and Policies , on page 20.

Deploy the intended VPN topology - P2P, Hub and Spoke, or Full Mesh.
Note: Ensure the Connection Type is set to Bidirectional for Hub peer when using Hub-and-Spoke topology.

In Tools> Security Manager Admin > Deployment, uncheck the Deploy only new or modified Flexconfigs checkbox.
Click Add FlexConfig, select Type as Append, and enter the multi-peer CLI and the corresponding tunnel group CLI.
Enter the multi-peer support-specific CLI, as shown in the Figure 4: Multi Peer-Specific and Tunnel-Group CLI.

Managing Site-to-Site VPNs: The Basics .
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Figure 4: Multi Peer-Specific and Tunnel-Group CLI

4] Add FlexConfig -
Mame:* newflex197 Group: v
| Type: Append v
Description:
Negate For v

Q2ednbo s

tunnel-group 5.5.5.5 type ipsec-121 A
tunnel-group 5.5.5.5 ipsec-attributes

ikevl pre-shared-key cisco

ikevZ local-authentication pre-shared-key 0 cisco

ikevZ remote-authentication pre-shared-key 0 cisco

exit

crypto map CSM outside map 1 set peer 3.3.3.3 5.5.5.5

< >
Variables
Name Default Value Object Property Dim... Opti... Description
< [} >
Step 5 Do a preview configuration, deploy the new configuration, and rediscover the VPN topology for which you have configured

the multi-peer crypto map using Policy > Discover VPN Policies.

Step 6 After rediscovering the VPN topology, the multi-peer cryptomap CLI is negated and added each time a new deployment
is done. Refer the image below to see how the CLI gets negated.

Figure 5: CLI Negation

@ Config Version Viewer: 10,197.74,186
g

Proposed Config Type: | ASA (Delta) v

no crypto map CSM_ou‘.:side_ma'p i .2t peer 3.5.3.3 F.5.5.5
crypto map CSM_ou‘.:side_map 1 set peer 3.3.3.3

crypto map CSM_ou‘.:side_map 1 set peer 3.3.3.3 5.5.5.5

[ I I A
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Step 7 Ensure to remove the tunnel-group CLI and retain only the multi-peer CLI in Flex Configs for further deployments as
shown below.

Figure 6: Multi Peer-Specific CLI

Edit FlexConfig -

Name:* newflex197 Group: v
Type: Append v
Description:
MNegate For v

2edho B

L:rypto map C35M outside map 1 set peer 3.3.3.3 5.5.5.5

Variables
Name Default Value Object Property Dim... Opti... Description

Understanding Devices Supported by Each IPsec Technology

Each IPsec technology supports different devices as members of their topology. The following table describes
the basic device support. These requirements are enforced when you select devices for a VPN; in some cases,
the device lists are filtered to show only supported devices. In other cases, a device might be supported in one
role (for example, as a spoke), but not supported in another role; in these cases, you can select the wrong
device type, but you are prevented from saving the change (a message will explain the specific problem).

\}

Note From version 4.21 onwards, Cisco Security Manager terminates whole support, including support for any bug
fixes or enhancements, for all Aggregation Service Routers, Integrated Service Routers, Embedded Service
Routers, and any device operating on Cisco IOS software.

Managing Site-to-Site VPNs: The Basics .
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2

Tip  Some device models have NO-VPN versions, which do not support VPN configuration. Thus, although the
3845 model might be supported for a type of VPN, the 3845 NOVPN model is not supported. In addition, the
Cisco Catalyst 6500 series ASA Services Module (running software release 8.5(x)) does not support any type
of VPN.

Table 2: Devices Supported by Each IPsec Technology

Technology Supported Platforms

Regular IPsec Regular IPsec policies can be configured on Cisco IOS security routers
(including Aggregation Service Routers, or ASRs), PIX Firewalls, and
ASA 5500 series devices. Except for Extranet VPN, Catalyst VPN service
modules are also supported.

See Configuring IKE and IPsec
Policies.

IKEV2 is supported on ASA release 8.4(x) only. If you limit the topology
to IKEv2 only, all devices must support IKEv2. If you allow both IKEv1
and IKEv2, devices that do not support IKEv2 automatically use IKEv1.

IPsec/GRE (Generic Routing GRE policies can be configured on Cisco 10S security routers (including
Encapsulation). ASRs) and Catalyst 6500/7600 devices.

See Understanding GRE.

GRE Dynamic IP. GRE Dynamic IP can be configured on Cisco IOS security routers
See Understanding GRE (including ASRs) and Catalyst 6500/7600 devices.

Configuration for Dynamically
Addressed Spokes.

Dynamic Multipoint VPN DMVPN configuration is supported on Cisco IOS 12.3T devices and later,
(DMVPN), Large Scale DMVPN. | and on ASRs running Cisco IOS XE Software 2.x or later (known as
12.2(33)XNA+ in Security Manager). Large Scale DMVPN configuration

See Dynamic Multipoint VPNs also supports Catalyst 6500/7600 devices as IPsec Terminators.

(DMVPN) and Configuring
Large Scale DMVPNSs. To use DM VPN phase 3 connections between spokes, devices must run
I0S Software release 12.4(6)T or later; ASRs must run IOS XE Software
release 2.4 (called 12.2(33)XND) or later.

Easy VPN. The Easy VPN Server can be a Cisco 10S security router (including ASRs),
a Catalyst 6500/7600 (with supported VPN service modules or port
See Easy VPN. adapters), a PIX Firewall, or an ASA 5500 series device.

The Easy VPN client is supported on PIX 501, 506, 506E Firewalls running
PIX 6.3, Cisco 800-3900 Series routers, and ASA 5505 devices running
OS version 7.2 or later.
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Technology Supported Platforms

GET VPN. Key servers can be configured on:

See Group Encrypted Transport * Cisco 1800, 2800, 3800 Series ISR, Cisco 7200 Series Routers, and

(GET) VPNs. Cisco 7301 Routers running Cisco IOS Software release 12.4(15)T
or later.

* Cisco 1900, 2900, 3900 Series ISR running release 15.0 or later.

Group members can be configured on Cisco 1800, 1900, 2800, 2900,
3800, 3900 Series ISR, Cisco 7200 Series Routers, and Cisco 7301 Routers
with the same minimum software releases. The Cisco 871 ISR can also
be used as a group member if GET VPN is deployed with very few (1-3)
IPSec SAs. In addition, you can configure Cisco ASR Routers using Cisco
IOS XE Software Release 2.3 (12.2(33)XNC) and above as group
members.

)

Note Beginning with Cisco Security Manager 4.21, although ASA software enhancements and bug fixes are still
supported, any hardware support for routers is not rendered, as Cisco IOS Software has reached its end of
life.

Related Topics
* Creating or Editing VPN Topologies , on page 31
* Understanding Mandatory and Optional Policies for Site-to-Site VPNs , on page 6
* Including Unmanaged or Non-Cisco Devices in a VPN , on page 13
* Understanding and Configuring VPN Default Policies , on page 14
» Understanding VPN Topologies , on page 2
* Configuring IKE and IPsec Policies

* Understanding Policies

Including Unmanaged or Non-Cisco Devices in a VPN

Your VPN might include devices that you cannot, or should not, manage in Security Manager. These include:

* Cisco devices that Security Manager supports, but for which your organization is not responsible. For
example, you might have a VPN that includes spokes in networks managed by other organizations within
your company, or a connection to a service provider or partner network.

* Non-Cisco devices. You cannot use Security Manager to create and deploy configurations to non-Cisco
devices.

You have two options for handling these kinds of devices:
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* If the connection is a regular [Psec point-to-point connection, you can configure the connection as an
Extranet VPN as described in Creating or Editing Extranet VPNs , on page 72.

* For other types of connections, you can include these devices in the Security Manager inventory as
“unmanaged” devices. These devices can serve as endpoints in a VPN topology, but Security Manager
does not discover any configurations from the device, nor does it deploy configurations to them.

When the Extranet VPN option will not work, you must do the following before you can add an unmanaged
device to a VPN topology:

* Manually add the device as an unmanaged device to the device inventory using the procedure described
in Adding Devices by Manual Definition. Ensure that you make the following selections:

* Select a Cisco device type that is comparable to the device you are adding in terms of VPN-supported
technologies. The device type controls the types of VPN topologies to which you can add the device.
For example, for GRE/DMVPN, you might select an integrated services router such as an 1800 or
2800 series, whereas in Easy VPN you could also select an ASA or PIX device if appropriate.

* Deselect the Managein Cisco Security Manager option. This is very important, because the default
is to make all new devices managed devices. If you forget to do this while adding the device, you
can deselect the option later on the General tab in the device properties (right-click the device and
select Device Properties).

+ Using the interface policy for the device, define the external VPN interface to which managed devices
will point. Because the device is unmanaged, your definitions in this policy are never configured on the
device; the policy simply represents what you have configured on the device outside of Security Manager.

Related Topics
* Understanding Devices Supported by Each IPsec Technology , on page 11

* Selecting Devices for Your VPN Topology , on page 36

* Creating or Editing VPN Topologies , on page 31

Understanding and Configuring VPN Default Policies

For most VPN policies that are mandatory, Security Manager includes “factory default” settings for the
policies. These defaults are generic, and might not be appropriate for your network, but they do allow you to
complete the creation of a VPN without having to stop and start over when you do not have the needed shared
policy configured. Therefore, you can, and should, create your own default VPN policies for mandatory
policies. You can also create defaults for certain optional policies.

Before configuring new defaults, consider the types of VPNs you are likely to configure, then review the
types of policies for which you can create defaults. Select Tools > Security Manager Administration, then
select VPN Policy Defaults from the table of contents. Select the tabs for the desired IPsec technologies to
see which policies are available. If a policy is assigned Factory Default, or if this option is available from the
drop-down list, the policy is mandatory; other policies are optional. You can also create default policies for
remote access VPN, and for site-to-site endpoint configurations. Click the View Content button next to a
selected policy to see the policy definition.

The following procedure explains how to create and use VPN policy defaults.

Tips
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Understanding and Configuring VPN Default Policies .

* When you configure VPN default policies, you are selecting shared policies. Although you can configure
only one default per policy per IPsec technology, users can select different shared policies when
configuring VPNs. Thus, you might want to configure more than one shared policy that users can select,
and configure the most commonly-used policy as the default policy. For more information about how
users can select different policies when configuring a VPN, see Assigning Initial Policies (Defaults) to
a New VPN Topology , on page 67.

* Although the IKEv2 Authentication policy is a mandatory policy for topologies that allow IKEv2
negotiations, there are no IKEv2 Authentication factory default settings, and you cannot create IKEv2
Authentication shared policies. Therefore, whenever you allow IKEv2 in a topology, you must manually
configure the IKEv2 Authentication policy before the topology is valid.

* The Public Key Infrastructure policy is required for IKEv1 if you configure the IKE Proposal policy to
use certificate authentication. However, there are no factory default settings for this policy, so if you
intend to use certificate authentication for IKEv1, consider creating default Public Key Infrastructure
policies.

* Keep in mind that any change to a shared policy affects all VPNs that are using the policy. This can make
it easy to implement across-the-board changes that are required for every VPN. However, after creating
the VPN, the user can switch from a shared policy to a local policy, so that any changes to the configuration
must be done specifically for the VPN topology. For more information about shared policies, see Managing
Shared Policies in Policy View.

* These default policies do not apply when you create Extranet VPNs. With Extranet VPNs, you must
always configure the settings for mandatory policies as part of the normal wizard flow.

Create the default policies. All default policies are shared policies.

a)
b)
<)

d)

In Policy view (select View > Policy View), select the policy for which you want to configure defaults. The policies
are in the Site-to-Site VPN or Remote Access VPN folders.

Click the Create a Policy (+) button at the bottom of the shared policy selector, enter a name for the policy, and click
OK.

Configure the desired settings. Click the Help (?) button in the toolbar to get reference information about the settings
available in the selected policy.

Repeat the process until you have created at least one shared policy for each policy for which you want to define a
default policy.

If desired, create defaults for the VPN endpoints. These defaults are interface role objects, which identify the interface
names used for VPN connections (for example, GigabitEthernet0/1). Create separate roles for internal and external VPN
interfaces.

a)
b)

<)

Select Manage > Policy Objectsto open the Policy Object Manager.
Select I nterface Roles from the table of contents.

Click the New Object (+) button, enter the interface name patterns that identify the most commonly used interfaces
for VPN internal or external interfaces in your network, and click OK.

For more information about interface roles and the wildcards you can use to configure them, see Understanding
Interface Role Objects and Creating Interface Role Objects.

Submit the policies and policy objects to the database. You will have to resolve any validation errors.

* In non-Workflow mode, select File > Submit.

* In Workflow mode without an activity approver, select Activities > Approve Activity.
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Step 4

* In Workflow mode with an activity approver, select Activities> Submit Activity. You will have to wait for the
activity to be approved before you can select the policies and objects as defaults.

Select your newly-configured policies and policy objects as VPN policy defaults.

a)

b)

Select Tools> Security Manager Administration, and then select VPN Policy Defaults from the table of contents
(see VPN Policy Defaults Page).

Select the desired tabs, then select the policies you configured from the drop-down lists for each of the mandatory
or optional policies for which you configured defaults.

On the S2S Endpoints tab, select the appropriate interface role objects.

Click Saveto save your defaults.

The next time a user runs the Create VPN wizard, the defaults you selected will be used as the wizard’s defaults.
Users can select any other shared policy or interface role to override the default.

Using Device Overrides to Customize VPN Policies

Many VPN policies use Security Manager policy objects in their configuration. Policy objects are containers
that allow you to create reusable configurations.

Because a VPN policy applies to every device in a VPN topology, you might need to make modifications to
a policy object used in a policy for certain devices within the VPN topology. There might even be situations
where you need to make modifications for all devices within a topology. You accomplish these modifications
with device-level overrides on the policy objects.

For example, when defining a PKI policy, you need to select a PKI enrollment object. If the hub of your VPN
uses a different CA server than the spokes, you must use device-level overrides to specify the CA server used
by the hub. Although the PKI policy references a single PKI enrollment object, the actual CA server represented
by this object differs for the hub, based on the device-level override you define.

To enable a policy object to be overridden, you must select the Allow Override per Device option in the
policy object definition. You can then create device-level overrides. For more information about overriding
a VPN policy object at the device level, see the following topics:

* Understanding Policy Object Overrides for Individual Devices
* Allowing a Policy Object to Be Overridden
* Creating or Editing Object Overrides for a Single Device

* Creating or Editing Object Overrides for Multiple Devices At A Time

Understanding VRF-Aware IPsec

One obstacle to successfully deploying peer-to-peer VPNs is the separation of routing tables, and the use of
overlapping addresses, which usually results from using private IP addresses in customer networks. The
VRF-Aware [Psec feature, which introduces IPsec tunnel mapping to Multiprotocol Label Switching (MPLS)
VPNs, solves this problem.

The VRF-Aware [Psec feature enables you to map IPsec tunnels to Virtual Routing Forwarding (VRF)
instances, using a single public-facing address. A VRF instance defines the VPN membership of a customer
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site attached to the Provider Edge (PE) router. A VRF comprises an IP routing table, a derived Cisco Express
Forwarding (CEF) table, a set of interfaces that use the forwarding table, and a set of rules and routing protocol
parameters that control the information that is included in the routing table. A set of routing and CEF tables
is maintained for each VPN customer across the MPLS/VPN network.

Since each VPN has its own routing and forwarding table in the router, any customer or site that belongs to
a VPN is provided access only to the set of routes contained within that table. Any PE router maintains a
number of routing tables and a global routing table per VPN, which can be used to reach other routers in the
provider network. Effectively, a number of virtual routers are created in a single physical router. Across the
MPLS core to the other PE routers, this routing separation is maintained by adding unique VPN identifiers,
such as the route distinguisher (RD).

A\

Note VRF-Aware [Psec can also be configured on devices in a remote access VPN. For more information, see
Configuring Dynamic VTI/VRF Aware [Psec in Remote Access VPNs (I0S Devices).

In Security Manager, you can configure VRF-Aware IPsec in your hub-and spoke VPN topology, with either
a single device providing all functionality (“one-box” solution) or with multiple devices, each providing a
part of the functionality (“two-box” solution). The solution of one device providing all the functionality can
affect performance by overloading the system, whereas separating the functionality in a two-box solution
provides better scaling for each function.

The following topics describe:
* VRF-Aware [Psec One-Box Solution , on page 17
* VRF-Aware [Psec Two-Box Solution , on page 18

* Enabling and Disabling VRF on Catalyst Switches and 7600 Devices , on page 20

For information on configuring VRF-aware [Psec, see Configuring VRF Aware IPsec Settings , on page 52.

VRF-Aware IPsec One-Box Solution

In the one-box solution, IPsec tunnels terminate on a Cisco 1OS router, which serves as the Provider Edge
(PE) device. The PE device maps these tunnels to the appropriate MPLS/VPN network and serves as the [Psec
Aggregator, by performing [Psec encryption and decryption from the Customer Edge (CE) devices.

N

Note The configuration of routing between the PE device and the MPLS cloud is done by Cisco IP Solution Center.
See the Cisco IP Solution Center MPLS VPN User Guide .

The following illustration shows the topology of a one-box solution.
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Figure 7: VRF-Aware IPsec One-Box Solution
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Related Topics
* Understanding VRF-Aware [Psec , on page 16
* Configuring VRF Aware [Psec Settings , on page 52

* Defining the Endpoints and Protected Networks , on page 37

VRF-Aware IPsec Two-Box Solution

In the two-box solution, the PE device does just the MPLS mapping, while a separate IPsec Aggregator device
does the IPsec encryption and decryption from the CEs.

\)

Note Security Manager fully manages the [Psec Aggregator, including routing to the PE device. The PE device is
fully managed by Cisco IP Solution Center. This includes routing between the PE device and the MPLS cloud,
and routing from the PE to the IPsec Aggregator. For more information, see the Cisco IP Solution Center
MPLS VPN User Guide.

The following illustration shows the topology of a two-box solution.
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Figure 8: VRF-Aware IPsec Two-Box Solution
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Using the two-box solution, you configure VRF-Aware IPsec on devices in your VPN topology, as follows:

1. Configure the connection between the [Psec Aggregator and the PE device.

Create a hub-and-spoke VPN topology and assign an [Psec technology to it. In this topology, the hub is the
IPsec Aggregator, and the spokes may be Cisco 10S routers, PIX Firewalls, Catalyst VPN service modules,
or Adaptive Security Appliance (ASA) devices. The IPsec Aggregator may be a security router or a Catalyst
VPN service module. You then define the VRF parameters (VRF name and unique routing identifier) on the
hub.

)

Note VRF-Aware IPsec supports the configuration of IPsec, GRE, or Easy VPN technologies on Cisco IOS routers
and Catalyst VPN service modules. DMVPN is also supported, but only on Cisco IOS routers.

1. Specify the VRF forwarding interface (or VLAN for a Catalyst VPN service module) between the [Psec
Aggregator and the PE device.

2. Define the routing protocol and autonomous system (AS) number to be used between the IPsec Aggregator
and the PE. Available routing protocols include BGP, EIGRP, OSPF, RIPv2, and Static Route.

If the routing protocol defined between the IPsec Aggregator and the PE differs from the routing protocol
used for the secured IGP, routing is redistributed to the secured IGP, using this routing protocol and AS
number. Routing is also redistributed from the secured IGP to the PE.

\)

Note Redistributing the routing is only relevant when IPsec/GRE or DMVPN is the selected technology.

Related Topics
* Understanding VRF-Aware [Psec , on page 16
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. Enabling and Disabling VRF on Catalyst Switches and 7600 Devices

* Configuring VRF Aware [Psec Settings , on page 52

* Defining the Endpoints and Protected Networks , on page 37

Enabling and Disabling VRF on Catalyst Switches and 7600 Devices

Step 1
Step 2
Step 3
Step 4
Step 5

\}

Note

From version 4.17, though Cisco Security Manager continues to support Cisco Catalyst switches, it does not
support any enhancements as Cisco Catalyst switches is now End of Life.

Deployment fails when you change the virtual routing and forwarding (VRF) mode on the Catalyst switches
and 7600 hub of an existing site-to-site VPN. For example, if you initially configured VRF in the Create VPN
wizard and deployed, but later return to the Peers policy and deselect the Enable VRF Settings check box,
deployment fails. (This setting is found in the VRF Aware IPSec tab of the Edit Endpoints dialog box; see
Configuring VRF Aware IPsec Settings , on page 52.) Deployment likewise fails if you try to enable VRF
on a VPN that was not initially configured with it.

You cannot change the VRF mode on a Catalyst 6500/7600 during VPN operation. This restriction applies
only to Catalyst 6500/7600 hubs, not to any other device type.

This restriction does not apply to changes made to the VRF settings themselves. For example, if VRF is
configured on the VPN topology, you can return to the Peers policy and change the VRF name or route
distinguisher.

If you need to change the VRF mode of a VPN, and you are using Catalyst 6500/7600 devices as hubs, use
the following procedure.

Related topics

* Understanding VRF-Aware [Psec , on page 16
* VRF-Aware [Psec One-Box Solution , on page 17

* VRF-Aware [Psec Two-Box Solution , on page 18

Delete the VPN topology from Security Manager.

Deploy your changes.

Reload (restart) the Catalyst 6500/7600 device.

Right-click the device in Security Manager and select Discover Policieson Device. Perform a complete policy rediscovery.

Open the Create VPN wizard and redefine the VPN topology. At this point, you can select a different VRF mode. See
Configuring VRF Aware IPsec Settings , on page 52 and Creating or Editing VPN Topologies , on page 31.

Accessing Site-to-Site VPN Topologies and Policies

You can use the following methods to access and configure site-to-site VPN topologies and policies:

* Site-to-Site VPN Manager—This is the main tool for configuring VPN topologies. You can view a list

of all site-to-site VPNs configured in Security Manager and edit their configurations and policies, including
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device membership. For information on using this tool, see Site-to-Site VPN Manager Window , on
page 21.

« Site-to-Site VPN policy in Device view—When you select a device in device view, you can select the
Site-to-Site VPN policy in the Policies selector to see a list of all site-to-site VPNs in which the device
participates and edit those topologies. You can also create new VPNs, or select a VPN and open the
Site-to-Site VPN Manager to edit the policies for the selected VPN. This device view policy is essentially
a short-cut into the Site-to-Site VPN Manager. For more information about using this policy, see
Configuring VPN Topologies in Device View , on page 22.

* Site-to-Site VPN folder in Policy view—Policy view is used to create shared policies. Many of the
site-to-site VPN policies are shareable. Thus, you can configure shared policies that you can assign to
more than one VPN topology while configuring the topology in the Site-to-Site VPN Manager. You can
configure shared policies as defaults for the Create VPN wizard, as described in Understanding and
Configuring VPN Default Policies , on page 14.

You can also create shared policies from the Site-to-Site VPN Manager window in much the same way you
can create them from local policies in Device view, although all sharing commands in the Site-to-Site VPN
Manager window are available only on the right-click context menu (when right-clicking a shareable policy).

For more information on creating shared policies in Policy view, see Managing Shared Policies in Policy
View.

Site-to-Site VPN Manager Window

The Site-to-Site VPN Manager lists all site-to-site VPNs configured in Security Manager. The VPN selector,
in the upper left pane of the window, lists all existing VPN topologies (see Understanding VPN Topologies
, on page 2). An icon indicates the type of VPN (hub and spoke, point to point, or full mesh).To view or
edit a topology, select it, and its policies are loaded into the policy selector in the lower left pane. Select a
policy to see its definition in the right pane.

To open the Site-to-Site VPN Manager, click the Site-To-Site VPN Manager button on the toolbar or select
Manage > Site-To-Site VPNs.

Use the Site-to-Site VPN Manager window to:
* Create, edit, and delete VPN topologies.

* To create a VPN topology, click the Create VPN Topology (+) button above the VPN selector and
select the type of topology you want to create from the options that are displayed. This action opens
the Create VPN Wizard or the Create Extranet VPN wizard. For more information, see Creating
or Editing VPN Topologies , on page 31 or Creating or Editing Extranet VPNs , on page 72.

To edit a VPN topology, select it and click the Edit VPN Topology (pencil) button, or right-click
it and select Edit. This opens the Edit VPN or Edit Extranet VPN dialog box, which contains the
most of the same pages as the Create VPN wizard in a tabbed layout.

To delete a VPN topology, select it and click the Delete VPN Topology (trash can) icon, or
right-click it and select Delete. You are asked to confirm the deletion. See Deleting a VPN Topology
, on page 76.

* View detailed information about each VPN topology; select the topology, then select the VPN Summary
policy. See Viewing a Summary of a VPN Topology’s Configuration , on page 68.
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* View and configure the endpoints defined for a VPN topology. You can see endpoints on the Endpoints
tab or when editing a VPN topology, or by selecting the Peerspolicy. For GET VPN topologies, there
is no Peers policy; instead, use the Key Serversand Group Member s policies to view and configure
endpoints. For Extranet VPNs, the endpoints are on the Device Selection tab when editing the VPN, or
also in the Peers policy.

* View and edit the policies assigned to a VPN topology, assign shared policies, or create shared policies
from existing policies. For information on individual policies, see Overview of Site-to-Site VPN Policies
, on page 8.

The options and methods for configuring shared policies from the Site-to-Site VPN Manager are the same as
those from Device view, as explained in the sections under Working with Shared Policies in Device View or
the Site-to-Site VPN Manager and Using the Policy Banner. You can share, assign, unassign, edit assignments,
and rename policies, but no VPN policies allow inheritance. To perform these tasks, select the VPN topology,
then right-click the desired policy and select the desired command.

You can also use Policy view to configure shared VPN policies.

Configuring VPN Topologies in Device View

Use the Site-to-Site VPN Device view policy to view and edit the site-to-site VPN topologies to which a
device belongs, if any. You can edit the VPN policies and change whether the device participates in the
topology. You can also create new VPN topologies.

This policy is essentially an access point for the Site-to-Site VPN Manager (see Site-To-Site VPN Discovery
, on page 23).

To open this policy, in Device view, select the desired device and then select Site-to-Site VPN from the Policy
selector.

The VPN topologies table lists all of the site-to-site VPNs to which this device belongs. Information includes
the type of VPN, its name, IPSec technology, and description. Beginning with version 4.9, Security Manager
also displays the Last Modified Ticket information for the VPN topologies. The VPN topologies that have
been created or edited using the Ticket Management system will have the last Modified Ticket ID information
available on this page. You can also filter the VPN topologies by the Last Modified Ticket ID.

* To add a VPN, click the Create VPN Topology button, or right-click in the table and select Create VPN
Topology and select the type of topology you want to create from the options that are displayed. This
action opens the Create VPN Wizard or the Create Extranet VPN wizard. For more information, see
Creating or Editing VPN Topologies , on page 31 or Creating or Editing Extranet VPNs , on page 72.

* To edit a VPN, select it and click the Edit VPN Topology button, right-click the VPN and select Edit
VPN Topology, or simply double-click the entry. This opens the Edit VPN or Edit Extranet VPN dialog
box, which is a tabbed version of the Create VPN wizard (see Creating or Editing VPN Topologies , on
page 31 or Creating or Editing Extranet VPNs , on page 72).

* To edit the policies for a VPN, select it and click the Edit VPN Policies button. The Site-to-Site VPN
Window opens displaying information about the VPN topology; select the desired policy from the Policies
selector to edit it.

* To delete a VPN, select it and click the Delete VPN Topology button, or right-click the VPN and select
Delete VPN Topology. You are asked to confirm the deletion. For more information, see Deleting a
VPN Topology , on page 76.
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Site-To-Site VPN Discovery

You can discover the VPN topologies that are already deployed in your network so that you can use Security
Manager to manage them. Your VPN configurations are brought into Security Manager and displayed as
site-to-site VPN policies.

Except for Extranet VPNs, you can also rediscover the configurations of existing VPN topologies that are
already managed with Security Manager. For information about Site-to-Site VPN rediscovery, see
Rediscovering Site-to-Site VPNs , on page 30.

\)

Note  You can also discover configurations on devices in remote access VPNSs that are already deployed in your
network. See Discovering Remote Access VPN Policies.

These topics provide information about Site-to-Site VPN discovery:

* Supported and Unsupported Technologies and Topologies for VPN Discovery , on page 23
* Prerequisites for VPN Discovery , on page 24

* VPN Discovery Rules , on page 25

* Discovering Site-to-Site VPNs , on page 27

* Defining or Repairing Discovered VPNs with Multiple Spoke Definitions , on page 29

* Rediscovering Site-to-Site VPNs , on page 30

Supported and Unsupported Technologies and Topologies for VPN Discovery

This topic lists the technologies and topologies that Security Manager can discover, as well as the VPN features
that are provisioned by Security Manager but cannot be discovered.

Supported Technologies for VPN Discovery
* [Psec, including LAN-to-LAN configurations on ASA devices.

* [Psec + GRE

* [Psec + GRE dynamic IP
* DMVPN

* Easy VPN

* GET VPN

Supported Topologies for VPN Discovery
* Point to point

* Hub and spoke
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* Full mesh

 Extranet VPN (point-to-point to an unmanaged device)

VPN Features Provisioned by Security Manager but Unsupported for VPN Discovery

* Large Scale DMVPN with IPsec Terminator (high-concentration hub)

* VRF-Aware [Psec

* Dial backup

* [Psec and ISAKMP profiles for Easy VPN

» Easy VPN with High Availability
If you define and deploy policies of these types using Security Manager, your policies overwrite the device
configurations that were not discovered. Therefore, if you want Security Manager to manage existing
configurations, you should define policies that match the existing configurations as closely as possible. (Use
Tools> Preview Configuration to examine the results before deploying.) The VPN provisioning mechanism
leverages the content of the existing configuration as much as possible (assuming the content matches the

policies configured in Security Manager), but does not retain the naming conventions used in the CLI
commands.

Related Topics
* Prerequisites for VPN Discovery , on page 24
* VPN Discovery Rules , on page 25

* Discovering Site-to-Site VPNs , on page 27

Prerequisites for VPN Discovery

For successful VPN discovery, the following prerequisites must be met:

* Except for Extranet VPN, all devices participating in the VPN must be added to the Security Manager
inventory.

* You must provide Security Manager with some basic information about the VPN. The VPN discovery
wizard prompts you for the following information:

* VPN topology (hub and spoke, point to point, full mesh, Extranet).
* VPN technology (Regular IPsec, IPsec/GRE, GRE dynamic IP, DMVPN, Easy VPN, GET VPN).

* Devices in the VPN and their roles (hub/spoke). For Extranet VPNs, you specify the managed device
only.

* Source of the VPN configuration. The VPN can be discovered directly from the live network or
from Security Manager’s Configuration Archive.

* Each device in the VPN must have a crypto map associated with a physical interface. This rule does not
apply to the remote (unmanaged) devices in an Extranet VPN.
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* If you use OSPF as your routing protocol in a VPN topology, all devices in the VPN must use the same
OSPF process number.

» Each PIX 6.3 or ASA 5505 client device in an Easy VPN topology must have a vpnclient configuration.

Related Topics
* Supported and Unsupported Technologies and Topologies for VPN Discovery , on page 23
* VPN Discovery Rules , on page 25

* Discovering Site-to-Site VPNs , on page 27

VPN Discovery Rules

The following table describes the rules by which Security Manager translates and discovers your VPN
configurations, and how it handles instances where your configuration on the device does not match what is
supported by Security Manager.

Je

Tip Because Extranet VPN discovery involves the analysis of a single device (the managed device), most of these
rules do not apply to Extranet VPN discovery. Any rule that involves consistency of values among devices
in the VPN is not applicable.

Table 3: VPN Discovery Rules

If this condition exists: The VPN discovery is handled as follows:

Security Manager cannot contact a « If the device is the only hub or spoke in the VPN, discovery
device in the VPN for live device fails.

discovery.

* [fthere are other hubs or spokes in the VPN, discovery proceeds
but the unavailable device is not discovered.

* Except for Extranet VPN, if the device is a peer in a
point-to-point topology, discovery fails. For Extranet VPN,
only the managed device is contacted, and discovery fails if it
cannot be contacted.

* If the device is a peer in a full mesh topology and there are only
two devices, including the unavailable one, in the topology,
discovery fails. If there are more than two devices, discovery
proceeds but the unavailable device is not discovered.

Managing Site-to-Site VPNs: The Basics .
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If this condition exists:

The VPN discovery is handled as follows:

The VPN is a LAN-to-LAN VPN on
an ASA.

The ASA documentation uses “LAN-to-LAN” as a synonym for
“site-to-site.” In a LAN-to-LAN VPN configuration, the ASA uses
tunnel groups, which when used in a remote access VPN
configuration, Security Manager discovers as connection profiles.

When discovering site-to-site VPNs on an ASA that uses
LAN-to-LAN (L2L) tunnel groups, Security Manager creates a
site-to-site VPN topology, and the L2L tunnel groups are not
presented to you as connection profiles. Instead, you edit the
properties of the VPN topology, and during deployment, Security
Manager will translate the configuration into the appropriate L2L
tunnel group commands.

There are inconsistencies in the policies
or values in the VPN configurations
across the devices in the VPN.

« If the values on the hub and the spokes differ, preference is
given to the values on the hub.

« Ifa simple selection of one policy or value from several eligible
policies or values is required and does not put functionality at
risk, Security Manager selects a single policy/value that is
common to all devices. For example, a VPN can have a single
IKE policy only, whereas there can be more than one IKE policy
on the devices.

* If selecting one value puts the functionality at risk, no value is
discovered for the policy and a validation message is received
upon deployment.

* If numeric values differ, a message is generated during
discovery, and the lower value is discovered. For example, the
lowest SA lifetime value in an IPsec policy.

* If none of the above options are possible, VPN discovery fails.

Preshared key configuration—there is
a different key per set of peers.

The preshared key policy is not discovered; you will have to
configure it after discovery is completed. Security Manager discovers
preshared key policies only when the preshared key has the same
value on all devices.

There is more than one eligible crypto
map on the device.

The crypto map that is associated with all or the majority of the
devices selected for VPN discovery is used.

A spoke does not have a crypto map
associated with the hub.

VPN discovery proceeds but the spoke is not discovered and an error
message is generated.

A device does not have the selected
transform set value.

VPN discovery proceeds but the device might removed from the
VPN topology.

A device does not have the selected
IKE proposal.

VPN discovery proceeds but the device might removed from the
VPN topology.

A device supports DVTI, but does not
have DVTI or a crypto map configured.

VPN discovery fails.
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Discovering Site-to-Site VPNs .

If this condition exists:

The VPN discovery is handled as follows:

A server supports DVTI, but does not
have an IP address configured in the
DVTI configuration.

VPN discovery proceeds but with a warning.

A client does not support DVTIL.

If the hub is configured with DVTI, discovery proceeds without any
warning or Error.

A Hub and Spoke topology where the
spokes are not using the same
VPNSPA/VSPA slot on the hub
(Catalyst 6500/7600).

VPN discovery fails.

The same set of key servers and group
members are participating in more than
one GET VPN.

Security Manager discovers only one of the topologies.

A User Group policy is configured with
backup servers using hostnames instead
of an IP addresses.

VPN policy discovery fails with the following error:

Policy Discovery Failed:
com.cisco.nm.vms.discovery.DiscoveryException: Internal Error

In order for discovery to be successful, you need to reconfigure the
user group policy on the device with backup servers using IP address,
not hostnames.

Related Topics

* Supported and Unsupported Technologies and Topologies for VPN Discovery , on page 23

* Prerequisites for VPN Discovery , on page 24

» Discovering Site-to-Site VPNs , on page 27

* Rediscovering Site-to-Site VPNs , on page 30

Discovering Site-to-Site VPNs

This procedure describes how to discover a Site-to-Site VPN that is already working in your network but that
has not yet been defined in Security Manager.

Related Topics

* Discovering Site-to-Site VPNs , on page 27

* Discovering Policies

* Supported and Unsupported Technologies and Topologies for VPN Discovery , on page 23

* Prerequisites for VPN Discovery , on page 24

* VPN Discovery Rules , on page 25

» Understanding Devices Supported by Each IPsec Technology , on page 11
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. Discovering Site-to-Site VPNs

* Including Unmanaged or Non-Cisco Devices in a VPN , on page 13

Step 1 In Device view, select Policy > Discover VPN Policesto open the Discover VPN Policies Wizard—Name and Technology
page.
Step 2 Specify the following information:

* VPN Name—The name of the VPN being discovered.

You cannot specify the name when discovering Extranet VPNSs. Instead, Security Manager discovers all Extranets defined
on the device, and for each Extranet, the VPN name is a hyphenation of the local and remote IP addresses. For example,
if the local address is 10.100.10.1 and the remote address is 10.100.11.1, the Extranet VPN is named
10.100.10.1-10.100.11.1.

* Description—An optional description of the VPN. You cannot add a description to Extranet VPN discovery.
* Topology—The type of VPN that you are discovering—Hub and Spoke, Point to Point, Full Mesh, or Extranet.

* | Psec Technology—The IPsec technology assigned to the VPN—Regular IPsec, IPsec/GRE, GRE Dynamic IP
(sub-technology), DMVPN, Easy VPN, GET VPN, or Regular IPSEC VTI. The topology you select controls what
is available in this list.

If you selected IPsec/GRE, you must also specify the type which may be Standard (for IPsec/GRE) or Spokeswith
Dynamic | P (to configure GRE Dynamic IP).

Note You can select Regular IPSEC VTI for tunnel based routing as applicable for Hub and Spoke, and Point to
Point topologies.

* Discover From—You can either discover the VPN directly from the network or from Configuration Archive.

* Network—Security Manager connects to all live devices to obtain the device configuration. For Extranet VPN
discovery, Security Manager connects to the single managed device that you specify.

* Config Archive—Discovery from Configuration Archive is recommended if you deploy to configuration files
instead of live devices. The most recent version of the device configuration in Configuration Archive is used
for all devices.

Step 3 Click Next to open the Discover VPN Policies Wizard—Device Selection Page.

Step 4 Select the devices participating in the VPN and their role in the VPN (hub, spoke, peer one, peer two, local device, key
server, group member, or simply selected devices for full-mesh VPNs) depending on the topology type. For Easy VPN
topologies, servers are hubs and clients are spokes.

If there are two or more IPsec terminators in a hub-and-spoke VPN, use the Up and Down arrow buttons to ensure the
primary hub is listed first. When there is only one IPsec terminator, regardless of how many hubs are connected to the
same IPsec terminator, it is not possible to designate one hub as the primary hub.

For more detailed information on selecting devices for a VPN, see Selecting Devices for Your VPN Topology , on page
36.

Step 5 Click Finish to close the wizard and start the discovery process. The Discovery Status window opens and displays the
status of the discovery and indicates whether the discovery of each device has been successful or has failed (see Viewing
Policy Discovery Task Status). Error or warning messages are provided to indicate the source of any problems, which
may be VPN specific or device specific.
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Step 6

Defining or Repairing Discovered VPNs with Multiple Spoke Definitions .

Except for Extranet discovery, when the discovery process completes successfully, and you close the Discovery Status
dialog box, the Site-to-Site VPN Manager window opens, displaying summary information for the VPN that was discovered.
For Extranet discovery, you must either manually open the Site-to-Site VPN Manager, or select the Site-to-Site VPN
policy in Device view, to see the list of discovered Extranet VPNs.

Verify that the VPN polices are as required. Edit the policies as necessary.

Tip When discovering Extranet VPN, all Extranet VPNs defined on the selected device are discovered. Delete
the ones that you do not want to manage in Security Manager.

Defining or Repairing Discovered VPNs with Multiple Spoke Definitions

Step 1

Step 2

If you discover a VPN whose spokes contain different definitions (for example, different client modes for
Easy VPN spokes), Security Manager changes the definitions during discovery to create a uniform definition
for all spokes. This behavior occurs because VPN topologies in Security Manager can contain only one set
of spoke definitions.

If you want to maintain your original definitions, or create a new VPN that has spokes with different definitions,
you can choose one of two approaches:

* Define multiple VPN topologies in Security Manager, where each topology includes spokes containing
matching spoke definitions.

* Define a FlexConfig policy that contains the specialized definition, then assign the policy to the spokes
that require this definition, as described in the following procedure.

Related Topics
* Creating a New Shared Policy
* Creating FlexConfig Policy Objects
* Modifying Policy Assignments in Policy View
» Site-To-Site VPN Discovery , on page 23
* Discovering Site-to-Site VPNs , on page 27
» VPN Discovery Rules , on page 25

Create a shared FlexConfig policy in Policy view:

a) Select View > Policy View.

b) Right-click FlexConfigsin the Policy Type selector, then select New FlexConfigs Policy.
¢) Enter a name for the policy and click OK.

Define the FlexConfig policy by creating and selecting a FlexConfig object:

a) In the work area of Policy view, click the Add button on the Details tab.

b) In the FlexConfigs Selector, click the Create button in the lower-left corner of the window to open Add or Edit
FlexConfig Dialog Box.

¢) Define an appended FlexConfig object that contains the required client definition. For example, to define the client
mode on an Easy VPN spoke, enter the following commands:
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