
Install Cisco Jabber

Review the options for installation and learn about different methods for installing Cisco Jabber. Understand
the requirements for successful deployments before you start the installation procedure.

• Methods of Installation, on page 1
• Use the Command Line, on page 2
• Run the MSI Manually, on page 3
• Create a Custom Installer, on page 4
• Deploy with Group Policy, on page 7
• Command Line Arguments, on page 9
• Installer Properties, on page 20
• Supported Languages, on page 21
• Cisco Media Services Interface, on page 21
• Uninstall Cisco Jabber for Windows, on page 23

Methods of Installation
Cisco Jabber for Windows provides an MSI installation package. You must be logged in as an administrator
to complete installation. You can use this installation package in the following ways:

Use the Command Line

Specify arguments in a command line window to set installation properties.

Choose this option if you plan to install multiple instances.

Run the MSI Manually

Run theMSI manually on the file system of the client workstation and then specify connection properties
when you start the client.

Choose this option if you plan to install a single instance for testing or evaluation purposes.

Create a Custom Installer

Open the default installation package, specify the required installation properties, and then save a custom
installation package.

Choose this option if you plan to distribute an installation package with the same installation properties.
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Deploy with Group Policy

Install the client on multiple computers in the same domain.

Use the Command Line
Specify installation arguments in a command line window.

Procedure

Step 1 Open a command line window.
Step 2 Enter the following command:

msiexec.exe /i CiscoJabberSetup.msi

Step 3 Specify command line arguments as parameter=value pairs.
msiexec.exe /i CiscoJabberSetup.msi argument=value

Step 4 Run the command to install Cisco Jabber for Windows.

Example Installation Commands
Review examples of commands to install Cisco Jabber for Windows.

Cisco Unified Communications Manager, Release 9.x

msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1

Where:

CLEAR=1 — Deletes any existing bootstrap file.
/quiet— Specifies a silent installation.

Cisco Unified Communications Manager, Release 8.x in Default Mode

msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1 AUTHENTICATOR=CUP CUP_ADDRESS=1.2.3.4

Where:

CLEAR=1 — Deletes any existing bootstrap file.
AUTHENTICATOR=CUP — Sets Cisco Unified Presence as the authenticator.
CUP_ADDRESS=1.2.3.4 — Sets 1.2.3.4 as the IP address of the presence server.
/quiet— Specifies a silent installation.

Cisco Unified Communications Manager, Release 8.x in Phone Mode

If you are integrating with UDS when you are installing in phone mode, you must first define the
<PresenceDomain>Domain address of your Presence server</PresenceDomain> parameter.
msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1 PRODUCT_MODE=Phone_Mode AUTHENTICATOR=CUCM
TFTP=1.2.3.4 CTI=5.6.7.8
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Where:

CLEAR=1 — Deletes any existing bootstrap file.
PRODUCT_MODE=Phone_Mode — Sets the client to phone mode.
AUTHENTICATOR=CUCM— Sets Cisco Unified Communications Manager as the authenticator.
TFTP=1.2.3.4 — Sets 1.2.3.4 as the IP address of the TFTP server that hosts the client configuration.
CTI=5.6.7.8 — Sets 5.6.7.8 as the IP address of the CTI server.
/quiet— Specifies a silent installation.

Cisco WebEx Messenger Service

msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1 AUTHENTICATOR=WEBEX

Where:

CLEAR=1 — Deletes any existing bootstrap file.
AUTHENTICATOR=WEBEX— Sets the Cisco WebEx Messenger service as the authenticator.
/quiet— Specifies a silent installation.

Cisco WebEx Messenger Service with SSO

msiexec.exe /i CiscoJabberSetup.msi /quiet CLEAR=1 AUTHENTICATOR=WEBEX
SSO_ORG_DOMAIN=example.com

Where:

CLEAR=1 — Deletes any existing bootstrap file.
AUTHENTICATOR=WEBEX— Sets the Cisco WebEx Messenger service as the authenticator.
SSO_ORG_DOMAIN=example.com — Sets example.com as the single sign-on (SSO) domain.
/quiet— Specifies a silent installation.

Run the MSI Manually
You can run the installation program manually to install a single instance of the client and specify connection
settings in the Advanced settings window.

Procedure

Step 1 Launch CiscoJabberSetup.msi.

The installation program opens a window to guide you through the installation process.

Step 2 Follow the steps to complete the installation process.
Step 3 Start Cisco Jabber for Windows.
Step 4 SelectManual setup and sign in.

The Advanced settings window opens.

Step 5 Specify values for the connection settings properties.
Step 6 Select Save.
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Create a Custom Installer
You can transform the default installation package to create a custom installer.

You use Microsoft Orca to create custom installers. Microsoft Orca is available as part of the Microsoft
Windows SDK for Windows 7 and .NET Framework 4.

Download and install Microsoft Windows SDK for Windows 7 and .NET Framework 4 from the Microsoft
website.

Note

Procedure

PurposeCommand or Action

You must have the default transform file to
modify the installation package with Microsoft
Orca.

Get the Default Transform File, on page 4Step 1

Transform files contain installation properties
that you apply to the installer.

Create Custom Transform Files, on page 5Step 2

Apply a transform file to customize the installer.Transform the Installer, on page 5Step 3

Related Topics
Microsoft Windows SDK for Windows 7 and .NET Framework 4

Get the Default Transform File
You must have the default transform file to modify the installation package with Microsoft Orca.

Procedure

Step 1 Download the Cisco Jabber administration package from Software Download page.
Step 2 CopyCiscoJabberProperties.msi from the Cisco Jabber administration package to your file system.

What to do next

Create Custom Transform Files, on page 5

Related Topics
Software Downloads
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Create Custom Transform Files
To create a custom installer, you use a transform file. Transform files contain installation properties that you
apply to the installer.

The default transform file lets you specify values for properties when you transform the installer. You should
use the default transform file if you are creating one custom installer.

You can optionally create custom transform files. You specify values for properties in a custom transform
file and then apply it to the installer.

Create custom transform files if you require more than one custom installer with different property values.
For example, create one transform file that sets the default language to French and another transform file that
sets the default language to Spanish. You can then apply each transform file to the installation package
separately. The result is that you create two installers, one for each language.

Before you begin

Get the Default Transform File, on page 4

Procedure

Step 1 Start Microsoft Orca.
Step 2 Open CiscoJabberSetup.msi and then apply CiscoJabberProperties.msi.
Step 3 Specify values for the appropriate installer properties.
Step 4 Generate and save the transform file.

a) Select Transform > Generate Transform.
b) Select a location on your file system to save the transform file.
c) Specify a name for the transform file and select Save.

The transform file you created is saved as file_name.mst. You can apply this transform file to modify
the properties of CiscoJabberSetup.msi.

What to do next

Transform the Installer, on page 5

Transform the Installer
Apply a transform file to customize the installer.

Applying transform files will alter the digital signature of CiscoJabberSetup.msi. Attempts to modify
or rename CiscoJabberSetup.msi will remove the signature entirely.

Note
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Before you begin

Create Custom Transform Files, on page 5

Procedure

Step 1 Start Microsoft Orca.
Step 2 Open CiscoJabberSetup.msi in Microsoft Orca.

a) Select File > Open.
b) Browse to the location of CiscoJabberSetup.msi on your file system.
c) Select CiscoJabberSetup.msi and then select Open.

The installation package opens in Microsoft Orca. The list of tables for the installer opens in the Tables pane.

Step 3 Required: Remove all language codes except for 1033 (English).

You must remove all language codes from the custom installer except for 1033 (English).

Microsoft Orca does not retain any language files in custom installers except for the default, which
is 1033. If you do not remove all language codes from the custom installer, you cannot run the
installer on any operating system where the language is other than English.

Restriction

a) Select View > Summary Information.

The Edit Summary Information window displays.

b) Locate the Languages field.
c) Delete all language codes except for 1033.
d) Select OK.

English is set as the language for your custom installer.

Step 4 Apply a transform file.
a) Select Transform > Apply Transform.
b) Browse to the location of the transform file on your file system.
c) Select the transform file and then select Open.

Step 5 Select Property from the list of tables in the Tables pane.

The list of properties for CiscoJabberSetup.msi opens in the right panel of the application window.

Step 6 Specify values for the properties you require.

Set the value of the CLEAR property to 1 to override any existing bootstrap file from previous
installations. If you do not override existing bootstrap files, the values you set in the custom installer
do not take effect.

Tip

Step 7 Remove any properties that you do not require.
It is essential to remove any properties that are not being set, otherwise the properties being set will not take
effect. Remove each property that is not needed one at a time.
a) Right-click the property you want to remove.
b) Select Drop Row.
c) Select OK when Microsoft Orca prompts you to continue.
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Step 8 Required: Enable your custom installer to save embedded streams.
a) Select Tools > Options.
b) Select the Database tab.
c) Select Copy embedded streams during 'Save As'.
d) Select Apply and then OK.

Step 9 Save your custom installer.
a) Select File > Save Transformed As.
b) Select a location on your file system to save the installer.
c) Specify a name for the installer and then select Save.

Related Topics
Installer Properties, on page 20

Deploy with Group Policy
Install Cisco Jabber for Windows with Group Policy using the Microsoft Group Policy Management Console
(GPMC) on Microsoft Windows Server.

To install Cisco Jabber for Windows with Group Policy, all computers or users to which you plan to deploy
Cisco Jabber for Windows must be in the same domain.

Note

Procedure

PurposeCommand or Action

You must use this procedure and set the
Language field to 1033 only if the MSI is to be
modified by Orca in any way.

Set a Language Code, on page 7Step 1

Deploy Cisco Jabber for Windows with Group
Policy.

Deploy the Client with Group Policy, on page
8

Step 2

Set a Language Code
Altering the installation language is not necessary in Group Policy deployment scenarios where the exact MSI
file provided by Cisco will be used. The installation language will be determined from the Windows User
Locale (Format) in these situations. You must use this procedure and set the Language field to 1033 only if
the MSI is to be modified by Orca in any way.

Procedure

Step 1 Start Microsoft Orca.
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Microsoft Orca is available as part of the Microsoft Windows SDK for Windows 7 and ,NET Framework 4
that you can download from the Microsoft website.

Step 2 Open CiscoJabberSetup.msi.
a) Select File > Open.
b) Browse to the location of CiscoJabberSetup.msi on your file system.
c) Select CiscoJabberSetup.msi and then select Open.

Step 3 Select View > Summary Information.
Step 4 Locate the Languages field.
Step 5 Set the Languages field to 1033.
Step 6 Select OK.
Step 7 Required: Enable your custom installer to save embedded streams.

a) Select Tools > Options.
b) Select the Database tab.
c) Select Copy embedded streams during 'Save As'.
d) Select Apply and then OK.

Step 8 Save your custom installer.
a) Select File > Save Transformed As.
b) Select a location on your file system to save the installer.
c) Specify a name for the installer and then select Save.

What to do next

Deploy the Client with Group Policy, on page 8

Related Topics
Supported Languages, on page 21

Deploy the Client with Group Policy
Complete the steps in this task to deploy Cisco Jabber for Windows with Group Policy.

Before you begin

Set a Language Code, on page 7

Procedure

Step 1 Copy the installation package to a software distribution point for deployment.

All computers or users to which you plan to deploy Cisco Jabber for Windows must be able to access the
installation package on the distribution point.

Step 2 Select Start > Run and then enter the following command:
GPMC.msc
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The Group Policy Management console opens.

Step 3 Create a new group policy object.
a) Right-click on the appropriate domain in the left pane.
b) Select Create a GPO in this Domain, and Link it here.

The New GPO window opens.

c) Enter a name for the group policy object in the Name field.
d) Leave the default value or select an appropriate option from the Source Starter GPO drop-down list and

then select OK.

The new group policy displays in the list of group policies for the domain.

Step 4 Set the scope of your deployment.
a) Select the group policy object under the domain in the left pane.

The group policy object displays in the right pane.

b) Select Add in the Security Filtering section of the Scope tab.

The Select User, Computer, or Group window opens.

c) Specify the computers and users to which you want to deploy Cisco Jabber for Windows.

Step 5 Specify the installation package.
a) Right-click the group policy object in the left pane and then select Edit.

The Group Policy Management Editor opens.

b) Select Computer Configuration and then select Policies > Software Settings.
c) Right-click Software Installation and then select New > Package.
d) Enter the location of the installation package next to File Name; for example,

\\server\software_distribution.

You must enter a Uniform Naming Convention (UNC) path as the location of the installation
package. If you do not enter a UNC path, Group Policy cannot deploy Cisco Jabber forWindows.

Important

e) Select the installation package and then select Open.
f) In the Deploy Software dialog box, select Assigned and then OK.

Group Policy installs Cisco Jabber for Windows on each computer the next time each computer starts.

Command Line Arguments
Review the command line arguments you can specify when you install Cisco Jabber for Windows.

Override Argument
The following table describes the parameter you must specify to override any existing bootstrap files from
previous installations:
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DescriptionValueArgument

Specifies if the client overrides any existing bootstrap
file from previous installations.

The client saves the arguments and values you set
during installation to a bootstrap file. The client then
loads settings from the bootstrap file at startup.

1CLEAR

If you specify CLEAR, the following occurs during installation:

1. The client deletes any existing bootstrap file.

2. The client creates a new bootstrap file.

If you do not specify CLEAR, the client checks for existing bootstrap files during installation.

• If no bootstrap file exists, the client creates a bootstrap file during installation.

• If a bootstrap file exists, the client does not override that bootstrap file and preserves the existing settings.

If you are reinstalling Cisco Jabber for Windows, you should consider the following:

• The client does not preserve settings from existing bootstrap files. If you specify CLEAR, you must also
specify all other installation arguments as appropriate.

• The client does not save your installation arguments to an existing bootstrap file. If you want to change
the values for installation arguments, or specify additional installation arguments, you must specify
CLEAR to override the existing settings.

Note

To override existing bootstrap files, specify CLEAR in the command line as follows:
msiexec.exe /i CiscoJabberSetup.msi CLEAR=1

Mode Type Argument
The following table describes the command line argument with which you specify the product mode:

DescriptionValueArgument

Specifies the product mode for the client. You can set
the following value:

• Phone_Mode — Cisco Unified Communications
Manager is the authenticator.

Choose this value to provision users with audio
devices as base functionality.

Phone_ModePRODUCT_MODE
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When to Set the Product Mode
In phone mode deployments Cisco Unified Communications Manager is the authenticator. When the client
gets the authenticator, it determines the product mode is phone mode. However, because the client always
starts in the default product mode on the initial launch, users must restart the client to enter phone mode after
sign in.

• CiscoUnified CommunicationsManager, Release 9.x and Later—You should not set PRODUCT_MODE
during installation. The client gets the authenticator from the service profile. After the user signs in, the
client requires a restart to enter phone mode.

• Cisco Unified CommunicationsManager, Release 8.x—You can specify phonemode during installation
if you set Cisco Unified Communications Manager as the authenticator. The client reads the bootstrap
file on the initial launch and determines it should start in phone mode. The client then gets Cisco Unified
Communications Manager as the authenticator from the bootstrap file or manual settings. After the user
signs in, the client does not require a restart.

Change Product Modes
To change the product mode, you must change the authenticator for the client. The client can then determine
the product mode from the authenticator.

The method for changing from one product mode to another after installation, depends on your deployment.

In all deployments, the user can manually set the authenticator in the Advanced settings window.

In this case, you must instruct the user to change the authenticator in the Advanced settings window to change
the product mode. You cannot override the manual settings, even if you uninstall and then reinstall the client.

Note

Change Product Modes with Cisco Unified Communications Manager Version 9.x and Later

To change product modes with Cisco Unified Communications Manager version 9.x and later, you change
the authenticator in the service profile.

Procedure

Step 1 Change the authenticator in the service profiles for the appropriate users.

Change Default Mode > Phone Mode

Do not provision users with an IM and Presence service.

If the service profile does not contain an IM and presence service configuration, the authenticator is Cisco
Unified Communications Manager.

Change Phone Mode > Default Mode

Provision users with an IM and Presence service.

If you set the value of the Product type field in the IM and Presence profile to:

• Unified CM (IM and Presence) the authenticator is Cisco Unified Communications Manager IM and
Presence Service.
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• Webex (IM and Presence) the authenticator is the Cisco Webex Messenger service.

Step 2 Instruct users to sign out and then sign in again.

When users sign in to the client, it retrieves the changes in the service profile and signs the user in to the
authenticator. The client then determines the product mode and prompts the user to restart the client.

After the user restarts the client, the product mode change is complete.

Change Product Modes with Cisco Unified Communications Manager Version 8.x

To change product modes with Cisco Unified CommunicationsManager version 8.x, you must reinstall Cisco
Jabber for Windows to change the authenticator.

Change Default Mode > Phone Mode

Set the following arguments, at a minimum:

• CLEAR=1 to delete any existing bootstrap file.

• AUTHENTICATOR=CUCM to set the authenticator to Cisco Unified Communications Manager.

• PRODUCT_MODE=Phone_Mode to set phone mode as the product mode.

Change Phone Mode > Default Mode

Set the following arguments, at a minimum:

• CLEAR=1 to delete any existing bootstrap file.

• AUTHENTICATOR= one of the following:

• CUP to set the authenticator to Cisco Unified Presence or Cisco Unified Communications
Manager.

• WEBEX to set the authenticator to the Cisco WebEx Messenger service.

Authentication Arguments
The following table describe the command line arguments you can set to specify the source of authentication:
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DescriptionValueArgument

Specifies the source of authentication for the client. This
value is used if Service Discovery fails. Set one of the
following as the value:

• CUP—Cisco Unified Communications Manager
IM and Presence Service. On-premises
deployments in the default product mode. The
default product mode can be either full UC or IM
only.

• CUCM—CiscoUnifiedCommunicationsManager.
On-premises deployments in phone mode.

• Webex—Cisco Webex Messenger Service.
Cloud-based or hybrid cloud-based deployments.

In on-premises deployments with Cisco Unified
Communications Manager version 9.x and later, you
should deploy the _cisco-uds SRV record. The
client can then automatically determine the
authenticator.

CUP

CUCM

Webex

AUTHENTICATOR

Specifies the address of Cisco Unified Communications
Manager IM and Presence Service. Set one of the
following as the value:

• Hostname (hostname)

• IP address (123.45.254.1)

• FQDN (hostname.domain.com)

IP address

Hostname

FQDN

CUP_ADDRESS

Specifies the address of your TFTP server. Set one of
the following as the value:

• Hostname (hostname)

• IP address (123.45.254.1)

• FQDN (hostname.domain.com)

You should specify this argument if you set Cisco
Unified CommunicationsManager as the authenticator.

If you deploy:

• In phone mode—you should specify the address
of the TFTP server that hosts the client
configuration.

• In default mode—you can specify the address of
the CiscoUnified CommunicationsManager TFTP
service that hosts the device configuration.

IP address

Hostname

FQDN

TFTP
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DescriptionValueArgument

Sets the address of your CTI server.

Specify this argument if:

• You set Cisco Unified Communications Manager
as the authenticator.

• Users have desk phone devices and require a CTI
server.

IP address

Hostname

FQDN

CTI

Sets the address of your CCMCIP server.

Specify this argument if:

• You set Cisco Unified Communications Manager
as the authenticator.

• The address of your CCMCIP server is not the
same as the TFTP server address.

The client can locate the CCMCIP server with the
TFTP server address if both addresses are the same.

Cisco Unified Communications Manager release 9.x
and earlier—If you enable Cisco Extension Mobility,
the Cisco Extension Mobility service must be
activated on the Cisco Unified Communications
Manager nodes that are used for CCMCIP. For
information about Cisco Extension Mobility, see the
Feature and Services guide for your Cisco Unified
Communications Manager release.

IP address

Hostname

FQDN

CCMCIP

Sets the value of the domain where the DNS SRV
records for Service Discovery reside.

This argument can be set to a domain where no DNS
SRV records reside if you want the client to use installer
settings or manual configuration for this information.
If this argument is not specified and Service Discovery
fails, the user will be prompted for services domain
information.

DomainSERVICES_DOMAIN
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DescriptionValueArgument

In Hybrid Deployments the domain required to discover
Webex via CAS lookup may be a different domain than
where the DNS records are deployed. If this is the case
then set the SERVICES_DOMAIN to be the domain
used forWebex discovery (or let the user enter an email
address) and set the VOICE_SERVICES_DOMAIN to
be the domain where DNS records are deployed. If this
setting is specified, the client will use the value of
VOICE_SERVICES_DOMAIN to lookup the following
DNS records for the purposes of Service Discovery and
Edge Detection:

• _cisco-uds
• _cuplogin
• _collab-edge

This setting is optional and if not specified, the DNS
records are queried on the Services Domain which is
obtained from the SERVICES_DOMAIN, email address
input by the user, or cached user configuration.

DomainVOICE_SERVICES_DOMAIN

Lists the services that you want Jabber to exclude from
Service Discovery. For example, you may have done a
trial with Webex which means that your company
domain is registered on Webex, but you do not want
Jabber users to authenticate using Webex. You want
Jabber to authenticate with an on-premises CUPCUCM
server. In this case set:

• EXCLUDED_SERVICES=WEBEX

Possible values are CUP, CUCM, Webex

To excludemore than one service, use comma separated
values. For example, to exclude CUP and CUCM,
specify: EXCLUDED_SERVICEs=CUP,CUCM. To
exclude all services, specify:
EXCLUDED_SERVICES=CUP,CUCM,WEBEX

If you exclude all services, you need to use manual
configuration or bootstrap configuration to configure
the Jabber client.

One or more of:

• CUP
• Webex
• CUCM

EXCLUDED_SERVICES

TFTP Server Address
Cisco Jabber for Windows retrieves two different configuration files from the TFTP server:

• Client configuration files that you create.

• Device configuration files that reside on the Cisco Unified Communications Manager TFTP service
when you provision users with devices.
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To minimize effort, you should host your client configuration files on the Cisco Unified Communications
Manager TFTP service. You then have only one TFTP server address for all configuration files and can specify
that address as required.

You can, however, host your client configuration on a different TFTP server to the one that contains the device
configuration. In this case, you have two different TFTP server addresses, one address for the TFTP server
that hosts device configuration and another address for the TFTP server that hosts client configuration files.

Default Deployments

This section describes how you should handle two different TFTP server addresses in deployments that have
a presence server.

You should do the following:

1. Specify the address of the TFTP server that hosts the client configuration on the presence server.

2. During installation, specify the address of the Cisco Unified Communications Manager TFTP service
with the TFTP argument.

When the client starts for the first time, it:

1. Retrieves the address of the Cisco Unified Communications Manager TFTP service from the bootstrap
file.

2. Gets device configuration from the Cisco Unified Communications Manager TFTP service.

3. Connects to the presence server.

4. Retrieves the address of the TFTP service that hosts the client configuration from the presence server.

5. Gets client configuration from the TFTP server.

Phone Mode Deployments

This section describes how you should handle two different TFTP server addresses in phonemode deployments.

You should do the following:

1. During installation, specify the address of the TFTP server that hosts the client configuration with the
TFTP argument.

2. Specify the address of the TFTP server that hosts the device configuration in your client configuration
file with the following parameter: TftpServer1.

3. Host the client configuration file on the TFTP server.

When the client starts for the first time, it:

1. Retrieves the address of the TFTP server from the bootstrap file.

2. Gets client configuration from the TFTP server.

3. Retrieves the address of the Cisco Unified Communications Manager TFTP service from the client
configuration.

4. Gets device configuration from the Cisco Unified Communications Manager TFTP service.
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Common Installation Arguments
The following table describes command line arguments that are common to all deployments:

DescriptionValueArgument

Defines the Locale ID (LCID), in decimal, of the
language that Cisco Jabber forWindows uses. The value
must be an LCID in decimal that corresponds to a
supported language.

For example, you can specify one of the following:

• 1033 specifies English.
• 1036 specifies French.

See the LCID for Languages topic for a full list of the
languages that you can specify.

This argument is optional.

If you do not specify a value, Cisco Jabber forWindows
uses the regional language for the current user as the
default.

From Release 11.1(1) onwards, if you do not specify a
value, Cisco Jabber for Windows checks the value for
the UseSystemLanguage parameter. If the
UseSystemLanguage parameter is set to true, the same
language is used as for the operating system. If the
UseSystemLanguage parameter is to set to false or not
defined, then the client uses the regional language for
the current user as the default.

The regional language is set atControl Panel >Region
and Language > Change the date, time, or number
format > Formats tab > Format dropdown.

LCID in decimalLANGUAGE

Specifies the URL where users can reset lost or
forgotten passwords.

This argument is optional but recommended.

In cloud-based deployments, you can specify
a forgot password URL using the Cisco
WebEx Administration Tool. However, the
client cannot retrieve that forgot password
URL until users sign in.

Note

URLFORGOT_PASSWORD_URL
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DescriptionValueArgument

Applies to Release 11.1(1) onwards.

Specifies whether the Sign me in when Cisco Jabber
starts check box is checked when the user installs the
client.

• true—The Sign me in when Cisco Jabber starts
check box is checked when the user installs the
client.

• false (default)—The Sign me in when Cisco
Jabber starts check box is not checked when the
user installs the client.

true

false

AUTOMATIC_SIGN_IN

Specifies the unique name of a group configuration file.

You can specify either an unqualified or fully qualified
filename as the value. The filename you specify as the
value for this argument takes priority over any other
configuration file on your TFTP server.

This argument is optional.

You can specify group configuration files in
the Cisco Support Field on the CSF device
configuration on Cisco Unified
Communications Manager.

Remember

FilenameTFTP_FILE_NAME

Controls user sign in to multiple client instances.

By default, users can sign in to multiple instances of
Cisco Jabber at the same time. Set one of the following
values to change the default behavior:

• WBX—Users can sign in to one instance of Cisco
Jabber for Windows at a time.

Cisco Jabber for Windows appends the
wbxconnect suffix to the user's JID. Users
cannot sign in to any other Cisco Jabber client that
uses the wbxconnect suffix.

• MUT—Users can sign in to one instance of Cisco
Jabber for Windows at a time, but can sign in to
other Cisco Jabber clients at the same time.

Each instance of Cisco Jabber for Windows
appends the user's JID with a unique suffix.

WBX

MUT

LOGIN_RESOURCE
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DescriptionValueArgument

Defines the directory where the client writes log files.

Use quotation marks to escape space characters in the
path, as in the following example:

"C:\my_directory\Log Directory"

The path you specify must not containWindows invalid
characters.

The default value is
%USER_PROFILE%\AppData\Local\Cisco\Unified
Communications\Jabber\CSF\Logs

Absolute path on the
local filesystem

LOG_DIRECTORY

Disables click-to-x functionality with Cisco Jabber.

If you specify this argument during installation, the
client does not register as a handler for click-to-x
functionality with the operating system. This argument
prevents the client from writing to the Microsoft
Windows registry during installation.

You must re-install the client and omit this argument
to enable click-to-x functionality with the client after
installation.

DISABLECLICK2X

Specifies whether analytics data is gathered. The default
value is true.

To improve your experience and product performance,
Cisco Jabber may collect and send non-personally
identifiable usage and performance data to Cisco. The
aggregated data is used by Cisco to understand trends
in how Jabber clients are being used and how they are
performing.

Full details on what analytics data Cisco Jabber does
and does not collect can be found in the Cisco Jabber
Supplement to Cisco’s On-Line Privacy Policy at
http://www.cisco.com/web/siteassets/legal/privacy_
02Jun10.html.

true

false

Telemetry_Enabled

SSO Arguments
This section describes the command line arguments you can use to deploy Cisco Jabber for Windows with
single sign on (SSO) capabilities.

Cloud-Based SSO Arguments
The arguments in the following table apply to cloud-based deployments only:
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DescriptionValueArgument

Specifies the domain name for the Cisco WebEx Org
that contains the URL for the SSO service.

Cisco Jabber forWindows uses this argument to retrieve
the URL of the SSO service from the Org. When Cisco
Jabber for Windows gets the SSO service URL, it can
request login tokens to authenticate with Cisco WebEx
Messenger.

You specify the URL for the SSO service as
the value of the Customer SSO Service
Login URL in the Cisco WebEx
Administration Tool.

Note

Domain nameSSO_ORG_DOMAIN

Installer Properties
The following are the properties you can modify in a custom installer:

• CLEAR

• PRODUCT_MODE

• AUTHENTICATOR

• CUP_ADDRESS

• TFTP

• CTI

• CCMCIP

• LANGUAGE

• TFTP_FILE_NAME

• FORGOT_PASSWORD_URL

• SSO_ORG_DOMAIN

• LOGIN_RESOURCE

• LOG_DIRECTORY

• CLICK2X

• SERVICES_DOMAIN

These properties correspond to the installation arguments and have the same values.
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Supported Languages
Cisco Jabber forWindows uses the regional language for the current user as the default. The regional language
is set at Control Panel > Region and Language > Change the date, time, or number format > Formats
tab > Format dropdown.

The following table lists the languages that Cisco Jabber for Windows supports.

RomanianFrenchArabic
RussianHebrewBulgarian
SerbianHungarianCatalan
SlovakItalianCroatian
SlovenianJapaneseCzech
SwedishKoreanDanish
ThaiNorwegianGerman
TurkishDutchGreek
Chinese - ChinaPolishEnglish

Portuguese - BrazilSpanish Chinese - Taiwan
Portuguese - PortugalFinnish

Cisco Jabber for Windows does not support Locale IDs for all sub-languages. For example, if you specify
French - Canada, Cisco Jabber for Windows uses French - France.

Note

See the following documentation for more information about Locale IDs:

• Microsoft Windows Locale Code Identifier (LCID) Reference

• Locale IDs Assigned by Microsoft

Related Topics
Microsoft Windows Locale Code Identifier (LCID) Reference
Locale IDs Assigned by Microsoft

Cisco Media Services Interface
Cisco Jabber for Windows supports Cisco Media Services Interface version 4.1.2 for Microsoft Windows 7
and later.

Cisco Jabber for Mac supports Cisco Media Services Interface version 4.0.2 or later.

Traffic Marking
Cisco Media Services Interface provides a service that works with Cisco Prime Collaboration Manager and
Cisco Medianet-enabled routers to ensure that Cisco Jabber can send audio media and video media on your
network with minimum latency or packet loss.
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Before Cisco Jabber sends audio media or video media, it checks for Cisco Media Services Interface.

• If the service exists on the computer, Cisco Jabber provides flow information to Cisco Media Services
Interface.

The service then signals the network so that routers classify the flow and provide priority to the Cisco
Jabber traffic.

• If the service does not exist, Cisco Jabber does not use it and sends audio media and video media as
normal.

Cisco Jabber checks for Cisco Media Services Interface for each audio call or video call.Note

Desk Phone Video Capabilities
Youmust install CiscoMedia Services Interface to enable desk phone video capabilities. CiscoMedia Services
Interface provides a driver that enables Cisco Jabber for Windows to do the following:

• Discover the desk phone device.

• Establish and maintain a connection to the desk phone device using the CAST protocol.

Prepare Your Network
To install Cisco Media Service Interface for traffic marking, you must prepare your network.

Procedure

Step 1 Install Cisco Prime Collaboration manager.
Step 2 Install routers or switches enabled for Cisco Medianet where appropriate.
Step 3 Configure your network to handle the metadata attributes that Cisco Media Service Interface applies to

applications.

Not all devices on your network must support Cisco Medianet.

The first hop should prioritize traffic based on the metadata attributes from Cisco Media Service Interface.
As the traffic traverses the network, all other devices should also prioritize that traffic unless you configure
policies on those devices to handle the traffic differently.

Install Cisco Media Services Interface

Procedure

Step 1 Download the Cisco Media Services Interface installation program from the download site on cisco.com.
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Step 2 Install Cisco Media Services Interface on each computer on which you install Cisco Jabber.

See the appropriate Cisco Medianet documentation for installing Cisco Media Services Interface.

Related Topics
Download software
Medianet Knowledge Base Portal

Uninstall Cisco Jabber for Windows
You can uninstall Cisco Jabber for Windows using either the command line or the Microsoft Windows control
panel. This document describes how to uninstall Cisco Jabber for Windows using the command line.

Use the Installer
If the installer is available on the file system, use it to remove Cisco Jabber for Windows.

Procedure

Step 1 Open a command line window.
Step 2 Enter the following command:

msiexec.exe /x path_to_CiscoJabberSetup.msi

For example,

msiexec.exe /x C:\Windows\Installer\CiscoJabberSetup.msi /quiet

Where /quiet specifies a silent uninstall.

The command removes Cisco Jabber for Windows from the computer.

Use the Product Code
If the installer is not available on the file system, use the product code to remove Cisco Jabber for Windows.

Procedure

Step 1 Find the product code.
a) Open the Microsoft Windows registry editor.
b) Locate the following registry key: HKEY_CLASSES_ROOT\Installer\Products
c) Select Edit > Find.
d) Enter Cisco Jabber in the Find what text box in the Find window and select Find Next.
e) Find the value of the ProductIcon key.
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The product code is the value of the ProductIcon key, for example,
C:\Windows\Installer\{product_code}\ARPPRODUCTICON.exe.

The product code changes with each version of Cisco Jabber for Windows.Note

Step 2 Open a command line window.
Step 3 Enter the following command:

msiexec.exe /x product_code

For example,
msiexec.exe /x 45992224-D2DE-49BB-B085-6524845321C7 /quiet

Where /quiet specifies a silent uninstall.

The command removes Cisco Jabber for Windows from the computer.
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