Introduction
Ce document décrit le processus permettant d'identifier si les problèmes de qualité audio sont un problème réseau ou un problème avec l'application virtualisée.
Problème
À mesure que les applications vocales en temps réel sont virtualisées, il devient beaucoup plus complexe de résoudre les problèmes de qualité audio. Utilisez Unity Connection comme sujet pour cette « application vocale en temps réel ».
Collecte d'informations
- La première étape consiste à déterminer si les invites sont déformées lorsque vous quittez Unity Connection. Afin de rassembler un paquet, capture « utils network capture eth0 file capture1 size all count 100000 ».
Note: Les invites Cisco Unified Communication (CUC) constituent une bonne ligne de base pour déterminer la qualité indésirable. N'utilisez pas les messages d'accueil enregistrés par l'utilisateur car ils peuvent constituer une ligne de base non fiable.
- Analyser la capture de paquets : Wireshark, prend en charge la loi A G.711 ou la loi MU G.711.
- Vérifiez la qualité du flux RTP (Routing Table Protocol) sortant avec Wireshark :
- Décoder avec les paramètres par défaut.
- Décodez avec l'option « utiliser l'horodatage RTP » dans Wireshark.
Causes possibles
Si les deux flux décodés rencontrent des problèmes de qualité vocale, le problème peut être lié à l'invite (fichier WAV) ou à Unity Connection.
Si l'enregistrement par défaut est déformé, mais que l'utilisation des horodatages RTP est correcte, le problème peut être lié aux ressources/VMware.
Si la qualité est acceptable lorsque vous écoutez le flux RTP à l'aide du décodage par défaut, le problème peut être lié à la connectivité réseau entre le CUC et le téléphone.
Note: Il est conseillé de capturer des paquets à partir du commutateur sur lequel le serveur ESXi est connecté et de vérifier la qualité. S'il est défectueux, il est probable que les pilotes sont vérifiés sur l'hôte ESXi lui-même.
Solution
Si le problème indique qu'il concerne Unity Connection ou le fichier WAV, vérifiez d'abord la qualité de l'enregistrement :
- Vérifiez le protocole NTP (Network Time Protocol).
- Si plusieurs NTP sont configurés pour le client, assurez-vous que le CUC ne bascule pas fréquemment entre les deux.
- Vérifiez si les serveurs NTP ont NTPv4 (capture de paquets) : « utils ntp status ».
- Utilisez l'interface utilisateur graphique Web pour vérifier la qualité.
- Assurez-vous qu'il n'y a pas de coredumps sur CUC. Rechercher le bogue connu : « utils core active list ».
- Utilisez l'éditeur de sauvegarde de Cobra pour vérifier la qualité.
Si le problème est lié à la vérification de VMware, procédez comme suit :
- Vérifiez que la réservation appropriée est effectuée sur les machines virtuelles Unity Connection : vérifiez les réservations de CPU et de RAM comme dans les plates-formes prises en charge.
- Assurez-vous que le déchargement de réception importante (LRO) est désactivé pour l'hôte ESXi (pas un problème avec ESXi 5.1+). Reportez-vous à Désactiver LRO sur les déploiements d'applications UCS/UC pour plus d'informations.
- Prenez un instantané de la machine virtuelle CUC. Pour plus d'informations, consultez Instantanés VMware.
Note: Les snapshots des machines virtuelles Unity Connection ne sont pas pris en charge et peuvent entraîner des problèmes de qualité vocale.
- Vérifiez que les outils VMware sont installés. Pour plus d'informations, consultez Outils VMware.
Note: VMware Tools installe les pilotes de carte réseau sur la machine virtuelle pour améliorer les performances du réseau.
- Assurez-vous que Sync VM with host n'est pas coché. Cette option synchronise l'heure de la machine virtuelle avec l'hôte ESXi. Dans le client Sphere, naviguez jusqu'à Sélectionner l'ordinateur virtuel et cliquez avec le bouton droit sur les paramètres de modification de l'ordinateur virtuel. Dans l'onglet Options, sélectionnez Outils VMware > Avancé. Assurez-vous que la case Synchroniser l'heure d'invité avec l'hôte est décochée.