In questo documento viene descritto come configurare ciascun profilo Multicast VPN (mVPN) all'interno di Cisco IOS® solo per IPv6.
Prima di procedere con la configurazione descritta in questo documento, verificare se è supportato un profilo mVPN sulla piattaforma specifica con Cisco IOS.
Le informazioni di questo documento si basano su tutte le versioni di Cisco IOS.
Le informazioni discusse in questo documento fanno riferimento a dispositivi usati in uno specifico ambiente di emulazione. Su tutti i dispositivi menzionati nel documento la configurazione è stata ripristinata ai valori predefiniti. Se la rete è operativa, valutare attentamente eventuali conseguenze derivanti dall'uso dei comandi.
Un profilo mVPN è configurato per il contesto globale o per Routing/inoltro virtuale (VRF). Per abilitare IPv6 per i profili mVPN, è possibile utilizzare solo il modo più recente di definire un VRF (definizione VRF). Di seguito è riportato un esempio:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
!
address-family ipv6
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
Il routing multicast per IPv6 deve essere abilitato per i profili nel contesto globale. Inoltre, è necessario abilitare il protocollo PIMv6 (Protocol Independent Multicast Version 6) sull'interfaccia di loopback globale. Ciò è vero se il comando ipv6 multicast-routing è abilitato e se l'interfaccia di loopback ha un indirizzo IPv6 o se il comando ipv6 enable è configurato sull'interfaccia di loopback.
ipv6 multicast-routing
È necessario abilitare il routing multicast per IPv6 nel VRF per i profili nel contesto VRF.
ipv6 multicast-routing vrf one
È buona norma abilitare la registrazione di MLDP (Multipoint Label Distribution Protocol) con questo comando globale per i profili con MLDP:
mpls mldp logging notifications
PIM per IPv6 è abilitato per impostazione predefinita sulle interfacce nel contesto globale o VRF se è configurato il rispettivo comando ipv6 multicast-routing o ipv6 multicast-routing vrf one.
interface Ethernet0/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
ipv6 address 2001:DB8:1::1/64
Ciò significa che il comando ipv6 pim è abilitato per impostazione predefinita sulle interfacce. Per i profili con VRF, è necessario che 6 Virtual Provider Edge (6VPE) siano completamente operativi per il traffico unicast. Per il profilo 7, 6 Provider Edge (6PE) deve essere completamente operativo per il traffico unicast.
Questa sezione descrive come configurare i profili mVPN in Cisco IOS.
L'ID VPN configurato per il VRF è richiesto solo per i profili che utilizzano MLDP come protocollo dell'albero principale e MDT (Default Multicast Distribution Tree).
vrf definition one
rd 1:1
vpn id 1000:2000
â¦
Per i profili con MDT predefinito e GRE (Generic Routing Encapsulation), se mVPN è abilitato per IPv4 e IPv6, è necessario utilizzare lo stesso MDT predefinito per entrambe le famiglie di indirizzi (AF).
Non è possibile combinare profili diversi per i diversi AF.
Per i profili con MDT partizionato con MLDP, se mVPN è abilitato per IPv4 e IPv6, viene segnalato un MDT partizionato diverso per ogni AF per lo stesso router PE radice. L'albero MLDP avrà un identificatore globale (GID) diverso nel valore opaco. Per entrambi gli AF viene utilizzata la stessa interfaccia LSPVIF (Label Switched Path Virtual Interface).
Di seguito è riportato un esempio in cui il profilo 14 viene utilizzato sia per i server AF IPv4 che per IPv6:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
mdt auto-discovery mldp
mdt partitioned mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
address-family ipv6
mdt auto-discovery mldp
mdt partitioned mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
Le origini 10.100.1.6 e 2001:DB8:2:6 si trovano dietro lo stesso router PE di origine PE2. La voce del database MRIB (Multicast Routing Information Database) per il gruppo multicast IPv4 e il gruppo multicast IPv6 utilizza una voce LSM (Label Switched Multicast) diversa o una voce MLDP nel database sul router PE in entrata, quindi entrambi i gruppi vengono inoltrati su alberi MLDP diversi.
PE2#show mpls mldp database opaque_type gid
LSM ID : 5 Type: P2MP Uptime : 02:18:54
FEC Root : 10.100.1.2 (we are the root)
Opaque decoded : [gid 65536 (0x00010000)]
Opaque length : 4 bytes
Opaque value : 01 0004 00010000
Upstream client(s) :
None
Expires : N/A Path Set ID : 5
Replication client(s):
MDT (VRF one)
Uptime : 02:18:54 Path Set ID : None
Interface : Lspvif1
10.100.1.4:0
Uptime : 00:32:50 Path Set ID : None
Out label (D) : 20 Interface : Ethernet2/0*
Local label (U): None Next Hop : 10.1.2.4
LSM ID : 6 Type: P2MP Uptime : 00:37:06
FEC Root : 10.100.1.2 (we are the root)
Opaque decoded : [gid 131072 (0x00020000)]
Opaque length : 4 bytes
Opaque value : 01 0004 00020000
Upstream client(s) :
None
Expires : N/A Path Set ID : 6
Replication client(s):
MDT (VRF one)
Uptime : 00:37:06 Path Set ID : None
Interface : Lspvif1
10.100.1.4:0
Uptime : 00:18:38 Path Set ID : None
Out label (D) : 22 Interface : Ethernet2/0*
Local label (U): None Next Hop : 10.1.2.4
PE2#show ip mfib vrf one 232.1.1.1
Entry Flags: C - Directly Connected, S - Signal, IA - Inherit A flag,
ET - Data Rate Exceeds Threshold, K - Keepalive
DDE - Data Driven Event, HW - Hardware Installed
ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
MS - MoFRR Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
NS - Negate Signalling, SP - Signal Present,
A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
MA - MFIB Accept, A2 - Accept backup,
RA2 - MRIB Accept backup, MA2 - MFIB Accept backup
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts: Total/RPF failed/Other drops
I/O Item Counts: FS Pkt Count/PS Pkt Count
VRF one
(10.100.1.6,232.1.1.1) Flags:
SW Forwarding: 374/0/100/0, Other: 122/0/122
Ethernet0/0 Flags: A
Lspvif1, LSM/6 Flags: F
Pkts: 374/0
PE2#show ipv6 mfib vrf one route FF3E::4000:1
Entry Flags: C - Directly Connected, S - Signal, IA - Inherit A flag,
ET - Data Rate Exceeds Threshold, K - Keepalive
DDE - Data Driven Event, HW - Hardware Installed
ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
MS - MoFRR Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
NS - Negate Signalling, SP - Signal Present,
A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
MA - MFIB Accept, A2 - Accept backup,
RA2 - MRIB Accept backup, MA2 - MFIB Accept backup
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts: Total/RPF failed/Other drops
I/O Item Counts: FS Pkt Count/PS Pkt Count
VRF one
(2001:DB8:2::6,FF3E::4000:1)
Ethernet0/0 A
Lspvif1, LSM/5 F
In questa sezione vengono descritte le configurazioni richieste per ogni profilo.
Utilizzare questa configurazione per il profilo 0:
interface Loopback0
ipv6 address 2001:DB8:100::2/128
!
vrf definition one
rd 1:1
!
address-family ipv6
mdt default 232.1.1.1
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
!
address-family ipv4 mdt
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Utilizzare questa configurazione per il profilo 1:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
ipv6 multicast-routing vrf one
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Il profilo 2 non è attualmente supportato in Cisco IOS e MLDP non supporta MDT partizionato con MP2MP (Multipoint-to-Multipoint).
Utilizzare questa configurazione per il profilo 3:
interface Loopback0
ipv6 address 2001:DB8:100::2/128
!
vrf definition one
rd 1:1
!
address-family ipv6
mdt auto-discovery pim
mdt default 232.1.1.1
route-target export 123:456
route-target import 123:456
exit-address-family
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Il profilo 4 non è attualmente supportato in Cisco IOS e MLDP non supporta Partitioned MDT con MP2MP.
Il profilo 5 non è attualmente supportato in Cisco IOS e la segnalazione PIM non è supportata su MDT partizionato.
Utilizzare questa configurazione per il profilo 6:
vrf definition one
rd 1:1
!
address-family ipv6
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
ipv6 multicast-routing vrf one
ipv6 multicast vrf one mpls source Loopback0
ipv6 multicast vrf one mpls mldp
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Utilizzare questa configurazione per il profilo 7:
ipv6 multicast-routing
ipv6 multicast mpls source Loopback0
ipv6 multicast mpls mldp
interface Ethernet0/0
ip address 10.2.2.2 255.255.255.0
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 2001:DB8:2::6 remote-as 65002
!
!
address-family ipv6
redistribute connected
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-label
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Il profilo 8 non è attualmente supportato in Cisco IOS.
Utilizzare questa configurazione per il profilo 9:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
route-target export 123:456
route-target import 123:456
exit-address-family
ipv6 multicast-routing vrf one
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Il profilo 10 non è attualmente supportato in Cisco IOS e il protocollo BGP-AD non è supportato per il progetto P2MP TE (Point-to-Multipoint Traffic Engineering).
Utilizzare questa configurazione per il profilo 11:
interface Loopback0
ipv6 address 2001:DB8:100::2/128
!
vrf definition one
rd 1:1
!
address-family ipv6
mdt auto-discovery pim
mdt default 232.1.1.1
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Utilizzare questa configurazione per il profilo 12:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
Utilizzare questa configurazione per il profilo 13:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp 10.100.1.3
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
ipv6 multicast-routing vrf one
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
!
Utilizzare questa configurazione per il profilo 14:
vrf definition one
rd 1:1
!
address-family ipv6
mdt auto-discovery mldp
mdt strict-rpf interface
mdt partitioned mldp p2mp
mdt overlay use-bgp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 2001:DB8:2::6 remote-as 65002
!
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate exit-address-family
Il profilo 15 non è attualmente supportato in Cisco IOS e MLDP non supporta Partitioned MDT con MP2MP.
Il profilo 16 non è attualmente supportato in Cisco IOS.
Utilizzare questa configurazione per il profilo 17:
vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv6
mdt auto-discovery mldp
mdt default mpls mldp p2mp
route-target export 123:456
route-target import 123:456
exit-address-family
!
interface Ethernet0/0
vrf forwarding one
ipv6 address 2001:DB8:2::2/64
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.2.2.6 remote-as 65002
neighbor 10.100.1.4 remote-as 1
neighbor 10.100.1.4 update-source Loopback0
neighbor 10.100.1.4 next-hop-self
!
address-family ipv6 mvpn
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family vpnv6
neighbor 10.100.1.4 activate
neighbor 10.100.1.4 send-community both
exit-address-family
!
address-family ipv6 vrf one
redistribute connected
neighbor 2001:DB8:2::6 remote-as 65002
neighbor 2001:DB8:2::6 activate
exit-address-family
Il profilo 18 non è attualmente supportato in Cisco IOS.
Il profilo 19 e la replica in ingresso (IR) non sono attualmente supportati in Cisco IOS.
Il profilo 20 e i tunnel automatici TE P2MP non sono attualmente supportati in Cisco IOS.
Profile 21 e IR non sono attualmente supportati in Cisco IOS.
Il profilo 22 e i tunnel automatici TE P2MP non sono attualmente supportati in Cisco IOS.
Profilo 23 e IR non sono attualmente supportati in Cisco IOS.
Il profilo 24 e i tunnel automatici TE P2MP non sono attualmente supportati in Cisco IOS.
Profilo 25 e IR non sono attualmente supportati in Cisco IOS.
Il profilo 26 e i tunnel automatici TE P2MP non sono attualmente supportati in Cisco IOS.
Attualmente non è disponibile una procedura di verifica per queste configurazioni.
Non sono attualmente disponibili informazioni specifiche sulla risoluzione dei problemi per queste configurazioni.
Revisione | Data di pubblicazione | Commenti |
---|---|---|
1.0 |
15-Jun-2015 |
Versione iniziale |