概要
このドキュメントでは、名前付きEnhanced Interior Gateway Routing Protocol(EIGRP)モード機能について説明し、関連する設定を使用して、従来のモードと名前付きモードの違いを説明します。
前提条件
要件
IPルーティングとEIGRPプロトコルに関する基本的な知識があることが推奨されます。
使用するコンポーネント
このドキュメントの内容は、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、初期(デフォルト)設定の状態から起動しています。対象のネットワークが実稼働中である場合には、どのようなコマンドについても、その潜在的な影響について確実に理解しておく必要があります。
背景説明
EIGRPを設定する従来の方法では、インターフェイスおよびEIGRPコンフィギュレーションモードでさまざまなパラメータを設定する必要があります。EIGRP IPV4とIPv6を設定するには、個別のEIGRPインスタンスを設定する必要があります。従来の EIGRP では、IPv6 EIGRP 実装の Virtual Routing and Forwarding(VRF)はサポートされていません。
名前付きモードのEIGRPでは、EIGRP設定の下に何もかも1箇所で設定され、前述のように制限はありません。
設定
ネットワーク図
この図は、このドキュメントの残りの部分のトポロジ例です。
従来の方法とは異なり、EIGRPインスタンスはルータで設定しても作成も開始もされません。
R1(config)#router eigrp TEST
インスタンスは、アドレスファミリと自律システム番号が設定されると作成されます。次に例を示します。
R1(config-router)#address-family ipv4 unicast autonomous-system 1
この名前付きモードでは、1 つの EIGRP インスタンスだけを作成する必要があります。これはすべてのアドレス ファミリ タイプにも使用できます。また、使用可能なシステム リソースによってのみ限定される複数の VRF もサポートしています。名前付きモードに関して注意すべき点の1つは、アドレスファミリの設定では、IPv4 EIGRPの従来の設定としてIPv4ルーティングが有効になっていないことです。プロセスを開始するには、「no shut」が必要です。
router eigrp [virtual-instance-name | asystem]
[no] shutdown
名前付きEIGRPには、設定の大部分が完了する3つのモードがあります。内容は次のとおりです。
- アドレス ファミリ コンフィギュレーション モード:(config-router-af)#
- アドレス ファミリ インターフェイス コンフィギュレーション モード:(config-router-af-interface)#
- アドレス ファミリ トポロジ コンフィギュレーション モード:(config-router-af-topology)#
アドレスファミリ コンフィギュレーション モード
このモードに入るには、次のコマンドを使用します。
R1(config-router)#address-family ipv4 unicast autonomous-system 1
R1(config-router-af)#?
Address Family configuration commands:
af-interface Enter Address Family interface configuration
default Set a command to its defaults
eigrp EIGRP Address Family specific commands
exit-address-family Exit Address Family configuration mode
help Description of the interactive help system
maximum-prefix Maximum number of prefixes acceptable in aggregate
metric Modify metrics and parameters for advertisement
neighbor Specify an IPv4 neighbor router
network Enable routing on an IP network
no Negate a command or set its defaults
shutdown Shutdown address family
timers Adjust peering based timers
topology Topology configuration mode
このモードでは、次のパラメータを設定できます。ネットワーク、EIGRPネイバー、およびEIGRPルータID。名前付きEIGRPのその他の2つのコンフィギュレーションモードは、このモードからアクセスします。
従来の設定
Interface GigabitEthernet 0/0
ip bandwidth-percent eigrp 1 75
ipv6 enable
ipv6 eigrp 1
ip bandwidth-percent eigrp 1 75
no shut
!
router eigrp 1
eigrp router-id 10.10.10.1
network 0.0.0.0 0.0.0.0
ipv6 router eigrp 1
eigrp router-id 10.10.10.1
no shut
名前付き設定
router eigrp TEST
!
address-family ipv4 unicast autonomous-system 1
!
network 0.0.0.0
eigrp router-id 10.10.10.1
no shutdown
exit-address-family
!
address-family ipv6 unicast autonomous-system 1
!
eigrp router-id 10.10.10.1
no shutdown
exit-address-family
アドレスファミリ インターフェイス コンフィギュレーション モード
このモードでは、実際のインターフェイス(論理または物理)で以前に設定されたすべてのインターフェイス固有コマンドが取り込まれます。 EIGRP認証、スプリットホライズン、およびサマリーアドレスの設定は、実際のインターフェイスではなく、ここで設定するオプションの一部です。
R1(config-router-af)#af-interface g0/0
R1(config-router-af-interface)#?
Address Family Interfaces configuration commands:
authentication authentication subcommands
bandwidth-percent Set percentage of bandwidth percentage limit
bfd Enable Bidirectional Forwarding Detection
dampening-change Percent interface metric must change to cause update
dampening-interval Time in seconds to check interface metrics
default Set a command to its defaults
exit-af-interface Exit from Address Family Interface configuration
hello-interval Configures hello interval
hold-time Configures hold time
next-hop-self Configures EIGRP next-hop-self
no Negate a command or set its defaults
passive-interface Suppress address updates on an interface
shutdown Disable Address-Family on interface
split-horizon Perform split horizon
summary-address Perform address summarization
注:af-interface defaultコマンドを使用すると、すべてのインターフェイスに設定を一度に適用できます。
アドレスファミリ トポロジ コンフィギュレーション モード
このモードでは、EIGRPトポロジテーブルで動作するいくつかの設定オプションが提供されます。このモードでは、再配布、距離、オフセットリスト、バリアンスなどを設定できます。このモードは、アドレスファミリコンフィギュレーションモードから開始できます。
R1(config-router-af)#topology base
R1(config-router-af-topology)#?
Address Family Topology configuration commands:
auto-summary Enable automatic network number summarization
default Set a command to its defaults
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter entries in eigrp updates
eigrp EIGRP specific commands
exit-af-topology Exit from Address Family Topology configuration
maximum-paths Forward packets over multiple paths
metric Modify metrics and parameters for advertisement
no Negate a command or set its defaults
offset-list Add or subtract offset from EIGRP metrics
redistribute Redistribute IPv4 routes from another routing proto
summary-metric Specify summary to apply metric/filtering
timers Adjust topology specific timers
traffic-share How to compute traffic share over alternate paths
variance Control load balancing variance
比較
ここで説明した2つの設定モードの比較を示します。
アベイラビリティ
EIGRP名前付き設定は、次のCisco IOS®リリースから使用できます。
- 15.0(1)M
- 12.2(33)SRE
- 12.2(33)XNE
- Cisco IOS XE Release 2.5
名前付き EIGRP への自動変換
設定を従来の方法から新しい方法に自動的に変換する方法があります。EIGRPプロセス内で、コマンド
eigrp upgrade-cli <EIGRP Virtual-Instance Name>を入力する必要があります。これにより、確立されたEIGRPピアリングに影響を与えることなく、設定が名前付きモードに自動的に変換されます。
Traditional Configuration
router eigrp 1
network 10.10.10.1 0.0.0.0
!
interface Ethernet0/0
ip address 10.10.10.1 255.255.255.0
ip hello-interval eigrp 1 100
Configuration
R1(config)#router eigrp 1
R1(config-router)#eigrp upgrade-cli TEST
Configuration will be converted from router eigrp 1 to router eigrp TEST.
Are you sure you want to proceed? ? [yes/no]: yes
*Oct 10 14:14:40.684: EIGRP: Conversion of router eigrp 1 to router eigrp TEST -
Completed.
Converted Named Configuration
router eigrp TEST
!
address-family ipv4 unicast autonomous-system 1
!
af-interface Ethernet0/0
hello-interval 100
exit-af-interface
!
topology base
exit-af-topology
network 10.10.10.1 0.0.0.0
exit-address-family
確認
現在、この設定に使用できる確認手順はありません。
トラブルシュート
現在、この設定に関する特定のトラブルシューティング情報はありません。