この製品のドキュメントセットは、偏向のない言語を使用するように配慮されています。このドキュメントセットでの偏向のない言語とは、年齢、障害、性別、人種的アイデンティティ、民族的アイデンティティ、性的指向、社会経済的地位、およびインターセクショナリティに基づく差別を意味しない言語として定義されています。製品ソフトウェアのユーザインターフェイスにハードコードされている言語、RFP のドキュメントに基づいて使用されている言語、または参照されているサードパーティ製品で使用されている言語によりドキュメントに例外が存在する場合があります。シスコのインクルーシブ ランゲージの取り組みの詳細は、こちらをご覧ください。
シスコは世界中のユーザにそれぞれの言語でサポート コンテンツを提供するために、機械と人による翻訳を組み合わせて、本ドキュメントを翻訳しています。ただし、最高度の機械翻訳であっても、専門家による翻訳のような正確性は確保されません。シスコは、これら翻訳の正確性について法的責任を負いません。原典である英語版(リンクからアクセス可能)もあわせて参照することを推奨します。
このドキュメントの目的は、EIGRP(Enhanced Interior Gateway Routing Protocol)名前付きモードを使用したEVN(Easy Virtual Network)の設定を示すことです。 これは、OSPF(Open Shortest Path First)の使用と、VNETトランクリストやルートレプリケーションなどの他の高度なトピックを示す『Easy Virtual Network Configuration』ドキュメントの補足です。 EVN VNETは、複数のVRFを導入するためのMPLS(Multi Protocol Label Switching)VPN(Virtual Private Network)またはVRF-lite(Virtual Routing and Forwarding)よりも簡単なオプションをオペレータに提供することを目的としています。 EVN VNETは、ルーティングプロトコルとVNETトランクインターフェイスに対する複製された設定の概念を使用して、オペレータの負担を軽減し、繰り返し行われるタスクの一部を保存します。 EIGRP、ルーティング、またはCEF(Cisco Express Forwarding)のトラブルシューティングは、このドキュメントでは扱いません。特に断りのない限り、通常のトラブルシューティング手順に従ってください。
EIGRPに関する基本的な知識があることが推奨されます。
この機能は、IOSバージョン15.2以降の一部のリリースで使用できます。EVN VNETを使用したEIGRP名前付きモードがサポートされているかどうかを確認するには、show ip eigrp pluginsの出力を確認します。 Easy Virtual Network(EVN)バージョン1.00.00以降が存在する場合は、使用しているバージョンでこの機能がサポートされています。
R1#show eigrp plugins
EIGRP feature plugins:::
eigrp-release : 21.00.00 : Portable EIGRP Release
: 1.00.10 : Source Component Release(rel21)
parser : 2.02.00 : EIGRP Parser Support
igrp2 : 2.00.00 : Reliable Transport/Dual Database
bfd : 2.00.00 : BFD Platform Support
mtr : 1.00.01 : Multi-Topology Routing(MTR)
eigrp-pfr : 1.00.01 : Performance Routing Support
EVN/vNets : 1.00.00 : Easy Virtual Network (EVN/vNets)
ipv4-af : 2.01.01 : Routing Protocol Support
ipv4-sf : 1.02.00 : Service Distribution Support
vNets-parse : 1.00.00 : EIGRP vNets Parse Support
ipv6-af : 2.01.01 : Routing Protocol Support
ipv6-sf : 2.01.00 : Service Distribution Support
snmp-agent : 2.00.00 : SNMP/SNMPv2 Agent Support
注:EVN VNETを使用するEIGRP名前付きモードは、15.1SYではサポートされていません。 このバージョンでは、利用可能なドキュメントですでに説明されているクラシックモードのEIGRP設定を使用する必要があります。
BFD(Bidirectional Forwarding Detection(BFD;双方向フォワーディング検出))は現在VNETグローバルでのみサポートされており、VNETトランク上の名前付きVNETサブインターフェイスでは機能しません。
EVN VNETでEIGRP名前付きモードを使用する場合は、予測不能な継承が発生する可能性があるため、af-interface defaultを使用することは推奨されません。
このドキュメントの情報は、Cisco IOSバージョン15.6(1)S2を実行する特定のラボ環境のデバイスから作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で開始しています。対象のネットワークが実稼働中である場合には、どのようなコマンドについても、その潜在的な影響について確実に理解しておく必要があります。
R3、R4、R5、およびR6の設定はすべて類似しているため、このドキュメントには記載されていません。これらはR1またはR2とのEIGRPネイバーを形成するように設定されているだけで、R1とR2の間で使用されるEVN VNETを認識しません。
R1からの関連する設定
vrf definition orange
vnet tag 101
!
address-family ipv4
exit-address-family
!
vrf definition red
vnet tag 102
!
address-family ipv4
exit-address-family
!
interface Ethernet0/0
vnet trunk
ip address 10.12.12.1 255.255.255.0
!
interface Ethernet1/0
vrf forwarding orange
ip address 192.168.13.1 255.255.255.0
!
interface Ethernet2/0
vrf forwarding red
ip address 192.168.15.1 255.255.255.0
!
!
router eigrp named
!
address-family ipv4 unicast autonomous-system 100
!
af-interface Ethernet0/0
authentication mode hmac-sha-256 cisco
exit-af-interface
!
topology base
exit-af-topology
network 10.0.0.0
exit-address-family
!
address-family ipv4 unicast vrf orange autonomous-system 101
!
af-interface Ethernet1/0
authentication mode hmac-sha-256 cisco
exit-af-interface
!
topology base
exit-af-topology
network 10.0.0.0
network 192.168.13.0
exit-address-family
!
address-family ipv4 unicast vrf red autonomous-system 102
!
topology base
exit-af-topology
network 10.0.0.0
network 192.168.15.0
exit-address-family
R2からの関連する設定
vrf definition orange
vnet tag 101
!
address-family ipv4
exit-address-family
!
vrf definition red
vnet tag 102
!
address-family ipv4
exit-address-family
!
interface Ethernet0/0
vnet trunk
ip address 10.12.12.2 255.255.255.0
!
interface Ethernet1/0
vrf forwarding orange
ip address 192.168.24.2 255.255.255.0
!
interface Ethernet2/0
vrf forwarding red
ip address 192.168.26.2 255.255.255.0
!
!
router eigrp named
!
address-family ipv4 unicast autonomous-system 100
!
af-interface Ethernet0/0
authentication mode hmac-sha-256 cisco
exit-af-interface
!
topology base
exit-af-topology
network 10.0.0.0
exit-address-family
!
address-family ipv4 unicast vrf orange autonomous-system 101
!
af-interface Ethernet1/0
authentication mode hmac-sha-256 cisco
exit-af-interface
!
topology base
exit-af-topology
network 10.0.0.0
network 192.168.24.0
exit-address-family
!
address-family ipv4 unicast vrf red autonomous-system 102
!
topology base
exit-af-topology
network 10.0.0.0
network 192.168.26.0
exit-address-family
Easy Virtual Networkの利点の1つは、設定の簡素化です。 これは、各VNETタグのVNETトランクを自動的に設定することによって実現されます。 EVNをVRF-liteと比較すると、各サブインターフェイスを手動で設定する必要があります。 Ethernet0/0はR1とR2を接続するVNETトランクであり、dot1Q VNETタグを付けたフレームを追加することで、EVNのトラフィック分離要件を満たすために、VNETサブインターフェイスが各VNETに自動的に作成されます。これらのサブインターフェイスは、show running-configurationの出力には表示されませんが、show derived-configでは表示できます。
R1#show derived-config | sec Ethernet0/0
interface Ethernet0/0
vnet trunk
ip address 10.12.12.1 255.255.255.0
no ip redirects
no ip proxy-arp
interface Ethernet0/0.101
description Subinterface for VNET orange
encapsulation dot1Q 101
vrf forwarding orange
ip address 10.12.12.1 255.255.255.0
no ip proxy-arp
interface Ethernet0/0.102
description Subinterface for VNET red
encapsulation dot1Q 102
vrf forwarding red
ip address 10.12.12.1 255.255.255.0
no ip proxy-arp
同様に、EIGRP設定も自動的に作成されていることがわかります。
R1#show derived-config | sec router eigrp
router eigrp named
!
address-family ipv4 unicast autonomous-system 100
!
af-interface Ethernet0/0
authentication mode hmac-sha-256 cisco
exit-af-interface
!
topology base
exit-af-topology
network 10.0.0.0
exit-address-family
!
address-family ipv4 unicast vrf orange autonomous-system 101
!
af-interface Ethernet0/0.101
authentication mode hmac-sha-256 cisco
exit-af-interface
!
af-interface Ethernet1/0
authentication mode hmac-sha-256 cisco
exit-af-interface
!
topology base
exit-af-topology
network 10.0.0.0
network 192.168.13.0
exit-address-family
!
address-family ipv4 unicast vrf red autonomous-system 102
!
af-interface Ethernet0/0.102
authentication mode hmac-sha-256 cisco
exit-af-interface
!
topology base
exit-af-topology
network 10.0.0.0
network 192.168.15.0
exit-address-family
R1#
上記の出力で興味深い点は、グローバルvrf autonomous-system 100のaf-interface ethernet0/0からのVNETサブインターフェイスのaf-interface継承です。 次の項では、この点について詳しく説明します。
次の図は、EVN VNETでEIGRP名前付きモードを使用する場合の継承ルールの視覚化に役立ちます。
上記の例では、VNETトランクaf-interface ethernet0/0があり、そこからVNETサブインターフェイスが派生コンフィギュレーションを受信します。hello-interval、hold-time、authenticationなどのデフォルト以外の値の設定は、継承を実証するために行われました。 グローバルEIGRPプロセスのaf-interfaceの下のVNETサブモードにも注目してください。 これは、EIGRP VRF設定内の各VNET用に動的に作成されたaf-interfaceに複製される設定オプションを制御する方法です。
たとえば、グローバルルーティングテーブルのEth0/0の派生コンフィギュレーションは、vnet global(hello-interval 30、hold-time 90)から継承されます。 Eth0/0のauthentication-mode hmac-sha-256は、running-configのこのaf-interfaceに直接設定されており、派生したconfig出力は、Eth0/0がコマンドを継承したことを示しています。 認証モードはVNETトランクaf-interfaceに設定されているため、すべてのVNETインターフェイスに継承されます。
vrf orangeの場合、VNET orangeはrunning-configでhello-interval 15に設定されています。派生した設定では、自律システム101のVRFオレンジが確認できます。15のhello間隔は、グローバルプロセスのaf-interface eth0/0の下のVNETサブモードから取得されています。 ホールドタイムは変更されず、デフォルト値を使用しているaf-interface eth0/0からクローンが作成されました。
VNET redにはaf-interface Eth0/0との設定の違いがないため、デフォルトのタイマー値と認証モードが継承されます。
これらの設定オプションにより、オペレータはVNETトランクサブインターフェイスごとに異なるパラメータを使用できます。たとえば、異なるタイマー値、認証モード、パッシブインターフェイスなどです。 継承ルールを集約するために、すべてのVNETがVNETトランクaf-interfaceから設定を継承します。 VNETサブモードのVNET固有の設定は、VNETトランクサブインターフェイスにも継承され、afインターフェイスからのパラメータよりも優先されます。
次に、設定の継承を確認するための追加出力を示します。
R1#show eigrp address-family ipv4 interface detail e0/0
EIGRP-IPv4 VR(named) Address-Family Interfaces for AS(100)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Et0/0 1 0/0 0/0 6 0/2 50 0
Hello-interval is 30, Hold-time is 90
Split-horizon is enabled
Next xmit serial <none>
Packetized sent/expedited: 3/1
Hello's sent/expedited: 2959/3
Un/reliable mcasts: 0/4 Un/reliable ucasts: 5/5
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 3 Out-of-sequence rcvd: 1
Topology-ids on interface - 0
Authentication mode is HMAC-SHA-256, key-chain is not set
Topologies advertised on this interface: base
Topologies not advertised on this interface:
R1#show eigrp address-family ipv4 vrf orange interface detail e0/0.101
EIGRP-IPv4 VR(named) Address-Family Interfaces for AS(101)
VRF(orange)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Et0/0.101 1 0/0 0/0 5 0/2 50 0
Hello-interval is 15, Hold-time is 15
Split-horizon is enabled
Next xmit serial <none>
Packetized sent/expedited: 4/1
Hello's sent/expedited: 2371/3
Un/reliable mcasts: 0/4 Un/reliable ucasts: 6/5
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 3 Out-of-sequence rcvd: 1
Topology-ids on interface - 0
Authentication mode is HMAC-SHA-256, key-chain is not set
Topologies advertised on this interface: base
Topologies not advertised on this interface:
R1#show eigrp address-family ipv4 vrf red interface detail e0/0.102
EIGRP-IPv4 VR(named) Address-Family Interfaces for AS(102)
VRF(red)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Et0/0.102 1 0/0 0/0 4 0/2 50 0
Hello-interval is 5, Hold-time is 15
Split-horizon is enabled
Next xmit serial <none>
Packetized sent/expedited: 6/1
Hello's sent/expedited: 2676/3
Un/reliable mcasts: 0/6 Un/reliable ucasts: 7/5
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 3 Out-of-sequence rcvd: 1
Topology-ids on interface - 0
Authentication mode is HMAC-SHA-256, key-chain is not set
Topologies advertised on this interface: base
Topologies not advertised on this interface:
EVNの利点の1つは、VNET間でルートを複製できることです。 たとえば、VRF redのR4は、VRF orangeの一部である192.168.13.0/24のサービスに到達する必要があります。 これは、次の設定を使用して実現できます。
R2#show run
vrf definition orange
vnet tag 101
!
address-family ipv4
exit-address-family
!
vrf definition red
vnet tag 102
!
address-family ipv4
route-replicate from vrf orange unicast eigrp 101 route-map filter
exit-address-family
!
<output removed>
!
ip prefix-list filter seq 5 permit 192.168.13.0/24
!
route-map filter permit 10
match ip address prefix-list filter
!
現在、192.168.13.0/24プレフィクスはVRF redに含まれていますが、送信元アドレスがVNET orangeにルート複製されないため、pingは機能しません。
R2#show ip route vrf red
Routing Table: red
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D 10.5.5.5/32 [90/1536640] via 10.12.12.1, 03:48:46, Ethernet0/0.102
D 10.6.6.6/32 [90/1024640] via 192.168.26.6, 03:48:37, Ethernet2/0
C 10.12.12.0/24 is directly connected, Ethernet0/0.102
L 10.12.12.2/32 is directly connected, Ethernet0/0.102
D + 192.168.13.0/24
[90/1536000] via 10.12.12.1 (orange), 03:48:46, Ethernet0/0.101
D 192.168.15.0/24 [90/1536000] via 10.12.12.1, 03:48:46, Ethernet0/0.102
192.168.26.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.26.0/24 is directly connected, Ethernet2/0
L 192.168.26.2/32 is directly connected, Ethernet2/0
R2#
R2#
R2#ping vrf red 192.168.13.1 source e2/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.13.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.26.2
.....
Success rate is 0 percent (0/5)
R1上のVRF赤からVRFオレンジに複製されたすべてのルートの後、次のような設定を使用します。
R2#ping vrf red 192.168.13.1 source e2/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.13.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.26.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R2#
注:接続、BGP、EIGRPなどのルート複製が可能です。 その他の例については、参考資料を参照してください。
EVNのもう1つの優れた機能は、ルーティングコンテキストの概念です。 これにより、各CLIに「vrf red」を含めなくても、VRF red内でコマンドを実行できます。 たとえば、ルーティングコンテキストを使用して上記と同じpingを次に示します。
R2#routing-context vrf red
R2%red#ping 192.168.13.1 source e2/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.13.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.26.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R2%red#
tracerouteコマンドの出力には、VNET VRF名も表示されます。これは、特にルートの複製が関与する場合にトラブルシューティングに役立ちます。
R6#traceroute 192.168.13.3
Type escape sequence to abort.
Tracing the route to 192.168.13.3
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.26.2 (red,orange/101) 1 msec 0 msec 0 msec
2 10.12.12.1 (orange/101,orange) 2 msec 1 msec 1 msec
3 192.168.13.3 0 msec * 1 msec
R2からの同じトレース
R2#trace vrf red 192.168.13.3 source 192.168.26.2
Type escape sequence to abort.
Tracing the route to 192.168.13.3
VRF info: (vrf in name/id, vrf out name/id)
1 10.12.12.1 (orange/101,orange) 1 msec 1 msec 0 msec
2 192.168.13.3 1 msec * 1 msec
この出力では、R2から192.168.13.0/24に到達するためにVRF orangeのネクストホップが直接取得されていることがわかります。
EIGRP名前付きモードを使用したEVN VNET設定は、仮想化ネットワーク環境を導入し、従来のMPLS VPN(VRF-lite)に関連する複雑さを軽減する方法を提供します。 この機能を正常に導入し、ネットワークが意図したとおりに動作していることを確認するには、継承ルールを理解することが重要です。
Easy Virtual Networksホワイトペーパー
設定ガイド