概要
このドキュメントでは、非ブロードキャストリンク上でのOpen Shortest Path First(OSPF)の初期設定について説明します。
背景説明
フレーム リレー、X.25、ATM、およびスイッチド マルチメガビット データ サービス(SMDS)などのノンブロードキャスト メディアでは、OSPF は 2 種類のモードで動作できます。
-
非ブロードキャストマルチアクセス(NBMA):代表ルータ(DR)とバックアップ代表ルータ(BDR)の選択によってブロードキャストモデルをシミュレートします。NBMAネットワークでブロードキャストモデルをシミュレートするには、ip ospf network broadcastインターフェイスサブコマンドを使用してネットワークタイプをブロードキャストとして定義する方法と、router ospfコマンドを使用するネイバーステートメントを設定する方法の2通りがあります。
-
ポイントツーマルチポイント:ip ospf network point-to-multipointコマンドの設定により、非ブロードキャストネットワークをポイントツーポイントリンクの集合として扱います。
隣接ステートメントの設定をしないように、ノンブロードキャスト ネットワークに対してネットワーク タイプを定義する必要があります。このドキュメントは、ノンブロードキャスト リンク上での OSPF の設定例を示します。show ip ospf interface コマンドを使用して、OSPF を実行しているインターフェイスのネットワーク タイプを確認すると、show ip ospf neighbor コマンドを使用してネイバー ルータの状態がわかります。
前提条件
要件
Cisco では、OSPF ルーティング プロトコルの基本設定について把握することを推奨しています。
使用するコンポーネント
このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づいています。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、初期(デフォルト)設定の状態から起動しています。本稼働中のネットワークでは、各コマンドによって起こる可能性がある影響を十分確認してください。
ネットワーク図
次に、このドキュメントの設定例で使用されているネットワーク構成図を示します。
ネットワーク・タイプ・ブロードキャストを使用した NBMA の設定
Router1 |
interface Loopback0
ip address 192.0.2.3 255.255.255.255
!
!
interface Serial2
ip address 192.0.2.1 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
no keepalive
frame-relay map ip 192.0.2.1 16 broadcast
!
!
router ospf 1
network 192.0.2.0 0.0.0.255 area 0 |
Router2 |
interface Loopback0
ip address 192.0.2.2 255.255.255.255
!
interface Serial1/0
ip address 192.0.2.1 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
no keepalive
clockrate 2000000
frame-relay map ip 192.0.2.1 16 broadcast
!
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
! |
検証のヒント
Router1 での show コマンド出力は、次のとおりです。
Router1# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.0.2.2 1 FULL/BDR 00:00:37 192.0.2.1 Serial2
Router1# show ip ospf interface s2
Serial2 is up, line protocol is up
Internet Address 192.0.2.1/24, Area 0
Process ID 1, Router ID 192.0.2.3, Network Type BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.0.2.3, Interface address 192.0.2.1
Backup Designated router (ID) 192.0.2.2, Interface address 192.0.2.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:00
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.0.2.2 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
そして、Router2 の出力は次のとおりです。
Router2# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.0.2.3 1 FULL/DR 00:00:38 192.0.2.1 Serial1/0
Router2# show ip ospf interface s1/0
Serial1/0 is up, line protocol is up
Internet Address 192.0.2.1/24, Area 0
Process ID 1, Router ID 192.0.2.2, Network Type BROADCAST, Cost: 64
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 192.0.2.3, Interface address 192.0.2.1
Backup Designated router (ID) 192.0.2.2, Interface address 192.0.2.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:03
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.0.2.3 (Designated Router)
Suppress hello for 0 neighbor(s)
隣接ステートメントを使用した NBMA の設定
Router1 |
interface Loopback0
ip address 192.0.2.3 255.255.255.255
!
interface Serial2
ip address 192.0.2.1 255.255.255.0
encapsulation frame-relay
ip ospf priority 2
no keepalive
frame-relay map ip 192.0.2.1 16
!
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
neighbor 192.0.2.1
! |
Router2 |
interface Loopback0
ip address 192.0.2.2 255.255.255.255
!
interface Serial1/0
ip address 192.0.2.1 255.255.255.0
encapsulation frame-relay
no keepalive
clockrate 2000000
frame-relay map ip 192.0.2.1 16
!
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
neighbor 192.0.2.1
! |
注:上記の設定では、Router1のip ospf priority 2コマンドによって、デフォルトのプライオリティ値である1よりも高いインターフェイスプライオリティが設定され、DRおよびRouter2がNBMAネットワークのBDRになります。必要に応じて、プライオリティ値を 0 に設定し、ルータが DR/BDR にならないようにすることができます。これは、ハブがDRになるように設定する必要があるハブアンドスポークネットワークで必要です。スポークはDRでもBDRでもなりません。近隣ステートメントは一端で設定すれば十分ではありますが、例で示すように、両端で設定することをお勧めします。また、frame-relay map コマンドは broadcast パラメータを必要としません。これは、隣接ステートメントにより、OSPF パケットがユニキャストされるからです。
検証のヒント
Router1 での show コマンド出力は、次のとおりです。
Router1# show ip ospf neighbors
Neighbor ID Pri State Dead Time Address Interface
192.0.2.2 1 FULL/BDR 00:01:39 192.0.2.1 Serial2
Router1# show ip ospf interface s2
Serial2 is up, line protocol is up
Internet Address 192.0.2.1/24, Area 0
Process ID 1, Router ID 192.0.2.3, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.0.2.3, Interface address 192.0.2.1
Backup Designated router (ID) 192.0.2.2, Interface address 192.0.2.1
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:19
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 2
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.0.2.2 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
そして、Router2 の出力は次のとおりです。
Router2# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.0.2.3 1 FULL/DR 00:01:49 192.0.2.1 Serial1/0
Router2# show ip ospf interface s1/0
Serial1/0 is up, line protocol is up
Internet Address 192.0.2.1/24, Area 0
Process ID 1, Router ID 192.0.2.2, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 192.0.2.3, Interface address 192.0.2.1
Backup Designated router (ID) 192.0.2.2, Interface address 192.0.2.1
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:01
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 2
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.0.2.3 (Designated Router)
Suppress hello for 0 neighbor(s)
ポイントツーマルチポイントの設定
Router1 |
interface Loopback0
ip address 192.0.2.3 255.255.255.255
!
interface Serial2
ip address 192.0.2.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
no keepalive
frame-relay map ip 192.0.2.1 16 broadcast
!
router ospf 1
network 192.0.2.0 0.0.0.255 area 0
! |
Router2 |
interface Loopback0
ip address 192.0.2.2 255.255.255.255
!
interface Serial1/0
ip address 192.0.2.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
no keepalive
clockrate 2000000
frame-relay map ip 192.0.2.1 16 broadcast
!
router ospf 1
network 192.0.2.0 0.0.0.255 area 0 |
検証のヒント
Router1 での show コマンド出力は、次のとおりです。
Router1# show ip ospf neighbors
Neighbor ID Pri State Dead Time Address Interface
192.0.2.2 1 FULL/ - 00:01:53 192.0.2.1 Serial2
Router1# show ip ospf interface s2
Serial2 is up, line protocol is up
Internet Address 192.0.2.1/24, Area 0
Process ID 1, Router ID 192.0.2.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:18
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.0.2.2
Suppress hello for 0 neighbor(s)
そして、Router2 の出力は次のとおりです。
Router2# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.0.2.3 1 FULL/ - 00:01:58 192.0.2.1 Serial1/0
Router2# show ip ospf interface s1/0
Serial1/0 is up, line protocol is up
Internet Address 192.0.2.1/24, Area 0
Process ID 1, Router ID 192.0.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:18
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.0.2.3
Suppress hello for 0 neighbor(s)
注:出力に示されているように、NBMAネットワークがポイントツーマルチポイントとして設定されている場合、選択されるDRおよびBDRはありません。これは、NBMAネットワークがポイントツーポイントリンクの集合として扱われるためです。
詳細については、『OSPF の設定』を参照してください。
関連情報