この製品のドキュメントセットは、偏向のない言語を使用するように配慮されています。このドキュメントセットでの偏向のない言語とは、年齢、障害、性別、人種的アイデンティティ、民族的アイデンティティ、性的指向、社会経済的地位、およびインターセクショナリティに基づく差別を意味しない言語として定義されています。製品ソフトウェアのユーザインターフェイスにハードコードされている言語、RFP のドキュメントに基づいて使用されている言語、または参照されているサードパーティ製品で使用されている言語によりドキュメントに例外が存在する場合があります。シスコのインクルーシブ ランゲージの取り組みの詳細は、こちらをご覧ください。
シスコは世界中のユーザにそれぞれの言語でサポート コンテンツを提供するために、機械と人による翻訳を組み合わせて、本ドキュメントを翻訳しています。ただし、最高度の機械翻訳であっても、専門家による翻訳のような正確性は確保されません。シスコは、これら翻訳の正確性について法的責任を負いません。原典である英語版(リンクからアクセス可能)もあわせて参照することを推奨します。
このドキュメントでは、ISISリモートループフリー(LFA)機能を使用してマルチプロトコルラベルスイッチング(MPLS)レイヤ3 VPNを設定する方法について説明します。ネットワークシナリオの例と、その設定と出力を示し、理解を深めます。
この文書には特定の要件はありませんが、MPLSの基本的な知識とISISプロトコルの実務知識が必ず役立ちます。
このドキュメントの内容は、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、初期(デフォルト)設定の状態から起動しています。対象のネットワークが実稼働中である場合には、どのようなコマンドについても、その潜在的な影響について確実に理解しておく必要があります。
ISISは世界中のISPに広く導入されており、ISPが提供する最も一般的なソリューションはMPLSレイヤ3 Vpnです。ISPのコアインフラストラクチャリンク障害の内部はパフォーマンスに直接影響するため、1秒未満のコンバージェンスが望ましい。MPLSトンネルリンク保護やノード保護などの機能は、これらの問題を解決しますが、手動設定が必要です。
ISISリモートLFAは、特定のエリアに対して、すべてのISISルータが同一のリンクステートデータベースを持つという概念を活用します。ルータAが宛先Xへのバックアップパスを選択する必要がある場合、ルータBが宛先XのネクストホップとしてルータAを使用しない限り、ルータAはバックアップのネクストホップとしてルータBを選択できます。これは、LFA機能の基本的な概念です。これで、このバックアップパスはCisco Express Forwarding(CEF)エントリに直接プログラミングされ、プライマリルートに障害が発生すると即座に使用されるようになります。その後、ルーティングプロトコルは従来のタイマーに従って収束できます。
リモートLFAの動作を理解するには、次の図を検討してください。
トラフィックは、パスA—C—Fを使用してルータAからFに流れます。ルータAとルータCの間のリンクがダウンした場合。ルータAはF宛てのパケットをルータBに即座に送信できますが、これは問題を解決しません。リンクがダウンしたばかりで、ISISトポロジは変更を認識しません。パケットがルータBに到着しても、ルータBには古いルーティング情報が残り、A経由でFにルーティングするためのエントリが残ります。したがって、パケットはBとAの間でポイントトポロジが収束するまでループされます。
この問題を解決するには、ルータAからルータDにパケットをトンネリングします。ルータDはルータA経由のパスを使用せずにFに向かうトラフィックをコンバージェンスせずにルータDに送信します。これで、ルータDは、ルータAからルータF宛てのトンネル化トラフィックを受信した際に、トポロジの変更を認識しなくなり、通常のルーティングロジックを介してパケットを転送します。そのため、トラフィックフローは影響を受けず、トポロジは再コンバージェンスできます。
リモートLFAを使用したMPLSレイヤ3 Vpnのトポロジ:
略語
CE = Customer Edge Router(カスタマー エッジ ルータ)
PE =プロバイダーエッジルータ
P=Provider Router(プロバイダー ルータ)
使用されるループバックは192.168.255.Xで、Xルータ番号です。たとえば、R1が検討中の場合、ループバックは192.168.255.1です。
#Basicデフォルトルートを使用したCE設定:
interface Ethernet0/0
ip address 192.168.18.8 255.255.255.0
!
!
ip route 0.0.0.0 0.0.0.0 192.168.18.1
!
!
#Basicデフォルトルートを使用したCE設定。
interface Ethernet0/0
ip address 192.168.79.9 255.255.255.0
!
!
ip route 0.0.0.0 0.0.0.0 192.168.79.7
!
!
# PE設定
interface Loopback1
ip address 192.168.255.1 255.255.255.255
ip router isis TAC
!
interface Ethernet0/0
vrf forwarding A
ip address 192.168.18.1 255.255.255.0
!
# ISISインターフェイスはポイントツーポイントである必要があります
interface Ethernet0/1
ip address 192.168.12.1 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
!
# ISISリモートLFAの設定
router isis TAC
net 49.0000.0000.0001.00
is-type level-2-only
metric-style wide
fast-reroute per-prefix level-2 all
fast-reroute remote-lfa level-2 mpls-ldp
mpls ldp autoconfig level-2
!
PE-2-R7を使用したBGP Vpnv4ピアリング
router bgp 65000
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 192.168.255.7 remote-as 65000
neighbor 192.168.255.7 update-source Loopback1
!
address-family ipv4
exit-address-family
!
address-family vpnv4
neighbor 192.168.255.7 activate
neighbor 192.168.255.7 send-community both
exit-address-family
!
address-family ipv4 vrf A
redistribute connected
exit-address-family
!
# P設定
interface Loopback1
ip address 192.168.255.2 255.255.255.255
ip router isis TAC
!
# ISISインターフェイスはポイントツーポイントである必要があります
interface Ethernet0/0
ip address 192.168.12.2 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface Ethernet0/2
ip address 192.168.26.2 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
!
# ISISリモートLFAの設定
router isis TAC
net 49.0000.0000.0002.00
is-type level-2-only
metric-style wide
fast-reroute per-prefix level-2 all
fast-reroute remote-lfa level-2 mpls-ldp
!
# P設定
interface Loopback1
ip address 192.168.255.3 255.255.255.255
ip router isis TAC
!
# ISISインターフェイスはポイントツーポイントである必要があります
interface Ethernet0/0
ip address 192.168.23.3 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface Ethernet0/1
ip address 192.168.34.3 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
!
# ISISリモートLFAの設定
router isis TAC
net 49.0000.0000.0003.00
is-type level-2-only
metric-style wide
fast-reroute per-prefix level-2 all
fast-reroute remote-lfa level-2 mpls-ldp
!
# P設定
interface Loopback1
ip address 192.168.255.4 255.255.255.255
ip router isis TAC
!
# ISISインターフェイスはポイントツーポイントである必要があります
interface Ethernet0/0
ip address 192.168.34.4 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface Ethernet0/1
ip address 192.168.45.4 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
!
# ISISリモートLFAの設定
router isis TAC
net 49.0000.0000.0004.00
is-type level-2-only
metric-style wide
fast-reroute per-prefix level-2 all
fast-reroute remote-lfa level-2 mpls-ldp
# P設定
interface Loopback1
ip address 192.168.255.5 255.255.255.255
ip router isis TAC
!
# ISISインターフェイスはポイントツーポイントである必要があります
interface Ethernet0/0
ip address 192.168.45.5 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface Ethernet0/1
ip address 192.168.56.5 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
!
# ISISリモートLFAの設定
router isis TAC
net 49.0000.0000.0005.00
is-type level-2-only
metric-style wide
fast-reroute per-prefix level-2 all
fast-reroute remote-lfa level-2 mpls-ldp
# P設定
interface Loopback1
ip address 192.168.255.6 255.255.255.255
ip router isis TAC
!
# ISISインターフェイスはポイントツーポイントである必要があります
interface Ethernet0/0
ip address 192.168.56.6 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface Ethernet0/1
ip address 192.168.26.6 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface Ethernet0/2
ip address 192.168.67.6 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
!
# ISISリモートLFAの設定
router isis TAC
net 49.0000.0000.0006.00
is-type level-2-only
metric-style wide
fast-reroute per-prefix level-2 all
fast-reroute remote-lfa level-2 mpls-ldp
!
# PE設定
interface Loopback1
ip address 192.168.255.7 255.255.255.255
ip router isis TAC
!
# ISISインターフェイスはポイントツーポイントである必要があります
interface Ethernet0/0
ip address 192.168.67.7 255.255.255.0
ip router isis TAC
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface Ethernet0/1
vrf forwarding A
ip address 192.168.79.7 255.255.255.0
!
!
# ISISリモートLFAの設定
router isis TAC
net 49.0000.0000.0007.00
is-type level-2-only
metric-style wide
fast-reroute per-prefix level-2 all
fast-reroute remote-lfa level-2 mpls-ldp
!
!
PE-1-R1とのBGP Vpnv4ピアリング
router bgp 65000
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 192.168.255.1 remote-as 65000
neighbor 192.168.255.1 update-source Loopback1
!
address-family ipv4
exit-address-family
!
address-family vpnv4
neighbor 192.168.255.1 activate
neighbor 192.168.255.1 send-community both
exit-address-family
!
address-family ipv4 vrf A
redistribute connected
exit-address-family
!
ここでは、設定が正常に機能しているかどうかを確認します。
コマンドshow isis fast-reroute remote-lfa tunnelsは、ルータ上に構築されたリモートLFAトンネルを表示します。
P1-R2#show isis fast-reroute remote-lfa tunnels
Tag TAC - Fast-Reroute Remote-LFA Tunnels: MPLS-Remote-Lfa1: use Et0/2, nexthop 192.168.26.6, end point 192.168.255.5
MPLS-Remote-Lfa2: use Et0/1, nexthop 192.168.23.3, end point 192.168.255.4
P2-R3#show isis fast-reroute remote-lfa tunnels
Tag TAC - Fast-Reroute Remote-LFA Tunnels: MPLS-Remote-Lfa1: use Et0/1, nexthop 192.168.34.4, end point 192.168.255.5
MPLS-Remote-Lfa2: use Et0/0, nexthop 192.168.23.2, end point 192.168.255.6
P3-R4#show isis fast-reroute remote-lfa tunnels
Tag TAC - Fast-Reroute Remote-LFA Tunnels: MPLS-Remote-Lfa1: use Et0/1, nexthop 192.168.45.5, end point 192.168.255.6
MPLS-Remote-Lfa2: use Et0/0, nexthop 192.168.34.3, end point 192.168.255.2
P4-R5#show isis fast-reroute remote-lfa tunnels
Tag TAC - Fast-Reroute Remote-LFA Tunnels: MPLS-Remote-Lfa1: use Et0/0, nexthop 192.168.45.4, end point 192.168.255.3
MPLS-Remote-Lfa2: use Et0/1, nexthop 192.168.56.6, end point 192.168.255.2
P5-R6#show isis fast-reroute remote-lfa tunnels
Tag TAC - Fast-Reroute Remote-LFA Tunnels: MPLS-Remote-Lfa1: use Et0/0, nexthop 192.168.56.5, end point 192.168.255.4
MPLS-Remote-Lfa2: use Et0/1, nexthop 192.168.26.2, end point 192.168.255.3
リンク障害を引き起こす前に、P-1-R2をチェックすると、RLFAによるバックアップパスとして、P-1-R2とP-5-R4の間にターゲットLDPセッションがすでに形成されていることがわかります。RLFAがなければ、ルーティングプロトコルは障害を検出し、再コンバージェンスする必要があります。
P-1-R2#show ip route repair-paths 192.168.255.7 Routing entry for 192.168.255.7/32 Known via "isis", distance 115, metric 30, type level-c Redistributing via isis TAC Last update from 192.168.26.6 on Ethernet0/2, 02:23:31 ago Routing Descriptor Blocks: * 192.168.26.6, from 192.168.255.7, 02:23:31 ago, via Ethernet0/2 Route metric is 30, traffic share count is 1 Repair Path: 192.168.255.4, via MPLS-Remote-Lfa6 [RPR]192.168.255.4, from 192.168.255.7, 02:23:31 ago, via MPLS-Remote-Lfa6 Route metric is 20, traffic share count is 1
P-1-R2#show mpls ldp neighbor 192.168.255.4 Peer LDP Ident: 192.168.255.4:0; Local LDP Ident 192.168.255.2:0 TCP connection: 192.168.255.4.32391 - 192.168.255.2.646 State: Oper; Msgs sent/rcvd: 184/183; Downstream Up time: 02:26:09 LDP discovery sources: Targeted Hello 192.168.255.2 -> 192.168.255.4, active, passive Addresses bound to peer LDP Ident: 192.168.255.4 192.168.34.4 192.168.45.4
ここでは、ルーティングテーブルのPE2-R7への修復パスが192.168.255.4(P3-R4)を経由していることが確認できます。 リモートLFAロジックの一部として、トンネルはP3-R4に事前に構築されます。そのため、プライマリリンクに障害が発生すると、ただちにパケットがP3-R4にトンネリングされ、エントリが事前に構築されると、ラインカードレベルで発生します。そのため、トラフィックの中断は発生せず、転送はシームレスです。ISISプロトコルは、設定されたタイマーに基づいて収束できます。
P1-R2ルータは、障害の前にP2-R3経由で形成されたCEFエントリが既に存在するため、バックアップパスを探す必要はありません。
P1-R2#show ip cef 192.168.255.7
nexthop 192.168.26.6 Ethernet0/2 label [25|26]
repair: attached-nexthop 192.168.255.4 MPLS-Remote-Lfa6
次の図は、前述の正確な動作を示しています。
検証のために、CE-1-R8からCE-2-R9への連続pingは、P1-R2とP5-R6の間のコアリンク(Eth 0/2)をシャットダウンして障害シナリオを再現した後に実行されます。テスト環境ではドロップが1つになることもありません。
CE-1-R8#ping 192.168.79.9
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.79.9, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! <Ouput Snipped> !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!
Success rate is 100 percent (149320/149320), round-trip min/avg/max = 1/1/18 ms
現在、この設定に関する特定のトラブルシューティング情報はありません。