概要
このドキュメントでは、音声品質の問題がネットワークの問題なのか、仮想化アプリケーションの問題なのかを特定するプロセスについて説明します。
問題
リアルタイムの音声アプリケーションが仮想化されると、音声品質の問題をトラブルシューティングすることがますます複雑になります。この対象にする「リアルタイム音声アプリケーション」として Unity Connection を使用します。
情報の収集
- 最初の手順では、Unity Connection を離れるとき音声ガイダンスが歪んでいるかを判断します。パケットを収集するには、「utils network capture eth0 file capture1 size all count 100000」をキャプチャします。
注:Cisco Unified Communications(CUC)の音声ガイダンスは、望ましくない品質を判定する良いベース ラインになります。ユーザが記録したメッセージは基準として信頼できない可能性があるため、使用しないでください。
- パケット キャプチャを分析します。Wireshark は、G.711 A-law、G.711 μ-law をサポートします。
- Wireshark でルーティング テーブル プロトコル(RTP)ストリーム出力の品質をチェックします。
- デフォルト設定で復号化します。
- Wireshark のオプション "use RTP timestamp" を指定して復号化します。
考えられる原因
復号化されたストリームの両方で音声品質の問題が発生する場合、問題は音声ガイダンス(WAV ファイル)または Unity Connection にある可能性があります。
デフォルトの録音が歪むが、RTP タイムスタンプの使用が正常であれば、問題はリソースまたは VMware にある可能性があります。
デフォルトの復号化を使用して RTP ストリームを聞いたときに品質が許容範囲内である場合、問題は CUC と電話の間のネットワーク接続にある可能性があります。
注:ESXi サーバが接続されて品質チェックが行われたスイッチからのパケット キャプチャを取得することをお勧めします。その品質が低い場合、ESXi ホスト自体でドライバがチェックされている可能性があります。
解決方法
問題が Unity Connection または WAV ファイルにある場合、最初に録音の品質を確認します。
- Network Time Protocol(NTP)を確認します。
- 顧客が複数の NTP を設定している場合、CUC がその 2 つを頻繁に切り替えていないことを確認します。
- NTP サーバに NTPv4(パケット キャプチャ)があることを「utils ntp status」で確認します。
- 品質を確認する Web GUI を使用します。
- CUC にコアダンプがないことを確認します。既知のバグを「utils core active list」で確認します。
- 品質を確認するために COBRAS バックアップ エディタを使用します。
問題が VMware にあることが示された場合は、次の手順を実行して確認してください。
- Unity Connection の仮想マシンで適切な予約が確立されたことを確認してください。サポートされているプラットフォームのように、CPU と RAM の予約を確認します。
- ESXi ホストで Large Receive Offload(LRO)がオフになっていることを確認します(ESXi 5.1+ では問題ではありません)。 詳細については、「UCS/UC アプリケーションの導入で LRO を無効にする」を参照してください。
- CUC VM のスナップショットを作成します。詳細については、「VMware のスナップショット」を参照してください。
注:Unity Connection VM のスナップショットはサポートされないため、音声品質の問題が発生する可能性があります。
- VMware ツールがインストールされていることを確認します。詳細については、「VMware のツール」を参照してください。
注:VMware ツールは、ネットワーク パフォーマンスを向上するために、VM にネットワーク インターフェイス カード(NIC)ドライバをインストールします。
- [Sync VM with host] がチェックされていないことを確認します。このオプションは、仮想マシンの時間を ESXi ホストと同期します。Sphere のクライアントでは、[Select the virtual machine] に移動して、仮想マシンの [Edit settings] を右クリックします。[Options] タブから、[VMware tools] > [Advanced] を選択します。[Synchronize guest time with host] チェックボックスがチェックされていないことを確認します。