소개
이 문서에서는 EIGRP와 BGP 간의 상호 재배포를 구성하는 방법에 대해 설명합니다.
사전 요구 사항
요구 사항
다음 주제에 대한 지식을 보유하고 있으면 유용합니다.
사용되는 구성 요소
이 문서의 정보는 Cisco 7200 Series Router with Cisco IOS® Software 릴리스 15.0(1)을 기반으로 합니다.
이 문서의 정보는 특정 랩 환경의 디바이스를 토대로 작성되었습니다. 이 문서에 사용된 모든 디바이스는 초기화된(기본) 컨피그레이션으로 시작되었습니다. 현재 네트워크가 작동 중인 경우 모든 명령의 잠재적인 영향을 미리 숙지하시기 바랍니다.
표기 규칙
문서 규칙에 대한 자세한 내용은 Cisco 기술 팁 표기 규칙을 참고하십시오.
구성
이 예에서 라우터 R1과 R2는 EIGRP를 사용하여 서로 통신합니다. 라우터 R2 및 R3는 eBGP를 사용합니다. EIGRP로 eBGP 경로를 상호 재배포하려면 EIGRP 메트릭과 redistribute bgp함께 명령을 사용합니다. 마찬가지로 EIGRP 경로를 BGP로 재배포하려면 명령을 redistribute eigrp AS number 사용합니다.
네트워크 다이어그램
이 문서에서는 이 네트워크 설정을 사용합니다.
네트워크 다이어그램
설정
이 문서에서는 다음 설정을 사용합니다.
라우터 R1 |
!
hostname R1
!
ip cef
!
!
interface Loopback0
ip address 10.30.30.30 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.101 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
network 10.30.0.0
network 192.168.1.0
no auto-summary
!
end
|
라우터 R2 |
!
hostname R2
!
ip cef
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
ip address 10.20.20.20 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.100 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.100.50 255.255.255.0
serial restart-delay 0
clock rate 2000000
!
router eigrp 100
redistribute static
redistribute bgp 1000 metric 100 1 255 1 1500
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
router bgp 1000
no synchronization
bgp log-neighbor-changes
network 10.20.20.20 mask 255.255.255.255
redistribute connected
redistribute static
redistribute eigrp 100
neighbor 172.16.100.51 remote-as 2000
neighbor 172.16.100.51 next-hop-self
no auto-summary
!
end
|
라우터 R3 |
!
hostname R3
!
ip cef
!
interface Loopback0
ip address 10.22.22.22 255.255.255.255
!
interface Serial0/0
ip address 172.16.100.51 255.255.255.0
serial restart-delay 0
clock rate 2000000
!
router bgp 2000
no synchronization
bgp log-neighbor-changes
network 10.22.22.22 mask 255.255.255.255
network 172.16.100.0 mask 255.255.255.0
neighbor 172.16.100.50 remote-as 1000
neighbor 172.16.100.50 default-originate
default-information originate
!--- Default route is configured!
no auto-summary
!
end
|
다음을 확인합니다.
구성이 올바르게 작동하는지 확인하려면 이 섹션을 활용하십시오.
CLI 분석기는 show 명령 출력의 분석을 보기 위해 사용됩니다.
참고: 등록된 Cisco 사용자만 내부 Cisco 툴 및 정보에 액세스할 수 있습니다.
명령 표시
EIGRP가 재배포된 경로를 수신하는지 확인하려면 명령을 show ip route eigrp 사용합니다.
show ip route eigrp |
라우터 R1 R1#show ip route eigrp
10.20.0.0/32 is subnetted, 1 subnets
D EX 10.20.20.20
[170/25625856] via 192.168.1.100, 01:00:33, FastEthernet0/0
10.22.0.0/32 is subnetted, 1 subnets
D EX 10.22.22.22
[170/25625856] via 192.168.1.100, 00:59:49, FastEthernet0/0
10.0.0.0/32 is subnetted, 1 subnets
D 10.10.10.10 [90/409600] via 192.168.1.100, 00:55:17, FastEthernet0/0
D*EX 0.0.0.0/0 [170/25625856] via 192.168.1.100, 00:46:24, FastEthernet0/0
!--- Shows the default route from router R3.
!--- EX indicates that the routes are EIGRP external routes.
|
EIGRP 경로가 BGP에서 제대로 재배포되는지 확인하려면 라우터 R3show ip route bgp에서 명령을 사용합니다.
show ip route bgp |
라우터 R3 R3#show ip route bgp
show ip route bgp
10.20.0.0/32 is subnetted, 1 subnets
B 10.20.20.20 [20/0] via 172.16.100.50, 01:03:02
10.0.0.0/32 is subnetted, 1 subnets
B 10.10.10.10 [20/0] via 172.16.100.50, 01:03:02
B 192.168.1.0/24 [20/0] via 172.16.100.50, 01:03:02
10.30.0.0/32 is subnetted, 1 subnets
B 10.30.30.30 [20/409600] via 172.16.100.50, 00:59:06
!--- The output indicates that the EIGRP routes are !--- redistributed in BGP.
|
관련 정보