본 제품에 대한 문서 세트는 편견 없는 언어를 사용하기 위해 노력합니다. 본 설명서 세트의 목적상, 편견 없는 언어는 나이, 장애, 성별, 인종 정체성, 민족 정체성, 성적 지향성, 사회 경제적 지위 및 교차성에 기초한 차별을 의미하지 않는 언어로 정의됩니다. 제품 소프트웨어의 사용자 인터페이스에서 하드코딩된 언어, RFP 설명서에 기초한 언어 또는 참조된 서드파티 제품에서 사용하는 언어로 인해 설명서에 예외가 있을 수 있습니다. 시스코에서 어떤 방식으로 포용적인 언어를 사용하고 있는지 자세히 알아보세요.
Cisco는 전 세계 사용자에게 다양한 언어로 지원 콘텐츠를 제공하기 위해 기계 번역 기술과 수작업 번역을 병행하여 이 문서를 번역했습니다. 아무리 품질이 높은 기계 번역이라도 전문 번역가의 번역 결과물만큼 정확하지는 않습니다. Cisco Systems, Inc.는 이 같은 번역에 대해 어떠한 책임도 지지 않으며 항상 원본 영문 문서(링크 제공됨)를 참조할 것을 권장합니다.
이 문서에서는 ISIS(Intermediate System to Intermediate System) 연결 비트의 동작을 설명합니다.
다음 주제에 대한 지식을 보유하고 있으면 유용합니다.
이 문서는 특정 소프트웨어 및 하드웨어 버전으로 한정되지 않습니다.
이 문서의 정보는 특정 랩 환경의 디바이스를 토대로 작성되었습니다.이 문서에 사용된 모든 디바이스는 초기화된(기본) 컨피그레이션으로 시작되었습니다.현재 네트워크가 작동 중인 경우, 모든 명령어의 잠재적인 영향을 미리 숙지하시기 바랍니다.
다음은 ISIS와 관련하여 기억해야 할 몇 가지 사항 및 첨부 파일의 동작입니다.
1. ISIS 네트워크에는 3가지 유형의 라우터, Level1(L1) 라우터, Level 2(L2) 라우터 및 Level1Level2(L1L2) 라우터가 있습니다.
2. OSPF와 마찬가지로 ISIS는 L2 영역을 백본 영역으로 합니다.
3. 레벨 1 및 레벨 2와 같은 두 영역에 모두 연결된 라우터를 L1L2 경로라고 합니다.
4. OSPF는 SPF(Shortest Path First) 계산 범위를 제한하는 다중 영역의 개념을 가지고 있으며 ISIS에서 서로 다른 영역을 가져야 하는 이유가 동일합니다.
5. 레벨 1 및 레벨 2 ISIS 라우터가 각각 레벨 1 및 레벨 2 LSP(링크 상태 PDU)를 생성합니다.L1L2 라우터는 LSP(예: Level1 및 Level2)를 모두 생성합니다.
6. 레벨 1 라우터가 L2 네트워크에 도달해야 하는 경우, Level 1 라우터는 백본 영역에 도달하기 위해 패킷을 L1L2 라우터로 전송합니다.
7. 기본적으로 레벨 2 라우터는 레벨 1 라우터가 항상 레벨 2 영역으로 전파되지만 L1L2 라우터가 레벨 1 영역으로 유출되지 않습니다.
8. L1L2 라우터는 레벨 2 영역에 도달하기 위해 레벨 1 LSP에서 어태치 비트를 설정합니다.Level1 라우터는 라우팅 테이블에 기본 경로를 설치합니다. 이 경로는 L1L2 라우터를 가리킵니다.
9. 네트워크에 동일한 L1 영역을 연결하는 둘 이상의 L1L2 라우터가 있는 경우 level2 경로가 level1 영역으로 이동하지 않으므로 최적 상태가 아닌 라우팅으로 이어질 수 있습니다.레벨 1 영역에서는 가장 가까운 L1L2 라우터를 가리키는 기본 경로만 설치합니다.level2 경로를 level1로 유출하면 이러한 제한을 극복할 수 있습니다.
루프 방지 기술을 이해하기 위해 이 네트워크 토폴로지를 고려하십시오.
R1#sh run int lo 0
Building configuration...
Current configuration : 82 bytes
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
ip router isis 1
end
R1#sh run int ethernet 0/0
Building configuration...
Current configuration : 127 bytes
!
interface Ethernet0/0
ip address 10.10.12.1 255.255.255.0
ip router isis 1
isis circuit-type level-1
end
R1#sh run int ethernet 0/1
Building configuration...
Current configuration : 111 bytes
!
interface Ethernet0/1
ip address 10.10.13.1 255.255.255.0
ip router isis 1
isis circuit-type level-1
end
!
router isis 1
net 49.0001.0000.0000.0001.00 >>>>> Area is 49.0001
is-type level-1 >>>>>>>>>> Globally this router belongs to Level1
R2#sh run int lo 0
Building configuration...
Current configuration : 82 bytes
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
ip router isis 1
end
R2#sh run int eth0/0
Building configuration...
Current configuration : 111 bytes
!
interface Ethernet0/0
ip address 10.10.12.2 255.255.255.0
ip router isis 1
isis circuit-type level-1 >>>>>> Circuit type is L1 towards R1
end
R2#sh run int eth0/1
Building configuration...
Current configuration : 84 bytes
!
interface Ethernet0/1
ip address 10.10.24.2 255.255.255.0
ip router isis 1
end
!
router isis 1
net 49.0001.0000.0000.0002.00
R3#sh run int lo 0
Building configuration...
Current configuration : 82 bytes
!
interface Loopback0
ip address 10.3.3.3 255.255.255.255
ip router isis 1
end
R3#sh run int eth0/0
Building configuration...
Current configuration : 84 bytes
!
interface Ethernet0/0
ip address 10.10.13.3 255.255.255.0
ip router isis 1
end
R3#sh run int eth0/1
Building configuration...
Current configuration : 84 bytes
!
interface Ethernet0/1
ip address 10.10.34.3 255.255.255.0
ip router isis 1
end
!
router isis 1
net 49.0001.0000.0000.0003.00
R4#sh run int lo 0
Building configuration...
Current configuration : 82 bytes
!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
ip router isis 1
end
R4#sh run int ethernet 0/0
Building configuration...
Current configuration : 84 bytes
!
interface Ethernet0/0
ip address 10.10.24.4 255.255.255.0
ip router isis 1
end
R4#sh run int ethernet 0/1
Building configuration...
Current configuration : 84 bytes
!
interface Ethernet0/1
ip address 10.10.34.4 255.255.255.0
ip router isis 1
end
!
router isis 1
net 49.0002.0000.0000.0004.00 >>>> Area on R4 is 49.0002.
참고:서로 다른 두 영역 간의 라우터는 항상 Level 2 인접 디바이스 관계에서 옵니다.이 경우 R4 영역은 49.0002이고 R2 및 R3 영역은 49.0001입니다. 따라서 R4는 R2 및 R3과 L2 인접성을 가져야 합니다.
이 섹션을 사용하여 컨피그레이션이 제대로 작동하는지 확인합니다.
R1#show clns neighbors
Tag 1:
System Id Interface SNPA State Holdtime Type Protocol
R2 Et0/0 aabb.cc01.f600 Up 6 L1 IS-IS
R3 Et0/1 aabb.cc01.f700 Up 9 L1 IS-IS
R1#
R1 neighbor relationship with R2 and R3 is only L1
R2#sh clns neighbors
Tag 1:
System Id Interface SNPA State Holdtime Type Protocol
R1 Et0/0 aabb.cc01.f500 Up 24 L1 IS-IS
R4 Et0/1 aabb.cc01.f800 Up 9 L2 IS-IS
R2 neighbor relationship with R1 is L1
R2 neighbor relationship with R4 is L2
So R2 is L1L2 router as it is building both adjanceny i.e. L1 and L2 neighbor
R3#sh clns neighbors
Tag 1:
System Id Interface SNPA State Holdtime Type Protocol
R1 Et0/0 aabb.cc01.f510 Up 25 L1 IS-IS
R4 Et0/1 aabb.cc01.f810 Up 7 L2 IS-IS
R3 neighbor relatioship with R1 is L1
R3 neighbor relationship with R4 is L2
So R3 is L1L2 router as it is building both adjanceny i.e. L1 and L2 neighbor
R4#sh clns neighbors
Tag 1:
System Id Interface SNPA State Holdtime Type Protocol
R2 Et0/0 aabb.cc01.f610 Up 29 L2 IS-IS
R3 Et0/1 aabb.cc01.f710 Up 23 L2 IS-IS
R4 neighbor relationship with R2 and R3 is L2 only .
이 토폴로지에서 R2와 R3은 L1L2 라우터이므로 어태치 비트를 설정해야 하므로 R1에는 두 개의 기본 경로가 있어야 합니다.
R1#show isis database
Tag 1:
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 * 0x0000002B 0x4269 576 0/0/0
R2.00-00 0x00000033 0xB1CA 997 1/0/0
R2.01-00 0x0000001F 0x42F0 1018 0/0/0
R3.00-00 0x0000002B 0xCA5E 857 1/0/0
R3.01-00 0x0000001B 0x50E4 964 0/0/0
ATT ( which is marked in Bold ) represents attach bit and is set to 1 for both R2 and R3
router in Level 1 LSP . ATT bit is only set in Level1 LSP .
R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is 10.10.13.3 to network 0.0.0.0
i*L1 0.0.0.0/0 [115/10] via 10.10.13.3, 00:00:26, Ethernet0/1
[115/10] via 10.10.12.2, 00:00:26, Ethernet0/0
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
C 10.1.1.1/32 is directly connected, Loopback0
i L1 10.2.2.2/32 [115/20] via 10.10.12.2, 00:00:26, Ethernet0/0
i L1 10.3.3.3/32 [115/20] via 10.10.13.3, 00:46:55, Ethernet0/1
C 10.10.12.0/24 is directly connected, Ethernet0/0
L 10.10.12.1/32 is directly connected, Ethernet0/0
C 10.10.13.0/24 is directly connected, Ethernet0/1
L 10.10.13.1/32 is directly connected, Ethernet0/1
i L1 10.10.24.0/24 [115/20] via 10.10.12.2, 00:00:26, Ethernet0/0
i L1 10.10.34.0/24 [115/20] via 10.10.13.3, 00:46:55, Ethernet0/1
In route table R1 is installing default route towards R2 and R3 .
기본 Level2 경로는 Level1 영역으로 유출되지 않으므로 여기에 라우팅 테이블에 R4에 대한 특정 경로가 없습니다.트래픽 포워딩에 기본 테이블을 사용하며, 이로 인해 최적 상태가 아닐 수 있습니다.위의 경우 두 가지 모두 동일한 메트릭이므로 두 기본 경로가 모두 설치되었습니다.R1과 R2 간에 메트릭이 증가하면 라우터가 R2에 대한 기본 경로만 설치해야 합니다.
R1(config)#int eth0/0
R1(config-if)#isis metric 20 >>>>> Metric is increased by 20
R1#sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
Known via "isis", distance 115, metric 10, candidate default path, type level-1
Redistributing via isis 1
Last update from 10.10.13.3 on Ethernet0/1, 00:00:05 ago
Routing Descriptor Blocks:
* 10.10.13.3, from 10.3.3.3, 00:00:05 ago, via Ethernet0/1
Route metric is 10, traffic share count is 1
Now only 1 default route in routing table i.e. towards R3 .
위의 경우 R4에 대한 모든 트래픽은 R3로 전달되고 R2에 대한 링크는 사용되지 않습니다.R2에 대한 링크를 활용하려면 R2에서 재배포를 수행해야 합니다. 이를 나타내려면 R4의 루프백 0이 재배포를 통해 R2로 유출됩니다.
R4#sh run int lo 1
Building configuration...
Current configuration : 85 bytes
!
interface Loopback1
ip address 10.44.44.44 255.255.255.255
ip router isis 1
end
R2#
router isis 1
net 49.0001.0000.0000.0002.00
redistribute isis ip level-2 into level-1 route-map LEVEL2_into_Level1
R2#show route-map
route-map LEVEL2_into_Level1, permit, sequence 10
Match clauses:
ip address (access-lists): 10
Set clauses:
Policy routing matches: 0 packets, 0 bytes
!
R2#sh access-lists 10
Standard IP access list 10
10 permit 10.4.4.4 (22 matches)
재배포 후 R1 데이터베이스 및 라우팅 테이블:
R1#show isis database R2.00-00 detail
Tag 1:
IS-IS Level-1 LSP R2.00-00
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R2.00-00 0x00000036 0xABCD 859 1/0/0
Area Address: 49.0001
NLPID: 0xCC
Hostname: R2
IP Address: 10.2.2.2
Metric: 10 IP 10.10.12.0 255.255.255.0
Metric: 10 IP 10.2.2.2 255.255.255.255
Metric: 10 IP 10.10.24.0 255.255.255.0
Metric: 10 IS R2.01
Metric: 148 IP-Interarea 10.4.4.4 255.255.255.255
After redistribution 10.4.4.4/32 route is being seen into R1 database .
R1#sh ip route 10.4.4.4
Routing entry for 10.4.4.4/32
Known via "isis", distance 115, metric 168, type inter area
Redistributing via isis 1
Last update from 10.10.12.2 on Ethernet0/0, 00:06:32 ago
Routing Descriptor Blocks:
* 10.10.12.2, from 10.2.2.2, 00:06:32 ago, via Ethernet0/0
Route metric is 168, traffic share count is 1
After redistribution 10.4.4.4/32 is also present in routing table as well .
참고:이 경우 R2는 라우팅 테이블에서 특정 경로를 광고하지만 기본 경로를 광고하지 않습니다.R1은 Level1 LSP에서 어태치 비트를 확인하고 라우팅 테이블에 기본 경로를 설치합니다.
현재 이 컨피그레이션에 사용할 수 있는 특정 문제 해결 정보가 없습니다.