ISP(Internet Service Provider)가 Cisco DSL(Digital Subscriber Line) 라우터에 동적 공용 IP 주소를 할당했습니다.
팁:Cisco 디바이스를 구성하는 방법에 익숙하지 않고 단계별 컨피그레이션을 따르고 싶은 경우 고정 IP 주소가 있는 PPPoA의 단계별 컨피그레이션을 참조하십시오.
이 문서에 대한 특정 요건이 없습니다.
이 문서는 특정 소프트웨어 및 하드웨어 버전으로 한정되지 않습니다.
문서 규칙에 대한 자세한 내용은 Cisco 기술 팁 표기 규칙을 참고하십시오.
-
프라이빗 LAN에 대한 IP 주소 지정 체계를 설계합니다.
-
Cisco DSL 라우터 이더넷 인터페이스에서 IP 주소 및 서브넷 마스크를 구성합니다.
-
ATM PVC(Permanent Virtual Circuit) 및 캡슐화를 사용하여 Cisco DSL 라우터의 ATM 인터페이스(Asynchronous Digital Subscriber Line) 인터페이스를 구성합니다.
-
고정 IP 주소를 사용하여 PPPoA(Point-to-Point Protocol over ATM)용 Cisco DSL 라우터의 다이얼러 인터페이스를 만들고 구성합니다.
-
NAT의 경우: 다이얼러 인터페이스의 고정 공용 IP 주소를 공유하도록 Cisco DSL 라우터에 NAT를 구성합니다.
-
IP 주소, 서브넷 마스크, 기본 게이트웨이 및 DNS(Domain Name System) 서버로 각 호스트 PC를 구성합니다.
또는 Cisco DSL 라우터가 PC 클라이언트의 동적 IP 주소를 할당하도록 하려면 DHCP를 통해 IP 주소와 DNS 서버를 자동으로 가져오도록 각 PC를 구성합니다.
이 섹션에서는 이 문서에 설명된 기능을 구성하는 정보를 제공합니다.
참고: 명령 조회 도구(등록된 고객만 해당)를 사용하여 이 문서에 사용된 명령에 대한 자세한 내용을 확인하십시오.
팁:Cisco 디바이스를 구성하는 방법에 익숙하지 않고 단계별 컨피그레이션을 따르고 싶은 경우 고정 IP 주소가 있는 PPPoA의 단계별 컨피그레이션을 참조하십시오.
고정 IP 주소가 있는 Cisco DSL 라우터 |
!--- Comments contain explanations and additional information.
service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!
!--- For DHCP:
ip dhcp excluded-address
ip dhcp pool
network
default-router
dns-server
!
interface ethernet0
no shut
ip address <ip address> <subnet mask>
!--- For NAT:
ip nat inside
no ip directed-broadcast
!
interface atm0
no shut
no ip address
no ip directed-broadcast
no ip mroute-cache
pvc <vpi/vci>
encapsulation aal5mux ppp dialer
dialer pool-member 1
!--- Common PVC values supported by ISPs are 0/35 or 8/35. !--- Confirm your PVC values with your ISP.
!
interface dialer1
ip address <ip address> subnet mask <subnet mask>
no ip directed-broadcast
!--- For NAT:
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname <username>
ppp chap password <password>
ppp pap sent-username <username> password <password>
!
!--- For NAT:
ip nat inside source list 1 interface dialer1 overload
!--- If you have a pool (a range) of public IP addresses provided !--- by your ISP, you can use a NAT Pool. Replace !--- ip nat inside source list 1 interface dialer1 overload
!--- with these two configuration statements: !--- ip nat inside source list 1 pool
overload
!--- ip nat pool
!--- netmask
!--- If Internet users require access to an internal server, you can !--- add this static NAT configuration statement: !--- ip nat inside source static tcp
{80 or 25}
!---
{80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used !--- for this example. You can open other TCP or UDP ports, if needed.
!
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
!--- For NAT:
access-list 1 permit
!--- In this configuration, access-list 1 defines a standard access list !--- that permits the addresses that NAT translates. For example, if !--- your private IP network is 10.10.10.0, configure !--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate !--- packets with source addresses between 10.10.10.0 and 10.10.10.255.
!
end |
현재 이 구성에 대해 사용 가능한 확인 절차가 없습니다.
ADSL 서비스가 제대로 작동하지 않으면 PPPoA 문제 해결을 참조하십시오.