본 제품에 대한 문서 세트는 편견 없는 언어를 사용하기 위해 노력합니다. 본 설명서 세트의 목적상, 편견 없는 언어는 나이, 장애, 성별, 인종 정체성, 민족 정체성, 성적 지향성, 사회 경제적 지위 및 교차성에 기초한 차별을 의미하지 않는 언어로 정의됩니다. 제품 소프트웨어의 사용자 인터페이스에서 하드코딩된 언어, RFP 설명서에 기초한 언어 또는 참조된 서드파티 제품에서 사용하는 언어로 인해 설명서에 예외가 있을 수 있습니다. 시스코에서 어떤 방식으로 포용적인 언어를 사용하고 있는지 자세히 알아보세요.
Cisco는 전 세계 사용자에게 다양한 언어로 지원 콘텐츠를 제공하기 위해 기계 번역 기술과 수작업 번역을 병행하여 이 문서를 번역했습니다. 아무리 품질이 높은 기계 번역이라도 전문 번역가의 번역 결과물만큼 정확하지는 않습니다. Cisco Systems, Inc.는 이 같은 번역에 대해 어떠한 책임도 지지 않으며 항상 원본 영문 문서(링크 제공됨)를 참조할 것을 권장합니다.
이 문서에서는 VxLAN Fabric with Nexus 9000 스위치에서 DHCP를 구성하고 문제를 해결하는 방법에 대해 설명합니다.
다음 주제에 대한 지식을 보유하고 있으면 유용합니다.
이 문서의 정보는 다음 소프트웨어 및 하드웨어 버전을 기반으로 합니다.
이 문서의 정보는 특정 랩 환경의 디바이스를 토대로 작성되었습니다. 이 문서에 사용된 모든 디바이스는 초기화된(기본) 컨피그레이션으로 시작되었습니다. 현재 네트워크가 작동 중인 경우 모든 명령의 잠재적인 영향을 미리 숙지하시기 바랍니다.
참고: 타사 소프트웨어 또는 하드웨어의 구성 및 통합성에 대한 모든 질문은 Cisco 지원 범위에 포함되지 않습니다. 타사 툴을 사용하는 것은 고객에게 Cisco 장비를 사용한 구성 및 운영을 보여주기 위한 최선의 노력입니다.
nv overlay evpn
feature ospf
feature bgp
feature pim
feature netconf
feature nv overlay
ip pim rp-address 192.168.11.11 group-list 224.10.10.0/24
ip pim ssm range 232.0.0.0/8
ip pim anycast-rp 192.168.11.11 192.168.0.11
ip prefix-list direct_routes seq 5 permit 10.104.11.0/30 le 32
route-map redistribution permit 10
match ip address prefix-list direct_routes
interface Ethernet1/1
speed 1000
ip address 10.104.11.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface Ethernet1/2
ip address 10.102.11.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface Ethernet1/3
speed 1000
ip address 10.103.11.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface loopback0
description ANYCAST-RP
ip address 192.168.0.11/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback1
description ANYCAST-RP-CANDIDATE
ip address 192.168.11.11/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
router ospf 1
router bgp 65000
neighbor 192.168.3.3
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 192.168.4.4
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
neighbor 192.168.5.5
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature dhcp
feature nv overlay
fabric forwarding anycast-gateway-mac 0000.0a0a.0a0a
ip pim rp-address 192.168.11.11 group-list 224.10.10.0/24
ip pim ssm range 232.0.0.0/8
vlan 1,10,20,300
vlan 10
vn-segment 101010
vlan 20
vn-segment 202020
vlan 300
vn-segment 303030
spanning-tree vlan 10 priority 4096
ip prefix-list host_subnets seq 5 permit 10.10.10.0/24 le 32
ip prefix-list host_subnets seq 10 permit 192.168.20.0/24 le 32
ip prefix-list host_subnets seq 15 permit 172.16.10.8/32
route-map direct_routes_tenant-a permit 10
match ip address prefix-list host_subnets
vrf context tenant-a
vni 303030
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
interface Vlan10
no shutdown
vrf member tenant-a
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
interface Vlan20
no shutdown
vrf member tenant-a
no ip redirects
ip address 192.168.20.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
interface Vlan300
no shutdown
vrf member tenant-a
no ip redirects
ip forward
no ipv6 redirects
interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 101010
suppress-arp
mcast-group 224.10.10.10
member vni 202020
suppress-arp
mcast-group 224.10.10.10
member vni 303030 associate-vrf
interface Ethernet1/1
ip address 10.104.11.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface loopback0
description UNDERLAY-VERIFICATION
ip address 192.168.5.5/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback100
vrf member tenant-a
ip address 172.16.10.8/32
router ospf 1
router bgp 65000
address-family ipv4 unicast
neighbor 192.168.0.11
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
vrf tenant-a
address-family ipv4 unicast
redistribute direct route-map direct_routes_tenant-a
evpn
vni 101010 l2
rd auto
route-target import auto
route-target export auto
vni 202020 l2
rd auto
route-target import auto
route-target export auto
nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature dhcp
feature vpc
feature nv overlay
fabric forwarding anycast-gateway-mac 0000.0a0a.0a0a
ip pim rp-address 192.168.11.11 group-list 224.10.10.0/24
ip pim ssm range 232.0.0.0/8
vlan 1,10,300,777
vlan 10
vn-segment 101010
vlan 300
vn-segment 303030
vlan 777
name BACKUP_VLAN_ROUTING_NVE_INFRA
spanning-tree vlan 1,10,300 hello-time 4
ip prefix-list host_subnets seq 5 permit 10.10.10.0/24 le 32
ip prefix-list host_subnets seq 15 permit 172.16.10.9/32
route-map direct_routes_tenant-a permit 10
match ip address prefix-list host_subnets
vrf context tenant-a
vni 303030
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
system nve infra-vlans 777
vpc domain 1
peer-switch
peer-keepalive destination 10.88.238.195
peer-gateway
layer3 peer-router
ip arp synchronize
interface Ethernet1/3
switchport
switchport mode trunk
switchport trunk allowed vlan 1,10,20
channel-group 10 mode active
no shutdown
interface Ethernet1/19
switchport
switchport mode trunk
channel-group 1 mode active
no shutdown
interface port-channel1
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link
interface port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 1,10
vpc 10
interface mgmt0
vrf member management
ip address 10.88.238.194/29
interface loopback0
description UNDERLAY-VERIFICATION
ip address 192.168.3.3/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback1
description OVERLAY-NVE
ip address 192.168.13.1/32
ip address 192.168.13.254/32 secondary
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback10
vrf member tenant-a
ip address 172.16.10.1/32
interface loopback100
vrf member tenant-a
ip address 172.16.10.9/32
interface Vlan10
no shutdown
vrf member tenant-a
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
interface Vlan300
no shutdown
vrf member tenant-a
no ip redirects
ip forward
no ipv6 redirects
interface Vlan777
description BACKUP_UNDERLAY_INFRA-VLAN
no shutdown
no ip redirects
ip address 10.255.77.1/30
no ipv6 redirects
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface Ethernet1/2
ip address 10.102.11.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface nve1
no shutdown
host-reachability protocol bgp
advertise virtual-rmac
source-interface loopback1
member vni 101010
suppress-arp
mcast-group 224.10.10.10
member vni 303030 associate-vrf
router ospf 1
router bgp 65000
address-family ipv4 unicast
address-family l2vpn evpn
advertise-pip
neighbor 192.168.0.11
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
neighbor 192.168.88.2
remote-as 65000
description OVERLAY_BACKUP
update-source Vlan888
address-family l2vpn evpn
send-community
send-community extended
vrf tenant-a
address-family ipv4 unicast
redistribute direct route-map direct_routes_tenant-a
evpn
vni 101010 l2
rd auto
route-target import auto
route-target export auto
vni 202020 l2
rd auto
route-target import auto
route-target export auto
nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature dhcp
feature vpc
feature nv overlay
fabric forwarding anycast-gateway-mac 0000.0a0a.0a0a
ip pim rp-address 192.168.11.11 group-list 224.10.10.0/24
ip pim ssm range 232.0.0.0/8
vlan 1,10,20,300,777
vlan 10
vn-segment 101010
vlan 20
vn-segment 202020
vlan 300
vn-segment 303030
vlan 777
name BACKUP_VLAN_ROUTING_NVE_INFRA
spanning-tree vlan 1,10,20,300 hello-time 4
ip prefix-list host_subnets seq 5 permit 10.10.10.0/24 le 32
ip prefix-list host_subnets seq 10 permit 192.168.20.0/24 le 32
ip prefix-list host_subnets seq 15 permit 172.16.10.10/32
route-map direct_routes_tenant-a permit 10
match ip address prefix-list host_subnets
vrf context tenant-a
vni 303030
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
system nve infra-vlans 777
vpc domain 1
peer-switch
peer-keepalive destination 10.88.238.194
peer-gateway
layer3 peer-router
ip arp synchronize
interface Ethernet1/1
ip address 10.103.11.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
no shutdown
interface Ethernet1/19
switchport
switchport mode trunk
channel-group 1 mode active
no shutdown
interface port-channel1
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link
interface port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 1,10,20
vpc 10
interface mgmt0
vrf member management
ip address 10.88.238.195/29
interface loopback0
description UNDERLAY-VERIFICATION
ip address 192.168.4.4/32
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback1
description OVERLAY-NVE
ip address 192.168.13.2/32
ip address 192.168.13.254/32 secondary
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface loopback10
vrf member tenant-a
ip address 172.16.10.2/32
interface loopback100
vrf member tenant-a
ip address 172.16.10.10/32
interface Vlan10
no shutdown
vrf member tenant-a
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
interface Vlan20
no shutdown
vrf member tenant-a
no ip redirects
ip address 192.168.20.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
interface Vlan300
no shutdown
vrf member tenant-a
no ip redirects
ip forward
no ipv6 redirects
interface Vlan777
description BACKUP_UNDERLAY_INFRA-VLAN
no shutdown
no ip redirects
ip address 10.255.77.2/30
no ipv6 redirects
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
ip pim sparse-mode
interface nve1
no shutdown
host-reachability protocol bgp
advertise virtual-rmac
source-interface loopback1
member vni 101010
suppress-arp
mcast-group 224.10.10.10
member vni 202020
suppress-arp
mcast-group 224.10.10.10
member vni 303030 associate-vrf
router ospf 1
router bgp 65000
address-family ipv4 unicast
address-family l2vpn evpn
advertise-pip
neighbor 192.168.0.11
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
neighbor 192.168.88.1
remote-as 65000
description OVERLAY_BACKUP
update-source Vlan888
address-family l2vpn evpn
send-community
send-community extended
vrf tenant-a
address-family ipv4 unicast
redistribute direct route-map direct_routes_tenant-a
evpn
vni 101010 l2
rd auto
route-target import auto
route-target export auto
vni 202020 l2
rd auto
route-target import auto
route-target export auto
feature lacp
vlan 1,10
interface port-channel10
switchport
switchport mode trunk
interface Ethernet1/11
switchport
switchport access vlan 10
no shutdown
interface Ethernet1/45
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown
interface Ethernet1/46
switchport
switchport mode trunk
channel-group 10 mode active
no shutdown
1단계. 기능 DCHP를 활성화합니다.
LEAF-1(config)# feature dhcp
참고: NX-OS 7.x부터 DHCP 서버 및 릴레이 에이전트 명령 서비스 dhcp, ip dhcp 릴레이, ipv6 dhcp 릴레이가 기본적으로 활성화되어 있습니다.
2단계. 명령 ip dhcp relay information 옵션을 적용합니다.
LEAF-1(config)# ip dhcp relay information option
참고: 이 명령을 사용하면 DHCP 릴레이 에이전트가 전달된 패킷에 대한 옵션 82 정보를 삽입하고 제거할 수 있습니다.
3단계. 명령 ip dhcp relay information option vpn을 적용합니다.
LEAF-1(config)# ip dhcp relay information option vpn
참고: 이 명령은 DHCP 서버가 속한 다른 VRF에 도착하는 DHCP 릴레이 요청을 활성화합니다.
4단계. "ip dhcp relay address [ip address of DCHP server]" 명령을 적용합니다.
참고: 이 예에서 DCHP 서버의 IP 주소는 10.10.10.150입니다.
LEAF-1(config)# interface vlan 10
LEAF-1(config-if)# ip dhcp relay address 10.10.10.150
5단계. "ip dhcp relay source-interface [unique loopback]" 명령을 적용합니다.
참고: 이 명령은 DHCP 릴레이 에이전트가 SVI의 IP 주소를 DHCP 릴레이 에이전트의 소스 IP 주소로 사용하는 유니캐스트 통신을 위해 검색, 제안, 요청 및 ACK를 처리하도록 DHCP 릴레이 에이전트의 소스 IP 주소를 구성합니다. 이 IP 주소가 여러 VTEP에 의해 공유되고 DHCP 패킷의 블랙홀링이 발생할 수 있기 때문에 이는 바람직하지 않습니다. 이를 방지하려면 각 VTEP를 구별하기 위해 고유한 IP 주소(루프백 인터페이스 사용)가 필요합니다.
LEAF-1(config)# interface vlan 10
LEAF-1(config-if)# ip dhcp relay source-interface loopback100
6단계. BGP 내의 VRF 해당 테넌트에서 루프백 인터페이스의 IP 주소를 포함하는 접두사 목록 및 경로 맵을 사용하여 직접 경로 재배포를 수행합니다.
참고: 이 루프백 인터페이스는 SVI 테넌트에 속합니다.
LEAF-1(config)# show running-config interface loopback 100
interface loopback100
vrf member tenant-a
ip address 172.16.10.8/32
LEAF-1(config)# ip prefix-list host_subnets seq 15 permit 172.16.10.8/32
LEAF-1(config)# route-map direct_routes_tenant-a permit 10
LEAF-1(config-route-map)# match ip address prefix-list host_subnets
LEAF-1(config-route-map)# router bgp 65000
LEAF-1(config-router)# vrf tenant-a
LEAF-1(config-router-vrf)# address-family ipv4 unicast
LEAF-1(config-router-vrf-af)# redistribute direct route-map direct_routes_tenant-a
7단계. 루프백 인터페이스의 IP 주소가 BGP L2VPN EVPN에서 show bgp l2vpn evpn [loopback IP] vrf [tenant vrf] 명령을 사용하여 Spines에 광고되는지 확인합니다.
LEAF-1(config)# show bgp l2vpn evpn 172.16.10.8 vrf tenant-a
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.5.5:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.8]/224, version 421
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn
Advertised path-id 1
Path type: local, path is valid, is best path, no labeled nexthop
Gateway IP: 0.0.0.0
AS-Path: NONE, path locally originated
192.168.5.5 (metric 0) from 0.0.0.0 (192.168.5.5)
Origin incomplete, MED 0, localpref 100, weight 32768
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:707d.b9b8.4daf
Path-id 1 advertised to peers:
192.168.0.11 <<<< Spine
8단계. 루프백 인터페이스의 IP 주소가 DHCP 서버가 있는 BGP L2VPN EVPN에 삽입되었는지 확인합니다.
참고: vPC에 Nexus 스위치가 있는 경우 둘 다 BGP L2VPN EVPN에서 루프백 인터페이스의 IP 주소를 학습하는지 확인합니다.
LEAF-1# show bgp l2vpn evpn 172.16.10.8
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.5.5:4
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.8]/224, version 754
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn, is not in HW
Advertised path-id 1
Path type: internal, path is valid, is best path, no labeled nexthop
Imported to 2 destination(s)
Imported paths list: tenant-a L3-303030
Gateway IP: 0.0.0.0
AS-Path: NONE, path sourced internal to AS
192.168.5.5 (metric 45) from 192.168.0.11 (192.168.0.11)
Origin incomplete, MED 0, localpref 100, weight 0
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:707d.b9b8.4daf
Originator: 192.168.5.5 Cluster list: 192.168.0.11
Path-id 1 not advertised to any peer
Route Distinguisher: 192.168.3.3:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.8]/224, version 761
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn, is not in HW
Advertised path-id 1
Path type: internal, path is valid, is best path, no labeled nexthop
Imported from 192.168.5.5:4:[5]:[0]:[0]:[32]:[172.16.10.8]/224
Gateway IP: 0.0.0.0
AS-Path: NONE, path sourced internal to AS
192.168.5.5 (metric 45) from 192.168.0.11 (192.168.0.11)
Origin incomplete, MED 0, localpref 100, weight 0
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:707d.b9b8.4daf
Originator: 192.168.5.5 Cluster list: 192.168.0.11
Path-id 1 not advertised to any peer
9단계. show ip route [DHCP server IP] vrf [tenant vrf] 명령을 사용하여 소스 테넌트에 DHCP 서버에 대한 경로가 있는지 확인합니다.
참고: 사용할 경로 항목은 VxLAN에서 기본 VRF로 설정되어야 합니다. 사용 가능한 경로가 없는 경우 VTEP가 로컬에서 DCHP 서버 IP 주소를 알고 있는지 확인합니다.
LEAF-1# show running-config interface vlan 10
interface Vlan10
no shutdown
vrf member tenant-a <<<< source tenant
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150 <<<< DHCP server
ip dhcp relay source-interface loopback100
LEAF-1# show ip route 10.10.10.150 vrf tenant-a
10.10.10.150/32, ubest/mbest: 1/0
*via 192.168.13.254%default, [200/0], 2w0d, bgp-65000, internal, tag 65000, segid: 303030 tunnelid: 0xd0d0dfe encap: VXLAN
10단계. 루프백 인터페이스 및 해당 VRF를 명령 ping[DHCP server IP]을 통해 VRF 소스로 사용하여 DCHP 서버 IP에 연결할 수 있는지 확인합니다. source-interface 루프백 [x] vrf [tenant vrf].
LEAF-1# ping 10.10.10.150 source-interface loopback 100 vrf tenant-a
PING 10.10.10.150 (10.10.10.150): 56 data bytes
64 bytes from 10.10.10.150: icmp_seq=0 ttl=126 time=1.262 ms
64 bytes from 10.10.10.150: icmp_seq=1 ttl=126 time=0.833 ms
64 bytes from 10.10.10.150: icmp_seq=2 ttl=126 time=0.808 ms
64 bytes from 10.10.10.150: icmp_seq=3 ttl=126 time=0.795 ms
64 bytes from 10.10.10.150: icmp_seq=4 ttl=126 time=0.78 ms
--- 10.10.10.150 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
11단계. DHCP 릴레이 에이전트의 상태를 확인합니다.
LEAF-1# show ip dhcp status
Current CLI Operation: show ip dhcp status
Last CLI Operation: DME: ip dhcp relay information option enable
Last CLI Operation Status: SUCCESS
12단계. vpn 옵션과 같은 옵션 82를 확인하고 릴레이 에이전트 아래에서 올바른 릴레이 IP 주소를 확인합니다.
LEAF-1# show ip dhcp relay
DHCP relay service is enabled <<<<<<
Insertion of option 82 is enabled <<<<<<
Insertion of option 82 customize circuitid is disabled
TLV format in CircuitId and RemoteId suboptions is enabled
Insertion of VPN suboptions is enabled <<<<<<<
Insertion of cisco suboptions is disabled
Global smart-relay is disabled
Relay Trusted functionality is disabled
Relay Trusted Port is Globally disabled
V4 Relay Source Address HSRP is Globally disabled
Server-ID-override-disable is disabled
Smart-relay is enabled on the following interfaces:
------------------------------------------------------
Subnet-broadcast is enabled on the following interfaces:
------------------------------------------------------
Relay Trusted Port is enabled on the following interfaces:
----------------------------------------------------------
Relay Source Address HSRP is enabled on the following interfaces:
-------------------------------------------------------------------
Helper addresses are configured on the following interfaces:
Interface Relay Address VRF Name
------------- ------------- --------
Vlan10 10.10.10.150 <<<<<<<<<
13단계. 처리 및 전달된 패킷의 통계를 확인합니다.
LEAF-1# show ip dhcp global statistics
Packets processed 1297177
Packets received through cfsoe 0
Packets forwarded 1297175
Packets forwarded on cfsoe 0
Total packets dropped 0
Packets dropped from untrusted ports 0
Packets dropped due to MAC address check failure 0
Packets dropped due to Option 82 insertion failure 0
Packets dropped due to o/p intf unknown 0
Packets dropped which were unknown 0
Packets dropped due to no trusted ports 0
Packets dropped due to dhcp relay not enabled 0
Packets dropped due to no binding entry 0
Packets dropped due to interface error/no interface 0
Packets dropped due to max hops exceeded 0
Packets dropped due to Queue full 0
14단계. 릴레이 패킷의 통계를 확인합니다.
LEAF-1# show ip dhcp relay statistics
----------------------------------------------------------------------
Message Type Rx Tx Drops
----------------------------------------------------------------------
Discover 260521 260520 0
Offer 289330 289330 0
Request(*) 267162 267161 0
Ack 8322 8322 0
Release(*) 181121 181121 0
Decline 1 1 0
Inform(*) 0 0 0
Nack 289280 289280 0
----------------------------------------------------------------------
Total 1295737 1295735 0
----------------------------------------------------------------------
DHCP L3 FWD:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
Non DHCP:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
DROP:
DHCP Relay not enabled : 0
Invalid DHCP message type : 0
Interface error : 0
Tx failure towards server : 0
Tx failure towards client : 0
Unknown output interface : 0
Unknown vrf or interface for server : 0
Max hops exceeded : 0
Option 82 validation failed : 0
Packet Malformed : 0
DHCP Request dropped on MCT : 0
Relay Trusted port not configured : 0
* - These counters will show correct value when switch
receives DHCP request packet with destination ip as broadcast
address. If request is unicast it will be HW switched
1단계. 기능 DCHP를 활성화합니다.
LEAF-1-VPC(config)#feature dhcp
참고: NX-OS 7.x부터 DHCP 서버 및 릴레이 에이전트 명령 서비스 dhcp, ip dhcp 릴레이, ipv6 dhcp 릴레이가 기본적으로 활성화되어 있습니다.
2단계. 명령 ip dhcp relay information 옵션을 적용합니다.
LEAF-1-VPC(config)#ip dhcp relay information option
참고: 이 명령을 사용하면 DHCP 릴레이 에이전트가 전달된 패킷에 대한 옵션 82 정보를 삽입하고 제거할 수 있습니다.
3단계. "ip dhcp relay information option vpn" 명령을 적용합니다.
LEAF-1-VPC(config)# ip dhcp relay information option vpn
참고: 이 명령은 DHCP 서버가 속한 다른 VRF에 도착하는 DHCP 릴레이 요청을 활성화합니다.
4단계. 명령 ip dhcp relay address [ip address of DCHP server]를 적용합니다.
참고: 이 예에서 DCHP 서버의 IP 주소는 10.10.10.150입니다.
LEAF-1-VPC(config)#interface vlan 10
LEAF-1-VPC(config-if)#ip dhcp relay address 10.10.10.150
5단계. "ip dhcp relay source-interface [unique loopback]" 명령을 적용합니다.
참고: 이 명령은 DHCP 릴레이 에이전트가 SVI의 IP 주소를 DHCP 릴레이 에이전트의 소스 IP 주소로 사용하는 유니캐스트 통신을 위해 검색, 제안, 요청 및 ACK를 처리하도록 DHCP 릴레이 에이전트의 소스 IP 주소를 구성합니다. 이 IP 주소가 여러 VTEP에 의해 공유되고 DHCP 패킷의 블랙홀링이 발생할 수 있기 때문에 이는 바람직하지 않습니다. 이를 방지하려면 각 VTEP를 구별하기 위해 고유한 IP 주소(루프백 인터페이스 사용)가 필요합니다.
LEAF-1-VPC(config)#interface vlan 10
LEAF-1-VPC(config-if)# ip dhcp relay source-interface loopback100
6단계. BGP 내의 VRF 해당 테넌트에서 루프백 인터페이스의 IP 주소를 포함하는 접두사 목록 및 경로 맵을 사용하여 직접 경로 재배포를 수행합니다.
참고: 이 루프백 인터페이스는 SVI 테넌트에 속합니다.
LEAF-1-VPC(config)# show running-config interface loopback 100
interface loopback100
vrf member tenant-a
ip address 172.16.10.9/32
LEAF-1-VPC(config)# ip prefix-list host_subnets seq 15 permit 172.16.10.9/32
LEAF-1-VPC(config)# route-map direct_routes_tenant-a permit 10
LEAF-1-VPC(config-route-map)# match ip address prefix-list host_subnets
LEAF-1-VPC(config-route-map)# router bgp 65000
LEAF-1-VPC(config-router)# vrf tenant-a
LEAF-1-VPC(config-router-vrf)# address-family ipv4 unicast
LEAF-1-VPC(config-router-vrf-af)# redistribute direct route-map direct_routes_tenant-a
7단계. 루프백 인터페이스의 IP 주소가 BGP L2VPN EVPN에서 show bgp l2vpn evpn [loopback IP] vrf [tenant vrf] 명령을 사용하여 Spines에 광고되는지 확인합니다.
LEAF-1-VPC# show bgp l2vpn evpn 172.16.10.9 vrf tenant-a
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.3.3:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.9]/224, version 637
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn
Advertised path-id 1
Path type: local, path is valid, is best path, no labeled nexthop
Gateway IP: 0.0.0.0
AS-Path: NONE, path locally originated
192.168.13.1 (metric 0) from 0.0.0.0 (192.168.3.3)
Origin incomplete, MED 0, localpref 100, weight 32768
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:6026.aa85.9887
Path-id 1 advertised to peers:
192.168.0.11
8단계. 루프백 인터페이스의 IP 주소가 DHCP 서버가 있는 BGP L2VPN EVPN에 삽입되었는지 확인합니다.
참고: vPC에 Nexus 스위치가 있는 경우 둘 다 BGP L2VPN EVPN에서 루프백 인터페이스의 IP 주소를 학습하는지 확인합니다.
LEAF-1-VPC# show bgp l2vpn evpn 172.16.10.9
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.3.3:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.9]/224, version 637
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn
Advertised path-id 1
Path type: local, path is valid, is best path, no labeled nexthop
Gateway IP: 0.0.0.0
AS-Path: NONE, path locally originated
192.168.13.1 (metric 0) from 0.0.0.0 (192.168.3.3)
Origin incomplete, MED 0, localpref 100, weight 32768
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:6026.aa85.9887
Path-id 1 advertised to peers:
192.168.0.11
9단계. show ip route [DHCP server IP] vrf[tenant vrf] 명령을 사용하여 소스 테넌트에 DHCP 서버에 대한 경로가 있는지 확인합니다.
참고: 사용할 경로 항목은 VxLAN에서 기본 VRF로 설정되어야 합니다. 사용 가능한 경로가 없는 경우 VTEP가 로컬에서 DCHP 서버 IP 주소를 알고 있는지 확인합니다.
LEAF-1-VPC# show running-config interface vlan 10
interface Vlan10
no shutdown
vrf member tenant-a <<<< source tenant
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
LEAF-1-VPC# show ip route 10.10.10.150 vrf tenant-a
10.10.10.150/32, ubest/mbest: 1/0, attached
*via 10.10.10.150, Vlan10, [190/0], 6d07h, hmm
10단계. DCHP 서버 IP가 루프백 인터페이스 및 해당 VRF를 명령 ping [DHCP server IP] source-interface 루프백 [x] vrf [tenvrf]를 사용하여 VRF 소스로 연결할 수 있는지 확인합니다.
LEAF-1-VPC# ping 10.10.10.150 source-interface loopback 100 vrf tenant-a
PING 10.10.10.150 (10.10.10.150): 56 data bytes
64 bytes from 10.10.10.150: icmp_seq=0 ttl=126 time=0.965 ms
64 bytes from 10.10.10.150: icmp_seq=1 ttl=126 time=0.57 ms
64 bytes from 10.10.10.150: icmp_seq=2 ttl=126 time=0.488 ms
64 bytes from 10.10.10.150: icmp_seq=3 ttl=126 time=0.524 ms
64 bytes from 10.10.10.150: icmp_seq=4 ttl=126 time=0.502 ms
--- 10.10.10.150 ping statistics ---
11단계. DHCP 릴레이 에이전트의 상태를 확인합니다.
LEAF-1-VPC# show ip dhcp status
Current CLI Operation: show ip dhcp status
Last CLI Operation: DME: ip dhcp relay information option vpn enable
Last CLI Operation Status: SUCCESS
12단계. vpn 옵션과 같은 옵션 82를 확인하고 릴레이 에이전트 아래에서 올바른 릴레이 IP 주소를 확인합니다.
LEAF-1-VPC# show ip dhcp relay
DHCP relay service is enabled <<<<<<
Insertion of option 82 is enabled <<<<<<<
Insertion of option 82 customize circuitid is disabled
TLV format in CircuitId and RemoteId suboptions is enabled
Insertion of VPN suboptions is enabled <<<<<<<
Insertion of cisco suboptions is disabled
Global smart-relay is disabled
Relay Trusted functionality is disabled
Relay Trusted Port is Globally disabled
V4 Relay Source Address HSRP is Globally disabled
Server-ID-override-disable is disabled
Smart-relay is enabled on the following interfaces:
------------------------------------------------------
Subnet-broadcast is enabled on the following interfaces:
------------------------------------------------------
Relay Trusted Port is enabled on the following interfaces:
----------------------------------------------------------
Relay Source Address HSRP is enabled on the following interfaces:
-------------------------------------------------------------------
Helper addresses are configured on the following interfaces:
Interface Relay Address VRF Name
------------- ------------- --------
Vlan10 10.10.10.150 <<<<<<<<<
13단계. 처리 및 전달된 패킷의 통계를 확인합니다.
LEAF-1-VPC# show ip dhcp global statistics
Packets processed 263162
Packets received through cfsoe 0
Packets forwarded 263161
Packets forwarded on cfsoe 0
Total packets dropped 0
Packets dropped from untrusted ports 0
Packets dropped due to MAC address check failure 0
Packets dropped due to Option 82 insertion failure 0
Packets dropped due to o/p intf unknown 0
Packets dropped which were unknown 0
Packets dropped due to no trusted ports 0
Packets dropped due to dhcp relay not enabled 0
Packets dropped due to no binding entry 0
Packets dropped due to interface error/no interface 0
Packets dropped due to max hops exceeded 0
Packets dropped due to Queue full 0
14단계. 릴레이 패킷의 통계를 확인합니다.
LEAF-1-VPC# show ip dhcp relay statistics
----------------------------------------------------------------------
Message Type Rx Tx Drops
----------------------------------------------------------------------
Discover 8 7 0
Offer 29304 29304 0
Request(*) 5029 5029 0
Ack 6535 6535 0
Release(*) 191482 191482 0
Decline 0 0 0
Inform(*) 3 3 0
Nack 29281 29281 0
----------------------------------------------------------------------
Total 261642 261641 0
----------------------------------------------------------------------
DHCP L3 FWD:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
Non DHCP:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
DROP:
DHCP Relay not enabled : 0
Invalid DHCP message type : 0
Interface error : 0
Tx failure towards server : 0
Tx failure towards client : 0
Unknown output interface : 0
Unknown vrf or interface for server : 0
Max hops exceeded : 0
Option 82 validation failed : 0
Packet Malformed : 0
DHCP Request dropped on MCT : 0
Relay Trusted port not configured : 0
* - These counters will show correct value when switch
receives DHCP request packet with destination ip as broadcast
address. If request is unicast it will be HW switched
1단계. 기능 DCHP를 활성화합니다.
LEAF-2-VPC(config)# feature dhcp
참고: NX-OS 7.x 이후 DHCP 서버 및 릴레이 에이전트 명령 서비스 dhcp, ip dhcp 릴레이 및 ipv6 dhcp 릴레이는 기본적으로 활성화되어 있습니다.
2단계. "ip dhcp relay information option" 명령을 적용합니다.
LEAF-2-VPC(config)# ip dhcp relay information option
참고: 이 명령을 사용하면 DHCP 릴레이 에이전트가 전달된 패킷에 대한 옵션 82 정보를 삽입하고 제거할 수 있습니다.
3단계. "ip dhcp relay information option vpn" 명령을 적용합니다.
LEAF-2-VPC(config)# ip dhcp relay information option vpn
참고: 이 명령은 DHCP 서버가 속한 다른 VRF에 도착하는 DHCP 릴레이 요청을 활성화합니다.
4단계. "ip dhcp relay address [ip address of DCHP server]" 명령을 적용합니다.
참고: 이 예에서 DCHP 서버의 IP 주소는 10.10.10.150입니다.
LEAF-2-VPC(config)# interface vlan 10
LEAF-2-VPC(config-if)# ip dhcp relay address 10.10.10.150
5단계. "ip dhcp relay source-interface [unique loopback]" 명령을 적용합니다.
참고: 이 명령은 DHCP 릴레이 에이전트가 SVI의 IP 주소를 DHCP 릴레이 에이전트의 소스 IP 주소로 사용하는 유니캐스트 통신을 위해 검색, 제안, 요청 및 ACK를 처리하도록 DHCP 릴레이 에이전트의 소스 IP 주소를 구성합니다. 이 IP 주소가 여러 VTEP에 의해 공유되고 DHCP 패킷의 블랙홀링이 발생할 수 있기 때문에 이는 바람직하지 않습니다. 이를 방지하려면 각 VTEP를 구별하기 위해 고유한 IP 주소(루프백 인터페이스 사용)가 필요합니다.
LEAF-2-VPC(config)# interface vlan 10
LEAF-2-VPC(config-if)# ip dhcp relay source-interface loopback 100
6단계. BGP 내의 VRF 해당 테넌트에서 루프백 인터페이스의 IP 주소를 포함하는 접두사 목록 및 경로 맵을 사용하여 직접 경로 재배포를 수행합니다.
참고: 이 루프백 인터페이스는 SVI 테넌트에 속합니다.
LEAF-2-VPC(config-if)# show running-config interface loopback 100
interface loopback100
vrf member tenant-a
ip address 172.16.10.10/32
LEAF-2-VPC(config)# ip prefix-list host_subnets seq 15 permit 172.16.10.10/32
LEAF-2-VPC(config)# route-map direct_routes_tenant-a permit 10
LEAF-2-VPC(config-route-map)# match ip address prefix-list host_subnets
LEAF-2-VPC(config-route-map)# router bgp 65000
LEAF-2-VPC(config-router)# vrf tenant-a
LEAF-2-VPC(config-router-vrf)# address-family ipv4 unicast
LEAF-2-VPC(config-router-vrf-af)# redistribute direct route-map direct_routes_tenant-a
7단계. 루프백 인터페이스의 IP 주소가 BGP L2VPN EVPN에서 show bgp l2vpn evpn [loopback IP] vrf [tenant vrf] 명령을 사용하여 Spines에 광고되는지 확인합니다.
LEAF-2-VPC(config-if)# show bgp l2vpn evpn 172.16.10.10 vrf tenant-a
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.4.4:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.10]/224, version 49
5
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn
Advertised path-id 1
Path type: local, path is valid, is best path, no labeled nexthop
Gateway IP: 0.0.0.0
AS-Path: NONE, path locally originated
192.168.13.2 (metric 0) from 0.0.0.0 (192.168.4.4)
Origin incomplete, MED 0, localpref 100, weight 32768
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:6026.aa85.9587
Path-id 1 advertised to peers:
192.168.0.11 <<<<< Spine
8단계. 루프백 인터페이스의 IP 주소가 DHCP 서버가 있는 BGP L2VPN EVPN에 삽입되었는지 확인합니다.
참고: vPC에 Nexus 스위치가 있는 경우 둘 다 BGP L2VPN EVPN에서 루프백 인터페이스의 IP 주소를 학습하는지 확인합니다.
LEAF-2-VPC(config-if)# show bgp l2vpn evpn 172.16.10.10
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 192.168.4.4:4 (L3VNI 303030)
BGP routing table entry for [5]:[0]:[0]:[32]:[172.16.10.10]/224, version 49
5
Paths: (1 available, best #1)
Flags: (0x000002) (high32 00000000) on xmit-list, is not in l2rib/evpn
Advertised path-id 1
Path type: local, path is valid, is best path, no labeled nexthop
Gateway IP: 0.0.0.0
AS-Path: NONE, path locally originated
192.168.13.2 (metric 0) from 0.0.0.0 (192.168.4.4)
Origin incomplete, MED 0, localpref 100, weight 32768
Received label 303030
Extcommunity: RT:65000:303030 ENCAP:8 Router MAC:6026.aa85.9587
Path-id 1 advertised to peers:
192.168.0.11
9단계. show ip route [DHCP server IP] vrf[tenvrf] 명령을 사용하여 소스 테넌트에 DHCP 서버에 대한 경로가 있는지 확인합니다.
참고: 사용할 경로 항목은 VxLAN에서 기본 VRF로 설정되어야 합니다. 사용 가능한 경로가 없는 경우 VTEP가 로컬에서 DCHP 서버 IP 주소를 알고 있는지 확인합니다.
LEAF-2-VPC(config-if)# show running-config interface vlan 10
interface Vlan10
no shutdown
vrf member tenant-a
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
LEAF-2-VPC(config-if)# show ip route 10.10.10.150 vrf tenant-a
10.10.10.150/32, ubest/mbest: 1/0, attached
*via 10.10.10.150, Vlan10, [190/0], 01:01:28, hmm
10단계. 루프백 인터페이스 및 해당 VRF를 명령 ping[DHCP server IP]을 통해 VRF 소스로 사용하여 DCHP 서버 IP에 연결할 수 있는지 확인합니다. source-interface 루프백 [x] vrf [tenant vrf].
LEAF-2-VPC(config-if)# ping 10.10.10.150 source-interface loopback 100 vrf tenant-a
PING 10.10.10.150 (10.10.10.150): 56 data bytes
64 bytes from 10.10.10.150: icmp_seq=0 ttl=127 time=0.928 ms
64 bytes from 10.10.10.150: icmp_seq=1 ttl=127 time=0.475 ms
64 bytes from 10.10.10.150: icmp_seq=2 ttl=127 time=0.455 ms
64 bytes from 10.10.10.150: icmp_seq=3 ttl=127 time=0.409 ms
64 bytes from 10.10.10.150: icmp_seq=4 ttl=127 time=0.465 ms
--- 10.10.10.150 ping statistics ---
11단계. DHCP 릴레이 에이전트의 상태를 확인합니다.
LEAF-2-VPC(config)# show ip dhcp status
Current CLI Operation: show ip dhcp status
Last CLI Operation: DME: ip dhcp relay information option vpn enable
Last CLI Operation Status: SUCCESS
12단계. vpn 옵션과 같은 옵션 82를 확인하고 릴레이 에이전트 아래에서 올바른 릴레이 IP 주소를 확인합니다.
LEAF-2-VPC(config)# show ip dhcp relay
DHCP relay service is enabled <<<<<<<
Insertion of option 82 is enabled <<<<<<<<<
Insertion of option 82 customize circuitid is disabled
TLV format in CircuitId and RemoteId suboptions is enabled
Insertion of VPN suboptions is enabled <<<<<<<
Insertion of cisco suboptions is disabled
Global smart-relay is disabled
Relay Trusted functionality is disabled
Relay Trusted Port is Globally disabled
V4 Relay Source Address HSRP is Globally disabled
Server-ID-override-disable is disabled
Smart-relay is enabled on the following interfaces:
------------------------------------------------------
Subnet-broadcast is enabled on the following interfaces:
------------------------------------------------------
Relay Trusted Port is enabled on the following interfaces:
----------------------------------------------------------
Relay Source Address HSRP is enabled on the following interfaces:
-------------------------------------------------------------------
Helper addresses are configured on the following interfaces:
Interface Relay Address VRF Name
------------- ------------- --------
Vlan10 10.10.10.150 <<<<
13단계. 처리 및 전달된 패킷의 통계를 확인합니다.
LEAF-2-VPC(config)# show ip dhcp global statistics
Packets processed 103030
Packets received through cfsoe 0
Packets forwarded 103030
Packets forwarded on cfsoe 0
Total packets dropped 0
Packets dropped from untrusted ports 0
Packets dropped due to MAC address check failure 0
Packets dropped due to Option 82 insertion failure 0
Packets dropped due to o/p intf unknown 0
Packets dropped which were unknown 0
Packets dropped due to no trusted ports 0
Packets dropped due to dhcp relay not enabled 0
Packets dropped due to no binding entry 0
Packets dropped due to interface error/no interface 0
Packets dropped due to max hops exceeded 0
Packets dropped due to Queue full 0
14단계. 릴레이 패킷의 통계를 확인합니다.
LEAF-2-VPC# show ip dhcp relay statistics
----------------------------------------------------------------------
Message Type Rx Tx Drops
----------------------------------------------------------------------
Discover 29312 29311 0
Offer 300001 300001 0
Request(*) 29324 29324 0
Ack 1574 1574 0
Release(*) 191493 191493 0
Decline 0 0 0
Inform(*) 1540 1540 0
Nack 472890 472890 0
----------------------------------------------------------------------
Total 1026134 1026133 0
----------------------------------------------------------------------
DHCP L3 FWD:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
Non DHCP:
Total Packets Received : 0
Total Packets Forwarded : 0
Total Packets Dropped : 0
DROP:
DHCP Relay not enabled : 0
Invalid DHCP message type : 0
Interface error : 0
Tx failure towards server : 0
Tx failure towards client : 0
Unknown output interface : 0
Unknown vrf or interface for server : 0
Max hops exceeded : 0
Option 82 validation failed : 0
Packet Malformed : 0
DHCP Request dropped on MCT : 0
Relay Trusted port not configured : 0
* - These counters will show correct value when switch
receives DHCP request packet with destination ip as broadcast
address. If request is unicast it will be HW switched
1단계. 서버 관리자를 열고 대시보드의 DCHP 서버에 경보가 없는지 확인합니다.
팁: 두 번 클릭하면 이미지가 확대됩니다.
2단계. DHCP 서버 애플리케이션을 엽니다.
3단계. IPv4를 마우스 오른쪽 버튼으로 클릭하고 New Scope(새 범위)를 클릭합니다.
4단계. Next(다음)를 클릭합니다.
5단계. 이름 및 설명을 작성합니다. 이 예에서 이름은 VLAN 10에 속하는 서브넷이며 설명은 VLAN 10에 나열된 L2VNI(L2VNI as L2VNI)입니다.
6단계. IP 주소 범위를 구성합니다. 호스트 풀입니다.
6단계. VTEP의 SVI 컨피그레이션에서 공유 IP 주소를 제외합니다. 이 예에서 인터페이스 VLAN 10의 주소는 IP.10.10.1/24입니다.
경고: SVI(또는 기본 게이트웨이)에서 IP 주소를 제외하지 않으면 IP 주소가 중복되어 트래픽 전달에 영향을 줄 수 있습니다.
LEAF-1# show running-config interface vlan 10
<snip>
interface Vlan10
no shutdown
vrf member tenant-a
no ip redirects
ip address 10.10.10.1/24
no ipv6 redirects
fabric forwarding mode anycast-gateway
ip dhcp relay address 10.10.10.150
ip dhcp relay source-interface loopback100
7단계. IP 주소의 임대 기간을 구성합니다. 이는 갱신 전에 호스트가 할당된 IP 주소를 사용할 수 있는 시간을 나타냅니다.
8단계. 예, 지금 이 옵션을 구성합니다.
9단계. 기본 게이트웨이 IP 주소를 구성합니다.
10단계. 도메인 이름 및 DNS 서버를 구성합니다.
11단계. 해당되는 경우 WINS 서버를 구성합니다. 정보가 알려지지 않은 경우 이를 건너뛸 수 있습니다.
12단계. 예, 지금 이 범위를 활성화하겠습니다.를 선택합니다.
1단계. IPv4를 마우스 오른쪽 버튼으로 클릭하고 IPv4Scope를 선택합니다.
2단계. 이름 및 설명을 작성합니다. 이 예에서 name은 루프백 주소가 있는 서브넷에 사용되는 서브넷입니다.
IPte: 루프백은 VxLAN 테넌트용 VxLAN 패브릭 전체에서 루프백 고유 IP 주소를 사용합니다. 이는 IPv4 address-famIPv4에 있는 해당 테넌트의 VRF 내 BGP에서 BGP L2VPN EVPN 경로 재배포에서 광고해야 합니다
LEAF-1# show running-config interface loopback 100
<snip>
interface loopback100
vrf member tenant-a
ip address 172.16.10.8/32
3단계. IP 주소 범위IP를 구성합니다. 루프백 풀입니다.
4단계. 제외를 구성합니다(DHCP 서버가 이 서브넷에 속하는 IP 주소를 임대하기 때문에 선택 사항).
5단계. 리스 기간을 건너뛰고 다음을 클릭합니다.
6단계. No(아니요)를 선택합니다. 나중에 이 옵션을 구성합니다.
7단계. Finish(마침)를 클릭합니다.
8단계. 생성된 범위를 마우스 오른쪽 버튼으로 클릭하고 activate(활성화)를 선택합니다.
1단계. IPv4를 마우스 오른쪽 버튼으로 클릭하고 New Superscope(새 대범위)를 선택합니다.
2단계. Next(다음)를 클릭합니다.
3단계. 대범위 이름을 작성합니다.
4단계. VxLAN Fabric에 속하는 모든 범위를 선택합니다.
5단계. VxLAN Fabric에 속하는 모든 범위를 선택합니다.
6단계. 모든 VxLAN 패브릭 대범위가 제대로 되어 있는지 확인하고 Finish(마침)를 클릭합니다.
1단계. 호스트 범위 내에서 Policies (last option)(정책(마지막 옵션))를 마우스 오른쪽 버튼으로 클릭하고 New Policy(새 정책)를 클릭합니다.
2단계. 이름과 설명을 입력하고 다음을 클릭합니다.
참고: 이 예에서는 VNI 101010 기반VNI Remote-ID(옵션 82의 매개변수)에 대해 리프-1의 호스트에 대해 IP 주소 지정 규칙을 선택하도록 정책이 생성됩니다.
3단계. Add(추가)를 클릭합니다. Criteria(기준)에서 Relay Agent Information(릴레이 에이전트 정보)을 선택합니다. 연산자에서 같음을 선택합니다. 그런 다음 에이전트 원격 ID를 선택하고 값을 입력합니다. OK(확인)를 클릭하고 Next(다음)를 클릭합니다.
참고: 원격 ID는 SVII가 연결된 SVI의 MAC 주소에서 가져옵니다.
팁: 여러 Remote-ID(또는 VTEP)에 정책을 적용하려면 조건을 추가하고 AND 대신 OR을 선택합니다.
LEAF-1# show interface vlan 10
Vlan10 is up, line protocol is up, autostate enabled
Hardware is EtherSVI, address is 707d.b9b8.4daf <<<<
Internet Address is 10.10.10.1/24
<snip>
4단계. ID로 선택한 VTEP에서 기존 IP가 사용할 수 있는 IP 주소 지정을 구성한 다음 Next(다음)를 클릭합니다.
참고: 이 예에서는 Leaf-1에 연결된 가상 머신이 하나만 있으므로 IP 주소 하나만 IPd가 필요합니다. 여기에 두 번째 IP 주소가 추가됨IPn 경우 다른 호스트가 연결됩니다.
5단계. DCHP Standard Option(DCHP 표준 옵션)에서 003 Router(003 라우터) 왼쪽에 있는 상자를 선택합니다. 그런 다음 이 정책에 속하는 호스트의 기본 게이트웨이 IP 주소를 쓰고 Add(추가)를 누릅니다. Next(다음)를 클릭합니다.
주의: 옵션을 두 개 이상 선택할 수 있지만 입력할 값을 모르는 경우에는 선택하지 마십시오. 컨피그레이션이 일관되지 않거나 잘못된 경우 예기치 않은 동작이 발생할 수 있습니다.
6단계. 정책 조건을 확인하고 Finish(마침)를 클릭합니다.
LEAF-1에서 검색 수신 | LEAF-1에서 디스커버리 전송 |
팁: 두 번 클릭하면 이미지가 확대됩니다.
SPINE에서 검색 수신 | SPINE으로 검색 전송 |
LEAF-1-vPC에서 검색 수신 | LEAF-1-vPC에서 검색 전송 |
참고: LEAF-2-vPC가 Discovert 패킷을 수신하지만 이는 스위칭된 것일 뿐입니다. 대상 MAC 주소는 DHCP 서버에 속합니다.
LEAF-2-vPC에서 받은 제안 | LEAF-2-vPC로 전송 |
SPINE에서 받은 제안 | SPINE으로 제안 보내기 |
LEAF-1에서 받은 제안 | LEAF-1에서 전송 제안 |
LEAF-1에서 요청 수신 | LEAF-1로 요청 전송 |
스파인 시 요청 수신 | SPINE으로 요청 보내기 |
LEAF-2-vPC에 receivePCd 요청 | vPCAF-2-vPC에서 요청 보내기 |
LEAF-2-vPC에서 받은 ACK | LEAF-2-vPC에서 ACK 전송 |
SPINE에서 ACK 수신 | SPINE으로 ACK 전송 |
LEAF-1에서 수신된 ACK | LEAF-1에서 ACK 전송 |
개정 | 게시 날짜 | 의견 |
---|---|---|
1.0 |
29-Apr-2024 |
최초 릴리스 |