Inleiding
Dit document beschrijft het proces om routekaart tussen Global Routing Table (GRT) en VRF te configureren met Cisco IOS® XR-software.
Voorwaarden
Vereisten
Cisco raadt kennis van de volgende onderwerpen aan:
- Kennis van basis IP-routing
- Kennis van Cisco IOS en Cisco IOS XR-opdrachtregel
Gebruikte componenten
Deze procedure is niet beperkt tot enige softwarerelease in Cisco IOS XR. Daarom kunnen alle releases worden gebruikt om de volgende stappen te voltooien.
De informatie in dit document is gebaseerd op de volgende software- en hardware-versies:
- Router met Cisco IOS XR-software
- Router met Cisco IOS-software
De informatie in dit document is gebaseerd op de apparaten in een specifieke laboratoriumomgeving. Alle apparaten die in dit document worden beschreven, hadden een opgeschoonde (standaard)configuratie. Als uw netwerk live is, moet u zorgen dat u de potentiële impact van elke opdracht begrijpt.
Achtergrondinformatie
Het doel van deze demonstratie is de configuratie voor routelekkage tussen globale routetabel en vrf
routetabel op Cisco IOS XR.
Topologie
Eerste verificatie
Interface- en statische routeconfiguratie
ASR 9901-1 router
RP/0/RSP0/CPU0:ASR9901-1#show run interface gi0/0/0/0 Wed Oct 19 15:21:21.122 UTC interface GigabitEthernet0/0/0/0 cdp vrf ORANGE ipv4 address 192.168.10.1 255.255.255.0 !
RP/0/RSP0/CPU0:ASR9901-1#show run router static Tue Feb 7 19:24:42.730 UTC router static vrf ORANGE address-family ipv4 unicast 172.16.20.0/24 192.168.10.2
ASR 9901-2 router
RP/0/RSP0/CPU0:ASR9901-2#show run int gi0/0/0/0
Wed Oct 19 15:40:18.599 UTC
interface GigabitEthernet0/0/0/0
cdp
vrf ORANGE
ipv4 address 192.168.10.2 255.255.255.0
!
RP/0/RSP0/CPU0:ASR9901-2#show run int gi0/0/0/6
Wed Oct 19 15:41:08.593 UTC
interface GigabitEthernet0/0/0/6
cdp
ipv4 address 172.16.20.1 255.255.255.0
!
CISCO 2911-3
CISCO2911-3#show run interface gigabitEthernet0/1
Building configuration...
Current configuration : 100 bytes
!
interface GigabitEthernet0/0
ip address 172.16.20.2 255.255.255.0
duplex auto
speed auto
end
CISCO2911-3#show run | section ip route
ip route 192.168.10.0 255.255.255.0 172.16.20.1
Test connectiviteit met ping, bijvoorbeeld, ASR9901-1 kan ASR 9901-2 pingen op VRF ORANGE.
RP/0/RSP0/CPU0:ASR9901-1#ping vrf ORANGE 192.168.10.2
Wed Oct 19 15:57:50.548 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms
ASR 9901-2 kan Cisco 291-3 op standaard-Vrf (GRT) pingen.
RP/0/RSP0/CPU0:ASR9901-2#ping 172.16.20.2
Wed Oct 19 15:58:05.961 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
Als u probeert de bereikbaarheid te testen van Subnet 192.168.10.0/24 op ASR9K-1 (VRF ORANGE) naar Subnet 172.16.20.0/24 op router 2911, moet deze test mislukken omdat er geen configuratie is geïmplementeerd op ASR9K-2 om de connectiviteit tussen VRF ORANGE en GRT te voltooien.
RP/0/RSP0/CPU0:ASR9901-1#ping 172.16.20.2 vrf ORANGE
Wed Oct 19 19:45:11.801 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Configuratie
Stap 1. Configureer een BGP-proces in ASR9K-2. Dit is de router die het routelek uitvoert en waar de configuratie moet worden toegepast. Naast de creatie van het BGP proces, moet u sommige netwerkverklaringen gebruiken om ervoor te zorgen dat de prefixes die u van plan bent om te lekken in de overeenkomstige BGP lijst worden geïnstalleerd:
RP/0/RSP0/CPU0:ASR9901-2#show run router bgp
Wed Oct 19 20:21:55.118 UTC
router bgp 100
bgp router-id 10.10.10.10
address-family ipv4 unicast
network 172.16.20.0/24
!
address-family vpnv4 unicast
!
vrf ORANGE
rd 100:100
address-family ipv4 unicast
network 192.168.10.0/24
!
!
!
RP/0/RSP0/CPU0:ASR9901-2#
Zoals u kunt zien, is er geen noodzaak om een BGP-buurt te maken, BGP is nodig om deze prefixes in de BGP-tabel te plaatsen.
Stap 2. Configureer het routebeleid, dit beleid is bedoeld om u te helpen filteren welke voorvoegsels mogen worden uitgelekt. In dit voorbeeld worden het routebeleid GLOBAL-2-VRF en het routebeleid VRF-2-GLOBAL gebruikt.
RP/0/RSP0/CPU0:ASR9901-2#show run route-policy GLOBAL-2-VRF
Wed Oct 19 20:37:56.548 UTC
route-policy GLOBAL-2-VRF
if destination in (172.16.20.0/24) then
pass
endif
end-policy
!
RP/0/RSP0/CPU0:ASR9901-2#show run route-policy VRF-2-GLOBAL
Wed Oct 19 20:38:10.538 UTC
route-policy VRF-2-GLOBAL
if destination in (192.168.10.0/24 le 32) then
pass
endif
end-policy
!
RP/0/RSP0/CPU0:ASR9901-2#
Stap 3. Configureer de VRF en pas het routebeleid toe dat bij de vorige stap is gemaakt met de opdrachten importeren van standaard-vrf routebeleid <beleidsnaam> en exporteren naar standaard-vrf routebeleid <beleidsnaam> zoals in de volgende uitvoer:
RP/0/RSP0/CPU0:ASR9901-2#show run vrf ORANGE
Wed Oct 19 20:40:38.851 UTC
vrf ORANGE
address-family ipv4 unicast
import from default-vrf route-policy GLOBAL-2-VRF
import route-target
100:100
!
export to default-vrf route-policy VRF-2-GLOBAL
export route-target
100:100
!
!
!
RP/0/RSP0/CPU0:ASR9901-2#
Definitieve verificatie
Zodra de vorige configuratie is vastgelegd, kunt u de bereikbaarheid van subnetnet 192.168.10.0/24 op ASR9K-1 (VRF ORANGE) aan subnetnet 172.16.20.0/24 op router 2911 verifiëren, die aanvankelijk faalde. Echter, met de juiste configuratie, deze ping test is nu succesvol:
RP/0/RSP0/CPU0:ASR9901-1#ping 172.16.20.2 vrf ORANGE
Wed Oct 19 22:07:47.897 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms
RP/0/RSP0/CPU0:ASR9901-1#
A debug ip icmp
geconfigureerd op de router 2911 kan ook helpen te verifiëren of de router het echoantwoord terugstuurt naar ASR9K-1:
CISCO2911-3#debug ip icmp
ICMP packet debugging is on
CISCO2911-3#
CISCO2911-3#
*Oct 19 21:34:20.069: ICMP: echo reply sent, src 172.16.20.2, dst 192.168.10.1, topology BASE, dscp 0 topoid 0
*Oct 19 21:34:20.073: ICMP: echo reply sent, src 172.16.20.2, dst 192.168.10.1, topology BASE, dscp 0 topoid 0
*Oct 19 21:34:20.077: ICMP: echo reply sent, src 172.16.20.2, dst 192.168.10.1, topology BASE, dscp 0 topoid 0
*Oct 19 21:34:20.077: ICMP: echo reply sent, src 172.16.20.2, dst 192.168.10.1, topology BASE, dscp 0 topoid 0
*Oct 19 21:34:20.081: ICMP: echo reply sent, src 172.16.20.2, dst 192.168.10.1, topology BASE, dscp 0 topoid 0
CISCO2911-3#
Een andere verificatie is om te controleren of de prefixes in de RIB- en BGP-tabellen verschijnen. In dit voorbeeld toont de GRT of default-vrf de volgende informatie:
RP/0/RSP0/CPU0:ASR9901-2#show route
Wed Oct 19 22:15:03.930 UTC
Codes: C - connected, S - static, R - RIP, B - BGP, (>) - Diversion path
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
U - per-user static route, o - ODR, L - local, G - DAGR, l - LISP
A - access/subscriber, a - Application route
M - mobile route, r - RPL, t - Traffic Engineering, (!) - FRR Backup path
Gateway of last resort is not set
C 10.88.174.0/24 is directly connected, 1d20h, MgmtEth0/RSP0/CPU0/0
L 10.88.174.223/32 is directly connected, 1d20h, MgmtEth0/RSP0/CPU0/0
L 10.10.10.10/32 is directly connected, 04:33:44, Loopback100
C 172.16.20.0/24 is directly connected, 07:03:18, GigabitEthernet0/0/0/6
L 172.16.20.1/32 is directly connected, 07:03:18, GigabitEthernet0/0/0/6
B 192.168.10.0/24 is directly connected, 03:02:21, GigabitEthernet0/0/0/0 (nexthop in vrf ORANGE)
RP/0/RSP0/CPU0:ASR9901-2#
RP/0/RSP0/CPU0:ASR9901-2#show ip bgp
Wed Oct 19 22:15:13.069 UTC
BGP router identifier 10.10.10.10, local AS number 100
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 5
BGP main routing table version 5
BGP NSR Initial initsync version 3 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs
Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 172.16.20.0/24 0.0.0.0 0 32768 i *> 192.168.10.0/24 0.0.0.0 0 32768 i
Processed 2 prefixes, 2 paths
RP/0/RSP0/CPU0:ASR9901-2#
Nu, de volgende output toont de informatie die voor VRF ORANGE wordt getoond:
RP/0/RSP0/CPU0:ASR9901-2#show route vrf ORANGE
Wed Oct 19 22:21:24.559 UTC
Codes: C - connected, S - static, R - RIP, B - BGP, (>) - Diversion path
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
U - per-user static route, o - ODR, L - local, G - DAGR, l - LISP
A - access/subscriber, a - Application route
M - mobile route, r - RPL, t - Traffic Engineering, (!) - FRR Backup path
Gateway of last resort is not set
B 172.16.20.0/24 is directly connected, 01:43:49, GigabitEthernet0/0/0/6 (nexthop in vrf default) C 192.168.10.0/24 is directly connected, 07:06:38, GigabitEthernet0/0/0/0
L 192.168.10.2/32 is directly connected, 07:06:38, GigabitEthernet0/0/0/0
RP/0/RSP0/CPU0:ASR9901-2#
RP/0/RSP0/CPU0:ASR9901-2#
RP/0/RSP0/CPU0:ASR9901-2#show bgp vrf ORANGE
Wed Oct 19 22:21:34.887 UTC
BGP VRF ORANGE, state: Active
BGP Route Distinguisher: 100:100
VRF ID: 0x60000003
BGP router identifier 10.10.10.10, local AS number 100
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000012 RD version: 9
BGP main routing table version 9
BGP NSR Initial initsync version 4 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:100 (default for vrf ORANGE)
*> 172.16.20.0/24 0.0.0.0 0 32768 i *> 192.168.10.0/24 0.0.0.0 0 32768 i
Processed 2 prefixes, 2 paths