Introdução
Este documento descreve como solucionar problemas do Customer Voice Portal (CVP) Call Studio quando não é possível importar projetos do Call Studio 10.5 para o Call Studio 11.0 ou o Call Studio 11.5.
Pré-requisitos
Requisitos
A Cisco recomenda que você tenha conhecimento destes tópicos:
- Estúdio de chamadas CVP
- Servidor de chamadas CVP
As informações neste documento são baseadas nestas versões de software:
- Servidor CVP 11.5
- CVP Call Studio 11.5
Problema
Os scripts do Call Studio foram desenvolvidos no Call Studio versão 10.5. Quando ele é importado no CallStudio versão 11.0/11.5, para alguns scripts, a importação falhou e mostrou uma mensagem de erro.
Mensagem de erro
Esta mensagem de erro mostra quando o script do Call Studio é importado "Falha na importação do projeto do Call Studio: O projeto contém o elemento Início da chamada com o mesmo nome de outro elemento no fluxo principal. A partir do Call Studio 10.5(1), o nome do elemento Início da chamada deve ser exclusivo. Renomeie usando a versão anterior do Call Studio e tente novamente".
Possíveis causas
A partir do Call Studio 11.0, nenhum elemento pode ter o mesmo nome que o elemento ‘início da chamada’.
Esta é a causa raiz da mensagem de erro que você pode ver para a importação dos aplicativos mais antigos, que costumava permitir o mesmo.
Solução
Ação recomendada
Etapa 1. Importe o projeto problemático para o Call Studio 11.5 como um projeto regular (não um projeto de estúdio de chamada). O projeto foi importado com êxito.
Etapa 2. Procure o nome do elemento start-of-call do aplicativo.
Etapa 3. Se você encontrar mais de uma ocorrência dela em qualquer página do aplicativo, essa será a causa raiz do erro de importação.
Etapa 4. Na página principal, crie um novo elemento Page Entry ao lado do elemento start-of-call.
Etapa 5. Aponte o estado de saída desse novo elemento para o mesmo elemento para o qual o elemento start-of-call aponta.
Etapa 6. Faça as ocorrências dos conectores de entrada de página, com o mesmo nome do elemento start-of-call, para apontar para o novo elemento Page Entry criado na página principal.
Etapa 7. O aplicativo agora é compatível com o Call Studio 11.0 / 11.5, salve-o e exporte-o.
Etapa 8. Exclua o projeto importado e importe novamente como um projeto existente do Call Studio.
Observação: esse defeito CSCvb95979 foi aberto para o problema.