简介
本文档介绍有关特定场景的详细信息,在该场景中,您将看到提供的呼叫少于在统一情报中心(CUIC)报告中应答的呼叫。
先决条件
要求
Cisco 建议您了解以下主题:
- Cisco Unified Intelligence Center与ICM数据库集成(用于报告)
- 核心ICM组件(路由器、记录器、PG和AW/HDS)
使用的组件
本文档中的信息基于以下软件版本:
本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您的网络处于活动状态,请确保您了解所有命令的潜在影响。
问题
在CUIC中,如果运行历史所有字段报告,将显示多个字段,其中一些字段是已受理的呼叫和已应答的呼叫。在此报告和多个其他报告中,预计所提供的呼叫将等于或多于已应答的呼叫。尽管在这个非常独特的场景中,您会看到应答的呼叫实际上比已受理的呼叫多。
解决方案
有关数据写入方式的步骤
- ICM路由器收到新呼叫并生成此呼叫的InvokeID。
- 路由器向设备目标发送预先指示,然后将呼叫标记为“已受理”。
- PG OPC定期(默认情况下,间隔为3秒)将代理状态更新发送到ICM路由器。ICM路由器将根据“InvokeID”和座席“通话”状态增加“已应答”计数。
- 呼叫完成后,OPC会将TCD记录刷新到ICM路由器,然后路由器将“已处理”计数增加1。
注意:请注意,TCD从OPC刷新到路由器的频率取决于PG服务器中的注册表MaxNumTCDBuffered。如果呼叫量很高,TCD刷新将更频繁。
问题原因
- 总之,路由器在将呼叫路由到设备目标时会生成“CallsOffered”计数。
- CallsAnswered计数由定期座席状态更新触发,而CallsHandled计数基于呼叫结束时的TCD记录。
- 这里需要注意的是,当呼叫非常短(少于3秒)时,TCD刷新将在座席状态更新之前到达。
- 因此,Call_Type_Interval表的CallsAnswered计数将少于CallsHandled计数。
总结;已受理呼叫==已应答呼叫+已放弃呼叫//此陈述不能完全正确,需要更多关联来自skillgroup表的数据。
解决方法
解决方法“可能”是查看skillgroup相关的半小时/间隔表以进行报告或增加TCDflush间隔(除非BU确定迫切需要执行此操作,否则不建议执行此特定步骤)。 如果CUIC库存报告在此并非真正有益,并且客户希望使用自定义报告,则很遗憾,这超出了TAC的故障排除情况。因此,我们建议您与思科设备团队协调更多查询。