简介
本文档介绍如何使用或不使用环回地址配置iBGP和eBGP。
先决条件
要求
思科建议您先了解下列主题的相关知识:
使用的组件
本文档不限于特定的软件和硬件版本。
本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您的网络处于活动状态,请确保您了解所有命令的潜在影响。
规则
有关文档规则的详细信息,请参阅 Cisco 技术提示规则。
背景信息
BGP 是一种 Exterior Gateway Protocol (EGP),用于在 TCP/IP 网络中执行域间路由。在交换BGP更新之前,BGP路由器需要与每个BGP对等体建立连接(在TCP端口179上)。如果两个 BGP 对等体位于不同的自治系统 (AS) 中,则二者之间的 BGP 会话将视为外部 BGP (eBGP) 会话。如果两个 BGP 对等体位于同一自治系统中,则将二者之间的 BGP 会话视为内部 BGP (iBGP) 会话。
默认情况下,使用最接近对等路由器的接口的IP地址建立对等体关系。但是,当使用neighbor update-source命令时,可以指定任何工作接口(包括环回接口)以建立TCP连接。这种与环回接口对等的方法非常有用,因为当BGP对等体之间存在多条路径时,它无法关闭BGP会话。否则,如果用于建立会话的物理接口断开,则会断开BGP会话。除此之外,它还允许运行 BGP 的之间有多条链路的路由器在可用路径中执行负载均衡。
本文档中的配置示例针对 iBGP 和 eBGP,包括有环回地址和无环回地址两种情况。
配置
本节包含以下配置示例:
本部分提供有关如何配置本文档所述功能的信息。
注意:要寻找关于用于本文的指令的其他信息,请使用命令查找工具。只有思科注册用户才能访问思科内部信息和工具。
网络图
本文档使用以下网络设置:
iBGP 配置
在此配置中,两台路由器都处于inAS 400中。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed.
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 400
!--- Enables BGP for the autonomous !--- system 400.
neighbor 10.10.10.2 remote-as 400
!--- Specifies a neighbor 10.10.10.2 !--- in the remote AS 400, making !--- this an iBGP connection.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
neighbor 10.10.10.1 remote-as 400
!-- Output suppressed.
end |
eBGP 配置
在此配置中,路由器R1-AGS位于AS 300中,而路由器R6-2500位于AS 400中。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 300
!--- Enables BGP for the autonomous !--- system 300.
neighbor 10.10.10.2 remote-as 400
!--- Specifies a neighbor 10.10.10.2 !--- in the remote AS 400, making !--- this an eBGP connection.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
neighbor 10.10.10.1 remote-as 300
!-- Output suppressed.
end |
使用eBGP时,对等体必须直接连接。如果它们不是直接连接的,则必须使用neighbor ebgp-multihop 命令,并且必须存在通过IGP或静态路由到达对等体的路径,以便路由器建立邻居关系。在先前的配置中,R1-AGS路由器属于AS 300,而R6-2500路由器属于AS 400。
具有环回地址的 iBGP 配置
如本部分所示,您可以使用环回地址(或任何其他操作接口)配置iBGP。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 300
neighbor 10.2.2.2 remote-as 300
neighbor 10.2.2.2 update-source Loopback0
!--- This command specifies that the TCP !--- connection with the specified external !--- peer should be established with the !--- address on the loopback interface.
!
ip route 10.2.2.2 255.255.255.255 10.10.10.2
!--- This static route ensures that the !--- remote peer address used for peering !--- is reachable.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 300
neighbor 10.1.1.1 remote-as 300
neighbor 10.1.1.1 update-source Loopback0
!
ip route 10.1.1.1 255.255.255.255 10.10.10.1
!-- Output suppressed.
end |
具有环回地址的 eBGP 配置
您还可以使用环回地址(或任何其他操作接口)配置eBGP,如本部分所示。以这种方式使用环回接口可保证具有多个路径的网络中的可达性,详细信息请参阅使用环回地址作为BGP邻居的负载共享。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 300
neighbor 10.2.2.2 remote-as 400
neighbor 10.2.2.2 ebgp-multihop 2
!--- This command changes the ttl value in !--- order to allow the packet to reach the !--- external BGP peer which is not directly !--- connected or is with an interface other !--- than the directly connected interface.
neighbor 10.2.2.2 update-source Loopback0
!--- This command specifies that the TCP !--- connection with the external BGP !--- peer should be established with the !--- address on the loopback interface.
ip route 10.2.2.2 255.255.255.255 10.10.10.2
!--- This static route ensures that the !--- remote peer address used for peering !--- is reachable.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
neighbor 10.1.1.1 remote-as 300
neighbor 10.1.1.1 ebgp-multihop 2
neighbor 10.1.1.1 update-source Loopback0
!
ip route 10.1.1.1 255.255.255.255 10.10.10.1
!-- Output suppressed.
end |
验证
您可以参考下列部分中的信息来确保您的配置正常工作。输出解释器工具支持某些show命令(只限于注册用户),通过它可以查看show命令输出的分析。
验证 iBGP 配置
使用show ip bgp neighbors 命令显示有关TCP和边界网关协议(BGP)连接的信息,并验证是否建立了BGP对等体。show ip bgp neighbors 命令的输出显示BGP状态为Established,表示已成功建立BGP对等体关系。
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2, remote AS 400, internal link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:04:20
BGP table version 1, neighbor version 1
R1-AGS#
show ip bgp neighbors命令先前已用到修饰符| include BGP。这样会使命令输出更可读,并且仅显示相关部分。
此外,show ip bgp summary 命令还可用于显示所有BGP连接的状态,如下所示。
R1-AGS(9)#show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 400
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.2 4 400 3 3 1 0 0 00:00:26 0
验证 eBGP 配置
使用show ip bgp neighbors 命令显示有关TCP和边界网关协议(BGP)连接的信息,并验证是否建立了BGP对等体。show ip bgp neighbors 命令的输出显示BGP状态为Established,表示已成功建立BGP对等体关系。
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2, remote AS 400, external link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:00:17
BGP table version 1, neighbor version 1
此外,show ip bgp summary 命令还可用于显示所有BGP连接的状态,如下所示。
R1-AGS(9)#show ip bgp summary
BGP router identifier 10.10.10.1, local AS number 300
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.2 4 400 3 3 1 0 0 00:00:26 0
验证具有环回地址的 iBGP 配置
使用show ip bgp neighbors 命令显示有关TCP和边界网关协议(BGP)连接的信息,并验证是否建立了BGP对等体。show ip bgp neighbors 命令的输出显示BGP状态为Established,表示已成功建立BGP对等体关系。
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.2.2.2, remote AS 300, internal link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:00:28
BGP table version 1, neighbor version 1
R1-AGS#
此外,show ip bgp summary 命令还可用于显示所有BGP连接的状态,如下所示。
R1-AGS(9)#show ip bgp summary
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.2.2.2 4 400 3 3 1 0 0 00:00:26 0
验证具有环回地址的 eBGP 配置
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.2.2.2, remote AS 400, external link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:00:16
BGP table version 1, neighbor version 1
External BGP neighbor may be up to 2 hops away.
此外,show ip bgp summary 命令还可用于显示所有BGP连接的状态,如下所示。
R1-AGS(9)#show ip bgp summary
BGP router identifier 10.1.1.1, local AS number 300
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.2.2.2 4 400 3 3 1 0 0 00:00:26 0
故障排除
有关详细信息,请参阅BGP邻居为何在空闲、连接和活动状态之间切换和排除常见BGP问题。
相关信息