本文档介绍如何将Cisco IOS®第2层交换配置转换为Cisco IOS XR第2层虚拟专用网络(L2VPN)配置。
本文档没有任何特定的要求。
本文档不限于特定软件,而是限于使用以太网虚拟电路(EVC)型号配置L2VPN的9000系列聚合服务路由器(ASR)相关硬件版本。ASR 9000系列路由器使用EVC型号,而运行Cisco IOS XR的运营商级路由系统(CRS)路由器不使用。
本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。
ASR 9000系列路由器不遵循IEEE模型的第2层(L2)配置,最明显的是802.1Q和802.1AD。而是使用EVC模型。EVC模式允许Cisco IOS XR以新的方式利用当前802.1Q VLAN标记。传统上,VLAN标记定义分类、VLAN、转发以及执行MAC地址查找要使用的内容可寻址存储器(CAM)表。通过EVC模型,此概念被分离,以便允许更大的灵活性和更高的规模。EVC模型消除了思科IOS对最大4096个VLAN的限制。
EVC使用以下构建基块:
ASR 9000系列路由器上的Cisco IOS XR使用以太网虚拟电路(EVC)模型。EVC模型没有中继、VLAN接口或交换机虚拟接口(SVI)的概念。Cisco IOS中的中继、VLAN接口和SVI必须通过子接口、L2VPN BD和网桥虚拟接口(BVI)转换为Cisco IOS XR配置。某些Cisco IOS用户首次迁移到Cisco IOS XR时,EVC型号可能是新产品。
Cisco IOS XR上的配置包括三个步骤:
本示例说明如何将配置从Cisco IOS转换为Cisco IOS XR。
interface GigabitEthernet3/13
switchport
switchport access vlan 4
speed 1000
duplex full
!
interface GigabitEthernet3/14
switchport
switchport access vlan 130
speed 1000
duplex full
!
interface GigabitEthernet3/15
switchport
switchport access vlan 133
speed 1000
duplex full
!
interface TenGigabitEthernet13/3
description IOS Trunk
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1*,4,130,133
switchport mode trunk
no ip address
!
interface Vlan 4
ip address 10.10.4.1 255.255.255.0
interface Vlan 130
ip address 10.10.130.1 255.255.255.0
!
*Vlan 1 is the native vlan
创建EFP接口。Cisco IOS XR为EFP和EVC配置实施结构化CLI。要配置EFP,请使用以下接口配置命令:
interface GigabitEthernet 0/0/0/1
!
interface GigabitEthernet 0/0/0/1.1 l2transport
encapsulation dot1q untagged **
!
interface GigabitEthernet 0/0/0/1.4 l2transport
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric
interface GigabitEthernet 0/0/0/2
!
interface GigabitEthernet 0/0/0/2.130 l2transport
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet 0/0/0/3
!
interface GigabitEthernet 0/0/0/3.133 l2transport
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0
!
interface tengig0/0/0/0.4 l2transport
no ip address
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.130 l2transport
no ip address
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.133 l2transport
no ip address
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!
要添加本征VLAN 1,请取消标记流量,并使用dot1q untagged encapsulation创建l2transport子接口。如果端口连接到IOS设备中为switchport access配置的端口,请在l2transport接口或子接口下使用encapsulation dot1q untagged命令。
示例如下:
IOS:
interface Gigabitethernet 1/1
switchport
switchport access vlan 3
IOSXR:
interfage GigabitEthernet 0/1/1/1.1 l2transport
encapsulation dot1q untagged
创建EFP后,可以创建BVI接口并将其添加到BD。BVI接口用于在Cisco IOS中容纳接口VLAN。
interface BVI4
ipv4 address 10.10.4.1 255.255.0.0
!
interface BVI130
ipv4 address 10.130.1.1 255.255.0.0
!
BVI接口编号不需要匹配VLAN标识符。L2传输接口的子接口编号也是如此。但是,在本例中,为了清楚起见,BVI编号匹配dot1q标记以及EFP子接口编号。
在本示例中,创建l2-VPN BD以将EFP和BVI桥接在一起:
l2vpn
bridge group VLAN4
bridge-domain VLAN4
interface ten0/0/0/0.4
!
interface GigabitEthernet 0/0/0/1.4
!
routed interface bvi4
!
!
bridge-domain VLAN130
interface ten0/0/0/0.130
!
interface GigabitEthernet 0/0/0/2.130
!
routed interface bvi130
!
!
bridge-domain VLAN133
interface ten0/0/0/0.133
!
interface GigabitEthernet 0/0/0/3.133
!
!
!
!
网桥组(BG)是一种非功能配置层次结构,将多个BD绑定到同一功能组的一部分。其功能与创建多个单独组及其域类似,与创建多个域的一个组不同。
下表列出了Cisco IOS中可用的其他命令,以及在BD下配置的Cisco IOS XR中的等效命令:
IOS | IOS XP |
---|---|
switchport block unicast} | flooding unknown-unicast disable |
switchport port-security maximum | mac limit maximum(范围为5-512000) |
switchport port-security violation | mac limit action(flood, no-flood, shutdown)mac limit notification(both, none, trap) |
mac address-table notification mac-move | 需要配置以下内容:mac secure action none mac secure logging |
switchport port-security mac-address | interface x mac limit max y static-mac-address H.H.H |
版本 | 发布日期 | 备注 |
---|---|---|
1.0 |
14-Feb-2014 |
初始版本 |