简介
本文档介绍如何安全地将文件从Cisco路由器和交换机复制到本地Windows/Linux/macOS PC。
先决条件
要求
Cisco建议您了解具有权限级别15访问设备的安全外壳(SSH)可达性。
使用的组件
本文档中的信息基于以下软件和硬件版本:
- 使用Cisco IOS® 17.3.5的Cisco C9300-24P交换机
- Windows 10操作系统
- RedHat Linux操作系统
本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您的网络处于活动状态,请确保您了解所有命令的潜在影响。
背景信息
本文档介绍了如何在不使用任何外部服务器或软件(如简单文件传输协议[TFTP]、文件传输协议[FTP]、安全文件传输协议[SFTP]或安全复制协议[SCP])的情况下将文件从Cisco路由器/交换机安全地复制到本地Windows/Linux/macOS PC的过程。
问题
有时,在安全环境中,很难通过TFTP/FTP/SFTP/SCP服务器将pcap、崩溃文件和Cisco IOS映像等文件从路由器和交换机复制到外部源。防火墙可能会在源设备和目的设备之间阻止上述任何协议使用的端口。
解决方案
在思科设备上启用SCP后,您可以将文件从没有任何服务器或应用程序的设备复制到本地PC。
以下是设备上所需的最低配置。
hostname Switch
!
interface GigabitEthernet0/0
ip address 10.197.249.101 255.255.255.0
no shut
!
ip route 0.0.0.0 0.0.0.0 10.197.249.1
!
aaa new-model
!
aaa authentication login default local
aaa authorization exec default local
!
ip domain name cisco.com
!
!--- key used in this example is 1024
!
crypto key generate rsa
!
username cisco privilege 15 secret 5 <redacted>
!
line vty 0 x
transport input ssh
login local
!
ip scp server enable
!--- you can disable the above command after copy is completed
!
end
!--- optional
!
ip ssh time-out 60
ip ssh authentication-retries 5
ip ssh version 2
!
在本地Windows/Mac/Linux上使用此命令从Cisco路由器/交换机复制文件:
scp username@<ip_address_of_the_device>:flash:/filename
Windows 10:
C:\Users\mmehtabu.CISCO>cd /
C:\>cd ios
C:\ios>dir
Volume in drive C has no label.
Volume Serial Number is xxxx-yyyy
Directory of C:\ios
05-01-2023 09.32 AM <DIR> .
05-01-2023 09.32 AM <DIR> ..
0 File(s) 0 bytes
2 Dir(s) 163,191,525,376 bytes free
C:\ios> scp cisco@10.197.249.101:flash:/mycap.pcap .
Password:
mycap.pcap 100% 33MB 105.8KB/s 05:19
Connection to 10.197.249.101 closed by remote host.
C:\ios>dir
Volume in drive C has no label.
Volume Serial Number is xxxx-yyyy
Directory of C:\ios
05-01-2023 09.39 AM <DIR> .
05-01-2023 09.39 AM <DIR> ..
05-01-2023 09.40 AM 1,606,582 mycap.pcap
1 File(s) 1,606,582 bytes
2 Dir(s) 163,182,600,192 bytes free
Linux:
[root@root0 ~]# pwd
/root
[root@root ~]# ls -l
total 1
drwxr-xr-x. 2 root root 6 Apr 6 2022 Pictures
[root@root ~]# scp cisco@10.197.249.101:flash:/mycap.pcap .
Password:
flash:/mycap.pcap 100% 45MB 2.9MB/s 00:15
[root@cpnr000 ~]# ls -l
total 1580
-rw-r--r--. 1 root root 1606582 Jan 5 09:47 mycap.pcap
drwxr-xr-x. 2 root root 6 Apr 6 2022 Pictures
MacOS有一个类似的命令:
scp username@<ip_address_of_the_device>:flash:/filename
相关信息