简介
本文档介绍如何在安装或升级Cisco Jabber for Windows时解决由永久注册表项引起的问题。
先决条件
要求
Cisco 建议您了解以下主题:
- 用于Windows的Cisco Jabber
- Microsoft Windows V7操作系统(32和64位)
- Microsoft Windows 10版操作系统(32和64位)
使用的组件
本文档不限于特定硬件或软件版本。
本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。
问题
当您尝试安装或升级Cisco Jabber for Windows 9.x或更高版本时,尝试失败,您收到以下错误消息:
Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical Support team
原因
通过Microsoft Installer(MSI)文件安装的程序在卸载密钥中包含一个条目,Windows Installer值为一(1)。 当“添加/删除程序”功能遇到此条目时,它会查看密钥名称并对其进行修改。然后,它会搜索在此位置以重排序的GUID命名的密钥:
HKLM >软件>类>安装程序>产品
由于注册表项已损坏,必须删除它。
解决方案
单击OK以收集Windows Installer日志;然后找到指向ARPPRouption的注册表,并查看哪个注册表受影响。
以下是Jabber安装日志的示例:
MSI (s) (00:68) [13:39:25:865]: Doing action: RemoveExistingProducts
Action 13:39:25: RemoveExistingProducts. Removing applications
Action start 13:39:25: RemoveExistingProducts.
RemoveExistingProducts: Application: {B63FA739-46CF-4270-B903-90F5698EDF39}, Command line: UPGRADINGPRODUCTCODE={F5C0DBF4-2D93-4A73-9AF3-E931AFF8BAF9} CLIENTPROCESSID=13016 CLIENTUILEVEL=0 REMOVE=ALL
MSI (s) (00:24) [13:39:25:880]: Unexpected or missing value (name: 'PackageName', value: '') in key 'HKLM\Software\Classes\Installer\Products\937AF36BFC6407249B30095F96E8FD93\SourceList'
CustomAction returned actual error code 1610 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (00:68) [13:39:25:880]: Note: 1: 1714 2: Cisco Jabber 3: 1610
MSI (c) (D8:B8) [13:39:28:589]: Doing action: setErrorUnknownError
Action 13:39:28: setErrorUnknownError.
Action start 13:39:28: setErrorUnknownError.
MSI (c) (D8:B8) [13:39:28:589]: PROPERTY CHANGE: Modifying ERROR_INSTALL property. Its current value is '0'. Its new value: '4'.
Action ended 13:39:28: setErrorUnknownError. Return value 1.
Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical support group. System Error 1610.
MSI (s) (00:68) [13:39:28:605]: Product: Cisco Jabber -- Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical support group. System Error 1610.
在客户端计算机中,单击“运行”>“重新编辑”并导航至以下位置:
HKLM >软件>类>安装程序>产品>937AF36BFC6407249B30095F96E8FD93 >源列表
删除密钥,重新启动计算机,然后重新启动安装或升级过程。
注意:访问计算机上的注册表项可能需要管理访问权限。