簡介
本文描述啟動Cisco Unified Contact Center Express(UCCX)指令碼編輯器10.5(1)版時遇到的問題。
問題
無法運行UCCX編輯器版本10.5(1)(CiscoUnifiedCXEditor.exe)。
症狀
啟動後,UCCX編輯器視窗出現的時間不到一秒,並且消失。應用程式嘗試啟動,但消失。
解決方案
為了解決此問題,您必須檢查CCX編輯器的檔案是否存在於資料夾中:C:\Program檔案(x86)\wfavvid_1051。要檢查此項目,請按一下右鍵「編輯器」圖示(快捷方式),然後導航到「屬性」(Properties)>「目標」(Target)。安裝資料夾應直接位於C:\Program files(x86)中。
有時,路徑可能不正確。例如:C:\Program Files(x86)\Cisco\Unified Serviceability\JRtmt\wfavvid_1051。
請採取以下步驟以解決此問題:
- 要在工作站上解除安裝CCX指令碼編輯器應用程式,請導航到控制面板>新增/刪除程式。
- 將Editor應用程式(以管理員身份運行)直接重新安裝到Program Files並明確定義路徑:C:\Program檔案(x86)\wfavvid_1051。
- 運行應用程式以進行測試。
根本原因
問題與安裝的預設位置(路徑)相關。 它會查詢硬編碼到該位置的檔案,如果未找到這些檔案,則不會啟動。預設情況下,CCX編輯器必須安裝在以下位置:C:\Program Files(x86)\wfavvid_1051。如果情況不正常,則編輯器將無法正確運行。為了測試此情況,如果您將wfavvid_1051資料夾複製到其他位置,可能會重新建立問題。
此外,如果以前在工作站上安裝過即時監控工具(RTMT),UCCX編輯器將提示使用者將其安裝在錯誤的路徑中:C:\Program Files(x86)\Cisco\Unified Serviceability\JRtmt\wfavvid_1051。
在錯誤位置安裝後,無法啟動編輯器。此時,應採取前面提到的步驟來解決問題。雖然存在一種變通方法,但已開啟了一個增強缺陷,以簡化和解決與安裝相關的問題:CSCur86817。