簡介
本文描述當Finesse Supervisor Desktop上顯示太多資訊時,Cisco Unified Contact Center Express(UCCX)遇到的問題,並描述該問題的解決方法。
必要條件
需求
思科建議您瞭解Finesse Desktop的UCCX版本10.0及更高版本。
採用元件
本文檔中的資訊基於UCCX版本10.0及更高版本和Finesse Desktop。
本文中的資訊是根據特定實驗室環境內的裝置所建立。文中使用到的所有裝置皆從已清除(預設)的組態來啟動。如果您的網路正在作用,請確保您已瞭解任何指令可能造成的影響。
問題
Finesse Supervisor Desktop在Finesse的Queue Data頁籤中的Voice CSQ Summary Report下顯示UCCX中配置的每個聯絡服務隊列(CSQ)的統計資訊。此報告是一個嵌入式即時資料小工具,可從思科統一情報中心(CUIC)獲取即時資訊。 主管還可以檢視從Finesse的「團隊資料」(Team Data)頁籤登入的所有座席,而不管座席分配給哪個團隊。
我們發現,只有部分主管能夠看到登入的所有隊列和代理。由於顯示的資訊過多,這將成為整個聯絡中心環境中的一個問題。
原因
之所以會出現此問題,是因為管理引擎可能也被配置為報告使用者。當主管成為「歷史報告」使用者時,也會將主管分配給AllUsers。ReportingUsers組,用於更改可訪問的集合清單(擴展範圍)。
在Finesse Supervisor Desktop的Queue Data頁籤中,從CUIC即時資料的Voice CSQ Summary Report、Voice CSQ Agent Detail Report和Agent Statistics Report提取資料。此時將顯示與主管範圍對應的CSQ條目,由於主管也是報告使用者,因此現在所有CSQ都是該條目。
在Finesse Supervisor Desktop的Team Data頁籤中,資料從CUIC即時資料的Agent Statistics Report中提取。此時將顯示與主管作用域相對應的座席,該座席現在全部為座席,因為主管也是報告使用者。
附註:預設情況下,主管僅有權訪問Cisco Unified Contact Center Express報告使用手冊10.6(1)中記錄的即時資料包告。
因應措施
附註:此問題會追蹤為思科錯誤ID CSCus17605下的增強功能要求。
此問題的解決方法縮小了Finesse Supervisor Desktop上顯示的統計資訊的範圍,其中包括通過Finesse Administration頁面修改XML佈局。您必須修改每個小工具的URL。以下是範例:
附註:不要從此部分複製和貼上XML代碼。以下是一個示例,對Finesse上的XML代碼所做的更改將逐個進行。
如果作為團隊「藍色」資源的主管希望檢視已分配團隊「藍色」和團隊「紅色」的CSQ的CSQ資料,但不檢視未分配給這兩個團隊的CSQ的其他CSQ資料,請在「團隊資源」(Team Resources)頁籤的「Finesse管理」(Finesse Administration)頁面上為團隊「藍色」(blue)編輯queueData URL,如本例所示。
<id>queueData</id>
<label>finesse.container.tabs.supervisor.queueDataLabel</label>
<columns>
<column>
<gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveData
Gadget.jsp?gadgetHeight=620&viewId_1=C8E2DB1610000140000000A60A4E5E6B&filterId_1
=VoiceIAQStats.esdName=CL%20blue,%20red&viewId_2=9A7A14CE10000140000000ED0A
4E5E6B&filterId_2=VoiceCSQDetailsStats.agentId=CL%20blue,%20red&compositeFilterId
=VoiceCSQDetailsStats.AgentVoiceCSQNames.agentVoiceCSQName=CL%20blue,%20red
&viewId_3=C8EF510810000140000000EB0A4E5E6B&filterId_3=VoiceIAQStats.esdName
=CL%20blue,%20red&viewId_4=C8EE241910000140000000C30A4E5E6B&filterId_4
=VoiceIAQStats.esdName=CL%20blue,%20red</gadget>
同樣,如果作為團隊「藍色」資源的主管希望檢視團隊「藍色」和團隊「紅色」成員的團隊資料,但不檢視不屬於這兩個團隊的座席的其他團隊資料,請編輯團隊「藍色」的teamData URL,如本例所示。
<id>teamData</id>
<label>finesse.container.tabs.supervisor.teamDataLabel</label>
<columns>
<column>
<gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=620&viewId_1=7291DCB410000140000000890A4E5B33&filterId_1=
ResourceIAQStats.resourceId=CL%20blue,%20red&viewId_2=728283C210000140000000530A4E5B33
&filterId_2=ResourceIAQStats.resourceId=CL%20blue,%20red</gadget>
以下是關於此範例的一些重要說明:
- 當在URL中僅使用CL時,報表將包含主管具有許可權的所有集合的值。
- 在URL內使用CL%20<Team_Name>時,<Team_Name> 將替換為主管希望檢視其資料的團隊的實際名稱;因此,只顯示<Team_Name>的資料。URL中的<Team_Name>是一個佔位符,替換為Finesse在傳送到CUIC伺服器之前傳遞給CUIC小工具代碼的實際值。如果主管想要檢視多個團隊的資料,例如團隊數是「N」,則必須使用CL%20<Team_Name_1>,%20<Team_Name_2>,.....%20<Team_Name_N>。
- 在URL內使用CL%20blue(假設blue是實際的團隊名稱)時,僅顯示屬於blue集合的值。
- 在URL內使用CL%20blue時,%20red(假設blue 和red是實際的組名),僅顯示屬於blue集合和red集合的值。
您還必須將這些修改應用到任何其他小工具。有關小工具URL以及即時資料的小工具定義的詳細資訊,請參閱Cisco Unified CCX管理指南10.6版。
附註:使用此解決方法時應仔細評估,因為修改必須在團隊級別的案頭佈局上完成。在團隊級別進行編輯時,可以覆蓋系統預設佈局。
附註:可以使用帶空格的團隊名稱,但是XML佈局必須設定為%20才能表示空間。
功能簡介
UCCX 11.6中引入了一個新功能來完全解決此問題。此功能是透過思科錯誤ID CSCus17605下的增強功能要求新增的。
從UCCX 11.6開始,主管可以訪問其團隊的歷史報告,因此無需設定其他報告使用者角色。這樣,主管將只能在Finesse Live Data報告中看到其團隊,並且仍然可以訪問其團隊的歷史報告,而無需具有報告使用者角色。如果將報告使用者角色新增到任何使用者,則他們有權檢視所有報表中所有團隊的座席和CSQ,並可檢視Finesse即時資料包表中的所有座席和CSQ。