簡介
本文檔介紹如何在不使用下一跳的情況下在全局路由(GRT)和虛擬路由轉發(VRF)之間生成路由洩漏。
必要條件
需求
思科建議瞭解以下主題:
- 基本IP路由
- 開放最短路徑優先(OSPF)路由協定概念和術語
採用元件
本文件所述內容不限於特定軟體和硬體版本。
本文中的資訊是根據特定實驗室環境內的裝置所建立。文中使用到的所有裝置皆從已清除(預設)的組態來啟動。如果您的網路運作中,請確保您瞭解任何指令可能造成的影響。
背景資訊
使用靜態路由有助於全局路由表(GRT)和虛擬路由和轉發(VRF)表之間的路由洩漏。 這兩種方法都提供下一跳IP地址(用於多接入網段)或將路由引出介面(點對點介面)。 但是,在多路訪問網段中沒有下一跳IP地址時,不能使用靜態路由。
網路圖表
在此過程中,本文會參考此網路圖。
適用於IP首碼匯入的BGP支援
全局IPv4單播或組播字首由標準思科機制(如IP access-list或IP prefix-list)定義為導入路由對映的匹配標準:
access-list 50 permit 10.10.1.0 0.0.0.255
or
ip prefix-list GLOBAL permit 10.10.1.0/24
為導入定義的IP字首,然後透過路由對映中的match子句進行處理。透過路由對映的IP字首將導入到VRF中:
route-map GLOBAL_TO_VRF permit 10
match ip address 50
or
match ip address prefix-list GLOBAL
!
ip vrf RED
rd 1:1
import ipv4 unicast mapGLOBAL_TO_VRF
!
ip route 10.10.3.0 255.255.255.0 Vlan900
此方法要求將邊界網關協定(BGP)與VRF lite配合使用。此方法不適用於所有案例。
原則型路由(PBR)
PBR可用於洩漏GRT和VRF之間的路由。 這是一個示例配置,其中顯示了從全局路由表到VRF的路由洩漏:
ip vrf RED
rd 1:1
!
interface Vlan100
description GLOBAL_INTERFACE
ip address 10.10.1.254 255.255.255.0
!
access-list 101 permit ip 10.10.3.0 0.0.0.255 10.10.1.0 0.0.0.255
!
route-map VRF_TO_GLOBAL permit 10
match ip address 101
set global
!
interface Vlan900
description VRF_RED
ip vrf forwarding RED
ip address 10.10.3.254 255.255.255.0
ip policy route-map VRF_TO_GLOBAL
這對6500交換機之類的高端裝置非常有效,但對3750之類的裝置則不支援。它是一種平台限制,如以下錯誤消息所示:
3750X(config)#int vlan 900
3750X(config-if)#ip policy route-map VRF_TO_GLOBAL
3750X(config-if)#
Mar 30 02:02:48.758: %PLATFORM_PBR-3-UNSUPPORTED_RMAP: Route-map VRF_TO_GLOBAL not supported for Policy-Based Routing
VRF接收
您可以使用VRF接收功能將連線的GRT子網作為VRF路由表中的連線路由條目插入:
ip vrf RED
rd 1:1
!
interface Vlan100
description GLOBAL_INTERFACE
ip vrf select source
ip vrf receive RED
ip address 10.10.1.254 255.255.255.0
end
!
interface Vlan900
description VRF_RED
ip vrf forwarding RED
ip address 10.10.3.254 255.255.255.0
end
!
ip route 10.10.3.0 255.255.255.0 Vlan900
3750X#show ip route vrf RED
Routing Table: RED
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.3.0/24 is directly connected, Vlan900
L 10.10.3.254/32 is directly connected, Vlan900
C 10.10.1.0/24 is directly connected, Vlan100
L 10.10.1.254/32 is directly connected, Vlan100
3750X#ping 10.10.3.1 source vlan 100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.1.254
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
3750X#show ip arp vrf RED vlan 900
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.10.3.254 - d072.dc36.7fc2 ARPA Vlan900
Internet 10.10.3.1 0 c84c.751f.26f0 ARPA Vlan900
注意:此配置沒有用於驗證或排除可能問題的過程。