簡介
本文描述如何在安裝或升級Cisco Jabber for Windows時解決由永久性登錄檔項引起的問題。
必要條件
需求
思科建議您瞭解以下主題:
- Windows版Cisco Jabber
- Microsoft Windows 7版作業系統(32位和64位)
- Microsoft Windows 10版作業系統(32位和64位)
採用元件
本檔案所述內容不限於特定硬體或軟體版本。
本文中的資訊是根據特定實驗室環境內的裝置所建立。文中使用到的所有裝置皆從已清除(預設)的組態來啟動。如果您的網路正在作用,請確保您已瞭解任何指令可能造成的影響。
問題
當您嘗試安裝或升級Windows 9.x版或更高版本的Cisco Jabber時,嘗試失敗,您將收到以下錯誤消息:
Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical Support team
原因
通過Microsoft Installer(MSI)檔案安裝的程式在解除安裝金鑰中包含一個條目,其Windows Installer值為1(1)。 Add/Remove Programs功能遇到此條目時,它會檢查金鑰名稱並對其進行更改。然後,它在此位置中搜尋以重新排序GUID命名的金鑰:
HKLM >軟體>類>安裝程式>產品
由於登錄檔項已損壞,必須將其刪除。
解決方案
按一下OK以收集Windows Installer日誌;然後找到指向ARPRoduction的登錄檔,並檢視哪個登錄檔受影響。
以下是Jabber安裝日誌的示例:
MSI (s) (00:68) [13:39:25:865]: Doing action: RemoveExistingProducts
Action 13:39:25: RemoveExistingProducts. Removing applications
Action start 13:39:25: RemoveExistingProducts.
RemoveExistingProducts: Application: {B63FA739-46CF-4270-B903-90F5698EDF39}, Command line: UPGRADINGPRODUCTCODE={F5C0DBF4-2D93-4A73-9AF3-E931AFF8BAF9} CLIENTPROCESSID=13016 CLIENTUILEVEL=0 REMOVE=ALL
MSI (s) (00:24) [13:39:25:880]: Unexpected or missing value (name: 'PackageName', value: '') in key 'HKLM\Software\Classes\Installer\Products\937AF36BFC6407249B30095F96E8FD93\SourceList'
CustomAction returned actual error code 1610 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (00:68) [13:39:25:880]: Note: 1: 1714 2: Cisco Jabber 3: 1610
MSI (c) (D8:B8) [13:39:28:589]: Doing action: setErrorUnknownError
Action 13:39:28: setErrorUnknownError.
Action start 13:39:28: setErrorUnknownError.
MSI (c) (D8:B8) [13:39:28:589]: PROPERTY CHANGE: Modifying ERROR_INSTALL property. Its current value is '0'. Its new value: '4'.
Action ended 13:39:28: setErrorUnknownError. Return value 1.
Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical support group. System Error 1610.
MSI (s) (00:68) [13:39:28:605]: Product: Cisco Jabber -- Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical support group. System Error 1610.
在客戶端電腦中,按一下Run > Regedit,然後導航到以下位置:
HKLM > Software > Classes > Installer > Products >937AF36BFC6407249B30095F96E8FD93 > SourceList
刪除金鑰,重新啟動電腦,然後重新啟動安裝或升級過程。
附註:可能需要管理訪問許可權才能訪問電腦上的登錄檔項。