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This module describes how to design the layout for display of the data that you have integrated and
mapped for output in Cisco StadiumVision Director using the External Content Integration feature. This
layout is required to create a content object referred to as a widget, that you can then publish with the
standard features of Cisco StadiumVision Director using playlists and scripts for eventual display on
TVs.

This module includes the following topics:

Prerequisites for Using the Widgets Tool, page 49

Restrictions for Using the Widgets Tool, page 50

Information About Using the Widgets Tool, page 50

How to Design the Layout of External Content for Display, page 58
Configuration Examples, page 67

What to Do Next, page 79

Prerequisites for Using the Widgets Tool

Before you design the layout of external content, be sure that the following requirements are met:

You have configured the external data sources and mapped the statistics to output fields in the
External Content Integration feature.

The data from the external source is being properly ingested by Cisco StadiumVision Director.

You have added any standalone graphics that you want to add to the layout by importing them into
Cisco StadiumVision Director from Control Panel > Content > Import.
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Restrictions for Using the Widgets Tool

Before you design the layout of external content using the Widgets tool, consider the following
restrictions:

e The Widgets layout tool can only be used for data sources that have been integrated into Cisco
StadiumVision Director using the External Content Integration feature.

¢ Cisco StadiumVision Director only supports widgets that are created internally using the Widgets
tool.

e Up tol6 different sessions can be supported in the Widgets tool on a single computer.

e The maximum graphic size supported is 1920x1080, which is also the maximum size of the area
supported in the Widgets layout tool.

~

Note If you attempt to use a larger graphic in the Widgets tool, it might not be displayed.

e The PicToScreen component has the following restrictions:

— A maximum of 5 images can be rotated using the PicToScreen component. Therefore, up to the
first 5 images received from the data feed can be displayed. A new set of images can be retrieved
at the next polling interval.

— Supports binding of image data fields only from a source feed. Therefore, the data source must
be defined with an image field for output display. For more information on field mapping in the
data source, see the “Selecting Input Statistics and Mapping to Output Fields for Display”
section on page 30.

e The TextToScreen component supports binding of text data fields from a source feed. Therefore, the
data source must be defined with a title, description, or other text data field for output display.

e The Widgets tool has the following font restrictions:
— Only the Arial font type with the ASCII character set is supported.

~

Note  While you might be able to see a supported localized language and create text components with
non-ASCII characters in the Widgets tool, these text components might not be rendered as
expected on the DMP.

— The maximum font size is limited to 128 due to a restriction by the DMP.
— Importing of fonts is not supported.

e The following functions are not supported in the Widgets tool:
- Undo

— Deleting a group of multi-selected components

Information About Using the Widgets Tool

This section includes the following topics:
e Components, page 51

e Layers, page 53
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e Properties and Effects, page 53
e Data Binding and Preview, page 57

e User Interface Characteristics, page 57

Components

Overall, the Widgets tool includes four component types, which are either image-based or text-based.
New components are added to the widget area simply by dragging the object type and dropping it onto
the canvas or by double-clicking the component.

Standalone Text and Graphic Components

Two component types are intended for data with standalone text or graphics:
e Text Area
e Graphic
The Widgets tool uses the Graphic component to support the addition of standalone images. Each

time a graphic component is added to a widget, it is added in numerical order as a Layer on the
canvas.

Data Feed Components

Cisco StadiumVision Director Release 3.1 introduces two new component types to support generic data
sources and feeds, whose content is either image-based or text-based.

P2S (PicToScreen)

The PicToScreen component supports only image data fields from the data source, and can display up to
5 images from a data feed. The images appear in a fixed overlapping cascade that rotates through the
available images from the feed (Figure 1).

~

Note  The cascading layout of the images cannot be changed. However, you can alter the position and
orientation of the top graphic within the Widgets tool.
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T2S (TextToScreen)

Figure 1 Example of PicToScreen Widget Display of 5 Maximum Images

Default Images and Display Behavior

Cisco StadiumVision Director has default images that are used as placeholders for any images that
cannot be found or when the number of images received does not equal the number defined in the
“Images to Display” property of the PicToScreen component (up to 5).

If Cisco StadiumVision Director must insert default images when enough images are not received from
the data feed, then only the good images from the data feed are rotated through the cascading
presentation. The default images will remain at the back of the stack in the presentation.

The default image is called Defaultimg.jpg and is found in the content library. You can change the
default image by uploading your own image into the content library and change the “ContentName”
property in the P2S component.

Image Orientation

You can change the position and rotation of the top graphic in the PicToScreen component. However,
you cannot control the position or rotation of individual images within the stack.

The TextToScreen component can support any number of messages from the data feed.

Figure 3 shows an example of a fixed background graphic component, with a TextToScreen component
overlay in Figure 3.

Figure 2 Example of TextToScreen Widget Background Graphic

CEE VDOIIR MEQGCACE HERE! Text SHOR and your message to 80929

Msg and date rates may apply. Get 5 msgs/mo. Text HELP for help. Text STOP for stop. T&C avail at mozes.com/go/tos
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Figure 3 Example of TextToScreen Widget Display

A
CEEFE VOIIPR MEQCACE HERFE! Text SHOR and your message to 80929

Text from Text2Screen

Similar to standard graphics editing applications, each time a Text Area or Graphic component is added
to a widget, it is labeled in numerical order (by type) as a Layer on the canvas. Unless reordered, the first
component added is at the bottom of the components added to the canvas, and the last component added
is the topmost layer. In the user interface, the Layers box also lists the layers in stacking order with the
topmost layer at the top of the list. In general, a background image should be at the bottom of the list.

You can reorder the layers by dragging and dropping them into a different order in the Layers box of the
Widget tool.

The first graphic component added to the widget is identified as “graphic 1,” and the first text area is
labeled “text area 1.” Components are numbered sequentially as they are added. Therefore, if you delete
a component, that component number is not replaced.

You can rename a component by double-clicking it.

Properties and Effects

The Properties panel allows you to set the characteristics of a component including explicitly setting its
size, location, and rotation on the canvas.

Depending on the component type, some additional Properties and Effects are available:
e Standalone Text Area Component Properties and Effects, page 53
e Standalone Graphic Component Properties, page 54
e PicToScreen Component Properties and Effects, page 55

e TextToScreen Component Properties and Effects, page 56

Standalone Text Area Component Properties and Effects

In addition to setting the size, location, and rotation on the canvas for Text Area components, you also
can specify the character string for the component, and select a font size and color.

Table 1 describes the property options and Table 2 describes the effects that can be applied to standalone
Text Area components.

pe

Tip Remember that the Widgets tool displays a white background for ease of use, but if you are not
using any background images, a black font will not be visible on the TV screen because the TV
background is actually black.
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Table 1

Text Area Component Properties

Property Name

Description

Values

X Number of pixels that defines the starting position of |Range is 0-1920.
the component horizontally.
y Number of pixels that defines the starting position of |Range is 0-1080.
the component vertically.
width Number of pixels that defines the horizontal width of |Range is 0-1920.
the component.
height Number of pixels that defines the vertical height of the |Range is 0-1080.
component.
rotation Number of degrees to rotate the component box. Range is 0-360. Default is 0.
Text Character string to display within the text area Default is “TextAreaN,”
component. where N is a number in
Note  The Text property does not support line wrap, sequential order of the
. number of Text area
so the length of the string that can be dded to th
supported is the canvas width. components added to the
canvas.
Font Size Size of the Arial font for the Text property. Default is 36. Maximum is
128.
Color Color for the Text property. Default is black.

Standalone Graphic Component Properties

In addition to setting the size, location, and rotation on the canvas for Graphic components, you can
import an image and also specify that it retain the dimensions of the original image.

Table 1 describes the property options that can be applied to standalone Graphic components. No effects
are supported for Graphic components.

Table 2

Graphic Component Properties

Property or Effect Name

Description

Values

X Number of pixels that defines the starting position of |Range is 0-1920.
the component horizontally.

y Number of pixels that defines the starting position of |Range is 0-1080.
the component vertically.

width Number of pixels that defines the horizontal width of |Range is 0-1920.
the component.

height Number of pixels that defines the vertical height of the |Range is 0-1080.
component.

rotation Number of degrees to rotate the component box. Range is 0-360.

Default is 0.
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Table 2 Graphic Component Properties (continued)
Property or Effect Name Description Values
Content Name Filename of the image to be displayed in the Unspecified.

component.

Note The image must be uploaded to the Content
Management System (CMS) from the Control
Panel > Content > Import area of Cisco
StadiumVision Director to be made available

to the widget.

Default images
from the system
are used.

Use image original size

When selected, changes the image size in the
component to the size stored in the CMS.

Note If you select this option and then unselect it,
the image does not revert to the settings in the

widget.

Default is
disabled.

PicToScreen Component Properties and Effects

Table 3 describes the property options and Table 4 describes the effects that can be applied to

PicToScreen components.

Table 3

PicToScreen Component Properties

Property or Effect Name

Description

Values

X Number of pixels that defines the starting position of |Range is 0-1920.
the component horizontally.

y Number of pixels that defines the starting position of |Range is 0-1080.
the component vertically.

width Number of pixels that defines the horizontal width of |Range is 0-1920.
the component.

height Number of pixels that defines the vertical height of the |Range is 0-1080.
component.

rotation Number of degrees to rotate the component box. Range is 0-360.

Default is 0.

Images to Display

Maximum number of images to display from the data
feed.
Tip The value of the Images to Display property
should match the value of the “Number of
messages keep” data option for an Atom or
RSS feed data source.

Range is 2-5.
Default is 5.

Use default image if no
image present.

When enabled, replaces any missing images that
might occur from the data feed (up to the maximum
number for display) with a default image.

Default is
enabled.
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Table 3 PicToScreen Component Properties (continued)
Property or Effect Name Description Values
Content Name Filename of an image to be used as the default when |Unspecified.

default images are enabled for the component.

Default images
from the system
are used.

Image Duration

Length of time (in seconds) to display the current set
of images.

Range is 5 to 25.
Default is 5.

Table 4

PicToScreen Component Effects

Property or Effect Name

Description

Values

Image Duration

Length of time (in seconds) to display the current set
of images.

Range is 5 to 25.

Default is 5.

TextToScreen Component Properties and Effects

Table 5 describes the property options and Table 7 describes the effects that can be applied to

TextToScreen components.

Table 5

TextToScreen Component Properties

Property or Effect Name

Description

Values

X Number of pixels that defines the starting position of |Range is 0—1920.
the component horizontally.
y Number of pixels that defines the starting position of |Range is 0-1080.
the component vertically.
width Number of pixels that defines the horizontal width of |Range is 0-1920.
the component.
height Number of pixels that defines the vertical height of the |Range is 0-1080.
component.
rotation Specifies the orientation of the component. Horizontal or
vertical. Default
is horizontal.
Font Size Size of the Arial font for the text that appears in the |Default is 36.

component.

Maximum is 128.

Font Color 1

Sets a font color for the first text data field in a feed,
and alternates with Font Color 2. If there is only one
message, then only Font Color 1 is used.

Default is black.

Font Color 2

Sets a font color for the second text data field in a feed
and alternates with Font Color 1.

Default is black.
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Table 6 TextToScreen Component Effects

Effect Name Description Values

Fade Gradually shows the text data field in the component. —

Message display Length of time (in seconds) that the text from the data Range is 5-25.
duration (Seconds) feed is displayed. Default is 5.

Data Binding and Preview

~

Note

After you have mapped the output fields for an external data source, you can bind that data to a
component in a widget and see a preview of that live content feed.

Live data is polled for preview every 15 seconds in the Widgets tool. There can be a slight delay before
you see an update of the content within a component. This polling interval is for preview only and is not
the same polling interval used in the data source configuration.

Only certain data fields are supported for the PicToScreen and TextToScreen components. For more
information, see the “Restrictions for Using the Widgets Tool” section on page 50.

User Interface Characteristics

Figure 4 shows the areas of the user interface for a new widget.

Figure 4 New Widget Interface
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The Widgets tool interface supports some of the following functions and characteristics:
e Multi-selection of components using standard Control key sequences to move components as a
group.
¢ Showing or hiding the bounding box of a component.
e “Zoom-to-fit” function by double-clicking the zoom knob.

e Change the widget dimensions by double-clicking the widget size in the upper right of the screen.
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How to Design the Layout of External Content for Display

This section includes the following tasks:
e Accessing the Widgets Tool, page 58
e Creating New Widgets, page 58
e Working with Images, page 60
¢ Adding Text Areas, page 62
e Showing the Component Bounding Box, page 63
e Resizing and Rotating Components, page 64
e Binding External Data to a Widget, page 65
e Modifying Existing Widgets, page 66

Accessing the Widgets Tool

To access the Widgets tool, complete the following steps:

Step 1 Log into Cisco StadiumVision Director as an administrator.
Step2  From the main menu, click Control Panel > Widgets.

A dialog box opens for you to select an existing widget or create a new one (Figure 5).

Figure 5 Dialog Box to Open Existing or Create New Widgets

Open
Create Hew
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+ .

Narme My_ssmple
Samplal "

Size:  (.) pre-set size:
Sample?

O Custom S
Width: 1 @
ight: =
create | | cancel

Creating New Widgets

You can create a new widget when you first access the Widgets tool, or you can create a new widget from
within the tool.
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To create a new widget from within the tool, complete the following steps:

Step1  From the menu bar in the Widgets tool, click File > New.

The Create New dialog box is displayed (Figure 6).

Figure 6 Create New Dialog Box
Mame: ‘
Sizei (o) Pre-set size:
() Custom Size:
wWidth: 1 tﬁ
Height: 1 tj

Step2  In the Name box, type a name for your new widget.
Step3 Do one of the following to specify the size of the widget:

e Click Pre-Set size and click the drop-down list to select a predefined dimension (WxH) for the
canvas in pixels.

¢ Click Custom Size and specify a number (in pixels) for the width and height dimensions of the
canvas.

Step4  Click Create.

The tool displays a white box of the size that you created, with the dimensions that you specified
displayed in the upper right corner (Figure 7).

Note  The background canvas of the widget is actually transparent, but it is not shown with the
graphics-standard checkerboard pattern to ease visibility of the components.

Figure 7 New Widget Screen
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Step5  Click File > Save.

Changes to the widget are saved.

Working with Images

This section includes the following topics:
¢ Adding Standalone Images, page 60
e Resizing and Rotating Images, page 61

Adding Standalone Images

Images can be added as a background to your layout in the Widgets tool, and they also can be bound to
a data field using the External Content configuration, such as to add a team logo to a score field that will
appear in the widget.

To support the addition of a graphic bound to a particular external source data field, see the “Modifying
the Output Format of a Statistic” section on page 43.

The Widgets tool uses the Graphic component to support the addition of images as a background or in
other places on your canvas.

Prerequisite

Before you can add an image to a widget, you must import the image file into Cisco StadiumVision
Director by going to Control Panel > Content > Import to select and open a file. In the Import Content
dialog box, specify any options and click Upload.

Procedure

To add an image to a widget, complete the following steps:

Step1  Open or create the widget where you want to add an image.

Step2  In the Components box, select the Graphic component and drag and drop it onto your widget canvas
(Figure 8).
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Figure 8 Drag and Drop Graphic Component on Widget Canvas
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Tip Double-click a component to automatically add it to the canvas.

Step3  To add an image, be sure that the graphic component where you want to add the image is selected, and
click Change.

Step4  In the Select Image dialog box, highlight the image that you want to add and click Select.

The image is added and scaled to the size of your graphic component box (Figure 9).

Figure 9 Image Added to Graphic Component
File Edit  View |
m Iy \Widget —O———  Size: 004600 _
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P2s
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Graphic Properties i Effects | Data Binding
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Step5  Click File > Save.

Changes to the widget are saved.

Resizing and Rotating Images

Images will automatically scale to the size of the graphic component box in the widget.

Tip To find the size of your image file, use the List view for your images in Control Panel > Content. Select
your image and look at the size in the Dimension field in the “Other content metadata” box.

You can scale the graphic to its original size after you add it, or if you modify the image size in the
widget, you can revert back to its original size using the “Use original image size” option, which is
recommended.

Cisco StadiumVision Director External Content Integration Guide
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Figure 10 shows the options available on the Properties panel for a graphic component and displays the
different bounding box handles that can be used to modify the size of a component box.

Figure 10 Graphic Component Properties Panel and Bounding Box Handles
My_Sample —(Q———  siza: 1920x1080
N
& =
Properties | Data Binding
PRNEET) S width 20024 Contant Name
I T ) e Eme g e

You can modify the size and position of an image in the following ways:
e Explicitly setting values on the Properties panel.
e Selecting the bounding box and using the handles to modify it.

e With the graphic component selected, select the “Use original image size” checkbox to revert the
image to its original size when imported.

For more information, see the “Resizing and Rotating Components” section on page 64.

Adding Text Areas

Step 1
Step 2
Step 3

A text area component is added to a widget in the same way as a graphic component, but with some
different properties. A text area supports a character string, and font size and color selection.

Currently the only available font is Arial.

To add a text area to a widget, complete the following steps:

Open or create the widget where you want to add the text area.
In the Components box, select the Text Area component and drag and drop it onto your widget canvas.
In the Properties panel, type the character string for the box, and select the font size and color.

Figure 11 shows the options available on the Properties panel for a sample text area component.
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Figure 11 Text Area Component Properties
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Step4  Resize or position the text area as needed. For more details, see the “Resizing and Rotating Components”
section on page 64.

Step5  Click File > Save.

Changes to the widget are saved.

Showing the Component Bounding Box

When you add a component onto the canvas, a temporary bounding box appears while the component is
selected. If you move away from that component into another area of the canvas, you will not be able to
see the boundaries of the component box.

Figure 12 shows an example of a text area and graphic component displaying the default setting without
a visible boundary when the component is unselected. Notice that while the graphic component is
selected the temporary bounding box is displayed in Figure 12, but when unselected it appears to
disappear from the canvas (Figure 13).

Figure 12 Default Setting Without Bounding Box and Selected Component
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Figure 13 Default Setting Without Bounding Box or Selected Components
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To display a boundary around all components in the widget, complete the following steps:

Step1  From the menu bar, go to View.
Step2  Click Show bounding box.

A checkmark appears beside the option when the bounding box is enabled for display, and all
components will display a boundary around them.

Figure 14 shows an example of a text area and graphic component after the Show bounding box option

is enabled.
Figure 14 Show Bounding Box Option Enabled
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o

Step3  Click File > Save.

Changes to the widget are saved.

Resizing and Rotating Components

You can resize and rotate both Text Area and Graphic components in the following ways:
e Change the component location:
— Select the component and manually drag it to the location that you want on the canvas.

— Specify the x/y horizontal and vertical values directly in the Properties panel.
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e Change the component size:

— Select and drag a handle on the component’s bounding box to enlarge or reduce the component
size. If using a handle on a side of the box, only that dimension is changed. If using a corner
handle, both dimensions of the box are changed.

— Shift+Click on a corner handle to resize the box proportionally.

— Specify the width and height values directly in the Properties panel.
¢ Change the component angle:

— Select the rotation handle and drag the box up or down to rotate it.

— Shift+Click on the rotation handle and drag the box up or down to change the angle in 45 degree
increments.

- Specify the rotation value in degrees directly in the Properties panel.

Figure 15 identifies the bounding box handles that you can use to resize and rotate components.

Figure 15 Bounding Box Handles
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Binding External Data to a Widget

The widget supports the binding of external data to a text area component so that you can display
dynamic output fields, such as game periods, scores, and so on from an external source.

~

Note If you add a text string to the component, it will be replaced by the real-time data from the output field
that you specified in the Data Binding panel.

Prerequisite

Before you can bind external data to a widget, you must have configured your external data source and
mapped the output fields by going to Control Panel > Setup > External Content. For more information,
see the “Configuring External Content Integration in Cisco StadiumVision Director”.
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Procedure

Step 1
Step 2
Step 3

Step 4

Step 5

Step 6

Step 7

To bind external data to a widget, complete the following steps:

Open or create the widget where you want to add the text area.
In the Components box, select the Text Area component and drag and drop it onto your widget canvas.

In the Properties panel, select the font size and color. Optionally, specify a character string if you want
to temporarily see some content in the component while the widget is open.

The font size and color will be applied to the bound data.

In the Data Binding panel, double-click in the first cell under the Data Source heading and open the
drop-down list (Figure 16).

Figure 16 Accessing the Data Source List
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Click the drop-down list and select the data source from which you want to bind data. Use the scroll bar
to reveal all data sources as necessary (Figure 17).

Figure 17 Selecting the Data Source
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Double-click inside the cell for the data field and select the drop-down list to select the data output field
that you want to display in the text area component (Figure 18).

Figure 18 Selecting the Data Field
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Click File > Save.

Changes to the widget are saved.

Modifying Existing Widgets

This section includes the following tasks:
e Changing the Size of a Widget, page 67
e Deleting Widgets, page 67
e Renaming Widgets, page 67
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Configuration Examples

Changing the Size of a Widget

To change the size of a widget, complete the following steps:

Step 1 Open the widget whose size you want to change.
Step2 From the Edit menu, select Widget Dimension.
Timesaver  You can also double-click the widget size in the upper right corner of the screen to open the Change
Widget Dimension dialog box. See the “User Interface Characteristics” section on page 57.
Step3  In the Change Widget Dimension dialog box, specify the new width and height values.
Step4  Click Change.
Deleting Widgets
To delete a widget, complete the following steps:
Step 1 From the File menu, select Manage Widgets.
Step2 In the Manage Widget dialog box, select the widget that you want to remove.
Step3  Click Delete.
Renaming Widgets
To rename a widget, complete the following steps:
Step 1 From the File menu, select Manage Widgets.
Step2  In the Manage Widget dialog box, select the widget that you want to rename.
Step3  Click Rename.
The widget name is changed to an editable box.
Stepd  Type a new name for the widget.
Step5  Click Close.

Configuration Examples

This section includes the following topics:

e Basic Widget Configuration Example, page 68
e TextToScreen Widget with Merged Generic Data Sources, page 70
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Basic Widget Configuration Example

~

Note

Step 1
Step 2
Step 3
Step 4

Step 5

This example demonstrates use of the Text Area and Graphic components with data binding. The figures
are based on the original interface for the External Content Integration feature; Therefore, some of the
figures do not reflect all of the latest available components in the interface.

This section shows a basic widget configuration example to bind external data for an OES Ice Hockey
Scoreboard data source. The example uses an image background (Figure 19) that creates static headings
for Period, Time Outs, and Score, with companion text area components that will be created as layers on
top of the background.

These text areas will be positioned beneath the background image headings and will have real-time data
bound to them to appear in the widget.

Figure 19 Image Background for Scoreboard Widget

PERIOD

TIME OUTS LEFT TIME QUTS LEFT

To create a widget and bind data to it, complete the following steps:

Create a new widget with size 1920x1080.

In the Components box, select the Graphic component and drag and drop it onto your widget canvas.
With the graphic component selected, go to the Properties panel and click Change.

In the Select Image dialog box, click on the background image that you want to add and click Select.
The image is added and scaled to the size of your graphic component box.

In the Properties tab, specify the following values (Figure 20):

a. xand y—0

b. width —1920

c. height—1080

d. rotation—O0
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Figure 20 Background Image Added to Graphic Component
| File  Edit iew |
Components | Hockey_Sample O Size: 1920v1080 | Layers
B F—

Properties | Data Binding

x o o width 1970 | 2 Content Name Scoreboard_background. pn:
5 B [ baskarmundong | [ change
volo A ekt | som|l | uss imags arignal size

rotation o[£ =l

Step6  Create two new text area components to add “HOME” and “GUEST” as the specified text string
positioned as layers on top of the background graphic component (Figure 21).

Figure 21 Addition of Home and Guest Text Areas
| File  Edit  View |
Components | Hockey_Sample O size d520xi080 | Layers
D [EJtaxtaraa 2
Taxt Ares [Earaphic 1
@
@raphic
Properties \| Data Binding
% [2s8 vidth 230 Text
y 3= =) height 10y Fontsiza 126 [ 3]
rotation ol Font Color [ =l

a. Drag and drop the Text Area component onto the background graphic.
b. In the Properties panel, specify the following values:
- Text box—Type “HOME”
— Font size—128
— Font color—Choose yellow
c. Select the handles on the text area box and expand its boundaries enough to reveal the text.

d. Select the text area component and drag it to the left side of the background graphic over the Time
Outs Left and Score fields.

e. Repeat steps a—d using “GUEST” text and drag the component to the right side of the background
graphic.

Step 7 Add Text Area components to bind data for Period, Time Outs, and Score areas for both teams:
a. Drag and drop the Text Area component onto the background graphic.

b. (Optional) Zoom in as needed to see the component better.

Cisco StadiumVision Director External Content Integration Guide
| g oo



Designing the Layout of External Content Using the Widgets Tool |

M Configuration Examples

¢. Position and resize the component beneath the heading for which you are going to bind
corresponding data (Figure 22).

d. (Optional) Add text to temporarily identify what data will be in the box, such as “period_data.”

Figure 22 Text Area Component to Bind Period Data
File  Edit  \View
Components | Hockey_Sample ——Q———  sizer 152002080 | Lavers
B | [ [textArea s
[E] E
Text Area [[Jtextarea 1
[ oraphic
=
@raphic
Properties Data Binding
x [s1a S width 150 (2 Text | period_data
v 566 Ii} height 155@ Font Size 36 Ii)
ratation = Fart color [ BE&

e. Inthe Data Binding panel, select the OES: Ice Hockey, Scoreboard data source and the period data
field (Figure 23).

Figure 23 Period Data Field Binding for OES Ice Hockey Scoreboard Source
File Edit  View
Components | Hockey_Sample ——O—— sizai 192041080 | Lavers
- EST
E FER r':" b Blsess
Text Aren ™ i o % ::)1
=

Properties | Data Binding homeT8L I
Property 4  Data Source guestTOL

Text OES: Tce Hockey,Scoreboard period

f. Repeat steps a—e for all other data fields that you need to bind.
Step8  Click File > Save.

Changes to the widget are saved.

TextToScreen Widget with Merged Generic Data Sources

This advanced example shows how to create generic data sources from RSS feeds, filter the data, and
combine the feeds into a new data source for layout in the Widgets tool. The example highlights the
following functionality in the External Content Integration feature:

e Generic data source configuration of an RSS data feed.

e Provision of XML sample data.

¢ Selection of specific item ranges in a data feed using the XPath expression editor.
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Step 2

Step 3

Step 4
Step 5
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e Merging of data sources into a data view.

e Data view configuration as a data source.

e Preview of received data in the data source.

e Use of a background graphic in the layout.

e Opverlay of a TextToScreen component with data bound from merged data sources (a data view).

e Use of color properties in the TextToScreen component.

To create a TextToScreen widget with merged data sources, complete the following steps:

From the Control Panel, click Data Integration.

For more information, see the “Accessing the External Content Integration Interface” section on page 17.
Add a new Generic Data Source with the HTTP message type.

For more information, see the “Adding a New Data Source” section on page 17.

In the Configuration panel for the new Generic Data Source, type the URL to your RSS feed.

Figure 24 creates a new Generic Data Source named “Twins_businessnews” with the following HTTP
URL “http://feeds.reuters.com/reuters/businessNews”. The rest of the configuration uses the default
values.

Figure 24 HTTP Configuration for First Generic Data Source

Users Zones & Groups Channels Devices Suites Triggers Proof of Play Templates Stores Menus Data Integration
Data sources Advanced

il @ Deploy  Undploy o Twins_businessnews - Generic Data Source

Data source name | Tyne Enabled = =
Configuration Field mapping

HTTP Settings
HTTF URL | http:/ffeeds reuters comireutersibusinesshlews

Polling frequency # B0 @ in seconds [5-G00]

Data polling,filtering and throttling

Incoming data filter rate | 20 = in seconds [5-60]
Twins_husinessnens Generic Data Source o B I=)

i
i

Click Field Mapping.
Click the pencil icon to open the Sample data box, paste the sample XML data from the feed, and save it.

For more information, see the “Providing Sample XML Data for Generic Data Sources” section on
page 28.
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Figure 25 shows a portion of the XML data pasted into the Sample data box.

Figure 25 Sample Data for First Generic Data Source

Data sources Advanced

T+ & Deplay  Undploy & Twins_businessnews - Generic Data Source

Data source name s | Type Enabled =
Configuration Field mapping

\E‘ Cancel

Sample data

=r55 version="2.0" xmins feedbumer="http.lrssnamespace.orgl
feedhurnerfext 0"
=channel=
=litle=Reuters: Business Mews=/itle=
=link=http Mty reuters.com=ilink=
=description=Reuters.com is your source for breaking news, business,
financial and investing news, including personal finance and stacks.
Reuters is the leading global provider of news, financial information and
technology solutions to the waorld's media, financial institutions,
Twins_businessnews Generic Data Source e businesses and individuals </description=
=images=
title~Reuters Mews=itile=

=wirfth=12N=hwirdth=
Schema

Step6  Expand the RSS input fields made available from the sample data and select a text-based input field to
be used in the output display.

For more information, see the “Selecting Input Statistics and Mapping to Output Fields for Display”
section on page 30.

Step7  Select the Expression mapping option and click Ok.

The default XPath expression for the data field is added to the Mapping expression field. For an RSS
title element, the default expression is “/rss/channel/title/text().”

Step8  Click the pencil icon in the Output field icon bar to modify the XPath expression to filter the data
provided by the feed.

Fore more information, see the “Modifying the Default XPath Expression” section on page 45.

Figure 26 shows a modification to the title data field to add the “item[position()>=2andposition()<5]”
predicate to the default /rss/channel/title/text() expression:

/rss/channel/item[position()>=2andposition()<5]/title/text

In this example, the data will be filtered to pull the 2nd, 3rd, and 4th items in the title element of the feed.

Figure 26 Output Data Filter Using XPath Expression for First Generic Data Source

Change Output Field X

Outputfield name = title

Mapping
() String
() Content lookup Select

(=) Expression | irssichanneliterposition(>=2 and position(<S)titleftext) Expression Editar
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Figure 27 shows selection of the “title” field for output display with the modified mapping expression
and the 3 items available for data preview from the RSS feed.

Figure 27 Field Mapping for First Generic Data Source

Users: Zones & Groups Channels Devices Suites: Triggers Proof of Play Templates Stores Menus Data Integration

Data sources Advanced

T @ Deploy  Undploy [ ] Twins_businessnews - Generic Data Source
Datasourcename & | Type Enabled
|| Configuration | Field mapping
" - I S
o ‘ 7 o, &+ =7 % a,
‘ Inputfield Sample data Dutput sl Mapping expression Data praview
version 20
{: ' ' ‘,HII” ' E w channel
. N link it routers com
h”— description Reuters.cam is your source for bre,
- — > image
. - B language en-us
e L ezt Tue 18 tan 2013 anneng nsn L7

[«

Click the link under Data preview to open the “Preview for” window, and verify the data from the RSS
feed.

Based on the filter used in our example to pull 3 items from the title element, a link named “3 items”
appears under Data preview. Figure 28 shows the preview of the three title items from the first generic

data source RSS feed.

Figure 28 Data Preview for First Generic Data Source with Business Data

Preview for .Twins_businessnews.litle X

Repeat Step 2-9 for the second generic data source whose RSS feed content you want to combine with
the first generic data source.
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Figure 29 creates a second Generic Data Source named “Twins_sportsnews” with the following HTTP
URL “http://feeds.reuters.com/reuters/sportsNews”. The rest of the configuration uses the default

values.

Figure 29
Datasources | Advanced
5 %  Deploy Undploy o,
Data source name s | Type Enabled
Twins_sportsnews Generic Data Source v

HTTP Configuration for Second Generic Data Source

Twins_sportsnews - Generic Data Source

Configuration | Field mapping
HTTP Settings

HTTP URL | hitp:/feeds.reuters.comiteutersisponsNews

i . = ds [5-600
Polling frequency = B0 [5; inseconos [s-600]

Data pollingfittering and throttling

Incoming data filter rate = | 20 2 inseconds (5-80]

[(EE=][E=T]

Figure 30 shows the corresponding XPath expression to filter the data to pull the 4th, 5th, and 6th items
from the title element for the second generic data source.

Figure 30

Change Output Field

Output Data Filter Using XPath Expression for Second Generic Data Source

Outputfield name # title

Mapping
) String

(O Content lookup Select

(®) Expression | irssfchanneliternposition=3 and position{=T)itleitexts Expression Editor

Cancel
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Figure 31 shows the preview of the 3 sports titles filtered from the second generic data source.

Figure 31 Data Preview for Second Generic Data Source with Sports Data

Preview for .Twins_sportsnews.title x

To combine content from multiple data sources, click Advanced to create a data view and add the data
sources that you created.

For more information, see the “Working with Data Views” section on page 37.

Figure 32 shows creation of a data view named “Twins_BusinessandSportsnews” with the
“Twins_businessnews” and “Twins_sportsnews” data sources included.

Figure 32 Data View Creation with Two Generic Data Sources Added

Users: Zones & Groups Channels Devices Suites: Triggers Proof of Play Templates Stores Menus Data Integration

Data sources Advanced

Advanced Twins_BusinessandSportsnews - Data fields
[(x] [ | [(x]

Twins_businessnews title:

Twins_sportsnews title:

Configure a third generic data source that connects internally to the created data view.

For more information, see the “Configuring the Data View as a New Data Source” section on page 42.
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Figure 33 shows configuration of the internal HTTP URL using the Cisco StadiumVision Director server
IP address and the name of the “Twins_BusinessandSportsnews” data view.

Figure 33 Data View HTTP Configuration

Users Zones & Groups Channels Devices Suites Triggers Proof of Play Templates Stores Menus Data Integration

Data sources Advanced

C L3 Deploy Undploy o

Data source name a  Type Enabled

Twinsbusinessandsports - Generic Data Source

Configuration | Field mapping

HTTP Settings

HTTP URL | http:10.194.172.32: mwing_|

Polling frequeney +| 50 [5] in seconas j5-600)

Data polling.fittering and throttling

Incoming data filter rate = | 20 @ in seconds [5-601

Twinsbusinessandsports  Generic Data Source o

K1 [

Step13  Go to Field Mapping and provide the sample XML data for the combined data sources.

The following is an example of the sample XML used:

~

Note  The “entry” node is required in the sample data.

<command>
<type>xmlDataFeed</type>
<version>l</version>
<channel>com.cisco.sv.databind</channel>
<xmlDataFeed>
<hashcode>45added260b54cb41765345a21efd3dc</hashcode>
<xmlDataFeedEntry>
<name>.Twins_businessnews.title</name>
<value>
<entry index="0">Exclusive:Thermo Fisher weighs Life Tech takeover -
sources</entry>
<entry index="1">Chesapeake CEO McClendon steps down after year of tumult</entry>
</value>
</xmlDataFeedEntry>
<xmlDataFeedEntry>
<name>.Twins_sportsnews.title</name>
<value>

<entry index="0">Never-say-die Kings rally to haunt Canucks again</entry>

<entry index="1">49ers' Moss: "I'm the greatest receiver ever"</entry>
<entry index="2">MLB investigating doping report involving top players</entry>
</value>
</xmlDataFeedEntry>
</xmlDataFeed>
</command>

After the XML sample data is saved, the data sources are combined.
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Figure 34 highlights the new link to 6 items available for preview, which includes the 3 items from the
business data source and 3 items from the sports data source.

Figure 34 Data View Field Mapping
Users | Zones&Groups | Chamnels | Devices | Sutes | Triggers | ProofofPlay | Templates | Stores | Menus | Dataintegration
Data sources Advanced
* @ Deploy  Undploy 2 ‘ Twinsbusinessandsports - Generic Data Source
Data source name s Type Enabled
| Configuration | Field mapping
1 R+ ® o
Inputfield Sample data Output ield Mapping expression Data preview
wversion 1 = |entry feommandixmiDataF ee.
channel com.cigeo.sv.databing
v xmiDataFeed
hasheode 45adde4 26005 4chd1TES345a21 el
v smiDataFeedEntry
name Twins_businessnews fille
v value
H > enty Exclusive:Thermo Fisherweighs Li
s somss ||
- Btk M i -

Click the link in the Data preview column to verify the content for display.

Figure 35 shows the combined title items from both the business and sports feeds.

Figure 35 Data View Field Mapping

Preview for .Twinshusinessandsports.entry x

Go to the Widgets tool.

For more information, see the “Accessing the Widgets Tool” section on page 58.
Create a new widget.
For more information, see the “Creating New Widgets” section on page 58.

Add a Graphic component to the canvas and adjust the size to accommodate the title fields from the RSS
feeds.

For more information, see the “Working with Images” section on page 60.

Add a TextToScreen component to the canvas to overlay the Graphic component.
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Step19 Bind the data view data source to the TextToScreen component.

Figure 36 shows binding of the “Twinsbusinessandsports” data source.

Figure 36 Data Binding of the Data Source Created From the Data View

Properties Effects Data Binding

Property Data Source Data Field

Bind Messages Twinshbusinessandsports entry

Step20 In the Properties panel, set the options and choose the font colors.

Figure 37 shows the properties used with black set for the first color, and red set for the second color.
The bound data automatically appears in the widget. Since two different colors were set in the
component properties, the colors will alternate for each message.

Notice that the first message of the combined data that was displayed in the Data Integration preview in
Figure 35 appears in the Widget in black font, followed by the second message in red.

Figure 37 TextToScreen Data Preview of First Message Color

File Edit “ew |
BatsTicker ——C———  Size: 1366116 =

P2s

PicToScreen

(& graphic 2

T25 RATS Most Active
TeTostreen Berkshire Hathaway, 3G Capital to buy Heinz for $28 billion °
Text rea
)
Graphic Properties | Effects | DataBinding
x| 44 I—]: width 11AEH: Font Gize Fant Colar2 !
y |2 2 height 582 Fontcalor [
mtation | Horizontal | v | j
BatsTicker —O0——— 5= 13600118 |

PepsiCo profit beats Street; 2013 in line with goals
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What to Do Next

After you have completed creating a widget, complete the following steps to publish it for display:

1. Create a playlist from the Control Panel for the widget that you created. Widgets are categorized in

the “By Type” folder under the “widget” type.

alrarlne i -
cisco Cisco StadiumVision Control Panel

Setup — Control
Newi Playlist & = Content View :: | Content | Playlist | Split |
P —

Import  Delste  New External Content

2. Create an event script to run the playlist.

3. Schedule the script to display the content on a TV.
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