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Preface

This document describes the requirements and tasks to integrate data from external sources in 
Cisco StadiumVision Director Release 3.0. 

The content is intended for Cisco StadiumVision system administrators, content managers, and technical 
field engineers who are responsible for designing and deploying Cisco StadiumVision solutions. It is 
expected that readers of this document are familiar with basic IP networking, have a general 
understanding of the sports and entertainment business, and understand the objectives and operations of 
live events.

Document Revision History
Table 1 lists the technical changes made to this document since it was first published.

Document Organization

Table 1 Document Revision History 

Date Change Summary

August 2, 2012 First release of this document for Cisco StadiumVision Director Release 3.0.

Chapter Description

“Overview of External Content 
Integration in Cisco StadiumVision 
Director”

Provides a high-level overview of the Cisco StadiumVision 
Director’s integration with external data sources for content 
ingestion and presentation.

“Configuring External Content 
Integration in Cisco StadiumVision 
Director”

Describes the requirements and how to configure support for 
external data sources in Cisco StadiumVision Director.

“Configuring Optional and 
Advanced Tasks for External 
Content Integration”

Describes additional tasks that can be performed to configure 
and maintain External Content Integration in Cisco 
StadiumVision Director.
v
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Preface
“Designing the Layout of External 
Content Using the Widgets Tool”

Describes how to design the layout for display of the data that 
you have integrated and mapped for output in Cisco 
StadiumVision Director using the External Content Integration 
feature.

“Troubleshooting External Content 
Integration in Cisco StadiumVision 
Director”

Describes how to monitor and troubleshoot problems with 
External Content Integration in Cisco StadiumVision Director..

Chapter Description
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Overview of External Content Integration in 
Cisco StadiumVision Director

First Published: August 2, 2012

Beginning in Cisco StadiumVision Director Release 3.0, the Cisco StadiumVision Director solution 
supports integration with external data sources for content ingestion and presentation. Figure 1 shows a 
high-level overview of the new feature support.

Figure 1 External Content Integration High-Level Overview

Supported External Content Sources
In Cisco StadiumVision Director Release 3.0, the following external content sources are supported:

 • National Football League (NFL) Game Statistics and Information System (GSIS) Cumulative 
Statistics

 • NFL GSIS Game Clock

 • Daktronics All Sport 5000 Scoreboard Controller (basketball and hockey only)

 • OES ISC9000 Intelligent Scoreboard Controller (basketball and hockey only)
1
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Overview of External Content Integration in Cisco StadiumVision Director
Restrictions for External Content Integration
Restrictions for External Content Integration
Before you configure External Content Integration, consider the following restrictions:

 • The frequency of the scoreboard clock updates is no more than once per second and a delay of up to 
2 seconds can occur.

 • Only basketball and hockey scoreboard statistics are currently supported.

Information About NFL GSIS Integration in Cisco StadiumVision 
Director

This section includes the following topics:

 • Network Considerations for NFL GSIS Integration, page 2

 • Supported NFL GSIS Data, page 3

Network Considerations for NFL GSIS Integration
The NFL GSIS statistics supported by the External Content Integration feature are transferred from data 
stored on an NFL Stats-in-a-Box (SIAB) server installed at the venue using an FTP connection to the 
Cisco StadiumVision Director server. The NFL SIAB server is a local server that connects to the central 
NFL GSIS database external to the venue and managed by the NFL.

Figure 2 shows a sample network architecture for NFL GSIS integration with Cisco StadiumVision 
Director. 

Note The actual network configuration with the NFL network is site-dependent and could vary at your venue.

Figure 2 Network Architecture for NFL GSIS Integration

It is important to note that the network where the SIAB server is installed is not necessarily (and likely 
not) on the same network where the Cisco StadiumVision Director server is installed. Therefore, 
depending on your specific network configuration, you might have some network configuration to do to 
ensure that the SIAB server is reachable by the Cisco StadiumVision Director server.

To configure the network connectivity to the NFL SIAB server you must specify the IP address, port, 
data path, username, and password for the NFL SIAB server on the Cisco StadiumVision Director server. 
2
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Overview of External Content Integration in Cisco StadiumVision Director
Information About Scoreboard Integration in Cisco StadiumVision Director
Supported NFL GSIS Data
Cisco StadiumVision Director supports the NFL GSIS Game Clock and all of the statistics in the 
Cumulative Statistics XML file (CumulativeStatisticsFile). For more information and documentation for 
these statistics, go to:

http://www.nflgsis.com/gsis/

From the NFL GSIS Home page, click Documentation. Click the corresponding documentation links 
for the Cumulative Statistics Report and the Real-time Game Information (Game Clock).

Information About Scoreboard Integration in Cisco 
StadiumVision Director

This section includes the following topics:

 • Overview of Scoreboard Integration Support, page 3

 • Network Considerations for Scoreboard Integration, page 3

Overview of Scoreboard Integration Support
Cisco StadiumVision Director scoreboard integration allows you to display real-time information (such 
as period, score, and clock) on Cisco StadiumVision Director TV displays.

Figure 3 shows a high-level overview of the scoreboard integration support. Cisco StadiumVision 
Director Release 3.0 supports the following devices and sports:

 • Daktronics All Sport 5000 Scoreboard Controller (basketball and hockey only)

 • OES ISC9000 Intelligent Scoreboard Controller (basketball and hockey only)

Figure 3 Scoreboard Integration High-Level Overview

Network Considerations for Scoreboard Integration
Cisco StadiumVision Director communicates with the supported scoreboard controllers through a User 
Datagram Protocol (UDP) port connection. Both the corresponding controller interface and the 
Cisco StadiumVision Director server must be configured to establish the network connectivity between 
these devices.
3
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Overview of External Content Integration in Cisco StadiumVision Director
Overview of the External Content Integration Interface
Overview of the External Content Integration Interface
The External Content Integration feature is implemented using two basic areas of the Control Panel:

 • Setup

The Setup screen for Content Integration consists of two tabs that are used to configure the network 
connection for the data source and to select and map statistics for output display.

 • Widgets

The Widgets screen for Content Integration is used to add graphics and design the layout for the 
statistics that you want to display.

The remainder of the tasks associated with publishing external content to a TV display use the existing 
Cisco StadiumVision Director playlist and script creation interfaces.
4
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Configuring External Content Integration in 
Cisco StadiumVision Director

First Published: August 2, 2012

This module describes the requirements and how to configure support for external data sources in Cisco 
StadiumVision Director.

This module includes the following topics:

 • Before You Begin, page 5

 • Workflow Summary for External Content Integration, page 7

 • How to Configure External Content Integration, page 10

Before You Begin
Before you configure Cisco StadiumVision Director for External Content Integration, be sure that the 
following requirements are met for the system that you are integrating with:

 • Prerequisites for Configuring NFL GSIS Integration, page 5

 • Prerequisites for Configuring OES ISC9000 Scoreboard Integration, page 6

 • Prerequisites for Configuring Daktronics All Sport 5000 Scoreboard Integration, page 7

Prerequisites for Configuring NFL GSIS Integration
Before you configure the National Football League (NFL) Game Statistics and Information System 
(GSIS) integration, be sure that the following requirements are met:

 • The required Cisco StadiumVision Director server hardware is installed and running Cisco 
StadiumVision Release 3.0 or later.

 • The NFL Stats-in-a-Box (SIAB) server is installed at the venue and is connected to the NFL GSIS 
database. Advise your network administrator to allow communication between these two servers.

 • The SIAB server is reachable by the Cisco StadiumVision Director server on the Internet Protocol 
(IP) network.

 • For support of the NFL GSIS clock, a router in the network must be configured for Network Address 
Translation (NAT) to change the local broadcast address to the unicast IP address of the Cisco 
StadiumVision Director server.
5
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Configuring External Content Integration in Cisco StadiumVision Director
Before You Begin
Tip You can verify reachability using the ping command from the Cisco StadiumVision Director 
server to the SIAB server. 

 • The NFL GSIS representative has provided the SIAB IP address and account information, which 
will be needed to configure Cisco StadiumVision Director connectivity to the SIAB server.

Prerequisites for Configuring OES ISC9000 Scoreboard Integration
Before you configure the OES ISC9000 Intelligent Scoreboard Controller integration, be sure that the 
following requirements are met:

 • The required Cisco StadiumVision Director server hardware is installed and running Cisco 
StadiumVision Release 3.0 or later.

 • The OES ISC9000 Scoreboard controller is installed at the venue (preferably in the Cisco 
StadiumVision network).

 • The OES ISC9000 Scoreboard controller is reachable by the Cisco StadiumVision Director server 
on the Internet Protocol (IP) network.

 • A site administrator or OES equipment vendor has added the Cisco StadiumVision Director server 
IP address and UDP port number in the OES controller.

Note Be sure to record the UDP port number used in the OES ISC9000 controller so that you can 
configure the same port in the network connection information for Cisco StadiumVision 
Director.

Figure 1 shows an example of the interface for the Serial Port Configuration on the OES ISC9000 
controller where the Cisco StadiumVision Director server information must be added.

Figure 1 OES ISC9000 Configuration
6
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Workflow Summary for External Content Integration
Prerequisites for Configuring Daktronics All Sport 5000 Scoreboard Integration
Before you configure the Daktronics All Sport 5000 Scoreboard integration, be sure that the following 
requirements are met:

 • The required Cisco StadiumVision Director server hardware is installed and running Cisco 
StadiumVision Release 3.0.

 • The Daktronics Scoreboard controller is installed at the venue (preferably in the Cisco 
StadiumVision network).

 • The Daktronics Scoreboard controller is reachable by the Cisco StadiumVision Director server on 
the Internet Protocol (IP) network.

 • A site administrator or Daktronics equipment vendor has added the Cisco StadiumVision Director 
server IP address in the Daktronics Scoring Timing Interface Application. 

Figure 2 shows an example of the DSTI application for the Daktronics controller where the Cisco 
StadiumVision Director server information must be added.

Figure 2 Daktronics All Sport 5000 Configuration

Workflow Summary for External Content Integration

Note This workflow assumes that you have completed the required backend network installation and 
integration at your venue for the external data sources that you plan to support, such as with the NFL 
GSIS network and Stats-in-a-Box (SIAB) server, or scoreboard device.

The following steps summarize the overall workflow to integrate data into Cisco StadiumVision Director 
and display that content on a TV:

Control Panel Setup Interface—External Content Configuration Tab

1. From the Control Panel, access the External Content interface.

2. Select the data source that you want to configure.

3. Complete the network connection configuration.
7
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Configuring External Content Integration in Cisco StadiumVision Director
Workflow Summary for External Content Integration
4. Modify any configuration options, such as data throttling, as applicable.

5. Enable the configuration.

6. Save the configuration.

Note Whenever you modify and save the External Content configuration, you must activate and restart 
the application in the Management Dashboard. Cisco StadiumVision Director prompts you to do 
this, and it can be done at this step or after you finish mapping and formatting your statistics.

Control Panel Setup Interface—Field Mapping Tab

7. Complete the field mapping for the selected data source by selecting the available statistics that you 
want to display in Cisco StadiumVision Director.

8. Format each statistic to set the output field name and any other output criteria as desired. 
8
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Configuring External Content Integration in Cisco StadiumVision Director
Workflow Summary for External Content Integration
Management Dashboard—External Content Integration

9. Activate and restart the External Content Integration application from the Management Dashboard.

Control Panel Widgets Interface

10. Use the Widgets tool from the Control Panel to design a layout of the statistics that you configured 
to add graphics and bind/position data fields, and save the widget. See the “Designing the Layout of 
External Content Using the Widgets Tool” module for more information.
9
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Configuring External Content Integration in Cisco StadiumVision Director
How to Configure External Content Integration
11. Create a playlist from the Control Panel for the widget that you created. Widgets are categorized in 
the “By Type” folder under the “widget” type.

12. Create an event script to run the playlist.

13. Schedule the script to display the content on a TV just like other pieces of content in Cisco 
StadiumVision Director.

How to Configure External Content Integration 
This section includes the following tasks:

 • Accessing the External Content Integration Interface, page 10 (required)

 • Configuring the Network Connection to the External Content Source, page 11 (required)

 • Configuring Data Throttling, page 14 (optional)

 • Enabling the Data Source Configuration, page 16 (required)

 • Activating External Content Integration System-Wide From the Management Dashboard, page 16 
(required)

 • Restarting the External Content Integration Application, page 17 (required)

 • Selecting Input Statistics and Mapping to Output Fields for Display, page 18 (required)

 • Verifying the Integration, page 19 (required)

Accessing the External Content Integration Interface

To access the external content integration interface, complete the following steps:

Step 1 Log into Cisco StadiumVision Director as an administrator.

Step 2 From the main menu, click Control Panel.

Step 3 To access the external content integration interface, do one of the following:

 • From the Setup screen, point your cursor to the blank tab on the far right end of the tab list. 
10
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Configuring External Content Integration in Cisco StadiumVision Director
How to Configure External Content Integration
The tab bar automatically scrolls horizontally to reveal the remaining tabs. Click External Content.

 • From the Setup screen, click the arrow to open the drop-down list of all tabs and click External 
Content.

Configuring the Network Connection to the External Content Source
Complete one or more of the following tasks according to the external content sources that your site is 
going to use:

 • Configuring the Connection to the NFL GSIS SIAB Server, page 11

 • Configuring the Connection to the Scoreboard Controllers, page 13

Configuring the Connection to the NFL GSIS SIAB Server

This section includes the following topics:

 • Configuring the FTP Connection for NFL Cumulative Statistics, page 11

 • Configuring the UDP Connection for the NFL Game Clock, page 12

Configuring the FTP Connection for NFL Cumulative Statistics

Note Before you configure the FTP connection, be sure that you have the IP address and account credentials 
for the SIAB server from your NFL GSIS representative.

Cisco StadiumVision Director uses FTP port 21 to communicate to the NFL GSIS SIAB server to obtain 
the GSIS statistics.
11
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Configuring External Content Integration in Cisco StadiumVision Director
How to Configure External Content Integration
To configure the FTP connection to the NFL GSIS SIAB server, complete the following steps:

Step 1 In the left pane, select the GSIS: NFL,Cumulative Statistics data source type.

Step 2 Click the Configuration tab.

Step 3 In the Connection information (FTP) section, configure the following options (Figure 3):

a. In the Server (IP Address) box, type the IP address of the SIAB server.

b. In the Port box, type 21.

c. In the Data path box, type “/”.

d. In the User box, type the username for the SIAB server account. The default is nfl.

e. In the Password box, type the password for the SIAB server account. The default is nfl.

Figure 3 NFL Cumulative Statistics FTP Connection Configuration

Step 4 Click Save.

A message box appears asking you to restart the application.

Step 5 If you have completed all of the changes that you want to make on the Configuration tab, restart the 
application.

For more information, see the “Restarting the External Content Integration Application” section on 
page 17. 

Configuring the UDP Connection for the NFL Game Clock

Cisco StadiumVision Director uses UDP port 50000 to communicate to the NFL GSIS SIAB server to 
obtain the GSIS game clock.

To configure the UDP connection for the NFL game clock, complete the following steps:

Step 1 In the left pane, select the GSIS: NFL,Clock data source type.

Step 2 Click the Configuration tab.

Step 3 In the Connection information (UDP) section, configure the following options (Figure 4):

a. In the StadiumVision Director (IP Address) box, type the IP address of the Cisco StadiumVision 
server.
12
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How to Configure External Content Integration
Tip The actual IP address of the Cisco StadiumVision server that you are logged into is provided in 
shadow, but you must type the address in the box to configure it.

b. In the Port box, type 50000.

Figure 4 NFL Game Clock UDP Connection Configuration

Step 4 Click Save.

A message box appears asking you to restart the application.

Step 5 If you have completed all of the changes that you want to make on the Configuration tab, restart the 
application.

For more information, see the “Restarting the External Content Integration Application” section on 
page 17. 

Configuring the Connection to the Scoreboard Controllers

Cisco StadiumVision Director uses a UDP port to communicate to the controllers to obtain the 
scoreboard statistics. 

Note The UDP port for the OES ISC9000 Scoreboard controller varies, but the UDP port for the Daktronics 
All Sport 5000 Scoreboard controller is always 21300. Be sure that you know the UDP port being used 
for the OES controller.

To configure the UDP connection to the scoreboard controllers, complete the following steps:

Step 1 In the left pane, select the scoreboard data source type that you want to configure.

Step 2 Click the Configuration tab.

Step 3 In the Connection information (UDP) section, configure the following options (Figure 5):

a. In the StadiumVision Director (IP Address) box, type the IP address of the Cisco StadiumVision 
server.

Tip The actual IP address of the Cisco StadiumVision server that you are logged into is provided in 
shadow, but you must type the address in the box to configure it.
13
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Configuring External Content Integration in Cisco StadiumVision Director
How to Configure External Content Integration
b. In the Port box, type the UDP port number used to connect to the scoreboard controller.

Note For the Daktronics All Sport 5000 Scoreboard controller, the UDP port is always 21300 
(Figure 5).

Figure 5 Daktronics Scoreboard Controller UDP Connection Configuration

Step 4 Click Save.

A message box appears asking you to restart the application.

Step 5 If you have completed all of the changes that you want to make on the Configuration tab, restart the 
application.

For more information, see the “Restarting the External Content Integration Application” section on 
page 17. 

Configuring Data Throttling

Caution Data throttling is required to maintain optimum DMP performance to support external content 
integration in Cisco StadiumVision Director. Be sure that if you plan to modify the data throttling values, 
you understand that DMP performance could be severely impacted, and that you make the change only 
when no events are running in the venue and during an adequate maintenance window for the system.

The following data throttling options are provided in Cisco StadiumVision Director:

 • Wait to read data from source (FTP polling interval)—NFL cumulative statistics only

Specifies how often (in milliseconds) to retrieve data from the SIAB server. The recommended value 
is 5000 ms (5 seconds).

 • Wait to push data to destination

Specifies the frequency with which the data is multicast to all DMPs in the Cisco StadiumVision 
Director server. The recommended value is 5000 ms (5 seconds).

 • Push data if wait exceeds

If there has not been any change in data since the last poll, then this throttle specifies the longest 
amount of time to wait before sending the multicast of unchanged data to all DMPs. The 
recommended value is 15000 ms (15 seconds).
14
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How to Configure External Content Integration
To configure data throttling, complete the following steps:

Step 1 In the left pane, select the data source type.

Step 2 Click the Configuration tab.

The configuration for the selected data source appears in the right pane.

Step 3 In the Data throttling section, set one or more of the throttling values.

Figure 6 shows a throttling configuration example for the NFL cumulative statistics data source.

Figure 6 NFL Cumulative Statistics Throttling Configuration Example

Figure 7 shows a throttling configuration example for the NFL clock UDP data source.

Note The same throttling options are available for the scoreboard controller UDP connections.

Figure 7 NFL Clock Throttling for UDP Configuration Example

Step 4 Click Save.

A message box appears asking you to restart the application.

Step 5 If you have completed all of the changes that you want to make on the Configuration tab, restart the 
application.

For more information, see the “Restarting the External Content Integration Application” section on 
page 17. 
15
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How to Configure External Content Integration
Enabling the Data Source Configuration
By default, external data collection and configuration is disabled. Once you have completed your 
configuration, you must both enable the data source and save the configuration to allow collection of the 
data. 

Note Real-time data collection from the SIAB server will not begin until the External Content Integration 
application has been both enabled and restarted in Cisco StadiumVision Director. For more information, 
see the “Activating External Content Integration System-Wide From the Management Dashboard” 
section on page 16 and “Restarting the External Content Integration Application” section on page 17.

To enable the data source configuration, complete the following steps:

Step 1 In the left pane, select the GSIS data source type.

Step 2 Click the Configuration tab.

The configuration for the selected data source appears in the right pane.

Step 3 At the top of the pane, select the Enabled checkbox.

A checkmark appears in the box when the data source is enabled.

Step 4 Click Save.

A message box appears asking you to restart the application.

Step 5 If you have completed all of the changes that you want to make on the Configuration tab, restart the 
application.

For more information, see the “Restarting the External Content Integration Application” section on 
page 17. 

Activating External Content Integration System-Wide From the Management 
Dashboard

By default, External Content Integration is disabled system-wide in Cisco StadiumVision Director. After 
you have saved and enabled your data source configuration, you must activate the application and restart 
it from the Management Dashboard before data collection can begin.

The External Content Integration application must only be activated once to deploy it in the Cisco 
StadiumVision Director server. Once the External Content Integration application has been activated in 
the system, then any time the configuration has been changed, the application only must be restarted.

To activate External Content Integration system-wide, complete the following steps:

Step 1 Log into Cisco StadiumVision Director as an administrator.

Step 2 From the Cisco StadiumVision Director main menu, click Management Dashboard.

Step 3 Using the Management Dashboard drawers, go to Tools > Settings > External Content Integration.

Step 4 Select Activate Application. 
16
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Configuring External Content Integration in Cisco StadiumVision Director
How to Configure External Content Integration
Step 5 Click the Play button. 

Step 6 When the confirmation message box appears, click Ok to run the command.

Step 7 To verify the application activation, look for the success message in the log display area of the screen.

Step 8 After the processing has completed, select Restart Application. 

For more information, see the “Restarting the External Content Integration Application” section on 
page 17.

Restarting the External Content Integration Application 
Any time that you have made a change to the External Content Integration settings on the Configuration 
tab for external data sources, you must restart the application from the Cisco StadiumVision Director 
Management Dashboard. 

When you save the configuration, a message is displayed as a reminder to restart:

Note Changes to the data source field mapping only need to be saved, but the application does not have to be 
restarted. However, if for some reason you did not do a restart of the application after making changes 
in the Configuration tab before going on to save changes in Field mapping, then you also will see this 
message about the required restart at the time you save the Field mapping.
17
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Configuring External Content Integration in Cisco StadiumVision Director
How to Configure External Content Integration
To restart the External Content Integration Application, complete the following steps:

Step 1 Log into Cisco StadiumVision Director as an administrator.

Step 2 From the Cisco StadiumVision Director main menu, click Management Dashboard.

Step 3 Using the Management Dashboard drawers, go to Tools > Settings > External Content Integration.

Step 4 Select Restart Application. 

Step 5 Click the Play button to run the command.

Step 6 When the confirmation message box appears, click Ok to run the command.

Step 7 To verify the application activation, look for the success message in the log display area of the screen.

Selecting Input Statistics and Mapping to Output Fields for Display

To select input statistics and map to output fields for display, complete the following steps:

Step 1 In the left pane, select the GSIS data source type.

Step 2 Click the Field Mapping tab.

The Input field displays the name of the data file for the selected NFL data source 
(CumulativeStatisticsFile or GameClock).

Step 3 To view the available statistics, click the arrow beside the data file name to expand the list.

Step 4 With your mouse, select a statistic and drag-and-drop it to the Output Fields panel on the right.

The Add Output field dialog box is displayed.
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Step 5 Modify the Output field name or other mapping options as needed.

For more information, see the “Modifying the Output Format of a Statistic” section on page 25.

Step 6 Continue to select and add statistics to the Output fields panel.

Step 7 Click Save.

Verifying the Integration
This section includes the following topics:

 • Verifying Receipt of Real-Time Data, page 19

 • Verifying the Integration Broker Service Status, page 21

Verifying Receipt of Real-Time Data

Assuming that your network connection to the external data source is available and you have enabled the 
data source, real-time data is collected after you both activate and restart the application in the 
Management Dashboard.

To verify the receipt of real-time data, complete the following steps:

Step 1 From the External Content Integration interface, select the data source that you want to verify.

Step 2 Click Field mapping.

Step 3 In the Output fields panel, select the View data checkbox.

Note The interface can show sample data and real-time data. Figure 8 shows which View data 
checkbox in the interface corresponds to each type of data.
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Figure 8 View Data Checkbox for Sample Data Versus Real-Time Data

Step 4 In the Output field, select a statistic.

Step 5 Observe the data value at the bottom of the panel for the selected statistic.

Figure 9 shows an example of real-time data for the NFL GSIS clockTime statistic.

Figure 9 Clock Time Real-Time Data Statistic

Step 6 Click the Refresh icon (Figure 10) and observe that the value is changing to confirm receipt of real-time 
data.

Figure 10 Refresh Icon for Real-Time Data
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Verifying the Integration Broker Service Status

To verify the integration broker service status, complete the following steps:

Step 1 From the Management Dashboard, go to the Service Alerts pane in the bottom right corner.

Step 2 Navigate to find the Integration Broker service name and observe its status icon.

When the icon is green, the External Content Integration service is successfully activated.
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First Published: August 2, 2012

This module describes some of the optional and advanced tasks that you can perform for External 
Content Integration in Cisco StadiumVision Director.

This module includes the following topics:

 • Disabling the Data Source Configuration, page 23 

 • Deactivating the External Content Integration Application From the Management Dashboard, 
page 24 

 • Viewing Sample Data Versus Real-Time Data, page 24

 • Modifying the Output Format of a Statistic, page 25

Disabling the Data Source Configuration
To disable the data source configuration, complete the following steps:

Step 1 In the left pane, select the GSIS data source type.

Step 2 Click the Configuration tab.

The configuration for the selected data source appears in the right pane.

Step 3 At the top of the pane, select the Enabled checkbox so that the checkmark is removed and the box is 
empty.

Step 4 Click Save.

A message box appears asking you to restart the application.

Step 5 If you have completed all of the changes that you want to make on the Configuration tab, restart the 
application.

For more information, see the “Restarting the External Content Integration Application” section on 
page 17. 
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Deactivating the External Content Integration Application From 
the Management Dashboard

By default, the External Content Integration Application is deactivated in Cisco StadiumVision Director.

If you have activated the application, but your site is no longer going to connect to any external servers, 
then you can deactivate it to disable the functionality of the application system-wide in Cisco 
StadiumVision Director.

To deactivate the External Content Integration application, complete the following steps:

Step 1 Log into Cisco StadiumVision Director as an administrator.

Step 2 From the Cisco StadiumVision Director main menu, click Management Dashboard.

Step 3 Using the Management Dashboard drawers, go to Tools > Settings > External Content Integration.

Step 4 Select Deactivate Application. 

Step 5 Click the Play button to run the command.

Step 6 When the confirmation message box appears, click Ok to run the command.

Step 7 After the processing has completed, select Restart Application and click the Play button.

Step 8 When the confirmation message box appears, click Ok to run the command.

The deactivation of the application will be completed.

Viewing Sample Data Versus Real-Time Data
The External Content Integration feature supports viewing of both sample data and real-time data in the 
Field Mapping tab of the user interface. Figure 1 shows where each of these View data options are 
specified.

Figure 1 Selection of Sample Data v. Real-Time Data for External Content Integration

The External Content Integration feature ships with sample data for the different statistics that are 
available for selection. The user interface automatically displays these sample values for the statistics in 
the Sample data column of the Field mapping tab.

Figure 2 shows the sample data for the different statistics that are available from the NFL Game Clock 
data source.
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Figure 2 Sample Data for the NFL Game Clock Data Source

Notice that the View data option is not selected. You also can select the View data box on the Field 
mapping tab when you want to see the collective sample data for all of the statistics nested under a 
selected Input field. 

Figure 3 shows an example of the display of sample data using the View data option for the 
CumeStatHeader Input field of the CumulativeStatisticsFile for the NFL GSIS Statistics data source.

Figure 3 Sample Data for the CumeStatHeader Input Field 

To see real-time data in the interface for the selected statistics, select the View data checkbox on the right 
side of the Field mapping tab in the Output fields panel as shown in Figure 1. For more information, see 
the “Verifying Receipt of Real-Time Data” section on page 19.

Modifying the Output Format of a Statistic
You can use the default format and value of a mapped statistic for output using the default “Pass through 
input field” option, or you can modify its characteristics for display. 

The following types of actions can be taken on input field data:

 • Change the output field name.
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 • Add a character string as a prefix or suffix to the input field value. 

For example, if the default input value for an input field called Period1 was a numeric value “1,” you 
could specify “st” in the suffix box so that the input field value is appended with this string and 
appears in the output as “1st.”

 • Find an image from the content library to display in the widget. An image can be located using the 
image name (such as “Image1.png”), either as part of the value of the input field or as an explicit 
reference in the text box. If you are locating the image as part of the input field, be sure to select the 
“Lookup by input field reference” checkbox.

 • Modify the default XPath expression using an expression editor. Currently, the two functions 
supported are “lookup” and “concat.”

For example, if the default input value for an input field called Period1 has a numeric value “1,” you 
can locate an image, “1.png,” to represent the first half of a soccer game and use the expression 
editor to build an expression as follows:

fn:lookupContent(fn:concat(/SoccerGameSource/ScoringSummary/@Period1, '.png'))

This editing can be done either when you first add a statistic to the Output fields panel (in the Add Output 
field dialog box), or later if you edit the statistic from the Output fields panel (in the Edit Output field 
dialog box) as shown in Figure 4.

Figure 4 Change Output Field Dialog Box
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First Published: August 2, 2012

This module describes how to design the layout for display of the data that you have integrated and 
mapped for output in Cisco StadiumVision Director using the External Content Integration feature. This 
layout is required to create a content object referred to as a widget, that you can then publish with the 
standard features of Cisco StadiumVision Director using playlists and scripts for eventual display on 
TVs.

This module includes the following topics:

 • Prerequisites for Using the Widgets Tool, page 27

 • Restrictions for Using the Widgets Tool, page 28

 • Information About Using the Widgets Tool, page 28

 • How to Design the Layout of External Content for Display, page 30

 • Basic Widget Configuration Example, page 40

 • What to Do Next, page 43

Prerequisites for Using the Widgets Tool
Before you design the layout of external content, be sure that the following requirements are met:

 • You have configured the external data sources and mapped the statistics to output fields in the 
External Content Integration feature.

 • The data from the external source is being properly ingested by Cisco StadiumVision Director.

 • You have added any graphics that you want to add to the layout by importing them into Cisco 
StadiumVision Director from Control Panel > Content > Import.
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Restrictions for Using the Widgets Tool
Before you design the layout of external content using the Widgets tool, consider the following 
restrictions:

 • The Widgets layout tool can only be used for data sources that have been integrated into Cisco 
StadiumVision Director using the External Content Integration feature. 

 • Cisco StadiumVision Director only supports widgets that are created internally using the Widgets 
tool.

 • Up to16 different sessions can be supported in the Widgets tool on a single computer.

 • The maximum graphic size supported is 1920x1080, which is also the maximum size of the area 
supported in the Widgets layout tool. 

Note If you attempt to use a larger graphic in the Widgets tool, it might not be displayed.

 • The Widgets tool has the following font restrictions: 

 – Only the Arial font type with the ASCII character set is supported.

Note While you might be able to see a supported localized language and create text components with 
non-ASCII characters in the Widgets tool, these text components might not be rendered as 
expected on the DMP.

 – The maximum font size is limited to 128 due to a restriction by the DMP.

 – Importing of fonts is not supported.

 • You cannot view sample or real-time data as you create a widget.

 • The following functions are not supported in the Widgets tool:

 – Undo 

 – Deleting a group of multi-selected components

Information About Using the Widgets Tool
This section includes the following topics:

 • Components, page 28

 • Layers, page 29

 • Properties, page 29

 • Data Binding, page 29

 • User Interface Characteristics, page 30

Components
The Widgets tool supports two different component types:
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 • Text Area

 • Graphic

The Widgets tool uses the Graphic component to support the addition of images. Each time a graphic 
component is added to a widget, it is added in numerical order as a Layer on the canvas.

New components are added to the widget area simply by dragging the object type and dropping it onto 
the canvas or by double-clicking the component.

Layers
Similar to standard graphics editing applications, each time a Text Area or Graphic component is added 
to a widget, it is labeled in numerical order (by type) as a Layer on the canvas. Unless reordered, the first 
component added is at the bottom of the components added to the canvas, and the last component added 
is the topmost layer. In the user interface, the Layers box also lists the layers in stacking order with the 
topmost layer at the top of the list. In general, a background image should be at the bottom of the list.

You can reorder the layers by dragging and dropping them into a different order in the Layers box of the 
Widget tool.

The first graphic component added to the widget is identified as “graphic 1,” and the first text area is 
labeled “text area 1.” Components are numbered sequentially as they are added. Therefore, if you delete 
a component, that component number is not replaced. 

Tip You can rename a component by double-clicking it.

Properties
The Properties panel allows you to set the characteristics of a component including explicitly setting its 
size, location, and rotation on the canvas. Depending on the component type, some additional options 
are provided:

 • For Text Area components, you can specify the character string for the component, and select a font 
size and color. 

Tip Remember that the Widgets tool displays a white background for ease of use, but if you are not 
using any background images, a black font will be invisible on the TV screen because the TV 
background is actually black.

 • For Graphic components, you can import an image and also specify that it retain the dimensions of 
the original image.

Data Binding
After you have mapped the output fields for an external data source, you can bind that data to either type 
of component in a widget. 
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Note You cannot see any data in the widget component until you publish the widget and view it in an active 
script.

When you bind data to a text component, any text that you might have configured for that component 
will be replaced by the data when the widget is published.

User Interface Characteristics
Figure 1 shows the areas of the user interface for a new widget.

Figure 1 New Widget Interface

The Widgets tool interface supports some of the following functions and characteristics:

 • Multi-selection of components using standard Control key sequences to move components as a 
group.

 • Showing or hiding the bounding box of a component.

 • “Zoom-to-fit” function by double-clicking the zoom knob.

 • Change the widget dimensions by double-clicking the widget size in the upper right of the screen.

How to Design the Layout of External Content for Display
This section includes the following tasks:

 • Accessing the Widgets Tool, page 31

 • Creating New Widgets, page 31

 • Working with Images, page 33

 • Adding Text Areas, page 35

 • Showing the Component Bounding Box, page 35

 • Resizing and Rotating Components, page 37

 • Binding External Data to a Widget, page 38

 • Modifying Existing Widgets, page 39
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Accessing the Widgets Tool

To access the Widgets tool, complete the following steps:

Step 1 Log into Cisco StadiumVision Director as an administrator.

Step 2 From the main menu, click Control Panel > Widgets.

A dialog box opens for you to select an existing widget or create a new one (Figure 2).

Figure 2 Dialog Box to Open Existing or Create New Widgets

Creating New Widgets
You can create a new widget when you first access the Widgets tool, or you can create a new widget from 
within the tool.

To create a new widget from within the tool, complete the following steps:

Step 1 From the menu bar in the Widgets tool, click File > New.

The Create New dialog box is displayed (Figure 3).
31
Cisco StadiumVision Director External Content Integration Guide

 



 

Designing the Layout of External Content Using the Widgets Tool
How to Design the Layout of External Content for Display
Figure 3 Create New Dialog Box

Step 2 In the Name box, type a name for your new widget.

Step 3 Do one of the following to specify the size of the widget:

 • Click Pre-Set size and click the drop-down list to select a predefined dimension (WxH) for the 
canvas in pixels.

 • Click Custom Size and specify a number (in pixels) for the width and height dimensions of the 
canvas.

Step 4 Click Create.

The tool displays a white box of the size that you created, with the dimensions that you specified 
displayed in the upper right corner. 

Note The background canvas of the widget is actually transparent, but it is not shown with the 
graphics-standard checkerboard pattern to ease visibility of the components.

Step 5 Click File > Save.

Changes to the widget are saved.
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Working with Images
This section includes the following topics:

 • Adding Images, page 33

 • Resizing and Rotating Images, page 34

Adding Images

Images can be added as a background to your layout in the Widgets tool, and they also can be bound to 
a data field using the External Content configuration, such as to add a team logo to a score field that will 
appear in the widget. 

To support the addition of a graphic bound to a particular external source data field, see the “Modifying 
the Output Format of a Statistic” section on page 25.

The Widgets tool uses the Graphic component to support the addition of images as a background or in 
other places on your canvas. 

Prerequisite

Before you can add an image to a widget, you must import the image file into Cisco StadiumVision 
Director by going to Control Panel > Content > Import to select and open a file. In the Import Content 
dialog box, specify any options and click Upload.

Procedure

To add an image to a widget, complete the following steps:

Step 1 Open or create the widget where you want to add an image.

Step 2 In the Components box, select the Graphic component and drag and drop it onto your widget canvas 
(Figure 4).

Figure 4 Drag and Drop Graphic Component on Widget Canvas

Tip Double-click a component to automatically add it to the canvas.
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Step 3 To add an image, be sure that the graphic component where you want to add the image is selected, and 
click Change.

Step 4 In the Select Image dialog box, highlight the image that you want to add and click Select.

The image is added and scaled to the size of your graphic component box (Figure 5).

Figure 5 Image Added to Graphic Component

Step 5 Click File > Save.

Changes to the widget are saved.

Resizing and Rotating Images

Images will automatically scale to the size of the graphic component box in the widget. 

Tip To find the size of your image file, use the List view for your images in Control Panel > Content. Select 
your image and look at the size in the Dimension field in the “Other content metadata” box.

You can scale the graphic to its original size after you add it, or if you modify the image size in the 
widget, you can revert back to its original size using the “Use original image size” option, which is 
recommended.

Figure 6 shows the options available on the Properties panel for a graphic component and displays the 
different bounding box handles that can be used to modify the size of a component box.

Figure 6 Graphic Component Properties Panel and Bounding Box Handles
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You can modify the size and position of an image in the following ways:

 • Explicitly setting values on the Properties panel.

 • Selecting the bounding box and using the handles to modify it.

 • With the graphic component selected, select the “Use original image size” checkbox to revert the 
image to its original size when imported.

For more information, see the “Resizing and Rotating Components” section on page 37.

Adding Text Areas
A text area component is added to a widget in the same way as a graphic component, but with some 
different properties. A text area supports a character string, and font size and color selection.

Currently the only available font is Arial.

To add a text area to a widget, complete the following steps:

Step 1 Open or create the widget where you want to add the text area.

Step 2 In the Components box, select the Text Area component and drag and drop it onto your widget canvas.

Step 3 In the Properties panel, type the character string for the box, and select the font size and color.

Figure 7 shows the options available on the Properties panel for a sample text area component.

Figure 7 Text Area Component Properties

Step 4 Resize or position the text area as needed. For more details, see the “Resizing and Rotating Components” 
section on page 37.

Step 5 Click File > Save.

Changes to the widget are saved.

Showing the Component Bounding Box
When you add a component onto the canvas, a temporary bounding box appears while the component is 
selected. If you move away from that component into another area of the canvas, you will not be able to 
see the boundaries of the component box.
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Figure 8 shows an example of a text area and graphic component displaying the default setting without 
a visible boundary when the component is unselected. Notice that while the graphic component is 
selected the temporary bounding box is displayed in Figure 8, but when unselected it appears to 
disappear from the canvas (Figure 9).

Figure 8 Default Setting Without Bounding Box and Selected Component

Figure 9 Default Setting Without Bounding Box or Selected Components

To display a boundary around all components in the widget, complete the following steps:

Step 1 From the menu bar, go to View.

Step 2 Click Show bounding box. 

A checkmark appears beside the option when the bounding box is enabled for display, and all 
components will display a boundary around them. 
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Figure 10 shows an example of a text area and graphic component after the Show bounding box option 
is enabled.

Figure 10 Show Bounding Box Option Enabled

Step 3 Click File > Save.

Changes to the widget are saved.

Resizing and Rotating Components
You can resize and rotate both Text Area and Graphic components in the following ways:

 • Change the component location:

 – Select the component and manually drag it to the location that you want on the canvas.

 – Specify the x/y horizontal and vertical values directly in the Properties panel. 

 • Change the component size:

 – Select and drag a handle on the component’s bounding box to enlarge or reduce the component 
size. If using a handle on a side of the box, only that dimension is changed. If using a corner 
handle, both dimensions of the box are changed.

 – Shift+Click on a corner handle to resize the box proportionally.

 – Specify the width and height values directly in the Properties panel.

 • Change the component angle:

 – Select the rotation handle and drag the box up or down to rotate it.

 – Shift+Click on the rotation handle and drag the box up or down to change the angle in 45 degree 
increments. 

 – Specify the rotation value in degrees directly in the Properties panel.

Figure 11 identifies the bounding box handles that you can use to resize and rotate components.
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Figure 11 Bounding Box Handles

Binding External Data to a Widget
The widget supports the binding of external data to a text area component so that you can display 
dynamic output fields, such as game periods, scores, and so on from an external source.

Note If you add a text string to the component, it will be replaced by the real-time data from the output field 
that you specified in the Data Binding panel once the widget is published. 

Prerequisite

Before you can bind external data to a widget, you must have configured your external data source and 
mapped the output fields by going to Control Panel > Setup > External Content. For more information, 
see the “Configuring External Content Integration in Cisco StadiumVision Director”.

Procedure

To bind external data to a widget, complete the following steps:

Step 1 Open or create the widget where you want to add the text area.

Step 2 In the Components box, select the Text Area component and drag and drop it onto your widget canvas.

Step 3 In the Properties panel, select the font size and color. Optionally, specify a character string if you want 
to temporarily see some content in the component while the widget is open. 

The font size and color will be applied to the bound data.

Step 4 In the Data Binding panel, double-click in the first cell under the Data Source heading and open the 
drop-down list (Figure 12).

Figure 12 Accessing the Data Source List

Step 5 Click the drop-down list and select the data source from which you want to bind data. Use the scroll bar 
to reveal all data sources as necessary (Figure 13).
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Figure 13 Selecting the Data Source

Step 6 Double-click inside the cell for the data field and select the drop-down list to select the data output field 
that you want to display in the text area component (Figure 14).

Figure 14 Selecting the Data Field

Step 7 Click File > Save.

Changes to the widget are saved.

Modifying Existing Widgets
This section includes the following tasks:

 • Changing the Size of a Widget, page 39

 • Deleting Widgets, page 39

 • Renaming Widgets, page 40

Changing the Size of a Widget

To change the size of a widget, complete the following steps:

Step 1 Open the widget whose size you want to change.

Step 2 From the Edit menu, select Widget Dimension.

Step 3 In the Change Widget Dimension dialog box, specify the new width and height values.

Step 4 Click Change.

Deleting Widgets

To delete a widget, complete the following steps:

Step 1 From the File menu, select Manage Widgets.

Step 2 In the Manage Widget dialog box, select the widget that you want to remove.
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Step 3 Click Delete.

Renaming Widgets

To rename a widget, complete the following steps:

Step 1 From the File menu, select Manage Widgets.

Step 2 In the Manage Widget dialog box, select the widget that you want to rename.

Step 3 Click Rename.

The widget name is changed to an editable box.

Step 4 Type a new name for the widget.

Step 5 Click Close.

Basic Widget Configuration Example
This section shows a basic widget configuration example to bind external data for an OES Ice Hockey 
Scoreboard data source. The example uses an image background (Figure 15) that creates static headings 
for Period, Time Outs, and Score, with companion text area components that will be created as layers on 
top of the background. 

These text areas will be positioned beneath the background image headings and will have real-time data 
bound to them to appear in the widget once it is published.

Figure 15 Image Background for Scoreboard Widget 

To create a widget and bind data to it, complete the following steps:

Step 1 Create a new widget with size 1920x1080.

Step 2 In the Components box, select the Graphic component and drag and drop it onto your widget canvas.

Step 3 With the graphic component selected, go to the Properties panel and click Change.
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Step 4 In the Select Image dialog box, click on the background image that you want to add and click Select.

The image is added and scaled to the size of your graphic component box.

Step 5 In the Properties tab, specify the following values (Figure 16):

a. x and y—0

b. width —1920

c. height—1080

d. rotation—0

Figure 16 Background Image Added to Graphic Component

Step 6 Create two new text area components to add “HOME” and “GUEST” as the specified text string 
positioned as layers on top of the background graphic component (Figure 17).

Figure 17 Addition of Home and Guest Text Areas

a. Drag and drop the Text Area component onto the background graphic.

b. In the Properties panel, specify the following values:

 – Text box—Type “HOME”

 – Font size—128

 – Font color—Choose yellow

c. Select the handles on the text area box and expand its boundaries enough to reveal the text.

d. Select the text area component and drag it to the left side of the background graphic over the Time 
Outs Left and Score fields.
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e. Repeat steps a–d using “GUEST” text and drag the component to the right side of the background 
graphic.

Step 7 Add Text Area components to bind data for Period, Time Outs, and Score areas for both teams:

a. Drag and drop the Text Area component onto the background graphic.

b. (Optional) Zoom in as needed to see the component better.

c. Position and resize the component beneath the heading for which you are going to bind 
corresponding data (Figure 18).

d. (Optional) Add text to temporarily identify what data will be in the box, such as “period_data.”

Figure 18 Text Area Component to Bind Period Data

e. In the Data Binding panel, select the OES: Ice Hockey, Scoreboard data source and the period data 
field (Figure 19).

Figure 19 Period Data Field Binding for OES Ice Hockey Scoreboard Source

f. Repeat steps a–e for all other data fields that you need to bind.

Step 8 Click File > Save.

Changes to the widget are saved.
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What to Do Next
After you have completed creating a widget, complete the following steps to publish it for display:

1. Create a playlist from the Control Panel for the widget that you created. Widgets are categorized in 
the “By Type” folder under the “widget” type.

2. Create an event script to run the playlist.

3. Schedule the script to display the content on a TV.
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First Published: August 2, 2012

This module describes how to monitor and troubleshoot problems with External Content Integration in 
Cisco StadiumVision Director.

This module includes the following topics:

 • Monitoring the External Content Integration Log, page 45

 • Troubleshooting NFL GSIS Statistics Problems, page 47

Monitoring the External Content Integration Log
All logging messages for External Content Integration are written to the following log file and location:

/opt/sv/servers/mule/mule.log

While logging can always be seen directly from the Unix console, you can also view messages using the 
log viewer in the Management Dashboard. When you start the log viewer, informational messages are 
displayed as the default severity level.

The log file is compressed once a day at 24:00.

Starting and Stopping the Log Viewer
If logs are turned on, they increase in size over time, which can lead to disk space issues.  Therefore, it 
is recommended that you use the log functionality only during troubleshooting.

To start and stop the log viewer, complete the following steps:

Step 1 Log into Cisco StadiumVision Director as an administrator.

Step 2 From the Cisco StadiumVision Director main menu, click Management Dashboard.

Step 3 Using the Management Dashboard drawers, go to Tools > Settings > External Content Integration.
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Step 4 Do the following:

 • To start logging, select Start Log Viewer.

 • To stop logging, select Stop Log Viewer.

Step 5 Click the Play button to run the command.

Modifying the Severity Level of Messages Displayed in the Log Viewer

Caution The logging service for External Content Ingestion can produce a very large number of messages when 
you specify the debug severity level, many of which can be seen only from the Unix console. Be sure to 
stop the log viewer or change the severity level of messages being logged, and do not allow the log to 
run continuously in debug mode to avoid potential problems with system performance or an unusually 
large log file. This can also use a lot of disk space on the hard drive.

The External Content Integration log supports 4 severity levels for messages, and each increasing 
severity level is cumulative and includes the logging of all message severity levels below it:

 • Debug

 • Info—This is the default.

 • Warn

 • Error

To modify the severity level of messages displayed in the log viewer, complete the following steps:

Step 1 Log into Cisco StadiumVision Director as an administrator.

Step 2 From the Cisco StadiumVision Director main menu, click Management Dashboard.

Step 3 Using the Management Dashboard drawers, go to Tools > Settings > External Content Integration.

Step 4 In the System panel, click the arrow in the Log Level drop-down list box:

a

Step 5 Select the severity level of the message that you want to view in the log.
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Troubleshooting NFL GSIS Statistics Problems
To troubleshoot any problems with obtaining the NFL GSIS statistics, look at the following areas:

 • Verify that the GSISGameStats.xml file resides on the SIAB server in the root directory.

Note There are five other GSIS files in this directory, but only the GSISGameStats.xml file is used by 
Cisco StadiumVision Director.

 • Verify connectivity to the SIAB server and access to the XML file using the following command 
from a Unix console on Cisco StadiumVision Director:

curl -u ‘user:pswd’ ftp://ip-address/GSISGameStats.xml

where user and pswd are replaced with your SIAB server username and password credentials from 
the NFL GSIS representative, and ip-address is replaced by the IP address of your SIAB server.

 • Check the External Content Integration logs in the Management Dashboard for FTP errors. For more 
information, see the “Monitoring the External Content Integration Log” section on page 45.

 • Restart the External Content Integration application from the Management Dashboard by navigating 
to Tools > Settings > External Content Integration > Restart Application.
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