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Preface

This preface describes who should read the Cisco Service Control Application Reporter User Guide, how 
it is organized, and its document conventions.

This guide is intended for experienced network administrators who are responsible for generating reports 
of the daily operation using the Cisco Service Control Application Reporter (SCA Reporter).

Document Revision History

Description of Changes 

Added the following new features:

 • Configuring colors used in charts. See:

 – How to Set the Colors Used in Charts, page 2-12

 – How to Change the Colors Used in a Chart, page 5-11

 • Configuring the chart legend globally (see How to Configure the Legend Displayed in Charts, 
page 2-17)

Cisco Service Control Release Part Number Publication Date

Release 3.1.5 OL-8411-05 November, 2007

Cisco Service Control Release Part Number Publication Date

Release 3.1.0 OL-8411-04 May, 2007
vii
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Description of Changes 

Added the following new features:

 • Installing the SCA Reporter under Linux, page 2-6

 • New Command-Line Interface commands

 • Prescheduled Reports, page 6-1

 • Virtual Links Monitoring Template Group, page D-8 and new templates to existing template groups

Description of Changes 

Editorial changes only

Description of Changes 

 • Updated Online Help

 • Added Troubleshooting Section

 • Added Glossary

Cisco Service Control Release Part Number Publication Date

Release 3.0.5 OL-8411-03 November, 2006

Cisco Service Control Release Part Number Publication Date

Release 3.0.3 OL-8411-02 May, 2006

Cisco Service Control Release Part Number Publication Date

Release 3.0.0 OL-8411-01 December, 2005
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Organization
The major sections of this guide are as follows:

Table 1 Documentation Organization 

Chapter Title Description

Chapter 1 General Overview Provides a brief overview of the 
Cisco Service Control solution 
and describes the components of 
the system.

Chapter 2 Getting Started Provides an introduction to the 
Cisco Service Control 
Application Reporter (SCA 
Reporter), explains some basic 
concepts, and provides 
instructions on how to install and 
launch the SCA Reporter. It also 
provides Basic terminology and 
a Quick Start section.

Chapter 3 Using the Cisco Service Control 
Application Reporter

Describes basic and advanced 
configuration of the SCA 
Reporter. It also describes how to 
navigate in the GUI.

Chapter 4 Managing Report Instances Describes the features of the 
SCA Reporter, including 
creating a new report instance 
and modifying an existing report 
instance.

Chapter 5 Working with Reports Describes the available actions 
for the SCA Reporter, including 
viewing and adjusting the chart 
display.

Chapter 6 The SCA Reporter 
Command-Line Interface

Explains how to use the SCA 
Reporter Command-Line 
Interface to generate reports.

Appendix A Installing and Upgrading SCA 
Reporter Templates

Describes how to install and 
upgrade SCA Reporter 
templates.

Appendix B Troubleshooting Describes SCA Reporter error 
messages and their probable 
causes and solutions.

Appendix C The SCA Reporter as a Tool in 
the SCA BB Console

Describes the SCA Reporter as a 
tool in the SCA BB Console.

Appendix D SCA Reporter Templates Describes the properties of 
report instances created from the 
SCA Reporter templates, 
organized by template groups.
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Related Publications
The following related publications are available for the Cisco Service Control Application Reporter:

 • Cisco Service Control Application for Broadband User Guide 

 • Cisco Service Control Application for Broadband Reference Guide 

 • Cisco Service Control Management Suite Collection Manager User Guide 

To view Cisco documentation or obtain general information about the documentation, refer to the 
following sources:

 • Obtaining Documentation and Submitting a Service Request, page xi

 • The Cisco Information Packet that shipped with your SCE 2000 platform.

Conventions
This document uses the following conventions:

Table 3-2 Documentation Conventions 

Convention Description

boldface font Commands and keywords are in boldface .

italic font Arguments for which you supply values are in 
italics .

[ ] Elements in square brackets are optional.

{x | y | z} Alternative keywords are grouped in braces and 
separated by vertical bars.

[x | y | z] Optional alternative keywords are grouped in 
brackets and separated by vertical bars.

string A nonquoted set of characters. Do not use 
quotation marks around the string, or the string 
will include the quotation marks.

screen font Terminal sessions and information that the system 
displays are in screen font.

boldface screen font Information you must enter is in boldface screen 
font.

italic screen font Arguments for which you supply values are in 
italic screen font.

<> Nonprinting characters, such as passwords, are in 
angle brackets.

[ ] Default responses to system prompts are in square 
brackets.

!, # An exclamation point (!) or a pound sign (#) at the 
beginning of a line of code indicates a comment 
line.
x
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Note Means reader take note . Notes contain helpful suggestions or references to materials not covered in this 
manual.

Caution Means reader be careful . In this situation, you might do something that could result in equipment 
damage or loss of data.

Warning Means reader be warned . In this situation, you might do something that could result in bodily injury.

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional 
information, see the monthly What’s New in Cisco Product Documentation, which also lists all new and 
revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed 
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free 
service and Cisco currently supports RSS Version 2.0.
xi
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General Overview  

This chapter provides a general overview of the Cisco Service Control solution. It introduces the Cisco 
Service Control concept and the Service Control capabilities.

It also briefly describes the hardware capabilities of the Service Control Engine (SCE) platform and the 
Cisco specific applications that together compose the total Cisco Service Control solution.

 • Information About the Cisco Service Control Concept, page 1-1

 • Cisco Service Control Capabilities, page 1-2

 • The SCE Platform, page 1-3

 • Information About Management and Collection, page 1-4

Information About the Cisco Service Control Concept  
The Cisco Service Control solution is delivered through a combination of purpose-built hardware and 
specific software solutions that address various service control challenges faced by service providers. 
The SCE platform is designed to support classification, analysis, and control of Internet/IP traffic.

Service Control enables service providers to create profitable new revenue streams while capitalizing on 
their existing infrastructure. With the power of Service Control, service providers have the ability to 
analyze, charge for, and control IP network traffic at multigigabit wire line speeds. The Cisco Service 
Control solution also gives service providers the tools they need to identify and target high-margin 
content-based services and to enable their delivery.

As the downturn in the telecommunications industry has shown, IP service providers’ business models 
need to be reworked to make them profitable. Having spent billions of dollars to build ever larger data 
links, providers have incurred massive debts and faced rising costs. At the same time, access and 
bandwidth have become commodities where prices continually fall and profits disappear. Service 
providers have realized that they must offer value-added services to derive more revenue from the traffic 
and services running on their networks. However, capturing real profits from IP services requires more 
than simply running those services over data links; it requires detailed monitoring and precise, real-time 
control and awareness of services as they are delivered. Cisco provides Service Control solutions that 
allow the service provider to bridge this gap.
1-1
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Chapter 1      General Overview
  Cisco Service Control Capabilities
Service Control for Broadband Service Providers 
Service providers of any access technology (DSL, cable, mobile, and so on) targeting residential and 
business consumers must find new ways to get maximum leverage from their existing infrastructure, 
while differentiating their offerings with enhanced IP services.

The Cisco Service Control Application for Broadband adds a new layer of service intelligence and 
control to existing networks that can:

 • Report and analyze network traffic at subscriber and aggregate level for capacity planning

 • Provide customer-intuitive tiered application services and guarantee application SLAs

 • Implement different service levels for different types of customers, content, or applications

 • Identify network abusers who are violating the Acceptable Use Policy

 • Identify and manage peer-to-peer, NNTP (news) traffic, and spam abusers

 • Enforce the Acceptable Use Policy (AUP)

 • Integrate Service Control solutions easily with existing network elements and BSS/OSS systems

Cisco Service Control Capabilities  
The core of the Cisco Service Control solution is the purpose-built network hardware device: the Service 
Control Engine (SCE). The core capabilities of the SCE platform, which support a wide range of 
applications for delivering Service Control solutions, include:

 • Subscriber and application awareness—Application-level drilling into IP traffic for real-time 
understanding and controlling of usage and content at the granularity of a specific subscriber.

 – Subscriber awareness—The ability to map between IP flows and a specific subscriber in order 
to maintain the state of each subscriber transmitting traffic through the SCE platform and to 
enforce the appropriate policy on this subscriber’s traffic.

Subscriber awareness is achieved either through dedicated integrations with subscriber 
management repositories, such as a DHCP or a Radius server, or via sniffing of Radius or DHCP 
traffic.

 – Application awareness—The ability to understand and analyze traffic up to the application 
protocol layer (Layer 7).

For application protocols implemented using bundled flows (such as FTP, which is implemented 
using Control and Data flows), the SCE platform understands the bundling connection between 
the flows and treats them accordingly.

 • Application-layer, stateful, real-time traffic control—The ability to perform advanced control 
functions, including granular BW metering and shaping, quota management, and redirection, using 
application-layer stateful real-time traffic transaction processing. This requires highly adaptive 
protocol and application-level intelligence.

 • Programmability—The ability to quickly add new protocols and easily adapt to new services and 
applications in the ever-changing service provider environment. Programmability is achieved using 
the Cisco Service Modeling Language (SML).

Programmability allows new services to be deployed quickly and provides an easy upgrade path for 
network, application, or service growth.
1-2
Cisco Service Control Application Reporter User Guide

OL-8411-05



Chapter 1      General Overview
  The SCE Platform
 • Robust and flexible back-office integration—The ability to integrate with existing third-party 
systems at the Service Provider, including provisioning systems, subscriber repositories, billing 
systems, and OSS systems. The SCE provides a set of open and well-documented APIs that allows 
a quick and robust integration process.

 • Scalable high-performance service engines—The ability to perform all these operations at wire 
speed.

The SCE Platform  
The SCE family of programmable network devices is capable of performing application-layer 
stateful-flow inspection of IP traffic, and controlling that traffic based on configurable rules. The SCE 
platform is a purpose-built network device that uses ASIC components and RISC processors to go 
beyond packet counting and delve deeper into the contents of network traffic. Providing programmable, 
stateful inspection of bidirectional traffic flows and mappingthese flows with user ownership, the SCE 
platforms provide real-time classification of network usage. This information provides the basis of the 
SCE platform advanced traffic-control and bandwidth-shaping functionality. Where most bandwidth 
shaper functionality ends, the SCE platform provides more control and shaping options, including:

 • Layer 7 stateful wire-speed packet inspection and classification

 • Robust support for over 600 protocols and applications, including:

 – General—HTTP, HTTPS, FTP, TELNET, NNTP, SMTP, POP3, IMAP, WAP, and others

 – P2P file sharing—FastTrack-KazaA, Gnutella, BitTorrent, Winny, Hotline, eDonkey, 
DirectConnect, Piolet, and others

 – P2P VoIP—Skype, Skinny, DingoTel, and others

 – Streaming and Multimedia—RTSP, SIP, HTTP streaming, RTP/RTCP, and others

 • Programmable system core for flexible reporting and bandwidth control

 • Transparent network and BSS/OSS integration into existing networks

 • Subscriber awareness that relates traffic and usage to specific customers

The following diagram illustrates a common deployment of an SCE platform in a network.

Figure 1-1 SCE Platform in the Network
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Chapter 1      General Overview
  Information About Management and Collection
Information About Management and Collection  
 • Network Management, page 1-4

 • Subscriber Management, page 1-5

 • Service Configuration Management, page 1-5

 • Data Collection, page 1-5

The Cisco Service Control solution includes a complete management infrastructure that provides the 
following management components to manage all aspects of the solution:

 • Network management

 • Subscriber management

 • Service Control management

These management interfaces are designed to comply with common management standards and to 
integrate easily with existing OSS infrastructure.

Figure 1-2 Service Control Management Infrastructure

Network Management 
Cisco provides complete network FCAPS (Fault, Configuration, Accounting, Performance, Security) 
Management.

Two interfaces are provided for network management:

 • Command-line interface (CLI)—Accessible through the Console port or through a Telnet 
connection, the CLI is used for configuration and security functions.

 • SNMP—Provides fault management (via SNMP traps) and performance monitoring functionality.
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  Information About Management and Collection
Subscriber Management 
Where the Cisco Service Control Application for Broadband (SCA BB) enforces different policies on 
different subscribers and tracks usage on an individual subscriber basis, the Cisco Service Control 
Management Suite (SCMS) Subscriber Manager (SM) may be used as middleware software for bridging 
between the OSS and the SCE platforms. Subscriber information is stored in the SM database and can 
be distributed between multiple platforms according to actual subscriber placement.

The SM provides subscriber awareness by mapping network IDs to subscriber IDs. It can obtain 
subscriber information using dedicated integration modules that integrate with AAA devices, such as 
Radius or DHCP servers.

Subscriber information may be obtained in one of two ways:

 • Push Mode—The SM pushes subscriber information to the SCE platform automatically upon logon 
of a subscriber.

 • Pull Mode—The SM sends subscriber information to the SCE platform in response to a query from 
the SCE platform.

Service Configuration Management 
Service configuration management is the ability to configure the general service definitions of a service 
control application. A service configuration file containing settings for traffic classification, accounting 
and reporting, and control is created and applied to an SCE platform. The SCA BB application provides 
tools to automate the distribution of these configuration files to SCE platforms. This simple, 
standards-based approach makes it easy to manage multiple devices in a large network.

Service Control provides an easy-to-use GUI to edit and create these files and a complete set of APIs to 
automate their creation.

Data Collection 
The Cisco Service Control solution generates usage data and statistics from the SCE platform and 
forwards them as Raw Data Records (RDRs), using a simple TCP-based protocol (RDR-Protocol). The 
Cisco Service Control Management Suite (SCMS) Collection Manager (CM) software implements the 
collection system, listening in on RDRs from one or more SCE platforms and processing them on the 
local machine. The data is then stored for analysis and reporting functions, and for the collection and 
presentation of data to additional OSS systems such as billing.
1-5
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Getting Started  

The Cisco Service Control Application Reporter (SCA Reporter) is the Cisco Service Control 
Application tool that allows you to produce reports based on the traffic analysis performed by the Service 
Control Engine (SCE) platform. The information is sent from the SCE platform and is stored in a 
database. The SCA Reporter can query and retrieve information from the database and present the results 
in a comprehensive range of reports, including global monitoring, subscriber monitoring, P2P, and traffic 
discovery statistics reports.

 • System Components, page 2-1

 • System Requirements, page 2-2

 • Installing the SCA Reporter under Windows, page 2-2

 • Installing the SCA Reporter under Linux, page 2-6

 • How to Launch the SCA Reporter, page 2-6

 • Configuring the SCA Reporter, page 2-8

 • Accessing Online Help, page 2-18

 • Quick Start, page 2-20

System Components 
The SCA Reporter is a valuable tool for understanding the habits and resource consumption of the 
applications and subscribers that use your network. It can also be used to judge the efficacy of various 
rules and the possible impact of their implementation on the network.

The SCA Reporter is available only in a deployment with a database. You can generate reports using any 
of the following methods:

 • Standalone application

 • Command-line interface (CLI)—See The SCA Reporter Command-Line Interface, page 6-1

 • Tool of the SCA BB Console—See The SCA Reporter as a Tool in the SCA BB Console, page C-1

The available reports can be displayed in a variety of chart renderings (for example, stacked-bar or area) 
or in tabular form. You can adjust the chart display for various presentation options (for example, 3D). 
You can export both tabular and chart reports to files. You can also modify the reports by changing the 
values assigned to the properties (for example, time boundaries). You can duplicate, export, and save 
reports.

You can also generate reports using the SCA Reporter Command-Line Interface (CLI) without using the 
GUI.
2-1
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  System Requirements
SCA Reporter consists of visual components (known as views). The following are the views and the tasks 
that you can perform in each view:

 • Templates view—Select a report template, create a new report instance, and generate a report.

 • Properties view—View properties of the object in focus and their values. The object in focus can be 
a template group, a report template, a report instance, or the chart display of a report. You can 
configure report instance and chart display properties.

 • Report view—View a graphical representation or tabular display of the data of the report. Each 
report is displayed in its own report view.

 • Progress view—Monitor reports executed or exported. You can view progress details in this view, 
and also choose to generate reports in the background so that you can continue working on other 
reports.

Generating a report can be divided into five broad steps:

1. Create a report instance from the Templates view.

2. Configure the properties of the report instance in the Properties view.

3. Execute the report instance.

4. View the report in tabular or graphic form in its report view.

5. Adjust the chart display of the report in the Properties view.

You can generate multiple reports simultaneously and later export them. While the reports are executing, 
you can monitor them and put them in the background by using the Progress view.

System Requirements 
You can install and run the SCA Reporter GUI front end and command-line application on any computer 
running Windows 98, Windows 2000, Windows NT, or Windows XP.

You can install the SCA Reporter command-line application for Linux on any computer running Red Hat 
Enterprise Linux 4.

The computer should have a minimum of 512 MB of memory; 1024 MB of memory is highly 
recommended.

Minimum screen resolution is 1024 by 768 pixels.

Installing the SCA Reporter under Windows 
 • How to Install the SCA Reporter under Windows, page 2-2

 • How to Uninstall the SCA Reporter under Windows, page 2-5

How to Install the SCA Reporter under Windows 

Step 1 Navigate to the SCA Reporter installation file, SCA Reporter 3.1.5 Setup.exe, and double-click it.

The Welcome page of the SCA Reporter 3.1.5 Setup wizard appears.
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Step 2 Click Next.

The Install Location page of the Setup wizard opens.

Step 3 (Optional) Click Browse to choose a different destination folder.

Step 4 Click Next.

The Start Menu Folder page of the Setup wizard opens.
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Step 5 (Optional) Enter a different Start Menu folder in the Start Menu Folder field.

Step 6 Click Install.

The Installing page of the Setup wizard opens.

Step 7 Wait until installation is complete.

The Installation Complete page of the Setup wizard opens.
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Step 8 Click Finish.

The SCA Reporter 3.1.5 Setup wizard closes.

The SCA Reporter is now installed on the machine.

How to Uninstall the SCA Reporter under Windows  

Step 1 Choose Start > All Programs > Cisco SCA > SCA Reporter 3.1.5 > Uninstall.

Step 2 Click Yes.

Step 3 Click OK.

The SCA Reporter is uninstalled from the machine.
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Installing the SCA Reporter under Linux 
You can install the SCA Reporter under Linux, and then run it from the command line. (See The SCA 
Reporter Command-Line Interface, page 6-1.)

 • How to Install the SCA Reporter under Linux, page 2-6

 • How to Uninstall the SCA Reporter under Linux, page 2-6

How to Install the SCA Reporter under Linux  

Step 1 Download the SCA BB installation package (reporter-cmd-linux.tgz) from the CCO.

Step 2 Open the installation package in a selected directory, using the command tar xpzf 
reporter-cmd-linux.tgz.

Step 3 From the installation directory, run the command reportercmd.sh –setup.

How to Uninstall the SCA Reporter under Linux  

Step 1 Delete the installation directory.

How to Launch the SCA Reporter 
You can access the SCA Reporter from the Start menu.

Step 1 Choose Start > All Programs > Cisco SCA > SCA Reporter 3.1.5 > SCA Reporter 3.1.5.

The Cisco Service Control SCA Reporter splash screen appears.
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After the SCA Reporter has loaded, the main window of the SCA Reporter appears, displaying the 
Welcome view.

Step 2 Close the Welcome view.

The Templates view is displayed.
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Configuring the SCA Reporter 
You must create a basic configuration for the SCA Reporter, which includes selecting a database type, 
connecting to a database, activating the database, and setting the IP address of the Service Control 
Engine (SCE) platform whose service configuration data is to be used.

In bundled mode, the Cisco Service Control Management Suite (SCMS) Collection Manager (CM) is 
used with the Sybase Adaptive Server Enterprise (Sybase ASE). The Sybase data management platform 
supports transaction-intensive enterprise applications. It enables you to store and retrieve information 
online and can warehouse information as needed. (For more information, see the Cisco Service Control 
Management Suite Collection Manager User Guide.) The CM can also be configured to work with 
Oracle and MySQL databases.

After a database is activated, you must select the IP address of one of the SCE platforms in the database. 
The choice is made for each repository, represented by a tab in the Preferences dialog box. All options 
offered in the Templates view of the SCA Reporter (available packages, services, etc.) are determined 
by the service configuration currently applied to the configured SCE platform. Each report is generated 
according to the SCE device to which it is configured. In the example configuration, there is one SCE 
device connected to the database and one repository preference.

 • Managing Database Connections, page 2-8

 • How to Set the IP Address of an SCE Platform, page 2-11

 • How to Set the Colors Used in Charts, page 2-12

 • How to Configure the Legend Displayed in Charts, page 2-17

 • How to Configure Advanced Options for the SCA Reporter, page 2-18

Managing Database Connections  
To use the SCA Reporter, you must create and activate a connection to a database containing data 
generated from an SCE platform.

You can add connections to a number of databases, and then change the active database as required.

 • How to Add a Database Connection, page 2-8

 • How to Activate a Database Connection, page 2-11

How to Add a Database Connection  

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 From the Preferences tree, select Reporter > Databases.
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Step 3 In the Databases pane, click Add.

The Add Database wizard appears.

Step 4 Select one of the Choose definition mode radio buttons.

 • Simple 

 • Advanced 

Step 5 Click Next.

The Define new database connection page of the Add Database wizard opens. The actual display depends 
on the definition mode you selected in Step 4:

 • If you selected Simple definition mode:
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 • If you selected Advanced definition mode:

Step 6 Fill in all the fields.

Step 7 (Optional) Check the activate this database check box.

Step 8 Click Finish.

The Add Database wizard closes.

The definition of the database is added to the list in the Preferences dialog box.
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Step 9 Click OK.

The Preferences dialog box closes.

How to Activate a Database Connection  

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 From the Preferences tree, select Reporter > Databases.

All defined database connections are listed in the table.

The currently active database (if any) is shown by a check mark ( ).

Step 3 Select the database connection you wish to activate.

Step 4 Click Activate.

Step 5 Click OK.

The Preferences dialog box closes.

How to Set the IP Address of an SCE Platform  

Note The Preferences dialog box contains one tab for each repository (set of templates) that is available in the 
Reporter. In each, you choose one SCE platform. If there is more than one repository, there will be more 
than one set of template groups in the Templates view.

Step 1 From the main menu, choose Window > Preferences.
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The Preferences dialog box appears.

Step 2 In the Preferences tree, select Reporter > Templates.

Step 3 In the Templates pane, from the IP of SCE for policy data drop-down list, select the IP address of the 
SCE platform whose service configuration data is to be used in reports. This IP address is added to the 
SCA Reporter templates repository.

Step 4 Click Apply.

The IP address of the SCE platform is set for service configuration data.

Note You must click Apply before you close the dialog box by clicking OK.

Step 5 Click OK.

The Preferences dialog box closes.

How to Set the Colors Used in Charts  
Instead of using the default color set for charts that is installed as part of the Reporter installation (the 
predefined colors are packaged within the SCA BB Templates package), you can define your own color 
set(s).

This allows you to ensure color persistence between different sessions of the Reporter, including:
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 • different sessions of the same Reporter installation

 • different Reporter installations using data from the same SCE platform, by exporting and importing 
color files

 • different Reporters using data from different SCE platforms

 • different versions of the Reporter

 • How to Work with Color Sets, page 2-13

 • How to Change the Color of Single Legend Items, page 2-15

How to Work with Color Sets  

The Color Set File  

Each line of the a color set file defines the color of one legend item.

It is recommended that you do not edit the color set file manually.

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 In the Preferences tree, select Reporter > Charts Colors.

The Charts Colors preference page opens.

Step 3 Select an action to perform.

 • To import a color set from a file, click Import.
2-13
Cisco Service Control Application Reporter User Guide

OL-8411-05



Chapter 2      Getting Started
  Configuring the SCA Reporter
An Open dialog box appears. Browse to the required file and click Open. The file is imported and 
overwrites the existing color set.

 • To export the current color set to a file, click Export.

A Save As dialog box appears. Browse to the required directory, enter a file name in the File name 
field, and click Save. The color set is exported.

 • To Restore the default color set (the predefined colors delivered with the SCA BB Templates 
package), click Restore Defaults.

 • To enable the color allocation method used prior to release 3.1.5, check the Enable legacy coloring 
mode check box.

Note Before applying Import, Restore Defaults, or Enable legacy color mode, a warning is displayed.

Step 4 Click OK.

The Preferences dialog box closes.
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How to Change the Color of Single Legend Items  

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 In the Preferences tree, select Reporter > Charts Colors.

The Charts Colors preference page opens.

Step 3 Select a legend item (in the following screen capture, a service) from the color tree.

Note Possible categories of legend items are Direction, Hostname, Host IP, Protocol, MOS, Range, Codec, 
Port Number, Newsgroup, Protocol, Service, Measure, and Subscriber. 
 
Categories and legend items are only displayed in the Charts Colors pane after colors are allocated to 
legend items. Colors are allocated to any legend items in the chart the first time a report instance is 
executed.

The current color of the legend item is displayed in the top right of the Charts Colors pane.

Step 4 Click on the displayed color.

A color palette dialog box appears.
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Step 5 Select a new color for the legend item and click OK.

The Color dialog box closes.

The selected color is applied to the legend item.

The Reset button is enabled.
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Note The Reset button restores the default color of a single selected legend item.

How to Configure the Legend Displayed in Charts  
You can configure globally the appearance of the legend in charts.

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 In the Preferences tree, select Reporter > Configuration.

Step 3 (Optional) Uncheck the Show item check box in legend check box.

Step 4 (Optional) Uncheck the Allow multi column in legend check box.

Step 5 (Optional) In the Max legend percentage field, enter a new value.

Step 6 Click OK.

The new settings are saved.

The Preferences dialog box closes.
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How to Configure Advanced Options for the SCA Reporter  
You can configure the following advanced options of the SCA Reporter:

 • Whether to log debug messages

 • The time to wait for a database connection

 • The maximum number of report instances that can be executed simultaneously

Step 1 From the main menu, choose Window > Preferences.

The Preferences dialog box appears.

Step 2 In the Preferences tree, select Reporter > Configuration.

Step 3 To log debug messages, check the Send debug messages to log check box.

Logging debug messages can cause the log file to grow rapidly.

Step 4 In the Seconds to wait for a database connection field, enter a new value.

Step 5 In the Maximum number of reports that can be executed simultaneously field, enter a new value.

Step 6 Click OK.

The new settings are saved.

The Preferences dialog box closes.

Accessing Online Help 
 • How to Access Online Help, page 2-19

 • How to Search Online Help, page 2-19
2-18
Cisco Service Control Application Reporter User Guide

OL-8411-05



Chapter 2      Getting Started
  Accessing Online Help
How to Access Online Help  
You can access relevant parts of this user guide from the SCA Reporter.

Step 1 From the Help menu, choose Help Contents.

Online help opens in a separate window.

How to Search Online Help  
You can also search online help from inside the SCA Reporter.

Step 1 From the Help menu, choose Search.

The Help view opens in the Reporter window.

Step 2 Enter a word, phrase, or more complex search expression in the Search expression field.

The Go button is enabled.

Note Click >> (Expand) for an explanation of how to construct search expressions.
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Step 3 Click Go.

Help topics containing your search expression are listed under Local Help.

Step 4 Click a help topic to view its contents.

Note You can bookmark topics for later reference.

Step 5 By clicking the appropriate link at the bottom of the Help view, you can switch to:

 • All topics

 • Related topics

 • Bookmarks

Quick Start 
This Quick Start section will help you get started with the SCA Reporter. You will configure the 
Reporter, create a report instance and generate a report, and then work with the report.

 • How to Create a First Report, page 2-20

 • How to Work with a First Report, page 2-24

How to Create a First Report  

Step 1 Launch the SCA Reporter (choose Start > All Programs > Cisco SCA > SCA Reporter 3.1.5 > SCA 
Reporter 3.1.5).
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Step 2 Add, configure, and activate a database connection (see Managing Database Connections, page 2-8).

Step 3 Set the IP address of the SCE platform (see How to Set the IP Address of an SCE Platform, page 2-11).

Step 4 Confirm that there is an active database and that the system is configured correctly. (From the main 
menu, choose Help > Check Conditions.)

Step 5 In the Templates view, expand the node of one of the template groups.
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Step 6 Right-click a report template.

A popup menu appears.

Step 7 From the menu, select New.

A report instance is added below the report template.
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The report instance has the same name as the report template with the addition of “#1”. You can rename 
the report instance.

The Properties view opens in the bottom right of the SCA Reporter window, displaying the basic report 
instance properties.

Step 8 If any property has the value  (not set) , assign it a value.

Step 9 Click  (Execute) to generate the report.

A report view, with the name of the report instance, opens in the top right of the SCA Reporter window, 
displaying a chart of the report.
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Step 10 View your report.

The chart display properties are shown in the Properties view.

How to Work with a First Report  

Step 1 Create a report, as described in the previous procedure.

Step 2 Adjust the chart display by modifying the chart display properties in the Properties view. (See Adjusting 
the Chart Display, page 5-8.)

Step 3 In the report view, from the drop-down menu above the view, select Go To Report.

The Properties view displays the report instance properties.

Step 4 Display all the report instance properties by clicking  (Show Advanced Properties).
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Step 5 Modify one or more properties. (See How to Modify an Existing Report Instance, page 4-3.)

Step 6 Click  (Execute) to regenerate the report.

The modified report is displayed in the report view.

(In the illustrated example, the Select services to view property was modified, and Browsing, Generic, 
and P2P were checked.
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Using the Cisco Service Control Application 
Reporter  

This chapter explains how to use the Cisco Service Control Application Reporter (SCA Reporter) GUI, 
which includes navigating and configuring.

Navigating in the Reporter: Views 
You can navigate to template groups, report templates, and report instances in the Templates view. When 
you select an item in the Templates view, the Properties view shows its properties.

When you generate a report, a report view opens and the Properties view shows the chart display 
properties of the report. To view the report instance properties, select the report instance in the Templates 
view. If necessary, you can locate the report instance that generated the report by choosing the drop-down 
menu item Go to report.

Each report view has the name of the report instance that generated the view. For example, a report may 
be named Global Bandwidth per Service #1. You can rename the report instance in the Templates view.

By default, each report view shows the chart of the report. You can view the raw data by clicking the 
Table tab.

 • Viewing Menu Items, page 3-1

 • Configuring Properties, page 3-2

 • Properties View, page 3-2

Viewing Menu Items 
The GUI has a drop-down menu for each view, which displays all available actions for that view. Some 
commonly used actions have icons for easy navigation.

The GUI also has a popup menu for each view. Right-click the tab of a view, and select an option to 
personalize the layout of the SCA Reporter window. Some of the available actions are:

 • Detached—Detach a view and move it over the SCA Reporter window

 • Move—Move a view or a tab group

 • Size—Change the size of a pane
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Configuring Properties 
Before generating a report, you can modify the values of the report instance properties. The new values 
are saved and applied the next time the report is generated.

You can also modify the values of chart display properties. For chart display properties, the value is 
applied at once.

Types of properties include:

 • No Value—When no value is assigned, (not set) is displayed. Mandatory properties that have no 
default value display as  (not set).

 • Free Text—You can enter any text string.

 • Boolean—The value toggles between True and False.

 • Date—Click the  icon to open a Choose Date and Time dialog box.

 • Single Choice—Click the  icon to open a drop-down menu.

 • Multiple Choice—Click the  icon to open a dialog box where more than one value can be 
checked.

The icons of the Multiple Choice dialog box are described in the following table.

Note Some properties are mutually exclusive. The properties From the last number of hours and Starting 
after date and time cannot both be implemented, even if both are selected. 
 
Thus, if you want to define the time frame to begin at a specified time, select Starting after date. Even 
if From the last number of hours is also chosen, the report time frame will be according to the date 
and time values.

Properties View  
The Properties view always shows the properties of the item that is selected in the view in focus. You 
can control how the properties are displayed by clicking on one of the following buttons:

 •  (Show Categories)—To view the properties with or without their categories

 •  (Show Advanced Properties)—To view all properties or only basic properties

Table 3-1 Multiple Choice Dialog Box Options 

Icon Option Description

Select All Select all values.

Invert Selection Uncheck the checked boxes and 
check the unchecked.

Select None Uncheck all boxes.

Cancel Exit the Multiple Choice dialog 
box without saving.

OK Save and exit the Multiple 
Choice dialog box.
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 •  (Restore Default Value)—To reset a selected property to its default value:

 – When a property is optional, it is unset.

 – When a property is mandatory and has a default value, it is reset to the default value.

 – When a property is mandatory and does not have a default value, the value is not changed.

To change the value of a property, select the property and reconfigure it (see How to Configure the 
Properties of a Report Instance, page 4-3 and Configuring the Properties of a Chart Display, page 5-8). 
Then re-execute the report instance so that the new report will appear with the new configuration.

The following example uses the “Package Bandwidth per Service” report template.

How to Change the Display of Properties in the Properties View 

Step 1 In the Templates view, select a report template and create a report instance.

The Properties view displays the report instance properties.

By default, the property categories are displayed and advanced properties are not displayed.

Step 2 Click  (Show Categories).

The display of property categories is toggled off.

Step 3 Click  (Show Advanced Properties).

All properties are displayed.
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Step 4 Click  (Show Categories).

The display of property categories is toggled on.
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Managing Report Instances  

The Cisco Service Control Application Reporter (SCA Reporter) installation includes report templates 
for a wide variety of reports, such as:

 • Global, per package, or per subscriber hourly or daily usage volume per service

 • Top server/clients/protocols/web hosts/e-mail senders/newsgroups

 • Top P2P consumers/uploaders/downloaders/protocols

 • Global, package, or subscriber bandwidth per service

Each report instance is based on a report template. You can create, select, duplicate, and delete 
report instances in the Templates view of the SCA Reporter. When you select a report instance, its 
properties are displayed in the Properties view; you can specify values for the various report 
properties. For example, if you want to see global bandwidth per service, you can create a new report 
instance from the Templates view. The Properties view allows you to specify the desired service(s), 
traffic direction, and time frame (either start/end time or previous number of hours).

The exact procedure for defining a report instance depends on the report template selected. The 
example in this chapter is intended as a general guide to the process of creating and defining a new 
report instance.

 • How to Create a New Report Instance, page 4-1

 • How to Modify an Existing Report Instance, page 4-3

 • How to Configure the Properties of a Report Instance, page 4-3

 • How to Duplicate an Existing Report Instance, page 4-4

 • How to Rename an Existing Report Instance, page 4-5

 • How to Delete a Report Instance, page 4-5

How to Create a New Report Instance 

Step 1 In the Templates view, right-click a report instance (for example, Global Monitoring > Global Hourly 
Aggregated Minutes per Service).

A popup menu appears.
4-1
o Service Control Application Reporter User Guide



Chapter 4      Managing Report Instances
  How to Create a New Report Instance
Step 2 From the menu, select New.

A report instance is added below the report template.

The report instance has the name Global Hourly Aggregated Minutes per Service #1. (If you create 
another report instance from this report template, it will be named Global Hourly Aggregated Minutes 
per Service #2 , and so on. You can rename report instances.)

The Properties view opens in the bottom right of the SCA Reporter window, displaying the basic report 
instance properties.
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You can display all report instance properties by clicking  (Show Advanced Properties).

How to Modify an Existing Report Instance 

Step 1 Select a report instance.

Do one of the following:

 • Select an existing report view and, from the drop-down menu above the view, select Go to report.

 • Select a report instance from the Templates view.

The Properties view displays the report instance properties.

Step 2 Edit a property by clicking on the row of the property and making changes.

The change is saved. The new value is used the next time the report instance is executed.

How to Configure the Properties of a Report Instance 
The following is an example of assigning values to report instance properties.

Step 1 In the Templates view, choose (or create) a report instance.

The report instance is selected in the Templates view, and the Properties view displays the report instance 
properties.

Note If the property that you wish to modify is not displayed, click  (Show Advanced Properties).

Step 2 Click in the Traffic Direction property row and then click the icon that appears.

A drop-down menu of property values appears, for example:

Step 3 Select a value.

Step 4 Click in the Services to View property row and then click the icon that appears.

A checklist of property values appears.
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Step 5 Check the services you want to view.

Step 6 Click  (OK).

Step 7 Click in the Ending Before Date property row and then click the icon that appears.

A choose date and time dialog box appears.

Step 8 Select a date and time and click OK.

Step 9 Click  (Execute).

The report is generated with the configured values.

How to Duplicate an Existing Report Instance 
Duplicating an existing report instance is a useful way to create a new report instance similar to an 
existing report instance. It is faster to duplicate a report instance and then modify the duplicate, rather 
than to define the new report instance from scratch.

Step 1 In the Templates view, right-click a report instance.

A popup menu appears.
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Step 2 From the menu, select Duplicate.

The report instance is duplicated.

How to Rename an Existing Report Instance 
You can rename an existing report instance. This is useful when the same report is generated on a regular 
basis. You can include the date or other identifying information in the name of the report.

Step 1 In the Templates view, right-click a report instance.

A popup menu appears.

Step 2 From the menu, select Rename.

The report instance is highlighted and you can edit its name.

Step 3 Enter a new name and press Enter.

The report instance is renamed and listed with the new name.

How to Delete a Report Instance 
You can delete report instances.

Step 1 In the Templates view, right-click a report instance (or select several instances, by holding down the Ctrl 
key while selecting the report instances, and then right-click).

A popup menu appears.
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Step 2 From the menu, select Delete.

The selected report instances are deleted.
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Working with Reports  

After you have created and defined a report instance, you can generate reports from the report instance.

You can:

 • Display reports in chart or tabular form

 • Adjust the chart display

 • Export the chart display and the report data

 • Information About Report Actions, page 5-1

 • How to Generate Reports, page 5-4

 • How to View Reports, page 5-6

 • Adjusting the Chart Display, page 5-8

 • How to Export Reports, page 5-16

Information About Report Actions 
The views found on the SCA Reporter display menu items. Some commonly used actions have icons for 
easy navigation.

The actions and their icons are described in the following table.

Table 5-1 Actions and Icons 

Action Icon Description Comments

Home Opens the Welcome 
view.

Menu Displays all the 
available actions for the 
view.

Common to all views.
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View Filter — Filters display of 
template groups in the 
Templates view.

Display either all 
template groups or only 
groups that can be used 
when the service 
configuration that 
generated the data is 
running in asymmetric 
routing classification 
mode.

Debug Displays template code. In the Templates 
view—Used to debug 
the structure of a report 
template.

Execute Generates the selected 
report.

In the Properties view 
and the Templates view.

New or Report (from 
Legend)

Creates a new report 
instance.

In the Templates 
view—When you select 
a report template, the 
icon is new.

In each report 
view—When you 
right-click a legend 
item, the Subset of 
Template Groups and 
Templates dialog box 
appears. Choose a 
template and click OK. 
The report instance is 
created (modified).

Refresh Collapses open nodes in 
the Templates view so 
that only the template 
groups are displayed.

In the Templates view.

Show Cmd Opens a window 
displaying the CLI 
command for the report 
instance.

In the Templates 
view—The CLI 
commands are placed 
on the clipboard. You 
can paste them into a 
vanilla text editor, edit 
them, and then execute 
them from a command 
file shell or a command 
prompt.

Delete Deletes the report 
instance.

In the Templates view.

Table 5-1 Actions and Icons (continued)

Action Icon Description Comments
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Duplicate Creates a copy of the 
report instance.

In the Templates view.

Rename Highlights the report 
instance so that you can 
rename it.

In the Templates view.

Show Categories Toggles between 
displaying properties 
with and without 
categories.

In the Properties view.

Show Advanced 
Properties

Toggles between 
displaying basic 
properties and 
displaying all 
properties.

In the Properties view.

Restore Default Value Restores property 
default value.

In the Properties 
view—Default values 
can be a value or (not 
set). Mandatory 
properties are not reset 
to (not set).

Go to report — Navigates from the 
selected report view to 
the associated report 
instance in the 
Templates view.

In each report view.

Export raw data — Opens a browse dialog 
box.

In each report view.

Show List Lists generated reports 
that for which no report 
view is open.

Above the report 
views—To display a 
report, click the icon 
and choose from the 
report names in the 
drop-down list.

The number in the icon 
indicates how many 
reports are not in view.

Preferences — Opens a dialog box that 
allows you to choose 
whether to show system 
tasks or not.

Sleeping (waiting) tasks 
are shown in either case.

In the Progress 
view—The icon is 
displayed while system 
tasks are running.

Remove All Finished 
Tasks

Removes all completed 
tasks.

In the Progress view.

Table 5-1 Actions and Icons (continued)

Action Icon Description Comments
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How to Generate Reports 
You can generate a report from an existing, defined report instance. Report instances are found in the 
Templates view. You can duplicate, modify, rename, or delete the report instances (see Managing Report 
Instances, page 4-1). You can generate multiple reports; you can put the generate process in the 
background while working on other reports.

Some types of reports cannot be generated using data collected from an SCE platform running in 
asymmetric routing classification mode.

You can define and generate reports using the SCA Reporter Command-Line Interface (CLI). You can 
also use the CLI to pre-schedule reports. (See The SCA Reporter Command-Line Interface, page 6-1.)

 • How to View Report Types that can be Generated in Asymmetric Routing Classification Mode, 
page 5-4

 • How to Generate a Report When a Report Instance is Selected, page 5-4

 • How to Generate Multiple Reports, page 5-5

How to View Report Types that can be Generated in Asymmetric Routing 
Classification Mode 

Step 1 In the Templates view, from the drop-down menu, select View Filter >split-flow.

Template groups whose report instances cannot be executed for asymmetric routing classification mode 
data are hidden.

How to Generate a Report When a Report Instance is Selected  

Step 1 In the Templates view, select a report instance.

The Properties view displays the report instance properties.

Step 2 Click ( Execute ).

The report is generated and is displayed in a new report view.
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The Properties view displays the chart display properties.

How to Generate Multiple Reports  

Note The maximum number of reports that can be generated simultaneously is configurable. If you select 
more report instances than this maximum values, the generation of some of the reports will be queued.

Step 1 From the Templates view, select the report instances while pressing Ctrl.

The selected report instances are highlighted.

Step 2 Click ( Execute ).

A Progress dialog box appears while reports are being generated.

Step 3 Select a further action to take.

Do one of the following:

 • Wait until the system task status at the bottom right corner of the SCA Reporter indicates that report 
generation is complete.

While the reports are being generated, the system task status shows: 
 

 • Click Details.

The status of all reports that are being generated is displayed.
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 • Click Run in Background.

Report generation continues running in the background. When it finishes, each report is displayed 
in a separate report view.

 • Click Cancel.

You can cancel a running report generation. It can take the Database Server a short time to 
acknowledge a cancel request, but you can move the cancelled report to the background and continue 
your work uninterrupted.

How to View Reports 
You can view a report as a chart or as a table.

Step 1 To select the desired display, click the appropriate tab located at the bottom-left of the report view.
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The table is useful for locating specific information.
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Adjusting the Chart Display 
You can change the appearance and type of any report chart by modifying chart display properties, such 
as three-dimensional display settings, chart rendering, and chart colors. You can also change the 
appearance of a report in the following ways:

 • Drag the legend to a different spot in the report.

 • Hide the legend.

 • Hide items from the legend; the corresponding items in the graph will be removed from view.

 • Zoom in or out—drag the graph so that the desired section is in focus.

 • Configuring the Properties of a Chart Display, page 5-8

 • Changing the Appearance of the Chart, page 5-10

 • Zooming, page 5-12

 • Hiding Variables, page 5-13

 • Managing the Chart Legend, page 5-15

Configuring the Properties of a Chart Display 
You configure chart display properties in the Properties view. As you make changes, the chart display is 
updated. There are also adjustments that are made directly in the report view (see Adjusting the Chart 
Display, page 5-8).

Note Changes to chart display properties are not saved in the report instance. When you next execute the report 
instance, the report will be generated with default chart display properties.

The following table lists chart display properties and their descriptions:

Table 5-2 Chart Display Properties 

Property Type Default Values Comments

Look 

3D Boolean True True, False Toggles between 
the two values.

Chart rendering Single choice Depends on report 
template

See list following 
this table

The chart can be 
displayed in many 
graphical formats.

Legend visibility Boolean True True, False Toggles between 
the two values.

Look/3D 
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Possible values for the Chart Rendering property:

Oblique Boolean True True, False Only displayed 
when 3D is True.

If True, there is 
always 90 degrees 
between the x and 
y axes when the 
chart is rotated.

Settings Sliding scale See table 
following this 
table

See table 
following this 
table

Only displayed 
when 3D is True.

Opens the 3D 
properties dialog 
box with sliding 
scales for eight 
graphical 
properties.

Table 5-2 Chart Display Properties (continued)

Property Type Default Values Comments

Table 5-3 Chart Rendering Values 

 • BAR

 • STACKED_BAR

 • STACKED100_BAR

 • SUPERIMPOSED_BAR

 • AREA

 • STACKED_AREA

 • STACKED100_AREA

 • POLYLINE

 • STACKED_POLYLINE

 • STACKED100_POLYLINE

 • SCATTER

 • STAIR

 • STACKED_STAIR

 • STACKED100_STAIR

 • SUMMED_STAIR

 • PIE

Table 5-4 Chart Properties Set in the 3D Properties Dialog Box 

Property Values Default

Rotation -90 ... 90 35

Elevation -90 ... 90 45

Depth 0 ... 100 20

Depth Gap 0 ... 100 0

Zoom 0 ... 200 100

Ambient Light 0 ... 100 10

Light Latitude -90... 90 0

Light Longitude -90... 90 0
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Changing the Appearance of the Chart  
You can change the chart type of the report, adjust the graphical display of the chart, and change the 
colors used in the chart.

 • How to Change the Chart Type, page 5-10

 • How to Modify the Graphical Display, page 5-10

 • How to Change the Colors Used in a Chart, page 5-11

How to Change the Chart Type  

Step 1 Generate a report.

A report view opens displaying the report, and the Properties view displays the chart display properties.

Step 2 In the Properties view, select the Chart Rendering row, and click the browse button to open a drop-down 
list.

Step 3 From the drop-down list, choose the type of chart that you want to display.

The report is updated when you click anywhere else in the Properties view.

How to Modify the Graphical Display  

Step 1 Generate a report.

A report view opens displaying the report, and the Properties view displays the chart display properties.

Step 2 To display the chart in two dimensions, click the 3D property.

The value of the 3D property toggles from True to False and the Look/3D category is removed from the 
Properties view.

Step 3 Click the 3D property again.

The chart displays in three dimensions, and the Look/3D category reappears.

Step 4 Select the Settings property.

The 3D properties dialog box appears.
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Step 5 Change the three-dimensional properties using the sliding scales.

Step 6 The chart display changes as you change the properties.

Step 7 Click OK.

The new values are assigned to the Settings property.

How to Change the Colors Used in a Chart  

You can change the default color applied to a legend item in a chart. You may want to do this if, for 
instance, legend items that are adjacent in the chart have similar colors.

Note If legacy coloring is enabled (see How to Set the Colors Used in Charts, page 2-12), this option is not 
available.

Note You can create and apply your own color sets globally. See How to Set the Colors Used in Charts, 
page 2-12.

Step 1 Generate a report.

A report view opens displaying the report.

Step 2 Right-click an item in the legend.

A popup menu appears.
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Step 3 From the menu, select either Edit Color (this chart only) or Edit Entity Color. The former option 
changes the color temporarily for this chart only, the latter makes the change persistent for all current 
and future charts.

A color palette opens.

Step 4 Select a new color from the palette.

Step 5 Close the palette.

The new color is applied in the chart to the selected variable.

If you selected Edit Entity Color at Step 3, the new color is applied to all open charts, except those using 
temporary colors.

Zooming  
 • How to Zoom in on a Two-Dimensional Chart, page 5-12

 • How to Drag a Zoomed-In Chart, page 5-13

 • How to Zoom Out of a Zoomed-In Chart, page 5-13

How to Zoom in on a Two-Dimensional Chart  

You can zoom in or out of two-dimensional charts.

While you are zoomed-in, you can drag the chart to view different sections.
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Step 1 Generate a report.

A report view opens displaying the report, and the Properties view displays the chart display properties.

Step 2 To display the chart in two dimensions, click the 3D property.

The value of the 3D property toggles from True to False and the Look/3D category is removed from the 
Properties view.

Step 3 Mark off a rectangle by dragging the mouse over the chart.

The cursor changes to a plus icon.

Step 4 Release the mouse button, and the view zooms in.

How to Drag a Zoomed-In Chart  

Step 1 Generate a report and display the chart in two dimensions.

Step 2 Zoom in to the top part of the chart.

Step 3 To move the chart down, right-click it while dragging the chart.

The chart moves up, and the bottom of the chart appears.

How to Zoom Out of a Zoomed-In Chart  

Step 1 Mark off a rectangle by dragging the mouse over the chart while pressing the Shift key.

The cursor changes to a minus icon.

Step 2 Release the mouse button, and the view zooms out.

Hiding Variables  
You can hide variables that are part of the report, so that they do not display in the chart.

Note You can also select which variables will be included in the report by modifying the report instance. (See 
How to Modify an Existing Report Instance, page 4-3.)

 • How to Hide Variables in the Chart, page 5-13

 • How to Redisplay a Hidden Variable, page 5-14

How to Hide Variables in the Chart  

Step 1 Generate a report.

A report view opens displaying the report.
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Step 2 Right-click a variable in the legend.

A popup menu appears.

Step 3 From the menu, select Hide.

The variable is dimmed out in the legend and removed from the chart.

How to Redisplay a Hidden Variable  

Step 1 Right-click a dimmed variable in the legend.

A popup menu appears.

Step 2 From the menu, select Show.

The variable is restored in the legend and displayed from the chart.
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Managing the Chart Legend  
You can move the chart legend from its default position, or you can remove it from the chart display.

Note You can also globally configure how the legend is displayed. See How to Configure the Legend 
Displayed in Charts, page 2-17.

 • How to Move the Chart Legend, page 5-15

 • How to Hide the Chart Legend, page 5-15

How to Move the Chart Legend  

Step 1 Generate a report.

A report view opens displaying the report.

Step 2 Right-click the legend of the chart and drag it to the required position.

The legend moves to the new position.

How to Hide the Chart Legend  

Step 1 Generate a report.

The Properties view displays the chart display properties.

Step 2 To hide the chart legend, click the Legend visibility property.

The value of the Legend visibility property toggles from True to False and the chart legend is removed 
from the chart.
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How to Export Reports 
You can export reports to most graphic formats, and you can export tables to CSV or Quoted CSV 
formats, which you can open as spreadsheets. You can export multiple reports in one export operation.

Step 1 After executing one or more report instances, select File >Export.

The Export wizard appears.

Step 2 Select Chart or Table.

Step 3 Click Next.

The Tables and Destination page of the Export wizard opens.
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Step 4 Check one or more of the Available reports.

Step 5 (Optional) To change the Output folder, click Browse.

Step 6 Click Next.

The Format page of the Export wizard opens. (The display depends on whether you chose Chart or Table 
in Step 2.)

Step 7 Enter required information.

Do one of the following:

 • (For Chart)
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 – From the File type drop-down list, choose a file type.

 – In the Image width and Image height fields, enter values in pixels.

 • (For Table)
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 – From the File type drop-down list, choose a file type.

Step 8 Click Finish.

Each report selected is saved in a separate file.
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The SCA Reporter Command-Line Interface  

This chapter describes the various ways of using the Cisco Service Control Application Reporter (SCA 
Reporter) Command-Line Interface (CLI) for executing the SCA Reporter features, including the syntax, 
switches, and options of the application.

 • Command-Line Interface Overview, page 6-1

 • Prescheduled Reports, page 6-1

 • Syntax and Usage, page 6-2

Command-Line Interface Overview 
The SCA Reporter Command-Line Interface (CLI) is a command-line application that complements the 
functionality of the SCA Reporter GUI. You can integrate the CLI, which provides capabilities and 
flexibility beyond that of its SCA Reporter GUI counterpart, into third-party applications to generate 
usage-based and statistics-based output.

The CLI includes the following features:

 • Runs under Windows or Linux

 • Runs predefined report instances or uses report templates

 • Allows prescheduling of periodic generation of reports

Prescheduled Reports 
You can use the Reporter CLI to produce selected reports periodically. You must configure an external 
scheduling utility (for example, cron, PyCron, or Windows scheduler) to do this. You can use either an 
existing report instance or a report template, as explained in the sections below.

The following is an example of a cron line to produce a “Global Bandwidth per Service” report every 
hour:

20 * * * * reportercmd -report "Global Bandwidth per Service #1" -params \ 
"numhours=24;units=Mbit/s;avgdata=true;trafficdir=Both Directions" \ -format jpeg -o 
GBpS1.jpeg
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Syntax and Usage 
You can execute the SCA Reporter as a command-line version that accepts input passed as parameters. 
In the Templates view, you can create a CLI command, either from a report instance or from a report 
template. The database information and the SCE platform IP parameters are included in the created CLI 
command, in addition to configured parameters.

When you create the command, it is automatically copied to the clipboard so that you can paste it into a 
command file shell or a command prompt and then execute it after making any necessary changes. You 
must add the file name in which to save the data and the format in which to save it; these parameters are 
not included when the command is created.

Not all parameters that exist in the original report instance are included in the params switch. When a 
parameter is not specifically listed in the CLI invocation:

 • If the command is based on a report instance, the value is taken from the report instance.

 • If the command is based on a report template, the default value is used. (You must define the values 
of mandatory parameters that do not have default values.)

 • Command-Line Usage, page 6-2

 • Command-Line Switches, page 6-2

 • Command-Line Options, page 6-3

 • How to Generate Reporter Commands for a Report Instance, page 6-4

 • How to Generate Reporter Commands for a Report Template, page 6-5

Command-Line Usage 
You can invoke the SCA Reporter application using a command such as:

reportercmd -report "Global Bandwidth per Service #1" -dbdriver "com.mysql.jdbc.Driver" 
-dburl "jdbc:mysql://127.0.0.1:3306/apricot" -dbuser "pqb_admin" -dbpassword "pqb_admin" 
-policysce "10.1.12.85" -params "numhours=240000000;seip=10.1.12.85;avgdata=true;link=Link 
0,Link 1;traficdir=Both Directions;services=Messaging Service,Generic UDP Service,Generic 
TCP Service,News Service,FTP Service,Browsing Service,Default Service" -o "myfile" -format 
"jpeg" 

You can generate a string to serve as the basis for a CLI command from the SCA Reporter. The generated 
command does not include the -o and -format parameters, which must be added to the command. You 
can also modify other parameters.

Command-Line Switches 
The following switches can be included in the command line when invoking the SCA Reporter 
application:

 • -report 

 – -dbdriver 

 – -dburl 

 – -dbuser 

 – -dbpassword 

 – -policysce 
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 – -params 

 – -o 

 – -format 

 – -show 

 • -template 

 – -dbdriver 

 – -dburl 

 – -dbuser 

 – -dbpassword 

 – -policysce 

 – -params 

 – -o 

 – -format 

 – -show 

 • -help 

 • -list 

Command-Line Options 
The following table describes the options of the command line for invoking the SCA Reporter 
application:

Table 6-1 Command-Line Options for SCA Reporter Application 

Option Action by SCA Reporter Comments

-report "report-name" Generates a report using the 
specified name of a report 
instance.

Use this parameter when 
generating a report from an 
existing report instance.

-template "template-name" Generates a report using the 
specified name of a report 
template.

Use this parameter when 
generating a report from a 
template.

-dbdriver "db-driver" The driver for the database. The same database that is 
configured in the SCA Reporter.

-dburl "db-url" The URL of the database.

-dbuser "db-user" The user of the database.

-dbpassword "db-password" The password for the database.

-policysce "IP of SCE for policy 
data" 

The IP address of the SCE 
platform whose service 
configuration data will be used 
in the report.

The IP address of the SCE 
platform that is configured in the 
SCA Reporter.
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How to Generate Reporter Commands for a Report Instance  

Step 1 Select a report instance from the Templates view.

Step 2 From the drop-down menu in the tab, select Show Cmd.

A Command line invocation dialog box appears, displaying the generated command.

Step 3 Click OK.

The command, with all the switches and parameters, is placed on the clipboard.

Step 4 Open a file or command prompt.

Do one of the following:

 • Open a file from which to execute the command from a shell and save the file in the Reporter 
directory.

 • Open a command prompt from which to execute the CLI command and change the directory to the 
Reporter directory.

-params "param1=value1;..." Parameters from the Properties 
view.

When a particular parameter is 
not listed, the default value is 
used.

-o "filename" The name of the file to which to 
direct output.

If the file name already exists, 
the original file is overwritten.

-format "fileformat" Specifies whether to output the 
report as a chart or as a table. The 
fileformat parameter can take 
one of the following values:

 • jpeg 

 • csv 

-show Shows the structure (including 
parameters) of a report or 
template instead of executing it.

-help 

-list Outputs a list of all template 
groups and report templates.

Table 6-1 Command-Line Options for SCA Reporter Application (continued)

Option Action by SCA Reporter Comments
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Step 5 Paste the clipboard contents.

The command is pasted in the file or in the command line.

Step 6 Add the mandatory flags.

 • -o "filename"

 • -format "fileformat"

Step 7 (Optional) Change parameters. For example, you may want to change the numhours parameter.

Step 8 Execute the command.

The exported file is saved in the defined directory with a time stamp appended to the name of the report 
instance.

How to Generate Reporter Commands for a Report Template  

Step 1 Select a report instance from the Templates view.

Step 2 From the drop-down menu in the tab, select Show Cmd.

The command, with all the switches and parameters, is placed on the clipboard.

Parameters that have default values are given the default value. Mandatory parameters that do not have 
default values are indicated by a value of ___ (underscore).

Step 3 Click OK.

The command, with all the switches and parameters, is placed on the clipboard.

Step 4 Continue at Step 5 of the previous procedure.
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Installing and Upgrading SCA Reporter 
Templates  

This appendix describes the how to install and upgrade Cisco Service Control Application Reporter 
(SCA Reporter) report templates.

 • How to Install Report Templates, page A-1

 • How to Upgrade Report Templates, page A-7

How to Install Report Templates 

Step 1 From the main menu, choose Help > Find and Install. 
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Step 2 Check the Search for new feature to install radio button and click Next. 
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Step 3 Click New Local Site. 

The Select Local Site Archive dialog box appears.

Step 4 Browse to the archive file and select it.

The file is named SCAS_bb_template_.<version>B<build>.zip. For example, the file may be named 
SCAS_bb_template_3.1.5B8.zip.

Step 5 Click Open. 

The Edit Local Site dialog box appears displaying the file name and its location and contents.

Step 6 Click OK. 
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Step 7 Click Finish. 
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Step 8 Accept the agreement and click Next. 

The Updates dialog box appears with the installed features available for the site.

Step 9 Select the required feature, which should be named SCAS BB Templates<version.<build>. For 
example, the file may be named SCAS BB Template 3.1.5.8.

Step 10 (Optional) To install the feature in a different location, click Change Location and browse to the 
required location.
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Step 11 Click Finish. 

Step 12 Click Install or Install All. 
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Step 13 Click Yes , and wait for the application to come up.

The computer restarts.

The new report templates are installed.

How to Upgrade Report Templates 

Step 1 From the main menu, choose Help > Find and Install. 

The Install/Update dialog box appears.

Step 2 Check the Search for updates of the currently installed features radio button.

Step 3 Click Finish. 

One of the following occurs:
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 • There are no updates.

 • There are updates.

The wizard appears (see How to Install Report Templates, page A-1).
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Troubleshooting  

If you encounter a problem while using the Cisco Service Control Application Reporter (SCA Reporter), 
use the information in this appendix to help isolate its cause. The procedures in this appendix assume 
that you are troubleshooting the initial system startup, and that the GUI is in the original factory 
configuration. If you have changed any default settings, the recommendations in this appendix might not 
apply.

 • Using the Troubleshooting Appendix, page B-1

 • General, page B-1

 • General Setup Errors, page B-2

 • Command-Line Interface, page B-2

 • Parameter Definition Errors, page B-2

 • How to Check System Conditions, page B-3

 • How to View the Error Log, page B-4

 • How to View the Installed Version of the Report Templates, page B-4

Using the Troubleshooting Appendix 
This appendix describes the subsystems available for more efficient problem solving. If, after applying 
the solutions in this appendix, you are still unable to solve your problem, contact a customer service 
representative for assistance. Please provide the representative with the following information:

 • Type of software and release number

 • Brief description of your problem

 • Brief explanation of the steps you have taken to isolate and resolve the problem

 • Maintenance agreement or warranty information

General 
Searching the Help menu allows you to learn more about the SCA Reporter while you are working. You 
can get assistance with the following functions from the Help Menu:

 • Creating a Basic Configuration

 • Accessing Online Help
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 • Checking System Conditions

 • Managing Configuration

 • Installing and Upgrading Templates

 • Viewing Plug-in Details

You can also access Online Help while working in the SCA Reporter (see Accessing Online Help, 
page 2-18).

General Setup Errors 
Check the following if the GUI does not open:

 • Ensure you have enough memory.

 • Uninstall an old release before installing a new release.

 • The database is installed and populated.

 • The IP address of the computer is not connected to another device.

Command-Line Interface 
To assist you in using and troubleshooting the SCA Reporter Command-Line Interface (CLI), refer to 
the following sections of the Cisco Service Control Engine (SCE) CLI Command Reference:

 • CLI Help Features

 • Navigational and Shortcut Features

 • Managing Command Output

Parameter Definition Errors 
In this example, a mandatory property is not set.

Figure B-1 Properties

When the report instance is executed, an error message appears.
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Figure B-2 Report Error

Click Details to view more specifics on the error.

Figure B-3 Report Error Details

How to Check System Conditions 
You can check that:

 • The database connection is defined correctly and that the connection is active

 • The system is configured correctly

Step 1 From the main menu, choose Help > Check Conditions.

A Condition testing message appears.
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Step 2 Click OK.

How to View the Error Log 
To configure debug message logging, see Configuring the SCA Reporter, page 2-8. When this mode is 
activated, you can view the error log.

Step 1 From the main menu, choose Help > About SCA Reporter.

The About SCA Reporter dialog box appears.

Step 2 Click Configuration Details.

Step 3 Click View Error Log.

How to View the Installed Version of the Report Templates 
Where the database structure has changed, but the repository was not updated, there may be Template 
Repository Errors (see Installing and Upgrading SCA Reporter Templates, page A-1).

Note The files used for installing and upgrading may need to be updated before the installation.

Step 1 From the main menu, choose Help > About SCA Reporter.

The About SCA Reporter dialog box appears.

Step 2 Click Plug-in Details.

The About SCA Reporter Plug-ins dialog box appears.

Step 3 Verify that the version of SCA BB Templates is correct.

Step 4 Click OK.

The About SCA Reporter Plug-ins dialog box closes.

Step 5 Click OK.

The About SCA Reporter dialog box closes.
B-4
Cisco Service Control Application Reporter User Guide

OL-8411-05



Cisco Serv
OL-8411-05

A
 P P E N D I X C 

The SCA Reporter as a Tool in the SCA BB 
Console  

This appendix describes the Cisco Service Control Application Reporter (SCA Reporter) as a tool in the 
SCA BB Console. For more information about the SCA BB Console, see the Cisco Service Control 
Application for Broadband User Guide.

How to Use the SCA Reporter Tool in the SCA BB Console 
The SCA Reporter can be run as a tool in the SCA BB Console.

Step 1 Choose Start > All Programs > Cisco SCA > SCA BB Console 3.1.5 > SCA BB Console 3.1.5.

The SCA BB Console opens.
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Step 2 Configure and activate a database connection. (See Managing Database Connections, page 2-8.)

Step 3 From the Console main menu, choose Tools > Reporter. 

The Reporter tool opens.
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Step 4 You use the Reporter tool in the same way that you use the SCA Reporter as a standalone, as described 
in this manual.
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SCA Reporter Templates  

This appendix describes the Cisco Service Control Application Reporter (SCA Reporter) report 
templates.

 • Information About Report Templates, page D-1

 • Global Monitoring Template Group, page D-7

 • Package Monitoring Template Group, page D-7

 • Virtual Links Monitoring Template Group, page D-8

 • Subscriber Monitoring Template Group, page D-9

 • Traffic Discovery - Statistics Template Group, page D-9

 • Demographic Data and Service Popularity Reports Template Group, page D-10

 • Web and Streaming Reports Template Group, page D-11

 • Mail and News Reports Template Group, page D-11

 • P2P Reports Template Group, page D-12

 • VoIP Reports Template Group, page D-12

 • Malicious Traffic Template Group, page D-13

Information About Report Templates  
The SCA Reporter installation includes report templates that you use to generate report instances. The 
templates are grouped by common themes. Each report template allows you to create new report 
instances. Default filter values are assigned to the properties, some of which are common to all the 
instances in a given group. You can impose additional constraints by configuring the properties.

Note The default filters are the values that are initially applied to the properties. Before generating a report, 
you can reconfigure its properties. In order to reset properties to their default values, select properties 
and click  (Restore Default Value. . Some mandatory properties have the default value  (not 
set) ; these properties must be assigned a value before a report can be generated. Optional properties may 
be assigned a value of (not set).  To view all properties, click  (Show Advanced Properties. .

You generate a report instance by selecting a report template from the list of available groups in the 
Templates view.

There are two main categories of reports:
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 • Monitoring reports—Show how network resources are used for selected services at various 
granularities (global, package, subscriber)

 • Traffic Discovery reports—Provide statistical information about network activity and help identify 
the characteristics of the traffic traversing the network

 • Report Instance Properties, page D-2

 • Information About Monitoring Reports, page D-4

 • Information About Traffic Discovery Reports, page D-6

Report Instance Properties 
The following table lists properties that appear in report templates that belong to more than one template 
group. (Properties of report instances that belong to only one template group are listed with the 
description of the group.)

Table D-1 Common Properties of Report Instances 

Property Field Type Default Comments

Items to Focus on 

One of the following is included in most report templates:

 • Services to view Multiple Choice (not set) When not set, all 
services are selected.

 • Select services to 
view

Multiple Choice (not set) When not set, all 
services are selected.

 • Focus on the 
service

Single Choice (not set) When not set, all 
services are selected.

One of the following two properties is included in many report templates:

 • Packages to View Multiple Choice (not set) When not set, all 
packages are selected.

 • Package Single Choice  (not set) Mandatory property.

Name of subscriber to 
focus on

Free Text (not set) Mandatory property for 
Subscriber template 
group report instances.

IP address (decimal 
format) or subscriber 
name.

Time Frames to focus Multiple Choice (not set) When not set, all four 
time frames are 
selected.

Time Boundaries —See note following table.

Starting after date Time/Date (not set)

Ending before date Time/Date (not set) When not set, the report 
is bound to the current 
time.
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 • From the last 
number of hours

Free Text 24 Ignored when the 
Starting After Date and 
Ending Before Date 
properties are both set.

 • From the last 
number of Days

Free Text 7

Specific Time Date/Time  (not set) Mandatory property.

Appears in three report 
instance types instead of 
the other three time 
boundary properties.

The selected time is 
rounded to the nearest 
hour/day.

Traffic Parameters 

Link to Focus Multiple Choice (not set) List of available links to 
focus.

One of the following is included in many report templates:

 • Traffic Direction Single Choice Depends on report 
template

Depends on report 
template:

 • Direction only

 • Direction and 
metric

 • Metric to order Single Choice Depends on report 
template

Depends on report 
template and metric:

 • Metric only

 • Metric and 
direction

Data Show 

Pick BW Over Single Choice 1 Hour

SCE IP to view Single Choice At installation:  (not 
set)

Thereafter: most recent 
assigned value

Mandatory property.

IP address of specific 
Service Control Engine 
(SCE) platform.

Units of results Single Choice Depends on report 
template

Limit number of results Free Text 10

Table D-1 Common Properties of Report Instances (continued)

Property Field Type Default Comments
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 • All report instances include the SCE IP to view property, which enables filtering to a specific SCE 
platform. This property is mandatory and persistent.  Persistent means that the current value is used 
for all subsequent reports until the value is changed.

 • Time Boundaries properties occur in all report instances except for Top Subscribers, Top Talkers, 
and Relative Consumption of Top Subscribers. These properties are:

 – Starting After Date

 – Ending Before Date

 – From the Last Number of Hours/Days

 • The property From the last number of hours/days is set to a default value in all report instances. 
When all three Time Boundaries properties are set, the From the last number of hours/days 
property is ignored. When the property Ending before date is not set, the report is bound to the 
current time.

Information About Monitoring Reports 
Monitoring reports provide information about the distribution and consumption of network resources. 
This information helps you understand how the network is used at different granularities (such as for the 
entire link, for traffic generated by all subscribers in a particular package usage counter, or for traffic 
generated by a particular subscriber). These reports are critical for tuning the Service Control solution’s 
configuration according to changing network patterns.

Monitoring reports are created from Link Usage, Package Usage, and Real-Time Subscriber Usage Raw 
Data Records (RDRs). These RDRs (that are generated by the SCE platform) provide periodic usage 
information (at the various granularities) that is processed according to the selected report template to 
provide the final report.

Monitoring reports typically show a specific metric for a set of service usage counters at a selected 
granularity , such as bandwidth for P2P and Browsing service usage counters at a link granularity, or 
volume for the Streaming service usage counter for subscribers in the Gold package usage counter.

Average Data by Hour Boolean True If this option is selected, 
a single, average value 
is calculated for each 
hour of the report. This 
option is recommended 
when generating the 
report for 24 or more 
hours.

Show other 
Consumption

Boolean False

Aggregation Period Single Choice Hourly

Subscriber Id Free Text (not set) Pattern that represent 
group of subscribers.

Table D-1 Common Properties of Report Instances (continued)

Property Field Type Default Comments
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You select the service usage counters on which to report via the SCA Reporter. The available service 
usage counters are those defined in the service configuration of the SCE platform from which the reports 
are generated.

 • Granularity, page D-5

 • Metrics, page D-5

Granularity  

A report instance’s granularity controls which traffic the generated report addresses. Three granularities 
are supported:

 • Global—Provides visibility into all traffic processed by the SCE platforms being reported on. Use 
global granularity to view the global distribution of network resources (for example, total P2P 
bandwidth for the last 24 hours).

 • Package—Reports on traffic mapped to subscribers in a particular package usage counter. Use 
package granularity to monitor how subscribers assigned to a particular package usage counter (for 
example, the total volume of streaming traffic for all subscribers assigned to the Gold package usage 
counter in the last ten days) use network resources. See the “Using the Service Configuration Editor: 
Traffic Control” chapter of the Cisco Service Control Application for Broadband User Guide for a 
description of how to define different packages in the system.

To generate package usage counter reports, subscribers must be defined (in any of the subscriber 
modes) and assigned to a particular package. See the “Using the Subscriber Manager GUI Tool” 
chapter of the Cisco Service Control Application for Broadband User Guide for a description of how 
to manage subscribers.

 • Subscriber—Provides insight into the activity of a single subscriber defined in the Service Control 
solution. Use subscriber granularity to view how a particular subscriber is using network resources 
(for example, the number of P2P sessions generated by a particular subscriber for each hour during 
the last 12 hours). Subscriber reports are available for those subscribers flagged for real-time 
reporting. (For a description of managing real-time subscriber reporting, see the “Using the Service 
Configuration Editor: Traffic Accounting and Reporting” chapter of the Cisco Service Control 
Application for Broadband User Guide.. 

Each report template generates reports in a specific granularity. Each type of report is accessible from 
the corresponding report template group:

 • Global report templates are accessible from the Global Monitoring Template Group, page D-7.

 • Package report templates are accessible from the Package Monitoring Template Group, page D-7.

 • Subscriber report templates are accessible from the Subscriber Monitoring Template Group, 
page D-9.

Metrics  

A metric is the statistic being reported on. The following metrics are available:

 • Bandwidth—The total bandwidth consumed by the selected services. By default, a bandwidth report 
is displayed as a stacked-area chart, where each area indicates the bandwidth used by a particular 
service.

When generating a bandwidth report, you can select the direction: upstream, downstream, or both.
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You can also display an hourly average of bandwidth. This is recommended when you are generating 
a report for many hours. In this case a single data point per hour is usually sufficient: it reduces the 
quantity of data displayed, improving performance and the visualization of the data.

 • Volume—The total volume (in kilobytes or megabytes) for a specific period of time, for the selected 
service usage counters. As opposed to the bandwidth metric, which provides normalized volume 
over time, volume reports give the total volume consumed, grouped by specific time durations. By 
default, a volume report is displayed as a stacked-bar chart, where each bar/series indicates the 
volume of a particular service usage counter.

Volume reports give the accumulated usage either for specific durations of time (hours or days), or 
for the entire duration of the report. For example: a Global Hourly Usage Volume report displays a 
bar that accounts for the total volume consumed by each service usage counter during each hour of 
the selected time frame, and a Global Aggregated Usage Volume per Service report accounts for all 
volume of each service usage counter for the entire time frame of the report.

 • Sessions—The number of sessions. A session is a single network transaction (for example, RTSP 
stream or P2P file download). By default, a sessions report is displayed as a stacked-bar chart, where 
each bar/series indicates the total number of sessions of a particular service usage counter.

Like volume reports, sessions reports can be grouped into specific durations (hours or days), in order 
to account for the total number of sessions in a particular hour/day consumed by a particular service 
usage counter.

Information About Traffic Discovery Reports 
Traffic discovery reports provide raw statistics for analyzing network activities. They are useful for 
obtaining information about the general activity in the IP network, and they are the key for defining the 
system’s service configuration.

Traffic discovery reports are based on the information in Transaction RDRs.

Traffic Discovery reports generate histograms and distribution charts that are grouped by a selected 
criterion and sorted by the selected order parameter.  For example: a Top Protocols report is sorted by 
Total Volume, and a Top Web-hosts report is sorted by Hit-Count.

 • Criteria, page D-6

 • Order Property, page D-6

Criteria  

Each report template focuses on a particular criterion based on Layers 3 to 7, such as:

 • Top Servers IP addresses

 • Top Server Port numbers

 • Top HTTP web-hosts

 • Top NNTP news-groups

Order Property  

The Metric to order property indicates the value by which the report will be sorted. Possible values are:

 • Upstream Volume

 • Downstream Volume
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 • Both Directions Volume—Total upstream and downstream volume

 • Hit-Count—Number of transactions

You can limit each report to a specific number of results, which allows you to focus on the top areas of 
activity (according to the selected value).

Global Monitoring Template Group  
The Global Monitoring group of report templates allows you to view statistics about the traffic 
bandwidth or volume that was consumed. The bandwidth/volume consumption can be displayed per 
service for the entire link.

The Global Monitoring group includes the following report templates:

 • Global Bandwidth per Service—Shows the distribution of bandwidth among the different services 
defined in the system for all traffic, regardless of subscriber or package

 • Global Aggregated Usage Volume per Service—Shows the total volume of traffic (upstream and 
downstream) for each service usage counter (for all traffic, regardless of subscriber or package)

 • Global Hourly Usage Volume per Service—Shows the distribution of volume among the different 
service usage counters defined in the system, grouped by hour

 • Global Hourly Aggregated Minutes per Service—Shows the total number of minutes used for each 
service usage counter defined in the system, grouped by hour

 • Global Hourly Usage Sessions per Service—Shows the distribution of sessions among the different 
service usage counters defined in the system, grouped by hour

 • Global Concurrent Session per Service—Shows the distribution of concurrent sessions among the 
different service usage counters defined in the system

 • Global Daily Usage Sessions per Service—Shows the distribution of sessions among the different 
service usage counters defined in the system, grouped by day

 • Global Daily Usage Volume per Service—Shows the distribution of volume among the different 
service usage counters defined in the system, grouped by day

 • Daily Peak BW for All Packages

Package Monitoring Template Group  
The Package Monitoring group of report templates allows you to view statistics of bandwidth or volume 
of traffic used by a package. The reports are provided per service usage counter for the total volume used 
by the package. The volume consumption can be displayed per service for the package.

The Package Monitoring group includes the following report templates:

 • Package Bandwidth per Service—Shows the distribution of bandwidth among the different service 
usage counters defined in the system for all subscribers belonging to a particular package

 • Package Aggregated Usage Volume per Service—Shows the total volume of traffic (upstream and 
downstream) for each service usage counter (for subscribers in a specific package)

 • Package Hourly Usage Volume per Service—Shows the distribution of volume among the different 
service usage counters defined in the system, for the traffic of subscribers in a specific package 
usage counter, grouped by hour
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 • Package Hourly Aggregated Minutes per Service—Shows the total number of minutes used for each 
service usage counter for a specific package usage counter defined in the system, grouped by hour

 • Package Hourly Usage Sessions per Service—Shows the distribution of sessions among the different 
service usage counters defined in the system, for the traffic of subscribers in a specific package, 
grouped by hour

 • Package Concurrent Session per Service—Shows the distribution of concurrent sessions among the 
different service usage counters for a specific package usage counter defined in the system

 • Package Daily Usage Sessions per Service—Shows the distribution of sessions among the different 
service usage counters defined in the system, for the traffic of subscribers in a specific package 
usage counter, grouped by day

 • Package Daily Usage Volume per Service—Shows the distribution of volume among the different 
service usage counters defined in the system, for the traffic of subscribers in a specific package 
usage counter, grouped by day

 • Daily Peak BW for Each Package

Virtual Links Monitoring Template Group  
The Virtual Links Monitoring group of report templates allows you to view statistics of bandwidth or 
volume of traffic used by a virtual link. The reports are provided per service usage counter for the total 
volume used by the virtual link. The volume consumption can be displayed per service for the virtual 
link.

These reports cannot be generated using data collected from an SCE platform running in asymmetric 
routing classification mode.

The Virtual Links Monitoring group includes the following report templates:

 • VLink Bandwidth per Service—Shows the distribution of bandwidth among the different service 
usage counters defined in the system for all subscribers

 • VLink Aggregated Usage Volume per Service—Shows the total volume of traffic (upstream and 
downstream) for each service usage counter

 • VLink Hourly Usage Volume per Service—Shows the distribution of volume among the different 
service usage counters defined in the system, grouped by hour

 • VLink Daily Usage Volume per Service—Shows the distribution of volume among the different 
service usage counters defined in the system, grouped by day

 • Daily Peak BW for all VLinks

Table D-2 Properties of Virtual Links Monitoring Group Templates only 

Property Field Type Default Comments

Items to Focus on 

Select VLink ID Free Text (not set)

Select VLink direction Single Choice (not set)

Select VLink names Multiple Choice (not set)
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Subscriber Monitoring Template Group  
The Subscriber Monitoring group of report templates allows you to view statistics about the bandwidth 
or volume of traffic used by the subscriber. The reports are provided per service usage counter for the 
total volume consumed by the subscriber. A Top Subscribers report identifies the subscribers that 
consume the largest traffic volume. Subscriber bandwidth and volume reports can be generated for those 
subscribers configured for real-time monitoring. See “Selecting Subscribers for Real-Time Usage 
Monitoring” in the “Additional Management Tools and Interfaces” chapter of the Cisco Service Control 
Application for Broadband User Guide for a description of how to configure real-time subscribers.

The Subscriber Monitoring group includes the following report templates:

 • Top Subscribers—Shows a list of the top subscriber volume consumption in a specific hour/day

 • Subscriber Bandwidth per Service—Shows the distribution of bandwidth among the different 
service usage counters defined in the system for a particular subscriber

 • Subscriber Aggregated Usage Volume per Service—Shows the most popular service usage counter 
for a particular subscriber

 • Subscriber Hourly Usage Volume per Service—Shows the hourly distribution of volume among the 
different service usage counters defined in the system for a particular subscriber

 • Subscriber Hourly Aggregated Minutes per Service—Shows the total number of minutes used for 
each service usage counter for a specific package usage counter defined in the system, grouped by 
hour

 • Subscriber Hourly Usage Sessions per Service—Shows the hourly distribution of sessions among 
the different service usage counters defined in the system for a particular subscriber

 • Subscriber Daily Usage Sessions per Service—Shows the daily distribution of sessions among the 
different service usage counters defined in the system for a particular subscriber

 • Subscriber Daily Usage Volume per Service—Shows the daily distribution of volume among the 
different service usage counters defined in the system for a particular subscriber

 • Daily Peak BW for Specific Subscriber

Traffic Discovery - Statistics Template Group  
The Traffic Discovery - Statistics group of report templates allows you to view statistics compiled from 
the source and destination IP addresses and ports of the system traffic.

These reports cannot be generated using data collected from an SCE platform running in asymmetric 
routing classification mode.

Note The reports in this group are not per subscriber; they supply general port and IP address information.

Table D-3 Property of Traffic Discovery - Statistics Group Templates only 

Property Field Type Default Comments

Traffic Parameters 

Transport Protocol Single choice TCP
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The Traffic Discovery - Statistics group includes the following report templates:

 • Top Servers—Shows the most popular servers for certain services

Note Server refers to the IP address of the other side of the flow initiator. It may be located on the Subscriber 
side or on the Network side.

 • Top Client—Shows the most popular client IP for certain services

Note Client refers to the IP address of the flow initiator. It may be located on the Subscriber side or on the 
Network side.

 • Top Server Ports—Shows the most popular server ports for certain services

 • Top Service Ports—Shows the most popular server ports of a certain service or services

 • Top Protocols—Shows the most popular protocol for certain services

 • Top IP Protocols—Shows the most popular IP protocol for certain services

 • Top Server IP to Server Port—Shows the most popular server IP to server port for certain services

 • Top Client IP to Server Port—Shows the most popular client IP to server port for certain services

 • Top Client IP to Server IP—Shows the most popular client IP to server IP for certain services

 • Top Client IP to Server IP and Server Port—Shows the most popular server IP and server port for 
certain services.

Demographic Data and Service Popularity Reports Template 
Group  

The Demographic Data and Service Popularity group of report templates allows you to view statistics of 
the demographic data.

The Demographic Data and Service Popularity group includes the following report templates:

 • Global Active Subscriber per Service—Shows the distribution of subscribers among the different 
services defined in the system for all traffic, regardless of subscriber or package

 • Package Active Subscriber per Service—Shows the distribution of bandwidth among the different 
services defined in the system for specific subscriber package

 • Service Popularity among Subscribers—Shows the percentage of subscribers using a specific 
service defined in the system

 • Service Popularity among Subscribers of a Specific Package—Shows the percentage of subscribers 
using a specific service in a specific package defined in the system

 • Relative Consumption of Top Subscribers—Shows the relative consumption of a specific number of 
subscribers compared to “other”

 • Service Popularity among Subscribers (Average)—Shows the total number of subscribers using a 
specific service compared to subscribers using all other services

 • Service Popularity among Subscribers of a Specific Package (Average)—Shows the total number of 
subscribers using a specific service compared to subscribers using all other services in a specific 
package
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Web and Streaming Reports Template Group  
The Web and Streaming group of report templates allows you to compile statistics presenting the most 
popular servers or hosts for the various predefined system services (such as Browsing, Streaming, and 
Downloading) and for user-defined services.

These reports cannot be generated using data collected from an SCE platform running in asymmetric 
routing classification mode.

The Web and Streaming group includes the following report templates:

 • Top Web Hosts—Shows the most popular web servers

 • Top Rtsp Hosts—Shows the most popular real-time streaming protocol (RTSP) servers

 • Top FTP Servers—Shows the most popular FTP file hosts

 • Top MMS Servers—Shows the most popular MMS hosts

 • Top Service Servers—Shows the most popular servers of a certain service or services

 • Service Distribution by Subscriber Packages—Shows the most popular web servers, grouped by the 
package of the requesting subscriber

 • Rtsp Host Distribution by Subscriber Packages—Shows the most popular RTSP servers, grouped by 
the package of the requesting subscriber

 • FTP Server Distribution by Subscriber Packages—Shows the most popular FTP file servers, 
grouped by the package of the requesting subscriber

 • MMS Server Distribution by Subscriber Packages—Shows the most popular Microsoft Manager 
Server servers, grouped by the package of the requesting subscriber

 • Service Distribution by Subscriber Packages—Shows the distribution of service usage according to 
the subscriber packages

Mail and News Reports Template Group  
The Mail and News group of report templates allows you to view statistics of the mail and news traffic.

These reports cannot be generated using data collected from an SCE platform running in asymmetric 
routing classification mode.

The Mail and News group includes the following report templates:

 • Top SMTP Servers—Shows the most popular SMTP hosts

 • Top POP3 Servers—Shows the most popular POP3 hosts

 • Top NNTP Servers—Shows the most popular NNTP hosts

Table D-4 Property of Web and Streaming Group Templates only 

Property Field Type Default Comments

Items to Focus on 

Where host is contained Free Text (not set) Filter to hosts 
containing the given 
pattern.
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 • Top E-mail Sender—Shows the top e-mail sender

 • Top E-mail Recipients—Shows the top e-mail recipients

 • Top NNTP Consumers—Shows the top NNTP consumers

 • Top Newsgroups—Shows the most popular newsgroups

 • SMTP Server Distribution by Subscriber Packages—Shows the most popular SMTP servers, 
grouped by the package of the requesting subscriber

 • POP3 Server Distribution by Subscriber Packages—Shows the most popular POP3 servers, grouped 
by the package of the requesting subscriber

 • NNTP Server Distribution by Subscriber Packages—Shows the most popular NNTP servers, 
grouped by the package of the requesting subscriber

 • Top Subscriber to Newsgroup—Shows the top subscriber to newsgroup for certain services

 • Top E-mail Account Owners—Shows the top e-mail account owners

P2P Reports Template Group  
The P2P group of report templates allows you to view statistics of the P2P traffic.

These reports cannot be generated using data collected from an SCE platform running in asymmetric 
routing classification mode.

The P2P group includes the following report templates:

 • Top P2P Protocols—Shows the most popular P2P protocol for certain services

 • Top P2P Consumers—Shows a list of the top P2P subscriber volume consumption

 • Top P2P Downloaders—Shows the top P2P download consumers

 • Top P2P Uploaders—Shows the most popular P2P upload consumers

VoIP Reports Template Group  
The VoIP group of report templates allows you to view statistics of the VoIP traffic.

These reports cannot be generated using data collected from an SCE platform running in asymmetric 
routing classification mode.

The VoIP group includes the following report templates:

 • Global Bandwidth per VoIP Service—Shows the distribution of bandwidth among the different VoIP 
services defined in the system for all traffic, regardless of subscriber or package

 • Global Concurrent Calls per VoIP Service—Shows the distribution of concurrent sessions among 
the different VoIP service usage counters defined in the system, grouped by day

Table D-5 Property of VoIP Group Templates only 

Property Field Type Default Comments

Data Show 

Codec to filter Multiple Choice (not set)
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 • Global Hourly Call Minutes per VoIP Service—Shows the distribution of call minutes among the 
different VoIP service usage counters defined in the system, grouped by day

 • Package Bandwidth per VoIP Service—Shows the distribution of bandwidth among the different 
VoIP services defined in the system for the traffic of subscribers in a specific package

 • Packet Concurrent Calls per VoIP Service—Shows the distribution of concurrent sessions among the 
different VoIP service usage counters defined in the system, grouped by day

 • Package Hourly Call Minutes per VoIP Service—Shows the distribution of call minutes among the 
different VoIP service usage counters defined in the system, grouped by day

 • Subscriber Bandwidth per VoIP Service—Shows the distribution of bandwidth among the different 
VoIP services defined in the system for the traffic of subscribers in a specific package

 • Subscriber Hourly Call Minutes per VoIP Service—Shows the distribution of call minutes among 
the different VoIP service usage counters defined in the system, grouped by day

 • Top SIP Domains—Shows the most popular SIP Domains

 • Top Talkers—Shows a list of the top talker volume/session/minutes consumption in a specific 
hour/day for a specific/all VoIP services

 • Global VoIP Packets Loss

 • Global VoIP Jitter

 • Global Hourly Average VoIP Packets Loss

 • Global Hourly Average VoIP Jitter

 • Global VoIP MOS

 • Global Hourly Average VoIP MOS

 • Global VoIP MOS Distribution

 • Global VoIP Codec Distribution

Malicious Traffic Template Group  
The Malicious Traffic group of report templates allows you to view statistics of the malicious events 
accrued in the system.

The Malicious Traffic group includes the following report templates:

 • Global Scan or Attack Rate—Shows the rate (session/sec) of scan/attacks originating from the hosts 
(typically because of a worm or zombie)

 • Global DoS Rate—Shows the rate (sessions/sec) of DoS attacks on the targeted host

 • Top Scanning or Attacking Hosts—Shows the top hosts identified as DoS attacking

Table D-6 Properties of Malicious Traffic Group Templates only 

Property Field Type Default Comments

Traffic Parameters 

IP protocol Single Choice (not set)

Filter to port Free Text (not set)

Detected IP side Single Choice (not set)
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Appendix D      SCA Reporter Templates
  Malicious Traffic Template Group
 • Top DoS Attacked Hosts—Shows the top DoS-attacked hosts

 • Infected Subscribers—Shows the distribution of infected subscribers over time among the different 
IP protocols in the system

 • DoS Attacked Subscribers—Shows the distribution of DoS-attacked subscribers over time among 
the different IP protocols defined in the system

 • Top DoS Attacked Subscribers—Shows thetop DoS-attacked subscribers

 • Top Scanning or Attacking subscribers—Shows the top subscribers identified as DoS attacking

 • Top Scanned or Attacked Ports—Shows the top scanned or attacked ports
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