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Change History
This table lists changes made to this guide. Most recent changes appear at the top:

DateSeeChange

June 2018Configure RAID for
C240 M5SX

Added RAID configuration for C240 M5SX servers

June 2018Create a Virtual
Machine from the
OVA

Added support for C240 M5SX servers.

February 2018Standalone
Deployment

Added notes on fresh install of Standalone CUIC when
a higher configuration is required.

September 2017Install and Upgrade
COP File

Added details for installing COP files.
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DateSeeChange

August 2017Initial Release of Document for Release 11.6(1)

Added details related to Outbound Option high
availability.

Preinstallation > Install
.NET Framework 4.5.2

Added details on installation of .NET Framework prior
to Unified CCE 11.6.

Appendix A, CLI
Commands

Added TLS minimum version CLI commands

Multistage Upgrades
and Maintenance
Windows

Unified CCE Contact
Center Upgrade
Flowcharts

Added another stage for Identity Service IdS Server(IdS)
/Single Sign-On(SSO) and included the upgrade scenario
in the note added. Updated the workflow accordingly.

Add Peripherals to
Peripheral Gateways

Common Ground
Upgrade

Installation Task Flow

Uninstall Unified CCE
Release 11.6(1)

Verify Upgrade to
Cisco Unified CCE
Router and Logger

Verify Upgrade to
Cisco Real Time
Administration
Workstation, Historical
Database Server
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DateSeeChange

Updated the step for configuring Agent Desk Settings
before creating CUCM PIM. Also included a reference
to Assign Agent Desk Settings.

Similarly, updated the step for VRU PG, added a note
and included a reference for Configure Network VRUs
in the same section.

Added the topic Enable Configuration changes in
Common Ground Upgrade.

Upgraded version (applicable for 11.6) and updated
Maintenance Release with Minor Release.

Removed references for Install Remote Silent Monitor
and E-mail and Web Interaction since it is not more
supported for 11.6.

Included various scenario If you have set the newly
introduced deployment as 2000 Agents Rogger and
switch to different deployment which is supported in
previous version of CCERelease 11.x, before attempting
permanent uninstall.

Updated Setup logs that indicates no errors or failure
conditions.

Updated the information for blocking uninstall with
UCCE 2000 Agents Rogger deployment. The update is
applicable when the deployment is set as UCCE: 2000
Agents Rogger, the user needs to switch to different
deployment which is supported in previous version of
CCE Release 11.x, before attempting permanent
uninstall.

Added a note in Unified CCE Release 11.6(1) Upgrade
Overview, to state that CCE 11.6 applies the use of TLS
1.2 in the entire solution and upgrade to SQL Server
2014 SP2 is a prerequisite before upgrading to 11.6(1).

Added a note in Upgrade to Unified CCERelease 11.6(1)
section to explain the values for Major, CCMinor,
AWMinor that are used in the backup folder name, are
derived from the 11.0 or 11.5 schema version of the
system being upgraded.

Updated Upgrade tools section and added that the User
Migration Tool (UMT) cannot be used for migrating
SSO enabled users.

A note was added stating the possibility of encountering
locked DLL's preventing patch installation /
uninstallation, if Windows Event Viewer is left open.
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DateSeeChange

Added steps to configure the Microsoft SQL User
Account for Outbound Option High Availability
database.

Configure SQL User
Account for Outbound
Options High
Availability

Set Up Virtual
Machines under the
chapter Preinstallation
Tasks.

Added information for configuring RAID for C240
M4SX.

About This Guide
This guide describes how to install the components and software for a newUnified CCE system, or to upgrade
an existing Unified CCE system.

Audience
This guide is intended for users who install and upgrade Unified CCE contact centers.

The procedures assume that the system has been thoroughly designed and staged in preparation for the
installation or upgrade.

Related Documents
LinkSubject

Design GuideDesign considerations and guidelines for deploying
a Unified CCE solution, including its various
components and subsystems.

Staging GuideSystem diagrams, staging steps and sample test cases
for supported models of Unified CCE.

Preinstallation and PlanningPre-installation requirements and issues to address
when you prepare for a Unified CCE installation.

Communications, Services, and Additional Information
• To receive timely, relevant information from Cisco, sign up at Cisco Profile Manager.

• To get the business impact you’re looking for with the technologies that matter, visit Cisco Services.

• To submit a service request, visit Cisco Support.
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• To discover and browse secure, validated enterprise-class apps, products, solutions and services, visit
Cisco Marketplace.

• To obtain general networking, training, and certification titles, visit Cisco Press.

• To find warranty information for a specific product or product family, access Cisco Warranty Finder.

Cisco Bug Search Tool

Cisco Bug Search Tool (BST) is a web-based tool that acts as a gateway to the Cisco bug tracking system
that maintains a comprehensive list of defects and vulnerabilities in Cisco products and software. BST provides
you with detailed defect information about your products and software.

Field Notice
Cisco publishes Field Notices to notify customers and partners about significant issues in Cisco products that
typically require an upgrade, workaround, or other user action. For more information, see Product Field Notice
Summary at https://www.cisco.com/c/en/us/support/web/tsd-products-field-notice-summary.html.

You can create custom subscriptions for Cisco products, series, or software to receive email alerts or consume
RSS feeds when new announcements are released for the following notices:

• Cisco Security Advisories

• Field Notices

• End-of-Sale or Support Announcements

• Software Updates

• Updates to Known Bugs

For more information on creating custom subscriptions, see My Notifications at https://cway.cisco.com/
mynotifications.

Documentation Feedback
To provide comments about this document, send an email message to the following address:
contactcenterproducts_docfeedback@cisco.com

We appreciate your comments.

Conventions
This document uses the following conventions:

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.6(1)
xix

Preface
Field Notice

https://www.cisco.com/go/marketplace/
https://www.cisco.com/go/marketplace/
http://www.ciscopress.com
http://www.cisco-warrantyfinder.com
https://www.cisco.com/c/en/us/support/web/tools/bst/bsthelp/index.html
https://www.cisco.com/c/en/us/support/web/tsd-products-field-notice-summary.html
https://cway.cisco.com/mynotifications
https://cway.cisco.com/mynotifications
mailto:contactcenterproducts_docfeedback@cisco.com


DescriptionConvention

Boldface font is used to indicate commands, such as user entries, keys, buttons,
folder names, and submenu names.

For example:

• Choose Edit > Find.

• Click Finish.

boldface font

Italic font is used to indicate the following:

• To introduce a new term. Example: A skill group is a collection of agents
who share similar skills.

• A syntax value that the user must replace. Example: IF (condition, true-value,
false-value)

• A book title. Example: See the Cisco Unified Contact Center Enterprise
Installation and Upgrade Guide.

italic font

Window font, such as Courier, is used for the following:

• Text as it appears in code or that the window displays. Example:
<html><title>Cisco Systems, Inc. </title></html>

window font

Angle brackets are used to indicate the following:

• For arguments where the context does not allow italic, such as ASCII output.

• A character string that the user enters but that does not appear on the window
such as a password.

< >
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C H A P T E R 1
Preparation

• Scenarios, on page 1
• System Requirements, on page 3

Scenarios
Cisco Unified Contact Center Enterprise (Unified CCE) is supported only in a virtualized environment.

Installation Scenario
In a virtualized environment, you can run Unified CCE on a VMware ESXi platform. Run the virtual machines
(VMs) on Cisco Unified Computing System (UCS) B-series or C-series servers, or equivalent third-party
servers.

Install the Cisco Unified CCE components after you configure the VMs.

You can use the OVA template to deploy the VMs before beginning with the installation of CCE components.

The Unified CCE 11.6(1) installer is available as an add-on release to Unified CCE 11.0(x). Therefore,
complete the installation of the base Unified CCE 11.0(1) before applying Unified CCE 11.6(1). Unified CCE
11.6(1) can be installed on 11.5(x) as well.

For more information about the complete procedure, see the Installation Task Flow, on page 31.

Upgrade Scenarios
Upgrading to Unified CCE Release 11.6(1) from Unified CCE Release 11.x, is the same as upgrading or
applying any other maintenance release. However, the Unified CCE 11.6(1) minor release contains an updated
database schema. Before the upgrade begins, the installer takes a backup of the configuration data from the
logger database of the existing Unified CCE 11.x configuration.

You can upgrade from Unified CCE Release 10.0(x)1 and 10.5(x) to Release 11.x by using one of the two
methods:

• The Common Ground method is an in-place upgrade performed on your existing virtual machine which
involves upgrading the Unified CCE and all other associated software hosted on it. If your hardware
meets the requirements for this release, you can perform a Common Ground upgrade without acquiring
additional hardware.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.6(1)
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• Use the Technology Refresh upgrade method to upgrade your hardware at the same time as the Unified
CCE system. When using the Technology Refresh method, you prepare a destination system on new
hardware and then migrate data from your existing deployment to the new one. You can also bypass the
Windows Server operating system and SQL Server upgrade process, as would be required when upgrading
from Unified CCE Release 10.0(x) and Release 10.5(x) to Unified CCE Release 11.0(x).

Upgrade scenarios are considered at a component level; you can perform one type of upgrade on one component,
and another type of upgrade on another component. However, the A and B side of any given component must
be running on identical hardware.

Follow the task flow and tasks for the upgrade scenario that applies to each individual component involved
in the overall upgrade.

Upgrade to Unified CCE Release 11.6(1) by either of the methods is possible by employing an in-line upgrade
(the process of specifying Release 11.6(1) installer location, while running the Release 11.0(1) base installer).
The system after upgrading to Release 11.0(1) and restarting, commences upgrading to Release 11.6(1).
1Note: The upgrade from 10.0(x) to 11.6(1) is specific to Unified CCE components (for example, Router, PG,
and so on).

Common Ground Upgrades
Unified CCE Release 11.6(1) is supported on a Windows Server 2012 R2 and SQL Server 2014 platform.
For information about supported editions or service packs, see theUnified CCE Solution Compatibility Matrix
at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html.

Unified CCE Release 11.5(1) is supported on a Windows Server 2012 R2 and SQL Server 2014 platform.
For information about supported editions or service packs, see theUnified CCE Solution Compatibility Matrix
at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html.

The common ground upgrade method consists of the following tasks:

• In-place upgrade of the operating system to Windows Server 2012 R2

• SQL server upgrade (for components such as Logger and Distributor)

• Database schema migration using the Enhanced Database Migration Tool (EDMT)

• Upgrade the Unified CCE software

For more information, see Virtualization for Unified Contact Center Enterprise at http://www.cisco.com/c/
dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

Technology Refresh Upgrades
To perform a Technology Refresh upgrade, you first prepare the destination system using new hardware, and
then migrate configuration data from your existing production system. This method reduces the maintenance
window required for the upgrade process compared to a Common Ground upgrade because the operating
system and SQL Server upgrade steps can be by-passed.

Follow the documented procedures to build a parallel network using new hardware and pre-stage it with
configuration data to support the existing production network. Use the Enhanced Database Migration Tool
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(EDMT) to transfer data and perform a schema upgrade during the upgrade process. Do not use backup and
restore procedures to perform the pre-staged configuration on the parallel network.

System Requirements

Platform Requirements
Server selection for Unified CCE in a virtualized environment involves several factors, including:

• The server and all related hardware must be supported for use in a virtualized Unified CCE system

• Minimum specifications for processing, memory, and storage

• Whether you want a packaged and tested Cisco configuration (Tested Reference Configuration or TRC)
or a configuration that you base on Cisco-defined minimum requirements (Specs-based Configuration)

• Compatibility requirements for all hardware, and Cisco and third-party software including the VMware
required to run and manage a virtual environment

Confirm that your hardware selection is supported for Unified CCE and meets all minimum specifications:

For detailed requirements information,
see

VMware requiredServer

Virtualization for Unified Contact Center
Enterprise at https://www.cisco.com/c/
dam/en/us/td/docs/voice_ip_comm/uc_
system/virtualization/
cisco-collaboration-virtualization.html

• VMware vSphere ESXi

• VMware vCenter (Optional)

UCS C-series (TRC):

• VMware vCenter

• VMware vSphere ESXi

UCS C-series
(Specs-based):

• VMware vCenter

• VMware vSphere ESXi

Third-party
(Specs-based)

In addition to confirming that your servers meet minimum specifications, confirm that your server choice is
compatible with all Cisco and third-party software.

Related Topics
Compatibility Requirements, on page 6

Network Requirements
Network requirements for virtualized Unified CCE systems vary widely, depending on the size and type of
Unified CCE solution deployment. Confirm that you have clearly established all network requirements before
you install or upgrade a Unified CCE contact center.

For more information, see Virtualization for Unified Contact Center Enterprise at https://www.cisco.com/c/
dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/cisco-collaboration-virtualization.html.
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Related Topics
Cisco Unified Contact Center Enterprise Design Guide

Transport Layer Security Version 1.2 Required
Contact center enterprise solutions require the use of TLS 1.2 only connections in this release. Our services
accept incoming TLS connections only over TLS 1.2. All outgoing TLS connection use only TLS 1.2.

All clients that connect to either our web interfaces or databases must support TLS 1.2.

The older versions of the TLS/SSL are disabled by 11.6 Installer.Note

For more information see, Unified CCE Solution Compatibility Matrix at https://www.cisco.com/c/en/us/
support/customer-collaboration/unified-contact-center-enterprise/products-device-support-tables-list.html.

Software License Requirements

Cisco Products

The following table lists the Cisco components that comprise a Unified CCE solution:

License requirementsComponents

One server license for each of the voice applications.

One agent license for each concurrent user with different feature tiers.

Cisco Unified Contact Center
Enterprise

One license for each Cisco Unified Communications Manager node,
plus device licenses for connected devices.

Cisco Unified Communications
Manager

One CVP software license for each server that runs Call Server or VXML
Server software (or both coresident), ports or redundant ports, or Call
Director software.

One CVP reporting license for each Reporting Server.

No license required for Operations Console.

Port license package required for ports used for simultaneous sessions
requiring self-service or queuing (voice and video).

Redundant port licenses required for each redundant port.

One license for each developer machine running Call Studio.

Upgrade licenses from Unified IP IVR available.

Cisco Unified Customer Voice
Portal (CVP)

One license for each server.Cisco Unified Intelligence Center
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License requirementsComponents

Cisco Finesse: User licenses included with selected tiers of Cisco Unified
Contact Center Enterprise user licenses. One license for each server pair.
One license for each Media Kit.

Cisco CTI Object Server (CTI OS): User licenses included with selected
tiers of Cisco Unified Contact Center Enterprise user licenses.

Cisco Finesse

or

Cisco CTI OS

User licenses includedwith selected tiers of Cisco Unified Contact Center
Enterprise user licenses.

Cisco Unified Contact Center
Management Portal

Server licenses required for Primary and Secondary Servers. Expansion
Server Software licenses required for extra capacity. Session licenses
(base, and either audio or video) required for each user.

Cisco MediaSense

User license included with Unified CCE Premium Agent License. One
server license for each SocialMiner server.

Cisco SocialMiner

Third-Party Products

For detailed information about the software editions and versions supported for this release, see the Unified
CCE Solution Compatibility Matrix at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-device-support-tables-list.html.

Note

Before you begin an installation or upgrade of any part of your contact center, confirm the following:

• That you have all the required software products.

• That all the software versions are compatible with each other.

• That all software versions are also compatible with all hardware and VMware.

Virtualization Requirements
You run the Unified Contact Center Enterprise solution on VMware ESXi platform.

The following requirements apply to VMware on virtual machines for Unified CCE:

• After you install the Unified CCE components on each VM, install the latest VMware Tools from your
VMware host using the VMware Tool default settings.

Update the VMware Tools whenever you patch or upgrade ESXi.Note
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Deploying VMwith Guest Operation System ‘Microsoft Windows Server 2019’
on ESXi 7.0 using CCE OVA template displays a warning message, “The
configured guest OS (Microsoft Windows Server 2016 or later (64-bit)) for this
virtual machine does not match the guest that is currently running (Microsoft
Windows Server 2019 (64-bit)). You should specify the correct guest OS to allow
for guest-specific optimization”. This warning message is informational only and
has no detrimental effect on the system. The warning message is displayed only
once and can be dismissed.

Note

For more information, see Virtualization for Unified Contact Center Enterprise at https://www.cisco.com/c/
dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/cisco-collaboration-virtualization.html.

Related Topics
Install VMware Tools for Windows, on page 23

ESXi Supportability
For information on supported versions of ESXi for this release seeUnified CCE Solution Compatibility Matrix
at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html.

As part of the CommonGround upgrade process, if there are no available overlapping supported ESXi versions,
upgrade the UCCE software first if a back-out of the upgrade is required.

If the upgrade is successful and working, you can then proceed to upgrade ESXi to a supported version for
final testing and restoring production operation.

Compatibility Requirements

As part of the planning process, ensure that all hardware, Cisco software, third-party software, VMware, and
firmware are compatible. Confirm that you meet all the following compatibility requirements:

SeeFor this
compatibility
information

Virtualization Software Requirements at http://www.cisco.com/c/dam/en/us/td/docs/voice_
ip_comm/uc_system/virtualization/virtualization-software-requirements.html

VMware and
Cisco software
components
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SeeFor this
compatibility
information

See the following:

VMware Compatibility Guide at
http://www.vmware.com/resources/compatibility/search.php.

For more information, see Virtualization for Unified Contact Center Enterprise at
http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

Cisco Installation and Upgrade Guides at http://www.cisco.com/c/en/us/support/
servers-unified-computing/ucs-c-series-rack-servers/products-installation-guides-list.html

Required
firmware

Unified CCE Solution Compatibility Matrix at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Review the compatibility between different versions of the Cisco components
to plan upgrades that occur across multiple maintenance windows. Components
that are upgraded in one maintenance window must continue to operate with
other components that are still at the previous version until the full upgrade is
completed.

Note

Cisco software
product
intercompatibility

See the following:

SNMP Guide for Cisco Unified ICM/Contact Center Enterprise at http://www.cisco.com/
c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html

Serviceability Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html

Windows OS
and SNMP

• SNMP
Service

• SNMP MI
Provider

Unified CCE Solution Compatibility Matrix at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Third party
software
products
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C H A P T E R 2
Installation Overview

• Installation Tools, on page 9
• Uninstallation, on page 10

Installation Tools
During installation, use one or all of the following tools, as required:

• ICM-CCE-Installer—The main Unified CCE Installer copies all files into relevant folders, creates the
base registries, and installs needed third-party software such as JRE and Apache Tomcat. It uses the
Microsoft .NET Framework which is an integral software of Windows Server.

Optionally, you can update the JRE installed by the Unified CCE Installer with
a later version of the JRE. See Update the Java Runtime Environment (Optional),
on page 56.

Note

Do not run the installer remotely. Download the installer to a local machine for installation.

• Cisco Unified Intelligent Contact Management Database Administration (ICMDBA) Tool—Used to
create new databases, modify or delete existing databases, and perform limited SQL Server configuration
tasks.

The SQL Server installation disables the Windows Computer Browser service.
The ICMDBA requires this service. If you need to run ICMDBA on this server,
enable the Computer Browser service.

Note

• Domain Manager—Used to provision Active Directory.

• Web Setup—Used to set up the Call Routers, Loggers, Network Gateways, Network Interface Controllers,
and Administration & Data Servers.

• Peripheral Gateway (PG) Setup—Used to set up PGs, the CTI server, Network Gateways, Network
Interface Controllers, and the Outbound Option dialer.
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• AdminClientInstaller—Installs the Administration Client on a system that is not running other Unified
CCE components.

The AdminClientInstaller is delivered on the installation media with the ICM-CCE-Installer.

• Administration Client Setup—Used to add, edit, or remove Administration Clients and Administration
Client Instances.

Related Topics
Update the Java Runtime Environment (Optional), on page 56

Uninstallation
Unified CCE supports the uninstall option from the Programs and Featureswindow in theWindows Control
Panel. This option removes the patches, base version files, and the related registry. The specific option also
removes Unified CCE component software installed by the ICM-CCE-Installer.

However, it does not remove the following:

• Java Runtime Environment

• Unified CCE databases

Reinstallation is also supported. To reinstall, rerun the ICM-CCE-Installer.
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C H A P T E R 3
Preinstallation

• Preinstallation Task Flow, on page 11
• Preinstallation Tasks, on page 11

Preinstallation Task Flow
Before you can install Unified CCE and the associated components, set up the network, create virtual machines,
and install and configure third-party software.

The length of the hostname of any Unified CCE server must not exceed 15 characters.Important

SeeTask

Set up Active Directory, on page 11If you are integrating Unified CCE into an
existing corporate network, verify Domain
Controller health. If you are installing into
a new Active Directory domain, install and
configure Active Directory and DNS server.

Set Up Virtual Machines, on page 15Download Open Virtualization Format
(OVA) templates and create virtual
machines.

Set Up Third-Party Software, on page 20Install and configure third-party software.

Preinstallation Tasks

Set up Active Directory
Ensure that you have a completed plan for your domain structure and Active Directory implementation before
you set up your network. For more information, see the Staging Guide for Cisco Unified ICM/Contact Center
Enterprise at
http://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-guides-list.html.
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Verify Domain Controller Health
Before you set up the Unified CCEDNS and Active Directory (AD) structure, ensure that your existing domain
controller environment is stable. Install and run the following tools, available from the Microsoft Windows
Server 2012 R2 installation media, in the Tools subfolder:

• dcdiag.exe—Generates a report on AD health, including connectivity, replication, topology integrity,
intersite health, and trust verification. Checks Network Card (NC) head security descriptors, net logon
rights, and roles. Locates the domain controller.

• repadmin.exe—Retrieves the replication status of all /csv >showrepl.csv domain controllers in a
spreadsheet, verifies DNS infrastructure, Kerberos, Windows time service (W32time), remote procedure
call (RPC), and network connectivity.

Ask your network administrator or qualified AD expert (for example, Microsoft Support Services) to evaluate
the resulting reports from these tools.

Run dcdiag.exe

Procedure

Step 1 Choose Start > Run.
Step 2 Type cmd.
Step 3 Press Enter.

A command console opens.

Step 4 At the prompt, enter dcdiag.exe /e /v /f:dcdiag.txt.

If you use the /e option, run dcdiag.exe at the root level. If you do not use the “/e” option, run
dcdiag.exe on each individual domain controller.

Note

The application creates the text file dcdiag.txt in the folder containing dcdiag.exe.

Step 5 Open the text file and note any items that are prefaced with “Warning” or “Error.”
Step 6 Correct all the issues, then rerun dcdiag.exe to ensure that no issues remain.

Run repadmin.exe

Procedure

Step 1 Choose Start > Run.
Step 2 Type cmd.
Step 3 Press Enter.

A command console opens.

Step 4 At the prompt, enter repadmin.exe /showrepl * /csv >showrepl.csv.
Step 5 Open Excel and choose File > Open.
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Depending on your version of Excel, the menu cascades may be slightly different.Note

Step 6 In the “Files of type” section, click Text Files (*.prn;*.txt;*.csv).
Step 7 In the “Look in” section, navigate to showrepl.csv, then click Open.
Step 8 In the Excel spreadsheet, right-click the column heading for showrepl_COLUMNS (column A), then click

Hide.
Step 9 In the Excel spreadsheet, right-click the column heading for Transport Type, then click Hide.
Step 10 Select the row just under the column headings, then choose Windows > Freeze Pane.
Step 11 Click the upper-left corner of the spreadsheet to highlight the entire spreadsheet. Choose Data > Filter >

AutoFilter.
Step 12 In the heading of the Last Success column, click the down arrow, then click Sort Ascending.
Step 13 In the heading of the Source DC column, click the down arrow, then click Custom.

In the Custom AutoFilter dialog box, complete the custom filter as follows:

a. Under Source DC, click does not contain.

b. In the corresponding text box, enter del to filter deleted domain controllers from the spreadsheet.

Step 14 In the heading of the Last Failure column, click the down arrow, then click Custom.

In the Custom AutoFilter dialog box, complete the custom filter as follows:

a. Under Last Failure, click does not equal.

b. In the corresponding text box, enter 0 to filter for only domain controllers that are experiencing failures.

For every domain controller in the forest, the spreadsheet shows the following:

• Source replication partner

• The time that replication last occurred

• The time that the last replication failure occurred for each naming context (directory partition)

Step 15 Use Autofilter in Excel to view the replication health for the following:

• Working domain controllers only

• Failing domain controllers only

• Domain controllers that are the least, or most recent

You can observe the replication partners that replicate successfully.

Step 16 Locate and resolve all errors.
Step 17 Rerun repadmin.exe to ensure that no issues remain.

Add DNS Server to Local Domain Controller
Ensure that the local Active Directory domain controllers have Domain Name Servers installed.
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See the Microsoft documentation at https://docs.microsoft.com/en-us/windows-server/identity/ad-ds/plan/
creating-a-dns-infrastructure-design for adding DNS role to Active Directory servers.

If the local domain controllers serve as Forest Root for the domain, see DNS requirement in Staging Guide
for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-guides-list.html
for additional requirements on Forest Root DNS configuration.

Note

Configure Active Directory Sites
Perform the following procedure on the Unified CCE root domain controller:

Procedure

Step 1 Start > Programs > Administrative Tools > AD Sites and Services.
Step 2 Rename the default first site name in accordance with your AD site plan.

a) For a geographically separated Domain Controller, right-click Sites.
b) Select New Site.
c) Enter the site name of the additional domain controller based on your AD site plan.

Step 3 Create subnets for each Domain Controller site:
a) Right-click the Subnets folder and select New Subnet.
b) Enter the subnet address and mask associated with the LAN at the Domain Controller Site.
c) Highlight the Site Name that is associated with that subnet.

Step 4 Expand the Servers folder from the original first site folder.
Step 5 For each server that you must move to a different site, right-click the server name, select Move, and highlight

the Site to which you want to move it.
Step 6 Expand Inter-Site Transport under Sites.

a) Open the IP folder and select DEFAULTIPSITELINK from the right pane.
b) Right-click and select Properties. Ensure that both sites appear as entries in the Sites in this Site Link

window.
c) Change the Replicate Every value to 15 minutes.

Assign Global Catalog and Set Time Source

Before you begin

Use the Administrator account and open command prompt to connect to the Domain Controller with the
PDC (Primary Domain Controller) role. If you have multiple Domain Controllers, use the following command
to determine which one contains the PDC role:
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Procedure

Step 1 Locate your PDC Server. Open the command prompt and enter the following command:netdom/query
fsmo

Step 2 Log in to your PDC Server and open the command prompt as Administrator. Configure the PDC to synchronise
to external sources. Type the following command at the command prompt: w32tm /config
/manualpeerlist:"<NTPServer 1> <NTP Server 2>”

Step 3 Make the Domain Controller a reliable time source for the clients: w32tm /config /reliable:yes.
Step 4 Start the w32time service: net stop w32time && net start w32time. The windows time service

begins synchronizing with the time.

If the Domain Controller does not synchronize time with the external NTP server, check the event
logs (Event Viewer >> System).

Note

Step 5 Check the source Time-Service in Event Viewer for any errors.

Set Up Virtual Machines

Verify Datastores
Before you install the VMs, verify that the datastore is in place. The type of datastore depends on the type of
server on which you deploy the VMs. For example, UCS-B servers use a SAN datastore and UCS-C servers
use DAS datastores.

For more information, see the VMware documentation at https://www.vmware.com/support/pubs/.

For more information, see Virtualization for Unified Contact Center Enterprise at https://www.cisco.com/c/
dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

Configure RAID for C240 M4SX
The disk array configuration for the C240 M4SX is already set up to match what is required for Unified CCE.
Verify the settings as follows.

Procedure

Using Cisco Integrated Management Controller, check that the following settings are configured correctly:

• Virtual Drive Info: RAID 5 with 5 (Physical Disks) * 4 (Virtual Drives/Datastores)

• Stripe Size: 128KB

• Write Policy: Write Back with BBU

• Read Policy: Read Ahead Always
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For more information regarding RAID configuration for C240 M4SX in Configure RAID with GUI (UCS
C-Series M4 Servers) section, see Cisco Collaboration on Virtual Servers Guide at:
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/virtual/CHCS_BK_C7C7ED05_00_cisco-collaboration-on-virtual-servers.html.

Configure RAID for C240 M5SX
The disk array configuration for the UCS C240 M5SX is already set up to match the requirements. Verify the
settings as follows:

Procedure

Using Cisco Integrated Management Controller, check that the following settings are configured correctly:

• Virtual Drive Info: RAID 5 with 6 (Physical Disks) * 4 (Virtual Drives or Datastores)

• Stripe Size: 128KB

• Write Policy: Write Back with BBU

• Read Policy: Read Ahead Always

For more information regarding RAID configuration for C240 M5SX, see the Installation and Configuration
section of the Cisco Collaboration on Virtual Servers Guide at:

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/virtual/chcs_b_
cisco-collaboration-on-virtual-servers.html

Download Unified CCE OVA Files
The Unified CCE Open Virtualization Format (OVA) files define the basic structure of the corresponding
VMs that are created. The structure definition includes the CPU, RAM, disk space, reservation for CPU, and
reservation for memory.

Before you begin

You must have a valid service contract associated with your Cisco.com profile.

Procedure

Step 1 Go to the Unified CCE Download Software page on Cisco.com.
Step 2 Click Download to download and save the appropriate OVA file to your local hard drive. When you create

VMs, you select the OVA required for the application.

Create a Virtual Machine from the OVA
To create virtual machines (VMs) from the OVA files, complete the following procedure.
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ECE requires a second virtual hard drive on its VM. The OVA creates one virtual hard drive. Create a second
hard drive of an appropriate size for your solution requirements.

Note

Procedure

Step 1 Select the Host in the vSphere client.
Step 2 Choose File > Deploy OVF Template.
Step 3 Browse to the location on your local drive where you stored the OVA. Click Open to select the file. Click

Next.

Step 4 Click Next at the OVF Template Details page.
Step 5 Enter the virtual machine name. It cannot contain spaces or special characters. Enter a maximum of 32

characters. Click Next.
Step 6 On the Name and Location page, enter a name of your choice in the Name field. Click Next.

After the VM is created, you cannot rename it.Important

Step 7 On the Deployment Configuration page, select the applicable configuration from the drop-down list. Click
Next.

Step 8 Choose a data store on which to deploy the new virtual machine. Click Next.

For each datastore, the following tables describe the RAID group, the ESXi Host, and the virtual machines
for the C240 M4SX and the C240 M5SX servers.

RAID configuration for the C240 M4SX and C240 M5SX

Virtual MachinesESXi HostVM DatastoreRAID Group

ESXi operating system

Unified CCE Rogger, Side A

Unified Communications Manager
Publisher

Cisco Finesse Primary

Adatastore 1VD0

Unified CCE AW-HDS-DDS, Side AAdatastore 2VD1

Unified Communications Manager
Subscriber 1

Unified CVP OAMP Server

Unified CVP Server, Side A

Adatastore 3VD2

Unified Intelligence Center Server
Publisher

Unified CCE PG, Side A

Adatastore 4VD3
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Virtual MachinesESXi HostVM DatastoreRAID Group

ESXi operating system

Unified CCE Rogger, Side B

Unified Communications Manager
Subscriber 2

Cisco Finesse Secondary

Bdatastore 1VD0

Unified CCE AW-HDS-DDS, Side BBdatastore 2VD1

Unified Customer Voice Portal
Reporting Server (optional)

Unified CVP Server, Side B

Bdatastore 3VD2

Unified Intelligence Center Server
Subscriber

Unified CCE PG, Side B

Enterprise Chat and Email Server
(optional)

Bdatastore 4VD3

Step 9 On the Disk Format page, choose Thick provisioned Eager Zeroed format for the virtual disk format.
Click Next.

Thick provisioned Lazy Zero is also supported, but Thin provisioned is not supported.Note

Step 10 Confirm that the Network Mapping page is correct:
a) Public network adapter to Public network
b) Private network adapter to Private network

Certain VMs do not require a private network connection. The OVAs for those VMs do not create
a second network adapter.

Note

Step 11 Click Finish.

Step 12 At the Successfully Completed message, click Close.

For more information, see Virtualization for Unified Contact Center Enterprise at
http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

Note

Allocate a Second Virtual Hard Drive
After deploying the OVA files, the second hard drive is no longer automatically created. To create a second
hard drive:
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Procedure

Step 1 Right-click the virtual machine and click Edit Settings.
Step 2 In the Hardware tab, click on Add.

The Add Hardware window appears.

Step 3 You can select the type of device you wish to add. Select Hard Disk, and then click Next.
Step 4 Select the Create a new virtual disk option, and then click Next.
Step 5 In the Capacity section, use the Disk Size box to assign the desired disk space, and then click Next.

Virtual machine templates for Logger, Rogger, AW, and HDS servers do not have a SQL database
drive preprovisioned. The following reference table can be used to assign disk space to the virtual
machine based on the type:

Default Second Disk SizeVirtual Machine Template

500 GBLogger

150 GBRogger

500 GBAW-HDS-DDS

500 GBAW-HDS

500 GBHDS-DDS

You can custom size the SQL database disk space to meet data retention requirements, as calculated
by the Database Estimator tool.

Note

Step 6 On the Disk Provisioning section choose Thick provision Lazy Zeroed format. Click Next.
Step 7 In the VM Options > Advanced Options section, retain the default options and then click Next.
Step 8 In the Ready to Complete section, click Finish to create the hard disk.
Step 9 Click OK to confirm the changes.

The Recent Tasks window at the bottom of the screen displays the progress.

Mount ISO Files
Upload ISO image to data store:

1. Select the host in the vSphere client and click Configuration. Then click Storage in the left panel.

2. Select the datastore that will hold the ISO file.

3. Right click and select Browse datastore.

4. Click the Upload icon and select Upload file.
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5. Browse to the location on your local drive where you saved the ISO file, and upload the ISO to the
datastore.

Mount the ISO image:

1. Right-click the VM in the vSphere client and select Edit virtual machine settings.

2. Click Hardware and select CD|DVD Drive 1.

3. Check Connect at power on (Device status panel upper right).

4. Click the Datastore ISO File radio button and then click Browse.

5. Navigate to the data store where you uploaded the file.

6. Select the ISO file and click OK.

Initialize and Format Secondary Disk
After the second hard disk is created, allocate memory to the hard disk.

Procedure

Step 1 Open the command prompt, and type diskmgmt.msc.
Step 2 Right-click Disk 1, and click Online.
Step 3 After the disk goes online, right-click the disk, and then click Initialize Disk.
Step 4 Select Master Boot Record (MBR) radio button.
Step 5 After the disk is initialized, right-click the disk, and then click Convert to Dynamic Disk.
Step 6 In the Convert to Dynamic Disk window, check the Disk 1 check box to select it, and then click OK.
Step 7 Right click on the unallocated disk space, and click New Simple Volume. The New Simple Volume Wizard

window appears.
Step 8 Click Next and follow the on-screen instructions to create a simple volume on the disk.
Step 9 Click Finish to complete the process of allocating memory to the hard drive.

Set Up Third-Party Software

Install Microsoft Windows Server
Complete the following procedure to install Microsoft Windows Server on the virtual machines deployed.

For information about supported editions, see the Unified CCE Solution Compatibility Matrix at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Note
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Procedure

Step 1 Mount the Microsoft Windows Server ISO image to the virtual machine.

Check the Connect at power on check box when mounting the ISO.

For more information, see Mount and Unmount ISO File.

Step 2 Power on the VM.
Step 3 Enter the Language, Time and Currency Format, and Keyboard settings. Click Next.
Step 4 Click Install Now.
Step 5 If prompted, enter the product key for Windows Server and click Next.
Step 6 Select the Desktop Experience option for the Windows Server and click Next.
Step 7 Accept the license terms and click Next.
Step 8 Select Custom: Install Windows only (advanced), select Drive 0 to install Microsoft Windows Server, and

then click Next.

The installation begins. After the installation is complete, the system restarts without prompting.

Step 9 Enter and confirm the password for the administrator account, and then click Finish.
Step 10 Enable Remote Desktop connections as follows:

a) Navigate to Control Panel > System and Security > System.
b) Click Remote Settings.
c) Click the Remote tab.
d) Select the Allow remote connections to this computer radio button. The Remote Desktop Connection

dialog displays a notification that the Remote Desktop Firewall exception is enabled. Click OK.

Step 11 Install VMWare tools. See Install Vmware Tools, on page 22
Step 12 Open the Network and Sharing Center, and in the View your basic network info and set up connections

section, click Ethernet.
Step 13 In the Ethernet Status window, click Properties.
Step 14 In the Ethernet Properties dialog box, configure the network settings and the Domain Name System (DNS)

data:
a) Uncheck Internet Protocol Version 6 (TCP/IPv6).
b) Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.
c) Select Use the following IP Address.
d) Enter the IP address, subnet mask, and default gateway.
e) Select Use the following DNS Server Address.
f) Enter the preferred DNS server address, and click OK.

Step 15 Navigate to Control Panel > System and Security > System. Follow the instructions:
a) ClickChange Settings.
b) In Computer name tab, click Change.
c) Change the name of the computer from the name randomly generated during Microsoft Windows Server

installation. The name does not contain underscores or spaces.
d) Select Domain radio button to change the member from Workgroup to Domain.
e) Enter qualified domain name and click OK.
f) In the Windows security dialog, validate the domain credentials and click OK.
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g) On successful authentication, click OK.
h) Reboot the server and sign in with domain credentials.
Restart your system for the change to take effect.

Step 16 Go to Settings > Update & Security and run Microsoft Windows Update. .

After the update is complete, click Do not enable automatic updates.

Microsoft Windows Server is installed. In addition, Internet Explorer 11 is installed automatically.

If you want to install Unified CCE on a multilingual version of Windows Server, run the Multilingual User
Interface (MUI) language pack. See https://software.cisco.com/download/
release.html?mdfid=268439622&flowid=46046&softwareid=280840583.

If Unified CCE language pack is applied on Chinese Windows OS machine, set the screen resolution to 1600
x 1200.

Note

Set Windows Locale
If theWindows system locale differs from the display language (and therefore also the SQL collation setting),
some characters appear incorrectly in the user interface and are saved incorrectly to the database. For example,
if the system locale is English and an agent works in Spanish, characters such as the acute a do not appear
correctly.

If you use a multilingual version of Microsoft Windows Server, complete this procedure to set the Windows
locale.

Procedure

Step 1 Open Control Panel > Clock, Region and Language.
Step 2 In the Region section, click Change date, time, or number formats.
Step 3 Click the Administrative tab.
Step 4 In the Language for non-Unicode programs section, click Change system locale.
Step 5 In the Region Settings window, select the language that matches the display language.
Step 6 Restart the virtual machine.

Install Vmware Tools
VMware Tools is a suite of utilities that enhance the performance of the virtual machine guest operating
system. It also aids virtual machine management.
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Install VMware Tools for Windows

Procedure

Step 1 From the vSphere Client, right-click the virtual machine, select Power, and click Power On.
Step 2 Click the Summary tab.

In the General section, the VMware Tools field indicates whether VMware Tools are:

• installed and current

• installed and not current

• not installed

Step 3 Click the Console tab to make sure that the guest operating system starts successfully. Log in if prompted.
Step 4 Right-click the virtual machine, select Guest OS, and then click Install/Upgrade VMware Tools. The

Install/Upgrade VMware Tools window appears with the option - Interactive Tools Upgrade and Automatic
Tools Upgrade.
a) To install/upgrade the VMware tools manually, select the Interactive Tools Upgrade option, and click

OK. Follow the on-screen instructions to install/upgrade the VMware tools, and restart the virtual machine
when prompted.

b) To install/upgrade the VMware tools automatically, select the Automatic Tools Upgrade option, and
click OK. This process takes a few minutes to complete, and restart the virtual machine when prompted.

Install VMware Tools for VOS

To install or upgrade VMware Tools using VOS, perform the following steps:

Procedure

Step 1 Ensure that your virtual machine is powered on.
Step 2 Right-click the VM menu. Select Guest > Install / Upgrade VMware tools .
Step 3 Choose the interactive tools update and press OK.
Step 4 Open the console and log in at the command prompt.
Step 5 Enter the command utils vmtools refresh and confirm.

The server automatically reboots twice.
Step 6 After reboot, check the Summary tab for the VM to verify that the VMware Tools version is current. If it is

not current, reboot the VM and check the version again.

The process takes a few minutes. After the process completes, the tools are listed as Running (Current) on
the VM's Summary tab in vSphere.
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Install Microsoft SQL Server
To use the default (two) vDisk design, install Microsoft SQL Server 2014, and store the SQL Server log and
temporary files on the same vDisk as the operating system. If you choose to use more than two virtual disks,
then the tempDB cannot be on the same vDisk as the solution database.

For further information about the database placement and performance tuning the SQL installation, see the
Microsoft documentation.

For information about supported editions, see the Unified CCE Solution Compatibility Matrix at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html.

Note

Before you begin

EnableMicrosoft .NET Framework 3.5 SP1 before installing SQL Server 2014. In theWindows Server, Server
Manager, use the Add Roles and Features Wizard to enable the .NET Framework 3.5 SP1. See the Microsoft
documentation at https://technet.microsoft.com/en-au/library/dn482071.aspx for detailed instructions.

If your computer is not connected to the internet to get the updates, download and install Microsoft .NET
Framework 3.5 SP1 manually.

Note

Procedure

Step 1 Mount the Microsoft SQL Server ISO image to the virtual machine. For more information, see Mount ISO
Files, on page 19.

Step 2 Select Installation in the left pane and then clickNew SQL Server stand-alone installation or add features
to an existing installation. Click OK.

Step 3 On the Product Key page, enter the product key and then click Next.
Step 4 Accept the License Terms and then click Next.
Step 5 Optional: On theMicrosoft Update page, check theUse Microsoft Update to check for updates check box,

and then click Next.

If you do not check the Use Microsoft Update to check for updates option, click Next on the
Product Updates page.

Note

Step 6 On the Install Rules page, click Next.

In this step, the installation program checks to see that your system meets the hardware and software
requirements. If there are any issues, warnings or errors appear in the Status column. Click the links for more
information about the issues.

Step 7 On the Setup Role page, select SQL Server Feature Installation and click Next.
Step 8 On the Feature Selection page, select only the following, and click Next:
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If you intend to use Outbound Option High Availability two-way replication, be sure to select the Replication
feature on this page. For more information about replication, see the Outbound Option Guide for Unified
Contact Center Enterprise.

Step 9 On the Instance Configuration page, select Default Instance and click Next.

Step 10 On the Server Configuration page, click the Services Account tab.
a) Associate the SQL services with the virtual account.

• For the SQL Server Agent service, in the Account Name field, select NT
Service\SQLSERVERAGENT. If you have enabled Outbound Option High Availability, this
account must have the system administrator privilege.

• For the SQL Server Database Engine, in the Account Name field, select NT
Service\MSSQLSERVER.

While you can use the Network or Local Services account instead of the Virtual account, using
the Virtual account provides security.

Note

b) For the remaining services, accept the default values.
c) In the Start Up Type column, for the SQL Server Agent service account, select Automatic from the

list.
d) EnableGrant Perform Volume Maintenance Task privilege to SQL Server Database Engine Service.

ICM Installer automatically enables the Grant Perform Volume Maintenance Task for the
NT service account.If it is not enabled automatically then you must enable Grant Perform
Volume Maintenance Task privilege to SQL Server Database Engine Service manually on
the SQL server.

Note

Step 11 On the Server Configuration page, click the Collation tab.
a) In the Database Engine section, click Customize.
b) Select the Windows Collation designator and sort order radio button.
c) Select the appropriate collation. Typically, you choose the SQL Server collation that supports theWindows

system locale most commonly used by your organization; for example, "Latin1_General" for English.

See the Unified CCE Solution Compatibility Matrix at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/products-device-support-tables-list.html
for details about collations used for other languages.

Note

The database entry is related to the collation that you select. For example, if you set the collation for
Latin1_General, but you select Chinese language at sign-in. When you enter field values in Chinese, the
application displays the unsupported character error, because the database does not support the
characters.

It is critical to select the correct collation setting for the language display on your system. If
you do not select the correct collation during installation, you must uninstall and reinstall
Microsoft SQL Server.

Important

d) Check the Binary check box.
e) Click OK, and then click Next.

Step 12 On the Database Engine Configuration page:
a) On the Server Configuration tab, click the Mixed Mode radio button.
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b) Enter the password for the SQL Server system administrator account, and confirm by reentering it.
c) Click Add Current User to add the user who is installing the SQL Server as an administrator.
d) On theTempDB tab, set the Initial size andAutogrowth for Rogger, Logger, AW-HDS-DDS, AW-HDS,

and HDS-DDS. For information about values for respective components .

For more information about the SQL Server TempDBDatabase and its use, see the Microsoft SQL Server
documentation.

e) Click Next.

Step 13 On the Ready to Install page, click Install.
Step 14 On the Complete page, click Close.
Step 15 Enable Named Pipes and set the sort order as follows:

a) Open the SQL Server Configuration Manager.
b) In the left pane, navigate to SQL Native Client 11.0 Configuration (32bit) > Client Protocols.
c) In the right pane, confirm that Named Pipes is Enabled.
d) Right-click Client Protocols and select Properties.
e) In the Enabled Protocols section of the Client Protocols Properties window, use the arrow buttons to

arrange the protocols in the following order:

1. Named Pipes

2. TCP/IP

f) Check the Enable Shared Memory Protocol and then click OK.
g) In the left pane, navigate to SQL Server Network Configuration > Protocols for MSSQLSERVER.
h) In the right pane, right-click Named Pipes and select Enable.

By default, Microsoft SQL Server dynamically resizes its memory. The SQL Server reserves the
memory based on process demand. The SQL Server frees its memory when other processes request
it, and it raises alerts about the memory monitoring tool.

Cisco supports the Microsoft validation to dynamically manage the SQL Server memory. If your
solution raises too many memory alerts, you can manually limit SQL Server’s memory usage. Set
the maximum and minimum limit of the SQLmemory using themaximum memory usage settings
in the SQL Server Properties menu.

For more information about the SQL Server memory settings and its use, see the Microsoft SQL
Server documentation.

Note

Step 16 Set the SQL Server's default language to English as follows:
a) Launch SQL Server Management Studio.
b) In the left pane, right-click the server and select Properties.
c) Click Advanced.
d) In the Miscellaneous section, set the Default Language to English.
e) Click OK.

Set the SQL Server default language to English because Cisco Unified Contact Center Enterprise
requires a US date format (MDY). Many European languages use the European date format (DMY)
instead. This mismatch causes queries such as select * from table where date = '2012-04-08

00:00:00' to return data for the wrong date. Handle localization in the client application, such as
Cisco Unified Intelligence Center.

Important
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Step 17 Restart the SQL Server service as follows:
a) Navigate to the Windows Services tool.
b) Right-click SQL Server (MSSQLSERVER) and click Stop.
c) Right-click SQL Server (MSSQLSERVER) and click Start.

Step 18 Ensure that the SQL Server Browser is started, as follows:
a) Navigate to the Windows Services tool.
b) Navigate to the SQL Server Browser.
c) Right-click to open the Properties window.
d) Enable the service, change the startup type to Automatic, and click Apply.
e) To start the service, click Start, and then click OK.

What to do next

Do not change the SQL port number. Retain the default port numbers as 1433 for TCP and 1434 for UDP
connections. In case you change the port numbers, the applications like CCEAdmin will not work.

Caution

Set Users as System Administrators

Any users who are involved in installing or upgrading a Unified ICM/CCE solution must be added as part of
SQL Server Security login and associated with the System Administrator role. Complete the following steps
to set a user as a System Administrator:

Procedure

Step 1 Open the Microsoft SQL Server Management Studio using the System Administrator login credentials.
Step 2 In the Object Explorer pane, click the Security folder.

The Security folder expands.

Step 3 Right-click the Logins folder, and then click New Login.

The Login-New view appears.

Step 4 In theLogin name field, enter the Domain login name of the user whom you want to associate with the System
Administrator role.

Use the following format:

<domain>\<username>

Step 5 In the Object Explorer pane, click the Server Roles folder.

The Server Roles view appears.

Step 6 Check the sysadmin check box.

This step is mandatory.Note
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System administrator is a predefined fixed server-level role in the Microsoft SQL Server. The system
administrator performs operations on a site-level. System administrators manage jobs, role definitions, and
shared schedules that are used to run reports.

You must be a system administrator to create, modify, and delete individual records in the Configuration
Manager tool.

For details about the sysadmin role, see the Microsoft SQL documentation.

Step 7 Click OK.

The user is now a part of the SQL Security login and is also associated with the System Administrator role.

Increase Database and Log File Size
Use the Microsoft SQL Server Management Studio to increase the database and log sizes.

For more information, see the corresponding Microsoft documentation.

For the Tempdb, follow these guidelines:

• For Data Files:

• Set the Space Allocated to 1400 MB.

• Set Automatically grow files to 100MB.

• Set Unlimited file size.

• For Transaction Log Files, follow these guidelines:

• Set the Space Allocated to 400 MB.

• Set Automatically grow files to 10%.

• Set Unlimited file size.

• In the Options page, ensure that the following options are set to False: ANSI NULL Enabled,
Recursive triggers Enabled, Auto close, Auto shrink and Quoted identifiers Enabled.

Install Antivirus Software
For details about supported anitvirus softwares, see Unified CCE Solution Compatibility Matrix, see
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Use your antivirus vendor's product documentation for installation instructions, and adhere to the following:

• Update antivirus software manually. Do not enable automatic updates.

• To allow required access to installation program files or folders, perform file-blocking exclusions in the
antivirus product file-and-folder protection rules. For example, to create the exclusions in McAfee
VirusScan:

1. Open the VirusScan console.

2. Right-click Access Protection and select Properties.
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3. In the Anti-virus Standard Protection category, make sure that the rule Prevent IRC communication
is unchecked in the Block column.

• Be aware that in the firewall component of Symantec Endpoint Protection 12.1, the Network Threat
Protection feature must be disabled. The feature is enabled by default. When the feature is enabled, both
sides of a redundant router come up in stand-alone mode which blocks communication between each
side of the router pair. This blocking affects all deployment types.

If you retain the default (enabled) and start serviceson side A and B of the router, the following Symantec
message appears in the system tray: “The client will block traffic from IP address [side A router address]
for the next 600 seconds.” The same message is also written to the security login client management.
The Symantec Network Threat Protection traffic log indicates that a default firewall rule called “Block_all”
was dynamically enabled. The router logs show that both sides of the router came up in stand-alone
mode.

• The firewall component of Trend Micro Deep Security blocks communication between each side of the
Router/PG.

If you retain the default (enabled) and start service on side A and B you can see a new deny event logged
in Trend Micro Manager > Events> Firewall Events.

To resolve the issue, disable the Trend Micro firewall policy or add a new firewall exception for that
particular policy.

To resolve the issue, disable the Symantec firewall on all Unifed CCE boxes and restart the services.

If you are using a managed client, perform the following steps:

1. Launch Symantec Endpoint Protection Manager.

2. Click Policies.

3. Right-click the firewall policy that you want to disable, and then select Edit.

4. Uncheck the check mark next to the policy to disable it.

5. Click OK to confirm.

If you are using an unmanaged client, perform the following steps:

1. Double-click the Symantec icon in the system tray and select Change Settings.

2. Configure settings for Network Threat Protection and uncheck the Enable Firewall check box at
the top of the Firewall tab.

Install .NET Framework 4.5.2
The Unified CCE installation or upgrade runs faster if .NET Framework 4.5.2 or later version is pre-installed.

If the appropriate version of the .NET Framework is not installed, the Unified CCE installer installs it.
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C H A P T E R 4
Installation

• Installation Task Flow, on page 31
• Installation Tasks, on page 33

Installation Task Flow
This section lists the installation tasks for a Unified CCE contact center solution.

Installation procedures for Unified CCE components appear later in this chapter. For the non-Unified CCE
components in your solution, follow the links in the table to access the installation guides for those components.

For the Unified CCE components, the sequence you follow can vary according to the distribution of Unified
CCE components on virtual machines.

SeeTask

Set Up Virtual Machines for Installation, on page 33Ensure that virtual machines are ready
for installation

Installing Cisco Unified Communications ManagerInstall Unified Communications
Manager

Install Unified CCE 11.6(1) Software, on page 35Install Unified CCE components
(Router, Logger, Administration&Data
Servers, peripherals)

Create Outbound Option Database, on page 40

and then see

Outbound Option Guide for Unified Contact Center Enterprise at
https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-user-guide-list.html

Install Outbound Option

Cisco Finesse Server Installation, on page 60Install Finesse

Enterprise Chat and Email Installation Guide (for Unified Contact
Center Enterprise) at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-installation-guides-list.html

Install Enterprise Chat and Email
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SeeTask

Installation and Upgrade Guide for Cisco Unified Intelligence
Center at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-intelligence-center/
products-installation-guides-list.html

or

Install Coresident Deployment (Cisco Unified Intelligence Center
with Live Data and IdS), on page 79

Install Cisco Unified Intelligence Center
Standalone (4000, 8000, 12000 Agent
Deployment)

or

Install Coresident Deployment (2000
Agent Deployment)

Live Data Standalone Installation, on page 72

or

Install Coresident Deployment (Cisco Unified Intelligence Center
with Live Data and IdS), on page 79

Install Live Data Standalone (4000,
8000, 12000 Agent Deployment)

or

Install Coresident Deployment (2000
Agent Deployment)

Cisco Unified Contact Center Enterprise Features Guide at
https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-feature-guides-list.html

Install Single Sign-On Identity Service
Standalone (4000, 8000, 12000 Agent
Deployment)

or

Install Coresident Deployment (2000
Agent Deployment)

Installation and Upgrade Guide for Cisco Unified Customer Voice
Portal at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-customer-voice-portal/
products-installation-guides-list.html

Install Cisco Unified Customer Voice
Portal (Unified CVP) 1

Installation and Configuration Guide for Cisco Unified Contact
Center Management Portal at https://www.cisco.com/c/en/us/
support/customer-collaboration/
unified-contact-center-management-portal/
products-installation-guides-list.html

Install Unified Contact Center
Management Portal (Unified CCMP)

Cisco Unified CRM Connector Implementation and Administration
Guide for Microsoft CRM, Oracle PeopleSoft and Salesforce.com
at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-crm-connector/products-installation-guides-list.html

and

Installation and Configuration Guide Cisco Unified CRM Connector
for SAP at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-crm-connector/
products-installation-guides-list.html

Install CRM connectors

Cisco SocialMiner User Guide at https://www.cisco.com/c/en/us/
support/customer-collaboration/socialminer/
products-user-guide-list.html

Install Cisco SocialMiner
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SeeTask

Installation and Administration Guide for Cisco MediaSense at
https://www.cisco.com/c/en/us/support/customer-collaboration/
mediasense/products-installation-guides-list.html

Install Cisco MediaSense 2

1 If you are using IP IVR for self-service and queueing, see Getting Started with Cisco Unified IP IVR.
2 UCCE 11.6(1) supports only Cisco MediaSense 11.5.

Installation Tasks
The following section provides instructions about installing Unified CCE components. For instructions about
installing non-Unified CCE components in a Unified CCE solution, see the links to component-specific
documents in the Installation Task Flow.

Set Up Virtual Machines for Installation

Validate Network Adapter Settings and Power On

Procedure

Step 1 Select the virtual machine (VM) in the vSphere client. Right-click the VM and choose Edit settings.
Step 2 On the Hardware tab, select each network adapter. Make sure that Connect at power on in the Device Status

group is checked.
Step 3 Under Network Connection, select the applicable network connection from the Network label drop-down

list:

• Network adapter 1 = Public (visible)

• Network adapter 2 = Private

Certain VMs do not require a private network connection. The OVAs for those VMs do not create
a second network adapter.

Note

Step 4 Close the dialog box.
Step 5 If you are powering up the VM for the first time, power on the VM and wait for the VM to restart and to apply

customization. The restart can take 5–10 minutes.

Do not press Ctrl-Alt-Delete. If you press Ctrl-Alt-Delete after powering on, the customization does
not take effect, which requires completing the customization manually.

Important
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Configure Network Cards

Procedure

Step 1 In the virtual machine, open Network and Sharing Center.
Step 2 Click Change adapter settings.
Step 3 Rename Ethernet 0 to public for the Public network card.
Step 4 Rename Ethernet 1 to private for the Private network card.
Step 5 Press Alt to display the menu bar, and on the Advanced menu, click Advanced Settings.
Step 6 Click the Adapters and Bindings tab, and in the Connections list, sort the connections so that public is on top,

and then click OK.

Configure Private Ethernet Card

Procedure

Step 1 Right-click private and select Properties.
Step 2 Uncheck Client for Microsoft Networks.
Step 3 Uncheck File and Printer Sharing for Microsoft Networks.
Step 4 Uncheck Internet Protocol Version 6 (TCP/IPV6).
Step 5 Check Internet Protocol Version 4 (TCP/IPV4) and click Properties.

a) Remove the IP Address for the Default Gateway.
b) Remove the IP Address for the Preferred DNS server.
c) Remove the IP Address for the Alternate DNS server.

Step 6 Click the Advanced button. Open the DNS tab. Uncheck Register this connection's addresses in DNS.
Step 7 Add an entry for the private IP address.

This IP address should have an entry in the DNS server. This would be required while adding the
Router or a Peripheral Gateway through Websetup and PeripheralGatewaySetup respectively.

A host (A) resource record must be created in the DNS' Forward Lookup Zones, and can be of
the form hostname followed by a suffix "p" to easily identify it as the private interface.

For example: If the host name isRoggerA, make an entry in the DNS as "RoggerAp" for the private
IP address.

Note

Step 8 Optional: Add another entry for the private high IP address.

This IP address should have an entry in the DNS server. This would be required while adding the
Router or a Peripheral Gateway through Websetup and PeripheralGatewaySetup respectively.

A host (A) resource record must be created in the DNS' Forward Lookup Zones, and can be of
the form hostname followed by a suffix "ph" to easily identify it as the private interface.

For example: If the host name is RoggerA, make an entry in the DNS as "RoggerAph" for the
private high IP address.

Note
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Step 9 Click OK twice. Then, click Close.

Configure Public Ethernet Card

Procedure

Step 1 Right-click public and select Properties.
Step 2 Check Client for Microsoft Networks.
Step 3 Check File and Printer Sharing for Microsoft Networks.
Step 4 Uncheck Internet Protocol Version 6 (TCP/IPV6).
Step 5 Check Internet Protocol Version 4 (TCP/IPV4) and click Properties.
Step 6 Confirm the Public IP address, Subnet mask, Default gateway and Preferred DNs server, and click

Advanced.
Step 7 On the Advanced tab, enter the high public addresses.
Step 8 On the DNS tab, in the DNS suffix for this connection field, enter the name of the local DNS zone for the

server and check Register this connection's addresses in DNS.
Step 9 Optional: Add another entry for the public high IP address.

This IP address should have an entry in the DNS server. This would be required while adding the
Router or a Peripheral Gateway through Websetup and PeripheralGatewaySetup respectively.

A host (A) resource record must be created in the DNS' Forward Lookup Zones, and can be of
the form hostname followed by a suffix "PuH" to easily identify it as the public interface.

For example: If the host name is RoggerA, make an entry in the DNS as "RoggerAPuH" for the
public high IP address.

Note

Step 10 If the server requires access to resources in a different trusting or trusted domain or DNS zone, selectAppend
these DNS suffixes (in order) and enter the local DNS zone for the server first, and then add the other
secondary zones that represent the trusting or trusted domain.

Install Unified CCE 11.6(1) Software
Before installing Unified CCERelease 11.6(1), you must install Unified CCERelease 11.0(1). While installing
Unified CCE Release 11.0(1), you can perform an in-line upgrade to Unified CCE Release 11.6(1).

Before you begin

Download the Unified CCE Release 11.6(1) installer from the Unified CCE Download Software page on
Cisco.com.
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Procedure

Step 1 Mount the Unified CCE Installer ISO image to the virtual machine. For more information, see Mount ISO
Files, on page 19.

Step 2 Open the ICM-CCE-CCHInstaller/AdminClientInstaller run Setup.exe. In casr if you are using
AdminClientInstaller skip to step 4.and click Next.

Step 3 Select Fresh Install and click Next.
Step 4 To apply the CCE Release 11.6(1) minor release, click Browse and navigate to the Unified CCE Release

11.6(1) installer. Click Next, and follow the onscreen instructions.

You can also proceed with the installation of Release ICM 11.0(1) without selecting the Release ICM 11.6(1)
installer in this step. After installing Release ICM 11.0(1), double-click the Release ICM 11.6(1) installer,
and proceed from step 7.

Step 5 Reboot the server when the installation is complete.
Step 6 Log in to your system using domain credentials with administrative privileges.
Step 7 Wait for the Unified CCE Release 11.6(1) installation wizard to launch. Click Next to proceed.
Step 8 Select the radio button to accept the license agreement and click Next.
Step 9 Click Install to begin the installation.
Step 10 Select the radio button to restart the system and click Finish.

Set up Organizational Units

Add a Domain
Use the Domain Manager tool to add a domain.

Procedure

Step 1 Log in with a Domain Administrator privilege.
Step 2 Open the Domain Manager Tool from Unified CCE Tools shortcut on your desktop.
Step 3 Click Select. under Domains.
Step 4 You can add domains through the Select Domains dialog box, or you can add a domain manually if the target

domain cannot be detected automatically.

To add domains by using the controls in the Select Domains dialog box:

a) In the left pane under Choose domains, select one or more domains.
b) Click Add to add the selected domains, or click Add All to add all the domains.

To add a domain manually:

a) In the field under Enter domain name, enter the fully qualified domain name to add.
b) Click Add.
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c) Click OK.

Add Organizational Units
Use the DomainManager tool to create the Cisco root Organizational Unit (OU) for a domain, and then create
the facility and instance OUs.

The system software always uses the root OU named Cisco_ICM. You can place the Cisco_ICM OU at any
level within the domain where the Unified ICMCentral Controller is installed. The system software components
locate the root OU by searching for this name.

The user who creates the Cisco Root OU automatically becomes a member of the Setup Security Group for
the Cisco Root OU. In effect, this user is granted privileges to all Unified CCE tasks in the domain.

Procedure

Step 1 Log in with a domain administrator privilege and open the Domain Manager Tool from Unified CCE Tools
shortcut on the desktop.

Step 2 Choose the domain.
Step 3 If this OU is the first instance, then perform the following steps to add the Cisco_ICM root:

a) Under Cisco root, click Add.
b) Select the OU under which you want to create the Cisco root OU, then click OK.

When you return to the Domain Manager dialog box, the Cisco root OU appears either at the domain root
or under the OU you selected. You can now add the facility.

Step 4 Add the facility OU:
a) Select the Cisco Root OU under which you want to create the facility OU.
b) In the right pane, under Facility, click Add.
c) Enter the name for the Facility, and click OK.

Step 5 Add the instance OU:
a) Navigate to and select the facility OU under which you want to create the instance OU.
b) In the right pane, under Instance, click Add.
c) Enter the instance name and click OK.

Step 6 Click Close.

Add Users to Security Groups
To add a domain user to a security group, use this procedure. The user is then granted the user privileges to
the functions that are controlled by that security group.

Procedure

Step 1 Open the Domain Manager tool and select the Security Group you want to add a user to.
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Step 2 Under Security group, click Members.
Step 3 Under Users, click Add.
Step 4 Select the domain of the user you want to add.
Step 5 (Optional) In the Optional Filter field, choose to further filter by the Name or User Logon Name, apply the

search condition, and enter the search value.
Step 6 Click Search.
Step 7 Select the member you want to add to the Security Group from the search results.
Step 8 Click OK.

Add Unified CCE Instance

Procedure

Step 1 Open the Unified CCE Web Setup tool from shortcut on your desktop.
Step 2 Sign in as a domain user with local administrator rights.
Step 3 Click Instance Management, and then click Add.
Step 4 On the Add Instance page, from the drop-down list, choose the customer Facility and Instance.
Step 5 Enter an instance number.

The same instance name can occur more than once in a domain, so the instance number provides the uniqueness.
The instance number must be between 0 and 24. The instance number must match for the same instance across
your entire deployment. For an Enterprise (single instance) deployment, select 0 unless there are reasons to
select another value.

Step 6 Click Save.

These steps of adding instance must be repeated on each Windows Server VM that hosts an ICM
component(s).

Note

Set Up Unified CCE Central Controller and Administration and Data Server
Components

Create Component Databases
To improve database performance, ICM uses a reduced fill factor from previous releases for the index pages
in every table of the Logger, AW, and HDS databases.

Create Logger Database

Perform this procedure on the Side A and Side B Rogger VM.
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Procedure

Step 1 From Unified CCE Tools, open the ICMDBA tool, and click Yes at any warnings that display.
Step 2 Navigate to Server > Instances.
Step 3 Right-click the instance name and choose Create to create the logger database.
Step 4 In the Select Component dialog box, choose the logger you are working on (Logger A or Logger B). Click

OK.
Step 5 At the prompt, “SQL Server is not configured properly. Do you want to configure it now?”, click Yes.
Step 6 On the Configure page, in the SQL Server Configurations pane checkMemory (MB) and Recovery Interval.

Click OK.
Step 7 On the Stop Server page, click Yes to stop the services.
Step 8 In the Select Logger Type dialog box, choose Enterprise. Click OK to open the Create Database dialog box.
Step 9 Create the Logger database and log as follows:

a) In the DB Type field, choose the Side (A or B).
b) In the region field, choose your region.
c) In the Create Database dialog box, click Add to open the Add Device dialog box.
d) Click Data.
e) Choose the drive on which you want to create the database, for example, the E drive.
f) For the Size field, consider whether to choose the default (which is 1.4GB, a fairly minimal size) or

calculate a value appropriate for your deployment by using the Database Size Estimator Tool. If you
calculate the value, enter it here.

a) Click OK to return to the Create Database dialog box.
b) Click Add again.
c) In the Add Device dialog box, click Log.
d) Choose the drive where you created the database.
e) In the Size field, choose the default setting or, if you have calculated an appropriate size for your

deployment, enter that value.
f) Click OK to return to the Create Database dialog box.

Step 10 In the Create Database dialog box, click Create, then click Start.
Step 11 When you see the successful creation message, click OK and then Close.

Create HDS Database

Perform this procedure on the Administration & Data Server on which you want to create the HDS database.

Procedure

Step 1 Open the ICMDBA tool, and click Yes at any warnings that display.
Step 2 Navigate to Servers > Instances.
Step 3 Right-click the instance name and choose Create.
Step 4 In the Select Component dialog box, choose Administration & Data Server. Click OK.
Step 5 At the prompt “SQL Server is not configured properly. Do you want to configure it now?”, click Yes.
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Step 6 On the Configure dialog box, click OK.
Step 7 On the Select AW Type dialog box, choose Enterprise. Click OK to open the Create Database dialog box.
Step 8 Create the HDS database as follows:

a) From the DB Type drop-down list, choose HDS.
b) Click Add.
c) On the Add Device dialog box, select Data.
d) From the Available Drives list, choose the drive on which you want to install the database.
e) In the Size field, you can leave the default value or enter an appropriate size for your deployment.

You can use the Database Size Estimator Tool to calculate the appropriate size for your
deployment.

Note

f) Click OK to return to the Create Database dialog box.
g) Click Add.
h) On the Add Device dialog box, select Log.
i) From the Available Drives list, choose the drive on which you created the database.
j) In the Size field, you can leave the default value or enter an appropriate size for your deployment.
k) Click OK to return to the Create Database dialog box.

Step 9 On the Create Database dialog box, click Create and then click Start.
Step 10 When you see the successful creation message, click OK and then click Close.

Create Outbound Option Database

Outbound Option uses its own SQL database on the Logger. Perform the following procedure on the Side A
Logger or the Side B Logger.

After you complete this procedure, see the Outbound Option Guide for Unified Contact Center Enterprise at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-user-guide-list.html .

Procedure

Step 1 Open the ICMDBA tool and click Yes to any warnings.
Step 2 Navigate to Servers > <Logger Server> > Instances > <Unified CCE instance> > LoggerA or LoggerB.

Right-click the instance name and select Database > Create.
Step 3 On the Stop Server message, click Yes to stop the services.
Step 4 In the Create Database dialog box, click Add to open the Add Device dialog box.
Step 5 Click Data, and choose the drive on which you want to create the database, for example, the E drive. In the

database size field, you can choose to retain the default value or enter a required value.
Step 6 Click OK to return to the Create Database dialog box.
Step 7 In the Add Device dialog box, click Log. Choose the desired drive. Retain the default value in the log size

field and click OK to return to the Create Database dialog box.
Step 8 In the Create Database dialog box, click Create, and then click Start. When you see the successful creation

message, click OK and then click Close.
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For more information see the Outbound Option Guide for Unified Contact Center Enterprise guide at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-user-guide-list.html

Configure SQL User Account for Outbound Options High Availability

Complete these steps on both sides of the Logger to configure the Microsoft SQL User for Outbound Options
High Availability database operations:

Procedure

Step 1 Launch Microsoft SQL Server Management Studio on the Logger.
Step 2 Navigate to Security > Logins, right-click Logins and select New Logins.
Step 3 On the General Screen:

a) Enter the login name.
b) Select SQL Server authentication.
c) Enter and confirm the password.

Step 4 On the Server Roles page, select the sysadmin check box.
Step 5 Navigate to Security>Logins>NT AUTHORITY\SYSTEM, right-click Properties.
Step 6 On the server roles page, check the sysadmin check box.
Step 7 Click OK.

Add Components to Unified CCE Instance

Add Logger Component to Instance

Perform this procedure on the Side A and Side B Loggers; both logger machines must be up and operational.

Before you begin

If you choose to enable Outbound Option, you can also enable Outbound Option High Availability. Outbound
Option High Availability facilitates two-way replication between the Outbound Option database on Logger
Side A and the Outbound Option database on Logger Side B. Use the ICMDBA tool to create an outbound
database on Side A and Side B; then set up the replication by using theWeb Setup tool, as described in several
of the following steps.

Procedure

Step 1 Open the Web Setup tool.
Step 2 Choose Component Management > Loggers. Click Add, and then choose the instance.
Step 3 On the Deployment page, select the Logger (A or B). Click Duplexed, and then click Next.
Step 4 On the Central Controller Connectivity page, enter the host names for Sides A and B for these interfaces:

Router Private and Logger Private. Then, click Next.
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Step 5 If an external AW-HDS-DDS exists in the deployment, check Enable Historical/Detail Data Replication.
If no external AW-HDS-DDS exists in the deployment, leave Enable Historical/Detail Data Replication
unchecked.

Step 6 On the Additional Options page, click Display Database Purge Configuration Steps.
Step 7 Click the Enable Outbound Option check box if you are installing a Unified CCE Logger and choose to

deploy Outbound Option.

If this Logger is being added for a Rogger server, where there are two IP addresses that are configured
on the public Network Interface Card (for IP-based prioritization), uncheck "Register this connection's
addresses in DNS" for the public ethernet card. In addition, ensure that there is only one A-record
entry in the DNS server corresponding to the host name of the server, which maps to the normal
priority IP address. This is necessary for processes like the campaign manager and replication
running as part of the Logger service, to listen on the right interface IP address for client connections.

Note

Step 8 Click the Enable High Availability check box to enable Outbound Option High Availability on the Logger.
(An Outbound Option database must exist on Logger Side A and Logger Side B.) Checking this check box
enables Outbound Option High Availability two-way replication between the Outbound Option database on
Logger Side A and the Outbound Option database on Logger Side B. Two-way replication requires that you
check this check box on both the Logger Side A and Side B Additional Options page. If you disable two-way
replication on one side, you must also disable it on the other side.

You must enable Outbound Option in order to enable Outbound Option High Availability. Similarly, if you
want to disable Outbound Option and you have enabled Outbound Option High Availability, you must disable
High Availability (uncheck theEnable High Availability check box) before you can disable Outbound Option
(uncheck the Enable Outbound Option check box).

Disabling HA will not disable outbound option, customer has to explicitly disable outbound when
HA is disabled.

Note

Step 9 If you enable High Availability, enter a valid public server hostname address for Logger Side A and Logger
Side B. Entering a server IP address instead of a server name is not allowed.

Step 10 If you enable High Availability, enter the SQL Server Admin Credentials (Username and Password),
which are required to establish two-way replication. The username and password must be the same on Logger
Side A and Logger Side B, and the user must have the SQL Server System Admin privilege.

SQL replication requires that the correct SQL system admin username and password be in place when setting
up Outbound Option High Availability. Changing the password for the SQL user used to set up SQL replication
in Outbound Option High Availability causes replication to fail until you disable High Availability and
re-enable it with the new username and password. Because of this requirement, be careful about how and
when you change the password for this user.

Step 11 If you enable High Availability, enter the Active Directory Account Name that the opposite side logger runs
under or a security group that includes that account. For example, if you are running Websetup on the logger
on Side A, enter the name of the Active Directory account (or security group) that is run on Side B logger.

Step 12 Select the Syslog box to enable the Syslog event feed process (cw2kfeed.exe).

The event feed is processed and sent to the Syslog collector only if the Syslog collector is configured.
For more information about the Syslog event feed process, see the Serviceability Guide for Cisco
Unified ICM/Contact Center Enterprise at http://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html.

Note

Step 13 Click Next.
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Step 14 On the Data Retention page, modify the Database Retention Configuration table:
a) For these tables, set the retention period to 40 days:

• Application_Event

• Event

• Network_Event

• Route_Call_Detail

• Route_Call_Variable

• Termination_Call_Detail

• Termination_Call_Variable

b) Accept the default settings for all other tables. If your contact center requires access to any of that data
for a longer period, enter an appropriate value.

Step 15 Click Next.
Step 16 On the Data Purge page, configure purges for a day of the week and a time when there is low demand on the

system.
Step 17 Accept the default Automatic Purge at Percent Full.
Step 18 Click Next.

Add Router Component to Instance

Perform this procedure for Side A and Side B Routers.

Procedure

Step 1 In the Web Setup tool, select Component Management > Routers.
Step 2 Click Add to set up the Call Router.
Step 3 On the Deployment page, choose the current instance.
Step 4 In the Deployment dialog, select the appropriate side.
Step 5 Click Duplexed, and then click Next.
Step 6 In the Router Connectivity dialog, configure the Private Interface and Public Interfaces. Click Next.

For the address input fields, use Fully Qualified Domain Names instead of IP addresses.

When there are two IP addresses configured on the public Network Interface Card (for IP-based
prioritization), manually add twoA-records on the DNS server. One A-record is for the high priority
IP address and the other one is for the normal priority IP address. The host part of the two DNS
entires should be different from the hostname of Windows server. Use the new DNS entries to
configure the interfaces. This note applies to the Router and to all PG machines.

Note

Step 7 In the Enable Peripheral Gateways field, enter the number assigned to the PGs to enable it. Click Next.

Use a hyphen to indicate a range and commas to separate values. For example, "2-4, 6, 79-80" enables PG2,
PG3, PG4, PG6, PG79, and PG80. Spaces are ignored.
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Step 8 In the Router Options dialog, the Enable Quality of Service (QoS) is enabled by default. Click Next.
On the Router Quality of Service page, you see preconfigured values for the Router QoS for the Private
Network. These values only appear if you selected a Side A Router. You can change the values in the DSCP
fields if necessary.
Keep QoS enabled for all Unified CCE Private network traffic. For most deployments, disable QoS for the
public network traffic. For more details, refer to the appropriate section in the Solution Design Guide for Cisco
Unified Contact Center Enterprise at http://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-implementation-design-guides-list.html.

Step 9 In the Router Quality of Service dialog, click Next.
Step 10 In the Summary dialog, make sure that the Router summary is correct, then click Finish.

Add Administration & Data Server Component to Instance

Follow this procedure for all types of Administration & Data Servers:

• Configuration-Only Administration Server—Supports configuration changes only. Does not support
reporting.

• Administration Server and Realtime Data Server (AW)—Supports configuration changes and real-time
reporting. Does not support historical reporting.

• Administration Server, Realtime and Historical Data Server, and Detail Data Server
(AW-HDS-DDS)—Supports configuration and real-time and historical reporting, including call detail
and call variable data.

Not all fields apply to all server types.

AW Database is created when you add Administration & Data Server Component. Data from the
Config_Message_Log table is replicated from the Logger database to the AW database; you can use the AW
database for auditing purposes. When you add the Administration & Data Server component, the retention
period for the Config_Message_Log table in the AW database defaults of 90 days. To change the retention
period, modify the following registry key: Cisco Systems, Inc.\ICM\<instancename>\Distributor

\RealTimeDistributor\CurrentVersion\Recovery\CurrentVersion\Purge\Retain\System\ConfigMessageLog.

Note

Set up Peripheral Gateways

To set up all the following types of Peripheral Gateways (PG), complete the procedures in this section:

• Cisco Unified Communications Manager PG (CUCM PG)

• Voice Response Unit PG (VRU PG)

• Media Routing PG (MR PG)

• Unified CCE Gateway PG (UCC Enterprise Gateway PG)
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Configure Peripheral Gateways in PG Explorer
Follow this procedure to complete the first portion of PG configuration. After this procedure, you add a
peripheral to the PG; you cannot save the configuration unless there is at least one peripheral in the
configuration.

Not all fields apply to all PG types.

Before you begin

Ensure that the Logger, Router, and Distributor services are running.

Procedure

Step 1 From your desktop, double-click the Unified CCE Tools icon, and open Administration Tools folder from
Unified CCE Tools icon on the desktop.

Step 2 Double-click the Configuration Manager icon.
Step 3 Select Tools > Explorer Tools > PG Explorer Tool.
Step 4 Click Retrieve, then click Add PG.
Step 5 Complete the Logical Controller section as follows:

a) Logical Controller ID—Leave blank. This value is generated automatically when the record is saved.
b) Physical Controller ID—Leave blank. This value is generated automatically when the record is saved.
c) Name—Enter a unique enterprise name for the PG.
d) List Tools —Select Agent Settings.
e) Client Type—Select as follows from the drop-down list:

• For a CUCM PG: CUCM

• For a VRU PG: VRU

• For an MR PG: MediaRouting

• For a UCC Enterprise Gateway PG: UCC Enterprise Gateway

f) Configuration Parameters—Leave blank.
g) Description—Enter any other information about the PG. Configuration Manager copies this value to the

description fields of the logical interface controller, physical interface controller, peripheral, and (if
applicable) the routing client records.

h) Physical Controller Description—Enter a description for the physical controller.
i) Primary CTI Address—Enter the address for the primary CTI server. Make this entry in the form of

<IP address or server name where the CTI server is installed>: <Client Connection Port Number>.
j) Secondary CTI Address—Enter an address for a secondary CTI server (for duplexed systems).
k) Reporting Interval—Select the 15 or 30 Minute reporting interval option (default is 30 Minute). Unified

CCE software stores historical information in either half-hour or 15-minute summaries (but not both),
based on the reporting interval value that you set. The Router sends these records to the Logger, which
in turn writes them to the Central Database.

Step 6 Do not exit the PG Explorer tool. You add a peripheral to the PG and save the configuration in the next
procedure.
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Add Peripherals to Peripheral Gateways
Fields can vary according to PG type.

Procedure

Step 1 With the PG record open in the PG Explorer tool, highlight the PG icon in the tree hierarchy in the lower-left
corner of the window.

Step 2 On the Peripheral tab, enter the following:
a) Name—Enter a unique enterprise name for this peripheral.
b) Peripheral Name—Enter the name of the peripheral as it is known at the site. Unlike the Enterprise Name

field, the value of this field does not have to be unique. For example, at each site you can label the
peripherals Switch1, Switch2, and so forth.

c) Client Type—Select as follows:

• For a CUCM PG: CUCM

• Configure Agent Desk settings before adding CUCM PG. See Assign Agent Desk Settings

• For a VRU PG: VRU

• Configure Network VRU before adding VRU PG. See Configure Network VRUs, on page 106

• For an MR PG: MediaRouting

• For a UCC Enterprise Gateway PG: UCC Enterprise Gateway

d) Location—Enter the peripheral's location, for example, the name of a city, building, or department.
e) Abandoned Call Wait Time—Enter the minimum time (in seconds) an incoming call must be queued

before being considered an abandoned call if the caller hangs up.
f) Configuration Parameters—As desired, enter a string containing any parameters that must be sent to

the device to initialize it. In most cases, you leave this field blank.
g) Peripheral Service Level Type—The default type of service level calculation that the peripheral performs

for its associated services. Select Calculated by Call Center.
h) Call Control Variable Map—As desired, enter a string that describes the mappings of the peripheral

call control variables to Unified CCE call control variables.
i) Agent Phone Line Control—Specify one of the following agent phone line control options:

• Single Line: Enables single-line monitoring and reporting (default).

• All Lines: Enables multiline monitoring and reporting.

j) NonACD Line Impact—Specify one of the following nonACD line impact options:

• Available Agent Goes Not Ready: Agent state is set to Not Ready with a system reason code when
the agent answers or calls out on a secondary line while in the Available or Not Ready state.

• Available Agent Stays Available: Agent state is unchanged when agent is on a call on a secondary
line.

k) Description—As desired, enter any additional information about the peripheral.
l) Default Desk Settings—Select as follows:
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• For a CUCM PG: Select the Agent Desk Settings that you created earlier

• For a VRU PG: None

• For an MR PG: None

• For a UCC Enterprise Gateway PG: None

m) Enable Post Routing—Check this check box to enable the Unified CommunicationsManager peripheral
to send route requests to the Router. When you check this check box, the Routing Client tab is enabled.

Step 3 On the Advanced tab, enter the following:
a) Available Holdoff Delay—Set this field to zero.
b) Answered Short Calls Threshold—Maximum duration, in seconds, for a short call. Any calls with a

duration below the threshold are considered short. You can choose to exclude short calls from handle
times you calculate.

c) Network VRU—The type of network VRU. Select as follows:

• For a CUCM PG: None

• For a VRU PG: Select the corresponding Network VRU that you created earlier.

• For an MR PG: Select the Type 2 Network VRU that you created earlier.

• For a UCC Enterprise Gateway PG: None

d) Agent Auto-Configuration—Not supported for Unified CCE. Leave this option disabled.
e) Internal IPTA Only—Be sure that you check this check box for the Unified CCE System PG.
f) Agent Targeting Mode—Determines how the Router builds the labels. Select Rule Preferred.

When this check box is checked, only the local PG can target agents on the PG. The Router uses the skill
group IPTA configuration to select agents. When this check box is unchecked, for calls routed between
different PGs, the Router picks the agent (which minimizes the benefit of the Unified CCE System PG).
Unchecking the check box also requires the creation of more device targets.

Step 4 On the Agent Distribution tab, enter the following:
a) Enable Agent Reporting—Check to allow Unified CCE reporting on agents.
b) Agent Event Detail—Enables label text (as opposed to numeric) Not Ready Reason Code reporting.
c) The Agent Distribution Entries section of this tab contains entries for agent Administration &Data Servers

available for distributing agent report data for the selected peripheral. Click New, then define the values
in the Currently Selected site section of this tab as follows:

• Administration & Data Server site name: The name of the currently selected site in the agent
distribution entries list. For MR PGs, do not specify a name for this field.

• Agent real time data: Check to enable the flow of agent real-time data from the peripheral to the
Administration & Data Server. Uncheck to disable the flow of agent real-time data.

• Agent historical data: Check to enable the flow of agent historical data from the peripheral to the
Administration & Data Server. Uncheck to disable the flow of agent historical data.

Step 5 On the Routing Client tab, enter the following:
a) Name—An enterprise name for this routing client. The name must be unique among all routing clients

in the enterprise.
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b) Timeout threshold—The maximum time, in milliseconds, the routing client can wait for a response to
a routing request.

c) Late threshold—The threshold value, in milliseconds, for classifying responses as late. Any response
that exceeds this threshold is considered late even if it does not exceed the Timeout threshold.

d) Timeout limit—The maximum time, in seconds, for which the routing client waits for a response. If the
routing client receives no responses from the Unified CCE system within this limit, it terminates routing
operation.

e) Default media routing domain—Retain the default value, which is None.
f) Default call type—Use this call type for any route request that does not match a defined call type mapping.

The drop-down list contains all configured call types. The Unified CCE uses the default call type for any
routing request from the routing client that does not otherwise map to a call type. If you do not define a
default call type for the routing client, the Unified CCE uses a general default call type if you define one
through the System Information command.

g) Configuration parameters—Leave blank.
h) Dialed Number/Label map—Indicates whether only specific labels are valid for each dialed number

associated with this routing client (when selected) or whether all labels associated with the routing client
are valid for any dialed number (when not selected). Leave unchecked.

i) Client Type—Select as follows from the drop-down list:

• For a CUCM PG: IPCC/Enterprise Agent

• For a VRU PG: VRU

• For an MR PG: MediaRouting

• For a UCC Enterprise Gateway PG: UCC Enterprise Gateway

j) Description—More information about the routing client.
k) Network routing client—A name used to associate routing clients across instances.
l) Network transfer preferred—If this check box is checked, indicates that network transfer is preferred.

When the target of a call is reachable by both a label defined for the requesting routing client and by
another label defined for the network routing client that prerouted the call, this option indicates which
choice is preferred.

Step 6 Click Save.
Step 7 Record the Logical Controller ID and Peripheral ID for subsequent use in setting up the PG.
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Configure Peripheral Gateway Setup

To ensure that PGs work synchronously, configure the PGs that are collocated on the same physical server
in the same order on both the sides. This must be based on the order in which they are installed and not on
peripheral identifiers. For information on port utilization, refer to the Port Utilization Guide for Cisco Unified
Contact Center Solutions at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html.

Before you enable secured connection between the components, ensure to complete the security certificate
management process.

For more information, see the Security Guide for Cisco Unified ICM/Contact Center Enterprise at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html.

Caution

Procedure

Step 1 Open the Peripheral Gateway Setup tool from Unified CCE Tools on the desktop.
Step 2 Click Add in the Instance Components section.
Step 3 Click Peripheral Gateway.
Step 4 Complete the following steps in the Peripheral Gateway Properties dialog box.

a) Choose Production Mode. Do not set the Auto Start feature until after the installation is complete.
b) Specify whether the PG is part of a duplexed pair.
c) In the ID field, select from the drop-down list the PG device number as enabled in the Router.
d) If the PG is duplexed, specify whether you are installing Side A or Side B. If the PG is simplex, select

Side A.
e) In the Client Type Selection section of the window, select the client type:

• For a CUCM PG: CUCM

• For a MediaRouting PG: MediaRouting

• For a VRU PG: VRU

• For a UCC Enterprise Gateway PG: UCC Enterprise Gateway

Step 5 Click Add, and then click Next.
Step 6 Enter the Logical Controller ID generated while configuring the PG in the PG Explorer tool. Click Add and

select PIM 1 from the list. Click OK.
Step 7 Configure the PG properties:

a) To put the PIM into service, check the Enabled option. Enabling the PIM allows it to communicate with
the peripheral when the Peripheral Gateway is running.

b) Enter the peripheral name in the Peripheral name field. Usually, the enterprise name from the associated
Peripheral record is themost appropriate name to use.When creating peripheral names, use short descriptive
names and keep the length to a minimum.

c) Enter the Peripheral ID in the Peripheral ID field. This is the ID that you created when you configured
the PG in the PG Explorer tool.
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d) For CUCM PG:

1. Enter the Agent extension length.

2. In the CUCM Parameters section, in the Service field, provide the IP address of the CUCM.

3. Enter the credentials of Application User that you created in CUCM.

For more information about Application User, see Set Up Application User , on page 147.

4. Select the appropriate Mobile Agent Codec, and click OK.

e) For MR PG:

1. Enter the hostname or the IP address of the multichannel application server machine in theApplication
Hostname (1) field. If you are configuring the Outbound Option PIM, enter the IP address or hostname
of the BA_IP Dialer.

2. For Outbound Option, enter the connection port for the BA_IP Dialer in theApplication Connection
Port (1) field. Otherwise, accept the default port number (38001) on the application server machine
that the PIM uses to communicate with the application.

3. If two applications interact with the Unified CCE, in the Application Hostname (2) field, enter the
hostname or the IP address of the second application server machine. If you are using the hostname,
the name must be in the hosts file.

4. For two applications that interact with the Unified CCE, in the Application Connection Port (2)
field, enter the port number on the second application server machine that is used by the PIM.

5. For Heartbeat Interval (seconds), specify how often the PG checks its connection to the call server.
Use the default value.

6. ForReconnect Interval (seconds), specify how often the PG should try to reestablish a lost connection
to the call server. Use the default value.

f) For VRU PG:

1. In the VRU host name field, enter the name by which the VRU is known to the network.

2. In the VRU connect port field, enter the number of the VRU connection port that the PG connects
to.

3. In theReconnect interval (sec) field, specify how often, in seconds, the PG tries to re-establish a lost
connection to the VRU. The default value is usually appropriate.

4. In the Heartbeat interval (sec) field, specify how often, in seconds, the PG checks its connection to
the VRU. The default value is usually appropriate.

5. In the DSCP field, use the drop-down box to override the default value and set it to the desired DSCP
value. The list of DSCP values in the drop-down box are the same as what are used during setup for
connection between the Peripheral Gateway (PG) and the CallRouter. On an existing VRU PG system,
this registry key does not exist. In that scenario, the PIM code uses CS3 as the default value when the
VRU PIM process is activated.

Step 8 Click OK.
Step 9 From the Peripheral Gateway Component Properties window, click Next. The Device Management

Protocol Properties window appears.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.6(1)
50

Installation
Configure Peripheral Gateway Setup



a) Enter the appropriate settings and click Next. The Peripheral Gateway Network Interfaces window
appears.

b) Configure the Private Interface and Public interfaces and click Next.

Note:

For the address input fields, use Fully Qualified Domain Names instead of IP addresses.

When there are two IP addresses configured on the public Network Interface Card (for IP-based
prioritization), manually add two A-records on the DNS server. One A-record is for the high priority IP
address and the other one is for the normal priority IP address. The host part of the two DNS entires should
be different from the hostname of Windows server. Use the new DNS entries to configure the public
interfaces. This note applies to the Router and to all PG machines.

Step 10 In the Check Setup Information window, verify the setup information and click Next.
Step 11 When the Setup Complete window appears, click Finish .

When you add new PG, ensure that the PG ID is provided in the Router configuration. Provide the
number that is assigned to the PG in the Enable Peripheral Gateway field in Web Setup

Note

Install Cisco JTAPI Client on PG
After setting up the Cisco Unified Communications Manager (CUCM) PG, you must install the Cisco JTAPI
client. PG uses Cisco JTAPI to communicate with CUCM. Install the Cisco JTAPI client from CUCM
Administration.

Continue with the steps provided in this section if you are installing the JTAPI client for CUCM version earlier
than Release 12.5.

To install the JTAPI client for CUCM, Release 12.5 and above, see Install Cisco JTAPI Client on PG, on
page 52.

Note

Before you begin

Before you install the JTAPI client, ensure that the previous version is uninstalled.

Procedure

Step 1 Open a browser window on the PG machine.
Step 2 Enter the URL for the Unified Communications Manager Administration utility: http://<Unified

Communications Manager machine name>/ccmadmin.
Step 3 Enter the username and password that you created while installing and configuring the Unified Communications

Manager.
Step 4 Choose Application > Plugins. Click Find.
Step 5 Click the link next to Download Cisco JTAPI for Windows.We recommend you to download the 64 bit

version. However, if you have already downloaded the 32 bit version, you can proceed to step 7.
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Download the JTAPI plugin file.

Step 6 Choose Save and save the plugin file to a location of your choice.
Step 7 Open the installer.
Step 8 In the Security Warning box, click Yes to install.
Step 9 Choose Next or Continue through the remaining Setup screens. Accept the default installation path.
Step 10 When prompted for the TFTP Server IP address, enter the CUCM IP address.
Step 11 Click Finish.
Step 12 Reboot the machine.

Install Cisco JTAPI Client on PG

Complete the following procedure only if you are installing JTAPI client to connect to Cisco Unified
Communications Manager, Release 12.5 and above.

Before you begin

Before you install the JTAPI client, ensure that the previous version is uninstalled.

Procedure

Step 1 Open a browser window on the PG machine.
Step 2 Enter the URL for the Unified Communications Manager Administration utility: http://<Unified

Communications Manager machine name>/ccmadmin.
Step 3 Enter the username and password that you created while installing and configuring the Unified Communications

Manager.
Step 4 Choose Application > Plugins. Click Find.
Step 5 Click the link next toDownload Cisco JTAPI Client for Windows 64 bit orDownload Cisco JTAPI Client

for Windows 32 bit.

Step 6 Choose Save and save the plugin file to a location of your choice.
Step 7 Unzip the JTAPI plugin zip file to the default location or a location of your choice.

There are two folders in the unzipped folder CiscoJTAPIx64 and CiscoJTAPIx32.

Step 8 Run the install64.bat file in the CiscoJTAPIx64 folder or run the install32.bat file in the
CiscoJTAPIx32 folder.

The default install path for JTAPI client is C:\Program Files\JTAPITools.

Step 9 To accept the default installation path, click Enter and proceed.

Follow the instructions. Click Enter whenever necessary as per the instructions.

Provide IP address of the TFTP server, when prompted for. For 4000 and 12000 deployments, IP address
should be same as CUCM IP address provided in CUCM PIM.

The JTAPI client installation completes at the default location. The following message is displayed:
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Installation Complete.

Step 10 Reboot the machine.

What to do next

The default location, where the JTAPI client is installed, also contains the uninstall64.bat and
uninstall32.bat file. Use this file to uninstall this version of the client, if necessary.

Note

Set up CTI Server
Use the PG Setup tool to set up a CTI Server.

Add CTI Server Component

Procedure

Step 1 Open Peripheral Gateway Setup tool from Unified CCE Tools on the desktop.
Step 2 Click Add in the Instance Components section.

The ICM Component Selection dialog box opens.

Step 3 Click CTI Server, and click OK.

The CTI Server Properties dialog box opens.

Set CTI Server Properties

Procedure

Step 1 In the CTI Server Properties dialog box, check Production mode and Auto start at system startup unless
your Unified CCE support provider tells you otherwise. These settings set the CTI Server Service startup type
to Automatic, so the CTI Server starts automatically when the machine starts up.

Step 2 Check the Duplexed CTI Server option if you are configuring redundant CTI Server machines.
Step 3 In the CG Node Properties section, the numeric portion of the CG node ID must match the PG node ID (for

example, CG 1 and PG 1).
Step 4 The ICM system ID is the Device Management Protocol (DMP) number of the PG associated with the CTI

Gateway. Generally this number is the number associated with the CG ID in step 3.
Step 5 If the CTI Server you add is duplexed, specify which Side you are setting up: Side A or Side B. If the CTI

Server is simplex, choose Side A.
Step 6 Click Next.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.6(1)
53

Installation
Set up CTI Server



The CTI Server Component Properties dialog box opens.

Set CTI Server Component Properties

Procedure

Step 1 In the CTI Server Component Properties dialog box, setup automatically generates aClient Connection Port
Number. You can use this value or change to a standard port number. Clients use this port number to connect
to the CTI Server.

If you have multiple nodes running on a single machine, each must use a different port number.

Step 2 If you require that an agent is logged in to the client before the client receives events from the CTI Server,
check the Agent Login Required for Client Events box. When you check this box, clients are prevented
from accessing data for other agents.

Step 3 Click Next.

The CTI Server Network Interface Properties dialog box opens.

Set CTI Server Network Interface Properties

Procedure

Step 1 In the CTI Server Network Interface Properties dialog box, in the PG public interfaces section, enter the
public network addresses for the PGs associated with the CTI Server.

Step 2 In the CG private interfaces section, enter the private network addresses of the CTI Server.
Step 3 In the CG visible interfaces section, enter the public network addresses of the CTI Server.
Step 4 Click Next.

The Check Setup Information window opens.

Complete CTI Server Setup

Procedure

Step 1 In the Check Setup Information window, ensure that the settings displayed are as you intended. If you want
to modify any settings before proceeding, use the Back button.

Step 2 When the settings are correct, click Next.
Step 3 The final screen displays and asks whether you want to start the Node Manager now.
Step 4 Click Finish to exit setup (and optionally start the Node Manager).
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If you choose to start it, the Node Manager automatically starts the other Unified CCE processes on the CTI
Server.

Install Unified CCE Administration Client

Install Administration Client
Do not install the Administration Client on a system that already has other Unified CCE software installed;
the Administration Client must reside on a standalone machine. AdminClientInstaller is available in the
Unified CCE Installer ISO image .

For information on supported operating systems, see the Unified CCE Solution Compatibility Matrix at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Procedure

Step 1 Mount the Unified CCE Installer ISO image to the virtual machine. For more information, see Mount ISO
Files, on page 19.

Step 2 Launch AdminclientInstaller from AdminClientInstaller folder.

The Administration Client Installer program proceeds through a series of screens on which you specify
information.

Step 3 When the installation is complete, reboot the server.

Set up Administration Client
You cannot run the Administration Client Setup tool remotely through a browser. Run the tool on the local
machine.

Before you begin

Any user who is a local administrator on the machine and a domain user can log in. However, to view the
lists and to perform tasks with the Administration Client Setup tool, you must have the following permissions:

• Administrator on the local machine

• Either a domain administrator or a member of at least one Setup security group in the machine domain.

If you cannot add an Administration Client instance on a Windows 7 system, check whether Cisco Security
Agent is installed. Cisco Security Agent is deprecated, uninstall it if you find it on a system.

Procedure

Step 1 Open the Administration Client Setup tool from Unified CCE Tools shortcut on the desktop.
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Step 2 Sign in as a domain user with local Administrator rights.
Step 3 Click Instance Management, and then click Add.
Step 4 On the Add Instance page, from the drop-down list, choose the customer facility and instance.
Step 5 Enter an instance number.

The same instance name can occur more than once in a domain, so the instance number provides the uniqueness.
The instance number must be between 0 and 24. The instance number must match for the same instance across
your entire deployment. For an Enterprise (single instance) deployment, select 0 unless there is a reason to
choose another value.

Step 6 Click Save.
Step 7 Select Component Management > Administration Clients.
Step 8 Click Add.
Step 9 Select an instance for the Administration Client from the drop-down list.
Step 10 Click the radio button for your Administration Client type.
Step 11 Enter the hostname or IP address of the Primary and Secondary Administration & Data Servers. If you have

only one Administration & Data Server, specify it for both Primary and Secondary Administration & Data
Servers; both fields are required

Step 12 Click Save.

Install Unified CCE Language Pack
The Unified CCE Language pack is used to install the localized version of the help files of the Unified CCE
Web Administration tool.

The Unified CCE Language pack also contains the customized version of Configuration Manager tools for
east Asian locales like Chinese, Japanese and Korean. The language pack enables localized input to be entered
in those Configuration Manager tool sets.

These tool sets include some of the following tools:

• Explorer Tools

• List Tools

• System Information

• Outbound Option related tools

Update the Java Runtime Environment (Optional)
Themain Unified CCE Installer installs the Java Runtime Environment (JRE) to a default location (for example,
C:\Program Files (x86)\Java\jre<version>) and creates a JAVA_HOME environment variable set to that
location. In most circumstances, you do not need to modify or configure the JRE after the Unified CCE
installation. For information on the version installed, see the Java requirements in the Unified CCE Solution
Compatibility Matrix at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-device-support-tables-list.html.

If required, you can update the JRE installed by the Unified CCE installation to a later version.
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To update the Unified CCE JRE to a later version:

1. Review and see the Java requirements in the Unified CCE Solution Compatibility Matrix to confirm that
Unified CCE supports the JRE version you want to install.

2. Follow the JRE installer procedure to install the JRE to the VM on which your Unified CCE components
are installed.

3. Set the JAVA_HOME environment variable to the location of the new JRE.

4. Restart the virtual machine.

The ICM-CCE-Installer installs the version of Java that is listed in the Unified CCE Solution Compatibility
Matrix. If an older version of JRE is currently installed on the deployment machine, the installer does not
uninstall it, you must manually uninstall it.

Note

Upgrade Tomcat Utility
Use the optional Cisco Upgrade Tomcat Utility to:

• Upgrade Tomcat to version 7.0 build releases. (That is, only version 7.0 build releases work with this
tool.) Youmay choose to upgrade to newer builds of Tomcat release 7.0 to keep up with the latest security
fixes.

Tomcat uses the following release numbering scheme: Major.minor.build. For example, you can upgrade
from 7.0.62 to 7.0.65 . You cannot use this tool for major or minor version upgrades.

Revert a Tomcat upgrade.

If you use the utility to upgrade Tomcat multiple times, you can revert to only
one version back of Tomcat. For example, if you upgrade Tomcat from 7.0.62
to 7.0.63, and then to 7.0.75, the utility reverts Tomcat to 7.0.63.

Note

Before using the tool:

• Download the Tomcat installer (apache-tomcat-version.exe) from the Tomcat website:
http://archive.apache.org/dist/tomcat/tomcat-7/ . Copy the installer onto the Unified CCE component
VMs. For Example C:\UpgradeTomcatTool.

• Download the utility zip file, extract it, and run the file to upgrade Tomcat.

Download link: .

• Delete or back up large log files in these directories to reduce upgrade time:

c:\icm\tomcat\logs
c:\icm\debug.txt
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Upgrade Tomcat
For detailed information on the results from each step, see the ../UpgradeTomcatResults/UpgradeTomcat.log
file.

Stop Unified CCE services on the VM before using the Tomcat Utility.Note

Procedure

Step 1 From the command line, navigate to the directory where you copied the Upgrade Tomcat Utility.
Step 2 Enter this command to run the tool: java -jar UpgradeTomcatTool-<version>.jar -upgrade

For example:
java -jar UpgradeTomcatTool-11.5.1.jar -upgrade

Step 3 When prompted, enter the full pathname of the new Tomcat installer.

For example:
c:\tomcatInstaller\apache-tomcat-<version>.exe

Step 4 When prompted, enter yes to continue with the upgrade.
Step 5 Repeat these steps for all unified CCE component VMs.

Silent Installation
In certain situations, such as when a system administrator wants to install or upgrade software silently on
multiple systems simultaneously, a silent installation is performed to run an installation wizard.

Silent Installation Prerequisites for Unified CCE Release 11.0(x)
Before running a silent installation, complete the following tasks:

• Stop all applications that are running on the system.

• By default, silent installation assumes the following parameter: Install on Drive C.

To override this default, edit the ICMCCSilentsetup.ini file in the ICM-CCE-Installer directory.

• Mount the ISO image to the target machine, and make the following edits on the target machine:

• If you are performing a Technology Refresh upgrade, change the szInstallType from 0 to 1. The
default value of 0 is for a Fresh Install.

• If you are performing a Technology Refresh upgrade, provide a path for the szExportedRegistryPath
parameter.

• To change the drive on which you are installing the application, change the szDrive parameter.
Replace C with the drive where you want to install.
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• If you do not want to apply SQL Security Hardening, change the line that reads szSQLSecurity=1
to szSQLSecurity=0.

You can apply SQL Security Hardening during the installation, or you can use the Security Wizard to apply
it after the install.

Note

Perform a Silent Installation for Unified CCE Release 11.0(x)

Procedure

Step 1 Mount the Installation ISO image to the target machine.
Step 2 From a command prompt window, navigate to the ICM-CCE-Installer directory.
Step 3 Enter the command setup.exe /s.

The installation application runs. The drive prompt reappears in the command prompt window when the
installation is complete.

If the installation is not successful, no error message appears in the command prompt window. You must
check the installation log file <SystemDrive>:\temp\ICMInstall.log to determine the reason why
the installation failed.

Note

Silent Installation Prerequisites for Unified CCE Release 11.6(1)
Before running a silent installation, complete the following tasks:

• Stop all applications that are running on the system.

• The machine on which you create your response file should have a configuration that closely matches
the machines on which you will run silent installs. This minimizes the chances of unexpected dialogs
being triggered during the installation that could terminate the installation.

For example, if the response file is created on a machine with Unified CCE services set to Manual and
then run on a machine with those services set to Automatic, an additional dialog will open during the
install (alerting you that the services have been set from Automatic to Manual). This unexpected dialog
will cause the install to terminate, potentially leaving the system in an invalid state that requires manual
recovery.

Perform a silent installation for Unified CCE Release 11.6(x)

Procedure

Step 1 Run setup from a command prompt with two command line arguments to create the response file.
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Example:

"c:\ICM11.6(1).exe" -r -f1c:\myanswerfilename.iss

The -r flag is for recording the response file.

The -f1 flag is the full path and filename for the resulting response file to be created.

There is no space between the -f1 and the start of the file path. If no -f1 flag is present, the response
file is written to a default location (C:\Windows)".

Note

When you have navigated through the setup process (which completes a full installation of the product on the
machine recording the response file) the resulting response file can be copied to any additional machine during
a silent installation.

Step 2 Run setup from a command prompt using the same syntax as listed in step 1, with one exception: use -s instead
of -r to indicate the install should run silently using the response file found at -f1filepath.

Example:

“c:\ICM11.6(1).exe” -s -f1c:\myanswerfilename.iss –f2c:\silentinstall.log

The -f2 flag creates a log file.

What to do next

Verify that the silent installation was successful by checking the installer log file to make sure no errors were
reported. If your silent installation does not run, check the log file for ResultCode=-5. It indicates the
installer could not find your response file; recheck your path and file names.

During the creation of the response file, if you chose not to reboot the machine after the installation, ensure
that you manually reboot any silently installed system prior to starting the services.

Cisco Finesse Server Installation
Cisco Finesse server is installed on a virtual machine (VM). The installation runs from an ISO image and uses
an OVA template. For more information, see Cisco Finesse Installation and Upgrade Guide at
https://www.cisco.com/c/en/us/support/customer-collaboration/finesse/products-installation-guides-list.html.

Configure a DataStore ISO file on the virtual CD/DVD drive of the target VM to install Finesse.Note

The installation takes about an hour. For most of that time, it can run unattended. Much of the installation
requires no action on the part of the person who runs it. When user input is required, use the following keyboard
navigation and selection actions. The installation wizard screens do not recognize a mouse or a touchpad.

Press this keyTo do this

TabMove to the next field.

Alt-TabMove to the previous field.

SpacebarSelect an option.
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Press this keyTo do this

Up or Down Arrow keysScroll up or down a list.

Tab to Back and press the SpacebarGo to the previous screen.

Tab to Help and press the SpacebarGet information about a screen.

Installation Task Flow
The following table provides an overview of the tasks you perform to install Cisco Finesse. Tasks must be
performed in the order they are listed.

See Install Finesse on Primary Node, on page 61.Install Finesse on the primary node.1

See Configure Contact Center Enterprise Administration
& Data Server Settings, on page 67.

Configure the database settings.2

See Configure Contact Center Enterprise CTI Server
Settings, on page 155

Configure the CTI server settings.3

See Restart Cisco Finesse Tomcat, on page 68.Restart Cisco Finesse Tomcat on the
primary node.

4

See Configure Cluster Settings, on page 68.Configure the cluster settings for the
secondary node.

6

See Install Finesse on Secondary Node, on page 68.Install Finesse on the secondary node.7

See Check Replication Status, on page 72.Ensure replication is functioning between
the two nodes.

8

See Install VMware Tools for VOS, on page 23Install VMware Tools9

Install Finesse on Primary Node

Procedure

Step 1 Follow the instructions in the OVA README.txt file to import and deploy the OVA, to edit VM settings,
and to power on the VM and edit the BIOS settings in the console. For more information, see the section on
Installation Files.

Do not use Thin Provisioning or a VM snapshot when creating a VM to host Cisco Finesse. The
use of Thin Provisioning or snapshots can negatively impact the performance of Cisco Finesse
operation.

Note

Messages appear while the preinstallation script runs. When the preinstallation script ends, the DVD Found
screen opens.

Step 2 Select OK on the Disk Found screen to begin the verification of the media integrity and a brief hardware
check.

If the media check passes, select OK to open the Product Deployment Selection screen. Continue to Step 3.
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If the media check fails, the installation terminates.

Step 3 The Product Deployment Selection screen states that the Cisco Finesse product suite will be installed. This
screen has only one choice: OK.

Select OK to open the Proceed with Install screen.

Step 4 The Proceed with Install screen shows the version of the product that is currently installed (if any) and the
version of the product for this ISO. For the initial installation, the version currently installed shows NONE.

Select Yes on the Proceed with Install screen to open the Platform Installation Wizard screen.

Step 5 On the Platform Installation Wizard screen, select Proceed to open the Basic Install screen.
Step 6 Select Continue on the Basic Install screen to open the Basic Install wizard.

The Basic Install wizard presents a series of screens that present questions and options pertinent to the platform
and the setup configuration. Help is available for each wizard screen.

The first Basic Install wizard screen is Timezone Configuration.

Step 7 On the Timezone Configuration screen:
a) Use the up and down arrows to locate the local time zone that most closely matches your server location.

You can also type the initial character of the time zone to move to that item in the list. The Timezone field
is based on country and city and is mandatory. Setting it incorrectly can affect system operation.

b) Select OK to open the Auto Negotiation Configuration screen.

Step 8 On the Auto Negotiation Configuration screen, select Continue to use automatic negotiation for the settings
of the Ethernet network interface card (NIC).

The MTU Configuration screen appears.

Step 9 In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission Units
(1500).

Finesse supports the default setting of 1500 for MTU only. No other value is supported.Note

Your selection of No opens the Static Network Configuration screen.

Step 10 On the Static Network Configuration screen, enter static network configuration values as follows, referring
to the Configuration Worksheet if necessary:
a) Enter the Host Name.
b) Enter the IP Address.
c) Enter the IP Mask.
d) Enter the GW Address.
e) Select OK to open the Domain Name System (DNS) Client Configuration screen.

Step 11 On the DNS Client Configuration screen, select Yes to specify the DNS client information.

DNS client configuration is mandatory for Cisco Finesse. Select Yes on this screen. If you select
No, after the installation is complete, agents cannot sign in to the desktop and you have to reinstall
Finesse.

Important

Step 12 Specify your DNS client information as follows, referring to the Configuration Worksheet if necessary:
a) Enter the Primary DNS (mandatory).
b) Enter the Secondary DNS (optional).
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c) Enter the Domain (mandatory).
d) Select OK to open the Administrator Login Configuration screen.

Step 13 On the Administrator Login Configuration screen:
a) Enter the credentials for the administrator.
b) Select OK to open the Certificate Information screen.

Step 14 On the Certificate Information screen:
a) Enter the following data to create your Certificate Signing Request: Organization, Unit, Location, State,

and Country.
b) Select OK to open the First Node Configuration screen.

Step 15 On the First Node Configuration screen, select Yes to indicate that you are configuring the first node.

Your selection of Yes opens the Network Time Protocol Client Configuration screen.

Step 16 On the Network Time Protocol Client Configuration screen, enter the IP address, NTP server name, or NTP
Server Pool name for at least one external NTP server.

Step 17 After you complete the NTP configuration, select OK. This action opens the Security Configuration screen.
Step 18 On the Security Configuration screen, enter the Database Access Security password, and then select OK.
Step 19 On the Application User Configuration screen, enter the credentials for the application user.

Select OK to open the Platform Configuration Confirmation screen. This screen states that the platform
configuration is complete.

Step 20 On the Platform Configuration Confirmation screen, select OK.

The installation begins.

The installation can take up to an hour to complete and can run unattended for most of that time.

During the installation, the monitor shows a series of processes, as follows:

• Formatting progress bars

• Copying File progress bar

• Package Installation progress bars

• Post Install progress bar

• Populate RPM Archive progress bar

• Application Installation progress bars (multiple Component Install screens, security checks)

• An informational screen saying the system will reboot momentarily to continue the installation

If you see the following virtual machine question, select Yes, and then click OK:
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Figure 1: Virtual Machine Message

• A system reboot

Messages stream down your monitor during the reboot. Some of them prompt you to press a key. Do
not respond to these prompts to press a key.

• Application Pre Install progress bars

• Configure and Setup Network progress bars

If a Network Connectivity Failure screen appears during the Configure and Setup Network
process, click Review, and then click OK at the Errors screen. Follow the prompts to reenter
the information that caused the failure. The installation continues when the connection
information is complete.

Note

• Security configuration

A message appears that states the installation of Cisco Finesse has completed successfully.
The installation of Cisco Finesse has completed successfully.

Cisco Finesse <version number>
<hostname> login: _

What to do next

Sign in to the Finesse administration console on the primary Finesse server (https://FQDN of Finesse
server:8445/cfadmin) to configure CTI server, Administration & Database server, and cluster settings.

After you configure these settings, install Finesse on the secondary node.

Contact Center Enterprise CTI Server Settings
Use the Contact Center Enterprise CTI Server Settings gadget to configure the A and B Side CTI servers.

All fields on this tab are populated with default system values or with values an administrator has previously
entered. Change values to reflect your environment and preferences.

For configuring secure connection select the Enable SSL encryption check box.

Test the CTI connection for given configuration using the Test Connection button.
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After you make any changes to the values on the Contact Center Enterprise CTI Server Settings gadget, you
must restart all the nodes of Cisco Finesse Tomcat. To make changes to other settings (such as Contact Center
Enterprise Administration&Data Server settings), you canmake those changes and then restart Cisco Finesse
Tomcat.

If you restart Cisco Finesse Tomcat, agents must sign out and sign in again. As a best practice, make changes
to CTI server settings and restart the Cisco Finesse Tomcat Service during hours when agents are not signed
in to the Finesse desktop.

The secure encryption and Test Connection functionality is supported only from Unified CCE 12.0.

Note

Although the B Side Host/IP Address and B Side Port fields are not shown as required, A and B Side CTI
servers are mandatory for a production deployment of Unified CCE and Cisco Finesse.

Note

The following table describes the fields on the Contact Center Enterprise CTI Server Settings gadget:

ExplanationField

The hostname or IP address of the A Side CTI server.
This field is required.

This value is typically the IP address of the Peripheral
Gateway (PG). The CTI server runs on the PG.

A Side Host/IP Address

The value of this field must match the port configured
during the setup of the A Side CTI server.

This field is required and accepts values between 1
and 65535.

You can find this value using the Unified CCE
Diagnostic Framework Portico tool on the PG box.
For more information about Diagnostic Framework
Portico, see the Serviceability Guide for Cisco Unified
ICM/Contact Center Enterprise.

The default value is 42027.

A Side Port

The ID of the Agent PG Routing Client (PIM).

The Agent PG Peripheral ID should be configured to
the same value for the A and B Side CTI server.

This field is required and accepts values between 1
and 32767.

The default value is 5000.

Peripheral ID

The hostname or IP address of the B Side CTI server.B Side Host/IP Address
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ExplanationField

The value of this field must match the port configured
during the setup of the B Side CTI server.

This field accepts values between 1 and 65535.

B Side Port

Check this box to enable secure encryption.Enable SSL encryption

Actions on the Contact Center Enterprise CTI Server Settings gadget:

• Save: Saves your configuration changes.

• Revert: Retrieves the most recently saved server settings.

• Test Connection: Tests the CTI connection.

CTI Test Connection

When you click Test Connection:

1. Input validation is done on the request attributes.

Host/IP Address must not be empty. Port and Peripheral IDs must be within the valid range.

2. Validation is done to check if the provided Host/IP is resolved by Finesse box.

3. Validation is done to check if AW Database is reachable and if a valid path ID is configured for the
provided Peripheral ID.

4. Socket connection is established to the provided Host/IP and port. The connection might fail if there is
no route to the provided IP. If SSL encryption box is checked, this step also checks for successful TLS
handshake. For TLS handshake to be successful, mutual trust has to be established between Finesse and
CTI server.

For information on how to establish trust between Finesse and CTI server, see Security Guide for Cisco
Unified ICM/Contact Center Enterprise at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html

5. After successful socket connection, a CTI initialization request is sent to check if the provided host is a
CTI host.

If the CTI response is a success for the CTI initialization request and peripheral provided is configured
with Unified CCE, it is confirmed to be a CTI host.

6. CTI connection is closed by sending a CTI session close request.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.6(1)
66

Installation
Contact Center Enterprise CTI Server Settings

https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html


If Test Connection is successful for Side A or B of the CTI cluster and the other side fails, it is a valid
configuration as CTI server works in active-passive mode and connects to the active node. Inactive CTI node
will refuse connection on the CTI port. However, Administrator has to ensure that the failed side also has a
valid entry for CTI host and port field. System cannot verify this due to server restrictions.

If Test Connection is successful on Side A and B of the CTI cluster, then there is an error in the system
configuration. Verify that the Side A and B of the CTI node have valid entries for port and host.

Test connection API success result does not guarantee peripheral to be online. It only validates if the peripheral
provided is configured with Unified CCE.

Test connection API with insecure connection parameter will function as intended for earlier versions of
Unified CCE deployments.

Note

Configure Contact Center Enterprise Administration & Data Server Settings
Configure the Contact Center Enterprise Administration & Data Server settings to enable authentication for
Finesse agents and supervisors.

If you are using HTTPS, the first time you access the administration console, you see a browser security
warning. To eliminate browser security warnings each time you sign in, you can trust the self-signed certificate
provided with Finesse or obtain and upload a CA certificate.

Note

Procedure

Step 1 Sign in to the administration console.
Step 2 In the Contact Center Enterprise Administration &Data Server Settings area, enter the Administration &Data

Server settings as described in the following table. Refer to your configuration worksheet if necessary.

DescriptionField

Enter the hostname or IP address of the Unified CCE Administration
& Data Server.

Primary Host/IP Address

Enter the hostname or IP address of the backup Unified CCE
Administration & Data Server.

Backup Host/IP Address

Enter the port of the Unified CCE Administration & Data Server.

Because Finesse expects the primary and backup
Administration & Data Server ports to be the same, the
Finesse administration console exposes only one port field.
You must ensure that the port is the same for the primary
and backup Administration & Data Servers.

Note

Database Port

Enter the name of the AW Database (AWDB) (for example,
ucceinstance_awdb).

AW Database Name
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DescriptionField

Enter the domain of the AWDB.Domain

Enter the username required to sign in to the AWDB.Username

Enter the password required to sign in to the AWDB.Password

Step 3 Click Save.

Configure Cluster Settings
Configure the cluster settings for the secondary Finesse node. The secondary Finesse node handles agent
requests if the primary server goes down.

Procedure

Step 1 If you are not already signed in the primary node, sign in to the administration console of the primary node
with the Application User credentials.

Step 2 In the Cluster Settings area, in the Hostname field, enter the hostname of the secondary Finesse server.
Step 3 Click Save.

Restart Cisco Finesse Tomcat
After youmake changes to the Contact Center Enterprise CTI Server, Contact Center Enterprise Administration
& Data Server, or cluster settings, restart Cisco Finesse Tomcat for the changes to take effect.

After you restart Finesse, it can take approximately 6minutes for all server-related services to restart. Therefore,
you wait 6 minutes before you attempt to access the Finesse administration console.

Note

Procedure

Step 1 Access the CLI and run the following command:

utils service restart Cisco Finesse Tomcat

Step 2 You can enter the command utils service list to monitor the Cisco Finesse Tomcat Service. After Cisco Finesse
Tomcat changes to STARTED, the configured agents can sign in to the desktop.

Install Finesse on Secondary Node
Install the same version of Finesse on both the primary and secondary Finesse nodes.
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Configure a Datastore ISO file on the virtual CD/DVD drive of the target VM to install Finesse.Note

Finesse administration tasks can only be performed on the primary Finesse server. After you install the
secondary server, sign in to the administration console on the primary server to perform administration tasks
(such as configuring reason codes or call variable layout).

Note

Before you begin

• Install Finesse on the primary server. See Install Finesse on Primary Node.

• Use the Finesse administration console on the primary Finesse server to configure CTI server,
Administration & Database server, and cluster settings.

• Ensure that the DNS server has forward and reverse DNS set up for both the primary and secondary
node.

Procedure

Step 1 Follow the instructions in the OVA README.txt file to import and deploy the OVA, to edit VM settings,
and to power on the VM and edit the BIOS settings in the Console.

Messages appear while the preinstallation script runs. When the preinstallation script ends, the DVD Found
screen opens.

Step 2 Select Yes on the DVD Found screen to begin the verification of the media integrity and a brief hardware
check.

If the media check passes, select OK to open the Product Deployment Selection screen. Continue to Step 3.

If the media check fails, the installation terminates.

Step 3 The Product Deployment Selection screen states that the Cisco Finesse product suite will be installed. This
screen has only one choice: OK.

Select OK to open the Proceed with Install screen.

Step 4 The Proceed with Install screen shows the version of the product that is currently installed (if any) and the
version of the product for this ISO. For the initial installation, the version currently installed shows NONE.

Select Yes on the Proceed with Install screen to open the Platform Installation Wizard screen.

Step 5 On the Platform Installation Wizard screen, select Proceed to open the Basic Install screen.
Step 6 Select Continue on the Basic Install screen to open the Basic Install wizard.

The Basic Install wizard presents a series of screens that present questions and options pertinent to the platform
and the setup configuration. Help is available for each wizard screen.

The first Basic Install wizard screen is Timezone Configuration.

Step 7 In the Timezone Configuration screen:
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a) Use the up and down arrows to locate the local time zone that most closely matches your server location.
You can also type the initial character of the time zone to move to that item in the list. The Timezone field
is based on country and city and is mandatory. Setting it incorrectly can affect system operation.

b) Select OK to open the Auto Negotiation Configuration screen.

Step 8 On the Auto Negotiation Configuration screen, select Continue to use automatic negotiation for the settings
of the Ethernet network interface card (NIC).

The MTU Configuration screen appears.

Step 9 On the MTU Configuration screen, select No to keep the default setting for Maximum Transmission Units
(1500).

Finesse supports the default setting of 1500 for MTU only. No other value is supported.Note

Your selection of No opens the Static Network Configuration screen.

Step 10 On the Static Network Configuration screen, enter static network configuration values as follows, referring
to the Configuration Worksheet if necessary:
a) Enter the Host Name.
b) Enter the IP Address.
c) Enter the IP Mask.
d) Enter the GW Address.
e) Select OK to open the Domain Name System (DNS) Client Configuration screen.

Step 11 On the DNS Client Configuration screen, select Yes to specify the DNS client information.

IMPORTANT: DNS client configuration is mandatory for Cisco Finesse. Select Yes on this screen. If you
select No, after the installation is complete, agents cannot sign in to the desktop and you have to reinstall
Finesse.

Step 12 Specify your DNS client information as follows, referring to the Configuration Worksheet if necessary:
a) Enter the Primary DNS (mandatory).
b) Enter the Secondary DNS (optional).
c) Enter the Domain (mandatory).
d) Select OK to open the Administrator Login Configuration screen.

Step 13 On the Administrator Login Configuration screen:
a) Enter the credentials for the administrator.
b) Select OK to open the Certificate Information screen.

Step 14 On the Certificate Information screen:
a) Enter the following data to create your Certificate Signing Request: Organization, Unit, Location, State,

and Country.
b) Select OK to open the First Node Configuration screen.

Step 15 On the First Node Configuration screen, select No to indicate that you are configuring the second node.

A warning message appears that indicates you must first configure the server on the first node before you can
proceed. If you already configured the first node, select OK.

Step 16 On the Network Connectivity Test Configuration screen, select No to proceed with the installation after
connectivity is verified.

Step 17 On the First Node Configuration screen, specify the information about the first node as follows:
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a) Enter the Host Name of the primary Finesse server.
b) Enter the IP Address of the primary Finesse server.
c) Enter the Security Password of the primary Finesse server.
d) Confirm the Security Password.

Step 18 Select OK to open the Platform Configuration Confirmation screen.
Step 19 On the Platform Configuration Confirmation screen, select OK.

The installation begins.

The installation can take up to an hour to complete and can run unattended for most of that time.

A message appears that states the installation of Cisco Finesse has completed successfully.
The installation of Cisco Finesse has completed successfully.

Cisco Finesse <version number>
<hostname> login: _

What to do next

Check the replication status. If all nodes in the cluster show a replication status of 2, replication is functioning
correctly.

It can take 10–20 minutes to establish replication fully between the two nodes.Note

To access platform specific applications like Disaster Recovery System, Cisco Unified Serviceability, and
Cisco Unified Operating SystemAdministration, use the following URL, https://FQDN of Finesse server:8443.

Note

Upgrade VMware Tools
To install or upgrade VMware Tools using VOS, for both nodes of Cisco Finesse, perform the following
steps:

Procedure

Step 1 Power on the virtual machine.
Step 2 Right-click the VM menu. Select Guest > Install / Upgrade VMware tools.
Step 3 Select the interactive tools update and click OK.
Step 4 Open the console and log in to command prompt.
Step 5 Enter the command utils vmtools refresh and confirm. The server automatically reboots twice.
Step 6 After reboot, check the Summary tab for the VM to verify whether the VMware Tools version is current. If

it is not current, reboot the VM and check the version again. The process takes a fewminutes. After the process
is completed, the tools are listed as Running (Current) on the VM's Summary tab in vSphere.
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Check Replication Status

Procedure

Step 1 Access the CLI on the primary Finesse server.
Step 2 Sign in with the Administrator User credentials that are defined during installation.
Step 3 Run the following command:

utils dbreplication runtimestate

This command returns the replication status on both the primary and secondary Finesse servers.

Live Data Standalone Installation
Follow this sequence of tasks to install Live Data Standalone.

TaskSequence

For all deployments except the 2000 agent reference design, verify that you created a separate
virtual machine for the IdS publisher node and the IdS subscriber node. See Set Up Virtual
Machines, on page 15.

1

Install Live Data Primary Node.

See Install Publishers/Primary Nodes of VOS-Based Contact Center Applications, on page
73

2

Set Live Data Secondary Node, on page 743

Install Live Data Secondary Node.

See Install Subscribers/Secondary Nodes of VOS-Based Contact Center Applications, on
page 74

4

Upgrade VMware Tools. See Upgrade VMware Tools, on page 71 .5

Configure Live Data with AW, on page 766

Configure Live Data Machine Services, on page 777

Configure Live Data for Unified Intelligence Center Data Sources, on page 788

Restart Live Data, on page 789

Set Up Certificates for Live Data, on page 7910
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Install Publishers/Primary Nodes of VOS-Based Contact Center Applications

Before you begin

DNS Configuration is mandatory for installation of Cisco Unified Communications Manager, Cisco Unified
Intelligence Center, Cisco Finesse and Cisco Identity Service (IdS). To configure DNS, add the VMs to the
forward and reverse lookups of the DNS.

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine, power it on, and open the console.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen:

• For the Progger (Lab only) or 2000 agent reference design, choose the coresident deployment option
Cisco Unified Intelligence Center with Live Data and IdS, and then selectOK. TheCisco Unified
Intelligence Center with Live Data and IdS option installs Cisco Unified Intelligence Center with
Live Data and Cisco Identity Service (IdS) on the same server.

• For all other deployments, select one of the standalone install options. For example, select Cisco
Unified Intelligence Center, Live Data, or Cisco Identity Service (IdS). Then select OK.

d) In the Proceed with Install screen, select Yes.
e) In the Platform Installation Wizard screen, select Proceed.
f) In the Apply Patch screen, select No.
g) In the Basic Install screen, select Continue.
h) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

i) In the Auto Negotiation Configuration screen, select Continue.
j) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
k) In the DHCP Configuration screen, select No.
l) In the Static Network Configuration screen, enter static configuration values. Select OK.
m) In the DNS Client Configuration screen, click Yes to enable DNS client.
n) Enter your DNS client configuration. Select OK.
o) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
p) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
q) In the First Node Configuration screen, select Yes.
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r) In the Network Time Protocol Client Configuration screen, enter a valid NTP server IP address and
select OK.

s) In the Security Configuration screen, enter the security password and select OK.
t) In the SMTP Host Configuration screen, select No.
u) In the Application User Configuration screen, enter the application username. Enter, and confirm the

application user password. Select OK.
v) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 5 Unmount the ISO image.

Set Live Data Secondary Node
Use the set live-data secondary command to provide the primary node the address of the secondary node.

Procedure

Step 1 Log in to your primary Live Data node.
Step 2 Run the following command to set the secondary node:

set live-data secondary name
name

Specifies the hostname or IP address of the Live Data secondary node.

Related Topics
set live-data secondary, on page 250

Install Subscribers/Secondary Nodes of VOS-Based Contact Center Applications

This task is required for installation of the subscriber/secondary nodes of the three VOS-based contact center
applications: Cisco Finesse, Cisco Unified Communications Manager, and Cisco Unified Intelligence Center.

Note

Before you begin

DNS Configuration is mandatory for installation of Cisco Unified Communications Manager, Cisco Unified
Intelligence Center, and Cisco Finesse. To configure DNS, add the VMs to the forward and reverse lookups
of the DNS.

Before you install the subscriber/secondary nodes, youmust install the publisher/primary nodes and configure
the clusters.
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Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine and power it on, and open the console.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen:

• For the Progger (Lab only) or 2000 agent reference design, choose the coresident deployment option
Cisco Unified Intelligence Center with Live Data and IdS, and then selectOK. TheCisco Unified
Intelligence Center with Live Data and IdS option installs Cisco Unified Intelligence Center, Live
Data, and Cisco Identity Service (IdS) on the same server.

• For all other deployments, select one of the standalone install options. For example, select Cisco
Unified Intelligence Center, Live Data, or Cisco Identity Service (IdS). Then select OK.

Step 5 Follow the Install wizard, making selections as follows:
a) In the Proceed with Install screen, select Yes.
b) In the Platform Installation Wizard screen, select Proceed.
c) In the Apply Patch screen, select No.
d) In the Basic Install screen, select Continue.
e) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

f) In the Auto Negotiation Configuration screen, select Continue.
g) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
h) In the DHCP Configuration screen, select No.
i) In the Static Network Configuration screen, enter static configuration values. Select OK.
j) In the DNS Client Configuration screen, click Yes to enable DNS client.
k) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
l) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
m) In the First Node Configuration screen, select No.
n) In the warning screen, select OK.
o) In the Network Connectivity Test Configuration screen, select No.
p) In the First Node Access Configuration screen, enter the host name and IP address of the first node.

Enter and confirm the security password. Select OK.
q) In the SMTP Host Configuration screen, select No.
r) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.
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• The installation ends at a sign-in prompt.

Step 6 Unmount the ISO image.

Install VMware Tools for VOS
To install or upgrade VMware Tools using VOS, perform the following steps:

Procedure

Step 1 Ensure that your virtual machine is powered on.
Step 2 Right-click the VM menu. Select Guest > Install / Upgrade VMware tools .
Step 3 Choose the interactive tools update and press OK.
Step 4 Open the console and log in at the command prompt.
Step 5 Enter the command utils vmtools refresh and confirm.

The server automatically reboots twice.
Step 6 After reboot, check the Summary tab for the VM to verify that the VMware Tools version is current. If it is

not current, reboot the VM and check the version again.

The process takes a few minutes. After the process completes, the tools are listed as Running (Current) on
the VM's Summary tab in vSphere.

Configure Live Data with AW
Configure Live Data with AW to access the primary AW DB and the secondary AW DB. The command also
automatically tests the connection from Live Data to the primary or secondary AW, checks to see if you (as
the configured user) have appropriate AW DB access, and reports the results.

You can use the optional skip-test parameter if you do not want to perform the test. When you include the
skip-test parameter, the command does not check if you (as the configured user) have appropriate AW DB
access and does not report results.

You do not need to configure the AW DB on both the Publisher and the Subscriber. The configuration is
replicated between the Publisher and Subscriber.

Note

Before you begin

Before you can configure Live Data, you must first configure a SQL user (with special permissions) to work
with Live Data, as described in Configure SQL User Account, on page 128.

The SQL administrative user "sa" or a user with sysadmin privileges must then execute the following SQL
queries on the master system database for the SQL user who is configured to work with Live Data:
USE master
GO
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GRANT CONTROL ON CERTIFICATE :: UCCESymmetricKeyCertificate TO "<user>"
GRANT VIEW DEFINITION ON SYMMETRIC KEY :: UCCESymmetricKey TO "<user>"

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure Live Data with the primary AW DB. The command automatically

tests the connection from Live Data, checks the user permission, and displays results.

The skip-test parameter is optional. Include it only if you do not want to perform the test.

set live-data aw-access primary addr port db user pwd [skip-test]

Step 3 Run the following command to configure Live Data with the secondary AWDB. The command automatically
tests the connection from Live Data, checks the user permission, and displays results.

The skip-test parameter is optional. Include it only if you do not want to perform the test.

set live-data aw-access secondary addr port db user pwd [skip-test]
You can also optionally run the following command at any time to show and test the AW configuration that
you set from Live Data to the primary and secondary AW DBs.

The skip-test parameter is optional. Include it only if you do not want to perform the test.

show live-data aw-access [skip-test]

For more information, see set live-data aw-access, on page 248 .

Related Topics
Configure SQL User Account, on page 128
set live-data aw-access, on page 248
show live-data aw-access, on page 249

Configure Live Data Machine Services
This command tells the AW where your Live Data machine services are located.

• Whenever you run set live-data machine-services, be sure to also run set live-data cuic-datasource to
reconfigure the Live Data data sources for the Unified Intelligence Center. See Configure Live Data for
Unified Intelligence Center Data Sources, on page 78.

Note

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure the Live Data machine services:

set live-data machine-services awdb-user awdb-pwd

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.6(1)
77

Installation
Configure Live Data Machine Services



Use the user@domain format to specify the AW database domain user with write-access permission. The
domain is a fully qualified domain name (FQDN), and the username is a user principal name. You must be
authorized to change Unified CCE configuration.

• The Router and Peripheral Gateway (PG) TIP and TOS connection information is automatically
populated for UCCE deployments that support Live Data. To set the deployment type, see Set
Deployment Type in Unified CCE Administration Configuration, on page 88. The Live Data
server uses this information to establish a connection, and receive reporting data as well as
agent and call events as they occur.

• Cisco Unified Communications Manager (CUCM) PG, generic PGs with CUCM peripherals,
and Unified CCE Gateway PGs are supported for Live Data.

Note

Configure Live Data for Unified Intelligence Center Data Sources
This command tells Unified Intelligence Center how to access Live Data.

If you are using any certificates that are unapproved by Cisco, ensure to import the CUIC certificate into the
Live Data server before you run set live-data machine-services.

Note

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure your Live Data Unified Intelligence Center data sources:

set live-data cuic-datasource cuic-addr cuic-port cuic-user cuic-pwd

Related Topics
set live-data cuic-datasource, on page 255

Restart Live Data
After you complete the configuration procedures for the AW, the Live DataMachine Services, and the Unified
Intelligence Center data source, restart the Live Data system to enable the changes.

Procedure

Access the Live Data CLI and run the following command:
utils system restart
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Whenever a new peripheral gateway that supports Live Data gets deployed and started, its feed will
not be available to Live Data server automatically. Restart the Live Data server to start the feed
from the newly deployed Peripheral Gateway.

Note

Set Up Certificates for Live Data
For secure Cisco Finesse, Cisco Unified Intelligence Center, and Live Data server-to-server communication,
perform any of the following:

• Use the self-signed certificates provided with Live Data.

When using self-signed certificates, agents must accept the Live Data certificates
in the Finesse desktop when they sign in before they can use the Live Data gadget.

Note

• Produce a Certification Authority (CA) certificate internally.

• Obtain and install a Certification Authority (CA) certificate from a third-party vendor.

Install Coresident Deployment (Cisco Unified Intelligence Center with Live
Data and IdS)

Follow this sequence of tasks to install the coresident deployment (Cisco Unified Intelligence Center with
Live Data and IdS).

TaskSequence

Set Deployment Type in Unified CCE Administration Configuration:

Set Deployment Type in Unified CCE Administration Configuration, on page 88

1

Install Coresident Deployment Primary Node.

See Install Publishers/Primary Nodes of VOS-Based Contact Center Applications, on page
73

2

Install Coresident Deployment Secondary Node.

See Install Subscribers/Secondary Nodes of VOS-Based Contact Center Applications, on
page 74

3

Add Coresident (Cisco Unified Intelligence Center with Live Data and IdS) Machine Type
to the System Inventory, on page 83

4

Upgrade VMware Tools. See Install VMware Tools, on page 83.5

Configure Live Data with AW, on page 846

Configure Live Data Unified Intelligence Center Data Sources, on page 857

Restart Live Data, on page 858
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TaskSequence

Set up certificates for Live Data. See9

Unified CCE 2000 agent reference design use the UCCE: 4000 Agents Rogger deployment type. But, you
can use the 2000 agent reference design OVA and server layout.

Note

Install Publisher/Primary Nodes of Coresident Deployment (Cisco Unified Intelligence Center with
Live Data and IdS)

Before you begin

DNS Configuration is mandatory for installation of Cisco Unified Communications Manager, Cisco Unified
Intelligence Center, Cisco Finesse and Cisco Identity Service (IdS). To configure DNS, add the VMs to the
forward and reverse lookups of the DNS.

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine, power it on, and open the console.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen:

• For the Progger (Lab only) or 2000 agent reference design, choose the coresident deployment option
Cisco Unified Intelligence Center with Live Data and IdS, and then selectOK. TheCisco Unified
Intelligence Center with Live Data and IdS option installs Cisco Unified Intelligence Center with
Live Data and Cisco Identity Service (IdS) on the same server.

• For all other deployments, select one of the standalone install options. For example, select Cisco
Unified Intelligence Center, Live Data, or Cisco Identity Service (IdS). Then select OK.

d) In the Proceed with Install screen, select Yes.
e) In the Platform Installation Wizard screen, select Proceed.
f) In the Apply Patch screen, select No.
g) In the Basic Install screen, select Continue.
h) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

i) In the Auto Negotiation Configuration screen, select Continue.
j) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
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k) In the DHCP Configuration screen, select No.
l) In the Static Network Configuration screen, enter static configuration values. Select OK.
m) In the DNS Client Configuration screen, click Yes to enable DNS client.
n) Enter your DNS client configuration. Select OK.
o) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
p) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
q) In the First Node Configuration screen, select Yes.
r) In the Network Time Protocol Client Configuration screen, enter a valid NTP server IP address and

select OK.
s) In the Security Configuration screen, enter the security password and select OK.
t) In the SMTP Host Configuration screen, select No.
u) In the Application User Configuration screen, enter the application username. Enter, and confirm the

application user password. Select OK.
v) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 5 Unmount the ISO image.

Install Subscribers/Secondary Nodes of Coresident Deployment (Cisco Unified Intelligence Center
with Live Data and IdS)

This task is required for installation of the subscriber/secondary nodes of the three VOS-based contact center
applications: Cisco Finesse, Cisco Unified Communications Manager, and Cisco Unified Intelligence Center.

Note

Before you begin

DNS Configuration is mandatory for installation of Cisco Unified Communications Manager, Cisco Unified
Intelligence Center, and Cisco Finesse. To configure DNS, add the VMs to the forward and reverse lookups
of the DNS.

Before you install the subscriber/secondary nodes, youmust install the publisher/primary nodes and configure
the clusters.

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine and power it on, and open the console.
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Step 4 Follow the Install wizard, making selections as follows:
a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen:

• For the Progger (Lab only) or 2000 agent reference design, choose the coresident deployment option
Cisco Unified Intelligence Center with Live Data and IdS, and then selectOK. TheCisco Unified
Intelligence Center with Live Data and IdS option installs Cisco Unified Intelligence Center, Live
Data, and Cisco Identity Service (IdS) on the same server.

• For all other deployments, select one of the standalone install options. For example, select Cisco
Unified Intelligence Center, Live Data, or Cisco Identity Service (IdS). Then select OK.

Step 5 Follow the Install wizard, making selections as follows:
a) In the Proceed with Install screen, select Yes.
b) In the Platform Installation Wizard screen, select Proceed.
c) In the Apply Patch screen, select No.
d) In the Basic Install screen, select Continue.
e) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

f) In the Auto Negotiation Configuration screen, select Continue.
g) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
h) In the DHCP Configuration screen, select No.
i) In the Static Network Configuration screen, enter static configuration values. Select OK.
j) In the DNS Client Configuration screen, click Yes to enable DNS client.
k) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
l) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
m) In the First Node Configuration screen, select No.
n) In the warning screen, select OK.
o) In the Network Connectivity Test Configuration screen, select No.
p) In the First Node Access Configuration screen, enter the host name and IP address of the first node.

Enter and confirm the security password. Select OK.
q) In the SMTP Host Configuration screen, select No.
r) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 6 Unmount the ISO image.
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Add Coresident (Cisco Unified Intelligence Center with Live Data and IdS) Machine Type to the
System Inventory

Procedure

Step 1 In Unified CCE Administration, navigate to System > Deployment.
Step 2 Add the new machine to the System Inventory:

a) Click Add.

The Add Machine popup window opens.

b) From the Type drop-down menu, select the following machine type:

CUIC_LD_IdS Publisher, for the coresident Unified Intelligence Center, Live Data, and Identity Service
machine available in the 2000 agent reference design.

c) In the Hostname field, enter the FQDN, hostname, or IP address of the machine.

The system attempts to convert the value you enter to FQDN.

d) Enter the machine's Administration credentials.
e) Click Save.

The machine and its related Subscriber or Secondary machine are added to the System Inventory.

What to do next

If you remove a component from your deployment, delete it from your System Inventory. If you add the
component again, or add more components, add those components to the System Inventory.

Install VMware Tools
To install or upgrade VMware Tools using VOS, for both nodes of Cisco Unified Intelligence Center
with Live Data and IdS, perform the following steps:

1. Ensure that your virtual machine is powered on.

2. Right-click the VM menu. Select Guest > Install / Upgrade VMware tools

3. Choose the interactive tools update and press OK.

4. Open the console and log in at the command prompt.

5. Enter the command utils vmtools refresh and confirm.

The server automatically reboots twice.

6. After reboot, check the Summary tab for the VM to verify that the VMware Tools version is current. If
it is not current, reboot the VM and check the version again.

The process takes a few minutes. After the process is complete, the tools are listed as Running (Current) on
the VM's Summary tab in vSphere.
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Configure Live Data with AW
This command tells Live Data how to access the primary AW DB and the secondary AW DB. The command
also automatically tests the connection from Live Data to the primary or secondary AW, checks to see if the
configured user has appropriate AW DB access, and reports the results.

You can use the optional skip-test parameter if you do not want the test that is performed. When you include
the skip-test parameter, no checking is done to see if you (as the configured user) have appropriate AW DB
access, and no results are reported.

You do not need to configure the AW DB on both the Publisher and the Subscriber. The configuration is
replicated between the Publisher and the Subscriber.

Note

Before you begin

Before you can configure Live Data, you must first configure a SQL user (with special permissions) to work
with Live Data, as described in Configure SQL User Account, on page 128.

The SQL administrative user "sa" or a user with sysadmin privileges must then execute the following SQL
queries for the SQL user who is configured to work with Live Data.
USE master
GO
GRANT CONTROL ON CERTIFICATE :: UCCESymmetricKeyCertificate TO "<user>"
GRANT VIEW DEFINITION ON SYMMETRIC KEY :: UCCESymmetricKey TO "<user>"

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure Live Data with the primary AW DB. The command automatically

tests the connection from Live Data, checks the user permission, and displays results.

(The skip-test parameter is optional; include it only if you do not want the test performed.)

set live-data aw-access primary addr port db user pwd [skip-test]

Step 3 Run the following command to configure Live Data with the secondary AWDB. The command automatically
tests the connection from Live Data, checks the user permission, and displays results.

(The skip-test parameter is optional; include it only if you do not want the test performed.)

set live-data aw-access secondary addr port db user pwd [skip-test]
You can also optionally run the following command at any time to show and test the AW configuration that
you set from Live Data to the primary and secondary AW DBs.

(The skip-test parameter is optional; include it only if you do not want the test performed.)

show live-data aw-access [skip-test]

For more information, see set live-data aw-access, on page 248 .
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Configure Live Data Unified Intelligence Center Data Sources
This command tells Unified Intelligence Center how to access Live Data.

Before you begin

• Ensure that AW distributor and Cisco Unified Intelligence Center Publisher are in service.

• Ensure that AW DB connection information is updated on the same node, where you want to configure
Live Data CUIC data source.

• Configure Live Data endpoints in the Machine Service table.

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure your Live Data Unified Intelligence Center data sources:

set live-data cuic-datasource cuic-addr cuic-port cuic-user cuic-pwd

Restart Live Data
After you complete the configuration procedures for the AW and the Unified Intelligence Center data source,
restart the Live Data system to enable the changes.

Procedure

Access the Live Data CLI and run the following command:
utils system restart
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C H A P T E R 5
Initial Configuration

• Initial Configuration Overview, on page 87
• Initial Configuration Task Flow, on page 87
• Initial Configuration Tasks, on page 88
• Configure SQL User Account for Outbound Options High Availability , on page 174

Initial Configuration Overview
This initial configuration brings the contact center to the point where a complete call flow is possible. The
configured systemwill process information about incoming calls, perform call routing, and enable call handling.

Related Topics
Initial Configuration Task Flow, on page 87

Initial Configuration Task Flow
SeeTask

Set Deployment Type in Unified CCEAdministration
Configuration, on page 88

Set Deployment Type in Unified CCEAdministration
Configuration

Configure Cisco Unified Contact Center Enterprise,
on page 88

Configure Cisco Unified Contact Center Enterprise

Configure Cisco Unified Intelligence Center, on page
127

Configure Cisco Unified Intelligence Center

Configure Cisco Unified Customer Voice Portal, on
page 134

Configure Cisco Unified Customer Voice Portal

Configure Cisco Unified Communications Manager,
on page 145

Configure Cisco Unified Communications Manager

Configure Cisco Finesse, on page 155Configure Cisco Finesse
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Initial Configuration Tasks

Set Deployment Type in Unified CCE Administration Configuration
Perform the following steps to set the deployment type.

For more information on deployment types, see the following document:

Solution Design Guide for Cisco Unified Contact Center Enterprise at http://www.cisco.com/en/US/products/
sw/custcosw/ps1844/products_implementation_design_guides_list.html

Configure Cisco Unified Contact Center Enterprise
You can configure individual records, or you can use the Bulk Configuration tool to configure multiple records
at one time. Bulk configuration is available for the following:

• Agents

• Call types

• Dialed number plans

• Dialed numbers

• Labels

• Network trunk groups

• Network VRU scripts

• Peripheral targets

• Persons

• Regions

• Region prefixes

• Routes

• Trunks

• Trunk groups

• Scheduled targets

• Services

• Skill groups

• VRU port maps

Related Topics
Perform Bulk Configuration, on page 122
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Access Configuration Manager tool
You perform all Unified CCE configuration tasks using the Configuration Manager tool, which is installed
with the Unified CCE software.

1. From your desktop, double-click the Unified CCE Tools icon, and then select Administration Tools.

2. Double-click the Configuration Manager icon.

Configure Media Routing Domain
You must establish Media Routing Domains (MRD) for each media type that your Unified CCE System
supports. A Voice MRD is installed by default with Unified CCE. You need to create MRDs for other media
such as chat, email, and tasks. Additionally, if you are using Cisco Enterprise Chat and Email (ECE), you
need to create media classes for ECE chat and email.

If you are configuring Media Routing Domains for ECE, see the Configuration Guide for Cisco Unified
ICM/Contact Center Enterprise for complete instructions, at http://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html.

If you are configuring a Media Routing Domain for Task Routing with third-party multichannel applications,
do not use this procedure. See the Cisco Unified Contact Center Enterprise Features Guide for instructions,
at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-feature-guides-list.html.

Important

Procedure

Step 1 Start the Configuration Manager and select Tools > List Tools > Media Routing Domain List.
Step 2 Click Retrieve and then click Add.

The Attributes tab appears.

Step 3 On the Attributes tab, provide values for the following fields:

Name. Enter the enterprise name of the MRD.

Media Class. Use the drop-down list to select the media class for the integrated application.

Max Time in queue. The default maximum queue time for calls in queue is one hour. To override this default,
modify the value of the Max Time In queue field.

The MR domain ID is automatically generated when you save the MRD.

Step 4 After completing the required fields, click Save.

Repeat this procedure to add an MRD for each media class that your system supports.
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Configure Trunk Groups
For the Unified CCE, the Network Trunk Group is the placeholder in the Unified CCE database for the trunk
group; it performs no other function.

For deployments that:

• Use the Unified CCE System PG, you must create one Network Trunk Group for each Unified CCE
System PG peripheral.

• Do not use the Unified CCE System PG, you must create two Network Trunk Groups—one for the
Unified Communications Manager and one for the Unified CVP or Unified IP IVR. If you are deploying
the Unified CVP, create one Network Trunk Group per CVP Server.

A Unified CCE Trunk Group is a collection of trunks associated with a single peripheral and usually used for
a common purpose. For the Unified CCE, the trunk groups for VRU peripherals are used primarily as a place
holder in the Unified CCE database.

Create a trunk group for each Unified CommunicationsManager peripheral and a trunk group for each Unified
IP IVR application. If you are deploying Unified CVP, you must create two trunk groups for each Unified
CVP Server that match the Group Numbers configured in Unified CVP Application Administration. For
Unified IP IVR, the trunk group peripheral number in the Unified CCE must match the CTI Port Group ID
on Unified IP IVR.

To configure a Network Trunk Group (and the trunk group under it):

Procedure

Step 1 From the ConfigurationManager, chooseConfigure ICM > Peripherals >Trunk Group >Network Trunk
Group Explorer. The ICM Network Trunk Group Explorer dialog box opens.

Step 2 Click Retrieve.
Step 3 Click Add Network Trunk Group. The Network Trunk Group tab opens.
Step 4 Add a unique name for the Network Trunk Group and an appropriate description.
Step 5 Click Add Trunk Group to add a trunk group.
Step 6 Complete these fields:

Peripheral. Select the peripheral to which the trunk group is associated.

Peripheral Number. Enter the number of the trunk group as understood by the peripheral. This number must
be unique among all trunk groups associated with the peripheral. For Unified IP IVR, this number must:

a. Match a CTI Port Group ID configured on the Unified IP IVR.

b. Be an odd number.

c. Be unique for all Unified IP IVRs handled by an Unified CCE System PG.

For example, if a Unified CCE System PG handles four Unified IP IVRs and each Unified IP IVR peripheral
has one CTI Port Group, then the CTI Port Group ID for the first Unified IP IVR should be 1, the port group
ID for the second Unified IP IVR should be 3, and so on. For the Unified CVP, this number must match a
CVP Server Group Number configured on the CVP Server.

Peripheral Name. Enter the name of the trunk group as understood by the peripheral. This name must be
unique among all trunk groups associated with the peripheral.
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Name. Enter the enterprise name of the trunk group. The Unified CCE forms a default for this name using
the entries from the Peripheral and Peripheral Name fields.

Extension. Leave this field blank.

Trunk Count. Select Use Trunk Data. When you specify Use Trunk Data, the system software determines
the trunk count dynamically by counting the associated records in the Trunk table.

Configuration Parameters. Leave this field blank.

Description. Enter an optional description.

Step 7 To add trunks to the trunk group, click Add Trunk.
Step 8 Add trunks as desired.
Step 9 Click Save and then click Close.
Step 10 Repeat these steps to create all necessary trunk groups.

Configure Network VRU Bank
The Network VRU Bank allows load balancing across multiple VRUs to occur and eliminates the need for
complex translation-route configuration.

Configure a Network VRU Bank, only if your deployment uses the Unified CCE System PG.

Before you begin

Do this after you configure the following:

• Network VRU

• Network Trunk Group

• All other trunk groups

Procedure

Step 1 From the Configuration Manager, choose Explorer Tools > Network VRU Explorer. The Network VRU
Explorer dialog box opens.

Step 2 Click Retrieve and select your Network VRU.
Step 3 Select the Network VRU Bank tab and click Add.

The Select Trunk Group dialog box opens, displaying the all trunk groups configured on all Unified CCE
System PG peripherals.

Step 4 Select the trunk group associated with the translation routing group on your Unified IP IVR. Make the
appropriate trunk group selection for each Unified IP IVR in your deployment.

Step 5 Click OK.
Step 6 Click Add Label to add a label for the Network VRU Bank. The label must be the CTI Route Point trigger

for the Translation-Routing application on the Unified IP IVR. By default, in the Label tab, the first field
shows the selected Network VRU, not the Network VRU Bank:
a) Click the drop-down list box to show the available Network VRU banks.
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b) Select a Network VRU bank in the drop-down list.
c) Then configure the label for the Network VRU bank.
d) Repeat the steps to configure labels for all of the Network VRU Banks.

If Network VRUBank labels are available, the Router uses themwhen it balances the load between the Unified
IP IVRs. If the Router cannot find an eligible Network VRU Bank labels, it uses the Network VRU label.

Configure services
A service refers to a type of processing that a caller requires. For example, separate services might be defined
for Sales, Support, or Accounts Payable. Services are often associated with a peripheral, and are sometimes
referred to as peripheral services. An agent is assigned one or more skills that in turn is associated with services.
Routing to a Unified CCE service effectively targets an agent assigned to a Unified CCE skill group associated
with the Unified CCE service.

Services on the Unified CCE correspond to CTI Route Points on Unified Communications Manager.

On Unified CCE systems that interface with Unified CVP systems, you must configure two services with
Peripheral Numbers of 1 and 2. However, outside of these services the preferred method of defining Unified
CCE routable tasks is by defining call types.

For the two Unified CVP services, you do not need to configure ServiceMembers, Routes, Peripheral Targets,
or Labels.

Note

Procedure

Step 1 From the Configuration Manager menu, choose Tools > Explorer Tools > Service Explorer. The Service
Explorer dialog box opens.

Step 2 Select the peripheral for which you want to create a service and click Retrieve.
Step 3 Click Add Service.

The Service Configuration window opens.
Step 4 On the Service tab, enter the following:

The Media Routing Domain associated with the service.

Peripheral Number. Enter the number for the service on the peripheral. This field must be unique for all
services for the peripheral, but not necessarily across all peripherals. If you are deploying the Unified CVP,
enter 1 for the first service and 2 for the second service.

Peripheral Name. Enter a name that describes the service.

Enterprise Name. Enter an enterprise name for the service. This name must be unique among all the services
in the enterprise. If you do not enter a value, this name is autogenerated.

Config Param. Not used for the Unified CCE.

Description. Enter any additional information about the service.

Service Level Type. Indicates how the Unified CCE calculates the service level for the service. You can
choose to omit abandoned calls from the calculation, treat them as having exceeded the threshold (negative
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impact on service level), or treat them as answered calls (positive impact on service level). You can also
choose to use the default specified for the peripheral.

Service Level Threshold. Enter the time in seconds, for the service level. The Unified CCE tracks the
percentage of calls answered within this threshold. If this field is negative, the value of the default for the
peripheral is used.

Step 5 On the Advanced tab, enter the following:

Peripheral Service Level. Indicates the type of service level calculation that the peripheral performs for this
service. This setting has no effect because the PG does not report a peripheral service level.

Schedule name. Identifies an imported schedule associated with the service.

Extension. If you are deploying Outbound Option, enter the extension to associate with this service. This
corresponds to a CTI Route Point defined in Unified Communications Manager and is associated with the
PG User.

Step 6 On the Service Members tab, select skill groups to associate with this service.
Step 7 Click Apply.
Step 8 Repeat this procedure to add any other services.

Configure dialed numbers
The dialed number (DN) is the number that the caller dials to start the call and identifies the Unified CCE
routing script to run. Set dialed numbers for ring no answer, dialed number plan entries, and for
Supervisor/emergency calls.

For Unified Communications Manager to generate a route request to the Unified CCE, the cluster associates
the DN with a CTI Route Point for the Unified CCE JTAPI User. Configure the DN in the Unified CCE. After
the Unified CCE receives the route request with the DN, that DN is mapped to a Unified CCECall type, which
is then mapped to a Unified CCE routing script.

You cannot use the DN for a CTI Route Point on a different CTI Route Point in another partition. Ensure that
DNs are unique across all CTI Route Points on all partitions.

Note

Unified CCE generates a unique value for the Label Name list after you configure a dialed number.

Procedure

Step 1 From the Configuration Manager, choose Tools > List Tools > Dialed Number/Script Selector List.

The Dialed Number/Script Selector List dialog box opens.

Step 2 Click Retrieve and then click Add.

The Attributes tab displays.

Step 3 In the Attributes tab, enter values in the following fields:
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Routing client. Choose the enterprise name of the routing client associated with this dialed number. After
you select a routing client and save to the database, this field becomes read only.

Media Routing Domain. The media routing domain associated with the selected dialed number or script
selector.

Dialed number string. Enter the string value that the routing client passes to the Unified CCE for this dialed
number (for example: 8005551212).

Name. Enter the enterprise name for the dialed number. This name must be unique among all dialed numbers
in the system. If you do not enter a value, the name is autogenerated.

Customer. Use the drop-down list to select the customer (Unified CCE instance) associated with the dialed
number.

Default label. Choose the name of the default label for this dialed number. The label must have been previously
defined for it to be in the selection list. Use the Label List tool in the Configuration Manager to define labels.
If the Unified CCE fails to determine a target for the call within the routing client's time-out threshold, then
the default label for the dialed number is used.

Description. Enter a description for the dialed number.

Permit application routing. If you intend to route calls from a parent system to this dialed number, check
this dialog box.

Reserved by IVR. For VRU dialed numbers, check this box. This setting prevents the CallManager PIM
from trying to exert control on the calls arriving on these Route Points.

Step 4 On the DNMapping tab, as desired, clickAdd to specify a call type and other dialing information to associate
with this dialed number.

Step 5 Click Save to enter the dialed number information.
Step 6 Repeat this procedure for any additional dialed numbers.

Configure call types
A call type is a category of Unified CCE routable task. Each call type has a schedule that determines which
routing script or scripts are active for that call type at any time.

There are two classes of call types:

• Voice (phone calls). Voice call types are categorized by the dialed number (DN), caller-entered digits
(CED), and calling line ID (CLID). The CED and CLID can be optional, depending on the call.

• Non-voice (email and text chat). Non-voice call types are categorized by the Script Type Selector,
Application String 1, and Application String 2. Application String 1 and Application String 2 can be
optional, depending on the application.

To facilitate Unified CCE reporting, it is good practice to create separate call types for VRU applications and
queuing applications.

Procedure

Step 1 From the Configuration Manager, select Tools > List Tools > Call Type List.
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The Call Type List dialog box opens.

Step 2 Click Retrieve and then click Add.

The Attributes tab appears.

Step 3 In the Attributes tab, enter values for the following fields:

Name. Enter an enterprise name for the call type. This name must be unique among call types in the system.

Customer. Choose the customer (Unified CCE Instance) from the drop-down list.

Service level threshold. The service level threshold is the target maximum time that a caller spends in a queue
before being connected to an agent.When you set up a peripheral, you specify a default service level threshold
for all services associated with that peripheral. If you enter a negative number, the service level threshold
from the Peripheral table is used.

This field is prepopulated with the default service level threshold for this peripheral and grayed out. If you
wish to override this default, check the Override System Information Default check box to the right of this
field and enter a different value.

You can also set the Service Level in the Configuration Manager with the System Information tool. When
the service level is defined with the Call Type tool, this setting overrides a setting made with the System
Information tool. If service level is not defined with the Call Type tool, but is defined with the System
Information tool, the Unified CCE uses the System Information setting.

Service level type. Indicates how the system software calculates the service level for the service. The default
is the level specified for the associated peripheral. To set a different level type, check the Override System
Information Default check box and select the type you want from the selection box.

Bucket Intervals. Indicates the Bucket Intervals setting for the call type. Bucket intervals are defined with
the Bucket Intervals List tool. If you wish to override the defined default, check the Override System
Information Default check box and select a different Bucket Intervals setting.

Description. Enter an optional description of the call type.

Step 4 Click Save to enter the call type information.

Repeat this procedure to add additional call types.

Configure Variables

Configure Expanded Call Context Variables

Expanded Call Context (ECC) variables are variables that you define and enable in the ConfigurationManager
to store values for a call. You can specify the variable name and data type. The name must begin with the
string "user." ECC variables are in addition to the variables the system software defines for each call
(PeripheralVariable1 through PeripheralVariable10, CallerEnteredDigits, CallingLineID, and so on).

An ECC variable name can be up to 33 bytes long (1–32 usable characters). Use the following naming
convention when creating an ECC variable:

user.<CompanyName>.<VariableDescription>

In this syntax:

• <CompanyName> is the name of your company.
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• <VariableDescription> is a descriptive tag for the variable.

For example:

user.Cisco.AcctNum

Using this naming convention prevents naming conflicts with any third-party applications that interface with
the system software.

For a large corporation, you can break <VariableDescription> down to include the Business Unit, Division,
or other organizational entities.

Note

ECC variables follow these size rules:

• An ECC variable can be either a scalar variable or an array element, each with a maximum length of 210
bytes.

Array types are not supported for an agent request.Note

• The maximum number of elements in an array is 255.

• The maximum buffer size for each scalar variable = 5 + the maximum variable length. The 5 bytes
includes 4 bytes to tag the variable and 1 byte for the null terminator.

• The maximum buffer size for each array = 5 + (1 + the maximum length of an array element) * (the
maximum elements in the array). There is a null terminator for each element, and a null terminator for
the array as a whole.

• Since the internal buffer which stores the variables is 2000 bytes, the total sum of all the maximum buffer
sizes for each variable and each array cannot exceed 2000.

For example, if you intended to use the following:

• A scalar ECC variable with a maximum length of 100 bytes

• A scalar ECC variable with a maximum length of 80 bytes

• An ECC array with a maximum of 9 elements with each element having a maximum length of 200
bytes

Totaled the buffer size is: (5+100) + (5+80) + (5 + (1+200)*9) = 2004. Because this size is too large,
you must change the length of one of the scalar ECC variables or the length of the array ECC variables.

For Web Callback and Delayed Callback to work properly, an ECC variable (also known as a named variable)
must be defined. The Cisco CTI driver supports the use of ECC variables in addition to the standard call
variables associated with a call. Before an ECC variable can be used, it must be defined in the Unified CCE
ECC variable database table.

ECC Variables for Voice MRDs with Collaboration

ECC variables must be configured in Configuration Manager's Expanded Call Variable List tool (for each
integrated application) to route requests using the voice Media Routing Domain.
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For Voice MRDs with Collaboration, the ECC variables are:

• user.ewm.activity.id

• user.ewm.customer.name

Validate ECC Variable Size for CTI Server

Before configuring ECC variables, validate the total size of the ECC variables against the following rules and
limits:

• Because the total size of the buffer used to store the variables in CTI Server internally is 2500 bytes, the
total sum of all the maximum buffer sizes for each scalar variable and arrays must be no greater than
2500.

• The maximum buffer size for each scalar variable = 4 + length of the ECC name + the maximum length
of the variable where the 4 bytes includes a 1 byte tag, 1 byte to define the length, and 2 terminating
NULL characters.

• The maximum buffer size for each array = (5 + length of the ECC name + the maximum length of array
element) * (the maximum number of elements in the array) where the 5 bytes includes a 1 byte tag, 1
byte to define the length, 1 byte for the array index, and 2 terminating NULL characters.

• For example, if you intend to use one scalar ECC variable with a maximum length of 100 bytes named
user.var, one scalar ECC variable with a maximum length of 80 bytes named user.vartwo, and an ECC
array named user.varthree with a maximum of 9 elements with each element having a maximum length
of 200 bytes, the buffer size would be:

(4+8+100) + (4+11+80) + ((5 + 13 + 200)*9)) = 2169

where 8 is the length of user.var, 11 is the length of user.vartwo and 13 is the length of user.varthree.

Enable ECC Variables

Procedure

Step 1 Within the Configuration Manager, double-click Tools > Miscellaneous Tools > System Information.

The System Information window appears.

Step 2 Select the Expanded call context enabled check box.
For additional information, refer to the online Help.

Step 3 Click Save to apply your changes.

Define ECC Variables

Procedure

Step 1 Within the Configuration Manager, double-click Tools > List Tools > Expanded Call Variable List.

The Expanded Call Variable List window appears.
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Step 2 Click Retrieve to enable adding ECC variables.
Step 3 Click Add.

The Attributes property tab appears.

Step 4 Complete the Attributes property tab. See the List Tools Online Help for details on the Attributes property
tab.

Step 5 Click Save to apply your changes.

What to do next

If you change the configuration of any ECC variable with the Expanded Call Variable List tool, restart the
Unified CVP Call Server or VRU PIM to force a renegotiation of the ECC variables.

Configure User Variables

You can also create global user variables; for example, you can create a user variable called usertemp to serve
as a temporary storage area for a string value used by an If node.

After you have defined a user variable, you can then use the Script Editor Formula Editor to access the variable
and reference it in expressions, just as you would with a “built-in” variable.

Each user variable must:

• Have a name that begins with user.

This name cannot contain the dot/period (.) character.Note

• Be associated with an object type, for example, Service. (This enables the system software to maintain
an instance of that variable for each object of that type in the system.)

• Be checked as persistent. A persistent variable maintians its value between script invocations. This allows
you to set the variable in one script and reference later in another script.

Because these variables may be persisted, do not use User Variables to store
sensitive information belonging to the customer or company. Using these variables
to store confidential information could lead to violation of security standards,
such as PCI, the Common Criteria, HIPAA, or FIPS 140-2.

Note

A user variable can store a value up to 40 characters long.

Define User Variables

Procedure

Step 1 Within the Configuration Manager, select Tools > List Tools > User Variable List.

The User Variable List window appears.
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Step 2 In the User Variable List window, click Retrieve to enable Add.
Step 3 Click Add.

The Attributes property tab appears.

Step 4 Complete the Attributes property tab.

The Variable name, Object type, and Data type fields are required. All other fields are optional.
For additional information refer to the online Help.

Note

Step 5 Click Save to apply your changes.

Configure Users

Create Person records

All Unified CCE agents must have a Person record. When you create an Agent record, you can associate the
record with an existing Person record. If you do not associate the Agent record with an existing Person record,
a new Person record is automatically created when you create the agent.

To configure a Person record before configuring an agent, complete the following steps:

Procedure

Step 1 From the Configuration Manager, choose Peripherals > Person > Person List.
The Person List dialog box opens.

Step 2 Click Retrieve and then click Add.
Step 3 in the Attributes tab, enter information in the following fields:

First Name. Enter the person's first name.

Last Name. Enter the person's last name.

Login Name. Enter the person's login name.

Password. Enter a password for the person.

Enable Logins. Check this check box.

Step 4 Click Save and then click Close.
Step 5 Repeat this procedure to add additional Person records.

Associate agents with peripherals

Procedure

Step 1 Select Tools > Explorer Tools > Agent Explorer.
The Agent Explorer dialog box displays.

Step 2 Select the peripheral you want associated with the agent from the drop-down list and click Retrieve.
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Step 3 Click Add Agent to display the Agent configuration tab.
Step 4 In the Agent tab, enter information in the following fields:

Last Name. Enter the agent's last name.

First Name. Enter the agent's first name.

Login Name. Enter the name the agent uses to login. This name must be unique in the enterprise.

Password. Enter the agent's password. This password is validated during the agent login process.

Login Enabled. Check this check box if you want the enable the agent to login.

Select Person. Click this button to select a person to associate with the agent record. You can select a person
for a new agent, an existing agent, or a temporary agent.

Enterprise Name. Enter an enterprise name for the agent that is unique within the enterprise. The default is
a combination of the peripheral name with the agent's first and last name.

Peripheral Name. Enter a name for the agent as known to the peripheral.

Peripheral Number. Enter the agent's login ID. This number identifies the agent to the peripheral. This
number needs to be unique among all agents for the peripheral, but does not need to be unique across all
peripherals. Agent IDs can be up to eleven digits long. The first digit in the ID must be 1 through 9. It cannot
be 0. Also, this number cannot be the same as the extensions on the Unified CommunicationsManager cluster
for this agent. Finally, the ID can not exceed the extension length specified in the Unified Communications
Manager Peripheral Gateway Setup

Step 5 Click the Advanced tab and enter information in the following fields:

Desk Setting. Use the drop-down list to select the desktop settings to be associated with the agent. If you do
not make a selection, the Unified CCE applies the default desk settings defined for the peripheral.

ConfigParam. Use this field to enter any specific configuration parameters that may be required. Make entries
in this field only if instructed to do so by your Cisco support representative.

Description. Enter any other information you want about the agent.

Agent State Trace. Select to enable the agent's state trace control. When enabled, the Unified CCE records
every state transition made by the agent.

Step 6 Click Save.
Step 7 Repeat this procedure to configure additional agents.

Assign Agent Desk Settings

Agent Desk Settings associate a set of permissions or characteristics with specific agents. The settings are
comparable to Class of Service settings on a PBX or ACD. Desk settings are associated with an agent when
you configure the agent. The desk settings are global in scope and you can apply them to any configured agent
on any peripheral within a Unified CCE configuration.

Agent Desk Settings provide a profile that specifies parameters such as whether auto-answer is enabled, how
long to wait before rerouting a call for Ring No Answer, what DN to use in the rerouting, and whether reason
codes are needed for logging out and going not-ready. You must associate each agent with an agent desk
setting profile in the Unified CCE configuration. A single agent desk setting profile can be shared by many
agents. Changes made to an agent's desk setting profile while the agent is logged in are not activated until the
agent logs out and logs in again.
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If Agent Desk Settings are not associated with an agent, the agent is assigned the peripheral default settings,
which depend on the peripheral to which the agent is assigned.

When you configure Agent Desk Settings, you specify the amount of non-active time after which an agent is
automatically logged out, whether wrap up is required following incoming and outbound calls, the amount
of time allocated for wrap up, and the method used for assist and emergency calls. You also specify settings
for the Ring No Answer feature.

Ring No Answer

The Ring No Answer feature, configured in Agent Desk Settings, ensures that when an agent does not answer
a call, the call is taken away from the agent after a specified number of seconds and re-assigned to another
agent or requeued.

When a call is routed to an agent but the agent fails to answer the call within a configurable amount of time,
the Unified Communications Manager PIM for the agent who did not answer changes that agent's state to not
ready (so that the agent does not get more calls) and launches a route request to find another agent. Any call
data is preserved and popped onto the next agent's desktop. If no agent is available, the call can be sent back
to the Unified IP IVR for queuing treatment again. Again, all call data is preserved. The routing script for this
RONA treatment should set the call priority to “high” so that the next available agent is selected for this caller.
In the agent desk settings, you can set the RONA timer and the DN used to specify a unique call type and
routing script for RONA treatment.

This feature behaves and is configured differently depending on whether you deploy the Unified CVP or
Unified IP IVR in the Unified CCE System.

The Dialed Number for Ring No Answer is peripheral-specific. Therefore, each Unified Communications
Manager PG in your deployment must have its own set of Agent Desk Settings configured for it; you cannot
use a particular desk setting across peripherals.

Note

About Ring No Answer with Unified IP IVR

For Unified CCE systems in which you deploy the Unified IP IVR, the Ring No Answer feature ensures that
when an agent does not answer a call the following applies:

• The call is taken away from that agent after ringing for a configurable number of seconds and is rerouted
to a different agent or placed in queue.

• The state of the agent who did not answer the call is changed to “Not Ready.”

Reroute a call on Ring No Answer works as follows for Unified IP IVR:

1. A routing script connects the call to an agent.

2. If the agent does not answer the phone within the Ring No Answer time set in Agent Desk Settings, the
Unified Communications Manager changes the agent's state to “Not Ready” and post routes the call to
Unified CCE.

3. The Unified CCE Router runs a routing script using the dialed number specified in the agent desk setting
record. The routing script associated with the DN typically looks for another agent and routes the call to
that new agent.

4. If no agents are available, the call typically is translation routed or queued to the VRU, or sent to some
other queue point. Queuing treatment is restarted.
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Give the call the highest priority in the queue so that the call is routed to the next available agent.Note

5. Any call data is preserved to be popped onto the agent screen. In addition, a flag is set in the database so
that Unified CCE can report on all of the occurrences of Ring No Answer.

About Ring No Answer with Unified CVP

For Unified CCE systems in which you deploy the Unified CVP, the Unified Communications Manager does
not control the Unified CVP and cannot send an unanswered call back to the Unified CVP for re-queuing.
You configure the Ring No Answer feature to only make the agent “Not Ready” when they do not answer a
call, and use the Unified CVP Router Requery feature to re-queue the call.

As of Release 9.0, the Unified CVP deployment no longer requires that you configure the RNA timer on both
sides (Unified CVP and Unified CCE); configure Ring No Answer (RNA) timeout only in Unified CVP. This
removes the requirement to manually align the relevant Unified CVP and Unified CCE timer configuration.
To configure RNA timeout in Unified CVP, see the Patterns for RNA timeout on outbound SIP calls
section in the Unified CVP OAMP console.

Reroute a call on Ring No Answer works as follows for Unified CVP:

1. A routing script connects the call to an agent by sending a connect message to the Unified CVP. The script
node should have Enable Target Requery enabled. To enable this, edit the node, select Change and check
the Enable Target Requery check box.

2. The agent's phone rings.

3. If the phone is not answered (either via the agent desktop or physically going off-hook) within the Ring
No Answer time set in Agent Desk Settings, Unified CCE makes the agent unavailable, but does not
actually change the agent state to Not Ready until the call is redirected.

4. When the Unified CVP Ring No Answer timeout expires, the Unified CVP sends an EventReport=No
Answer message to the Router instructing it to select another target according to the routing script and
send a Connect message to Unified CVP. The target might be another agent or a VRU label to requeue
the call.

Give the call the highest priority in the queue so that the call is routed to the next available agent.Note

5. Any call data is preserved to be popped onto the second agent screen.

In addition, a flag is set in the database so that Unified CCE can report on all of the occurrences of Ring No
Answer.

Note

6. When the call is redirected from the original agent, the agent's state changes to “Not Ready.”
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Configure Agent Desk Settings

Procedure

Step 1 From the AW server, open Configuration Manager, choose Configure ICM > Enterprise > Agent Desk
Settings > Agent Desk Settings List. The Agent Desk Settings List dialog box opens.

Step 2 Click Retrieve and then Click Add.
Step 3 Fill in the Attributes tab information:

Name. Enter a name for the agent desk settings that is unique within the enterprise.

Ring No Answer Time. Enter the number of seconds (between 1 and 120) that a call may ring at the agent's
station. If you are deploying the Unified CVP, make sure this number is less than the number set for the No
Answer Timeout for Router Requery that you set in the Unified CVP.

If you configure this timer, you do not need to configure the Unified Communications Manager Call Forward
on No Answer for agent extensions in the Unified Communications Manager, unless you want them to be
used when the agent is not logged in. If you set the Unified Communications Manager Call Forward No
Answer time, enter a value at least 3 seconds higher than the Ring No Answer Time on each Unified
Communications Manager node.

Ring no answer dialed number. Enter the Unified CCE DN associated with the routing script that you want
to use to reroute a call that an agent has not answered. If you are deploying the Unified CVP, leave this field
blank.

Logout non-activity Time. Enter the number of seconds (between 10 and 7200) in which the agent can remain
in Not Ready state before Unified CCE automatically logs out the agent.

Work Mode on Incoming. Select whether wrap-up is required following an incoming call. Select an option
from the drop-down list.

Work Mode on Outgoing. Select whether wrap-up is required following an outgoing call. Select an option
from the drop-down list.

Wrap Up Time. Enter the amount of time, in seconds, allocated to an agent to wrap up a call.

Assist Call Method. Select whether Unified CCE creates a consultative call or a blind conference call for a
supervisor assistance request.

Emergency Alert Method. Select whether the Unified CCE creates a consultative call or a blind conference
call for an emergency call request.

Blind conference is not supported if the call may queue on a VRU.

Description. Enter additional optional information about the agent desk settings.

Step 4 Use the following boxes to select or de-select miscellaneous settings:

Auto-answer. Indicates whether calls to the agent are automatically answered. The agent is not required to
take any action to answer the call. If a second call comes in while a call is in progress, the call is not
automatically answered. This is the same behavior as with Unified Communications Manager.

If you enable auto-answer, you must also configure the agent phone in Unified Communications Manager to
turn the speakerphone or headset (or both) to ON. If you turn only the headset to ON, the agent must also turn
the phone headset button to ON.
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In a multi-line enabled environment with auto-answer selected, if you are on a call on your non-ACD line,
the call will not auto-answer. However, if you turn on Unified Communications Manager Auto Answer, the
call will answer.

Idle Reason Required. Indicates whether an agent is required to enter a reason before entering the Idle state.

Logout Reason Required. Indicates whether an agent is required to enter a reason before logging out.

Auto Record on Emergency. Indicates in a record request is automatically sent when an emergency call
request starts.

Cisco Unified Mobile Agent (check box). Enables the Unified Mobile Agent feature so that the agent can
log in remotely and take calls from any phone. For more information about the Unified Mobile Agent, see
the Cisco Unified Contact Center Enterprise Features Guide at https://www.cisco.com/en/US/products/sw/
custcosw/ps1844/products_feature_guides_list.html.

Step 5 Click Save and then click Close.

For any change, you perform in the Agent Desk Settings to take effect, log out and then log in to
the Finesse Agent Desktop.

Note

Designate Agent Supervisor

You can identify an agent as a supervisor.

If you define an agent as a supervisor:

• If single sign-on is disabled either globally or for the agent you want to designate as a supervisor, the
supervisor must have an Active Directory account. If the supervisor does not have an Active Directory
account, the designation fails.

• If single sign-on is enabled either globally or for the agent you want to designate as a supervisor, you
must enter the individual's name in the format that your identity provider requires.

To create an agent who is a supervisor:

Procedure

Step 1 In the Configuration Manager menu, select Tools > Explorer Tools > Agent Explorer. The Agent Explorer
window appears.

Step 2 In the Select filter data box, select the peripheral with which the agent is to associated and click Retrieve.
This enables the Add Agent button.

Step 3 Click Add Agent.

You must add the agent supervisor, as both member and supervisor, to theMember tab on the agent
team list. To get the benefit from the Team layout in Finesse, the agent supervisor must be a member
of the team.

Note

Step 4 In the property tabs on the right side of the window, enter the appropriate property values. Use the Agent Tab
to define the agent and designate the agent as a supervisor. Use the Skill Group Membership Tab to map the
agent to any skill groups. (See the Configuration Manager online help for more information.)
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An agent team can have only one primary supervisor. There is no upper limit to the number of
secondary supervisors for a team. Refer to the online help for instructions on how to assign a primary
supervisor.

Note

Step 5 When finished, click Save.

Create agent teams

You can group individual agents into agent teams that supervisors can manage. Agent teams are assigned to
specific peripherals, so you must assign all agents of a given team to the same peripheral. You assign agents
individually to agent teams.

When configuring agent teams, be aware of the following rules:

• An agent can be a member of only one agent team.

• An agent team can have only one Primary Supervisor.

• A supervisor can be a supervisor of any number of agent teams.

• A supervisor for an agent team can also be a member of that agent team.

• All agents belonging to an agent team and all supervisors for that agent team must be on the same
peripheral.

For more information on team limits, see the appendix on system requirements in the Solution Design Guide
for Cisco Unified Contact Center Enterprise at http://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-implementation-design-guides-list.html.

Procedure

Step 1 From the Configuration Manager, select Configure ICM > Peripherals > Agent Team > Agent Team List.
Step 2 Click Retrieve and then Add to add a new agent team.
Step 3 Click the Attributes tab and enter values in the following fields:

Name. Enter an enterprise name for the agent team that is unique within the enterprise.

Peripheral: Enter the name of the agent team peripheral. You can select the name from the drop-down list.

Supervisor Script Dialed Number: Select a dialed number for the agent team from the drop-down list. If
you have not created a supervisor script, select the default, “none”. When you create the script, return to this
screen and enter the dialed number for the script.

Description: Enter additional information about the agent team.

Step 4 Click the Members tab and click Add.
Step 5 Choose the agents that you to assign to the team and click OK.
Step 6 Click the Supervisor tab and choose the supervisor from the Primary Supervisor drop-down list.
Step 7 To add a secondary supervisor, click the Add button and select a secondary supervisor from the list. Click

OK.
Step 8 Click Save and then click Close.
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Configure Network VRUs
Use the Configuration Manager tool to configure Network VRUs.

After you configure a Network VRU and VRU scripts, you can use the Script Editor to write a routing script
to send a call to the VRU and invoke a specific VRU script.

See Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_user_guide_list.html formore information.

Create Network VRU Target

Procedure

Step 1 Within the Configuration Manager, select Tools > Explorer Tools > Network VRU Explorer.

The Network VRU Explorer window appears.

Step 2 In the Network VRU Explorer window, click Retrieve to enable Add Network VRU .
Step 3 Click Add Network VRU.

The Network VRU property tab appears.

Step 4 Complete the Network VRU property tab.

The Name and Type fields are required. All other fields are optional.

Step 5 Click Save to apply your changes.

Define Network VRU Label

You must associate all VRU Types (except Type 6) with a Network VRU label.

Procedure

Step 1 In the Network VRU Explorer window, clickRetrieve and select the Network VRU you want to add the label
to.

The Label property tab appears.

Step 2 Complete the Label property tab.
The Routing client, Label, and Label type fields are required. All other fields are optional. For additional
information refer to the online Help.

Step 3 Click Save to apply your changes.

Set Default Network VRU and Range of Correlation Numbers

For Network VRUs, you must use the System Information dialog to define a range of correlation IDs so the
system software can communicate with the VRU about the call.
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Procedure

Step 1 Within the Configuration Manager, select Tools > Miscellaneous Tools > System Information.

The System Information window appears.

Step 2 In the System Information window, select the Default Network VRU.
Step 3 Enter the Minimum Correlation Number.
Step 4 Enter the Maximum Correlation Number.

For additional information refer to the online help.

Step 5 Click Save to apply your changes.

Configure scripts

Network VRU scripts

VRU scripts differ from routing scripts. A configured VRU script runs only when the Unified CCE instructs
it to do so from a routing script. A VRU script on the Unified CCE is the configured record for the VRU script
that resides on the VRU system. A VRU script executes to collect digits, play hold music, or perform many
other common functions.

After you configure the VRU scripts, you can use the Script Editor to write a routing script to send a call to
the VRU and invoke a specific VRU script.

For deployments that include the Unified CVP, use the Translation Route to VRU node to send calls to the
Network VRU and invoke VRU scripts. Do not use Translation Route to VRU node for deployments that use
the Unified CCE System PG. Instead, use any one of Queue to Skill Group or Send to VRU nodes.

Routing and administrative scripts

A routing script processes call routing requests from a routing client. Typically it examines several targets
and applies selection rules to find an available qualified agent or a target with the shortest expected delay.
You can set up different routing scripts to execute for different types of tasks. You can define call types in
terms of the telephone number the caller dialed, the number the caller is calling from, and additional digits
entered by the caller. For each call type, you can schedule different routing scripts to execute on different
days or at different times of the day.

An administrative script runs periodically to perform a task, such as setting variables.

Configure Network VRU scripts

Procedure

Step 1 From the Configuration Manager, select Tools > List Tools > Network VRU Script List.

The Network VRU Script List dialog box opens.

Step 2 Click Retrieve and then click Add.
Step 3 On the Attributes tab, enter the configuration information for the VRU script as follows:
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Network VRU. Specify the Network VRU with which this script should be associated.

VRU Script Name. Enter script name; for example, BasicQ.

Name. Enter the script file name; for example, BasicQ.aef

Timeout [seconds]. Enter 180.

Configuration param. Leave blank.

Customer. Choose the same Unified CCE customer you chose for call type from the drop-down list.

Step 4 Check the Interruptible check box.
Step 5 Click Save and the click Close.

Troubleshoot Network VRU scripts

If a timeout occurs on a VRU script, it is possible that the Router does not notify the VRU PIM that a timeout
has occurred. Because the VRU PIM is not informed of the problem, it does not notify the VRU to cancel the
script.

At this point, the options for script flow include the following:

• The failure path in the Router script sends the call to a label, the VRU PIM gets a Connect and, if the
VRU supports it, generates a Cancel message. This is the most common result.

• Before the Router picks a label, the VRU script completes and the VRU sends a Script Result message
to the Router. The Router then sends a Dialogue Failure Event because it is not expecting a Script Result.
This is the next most common result.

• The failure path in the Router script tries to run another VRU script. This is not a common result.

Currently, the best resolution to this problem is to use longer time-outs or create shorter VRU scripts. Be
aware that the failure exit from the Run VRU Script node is a problem that you may need to resolve.

VRU error checking

A special call variable VruStatus, allows you to check the result of the last VRU node (Send To
VRU/Translation Route to VRU/Run VRU Script) that the Unified CCE processed. The following table lists
the values for this variable.

DescriptionMeaningValue

The last VRU node was successful.VRU_SUCCESS0

The last VRU node failed because of a routing or
configuration error.

VRU_ERROR1

The last Send To VRU or Translation Route to VRU node
failed because the routing client did not respond within
20 seconds or the last RunVRUScript node failed because
the timeout limit defined for the script expired.

VRU_TIMEOUT2
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DescriptionMeaningValue

The last VRU node did not complete because the caller
hung up or was otherwise lost. (Because this causes the
routing script to terminate immediately, this value is never
seen.)

VRU_ABORTED3

The last VRU node failed because communication with
the VRU ended unexpectedly.

VRU_DIALOG_FAILED4

The VRU failed because the referenced VRU script was
not found in the Unified CCE configuration.

VRU_SCRIPT_NOT_FOUND5

Configure routing and administrative scripts

After you complete your Unified CCE configuration, you can write routing scripts and administrative scripts.
You create, maintain, and monitor these scripts using the Script Editor.

SeeFor Information about

Configuration Guide for Cisco Unified ICM/Contact Center
Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_installation_and_configuration_guides_list.html

Creating Unified CCE scripts

Scripting and Media Routing Guide for Cisco Unified
ICM/Contact Center Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_user_guide_list.html

Designing scripts for Unified CCE using the
Script Editor

Cisco Unified Contact Center Enterprise Reporting User
Guide at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_user_guide_list.html

Planning scripts for your Unified CCE
reporting needs

Outbound Option Guide for Unified Contact Center
Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps524/prod_installation_guides_list.html

Creating scripts for Outbound Option

Configure Agent Targeting Rules
The Agent Targeting Rules (ATR) configures call routing by specifying the agent extension range, instead
of configuring Device Targets and Labels for every phone/Routing Client. This simplifies the call routing
configuration for the Agent PGs. Also, this feature reduces the amount of memory used by the Router because
a large number of Device Targets and Labels are replaced by a few rules. ATRs are therefore, the preferred
method for installation.

Before you begin

You must configure the PGs and routing clients before you configure the Agent Targeting Rules.

Procedure

Step 1 From the Configuration Manager, choose one of the following:
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• Configure ICM > Targets > Device Target > Agent Targeting Rule.
• Tools > List Tools > Agent Targeting Rule.

The ICM Agent Targeting Rules dialog box opens.

Step 2 Click Retrieve.
Step 3 Click Add.
Step 4 Enter a name for the rule.
Step 5 Select a peripheral where the rule will be associated.
Step 6 Select the rule type:

• Agent Extension

• Substitute Agent Extension: Enter the agent extension prefix and agent extension length.

• Translation Route: Select a Translation Route.

For the Translation Route option, you must also configure the Translation Route DAIS as dialed numbers
associated with the target agent's peripheral routing client in Unified CCE. You must map the dialed
numbers to the route points that are configured in Unified CommunicationsManager and associated with
the JTAPI user. This is necessary to complete the Translation Route Rule.

Step 7 Select one or more routing clients that can initiate the route request.
Step 8 Enter the agent's extension range.
Step 9 Click Save.
Step 10 Test the rule configuration by routing calls from each routing client to each agent extension you defined. If

you defined a range, simplify the test by testing the lower and the upper limits of the agent extension, and a
sampling of the extensions in between the range limits.

Configure translation routes
Use the Translation Route wizard to configure the translation routes for the Unified CommunicationsManager
and VRU peripherals. This wizard automates the correct associations with peripheral targets, labels, and
routes.

Run the Translation Route Wizard only if your Unified CCE solution uses Unified CVP.Note

Procedure

Step 1 In the Configuration Manager, select Tools > Wizards > Translation Route Wizard.

The Translation Route Wizard introductory dialog box opens.

Step 2 Click Next.

The Acquire Lock and Select Configuration Task dialog box opens.

Step 3 Select Create New.
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Step 4 Click Next.

The Define Translation Route dialog box opens. The graphic on the left of the dialog box shows the entities
you are defining while using the Translation Route Wizard.

Step 5 Enter a long and short name for the translation route and, optionally, a description (the short name is used in
forming target names).

Step 6 Click Next.

The Select Configuration dialog box opens.

Step 7 Choose the single peripheral, single routing client configuration from the drop-down list.

The graphic changes to show the configuration you select.

Step 8 Click Next.

The Select Peripheral Gateway, Peripherals, and Services dialog box opens.

Step 9 Enter values for the following fields:

Peripheral Gateway. Choose the gateway target for the translation route.

Peripheral. Choose the single peripheral or the peripheral to route calls to.

Service/Service Array. If the translation route is associated with a single peripheral, choose the service
associated with the translation route. If the translation route is associated with multiple VRUs, then select a
service array.

Step 10 Click Next.

The Select Routing Clients and Dialed Numbers dialog box opens. Use this dialog box to specify the Unified
Communications Manager peripheral (or VRU peripheral) as the routing client from which translation routed
calls originate. For the Unified CCE the dialed number string is not applicable.

Step 11 Click Next.

The Select Network Trunk Groups for Routing Clients dialog box opens. Choose at least one network trunk
group to be used in peripheral targets associated with the translation route.

Step 12 Choose a routing client, select a network trunk group value for it, and click Add.

The Network Trunk Group appears in the list at the bottom of the dialog box.

Step 13 Click Next.

The Configure DAIS dialog box opens.

Step 14 Use this dialog box to specify the DAIS values that map to route points on the VRU. Do one of the following:

• To enter a specific DAIS value, click Add DAIS and enter the value.

• To add a range of DAIS values, typically required by a translation route, click Add DAIS Range.

A dialog box prompts you to enter a starting and ending DAIS value. The Translation Route Wizard
automatically generates the DAIS values in the range.

Step 15 Click Next.

The Configure Label dialog box appears.
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Step 16 Use this dialog box to define a label that maps to the DAIS/CTI route points. A label consists of a prefix and
a suffix. Each DAIS value requires a unique label. Do one of the following:

• Enter prefixes and suffixes individually.

• Use the buttons in this dialog box to set a range of values or to base the prefix or suffix values on the
DAIS values.

Step 17 Click Next.

The Wizard Complete dialog box opens.

Step 18 Click Create Translation Route to create the translation route and its associated entities.

First, the Translation Route Wizard displays a success message and then the dialog box appears.

Step 19 Do one of the following:

• To see details about the translation route you just created, click Run Report.

• To return to the beginning of the Translation Route Wizard and perform a new task, select Start New
Task and click Finish.

• To exit the Translation Route Wizard, click Finish.

You can also use the Translation Route Explorer to create a translation route or to modify a translation route
that you created with the Translation Route Wizard. Select Configuration Manager > Tools > Explorer
Tools > Translation Route Explorer.

Note

Configure Skill Groups or Precision Routing
Skill groups are collections of agents that share a common set of skills. Skill groups are associated with a
peripheral and are members of Services. You can associate agents with one or more skill groups.

To configure skill groups, you create skill groups, add the skill groups to services as members, and assign
agents to one or more skill groups.

Precision routing offers an alternative to skill group routing. Using Unified CCE scripting, you can dynamically
map the precision queues to direct a call to the agent who best matches the precise needs of the caller.

To configure precision routing, you create attributes, assign attributes to agents, create precision queues, and
create routing scripts.

Configure Skill Groups

Add skill groups

You configure skill groups to group agents with similar skills. You can associate agents with one or more
skill groups. Skill groups are associated with a specific Unified Communications Manager PIM. You can
group skill groups from multiple PIMs into Enterprise Skill Groups. You can direct calls to (routed to)
Enterprise Skill Groups to share the load across multiple call centers or Unified Communications Manager
installations. You can do reporting on Enterprise Skill Groups.

Agents are assigned one or more skills by associating the agent with the desired skill group.
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After you create services and skill groups, you associate one or more skill groups with a service by making
them members of that service.

A default skill group is created automatically when you create system PGs. The default skill group acts as a
bucket to capture information about calls not routed by Unified CCE. (A call placed directly to an agent
extension is an example of such a scenario.) If you deploy multichannel applications in your Unified CCE
system, default skill groups are created for each Media Routing Domain that you configure.

An agent must be assigned to at least one skill group to log in.Note

Procedure

Step 1 From the Configuration Manager, select Configure ICM > Peripherals > Skill Group > Skill Group
Explorer.
The Skill Group Explorer dialog box opens.

Step 2 In the Select filter data section, select the peripheral from the drop-down list:
Step 3 Click Retrieve and then click Add Skill group to add a new skill group for the selected peripheral.
Step 4 Click the Skill Group tab and enter values for the following:

Media Routing Domain. Use Cisco_Voice for agents that do not use other media. For more information, see
the Enterprise Chat and Email Installation Guide (for Unified Contact Center Enterprise) at
https://www.cisco.com/c/en/us/support/customer-collaboration/cisco-enterprise-chat-email/
products-installation-guides-list.html.

Peripheral Number. Enter the skill group number as known by the peripheral. This value must be unique
among all skill groups for the peripheral, but does not need to be unique across peripherals.

Peripheral Name. Enter the local name for the skill group. This value must be unique among all skill groups
for the peripheral, but does not need to be unique across peripherals.

Name. The Configuration Manager generates the value for this field. This value is a unique name for the skill
group made up of a default value from the peripheral enterprise name and the skill group peripheral name.

Available Holdoff Delay. For the Unified CCE peripheral type, set this field to 0.

Priority. This field is read-only and defaults to 0.

Extension. Leave blank for the Unified CCE peripheral type.

ICM picks the agent. Check this check box.

Step 5 Click Save and then click Close.
Step 6 Repeat this procedure for any additional skill groups.

Assign skill groups as service members

To make a skill group a member of a service, you establish mappings of skill groups to services. Each skill
group can be mapped to zero, one, or more services. Each service can have zero, one, or more skill group
members.
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Procedure

Step 1 From the Configuration Manager, choose Configure ICM > Peripherals > Service > Service Explorer.
The Service Explorer dialog box opens.

Step 2 Click Retrieve.
Step 3 Click the service that directs the skill group and then click the Service Members tab.
Step 4 On the Service Members tab, click Add to associate a skill group with the service.
Step 5 Click OK.
Step 6 Click Save and then click Close.
Step 7 Repeat this procedure for each skill group you want to associate with a service.

Assign agents to skill groups

Agents must be assigned to at least one skill group in order to log in. You can assign agents to the most
appropriate skill groups according to their talents and skills to ensure that the most appropriate agent for a
request responds to the customer.

Procedure

Step 1 From the Agent Explorer dialog box, choose the Skill Group Membership tab.
Step 2 From the Skill group name list, select the skill groups to which you want this agent assigned.
Step 3 Click Add.

The Add Skill Group Membership box opens, showing the skill groups to which the agent has been assigned.
Step 4 Click OK.
Step 5 Click Save and then click Close on the Agent Explorer dialog box.
Step 6 Repeat this procedure to assign additional agents to skill groups.

You can remove agents from the Skill Group tab if necessary by selecting the agent and clicking Remove,
then Save.

Note

Configure Precision Routing
To configure precision routing, use the Unified CCE Web Administration application, which links to various
precision routing gadgets. To access the application, click the CCE Web Administration shortcut on your
desktop, or copy the following URL into your browser: https://distributor ip/cceadmin.

For more information on precision routing, see the Cisco Unified Contact Center Enterprise Features Guide
at https://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_feature_guides_list.html
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Add Attributes

Procedure

Step 1 Navigate to Unified CCE Administration > Organization > Skills > Attributes.
Step 2 In the List of Attributes window, click New.
Step 3 Complete the following fields on the General tab:

DescriptionRequiredField

Type a unique attribute name. For example, to create
an attribute for mortgage insurance, type mortgage.

yesName

Enter a maximum of 255 characters to describe the
attribute.

noDescription

Select the type: Boolean or Proficiency.noType

Select the default (True or False for Boolean, or a
number from 1 to 10 for Proficiency).

noDefault

Step 4 Click Save.

Search for Agents

The Search field in the Agents tool offers an advanced and flexible search.

Click the + icon at the far right of the Search field to open a popup window, where you can:

• Select to search for agents only, supervisors only, or both.

• Enter a username, agent ID, first or last name, or description to search for that string.

• Enter one or more site names separated by spaces. (Site is an OR search.)

• Enter one or more peripheral set names separated by spaces (Peripheral Set is an OR search). The search
is case-insensitive and does not support partial matches.

Search by department is available only when departments are configured.Note

Assign Attributes to Agents

Procedure

Step 1 With the selected agent displayed, click the Attributes tab.
Step 2 Complete the Attributes tab:

This tab shows the attributes associated with this agent and their current values.
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Click Add to open a popup list of all attributes, showing the name and current default value for each.

a) Click the attributes you want to add for this agent.
b) Set the attribute value as appropriate for this agent.

Add Precision Queue

Procedure

Step 1 Navigate to Unified CCE Administration > Organization > Skills > Precision Queues.

This opens a List of Precision Queues window showing all precision queues that are currently configured.

Step 2 Click New to open the New Precision Queue window. Complete the fields.

DescriptionRequiredName

Enter up to 255 characters to
describe the precision queue.

noDescription

MRDs organize how requests for
media are routed. The system routes
calls to skill groups or precision
queues that are associated with a
particular communicationmedium;
for example, voice or email. This
field defaults to Cisco_Voice.

noMedia Routing Domain
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DescriptionRequiredName

Select the service level type used
for reporting on your service level
agreement.

Service level type indicates how
calls that are abandoned before the
service level threshold affect the
service level calculation.

• Ignore Abandoned Calls (the
default): Select this option if
you want to exclude
abandoned calls from the
service level calculation.

• Abandoned Calls have
Negative Impact: Select this
option if you want only those
calls that are answered within
the service level threshold
time to be counted as treated
calls. The service level is
negatively affected by calls
that abandon within the
service level threshold time.

• Abandoned Calls have
Positive Impact: Select this
option if you consider a call
that is abandoned within the
service level threshold time as
a treated call. With this
configuration, abandoned calls
have a positive impact on the
service level.

yesService Level Type

Enter the time in seconds that calls
are to be answered based on your
service level agreement, from 0 to
2,147,483,647.

The time that you enter in this field
is used to report on service level
agreements and does not affect how
long a call remains in a precision
queue. The length of time a call
remains in a step is determined by
the wait time for each individual
step.

yesService Level Threshold
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DescriptionRequiredName

Select an option to determinewhich
agents receive calls from this
queue.

The ordering of agents does not
dictate the agents who are selected
into a Precision Queue step. Agents
are included or excluded based on
the conditions specified for the step.

• Longest Available Agent (the
default): The default method
of agent ordering for a
precision queue. The call is
delivered to the agent who has
been in the available (or
ready) state the longest.

• Most Skilled Agent: The call
is delivered to the agent who
has the highest competency
sum from all the attributes
pertinent to the Precision
Queue step. In an agent-rich
environment, this can mean
that more competent agents
would be utilized more than
less competent agents.

• Least Skilled Agent: The call
is delivered to the agent who
has the lowest competency
sum from all the attributes
pertinent to the Precision
Queue step.

yesAgent Order

Select the bucket interval whose
bounds are to be used to measure
the time slot in which calls are
answered.

The field defaults to the system
default.

To select a different bucket
interval:

noBucket Intervals

Step 3 Click the numbered Step Builder link (Step 1, Step 2, and so on) to build a precision queue step in the Step
Builder popup window.

Step 4 When you have finished adding, click Save.
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Consider If Formula for Precision Queue

If you are not on the last step of the precision queue, then you can enter a Consider If formula for that step.
A Consider If formula evaluates a call (within a step) against additional criteria. Each time a call reaches a
step with a Consider If expression, the expression is evaluated. If the value for the expression returns as true,
the call is considered for the step. If the value returns as false, the call moves to the next step. If no expression
is provided for a step, the step is always considered for calls.

To add a Consider If formula, type the formula into the Consider If box. Alternatively, you can use the Script
Editor to build the formula and then copy and paste it into the Consider If box. Objects used in Consider If
formulas are case-sensitive. All Consider If formulas that you add to a precision queue must be valid. If you
add an invalid formula, you cannot save the precision queue. To ensure that the formula is valid, use Script
Editor to build and validate the formula.

Only the following scripting objects are valid in a Consider If formula:

• Call

• PQ

• Skillgroup

• ECC

• PQ Step

• Call Type

• Custom Functions (You can create custom functions in Script Editor.)

It is possible that a valid Consider If formula can become invalid. For example, if you delete an object used
in the formula after you create or update the precision queue, the formula is no longer valid.

Consider If Formula Examples

• PQ.PQ1.LoggedOn > 1--Evaluates whether there is more than one agent logged in to this queue.

• CallType.CallType1.CallsRoutedToday > 100--Evaluates whether more than 100 calls of this call type
were routed today.

• PQStep.PQ1.1.RouterAgentsLoggedIn > 1--Evaluates whether there is more than one router agent
logged in to this queue for Step 1.

• CustomFunction(Call.PeripheralVariable1) > 10--Evaluates whether this formula using a custom
function returns a value greater than 10.

Build Precision Queue Steps

Every precision queue must have a step, and every step must have an Expression. An Expression is a collection
of attribute terms.

Procedure

Step 1 Click the numbered step link in the Steps panel (Step 1, Step 2, and so on).

The step number popup window opens.
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Step 2 Build the first step as follows.
a) Click the magnifying glass icon to the right of the Select Attribute field in the Expression 1 panel.
b) Select an attribute from the list.
c) Use the two Select fields to establish the terms of the attribute. Click the first Select field to choose an

operator.

• For Boolean attributes, choices are the operators for Equal and Not Equal.

• For Proficiency attributes, choices are the operators for True, False, Less Than, Less Than or Equal
To, Greater Than, and Greater Than or Equal To.

d) Click the second Select field to choose a value.

• For Boolean attributes, values are True and False.

• For Proficiency attributes, values are numbers from 1 to 10.

Your selection creates an attribute term for the Expression.

Step 3 To add a second attribute to the first Expression, click Add Attribute in the Expression 1 row.
a) Select AND or OR to establish the relationship between the first and second attributes.
b) Repeat steps 2b, 2c, and 2d.

Step 4 Continue to add attributes to Expression 1.

All attributes within an expression must be joined by the same logical operator. They must all be ANDs, or
they must all be ORs.

Step 5 To add a second Expression, click the Add Attribute drop-down in the Expression 1 row and select Add
Expression.

Step 6 Select AND or OR to establish the relationship between the first and second Expressions.
Step 7 Add attributes to Expression 2.
Step 8 Continue to add Expressions as needed.

In this example, a Spanish caller located in the Boston area needs an onsite visit from a technician to repair
his ServerXYZ. An ideal agent should be fluent in Spanish and have the highest proficiency in ServerXYZ.
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This can be seen in Expression 1. Expression 2 allows us to specify that the selected agent must also be from
either Boston or the New England area.

Step 9 When you have completed the step, click OK to add it to the precision queue.
Step 10 To build the next step, click Add Step.

Each successive step is prepopulated with the Expressions and attributes of its predecessor. Decrease the
attribute qualifications and competencies in successive steps to lower the bar such that the pool of acceptable
agents increases.

Step 11 When you have created all steps, you can open any step except the last and enter values in the Consider if
and Wait for fields.

• Consider if is a formula that evaluates a call within a step against additional criteria. (See Consider If
Formula for Precision Queue, on page 119 for more information about Consider If.)

• Wait for is a value in seconds to wait for an available agent. A call will queue at a particular step and
wait for an available agent matching that step criteria until the number of seconds specified. A blank
wait time indicates that the call will proceed immediately to the next step if no available agents match
the step criteria. Wait time defaults to 0 and can take a value up to 2147483647.

Configure routes
The route is a value returned by a routing script that maps to a target or a peripheral. Those targets include
services, skill groups, agents, translation routes, queue points, or CTI route points. The Unified CCE converts
a route to a device target to direct to the request destination.

When you create a route, you associate the route with a service.

Procedure

Step 1 From the Configuration manager, choose Tools > Explorer Tools > Skill Group Explorer.
The Skill Group Explorer dialog box opens.

Step 2 Click Retrieve.
Step 3 Choose the skill group for which you are creating the route.
Step 4 Click Add Route.

The Route tab opens.

Step 5 In the Route tab, enter information in the following fields:

Skill group priority. The value 0 indicates a base skill group. This is the default when there is only one skill
group and there are no priorities.

Name. The enterprise name of the route.

Description. Enter an optional description of the route.

Service Name: The name for the service.
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Step 6 Click Save.

When you break the association between a route and a peripheral, the Unified CCE removes the Route ID
value from all peripheral targets that reference that route.

Caution

Perform Bulk Configuration

Access Bulk Configuration Tools

Procedure

Step 1 Double-click Configuration Manager in the Administration Data Server group or the Administration Client
group.

Step 2 In the Menu selection box, select Tools > Bulk Configuration.
Step 3 From the submenu selection list, select Insert if you need to insert data or Edit if you need to edit.
Step 4 In the next menu selection list, select the type of table with which you need to work.

Add New Records

You can add records by inserting multiple blank rows (records) and filling in the data or by importing the
data.

You can also edit the data you insert when you insert it.

Insert New Records

To insert a new record:

Procedure

Step 1 In the Bulk Configuration > Insertmenu, select the name of the data table to which you want to add records.
The appropriate Insert window opens, automatically displaying one new row.

Step 2 To create additional rows, enter the number of additional rows in the Quantity field and click Insert. The
additional rows are added in the Insert window.

Step 3 Enter the data in the rows:
a) If you want to edit individual fields in the new rows, type the information you want in each of the fields

and skip to Step 8.
b) If you want to edit a column in multiple rows so that a range of values is entered, continue to Step 4.

For other ways of entering data into multiple rows, see Edit Range of Data, on page 125Note

Step 4 Select the rows in the column you want to modify.
Step 5 Click Edit Range. The Edit Range dialog appears.
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Step 6 Enter a prefix (optional), the start value for the range, and a suffix (optional). The generated values are listed
in the dialog.

Step 7 Click OK to close the Edit Range dialog and apply the values to the column you selected.
Step 8 When you have finished setting fields in the new rows, press Enter to apply your changes to the Unified CCE

database.

You can leave empty rows, the system ignores them. No changes are made to the database until you
press Enter.

Note

Import Data

You can import data from a specified text file into the opened database table. You can import whole records
or only columns of data if the data matches (see Step 3 of the following procedure). The process cancels if
any error occurs during the import process.

Procedure

Step 1 In the Insert or Edit window, click Import.
Step 2 In the Import dialog, click File.
Step 3 In the File Open dialog, select the file containing the data that you want to import and click Open.

The Import File Data area displays the first few lines of the opened file.

• When importing data in the Edit mode, the following rules apply:

• The Bulk Configuration tool reads only those records whose primary key values match those of
records in the Edit window.

If a record does not match the primary key value, the record is considered to be an error and a
message box with the primary key value pops up to ask you to correct the problem.

• If any field in the import record is null, the corresponding field value in the grid window become
blank for an edit cell or uses the default value for a drop-down list cell.

• If any field is missing in the import file, the corresponding field in the Edit window remains
unchanged.

• If there is a larger number of records in the file to be imported than the number of rows in the grid,
it is considered an error and a message box pops up asking you to correct it.

• If there is a duplicated primary key in the file to be imported, it is considered an error and a message
box with the duplicated primary key value pops up asking you to correct it.

• After importing, all records imported (including records marked for deletion in the grid) are marked
as “Changed” regardless of whether the value is changed or not.

• After importing, the records display in index order (ordered by logical keys). If you did not sort
before importing, the order appears the same after the import.

• When importing data in the Insert mode, the following rules apply:

• Only a single import is supported and any existing rows are removed from the grid. When you click
Import, the following message box pops up if there is any record in the grid:
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All the existing data will be replaced by the data to be imported.
If you want to retain the current data on the grid please click
the Cancel button then save or export the existing data. Click the
OK button to proceed with the importing.

• After importing, all rows are marked as “New” and the ordering is the same as that in the file
imported from.

• In the Import Insert mode, the tool reads only those records whose primary key values are not
presented. If the primary key field is selected for file to be imported, it is considered an error and a
message box with the primary key field name pops up asking you to correct the problem.

• If any field in the import record is null, the corresponding field value in the grid window becomes
blank for an edit cell or uses the default value for a drop-down list cell.

If headers are included in the imported file, the Add and Remove buttons are not enabled
and you can only import the records as a whole. In that case, skip to Step 6.

Note

Step 4 If the imported data does not contain headers, in the Available Fields list box, select the names of the fields
to import that match the data and click Add.

Step 5 To change the order of the columns, select a column and move it within the list by clicking Up or Down.
Step 6 Click OK. The data is imported into the data table.

Data File Format

The import and export files used by the Bulk Configuration tool can optionally include a header that identifies
the table and columns in the file. The header is followed by one line for each row of data.

The following rules apply to file headers:

• A line beginning with a number sign (#) is a comment and is ignored.

• Blank lines are also ignored.

• The header content is indicated by a line beginning with two underline characters and the word TABLE
or COLUMNS. The following line contains the name of the table or the name of the columns. For
example:

__TABLE

Call_Type __

COLUMNS

CallTypeID EnterpriseName Description Deleted CustomerDefinitionID

• All column names must be on a single line and are separated by Tab characters.

The following rules apply to the data in the files:

• One row of table data per line.

• Column values must be in the same order in all rows. If columns are specified in the header, the
columns in the data rows must be in the same order.

• Column values are separated by a single Tab character.
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• Fields intentionally left blank must be represented by two adjacent Tab characters or a Tab character
at the end of a line. On import, the default value is used for such a value.

• String values may include spaces.

• An error occurs on import if a line contains too few or too many values.

A simple way to create the import file with a valid format is to use Excel and
save the file as Text (Tab delimited) (*.TXT).

Note

Select Data

You can select whole records for importing, exporting, setting security, deleting, or undeleting. Or, you can
select the same field in multiple records for simultaneous editing.

Select Records

Click in the left-most numbered field in a row to select that row and highlight it. Click in any other field in a
row to select the row but not highlight it.

Select One Field in Multiple Records

You can select one edit-control field (when there is no section box in the field) in multiple records in any of
the following three ways:

• Click the field where you want to start and, keeping the left mouse button held down, move the cursor
to the last field.

• Click the field where you want to start. While holding down the Shift key, click the last field.

• Click the field where you want to start. While holding down the Shift key, click the down arrow to select.

• Press Ctrl, then click on each field you wish to select. This allows you to select a discontinuous group
of fields.

Edit Range of Data

You can edit a range of data in a table column in three ways:

Procedure

• Apply a single value to a range of edit-control fields
• Apply a single value to a range of selection-box fields
• Apply a range of values to a range of fields

Apply a Single Value to a Range of Edit-Control Fields

An edit-control field is one you can edit that does not contain a selection box.

To apply a single value to a range of edit-control fields:
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Procedure

Step 1 Make your selection: click the field where you want the range to start and, keeping the left mouse button held
down, move the cursor to the last field in the range.

Step 2 Type the new entry that you want to appear in all the fields.
Step 3 Click Enter or Tab. This applies the change to all the records in the range and moves the focus to the next

data field.

Apply a Single Value to a Range of Selection-Box Fields

To apply a single value to a range of selection-box fields:

Procedure

Step 1 Select the first field where you want the range to start.
Step 2 Press the Shift key and hold it down for steps 3, 4, and 5.
Step 3 Click the selection-box down arrow but keep the left mouse button held down and select the fields you want

in the range.
Step 4 Click the last field in the selection to display the selection list. You can also open the selection box by pressing

Alt + an arrow key.
Step 5 Click your selection.
Step 6 Click Enter or Tab (or any other field). This applies the change to all the records and moves the focus to the

next data field.

Apply a Range of Values to a Range of Fields in a Column

To apply a range of values to a range of fields in a column:

Procedure

Step 1 Select the range of fields in a database column. This enables the Edit Range button.

The Edit Range button does not work for selection-box fields.Note

Step 2 Click Edit Range. The Edit Range dialog displays.
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Figure 2: Edit Range Dialog Box

Step 3 In the Edit Range From field, enter the first number of the range.
Step 4 In the Prefix and Suffix fields, you can optionally enter substrings to appear before or after each value. The

Edit Range dialog lists the generated values.

When entering a numeric range, you may also enter leading zeros to ensure proper alignment (that
is, 001 to 999).

Note

Step 5 Click OK. This applies the changes to the fields you selected in the Insert or Edit window.

Configure Cisco Unified Intelligence Center

Acquire License

Procedure

Step 1 Go to the following URL:

https://software.cisco.com/download/home/282163829/type/282377062/release/11.5%25281%2529

Step 2 Download the CUIC_Premium.lic file.
Step 3 Save the license file in a location where the System Application User can access it.

Sign In to Administration Console
Who can sign in to the administration console: The System Application User who is the default Superuser.

To upload the license, you must sign in to the Unified Intelligence Center Administration Console. This is
the OAMP interface for Unified Intelligence Center. The first person who signs in to the Administration
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application must do so using the user ID and password that were defined for the System Application User
during the installation. This user is the initial Superuser for Unified Intelligence Center Administration.

Procedure

Step 1 Enter this URL: http://<HOST ADDRESS>/oamp, where HOST ADDRESS is the IP address or hostname of
your Controller node.

Step 2 Enter the System Application User ID and password that you defined during installation.

Upload License
After the license file is uploaded to the publisher node, within a minute, it is automatically replicated to all
nodes in the cluster.

Procedure

Step 1 In the Administration application, choose Cluster Configuration > License Management.
Step 2 Click Browse.
Step 3 Navigate to the location where the *.lic file was saved.
Step 4 Click Apply License to load the license.

A message appears indicating that the license file was uploaded successfully and will be distributed to other
nodes (if any) in the cluster in approximately one minute.

The databases are polled once a minute for changes. The license replication is not immediate but
occurs within a minute.

Note

Configure SQL User Account

Procedure

Step 1 Launch Microsoft SQL Server Management Studio on the Unified CCE Administration Client workstation.
Step 2 Navigate to Security > Logins, right-click Logins and select New Logins.

Use these steps to create login accounts for theCisco Unified Intelligence Center reporting data sources and
for Finesse connectivity to the AW Database on the Cisco Finesse Administration page.

Step 3 On the General Screen:
a) Enter the Login Name.
b) Select SQL Server authentication.
c) Enter and confirm the password.
d) Uncheck Enforce password policy.

Step 4 In the Server Roles page, check the following check boxes:
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• public

• securityadmin

• serveradmin

• setupadmin

• sysadmin

Step 5 On the User Mapping page, do the following:

a. Check the Real-time database and Historical database check boxes.

b. In Database role memberships pane, check the following check boxes:

• db_datareader

• db_datawriter

• db_ddladmin

• db_owner

• db_securityadmin

• public

For an SQL user configured to work with Live Data, check the master database check box and
the db_datareader and db_datawriter check boxes (in Database role memberships pane).

Note

Step 6 Click OK.

What to do next

Ensure that you configure SQL User Account on both the primary and secondary AW databases.Note

Related Topics
Configure Live Data with AW, on page 76
set live-data aw-access, on page 248

Configure Data Sources
To integrate Unified Intelligence Center with Unified CCE, youmust configure the following two data sources:

• Unified CCE Historical data source—This data source is added by default to support the Unified CCE
stock historical reports and Unified CCEUser Integration. Complete the Database Host, Database Name,
and the Database User ID and Password fields for this data source and ensure that it is online before
Unified CCE User Synchronization can occur.

• Unified CCE Realtime data source—This data source is added by default to support the Unified CCE
stock real time reports. Complete the Database Host, Database Name, and the Database User ID and
Password fields for this data source.
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Depending on your environment, the Unified CCE Historical and Realtime data sources can point to the same
machine.

You can execute a CLI command to point each node to a unique IP Address for the Unified CCE Historical
or Realtime data source. The command is set cuic properties host-to-ip. For more information about
the CLI, see the Administration Console User Guide for Cisco Unified Intelligence Center at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/products-maintenance-guides-list.html.

To integrate Unified Intelligence Center with Unified CVP, you must add a Unified CVP data source.

A Unified Intelligence Center data source is also installed by default. This data source represents the Unified
Intelligence Center database on the node that stores records for reports, dashboards, and users maintained on
that node. This data is replicated across all nodes in the cluster. You can edit the description for this data
source, but do not change other fields. The Unified Intelligence Center data source for each node is configured
by default to point to that member.

Configure Unified CCE Data Sources

Placeholders for two Unified CCE data sources appear by default on the Data Sources page. These are the
data sources for the data that populates the stock templates. Before you can run reports or can run Unified
CCE User Integration, you must edit the parameters of these data sources to complete the configuration,
including Database Host, Database port, Database Name, User ID and Password.

The two data sources—Unified CCE Historical and Unified CCE Realtime—contain the same information,
but the Unified CCE Historical data source has a lower load volume and is used to gather data for most of the
stock value lists and for Unified CCE User Integration.

Before you can run reports or can run Unified CCEUser Integration, youmust edit the Unified CCEHistorical
data source to complete the configuration for the Database Host Address, Database Name, IP Address, User
ID, and Password.

Procedure

Step 1 From the Unified Intelligence Center Reporting application, click Data Sources drawer on the left panel to
open the Data Sources page.

Step 2 Select the Unified CCE Historical Data Source.
Step 3 Click Edit to open the Data Source Create/Edit page.
Step 4 Complete the fields for the selected data source. See online help for guidance.

The name of the database instance is a required field only for Informix databases.Note

Step 5 Test the data source connection. Troubleshoot, if required.
Step 6 Save the data source.
Step 7 Repeat steps 2 through 6 for the Unified CCE Realtime data source.
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Create Data Source for Cisco Unified CVP Report Data

Procedure

Step 1 Log in to the Unified Intelligence Center at https://<hostname/ IP address of CUIC
Publisher>:8444/cuicui.

Step 2 Select the Data Sources drawer to open the Data Sources page.
Step 3 Click New to open New Data Source window.
Step 4 Complete fields on this page as follows:

ValueField

Enter the name of this data source.

Report Designers and Report Definition Designers do not
have access to the Data Sources page but can see the list of
Data Sources when they create custom reports. To benefit
those users, give a new Data Source a meaningful name.

Name

Enter a description for this data source.Description

Choose Informix.

Type is disabled in Edit mode.Note

Data Source Type

Host Settings

Enter the IP address or hostname for the Unified CVP
Reporting server.

Database Host

Enter the port number. Typically, the port is 1526.Port

Enter the name of the reporting database on the Unified CVP
reporting server. The database name can be cvp_data or
callback.

Database Name

Specify the instance name of the desired database. By default,
this is cvp.

Instance

Choose the correct time zone for the data stored in the
database. In locations that change from Standard Time to
Daylight Savings Time, this time zone is updated
automatically.

Set CVP datasource timezone configuration to
UTC on CUIC.

Note

Timezone

Authentication Settings
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ValueField

Enter the user ID of the Reporting User who is configured in
the Operations Console to access the Unified CVP reporting
database.

(The cvp_dbuser account is created automatically during
Unified CVP Reporting server installation.)

Database User ID

Enter and confirm the password for the database user.Password and Confirm Password

Choose UTF-8.Charset

View or edit the permissions for this datasource forMyGroup
and for the All Users group.

Default Permissions

Select the maximum pool size.

Value ranges from 5-200. The default Max Pool Size value
is 100 and is common for both the primary and secondary
data source tabs.

Max Pool Size

Step 5 Click Test Connection.

If the status is not Online, review the error message to determine the cause and edit the data source accordingly.

Step 6 Click Save to close the Add Data Source window.

The new data source appears on the Data Sources list.

Download Report Bundles
The following Cisco Unified Intelligence Center report bundles are available as downloads from Cisco.com
https://software.cisco.com/download/type.html?mdfid=282163829&catid=null. Click the Intelligence Center
Reports link to view all available report bundles:

• Realtime and Historical Transitional templates - Introductory templates designed for new users. These
templates are simplified versions of the All Fields templates, and are similar to templates available in
other contact center solutions.

• Realtime and Historical All Fields templates - Templates that provide data from all fields in a database.
These templates are most useful as a basis for creating custom report templates.

• Live Data templates - Templates that provide up to the moment data for contact center activity.

• Realtime and Historical Outbound templates - Templates for reporting on Outbound Option activity.
Import these templates if your deployment includes Outbound Option.

• Cisco Unified Intelligence Center Admin Security templates - Templates to report on Cisco Unified
Intelligence Server audit trails, permissions, and template ownership.

Additionally, sample custom report templates are available from the Cisco Developer Network
(https://developer.cisco.com/web/ccr/documentation).
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Import Report Bundles

Procedure

Step 1 Sign in to Unified Intelligence Center at https://<hostname/ IP address of CUIC Publisher>:8444/cuicui, and
click Reports in the left pane.

Step 2 Click Import Report.
Step 3 In the File Name (XML or ZIP file) field, click Browse.
Step 4 Browse to and select the report bundle zip file, and click Open.

Select a report bundle for the version of software deployed in the contact center.

Step 5 Select the location where you want to save the file.
Step 6 Click Import.
Step 7 Choose one:

• If the report or reports do not yet exist, you must provide the data source. From the Data Source for
ValueList drop-down list, select the data source used. Then click Import.

You must select a data source for the value list only if it does not use the same data source as
the report definition. For LiveData, the Data Source for ReportDefinition should be LiveData
JMS DataSource. The Data Source for ValueList should be UCCE Realtime.

Note

• If the report or reports do exist, a message appears asking you if you want to replace the existing report
(which overwrites any report definition changes associated to it). Click Yes, Yes to All, No, or No to
All.

Configure Unified Intelligence Center Administration
Complete the following procedure to configure Unified Intelligence Center Administration.

Procedure

Step 1 Sign in to the Cisco Unified Intelligence Center Administration Console
(https://<hostname>:8443/oamp).

Step 2 Configure the Active Directory tab under Cluster Configuration > Reporting Configuration.
a) For Host Address for the Primary Active Directory Server, enter the IP address of the domain controller.
b) For Port, enter the port number for the domain controller.
c) Complete the Manager Distinguished Name fields that are required for the customer.
d) Enter and confirm the password with which the Manager accesses the domain controller.
e) For User Search Base, specify users and the domain name and any sub-domain names .
f) For Attribute for User ID, select the required option.
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If the Windows domain name and the NETBIOS names are different, do the following: in the
Cisco Unified Intelligence Center Administration Console, underActive Directory Settings,
in the field Attribute for User ID, ensure to select sAMAccountName, and add the NETBIOS
value to set it as default value.

Note

g) Add at least one domain for the UserName Identifier. Do not type the @ sign before the domain name.
h) Set a domain as the default.
i) Click Test Connection.
j) Click Save.

For more details, see the online help.Note

Step 3 Configure syslog for all devices.
a) Choose Device Management > Logs and Traces Settings.
b) For each host address:

• Select the associated servers and click the arrow to expand.

• Select the server name.

• In the Edit Serviceability Settings screen Syslog Settings pane, configure the Primary and Backup
Host. Click Save.

Step 4 Configure SNMP for all devices, if used.
a) Select Network Management > SNMP.
b) Navigate to SNMP and for each server add the following:

• V1/V2c Community Strings.

• Notification Destination.

Configure Cisco Unified Customer Voice Portal

Configure Unified CVP Server

Set Up FTP Server

Procedure

Step 1 Install the FTP Service on the server.
a) Choose Start > Administrative Tools > Server Manager.
b) Expand Roles in the left panel of the Server Manager window.
c) Right-click Web Server (IIS) and click Add Role Services.
d) Check the FTP Server check box and then click Install, installation takes a few moments.
e) When the installation is complete, click Close.
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Step 2 Enable the FTP Service on the server.
a) Choose Start > Administrative Tools > Server Manager.
b) Expand Roles in the left panel of the Server Manager window.
c) Expand Web Server (IIS) and then click Internet Information Services (IIS) Manager.
d) Expand hostname.
e) Right-click Sites and click Add FTP Site.
f) Enter a FTP site name.
g) Enter c:\Inetpub\wwwroot in the Physical path of the FTP site name, and click Next.
h) Enter the IP address of the CVP Server.
i) Select No SSL in SSL Options and then click Next.
j) Check the Anonymous and Basic check boxes.
k) Select All Users from the Allow Access To drop-down list.
l) Check the Read and Write check boxes, and then click Finish.

Step 3 Set the Basic Setting for the FTP Server.
a) Click Sites and then click the FTP server that you have created.
b) Click Basic Settings in the Actions tab and click Connect as.
c) Select Application user (pass-through authentication) option and click OK twice.

Configure Unified CVP Reporting Server

Create Reporting Users

Who can create a user:

• Initially, the System Application User who is the default Superuser.

• Eventually, any Superuser.

Unified CVP reporting users can sign in to Unified Intelligence Center only if they exist in the Administration
console as Superusers or if Active Directory (AD) is configured in the Unified Intelligence Center
Administration console for their domain:

• Superusers who are added are considered to be IP Multimedia Subsystem (IMS) users.

• Users who are authenticated through Active Directory are considered to be Lightweight Directory Access
Protocol (LDAP) users.

Both IMS users and LDAP users can log in to Unified Intelligence Center reporting and are restricted to the
limited Login User role until the Unified Intelligence Center reporting security administrator gives them
additional roles and flags them as active users.

Create Superusers

Procedure

Step 1 Log in to the Cisco Unified Intelligence Center Administration Console (https://<HOST ADDRESS>/oamp).
Step 2 Navigate to Admin User Management > Admin User Management to open the Users page.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.6(1)
135

Initial Configuration
Configure Unified CVP Reporting Server



Step 3 Click Add New to add and configure a new user or click an existing username to edit the configuration for
that user.

This page has three tabs: General, Credentials, and Policy. For information about completing these tabs, see
Administration Console User Guide for Cisco Unified Intelligence Center at https://www.cisco.com/en/US/
products/ps9755/prod_maintenance_guides_list.html or the Administration console online help.

Step 4 Click Save.

Set Up Active Directory Server for LDAP Users

Configure the Active Directory tab in the Cisco Unified Intelligence Center Administration console so that
Unified CVP reporting users can log in to the Unified Intelligence Center reporting application with the user
name and password that is defined in their domain.

Procedure

Step 1 In the Cisco Unified Intelligence Center Administration application, navigate to Cluster Configuration >
Reporting Configuration and select the Active Directory tab.

Step 2 Complete all fields on this page, referring to the online help for guidance.
Step 3 Click Test Connection.
Step 4 When the connection is confirmed, click Save.

Sign In to Cisco Unified Intelligence Center Reporting Interface

Who can sign in to the Unified Intelligence Center reporting interface:

• Initially, the System Application User who is the default Superuser.

• Eventually, any Unified CVP user who was created in the Administration Console as an IMS superuser
or an LDAP user.

Perform the following procedure to sign in to the Unified Intelligence Center reporting interface.

Procedure

Step 1 Sign in to the Cisco Unified Intelligence Center Administration Console (https://<HOST ADDRESS>/oamp).
Step 2 Navigate to Control Center > Device Control.
Step 3 Click on the name of the Member node you want to access. This opens the Cisco Unified Intelligence Center

login page for that member.
Step 4 Enter your user ID and password. The Overview page appears.
Step 5
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Cisco Unified Customer Voice Protocol Reporting User Role Additions

Obtain and Import Report Templates

Obtain Cisco Unified CVP Report Templates

Who can obtain import Unified CVP report templates: any user in your organization.

The Unified CVP reporting template XML files are installed with Unified CVP. Locate them and copy them
to a Cisco Unified Intelligence Center client workstation.

Perform the following procedure to obtain import Unified CVP report templates.

Procedure

Step 1 In the Unified CVP server, locate the Unified CVP template files. These are XML files that reside on the
reporting server in %CVP_HOME%\CVP_Reporting_Templates. You can also find them in the Installation
directory \Downloads and Samples\Reporting Templates.

Step 2 Choose the files and copy them to the client computer from where you can launch the Unified Intelligence
Center Reporting web application.

Import Unified CVP Report Templates

Procedure

Step 1 Launch the Unified Intelligence Center web application using the URL https://<CUCI ADDRESS:8444/cuicui/.
Step 2 Enter CUIC Username and Password.
Step 3 Create a folder to import the reports.

a) Click Reports.
b) From the toolbar, click New > Folder.
c) Enter the folder name and click Save.

Step 4 Import the report templates.
a) Click Reports > New > Import. You will be redirected to the CUIC legacy interface.
b) Click Reports > Import Report.
c) In the File Name (XML or ZIP File) field, click Browse and select the template file to import.
d) In the Save To field, expand the Reports tree and select the folder created to import the report template.
e) Click Import. CUIC validates the Report Definition ID in the template and successfully imports the

template.

When one or more underlying Report Definitions do not exist in CUIC, you will be prompted to
select a data source for the Report Definition and Value Lists. For information on creating Data
Sources and Value Lists, see Cisco Unified Intelligence Center Report Customization Guide at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-user-guide-list.html.

Note
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Configure Unified CVP Operations Console

Enable Unified CVP Operations Console

Complete the following procedure on the Unified CVP OAMP server to enable the Unified CVP Operations
Console.

Procedure

Step 1 Go to Start > Run and type services.msc.
Step 2 Check that Cisco CVP OPSConsoleServer service is running. If it is not, right-click that service and click

Start.
Step 3 Go to Start > All Programs > Cisco Unified Customer Voice Portal > Operation Console to open the

Unified CVP OPSConsole page. If you are using Microsoft Internet Explorer, you will need to accept the
self-signed certificate.

Configure Unified CVP Call Server Component

• There is one Unified CVP server on Side A and one Unified CVP server on side B for the 500 agent
deployment.

• There are two Unified CVP servers on Side A and two Unified CVP server on side B for the 1000 agent
deployment.

Note

Procedure

Step 1 On the Unified CVP OAMP server, go to Start > All Programs > Cisco Unified Customer Voice Portal.
Step 2 Click Operations Console and log in.
Step 3 Navigate to Device Management > Unified CVP Call Server.
Step 4 Click Add New.
Step 5 On the General tab, enter the IP address and the hostname of the Cisco Unified CVP Server. Check ICM,

IVR, and SIP. Click Next.
Step 6 Click the ICM tab. For each of the Cisco Unified CVP Call Servers, retain the default port of 5000 for the

VRU Connection Port.
Step 7 Click the SIP tab:

a) In the Enable outbound proxy field, select No.
b) In the Use DNS SRV type query field, select Yes.
c) Check Resolve SRV records locally.

Step 8 Click the Device Pool tab. Make sure the default device pool is selected.
Step 9 (Optional) Click the Infrastructure tab. In the Configuration Syslog Settings pane, configure these fields as

follows:
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a) Enter the IP address or the hostname of the syslog server.

Example:

Prime server
b) Enter 514 for the port number of the syslog server.
c) Enter the name of the backup server to which the reporting server writes log messages.
d) In the Backup server port number field, enter the port number of the backup syslog server.

Step 10 Click Save & Deploy.
Step 11 Repeat this procedure for the remaining Unified CVP Servers.

Configure Unified CVP VXML Server Component

Procedure

Step 1 In the Unified CVP Operations console, navigate to Device Management > Unified CVP VXML Server.
Step 2 Click Add New.
Step 3 On the General tab, enter the IP address and the hostname of the Cisco Unified CVP Server.
Step 4 Configure the primary and backup CVP Call Servers as follows:

a) For CVP-1A, the primary call server is CVP-1A and the backup call server is CVP-1B.
b) For CVP-2A, the primary call server is CVP-2A and the backup call server is CVP-2B.
c) For CVP-1B, the primary call server is CVP-1B and the backup call server is CVP-1A.
d) For CVP-2B, the primary call server is CVP-2B and the backup call server is CVP-2A.

Step 5 Click the Configuration tab. In the Enable reporting for this CVP VXML Server field, click Yes to
optionally enable reporting. If you do not want to enable reporting, click No.

Step 6 Click the Device Pool tab. Make sure the default device pool is selected. If prompted to restart the primary
and secondary call servers, click No. Do not restart at this time.

Step 7 Click Save & Deploy.
Step 8 Repeat this procedure for all CVP Servers.

Configure Unified CVP Media Server

Procedure

Step 1 In the CVP Operations Console, navigate to Device Management > Media Server.
Step 2 Click Add New.
Step 3 On the General tab, configure the following.

a) Enter the IP address and the hostname of the Unified CVP server.
b) Check FTP Enabled.
c) Either Check Anonymous Access or enter the credentials.
d) Click Test SignIn to validate the FTP access.
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Step 4 Click Save.
Step 5 Repeat Steps 1 through 4 for all CVP Servers.
Step 6 In the CVP Operations Console, navigate to Device Management > Media Server.
Step 7 Change Default Media Server from None to any one of the Unified CVP servers. Then click Set.
Step 8 Click Deploy.

Install Unified CVP licenses

Procedure

Step 1 Sign in to the CVP Operations Console.
Step 2 Choose Bulk Administration > File Transfer > Licenses.
Step 3 In the Select device type field, choose All Unified CVP devices.
Step 4 Browse and select the license file.
Step 5 Click Transfer.
Step 6 Click File Transfer Status to monitor transfer progress.

Configure Gateways

Procedure

Step 1 In the Unified CVP Operations Console, navigate to Device Management > Gateway.
Step 2 Click Add New.
Step 3 On the General tab, configure as follows:

a) Enter the IP address.
b) Enter the hostname.
c) Choose the Device Type.
d) In the Username and Passwords pane, enter the username, password, and enable password.

Step 4 Click Test Sign-in to verify that a connection with the gateway can be established and that the credentials
are correct.

Step 5 Click Save.
Step 6 Repeat for every gateway.

Add Unified CCE Devices

Procedure

Step 1 Log in to the Unified CVP Operations Console.
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Step 2 Choose Device Management > Unified ICM.
Step 3 Click Add New.
Step 4 On the General tab, configure as follows:

a) Enter the IP address.
b) Enter the Hostname.
c) Check Enable Serviceability.
d) Enter the Username.
e) Enter the Password.
f) Confirm Password.
g) Accept the default port.

Step 5 Click Save.
Step 6 Repeat Steps 1 to 5 for all Unified CCE machines.

Add Unified Communications Manager Devices

Procedure

Step 1 Log in to the CVP Operations Console.
Step 2 Choose Device Management > Unified CM.
Step 3 Click Add New.
Step 4 On the General tab, configure as follows:

a) Enter the IP address.
b) Enter the Hostname.
c) Check Enable Synchronization.
d) Enter the Username.
e) Enter the Password.
f) Confirm Password.
g) Accept the default port.

Step 5 Click Save.
Step 6 Repeat Steps 1 to 5 for all Unified Communications Manager Devices.

Add Unified Intelligence Center Devices

Procedure

Step 1 Log in to the CVP Operations Console.
Step 2 Navigate to the Cisco Unified Intelligence Center Device. Choose Device Management > Unified IC.
Step 3 Click Add New.
Step 4 On the General tab, configure as follows:

a) Enter the IP address.
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b) Enter the Hostname.
c) Check Enable Serviceability.
d) Enter the Username.
e) Enter the Password.
f) Confirm Password.
g) Accept the default port.
h) Associate all the existing CVP Reporting Servers.

Step 5 Click Save.

Transfer Scripts and Media Files

Create the notification destination and deploy to all of the Unified CVP devices.

Procedure

Step 1 In the Unified CVP Operations Console, navigate to Bulk Administration > File Transfer > Scripts &
Media.

Step 2 In the Select device type field, select the Gateway.
Step 3 Move all Gateways to Selected.
Step 4 Click Default Gateway files.
Step 5 Click Transfer and select OK at the popup window.
Step 6 Click File Transfer Status to monitor transfer progress.

Configure SNMP

Formore information about SNMP inUnified CCE, see the Serviceability Guide for Cisco Unified ICM/Contact
Center Enterprise at http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_installation_and_
configuration_guides_list.html and SNMP Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_installation_and_configuration_guides_
list.html.

Procedure

Step 1 In the Unified CVP Operations Console, navigate to SNMP > V1/V2c > Community String .
Step 2 Click Add New.

a) On the General tab, name the community string.
b) On the Devices tab, select the required device from the list of available devices.
c) Click Save and Deploy.

Step 3 Create the notification destination and deploy to all of the Unified CVP devices.
a) Navigate to SNMP > V1/V2c > Notification Destination.
b) Click Add New.
c) Complete the fields.
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d) Select the Devices tab and assign the SNMP notification destination to a device.
e) Click Save and Deploy.

Configure SIP Server Group

SIP Server Groups are required for Cisco Unified Communications Manager and Gateways.

Procedure

Step 1 In the Unified CVP Operations Console, navigate to System > SIP Server Group .
Step 2 Create a server group for the Cisco Unified Communications Manager devices:

a) On the General tab, click Add New.
b) Fill in the SRV Domain Name FQDN field with a value that will also be used in the Cluster FQDN

setting in Enterprise Parameters in Communications Manager. For example, cucm.cisco.com.
c) In the IP Address/Hostname field, enter an IP address or hostname for the Unified Communications

Manager node.
d) Click Add.

The FQDN should match the FQDN configured in the Enterprise Cluster FQDN setting on the Cisco Unified
Communications Manager. For example, cucm.cisco.com. Adding the cluster subscriber nodes will load
balance across all sub nodes.

Step 3 Create a server group for the gateway devices:
a) On the General tab, click Add New.
b) In the SRV Domain Name FQDN field, enter the SRV Domain Name FQDN. For example

vxmlgw.cisco.com.
c) In the IP Address/Hostname field, enter an IP address or hostname for each gateway.
d) Click Add.
e) Repeat Steps c and d for each gateway. Click Save.

Add all VXML gateways as appropriate for deployment and branches. Adding all VXML gateways to
the server group will load balance calls across all the member server group gateways.

Step 4 Associate these server groups to all Unified CVP Call Servers:
a) On the Call Server Deployment tab, move all Unified CVP Call Servers from the Available list to the

Selected list.
b) Click Save and Deploy.

Validate Clusterwide Domain Configuration

This validation is required for running calls.

Procedure

Step 1 In the Cisco Unified CM Administration, navigate to System > Enterprise Parameters.
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Step 2 Scroll down to Clusterwide Domain Configuration.

Cluster Fully Qualified Domain Name should match the Server Group name in the Unified CVP SIP Server
Groups Configure SIP Server Group, on page 143.

Configure Dialed Number Patterns

Dialed number patterns are required for:

• Agent Device

• Network VRU

• Ringtone

• Error

Procedure

Step 1 In the Unified CVP Operations Console, navigate to System > Dialed Number Pattern.
Step 2 For each dialed number pattern in the following table:

a) Click Add New.
b) In the Dialed Number Pattern field, enter the dialed number pattern.
c) In the Description field, enter a description for the dialed number pattern.
d) In the Dialed Number Pattern Types pane, check the specified dialed number pattern types.
e) Click Save.

Step 3 After you configure all dialed number patterns, click Deploy.
Step 4 Click Deployment Status to make sure that you applied the configuration.

Dialed number pattern typesDescriptionDialed number pattern

Check Enable Local Static Route.

Route to SIP Server Group and IP
Address/Hostname/Server Group Name are both VXML
Gateway (for example, vxmlgw.cisco.com).

Check Enable Send Calls to Originator.

Ringtone91*

Check Enable Local Static Route.

Route to SIP Server Group and IP
Address/Hostname/Server Group Name are both VXML
Gateway (for example, vxmlgw.cisco.com).

Check Enable Send Calls to Originator.

Error92*
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Dialed number pattern typesDescriptionDialed number pattern

Check Enable Local Static Route.

Route to SIP Server Group and IP
Address/Hostname/Server Group Name are both the
Unified Communications Manager gateway.

Check Enable RNA Timeout for Outbound Calls. The
default timeout value is 60 seconds.

Agent Device.The agent extension
pattern. For example,
enter 500* where the
range of agent
extensions is 5001 to
500999.

Check Enable Local Static Route.

Route to SIP Server Group and IP
Address/Hostname/Server Group Name are both VXML
Gateway (for example vxmlgw.cisco.com).

Check Enable Send Calls to Originator.

Network VRU Label777*

Step 5 Restart the Unified CVP Call Server components.

Configure Cisco Unified Communications Manager

Set Up Device Pool
Complete the following procedure to configure a device pool.

Procedure

Step 1 Choose System > device pool.
Step 2 Click Add new.
Step 3 Provide an appropriate device pool name in Device Pool Name.
Step 4 Select a corresponding Call manager group in Cisco Unified Communications Manager group.
Step 5 Select an appropriate Media resource group list in Media Resource Group List.

Step 6 Click Save.

Set Up Unified Communications Manager Groups
Complete the following procedure to add a Unified CommunicationsManager to the Unified Communications
Manager Group.

Before you configure a Unified Communications Manager Group, you must configure the Unified
Communications Managers that you want to assign as members to that group.
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Procedure

Step 1 Login to the Cisco Unified Communication Manager Administration page, choose System > Server.
Step 2 Make sure that you configured both the Publisher and Subscriber.
Step 3 Choose System > Cisco Unified CM.
Step 4 Click Find.
Step 5 Make sure that you configured both the Publisher and Subscriber.
Step 6 Choose System > Cisco Unified CM Group.
Step 7 Add both Cisco Unified CommunicationsManagers to the Default Unified CommunicationsManager Group.
Step 8 Click Save.

Set Up CTI Route Point
Complete the following procedure to add a computer telephony integration (CTI) route point for agents to
use for transfer and conference.

Procedure

Step 1 Choose Device > CTI Route Point.
Step 2 Click Add New.
Step 3 Use the wildcard string XXXXX to represent the digits of the dialed number configured on theUnified CCE.

For example, the preconfigured dialed number in the Unified CCE for an agent phone is 10112.Note

Step 4 Click Save.

Set Up Trunk
Complete the following procedure to configure a trunk for the Unified CVP Servers.

Procedure

Step 1 Choose Device > Trunk.
Step 2 Click Add New.
Step 3 From the Trunk Type drop-down list, choose SIP Trunk, and then click Next.
Step 4 In the Device Name field, enter a name for the SIP trunk.
Step 5 In the Description field, enter a description for the SIP trunk.
Step 6 Click Next.
Step 7 In the Trunk Configuration window, enter the appropriate settings:

a) Do not check the Media Termination Point Required check box.
b) From the DTMF Signaling Method drop-down list, choose RFC 2833.
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c) From the SIP Profile drop-down list, choose Standard SIP Profile.

Step 8 Click Save.

Set Up Application User

Procedure

Step 1 Choose User Management > Application User.
Step 2 In the Application User Configuration window, click Add New.
Step 3 Enter the User ID that you entered in Set Up Enterprise Parameters , on page 150. Unified CCE defines the

user ID as pguser.
Step 4 Enter a cisco in the Password field of your choice.

If you change this user ID or password in Unified CCE, you must also change the Unified
Communications Manager application user configuration.

Note

Step 5 Add the application user to the Standard CTI Enabled Group and Role:
a) Click Add to Access Control Group.
b) Select the Standard CTI Enabled group.
c) Select the Standard CTI Allow Control of Phones supporting Connected Xfer and conf group.
d) Select the Standard CTI Allow Control of Phones supporting Rollover Mode group.
e) Click Add Selected.
f) Click Save.

Step 6 Associate the CTI route points and the phones with the application user.
Step 7 Click Save.

Set Up SIP Options

Procedure

Step 1 Select Device > Device Settings > SIP Profile.
Step 2 Enter values for the mandatory fields.
Step 3 Select the Enable OPTIONS Ping to monitor destination status for Trunks with Service Type "None

(Default)" check box.
Step 4 Associate this SIP profile on the trunk.
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Set Up Route Pattern

Procedure

Step 1 Choose Call Routing > Route Hunt > Route Pattern.
Step 2 Add a route pattern for the Unified CVP routing clients as follows:

a) Click Add New.
b) In the Route Pattern field, enter 7777777777!
c) In the Gateway/Route List field, choose SIPTRK_to_CVP_1.
d) Click Save.

Step 3 Add a route pattern for the Cisco Unified Communications Manager routing client.
a) Click Add New.
b) In the Route Pattern field, enter 8881111!
c) In the Gateway/Route List field, choose SIPTRK_to_CVP_1.
d) Click Save.

These route patterns must match the network VRU label defined in Unified CCE.Note

Set Up Conference Bridge

Procedure

Step 1 Choose Media Resources > Conference bridge.
Step 2 Add a conference bridge for each ingress/VXML combination gateway in the deployment.
Step 3 In the Conference Bridge name field, enter a unique identifier for the conference bridge name that coincides

with the configuration on the gateway.
Step 4 Click Save.
Step 5 Click Apply Config.

Set Up Media Termination Point

Procedure

Step 1 Choose Media Resources > Media Termination Point.
Step 2 Add a media termination point for each ingress/VXML combo gateway in the deployment.
Step 3 In the Media Termination Point Name field, enter a media termination point name for each ingress/VXML

combo gateway in the deployment.
Step 4 Click Save.
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Step 5 Click Apply Config.

Set Up Transcoder

Procedure

Step 1 Choose Media Resources > Transcoder.
Step 2 Add a transcoder for each ingress/VXML combo gateway in the deployment.
Step 3 In the Device Name field, enter a unique identifier for the transcoder that coincides with the configuration on

the gateway.
Step 4 Click Save.
Step 5 Click Apply Config.

Set Up Media Resource Group
Complete the following procedure to configure amedia resource group for conference bridge, media termination
point, and transcoder.

Procedure

Step 1 Choose Media Resources > Media Resource Group.
Step 2 Add a Media Resource Group for Conference Bridges.
Step 3 Select all the hardware conference bridge resources configured for each ingress/VXML combination gateway

in the deployment and add them to the group.
Step 4 Click Save.
Step 5 Choose Media Resources > Media Resource Group.
Step 6 Add a Media Resource Group for Media Termination Point.
Step 7 Select all the hardware media termination points configured for each ingress/VXML combination gateway in

the deployment and add them to the group.
Step 8 Click Save.
Step 9 Choose Media Resources > Media Resource Group.
Step 10 Add a Media Resource Group for Transcoder.
Step 11 Select all the transcoders configured for each ingress/VXML combination gateway in the deployment and

add them to the group.
Step 12 Click Save.

Set Up and Associate Media Resource Group List
Complete the following procedure to configure and associate a media resource group list. Add the media
resource group list to the following devices and device pool.
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Procedure

Step 1 Choose Media Resources > Media Resource Group List.
Step 2 Add a Media Resource Group list and associate all of the media resource groups.
Step 3 Click Save.
Step 4 Choose System > Device Pool.
Step 5 Click Default.
Step 6 From the Media Resource Group List drop-down list, choose the media resource group added in Step 2.
Step 7 Click Save.
Step 8 Click Reset.
Step 9 Choose Device > CTI Route Point.
Step 10 Click the configured CTI Route Point. For more information, see Set Up CTI Route Point , on page 146.
Step 11 From the Media Resource Group List drop-down list, choose the media resource group added in Step 2
Step 12 Click Save.
Step 13 Click Reset.
Step 14 Choose Device > SIP Trunk.
Step 15 Click the configured SIP Trunk for. For more information, see Set Up Trunk , on page 146.
Step 16 From the Media Resource Group List drop-down list, choose the media resource group added in Step 2
Step 17 Click Save.
Step 18 Click Reset.

Set Up Enterprise Parameters

Procedure

Step 1 Choose System > Enterprise Parameter.
Step 2 Configure the Cluster Fully Qualified Domain Name.

Example:

ccm.hcscc.icm

The Cluster Fully Qualified Domain Name is the name of the Unified Communications Manager
Server Group defined in Unified CVP.

Note

Configure Mobile Agent
Complete the following procedure to configure CTI ports for Unified Mobile Agent.
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Procedure

Step 1 In Unified Communications Manager Administration, choose Device > Phone.
Step 2 Click Add a New Phone.
Step 3 Select CTI Port from the Phone Type drop-down list.
Step 4 Click Next.
Step 5 In Device Name, enter a unique name for the local CTI Port pool name; click OK when finished.

Using the example naming convention format LCPxxxxFyyyy:

a) LCP identifies the CTI Port as a local device.
b) xxxx is the peripheral ID for the Unified Communications Manager PIM.
c) yyyy is the local CTI Port.

The name LCP5000F0000 would represent CTI Port: 0 in a local CTI Port pool for the Unified
Communications Manager PIM with the peripheral ID 5000.

Step 6 In Description, enter text identifying the local CTI Port pool.
Step 7 Use the Device Pool drop-down list to choose the device pool to which you want network CTIPort pool

assigned. (The device pool defines sets of common characteristics for devices.)
Step 8 Click Save.
Step 9 Highlight a record and select Add a New DN.
Step 10 Add a unique directory number for the CTI port you just created.
Step 11 When finished, click Save and Close.
Step 12 Repeat the preceding steps to configure the network CTI Port pool.
Step 13 In Device Name, enter a unique name for the local CTI Port pool name; click OK when finished.

Use the example naming convention format RCPxxxxFyyyy, where:

a) RCP identifies the CTI Port as a network device.
b) xxxx is the peripheral ID for the Unified Communications Manager PIM.
c) yyyy is the network CTI Port.

The name RCP5000F0000 would represent CTI Port: 0 in a network CTI Port pool for the Unified
Communications Manager PIM with the peripheral ID 5000.

Step 14 In Description, enter text identifying the network CTI Port pool.
Step 15 Use the Device Pool drop-down list to choose the device pool to which you want network CTI Port pool

assigned. (The device pool defines sets of common characteristics for devices.)
Step 16 Click Save.
Step 17 Highlight a record and select Add a New DN.
Step 18 Add a unique directory number for the CTI port you just created.
Step 19 When finished, click Save and Close.

Configure Local Trunk
Complete the following procedure to configure Unified Communications Manager for Local Trunk.
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Procedure

Step 1 From Unified Communications Manager Administration choose System > Location info > Location.
Step 2 Click Find to list the locations and add new ones with appropriate bandwidth (8000).
Step 3 For the branch phones, configure each phone so that it is assigned the branch location for that phone.

a) Choose Device > Phone.
b) Click Find to list the phones.
c) Select a phone and set the Location field.

Step 4 Verify that the Cisco AXL Web Service is started and that an Application User is defined and has a role of
Standard AXL API Access.
a) Select Cisco Unified Serviceability from the Navigation drop-down list and click Go.
b) Navigate to Tools > Control Center > Feature Services .
c) Start the Cisco AXL Web Service, if it is not started.
d) FromUnified CommunicationsManager Administration, chooseUser Management > Application User.

Verify you have a user with the role of Standard AXL API Access, or create a new one and add that user
to a group that has the role of Standard AXL API Access.

Deploy SIP Trunk

Complete the following procedure to deploy the SIP trunk for local trunk:

Procedure

Step 1 Using Unified Communications Manager, create a SIP trunk toward the SIP proxy server and select the
Phantom location.

Step 2 Create a SIP trunk for each ingress gateway and make the location of these ingress TDM-IP gateways the
actual branch location.

Step 3 Create a route pattern pointing the Network VRU Label of the Unified Communications Manager routing
client to the SIP trunk toward the SIP proxy.

The SIP proxy should route the Network VRU label of the Unified Communications Manager routing client
to the Unified CVP Servers.

Step 4 For any IP-originated calls, associate the Unified Communications Manager route pattern with the SIP trunk.
Step 5 Using the Unified CommunicationsManager Administration, chooseDevice > Device Settings > SIP Profile

> Trunk Specific Configuration > Reroute Incoming Request to new Trunk based on > Call-Info header
with the purpose equal to x-cisco-origIP.

Step 6 Associate the new SIP profile with the SIP trunk and each ingress gateway.

Configure Outbound Dialer
Complete the following procedure to configure Unified Communications Manager:
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Procedure

Step 1 Log in to the Unified Communications Manager administration page.
Step 2 Select Devices > Trunk.
Step 3 Create a SIP trunk to Outbound gateway.

Configure A-Law Codec
Complete the following procedure to configure Unified Communications Manager.

Procedure

Step 1 Click the System.
Step 2 Select Service Parameters.
Step 3 Select a Server.
Step 4 Select the service as Cisco Call Manager(Active).
Step 5 Under Clusterwide Parameters (system-location and region), ensure the following:

• G.711 A-law Codec Enabled is Enabled.

• G7.11 mu-law Codec Enabled to Disabled.

Step 6 Click Save.

Configure Support for Multiline Agent Control
To enable reporting and control of secondary lines, follow these configuration steps onUnified Communications
Manager. This is required for deployments that have agents using phones that require Join Across Line (JAL)
to be enabled.

Use of JAL and DTAL phone features is deprecated. Do not use these features in new deployments.Note

Multiline Agent Control supports a maximum of four lines per phone, one ACD line and up to three non-ACD
lines.

Unified CCE does not support shared lines for ACD or Non ACD lines.

Several agents cannot share a common extension on their phones. However, one agent can have two phones
that share a common second line. The agent cannot sign in on both phones at the same time.

Note
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Procedure

Step 1 Enable the Application User for the agent peripheral with the role of Standard CTI Allow Control of Phones
supporting Connected Xfer and conf to support phones that require Join Across Line setting.

Step 2 Configure all agent phones with the following parameters:

• Busy Trigger: 1
• Maximum Number of Calls: 2

Configure Caller-Specific Music on Hold

Upload audio file

Follow this procedure to upload an audio file in an existing node or new node in a Cisco Unified
Communications Manager cluster.

If you are uploading to a new node, you must first configure a new and dedicated Music on Hold node that
can have only two Cisco Unified Communications Manager services running: Cisco Call Manager, and Cisco
IP VoiceMedia Streaming Application. Additionally, the Cisco IP VoiceMedia Streaming Application service
must be deactivated in all of the other nodes in the Cisco Unified Communications Manager cluster that
contains the dedicatedMusic onHold node. Formore information, see Installing CiscoUnified Communications
Manager.

Procedure

Step 1 Log in to the Cisco Unified Communications Manager Administration page.
Step 2 Click the Media resources tab, and then click MOH Audio File Management.
Step 3 In the MOH Audio File Management page, click Upload File.
Step 4 In the Upload File window, click Browse, select the audio file that you want to set for Music on Hold, and

then click Open.
Step 5 Click Upload File.

The audio file is now available for use as a Music on Hold audio source.

What to do next

Configure the uploaded audio file so that it can be used as an audio source for Music on Hold.

Configure audio source

Procedure

Step 1 In the Cisco Unified Communications Manager Administration page, click Media resources tab, and then
click Music On Hold Audio Source.

Step 2 Click Add new.
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Step 3 In the MOH Audio Stream Number field, enter a number that you want to assign to the audio file. You cannot
choose a number that has already been assigned to another audio file.

Step 4 In the MOH Audio Source file drop-down menu, choose the audio file that you want to configure as the MoH
audio source.

Step 5 (Optional) The MOH Audio Source Name field automatically populates the name of the audio file that you
chose in the previous step. You can edit the name of the audio file that you selected.

Step 6 Click Save.

What to do next

Configure the audio source in the Unified CCE routing script.

Configure Unified CCE routing script

Procedure

Step 1 Log in to the Unified CCE Administrator workstation.
Step 2 Open the Script Editor.
Step 3 Open the script in which you want to set the caller specific Music on Hold.
Step 4 Set the call variable SIPHeader with the value X-cisco-moh-source~mod~<User Hold MoH Audio File

number>,<Network Hold MoH Audio File number>.

Example:

For example, X-cisco-moh-source~mod~6,7; where 6 and 7 are the numbers that you assigned to the audio
file. In this example, the audio file assigned for number 6 is played when the call is placed on user hold, and
the audio file assigned for number 7 is played when the call is placed on network hold.

• List the new call variable after a Dialed Number (DN) or CallingLineID node. This ensures
that the call is for a particular DN, or from a particular Calling Line ID.

• If only one audio file is specified, the same file is used for both user hold and network hold.

• If the audio stream that you specified is not present in the Cisco Unified Communications
Manager cluster, then the default Music on Hold of the device plays.

Note

Step 5 Click Save.

The audio file is now configured as the source audio file that will play for caller specific Music on Hold.

Configure Cisco Finesse

Configure Contact Center Enterprise CTI Server Settings
Configure the A Side and B Side CTI servers on the primary Finesse server.
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Procedure

Step 1 If you are not already signed in, sign in to the administration console on the primary Finesse server:

http://FQDN of Finesse server/cfadmin

Step 2 Sign in with the Application User credentials defined during installation.
Step 3 In the Contact Center Enterprise CTI Server Settings area, enter the CTI server settings as described in the

following table. Refer to your configuration worksheet if necessary.

DescriptionField

Enter the hostname or IP address of the A Side CTI server.

This value is typically the IP address of the Peripheral Gateway (PG).
The CTI server runs on the PG.

A Side Host/IP Address

Enter the port number of the A Side CTI server. The value of this
field must match the port configured during the setup of the A Side
CTI server.

A Side Port

Enter the ID of the Agent PG Routing Client (PIM).

The Agent PG Peripheral ID should be configured to the same value
for the A Side and B Side CTI servers.

Peripheral ID

Enter the hostname or IP address of the B Side CTI server.B Side Host/IP Address

Enter the port of the B Side CTI server. The value of this field must
match the port configured during the setup of the B Side CTI server.

B Side Port

Check this box to enable secure encryption.Enable SSL encryption

Step 4 Click Save.

Configure Contact Center Enterprise Administration & Data Server Settings
Configure the Contact Center Enterprise Administration & Data Server settings to enable authentication for
Finesse agents and supervisors.

If you are using HTTPS, the first time you access the administration console, you see a browser security
warning. To eliminate browser security warnings each time you sign in, you can trust the self-signed certificate
provided with Finesse or obtain and upload a CA certificate.

Note

Procedure

Step 1 Sign in to the administration console.
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Step 2 In the Contact Center Enterprise Administration &Data Server Settings area, enter the Administration &Data
Server settings as described in the following table. Refer to your configuration worksheet if necessary.

DescriptionField

Enter the hostname or IP address of the Unified CCE Administration
& Data Server.

Primary Host/IP Address

Enter the hostname or IP address of the backup Unified CCE
Administration & Data Server.

Backup Host/IP Address

Enter the port of the Unified CCE Administration & Data Server.

Because Finesse expects the primary and backup
Administration & Data Server ports to be the same, the
Finesse administration console exposes only one port field.
You must ensure that the port is the same for the primary
and backup Administration & Data Servers.

Note

Database Port

Enter the name of the AW Database (AWDB) (for example,
ucceinstance_awdb).

AW Database Name

Enter the domain of the AWDB.Domain

Enter the username required to sign in to the AWDB.Username

Enter the password required to sign in to the AWDB.Password

Step 3 Click Save.

Configure Cluster Settings
Configure the cluster settings for the secondary Finesse node. The secondary Finesse node handles agent
requests if the primary server goes down.

Procedure

Step 1 If you are not already signed in the primary node, sign in to the administration console of the primary node
with the Application User credentials.

Step 2 In the Cluster Settings area, in the Hostname field, enter the hostname of the secondary Finesse server.
Step 3 Click Save.

Restart Cisco Finesse Tomcat
After youmake changes to the Contact Center Enterprise CTI Server, Contact Center Enterprise Administration
& Data Server, or cluster settings, restart Cisco Finesse Tomcat for the changes to take effect.
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After you restart Finesse, it can take approximately 6minutes for all server-related services to restart. Therefore,
you wait 6 minutes before you attempt to access the Finesse administration console.

Note

Procedure

Step 1 Access the CLI and run the following command:

utils service restart Cisco Finesse Tomcat

Step 2 You can enter the command utils service list to monitor the Cisco Finesse Tomcat Service. After Cisco Finesse
Tomcat changes to STARTED, the configured agents can sign in to the desktop.

Check Replication Status

Procedure

Step 1 Access the CLI on the primary Finesse server.
Step 2 Sign in with the Administrator User credentials that are defined during installation.
Step 3 Run the following command:

utils dbreplication runtimestate

This command returns the replication status on both the primary and secondary Finesse servers.

Ensure Agents Have Passwords
Agents who do not have a password defined in Unified CCEConfigurationManager cannot sign in to Finesse.

Agent password is an optional field in Unified CCE, but it is mandatory for Cisco Finesse.

For agents who do not have passwords, you must perform the following steps:

Procedure

Step 1 Launch Unified CCE Configuration Manager.
Step 2 Locate the record for the agent (Agent Explorer > Agent tab).
Step 3 Enter a password, and save the record.
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Ensure Logout Non-Activity Time for Agents is Configured
The Logout non-activity time specifies how long an agent can remain inactive in the Not Ready state before
that agent is signed out of Finesse.

For agents who use the Task Routing interface on Finesse for non-voice tasks, set the Logout non-activity
time to blank.

Perform the following steps to configure Logout non-activity time for an agent.

Procedure

Step 1 Launch the Unified CCE Configuration Manager.
Step 2 Launch Agent Desk Settings List (Tools > List Tools).
Step 3 Select Agent Desk Settings List.
Step 4 In the Logout non-activity time field, enter the number of seconds of agent inactivity while in the Not Ready

state before the system software signs the agent out. You can enter a value between 10 seconds and 7200
seconds.

Step 5 Click Save.
The modified settings are applied to all of the agents who use these agent desktop settings.

Browser Settings for Internet Explorer
If Internet Explorer is used to access the Finesse desktop, certain settings must be configured in the browser
to ensure all features of Finesse work properly.

1. Disable pop-up blockers.

Finesse does not support Compatibility View.When the desktop is running in Compatibility View, Internet
Explorer renders in the standard mode for that version.

2. Configure the following privacy and advanced settings:

a. From the browser menu, select Tools > Internet Options.

b. Click the Privacy tab.

c. Click Sites.

d. In the Address of website box, enter the domain name for the Side A Finesse server.

e. Click Allow.

f. In the Address of website box, enter the domain name for the Side B Finesse server.

g. Click Allow.

h. Click OK.

3. You must enable the following security settings to allow users to sign in:

• Run ActiveX controls and plug-ins

• Script ActiveX controls marked as safe for scripting
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• Active scripting

To enable these settings:

a. From the Internet Explorer browser menu, select Tools > Internet Options.

b. Click the Security tab.

c. Click Custom level.

d. Under ActiveX controls and plug-ins, select Enable for Run ActiveX controls and plug-ins and
Script ActiveX controls marked safe for scripting.

e. Under Scripting, select Enable for Active Scripting.

If the customer is using self-signed CA (Certificate Authority) and their agents use the server's FQDN, there
should not be any certificate errors or warnings when connecting to Finesse over HTTPS.

Note

Browser Settings for Firefox
Complete the following steps to ensure Finesse behaves as expected when it is not the active window.

Procedure

Step 1 Open Firefox and enter about:config in the address bar.
A warning page appears that states, This might void your warranty!.

Step 2 Click I'll be careful, I promise!.
Step 3 In the Search field, enter dom.disable_window_flip.
Step 4 Double-click dom.disable_window_flip to set the value to false.
Step 5 Restart Firefox.

Ensure Agents Can Sign in to Desktop
After the system administrator defines configuration settings and restarts services, agents who have passwords
and operational handsets can sign in to the Finesse Agent Desktop.

Finesse agents can enter either their AgentID or Login name (in the Username field of the desktop login
screen) to sign in. Ensure that each agent's AgentID and Login name are unique across both sets of data. If
one agent's AgentID matches another agent's Login name, neither agent can sign in.

Note

After you restart Finesse, it takes approximately 6 minutes for all server-related services to restart. Therefore,
you should wait 6 minutes before you attempt to sign in to the desktop.

Note
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If you are using HTTPS, the first time you access the agent desktop, you see a browser security warning. To
eliminate browser security warnings each time you sign in, you can trust the self-signed certificate provided
with Finesse or obtain and upload a CA certificate.

Note

Procedure

Step 1 Enter the following URL in the address bar of your browser:

http://FQDN of Finesse server/desktop

Step 2 If you installed the language pack COP file, you can select the language you want to appear on the desktop
from the language selector drop-down list. If you did not install the language pack COP file, the language
selector drop-down list does not appear in the user interface.

If you installed the language pack COP file, you can also select a language by passing the locale as
part of the URL (for example, http://FQDN of Finesse server/desktop?locale=fr_FR) or by changing
your browser preferred language. The default language is English (en_US).

Note

Step 3 Enter your Username, Password, and Extension, and then click Sign In.

If your agent is signed into the Agent Desktop in Single Sign-On Mode or Hybrid Mode, refer to the sections
Sign In to Finesse Desktop Single Sign-On Mode or Sign In to Finesse Desktop Hybrid Mode in the Cisco
Finesse Desktop User Guide for Unified Contact Center Enterprise.

Trust Self-Signed Certificate
Trust the self-signed certificate provided by Finesse to eliminate browser warnings each time you sign in to
the administration console or agent desktop.

If you are not using HTTPS or if you uploaded a CA certificate, you can skip this procedure.

Procedure

Step 1 In your browser, enter the URL for the administration console (https://FQDN of the primary Finesse
server/cfadmin) or the agent desktop (https://FQDN of the primary Finesse server/desktop).

Step 2 Perform the steps in the following table for the browser you are using.
DescriptionOption

If you use
Internet
Explorer:

a. A page appears that states there is a problem with the website's security certificate. Click
Continue to this website (not recommended). This action opens the sign in page for
the administration console (or agent desktop). A certificate error appears in the address
bar of your browser.

b. Click Certificate Error, and then click View Certificates to open the Certificate dialog
box.
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DescriptionOption

c. On the Certificate dialog box, click Install Certificate. This action opens the Certificate
Import Wizard.

If you use Internet Explorer 11, you must add Finesse to your trusted sites
before the Install Certificate option appears (Internet Options > Security >
Trusted Sites > Sites).

After you click Install Certificate, under Store Location, select Current
User to install the certificate for the current user only, or selectLocal Machine
to install the certificate for all Windows users who use this computer.

Note

d. Click Next.

e. Select Place all certificates in the following store, and then click Browse.

f. Select Trusted Root Certification Authorities, and then click OK.

g. Click Next.

h. Click Finish.

i. If a Security Warning dialog box appears that asks if you want to install the certificate,
click Yes.

A Certificate Import dialog box that states the import was successful appears.

j. Click OK.

k. Enter your credentials, and then click Sign In.

If you use
Firefox:

a. A page appears that states this connection is untrusted.

b. Click I Understand the Risks, and then click Add Exception.

c. On the Add Security Exception dialog box, ensure the Permanently store this exception
check box is checked.

d. Click Confirm Security Exception.

The page that states this connection is untrusted automatically closes and the
administration console (or agent desktop) loads.

e. Enter your credentials, and then click Sign In.

f. For the agent desktop only, an error appears that states Finesse cannot connect to the
Cisco Finesse Notification Service and prompts you to add a security exception for the
certificates issued by the Finesse server.

Click OK.
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Obtain and Upload CA Certificate

This procedure only applies if you are using HTTPS.

This procedure is optional. If you are using HTTPS, you can choose to obtain and upload a CA certificate or
you can choose to use the self-signed certificate provided with Finesse.

Note

To eliminate browser security warnings each time you sign in, obtain an application and root certificate signed
by a Certificate Authority (CA). Use the Certificate Management utility from Cisco Unified Communications
Operating System Administration.

To open Cisco Unified Communications Operating System Administration, enter the following URL in your
browser:

https://FQDN of primary Finesse server:8443/cmplatform

Sign in using the username and password for the Application User account created during the installation of
Finesse.

You can find detailed explanations in the Security topics of the Cisco Unified Communications Operating
System Administration Online Help.

Note

Procedure

Step 1 Generate a CSR.
a) Select Security > Certificate Management > Generate CSR.
b) From the Certificate Name drop-down list, select tomcat.
c) Click Generate CSR.

For information on updating Subject Alternate Names (SANs), refer toConfiguration Examples
and TechNotes > Unified CCE Solution: Procedure to Obtain and Upload Third-Party CA
certificates.

Note

To avoid certificate exception warnings, you must access the servers using the Fully Qualified
Domain Name (FQDN).

Do not select "Multi-server (SAN)" as multi-server certificates is not supported with Cisco
Finesse.

Note

Step 2 Download the CSR.
a) Select Security > Certificate Management > Download CSR.
b) From the Certificate Name drop-down list, select tomcat.
c) Click Download CSR.

Step 3 Generate and download a CSR for the secondary Finesse server.

To open Cisco Unified Operating System Administration for the secondary server, enter the following URL
in the address bar of your browser:
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https://FQDN of secondary Finesse server:8443/cmplatform

Step 4 Use the CSRs to obtain the CA root certificate, intermediate certificate, and signed application certificate
from the Certificate Authority.

To set up the certificate chain correctly, you must upload the certificates in the order described in
the following steps.

Note

Step 5 When you receive the certificates, select Security > Certificate Management > Upload Certificate.
Step 6 Upload the root certificate.

a) From the Certificate Purpose drop-down list, select tomcat-trust.
b) In the Upload File field, click Browse and browse to the root certificate file.
c) Click Upload File.

Step 7 Upload the intermediate certificate.
a) From the Certificate Purpose drop-down list, select tomcat-trust.
b) In the Upload File field, click Browse and browse to the intermediate certificate file.
c) Click Upload File.

Step 8 Upload the application certificate.
a) From the Certificate Purpose drop-down list, select tomcat.
b) In the Upload File field, click Browse and browse to the application certificate file.
c) Click Upload File.

Step 9 After the upload is complete, sign out from the Platform Admin page of Finesse.
Step 10 Access the CLI on the primary Finesse server.
Step 11 Enter the command utils service restart Cisco Finesse Notification Service to restart the Cisco Finesse

Notification service.
Step 12 Enter the command utils service restart Cisco Finesse Tomcat to restart the Cisco Finesse Tomcat service.
Step 13 Upload the application certificate to the secondary Finesse server.

You do not need to upload the root and intermediate certificates to the secondary Finesse server. After you
upload these certificates to the primary server, they are replicated to the secondary server.

Step 14 Access the CLI on the secondary Finesse server and restart the Cisco Finesse Notification Service and the
Cisco Finesse Tomcat Service.

Configure DNS on Clients

This procedure is required for uncommon environments where non-hierarchical DNS configuration exists. If
your environment has hierarchical DNS configuration, you do not need to perform this procedure. This
procedure applies to clients that use a Windows operating system. For information about configuring DNS
on Mac clients, see your Apple documentation (www.apple.com/mac).

Note

Configuring DNS on client computers allows the clients to resolve the fully-qualified domain name (FQDN)
of the active Finesse server during a failover.
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Procedure

Step 1 Go to Control Panel > Network and Internet > Network and Sharing Center. (Open the Control Panel,
enter Network Connections in the search bar, and then click View network connections.)

Step 2 Click the appropriate network connection.
A dialog box showing the status of the connection appears.

Step 3 Click Properties.
Step 4 On the Networking tab, select Internet protocol version 4 (TCP/IPv4) or Internet protocol version 6 (TCP/IPv6)

if the client is IPV6, and then click Properties.
Step 5 Click Advanced.
Step 6 On the DNS tab, under DNS server addresses, in order of use, click Add.
Step 7 Enter the IP address of the DNS server that was entered during installation and click Add.
Step 8 If a secondary DNS was entered during installation, repeat Step 5 and Step 6 to add its IP address.

Live Data Reports
Cisco Unified Intelligence Center provides Live Data real-time reports that you can add to the Finesse desktop.

Prerequisites for Live Data

Before you add Live Data reports to the desktop, you must meet the following prerequisites:

• You must have the Live Data reports configured and working in Cisco Unified Intelligence Center.

• Youmust use either HTTP or HTTPS for both Cisco Unified Intelligence Center and Finesse. You cannot
use HTTP for one and HTTPS for the other. The default setting for both after a fresh installation is
HTTPS. If you want to use HTTP, you must enable it on both Cisco Unified Intelligence Center and
Finesse. For information about enabling HTTP for Cisco Unified Intelligence Center, see the
Administration Console User Guide for Cisco Unified Intelligence Center at http://www.cisco.com/c/
en/us/support/customer-collaboration/unified-intelligence-center/products-maintenance-guides-list.html.

• Ensure that user integration synchronization is enabled for Cisco Unified Intelligence Center. For more
information, see the Administration Console User Guide for Cisco Unified Intelligence Center .

• If your deployment uses HTTPS, you must upload security certificates to the Finesse, Cisco Unified
Intelligence Center, and Live Data servers depending your deployment:

Import Certificates FromOn Server

Live Data and Cisco Unified Intelligence CenterFinesse

None requiredLive Data

Live DataCisco Unified Intelligence Center

Finesse, Cisco Unified Intelligence Center, and Live Data are installed with self-signed certificates.
However, if you use the self-signed certificates, agents and supervisors must accept certificates in the
Finesse desktop when they sign in before they can use the Live Data gadget. To avoid this requirement,
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you can provide a CA certificate instead. You can obtain a CA certificate from a third-party certificate
vendor or produce one internal to your organization.

Related Topics
Add Self-Signed Certificates for Live Data, on page 269
Set Up Certificates for Live Data, on page 79

Add Live Data Reports to Finesse

The following sections describe how to add the Live Data reports to the Finesse desktop. The procedure that
you follow depends on several factors, described in the following table.

When to useProcedure

Use this procedure if you want to add Live Data
reports to the Finesse desktop after a fresh installation
or after an upgrade if you have not customized the
default desktop layout.

Add Live Data reports to default desktop layout

Use this procedure if you have customized the Finesse
desktop layout.

Add Live Data reports to custom desktop layout

Use this procedure if you want to add Live Data
reports to the desktop layout for specific teams only.

Add Live Data reports to team layout

Add Live Data Reports to Default Desktop Layout

The Finesse default layout XML contains commented XML code for the Live Data report gadgets available
for the Finesse desktop. The gadgets are divided into two categories: HTTPS version of Live Data gadgets
and HTTP version of Live Data gadgets.

This procedure explains how to add the Live Data report gadgets to the default desktop layout. Use this
procedure after a fresh installation of Finesse. If you upgraded Finesse but do not have a custom desktop
layout, clickRestore Default Layout on the Manage Desktop Layout gadget and then follow the steps in this
procedure. Note that line breaks and spaces that appear in the example text are provided only for readability
and must not be included in the actual code.

Procedure

Step 1 Sign in to the Finesse administration console (https://FQDN of Finesse server:Port
Number(8445)/cfadmin), in which FQDN refers to the fully qualified domain name.

Step 2 Click the Desktop Layout tab.
Step 3 Remove the comment characters (<!-- and -->) from each report that you want to add to the desktop layout.

Make sure you choose the reports that match the method your agents use to access the Finesse desktop (HTTP
or HTTPS).

Step 4 Replace my-cuic-server with the fully qualified domain name of your Cisco Unified Intelligence Center Server.
Step 5 Optionally, change the gadget height.

Example:
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The height specified in the Live Data gadget URLs is 310 pixels. If you want to change the height, change
the gadgetHeight parameter in the URL to the desired value. For example, if you want the gadget height to
be 400 pixels, change the code as follows, replacing 310 with 400:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=400&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName
</gadget>

Tomaintain the optimal display of the gadget with scroll bars, set the value for the gadget height to a minimum
of 200 pixels. If the report does not require scroll bars, for example a one-row report, you can set a smaller
gadget height (for example, 100 pixels). If you do not specify anything for the gadget height (if you remove
the 310 from the URL), it defaults to 170 pixels.

Step 6 Click Save.

After you add a gadget, sign in to the Finesse desktop and make sure it appears the way you want.
If you use a report with a large number of rows, you may want to adjust the gadget height or the
screen resolution on the computer used to access the desktop to make the report easier to read or
make more rows appear on the screen without needing to scroll down.

Agents who are signed in when you change the desktop layout must sign out and sign back in to
see the change on their desktops.

Note

Add Live Data Reports to Custom Desktop Layout

The Finesse default layout XML contains commented XML code for the Live Data report gadgets available
for the Finesse desktop. The gadgets are divided into two categories: HTTPS version of Live Data gadgets
and HTTP version of Live Data gadgets.

This procedure explains how to add the Live Data report gadgets to a custom desktop layout. Note that line
breaks and spaces that appear in the example text are provided only for readability and must not be included
in the actual code.

Procedure

Step 1 Sign in to the Finesse administration console.
Step 2 Click the Desktop Layout tab.
Step 3 Click Finesse Default Layout XML to show the default layout XML.
Step 4 Copy the XML code for the report you want to add from the Finesse default layout XML. If your agents use

HTTP to access Finesse, copy the XML code for the HTTP report. If they use HTTPS, copy the XML code
for the HTTPS report.

Example:

To add the Agent Report for HTTPS, copy the following:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=310&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&
viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName

</gadget>
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Step 5 Paste the XML within the tab tags where you want it to appear.

Example:

To add the report to the home tab of the agent desktop:
<layout>
<role>Agent</role>
<page>
<gadget>/desktop/gadgets/CallControl.jsp</gadget>

</page>
<tabs>
<tab>
<id>home</id>
<label>finesse.container.tabs.agent.homeLabel</label>
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=310&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&
viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName

</gadget>
</tab>
<tab>
<id>manageCall</id>
<label>finesse.container.tabs.agent.manageCallLabel</label>

</tab>
</tabs>

</layout>

Step 6 Replace my-cuic-server with the fully qualified domain name of your Cisco Unified Intelligence Center Server.
Step 7 Optionally, change the gadget height.

Example:

The height specified in the Live Data gadget URLs is 310 pixels. If you want to change the height, change
the gadgetHeight parameter in the URL to the desired value. For example, if you want the gadget height to
be 400 pixels, change the code as follows:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=400&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName
</gadget>

Tomaintain the optimal display of the gadget with scroll bars, set the value for the gadget height to a minimum
of 200 pixels. If the report does not require scroll bars, for example a one-row report, you can set a smaller
gadget height (for example, 100 pixels). If you do not specify anything for the gadget height (if you remove
the 310 from the URL), it defaults to 170 pixels.

Step 8 Click Save.

After you add a gadget, sign in to the Finesse desktop and make sure it appears the way you want.
If you use a report with a large number of rows, you may want to adjust the gadget height or the
screen resolution on the computer used to access the desktop to make the report easier to read or
make more rows appear on the screen without needing to scroll down.

Agents who are signed in when you change the desktop layout must sign out and sign back in to
see the change on their desktops.

Note
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Add Live Data Reports to Team Layout

The Finesse default layout XML contains commented XML code for the Live Data report gadgets available
for the Finesse desktop. The gadgets are divided into two categories: HTTPS version of Live Data gadgets
and HTTP version of Live Data gadgets.

This procedure explains how to add the Live Data report gadgets to the desktop layout of a specific team.
Note that line breaks and spaces that appear in the example text are provided only for readability and must
not be included in the actual code.

Procedure

Step 1 Sign in to the Finesse administration console.
Step 2 Click the Desktop Layout tab.
Step 3 Click Finesse Default Layout XML to show the default layout XML.
Step 4 Copy the XML code for the report you want to add from the Finesse default layout XML. If your agents use

HTTP to access Finesse, copy the XML code for the HTTP report. If they use HTTPS, copy the XML code
for the HTTPS report.

Example:

To add the Agent Report for HTTPS, copy the following:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=310&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName
</gadget>

Step 5 Click the Team Resources tab.
Step 6 Select the team from the list of teams for which you want to add the report.
Step 7 In the Resources for <team name> area, click the Desktop Layout tab.
Step 8 Check the Override System Default check box.
Step 9 Paste the XML within the tab tags where you want it to appear.

Example:

To add the report to the home tab of the agent desktop:
<layout>
<role>Agent</role>
<page>
<gadget>/desktop/gadgets/CallControl.jsp</gadget>

</page>
<tabs>
<tab>
<id>home</id>
<label>finesse.container.tabs.agent.homeLabel</label>
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=310&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&
viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName

</gadget>
</tab>
<tab>
<id>manageCall</id>
<label>finesse.container.tabs.agent.manageCallLabel</label>
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</tab>
</tabs>

</layout>

Step 10 Replace my-cuic-server with the fully qualified domain name of your Cisco Unified Intelligence Center Server.
Step 11 Optionally, change the gadget height.

Example:

The height specified in the Live Data gadget URLs is 310 pixels. If you want to change the height, change
the gadgetHeight parameter in the URL to the desired value. For example, if you want the gadget height to
be 400 pixels, change the code as follows:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=400&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName
</gadget>

Tomaintain the optimal display of the gadget with scroll bars, set the value for the gadget height to a minimum
of 200 pixels. If the report does not require scroll bars, for example a one-row report, you can set a smaller
gadget height (for example, 100 pixels). If you do not specify anything for the gadget height (if you remove
the 310 from the URL), it defaults to 170 pixels.

Step 12 Click Save.

After you add a gadget, sign in to the Finesse desktop and make sure it appears the way you want.
If you use a report with a large number of rows, you may want to adjust the gadget height or the
screen resolution on the computer used to access the desktop to make the report easier to read or
make more rows appear on the screen without needing to scroll down.

Agents who are signed in when you change the desktop layout must sign out and sign back in to
see the change on their desktops.

Note

Modify Live Data Stock Reports for Finesse

This procedure describes how to modify the Live Data stock reports in Cisco Unified Intelligence Center and
add the modified report to the Finesse desktop layout. Note that line breaks and spaces that appear in the
example text are provided only for readability and must not be included in the actual code.

To make sure the modified gadget renders in the Finesse desktop, you must give the appropriate permission
for that report in Cisco Unified Intelligence Center.

Note

Procedure

Step 1 Sign in to the Finesse administration console.
Step 2 Click the Desktop Layout tab.
Step 3 Click Finesse Default Layout XML to show the default layout XML.
Step 4 Copy the gadget URL for the report you want to modify from the Finesse default layout XML and paste it

into a text editor.
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Example:

If you want to modify the Agent Report for HTTPS, copy the following URL and paste it into a text editor:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=310&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName
</gadget>

Step 5 In Cisco Unified Intelligence Center, in Edit view of the report, select the view for which you want to create
a gadget URL and then click Links.

The HTML Link field displays the permalink of the customized report.

Step 6 Copy the permalink of the customized report from the HTML Link field, and paste it in a text editor. Then
copy the viewId value from this link into the desired view.

Example:

Copy the viewId, which is underlined in this example, from the permalink for the report.

https://<Server Name>:8444/cuic/permalink/PermalinkViewer.htmx?
viewId=5C90012F10000140000000830A4E5B33&linkType=htmlType&viewType=Grid

Step 7 Replace the desired viewId value in the gadget URLwith the viewId value from the permalink of the customized
report.

Step 8 Replace my-cuic-server with the FQDN of the Cisco Unified Intelligence Center Server.
Step 9 Add the customized gadget URL to the desktop layout XML in the Manage Desktop Layout gadget and click

Save.

After you add the gadget, sign in to the Finesse desktop and make sure it appears the way you want.
If you use a report with a large number of rows, you may want to adjust the gadget height or the
screen resolution on the computer used to access the desktop to make the report easier to read or
make more rows appear on the screen without the need to scroll.

Agents who are signed in when you change the desktop layout must sign out and sign back in to
see the change on their desktops.

Note

Initial Configuration Troubleshooting

ThenIf

1. Clear your browser cache (delete browsing history and cookies).

2. If the problem persists, restart the Cisco Finesse Tomcat service or
restart the Finesse server.

The administration console does
not load after a fresh installation.
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ThenIf

Agents cannot sign in to the
desktop after a fresh installation.
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ThenIf

1. Verify that the agent ID and password are correct.

Finesse agents can use either their loginID or loginName
to sign in. Ensure that each agent's loginID and

Note

loginName are unique across both sets of data. If one
agent's loginID matches another agent's loginName,
neither agent can sign in.

2. Verify that a valid domain was configured during installation and
that forward and reverse DNS are set up correctly. To check whether
DNS was configured during installation, check the install.log for
the following:

InstallWizard|USER_ACTION_BTN_PUSH: Screen =DNSClient
Configuration, button pushed = No|<LVL::Info

The precedingmessage indicates that DNSwas not configured during
the installation. Reinstall Finesse and configure the DNSwith a valid
domain.

3. Verify that the agent is configured in Unified CCE.

4. Verify that the AWDB is configured correctly.

a. Check the realm.log for the following line:

"ERROR
com.cisco.ccbu.finesse.realms.ccerealm.CCERealmConfig -
Cannot connect to any AWDB! Ensure that at least one AWDB
is configured properly and running!"

This line indicates that Finesse cannot connect to the AWDB.

b. Check that the values entered in the Contact Center Enterprise
Administration & Data Server Settings gadget are correct.

• Verify that the username entered is a Windows domain
user.

• Verify that the username is not prepended with the domain
(for example, domain\username).

• Verify that the port configured is open to the Finesse server.

c. Check that the AWDB is set up correctly and running.

• The AWDBSQL server must useWindows authentication.

• Verify that the AWDB server is up and that the Distributor
service is running.

5. Restart Cisco Finesse Tomcat on the primary and secondary Finesse
servers.

6. Verify that the agent's device is properly configured in Unified
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ThenIf

Communications Manager and is active.

Configure SQL User Account for Outbound Options High
Availability

Complete these steps on both sides of the Logger to configure the Microsoft SQL User for Outbound Options
High Availability database operations:

Procedure

Step 1 Launch Microsoft SQL Server Management Studio on the Logger.
Step 2 Navigate to Security > Logins, right-click Logins and select New Logins.
Step 3 On the General Screen:

a) Enter the login name.
b) Select SQL Server authentication.
c) Enter and confirm the password.

Step 4 On the Server Roles page, select the sysadmin check box.
Step 5 Navigate to Security>Logins>NT AUTHORITY\SYSTEM, right-click Properties.
Step 6 On the server roles page, check the sysadmin check box.
Step 7 Click OK.
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C H A P T E R 6
Upgrade Overview

• Multistage Upgrades and Maintenance Windows, on page 175
• Unified CCE Contact Center Upgrade Flowcharts, on page 178
• Silent Upgrade, on page 182
• Unified CCE Release 11.6(1) Upgrade Overview, on page 182
• Ensure Campaigns are not Lost on Upgrade, on page 184

Multistage Upgrades and Maintenance Windows
A Unified CCE solution upgrade likely involves a multistage process; components are grouped in several
stages for upgrading. At each stage in the upgrade, the upgraded components must interoperate with components
that have not yet been upgraded to ensure the overall operation of the contact center. Therefore, it is important
to verify this interoperability during the planning stages of the upgrade.

Before upgrading a production system, perform the upgrade on a lab system that mirrors your production
system to identify potential problems safely.

The following table details the required sequence for upgrading Unified CCE solution components, and the
minimum component groupings that must occur together within one stage. Follow each stage to completion
within one maintenance window. Eachmaintenance windowmust accommodate any testing required to ensure
system integrity and contact center operation.

You can combine more than one complete stage into a single maintenance window, but you cannot break any
one stage into multiple maintenance windows.

Upgrade the components that apply to your Unified CCE contact center as follows:
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NotesComponentsComponent GroupStage

SSO is an optional feature and exchanges authentication and
authorization details between an identity provider (IdP) and
an identity service (IdS).

If you upgrade to 11.6(1) from 11.5(x) with SSO enabled
then upgrade the standalone Cisco IdS server before
upgrading other components like Cisco Unified Intelligence
Center (CUIC), and Finesse.

For co-resident configurations, CUIC must be at the same
version as Finesse. Upgrade both, CUIC and Finesse in the
same maintenance window.

Install the Identity Service. See the Installation Task Flow
for Cisco Identity Service section in the Cisco Unified
Contact Center Enterprise Features Guide at
https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-feature-guides-list.html

• IdS ServerIdentity Service
(IdS)/Single
Sign-On(SSO)

0

• Cisco FinesseAgent and supervisor
desktops

1

• Cisco Unified Customer
Voice Portal (CVP)
(Operations Console,
Reporting Server, Call
Server/VXMLServer,
Unified Call Studio)

Queuing and
self-service*

2

• IOS Gateways (If used
for ingress access only.
If used for Outbound
Option Dialer, see Stage
6.)

• CVP VXML Gateways

Gateways3

Cisco Unified Intelligence Center 11.6(1) supports TLS 1.2
only. For Cisco Unified Intelligence Center 11.6(1) to be
compatible with releases earlier than Unified CCE Release
11.6(1), run the CLI command set client tls min-version.
This command allows you to set the minimum TLS version
in the client for outbound SSL connections to TLS 1.0 or
1.1. Restart the system for the changes to take effect.

For information about the CLI command to display the
current TLSminimum version for client, see Transport Layer
Security CLI Commands, on page 258.

• CUIC serverReporting server4
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NotesComponentsComponent GroupStage

• Unified CCE Router

• Unified CCE Logger

• Admin & Data server
(AW/HDS/DDS)

• Standalone Live Data (if
Deployed)

• CUIC Reporting
Templates

• CCMP

• Administration Client

Central Controller5

Everything that resides on one virtual machine must be
upgraded together.

You can have many PGs located on different virtual
machines. You can upgrade each PG virtual machine in its
own maintenance window.

• Agent (Unified
Communications
Manager) PG or System
PG, plus

• CTI Server

• CTI OS Server

• Outbound Option
Dialer and SIP IOS
Gateway

• VRU PG (if collocated
with Agent PG on VM)

• MR PG (if collocated
with Agent PG on VM),
plus

• Unified CCE Gateway
PG (if collocated with
Agent PG on VM)

Peripherals6
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NotesComponentsComponent GroupStage

You can have many PGs located on different virtual
machines. You can upgrade each PG virtual machine in its
own maintenance window.

• MRPG (if not collocated
with Agent PG on VM),
plus

• VRU PG (if not
collocated with Agent
PG on VM)

• Unified CCE Gateway
PG (if not collocated
with Agent PG on VM)

• CRM connector

Peripherals7

You can have many desktops located in many different sites.
You can upgrade CTI OS desktops in multiple maintenance
windows; the later upgrade stages are not dependent on the
completion of this stage.

• CTI OS
(Agent/Supervisor
Desktops)

Agent desktop client
software

8

(Recursive,
see Notes)

If you upgrade to CUCM12.5 on theM4 servers,
ensure that you deploy CUCM off-box. CUCM
12.5 on-box deployment are only supported for
M5 servers.

Note

For more information, refer to the Virtualization for Unified
Contact Center Enterprise, at http://www.cisco.com/c/dam/
en/us/td/docs/voice_ip_comm/%20uc_system/virtualization/
%20virtualization-unified-contact-center-enterprise.html.

• Cisco Unified
Communications
Manager (Unified
Communications
Manager)

• JTAPI onAgent (Unified
Communications
Manager) PG

Call Processing9

MediaSense is a standalone application that you can upgrade
at any time after IOS Gateway upgrades3.

• MediaSenseMedia RecordingAny (See
Notes)
*If you are using Unified IP IVR for self-service and queueing, see Getting Started with Cisco Unified IP IVR.

3 UCCE 11.6(1) supports only Cisco MediaSense 11.5.

Unified CCE Contact Center Upgrade Flowcharts
The following diagram illustrates the solution-level upgrade flow for a Cisco Unified Contact Center Enterprise
solution upgrade.
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• When you upgrade Unified CVP to Release 12.0, the following considerations apply:

• If you are upgrading Cisco VVB to Release 12.0, upgrade Unified CVP and Cisco VVB to Release
12.0 in the same maintenance window.

• If you are upgrading to Unified CVP, Release 12.0 with VVB, Release 11.6(1), you must install
VVB, Release 11.6(1) ES84 before you upgrade Unified CVP to Release 12.0.

• Cisco VVB, Release 11.5(1) is incompatible with Unified CVP, Release 12.0.

Note
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Silent Upgrade
There are situations when silent upgrade can be used in running an installation wizard. You can run a silent
installation while performing a fresh install or an upgrade.

For more information, see Silent Installation, on page 58.

Related Topics
Silent Installation, on page 58

Unified CCE Release 11.6(1) Upgrade Overview
Before you upgrade to Unified CCE Release 11.6(1), ensure that Unified CCE Release 11.x is installed on
your machine. If you use Unified CCE Release 10.0(x) or Release 10.5(x), first upgrade to Unified CCE
Release 11.0(1) using 11.0 ICM-CCE-CCHInstaller.

The supported upgrade paths to 11.6(1) are as follows:

• Release 10.0(x) to Release 11.0(1), followed by 11.6(1)
• Release 10.5(x) to Release 11.0(1), followed by 11.6(1)
• Release 11.0(1) to 11.6(1)
• Release 11.0(2) to 11.6(1)
• Release 11.5(1) to 11.6(1)

Any other Maintenance Release on 11.x needs to be removed before upgrading to 11.6(1). It may also be
possible to upgrade directly to a Maintenance Release on top of 11.6(1) from other MR not mentioned in the
above list.

For more information on available MR, see https://software.cisco.com/download/
release.html?mdfid=268439622&flowid=46046&softwareid=280840583

Note

See the Cisco Unified Contact Center Enterprise Installation and Upgrade Guide at http://www.cisco.com/
c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-guides-list.html
for instructions on upgrading to Unified CCE Release 11.0.

For more information on the uninstallation process, see the section Uninstall Methods, on page 237

.

As part of the upgrade of CCE servers, self-signed certificates employed by CCE web applications like CCE
web administration tool and Websetup, may get regenerated. You must add the new certificates to the trust
list on the appropriate end devices.

Note

As CCE 11.6 enforces the use of TLS 1.2 in the entire solution, an upgrade to SQL Server 2014 SP2 is a
prerequisite before upgrading to 11.6(1).

Note
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Related Topics
Transport Layer Security Version 1.2 Required, on page 4

Upgrade to Unified CCE Release 11.6(1)

Before you begin

• An upgrade to Release 11.6(1) requiresWindows Update KB2919355 (Hotfix). If you applied aWindows
update sinceMarch 2014, this update should be installed. To determine if thisWindows Hotfix is installed,
from your Control Panel go to Programs > Programs and Features. Click View installed updates.

Make sure that Windows Update is not running in parallel when you install the Release 11.6(1) patch.

• If you are upgrading from 11,0(1), 11.0(2) or 11.5(1), youmust run themandatoryCustomRegionFixTool
before upgrading to Release 11.6 to avoid any region data corruption.

CustomRegionFixTool.exe: Before upgrading Unified CCE, run the CustomRegionFixTool.exe tool
on machines that have <instance name>_sideA, <instance name>_sideB, and <instance name>_awdb
databases.

You can download CustomRegionFixTool.exe from Cisco.com.

• Before upgrading Unified CCE, update the OS and SQL Server on your VMs to meet the requirements
listed on the Unified CCE Solution Compatibility Matrix. Your upgrade can fail if the OS and SQL
Server versions do not meet these requirements.

• Database partitioning, if enabled, prevents Unified CCE Release 11.6(1) upgrade because database
partitioning was obsoleted in Unified CCERelease 9.0(1). Remove partitioning before you run the Unified
CCE Release11.6(1) installer.

To remove partitioning from logger/AW/HDS database, follow the steps mentioned in the tech-zone
article: https://techzone.cisco.com/t5/Administration-and-Data-Servers/
Removing-Database-partitioning-UCCE-8-5-4/ta-p/743317.

• The minimum disk space required to perform the upgrade is 2175 MB.

• During the upgrade process, the installer takes a backup of the existing configuration database. This
backup is available in drive\temp\<instance name_logger side><Major_CC Minor_
AW Minor>

The values for Major, CCMinor, AWMinor that are used in the backup folder
name, are derived from the 11.0 or 11.5 schema version of the system being
upgraded (These are stored in the Version table of the CCE database and would
translate into 181,3,3 for upgrades from 11.0(x) systems and 188,0,0 for 11.5(x)
upgrades).

Note

For example: C:\Temp\Inst_sideA_181_3_3 from 11.0(1) upgrade and
C:\Temp\Inst_sideA_188_0_0 from 11.0(1) upgrade
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This backup may fail if the space required to backup configuration data as
calculated by the installer is not available on the system. This is independent of
the minimum space requirement listed above.

Note

• Before upgrading or uninstalling 11.6(1) Installer, close all the open Windows Event Viewer instances.
If you do not follow the same, the installer may fail to proceed. You might see an error that says the
following DLLS are locked.

• icrcat.dll

• icrmsgs.dll

• snmpeventcats.dll

• snmpeventmsgs.dll

In such a scenario, close the Event Viewer and retry the installation or uninstallation.

Procedure

Step 1 Log in to your system as a user with administrative privileges.
Step 2 After either downloading the installer or placing the media in the drive, start the Cisco ICM Minor Release

ICM 11.6(1) Installer.
Step 3 Follow the on-screen instructions to install Unified CCE Release 11.6(1).

A pop-up window displays a notification that some services were automatically changed to Manual
as part of the upgrade. Make sure that both A and B sides of your system operate properly after the
Unified CCE Release 11.6(1) upgrade. Then, set the ICM services that were changed during the
upgrade back to their original setting (Automatic).

If you are not sure which services were changed from Automatic to Manual during the upgrade,
examine the setup logs located in C:\Temp\Minor Release ICM11.6(1).

Note

Step 4 If you use the Diagnostic Portal to monitor Live Data standalone servers, rerun the following command:

set live-data machine-services awdb-user awdb-pwd

Related Topics
Configure Live Data Machine Services, on page 77

Ensure Campaigns are not Lost on Upgrade
Database schema updates in release 11.5 and 11.6 modify the campaign data during upgrade, which can
potentially cause all the campaign configuration data to be lost. Verify the default time zone set for the
configured campaigns to make sure you do not lose the campaign configuration data as identified by these
issues. Refer to CSCvg84326 and CSCvu45133 for more details.
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C H A P T E R 7
Common Ground Upgrade

• Preupgrade Overview, on page 185
• Common Ground Preupgrade Task Flow, on page 186
• Common Ground Preupgrade Tasks, on page 188
• Common Ground Upgrade Task Flow, on page 191
• Common Ground Upgrade Tasks, on page 196

Preupgrade Overview
The preupgrade process ensures that your systems have the necessary software to support your contact center.
These tasks prepare the way for a successful upgrade of your Cisco contact center components to the new
release.

Upgrade Tools

During the preupgrade process, use the following tools as required:

• User Migration Tool—A standalone Windows command-line application that is used for all upgrades
that involve a change of domain. The tool exports all existing user accounts (config/setup and supervisors)
in the source domain into a flat file. The file is used in the target domain during the upgrade.

You can download the User Migration Tool from Cisco.com by clicking ICM User Migration Tool
Software.

• Regutil Tool—Used in Technology Refresh upgrades, exports the Cisco Systems, Inc. registry from the
source machine during the preupgrade process. The output of the tool is required on the destination
machine when running the Unified CCE Installer during the upgrade process.

You can download the Regutil Tool from Cisco.com by clicking Contact Center Enterprise Tools.

• Domain Manager—Used to provision Active Directory.

The Domain Manager Tool is delivered with the main installer.

• Upgrade.exe—Used to upgrade the schema of the logger, AW DB, HDS DB, and BA databases to a
version compatible with the current CCE Software version. It is typically used when the installer fails
to automatically upgrade the schema of the AW database. The other databases are typically upgraded
using EDMT and not the installer.

Perform the following steps to use the tool:
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<Install Drive>: \icm\bin>upgrade.exe -s <Server Name> -d <Database
name> -dt <Database Type> -i <Instance Name>

Where

<Database Type> - can be either " logger" or "hds" or "aw" or "ba", depending on the database that
requires the schema to be upgraded.

• Enhanced Database Migration Tool (EDMT)—A wizard application that is used for all upgrades to
migrate the HDS, Logger, and BA databases during the upgrade process.

You can download the EDMT from Cisco.com by clicking Cisco Enhanced Data Migration Tool
Software Releases.

The prerequisites for running EDMT are:

• EDMT also requires Microsoft® ODBC Driver 11 for SQL Server® andDriver 11 for SQL Server®
and Visual C++ Redistributable for Visual Studio 2015 . The latest version of these packages can
be downloaded from the Microsoft website. However, a copy of the same is also available in the
Prerequisites folder of EDMT.

The EDMT displays status messages during the migration process, including warnings and errors.
Warnings are displayed for informational purposes only and do not stop the migration. Errors stop the
migration process and leave the database in a corrupt state. If an error occurs, restore the database from
your backup, fix the error, and run the tool again.

• If you are configuring SQL services to run as Virtual account (NT SERVICE)
or Network Service account (NT AUTHORITY\NETWORK SERVICE),
you must run EDMT as an administrator.

• The installer, not the EDMT, upgrades the AW database for the
Administration & Data Server.

Note

• User Role Update Tool—A powershell script which is required to be executed in any one of the distributor
boxes once after the upgrade. Logger, Router and distributor services should be running before running
this tool. The User Role Update tool gets the AD security group membership (config and setup groups)
of the users in User_Group table and update the UserRole column.

Common Ground Preupgrade Task Flow
Perform the following Common Ground preupgrade tasks in any order.

The Common Ground upgrade assumes the host server runs on Windows Server 2012 R2.Note
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SeeRelease 10.0 to 11.0

Release 10.5 to 11.0

Task

Release Notes for Cisco Unified Contact Center Enterprise
Solutions at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-release-notes-list.html

yesReview target release notes

ESXi Supportability, on page 6yesESXi Supportability

Disaster Recovery Plan, on page 188yesDisaster Recovery Plan

Change the SCSI Controller Type, on page 188yesChange the SCSI Controller Type

Upgrade VM Network Adapters from E1000 to VMXNet3, on
page 189

yesUpgrade VM Network Adapters from
E1000 to VMXNet3

VM Hardware Version Upgrade, on page 190yesVM Hardware Version Upgrade

Upgrade OverviewyesDownload the Enhanced Database
Migration Tool

Use your established processes.yesBack up the server registry

Use your established processes.yesCopy ICM directory on all system nodes

Use your established processes.yesRun the following and save the results:

ipconfig -all

route print -p

netstat -a

Use your established processes.yesCreate bootable image of operating system
and network configuration

Microsoft SQL HelpyesBack up Logger, HDS, BA databases using
Microsoft SQL Server Backup and Restore
utility

yesNotify all stakeholders, including:

• Cisco Technical Assistance Center
(TAC)

• Local Cisco Representatives

• Customer Operations and Emergency
Management Center

• Third-party vendors as applicable

yesRemove DB-lib key from
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\
Microsoft\MSSQLServer\Client\DB-Lib
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Common Ground Preupgrade Tasks

Disable Configuration Changes

Procedure

Step 1 To disable configuration changes during the upgrade, set the following registry key to 1 on the Side A Call
Router: HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<instance name>\Router
A\Router\CurrentVersion\Configuration\Global\DBMaintenance.

Step 2 Confirm that configuration changes are disabled by attempting to save a configuration change.

When you try to save the change, a message is displayed confirming the change failure.

Disaster Recovery Plan
Before you start the upgrade process, take a snapshot of the virtual machines on which you are performing
an upgrade. Take the snapshot with the VM powered off to reduce the Size of the snapshots and post successful
migration to UCCE 11.0(1), Snapshots have to be removed to avoid performance impacts.

It's preferred to take a backup of Virtual Machine OVA as well. In case of Snapshot reversal failure, We still
have one more backup.

Change the SCSI Controller Type
LSI Logic Parallel is not supported with Windows Server 2012. If the virtual machine has SCSI Controller
type as LSI Logic Parallel, you must change it to LSI Logic SAS.

Procedure

Step 1 Ensure the virtual machine is powered on.
Step 2 Add a new hard disk to the virtual machine.

When choosing the Virtual Device Node, select SCSI (1:0) and hard disk size as 1MB.

When the new virtual disk is created, it creates a second virtual SCSI controller.Note

Do not click OK at this stage to confirm the changes.Caution

Step 3 Select the second virtual SCSI controller, and then click Change Type.
Step 4 Select the LSI Logic SAS radio button, and then click OK.
Step 5 Click OK to confirm the changes.
Step 6 Log in to the virtual machine.
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The operating system automatically detects the new SCSI controller and adds the driver for LSI Logic SAS.

Step 7 In Device Manager, under Storage controllers, ensure that the controller is listed as LSI Adapter SAS 3000
Series.

Step 8 Power down the virtual machine.
Step 9 Remove the newly added virtual disk. Ensure that you select the Remove from virtual machine and delete

files from disk option.

Selecting this option purges the new disk from the data store.

The controller is removed automatically.

Step 10 Change the first virtual controller to the LSI Logic SAS setting.
Step 11 Power on the virtual machine.
Step 12 Usually, Windows displays a message telling you to restart the virtual machine for the changes to take effect.

If this message is not displayed, restart the virtual machine manually.

Upgrade VM Network Adapters from E1000 to VMXNet3
Before you upgrade the VM's operating system from Windows Server 2008 R2, upgrade the VM network
adapters to VMXNet3. Unified CCE 11.0(1) requires VMXNet3 network adapters. If you upgrade the operating
system toWindows Server 2012 R2without upgrading to VMXNet3, the static IP configuration on the ethernet
adapter resets to automatic after the Windows upgrade.

VMware deprecated support for E1000 Ethernet Controllers from ESXi 5.5 onwards: http://kb.vmware.com/
selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2056935

Note

Procedure

Step 1 Ensure the VMware Tools are Installed.
Step 2 Record the public and private network settings, including the IP addresses, Subnet masks, Default Gateway,

DNS, Persistent Static Routes, and so on.

You need these values to recreate the configurations on the new virtual machine network adapters.Important

Step 3 Stop the Unified CCE services. The services cannot be active during reconfiguration of the network adapters.
Step 4 Remove the persistent static routes from Windows Server 2008 R2 on the VM. For more information about

persistent static routes, see the Staging Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/prod_installation_guides_list.html.

Step 5 Disable the E1000 public network adapter.
Step 6 Disable the E1000 private network adapter, if the VM has a PG, Router, or Logger.
Step 7 Remove the E1000 public network adapter:

a) Shut down the operating system of the VM.
b) Select Edit Settings from the VM context menu.
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c) Select the E1000 public network adapter on the Hardware tab.
d) Click Remove and then click Finish.
e) Start the VM.

Step 8 Remove the E1000 private network adapter from VMs for PGs, Routers, and Loggers:
a) Shut down the operating system of the VM.
b) Select Edit Settings from the VM context menu.
c) Select the E1000 public network adapter on the Hardware tab.
d) Click Remove and then click Finish.
e) Start the VM.

Step 9 Remove ghosted network adapters
a) Run this in cmd prompt 'set devmgr_show_nonpresent_devices=1' and press Enter.
b) Launch Device manager using this cmd'start devmgmt.msc' .
c) In Device Manager, Click View and select show hidden device.
d) Expand Network Adapter and uninstall the dimmed E1000 network adapters.

Step 10 Add the VMXNet 3 public network adapter:
a) Select Edit Settings from the VM context menu.
b) Click Add on the Hardware tab.
c) Select Ethernet Adapter in the Device Type page and click Next.
d) Select VMXNet 3 from the Adapter Type drop-down list.
e) Select the public network port group from the Network label drop-down list and click Next.
f) Click Finish.

Step 11 Add the VMXNet 3 private network adapter to VMs for PGs, Routers, and Loggers:
a) Select Edit Settings from the VM context menu.
b) Click Add on the Hardware tab.
c) Select Ethernet Adapter in the Device Type page and click Next.
d) Select VMXNet 3 from the Adapter Type drop-down list.
e) Select the public network port group from the Network label drop-down list and click Next.
f) Click Finish.

Step 12 Apply the network settings that you recorded in Step 1 from the E1000 public and private network adapters
to the VMXNet 3 public and private network adapters.

Step 13 Enable the VMXNet 3 public and private network adapters.
Step 14 Add the persistent static routes to the Windows Server 2008 R2 on the VM.
Step 15 Use traceroute to test the connectivity for the public and private networks.
Step 16 Re-enable the unified CCE services.

VM Hardware Version Upgrade
In the VSphere Client, ensure that you have upgraded the VM hardware version to 9. Download VMware
Vsphere Powercli tool and use it to complete this procedure. Ensure the VM is powered off during this
procedure.
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Procedure

Step 1 Connect to the ESX using VMware VSphere PowerCli "Connect-VIServer -Server ESXIP -Protocol https
-User username -Password password".

Step 2 Run command Get-VM "<VM name>" | Set-VM -Version "v9"to change the VM version.

Increase the Provisioned Disk Size for Unified Intelligence Center VMs
(Standalone and Coresident)

Procedure

Step 1 Power off the virtual machine.
Step 2 Click Edit Settings.
Step 3 Click the Hardware tab, and select the hard disk to modify.
Step 4 In the Disk Provisioning pane, increase the provisioned size from 146 GB to 200 GB.
Step 5 Click OK to save your changes and close the dialog box.
Step 6 Start the virtual machine.

Common Ground Upgrade Task Flow
For the Unified CCE core components, there is a general flow for redundant systems to ensure that contact
center operation continues during the entire upgrade process. Sides A and B are brought down, upgraded,
tested, and brought back up in a sequence that ensures continuous operation of the contact center.

For Common Ground upgrades, perform the following upgrade tasks:

SeeTask

Agent and supervisor desktops

SSO is an optional feature and exchanges authentication and authorization details between
an identity provider (IdP) and an identity service (IdS). If you upgrade to 11.6(1) from
11.5(x) with SSO enabled then upgrade the standalone Cisco IdS server before upgrading
other components like Cisco Unified Intelligence Center (CUIC), and Finesse. For
co-resident configurations, CUIC must be at the same version as Finesse. Upgrade both,
CUIC and Finesse in the same maintenance window.

Install the Identity Service. See the Installation Task Flow for Cisco Identity Service
section in the Cisco Unified Contact Center Enterprise Features Guide at
https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-feature-guides-list.html

Identity Service

(IdS)/Single
Sign-On(SSO)
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SeeTask

Cisco Finesse Installation and Upgrade Guide at

http://www.cisco.com/en/US/products/ps11324/prod_installation_guides_list.html

ES65 provides the ability to connect a maximum of two versions of Finesse to
the same PG during the upgrade or migration process to facilitate the migration
of agents and supervisors to the new Finesse version. However, this mode of
operation is not supported for production use beyond the upgrade or migration
phase.

Note

Upgrade
Finesse.

Cisco SocialMiner User Guide at

http://www.cisco.com/c/en/us/support/customer-collaboration/socialminer/products-installation-guides-list.html.

Upgrade
SocialMiner

Queuing and self-service components

Installation and Upgrade Guide for Cisco Unified Customer Voice Portal at

http://www.cisco.com/en/US/products/sw/custcosw/ps1006/prod_installation_guides_list.html

Upgrade Cisco
Unified
Customer Voice
Portal.*

Infrastructure and media resource components

Upgrade Voice and Data Gateways, on page 205Upgrade voice
and data
gateways.

Reporting server

Installation and Upgrade Guide for Cisco Unified Intelligence Center at

http://www.cisco.com/en/US/products/ps9755/prod_installation_guides_list.html

Upgrade Cisco
Unified
Intelligence
Center server.

Unified CCE Central Controller and Administration & Data Server components

Upgrade to Windows Server 2012 R2, on page 196

Upgrade to SQL Server 2014, on page 198

Bring down
Side A Logger,
and upgrade the
VM to the new
platform of
Windows
Server and SQL
Server.

Bring down
Side A Logger,
and upgrade the
VM to the new
platform of
Windows
Server and SQL
Server.
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SeeTask

Migrate Unified CCE Logger Database and Upgrade Logger, on page 199Migrate Side A
Logger
database, and
upgrade the
Logger.

Upgrade to Windows Server 2012 R2, on page 196Bring down
Side A Call
Router, and
upgrade theVM
to new platform
of Windows
Server.

Upgrade Unified CCE Call Router, on page 200Upgrade Side A
Call Router.

Upgrade to Windows Server 2012 R2, on page 196

Upgrade to SQL Server 2014, on page 198

Upgrade the
VM for the
Administration
& Data Server
connected to
Side A to the
new platform of
Windows
Server and SQL
Server.

Migrate HDS Database and Upgrade the Unified CCE Administration & Data Server, on
page 201

Upgrade the
Administration
& Data Server
connected to
Side A.

Bring Upgraded Side A into Service, on page 205Bring Side A
Logger and Call
Router into
service, bring
down Side B
Logger and Call
Router.

Upgrade to Windows Server 2012 R2, on page 196

Upgrade to SQL Server 2014, on page 198

Upgrade the
VM for the Side
B Logger to the
new platform of
Windows
Server and SQL
Server.
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SeeTask

Migrate Unified CCE Logger Database and Upgrade Logger, on page 199Migrate Side B
Logger database
and upgrade the
Logger.

Upgrade to Windows Server 2012 R2, on page 196Upgrade the
VM for the Side
BCall Router to
new platform of
Windows
Server.

Upgrade Unified CCE Call Router, on page 200Upgrade Side B
Call Router.

Verify operation of upgraded Side B Call Router and Logger, on page 207Bring Side B
Call Router into
service and
verify
operation.

Bring Side B
Logger into
service and
verify
operation.

Upgrade to Windows Server 2012 R2, on page 196

Upgrade to SQL Server 2014, on page 198

Upgrade the
VM for the
Administration
& Data Server
connected to
Side B to the
new platform of
Windows
Server and SQL
Server.

Migrate HDS Database and Upgrade the Unified CCE Administration & Data Server, on
page 201

Upgrade the
Administration
& Data Server
connected to
Side B.

Installation and Upgrade Guide for Cisco Unified Intelligence Center at

http://www.cisco.com/en/US/products/ps9755/prod_installation_guides_list.html

Upgrade Cisco
Unified
Intelligence
Center reporting
templates.
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SeeTask

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal
at http://www.cisco.com/en/US/products/ps7076/prod_installation_guides_list.html

Upgrade
Unified Contact
Center
Management
Portal(Unified
CCMP).

Upgrade Unified CCE Administration Client, on page 227Upgrade
Administration
Client.

Database Performance Enhancement, on page 210Database
Performance
Enhancement.

Unified CCE Peripheral Gateways and associated components

Upgrade to Windows Server 2012 R2, on page 196Upgrade PGs to
new platform of
Windows
Server.

Upgrade Peripheral Gateways, on page 202Upgrade PGs.

Upgrade Outbound Option Dialer, on page 203Upgrade
Outbound
Option Dialer.

CTI OS System Manager Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps14/prod_installation_guides_list.html

Upgrade CTI
server.

Upgrading Dual Sided Unified CCMP at
http://www.cisco.com/en/US/products/ps7076/tsd_products_support_install_and_upgrade_technotes_list.html

Upgrade Cisco
Unified Contact
Center
Management
Portal.

Desktop client components

Call processing components

Upgrade Guide for Cisco Unified Communications Manager at
http://www.cisco.com/c/en/us/support/unified-communications/unified-communications-manager-callmanager/products-installation-guides-list.html

Upgrade Cisco
Unified
Communications
Manager.

Upgrade Cisco JTAPI Client on PG, on page 209Upgrade
(uninstall and
reinstall) the
JTAPI client on
the Cisco
Unified
Communications
Manager PG.
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SeeTask

Media recording components

Installation and Administration Guide for Cisco MediaSense at
http://www.cisco.com/en/US/products/ps11389/prod_installation_guides_list.html

Upgrade
MediaSense. 4

*If you are using IP IVR for self-service and queueing, see Getting Started with Cisco Unified IP IVR.

4 UCCE 11.0(1) supports only Cisco MediaSense 11.5.

Related Topics
Multistage Upgrades and Maintenance Windows, on page 175

Common Ground Upgrade Tasks
The following section provides instructions about upgrading the virtual environment and the Unified CCE
components. For instructions about upgrading non-Unified CCE components in a Unified CCE solution, for
example Finesse and CUIC, see the links to component-specific documents in the Common Ground Upgrade
Task Flow, on page 191.

Upgrade to Windows Server 2012 R2
Microsoft supports in-place upgrade of the operating system and SQL. This topic does not provide instructions
for upgrading to Microsoft Windows Server 2012 R2. For this information, see the corresponding Microsoft
documentation. This topic only highlights the actions that you perform before you attempt the upgrade and
after you complete the upgrade of the operating system.

Unified CCE 11.0(x) supports only Windows Server 2012 R2. For information about supported editions or
service packs, see the Unified CCE Solution Compatibility Matrix at http://docwiki.cisco.com/wiki/
Compatibility_Matrix_for_Unified_CCE.

Important

Before you begin

• Using Unified CCE Service Control, stop all Unified CCE services on the Unified CCE servers that you
are upgrading, and set the startup type as Manual.

If you are upgrading the Logger, ensure that you have disabled configuration changes by performing the
following steps:

1. On the A side of the CallRouter in the system that you are upgrading, set the
HKEY_LOCAL_MACHINE\Software\Cisco Systems,
Inc.\ICM\<instance_name>\RouterA\Router\CurrentVersion\Configuration\Global\DBMaintenance
key to 1 .

2. On the B side of the CallRouter in the system that you are upgrading, set the
HKEY_LOCAL_MACHINE\Software\Cisco Systems,
Inc.\ICM\<instance_name>\RouterB\Router\CurrentVersion\Configuration\Global\DBMaintenance
key to 1.
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3. Verify that configuration changes are prevented. When you attempt to save a configuration change,
you should see the following message: Failed to update the database. Exclusive
access to the CallRouter denied because configuration changes are
currently disabled in the router registry.

• If the virtual machine has SCSI Controller type as LSI Logic Parallel, change it to LSI Logic SAS. For
more information, see Change the SCSI Controller Type, on page 188.

• If you did not already upgrade the VM network adapters to VMXNet3, upgrade them before upgrading
the OS. see Upgrade VM Network Adapters from E1000 to VMXNet3, on page 189.

• Upgrading to Windows Server 2012 R2 may delete the persistent static routes and static network
configurations (for private and public interfaces). Record your configurations before starting the upgrade
process, and reconfigure it after the upgrade completes.

If your persistent static route uses the private interface IP address as the gateway
IP, change it to use the local gateway IP.

Note

For more information about persistent static routes, see the Staging Guide for Cisco Unified ICM/Contact
Center Enterprise at http://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-installation-guides-list.html.

• Ensure that the VM does not have a ghosted network adapter before the upgrade.

During an upgrade, you can lose Static Network configuration if there is a ghosted network adapter on
the VM.

Make any ghosted network adapter visible and uninstall it from the device manager before the upgrade
to Windows Server 2012 R2 Standard. See Upgrade VM Network Adapters from E1000 to VMXNet3,
on page 189.

• In the vSphere Client, ensure that you have upgraded the VM hardware version to the version 9.

• Change the guest operating system to Microsoft Windows Server 2012 (64 bit). To do so, right-click the
virtual machine, selectEdit settings >Options >General Options and select the guest operating system
as Microsoft Windows Server 2012 (64 bit) and ensure the VM is powered off during this procedure.

• Ensure that the virtual machine has enough space before the upgrade. Operating System upgrade to
Windows Server 2012 requires minimum of 16-GB primary hard disk space. If the virtual machine is a
Logger/Distributor machine, the upgrade to SQL Server 2014 Standard or Enterprise edition requires an
extra 6 GB.

If you are performing the Windows upgrade on an AW-only server that does not
have 16 GB, then upgrade the AW-only server using Technology Refresh.

Note

What to do next

After upgrading your operating system to Windows Server 2012 R2, do the following:

• Remove the previous windows installation. see Remove Previous Windows Installation.
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• Multilingual language pack will be uninstalled. Install the language pack manually. For more information
on installing language pack, see Microsoft documentation at http://www.microsoft.com/OEM/en/
installation/downloads/Pages/Windows-Server-2012-Language-Packs.aspx#fbid=bSYXlh5sO3X.

• Check the persistent static routes and static network configurations (for private and public interfaces).
If the network settings are lost, reconfigure it manually.

Related Topics
Change the SCSI Controller Type, on page 188
Set Up Virtual Machines, on page 15
Technology Refresh Upgrades, on page 2
Upgrade VM Network Adapters from E1000 to VMXNet3, on page 189

Remove Previous Windows Installation

Before you begin

Enable Desktop Experience feature under User Interfaces and Infrastructure from Server Manager. This
step is necessary for the disk cleanup process.

Procedure

Step 1 Click Start, search disk cleanup and then click Disk Cleanup.
Step 2 In the Disk Cleanup Options dialog box, click Files from all users on this computer.
Step 3 In the User Account Control dialog box, click Continue.
Step 4 Click to select the previous Windows Installation check box, and then click OK.

Upgrade to SQL Server 2014
Microsoft supports in-place upgrade of operating system and SQL Server. After you upgrade the operating
system, upgrade to SQL Server 2014.

Unified CCE Solution Compatibility Matrix at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-device-support-tables-list.html

Note

Before you begin

• The upgrade to SQL Server 2014 requires a minimum of 6-GB hard disk space. Ensure that the virtual
machine has the required space before you begin the upgrade.

• Ensure that the virtual machine has SQL Server 2008 R2 SP2. Ensure that your SQL Server 2008 R2
installation works properly. Set the SQL Server service to Active state during the upgrade.
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• If the virtual machine has SQL Server 2008 R2 Enterprise, then upgrade to SQL Server 2014 Enterprise
version only. However, if the virtual machine has SQL 2008 R2 Standard Edition, it can be upgraded to
either SQL Server 2014 Standard or Enterprise Edition.

• If present, remove DB-lib registry key from the location
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MSSQLServer\Client\DB-Lib
before starting the SQL upgrade.

Procedure

Step 1 Run the SQL Server 2014 Standard or Enterprise Edition installer. Consult Microsoft documentation as needed.
Step 2 Step through the wizard. As appropriate, accept the default or choose the correct instance for your deployment.

Select Rebuild on the Full-Text Search Upgrade Options page.
Step 3 After the upgrade, change the SQL Server and SQL Server Agent service accounts to Virtual accounts.

To change to Virtual account:

a. Open SQL Server 2014 Configuration Manager.

b. Under SQL server services, right-click SQL Server(MSSQLSERVER), and select Properties.

c. Select This Account.

d. In the Account Name field, enter NT SERVICE\MSSQLSERVER.

e. Leave the Password field blank. See Microsoft documentation on Windows service accounts and
permissions for more information at https://msdn.microsoft.com/en-us/library/ms143504.aspx.

f. Click OK.

Repeat the same steps for SQL Server Agent with Account Name as NT SERVICE\SQLSERVERAGENT
and start the services.

While you can use the Network or Local Services account instead of the Virtual account, using the
Virtual account provides security.

Note

• SQL Server Client Tools of SQL Server 2008 R2 remain on the server along with the same tools of SQL
Server 2014. These tools include SQL Server Management Studio, SQL Server Profiler, the Database
Engine Tuning Advisor, sqlcmd, and osql.

• SQL Server 2014 supports importing of settings from earlier versions of SQL Server Client Tools.

Note

Migrate Unified CCE Logger Database and Upgrade Logger
To upgrade the Logger, you do the following tasks:

• Migrate the Logger database.
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• if you use Outbound option, migrate the outbound option database.

• Install the new software.

Before you begin

Before you perform this procedure, ensure that you have upgraded the VM to the new platform of Windows
Server and SQL Server.

Procedure

Step 1 Using Unified CCE Service Control, stop all Unified CCE services on the Server and change to Manual Start.
Step 2 Launch the EDMT, and click Next.
Step 3 Select Common Ground, and click Next.
Step 4 On the warning message, click Yes if you have taken a backup of your database, and no services are currently

running.

If you have not taken the backup of your database, click No to exit the installer.Note

Step 5 In the Database Connection section, highlight the database that you want to upgrade, and then click Next.
Step 6 Click Start Migration. A warning message is displayed asking for confirmation of the data migration.
Step 7 Click Yes to confirm.
Step 8 ClickOK to acknowledge the message. After completion of the data migration, a warningmessage is displayed

telling you to select a valid deployment type.
Step 9 Exit the EDMT.

If Outbound Option is deployed, repeat the same steps to migrate the BA database.

Step 10 To upgrade the Logger, launch the 11.0 ICM-CCE-Installer by running setup.exe, and click Next.
Step 11 To apply any Minor Releases, click Browse and navigate to the 11.5(1) Minor Release software. Click Next.
Step 12 To apply any Minor Releases, click Browse and navigate to the 11.6(1) Minor Release software. Click Next.
Step 13 Select SQL Server 2014 Security Hardening and click Next.
Step 14 Click OK on any informational messages that display.
Step 15 Click Install.
Step 16 Reboot the server when the upgrade completes.

Related Topics
Upgrade to SQL Server 2014, on page 198
Upgrade to Windows Server 2012 R2, on page 196

Upgrade Unified CCE Call Router

Before you begin

Before you perform this procedure, ensure that you have upgraded the virtual machine to new platform of
Windows. For more information, see Upgrade to Windows Server 2012 R2, on page 196.
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Procedure

Step 1 Reboot the Call Router virtual machine.
Step 2 Launch the 11.0 ICM-CCE-Installer and click Next.
Step 3 (Optional) To apply any Minor Releases, click Browse and navigate to the Minor 11.5(1) Release software.

Click Next.
Step 4 (Optional) To apply any Minor Releases, click Browse and navigate to the Minor 11.6(1) Release software.

Click Next.
Step 5 Click OK on any informational messages that display.
Step 6 Click Install.
Step 7 Reboot the server when the upgrade completes.

Migrate HDS Database and Upgrade the Unified CCE Administration & Data
Server

The deployment of the Administration & Database Server determines which tools to use for an upgrade:

• For an AW-only deployment, the EDMT is not required; the ICM-CCE-Installer completes the upgrade.
• For any deployment that involves an HDS database, use the EDMT to migrate the HDS database before
running the installer.

Before you begin

Before you perform this procedure, ensure that you have upgraded the VM to the compatible versions of
Windows Server and SQL Server.

Procedure

Step 1 Using Unified CCE Service Control, stop all Unified CCE services on the Server and change to Manual Start.
Step 2 For HDS-related deployments, launch the EDMT and click Next. Select Common Ground and click Next.

Review or change the information that is displayed as required and click Start Migration. Click Yes on the
warning message that displays. Exit the EDMT.

Step 3 Launch the 11.0 ICM-CCE-Installer and click Next.
Step 4 Optional: To apply any Minor Releases, click Browse and navigate to the 11.5(1) Minor Release software.

Click Next.
Step 5 Optional: To apply any Minor Releases, click Browse and navigate to the 11.6(1) Minor Release software.

Click Next.
Step 6 (Optional) Select SQL Server 2014 Security Hardening and click Next.
Step 7 Click OK on any informational messages that display.
Step 8 Click Install.
Step 9 Reboot the server when the upgrade completes.
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The time required to complete a data migration varies in a direct relationship to the database size
(the larger the database size, the longer it takes to migrate) and the server hardware performance
level.

Note

Related Topics
Upgrade to SQL Server 2014, on page 198
Upgrade to Windows Server 2012 R2, on page 196

Upgrade Peripheral Gateways
You can upgrade different Peripheral Gateways (PGs) within a contact center within different maintenance
windows. However, upgrade all PGs that reside on the same virtual machine and their redundant PGs (Side
A and then the corresponding Side B; or vice-versa) during the same maintenance window.

The following dependencies occur when upgrading the Unified Communications Manager PG:

• If your contact center uses the CTI OS component, upgrade the CTI OS server at the same time as the
associated Unified Communications Manager PG.

• If your contact center uses Outbound Option, upgrade any Outbound Option Dialers that are associated
with Unified Communications Manager PGs at the same time.

• When you upgrade the Unified Communications Manager application, upgrade the JTAPI client that is
associated with the Unified Communications Manager PG at the same time.

Before you begin

Before you perform this procedure, ensure that you have upgraded the virtual machine to the new platform
of Windows. For more information, see Upgrade to Windows Server 2012 R2, on page 196.

Procedure

Step 1 Launch the 11.0 ICM-CCE-CCHInstaller and click Next.
Step 2 (Optional) To apply any Minor Releases, click Browse and navigate to the 11.5(1) Minor Release software.

Click Next.
Step 3 (Optional) To apply any Minor Releases, click Browse and navigate to the 11.6(1) Minor Release software.

Click Next.
Step 4 Click OK on any informational messages that display.
Step 5 Click Install.
Step 6 Reboot the server when the upgrade completes.

Related Topics
Set up Peripheral Gateways , on page 44
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Upgrade Outbound Option Dialer
During the upgrade, information about which contacts were called and which you need call is lost for in-process
outbound campaigns. Plan the timing of the upgrade accordingly.

Procedure

Step 1 Launch the 11.0 ICM-CCE-Installer and click Next.
Step 2 (Optional) To apply any Minor Releases, click Browse and navigate to the 11.5(1) Minor Release software.

Click Next.
Step 3 (Optional) To apply any Minor Releases, click Browse and navigate to the 11.6(1) Minor Release software.

Click Next.
Step 4 (Optional) Select SQL Server 2014 Security Hardening and click Next.
Step 5 Click OK on any informational messages that display.
Step 6 Click Install.
Step 7 Reboot the server when the upgrade completes.
Step 8 Use Unified CCE Service Control to set all Unified CCE services to Automatic Start.

Upgrade Unified CCE Administration Client

Procedure

Step 1 Launch the 11.0 AdminClientInstaller and click Next.
Step 2 (Optional) To apply any Minor Releases, click Browse, and navigate to the 11.5(1) Minor Release software.

Click Next.
Step 3 (Optional) To apply any Minor Releases, click Browse, and navigate to the 11.6(1) Minor Release software.

Click Next.
Step 4 Click OK on any informational messages that display.
Step 5 Click Install.
Step 6 Reboot the server when the upgrade completes.

Enable Configuration Changes

Procedure

Step 1 To enable configuration changes during the upgrade, set the following registry key to 0 on the Side A Call
Router: HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<instance name>\Router
A\Router\CurrentVersion\Configuration\Global\DBMaintenance.

Step 2 To confirm that configuration changes are enabled, save a configuration change.
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Save your changes.
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C H A P T E R 8
Common Upgrade Tasks

• Upgrade Voice and Data Gateways, on page 205
• Bring Upgraded Side A into Service, on page 205
• Verify operation of upgraded Side B Call Router and Logger, on page 207
• Upgrade Cisco JTAPI Client on PG, on page 209
• Database Performance Enhancement, on page 210

Upgrade Voice and Data Gateways
Perform the following procedure on eachmachine that hosts gateways that are used for TDM ingress, Outbound
Option dialer egress, and VXML processing.

Procedure

Step 1 For VXML gateways only, perform this step. For all other gateways, proceed to the next step.

Run the #copy tftp flash <IP Address> <filename>.bin command to copy the flash from a remote
machine to the gateway.

Step 2 Run the #sh flash command to check the version.
Step 3 Run the following commands in order:

a) #conf t

b) #no boot system flash: <old image>

c) #boot system flash: <new image>

d) #wr

e) #reload

Step 4 Run the #sh version command to verify that the new version shows in the gateway.

Bring Upgraded Side A into Service
After the Side A Unified CCE Logger, Call Router, and Administration & Data Server are upgraded, follow
this procedure to bring Side A into service.
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The logger and distributor services run with existing service logon account and is authorized by service security
group in the domain. If you want to run logger and distributor services with local authorization, then you have
to modify the service accounts using Service Account Manager Tool.

For more information on how to run Service Account Manager tool, see the Staging Guide for Cisco Unified
ICM/Contact Center Enterprise at
http://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-guides-list.html.

Procedure

Step 1 Use Unified CCE Service Control to stop all Unified CCE services on the side B Call Router and Logger.
However, before stopping Side B Router and Logger, also make sure that all non-upgraded Adminitration
and Data Servers are stopped and shutdown, before starting the upgraded Side A Logger and Router servers.

Step 2 Manually start the Unified CCE services on the Side ACall Router and Logger, and the upgradedAdministration
& Data Server. Verify the following basic operations of the Side A Central Controller categories:

OperationCategory

• Setup logs indicate no errors or failure conditions.

• AD domain has all users.

• Schema upgrade is successful for all databases (no loss of data integrity or loss of data).

• All component services start without errors.

• Calls are successfully processed.

General

• The Rtsvr logs indicate that the upgraded Administration & Data Server has connected
successfully.

Call
Router

• Recovery process that is not required, no activity other than process start up.

• Users are in correct domain.

• Configuration information is passed to Call Router.

• Replication process begins when HDS comes online.

Logger

• The updateAW process logs indicate that the Administration & Data Server is waiting for
work.

• Replication process begins with no errors.5

Administration
& Data
Server

• Specified users are able to use configuration manager.Security

• Previous settings for users are present when application is opened.

• Validate All script yields the same results that the preupgrade test yielded.

• You can open, edit, delete, or create new scripts.

Script
Editor
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OperationCategory

• Import or Export functionality is present.

• Database space allocation and percent used are correct.

ICMDBA

5 During replication, data from Config_Message_Log table is replicated from Logger database to
AW database. A purge mechanism is also introduced for Config_Message_Log table in AW
Database. The default retention period is set to 90 days. To change the retention period, modify
the following registry key:

Cisco Systems,

Inc.\ICM\<instancename>\Distributor\RealTimeDistributor
\CurrentVersion\Recovery\CurrentVersion\Purge\Retain\System\ConfigMessageLog

Step 3 Use Unified CCE Service Control to set the Unified CCE services to Automatic Start on each of the upgraded
Unified CCE components.

Step 4 Verify production system operation while running with the upgraded Side A Call Router and Side A Logger.

Verify operation of upgraded Side B Call Router and Logger
Procedure

Step 1 Before bringing Side B into service, manually synchronize Logger B to Logger A using ICMDBA.
Step 2 Start the Side B Call Router and Logger services.

As each node starts up, it searches for the other server components and attempts to register with them. If you
completed the ICM-CCE-Installer and network testing successfully, no major errors should occur.

To verify whether a process is up, use the Diagnostic Framework Portico ListProcess option, available through
the Unified CCE Tools shortcut that is created by the installer.

In order to add configuration data, the Central Controller and Administration &Data Servers must be running.
The Unified CCE software loads the Unified CCE Service Control Tool on the desktop of each server and is
used to control the services that are loaded on that machine.

Verify that the Unified CCE processes have no errors:

OperationCategory

• Router: Running and synchronized with peer.

• Rtsvr: Indicates no connectivity to Administration & Data Server at
this time.

Call Routers
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OperationCategory

• Logger: Connected to its respective database and synchronized with
peer. MDS is in service.

• Replication: No connectivity to Administration & Data Server HDS
at this time.

Loggers

Step 3 Use Unified CCE Service Control to start the Unified CCE services. Verify that the Unified CCE processes
have no errors:

OperationCategory

• Router: Running and synchronized with peer.

• Ccagent: In service but not connected to any peripheral gateways.

• Rtsvr: Feed activated to Administration & Data Server.

Call Routers

• Logger: Connected to its respective database and synchronized with
peer. MDS is in service.

• Replication: Connected to the Administration & Data Server.

Loggers

• Updateaw: Displays "Waiting for new work."

• Iseman: Listen thread waiting for client connection. (Exists only if
Internet Script Editor is configured.)

• Replication: Replication and recovery client connection initialized. 6

Administration & Data Server

6 During replication, data from Config_Message_Log table is replicated from Logger
database to AW database. A purge mechanism is also introduced for
Config_Message_Log table in AW Database. The default retention period is set to 90
days. To change the retention period, modify the following registry key:

Note

Cisco Systems,
Inc.\ICM\<instancename>\Distributor\RealTimeDistributor\CurrentVersion\Recovery\CurrentVersion\Purge\Retain\System\ConfigMessageLog

Step 4 Validate the following settings from the system diagram for the Production Environment andmake the required
changes before you place the systems in production:
a) Clear event logs.
b) Remove any media from drives.
c) Ensure that all services are set to Manual Start. Services are not set to Automatic Start until after the

implementation testing in the production environment.

Step 5 Use Unified CCE Service Control to start the Unified CCE services on the new Side B Call Router and Logger.

If possible, after data synchronization is complete between the Loggers, cycle the Unified CCE services on
the Side A Call Router and Side A Logger and verify that Side B takes over and that the system continues to
operate normally.

Step 6 Verify overall system operation.
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Step 7 Enable configuration changes.
a) Set the following registry key to 0 on the Side A and Side B Call Routers of the system:

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<instance
name>\Router<A/B>\Router\CurrentVersion\Configuration\Global\DBMaintenance

b) Verify that configuration changes can be made.
c) Sign in to Unified CCE Administration and use the Configure Deployment tool to select the deployment

type.

Step 8 Upgrade any other Administration & Data Servers or HDSs using the steps documented in Migrate HDS
Database and Upgrade Unified CCE Administration & Data Server, on page 223.

Upgrade Cisco JTAPI Client on PG
If you upgrade Unified CommunicationsManager (Unified CM) in the contact center, also upgrade the JTAPI
client that resides on the PG. To upgrade the JTAPI client, uninstall the old version of the client, restart the
server, and reinstall a new version. You install the JTAPI client using the Unified Communications Manager
Administration application.

Before you begin

Before you perform this procedure, you must:

• Uninstall the old JTAPI client from the Unified Communications Manager PG

• Restart the PG server.

Procedure

Step 1 To launch the Unified Communications Manager Administration application, enter the following URL in a
web browser on the server that hosts the Unified CommunicationsManager: https://<Unified Communications
Manager machine name>.

Step 2 Enter the username and password that you created when you installed and configured Unified Communications
Manager.

Step 3 Select Application > Install Plug-ins.
Step 4 Click the link next to Download Cisco JTAPI for Windows. We recommend you to download the 64 bit

version. However, if you have already downloaded the 32 bit version, you can proceed.
Step 5 Choose Run this program from its current location. Click OK.
Step 6 If a Security Warning box appears, click Yes to install.
Step 7 Choose Next or Continue through the remaining setup windows. Accept the default installation path.
Step 8 Click Finish and reboot the system.
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Database Performance Enhancement
After you perform a Common Ground or a Technology Refresh upgrade, complete the procedures described
in this section to enhance the performance of the database. This is a one-time process and must be run only
on the Logger and AW-HDS databases during a maintenance window.

Performance Enhancement of Logger Database
Perform this procedure on Side A and Side B of the Logger database.

Procedure

Step 1 Use the Unified CCE Service Control to stop the Logger service.
Step 2 From the command prompt, run the RunFF.bat file which is located in the <SystemDrive>:\icm\bin

directory.
Step 3 Proceed with the application of fill factor to ICM databases.

Note: Based on the size of the database, it takes several minutes to several hours to apply fill factor to the
database. For example, it takes anywhere between 2 to 3 hours for a 300-GB HDS. After the process is
completed, the log file is stored in <SystemDrive>\temp\<DatabaseName>_Result.txt.

Step 4 Use the Unified CCE Service Control to start the Logger service.

Troubleshooting Tips

See the RunFF.bat/help file for more information.

Performance Enhancement of AW-HDS Database

Procedure

Step 1 Use the Unified CCE Service Control to stop the Distributor service.
Step 2 From the command prompt, run the RunFF.bat file which is located in the <SystemDrive>:\icm\bin

directory.
Step 3 Proceed with the application of fill factor to ICM databases.

Note: Based on the size of the database, it takes several minutes to several hours to apply fill factor to the
database. For example, it takes between 2 to 3 hours for a 300-GB HDS. After the process is completed, the
log file is stored in <SystemDrive>\temp\<DatabaseName>_Result.txt.

Step 4 Use the Unified CCE Service Control to start the Distributor service.

Troubleshooting Tips

See the RunFF.bat/help file for more information.
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Improve Reporting Performance
To improve the performance of the reporting application, modify the following Windows settings on the
database servers (AW-HDS, AW-HDS-DDS, HDS-DDS).

• Increase the Paging File Size to 1.5 times the server's memory.

To change the Paging File Size, from the Control Panel search for Virtual Memory. In the Virtual Memory
dialog box, selectCustom size. Set both Initial size andMaximum size to 1.5 times the server memory.

• Set the server's Power Options to High Performance.

From the Control Panel, select Power Options. By default, the Balanced plan is selected. Select Show
additional plans and select High performance.

In SQL Server, disable Auto Update Statistics for AW and HDS databases.

In the SQL Server Management Studio, right-click the database name in the Object Explorer and select
Properties. Select the Options page. In the Automatic section of the page, set Auto Create Statistics and
Auto Update Statistics to False.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.6(1)
211

Common Upgrade Tasks
Improve Reporting Performance



Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.6(1)
212

Common Upgrade Tasks
Improve Reporting Performance



C H A P T E R 9
Technology Refresh Upgrade

• Preupgrade Overview, on page 213
• Technology Refresh Preupgrade Task flow, on page 214
• Upgrade Overview, on page 215
• Technology Refresh Upgrade Task Flow, on page 217
• Technology Refresh Upgrade Tasks, on page 221

Preupgrade Overview
The preupgrade process ensures that your systems have the necessary software to support your contact center.
These tasks prepare the way for a successful upgrade of your Cisco contact center components to the new
release.

Upgrade Tools

During the preupgrade process, use the following tools as required:

• User Migration Tool—A standalone Windows command-line application used for all upgrades that
involve a change of domain. The tool exports all existing user accounts (config/setup and supervisors)
in the source domain into a flat file. The file is used in the target domain during the upgrade.

You can download the User Migration Tool from Cisco.com by clicking ICM User Migration Tool
Software.

• Regutil Tool—Used in Technology Refresh upgrades, exports the Cisco Systems, Inc. registry from the
source machine during the preupgrade process. The output of the tool is required on the destination
machine when running the Unified CCE Installer during the upgrade process.

You can download the Regutil Tool from Cisco.com by clicking Contact Center Enterprise Tools.

• Domain Manager—Used to provision Active Directory.

The Domain Manager Tool is delivered with the main installer.

• Upgrade.exe—Used to upgrade the schema of the logger, AW DB, HDS DB, and BA databases to a
version compatible with the current CCE Software version. It is typically used when the installer fails
to automatically upgrade the schema.

Perform the following steps to use the tool:
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<Install Drive>: \icm\bin>upgrade.exe -s <Server Name> -d <Database
name> -dt <Database Type> -i <Instance Name>

Where

<Database Type> - can be either " logger" or "hds" or "aw" or "ba", depending on the database that
requires the schema to be upgraded.

Technology Refresh Preupgrade Task flow

Disable Configuration Changes
Perform this step on one side only. It is automatically replicated to the other side.

Procedure

Step 1 To disable configuration changes during the upgrade, set the following registry key to 1 on the Side A Call
Router: HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<instance name>\Router
A\Router\CurrentVersion\Configuration\Global\DBMaintenance.

Step 2 Confirm that configuration changes are disabled by attempting to save a configuration change.

When you try to save the change, a message is displayed confirming the change failure.

Export the Server Registry
Export the Cisco registry on each source machine that is involved in a Technology Refresh upgrade.

During the upgrade process, you are prompted for the path to the exported registry file location. Perform the
following procedure and note the location of the resulting file for later in the upgrade process.

Each time you run the RegUtil with the export option, if a RegUtil_<hostname>.dat file exists, the utility
renames that file to RegUtil_<hostname>.dat.bak<number>.

Procedure

Step 1 Open a command prompt and change the directory to the location where the RegUtil.exe resides.
Step 2 Run the RegUtil tool to export the Cisco Systems, Inc. registry using the following command:RegUtil -export

[target directory] , for example, C:\icm\bin>RegUtil -export C:\RegUtil

The target directory must have write access. Therefore, you cannot select the install media on a DVD. The
target directory is optional. If it is not specified, the tool outputs the result of the Registry export to the current
directory. The output filename is of the format RegUtil_<hostname>.dat, where hostname is the name of the
source machine.
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Upgrade Overview
Unified CCE Redundant Central Controller Upgrade Flow

The Unified CCE central controller consists of the Logger, Router, and Administration & Data Server. When
upgrading the Unified CCE portion of your contact center, the central controller is upgraded before the other
Unified CCE components. While one side (Side A or B) of the redundant system is being upgraded, the other
side (Side A or B) operates in stand-alone mode.

For redundant systems, the general flow for upgrading the Unified CCE central controller is as follows:

1. Upgrade the Logger, Router, and Administration & Data Server on Side A.

2. Bring Side A into service and verify the operation. Side B is brought down as Side A is coming into
service.

3. Upgrade the Logger, Router, and Administration & Data Server on Side B.

4. Bring Side B into service and verify that duplexed operation begins.

Update VM Properties

Rather than recreate the VMs from the new version of the OVA, you can manually update the VM properties
to match the new OVA. After you upgrade the vSphere ESXi and before you upgrade the Unified CCE
components, update the properties of each VM to match the appropriate OVA, as follows:

1. Determine the version of the OVA from which you created the VM.

2. Update the properties of each VM tomatch the properties of the appropriate OVA. Check the Virtualization
for Unified Contact Center Enterprise at https://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/
uc_system/virtualization/virtualization-unified-contact-center-enterprise.html for descriptions of each
OVA.

3. Stop the VM.

4. Edit the properties of the VM tomatch the properties from the new version of the OVA. Save your changes.

5. Restart the VM.

Be careful when you upgrade the virtual machine network adapters. Done incorrectly, this upgrade can
compromise the fault tolerance of your contact center.

Caution

For version-specific information on the VM properties in an OVA, Check the Virtualization for Unified
Contact Center Enterprise at https://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/
virtualization/virtualization-unified-contact-center-enterprise.html for descriptions of each OVA.

SQL Security Hardening

You can optionally apply SQL security hardening when running the installer. If your company employs custom
security policies, bypass this option. Most other deployments benefit from SQL security hardening.
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For more information about SQL security hardening, see the Security Guide for Cisco Unified ICM/Contact
Center Enterprise at http://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html.

Upgrade Tools

During the upgrade process, use the following tools as required:

• 11.0(1) ICM-CCE-CCHInstaller—Themain Unified CCE Installer. It copies all files into relevant folders,
creates the base registries, and installs needed third-party software such as JRE, Apache Tomcat, and
Microsoft .NET Framework.

Optionally, update the JRE installed by the Unified CCE Installer with a later
version of the JRE. See Update the Java Runtime Environment (Optional), on
page 56.

Note

Optionally, update the Apache Tomcat software. See Upgrade Tomcat , on page 58.

You cannot run the installer remotely. Mount the installer ISO file only to a local machine.

• Domain Manager—Used to provision Active Directory.

• Web Setup—Used to set up the Call Routers, Loggers, and Administration & Data Servers.

• Peripheral Gateway Setup—Used to set up PGs, the CTI server, and the Outbound Option dialer.

• 11.0(1) AdminClientInstaller—Installs the Administration Client on a system that is not running other
Unified CCE components.

The AdminClientInstaller is delivered on the installation media with the installer.

• ICM11.6(1).exe Installer - The Minor Release 11.6(1) installer which needs to be applied on 11.x base
version.

• Administration Client Setup—Used to add, edit, or remove Administration Clients and Administration
Client Instances.

The Administration Client Setup is delivered on the installation media with the installer.

• Enhanced Database Migration Tool (EDMT)—A wizard application that is used for all upgrades to
migrate the HDS, Logger, and BA databases during the upgrade process.

Back up your databases before running this tool. The EDMT displays status messages during themigration
process, including warnings and errors. Warnings are displayed for informational purposes only and do
not stop the migration. On the other hand, errors stop the migration process and leave the database in a
corrupt state. If an error occurs, restore the database from your backup, fix the error, and run the tool
again.

If you are configuring SQL services to run as Virtual account (NT SERVICE)
or Network Service account (NT AUTHORITY\NETWORK SERVICE), you
must run EDMT as an administrator.

Note
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You can download the EDMT from Cisco.com by clicking Cisco Enhanced Data Migration Tool
Software Releases.

The installer, not the EDMT, upgrades the AW database for the Administration
& Data Server.

Note

• User Migration Tool—A standalone Windows command-line application that is used for all upgrades
that involve a change of domain. The tool imports the previously exported user accounts into the target
domain during the upgrade.

You can download the User Migration tool from Cisco.com.

User Migration Tool cannot be used for migrating users that are SSO enabled.Note

• Regutil Tool—Used in Technology Refresh upgrades, exports the Cisco Systems, Inc. registry from the
source machine during the preupgrade process. The output of the tool is required on the destination
machine when running the Unified CCE Installer during the upgrade process.

You can download the Regutil tool from Cisco.com.

Technology Refresh Upgrade Task Flow
For the Unified CCE core components, there is a general flow for redundant systems; Sides A and B are
brought down, upgraded, tested, and brought back up in sequence. That sequence ensures the operation of the
contact center during the entire upgrade process.

For Technology Refresh upgrades, perform the following upgrade tasks:

SeeTask

Agent and supervisor desktops

SSO is an optional feature and exchanges authentication and authorization details between
an identity provider (IdP) and an identity service (IdS). If you upgrade to 11.6(1) from
11.5(x) with SSO enabled then upgrade the standalone Cisco IdS server before upgrading
other components like Cisco Unified Intelligence Center (CUIC), and Finesse. For co-resident
configurations, CUIC must be at the same version as Finesse. Upgrade both, CUIC and
Finesse in the same maintenance window.

Install the Identity Service. See the Installation Task Flow for Cisco Identity Service
section in the Cisco Unified Contact Center Enterprise Features Guide at
https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-feature-guides-list.html

Identity
Service

(IdS)/Single
Sign-On(SSO)
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SeeTask

Cisco Finesse Installation and Upgrade Guide at
http://www.cisco.com/en/US/products/ps11324/prod_installation_guides_list.html

ES65 provides the ability to connect a maximum of two versions of Finesse to
the same PG during the upgrade or migration process to facilitate the migration
of agents and supervisors to the new Finesse version. However, this mode of
operation is not supported for production use beyond the upgrade or migration
phase.

Note

Upgrade
Finesse

Cisco SocialMiner User Guide at http://www.cisco.com/c/en/us/support/
customer-collaboration/socialminer/products-installation-guides-list.html.

Upgrade
SocialMiner

Queuing and self-service components

Installation and Upgrade Guide for Cisco Unified Customer Voice Portal at
http://www.cisco.com/en/US/products/sw/custcosw/ps1006/prod_installation_guides_list.html

UpgradeCisco
Unified
Customer
Voice Portal*

Infrastructure and media resource components

Upgrade Voice and Data Gateways, on page 205Upgrade voice
and data
gateways

Reporting server

Installation and Upgrade Guide for Cisco Unified Intelligence Center at
http://www.cisco.com/en/US/products/ps9755/prod_installation_guides_list.html

UpgradeCisco
Unified
Intelligence
Center server

Unified CCE Central Controller and Administration & Data Server components

Migrate the Logger Database and Upgrade the Logger, on page 221Bring down
Side A
Logger,
migrate
Logger
database, and
upgrade
Logger

Upgrade Unified CCE Call Router, on page 222Bring down
Side A Call
Router, and
upgrade
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SeeTask

Migrate HDS Database and Upgrade Unified CCE Administration & Data Server, on page
223

Upgrade
Administration
& Data Server
connected to
Side A.

Bring Upgraded Side A into Service, on page 205Bring Side A
Logger and
Call Router
into service,
bring down
Side B Logger
and Call
Router

Migrate the Logger Database and Upgrade the Logger, on page 221Migrate Side
B Logger
database and
upgrade
Logger

Upgrade Unified CCE Call Router, on page 222Upgrade Side
B Call Router

Verify operation of upgraded Side B Call Router and Logger, on page 207Bring Side B
Call Router
into service
and verify
operation

Bring Side B
Logger into
service and
verify
operation.

Migrate HDS Database and Upgrade Unified CCE Administration & Data Server, on page
223

Upgrade
Administration
& Data Server
connected to
Side B.

Installation and Upgrade Guide for Cisco Unified Intelligence Center at
http://www.cisco.com/en/US/products/ps9755/prod_installation_guides_list.html

UpgradeCisco
Unified
Intelligence
Center
reporting
templates
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SeeTask

Upgrading Dual Sided Unified CCMP at
http://www.cisco.com/en/US/products/ps7076/tsd_products_support_install_and_upgrade_technotes_list.html

UpgradeCisco
Unified
Contact Center
Management
Portal

Upgrade Unified CCE Administration Client, on page 203Upgrade
Administration
Client

Database Performance Enhancement, on page 210Database
Performance
Enhancement

Unified CCE Peripheral Gateways and associated components

Upgrade Peripheral Gateways, on page 225Upgrade PGs

Upgrade Outbound Option Dialer, on page 226Upgrade
Outbound
Option Dialer

CTI OS System Manager Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps14/prod_installation_guides_list.html

Upgrade CTI
server

Desktop Client components

CTI OS System Manager Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps14/prod_installation_guides_list.html

Upgrade CTI
OS Agent and
Supervisor
Desktops

Call Processing components

Upgrade Guide for Cisco Unified Communications Manager at

http://www.cisco.com/c/en/us/support/unified-communications/unified-communications-manager-callmanager/products-installation-guides-list.html

UpgradeCisco
Unified
Communications
Manager

Upgrade Cisco JTAPI Client on PG, on page 209(Install) the
JTAPI client
on the Cisco
Unified
Communications
Manager PG

Media Recording components

Installation and Administration Guide for Cisco MediaSense at
http://www.cisco.com/en/US/products/ps11389/prod_installation_guides_list.html

Upgrade
MediaSense 7
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SeeTask
*If you are using Unified IP IVR for self-service and queueing, see Getting Started with Cisco Unified IP
IVR.

7 UCCE 11.6(1) supports only Cisco MediaSense 11.5.

Technology Refresh Upgrade Tasks
The following section provides instructions about upgrading Unified CCE components. For instructions about
upgrading non-Unified CCE components in a Unified CCE solution, see the links to component-specific
documents in the Technology Refresh Upgrade Task Flow.

Migrate the Logger Database and Upgrade the Logger
To upgrade the Logger, you do the following tasks:

• Migrate the Logger database.

• if you use Outbound option, migrate the outbound option database.

• Install the new software.

Before you begin

Create a shared folder in any desired location. Ensure that:

• in the Properties window > Sharing tab > Advanced Sharing, the Share this folder check box is checked.

• in the Properties window > Security tab, the permission level is set as full control for everyone .

Procedure

Step 1 Use Unified CCE Service Control to stop all Unified CCE services on the Logger.
Step 2 Run the EDMT from the server that hosts the destination Logger and click Next.
Step 3 Select Technology Refresh and click Next.
Step 4 Under Source Database Connection, in the HostName\IP Address field, type the Source IP and click

Refresh Database List.
Step 5 Select the Logger Database name, and click Next.
Step 6 In the Windows Share Name field, type the name of the shared folder that you created.
Step 7 In the Windows Share Password field, type the password of the destination machine, and click Next.
Step 8 Review or change the information displayed as required and click Start Migration.
Step 9 Exit the EDMT.
Step 10 If Outbound Option is deployed, to migrate the BaA database, reopen the EDMT and click Next.
Step 11 Select Technology Refresh and click Next.
Step 12 Under Source Database Connection, in the HostName\IP Address field, type the Source IP and click

Refresh Database List.
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Step 13 Select the Outbound Database name, and click Next.
Step 14 In the Windows Share Name field, type the name of the shared folder that you created.
Step 15 In the Windows Share Password field, type the password of the destination machine, and click Next.
Step 16 Review or change the information displayed as required and click Start Migration.
Step 17 Exit the EDMT.
Step 18 Launch the ICM-CCE-Installer 11.0(1) and click Next.
Step 19 Select Technology Refresh and click Next.
Step 20 Click Browse and specify the path for the RegUtil file you exported from the source machine during the

preupgrade process.
Step 21 (Optional) To apply any 11.5(1) Minor Releases, click Browse and navigate to the Minor Release software.

Click Next.
Step 22 (Optional) To apply any 11.6(1) Minor Releases, click Browse and navigate to the Minor Release software.

Click Next.
Step 23 (Optional) Select SQL Server 2014 Security Hardening and click Next.
Step 24 Click OK on any informational messages that display.
Step 25 Click Install.
Step 26 Reboot the system after the upgrade completes.
Step 27 Open the Web Setup tool from the Installer dialog box or desktop shortcut.
Step 28 Edit the instance as necessary.
Step 29 (Optional) In case of Cross Domain upgrade, launchWebsetup , select instance and click on "Change Domain"

in order to use the new domain for destination UCCE.

Edit instance and you might need to change the facility or instance number if required.

Step 30 Edit the Logger component as necessary.

If the registry now references out-of-date network interface names or IP addresses for the public and private
networks for the Logger, update this information.

Step 31 (Optional) If it is a Cross Domain upgrade, use User Migration tool to export the users and OU information
which you exported from the source machine during the pre-upgrade process. See User Migration Tool in
Preupgrade Overview, on page 185.

Step 32 Use Unified CCE Service Control to set all Unified CCE services on the new Logger to Manual Start.

Upgrade Unified CCE Call Router
To upgrade the Call Router, you do the following tasks:

• Import the Cisco registry information.

• Install the new software.

• Set up the new Call Router using the Web Setup tool.
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Procedure

Step 1 Launch the ICM-CCE-Installer and click Next.
Step 2 (Optional) To apply any 11.5(1) Minor Release or Maintenance Releases, click Browse and navigate to the

Maintenance or Minor Release software. Click Next.
Step 3 (Optional) To apply any 11.6(1) Minor Release or Maintenance Releases, click Browse and navigate to the

Maintenance or Minor Release software. Click Next.
Step 4 Select Technology Refresh and click Next.
Step 5 Specify the path for the RegUtil file you exported from the source machine during the preupgrade process.
Step 6 Click OK on any informational messages that display.
Step 7 Click Install.
Step 8 Reboot the server when the upgrade completes.
Step 9 Open the Web Setup tool from the Installer dialog box or desktop shortcut.
Step 10 Edit the instance as necessary.

For a domain change, change the domain of the instance. Additionally, you might need to change the facility
or instance number as required.

Step 11 Edit the Call Router component as necessary.

If the registry now references out-of-date network interface names or IP addresses for the public and private
networks for the router, update this information.

Step 12 Use Unified CCE Service Control to set all Unified CCE services on the new Call Router to Manual Start.

Migrate HDS Database and Upgrade Unified CCE Administration & Data Server
To upgrade the Administration & Data Server, do the following tasks:

• Migrate the HDS database (if applicable. Non-HDS configurations do not require this action.)

• Import the Cisco registry information.

• Install the new software.

• Set up the new Administration & Data Server through the Web Setup tool.

The Installer upgrades the AW database that is associated with the Administration & Data server. The EDMT
does not upgrade the AW database.

Before you begin

Create a shared folder in any desired location. Ensure that:

• in the Properties window > Sharing tab > Advanced Sharing, the Share this folder checkbox is checked.

• in the Properties window > Security tab, the permission level is set as full control for everyone .
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Procedure

Step 1 Use Unified CCE Service Control to stop all Unified CCE services on the server.
Step 2 For Administration & Data Server configurations with an HDS database, open the EDMT and click Next.

For non-HDS Server configurations, go to Migrate HDS Database and Upgrade Unified CCE Administration
& Data Server, on page 223.

Step 3 Select Technology Refresh and click Next.
Step 4 Under Source Database Connection, in the HostName\IP Address field, type the Source IP and click

Refresh Database List.
Step 5 Select the HDS Database name, and click Next.
Step 6 In the Windows Share Name field, type the name of the shared folder that you created.
Step 7 In the Windows Share Password field, type the password of the destination machine, and click Next.
Step 8 Review or change the information displayed as required, highlight the HDS database, and click Start Migration.
Step 9 Exit the EDMT.
Step 10 Launch the ICM-CCE-Installer 11.0(1) and click Next.
Step 11 (Optional) To apply any Minor Releases or other Maintenance Releases, click Browse and navigate to the

Minor Release software. Click Next.
Step 12 (Optional) Select SQL Server 2014 Security Hardening and click Next.
Step 13 Select Technology Refresh and click Next.
Step 14 Specify the path for the RegUtil file you exported from the source machine during the preupgrade process.
Step 15 Click OK on any informational messages that display.
Step 16 Click Install.
Step 17 Reboot the server when the upgrade completes.
Step 18 Open the Web Setup tool from the Installer dialog box or desktop shortcut.
Step 19 Edit the instance as necessary.
Step 20 (Optional) In case of Cross Domain upgrade, launchWebsetup, select instance and click on "Change Domain"

in order to use the new domain for destination UCCE.

Edit instance and you might need to change the facility or instance number if required.

Step 21 Edit the Administration & Data Server component as necessary.

If the registry now references out-of-date network interface names or IP addresses for the public and private
networks for the server, update this information.

Step 22 Use Unified CCE Service Control to set all Unified CCE services on the new Administration & Data Server
to Manual Start.

The time required to complete a data migration varies in a direct relationship to the database size
(the larger the database size, the longer it takes to migrate) and the server hardware performance
level.

Note
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Synchronizing or Updating Data from Logger or HDS Production Server to
Staged 11.6(1) Server During Cut-over

The EDMT tool can also be used to migrate data from a Logger or HDS production server, to the one that has
already been staged on version 11.6(1). These two pronged upgrade steps are typically performed to reduce
the downtime needed during cut-over to the new version.

While the parallel 11.6(1) systems are staged and tested, the 10.x production servers continue to process calls.
On the day of the cut-over, the data in the 11.6(1) staged servers, can be updated or synchronized with that
of the production server, by running the 11.0 EDMT tool, for each of the Logger and HDS database.

This will synchronize the database with 11.0 schema. However, due to the 11.6(1) database schema version
(188, 1, and 1)# being different from its base 11.0 version (181, 3, and 3), the synchronized database will be
incompatible with 11.6(1). The administrator would have to manually use upgrade.exe utility to upgrade the
database schema before starting the CCE Logger or Distributor service.

EDMT is not required while upgrading from 11.0 to 11.6 as the 11.6 installer is capable of performing the
backup.

Note

The utility is present in the icm\bin folder, and needs to be run against each of the database that was updated
/ synchronized from the production server.

Perform the following steps to use the tool:

<Install Drive>: \icm\bin>upgrade.exe -s <Server Name> -d <Database name>
-dt <Database Type> -i <Instance Name>

Where

<Database Type> - can be either " logger" or "hds", depending on the database that requires the schema to
be upgraded.

For Example C:\icm\bin>upgrade -s PRGR-A -d abc_sideA -dt logger -i abc

# - The value as stored in columns Major,CCMinor, and AWMinor of Version table in the CCE database.

Stop the Logger, AW-HDS, and Apache Tomcat services on 11.6 staged systems, before running the EDMT
tool while changing over to synchronize.

Note

Upgrade Peripheral Gateways
You can upgrade different Peripheral Gateways (PGs) within a contact center at different times within different
maintenance windows. However, upgrade all PGs that reside on the same virtual machine and redundant PGs
(Side A and corresponding Side B) during the same maintenance window.

The following dependencies occur when upgrading the Unified Communications Manager PG:

• If your contact center uses the CTI OS component, upgrade the CTI OS server at the same time as the
associated Unified Communications Manager PG.
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• If your contact center uses Outbound Option, upgrade any Outbound Option Dialers associated with
Unified Communications Manager PGs at the same time.

• If the Unified Communications Manager application is upgraded, upgrade the JTAPI client associated
with the Unified Communications Manager PG at the same time.

Procedure

Step 1 Use Unified CCE Service Control to stop all Unified CCE and CTI OS (if applicable when upgrading the
Unified Communications Manager PG) services on the PG server. Change the services to Manual Start.

Step 2 Launch the ICM-CCE-Installer and click Next.
Step 3 (Optional) To apply any 11.5(1) Minor Releases or other Maintenance Releases, click Browse and navigate

to the Maintenance Release software. Click Next.
Step 4 (Optional) To apply any 11.6(1) Minor Releases or other Maintenance Releases, click Browse and navigate

to the Maintenance Release software. Click Next.
Step 5 Select Technology Refresh and click Next.
Step 6 Specify the path for the RegUtil file you exported from the source machine during the preupgrade process.

The registry information for the Unified Communications Manager PG also contains information for the CTI
OS server (if applicable).

Step 7 Click OK on any informational messages that display.
Step 8 Click Install.
Step 9 Reboot the system after the upgrade completes.
Step 10 After reboot, open the Peripheral Gateway Setup tool from the Installer dialog box or desktop shortcut and

make any necessary changes. See the "Install" section of this document for specific information.

If the registry now references out-of-date network interface names or IP addresses for the public and private
networks for the PG, update this information.

Upgrade Outbound Option Dialer
To upgrade the Outbound Option Dialer, import the Cisco registry information, install the new software, and
set up the new Dialer using the PG Setup tool.

Before you begin

You must have previously migrated the Outbound Option database during the Logger upgrade.

Procedure

Step 1 Launch the ICM-CCE-Installer and click Next.
Step 2 (Optional) To apply any Maintenance Releases, click Browse and navigate to the Maintenance Release

software. Click Next.
Step 3 Select Technology Refresh and click Next.
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Step 4 Click Browse and specify the path for the RegUtil file you exported from the source machine during the
preupgrade process.

Step 5 Click OK on any informational messages that display.
Step 6 Click Install.
Step 7 Reboot the system after the upgrade completes.
Step 8 Run the mandatory update before applying any ES, if you have a fresh install or Technology Refresh upgrade

planned for PCCE or UCCE 12.0(1), on the Windows Server 2016. You can download the CCE 12.0
Mandatory Update for Fresh Install/Tech Refresh from
https://software.cisco.com/download/home/268439622/type/280840583/release/12.0(1).

Step 9 Open the Peripheral Gateway Setup tool from the Installer dialog box or desktop shortcut and edit the Dialer
as required.

Step 10 Use Unified CCE Service Control to set all Unified CCE services to Automatic Start.

Related Topics
Migrate the Logger Database and Upgrade the Logger, on page 221

Upgrade Unified CCE Administration Client
There is no support for Administration Clients to be upgraded via Technology Refresh upgrade. Either perform
an in-place common ground upgrade of Administration Clients, and make edits as necessary using the
Administration Client setup, or perform a fresh installation of Administration Client on a new system.

Related Topics
Install Unified CCE Administration Client, on page 55
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C H A P T E R 10
Upgrade from a Standalone Deployment to a
Coresident Deployment (Cisco Unified
Intelligence Center with Live Data and IdS)

• Upgrade from a Standalone to a Co-resident Deployment, on page 229
• Set Deployment Type in Unified CCE Administration Configuration, on page 229
• Install and Upgrade COP File, on page 230
• Install Publisher/Primary Nodes of VOS-Based Contact Center Applications, on page 231
• Install Subscribers/Secondary Nodes of VOS-Based Contact Center Applications, on page 232
• Set Up the System Inventory, on page 234
• Install Vmware Tools, on page 234
• Configure Live Data with AW, on page 234
• Configure Live Data Unified Intelligence Center Data Sources, on page 235
• Restart Live Data, on page 236

Upgrade from a Standalone to a Co-resident Deployment
Release 11.6(1) adds a new deployment type called UCCE: 2000 Agents Rogger, that should be set for such
deployments. The reference VM layout uses oversubscription to minimize the required ESXi hosts. If you
have an existing standalone deployment and want to transition to the co-resident layout, then this upgrade is
essential.

Set Deployment Type in Unified CCE Administration
Configuration

Ensure that the deployment type has been set to UCCE: 2000 Agents Rogger via CCE Web Administration
tool.

Perform the following steps to set the deployment:
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Procedure

Step 1 On Administration & Data Server open the Unified CCE Tools folder.
Step 2 Go to Administration Tools > CCE Web Administration.

Step 3 Log in as a Config security group member in the user@domain.
Step 4 Double-click Unified CCE Administration.
Step 5 Go to Infrastructure Settings > Deployment Settings.
Step 6 On the Deployment Type page, select UCCE: 2000 Agents Rogger deployment from the drop-down list

and then click Next.

Whenever you change the deployment type, you need to restart the Apache Tomcat on Logger and
AWs.

Note

Install and Upgrade COP File
Before upgrading CUIC standalone deployment to a coresident UCCE:2000 Agents deployment (CUIC with
Live Data and IdS), perform the following steps:

Procedure

Step 1 Install the COP file:

• To upgrade from UCCE 10.5 to 11.6(1):

a. Apply RU COP "ciscocuic.refresh_upgrade_v1.4.cop.sgn" on CUIC
b. Upgrade CUIC 10.5 to CUIC 11.0(1)
c. In case of "UCCE 2000 Agents Rogger model, install co-resident deployment COP

"ciscocuic.cce2k-cores-deployment.cop.sgn" on CUICVM to get the benefits of Coresident of CUIC,
LD and IDS.

d. Upgrade CUIC 11.0(1) to CUIC 11.6(1)

• To upgrade from UCCE 11.0(1) to 11.6(1):

a. In case of "UCCE 2000 Agents Rogger model, install co-resident deployment COP
"ciscocuic.cce2k-cores-deployment.cop.sgn" on CUIC to get the benefits of Coresident of CUIC,
LD and IDS.

b. Upgrade CUIC 11.0(1) to CUIC 11.6(1)

For detailed steps on installing and upgrading COP files, see https://www.cisco.com/c/en/us/td/docs/voice_
ip_comm/cust_contact/contact_center/intelligence_suite/intelligence_suite_1105/install/gudie/CUIC_BK_
IF498FAF_00_installation-and-upgrade-guide-for/CUIC_BK_IF498FAF_00_
installation-and-upgrade-guide-for_chapter_01000.html?bookSearch=true#task_
E972191E3AB1E59C20C9B653359792B9.
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Step 2 Delete the standalone Live Data virtual machine after you have upgraded the standalone deployment to a
coresident deployment.

Install Publisher/Primary Nodes of VOS-Based Contact Center
Applications

Before you begin

DNS Configuration is mandatory for installation of Cisco Unified Communications Manager, Cisco Unified
Intelligence Center, Cisco Finesse and Cisco Identity Service (IdS). To configure DNS, add the VMs to the
forward and reverse lookups of the DNS.

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine, power it on, and open the console.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen:

• For the Progger (Lab only) or 2000 agent reference design, choose the coresident deployment option
Cisco Unified Intelligence Center with Live Data and IdS, and then selectOK. TheCisco Unified
Intelligence Center with Live Data and IdS option installs Cisco Unified Intelligence Center with
Live Data and Cisco Identity Service (IdS) on the same server.

• For all other deployments, select one of the standalone install options. For example, select Cisco
Unified Intelligence Center, Live Data, or Cisco Identity Service (IdS). Then select OK.

d) In the Proceed with Install screen, select Yes.
e) In the Platform Installation Wizard screen, select Proceed.
f) In the Apply Patch screen, select No.
g) In the Basic Install screen, select Continue.
h) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

i) In the Auto Negotiation Configuration screen, select Continue.
j) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
k) In the DHCP Configuration screen, select No.
l) In the Static Network Configuration screen, enter static configuration values. Select OK.
m) In the DNS Client Configuration screen, click Yes to enable DNS client.
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n) Enter your DNS client configuration. Select OK.
o) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
p) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
q) In the First Node Configuration screen, select Yes.
r) In the Network Time Protocol Client Configuration screen, enter a valid NTP server IP address and

select OK.
s) In the Security Configuration screen, enter the security password and select OK.
t) In the SMTP Host Configuration screen, select No.
u) In the Application User Configuration screen, enter the application username. Enter, and confirm the

application user password. Select OK.
v) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 5 Unmount the ISO image.

Install Subscribers/Secondary Nodes of VOS-Based Contact
Center Applications

This task is required for installation of the subscriber/secondary nodes of the three VOS-based contact center
applications: Cisco Finesse, Cisco Unified Communications Manager, and Cisco Unified Intelligence Center.

Note

Before you begin

DNS Configuration is mandatory for installation of Cisco Unified Communications Manager, Cisco Unified
Intelligence Center, and Cisco Finesse. To configure DNS, add the VMs to the forward and reverse lookups
of the DNS.

Before you install the subscriber/secondary nodes, youmust install the publisher/primary nodes and configure
the clusters.

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine and power it on, and open the console.
Step 4 Follow the Install wizard, making selections as follows:
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a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen:

• For the Progger (Lab only) or 2000 agent reference design, choose the coresident deployment option
Cisco Unified Intelligence Center with Live Data and IdS, and then selectOK. TheCisco Unified
Intelligence Center with Live Data and IdS option installs Cisco Unified Intelligence Center, Live
Data, and Cisco Identity Service (IdS) on the same server.

• For all other deployments, select one of the standalone install options. For example, select Cisco
Unified Intelligence Center, Live Data, or Cisco Identity Service (IdS). Then select OK.

Step 5 Follow the Install wizard, making selections as follows:
a) In the Proceed with Install screen, select Yes.
b) In the Platform Installation Wizard screen, select Proceed.
c) In the Apply Patch screen, select No.
d) In the Basic Install screen, select Continue.
e) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

f) In the Auto Negotiation Configuration screen, select Continue.
g) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
h) In the DHCP Configuration screen, select No.
i) In the Static Network Configuration screen, enter static configuration values. Select OK.
j) In the DNS Client Configuration screen, click Yes to enable DNS client.
k) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
l) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
m) In the First Node Configuration screen, select No.
n) In the warning screen, select OK.
o) In the Network Connectivity Test Configuration screen, select No.
p) In the First Node Access Configuration screen, enter the host name and IP address of the first node.

Enter and confirm the security password. Select OK.
q) In the SMTP Host Configuration screen, select No.
r) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 6 Unmount the ISO image.
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Set Up the System Inventory
Procedure

Step 1 In Unified CCE Administration, navigate to Infrastructure Settings > Inventory .
Step 2 Add the new machine to the System Inventory:

a) Click New.

The Add Machine popup window opens.

b) From the Type drop-down menu, select the following machine type:

CUIC_LD_IdS Publisher, for the coresident Unified Intelligence Center, Live Data, and Identity Service
machine available in the 2000 agent reference design.

c) In the Address field, enter the FQDN or IP address of the machine.
d) Enter the machine's Administration credentials.
e) Click Save.

The machine and its related Subscriber or Secondary machine are added to the System Inventory.

Install Vmware Tools
To ensure that your version of the VMware Tools is current, refresh the installed version of VMware Tools
from the local VMware host on both Live Data nodes.

Procedure

Step 1 Log in to the primary Live Data node.
Step 2 Run the command to update the VMware Tools: utils vmtools refresh

Step 3 Log in to the secondary Live Data node.
Step 4 Run the command to update the VMware Tools: utils vmtools refresh

Configure Live Data with AW
This command tells Live Data how to access the primary AW DB and the secondary AW DB. The command
also automatically tests the connection from Live Data to the primary or secondary AW, checks to see if the
configured user has appropriate AW DB access, and reports the results.
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You can use the optional skip-test parameter if you do not want the test performed. When you include the
skip-test parameter, no checking is done to see if the configured user has appropriate AW DB access, and no
results are reported.

You do not need to configure the AW DB on both the Publisher and the Subscriber. The configuration is
replicated between the Publisher and the Subscriber.

Note

Before you begin

Before you can configure Live Data, you must first configure a SQL user (with special permissions) to work
with Live Data, as described in Configure SQL User Account, on page 128.

The SQL administrative user "sa" or a user with sysadmin privileges must then execute the following SQL
queries for the SQL user configured to work with Live Data.
USE master
GO
GRANT CONTROL ON CERTIFICATE :: UCCESymmetricKeyCertificate TO "<user>"
GRANT VIEW DEFINITION ON SYMMETRIC KEY :: UCCESymmetricKey TO "<user>"

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure Live Data with the primary AW DB. The command automatically

tests the connection from Live Data, checks the user permission, and displays results.

(The skip-test parameter is optional; include it only if you do not want the test performed).

set live-data aw-access primary addr port db user pwd [skip-test]

Step 3 Run the following command to configure Live Data with the secondary AWDB. The command automatically
tests the connection from Live Data, checks the user permission, and displays results.

(The skip-test parameter is optional; include it only if you do not want the test performed).

set live-data aw-access secondary addr port db user pwd [skip-test]
You can also optionally run the following command at any time to show and test the AW configuration that
you set from Live Data to the primary and secondary AW DBs.

(The skip-test parameter is optional; include it only if you do not want the test performed).

show live-data aw-access [skip-test]

Configure Live Data Unified Intelligence Center Data Sources
This command tells Unified Intelligence Center how to access Live Data.
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Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure your Live Data Unified Intelligence Center data sources:

set live-data cuic-datasource cuic-addr cuic-port cuic-usercuic-pwd

Restart Live Data
After you complete the configuration procedures for the AW and the Unified Intelligence Center data source,
restart the Live Data system to enable the changes.

Procedure

Access the Live Data CLI and run the following command:
utils system restart
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C H A P T E R 11
Uninstall Unified CCE Release 11.6(1)

• Uninstall Methods, on page 237
• Temporary Uninstallation, on page 237
• Permanent Uninstallation , on page 238
• Uninstall Unified CCE Release 11.6(1), on page 240

Uninstall Methods
When you uninstall Unified CCE Release 11.6(1), you must choose one of two methods of uninstallation:

• Temporary - leaves the schema unmodified

• Permanent - reverts the database schema to the previous schema version

The option to temporarily or permanently uninstall Unified CCE Release 11.6(1) appears only when you try
to perform this task on a machine that is running the following components:

• Logger

• AW only

• HDS

• AW-HDS

Temporary Uninstallation
In a temporary uninstallation, the schema that was updated during the upgrade process does not revert to
previous version of Unified CCE Release 11.6(1). Use this method of uninstallation when you want to rerun
the Unified CCE Release 11.6(1) installer to fix initial installation issues. This method is also useful when
you want to upgrade to a future maintenance release.

The Logger, AW, and HDS components check the version table in the ICM database schema for their
corresponding schema version. If the versions of the schema and the executable do not match, the system
generates an error message and the services are shut down. This error is captured in the component logs.

Note
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Permanent Uninstallation
In permanent uninstallation, both the application and the database schema change. Uninstallation will revert
the system and the database to previous version of Unified CCE Release 11.x.

A permanent uninstallation is necessary if you wish to revert to previous version of Unified CCE Release
11.x.

Configuration data may change when you revert to previous version of Unified CCE Release 11.x:

• Newly added non-voice PQs are converted to voice PQs.

• Agent login names that exceed 32 characters are truncated.

Use the data from the previous version of Unified CCE Release11.x configuration database or the virtual
machine which you backed up before starting the upgrade process.

Note

If you have used the ICMDBA tool to create an Outbound Option database on Logger Side B, you canmanually
delete the database after the uninstall by using SQL Server Management Studio (SSMS). If you have enabled
Outbound Option two-way replication, you must disable replication from both Logger Side A and Logger
Side B before you can delete the database.

If there are any database schema rollback errors encountered during permanent uninstall, the database schema
may be in a corrupted state. The state prevents CCE Logger / Distributor services to start correctly due to
schema mismatch. To recover from the state, the ICMDBA tool can be used to recreate the Logger or HDS
database that may have failed.

Configuration data lost due to the schema rollback failure on the logger database, can be recovered by
re-importing the configuration database backup that the patch installer would have taken, during 11.5(1)
upgrade.

Configuration data lost due to the schema rollback failure on the logger database, can be recovered by
re-importing the configuration database backup that the patch installer would have taken, during 11.6(1)
upgrade.

Configuration data lost due to the schema rollback failure on the logger database, can be recovered by
re-importing the configuration database backup that the patch installer would have taken, during 12.6(1)
upgrade.

Important

Routing Scripts which has dynamic queues configured for skill group node will not be accessible after
permanent rollback to previous version of Unified CCE Release 11.x.

Note

Rollback Caveats
The section provides following information about permanent Rollback to version 11.0(x):
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1. Routing Scripts which have dynamic queues configured for skill group node are not accessible after
permanent rollback to previous version of Unified CCE Release 11.x.

2. SSO global and agent/supervisor level configuration, if set, will be removed after rollback to 11.0(x).

3. Agent or Supervisor login names in UPN format gets converted to user account name (netbios name)
only. Any login name which exceeds 32 characters gets truncated.

4. If the deployment type has been set to the newly introduced UCCE 2000 Agents Rogger deployment type,
then the installer would prevent any rollback to the previous version, unless the deployment type is changed
to a deployment type like UCCE 4000 Agents, that is supported in the previous release.

5. Unified CCE 11.6(1) has configuration limits enhanced for some of the deployment types. The configuration
limits do not get reverted back after performing a rollback to previous version. One would have to reset
the previous deployment type again using CCE Admin tool to reset the configuration limit.

For more information on Configurtion Limit change in 11.6(1), see Solution Design Guide for Cisco
Unified Contact Center Enterprise at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-implementation-design-guides-list.htmlhttp://www.cisco.com/
c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html

6. Newly Added non-voice PQs are converted to voice PQs rollback to 11.0(x).

7. If Outbound Option is enabled with or without high availability on LoggerB side, permanent uninstallation
of 11.6(1) is not allowed. Disable outbound option on LoggerB database before performing uninstallation
of 11.6(1).

8. Upgraded Java 1.8_0_121 are not removed after uninstallation.

Revert Tomcat
For detailed information on the results from each step, see the ../UpgradeTomcatResults/UpgradeTomcat.log
file.

Stop Unified CCE services on the VM before using the Tomcat Utility.Note

Procedure

Step 1 From the command line, navigate to the directory where you copied the Upgrade Tomcat Utility.
Step 2 Enter this command to run the tool: java -jar UpgradeTomcatTool-<version>.jar -revert

For example:
java -jar UpgradeTomcatTool-<version>.jar -revert

Step 3 When prompted, enter yes to continue with the reversion.
Step 4 Repeat these steps for all unified CCE component VMs.
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Uninstall Unified CCE Release 11.6(1)
This procedure assumes that you are uninstalling the Unified CCE Release 11.6(1) upgrade from a machine
that is running the database.

If you have enabled the optional feature Outbound Option High Availability, you must disable it before you
can uninstall the upgrade. From Unified CCE Web Setup, choose Component Management > Loggers.
Select a logger that is enabled for High Availability, and clickNext until theAdditional Options page appears.
Uncheck the Enable High Availability check box. Perform this action for each logger enabled for Outbound
Option High Availability.

Procedure

Step 1 Log in to your system as a user with administrative privileges.
Step 2 Choose Control Panel > Programs and Features > Cisco ICM Minor Release ICM 11.6(1) > Uninstall.

The InstallShield Wizard launches.
Step 3 Select either permanent or temporary uninstallation.

a) If you choose temporary uninstallation, follow the on-screen instructions to temporarily uninstall the
application.

b) If you choose permanent uninstallation and you have enabled Outbound Option High Availability, a
message appears informing you that you disable High Availability before you can proceed with the
uninstallation. Disable High Availability, and then restart the upgrade uninstallation process.

If you have set UCCE: 2000 Agents Rogger deployment, a message appears. The message informs you
to change the deployment type before you uninstall the Unified CCE Release 11.6.

Step 4 On the Database Schema Rollback window, specify if you want to proceed with the uninstallation.
ActionOption

Go to step 5Yes

The uninstallation process cancelsNo

Step 5 On the confirmation window, click Yes.
Step 6 (Optional) On the Installation Messages window, click Next.

Post InstallationWindow specifies if any service is set to manual than a pop-up window displays a notification
that some services were automatically changed to manual as part of the uninstallation. Make sure that both A
and B sides of your system operate properly after uninstalling Unified CCE Release 11.6(1). Then, set the
ICM services that were changed during the uninstallation back to their original setting (Automatic).

Step 7 At the prompt, restart the machine.

The Unified CCE Release 11.6(1) application is uninstalled from your machine.
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C H A P T E R 12
Testing

• Testing Overview, on page 241
• Testing Tasks, on page 241

Testing Overview
System testing is a part of the installation, upgrade, and ongoing maintenance of a Unified CCE solution.
Testing requirements and processes vary from customer to customer. Therefore, specific steps for executing
tests are not included in this document.

For installations, testing must ensure all aspects of contact center operation before going live.

For upgrades, at the beginning of each maintenance window, consider running preupgrade tests to establish
a benchmark. The benchmark is used when you run the postupgrade tests. Postupgrade tests are necessary for
each maintenance window to ensure continued contact center operation throughout the entire upgrade process,
which can span multiple maintenance windows.

If you require assistance with Unified CCE solution testing, work with your Cisco representative.

Contact centers need established tests plans and processes for all aspects of contact center operation. Have
the plans, tools, and processes in place to test your contact center.

Testing Tasks

Verify Upgrade to Cisco Unified Customer Voice Portal
After upgrading Unified CVP, verify the following:

Procedure

Step 1 Verify that error messages did not display during the upgrade process.
Step 2 Check the upgrade logs for error messages.
Step 3 Ensure that the Unified CVPOperations, Administration,Monitoring and Provisioning (OAMP)Web interface

is available for use.
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Step 4 Use the diagnostic page at http://<CVPHOST>:8000/cvp/diag to verify the status of the Unified CVP system.
Step 5 Use the Operations Console (System > Control Center, Device Pool tab) to verify that the upgraded Unified

CVP Call Servers, Unified CVP VXML Server and Unified CVP Reporting Server show a status of “Up”.
Step 6 Use the Operations Console (Device Management >Unified CVP Call Server, General tab for selected Call

Server) to verify that the Device Version reflects the correct upgraded version.
Step 7 Verify that the appropriate voice prompt is heard when the call is made.
Step 8 Ensure that the Unified CVP license is properly installed.

Verify IOS Gateway Upgrade
After upgrading IOS gateways, verify the following:

Procedure

Step 1 At the Cisco IOS exec level, execute the following CLI commands:

• To check that the upgraded IOS target image is running:

show version

• To verify that the boot system is configured to boot the correct image:

show running-config

• To verify that configuration done previously is not lost:

show running-config

• To verify that the ISDN connection status is at MULTIFRAME_ESTABLISHED:

show isdn status

• To verify that configured interfaces are in up/up state:

show ip interface brief

• To verify manually placed incoming calls:

show isdn history

• To verify IP routing from branch site to a data center:

ping or traceroute

• To verify IP routing from one branch site to another branch site:

ping or traceroute

Step 2 Ensure that the following devices are configured and registered correctly: Gatekeeper, trunks, and CTI Route
Point.

Step 3 Ensure that all MGCP end points (FXS, FXO, PRI, T1 CAS and BRI) are properly registered with Unified
Communications Manager.

Step 4 Manually spot check calls as appropriate from the PSTN vis SIP Gateways.
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Step 5 Verify that a PSTN user who places an inbound call from the PSTN to a Unified IP Phone in a Unified
CommunicationsManager cluster through gateways and puts the call on hold can hearMusic-on-Hold (MOH)
and can also finally resume the call.

Verify Upgrade to Cisco IOS-Based Transcoders and Conference Bridges
After upgrading Cisco IOS-based transcoders and conference bridges, verify the following:

Procedure

Step 1 Check if the complete configuration before the upgrade still exists.
Step 2 Check if all DSPs are registered and are functioning normally.
Step 3 Check if there are no error messages in the buffer log or console.
Step 4 Check if no dump file is created in the flash memory.
Step 5 To verify that the configuration is not lost, type the “show running-config” command.
Step 6 To verify that the interfaces are in up state, type the “show ip interface brief” command.
Step 7 Make an inbound call to a Unified IP Phone through a gateway and conference the call with another Unified

IP Phone, using a conference bridge in the gateway.
Step 8 Verify IOS Transcoding is working with G711 codec configure for one device while G729 codec is configured

on another device.

Verify Upgrade to Cisco Unified CCE Router and Logger
After upgrading the Cisco Unified CCE Router and Logger, verify the following:

Procedure

Step 1 Verify basic operations such as the following:

• Setup logs indicate no errors or failure conditions (icmsetup.txt and ICMInstall.txt, located in the \Temp
directory of the disk on which the application was installed).

• All components can “ping” public and private IP addresses as applicable.
• Schema upgrade is successful for all databases and there is no loss of data integrity or data.
• All component services start correctly without generating errors.
• Firewalls and other security measures do not block the ability to access Microsoft SQL Server and to
run third-party software components, like VNC or PCAnywhere.

• Ccagent is in service and connected to any Peripheral Gateways located in Side A.
• Recovery process not required, no activity other than process start-up.
• Configuration information is passed to the Router by the Logger. Replication process begins when the
Historical Database Server comes online.

• Replication process begins with no errors. (Use the Windows Event Viewer to view Windows Event
logs).
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• The Router is in a synchronized state. (Use the Diagnostic Framework Portico, under ListProcesses,
verify that the status of ccagent and mdsproc is "InSvc".)

• Database space allocation and % used are reported correctly. (Use the dumplog utility to view the hlgr
and rcv processes on the Logger server. The trace messages display the percentage of available free space
and the log space of the database at 30-second intervals. Verify this using Microsoft SQL Management
Studio to view the Logger database properties.)

Step 2 Use the Windows Event Viewer on each server to check that no exceptions, errors, or unexpected events have
occurred. Select Administrative Tools > Event Viewer, then expand Windows Logs and review the
Application and System logs.

Step 3 Verify that configuration changes can be made and are passed to the Logger and AW databases.
Step 4 Ensure that basic calls and call functionality such as transfers, conferences, call treatment and queuing are

working properly.

Verify Upgrade to Cisco Real Time Administration Workstation, Historical
Database Server

After upgrading the Real Time AW/HDS software, verify the following:

Procedure

Step 1 Use the Windows Event Viewer on each server to check that no exceptions, errors, or unexpected events have
occurred. Select Administrative Tools > Event Viewer, then expand Windows Logs and review the
Application and System logs.

Step 2 After Side A Central Controller components have been upgraded, verify basic operations such as the following:

• Setup logs indicate no errors or failure conditions (for 11.0,icmsetup.txt and ICMInstall.txt, located in
the \Temp directory of the disk on which the application was installed and for 11.6 Minor Release
YYYYMMDD_HHMMSS_Minor Release ICM11.6(1).log located in the C:\Temp\Minor Release
ICM11.6(1) directory of the disk on which the application was installed).

• All components can “ping” public and private IP addresses as applicable.
• Schema upgrade is successful for all databases and there is no loss of data integrity or data.
• All component services start correctly without generating errors.
• All general activities such as the ability to access SQL server and to run third-party software components
like VNC or PCAnywhere, etc. are not stopped by any security application.

• Rtsvr, the process that provides real time data from the Router to the AW database, is connected to the
primary Administrative Workstation. (Open the Configuration Manager tool on Administration & Data
server. If the tool opens without any errors, the feed is active. Additionally, use the Dumplog utility to
view the uaw process. The uaw trace message shows "Waiting for new work…".)

• Configuration information is passed to the router by the Logger. Replication process begins when the
Historical Database Server comes online.

• Real Time Administrative Workstation indicates that it is ready.
• Replication process begins with no errors. (use the Windows Event Viewer to view Windows Event
logs).

• Authorized users are able to use the ConfigurationManager on the Real TimeAdministrativeWorkstation.
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• Authorized users are able to log into Cisco Unified Intelligence Center and can access both public and
private reports and that all previously existing reports are still available.

• Previous settings for users are still valid when any application is opened.
• The “Validate All” script yields the same results after the upgrade as prior to the upgrade.

All existing scripts can be opened and edited and new scripts can be created.Note

• Database space allocation and % used are reported correctly. (Use the dumplog utility to view the hlgr
and rcv processes on the Logger server. The trace messages display the percentage of available free space
and the log space of the database at 30 second intervals. Verify this using Microsoft SQL Management
Studio to view the Logger database properties.)

• Diagnostic Framework Portico can acquire logs, capture registry information, and schedule collection
of logs.

• Verify that configuration changes are possible.

Verify Upgrade to Peripheral Gateways
After upgrading the peripheral gateways, verify the following:

Procedure

Step 1 Use the Windows Event Viewer on each server to check that no exceptions, errors, or unexpected events have
occurred. Select Administrative Tools > Event Viewer, then expand Windows Logs and review the
Application and System logs.

Step 2 Ensure that real time and historical data is sent to the Router and AW database.
Step 3 Ensure that basic calls and call functionality (such as transfers, conferences, call treatment and queuing) are

working properly.
Step 4 Ensure that the peripheral is running properly on the upgraded gateway by verifying call flows, CTI desktops,

Outbound Option, and other applications.

Verify Redundancy
After you upgrade both sides of all redundant components, verify the following:

Procedure

Step 1 Stop each active component.
Step 2 Ensure that the backup component assumes an active state and that the system operation switches to the backup

component with no loss of functionality.
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Verify Upgrade to Cisco Unified Communications Manager
After upgrading Unified Communications Manager, verify the following:

Procedure

Step 1 Verify that no error messages have occurred during the upgrade process.
Step 2 Check the upgrade log file for any errors.
Step 3 Start all first node and subsequent node servers.
Step 4 Verify that there is no replication failure between the first node and subsequent node servers.
Step 5 Verify that SIP and SCCP IP Phones are registered with Unified Communications Manager.
Step 6 Ensure that the following devices are configured correctly: gatekeeper, trunks, and CTI route points.
Step 7 Ensure that the media resources (conference bridges, MTP and transcoders) are configured correctly by

checking their status.
Step 8 Verify if the end users are able to connect to their CTI managers.
Step 9 Check if the license usage is correct as reported in the License Unit Report.
Step 10 Check if services on all servers in the cluster are up.
Step 11 Perform the Unified Communications Manager first node and subsequent node process verification using the

following Real Time Monitoring Tool feature verification process:
a) Verify if Multiple Route Patterns and Route Lists are configured and working properly.
b) Verify if Extension Mobility is configured and working properly.
c) Verify if Unified IP Phone Services are configured and working properly.
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A P P E N D I X A
CLI Commands during Installation and Upgrade

• Live Data CLI Commands, on page 247
• Transport Layer Security CLI Commands, on page 258

Live Data CLI Commands

Supported Character Set for Live Data Installation CLI Commands
When working with the CLI (and not exclusively for Live Data), you can use plain alphanumeric characters
[0-9] [A-Z] [a-z] and the following additional characters:

• ". " (dot)

• "!" (exclamation mark)

• "@" (at sign)

• "#" (number sign)

• "$" (dollar)

• "%" (percent)

• "^" (caret)

• "*" (star)

• "_" (underscore)

• "+" (plus sign)

• "=" (equal sign)

• "~" (tilde)

• ":" (colon)

• "(" and ")" (open and close parentheses)

• "{" and "}" (open and close brackets)

• "[" and "]" (open and close square brackets)
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Spaces are used as input separators.Most special characters carry specific meaning to the Cisco Voice Operating
System (VOS) command console (for example, "\", "|", and so on). Characters above standard ASCII are
mostly ignored.

Privilege Levels for Live Data Commands
The Live Data CLI commands support the following privilege levels:

• Ordinary

• Advanced

Each Live Data command has a required privilege level related to the sensitivity of data it exposes or its ability
to severely affect the operation of the application. The privilege level for each command is the minimum level
required; a user with a higher privilege level also has access to the command.

The Cisco Voice Operating System (VOS) also supports a higher privilege level for the administrative user;
this user is configured at installation. When the administrative user creates other users (with the set account
name command), the administrative user sets each newly created user's privilege level. (For more information
about the set account command, see the Administration Console User Guide for Cisco Unified Intelligence
Center at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-maintenance-guides-list.html. )

Live Data AW DB Access

The Live Data AW DB access commands allow you to configure and display CCE AW DB (real-time
distributor) access for the Contact Center Enterprise Live Data Product Deployment Selection. By default,
the set and show commands also test the connection from Live Data to the primary or secondary AWdatabase,
check to see if the configured user has appropriate AW DB access, and report the results.

set live-data aw-access
Required Minimum Privilege Level: Advanced

Use this command to set the access information to the primary or secondary CCE AW. The command also
automatically tests the connection from Live Data to the primary or secondary AW, checks to see if the
configured user has appropriate AW DB access, and reports the results.

You can use the optional skip-test parameter if you do not want the test performed. No checking is done to
see if the configured user has appropriate AW DB access, and no results are reported.

Command Syntax
set live-data aw-access {primary | secondary} addr port db user pwd [skip-test]
addr

Specifies the hostname or IP address of the primary or secondary CCE AW (maximum 255 characters).

port

Specifies the listening port of the database server (range 1 through 65535).

db

Specifies the database name (maximum 128 characters).

user
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Specifies the login user (maximum128 characters).

pwd

Specifies the login password (maximum 128 characters).

skip-test

Skips the testing of the connection from Live Data to the primary or secondary AW. No checking is done to
see if the configured user has appropriate AWDB access, and no results are reported. The skip-test parameter
is optional.

Related Topics
Configure SQL User Account, on page 128
Configure Live Data with AW, on page 76

unset live-data aw-access
Required Minimum Privilege Level: Advanced

Use this command to unset the access information to the primary or secondary CCE AW DB.

Command Syntax
unset live-data aw-access {primary | secondary}

There is a single, required parameter with two possible values.

show live-data aw-access
Required Minimum Privilege Level: Ordinary

Use this command to display the primary and secondary CCE AW DB access information and test the
connection from Live Data to each AWDB, check to see if the configured user (on each node) has appropriate
AW DB access, and report the results.

You can use the optional skip-test parameter if you do not want the test performed. No checking is done to
see if the configured user (on each node) has appropriate AW DB access, and no results are reported.

Command Syntax
show live-data aw-access [skip-test]

Shows the configured primary and secondary CCE AW DB access information. There are no required
parameters.

skip-test

Skips the testing of the connection from Live Data to the primary or secondary AW. No checking is done to
see if the configured user (on each node) has appropriate AW DB access, and no results are reported. The
skip-test parameter is optional.

Related Topics
Configure SQL User Account, on page 128

Live Data Cluster Configuration
Use the following commands to set, unset, or show Live Data cluster configuration information.
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set live-data secondary
Required Minimum Privilege Level: Advanced

Use this command to register the Live Data secondary node.

Command Syntax
set live-data secondary name
name

Specifies the hostname or ip address of the Live Data secondary node.

unset live-data secondary
Required Minimum Privilege Level: Advanced

Use this command to unset Live Data secondary node configuration.

unset live-data secondary

There are no required parameters.

show live-data secondary
Required Minimum Privilege Level: Ordinary

Use this command to show Live Data secondary node configuration information.

show live-data secondary

There are no required parameters.

Live Data CORS Configuration
Live Data CORS commands allow you to configure CORS and hence allow web applications running on
different origins to communicate with Live Data.

Live Data CORS commands are available only after installing Cisco Unified Intelligence Center Release
11.6(1) ES18 or later in Unified CCE 11.6 release and Cisco Unified Intelligence Center Release 12.0(1)
ES06 or later in Unified CCE 12.0 release respectively.

Ensure that the CORS update commands are run on all the live data nodes in the cluster.

After you make changes to the CORS status, allowed origins, allowed headers, or exposed headers, restart
the Unified CCE Live Data NGINX service.

Note

utils live-data cors status

Required Minimum Privilege Level: Ordinary

Use this command to query the Live Data CORS status.
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Command Syntax
utils live-data cors status

There are no required parameters.

utils live-data cors enable

Required Minimum Privilege Level: Advanced

Use this command to enable CORS in Live Data.

Command Syntax
utils live-data cors enable

There are no required parameters.

For Unified Intelligence Centre gadgets (Live Data) to load in Cisco Finesse, ensure to:

• Enable CORS using utils cuic cors enable and utils live-data cors enable commands.

• Set the Finesse host URL in utils cuic cors allowed_origin add URLs and utils live-data cors

allowed_origin add URLs commands.

Examples:

• https://<finesse-FQDN>

• https://<finesse-FQDN>:port

Note

utils live-data cors disable

Required Minimum Privilege Level: Advanced

Use this command to disable CORS in Live Data.

Command Syntax
utils live-data cors disable

There are no required parameters.

utils live-data cors allowed_origin list

Required Minimum Privilege Level: Ordinary

Use this command to display the list of allowed URLS that can make CORS request to Live Data.

Command Syntax
utils live-data cors allowed_origin list

There are no required parameters.
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utils live-data cors allowed_origin add

Required Minimum Privilege Level: Advanced

Use this command to add the given list of URLs to the allowed origin list.

Command Syntax
utils live-data cors allowed_origin add URLs

URLs

Comma separated list of URLs (without spaces) that has to be added to the allowed origins list. The URL
should be of the format: http[s]://<hostname>[:port]

utils live-data cors allowed_origin delete

Required Minimum Privilege Level: Advanced

Use this command to delete a particular URL entry or all the URL entries from the allowed origins list.

Command Syntax
utils live-data cors allowed_origin delete

There are no required parameters. This command will prompt for a choice to delete a particular entry or all
URL entries from allowed origins list.

Example

Utils live-data cors allowed_origin delete

1. https://cisco.com

2. https://google.com

a: all

q: quit

utils live-data cors allowed_headers list

Required Minimum Privilege Level: Ordinary

Use this command to display the list of allowed headers that the client can use to make CORS request to Live
Data.

Command Syntax
utils live-data cors allowed_headers list

There are no required parameters.

utils live-data cors allowed_headers add

Required Minimum Privilege Level: Advanced

Use this command to add the given list of headers to the allowed header list.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 11.6(1)
252

CLI Commands during Installation and Upgrade
utils live-data cors allowed_origin add

https://cisco.com
https://google.com


Command Syntax
utils live-data cors allowed_headers add headers

headers

Comma separated list of headers (without spaces) that has to be added to the allowed headers list.

utils live-data cors allowed_headers delete

Required Minimum Privilege Level: Advanced

Use this command to delete a particular header entry or all the header entries from the allowed headers list.
The header names are case-insensitive and any duplicate header name will be ignored.

Command Syntax
utils live-data cors allowed_headers delete

There are no required parameters. This command will prompt for a choice to delete a particular entry or all
the header entries from the allowed headers list.

Example

Utils live-data cors allowed_headers delete

1. Header1

2. Header2

a: all

q: quit

utils live-data cors exposed_headers list

Required Minimum Privilege Level: Oridnary

This command displays the list of exposed headers that the client can expect from Live Data when it makes
CORS request to Live Data .

Command Syntax
utils live-data cors exposed_headers list

There are no required parameters.

utils live-data cors exposed_headers add headers

Required Minimum Privilege Level: Oridnary

This command adds given list of headers to the exposed header list.

Command Syntax
utils live-data cors exposed_headers add headers

headers

Comma separated list of headers that has to be added to the exposed headers list.
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utils live-data cors exposed_headers delete

Required Minimum Privilege Level: Oridnary

This command deletes a particular header entry or all the header entries from the exposed headers list. The
header names are case-insensitive, any duplicate header name will be ignored.

Command Syntax
utils live-data cors exposed_headers delete

There are no required parameters. This command will prompt for a choice to delete a particular entry or all
header entries from exposed headers list.

Example

Utils live-data cors exposed_headers delete.

1. Header1

2. Header2

a: all

q: quit

Live Data Reporting Configuration

set live-data reporting-interval
Required Minimum Privilege Level: Advanced

Use this command to set the Live Data reporting interval in minutes. The reporting interval is the duration of
time for which values are aggregated and reported for the To Interval fields.

Command Syntax
set live-data reporting-interval reporting-interval-in-minutes
reporting-interval-in-minutes

Specifies the reporting interval in minutes. The valid values are 5, 10, 15, 30, and 60 minutes.

When you set the Live Data reporting interval, restart the publisher and then the subscriber. Restart the inactive
node and then the active node by using the utils system restart command. (For more information about the
command, refer to the Administration Console User Guide for Cisco Unified Intelligence Center at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-maintenance-guides-list.html.)

If you restart only the publisher and not the subscriber, the new reporting interval takes effect only on the
publisher; likewise, if you restart the subscriber but not the publisher, only the subscriber uses the newly set
reporting interval.

When the publisher and the subscriber restart, use the show live-data reporting-interval command to validate
the new interval.

Related Topics
show live-data reporting-interval, on page 255
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show live-data reporting-interval
Required Minimum Privilege Level: Ordinary

Use this command to show the configured and current reporting interval for both the Live Data publisher and
subscriber.

Command Syntax
show live-data reporting-interval

unset live-data reporting-interval
Required Minimum Privilege Level: Advanced

Use this command to reset the Live Data reporting interval to the default value (which is five minutes).

Command Syntax
unset live-data reporting-interval

When you reset the Live Data reporting interval, restart the publisher and then the subscriber. Restart the
inactive node and then the active node by using the utils system restart command. (For more information
about the command, refer to the Administration Console User Guide for Cisco Unified Intelligence Center
at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-maintenance-guides-list.html.)

If you restart only the publisher and not the subscriber, the reset interval takes effect only on the publisher;
likewise, if you restart the subscriber but not the publisher, only the subscriber uses the reset reporting interval.

When the publisher and the subscriber restart, use the show live-data reporting-interval command to validate
the new interval.

Related Topics
show live-data reporting-interval, on page 255

Live Data Services Registration

set live-data cuic-datasource
Required Minimum Privilege Level: Advanced

Use this command to create or update the Live Data data source in Cisco Unified Intelligence Center.

You can run the command from either the Side A or Side B (not both) Live Data node; and you must run it
once for each of the Cisco Unified Intelligence Center Publisher nodes. The AWDistributor and Cisco Unified
Intelligence Center Publisher must be in service.

You can use this command after you:

• Set the AW DB connection information on the same node where you want to run this command.

• Configure Live Data endpoints in the Machine Service table.
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You must run this command when there is a change in machine service inventory table. The changes can
occur when,

• Recreating the node in Unified CCE Inventory

• Restoring AW database using EDMT

• Running the set livedata machine-services CLI command (for 4K and above)

Note

Command Syntax
set live-data cuic-datasource cuic-addr cuic-port cuic-user cuic-pwd
cuic-addr

Specifies the Cisco Unified Intelligence Center publisher node's fully qualified domain name (FQDN). This
node must be in service.

cuic-port

Specifies the Cisco Unified Intelligence Center REST API port, which must be 8444.

cuic-user

Specifies the user name to use for authentication with Cisco Unified Intelligence Center. By default, Cisco
Unified Intelligence Center requires that you specify CUIC as the domain with the user name (for example,
CUIC\administrator).

This user must have system configuration administrative privileges.

cuic-pwd

Specifies the password to use for authentication with Cisco Unified Intelligence Center.

show live-data cuic-datasource
Required Minimum Privilege Level: Ordinary

Use this command to list the Live Data data source configuration in Cisco Unified Intelligence Center.

You can use this command after you:

• Set the AW DB connection information on the same node where you want to run this command.

• Configure Live Data endpoints in the Machine Service table.

Command Syntax
show live-data cuic-datasource cuic-addr cuic-port cuic-user cuic-pwd
cuic-addr

Specifies the Cisco Unified Intelligence Center publisher node's fully qualified domain name (FQDN).

cuic-port

Specifies the Cisco Unified Intelligence Center REST API port, which must be 8444.

cuic-user

Specifies the user name to use for authentication with Cisco Unified Intelligence Center. By default, Cisco
Unified Intelligence Center requires that you specify CUIC as the domain with the user name (for example,
CUIC\administrator).
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cuic-pwd

Specifies the password to use for authentication with Cisco Unified Intelligence Center.

unset live-data cuic-datasource
Required Minimum Privilege Level: Advanced

Use this command to delete the existing Live Data data source. Ensure that there are no existing reports or
report templates that reference the Live Data data source before you run the command; otherwise, the command
fails.

After you run this command successfully, you can no longer generate Live Data reports.

You can use this command after you:

• Set the AW DB connection information on the same node where you want to run this command.

• Configure Live Data endpoints in the Machine Service table.

Command Syntax
unset live-data cuic-datasource cuic-addr cuic-port cuic-user cuic-pwd
cuic-addr

Specifies the Cisco Unified Intelligence Center publisher node's fully qualified domain name (FQDN).

cuic-port

Specifies the Cisco Unified Intelligence Center REST API port, which must be 8444.

cuic-user

Specifies the user name to use for authentication with Cisco Unified Intelligence Center. By default, Cisco
Unified Intelligence Center requires that you specify CUIC as the domain with the user name (for example,
CUIC\administrator).

This user must have system configuration administrative privileges.

cuic-pwd

Specifies the password to use for authentication with Cisco Unified Intelligence Center.

set live-data machine-services

This command is not valid for coresident deployments. If you have a coresident deployment, use the System
Inventory in the Unified CCE Administration tool.

Note

Required Minimum Privilege Level: Advanced

Use this command to set or update the Machine Service table with the latest information from Live Data
services (publisher and subscriber).

You must run the set live-data cuic-datasource CLI command after executing the set live-data
machine-services command.

Note
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Command Syntax
set live-data machine-services awdb-user awdb-pwd
awdb-user

Use the user@domain format to specify the AW database domain user with write-access permission. The
domain is a fully qualified domain name (FQDN). The username is a user principal name. The user must be
authorized to change Unified CCE configuration.

awdb-pwd

Specifies the AW database user password.

show live-data machine-services
Required Minimum Privilege Level: Ordinary

Use this command to display Live Data entries in the Machine Services table.

Command Syntax
show live-data machine-services [awdb-user] [awdb-password]
awdb-user

Use the user@domain format to specify the AWdatabase domain user with at least read-access permission.

awdb-password

Specifies the AW database user password.

Transport Layer Security CLI Commands

These CLI commands are only for VOS systems. They are not available for VMs running Windows Server.Note

TLS Server Minimum Version

set tls server min-version
Use this command to set the current TLS minimum version for inbound connections.

Command Syntax

set tls server min-version {1.0|1.1|1.2}
1.0

Specifies the TLS server minimum version 1.0 for inbound connections.

1.1

Specifies the TLS server minimum version 1.1 for inbound connections.

1.2

Specifies the TLS server minimum version 1.2 for inbound connections.
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show tls server min-version
Use this command to display the current TLS minimum version for inbound connections.

Command Syntax
show tls server min-version

TLS Client Minimum Version

set tls client min-version
Use this command to set the current TLS minimum version for outbound connections.

Command Syntax

set tls client min-version {1.0|1.1|1.2}
1.0

Specifies the TLS client minimum version 1.0 for outbound connections.

1.1

Specifies the TLS client minimum version 1.1 for outbound connections.

1.2

Specifies the TLS client minimum version 1.2 for outbound connections.

show tls server min-version
Use this command to display the current TLS minimum version for inbound connections.

Command Syntax
show tls server min-version
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A P P E N D I X B
Certificates for Live Data

• Certificates and Secure Communications, on page 261
• Export Self-Signed Live Data Certificates, on page 262
• Import Self-Signed Live Data Certificates, on page 263
• Produce Certificate Internally, on page 264
• Deploy Root Certificate for Internet Explorer , on page 265
• Set Up CA Certificate for Internet Explorer Browser, on page 265
• Set Up CA Certificate for Firefox Browser, on page 266

Certificates and Secure Communications
For secure Cisco Finesse, Cisco Unified Intelligence Center, and Live Data server-to-server communication,
perform any of the following:

• Use the self-signed certificates provided with Live Data.

When using self-signed certificates, agents must accept the Live Data certificates
in the Finesse desktop when they sign in before they can use the Live Data gadget.

Note

• Obtain and install a Certification Authority (CA) certificate from a third-party vendor.

• Produce a Certification Authority (CA) certificate internally.

Related Topics
Export Self-Signed Live Data Certificates, on page 262
Import Self-Signed Live Data Certificates, on page 263
Set Up Certificates for Live Data, on page 79
Set up Microsoft Certificate Server for Windows Server, on page 264

Obtain and Upload Third-party CA Certificate
You can use a Certification Authority (CA) certificate provided by a third-party vendor to establish an HTTPS
connection between the Live Data, Cisco Finesse, and Cisco Unified Intelligence Center servers.

To use third-party CA certificates:
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• From the Live Data servers, generate and download a Certificate Signing Requests (CSR).

• Obtain root and application certificates from the third-party vendor.

• Upload the appropriate certificates to the Live Data, Unified Intelligence Center, and Cisco Finesse
servers.

Follow the instructions provided in the Unified CCE Solution: Procedure to Obtain and Upload Third-Party
CA certificates (Version 11.x) technical note at https://www.cisco.com/c/en/us/support/docs/
customer-collaboration/unified-contact-center-enterprise-1101/
200286-Unified-CCE-Solution-Procedure-to-Obtai.html .

Export Self-Signed Live Data Certificates
Live Data installation includes the generation of self-signed certificates. If you choose to work with these
self-signed certificates (rather than producing your own CA certificate or obtaining a CA certificate from a
third-party certificate vendor), you must first export the certificates from Live Data and Cisco Unified
Intelligence Center, as described in this procedure. You must export from both Side A and Side B of the Live
Data and Cisco Unified Intelligence Center servers. You must then import the certificates into Finesse,
importing both Side A and Side B certificates into each side of the Finesse servers.

As is the case when using other self-signed certificates, agents must accept the Live Data certificates in the
Finesse desktop when they sign in before they can use the Live Data gadget.

Procedure

Step 1 Sign in to Cisco Unified Operating System Administration on Cisco Unified Intelligence Center
(https://hostname of Cisco Unified Intelligence Center server/cmplatform).

Step 2 From the Security menu, select Certificate Management.
Step 3 Click Find.
Step 4 Do one of the following:

• If the tomcat certificate for your server is on the list, click the certificate to select it. (Ensure that the
certificate you select includes the hostname for the server.)

• If you are using self-signed certificate, do the following:

a. Click Generate New.

b. When the certificate generation is complete, restart the Cisco Tomcat service and the Cisco Live
Data NGNIX service.

c. Restart this procedure.

Step 5 Click Download .pem file and save the file to your desktop.

Be sure to perform these steps for both Side A and Side B.
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Step 6 After you have downloaded the certificates from Cisco Unified Intelligence Center, sign in to Cisco Unified
Operating System Administration on the Live Data server (http://hostname of LiveData server/cmplatform),
and repeat steps 2 to 5. This is applicable only for Standalone LiveData.

What to do next

Youmust now import the Live Data and Cisco Unified Intelligence Center certificates into the Finesse servers.

Related Topics
Import Self-Signed Live Data Certificates, on page 263

Import Self-Signed Live Data Certificates
To import the certificates into the Finesse servers, use the following procedure.

Procedure

Step 1 Sign in to Cisco Unified Operating System Administration on the Finesse server using the following URL:

http://FQDN of Finesse server:8443/cmplatform

Step 2 From the Security menu, select Certificate Management.
Step 3 Click Upload Certificate.
Step 4 From the Certificate Name drop-down list, select tomcat-trust.
Step 5 Click Browse and browse to the location of the Cisco Unified Intelligence Center certificate (with the .pem

file extension).
Step 6 Select the file, and click Upload File.
Step 7 After you have uploaded the Cisco Unified Intelligence Center certificate repeat steps 3 to 6 for Live Data

certificates.This is applicable only for standalone Live Data.
Step 8 After you upload both the certificates, restart Cisco Finesse Tomcat on the Finesse server.

What to do next

Be sure to perform these steps for both Side A and Side B.

Related Topics
Export Self-Signed Live Data Certificates, on page 262
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Produce Certificate Internally

Set up Microsoft Certificate Server for Windows Server
This procedure assumes that your deployment includes a Windows Server Active Directory server. Perform
the following steps to add the Active Directory Certificate Services role on the Windows Server domain
controller.

Before you begin

Before you begin, Microsoft .Net Framework must be installed. See Windows Server documentation for
instructions.

Procedure

Step 1 In Windows, open the Server Manager.
Step 2 In the Quick Start window, click Add Roles and Features .
Step 3 In the Set Installation Type tab, select Role-based or feature-based installation , and then click Next.
Step 4 In the Server Selection tab, select the destination server then click Next.
Step 5 In the Server Roles tab, check theActive Directory Certificate Services box, and then click theAdd Features

button in the pop-up window.
Step 6 In the Features and AD CS tabs, click Next to accept default values.
Step 7 In the Role Services tab, verify that Certification Authority box is checked, and then click Next.
Step 8 In the Confirmation tab, click Install.
Step 9 After the installation is complete, click theConfigure Active Directory Certificate Service on the destination

server link.
Step 10 Verify that the credentials are correct (for the domain Administrator user), and then click Next.
Step 11 In the Role Services tab, check the Certification Authority box, and then click Next.
Step 12 In the Setup Type tab, select Enterprise CA, and then click Next.
Step 13 In the CA Type tab, select Root CA, and then click Next.
Step 14 In the Private Key, Cryptography, CA Name, Validity Period, and Certificate Database tabs, click Next

to accept default values.
Step 15 Review the information in the Confirmation tab, and then click Configure.

Download CA certificate
This procedure assumes that you are using the Windows Certificate Services. Perform the following steps to
retrieve the root CA certificate from the certificate authority. After you retrieve the root certificate, each user
must install it in the browser used to access Finesse.
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Procedure

Step 1 On the Windows domain controller, run the CLI command certutil -ca.cert ca_name.cer, in which ca_name
is the name of your certificate.

Step 2 Save the file. Note where you saved the file so you can retrieve it later.

Deploy Root Certificate for Internet Explorer
In environments where group policies are enforced via the Active Directory domain, the root certificate can
be added automatically to each user's Internet Explorer. Adding the certificate automatically simplifies user
requirements for configuration.

To avoid certificate warnings, each user must use the fully-qualified domain name (FQDN) of the Finesse
server to access the desktop.

Note

Procedure

Step 1 On the Windows domain controller, navigate to Administrative Tools > Group Policy Management.

Users who have strict Group Policy defined on the Finesse Agent Desktop are required to disable
Cross Document Messaging from Group Policy Management to ensure proper functioning of
Finesse on Internet Explorer 11.

Note

Step 2 Right-click Default Domain Policy and select Edit.
Step 3 In the Group Policy Management Console, go to Computer Configuration > Policies > Window Settings >

Security Settings > Public Key Policies.
Step 4 Right-click Trusted Root Certification Authorities and select Import.
Step 5 Import the ca_name.cer file.
Step 6 Go toComputer Configuration > Policies >Windows Settings > Security Settings > Public Key Policies >

Certificate Services Client - Auto-Enrollment.
Step 7 From the Configuration Model list, select Enabled.
Step 8 Sign in as a user on a computer that is part of the domain and open Internet Explorer.
Step 9 If the user does not have the certificate, run the command gpupdate.exe /target:computer /force on the user's

computer.

Set Up CA Certificate for Internet Explorer Browser
After obtaining and uploading the CA certificates, either the certificate must be automatically installed via
group policy or all users must accept the certificate.
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In environments where users do not log directly in to a domain or group policies are not utilized, every Internet
Explorer user in the system must perform the following steps once to accept the certificate.

Procedure

Step 1 In Windows Explorer, double-click the ca_name.cer file (in which ca_name is the name of your certificate)
and then click Open.

Step 2 Click Install Certificate > Next > Place all certificates in the following store.
Step 3 Click Browse and select Trusted Root Certification Authorities.
Step 4 Click OK.
Step 5 Click Next.
Step 6 Click Finish.

A message appears that states you are about to install a certificate from a certification authority (CA).

Step 7 Click Yes.

A message appears that states the import was successful.

Step 8 To verify the certificate was installed, open Internet Explorer. From the browser menu, selectTools > Internet
Options.

Step 9 Click the Content tab.
Step 10 Click Certificates.
Step 11 Click the Trusted Root Certification Authorities tab.
Step 12 Ensure that the new certificate appears in the list.
Step 13 Restart the browser for certificate installation to take effect.

If using Internet Explorer 11, you may receive a prompt to accept the certificate even if signed by
private CA.

Note

Set Up CA Certificate for Firefox Browser
Every Firefox user in the system must perform the following steps once to accept the certificate.

To avoid certificate warnings, each user must use the fully-qualified domain name (FQDN) of the Finesse
server to access the desktop.

Note

Procedure

Step 1 From the Firefox browser menu, select Options.
Step 2 Click Advanced.
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Step 3 Click the Certificates tab.
Step 4 Click View Certificates.
Step 5 Click Authorities.
Step 6 Click Import and browse to the ca_name.cer file (in which ca_name is the name of your certificate).
Step 7 Check the Validate Identical Certificates check box.
Step 8 Restart the browser for certificate installation to take effect.
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A P P E N D I X C
Certificates for Live Data Coresident

• Add Self-Signed Certificates for Live Data, on page 269
• Obtain and Upload CA Certificate for Live Data from a Third Party Vendor, on page 270
• Produce Certificate Internally, on page 270
• Deploy Root Certificate for Internet Explorer , on page 272
• Set Up CA Certificate for Internet Explorer Browser, on page 273
• Set Up CA Certificate for Firefox Browser, on page 273

Add Self-Signed Certificates for Live Data
Both Finesse and Unified Intelligence Center are installed with self-signed certificates. If you choose to work
with these self-signed certificates (rather than producing your own CA certificate or obtaining a CA certificate
from a third-party certificate vendor), you must first export the certificates from the Unified Intelligence
Center Publisher and Subscriber. You must then import the certificates into Finesse, importing the Publisher
certificate to the Finesse Primary node and the Subscriber certificate to the Finesse Secondary node.

As is the case when using other self-signed certificates, agents must accept the Live Data certificates in the
Finesse desktop when they sign in before they can use the Live Data gadget.

Procedure

Step 1 Sign in to Cisco Unified Operating System Administration on Cisco Unified Intelligence Center
(https://<hostname of Cisco Unified Intelligence Center server>/cmplatform).

Step 2 From the Security menu, select Certificate Management.
Step 3 Click Find.
Step 4 Do one of the following:

• If the tomcat certificate for your server is on the list, click the certificate to select it. (Ensure that the
certificate you select includes the hostname for the server.)

• If the tomcat certificate for your server is not on the list, do the following:

a. Click Generate New.

b. When the certificate generation is complete, restart the Cisco Tomcat service, Unified Intelligence
Center Reporting service, and Cisco Live Data NGNIX service.
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c. Restart this procedure.

Step 5 Click Download .pem file and save the file to your desktop.
You must download the certificates that contain the hostnames Cisco Unified Intelligence Center publisher
and Cisco Unified Intelligence Center subscriber.

Step 6 Sign in to Cisco Unified Operating System Administration on the primary Finesse server (https://FQDN of
Finesse server:8443/cmplatform).

Step 7 From the Security menu, select Certificate Management.
Step 8 Click Upload Certificate.
Step 9 From the Certificate Name drop-down list, select tomcat-trust.
Step 10 Click Browse and browse to the location of the .pem files (Cisco Unified Intelligence Center publisher and

subscriber certificates).
Step 11 Click Upload File.
Step 12 Restart Cisco Finesse Tomcat on the Finesse server.

Obtain and Upload CA Certificate for Live Data from a Third
Party Vendor

You can use a Certification Authority (CA) certificate provided by a third-party vendor to establish an HTTPS
connection between the Finesse and Cisco Unified Intelligence Center servers.

Follow the instructions in the TechNote Procedure to Obtain and Upload CA Certificate from a Third-party
Vendor, available at https://www.cisco.com/c/en/us/support/docs/customer-collaboration/
unified-contact-center-enterprise-1101/200286-Unified-CCE-Solution-Procedure-to-Obtai.html.

Produce Certificate Internally

Set up Microsoft Certificate Server for Windows 2008 R2
This procedure assumes that your deployment includes aWindows Server 2008 R2 (Standard) Active Directory
server. Perform the following steps to add the Active Directory Certificate Services role on the Windows
2008 R2 (Standard) domain controller.

Procedure

Step 1 Click Start, right-click Computer, and select Manage.
Step 2 In the left pane, click Roles.
Step 3 In the right pane, click Add Roles.

The Add Roles Wizard opens.
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Step 4 On the Select Server Roles screen, check the Active Directory Certificate Services check box, and then
click Next.

Step 5 On the Introduction to Active Directory Certificate Services screen, click Next.
Step 6 On the Select Role Services screen, check the Certification Authority check box, and then click Next.
Step 7 On the Specify Setup Type screen, select Enterprise, and then click Next.
Step 8 On the Specify CA Type screen, select Root CA, and then click Next.
Step 9 Click Next on the Set Up Private Key, Configure Cryptography for CA, Configure CA Name, Set Validity

Period, and Configure Certificate Database screens to accept the default values.
Step 10 On the Confirm Installations Selections screen, verify the information, and then click Install.

Set up Microsoft Certificate Server for Windows Server
This procedure assumes that your deployment includes a Windows Server Active Directory server. Perform
the following steps to add the Active Directory Certificate Services role on the Windows Server domain
controller.

Before you begin

Before you begin, Microsoft .Net Framework must be installed. See Windows Server documentation for
instructions.

Procedure

Step 1 In Windows, open the Server Manager.
Step 2 In the Quick Start window, click Add Roles and Features .
Step 3 In the Set Installation Type tab, select Role-based or feature-based installation , and then click Next.
Step 4 In the Server Selection tab, select the destination server then click Next.
Step 5 In the Server Roles tab, check theActive Directory Certificate Services box, and then click theAdd Features

button in the pop-up window.
Step 6 In the Features and AD CS tabs, click Next to accept default values.
Step 7 In the Role Services tab, verify that Certification Authority box is checked, and then click Next.
Step 8 In the Confirmation tab, click Install.
Step 9 After the installation is complete, click theConfigure Active Directory Certificate Service on the destination

server link.
Step 10 Verify that the credentials are correct (for the domain Administrator user), and then click Next.
Step 11 In the Role Services tab, check the Certification Authority box, and then click Next.
Step 12 In the Setup Type tab, select Enterprise CA, and then click Next.
Step 13 In the CA Type tab, select Root CA, and then click Next.
Step 14 In the Private Key, Cryptography, CA Name, Validity Period, and Certificate Database tabs, click Next

to accept default values.
Step 15 Review the information in the Confirmation tab, and then click Configure.
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Download CA certificate
This procedure assumes that you are using the Windows Certificate Services. Perform the following steps to
retrieve the root CA certificate from the certificate authority. After you retrieve the root certificate, each user
must install it in the browser used to access Finesse.

Procedure

Step 1 On the Windows domain controller, run the CLI command certutil -ca.cert ca_name.cer, in which ca_name
is the name of your certificate.

Step 2 Save the file. Note where you saved the file so you can retrieve it later.

Deploy Root Certificate for Internet Explorer
In environments where group policies are enforced via the Active Directory domain, the root certificate can
be added automatically to each user's Internet Explorer. Adding the certificate automatically simplifies user
requirements for configuration.

To avoid certificate warnings, each user must use the fully-qualified domain name (FQDN) of the Finesse
server to access the desktop.

Note

Procedure

Step 1 On the Windows domain controller, navigate to Administrative Tools > Group Policy Management.

Users who have strict Group Policy defined on the Finesse Agent Desktop are required to disable
Cross Document Messaging from Group Policy Management to ensure proper functioning of
Finesse on Internet Explorer 11.

Note

Step 2 Right-click Default Domain Policy and select Edit.
Step 3 In the Group Policy Management Console, go to Computer Configuration > Policies > Window Settings >

Security Settings > Public Key Policies.
Step 4 Right-click Trusted Root Certification Authorities and select Import.
Step 5 Import the ca_name.cer file.
Step 6 Go toComputer Configuration > Policies >Windows Settings > Security Settings > Public Key Policies >

Certificate Services Client - Auto-Enrollment.
Step 7 From the Configuration Model list, select Enabled.
Step 8 Sign in as a user on a computer that is part of the domain and open Internet Explorer.
Step 9 If the user does not have the certificate, run the command gpupdate.exe /target:computer /force on the user's

computer.
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Set Up CA Certificate for Internet Explorer Browser
After obtaining and uploading the CA certificates, either the certificate must be automatically installed via
group policy or all users must accept the certificate.

In environments where users do not log directly in to a domain or group policies are not utilized, every Internet
Explorer user in the system must perform the following steps once to accept the certificate.

Procedure

Step 1 In Windows Explorer, double-click the ca_name.cer file (in which ca_name is the name of your certificate)
and then click Open.

Step 2 Click Install Certificate > Next > Place all certificates in the following store.
Step 3 Click Browse and select Trusted Root Certification Authorities.
Step 4 Click OK.
Step 5 Click Next.
Step 6 Click Finish.

A message appears that states you are about to install a certificate from a certification authority (CA).

Step 7 Click Yes.

A message appears that states the import was successful.

Step 8 To verify the certificate was installed, open Internet Explorer. From the browser menu, selectTools > Internet
Options.

Step 9 Click the Content tab.
Step 10 Click Certificates.
Step 11 Click the Trusted Root Certification Authorities tab.
Step 12 Ensure that the new certificate appears in the list.
Step 13 Restart the browser for certificate installation to take effect.

If using Internet Explorer 11, you may receive a prompt to accept the certificate even if signed by
private CA.

Note

Set Up CA Certificate for Firefox Browser
Every Firefox user in the system must perform the following steps once to accept the certificate.

To avoid certificate warnings, each user must use the fully-qualified domain name (FQDN) of the Finesse
server to access the desktop.

Note
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Procedure

Step 1 From the Firefox browser menu, select Options.
Step 2 Click Advanced.
Step 3 Click the Certificates tab.
Step 4 Click View Certificates.
Step 5 Click Authorities.
Step 6 Click Import and browse to the ca_name.cer file (in which ca_name is the name of your certificate).
Step 7 Check the Validate Identical Certificates check box.
Step 8 Restart the browser for certificate installation to take effect.
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A P P E N D I X D
Migrate from Co-resident Deployment to
Standalone Deployment

• Upgrade from Co-resident to Standalone Deployments, on page 275

Upgrade from Co-resident to Standalone Deployments
If your solution exceeds the configuration limits of 2000 Agent Reference Design, use a Reference Design
with higher limits and replace the co-resident deployment of CUIC with a standalone deployment of CUIC,
Live Data, and IdS. A standalone deployment allows higher capacity and increased reporting end users. You
cannot convert the existing co-resident server to a standalone server.

You can export the CUIC reports from the co-resident deployment and import them into the new standalone
CUIC.

Note

For a new standalone deployment, you must perform fresh install of the following servers, using the method
outlined below:

TaskSequence

Set up the System Inventory for Standalone Deployment, on page 2761

Install Cisco Unified Intelligence Center Standalone (4000, 8000, 12000 Agent Deployment).
See Installation and Upgrade Guide for Cisco Unified Intelligence Center at
http://www.cisco.com/en/US/products/ps9755/prod_installation_guides_list.html.

2

Install Live Data. See Live Data Standalone Installation, on page 72.3

Install the Identity Service. See the Installation Task Flow for Cisco Identity Service
section in the Cisco Unified Contact Center Enterprise Features Guide at
https://www.cisco.com/%20c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/%20products-feature-guides-list.html

4
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Set up the System Inventory for Standalone Deployment

Procedure

Step 1 In Unified CCE Administration, navigate to System > Deployment.
Step 2 Add the new machine to the System Inventory:

a) Select the coresident machine to remove. Cick Delete.
b) Click New. The Add Machine popup window opens.

The Add Machine popup window opens.

c) From the Type drop-down menu, select the following machine type:

Unified Intelligence Center Publisher.

d) In the Hostname field, enter the FQDN, hostname, or IP address of the machine.

The system attempts to convert the value you enter to FQDN.

e) Enter the machine's Administration credentials.
f) Click Save.

The machine and its related Subscriber or Secondary machine are added to the System Inventory.

What to do next

If you remove a component from your deployment, delete it from your System Inventory. If you add the
component again, or add more components, add those components to the System Inventory.
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A P P E N D I X E
IPv6 Configuration

• Configure NAT64 for IPv6-Enabled Deployment, on page 277
• Set Up IPv6 for VOS-Based Contact Center Applications, on page 279

Configure NAT64 for IPv6-Enabled Deployment
NAT64 allows communication between IPv6 and IPv4 networks. For IPv6-enabled deployments, you must
set up NAT64 so that supervisors on an IPv6 network can access Unified CCE Administration web tools on
an IPv4 network.

You can use either Stateful and Stateless NAT64. To read more about which translation type is the most
appropriate for your deployment see Table 2. Comparison Between Stateless and Stateful NAT64 here:
https://www.cisco.com/c/en/us/products/collateral/ios-nx-os-software/enterprise-ipv6-solution/white_paper_
c11-676278.html

NAT64 is NOT supported on M train IOS. T train is required.

For more information on Unified CCE Solution Compatibility Matrix, see https://www.cisco.com/c/en/us/
support/customer-collaboration/unified-contact-center-enterprise/products-device-support-tables-list.html.

Note

The following example network diagram and interface configuration demonstrates Stateful NAT64 translation
between an IPv6 network and an IPv4 network.

interface GigabitEthernet0/0
description ipv4-only interface
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ip address 10.10.10.81 255.255.255.128
duplex auto
speed auto
nat64 enable
no mop enabled

interface GigabitEthernet0/1
description ipv6-only interface
no ip address
duplex auto
speed auto
nat64 enable
ipv6 address 2001::1/64
ipv6 enable

ipv6 unicast-routing
ipv6 cef
!
nat64 prefix stateful 3001::/96
nat64 v4 pool POOL1 10.10.10.129 10.10.10.250
nat64 v6v4 list V6ACL1 pool POOL1 overload
ipv6 router rip RIPv6
!
ipv6 router rip RIP

!
ipv6 access-list V6ACL1
permit ipv6 2001::/64 any

Configure DNS for IPv6
To meet the requirement that Unified CCE Administration be accessed by FQDN, a Forward lookup AAAA
record for the AW must be created in DNS.

The steps in this procedure are for a Windows DNS server.

Procedure

Step 1 In Windows, navigate to Administrative Tools > DNS. This opens the DNS Manager.
Step 2 In the Forward lookup zone, navigate to your deployment's domain name.
Step 3 Right-click the domain name and select New Host (A or AAAA).
Step 4 In the New Host dialog box, enter the computer name and IP address of the AW. Click Add Host.

Determine IPv6 Translation of IPv4 Address for DNS Entry
You can determine the IPv6 address needed for the AAAA DNS record by running a ping command on any
Windows machine using mixed notation. Type “ping -6” followed by your IPv6 Nat64 Prefix, two colons,
and then the IPv4 address.
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In the ping response, the IPv4 address is converted to the hexadecimal equivalent. Use this address in your
static AAAA record.

Optionally, DNS64 can be used in place of static DNS entries. Use of DNS64 helps facilitate translation
between IPv6 and IPv4 networks by synthesizing AAAA resource records from A resource records.

The NAT64 Technology: Connecting IPv6 and IPv4 Networks whitepaper gives an overview of DNS64 and
how it is used with IPv6: https://www.cisco.com/c/en/us/products/collateral/ios-nx-os-software/
enterprise-ipv6-solution/white_paper_c11-676278.html.

Note

Set Up IPv6 for VOS-Based Contact Center Applications
By default, only IPv4 is enabled for Unified CommunicationsManager, Cisco Finesse, and Unified Intelligence
Center.

If you choose to enable IPv6 on these applications, you must enable it on both the publisher/primary nodes
and subscriber/secondary nodes for those applications.

You can use Cisco Unified Operating System Administration or the CLI to enable IPv6.

See the Solution Design Guide for Cisco Unified Contact Center Enterprise at https://www.cisco.com/c/en/
us/support/customer-collaboration/unified-contact-center-enterprise/
products-implementation-design-guides-list.html for more information about IPv6 support in Unified CCE.

Set Up IPv6 Using Cisco Unified Operating System Administration
To set up IPv6 using Cisco Unified Operating System Administration, perform the following procedure on
the primary and secondary VOS servers.

Procedure

Step 1 Sign into Cisco Unified Operating System Administration on the Publisher/Primary node:.
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• Unified Communications Manager and Unified Intelligence Center: https://<host or IP
address of the Publisher or Primary node>/cmplatform

• Finesse: https://FQDN of the Primary node:8443/cmplatform

Step 2 Navigate to Settings > IP > Ethernet IPv6.
Step 3 Check the Enable IPv6 check box.
Step 4 Enter values for IPv6Address, Prefix Length, and Default Gateway.
Step 5 Check the Update with Reboot check box.
Step 6 Click Save.

The server restarts.
Step 7 Repeat this procedure on the subscriber/secondary node.

Set Up IPv6 for VOS-Based Applications Using the CLI
To set up IPv6 using the CLI, perform the following procedure on both the primary and secondary VOS
servers.

Procedure

Step 1 Access the CLI on the VOS server.
Step 2 To enable or disable IPv6, enter:

set network ipv6 service {enable | disable}

Step 3 Set the IPv6 address and prefix length:
set network ipv6 static_address addr mask

Example:

set network ipv6 static_address 2001:db8:2::a 64

Step 4 Set the default gateway:
set network ipv6 gateway addr

Step 5 Restart the system for the changes to take effect.
utils system restart

Step 6 To display the IPv6 settings, enter:
show network ipv6 settings
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