Time Sensitive Networking

Table 1. Feature History Table

Feature Name

Release Information

Feature Description

Prioritize Transportation of Higher Frames Using Frame Preemption

Release 7.4.2

Based on IEEE 802.1Qbu-2016 and Time Sensitive Networking (TSN) standards, Frame Preemption is now available on converged xHaul transport networks. This feature accelerates the transport of express frames such as radio packets or low latency service packets.

This feature is available on N540-FH-CSR-SYS and N540-FH-AGG-SYS routers for transporting radio traffic and traditional enterprise access traffic.

For more information, see Cisco NCS 540 Fronthaul Router Portfolio At-a-Glance.

Time Sensitive Networking (TSN) is a set of IEEE standards that addresses the timing-critical aspect of signal flow in a packet switched Ethernet network to ensure deterministic operation. TSN preemption has a discovery phase where each member of the network is able to announce its preemption capability and inquire the capabilities of its directly connected neighbor using Link Layer Discovery Protocol (LLDP).

Frame Preemption

Preemption is a point-to-point technology (directly connected). Frame preemption increases the efficiency of the network by creating a reduction in the guard band requirements for Ethernet packets. Preemption allows best effort (nontime sensitive) data frames to be interrupted by time-sensitive frames. Routers that comply with these standards need to read and respond to the preamble field of the Ethernet frame prior to the start frame delimiter (SFD).

Used to suspend the transmission of a preemptable frame to allow one or more express traffic frames to be transmitted before transmission of the preemptable frame is resumed. During transmission of the initial frame, the router needs to pause transmission of a preemptable frame to allow an express frame to occupy the wire, then the remaining section of the initial frame occupies the wire.

MAC support for interspersing express traffic defines what is required at the MAC layer of a router to support preemptable and express traffic types to a single physical signaling sublayer service.

Frame Preemption on Fronthaul

Converged platform has a mix of FH and Carrier-Ethernet (CE) traffic towards same network-to-network interface (NNI). FH-Specific Express-Frames can get behind jumbo-packets of CE flows leading to more latency. The 802.1CM doesn’t suggest Frame Preemption for 25G interfaces but for converged platforms you need to have Frame Preemption on 25G. Whereas latency improvements for 100G occur within nanoseconds.

Frame Preemption on N540-FH-AGG-SYS

Express and non-express traffic streams are sent from routers to FPGA on different Interlaken channels. Interlaken channels operate in Burst-Interleave mode, which prevents BE packets blocking express packets. The bandwidth of Interlaken channels is higher than port speeds. The delay for express traffic on Interlaken is minimized and the routers need to identify express packet stream and send on express Interlaken channel. FPGA merges the traffic and sends out on the 802.1Qbu enabled port.

Prerequisites

  • TSN operates at MAC Merge Sublayer and is agnostic to the forwarding decisions.

  • Traffic forwarding needs to be ensured via L2 switching, static routing, IGP, SR-MPLS, L2VPN, EVPN, L3VPN, and so on.

  • Express traffic and non-express traffic need to be bifurcated via QoS on ingress using traffic class.

  • Traffic class 7 is standard for express traffic and traffic class 0-5 is for preemptable traffic.

Limitations

  • Multi-Flow bifurcation from Single Ingress interface doesn’t work for Frame Pre-emption. Flow needs to be from multiple ingress interfaces.

  • TSN interfaces doesn’t support bundle.

  • Frame re-assembly don’t work without frame preemption enabled.

  • TSN Discovery with LLDP isn’t supported.

Configuring Frame Preemption

class-map match-any express
 match cos  7
class-map match-any be-priority
 match cos  3
class-map match-any tos7
 match traffic-class  7
class-map match-any tos3
 match traffic-class  3
policy-map Mark
 class express
  set traffic-class 7 
class be-priority
  set traffic-class 3 
policy-map TSN
 class tos7
  priority level 1 
class tos3
  priority level 2 
class best-effort
  bandwidth percent 50
Ingress:
interface TenGigabitEthernet0/0/0/1
 ip address 14.0.0.1 255.255.255.0
 service-policy input Mark
 
Egress:
interface TenGigabitEthernet0/0/0/0
 ip address 12.0.0.1 255.255.255.0
 mpls ip
 service-policy output TSN
 frame-preemption

/*Note: Egress Service-Policy is not mandatory for TSN*/

Verification

Router#show tsn-stats interface tenGigE 0/0/0/12
TSN RX STATS for port:12
 Input Fragmented Assembly Error Packets: 0
 Input SMD Error Packets: 0
 Input Assembled Packets: 80
 Input Fragmented Packets: 80
 Input Non Fragmented Packets: 40
 Input Express Packets: 30
 Input Non Fragmented Preemptable Packets: 10
 Output Preemptable Packets: 0
 Output Fragments of Preemptable Packets: 0
 Output hold packets: 0