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C H A P T E R 1

Overview

To visualize a network topology in WAE Design, you need a basic understanding of layouts and 
templates, and how they relate to plan files. Once you understand these concepts, you can proceed to 
visualize the network and save a plan file as a template for use in WAE Live or WAE Design Archive, or 
simply save it as a plan file for simulation purposes in WAE Design. This chapter describes these 
concepts. The guide itself includes the following topics.

• Visualizing a WAE Network—Describes how to affect the visualization of a network, including such 
topics as how to assign sites to nodes, how to modify visual attributes of objects, and how to change 
the canvas (background) of the weathermap (WAE Live) or network plot (WAE Design). It also 
explains the use of traffic utilization colors, their defaults, and how to change these colors.

• Using Layouts—Explains the basic differences between Weathermap and Design layouts and how 
they are typically used, as well as how to create, edit, and view layouts.

• Plan Files and Templates—Describes how to save plan files and templates locally and remotely, how 
to copy visual elements and objects from a template, and how to modify the plan file database using 
the WAE Design GUI.

• Access WAE Live—Describes how to open plan files and templates from WAE Live, as well as how 
to save templates to WAE Live.

• Access an Archive—Describes how to open/save plan files and templates from/to an archive.

• Access WAE Automation Server and Deploy—Describes how to open/save plan files from/to a WAE 
Automation server, as well as how to deploy plan files and patch files to the network.

Plan Files and Templates
The unit of data storage that is displayed in weathermaps (web UIs) and network plots (WAE Design 
GUI) is the plan file. Each plan file consists of a series of tables that describe network characteristics, 
including network topology, traffic, service classes, and routing protocols. Note that what is visible in 
the web applications and the WAE Design GUI differs since the former represents collected data from 
an operating network, while the latter can additionally represent simulated networks and network state. 

These plans files are typically created as a result of the process that discovers topology and traffic. They 
can, however, be created using CLI tools or the WAE Design GUI, which can be useful when designing 
greenfield networks.

• Plan files—Plan files might reside on a single local devise, such as a laptop, and are typically used 
for simulation purposes in WAE Design. Plan files might also be stored remotely in an archive for 
use in web applications. The WAE Automation server contains a working plan file (of the current 
network), and potentially contains plan files in staging areas.
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• Templates—Each archive contains a “pattern” plan file called a template by which all the plan files 
are modeled for visualization in the web application. Templates usually contain visual elements that 
dictate how the objects appear in the network and the canvas (background) behind it. Templates 
might also contains objects that are not discoverable but are of use in network simulations, for 
example physical circuit routes. For more detailed information about templates, see the Plan Files 
and Templates chapter. 

Note The WAE Automation server does not contain templates as defined here. Also note that while the 
Coordinated Maintenance uses templates, the application does so only for the purpose of having current 
topology (not for visualization purposes).

Layouts and Visualization
The manner in which plan files are laid out to visualize the network is called a layout. Each plan has a 
default layout. The WAE Design GUI provides numerous tools for re-arranging the topology and 
affecting the appearance of objects, both for newly discovered networks and for greenfield designs. With 
these tools you can create multiple layouts per plan file, each with its own visualization. For example, 
layouts can have schematic or geographic site canvases, or show specific sections of the network. 

All layouts are one of two types: either Weathermap (primarily for preparing layout templates) or Design 
(for planning and design work in WAE Design). Unless otherwise noted, the procedures described in this 
guide apply to both Weathermap and Design layouts. 

Layer 3 visualization is supported in WAE Design, WAE Design Archive, and WAE Live. Layer 1 
visualization is supported in WAE Design. Most of the visualization tools are available for both Layer 3 
and Layer 1.

Figure 1-1 shows an example of a newly discovered network, a Design layout with a schematic canvas, 
and a Weathermap layout with a geographic canvas. 
1-2
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Figure 1-1 Example Network Before and After Modifying the Layout

Related Topics
• WAE Design Use Guide

• WAE Design Integration and Development Guide

• WAE Live Administration Guide

• WAE Design Archive User and Administration Guide
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C H A P T E R 2

Visualizing a WAE Network

WAE Design creates a simple default layout for newly discovered networks using one site per node, and 
each site name is based on the node name. Once the plan is opened in the WAE Design GUI, you 
typically rename and re-arrange objects in the newly discovered network using a sequence of steps 
outlined in the following sections.

• Remove Suffixes from Node Names—Remove suffixes from node names to ease readability of them 
in the plot and tables.

• Assign Sites to Nodes—Automatically places nodes into appropriate sites using simple rules or 
using a mapping table kept in the plan file. 

• Arrange Sites and Nodes—Arrange sites and nodes using tools that offer a variety of alignment and 
display options.

• Circuits and Interfaces—Change the manner in which circuits and interfaces are displayed.

• Set Plot Backgrounds—Set the background for the network plot, including schematic view, 
geographic outline background, and detailed geographic map views. 

• Traffic Utilization Colors—Change the traffic utilization colors saved with the plan and its multiple 
layouts, and create a customized user default color scheme.

• Set Plot Option Defaults—Set and use both user defaults and system defaults.

Helpful Tips

• If you are using multiple layouts, arranging sites and nodes maintains the position of these sites in 
all layouts within the plan file. However, all changes made using the Plot Options dialog box are set 
on a per-layout basis so before making such changes, ensure you are in the proper layout.

• Topology changes, such as adding, duplicating, and deleting objects, affect simulation results. It is 
recommended that after making these types of changes that you rerun the initializers and 
optimization tools if you have been using them. For example, you might want to rerun Metric 
Optimization to optimize the undifferentiated traffic, or if modeling an MPLS network, you might 
want to rerun the FRR LSP initializer. 

Remove Suffixes from Node Names
Node names collected from the network often have long suffixes that are the same for all nodes. This 
tool simplifies the process of removing these unwanted suffixes and acts on all nodes in the network 
regardless of whether they are selected.

Example: If all nodes in the network had a .mycompany.net suffix, you could remove this suffix by 
entering .mycompany.net in the Suffix to Remove field.
2-1
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Step 1 Select the Initializers->Rename Nodes menu.

Step 2 Enter the suffix that you want to remove from the node names.

Step 3 To remove this suffix from sites as well, select the “Also remove from containing sites” option. Then 
click OK.

Assign Sites to Nodes
Although nodes do not have to be contained in sites, adding them to sites can simplify and improve the 
visualization of the network. The Assign Sites to Nodes tool enables you to re-organize your network by 
changing the node-to-site mappings. For instance, you would typically place all nodes in the same 
geographic location or point-of-presence (PoP) into a single site. There are two options.

• One approach enables you to create a node-to-site association based on a simple mapping rule that 
applies to all nodes. This creates a temporary mapping that is not stored in the plan file.

• Another approach enables you to create or further customize a Node-to-Site Mapping table. This 
table uses more powerful rules to map nodes to sites based on regular expression substitutions. 
Because the table is stored in the plan file (as a <NodeSiteMappingRules> table), you can maintain 
and re-use it. In particular, when a collected plan is provided with a visual layout by a template plan 
for insertion into the WAE Design Archive, this table in the template is applied to assign sites to 
nodes in the collected plan file.

Figure 2-1shows an example of network plot before and after assigning sites to nodes. Beforehand, there 
were 19 sites and after there were 13. Notice the new site names that were generated.

For a description of how WAE Design makes node-to-site assignments when nodes are discovered, see 
the Plan Files and Templates chapter. 
2-2
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Figure 2-1 Example Before and After Assigning Sites to Nodes

Site Assignment Rules
The Assign Sites to Nodes tool assigns sites as follows.

If a node is not in an external AS and is not a PSN, then WAE Design assigns nodes to sites based on the 
Simple Mapping Rules or on the Node-to-Site Mapping Rules, depending on which is selected in the 
Assign Sites to Nodes dialog box.

If the node is in an external AS, WAE Design assigns it to a site named after the AS name. If the AS 
name does not exist, WAE Design assigns the node to a site named after its ASN.

If the node is not in an external AS and it is a pseudo-node (PSN), then WAE Design assigns it to the 
site that contains the most nodes connected to the PSN. In case of a tie, WAE Design assigns the node 
to the site with the lowest lexicographic name.

Simple Mapping Rules
To create temporary node-to-site mappings that are not stored in the plan file, use the “Simple Mapping 
Rules” option in the Assign Sites to Nodes dialog box. The mapping is created using two fields: Node 
Name Delimiter and Site Name.

• Node Name Delimiter—WAE Design uses this field to identify which sections of the node names 
are to be used in the assignments. By default, these are a period, a dash, and a colon (.-:). This means 
that new site names are based on the sections between these characters. For example, by default 
WAE Design parses the node name of acme.router into two sections: acme and router.
2-3
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– Site Name—WAE Design uses this field to determine how to create the site names based on the 
node names. In the following list, # equals any integer.

– $# — Specifies the section reading left to right. For example, $1 matches chicago in 
chicago.isp. Note that $0 specifies the entire node name. In Figure 2-1, the new site names were 
created using $2.

– [#:#] — Specifies the character range reading left to right. For example, $1[1:3] matches chi in 
chicago.isp.

– $-# — Specifies the section name reading right to left. For example, $-1 matches jose in 
san.jose.

– [-#:-#] — Specifies the character range reading right to left. For example, both $2[-4:-1] and 
$-2[-4,-1] match jose in san.jose.cr1.

Node-to-Site Mapping Rules
To create a Node-to-Site Mapping <NodeSiteMappingRules> table in the plan file, particularly for use 
by the template, use the “Use rules in Node-to-Site Mapping Table” option in the Assign Sites to Nodes 
dialog box. An attempt is made to match the node name to expressions in the Node Matches column. If 
a match is found, then the node is assigned to the site as defined by the corresponding Site Expression. 
This graphical example matches cr1.lax into lax-core and er1.lax into lax-edge.

The order in which these matches are attempted is defined by the Order column.

Examples

Column Description

Order Identifies the order in which rules are applied

Node Matches Regular expression matching the node names

Site Expression Site name expression, which can use references in the Node Matches rule

Node Matches Site Expression Result

cr1.chi.isp.net chi Map node cr1.chi.isp.net to site chi

.*\.(.*)\..* $1 Map node cr1.chi.isp.net to site chi as above, but also maps node 
cr1.okc.isp.net to site okc
2-4
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Assign Sites to Nodes Dialog Box

Step 1 Select one or more nodes if you want to assign sites to specific nodes. If you do not select nodes, WAE 
Design assigns sites for all nodes in the plan file for that view.

Step 2 Access the Assign Sites to Nodes initializer using one of these methods.

• Right-click on one of the selected nodes, and select Assign Sites to Nodes from the context menu.

• Select the Initializers->Assign Sites to Nodes menu.

Step 3 Select which method of node-to-site mappings you want to use.

• To use a temporary node-to-site mapping that is not stored in the plan file, select the “Simple 
Mapping Rules” option. See the Simple Mapping Rules section.

To use a Node-to-Site Mapping table that is saved with in the file, select the “Use # rules in 
Node-to-Site Mapping Table” option. 

To edit those rules, click the Edit Table button. See the Node-to-Site Mapping Rules section.

– To add a new rule, select an existing rule (if applicable) from the list, and then click on either 
the Insert Before or Insert After button to determine where the new rule goes sequentially. This 
opens a dialog box for adding a new rule.

– To edit an existing rule, select it from the list and then select the Edit button. 

– To delete an existing rule, select it from the list, select the Delete button.

Step 4 For those nodes that the node-to-site definition does not find or cannot create a matching site, you have 
the option to keep the nodes in their current sites (if applicable) or to remove them from sites. To keep 
them in their current sites, select the “Keep unmatched nodes in current sites” option.

Step 5 Select options based on whether you are in the Layer 3 or Layer 1 view, as follows.

..(.)\.(.*)..* $2-$1 Map node cr1.par.isp.net to site par-1

Node Matches Site Expression Result
2-5
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Step 6 To verify assignments, click the Update Preview button. Once satisfied with the mappings, click OK.

Arrange Sites and Nodes
You can arrange sites and nodes using the following methods. 

Note All schematic (X and Y) properties are relevant to the network plot, not to a parent site. 

• Schematically

– Align sites and nodes automatically through using the Arrange palette. See the Align Sites and 
Nodes Schematically section.

– Click and drag them to the desired location.

– Sites: Enter values in the Screen X and Screen Y fields of a site Properties dialog box.

– Nodes: Enter values in the X and Y fields of a node Properties dialog box.

• Geographically—Note that WAE Design uses geographic longitude and latitude for calculating 
distances and latencies between nodes that are used in various analyses.

– Automatically assign sites to locations using the Initializers->Assign Locations to Sites tool. 
See the Assign Geographic Locations to Sites section.

– Click and drag them to the desired location.

– Enter values in the Longitude and Latitude fields of a site or nodes Properties dialog box.

Layer Description

Layer 3 • For nodes that are in external AS’s, assign 
them to sites according to one of the 
following options.

– AS name, then ASN if the name is 
empty

– ASN

– Using the same rules as other sites 

• Select whether to assign PSN nodes and all 
remaining nodes to sites with most 
connections

Layer 1 • Select whether to assign remaining nodes to 
sites with most connections
2-6
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Helpful Tips

• Moving nodes and sites can often change the visibility of objects in within a site plot. Use the 
Fit-to-Plot (four arrows) icon in the site plot to bring all objects into view.

• Ensure you are in the proper plot background (Schematic or Geographic) for making the type of 
change you want to make. If you are using a geographic background and you move an object, this 
changes the geographic coordinates, but not the schematic ones. Conversely, if you are using a 
schematic background and you move an object, this changes the schematic coordinates, but not the 
geographic ones. To change the schematic or geographic background, use the Plot Options icon on 
the Visualization toolbar. For more information, see the Set Plot Backgrounds section.

Assign Geographic Locations to Sites
WAE Design includes a database of worldwide city names and airport codes that identify the longitude 
and latitude of major cities. Using the Locations tool that accesses this database enables you to quickly 
lay out sites within a network with geographic precision. 

You can quickly assign multiple sites to these locations following these steps. Note that changing the 
geographic location of a site does not change the location of its children sites.

Note To see the effects of geographic moves, you must be using a geographic background. To enable a 
geographic background, use the Plot Options icon on the Visualization toolbar. For more information, 
see the Set Plot Backgrounds section. 

Figure 2-2 Example Before and After Assigning Locations to Sites

Step 1 Optional: Select one or more sites. If you do not make a selection, a table containing airport codes for 
all sites is populated.

Step 2 Open the tool in one of these ways. 

• Right-click on a selected site, and select Assign Locations to Sites from the context menu.

• Select the Initializers->Assign Locations to Sites menu.

Step 3 Set the longitude and latitude values using one of the following methods.

• Enter longitude and latitude values directly into the table cells.
2-7
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• In each of these two methods, WAE Design fills in the fields with the most closely associated airport 
or city code in its database, thereby assigning longitude and latitude. 

If desired, select one or more rows from the table. If you do not select rows, WAE Design fills in the 
longitude and latitude values for all sites.

– Click the Best Match button. 

– Press Enter. (Do not press OK.) 

• Select a cell in the table, and click the All Matches button. WAE Design finds all airport or city codes 
that might be applicable to that site or location. Select the one you want, and press OK.

Step 4 If using an automated way of assigning locations, select whether to match the longitude and latitude 
values based on the sites or on the locations.

Note You can directly enter location information in the Location column. If you then match by site, locations 
might change based on the match. If you match by location, the site names do not change.

Step 5 Click OK to accept the newly assigned locations. 

Initialize Site Location

As an alternative to using the Assign Locations to Sites initializer, you can set a location from the 
Properties dialog box. 

Helpful Tip: Use airport codes for best results.

Step 1 Right-click on a site, and select Properties.

Step 2 In the Location field, enter a geographic name, such as a city, or enter an airport code.

• To replace the location with the best match in the WAE Design database, press Enter.

• To look up the best location, press Alt-Enter. (On a Mac, press Option-Return.) A Lookup Location 
dialog box appears.
2-8
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WAE Design fills in the Location fields with the most closely associated airport or city code in its 
database. Select a location, and click OK.

Step 3 Click OK to accept the newly assigned location. 

Align Sites and Nodes Schematically
The Arrange palette offers a number of options for precisely aligning sites or nodes within the network 
plot and on a per-site basis. Although the schematic X and Y properties are in relationship to the network 
plot, the tools within the Arrange palette operate within the container, where the container can be the 
network plot or one or more sites, depending on which nodes and/or sites you selected. 

Note To see the effects of schematic moves, you must be using a schematic background. To enable a schematic 
background, use the Plot Options icon on the Visualization toolbar. For more information, see the Set 
Plot Backgrounds section. 

Step 1 Select multiple nodes or sites. If the selected nodes or sites are within different parent sites, they are 
arranged on a site-by-site basis, if applicable. 

Step 2 To open the Arrange palette, either right-click in an empty area of the network plot and select Arrange 
from the context menu, or select the Arrange icon in the Visualization toolbar.

Step 3 Select objects to reposition in one of the following ways.

• Select sites or nodes either by selecting them individually (Shift-click) or by dragging the cursor 
around them. This is a good way to select a group of objects based on location or connectivity. 

• Select sites or nodes by selecting rows in the Sites or Nodes table, respectively. Both tables can be 
filtered and sorted so this is a good way to select a group of objects based on their name or other site 
properties. 

Step 4 Arrange the selected sites or nodes.

• To arrange sites or nodes within a plot, click the desired alignment icon.

• To arrange sites or nodes within a specific boundary, set the boundary box and then click the desired 
icon. 
2-9
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Boundary Box: A user-defined boundary box sets the borders within which the sites or nodes are 
arranged. To create a boundary box, press and hold the Ctrl key (Cmd on Mac), click the alignment icon, 
and drag the cursor to form a box. When you release the Ctrl (Cmd) key, the sites or nodes are arranged 
to positions within that boundary box.

Edge Groups

Large, complex networks often contain a limited number of core sites that form the network backbone, 
with many edge sites that connect locally to one or more of the core sites. 

• A core site contains at least one core node, and an edge site contains only edge nodes. 

• An edge group is the collection of edge sites that attach to core sites in the same way. A common 
example of an edge group is a topology where several edge sites have redundant connections to the 
core sites. If each edge site has the same redundant connections to the same core sites, they are in 
the same edge group.

Arrange Edge Sites

The Arrange palette has special features for arranging edge sites. To access this palette, right-click in an 
empty area, and select Arrange from the context menu. 

Icon Description

Align selected objects vertically without changing their horizontal location. 

Align selected objects horizontally without changing their vertical location.

Align selected objects vertically, horizontally, or diagonally. The objects are 
evenly positioned between the outermost selections. You can use boundary 
boxes. 

Align selected objects vertically, horizontally, or diagonally. The objects are 
evenly positioned between the outermost selections. You can use boundary 
boxes. 

Distribute to a grid determined by upper left and lower right of the selected 
items. You can use boundary boxes. 

Arrange objects in an orderly way based on connections between them. You 
can use boundary boxes.

Arrange selected objects proportional to their longitudes and latitudes, 
either within their original boundary box or within a new one. Any selected 
objects that do not contain longitudes and latitudes are arranged in an 
orderly way based on connections between them.
2-10
Cisco WAE 6.4 Network Visualization Guide



    

Chapter 2      Visualizing a WAE Network
  Arrange Sites and Nodes
Figure 2-3 shows an example network with edge sites that have been arranged to separate them from the 
core. Both sites on the left are in the same edge group because they each have two connections to the 
same two core sites. The site at the top of the diagram is in a separate edge group because it has different 
connections to the core sites. Edge sites can have a somewhat more complex topology, because they can 
also connect to a core site through another edge site.

Figure 2-3 Example Network with Edge Groups

Define Nodes as Edge or Core

Follow these steps to define nodes as core or edge. By default, all nodes are core nodes. 

Step 1 Select one or more nodes. Typically, in a large network with hundreds of nodes, filtering to the edge 
nodes is the fastest way to find and select them. For information on how to filter table entries, see the 
WAE Design User Guide.

Step 2 Right-click on one of the nodes, and select Properties. 

Step 3 Select core or edge from the Function list, and press OK.

Initializers->Edge Group Menu Description

Select • Select all sites in all edge groups. 

• Select all sites within a specific edge group, select one site within it, and then select 
this menu.

Separate To separate one or more sites from the network, select those sites and then select this 
menu. Note this does not separate the entire edge group. It only separates the selected 
sites.
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Show and Hide Nodes or Sites
By default, nodes and sites are visible in the network plot. You can hide nodes and sites and their 
connecting circuits on a per-layout basis, though they still exist in the plan file and tables.

Note Hiding a site also hides all of its contained objects.

Site Relationships to L3 and L1 Nodes

The WAE Design network plot supports the visualization of both L1 and L3 topologies. By default, sites 
containing L3 nodes appear in the L3 view and sites containing L1 nodes appear in the L1 view. Empty 
sites and sites containing both L3 and L1 nodes appear in both views. To toggle whether to show or hide 
sites per view based on whether they contain L3 or L1 nodes, use the Layer 1 tab in the Plot Options 
dialog box. For detailed information, see the WAE Design User Guide. For information on saving user 
defaults, see the Set Plot Backgrounds section. 

Although the WAE Design GUI shows weathermap layouts in the Layer 1 view, WAE Live and WAE 
Design Archive applications show only L3 topologies. 

Set and Position Display Name
By default, site and node names appear above the object. However, you can change this positioning. 
Additionally, rather than showing the site names, you can set a different display name that can be 
internationalized. Figure 2-4 shows an example of changing both for a site.

To ... Do This ...

Hide nodes or 
sites 

1. Select one or more nodes or sites from the plot, or select them from their 
respective Nodes or Sites table.

2. Right-click on one of the selected objects, and select Layout->Hide Nodes or 
Hides Sites from the context menu.

Find hidden 
nodes or sites

1. Use the Shown column of the Nodes table or Sites table.

Show nodes or 
sites 

1. Select one or more nodes or sites from their respective Nodes or Sites table.

2. Right-click on one of the objects, and select Layout->Show Nodes or Show 
Sites from the context menu.

To ... Do This ...

Set the site display name 1. Either double-click a site in the Sites table, or right-click on a site and select Properties 
from the context menu. 

2. Enter a name in the Display Name field, and click OK.
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Figure 2-4 Example of Changing the Site Display Name and Position

Circuits and Interfaces

Set Circuit and Interface Appearance
You can change how circuits are displayed by clicking the Plot Options icon in the top, right of the 
Visualization toolbar. Alternatively, select the Edit->Plot->Plot Options->Edit Options menu. For 
information on saving user defaults, see the Set Plot Backgrounds section.

The Design Circuits tab has the following options.

Change where site names are 
positioned

1. Right-click on one or more selected sites, and select the Layout->Set Site Name 
Position context menu. 

2. Select the direction in which you want the site name to appear in reference to the site, 
and click OK.

Change where node names are 
positioned

1. Right-click on one or more nodes selected nodes, and select the Set Node Name 
Position context menu. 

2. Select the direction in which you want the node name to appear in reference to the site, 
and click OK.

To ... Do This ...
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• Circuit Width—The circuit width is based on its capacity (the higher the capacity, the wider the 
circuit). Using these options, you can set the minimum width and the capacity it represents, as well 
as how fast the width grows as the capacity grows.

• Interface Text—This option, which is applicable to Design layouts only, enables you to display the 
percentage of interface filled with traffic, or the interface name, IP address, or IGP metric.

• Parallel Grouping—This option simplifies the representation of parallel circuits into a single circuit. 
By default, there is no grouping. See Set How Parallel Circuits Appear.

• Show QoS Bounds—This option, which is applicable to Design layouts only, enables you to toggle 
on/off the display of QoS bounds, which is the maximum interface capacity available without 
violating the QoS requirements. The default is On. For QoS bound information, see the WAE Design 
User Guide.

• The Other tab enables you to toggle on/off the following settings.

– Whether remote node names appear in the site plot.

– Whether to use anti-aliased lines. Turning off this option reduces the smoothness of lines in the 
plot, but speeds up the plot updates on some platforms.

– Whether transparency effects are used when plotting some circuits on top of others. Turning off 
this option speeds up the plot updates on some platforms.

Set How Parallel Circuits Appear

By default, WAE Design displays all circuits individually. For example, if you have parallel site circuits, 
they are displayed in a stacked manner. 

To simplify the visual display of a plan, you can group parallel circuits using any one of the methods 
described in step 3 of the following instructions. The grouped circuits show capacity and outbound 
utilization in the network plot and if applicable, in the site plots as follows. If the circuits are between 
sites, the utilization includes the utilization of nested interfaces, if applicable. 
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• The capacity of the grouped circuit is the sum of the individual circuits.

• The utilization of the grouped circuit is the average of the utilizations (weighted by capacity) of the 
individual circuits. The color fill of the grouped circuit shows this average. 

• In the Design layout, each side of the grouped circuit is divided lengthwise into its constituent 
interfaces that are individually selectable. Each interface within a grouped circuit has a thin colored 
border showing the utilization of that interface. Each interface continues to show textual 
information, such as IGP metric, if this has been enabled.

Figure 2-5 shows an example in the network plot using a Design layout. 

Note Parallel groupings change the visual representation of the layout, but do not affect the plan itself. If you 
want to literally merge parallel circuits (rather than just change the appearance), see the WAE Design 
User Guide.

Step 1 Click the Plot Options icon in the Visualization toolbar.

Step 2 Select the Design Circuits tab.

Step 3 From the Parallel Grouping drop-down list, select one of the following methods. 

• None—Each parallel circuit is displayed as a separate circuit (default).

• Node—Groups parallel circuits between two nodes.

• Metric—Groups parallel circuits between two nodes whose interfaces have the same IGP metric.

• Site—Groups parallel circuits between two sites. 

• SRLG—Groups parallel circuits that belong to the same SRLG.

• Group Name—Groups circuits belonging to a user-specified group set in the Parallel Group Name 
field of the circuit Properties dialog box. (See the WAE Design User Guide.)

Step 4 For Design layouts, you can set the maximum display width for parallel circuits. 

Step 5 Click OK. For information on saving user defaults, see the Set Plot Option Defaults section.
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Figure 2-5 Both Ungrouped and Grouped Parallel Circuits by Site in a Design Layout

Set Interface Style

By default, two interfaces are represented in the plot as two sides of a full-length circuit drawn from one 
site to another. However, circuits connected to internal or external AS’s are shortened.

This full-length model works well when the sites are close together, but if they are far apart full-length 
circuits can clutter the plot. You may want to display the sites as regions by shortening circuits between 
them.

Interfaces between the same two sites or between the same two nodes have the same interface style. If 
you change the style for any one of these interfaces, the style of all associated interfaces changes too.

Step 1 Select one or more interfaces or circuits. 

Step 2 Right-click on one of the selections. From the context menu, select Layout->Set Interface 
Style->Option, where Option is one of the following choices.

• Full Length—The entire interface is displayed.

• Shortened—A short portion of each interface is shown attached to the node containing the 
outward-bound interface. 
2-16
Cisco WAE 6.4 Network Visualization Guide



    

Chapter 2      Visualizing a WAE Network
  Circuits and Interfaces
• Collapsed—The interfaces are not shown on either side of the node or site. The remote interface on 
the circuit does not appear.

• Default—If the circuit is connecting two nodes in the same internal AS, the interfaces appear as full 
length; if it connecting two nodes in different AS’s, the interfaces appear as shortened. 

Curved Weathermap Circuits

Follow these steps to move and curve the circuits in a Weathermap layout.

Step 1 Click the circuit to see a circular pink icon. 

Step 2 Drag the pink circle in any direction, thus creating curved circuit lines.

To move circuits such that the sites or peers stay in horizontal or vertical alignment, press and hold the 
Shift key while dragging the circular icon. 

Reset Curves

One way to simplify a Weathermap layout is to reset the circuits’ curves. Doing so changes the curves 
so they are more similar to ones that exist, and removes circuit overlap.
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Step 1 Select all circuits that you want to reset.

Step 2 Right-click on one of the selected circuits, and select Layout->Reset Curves from the context menu.
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Set Plot Backgrounds
Select the network plot background in the Plot Options dialog box, General Options tab, which is 
selectable via the Plot Options icon in the Visualization toolbar. Alternatively, select the 
Edit->Plot->Plot Options->Edit Options menu. Figure 2-6 shows an example of three available options. 
For information on user and system defaults, see the Set Plot Backgrounds section.

• Schematic views show the network based on the X,Y properties of the nodes and sites. 

Additionally, you have the option to select or add a static background image in .png format. If the 
image is a background map, the topology likely will not map to an imported image, so you have to 
re-arrange the sites accordingly. Note that these images can be saved in .pln or .db formats, but not 
in .txt format.

• Geographic views show the network based on the Longitude and Latitude properties of the nodes 
and sites. 

– Outline Background Map—Geographic map with outline of countries and if applicable, USA 
states.

– Detailed Background Map—Geographic map with streets. Click the zoom icon (magnifying 
glass icon in the Visualization toolbar) to see the level of desired detail. This option requires 
Internet connectivity to access the online map server. If connectivity is unavailable, use the 
outline background, or download a map image and import it as a background image. To access 
a different online map server, see the WAE Design Integration and Development Guide.

– Longitude Boundary—Measurement in degrees that specifies the east-west position of a point 
on the Earth's surface. The default is the -180 degrees, but could be changed, for example, to 
provide a continuous view of the Pacific.
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– Site Canvas—If you are using the schematic view for the network plot, all sites show only the 
schematic view and you cannot further configure the site view. If you are using either of the 
geographic views, you can specify how to view the sites using the Site Canvas options. These 
options apply to all sites, regardless of whether they contain L3 nodes, L1 nodes, or both. Note 
that this option does not affect the placement of nodes that are not in sites. 

Schematic view—Shows nodes and sites network based on the X,Y properties of the nodes and 
sites.

Geographic view—Shows the same background as the geographic view selected for the network 
plot (outline or detailed). 

Schematic view when site contains only nodes—Use this option to visualize nodes that have the 
same geographic coordinates within the same site. Using the geographic view results in these 
nodes being placed on top of each other. 

Figure 2-6 Backgrounds for WAE Design Network Plot
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Create Static Background Map
If you have a static .png image that you prefer to use as a background, you can add these either through 
the Plot Options dialog box or the Edit menu. You can also rename and delete them using the Edit option.

Figure 2-7 Add a Static Background Image

Traffic Utilization Colors
Interfaces have both measured and simulated traffic (in Mbps). This traffic appears on the interfaces as 
color fills that represent the percentage of outbound traffic in comparison to its capacity. The default 
colors for these representations appear in the Utilization Color menu, which is a set of color-coded 
drop-down lists in the Visualization toolbar. There are six default colors representing thresholds ranging 
from 0% to 100% (Figure 2-8).

Add Static Background Map Through Plot Options Add Static Background Map Through Edit Menu

1. Click the Plot Options icon in the Visualization toolbar, or 
select the Edit->Plot->Plot Options->Edit Options menu.

2. In the General Options tab, select the Schematic option.

3. Click the New button next to the Background Image list.

a. Enter the name of the map as it will appear for 
selection from the GUI.

b. Enter or browse to the name of the .png file that is the 
static image you are uploading.

c. Click OK.

4. Click OK in the Plot Options dialog box.

1. Select the Edit->Plot->Background Images menu.

2. Click the New button. 

a. Enter the name of the map as it will appear for 
selection in the GUI.

b. Enter or browse to the name of the .png file that is 
the static image you are uploading.

c. Click OK.

3. Click Done in the Edit Background Images dialog box. 
2-21
Cisco WAE 6.4 Network Visualization Guide



    

Chapter 2      Visualizing a WAE Network
  Traffic Utilization Colors
Note that in the L1 view, only the Failure Impact view shows colors, and those colors are related to L3 
interface utilization. For information, see the WAE Design User Guide, Layer 1 chapter.

Figure 2-8 Default Utilization Colors

Each default utilization color has a menu whose numbers correspond with their values in the Design 
Colors tab of the Plot Options dialog box (Figure 2-9). It is from this Edit Colors dialog box that you 
edit the colors used for traffic utilization.

You can edit the utilization values, add and remove colors, and locate interfaces that meet utilizations 
levels of special concern. Edits to these colors are saved to the plan file when the file is saved. You can 
also create and save a set of user defaults that can be applied to other plan files. Different utilization 
colors can be set for different layouts in a plan. For information on saving and applying user defaults, 
see the Set Plot Backgrounds section.

Note All documentation and instructions are written according to default colors using a Design layout. If you 
change to a Weathermap layout or if you change colors and their uses, the instructions herein still apply.
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Figure 2-9 Relationship of Edit Colors Dialog Box to Traffic Utilization Color Menu

Change Traffic Utilization Values

Find and Set Maximum Utilization

• Select Max from the purple drop-down list. WAE Design finds the most utilized interface and sets 
the minimum utilization for purple to that value. As a result, that interface (and only that interface) 
is highlighted in the plot with purple. This method offers a quick way to determine the most highly 
utilized interface.

• Open the Plot Options, Design Colors dialog box by selecting the far right, gray drop-down list from 
the Utilization Color menu. Here, either enter a new value or select a value from the drop-down list 
in the top, purple row. Click OK to save the changes.

Change Minimum Utilization Values

If you set a minimum value that imposes on an existing utilization value, WAE Design calculates a new 
percentage for that existing utilization or calculates that it cannot be used. 

Example: The default for red is 90-100%, and the default for orange is 80-90%. If you set red to mean 
80-100% utilization, orange is not used in the plot to show utilization. If you set red, however, to mean 
85-100%, then WAE Design adjusts the orange value to the remaining amount available, which in this 
example is 80-85%.

To change minimum utilization values, use either the color drop-down list or the Plot Options, Design 
Colors dialog box. Both options behave the same way. Modifications in the drop-down list appear in the 
Design Color dialog box and vice versa. 

Step 1 If using the dialog box, open it using one of these methods. 

• Click the Plot Options icon, and select the Design Colors tab.

• Select the far right, gray drop-down list from the Utilization Color menu.

• Select the Edit->Plot->Plot Options->Edit Options menu, and select the Design Colors tab.
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Step 2 Change the minimum value using one of these methods.

• If you select an exact value, that value becomes the new minimum.

• If you select a number with a greater-than sign (>) next to it, WAE Design finds the interface that is 
closest to and greater than that value. 

Example: By default, yellow is 50-80%. If you select >50%, WAE Design finds the interface with 
a utilization that is closest to and greater than 50% (Figure 2-10).

• If you select a number with a less-than sign (<) next to it, WAE Design finds the interface that is 
closest to and less than that value.

Example: By default, light green is 30-50%. If you select <50%, WAE Design finds the interface 
with a utilization that is closest to and less than 50% (Figure 2-11).

• If in the dialog box, you can enter a value directly into the field.

Step 3 If in the dialog box, click OK to save the changes. 

Figure 2-10 Example of Changing a Minimum Utilization Value Using the Color Drop-Down List
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Figure 2-11 Example of Changing a Minimum Utilization Value in the Plot Options, Design Colors 

Dialog Box

Add and Delete Utilization Colors

Add New Utilization Colors

After adding a color, the maximum utilization value for it is based on the minimum value above it. When 
you assign the new color a minimum utilization value, it always imposes on the utilization range below 
it (unless the utilization value you are adding is the lowest). Since this minimum value imposes on an 
existing one, WAE Design recalculates a new percentage for that existing utilization or calculates that it 
cannot be used. 

Once a utilization color is added, it appears in the Utilization Color menu.

Step 1 Open the Design Colors dialog box using one of these methods. 

• Click the Plot Options icon, and select the Design Colors tab.

• Select the far right, gray drop-down list from the Utilization Color menu.

• Select the Edit->Plot->Plot Options->Edit Options menu, and select the Design Colors tab.

Step 2 Click on the plus (+) button to the right of the color below which you are adding a new color. The row 
is replicated below it and is marked as Not used. For example, to add a utilization color below red, click 
on the + button on the same row as red.

Step 3 In the new row, either enter a new minimum value or select it from the list, and then click OK.

Example: Figure 2-12 demonstrates adding a magenta utilization color with a range of 95-100%.
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Figure 2-12 Example of Adding a Magenta Utilization Color with a Range of 95-100%

Delete a Utilization Color

Although you can delete a default color so that it is not represented on the plot, doing so does not remove 
that color from the Utilization Color menu. Deleting a color that you previously added, however, 
removes it from the toolbar.

Step 1 Select the far right, gray drop-down list from the Utilization Colors toolbar.

Step 2 Click on the minus (-) button associated with the row you want delete. Then click OK.

Set Plot Option Defaults
Each time you modify one or more plot options, they are saved in the plan file for the current layout. 
When you save the file, these plot options are saved per layout. 

There are two types of plot option defaults.

• User Defaults—A set of customized plot options that you can create, set, and apply to other plan 
files. Each time you set a user default, it overrides the previous version. 
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If you open a previously unopened plan file, its default plot options are the user defaults if they exist.

Example: If you set the user defaults for plan A, you can then open plan B and apply these user 
defaults to it.

• System Defaults—The set of plot option defaults that comes with WAE Design. These are not 
configurable, and can always be applied.

System defaults are applied to a previously unopened plan file if no user defaults have yet been 
defined. 

User and system defaults are per layout type. For instance, if you are in a Design layout and you apply 
user defaults, then the Design user defaults apply. If you are in a Weathermap layout and you apply 
system defaults, then the Weathermap system defaults apply.

Note You can also save how you view tables, columns, foreground and background objects, and other 
preferences for all plan files that you open in the future, use the View menu. For more information, see 
the WAE Design User Guide, User Interface chapter.

Related Topics
• Using Layouts chapter

• WAE Design User Guide

• WAE Design Integration and Development Guide

To ... Select This Menu ... 

Apply system defaults. Edit->Plot->Plot Options->Apply System Defaults

Save current plot options to user defaults. Note you cannot cancel 
the result of having saved the user defaults.

Edit->Plot->Plot Options->Save User Defaults

Apply user defaults. Edit->Plot->Plot Options->Apply User Defaults
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Using Layouts

A single plan can contain numerous layouts, each containing its own set of visual properties. Given the 
complexity of networks, you might need to create different layouts for numerous reasons. For instance, 
you might need to simplify sections of the network for better analysis or planning purposes. Another use 
might be to display a geographic layout or a schematic layout. 

The attributes that are set and saved on a per-layout basis are hide/show objects, interface styles, site 
name placement, and all plot options. You can save the plot options as user defaults, thus making it easier 
to apply the same plot options to different layouts.

Saving a plan file saves all layouts. Once plot layouts have been designed for a particular plan file, you 
can copy them to another plan file by selecting the File->Copy From Template menu. 

Weathermap vs. Design Layouts
There are two layout types: Weathermap and Design. 

• The Weathermap layout is designed for use in a static, non-interactive view of a fixed network 
layout, with an emphasis on seeing operational issues such as high utilization. It is recommended 
for creating and editing WAE Live weathermap templates. 

• The Design layout is more useful for interactive work where the emphasis is on detailed interactions 
and network editing. It is recommended for planning and design work within the WAE Design GUI. 
The WAE Design Archive application only supports the Design layout.

Note Plan files open using the layout named Default, which is a Design layout. If this is your first time opening 
a plan file and you are modifying it to use in WAE Live, you must first either create a Weathermap layout 
or change the Default type to be a Weathermap layout. For instructions, see the Create or Edit Layouts 
section.

The conventions described in this guide apply to both Weathermap and Design layout types, but there 
are key differences between the two. Table 3-1 describes these differences, and Figure 3-1 shows an 
example of each layout using the same topology and canvas.
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Table 3-1 Differences Between Weathermap and Design Layouts

Description Weathermap Layout Design Layout

The shape and size of the circuits differ. 

• Weathermap circuits have a fixed width. They 
can also be curved to enhance a static network 
view. 

• Design circuits show different widths 
depending on capacity. These circuits cannot 
be curved.

Example: In the graphs on the right, the top 
circuit has a capacity of 1,000 Mbps, and the 
circuit on the bottom has a capacity of 10,000 
Mbps. 

In Weathermap layouts, the traffic utilization 
color fills the entire interface. In Design layouts, 
the color fills up the interface proportional to 
traffic utilization levels.

Parallel circuits render differently. In both 
layouts, color fill of the grouped circuit shows this 
average. In the Design layout, however, the circuit 
is divided lengthwise into its constituent 
interfaces, and each interface has a colored border 
showing the utilization of that interface.

The default utilization colors are different. The 
Weathermap layout uses more saturated and more 
appropriate colors for static viewing in a Web 
browser, whereas the Design colors are more 
suitable for the interactive work in the GUI.

The site icon and site name appear differently.

• In the Weathermap layout, the color of the 
site icon is the maximum utilization color of 
all intrasite interfaces within the site. The site 
icon does not reflect whether interfaces from 
it are collapsed. 

• In the Design layout, the color of the site 
border is the maximum utilization color of all 
intrasite interfaces within it.

Up/down triangles in a site reflect interfaces 
from it are collapsed. 
3-2
Cisco WAE 6.4 Network Visualization Guide



    

Chapter 3      Using Layouts
  Create or Edit Layouts
Figure 3-1 Example Weathermap and Design Layouts Using the Same Topology and Canvas

Create or Edit Layouts
You can create or edit layouts to change the appearance or to narrow or broaden what you see in the plan 
file. This might be useful, for example, to focus on a specific section of a network. For example, 
Figure 3-2 shows a transatlantic layout that was modified to show only the European sites. Following are 
a few of the ways in which you might choose to create or edit layouts.

• Modify interface style. For example, you might want to shorten the interfaces to external sites. 

The node icon and node name appear differently. 
In the Weathermap layout, the node icon does not 
reflect whether interfaces from it are collapsed, 
whereas in the Design layout, it does.

The peer site icon and peer name appear 
differently. In the Weathermap layout, peering 
sites (that is, any site containing one or more 
external AS nodes) appears as a cloud. In the 
Design layout, they have the same appearance as 
sites, and, like other sites, they reflect whether 
interfaces from them are collapsed.

Description Weathermap Layout Design Layout
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• Show or hide sites.

• Arrange objects.

• Change the background map. 

• Make other visual changes to the plot, such as identifying how circuits and interfaces appear.

Figure 3-2 Example Modified Weathermap Layout

Create Layouts

Step 1 Select Edit Layout from the Layouts drop-down list. The Edit Plot Layouts dialog box appears.

Step 2 You can use either New or Duplicate to create a new layout, or use the Edit option to edit existing layouts.

• To create a new layout based on the layout that is currently open, click New. 

In the New Plot Layout dialog box, enter the layout name.

Select whether this is a Design or Weathermap layout.

Click OK.
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If the sites have longitude and latitude coordinates defined, those are preserved. Otherwise, the sites 
are arranged in a square formation. Other plot settings are set to their defaults.

• To duplicate the layout exactly, select an existing layout, and then click Duplicate. Enter the name, 
and then click OK. This copies the layout type (Design or Weathermap). If you need to change the 
layout type, you must then edit it.

Step 3 Click OK in the Edit Plot Layouts dialog box.

Edit Layout Name or Type

Step 1 Select the name of an existing layout from the Edit Layouts menu, and then click Edit. 

Step 2 Modify the name, the type, or both, and then click OK.
3-5
Cisco WAE 6.4 Network Visualization Guide



    

Chapter 3      Using Layouts
  View Layouts
Step 3 Click OK in the Edit Plot Layouts dialog box. 

View Layouts
To view a layout, click on the Layout icon in the top, right corner, and select the desired layout from the 
drop-down list. 

Related Topics
• Visualizing a WAE Network chapter

• Plan Files and Templates chapter

• Access WAE Live chapter

• Access an Archive chapter

• Access WAE Automation Server and Deploy chapter
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Plan Files and Templates

This chapter describes plans files and templates so that you understand their structure, and how templates 
are applied to plan files for visualization in the applications. Only those applications or servers that are 
accessible from the WAE Design GUI are mentioned in this chapter.

• Plan Files—Provides a brief description of plan files. For detailed plan file information, see the WAE 
Design Integration and Development Guide.

• Templates—Describes how templates apply to plan files, how they integrate with the applications, 
how the Copy from Template tool works.

Figure 4-1 shows the plan file and template workflow for applications. The recommendation is to open 
the remote plan file, modify it in the GUI to create the visual template, and save it to the remote archive 
as a template (where it overwrites the archived template).

Figure 4-1 also shows the workflow of using the WAE Design GUI to open plan files from and save plan 
files to the remote WAE Automation server, wherein they can then be deployed to the network.

Plan Files
A plan file is comprised of a series of tables that store information about a network, including topology, 
configuration information, traffic, failure state, and visual layout Additionally, WAE Design uses plan 
file information to perform simulations.

Plans files are typically created by the WAE Collector discovery process for use by the applications or 
the APIs. The WAE Live, WAE Design Archive, and WAE Design applications all have interfaces for 
viewing the network through a plan file. The WAE Coordinated Maintenance application uses plan files 
for traffic data. 

The WAE Design GUI can access remote servers to send and receive plan files. 

Templates
A WAE Design template identifies how the plan file visually looks and can contain information that is 
not discovered. As such, templates are a convenient way to replicate manual changes across multiple 
plan files. For instance, you can augment newly discovered plans with non-discoverable information.

No matter the discovery method, the way to make further visual enhancements to the plan file is using 
the WAE Design GUI, which can access remote servers to send and receive templates. 

Where templates are created depends on the discovery method.
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• For WAE Live, the template is stored in a map archive. It is to this location that you are saving a 
template if saving it from the WAE Design GUI to WAE Live.

Once WAE Live requests and receives a plan file, it automatically applies its own template that 
contains the visual elements for laying out the network. If this template has not yet been enhanced 
using the WAE Design GUI, the plan file is visualized in the default, unprocessed state. If a template 
does not yet exist in the map archive, WAE Live creates one from the latest plan file and stores it 
that location.

• If using the augmented or manual method of discovery, the copy_from_template tool is used within 
the snapshot process to either include more objects in the template, change the visual representation 
of them, or both. The resulting snapshot plan file is saved to an external archive. These files are 
available for use in the applications. While those plan files might already have visualization 
enhancements (via copy_from_template), WAE Live will still apply its own template as described 
in the previous bullet.

When saving a template from WAE Design to either WAE Live or to an archive, template changes apply 
only to plan files collected after that template is saved. That is, those templates changes do not apply to 
historical plan files.

Note The WAE Automation server does not contain templates as defined here. Also note that while the WAE 
Coordinated Maintenance application uses templates, it does so only for the purpose of having current 
topology (not for visualization purposes). This section only describes templates used for visualization 
purposes.
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Figure 4-1 Plan File and Template Flow Using the WAE Design GUI

Copy from Template 
The Copy from Template tool enables you to copy objects and their properties from one a template to 
another file. By copying a template, you can augment newly discovered plans with non-discoverable 
information, such as sites, layouts, shared-risk link groups (SRLGs), external endpoints, and Layer 1 
(L1) objects.

• One common use is to use the CLI copy_from_template tool to automate the process of applying a 
template to newly discovered network snapshots before saving them in an archive. Thus, when you 
open the new plan file, you need not complete its layout or insert non-discovered objects. Note that 
this CLI copy_from_template tool has more functionality than in the GUI. For information, see the 
copy_from_template -help output.

• Another use is to create one or more visual layouts in one plan file and copy the layouts into other 
plan files, thus avoiding repetitive efforts of recreating layouts. This practice is useful even for plans 
created outside of network discovery.

WAE Live

Archives

WAE Design

WAE Design
Archive

Plan Files

Templates

4
0

7
0

5
7

WAE Collector WAE Automation Server

WAE Platform

Network
4-3
Cisco WAE 6.4 Network Visualization Guide



    

Chapter 4      Plan Files and Templates
  Templates
The selected properties or objects are copied from the template to the open plan file, and a report is 
displayed. If there are nodes or interfaces in the plan file that are not in the template, this might indicate 
that the discovered network has been changed, and the template is out of date. In this case, the report 
states that the template should be updated.

Note that you can individually import SRLGs, a Layer 1 model, a QoS model, demand groupings, 
external endpoints, and tags from one plan file to another, all from the File->Import menu. For 
information, see the WAE Design Integration and Development Guide. 

Assigning Nodes to Sites

In the WAE Design GUI, the visual layout is based on the schematic or geographic arrangement of sites 
and nodes. If nodes are within sites, this node-to-site assignment is not discoverable. 

When layouts are copied from the template, nodes that are discovered are placed in the plan file as 
follows.

• Each existing node without a parent site continues to exist without a parent.

• If a discovered node is matched to a node within a site in an existing template, it is assigned to the 
same site.

• If the node is new, it is assigned to a site based on the Node-to-Site Mapping 
(<NodeSiteMappingRules>) table in the template. For information on how these tables are created, 
see the Visualizing a WAE Network chapter.

• If WAE Design cannot assign the discovered node to an existing site, an ExtraNodes site is created 
and the unassigned node is placed there. This site appears at the top, right of the plot. 

Copying Missing Information

If any nodes, circuits, L1 nodes, or L1 links are down, the network discovery process omits them from 
the discovered plan file. Since a template used for network discovery typically contains these objects, it 
can fill in the missing objects to provide a complete visualization of the network. Whether these objects 
are set to inactive or active depends on the selected copy method (Table 4-1).

Errors in network discovery can sometimes prevent node names, interface names, or IP addresses from 
being discovered correctly. The Copy from Template tool attempts to fill in the missing object 
information by matching nodes and interfaces in the two plans by name and IP address; for nodes that 
are in external AS's, it also checks the BGP-ID. For example, if the discovery process finds an IP address 
of an interface, but not its name, the tool looks for an interface in the template with a matching IP 
address, and then copies over the name from the template interface.

Copy Methods

The objects and properties that are copied depends on the selected method (Table 4-1). 
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Table 4-1 Copy from Template Methods

Copy from Template Steps

For information on how to copy from template in the CLI, refer to the copy_from_template -help 
output.

Step 1 Select the File->Copy From Template menu. The Copy Values From Template File dialog box appears. 

Step 2 In the Template File field, enter or browse to the fully-qualified path and filename of the plan you are 
copying.

Step 3 Specify how to copy L3 values from the template into the plan. See Table 4-1.

Step 4 Specify how to match nodes in the plan with those in the template.

Copy from Template Method Description

Fill in missing details • Copies L3 template layout, including site assignments for nodes.

• Copies L3 nodes and circuits, and sets them to inactive. 

• For newly discovered L3 nodes, assigns nodes to sites based on the 
<NodeSiteMappingRules> table created using the Assign Sites to Nodes 
feature. For information on creating this table, see the Visualizing a WAE 
Network chapter.

• Copies non-discoverable L3 objects, such as SRLGs and AS relationships.

Fill in visual elements only • Copies L3 template layout.

• For newly discovered L3 nodes, assigns nodes to sites based on the 
<NodeSiteMappingRules> table created using the Assign Sites to Nodes 
feature.

Copy L1 visual layout • Copies template layout for L1 objects.

• Site assignments are based on the site assignments in the template. Any L1 
nodes that exist in the plan file but not in the template are placed in an 
ExtraL1Nodes site that is created for this purpose.

Copy the L1 model from the template You cannot copy L1 objects without copying L3 objects (without “Fill in missing 
details” also being selected).

• Copies template layout, including site assignments for L1 nodes.

• Copies all L1 objects.

• Site assignments are based on the site assignments in the template. Any L1 
nodes that exist in the plan file but not in the template are placed in an 
ExtraL1Nodes site that is created for this purpose.
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• Name, the IP address, then BGP ID—Select this option to match all nodes by name if possible, then 
by IP address, and then by BGP ID.

• IP Address, then BGP ID, then Name—Select this option to match all nodes by matching by IP 
address if possible, then by BGP ID, and then by name.

Step 5 Specify how to match interfaces in the plan with those in the template.

• Name, then IP Address (if available)—Select this option to match all interfaces and circuits by name 
if possible, and then by IP address.

• IP Address (if available), then Name—Select this option to match all interfaces and circuits by 
matching by IP address if possible, and then by name.

Step 6 Optional: Specify how to copy L1 values from the template into the plan. See Table 4-1.

Step 7 Optional: Selectively choose which nodes to include by clicking the Preview/Customize button. From 
here you can click the Edit button to select nodes, as well as set copied nodes to inactive. If the plan file 
contains nodes that the template does not contain, they are put into a site named ExtraNodes (for L3 
nodes) or ExtraL1Nodes (for L1 nodes).

To view which circuits to include, click the Next button.You can click Edit to select specific circuits 
and/or you can set the circuits to inactive. It is recommended that you not use this option unless you also 
choose to include nodes associated with these circuits.

Step 8 Click OK. 

Step 9 Look at the network plot to verify the success of the copied template.

Related Topics
• Access WAE Live chapter

• Access an Archive chapter

• Access WAE Automation Server and Deploy chapter

• WAE Design Integration and Development Guide
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• copy_from_template CLI tool in $CARIDEN_HOME/bin, where $CARIDEN_HOME is the directory in 
which the WAE Design, WAE Live, and WAE Collector executables and binaries are installed. On 
Linux, the default $CARIDEN_HOME is /opt/cariden/software/mate/current.
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Access WAE Live

WAE Live can be installed on the same or different Linux device or VM as WAE Design. WAE Live plan 
files and templates are stored in map archive repositories. 

From the WAE Design GUI, you can extract WAE Live .pln plan files and templates from WAE Live and 
make whatever modifications are necessary. You can then re-insert them as template files into a map 
archive directory. Another use case for accessing WAE Live is to open plan files containing traffic used 
in the Forecasting tool.

Note When uploading a template to a map archive, you are overwriting the template that is in that map archive. 

Prerequisites
• You must know the username and password for the WAE Live administrator (admin role), which is 

set in the web System UI.

• To access any network other than the default, that network must first be configured for WAE Live.

• You must know the name of the network and the map archive.

– The default WAE Live network name is “default,” and the default map archive name is 
“default-archive.” 

– All other map archive names use the format <network_name>-archive. 

Access WAE Live

Step 1 In the WAE Design GUI, use the File menu to start the process.

• To download a WAE Live plan file or template from a remote Live Map archive, select the 
File->Open from->WAE Live menu.
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• To upload a WAE Live template to a remote Live Map archive, select the File->Save to->WAE Live 
menu. You must have an administrative username and password to upload templates.

Step 2 After opening the dialog box, enter or select the hostname or IP address of the server. 

Step 3 Identify how to connect to the server by selecting the appropriate protocol and by entering or selecting 
the port number (for example, HTTPS 8443).

Step 4 Enter or select the name of the network you are accessing. The name of the default WAE Live network 
is “default.”

Step 5 Enter the username and password that gives you access to the server. Both are case sensitive. If you do 
not know the password, contact your system administrator. 

Step 6 If saving a template, click OK and stop here. If opening a plan file or template, continue to step 7.

Step 7 Select one of the following options, and then click OK.

• Template—Open the template file.

• Latest plan—Open the most recent plan file available.

• Plan at time—Specify an exact date and time. If these plan file are not local, you either need to log 
in to the server or ask the administrator of that server for the proper date and time.

On the server, these plan files are stored in a map archive. To find it, go to the directory in which the 
plan file is stored and then drill down to the specific directory to list contents. The format of this 
directory structure is as follows. 

<map_archive_path>/data/<year>/<month>/<YYMMDD>_UTC

Note that the default map archive path is 
/opt/cariden/data/mldata/archives/<network_name>-archive.

Plan files are listed in these map archive directories in the following format.

YYMMDD_HHMM_UTC.pln

Example: Using the map archive named acme-archive, you would drill down to the following 
directory to choose a plan file created on February 23, 2016.

/opt/cariden/data/mldata/archive/acme-archive/data/2016/02/160223_UTC

ll

-rw-r--r-- 1 cariden cariden 115651 Feb 23 02:04 160223_0204_UTC.pln

-rw-r--r-- 1 cariden cariden 115651 Feb 23 02:04 160223_0304_UTC.pln

-rw-r--r-- 1 cariden cariden 115651 Feb 23 02:04 160223_0404_UTC.pln
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If selecting a specific plan file and if the operating system’s UTC is different than 0, you must enter 
that UTC value.

Note If you have access to the WAE Live UI, the plan files are displayed in a configurable time zone. These 
time zones might not be the same as stored in the map archive. For instance, in the above example, the 
WAE Live GUI might be displaying this same plan file as February 22, 14:04 with a UTC of -8. 
Therefore, it is best practice to reference the map archive in the directory structure (not the plan files in 
WAE Live) to determine specific plan file dates and times to open in WAE Design.

Save and Clear Settings
• To save all settings for use the next time you open the remote access dialog box, click Save Settings. 

This saves all settings whether the fields and all entries in the drop-down lists are empty or not. You 
can optionally save the authentication password.

• To clear all current user-specified settings from the fields and from the drop-down lists, click Clear 
Settings. Note that this does not clear the default Protocol, Port, and Network values, though manual 
entries in these fields are cleared.

• To delete all user-specific settings so the next time you open the remote access dialog box all fields 
and all drop-down lists are empty (except for the default Protocol, Port, and Network values), follow 
these steps.

Click Clear Settings.

Ensure Save Settings is enabled.

Click OK to exit. Upon being prompted for whether to continue, click Yes.

Related Topics
• WAE Live Administration Guide

• WAE Live User Guide

• WAE Design User Guide

• WAE Design Integration and Development Guide
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Access an Archive

Plan files and templates are stored in archive repositories, which can be installed on the same or on a 
different device or VM than WAE Design GUI. From the WAE Design GUI, you can extract .pln plan 
files from these archive directories, make whatever modifications are necessary, and re-insert them as 
.pln files into an archive used by other applications. You can also open, modify, and then save a remote 
archive template. 

Note When uploading a template to a remote archive, you are overwriting the template that is in the archive. 

Prerequisites
• You must know the username and password for the WAE Design Archive administrator (admin role), 

which is set in the web System UI.

• One or more archives must be configured.

Access an Archive

Step 1 In the WAE Design GUI, use the file menu to start the process.

• To open a WAE Design Archive plan file or template from a remote archive directory, select the 
File->Open from->Archive menu.

• To save a WAE Design Archive plan file or template in a remote archive directory, select the 
File->Save to->Archive menu. You must have an administrative username and password to upload 
plan files or templates.
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Step 2 After opening the dialog box, enter or select the hostname or IP address of the server. 

Step 3 Identify how to connect to the server by selecting the appropriate protocol and by entering or selecting 
the port number (for example, HTTP 8080).

Step 4 Enter or select the name of the archive you are accessing.

Step 5 Enter the username and password that gives you access to the server. Both are case sensitive. If you do 
not know the password, contact your web system administrator. 

Step 6 Enter the UTC offset to apply to the date specified in the "Plan at Time" field. If you do not enter a date, 
the file is opened or saved according the server’s UTC time.

Step 7 Select options for either opening/saving a plan file or template.

• If opening or saving a template, select the Template option. 

• Plan files

– If opening a plan file, identify which one by the latest or by a specific time. 

– If saving a plan file, identify the time as current or as a specific time. 

– If entering a time, use the YY/MM/DD HH:MM format.

Then click OK.

Step 8 Select one of the following options, and then click OK.

• Template—Open the template file.

• (Open from) Latest plan—Open the most recent plan file available.

• (Save to) Plan at current time—Save the plan file using the current date and time stamp.

• Plan at time—Specify an exact date and time. If these plan file are not local, you either need to log 
in to the server or ask the administrator of that server for the proper date and time.

On the server, these plan files are stored in an archive directory. To find it, go to the directory in 
which the plan file is stored and then drill down to the specific directory to list its contents. The 
format of this directory structure is as follows.

<archive_path>/data/<year>/<month>/<YYMMDD>_UTC

Plan files are listed in these archive directories in the following format.

YYMMDD_HHMM_UTC.pln
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Example: This example shows an archive directory named cgo-archive for November 8, 2015. It has 
three plan files that were collected 30 minutes apart as shown by their times.

/opt/cariden/archives/cgo-archive/data/2015/11/151108_UTC

ll

-rw-r--r-- 1 cariden cariden 115651 Feb 23 02:04 151108_0201_UTC.pln

-rw-r--r-- 1 cariden cariden 115651 Feb 23 02:04 151108_0231_UTC.pln

-rw-r--r-- 1 cariden cariden 115651 Feb 23 02:04 151108_0301_UTC.pln

Save and Clear Settings
• To save all settings for use the next time you open the remote access dialog box, click Save Settings. 

This saves all settings whether the fields and all entries in the drop-down lists are empty or not. You 
can optionally save the authentication password.

• To clear all current user-specified settings from the fields and from the drop-down lists, click Clear 
Settings. Note that this does not clear the default Protocol, Port, and UTC Offset values, though 
manual entries in these fields are cleared.

• To delete all user-specific settings so the next time you open the remote access dialog box all fields 
and all drop-down lists are empty (except for the default Protocol, Port, and UTC Offset values), 
follow these steps.

Click Clear Settings.

Ensure Save Settings is enabled.

Click OK to exit. Upon being prompted for whether to continue, click Yes.

Related Topics
• WAE Design Archive User and Administration Guide

• WAE Design User Guide

• WAE Live Administration Guide
6-3
Cisco WAE 6.4 Network Visualization Guide



    

Chapter 6      Access an Archive
  Related Topics
• WAE Coordinated Maintenance User and Administration Guide
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Access WAE Automation Server and Deploy

From the WAE Design GUI, you can open plan files residing on a remote WAE Automation server to 
make modifications before deploying LSPs or saving the plan file back to the server.

To work with files being deployed to the network or saved to the WAE Automation server, you need to 
understand these two terms. 

• The working plan file represents the current state of the network. 

• A staging area is an area in which you can work on plan files without deploying them. There is only 
one working plan file area, but there can be multiple staging areas. 

For general descriptions of patch files and plan files, and for information on creating patch files, see the 
WAE Design User Guide. 

Prerequisites
• You must know the username and password of the WAE Automation server, or its authentication 

must be disabled.

• If using the staging area, it must already exist on the server, and you must know the stage ID.

• The WAE Automation server must be configured for the type of deployment you are using. 

Open Remote Plan File

Step 1 Select the File->Open from->WAE Automation Server menu.

Step 2 Identify the remote server using the steps outlined in the Identify Server Location section.

Step 3 If opening a plan file from a staging area, enter the stage ID. If left blank, the working plan file is opened.

Deploy to the Network
You have two options for deploying LSPs to the network. One is using a patch file, and the other is using 
a plan file.
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Note It is strongly recommended that you verify a patch file or plan file before deploying LSPs to the network. 
The patch file can be verified via the View Dry Run option. Verification of the plan file is a manual 
process. 

Deploy Patch Files
When deploying a patch file, it is applied to the working plan file that currently resides on the server, 
and the working plan file is then deployed to the network. 

Note You can only deploy new, modified, and deleted LSPs.

Patch Deployment

Step 1 Select the File->Save to->WAE Automation Server menu.

Step 2 Identify the remote server using the steps outlined in the Identify Server Location section.

Step 3 Select Deploy Patch. 

If deploying a patch file, you can browse to or enter its full path. Best practice is to select View Dry Run 
to verify the patch file can be successfully applied to the working plan file on the server. If you choose 
this option, a dialog box appears showing whether the deployment of this patch would be successful, 
unsuccessful, or only partially successful. To view details about the dry run on a per-LSP basis, click the 
Show Details button. All LSPs have a State field that identifies success, failure, or that the analysis is in 
progress. Additionally, LSPs that would not deploy successfully appear in red. To save this information 
for future analysis, which can be helpful in troubleshooting issues, click Save Status. 

Step 4 Click OK. A status bar appears followed by a display of the deployment status, which provides a job ID 
that uniquely identifies this deployment. The status also identifies the success, failure, or partial success 
of the deployment of these LSPs to the network. Click the Show Details button for more information on 
a per-LSP basis. All LSPs have a State field that identifies success, failure, or that the deployment is 
currently in progress. Additionally, LSPs that failed to deploy appear in red. To save this information for 
future analysis, click Save Status. 
7-2
Cisco WAE 6.4 Network Visualization Guide



    

Chapter 7      Access WAE Automation Server and Deploy
  Save to WAE Automation Server
Deploy Plans
When deploying a plan file, it is compared to the working plan file that currently resides on the server, 
and then the LSP differences are deployed directly to the network. A copy of it is also saved to the 
working plan file area. 

Step 1 Select the File->Save to->WAE Automation Server menu.

Step 2 Identify the remote server using the steps outlined in the Identify Server Location section.

Step 3 Select Deploy Plan. 

Step 4 Click OK. 

Save to WAE Automation Server
You can save plan files to either the working plan file area or staging area. You can optionally “process” 
the plan so that upon querying a demand, worst-case analysis is automatically performed on interfaces, 
circuits, and SRLGs. Note that these plan files are not stored with the plan files generated by WAE 
Collector.

Saving the plan file to the working area overwrites the existing plan file. This means that any newly 
discovered or recently modified plan files are overwritten. For this reason, if you are not deploying a 
patch file or plan file, it is a best practice to save plan files to a staging area.

Step 1 Select the File->Save to->WAE Automation Server menu.

Step 2 Identify the remote server using the steps outlined in the Identify Server Location section.

Step 3 Select the Save Plan option. 

Step 4 If using a staging area for this access, enter the stage ID number. If this field is left empty, the plan file 
is saved to the working plan area. 

Step 5 (Optional) to simulate failure scenarios such that upon querying a demand, worst-case analysis is 
automatically performed on interfaces, circuits, and SRLGs, select the Process Plan option.

Step 6 Click OK. 

Identify Server Location

Step 1 After opening the dialog box, enter or select the hostname or IP address of the server. 
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Step 2 Identify how to connect to the server by selecting the appropriate protocol and by entering or selecting 
the port number (for example, HTTP 7777).

Step 3 If the authentication is enabled, enter the same username and password. If the authentication is disabled, 
the username and password fields must be empty.

Save and Clear Settings
• To save all settings for use the next time you open the remote access dialog box, click Save Settings. 

This saves all settings whether the fields and all entries in the drop-down lists are empty or not. You 
can optionally save the authentication password.

• To clear all current user-specified settings from the fields and from the drop-down lists, click Clear 
Settings. Note that this does not clear the default Protocol, Port, and Stage ID values, though manual 
entries in these fields are cleared.

• To delete all user-specific settings so the next time you open the remote access dialog box all fields 
and all drop-down lists are empty (except for the default Protocol, Port, and Stage ID values), follow 
these steps.

Click Clear Settings.

Ensure Save Settings is enabled.

Click OK to exit. Upon being prompted for whether to continue, click Yes.

Related Topics
• WAE Design User Guide (For descriptions of patch files and plan files, and for information on 

creating patch files.)
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