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CHAPTER 1

Overview

WAE Design is a standal one application that you can run on multiple platforms, or on standard |aptops or
desktops.

Note

Use Cases

This guide references SCARIDEN_HOME , which is the directory in which the Cisco WAE executables and
binaries are installed. On Linux, the default is /opt/cariden/software/mate/current , where /opt/cariden is the
default installation directory.

This section contains the following topics:

» Use Cases, on page 1

* Plan Files, on page 2

* Patch Files, on page 3

* WAE Design Tools, on page 3

WAE Design lets you model, simulate, and analyze failures, design changes, and impact of traffic growth, as
well as optimize your network for maximum efficiency. For example, with WAE Design models and tools,
you can answer awide variety of questions about traffic management.

Planning:
» Where istraffic going in the network?
» When and where will my network run out of capacity?
* How do | convert my growth forecasts into upgrade plans?
Engineering:
* How can | better distribute traffic throughout the network?
* How can | design for differentiated quality of service?
» Where is my network most vulnerable to failure, and how can | mitigate it?

» How will aLayer 1 design affect the resilience of Layer 3?
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B ranFiles

Operations:
* How can | visualize the current health of the network?
» What caused the outage experienced earlier today?
» How would a current failure affect the network at peak time tomorrow?

« Which VPN customers will be affected by a planned outage or by an unplanned failure?

Plan Files

A plan file (Figure 1: Opened Plan File, on page 2) is comprised of a series of tables that store information
about a network, including topology, configuration information, traffic, failure state, and visual layout.
Additionally, WAE Design uses plan file information to perform simulations.

Figure 1: Opened Plan File

Plan File Opened in Excel Plan File Opened in the GUI

<Nodes> <4— Table Name — Nodes

Name Site Function Protected | ¢— Column Names —p| Name Site Function Protected
crl.ams AMS core F <4— Values —»{crlams AMS core F

crl.fra FRA core F crlfra FRA core F

cridon  LON core F crllon LON core F

crl.par  PAR core F crlpar PAR core E

erl.ams |AMS edge T erl.ams AMS edge 1

<Sites> Sites

Name LocationCode Longitude Latitude Name Location Code Longitude  Latitude
AMS AMS 478 52.32 AMS AMS 478 5232
BRU BRU - Brussels (Belgium) 4.48 50.9 BRU BRU - Brussels (Belgium) 448  50.90
FRA FRA 8.57 50.03 FRA FRA 8.57 50.03
LON LON -0.45 51.47 LON LON -045 5147|
PAR PAR 2.55 49.02 PAR PAR 2.55 49.02 g

Initially, network topology and routing information is captured by WAE discovery tools and stored in plan
files. These plan files are the basis of information displayed in and used by WAE Design. Plan files contain:

* Network configurations

« Visua layouts

« IPIMPL S routes, including multicast and LSPs
» Measured traffic

* Estimated end-to-end traffic matrix

* Operationa state of network objects

* Results of analyses, such as worst-case failure analysis results

Plan files have two formats, both of which are editable by SQL commands:
» The .pIn format is compact and can be quickly loaded to and saved in the WAE Design GUI.
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« The .txt format contains tab-delimited columns. You can create and edit these directly in atext editor or
spreadshest, such as Excel, and quickly apply bulk edits. In these plan files, each tableislabeled with
angle brackets, such as <Nodes> and <Sites>.

Patch Files

A patch fileis acompact way to represent differences between plan files. These differences or “patches’ can
be applied to other plan files or deployed to the network. Patch files have a .plp format.

For information on creating and sending patches, see Patch Files, on page 375.

WAE Design Tools

WAE Design contains numerous tools with user-friendly features, such as easy navigation of object
dependencies, bulk editing, and tight interaction between plots and tables. Tools fall under these categories:

« Visualization—Provides graphical layouts of the network, showing views of different regionsand layers,
aswell as utilizations and routings.

« Simulation—L etsyou perform interactive what-if simulations by, for example, failing objects, modifying
network topology, creating and changing the traffic demands (which simulate traffic flows), and modifying
routing configurations.

» Demand deducti on—Estimates an end-to-end traffic flow matrix based on avail able measured traffic,
such as interface utilizations and L SP traffic.

* Failures and simulation analysis—Allows evaluation of the effect of failures of network objects,
including circuits, nodes, and Layer 1 equipment. You can evaluate overall risk using worst-case
analyses over these failures.

» Forecasting—L ets you create plans for future expected traffic levels.

« Offline traffic engineering—L ets you optimize the network’s reliability and performance.

* Optimization—Suggests changes that |et you optimize the network, for example, by reducing
congestion under circuit failures.

» Changeover—Recommends a step-by-step series of configuration changes to maneuver a network
safely from one configuration state to another.

* Other tools:

* Reporting—L etsyou generate reportsthat compare | P/MPL S topology and configuration information,
demand routings, demand groupings, and L SP routings. You can a so generate reports that compare
traffic, compare plan files, and estimate network infrastructure costs. Other reports, such as Simulation
Analysis and Demand Deduction, are automatically generated.

* Importing, exporting, and getting plans—M uultiple tools are available for importing traffic and
objects, exporting routes, tables, explicit L SP settings, and spectrum utilization, and for getting data
from sources such as config files and | GP databases.

Cisco WAE Design 7.4.0 User Guide .



Overview |
. Extensible Tools

Extensible Tools

Theplan fileformat isopen and documented. Add-on capabilities are availablefor extending GUI functionality.
Additionally, command-line tool equivalents of the GUI tools are provided for scripting and automation. For
information, see the Cisco WAE Design Integration and Development Guide .
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CHAPTER 2

User Interface

This chapter explains how to use the WAE Design GUI.
This section contains the following topics:

« Starting WAE Design, on page 5

* Main Window, on page 5

* Viewing Plots, on page 8

* Objects, on page 10

« Configuring Preferences, on page 15

* Tables, on page 16

* Context Menus, on page 21

* Log and Report Windows , on page 21

Starting WAE Design

To start WAE Design from the directory in which the WAE Design software isinstalled, do one of the
following:

» On Windows or Linux, double-click the wae_design executable.
* On aMac, navigate to the directory where you unpacked the distribution and double-click the
WAE_Design application. Alternately, from the Terminal, enter:

cd
<di rect ory- wher e- you- unpacked-t he-di st ri buti on>
open ./ WAE_Desi gn. app

* From the CL1, enter ./wae _design.

(Optional) On Windows, you can associate the plan file using the .pln format with the wae_design
executable. Double-clicking a .pIn file opens the plan in a new instance of the GUI.

Main Window

The WAE Design GUI isdivided into the following primary sections. Figure 2: WAE Design User Interface,
on page 6 shows the GUI with a sample us_wan.txt plan in the network plot area.
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. Visualization Toolbar

* Menus—Menu selections for network modeling, simulation, and optimization.
« Visualization toolbar—Drop-down lists and icons that control how the network is displayed.

« Plan file tabs—Identify which plan is currently opened. There can be multiple plans open; the tab with
awhite background is the active plan. To bring a plan to the forefront and make it the active plan, click
its associated tab.

» Network plot—Displays a visual representation of the network topology. The color on each interface
represents the percentage of traffic utilization on that interface. Rowsthat are selected in the tables, such
as demands or interfaces, are highlighted in the plot with additional graphical attributes.

* Tables—Display network properties, including both measured and simulated information, for the network
plan.

« Status bar—Identifies the network simulation mode.

« Context menus—L et you right-click anywhere to view alist of actions that you can take.

Figure 2: WAE Design User Interface

Menus File Edit View Insert Initializers Tools Window Add-Ons Help
; ’ ’ L3 Simulated Trafic + G b O« B :-:.- §N (Traffic Levels) + (QoS) « X ow»
Visualization v
Toolbar I_ = = = =
. [ [ 1 - = 3 11 W e T .8
Plan Files S =
- 1 '— i l. nyc
11 &
Network D | . " T . m— =R e mre—r— m—— 1
Plot ' <
W t />
2 1 atl & -
o B 1] il -
- L “r '..' het=—"—" = : . ]
Utilization Level \ ¥
(For Example, Green Fill) Selected Interface "m
(Solid Blue)
Tables i
stat Interfaces | Demands | Modes | Sites | SRiGs | Ports | Portcircuis | LL [ taports | Lol 4{p)
aBl;.?' — | chowall | [Selectall [¥] [Filter '¥] 100/100 rows (1 selected) (@
Node Interface IGP N Remote N¢ Traff Sim  Traffl Capacity Si Ul S Util W WCU WCFa *
O c2mia o criat | 36lciat | 8587|8252  248800] 345 332] nalna |
63 cr2mia {to_crlm... 1 crlmia 000 000 1000000 000 000 na na §
—
64 cr2mia {to_erlm.. 1000 erlmia 52.16 80.71 na na na na na 2

Visualization Toolbar

The Visualization toolbar (Figure 3: Visualization Toolbar, on page 7) provides a convenient way to change
the visual aspects of the network plot.
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Visualization Toolbar .

Figure 3: Visualization Toolbar

Worst-Case
Simulation Subset
Network Arrange Sites Simulation
Plot View and Nodes OnfOff QoS
Levels Plot Options

13 simusted Traffic v @ O3 v ¥ [ Ol - (@9 (rafiicLevels) v @oS) v X (Layouts) v P E?l

Layer Traffic Utilization
{L3IL1) View Colors

| T | |

Traffic Levels Layouts Legend

Refine View Network
Options

407028

« L3/L1 View—A toggle button to change the view between Layer 3 (L3) and Layer 1 (L1). You can also
simultaneously view L3 and L1 networks. Thisis set in the Layer 1 tab of the Plot Options. For more
information, see Layer 1 Simulation, on page 191.

» Network Plot—A drop-down menu from which you choose the type of traffic displayed in the plot.

* Refine View icons—These icons let you refine and enhance your view in the network plot and in the
site plots.

« Arrange icon—Opens an Arrange pal ette that lets you move selected nodes and sites into a selected
schematic alignment.

« Utilization Color—Traffic utilizations are displayed by colors as a percent of available capacity used on
that interface. This enhances the other visual cues, which isthe length of thefill. You can change the
colors and the utilizations they represent.

N

Note All traffic is displayed in Mbps. In the network plot, the traffic utilization colors
represent outbound traffic.

 Simulation On/Off (white arrow in green circle) icon—ByY default, any change that voids the current
simulation automatically triggers aresimulation. For example, changesin topology trigger aresimulation.
To turn off this resimulation, use the drop-down arrow next to the icon to uncheck Auto resimulate.

» Network Optionsicon—L etsyou set global simulation modes, such as Full Convergence or Fast Reroute
for MPLS, and whether to include multicast hops. You can also set IGP, BGP, and Multicast protocol
options.

« Traffic Levels—Drop-down list of user-defined traffic levelsin the plan. For more information, see
Traffic Demand Modeling, on page 43.

* QoS Level—Drop-down list of service classes, interface queues, and undifferentiated traffic. From the
Manage QoS option, you can add or edit service classes, assign service classes to queues, and add or edit
service policies. For more information, see Quality of Service Simulation, on page 239.

« Worst-Case Simulation Subset (red X) icon—After asimulation analysisis performed over a specified
set of failure scenarios (for example, circuits, nodes, and ports), you can click thisicon to select which
subset of these failure scenarios (for example, circuitsonly), aswell as service classes you want included
in the worst-case analysis. This avoids having to run a second simulation analysis.
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« Layouts—Drop-down list of user-defined plots. For example, you might have schematic layouts,
geographic layouts, separate layouts for different continents, simplified layouts with hidden nodes or
sites, or other representations of the network.

« Plot Options icon—L ets you customize circuit width, text on interfaces, layouts (such as background
images and geographic views), and other plot options.

« Legend (question mark) icon—Displays alegend of icons and line typesin the plot and their meanings.
For more information, see Plot Legend for Design Layouts, on page 401.

Viewing Plots

WAE Design opens to the main network plot. Although WAE Design shows only the sites in the network
plot and tables, you can view those sitesin more depth. You can also view more depth of interfaces and
demandsin their respective plots. In addition to these plot views, you can create and view layouts that show
only those portions of the network plot that you choose. For more information, see the Cisco WAE Network
Visualization Guide .

Viewing Network Plots

The network plot, also referred to simply as the plot , is the main area showing the network topology. It can
contain both sites and nodes.

There are multiple network plot views available (top left of Figure 3: Visualization Toolbar, on page 7).
The default view is Simulated Traffic. To change the view, select it from the Network Plot View drop-down
list in the Visualization toolbar.

» Simulated Traffic—View of simulated traffic that can be used for capacity planning, what-if anaysis,
and failure planning. Circuits are sized proportional to their capacity. Interfaces are colored according
to the percentage of simulated traffic (in comparison to available capacity as defined by the size of the
interface or the QoS bound).

» Measured Traffic—View of traffic as measured from live views of the network. Circuits are sized
proportional to their capacity. Interfaces are colored according to the percentage of measured traffic (in
comparison to available capacity as defined by the size of the interface or the QoS bound).

« Worst-Case Traffic—Interfaces are colored to show the maximum utilization of the interface over all
failure scenarios as defined by the most recently run simulation analysis. For more information, see
Simulation Analysis, on page 79.

« Failure Impact—Interfaces and nodes are col ored to indicate how afailure of that interface or nodewould
impact other interfaces and nodes. For more information, see Simulation Analysis, on page 79.

* LSP Reservations—Circuits are sized proportional to their L SP reservable bandwidth. Interfaces are
colored according to the percentage of bandwidth (in comparison to what is reserved for the L SP). For
information, see RSVP-TE Simulation, on page 135.

* By editing the plan file directly, you can add a user-defined static view to display interfaces with
customized color fillsand fill percentages. The view then appears as an option in the Network Plot
drop-down list. For information, see the Cisco WAE Design Integration and Development Guide .
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Although WAE Design focuses on IPPIMPLS Layer 3 (L3) network views and traffic, you can also create and
view Layer 1 topologies. To toggle between views of these two layers, choose View > Layer 1 View or View
> Layer 3 View, or use the shortcuts Ctrl-1 for Layer 1 and Ctrl-3 for Layer 3. For information, see Layer 1

Simulation, on page 191.

Viewing Site Plots

The site plot can contain other sites or nodes and their connecting interfaces, including external interfaces
that are labeled with their destination node (Figure 4: Site Plots, on page 9).

To open asite plot, do one of the following:

 Double-click asingle site from the plot.

 Choose multiple sites from the plot and then double-click one of those sites.

« Right-click one or more sites from the plot or the Sites table and choose Open Site View.

Figure 4: Site Plots
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Viewing Interface Plots

Step 1
Step 2

Theinterface plot isawindow that displays selected interfacesin astacked format, making it easier to compare

one with another (Figure 5: Interface Plot, on page 10).

Select one or more interfaces from either the Interfaces table or the plot.

Open the interface plot in one of two ways:
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* Choose View > Interface Plot.

* Right-click and choose Plot I nterfaces.

Step 3 Work with interface plots in these ways:
« To vertically move the interface list within the plot, click the up and down arrows.
« To view atable of the selected interfaces, click the Adjust button. A new Interfaces table appears.

* To sort the interfaces by ascending or descending order, click the Adjust button. Click a column heading to toggle
its sorting between ascending or descending order, then click OK.

Theinterface plot displays the interfaces according to the sort.

What to do next
Figure 5: Interface Plot

us_wan Interface Plot X

olchi [ z 7 X a2y

alchi T " " 1 al.ses

o2di s 1 alsk

Adjust... | L{j [05
Adjust Plot Interfaces. ﬁ
[ Showall | [Selectall '] [Filter ] 3/3 rows (0 selected) @
Mode Interface Remote Nodt IGP Metric Traff Sim Traff Meas Capacity Sim  Util Sim Util Meas WC Util 'WC Failures
1 crlchi {to_cr2nyc}  cr2nyc 38 154745 1586.00 2488.00 62.20 63.75 na na
2 crlchi {to_cr2sea}l crlsea 87 631.17 75323 248800 25.37 30.27 na na
3 crachi {to_crlsjc} crlsjc 92 1020.08 1161.60 2488.00 41.00 46,69 na na
ok || cancel

Objects

Other than asite, an object is a representation of elements found in networks, such as nodes (which represent
routers), circuits, interfaces, L SPs, and more. A siteisalso an object, and is a WAE Design construct for
simplifying the visualization of a network by grouping nodes within a site, or even by grouping sites within
asite.

Objects have properties that identify and define them, many of which are discovered, though they can also
be manually added and changed. For example, all circuits have a discovered Capacity property that can be
edited. Other properties are derived. For example, Capacity Simisderived from the Capacity property. Another
exampleisthat interfaces have aUtil Sim property that identifies the percentage of Capacity Sim thesimulated
traffic isusing. Properties are viewable and editabl e through an object’s Properties dialog box (right-click the
object and choose Properties). They are also viewable as table columns,
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Object Selections .

Objects are selectable through tables and plots. However, not all objects are selectable from both, though
most are. Some object types are only selectable through their tables, such as L SPs.

All selections made in a plot appear in the associated table and vice versa (Table 1: Select Objects, on page
11). Likewise, changes madein the plot arereflected in the tables, and vice versa. Hidden objects are excluded

from the selection.

Table 1: Select Objects, on page 11 assumesthat all objectsarein the foreground. For information on selecting
objects that are in the foreground versus background, see Refining Viewable Objects, on page 13.

Table 1: Select Objects

To...

Do This...

Site Selections

« If the object you select is a site, none of the child objects
(child sites, nodes, and circuits) are selected.

» To select asite and all objects contained within it, press
and hold the Alt key during the selections identified in
thistable.

Examples

» To select only asite, click it.

To select asite and al of its nested child objects, press
and hold Alt while clicking the site.

« To select only two sites, click one object and then
Ctrl-click each site that you want to select.

To select two sites and all the objects they contain, press
and hold both Alt and Ctrl while selecting both sites.

* To select all sitesin the plan file, press Ctrl-A in either
the network plot or the Sitestable.

To select al sitesand all objects they contain, press and
hold Alt and Ctrl-A together in either the network plot or
the Sites table.

Select an object. If other objectswere selected prior to thisnew
selection, those objects become desel ected.

Click one or more objectsin any plot or table.
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To...

Do This...

Select multiple objects from the plot.

« Do one of these steps from the plot:

« Click and hold while you drag the cursor across any
objects you want included in the selection.

« Click one object and then Ctrl-click each object that you
want to select.
* Select al objects showing in aplot:
* Press Ctrl-A (Cmd-A on aMac).

« Click and hold while you drag the cursor over an entire
plot.

Select multiple objects from tables.

« Do one of these stepsin atable:

« Click and hold while you drag the cursor across any
objects you want included in the selection.

« Click one aobject and then Ctrl-click each object that you
want to select.
» Select al objectsin atable:
* Press Ctrl-A (Cmd-A on aMac).

« Click and hold while you drag the cursor over an entire
table.

« If you are selecting objects from multiple tables, make your
selection in one table, and then press and hold the Alt key
(Option key on aMac) while making selectionsin another table.

Clear the entire selection.

Do one of these steps:

* Choose Select All > Clear Selection. Thisdeselectsall objects
within that table. If objects in other tables are selected, they
remain selected.

« Click anywhere in any plot. This deselects al objectsin that
plot and in the associated table.

Invert the current selection (everything selected becomes
deselected and vice versa).

1. Show the table whose selections you want to invert.

2. Choose Select All > Invert Selection.
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Filtering to Selected Objects

To filter only to the selected objects, choose one or more objectsin any plot or table, then choose Filter >
Filter to Selection. Alternatively, you can press and hold Ctrl-Shift (Cmd-Shift on aMac), and then
double-click.

Aswith other object selections, to include the nested objectsfor site sel ections, add Alt to the sel ection process.
For example, pressand hold Alt while clicking one or moressites, and then choose Filter > Filter to Selection.

Filtering to Nested or Parent Objects

If asite contains multiple levels of child sites, you can filter to those nested objects. Right-click asite, choose
Filter to Contained <object> , and then choose one of the following, where <object> equals sites, nodes,
or L1 nodes:

* Direct—To see only the objects immediately contained within the site.

 All—To see all contained objects, no matter how deeply nested they are within child sites.

If asite contains only one level, the context menu changes to reflect as such.

Conversely, you can find a parent site for any given node. Choose it, and then choose Filter to Sites.

Refining Viewable Objects

View icons are available both in the network plot and in the site plots. Each of these icons makesit easier to
find what you need.

Set to Foreground

Fit to Plot

RO~

Zoom

Adjust Opacity of
Background Objects

Drag Plot

407029
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Except for Set to Foreground, when accessed through the Visualization toolbar, the view changes apply only
to the network plot. When accessed through a site plot, the Zoom, Fit-to-Plot, and Drag actions apply only to
that site plot.

Both the Zoom and Set to Foreground icons let you better focus and work in specific plot aress.
» Zoom—L ets you drag in the area that you want enlarged to fit the entire plot.

Shortcut—Press the letter “z,” which toggles this functionality on and off.

To escape from the Zoomed view, press Esc.
* Fit-to-Plot—Resizes the diagram to fit within and fill the plot area.

Shortcut—Press the letter “f,” which toggles this functionality on and off.

« Drag Plot—L ets you move the cursor over any portion of the plot to drag it to a different location.

Shortcut—Press the letter “d” or pressthe icon again to toggle this functionality on and off. The feature
remains enabled until you turn it off.

To escape from the Drag option, either press Esc or click theicon to toggle it off.

* Set to Foreground—Brings selected objects to the foreground for improved viewing while sending all
other objects to the background where they appear asif they are transparent. Selected objects must be
L3 nodes, L3 circuits, sites, L1 nodes, or L1 links. This feature does not apply to other objects, such as
demands, LSPs, L1 circuits, and L1 circuit paths.

To escape the Set to Foreground option, click the icon to toggle it off while objects are selected.

To increase or decrease the transparency (opacity) of how well the background objects appear, click the
drop-down arrow next to the Set to Foreground icon. Enter the desired value, and click OK. The higher
the value, the denser (darker) the background objects appear.

A\

Note |f you areviewing both L3 and L1 objects, this opacity value for background
objects takes precedence over the layout opacity value that is set for viewing
different layers.

a vy N
i B

Set Opacity... |

Background Opacity:

K. Cancel
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Configuring Preferences

Table 2: Feature History

Feature Release Information Description

User specified online map support | Cisco WAE Release 7.4.0 WAE Design now allows you to
connect to a map server using
proxy. You can now connect to a
map sever of your choice using the
URL of the map server.

You can configure scaling, foreground and background object preferences, and the background color for

layouts.
Step 1 Choose View > Preferences.
Step 2 Click the General tab and configure the following options;

« Uniform Scaling—Enter a scale factor from 5% to 1000%. Objects and fonts are scaled uniformly based on the
factor you enter.

* Individual Scaling—Enter an individual scale factor for L3/L1 nodes and sites, circuitsand L1 links, and fonts.

WAE Design considers the settings on circuit and link width in the layouts and scal es them accordingly based on
the given scale factorsin the network plot.

« Enable Selection of Background Objects—If checked, you can select objects in the background.

« Fit to Screen Zooms to Foreground Objects—If checked, clicking the Fit to Screen icon takes into account only the
foreground objects. If unchecked, clicking Fit to Screen takes all objectsinto account.

« Show Tooltips—If checked, tooltips are shown.

One method of seeing related information about an object isto show the tooltips and then hover the mouse over a
site, node, L1 node, interface, or L1 link. For example, hovering over a site you can see the number of contained
L3 nodes, L1 nodes, and sites, aswell as the total number of interfaces connected to the contained L3 nodes.

« Scroll Table to Selected Object—If checked, when you click asingle plot object (site, node, L1 node, interface, or
L1 link), the table automatically scrollsto the row for that object.

For example, if in the plot you click a node, and the Nodes table is open, the table scrolls automatically to the row
for that node.
Step 3 Click the Layouts tab and configure the following options:

* Schematic Layout—Choose a gray or white background for schematic plots. (If sites or nodes have a white border
and the background is also white, a black line appears around them.)

* Geographic Layout—Choose a gray or multi-color palette for geographic plots.

* Online Map Server URL—If not specified, the default background map server is used by WAE Design. Use Online
Map Server URL to specify a different server. Add markers (%1 %2 %3) for substituting map zoom level and
coordinatesin the URL.
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For example, https://a.tile.openstreetmap. de/ %/ %2/ ¥3. png
Note The map server must conform to OpenStreetMap standard.
* Online Map Proxy—Use this option to configure map proxy. Click Enable Proxy to enable the proxy settings.
Enter the following details:
* Authentication Type: Choose between Anonymous, User + Password, Client Side Certificate.
* Proxy Server: Enter the server name or |P address.
* Proxy Protocol: Choose between HTTP or HTTPS.
* Proxy Port: Enter the port number
¢ Username: Only for Authentication Type 'User + Password'.
* Password: Only for Authentication Type 'User + Password'.
* Certificate File: Path to file containing certificate (only for type Client Side Certificate)
* Certificate Type: Choose between DER, PEM, ENG (only for type Client Side Certificate)
Select Save Settings to save the configurations for future WAE Design sessions.
Select Save Passwor d to save the password in config file.
Note To disable proxy, uncheck the Enable Proxy check box and save the settings.
* Use Site, Node, and L1 Node Icons—If checked, icons are displayed for sites, nodes, and L1 node names.
Step 4 (Optional) To save al preferences for future sessions, check Save Preferences.
Step 5 (Optional) To reset the settings back to their default, click Reset. The dialog box refreshes automatically with the default
values.

Step 6 Click OK.

Tables

Thetablesthat are viewable from the WAE Design GUI display a series of rows and columns, where the rows
are objects and the columns are properties (Figure 6: Common Table Functions, on page 17). Plan files also
contain other tablesthat are not viewabl e from the GUI. These tables contain more complex information, such
as showing complex relationships between objects. If you open aplan file using a .txt editor, each tableis
labeled with angle brackets, such as <Nodes> and <Sites>.

Note For detailed information about plan files and tables, aswell as information on creating user-defined columns
and tables, see the Cisco WAE Design Integration and Development Guide .
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Common Tables

There are numerous tables available for specialized purposes, such as Multicast, P2MP L SPs, and Ports. The
tables listed below are the most commonly used and are the defaults.

To bring atable to the forefront and make it the active table, click its associated tab. For example, to open
the LSPs table, click the L SPstab.

* Interfaces—A list of the interfaces in the network.

» Demands—A list of the demandsin the network. Each demand specifies how much traffic isrouted from

asource (node, external AS, or external endpoint) to a destination (node, external AS, external endpoint,
or multicast flow destination).

* Shortest Paths—A list of the routes between selected sites.

* Nodes—A list of network routers, which typically have names that suggest their location and function.
For example, node crl.atl is core router 1 in the Atlanta site.

* L SPs—A list of MPLS L SPsin the network; each L SP contains both a source and destination. Note that
sub-L SPs within point-to-multipoint (P2MP) LSPs are listed in the L SP table.

 Sites—A list of network sites.

» SRLGs—A list of the shared risk link groups (SRLGs); an SRLG isagroup of objectsthat might all fail
due to a common cause.

* AS—A list of both internal and external autonomous systems (ASes). An ASisacollection of connected
IP routing prefixes that are controlled by one operator.

Figure 6: Common Table Functions
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« Select any table tab to bring that table to the front. 16 (Unique

« Right-click on any table tab to hide that table or add new tables.

* Right-click on any column (or click wheel icon) to hide that column or add new columns for
that table, and to view other variables related to the column, such as average values.

* Click on any column to toggle its sort between ascending and descending order.

» Enter text or numbers in the Search field to find a matching string for that table.
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Showing or Hiding Tables or Columns

Table 3: Show or Hide Tables or Columns

To... Do This...

Show or hide one or moretables |1. Do one of these two steps:

Choose View > Tables > Show/Hide Tables.

Right-click any table tab and choose Show/Hide Tables.
2. Togglethetablesyou want to show to T (true) and the ones you want to hideto F (false).
3. Click OK.

Hideasingletable Right-click any table tab and choose Hide this Table.

Show or hide one or morecolumns| 1. Do one of these steps:
Choose View > Tables > Show/Hide Columns.
Right-click any column heading and choose Show/Hide Columns.

Click the whee! icon in the table area.

2. Toggle the columns you want to show to T (true) and the ones you want to hideto F
(false).

3. Click OK.

Hide a single column Right-click any column heading and choose Hide this Column.

Searching and Filtering in Tables

Most WAE Design tables, whether below the network plot or with dialog boxes, have an empty Search field
in the top right as shown in Figure 6: Common Table Functions, on page 17. Likewise, they usually have a
Filter control menu that opens a Filter dialog box specific to that table. Figure 7: Interfaces Filter, on page
19 is an example of an Interfaces Filter dialog box.

Table 4: Table Search and Filter Features

To... Do This...

Search for objects that match a specific string. | 1. If you are not in adialog box, show the table whose objects you want to search.

2. Inthe Search field, enter a search string and press Enter.
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To...

Do This...

Filter thetableto alist of specific search values,
and either replace, add to, or narrow the list of
objects currently showing in atable.

1
2
3.
4

If you are not in a dialog box, show the table whose objects you want to filter.
Click the Filter control menu button (Figure 7: Interfaces Filter, on page 19).
Choose from the drop-down lists and enter search criteria.

If you are filtering by more than one criterion, you can optionally use these
controls:

Match All—(Default) Filters to only those rows that match all the specified
criteria (default).

Match Any—Filters to rows that match any one of the criteria

Select whether to replace, add to, or narrow thelist of objects currently showing
inatable.

Replace—Replaces objects showing in the table with those found in the search
(default).

Union—Adds the objects found to those showing in the table.

Intersection—Filters to (search for) objects only within those objectsthat are
currently showing in the table.

Filter the selection to associated objects. For
example, you might want to filter acircuit to
associated interfaces.

Choose Filter > Filter to X, where X is aname of aviable object.

Toggle whether to change the filter selection
with or without first asking.

Choose Filter > Interaction with current filter > X, where X is either Always
Ask or Replace.

Figure 7: Interfaces Filter
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Saving Table Settings or Restoring Defaults

Table 5: Table Settings

To... Do This...
Save table and column settings Choose View > Tables > Save All Settings.
Save table settings Do one of these steps:

» Choose View > Tables > Show/Hide Tables.
* Right-click any table tab and choose Save Table Settings.

Save column settings 1. Show the table whose column settings you want to save.
2. Do one of these steps:
Choose View > Tables > Show/Hide Columns.

Right-click any table tab and choose Save Column Settings.

Restore al table and column settingsto | Choose View > Tables > Reset All.
system defaults

Resize column widths 1. Show the table whose column settings you want to save.

2. To adjust the column width to that of the longest variable, right-click the column
heading, and choose Adjust Width to Fit.

To adjust the column width to any desired size, click and drag the column heading
edgeto any size.

Restore column widthsto their original size| 1.  Show the table whose column widths you want to restore.

2. Choose View > Tables > Reset Column Widths,

Other Table Actions

Table 6: Miscellaneous Table Tools

To... Do This...

Show all objects for atable within the plan 1. Show the table whose objects you want to see.

2. Click Show All.

Toggle the columns to sort in ascending or Click a column heading.
descending order

View the sum of the valuesin acolumn, the average, | Right-click a column heading.
the minimum, and the maximum
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To...

Do This...

View how many entriesin a column are unique

Right-click a column heading.

Resize column widths

« To adjust the column width to that of the longest variable, right-click the
column heading and choose Adjust Width to Fit.

* To adjust the column width to any desired size, click and drag the column
heading edge to any size.

Restore column widths to their original size

1. Show the table whose column widths you want to restore.

2. Choose View > Tables> Reset Column Widths.

Detach the table from the plot Do one of these steps:
« Click and hold the empty gray area above the table whileyou dragitto a
different location.
« Click the double-pageicon in the right of that same gray area.
Reattach the table to the plot Click and hold the empty gray area above the table while you drag it to the

bottom of the plot. When an empty blue area appears, rel ease the mouse button.

Context Menus

WAE Design has a hidden menu called a context menu . Anywhere that you right-click, whether it isin an
empty areain the plot, on an object in the plot, on atabletab, or on acolumn or row in atable, acontext menu
appears with available options based on where you clicked. The context menu does not apply only inthemain
menus and in the Visualization toolbar.

The most common use case for context menusis for filtering to related objects. For example, to find the L1
circuits mapped to an L 3 circuit, right-click the L3 circuit and choose Filter to L1 Circuits. You can select
multiple objects and right-click just oneto find the related information for all selected objects. If you want to
see only selected objectsin atable, right-click one of the selected objects and choose Filter to Selections.

If in asite, an interface, or ademand plot, the right-click actions taken affect the network plot.

Log and Report Windows

The following additional windows are displayed using menu items or after running tools:

* Log window—This window appears automatically when warnings or errors are logged. You can view
these by choosing Window > L og window.

* Reports—Reports are generated through the Tool s > Reports menu, aswell as automatically when running
certain tools such as Simulation Analysis. The report window appears at that time, and is accessible later
by choosing Window > Reports. For more information, see Reports, on page 381.
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CHAPTER 3

Plan Objects

WAE Design networks consist of objects, such as nodes, sites, interfaces, circuits, SRLGs, ports, and port
circuits. This chapter describes these basic objects and their relationships, as well as how to create, edit, and
delete them.

Most objects are represented in the network plot, and all of them are represented in tables. Objectsin the plot
and in the associated tables have a set of propertiesthat you can manage using a Properties dialog box. These
object properties are represented by columnsin the object’s table, or by entriesin tables of related objects.
For example, al circuits have a Capacity property.

WAE Design has both aLayer 3 (L3) view and aLayer 1 (L1) view, each containing objects.

 Throughout this guide, the terms node and circuit refer to objects in the L3 view. When describing or
contrasting both layers, the qualifier L3 is used.

» Theterms L1 node and L1 circuit refer to objectsin the Layer 1 view.

This section contains the following topics:

« Editing Objects Quick Reference, on page 23
* Understanding Nodes and Sites, on page 24

« Circuits and Interfaces, on page 31

¢ SRLGs, on page 35

* Ports, Port Circuits, and LAGs, on page 36

« Editing Object Properties, on page 39

« Tags, on page 40

Editing Objects Quick Reference

Thistable is a simplification of basic object editing capabilities. Not all tasks apply to all objects.

Task Select Object First? | Menu Context
Menu
Add — Insert New
Duplicate One object Edit > Duplicate
Duplicate
Delete Oneor moreobjects| Edit > Delete | Delete
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Task Select Object First? | Menu Context

Menu
Merge Oneor moreobjects| Edit > Merge |Merge
Edit Oneor more objects Properties
properties

Understanding Nodes and Sites

Both node and site are WAE Design terminology.

» Node—A deviceinthe network, which can be one of threetypes: physical, PSN (pseudonode), or virtual.
The Type property distinguishes whether the node represents areal device or an abstraction, such asa
single node representing a number of edge nodes connected in the same way to the network. A physical
nodeisaLlayer 3 device, or router. Physical and virtual nodes behave in the same way within WAE
Design. A pseudo-node (PSN) is typically used to represent a Layer 2 device or aLAN.

Nodes can reside both inside and outside of sites. The external arrangement could be useful for small
networks where routers are not geographically dispersed.

* Site—A collection of nodes and/or other sites that potentially form a hierarchy of sites. Any site that
contains other sitesis called the parent site.

Both nodes and sites have simulated traffic, while nodes also have measured traffic.

» Nodes are shown as rectangles. The border color is an indication of traffic sourced from and destined to
the node.

« Sites are shown as squares. The border color indicates the traffic utilization of al the nodes and circuits
inside the site, including all nested nodes and circuits.

Note that sites can contain both L3 nodes and L 1 nodes. Empty sites appear in both views, as do sites
containing both L3 and L1 nodes. Only sites containing L3 nodes appear in the L3 view, and only sites
containing L1 nodes appear in the L1 view. To change these defaults, see the Cisco WAE Network
Visualization Guide .

Parent Sites and Contained Objects

Unless asite is empty, there is a hierarchy of the sites and nodes that a site contains. A site can be both a
parent and a child site. If asite contains another site, it is a parent site. Any nodes, sites, or circuits within a
parent site are contained (nested ) objects. The contained nodes and sites are also called children . Often the
child nodes and sites are geographically co-located. For example, a site might be a PoP where the routers
reside.

* The site's Parent Site property defines whether it is nested within another site. If it is empty, the siteis
not nested.

« In the network plot, the parent site shows all egressinter-site interfaces of al nodes contained within it,
no matter how deeply the nodes are nested. Similarly, thisistrue for each child site plot within it.

* Selecting a site from the network plot does not select the sites or nodes under it.
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Deleting Sites .

« Tofilter to the sites or nodes contained within a site, right-click to accessits “Filter to contained” menu.
If you select “Direct,” WAE Design filtersto only those objects contained immediately within it. If you
select “All,” WAE Design filtersto all objects contained within it, no matter how deeply they are nested.

Figure 8: Example of Node and Site Relationships, on page 25 shows an example of nodes outside of sites
(atl nodes), sites containing other sites (the East site contains three NY C sites and one BOS site), and nodes
within asite (NY C_2 site contains three nyc nodes). While this figure only shows one of the child site plots,
if you were to expand all nested sites with the East site, you would find more nested child sites and nodes.
Asyou can see in the network plot, the East site has 10 egress interfaces extending from it, some of which
are within nested sites.

Figure 8: Example of Node and Site Relationships
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Nodesin Sites

Sites in Sites

Selecting a site from the network plot does not select the sites or nodes under it except when deleting the site.
In this case, all objects within asite are selected for deletion. However, in the confirmation that appears, you
have the option to keep the contained sites and nodes. If you do, then the objects that are contained directly
within it are moved to be on the same level asthe site that is removed. The other, more deeply nested objects
maintain their parent relationships.

Figure 9: Example Site Deletion, on page 26 shows a West site plot directly containing two sites (SJC and
LAX) and three nodes. This parent West site residesin the network plot. Both SJIC and LAX contain two sites
each. By deleting the West site plot, but retaining its children, both SJC and LAX move to the network plot
level, as do the three sea nodes. The sites within SJIC and LAX remain as children sites to their respective
parent sites.
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Figure 9: Example Site Deletion

PSN Nodes

WAE Design plan files can contain nodes of with a Type property of “psn.” These nodes represent pseudonodes
(PSNs), which are used to model LANSs or switches that connect together more than two routers. They are
used in two situations: for IGP modeling and BGP peer modeling.

In an IGP network, aLAN interconnecting multiple routersis represented by a PSN node, with circuits
connected to each of the nodes representing the interconnected routers. Both OSPF and | SIS have a built-in
system whereby one of the routers on that LAN is the designated router (DR) for OSPF or the designated
intermediate system (DIS) for IS-IS. The PSN node is named after this designated router. WAE creates nodes
with a property Type of psn automatically during |GP discovery.

When BGP peers are discovered, WAE might find that a router is connected to multiple peers using asingle
interface. Thisistypical at switched Internet Exchange Points (1XPs). WAE then creates anode with aproperty
Type of psn, and connects all the peersto it, each on a different interface.

Following are afew points to consider when working with nodes that have psn as a Type property.
» Two PSNs cannot be connected by a circuit.

« If aPSN nodeis created by WAE, “psn” is prepended to the designated router’s node name.
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» When creating demand meshes, WAE Design does not create demands with nodes of Type psn as sources
or destinations. Thisis possible in manual demand creation, but not recommended. WAE Design sets
the IGP metric for all egress interfaces from a node of Type psn to zero. This ensures that the presence
of aPSN in aroute does not add to the IGP length of the path.

Creating Nodes and Sites

Creating Nodes

To create anode, either choose I nsert > Node, or right-click in an empty plot area and choose New > Node.
Following are some of the frequently used fields:

» Name—Required unique name for the node.
* |P Address—Often the loopback address used for the router 1D.

 Site—Name of the site in which the node exists. If left empty, the node resides in the network plot. This
offers a convenient way to create a site while creating the node, move nodes from one site to another, or
remove nodes from a site so it stands alone in the network plot.

* AS—Name of the ASin which this node resides, which identifiesits routing policy. This can be left
empty if no BGP isbeing simulated.

* BGP ID—IP address that is used for BGP.
« Function—Identifies whether thisis a core or edge node.

» Type—The node type, which is physical, PSN, or virtual. Because a PSN node represents a Layer 2
deviceor aLAN, interfaces on a PSN must all have their IGP metrics set to zero, and two PSN nodes
cannot bedirectly connected to one ancther. If you change anodetypeto PSN, WAE Design automatically
changes the IGP metrics on its associated interfaces to zero.

* Longitude and L atitude—Geographic location of the node within the network plot. These values are
relevant when using geographic backgrounds.

» X and Y—L ocation of the node within the network plot. These values are relevant when using schematic
backgrounds.

Creating Sites

To create a site, either choose Insert > Site, or right-click in an empty plot area and choose New > Site.
Following are some of the frequently used fields:

» Name—Required unique name for the site.
* Display Name—Site name that appearsin the plot. If thisfield is empty, the Name entry is used.

« Parent Site—The sitethat immediately containsthissite. If empty, the siteis not contai ned within another
one.

« Location—To automatically place asitein its correct geographic location and update the Longitude and
Latitude fields, enter the airport code and press Enter. To select from alist of cities worldwide, press
Alt-Enter.
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« Longitude and L atitude—Geographic location of the site within the network plot. These values are
relevant when using geographic backgrounds.

* Screen X and Y—L ocation of the site within the network plot. These values are relevant when using
schematic backgrounds.

Duplicating Nodes

Duplicating a node creates an identical node and duplicates the connectivity of that node by creating new,
identical circuits containing the same amount of traffic. By default, each demand and each L SP that uses the
node as a source or destination is also duplicated. The newly created node is sequentially named the same.
For example, if you duplicate a node named “chi,” WAE Design creates a chi[1] node. If you duplicate it
again, achi[2] nodeis created.

Step 1 Use one of these methods to open the Duplicate Node dialog box:

* Right-click a node and choose Duplicate.

* Select anode and choose Edit > Duplicate.

Step 2 Select whether to duplicate demands and L SPs, and then click OK.

Duplicating Sites

Duplicating a site creates an identical site, including the nodes within it and its connectivity. The default site
name and display name are the same as the copied site plus a sequential number. For example, duplicating
OKC creates OKC[1]. However, you have the option to change both the site name and the display name. The
nodes that are created are likewise sequentially renamed. To change a duplicated node name, open the node's
Properties dialog box.

You cannot duplicate a site that contains other sites.

Step 1 Use one of these methods to open the Duplicate Site dialog box:
* Right-click a site and choose Duplicate.

* Select asite and choose Edit > Duplicate.

Step 2 If desired, rename the new site or display name, and click OK.

Merging Nodes

Real network topologies often have anumber of nodes, typically edge nodes, connected to the network in the
sameway. For example, they might all be connected to the same core node or pair of core nodes. For planning
and design of the network core, it is often desirable to merge these physical nodesinto a single virtual node,
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Plan Objects

Merging Nodes .

which simplifiesthe plan and accel erates the cal cul ations and simul ations performed. Note that merging nodes
changes the plan itself, not just the visual representation.

Merge (2/4) selected nodes.

Separate merge per site
Mew node suffix:

@  Merge all nodes together into base node:

Site m MNode |cri.fra =

Mew name:;

Merge Modes Table Browise...

The name of a newly merged node can be based on the site name, selected node name (base node), or have a
new user-specified name. The node merge effects are as follows:

1167

* Reattach circuits from other nodes to the base node.

* Move demands to or from other nodes to the base node.

* Move LSPsto or from other nodes to the base node.

* Set base node traffic measurements to the sum of measurements of the selected nodes.

* Delete other nodes.

Select multiple nodes. If you do not select nodes, WAE Design merges all nodes.
Choose I nitializers > M erge Nodes, or right-click one of the nodes and choose M er ge.
Select whether to merge the nodes per site or merge them into one node.

* Separate merge per site—Merges nodes on a per-site basis. For example, if you selected all nodes in the plan, the
result would be one merged node per site. If you do not specify a new suffix, the default name is the same asthe
site.

* Merge all nodes together into base node—Merges al nodes selected into one node. For example, if you selected
two nodes in one site and three nodes in another, the result would be a single node in the site and node combination
selected as the base node.

If you do not specify a new name, the default isto use the name of the base node.

Click OK.
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Trimming Nodes and Moving Their Traffic

Step 1

Step 2
Step 3
Step 4
Step 5

A plan file created through WAE discovery often has more edge nodes in the plot than you are interested in
viewing or simulating. These might be nodes that forward very little traffic or are singly connected to the
core. However, you can reduce such a network model in WAE Design for simplicity and performance
improvements by trimming (removing) these nodes. This process also removesall associated circuits, demands,
and external endpoints.

Note that you can either select nodesto trim or you can chooseto trim all nodes except those that are selected.

@ Trim (25/67) selected nodes from the plan.
) Trirn all nodes in plan except the (25/67) selected nodes.

] Trim Dermands

MNarme of trimmed demands: | Trimmed

Typicaly, plan files are trimmed before demands are created. However, you can optionally trim demandsin
aplan file. This moves ademand that is sourced on atrimmed node to the first hop on the demand path in the
remaining network. Likewise, a destination to atrimmed node is moved to the last hop of the demand path
in the remaining network. If two or more demandsin the same service class are trimmed so that their resulting
source and destination nodes are equal, these demands are aggregated into one demand with their traffic
summed. Demands split by ECMPs are converted into multiple demands, each with traffic divided
proportionally to the ECMP split.

Trimming anodeis not the same as deleting a node. When you trim a node, the measured traffic carried
through that node is transferred to the nodes that remain so that the overall traffic in the network remains
unchanged. If the node is deleted, thistraffic is discarded. Only measured traffic is preserved in this way.

Note that multicast demands are removed, and cannot be trimmed.

Example: Edge node E is singly connected to node C in the core. When E is trimmed, the measured traffic
ontheinterfacefrom E to C isadded to thetotal sourcetraffic on node C. The measured traffic ontheinterface
from C to E is added to the total destination traffic on node C. By default, demands to and from node E are
removed.

Example: A demand sourceisnode A, and destination is node E, and is routed through nodes A-B-C-D-E. If
nodes A and E are trimmed and if you select the option to trim demands, then the new route for the demand
isB-C-D.

(Optional) If you want to trim the traffic of nodes under a specific utilization, sort one of the Traffic columnsto find the
lowest to highest utilization. Alternatively, use the Nodes table filter to search for traffic of a certain level using, for
example, the less than operator (<).

Select one or more nodes that you either want to trim or that you want to preserve while trimming nodes.
Right-click and choose Trim.

Select whether to trim the nodes or to keep the nodes and trim those that are unselected.

(Optional) Select the option to trim demands.

By default, the moved demands are named “ Trimmed,” though you can enter a different name.
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Step 6 Click OK.

Circuits and Interfaces

In WAE Design, an interface is aeither an individual logical interface or aLAG logical interface. If thereis
a one-to-one mapping between alogical and physical interface, then the interface contains both Layer 3
properties (for example, Metric) and physical properties (for example, Capacity). If there is a one-to-many
mapping between logical and physical interfaces, then the interface isthe logical LAG and the ports are
included in the plan file as the physical portsin the LAG. For more information on ports and port circuits,
see Ports, Port Circuits, and LAGSs, on page 36.

Each circuit connects a pair of interfaces on two different nodes. Therefore, an interface always has an
associated circuit. Both the interface Properties dialog box and the circuit Properties dialog box let you
simultaneously edit properties for the pair of interfaces and the circuit.

Interfaces have both measured and simulated traffic. Thetraffic that appearsin the Circuitstableisthe higher
of the traffic in the two interfaces.

Layer 1 Relationships

Each circuit can be connected directly to an L1 circuit. To make this connection, select the circuit, and either
select or createthe L1 circuit from the Advanced tab. An L3 circuit can be associated to multiple port circuits,
and each port circuit can be associated with adifferent L1 circuit. Thus, L3 circuits can be associated indirectly
with multiple L1 circuits. For more information, see Ports, Port Circuits, and LAGs, on page 36 and Layer
1 Simulation, on page 191.

The Latency and Distance Initializer uses mapped L1 circuit delaysto calculate L3 circuit delays. If L1 circuits
are not mapped to the L 3 circuits, the node L ongitude and L atitude properties are used in the calculation. For
information, see Simulation, on page 69.

Creating Circuits and Interfaces

To create a circuit, choose I nsert > Circuit, or right-click in an empty plot area and choose New > Circuit.
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Circuit Mame: crl.chi-cr2.nyc

Capacity: 10 GigE {10,000 Mbps)

Delay: 8.37 Distance: 1630.77
SRLGs: 1

Last Template Update: wyyy M dd bhemmeiss UTC

[ | Protected & Active || | Failed

Parallel Group Mame: E

Asaresult of creating a circuit, two interfaces are also created.

« Capacity—The amount of total traffic this circuit can carry. The drop-down list has a selection of the
most widely used capacities.

* SRLGs—If you want this circuit to belong to an SRLG, select it from thislist or create a new one by
clicking Edit. See Creating SRLGs for Circuits Only, on page 36.

* Parallel Group Name—To include this circuit in anew or existing parallel grouping, enter its name. To
visually combine these parallel groups in the network plot, see the Cisco WAE Network Visualization

Guide.
* Interface A and B—You must specify two interfaces that are connected by the circuit.

Interface A
Interface B
Site: |t|us
Site: chi
Mode: |cr1.hus
MNode: cr2.chi
Mame: fto_cr2.chi} &
MName: fto_crl.bos} |2

Duplicating Circuits
Duplicating acircuit has the following effect on the new circuit and itsinterfaces:

« Duplicates the circuit itself and all its properties, including the circuit name.

. Cisco WAE Design 7.4.0 User Guide



| Plan Objects
Creating a Circuit Mesh Between Nodes .

» Asaresult, it duplicates both associated interfaces and renames them by adding an incremental numeric
suffix to the original names, such as[1]. All other interface properties are copied to the new interfaces.

Duplicated selected Circuits (1/91)
Number of new Circuits; 1

Duplicate mapped L1 Circuits

Original Circuit

Duplicated Circuit i
e e i
Step 1 Select one or more circuits to duplicate.
Step 2 Right-click one of these circuits and choose Duplicate.
Step 3 Enter the number of new circuits you want to create for each selected circuit. For example, if you selected two circuits

and you enter 3, each of the selected circuits has three new parallel circuits, for atotal of six new circuits.
Step 4 To duplicate L1 circuits that are mapped to selected L3 circuits, check Duplicate mapped L 1 Circuits.
Step 5 Click OK.

Creating a Circuit Mesh Between Nodes

To create amesh of circuits between multiple nodes, follow these steps. Figure 10: Example Circuit Mesh,
on page 34 shows an example circuit mesh created between all the nodes within a site.

Step 1 Select multiple nodes that you want to interconnect.
Step 2 Right-click the interface you want to duplicate and choose Duplicate Between Selected Nodes.
Step 3 Click OK.
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What to do next
Figure 10: Example Circuit Mesh
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Merging Circuits

You can simplify the plan by merging circuits that have the same source and destination endpoints (nodes).
This capability is useful, for example, in long-term capacity planning where multiple parallel circuits can be
ignored and only the site-to-site connections are of interest.

Merging circuits changes the plan itself, not just the visual representation. (To change only the visual
representation, see the Cisco WAE Network Visualization Guide .)

The circuit merge effects are as follows:
* Set base circuit capacity to the sum of capacities.
* Set base circuit metric to minimum of metrics.
* Set base traffic measurements to the sum of measurements.

« Delete other circuits.

Before Circuit Merge

c Ky
o e—— ‘.
After Circuit Merge

{1=]
9 koy |2
B I o g
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Step 1
Step 2
Step 3

Step 4

sries [

Select multiple circuits that have the same source and destination endpoints.
Choose I nitializers > Merge Circuits, or right-click one of the circuits and choose M er ge.

The name of a newly merged circuit is based on the selected circuit. If you want to base the name on a different circuit,
select it from the Base Circuit list.

Click OK.

SRLGs

An SRLGisagroup of objectsthat might all fail dueto acommon cause. For example, an SRLG could contain
all the circuits whose interfaces belong to a common line card.

Creating SRLGs

Step 1

Step 2
Step 3
Step 4
Step 5

To open the SRLG dialog box, do one of the following:
* Choose Insert > SRLG.

* Right-click in the plot and choose New > SRL G.

SRLG Name: SRLG1
Object Type: |Nodes
L Show Al Circyits
IncludePorts
Fort Circuits
1 F | Bxernal Endpoint Members
2 : L1 Nodes
L1 Links
3 W7 i
4 WT e

Enter the SRLG name, or keep the sequentially named default names (SRLG1, SRLG2, and so on).

From the Object Type drop-down list, choose the type of object that you want to include in the SRLG.

For each that object you want to include in the SRLG, check the F (false) check box to toggleitto T (true).
Repeat Step 3 and Step 4 for each object included, and then click OK.
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Creating SRLGs for Circuits Only

Step 1 Open the Circuits Properties dialog box.

« If you are creating SRLGs for selected circuits, select one or more circuits. Then double-click one of them. Thisis
avery quick method of adding numerous circuitsto an SRLG.

« If you are creating anew circuit, right-click in an empty plot areaand choose New > Cir cuit. For more information,
see Creating Circuits and Interfaces, on page 31.

SRLGS: | Edt.
SRLGs
SELGs for cicuit:
| Showall | | select All =]
Included SRLG Create New SRLG — |
1 [T SRLG1
2 ; s SRLG2 MNew SRELG Name: |
3 [F1F SRLG3 [ ok || concel |
|

Step 2 Click the Edit button associated with the SRLG field.
Step 3 Associate the circuits with one or more existing SRLGs, or create anew SRLG.

Associate Circuits with Existing SRLGs Create New SRLG

For each SRL G in which you want to include the selected circuits, check the|a.  Click the New button.
F (false) or “na” check box to toggleitto T (true).

b. Enter the new SRLG name, and click
An*“na’ next to an SRL G meansthat one or more of the selected circuits are OK.

contained in that SRLG, but not all circuits are contained in it.

Step 4 Click OK in the SRLG dialog box to save the changes, and click OK again in the Properties dialog box.

Ports, Port Circuits, and LAGs

In WAE Design, aport isaphysical interface. You can model link aggregation groups (LAGSs) and port
channels using WAE Design port and port circuits (Figure 11: Ports, Port Circuits, and LAGs, on page 37).

A LAG isagroup of physical portsthat are bundled into asingle logica interface. A LAG isaso known as
bundling or trunking .
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By default, each logical interface listed in the I nterfaces table correspondsto asingle physical port, and these
ports need not be explicitly modeled. The exception is when the logical interfaceis a LAG, which bundles
more than one physical port. In this case, the physical ports are listed in the Ports table.

A port circuit is a connection between two ports. However, ports are not required to be connected to other
ports by port circuits.

Port circuits can be associated with L1 circuits, and ports can be connected to L1 nodes. The port circuit’'s
Delay Sim valueis copied from the associated L1 circuit’s Delay Sim property. Otherwise, the Delay Sim
valueisset to 0. For information on L3 Delay and Delay Sim calculations, see Simulation, on page 69. For
information on L1 Delay and Delay Sim calculations, see Layer 1 Simulation, on page 191.

Figure 11: Ports, Port Circuits, and LAGs
4,000 Mbps Circuit

4x Ports }\
1,000 Mbps Each( \

st | | I\

(Port Channel) Y 4x Port Circuits
4,000 Mbps Interface 4,000 Mbps Interface 1,000 Mbps Each

381174

Creating Ports

To create a port, either choose Insert > Port, or right-click in an empty plot area and choose New > Port.
Following are some of the frequently used fields:

« Site and Node—Site and node on which this port exists.

* Interface—L ogical interface to which this port is mapped. This must be defined to create port circuits
using this port.

* Capacity—The amount of total traffic this port can carry. The drop-down list has a selection of the most
widely used capacities.
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Mame: port_erl.chi

Site: [chi

Mode: [erl.chi

Interface: l{tn_crz.chi}
Description:

Capacity: GigE (1,000 Mbps) o
MAC Address: g

Layer 1 Relationships

Each port can be connected to an L1 node or to both an L1 node and an L1 port. Creating these connections
populatesthe L1 Node and L1 port columnsin the Portstable. If this port belongsto aport circuit, the Remote
L1 Node and Remote L1 Port columns are updated, as applicable.

To connect the port to an L1 node or L1 port, select the Layer 1 tab. Then select the site (if applicable), the
L1 node, and the L1 port to which the port is connected. For more information on Layer 1, see Layer 1
Simulation, on page 191.

Creating Port Circuits

A port circuit specifies a pair of connected ports.
« Both of the ports must exist and be mapped to interfaces that are connected by a circuit.

» When selecting the two ports for the port circuit, note that if one is assigned to an interface, the other
must be assigned to the remote interface on the same circuit.

To create ports and map them to their interfaces, see Creating Ports, on page 37.

To create a port circuit, either choose Insert > Port Circuit, or right-click in an empty plot area and
choose New > Port Circuit. The site, node, and port are al required fields.

PortA
Site: | chi
FPortB
Mode: |erl.chi ) y
Site: |chi
Port: ort_erl.chi
ROE. MNode: |cr2.chi
Port: |pnr‘t_cr2.chi ._

« Site and Node—Site and node on which the port exists.

* Port—Name of the port.
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* Capacity—The amount of total traffic this port circuit can carry. The drop-down list has a selection of
the most widely used capacities.

Each port circuit can be indirectly associated with an L1 circuit via direct mappings of L1 portsto L3 ports.
For more information on Layer 1, see Layer 1 Simulation, on page 191.

Creating LAGs

Step 1
Step 2

To make one of the existing interfaces into a LAG by assigning portsto it, follow these steps. If the interface
does not contain ports, you must first create them (see Creating Ports, on page 37).

From the Portstable, select all portsthat belong to the LAG. You can quickly do thisby filtering to their common interface.
Double-click one of the ports to open the Properties dialog box.

a) Select theinterface that contains these ports.
b) Click OK.

Setting LAG Simulation Properties

Step 1
Step 2
Step 3

Step 4

Each interface is considered to be aLAG (port channel). You can configure LAG properties so that if it loses
too much capacity due to non-operational ports, the entire LAG istaken down.

Double-click an interface or circuit; the Properties dialog box opens.
Click the Advanced tab.
In the Port Channel area, set one or both of the following parameters for one or both interfaces on the circuit:

a) Inthe Min Number of Portsfield, enter the minimum number of ports that must be active and operating for the LAG
circuit to be up.

b) Inthe Min Capacity field, enter the minimum capacity that must be available for the LAG circuit to be up.
Click OK.

Editing Object Properties

Most objects in the plot and in the associated tables have a set of properties that you can manage using a
Properties dialog box. These are the properties that WAE Design uses to define and simulate an object.

To change the properties of individual objects, do one of the following to open the Properties dialog box:

* Right-click one or more objects from the network plot or atable and choose Properties

* Double-click one or more objects from the network plot or table. (The exception isthat double-clicking
asite from the plot opens asite plot.)
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Tags

Plan Objects |

The Properties dialog box always lists how many objects were selected before opening the dialog box.
For example, if the plan file includes 500 interfaces, and you have 342 of them selected, the notation is
342/500.

Many objects can be tagged as away to group them for subsegquent processing. Once created, tags appear as
optionsin dialog boxes, enabling you to select and act upon all objects with a given tag name. Thus, tags
provide avery flexible way to group interfaces, demands, nodes, L SPs, sites, and ASes that are not easily
selected using standard attributes. For example, when using L SP paths you might want to tag selected paths
to make it easier to assign or change their path affinities.

Adding tags to a parent site does not add tags to its children sites and nodes.

v | Nodes: [Tag: Midwest Region (4/33) *]
All
| Selected in table (33/33)

| Internal (33/33)

381179

Right-click one or more objects and choose Properties.
Click the Tags tab and then New Tag.
Enter a name that identifies the objects you are tagging (for example, Midwest Region), then click OK.

Adding Tags
Step 1

Step 2

Step 3

Step 4 Click OK.

Enabling and Disabling Tags

Step 1
Step 2

Right-click one or more objects and choose Properties.
Click the Tags tab; alist of available tags opens.
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| Basic | LUser Tags
| Showall | | Select All [ *| |Filter |[*| 3/3 rows
Included Tags
1T Eastern Region
2T Midwest Region
30F Northern Region

Step 3 Toggle the tags to enable (T istrue) or disable (F isfalse).

Step 4 Click OK.

What to do next

3|77

Enabling and Disabling Tags .
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CHAPTER 4

Traffic Demand Modeling

WAE Design uses demands to describe the source and destination of apotential traffic flow across a network.
A route simulation determines the routes that this traffic takes from the source to the destination, which are
determined by the topol ogy, the routing protocols, and the failure state of the network. To model IGP routing,
these sources and destinations are nodes or interfaces within the topology. To model basic inter-AS routing,
the sources and destinations are neighboring external A Ses, peering nodesin these A Ses, or interfacesto these
peering nodes.

Each demand has a specified amount of traffic. There are several methods for putting this traffic into the
demands, including the Demand Deduction tool, which calculates a realistic amount of per-demand traffic
based on measured traffic.

The demand traffic is the basis for many of the WAE Design simulation and traffic engineering tools. An
accurate set of demands and demand traffic is essential for effective planning, designing, engineering, and
operating of a network. Accurate knowledge of the demands is essential for accurate traffic trending and
traffic growth predictions.

This chapter describes demands, including how they are created and how their traffic can be estimated.

Use Demands To... Suggested Steps to Take...

Model discovered networks| 1. Create a demand mesh based on where the traffic originates. For example,
if al traffic is between edge routers, create a demand mesh between those
edge routers.

2. Set the demand traffic by importing it or using Demand Deduction.

Model future usageinthe |1. Create ademand mesh.

network _ i . : )
2. After setting the traffic, use WAE Design tools for growing the traffic and

then analyze the effects on the network. You can import demand growth,
you can modify selected demand traffic to emulate growth, or you can use
demand groupings and other forecasting tools (described in Traffic
Forecasting, on page 91).

Design networks 1. Create ademand mesh.

2. Set the demand traffic using methods described in Traffic Forecasting, on
page 91.
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. Demands
Use Demands To... Suggested Steps to Take...
Analyze existing plans Use avariety of WAE Design tools that rely on demand traffic.
» Simulation Analysis lets you run what-if analysis.
» Manually edit the network topology and configuration to determine the
effects on traffic utilization.
« Traffic Engineering tools|let you control routings and optimize utilizations.
This section contains the following topics:
« Demands, on page 44
» Demand Traffic, on page 50
* Creating Demands and Demand Meshes, on page 58
* Adding and Modifying Demand Traffic, on page 64
Demands
Table 7: Feature History
Feature Release Information Description
Private Demand/L SP Cisco WAE Release 7.4.0 A new attribute called Require
Enhancements L SP is added to Demands

propertiestable. When thisattribute
is set to True for ademand, the
WAE Design simulation uses only
L SPsto route this demand in both
steady-state and under failures. If
thisis not possible, the demand is
not routed.

Because demands determine how trafficisrouted through the simulated WAE Design model, creating realistic
demands and demand meshes is imperative to the accuracy of other information that can be derived from
WAE Design. Assuch, all defaults are set to create demands and demand meshes that best suit most network
models.

Each demand is comprised of unique properties (keys) that defineit, other properties, and traffic. Thefollowing
list summarizes these, though for acomplete list of properties, refer to the available columnsin the Demands
table.

Selected demand paths are blue. An “A” labels the source, and a“Z” labels the destination.
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Demands .

w0 mig

Aalacs

Unique
Properties
(Keys)

Each demand is defined by a unique combination of these four properties.

Name—BY defaullt, thisis blank.

Source—Nodes, interfaces, external ASes, or external endpoints.

Destination—Nodes, interfaces, external ASes, external endpoints, or multicast destinations.

Service class—User-defined classification of traffic, such asfor voice or video.

Commonly
Used
Properties

Latency bound—~Policy that sets the maximum permissible latency on a demand under normal
operation. This property is used by WAE Design traffic engineering tools.

Topology—Demands can be assigned to a specific IGP, and only route through interfaces that
belong to that IGP.

Active—Only active demands are routed during simulations.

Reroutable—Enabl e/disabl e the routing of demands around failures. Turning off reroutes around
failures might be useful, for example, when simulating Layer 2 traffic.

Require L SP—If this option is selected, WAE Design simulation only uses L SPsin routing that
demand. If thisis not possible, the demand will not be routed. By default, this option is disabled.

Tags—User-defined label that lets you group demands for subsequent processing. Most tools,
for example, alow you to choose a set of tags on which to operate.

Private L SP—If a demand is associated with a private L SP, the demand can only route through
that L SP, and the only demand that is permitted to cross that L SP is this demand.

You can associate an existing demand to an existing private L SP. The Private L SP drop-down
list shows the private L SP that is currently associated with the selected demand. You can choose
adifferent private L SP, or you can choose None to remove an associated L SP.
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Traffic | By default, demands have zero traffic, so you must add the simulated traffic to them.

Demand traffic belongs to the service class of the demand.

Demand traffic can be set per traffic level.

Demand Sources and Destinations

When creating sources and destinations, follow these recommendations:
« For internal routing, use nodes.

* For external ASes, use a combination of ASes, nodes, and interfaces. Using interfaces lets you specify
the exact interface on which the demand traffic is going into or out of a node.

« For more complex routing where multiple sources or destinations (and multiple failover scenarios) are
required, use external endpoints.

* For multicast routing, use multicast destinations.

If multiple interfaces are attached to anode and if ademand is sourced to or destined for that node, the traffic
splits across one or more of those interfaces, depending on other properties, such as |GP metrics or BGP

policies (on apeering circuit). You can, however, specify just one of those interfaces. Figure 12: Example of
Demands Destined for a Node Versus an Interface, on page 47 shows an example of this difference between
using nodes and interfaces. In this example, the interface destination is one of three interfaces going into the

erl.atl node.

Noteif using an interface as a source of ademand, the source is the inbound interface. If using an interface
as the destination of a demand, the destination is the outbound interface.
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Figure 12: Example of Demands Destined for a Node Versus an Interface

Demand Meshes .

Demand Meshes
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Demand meshes are a time-efficient way of creating numerous demands for all or part of the network. By
default, WAE Design creates a source-destination mesh among nodes, interfaces, external ASes, and external
endpoints. There are also advanced options, such as the ability to use a different set of destinationsto create

the demand meshes.

Alternatively, you can import an existing <DemandMesh> table that contains estimated traffic. WAE Design
uses these estimations to calculate afull mesh of demands.

Demand Latency Bounds

Each demand can have a latency bound, which isa policy that sets the maximum permissible latency on a
demand under normal operation. These can then be used to guide the route selection of the traffic engineering
tools. The Simulation Analysistool can use these values to determine if latency bounds are violated when

worse-case failures occur.

The Demands table has several Latency columns. Key ones are as follows:

« Average Latency—Average latency over all ECMP subroutes.
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e Minimum Latency—Minimum latency over all ECMP subroutes.

* Maximum Latency—Maximum latency over all ECMP subroutes.

« Latency Bound—Maximum permissible latency on a demand.

« Min Possible Latency—Total latency of the shortest path that the demand could take.

* % Diff Min Possible Latency—Maximum latency minus the minimum possible latency expressed as a
percentage of Min Possible Latency.

Visualizing Demands

To view demand pathsin the network plot, select them in the Demandstable. Their path highlight isblue. An
“A” labelsthe source, and a“Z” labels the destination. If sites are nested, these “A” and “Z” labels appear in
all relevant child sites.

When you sel ect demandsin the Demandstable, their associated L 1 circuit paths are highlighted in the network
plot.

Demands are most commonly used to show how traffic reroutes around failures. A dashed line shows the
rerouted demand.

kiy Wil
E- : - - I s

Rerouted
Demand

Original Demand Route

353484

Viewing Demand Plots

Demand routes can be complex because they can go through multiple sites that could hide the details of the
path. For example, the network plot might not show theindividual nodestraversed by the demand, asin Figure
13: Network View of Selected Demand, on page 49. The demand plot offers an easier way to view end-to-end
demands, letting you view the hops that the demands take without having to individually select sitesto view
them. For example, Figure 14: Demand Plot View, on page 49 shows the demand plot view of the same
selected demand as in Figure 13: Network View of Selected Demand, on page 49.
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Step 1 In the Demand table, select one or more demands.
Step 2 Right-click and choose Plot Demands.
Step 3 To move the plot horizontally or vertically, use the left/right arrows and up/down arrows.

Step 4 To select al demands within the demand plot view, click Select Demands. To deselect all of these demands, click in an
empty plot area.

Step 5 To visualize multilayer L1 paths when plotting demands, use the following drop-down options:
» L3—Displays the path in terms of interfaces.
* L1—Displaysthe path in terms of L1 links.

To better align the L1 links, WAE Design checks for L3-L1 links. If they do not exist, WAE Design checks for
collocated L3/L1 nodes within sites.

« L3+L 1—Displaysthe L3 plot above and the L 1 plot below.

WAE Design does not perform alignment between L3 and L 1 nodes. When you click an L3 interface, the associated
L1 links are highlighted automatically.

What to do next

Figure 13: Network View of Selected Demand
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Viewing Shortest Paths and Shortest Latency Paths
For a description of shortest IGP paths and shortest latency paths, see |GP Simulation, on page 105.

To View... Choose... Example
Shortest IGP path | View > Demands > Shortest - bos
| GP Paths - i'h' e ————
; \ i
< key .'
Ly T R ",. Wl
L i ]
hist \\\' a E
B mia 2
Shortest latency path | View > Demands > Shortest . e
Latency Paths 115 i
-.-?:'1 .!‘_._ . . R | : o a « B
e - k. ) 3 : {;
H "B nvc
R ,‘
L » 1 Il.- 0 wdc
|T| ._/':'N/' !
] . s ]
st }\\' & %
B iz g

Demand Traffic

Simulated traffic is the amount of traffic ademand is attempting to propagate through the network. For
example, demand traffic is used to calculate interface utilizations during simulations. By default, demands
have no traffic, and thus there is no simulated traffic. The most complex and powerful method of adding
demand traffic is the Demand Deduction tool, which estimates demand traffic from measured traffic values.
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Creating and

Creating and Editing Traffic Levels .

Editing Traffic Levels

You can associate demands with specific traffic levels, which are identified in the Traffic Levels drop-down
list in the Visualization toolbar. The traffic level displayed determines what is displayed in the plot and table
calculations. For example, consider atotally static network that has no changesin topology or routing protocols.
Throughout a day, the only thing that changes from one plan to the next is the traffic level. Thus, you can
store traffic levels for different times of day all in asingle plan file. Then, you can view the different states
of the network from a single plan file by switching the view between different traffic levels.

You can create and edit traffic levels using the Edit Traffic Levels option (Figure 15: Create and Edit Traffic
Levels, on page 51).

Step 1 From the Traffic L evels drop-down list, choose Edit Traffic L evels.

Step 2 Click New,

Step 3 In the New

or choose an existing traffic level and click Duplicate.
Traffic Level dialog box, enter the name and click OK.

Step 4 Click Done. The traffic level now appearsin the Traffic Level drop-down list.

What to do next

Figure 15: Create and Edit Traffic Levels

(TrafficLevels) + (Qos) -
Default |

Edit Traffic Levels...

Edit Traffic Levels... Edit Traffic Levels - WAE Design ? *
Traffic Levels
Shaw All Select All [»| | Filter | 1/1 rows (0 selected) @l
Mame
1 Default
New Traffic Level
Mame: |Peak| Default * (QoS) «
Default |
Mew... Duplicate. .. Rename. .. Delete Bl Peak ‘

Demand Deduction

Plan files contain traffic measurements on the discovered network. Traffic can be measured on interfaces,
interface queues, and RSV P LSPs, aswell as on general traffic flows, such asfrom LDP LSPs. You can use
Demand Deduction to estimate demand traffic based on any of these measurements.

The accuracy and usefulness of the results depend on many factors, including how much measured traffic is
available, and of what type. For example, interface measurements are most often available, but LSP
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measurements might provide more information. The results also depend on the accuracy of the demand mesh
and the routing model.

Typicaly, you only have interface traffic measurements. In this case, the individual demands estimated by
Demand Deduction are not necessarily accurate. However, aggregates of demands can be highly accurate.
For example, predicting the overall utilization after afailure, atopology change, or a metric change, can be
very accurate even if the underlying demandsindividually are not reliable.

For more accuracy of individual demands, include point-to-point measurements, such as for RSVP LSPs or
LDP flows measurements. Also, it is useful to combine different types of measurements together for usein
Demand Deduction. Interface measurements are generally the most accurate measurements available, and if
included in a Demand Deduction, can correct for missing or inaccurate L SP or flow measurements.

Notethat you can a so use Demand Deduction to set Traffic Balance (%) valuesfor external endpoint members
that are set to a Deduce Traffic type. See Advanced Routing with External Endpoints, on page 265.

Example Demand Deduction

This example demonstrates results when using the Demand Deduction tool on a simple network. Figure 16:
Network Containing Two Demands and No Demand Traffic, on page 53 shows the routes of two demands
in a network. These demands split between the two parallel core circuits due to an ECMP, and they have a
common routing until the last hop. The Traffic column in the Demands table shows 0 because these demands
do not yet contain traffic. Figure 17: Measured Traffic View and I nterfaces Associated with the Demands,
on page 54 shows the Measured Traffic view and the five interfaces associated with the two demands, three
of which have measured traffic.

« Edgel to Corel has 470 Mbps of measured traffic.

» One Corel to Core2 interface has 210 Mbps, while the other has 240 Mbps, for atotal of 460 Mbps. This
unequal split is due to imperfect load balancing of the ECMP.

* Thereis no traffic from Core2 to Edge2 or from Core2 to Edge3.

. Cisco WAE Design 7.4.0 User Guide



| Traffic Demand Modeling

Figure 16: Network Containing Two Demands and No Demand Traffic

Example Demand Deduction .
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Figure 17: Measured Traffic View and Interfaces Associated with the Demands
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Upon running Demand Deduction with its default options, the Simulated Traffic view appears. Other than
the measured interface traffic, there is no other information about the demand traffic. So Demand Deduction
first splitsthe difference between the measured 470 Mbps of traffic (Edgel to Corel) and the measured traffic
of 460 Mbps (Corel to Core2) to get an estimated total demand traffic of 465 Mbps. In the absence of any
other information, it dividesthis 465 equally to give 232.5 Mbps of traffic to each demand (Figure 18: Simulated
View Showing Demand Traffic, on page 55). In the Interfaces table, the Traff Sim column now has values
and the network plot shows simulated traffic percentages on al five interfaces associated with the demands.

« Edgel to Corel has 465 Mbps of simulated traffic.
« Both Corel to Core2 interfaces have 232.50 Mbps.
* Core2 to Edge2 and Core2 to Edge3 both have 232.50 Mbps.

The Abs Meas Diff and Meas Diff/Cap (%) columnsin the Interfaces table show mismatches between
measured and simulated values.

* Edgel to Corel has a difference of 5 Mbps, or 0.5%.

 One Corel to Core2 has a difference of 22.5 Mbps, or 2.25%, while the other has a difference of 17.5%,
or 1.75%.

« Neither the Core2 to Edge2, nor the Core2 to Edge3 interfaces have val ues because they had no measured
traffic.
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Differences in Measured and Simulated Traffic .

Figure 18: Simulated View Showing Demand Traffic
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2 Corel {to_Corel} Core? 1 23250 210,00 1000.00 23.25 21.00 2250 225
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Inthissameexample, if the Core2 to Edge2 interface had 50 M bpstraffic, the resultswould have been different.
Because this interface is used only by the one demand, the measured 50 Mbps of traffic would be used as an
estimate only for that one demand. Using the same logic as before, the demands should total to 465 Mbps, so
the other demand is set to the difference, which is 415 Mbps.

Differences in Measured and Simulated Traffic

Demand Deduction relies on accurate topol ogies, demand meshes, and traffic measurements. These can affect
the results of the traffic simulated in the demands and cause simulated traffic to differ from the measured
traffic, thus affecting the accuracy of WAE Design simulations. You can see how close these values are by
showing the Abs Meas Diff and Meas Diff/Cap (%) columnsin the Interfaces column.

Abs Meas Diff—The difference between measured traffic (Traff Meas) and simulated traffic (Traff Sim).
Meas Diff/Cap (%)—The absolute measured difference expressed as a percentage of capacity.
If these columns show large values, one of the following situations likely exists:

* Inaccurate measurements—Different measurements, for example of traffic through different interfaces,
can be made at dightly different pointsin time. Fluctuations in traffic levels might take place between
the times that measurements are being taken. This means that measurements could be inconsistent with
one another. Usually, these inconsistencies are small and do not serioudly affect the Demand Deduction
results.
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« Insufficient measurements—There are typically many more demands in a network than measurements,
and many solutionswill fit the observed datawell. Demand Deduction chooses between possible solutions
using knowledge of typical behavior of point-to-point traffic.

« Incorrect network configurations—If the network topology isincorrect in the plan file, the ssimulated
routes would naturally be incorrect and measurements would not be adequately interpreted.

* Unbalanced ECM P—ECM P hashing can result inimperfect |oad balancing. Demand Deduction, however,
distributes traffic evenly across ECMPs.

« Static routes—WAE Design does not model static routes. If these are present, demands routes might be
simulated incorrectly, leading to deduction errors.

* Incompl ete demand meshes—Demand meshes do not contain nodes even though traffic is routed between
those nodes.

* Inappropriate priorities—In the Demand Deduction dialog box, you have the option to set the priority
for caculations as 1 or 2. WAE Design first uses the measurements identified as Priority 1 to calculate
the demands. Therefore, if the priority settings do not match the consistency of the traffic measurements
in the network, the simulated traffic measurements will be less than optimal.

Additionally, Demand Deduction displays warnings for misleading or undesirable results:

* AS“(AS Name)” contains both dynamic LSPs and interface traffic. Interface traffic in AS has been
ignored.

Routing of dynamic L SPsisnondeterministic. Soit isnot possibleto make use of both measured interface
traffic and measured dynamic L SP traffic for L SPsthat may (or may not) traverse these interfaces. If the
network contains an AS with both dynamic L SPs and interface traffic, thiswarning is issued and the
interface traffic is not used.

» Some interface measurements exceed capacities by as much as (percent).

Thiswarning isissued if a specified measurement exceeds the corresponding circuit capacity.

Minimizing Differences Between Measured and Simulated Traffic

Demand Deduction estimates demands that predict interface utilizations under incremental changesto the
topology, for example failures, metric changes, or design changes, such as adding a new express route. If
interface measurements alone are avail able, you might choose to fine-tune the Demand Deduction calculations
to get better results, such as for site-to-site traffic. To enhance the accuracy of Demand Deduction results,
consider the following suggestions:

* Include RSV P L SP or L DP measurementsin the network discovery process.

* Restrict demand meshes to exclude demands that are known to be zero. For example, if you know that
core nodes do not source traffic, then exclude core nodes when creating the demand mesh.

« Check the Nodestableto seeif thereisanode where the measured traffic going into it (Dest Traff Meas)
and out of it (Source Traff Meas) are very different. Ensure these nodes are included in the demand mesh
because they are either sources or destinations for traffic.

« In the Demand Deduction dialog box, always set the most consistent measurementsto a Priority 1. The
most reliable measurements are usually interface measurements. Likewise, L SP measurements are
end-to-end, and thus also generally highly reliable. You can set multiple measurementsto priority 1.
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Flow Measurements in Demand Deduction .

For example, if the flow measurements areinconsistent and theinterface measurements are very consistent,
then interfaces should be set to Priority 1 and the flow measurements to Priority 2.

* The Use Selected option in the Demand Deduction dialog box cal culates demands for the selected rows
in the Demand table. If you know beforehand the traffic for certain demands, you can set the traffic for
those demands and then run Demand Deduction on just the unknown demands. Select the Use
Selected—Fix Remaining option to fix the traffic of the remaining demands. A typical exampleis
multicast demands, which often have a fixed, known bandwidth. (You can identify multicast demands
in the Cast column of the Demands table.)

« If only afew measurementsare available or if there are many inaccurate measurements, the tool sometimes
estimates more traffic in a circuit than its capacity. To prevent this, in the Demand Deduction dialog
box, select the option to keep the interface utilization below 100%. This forces the resulting simulated
calculations to be below the given percentage of circuit capacity.

Flow Measurements in Demand Deduction

Besides node, interface, and L SP traffic measurements, Demand Deduction allows more general flow
measurements to be used. These flow measurements can be flows from (or through) a specified node, to (or
through) another node. M easurements can al so be combinations of these node-to-node flows. This measurement
format can be used to enter, for example, peer-to-peer flow measurements, or traffic measurements obtained
from LDP routing or from NetF ow.

Flow measurements are entered in the plan file in the <Flows> table, and appear in the GUI in the Flowstable.
Table 8: Flows Table Columns, on page 57 lists some of the more useful columnsin the Flows table. Note
that exactly which traffic isincluded is defined in the FromType and ToType columns.

Table 8: Flows Table Columns

Column | Description
From Source node.
FromType * Source—Traffic originating at the From nodeis included in the flow.
« Interior—Traffic isincluded that passes through the From node, entering that node from another node in the same
AS
» Border—Traffic isincluded that passes through the From node, entering that node from another node in adifferent
AS.
To Destination node.
ToType » Dest—Traffic that is destined for the To node.
* Interior—Traffic that passes through the To node to another node in the same AS.
» Border—Traffic that passes through the To node to another node in adifferent AS.
Traff Measured traffic used by Demand Deduction in its calculations. If more than one node isincluded in either the From
Meas or To columns, this measurement is the sum of the traffic over al flows between individual pairs of From and To nodes.
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Creating Demands and Demand Meshes

Creating Demands

All selections and entries are optional except for identifying the source and destination.

Step 1 Choose I nsert > Demands > Demand, or right-click in an empty plot area and choose New > Demands > Demand.
Source Destination
Source: crl.sjc Destination: f{crl.sjcito_orl.key)
Nonde
interface
External AS External AS
External Endpoint External Endpoint

Multicast Destination
Interface: o caolky =

380858

Step 2 Enter ademand name. The default is to create the demand without a name.

Step 3 Specify the source as anode, interface, external AS, or external endpoint.

Step 4 Specify the destination as a node, interface, external AS, external endpoint, or multicast group.

Step5 Choose the service class. If there are no service classes, the demand operates on a service class named Default .

Service Class: |Default

Latency Bound:

Topology: (Mo change)
Private LSP: (Mone) @
[¥] Active 2
Step 6 Enter avalue for the latency bound.
Step 7 Choose atopology to restrict the demand routes only to interfaces or L SPs belonging to that topology. The default is
unrestricted routing.
Step 8 Retain the Active default to include the demand in WAE Design simulations, or uncheck Active to exclude this demand

from simulations.
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Step 9
Step 10

Step 11

Duplicating Demands .

Traffic

| Show Al | | Select All |*| [ Filter |*| 3/3 rows
Traffic Level Traffic Growth %

1 Default na

2 Morning 1300.00

3 Peak 2020.00

Mew Traffic Level...

Janasy

For each traffic level, specify the amount of traffic or leave it empty for Demand Deduction to complete. You can also
create atraffic level if one does not exist (click New Traffic Level).

For each traffic level, specify the amount of growth rate you want to use for forecasting purposes. For moreinformation,
see Traffic Forecasting, on page 91.

Click OK.

Duplicating Demands

Step 1

Step 2
Step 3

Step 4

Step 5

Choose one or more demands.

Duplicate selected demands (3/96)

Number of new demands: 1

JE0RET

W] Share current traffic evenly

Right-click one of them and choose Duplicate.

Enter the number of new demands you want to create per selected demand. For example, if you have three demands
selected and you enter 2, each of the three demands is duplicated twice for atotal of six new demands.

To evenly distribute the traffic of each demand being duplicated, select “ Share current traffic evenly.” If thisisunsel ected,
the amount of traffic on the newly created demand is replicated. For example, if the original demand has 1000 Mbps of
traffic and you share it with one newly created demand, the resulting traffic is 500 M bps per demand. If you do not share
it, both the origina and the new demand have 1000 Mbps of traffic.

Click OK. Duplicated demands are named sequentially.
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Creating Demand Meshes

Step 1 To restrict the demand mesh source to a specified set of nodes, external ASes, or external endpoints, select them before
opening the Demand Mesh dialog box.

@ Source and Destination

Source

|+ | Nodes: | Selected in table (5/67)
- All

= table (5/¢
[¥] Bxternal Endpoints: | Internal (45/67)

Taqg: Central_Region (20/67)

Tag: Eastern_Region (20/67)

| Tag: Western_Region (27/67)

Advanced Options... ]

Import from Demand Mesh Table

Browse.. %
Step 2 Chooselnsert > Demands > Demand Mesh, or right-click in the plot and choose New > Demands > Demand M esh.
Step 3 Create a demand mesh based on the current plan file or import a Demand Mesh table.

« If creating a demand mesh based on the current plan file, select one or more sources from the Source drop-down
lists. Options include using the selected objects (in Step 1) as the source, which is the default. Another option is
to use all nodes, external ASes, or external endpoints as the source, which is the default if none were selected.
The remaining option isto select the source based on tags. (Tags are set in an object’s Properties dialog box.)

« If importing demandsfrom atable, select the Import from Demand Mesh Table option. Then browseto the desired
table. Note that this table specifies amesh of sourcesand destinations, rather than creating demands. For information
on how to create this table, see the Cisco WAE Design Integration and Development Guide .

Demand Mame:

Service Class: -

Topology: i

|| Edit demand traffic after insertion

3p085S

] Delete existing Demands with same name

Step 4 Enter a demand name. The default is to have no name to prevent large numbers of demands using the same name from
being created. The names are useful if needing to identify a specific area of the network, such asaVPN. However, not
using demand names helps ensure you do not create alarge number of demands that all have the same name.

Step5 Choose a service class. The default is the Default service class.
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Step 6 Choose atopology. The default is that demands are applied to all topologies.

Step 7 If you want to create demand traffic immediately upon creating the demands, check Edit demand traffic after insertion.
For information on entering traffic in the dialog box that appears, see Generating Demand Traffic Using Node Traffic
Estimates, on page 65. Note, however, if you have measured traffic in the plan file, amore accurate means of populating
the demands with traffic is to use the Demand Deduction tool. For information, see Demand Deduction, on page 51.

Step 8 If you want to delete all existing demands before new ones are created, check Delete existing demandswith same
name. The default (unselected) isto keep the existing demands and add only new ones.

Step 9 For any of the following options, click Advanced Options, make changes, and click OK.

« Destination—Choose this option if you want to create demands to destinations other than what has been selected
as the source.

Advanced Options...

Destination

|| Specify separate set of destinations

[ | oy 1 [ s W e B |

[ | Modes: Selected in table {33/33

[ | Bxternal AS's: Selected in table (0/0)

[+ External Endpoints: |All =

V] Also create demands from destination to source

W] Use interface endpoints toffrom external AS nodes
'¥| Respect AS Relationships

|¥| Respect External Mesh settings

AB0B53

V| Include Demands to Self

* Also create demands from destination to source—Uncheck this option if you want the demands created in only
one direction. Thisapplies only if you have selected a different set of destinations.

* Useinterface endpoints to/from external AS nodes—When creating demands for external ASes, use a
source/destination type of interface, and create a demand for all interfaces connected to each node in the external
AS. For information on AS relationships and routing policies, see BGP Simulation, on page 253.

» Respect AS Rel ationships—If checked, keep the existing A S rel ationshi ps defined by the Routing Policy (default).
If unchecked, recreate the AS relationships. The Routing Policy property is defined in the Edit AS Relationships
dialog box. For information on AS relationships and routing policies, see BGP Simulation, on page 253.

 Respect External Mesh Settings—If checked, keep the existing External Mesh settings defined for external AS
meshes (default). If unchecked, recreate the external AS mesh. The External Mesh property isset inthe AS
Properties dialog box.

¢ Include Demands to Self—Creates demands that have the same source and destination node (default).

Step 10 Click OK.
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Creating Demand Meshes for LSPs

Step 1

Step 2
Step 3
Step 4
Step 5

Step 6

Step 7

If applicable, choose L SPs over which you want to run the demands.

LSPs: Al - |

Service Class: [Default T]

Set Demand Traffic to

@) LSP Setup BW
[ ) LSP traffic measurements

) Zero

o
el

W] Mark LSPs as private. =

Choose Insert > L SPs > Demandsfor L SPs, or right-click in the plot and choose New > L SPs > Demands for L SPs.
Choose which LSPsto use: All, those selected, or tags.

Choose the service class for the resulting demands.

Choose the traffic for the newly created demands.

« Traffic equal to the L SP setup bandwidth
« Traffic equal to the L SP measurements
« Zero, which is appropriate if you need to insert demand traffic in other ways, such as using Demand Deduction,

importing it, or manually modifying it.

To remove the restriction of setting these demands to only these L SPs, uncheck Mark L SPs as private. Otherwise, the
default isto restrict these L SPs so that they use only the resulting demands.

Click OK.

Creating Demand Latency Bounds

You can set demand latency bounds to fixed values or to the following relative values (Table 9: Editing
Demand Latency Bounds, on page 63). All values are in ms (milliseconds).

* To set afixed value or to remove demand latency bounds, use either the Properties dialog box or the
Initializer tool.

» To set arelative value, use the Initializer tool.
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Creating Demand Latency Bounds .

Remove
) Fixed Value

1@ Relative

value:

minimum:

maximum:

Set latency bound for selected demands (95 / 95):

50

20

35

ms

% above shortest path

ms

%

ms above shortest path

38087

* Minimum—Minimum possible latency. Any latency boundsthat are lessthan thisvalue are set to exactly

toit. The default is 20 ms.

e Maximum ___ms above shortest path—M aximum possible latency. Any resulting latency bounds that
are more than their minimum possible latency are set to exactly to this value above their minimum
possible latency. The default is 35.

For example, if the minimum possiblelatency is20 msand this maximum is 35 ms, if ademand’slatency
wereto go up to 70 ms, it would be reset to 55 ms.

» Value _ % above shortest path—The latency bound is set to a percentage over the minimum possible
latency for that demand. The default is 50%.

For example, if thisvalueis set to 50% and if the minimum is 20 ms, then two demands with shortest
paths by latency of 10 ms and 16 ms would have bounds set to 20 ms and 24 ms, respectively.

Table 9: Editing Demand Latency Bounds

Using Demands Properties Dialog Box

Using the Initializer Tool

in the Latency Bound field.

4. Click OK.

1. Select one or more demands in the Demands table.
2. Right-click ademand and choose Properties.

3. Toset afixed value for the latency bound, enter avalue

To delete alatency bound, delete the text in thisfield.

1. If applicable, select one or more demands in the Demandstable. If
you do not select demands, the result appliesto all demandsin the
planfile.

2. Choose Initializers> Demand L atency Bounds.
You have several options:
To delete latency bounds, click Remove.
To set afixed value, enter this number in the Fixed Value field.

To set arelative value, click Relative and enter values.

4. Click OK.
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Adding and Modifying Demand Traffic

Estimating Demand Traffic Using Demand Deduction

Step 1
Step 2
Step 3

Traffic Demand Modeling |

Demand Deduction cal cul ates demand traffic when traffic measurements are available.

The options available can significantly affect the cal culations. For information on improving accuracy of
results, see Minimizing Differences Between Measured and Simulated Traffic, on page 56. For information
on setting up external endpoint members to be included in Demand Deduction calculations, see Advanced

Routing with External Endpoints, on page 265.

@ @
v -

®

Demand Deduction

Estimate demand traffic based on measurements.
Traffic
Traffic Level: | Selected: Default

Edit Traffic...

Measurements (measurement/total)

v Node Source and Dest (66/66) Priority 2
v Interfaces (99/100) Priority 1
LSPs (0/0)
Flows (0/0)

Fitting Parameters

(For operational use, once modelling is correct)
Concentrate errors in fewer places

Keep interface utilization below 100

Output

Demands: | Use existing

Fix multicast demands

| v| Remove demands with zero traffic

OK Cancel

®) Spread measurement errors evenly throughout network

(Slower, used for identifying measurement/modelling errors)

If applicable, choose one or more demands.
Choose Tools > Demand Deduction.

Choose the traffic level on which you are creating simulated traffic. The measurements used come from this traffic
level, and the simulated traffic for each demand is placed in this traffic level.
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Step 4

Step 5

Step 6

Step 7
Step 8

Step 9

Step 10
Step 11

Step 12

Generating Demand Traffic Using Node Traffic Estimates .

If needed, modify traffic measurements for one or more demands by clicking the Edit Traffic button. In the dialog box
that appears, you can modify measured traffic of interfaces, nodes, L SPs, flows, multicast flows, and/or ports. You can
further change these measurements for a traffic level and interface queue.

Another option in thisdialog box isto enter growth percents for use with Forecasting tool. For information, see Traffic
Forecasting, on page 91.

Identify one or more types of measurements used in the cal cul ations: nodes (source and destination), interfaces, L SPs,
and flows.

For each type, set its priority. Select Priority 1 for high priority and Priority 2 for lower priority. You can have multiple
measurements of the same priority. Like priorities are calculated simultaneously with equal consideration for the
measurements.

By default, all available measurementsin the selected traffic set are used, and the interface measurements have priority
over node, LSP, and flow measurements.

Choose the Fitting Parameters.

If you need to keep the traffic utilization below a different percentage than 100% (default), check Keep interface
utilization below and enter avalue.

Choose the demands for use in constructing the demand cal culations.

 Use existing—Cal cul ates demands using the existing demands only. This option is useful when simulating a
pattern of demands that cannot be represented as a simple mesh between nodes. If you did not select one or more
demands before opening this dialog box, use this option.

* Use selected—Cal culates demands for the selected rows in the Demand table. This option is helpful when you
want to recal culate some of the demands, for example, such asa VPN submesh.

Ignore Remaining—Does not include unsel ected demandsinitscalculations (that is, it treats those unsel ected demands
as zero).

Fix Remaining—Includes unselected demandsin its cal culations without changing their values. For example, if you
select 6 out of 10 demands, then those 4 unselected demands would remain as they are, but would be included in the
caculations.

Determine whether to fix multicast demands. If selected, the multicast demands are fixed at their current traffic value.

Determine whether to remove demands with zero traffic. The default is to remove them because Demand Deduction
typicaly estimates a significant percentage of the simulated traffic to be zero when alarge number of point-to-point
utilizations in amesh are extremely small. Using this default can substantially improve simulation and optimization
performance in large plans. Do not remove demands with zero traffic if all demand routes are of interest, irrespective
of traffic.

Verify your parameters, and click OK . Demand Deduction calculates the simulated traffic and liststhe resultsin a
Demand Deduction report.

Generating Demand Traffic Using Node Traffic Estimates

When alive network cannot be measured, you can estimate the demand traffic by editing the demand mesh.
Thisisasimple way to create traffic in a mesh of demands by specifying the total source and destination
traffic per node using one of the following a gorithms. For traffic mesh options used in more sophisticated
growth estimates, see Traffic Forecasting, on page 91.
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* Gravity Model—This estimation method allocates total traffic among the demands with roughly equal
weights.

* Proportional to current traffic—This estimation method allocates total traffic among the demandsin
proportion to simulated traffic on existing demands.

After you manually enter total traffic datain the dialog box, you can export it to afile for later use.

Step 1 Open the Demand Mesh Traffic dialog box in one of two ways:
¢ Choose Edit > Traffic > Demand Mesh.

» When creating demand meshes, choose Edit traffic after insertion from the Insert Demand Mesh dial og box.

Step 2 Each node used in ademand islisted. The SrcDest column identifies whether it is a source, a destination, or both.

For each node, enter the traffic measurement on which you want the estimated demand traffic to be based. You can
specify different values for source and destination traffic.

Step 3 You can set demand traffic based on an estimation model, afixed value, or randomly based on arange.

* To base the demand traffic on an estimation model, click Gravity Model or Proportional to current traffic.

» To change the demand traffic to a fixed amount or on range of random values, follow these steps.

SrcTraffic DestTraffic
Set Value...
Fixed
9 {Random
Min: 500 Max: 1500  |§

a. Choose one or more demands.
b. Right-click in a SrcTraffic or DestTraffic field, and choose Set Value.

c. Inthedialog box that appears, click Fixed or Random. If you choose Random, enter the minimum and maximum
traffic values.

d. Click OK.

Step 4 Choose the traffic level to which you want to apply the calculations, and then click OK.
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Traffic Level: Default
Default

Morning
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Modifying Demand Traffic

You have numerous options for modifying demand traffic, all from the same dialog box. The changes that
you make apply to the selected demands for the current traffic level.

You can modify demand traffic to either fixed values or to the following relative values.

* To et afixed value, use either the Properties or the Modify Demand Traffic dialog box (Table 10:
Modifying Demand Traffic , on page 68).

« To set arelative value, use the Modify Demand Traffic dialog box (Figure 19: Modify Demand Traffic,
on page 68 and Table 10: Modifying Demand Traffic , on page 68). Following are the avail able options.
Except for the percentage option, all values arein Mbps.

« Change traffic by a specified percentage. Positive percentages add to the traffic, and negative
percentages subtract. For example, if the traffic were 1000 Mbps and you entered —10, the traffic
would be reduced to 900 Mbps.

» Add aset amount of traffic spread over all demandsin proportion to their current traffic. For example,
if one demand had 1000 Mbps of traffic and the other had 2000 Mbps, and if you added 50 Mbps
proportionally, one would have 1016.67 Mbps and the other would have 2033.33 Mbps.

» Add aset amount of traffic uniformly to all the demands. For example, if one demand had 1000
Mbps of traffic and the other had 2000 M bps, and if you added 50 Mbps uniformly, one would have
1025 Mbps and the other would have 2025 Mbps.

* Set traffic to afixed value.

* Set traffic to a specific value that is spread proportionally over all demands. For example, if one
demand had 1000 Mbps of traffic and the other had 2000 Mbps, and if you set them to 4000 Mbps
proportionally, one would have 1333.33 Mbps and the other would have 2666.67 Mbps.

* Set aspecified amount of traffic, in Mbps, uniformly to all the demands. For example, if one demand
had 1000 M bps of traffic and the other had 2000 M bps, and if you set them to 4000 M bps uniformly,
they would both be 2000 Mbps.
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Table 10: Modifying Demand Traffic

Traffic Demand Modeling |

Modify Fixed Demand Traffic

Modify Fixed or Relative Demand Traffic
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1. Chooseoneor moredemandsinthe Demandstable. | 1. Choosethetraffic level you want the changesto apply to from the Traffic
. . Level menu in the Visualization toolbar.
2. Right-click one of these demands and choose
Properties. 2. If applicable, choose one or more demandsin the Demandstable. If you
. i . do not choose demands, the result appliesto al demandsin the plan file
3. For each applicable traffic level, enter the desired : P P
) o e for the selected traffic level.
amount of simulated traffic in the Traffic field.
If needed, click New Traffic L evel to create anew 3. Open the Modify Demand Traffic dialog box in one of two ways:
traffic level. Right-click a demand and choose M odify Demand Tr affic.
4. Click OK. Choose I nitializers > M odify Demand Traffic.
4. Choose one of the options identified in the preceding list and enter a
value accordingly.
5. Click OK.
Figure 19: Modify Demand Traffic
Modify Fixed Values
Traffic
[ Showall | [Selectall [¥] [Filter [¥] 2/2 rows (1 selected) gl
I Traffic Level Traffic Growth % ]
|1 evening 12323
!2 morning 77.04
Mew Traffic Level...|
Modify Fixed or Relative Values
Modify traffic for selected demands. i&
Traffic Level: Default
Number of Selected Demands: 6/95
Total Traffic (Mbps): 704.99
(@) Change trafficby 15 %
) Add Mbps in total, proportionally
) Add Mbps in total, uniformly
) Set traffic to Mbps each
) Set traffic to Mbps in total, proportionally
) Set traffic to Mbps in total, uniformly




CHAPTER 5

Simulation

WAE Design network simulations cal culate demand routings and traffic distributions through the network
based on the given traffic demand, network topology, configuration, and state. Simulation is the fundamental
capability of WAE Design on which most of the other tools are built, including those for planning, traffic
engineering, and worst-case failure analysis. A number of protocolsand models are supported, including IGP,
MPLS RSVP-TE, BGP, QoS, VPNs, Multicast, and Layer 1 (L1).

Thischapter focuses on the general features of WAE Design simulations. Theindividual protocolsand models
are described in their respective chapters.

Simulations can be performed under different simulation convergence modes (Fast Reroute, IGP and L SP
Reconvergence, and Autobandwidth Convergence), depending on which stage of the network recovery after
failureis being investigated. If in Autobandwidth simulation mode, the results for simulations with failures
areidentical to those in the IGP and L SP Reconvergence simulation mode. The default simulation modeis

I GP and L SP Reconvergence, and except whereidentified, the documentati on describes this simulation mode.
For more information, see RSV P-TE Simulation, on page 135.

This section contains the following topics:

« Traffic Simulation, on page 69

* State, on page 70

» Simulated Capacity, on page 75

» Simulated Delay and Distance, on page 76

Traffic Simulation

WAE Design uses demands to simulate traffic between source and destination endpoints within a network.
Each demand has a specified amount of traffic.

By default, an up-to-date ssmulation of an open plan is aways available. Any change in the plan that affects
or invalidates the current simulation automatically triggers a resimulation. Types of changes that result in
resimulations are those that would typically affect routing in a network.

* Changes in topology, such as adding and deleting objects or changing explicit paths.
» Changes to an object’s state, such as failing an object or making it inactive.

* Changes in numerous properties, such as metrics, capacities, and delay.

To toggle automatic resimulation on and off, do one of the following:
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. State

* Click the drop-down arrow next to the Simulation On/Off icon (white arrow in green circle) in the
Visualization toolbar. Check or uncheck Auto resimulate to toggleit on or off.

Ol

v Auto resimulate

ag1215

» Choose Tools > Simulator > Switch On/Switch Off.

State

The state of an object affects simulation and determines whether an object is operational.

« Failed State—Identifies whether the object isfailed.

« Active State—Identifies whether the object is available for use in the simulated network. For example,
an object might be unavailable because it has been set administratively down.

* Operational State—Identifies whether an object is operational. For example, an object might be
non-operational because it isfailed, isinactive, or because other objects on which it depends are not
operational.

The Failed and Active columns in the tables show a visual representation of their status. Likewise, you can
show the Operational column to show the calculated operational state. In each column, T meansthe object is
in that state and F meansit is not. Note that the T or F for Active state in the Interfaces table is reflective of
the associated circuit. The plot shows graphical representations of these states with crosses of various colors
andfills.

Failed State

The quickest way to see the effects of failuresin a Simulated Traffic view isto have demandsin place and
then fail an object. The plot immediately displays where the traffic increases as a result (Figure 20: Failed
Circuit, on page 71), and the Util Sim column in the Interfaces table reflects the traffic changes. Demands
are then rerouted around the failure (Figure 21: Reroute of Demand Around Failed Circuit, on page 72).

To specify that a demand should not reroute around failures, uncheck the Reroutable check box in the
demand’s Properties dialog box. This can be used asaway of including L 2 traffic on an interface. For example,
a one-hop, non-reroutable demand can be constructed over the interface to represent the L2 traffic. Other
reroutable demands can be constructed through the interface as usual. If the interface fails, the L2 traffic is
removed and the L3 traffic reroutes.

You can simultaneously fail one or more objects of the same type. If you select an interface to fail, you are
actually failing its associated circuit.
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Objects That Can Be Failed

« Circuits
* Nodes
* Sites

* Ports

« Port circuits

* SRLGs
e L1links
* L1 nodes

* External endpoint
members

Figure 20: Failed Circuit

Failed State [}

No Failure

Interface Util Sim
{to_crl.ams} 87.08]
{to_cr2.fra} 65.92
{to_crl.par} 47.75
. [|to_cr2ams} 21.14
.ti;NfRA
——« l
Interface Util Sim‘
[to_crl.ams} 2114
(to_cr2.fra} na
(to_crl.par} 11367

(to_cr2.ams}

2114
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Figure 21: Reroute of Demand Around Failed Circuit

AMS

4
-

FRA
-
== — -
- ©
Failing and Recovering Objects
From the... Fail Objects Recover Objects
Context menu 1. Select one or more objects. 1. Right-click in an empty plot area.

2. Right-click oneand choose Fail. |2. ChooseAll to recover al failed objectsor
individually select an object to recover it.

Propertiesdialog |1. Select one or more objects. 1. Select one or more objects.
box
2. Right-click one and choose 2. Right-click one and choose Properties.
Properties.

3. Uncheck Failed and click OK.
3. Check Failed and click OK .

Protecting Circuits Within SRLGs

You can protect circuits from being included in SRLG failures and SRLG worst-case analysis, though there
are differencesin behavior, asfollows:

 Thesecircuits do not fail if you individually fail an SRLG as described in the preceding steps. However,
if you fail the circuit itself, it will fail.

* These circuits are protected from being included in Simulation Analysis regardless of whether they are
inan SRLG.

Note that this setting has no effect on how FRR SRLGs are routed. For information on FRR SRLGs, see
RSV P-TE Optimization, on page 323.

Step 1 Set the Protected property for circuits.
a) Select one or more circuits.
b) Right-click aselected circuit and choose Properties.
c) Check Protected and click OK.
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Step 2 Set the Network Option property for protecting circuitsincluded in SRLGs.

a) Choose Edit > Network Options or click the Network Optionsicon in the Visualization toolbar.
b) Click the Simulation tab.
c) Check Exclude protected circuitsfrom SRLG failure and click OK.

¥ Exclude protected circuits from SRLG failure

Active State

An active/inactive state identifieswhether an object isavailable for measured or simulated traffic calculations.
An object can be inactive because:

* It isadministratively down.

« It isa placeholder. For example, you might be planning to install an object and want its representation
in the network plot.

* It existsin acopied plan, but was not in the original plan that was discovered.

You can simultaneously change the active state of one or more objects. If you change the active state of an
interface, you are actually changing its associated circuit.

Objects That Can Be Set to Inactive

« Circuits e L1links
* Nodes L1 nodes
* Sites « External endpoint
members
¢ Ports
N * Demands
« Port circuits
* LSPs
e SRLGs
* LSP paths

Like failures, changing an object from active to inactive immediately affects how demands are routed, and
affects the Util Sim column in the Interfaces tables (Figure 22: Inactive Circuit, on page 74).
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Figure 22: Inactive Circuit

Active =

% =
Demand Reroutes Around Inactive Circuit 8
Setting Active or Inactive States
Step 1 Right-click one or more like objects from their respective tables.
Step 2 In the Properties dialog box, check the Active check box to toggleit on or off. A check mark means the object is active.
Then click OK.

Operational State

The operational state identifies whether the object is functioning. You cannot set an operational state; rather,
it is automatically calculated based on the failed and active states.

» Any object that isfailed or inactive is operationally down.

« If the object relies on other objects to function, its operational state mirrors the state of those objects.

If This Object Fails or Is Inactive | These Objects Are Operationally Down

Node Circuits connected to the failed node

Site Sites, nodes, and circuits within thefailed site
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If This Object Fails or Is Inactive | These Objects Are Operationally Down

SRLG Objects within the failed SRLG

Port Port circuits that contain the failed port

Simulated Capacity

The Capacity column displaysthe configured physical capacity of interfaces, circuits, ports, and port circuits.
Each circuit, port, and port circuit hasaphysical capacity that you can set in the Capacity field of the Properties
dialog box. The interfaces have a configurable capacity that you can set in the Configured Capacity field.
From these properties, a simulated capacity (Capacity Sim) is derived for each object.

The Capacity Sim column is the calculated capacity of the object given the state of the network, which could
include failures that reduce capacity. All utilization figuresin the Interfaces, Circuits, and Interface Queues
tables are calculated based on this Capacity Sim value. When referencing the Capacity Sim value, there are
afew rulesto note regarding its calculation.

« If acircuit’s Capacity is specified, this becomes the Capacity Sim of the circuit, and all other capacities
(interface and constituent port capacities) areignored. Specifying circuit capacities (rather than interface
capacities) isthe simplest way to modify existing capacities, which is useful, for example, for build-out
planning.

« If the circuit has no Capacity, then its Capacity Sim isthe minimum of its constituent interface Capacity
values. The interface Capacity is the sum of the Capacity values of the associated ports. If the interface
has no portsor if the ports have no Capacity, it isthe same asthe interface's Configured Capacity property.
(Notethefield in the interface Property dialog box is “Configured Capacity,” while the column namein
the Interfaces table is “ Capacity.”)

* If two ports are connected explicitly by a port circuit, the Capacity Sim of the port circuit is set to the
minimum capacity of the three, which effectively negotiates down the capacity of each side of the
connection.

« If two ports are connected implicitly by an L1 circuit, the Capacity Sim of the two portsis set to the
minimum Capacity of the two, which again, effectively negotiates down the capacity of each side of the
connection.

« InaLAG interface, if any of the constituent LAG members are operationally down, the interface Capacity
Sim column displays a value that is reduced by the aggregate capacity of all the LAG membersthat are
down. For example, if a 1000-Mbps port of a four-port 4000-Mbps LAG is operationally down, the
simulated capacity for that LAG interface becomes 3000 Mbps.

A

Note |f apair of portsisconsidered in Capacity Sim calculations, both must be
operationa to be considered.
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Simulated Delay and Distance

Both Delay and Distance are properties that can be set in the circuit Properties dialog box. To automate the
process of setting these, use the Latency and Distance Initializer.

Delay:

11.8

Distance: 9447 58

All WAE Design delay calculations that use the L3 circuit delay, such as Metric Optimization, use the Delay

Sim value.

Circuits Table
Column

Description

Delay

One-way transmission latency over the circuit in milliseconds (ms).

Distance

Distance of the circuit in kilometers (km).

Delay Sim

* (Derived) If thecircuit Delay valueisentered, it is copied to the Delay Sim column.

« If no Delay isexplicitly set, the Delay Sim column in the Circuits table is copied
from the L1 Delay Sim column of the mapped L1 circuit (if one exists), whichis
based on the L1 circuit path that is currently the active path.

« If no Delay isexplicitly set and thereisno mapped L 1 circuit, the Delay Sim value
in the Circuitstable is copied from the maximum Delay Sim property of all
associated port circuits. If none of these port circuits is mapped to an L1 circuit,
then the Delay Sim valueis set to O.

* If thereisno circuit Delay value, no associated L1 circuits, and no associated port
circuits with Delay Sim values, the Delay Sim value is 0.

Distance Sim

* (Derived) If the circuit Distance value is entered, it is copied to the Distance Sim
column.

* If no Distance is explicitly set for the circuit, the Distance Sim column in the
Circuitstableis copied from the L 1 Distance Sim column of the mapped L 1 circuit
(if one exists), which is based on the L1 circuit path that is currently the active
path.

* If the Distanceis not specified (na) and if there are no L1 circuits mapped to the
circuit, the Distance Sim column is 0.

Latency and Distance Initializer

Following is the default behavior for the Latency and Distance Initiaizer. If there are no Longitude and
Latitude available for use, the Distance and Delay properties are set to zero.

L1 defaults
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» Thecurrent L1 circuits Delay and Distance properties are removed unless K eep existing distances
if available is checked.

» TheL1 nodeand L1 waypoint Longitude and L atitude properties are used to estimate the L 1 distances.
If an L1 node does not have these properties set, the shortest distance calculation is based these
same properties of itsimmediate parent site, if applicable. (L1 nodes are not required to have parent
sites.) The L1 link delays are calculated from these distances.

» Each L1 circuit path’s Distance Sim and Delay Sim columns are cal cul ated asthe sum of the distances
and delays of L1 links over which the L1 circuit path is routed.

e L3 defaults

« L3 circuit delays and distances are inherited from L 1 circuitsif there are L1 circuits mapped to the
L3 circuits. Otherwise, the L3 delay and distance are estimated using the shortest distance between
nodes at the endpoints of the circuits. If a node does not have Longitude and L atitude properties,
the calculation is based on these same properties of itsimmediate parent site, if applicable. (Nodes
are not required to have parent sites.) Thus, if you have an L1 model, the delays and distances are
more precise because the physical paths that the L3 circuits take are known.

* ITU G.826 adjustments are used to convert L3 circuit distance (d) to an adjusted circuit distance
(r) asfollows.

Ifd<1000,setr=15*d

If 1000 <=d <= 1200, set r = 1500
Ifd>1200,setr=1.25*d

If this option is unchecked, set r equal to d.

» Boththe L3 and L 1 delays are calculated to be the speed of light along a distance r, multiplied by
the speed of light in medium correction factor (between 0 and 1). The default for this correction
factor is 0.67.

Step 1 Thisinitializer can act on two different selected object types (L1 links and L 3 circuits), so the defaults for the dial og box
differ, depending both on selections and on how you access it. Regardless of the method, you can modify your selection
options once the dialog box is opened. Following are guidelines for having the dialog box open with the most desirable

defaults.
To Calculate... Select These Objects Choose
L1 link distance and delay, » No selections Initializers > Latency and Distance.
and L3 circuit delay
or
* One or more L1 links and one or
more L3 circuits
L1 link distance and delay » No selections Right-click an L1 link and choose I nitialize
Latency.
or
* One or more L1 links
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To Calculate... Select These Objects Choose
L3 circuit delay * No selections Use one of these options:
* Right-click an L3 circuit and choose
or s
Initialize L atency.

« One or more L3 circuits , ) L
« Right-click acircuit or interface and choose

Properties. Click the Estimate button. This
option is specific to L3 circuits.

Step 2 In each area, Layer 1 and Layer 3, verify or change your selection to act on the desired objects.

Estimate propagation delay and distance using longitude, latitude of nodes.
Layer 1

® Set distance (km) and delay {ms) on L1 Links
] Keep existing distances if available
® L1 Circuit Paths inherit distance and delay from Links

L1 Links [all v

Laver 3

e Inherit delay and distance from mapped L1 Circuits
e If no mapped L1 Circuit, estimate delay and distance using shortest distance between nodes

v Use ITU G.B26 adjustments

Circuits [all v

31228

Speed of light in medium correction factor (0-1):  0.67

« For L1 links, the default is to delete distances. To keep them, check Keep existing distancesif available.

« For L1 circuit paths, the default isto inherit distance and delay from L1 links. If desired, usetheL 1 Linksdrop-down
list to base these calculations on all, selected, or tagged L1 links. If you do not want the distance and delay set,

choose None.

« For L3 circuits, use the Circuits drop-down list to calculate L3 circuit delay and distance for all, selected, or tagged
L3 circuits. If you do not want the delay or distance set, choose None.

Verify theinclusion ITU G.826 adjustmentsin the cal culation, which is the default and which is usually left unchanged.

Step 3 For both L1 linksand L 3 circuits, verify or change the default speed of light factor of 0.67. Thisisusually left unchanged.
Then click OK.
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Simulation Analysis

The Simulation Analysis tool combines the simulation results of alarge set of failure scenarios. These results
are useful for determining how vulnerable a network is to congestion and high latencies under failures, thus
alowing you to plan sufficient capacity for any given failure scenario.

Simulation Analysisisrun across a set of failure scenarios that include selected objects, such as circuits, and
traffic levels. WAE Design calcul ates these failure scenarios across all service classes. Each scenariois
simulated and results in the following available analyses, which vary depending on whether the network has
QoS parameters and depending on which options are selected when running the simulation.

» Worst-Case Traffic Utilization, on page 80 on interfaces per service class
* (Optional) VPN worst-case utilization and latency
* (Optional) Worst-Case Demand Latency, on page 84

« Failure Impact, on page 85, which analyzestheimpact that each failed object has on interface utilizations
throughout the network

Upon compl etion, areport window opens with asummary of each analysis, along with the list of simulations
performed. Each time you run asimulation, thisinformation is updated (replaced).

After performing aSimulation Analysisacross multiplefailure sets, you can fine-tune the analysisfor asubset
of failure scenarios and a subset of service classes without running a new analysis. For example, if you run a
simulation for nodes, circuits, and ports, you can later go back and view the results for any one of those three
objects. See Viewing Simulation Analysis on a Subset of Failure Scenarios or Service Classes, on page 89.

Simulation Analysis can be performed under different simulation convergence modes (Fast Reroute, |GP and
L SP Reconvergence, Autobandwidth Convergence, and Autobandwidth Convergence Including Failures),
depending on which stage of the network recovery after failure is being investigated. The default simulation
modeis|GP and L SP Reconvergence, and except whereidentified, the documentation describesthissimulation
mode. For more information, see RSV P-TE Optimization, on page 323.

This section contains the following topics:

 Worst-Case Traffic Utilization, on page 80
» Worst-Case Demand Latency, on page 84

* Failure Impact, on page 85

» Simulation Analysis Reports, on page 86

* Protecting Objects, on page 87

* Running Simulation Analysis, on page 88
* Parallelization, on page 89

Cisco WAE Design 7.4.0 User Guide .



. Worst-Case Traffic Utilization

Worst-Case Traffic Utilization

Simulation Analysis |

The default analysisisto identify up to 10 failures for the worst-case utilization on each interface in the
network.

Worst case is the highest utilization that a particular interface experiences over all the failure sets and traffic
levelsthat you selected. WAE Design also determines which combination of failures would cause this
worst-case utilization.

Alternatively, you can record failures causing utilizations within a specified percent of the worst-case utilization.

Note

To control the number of threads that WAE Design processes in parallel when examining failure scenarios,
set the “Maximum number of threads’ field.

Upon finishing the analysis, WAE Design switches to the Worst-Case Traffic view and updates the plot to
simultaneously display all worst-case failures (Figure 23: Worst-Case Traffic Utilization for All Interfaces,
on page 81). It aso updates the following columns in the Interfaces and Circuits tables.

» WC Util—The worst-case utilization for that interface. The worst-case for a circuit is defined to be
whichever of the worst cases of the two constituent interfaces results in the larger utilization. Thus, for
circuits, this value is the larger of the WC Util values for the two interfaces in the circuit.

» WC Traffic—The actual traffic (Mbps) through the interface under the worst-case scenario.
* WC Traff Level—The traffic level under which this worst-case scenario occurs.

» WC Failure—L.ist of one or more failures that cause the worst-case failure of the circuit. An easier way
to read thislist isto right-click an interface and choose Fail to WC.

Calculate worst-case utilization per interface
» Record failures causing utilizations within 0 % of worst case

* Record up to 10 failure scenarios per interface

a@1213

Example: The circuit between crl.lon to cri.par, the crl.lon node, and the L1 link between lon and par
would all cause the worst-case utilization failure. ct{ crl.lonjto_crl.par}|crl.parf{to_crl.lon}};
nd{ crl.lon} ;L 1ink{lon|par|lon-par}

If you record failures causing utilizations within a given percent of worst case, this column shows QoS
violations as a percent. (See Worst-Case QoS Violations, on page 81.) If the number is positive, then
the allotted capacity has been surpassed. If negative, the capacity has not been surpassed. For example,
if acircuit has 10,000 M bps capacity, and if the amount of traffic onit asaresult of three different failures
is$11,000, 8000, and 4000 Mbps, the utilizations are 10%, —20%, and —-60%, respectively and in descending
order.

Calculate worst-case utilization per interface

& Record failures causing utilizations within 15 % of worst case

Jaizo2

* Record up o 10 failure scenarios per interface
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Example: Thecircuit between crl.amsand cr2.lon isthe worst-case failure and would cause thisinterface
to exceed its capacity by 24.75%. The failure of the cr2.lon node would cause the interface traffic to go
to its second highest utilization, which is 2.8% less than its capacity.

ct{ crl.amg|{to_cr2.lon}|cr2.lon|{to_crl.ams}} (—24.75%);nd{ cr2.lon} (2.8%)

For information on reading notation of objects within tables, see the Cisco WAE Design Integration and
Development Guide .

* WC Service Class—The service class for which this worst-case scenario occurs. For information on
running a Simulation Analysis with QoS, see Worst-Case QoS Violations, on page 81.

N\

Note For information on worst-case calculations for VPNs, see VPN Simulation, on
page 279.

Figure 23: Worst-Case Traffic Utilization for All Interfaces

Worst-Case QoS Violations

WAE Design includes QoS bound (maximum available capacity) as part of the worst-case calculations. If
there are no QoS parameters set, then the QoS bound is 100% and violations occur if utilization goes over
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that 100%. However, if aworst-case policy has been set on a service class or if interface queue parameters
have been set, then worst-case QoS violations are calculated. In these instances, WAE Design identifies the
interface with the highest percentage of QoS violation as the worst-case possibility. The following columns
are updated accordingly.

* WC QoS Bound—Theworst-case interface capacity available without violating these QoS requirements.
Thisvalue is based on available capacity, traffic utilization, worst-case policies set on service classes,
and interface queue parameters. The WC QoS Bound (%) column identifiesthis same value as a percentage
of the total capacity.

* WC QoS Violation—The worst-case traffic minus the worst-case capacity permitted (worst-case QoS
bound). A violation occurs if the QoS capacity allotted through worst-case policies for service classes
isexceeded or if QoS capacity allotted through interface queue parameters was exceeded. If the number
appearing in the WC QoS Violation column is positive, then the allotted capacity has been surpassed. If
negative, the capacity has not been surpassed. The WC QoS Violation (%) column identifies this same
value as a percentage of total capacity.

To see the cause of worst-case QoS violations, right-click a circuit and choose Fail to WC. Thetable
that appears lists all causes of thisinterface’s worst-case utilization and its worst-case QoS violations.
Choose the worst-case failure to view, and click OK.

» WC Service Class—The service contributing to the worse-case QoS violation.

For More Information... See...
* QoS parameters and QoS Quality of Service Simulation, on page 239
calculations

* Set worst-case policies on service
classes

« Set interface queue parameters

Worst-case QoS calculationsfor VPNs | VPN Simulation, on page 279
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Figure 24: Worst-Case QoS Violations
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Failing Circuits to Worst-Case Utilization

You have the option to selectively view each failure scenario that causes the worst-case utilization or worst-case
QoS violation for asingle interface.

* Right-click aninterface or acircuit and choose Fail to WC. If thereis only one worst-case failure (listed
in the WC Failure column), the object causing the worst-case utilization islisted. You can select it to
fail it immediately.

If there are multiple possibilities for aworst-case failure, or if thereis arange of failures within a
percentage of the worst-case failure, a Worst-Case Failures dialog box lists each failure, its worst-case
utilization percent, and its QoS violation percent (Figure 25: Failure of Single Circuit to Its Worst-Case,
on page 84). Choose the worst-case failure to view, and click OK. The network plot changes to show
this particular failure scenario. If you chooseto fail an L1 link or L1 node, switch to the L1 view to see
the failure.

N

Note |f you choose an interface, you are actually failing its associated circuit to its
worst case.

* Alternatively, to filter to these worst-case failures for an interface without invoking afailure, right-click
aninterface or acircuit, choose Filter to > Filter to WC, and then choose the worst-case failure scenario
of interest. If you fail this object from here, it achieves the same asif you had selected it from the
Worst-Case Failures dialog box.
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Figure 25: Failure of Single Circuit to Its Worst-Case
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Worst-Case Demand Latency

When running a Simulation Analysis, you have the option to simulate worst-case latency for each demand in
the plan. WAE Design cal culates the maximum latency of each demand under the failure scenarios selected.
The result does not depend on service classes or traffic level s because demand routing isindependent of these
plans. The simulation also records the failures that cause this maximum latency.

The following columns in the Demands tabl e are updated when you check Calculate demand wor st-case
latency for Simulation Analysis:

» WC Latency—The highest demand latency over al failure scenariosin the analysis.
* WC Latency Failures—The failures that caused this worst-case latency. Up to 10 failures are identified.

Failing Demands to Worst-Case Latency

After running Simulation Analysisto cal culate demand worst-case latency, you have the option to fail asingle
demand to itsworst-case latency. Right-click the demand and choose Fail to WC L atency (Figure 26: Example
of Worst-Case Demand Latency, on page 85).
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Figure 26: Example of Worst-Case Demand Latency

Failure Impact

The Failure Impact view isavailable upon running aSimulation Analysis (Figure 27: Example Failure Impact,
on page 86). The plot in this view colors the nodes and circuits according to the maximum utilization level
that would be caused el sewhere in the network should the node or circuit fail. The color indicates the resulting
utilization and severity of the congestion.

Example: In the Failure Impact view, a PAR-LON has a utilization of 90-100% and its color representation
isred. Thismeansthat if If PAR-LON wereto fail, one or more interfaces would react by exceeding a 90%
utilization level and correspondingly, would turn red in the plot.

The Node, Interface, and Circuit tables contain the Failure Impact and Failure Impact Interface columns. In
the Interfaces table, the information describes the failure impact of the circuit containing the interface.

« Failure Impact—The failure impact of each node or circuit. For example, if the value is 80%, it means
that if this node or circuit failed, the resulting traffic utilization on one or more interfaces would exceed
80%.

« Failure Impact Interface—The interface that will experience the highest utilization asaresult of the node
or circuit going down.
Format = if{ Node|l nterface}

Example: if{ cr2.lonlto_crl.ams} meansif the circuit goes down, it will have the greatest traffic impact on the
cr2.lon to crl.amsinterface.

If you are showing only an L3 view, site borders show the maximum utilization level that would be caused
elsawherein the network should nodeswithinit fail or should intrasite circuitswithin it fail. If you are showing
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ajoint L3 and L1 view, site borders show the maximum utilization level that would be caused elsewherein
the network should a contained L3 node, L3 circuit, L1 node, or L1 link fail.

Note The Failure Impact view only showsthe impact of circuit and node failures. It does not show failures of other
objects.

Figure 27: Example Failure Impact

Simulation Analysis Reports

Each time Simulation Analysisisrun, areport is automatically generated. You can access thisinformation
again by choosing Window > Reports. Note that new reports replace previous ones.

The Summary information detailsthe options used in the analysis and summarizes the most important problems
identified, such as QoS violations and latency bound violations.

The Max Util tab shows the impact of failures on maximum utilization in the form of a pie chart.

The Simulations table lists each simulation that was performed in the Simulation Analysis (Table 11:
Simulations Table in Simulation Analysis Report , on page 87).
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Table 11: Simulations Table in Simulation Analysis Report

Simulation Data Point

Description

Failure Failure scenario used in the analysis.
Service Class Service class used in the analysis.
Traffic Level Traffic level used in the analysis.

Network Breakpoint

| dentifies whether there are network breaks resulting from the failuresin this simulation. If multiple
network breakpoints occur, the most serious oneis listed.

* Yes (Total)—A break exists that completely partitions the network into two or more disconnected
sections.

* Yes (AS)—A break existsthat completely partitions an AS into two or more sections. However,
routes exist between the sections of the AS through other ASes.

* Yes (OSPF Area 0)—A break exists that completely partitions Area 0 of an AS running OSPF.
Under OSPF, traffic cannot route between the partitionseven if apath isavailable through non-zero
areasinthe AS.

* No—No break in the network.

Num Unrouted Demands

Number of demands that cannot be routed under this failure for any of the reasons identified by the
network breakpoint.

Unrouted Traffic Total amount of demand traffic that cannot be routed under thisfailure for any of the reasonsidentified
by the network breakpoint.

Max Util Maximum utilization over all interfacesin thissimulation. Utilization isthe traffic through theinterface
as a percentage of the capacity of the interface.

Max QoS Bound Percent | Worst-case capacity available without violating QoS bounds, expressed as a percentage of the total
capacity.

Num QoS Violations Number of times the QoS bound is violated. QoS bounds are set through service class policies and

interface queue parameters.

Latency Bound Violations

Number of demands with maximum latency in excess of the latency bound specified for the demand.

Num Unrouted L SPs

Number of unrouted non-Fast Reroute (FRR) LSPsin the analysis.

Num Unrouted FRR L SPs

Number of unrouted FRR LSPsin the analysis.

Num Unrouted L1 Circuits

Number of unrouted L1 circuitsin the analysis.

Protecting Objects

To exclude an object from the list of those objects failed when performing a Simulation Analysis, you can
mark it as Protected in its Properties dialog box. For example, if you want to run a Simulation Analysis only
on core nodes, you could first protect all edge nodes.
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Step 1
Step 2

You can protect nodes, sites, circuits ports, port circuits, external endpoint members, parallel circuits, L1
links, and L1 nodes.

\)

Note If you select an interface, you are actually protecting its associated circuit.

Right-click one or more like objects from their respective tables.

In the Properties dialog box, check the Protected check box to toggleit on or off. A check mark meansthe object is
protected. Then click OK.

Running Simulation Analysis

Step 1
Step 2
Step 3
Step 4

Step 5

Step 6
Step 7

Step 8
Step 9

The Simulation Analysistool isthe basis of four failure analysis options; worst-case utilization on interfaces,
worst-case VPN utilization and latency, worst-case demand latency, and failure impact.

\}

Note  Recording worst-caselatencies or VPN worst-case utilizationsincreases the timeit takes to perform aworst-case
analysis.

Choose Tools > Simulation Analysis.
Select one or more failure sets.
Select one or more traffic levels.

In the Record failures causing utilizations within __ % of wor st case field, enter O to record only worst-case failures,
or enter anumber to find all failures causing utilizations within that percentage range of the worst-case failure.

Define the maximum number of failure scenarios to record per interface. The default is 10.
Example: If you record failures causing utilizations within 10% of the worst case, and if the worst-case utilization for an
interface is 90%, then WAE Design recordsfailures on thisinterface resulting in utilization of 81% or higher (90 -(90/10)).

In this same scenario, if you record 10 failure scenarios per interface, and if there are failures that could cause utilizations
of 90%, 85%, 82%, and 76% for an interface, WAE Design does not record the failure causing 76% utilization.

Select whether or not to record demand worst-case latency calculations.

Select whether or not to record VPN worst-case utilizations and |atencies. For more information, see VPN Simulation,
on page 279.

Enter the value for Maximum number of threads.

Click OK.

You can now use the Worst-Case Traffic view to analyze the worst-case traffic utilization, worst-case QoS violation, and
worst-case latency information. Here you can also fail interfaces and nodes to their worst case, and fail demandsto their

worst-case latency. You can also use the Failure Impact, on page 85 view to identify the circuits that are responsible for
worst-case traffic congestion.
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Viewing Simulation Analysis on a Subset of Failure Scenarios or Service

Classes

After running a Simulation Analysis, you can select a subset of failure scenarios or service classes, and view
the results for just these subsets. This practice saves time because you do not have to rerun the analysis.

X |
Failure Sets Service Classes Traffic Levels
- [ Default . ’
{v'| Circuits Evening
= || Internet ;
| Nodes Morning
— [ Video = Peak
|t | Ports —
= [l | Voice '
| L1 Links ' > "
PR I—TTE— 5
—

After running a Simulation Analysis, follow these steps:

Step 1 Click thered X in the top, right toolbar. A list of failure scenarios, service classes, and traffic levels appears. These are
the options on which you last ran a Simulation Analysis.

Step 2 Click one or more failure sets and service classes. Then click OK.
If you need to change the traffic level selection, you must rerun a Simulation Analysis.

Parallelization

Simulation Analysis tool alows parallelizing the computaion and hence arrive at afaster result for large
network models.

Example: If there are 10000 Circuits in a network model, and there are 10 different machines available, the

tool can be used to break up the network model into 10 partitions with each partition handling 1000 failure

scenarios. Thisresultsin 10 different result files. The results from each of these independent runs are merged
together to obtain the final result.

Use the following CLI commands to execute parallelization:

Simulation Analysis with parallelization:

simanalysis -plan-file <input-plan-filename> -out-file <output-plan-filenane> -failure-sets
<failure-sets> -numpartitions <nunber-of-partitions> -numthreads <nunber-of-threads>
-partition-index <partition-index> -result-file <result-fil ename>

where
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* -num-partitions— Number of partitions of the failure scenarios. Each partition has an associated set of
failure scenarios and is identified by an index ranging from O up to the number of partitions minus 1.
Defaultis 1.

* -partition-index— Simulate the set of failure scenarios belonging to the specified partition. Default is 0.
« -result-file- If specified, the simulation analysis report results are written to thisfile. Can be *.txt or
*.dbfile.

Merging results:

nmerge_si manalysis -plan-file <input-plan-filename> -out-file <output-plan-filename>
-partial-results <list-of-files-w th-simulation-results>

where
« -plan-file: Input plan file.
« -out-file: Output plan file.

* -partial-results: Comma separated list of files containing simulation analysis results for each partition.
These may be plan files or files generated using the -result-file option of sim_analysis command.

« -partial-result-pathsfile: File containing list of files, one per line, with simulation analysis results for
each partition. These may be plan files or files generated using the -result-file option of sim_analysis
command. Thisisignored if the -partial-results option is specified.

. Cisco WAE Design 7.4.0 User Guide



CHAPTER 7

Traffic Forecasting

WAE Design traffic forecasting tools et you create plans containing estimates of future traffic based on
projected growth of current measured or simulated traffic. From these new plansyou can determine theimpact
of the new traffic on the network and plan for upgrades. The traffic growth estimates used in this process can
be manually entered, for example, based on knowledge of new services being introduced. After creating these
growth plans, you can analyze their capacity requirements using Simulation Analysis, and use the GUI to
upgrade the network to meet these requirements.

One exampl e use of these growth plan toolswould beto predict the effects of acertain percentage of increased
traffic for each quarter of the coming year. You could generate a separate plan for each of these traffic
predictions to forecast the impact of each quarter’s anticipated growth. Another example application would
be to group the demands into demand groupings to predict the effects of different traffic growth at each site,
such as 10% for Paris, 20% for London, and 30% for Amsterdam.

This section contains the following topics:

« Demand Groupings, on page 91
 Growth Plans, on page 100

Demand Groupings

Demand Groupings define a group of demands. They provide a convenient way of specifying aggregated
traffic in a plan, which can be used as a basis for traffic reports and growth plans. For example, you can use
demand groupings to represent the following.

« Total traffic sourced from one specific site
« Total VPN traffic, or any defined service class, sourced from one specific site to another
« Total traffic destined for aparticular AS
To generate areport on demand groupings, including costs associated with them, choose Tools > Reports >

Demand Groupings. For detailed information, see Demand Groupings Reports, on page 98. For adescription
of the cost modeling columnsin the report output, see Cost Modeling, on page 391.

Demand Groupings and Their Filters

The term demand grouping refers to a set of filters (rules) that determine a group of demands. For example,
you could create a demand grouping that filters all demands sourced from Paris, and name it ParisSrc. When
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you apply the filter, if 52 of the existing demands contain Paris as a source, those 52 demands combined
comprise asingle demand grouping called ParisSrc.

Each row in the Demand Groupings table identifies a uniquely named demand grouping and the associated
filters that define which demands areinit.

« Each column other than Name is a criterion that a demand must meet to be in that demand grouping.

* A demand must meet all criteria defined in these columnsin order for it to be a member of the demand
grouping.

« If thefield is empty, it is not used as a criterion.

 The column headings with “Matches’ in the name use regular expressions and the filters are applied
accordingly.

Example: If Destination Node Matchesis .*\.atl$, a demand can be a member of this demand grouping
only if it has destination nodesending in .atl and if it meetsall other criteria (listed in the other columns).

The column heading that use “Equals’ in the name must be exact matches.

Example: If Source Site Equalsis chi, ademand can be a member of this demand grouping if its source
siteis named exactly chi and if it meets all other criteria.

If the Tags Include column has an entry, a demand must contain this tag to be included in this demand
grouping. (Demands can have multiple tags.)

Example: If Tags Includeis atlantic, and if ademand has three tags named europe, atlantic, and apac,
then the demand would be included in this demand grouping provided it meets al other criteria.

There are other object-based Tags Include columns for source and destination sites, nodes, and ASes. If
one of these columns has an entry, the source or destination object must contain this tag to be included
in this demand grouping.

Example: If Source Site Tags Include is Europe and if the Dest Site Tags Include is Asia, the demand
would be included in this demand grouping if its source site is tagged with Europe, if its destination site
istagged with Asig, and if it meets all other criteria.

Demand Grouping columns can contain information that does not exist in the current plan. Thisflexibility
alows ademand grouping to be applied to any network.

To see alist of demands that comprise a demand grouping, in the Demands Grouping table, right-click
the row containing the unique demand grouping name and select Filter to Associated Demands.

In Figure 28: Demand Groupings Contain Demands, on page 93, if you were to filter to associated
demands on the first row (chi to bos), the resulting Demands table would show four demands because
they are the only ones with both chi as the source and bos as the destination.

If you were to filter to associated demands on the second row (chi to All), the resulting Demands table
would show all demands with chi as the source, no matter the destination.

To see all demand groupings in which a demand exists, in the Demands table, right-click the row
containing the demand of interest and select Filter to Demand Groupings.

* In Figure 29: Demands Contained in Demand Groupings, on page 94, if you were to filter to associated
demand groupings on the second row (crl.chi_crl.mia), the resulting Demand Groupings table would
show the two demand groupings that contain this demand (chi to All, and All to mia).

« If you were to filter to associated demand groupings on the first row (crl.bos crl.mia), the resulting
Demand Groupings table would show the only demand grouping that containsit (All to mia).
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Figure 28: Demand Groupings Contain Demands
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Figure 29: Demands Contained in Demand Groupings

Creating a Single Demand Grouping

This method lets you create a single demand grouping. All fields other than the Name field combine to create
aset of rules, or filters, for the demand grouping. A demand must meet all of the specified criteriafor it to be
included in the demand grouping. If you specify one or more growth values, the demand grouping can be
used in creating growth plans.

Note that you can also import demand groupings. For information, see the Cisco WAE Design Integration
and Devel opment Guide .

Step 1 Choose Insert > Demands > Demand Grouping, or right-click in the empty plot area and choose New > Demands >
Demand Grouping.

Step 2 Enter a unique name for the demand grouping. If you do not add a name, WAE Design renames the grouping to make it
unique.
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Demands Filter

|| bemand Name
|| Service Class  voice

|| Tags Include

Source Destination

| site ] site
W] site Tags Include  Midwest_Region [¥] site Tags Include ~ Southern_Region
] as ] as

| AS Tags Include ] AS Tags Include
V| Node Matching \(gbd\)* | Node Matching
"] node Tags Include "] Mode Tags Include .
| External Endpoint ] External Endpoint i

Step 3 Enter information as needed in the Demands, Source, and Destination fields to create the set of rules that define the
demand grouping. Each of these is a demand filter.

* You can enter only one parameter per field.
« If afield is unchecked, the filter is not used.

« If you make a selection, you must enter avalue in the empty field.

« All fieldsusing “ Tags Include” require asingletag to be specified. Thelist of tags for the corresponding object must
include this tag.

« All fieldsusing “Matching” allow you to use regular expressions.
« All fields without “Matching” require an exact match.

Step 4 If you want to use this demand grouping when creating growth plans, enter one or more values in the Growth area. See
Single-Period Demand Grouping Traffic, on page 101 for information on these values.

Step 5 Click OK.

Creating a Demand Grouping Mesh

A mesh of demand groupings is a set of demand groupings created between a specified set of sources and

destinations. It is often more convenient to create an entire mesh at once than to create the demand groupings
individually.

There are two methods for quickly creating a demand grouping mesh:;
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* Choose Insert > Demands > Demand Grouping Mesh or New > Demands > Demand Grouping as
described the following steps.

* Importing existing demand groupings from another plan file or table file. For information on importing
demand groupings, see the Cisco WAE Design Integration and Devel opment Guide .

Because you are creating a set of filters, not all steps are required. By default, the Insert Demand Grouping
Mesh uses selected sites (or all sitesif none are selected) as the source and does not group by destination. To
change the default and further restrict the demand grouping, you can choose from any combination of source,
destination, service class, and demand name, as well as use object tags.

If you select multiple sites before opening the dial og box and use those sites for either the source, destination,
or both, a unique demand grouping is created for each selection.

Examples: If you select both chi and miasitesfor the source and nothing for destination, two demand groupings
are generated: one named chi to All and one named mia to All . If you select both bos and nyc as both source
and destination, four demand groupings are created: bos to bos, bosto nyc, nyc to nyc, and nyc to bos .

Step 1 Select sites, nodes, or ASesif you want to create the demand grouping for a specific set of selected objects, whether as
source, destination, or both.

Step 2 Choose I nsert > Demands > Demand Grouping Mesh, or right-click in an empty area and choose New > Demands >
Demand Grouping Mesh.
Step 3 For both source and destination, you have these options:

« Sites—A\l, those selected prior to opening the dialog box, internal sites only (those not containing external AS
nodes), or a sites with a specific tag. For example, if you selected source sites tagged with Acme, only demand
groupings whose source site was tagged with Acme would be included.

» AS's—All, those selected prior to opening the dialog box, external only, or ASes with a specific tag.
» Nodes—All, those selected prior to opening the dialog box, internal nodes only, or nodes with a specific tag.
« External Endpoints—All, those selected prior to opening the dialog box, or external endpoints with a specific tag.

« Site Tags, AS Tags, Node Tags—Objects that are tagged with any value. For example, if you select “Node Tags’
for destination nodes, demand groupings would include those demands whose destination nodes have one or more
tagsof any name. If adestination node was tagged with APAC and another destination node was tagged with Europe,
both would be included in the demand grouping mesh.

« Do not group by—Ignore sources or destinations as filters for the demand grouping meshes.
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Sources
Sites 2 5ike Tags
AS's 85 Tags
Nodes Mods Tags
Externsl Endpoints
Do ot growp by source

Destinations

@ Stes {Inkernal (12/12) | Site Tags
AS's A5 Tags
Nodes Mode Tags
External Endpoints 2
Do not group by destination ;E
Step 4 In addition to or instead of selecting sources or destinations, you can create the grouping by restricting it to specific

demands.
* Enter the exact demand name.

» Select aservice class.

« Enter the exact source and destination node names or use regular expressions.

Restrict to

| pemand Name

| service Class

| Source Nodes Matching

|| Destination Nodes Matching

Default

380887

Step 5 The demand grouping names are created based on the name or variables used in the Name of Grouping field.

* Because each demand grouping created must have a unigque name, we recommend that the string “$1 to $2” be used
asthe name, which isthe default. The $1 variable is source site, node, or AS, or All if none of these are selected but
you have chose to include sources in the grouping. Likewise, $2 is the destination site, node, AS, or All if neither
is selected. Thus, a name can potentially be All to All .

If ademand grouping is selected using source and destination tags, then $1 is the name of the source tag, and $2 isthe

name of the destination tag.

* You can thisfield to create uniquely named demand groupings for the same site selections by entering extensions.

Example: You could select and use chi as the source, |eave the destination empty, and add an extension of voice, thus

creating a demand grouping named chi to All voice.
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Grouping Mames: $1 to $2-voice

3IB0BBE

£1 is Source, $2 is Destination

Step 6 Click OK.

Demand Groupings Reports

You can generate Demand Groupings reports on plan files that contain demand groupings. Each report has
two sections:

» Demand Groupings—For each demand grouping in the plan file, this section lists the name, traffic level
to which it applies, and the number of demands. All other columns are based on the total (aggregate) of
al demandsin the demand grouping, traffic, capacity bound, capacity violation, QoS bound, QoSviolation,
cost by capacity, and cost by utilization. These costs are the sum of the demandsin the demand grouping.

* Capacity Bound—The maximum amount that the sum of the demands in the demand grouping can
be without causing over 100% utilization on any interface in the network. The calculation is based
on the assumption that all demand traffic increases proportionally.

» Capacity Violation—Total traffic minus the capacity permitted for the demand grouping (Capacity
Bound). A violation occurs if the Capacity Bound is exceeded. If the number appearing in the
Capacity Violation column is positive, then the Capacity Bound has been surpassed. If the number
is negative, the Capacity Bound has not been reached.

* For information on QoS bound and QoS violation, see Quality of Service Simulation, on page 239.
* For information on how these costs are calculated, see Cost Modeling, on page 391.
» Demands—For each demand in the plan file, regardless of whether it isin a demand grouping or not,

this section lists the name, source and destination, service class, and number of demand groupings to
which it belongs.

To generate a Demand Groupings report, choose Tools > Reports> Demand Groupings, and then click
OK.

Example of Capacity Bound and Capacity Violation
Each interface imposes a limit on the traffic that can be carried by all demands in the demand grouping.

The goal of this exampleis to determine which interface is limiting the demand grouping’s ability to deliver
traffic. To do this, WAE Design looks at the interfaces over which each demand is routed. WAE Design then
calculates the maximum traffic that can be used for the demand without exceeding 100% utilization for any
routed interface.

In this example, the demands and interfaces are as follows.
* All interfaces have 1000 Mbps of traffic.
* The demand grouping is Acme_Region.
* §c_wdc_demand has 300 Mbps of traffic, and it traverses A_interface and B_interface.

* §c_hst_demand has 200 Mbps of traffic, and it traverses A_interface and C_interface.
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* There are other demands outside this demand grouping.

A_interface has 600 Mbps of traffic. Of this, 500 Mbps of it isfrom the Acme Region demand grouping,
and the remaining 100 Mbps is from demands outside this Acme_Region demand grouping.

B_interface has 500 Mbps of traffic, of which 300 Mbps is from the §c_wdc_demand. The remaining
200 Mbps of traffic is from demands outside this demand grouping.

C_interface has 400 Mbps of traffic, of which 200 Mbpsisfrom the §c_hst_demand. The remaining
200 Mbps of traffic is from demands outside this demand grouping.

The calculation is as follows:

* A interface

 A_interface can hold 900 Mbps of demand grouping traffic.
A_interface capacity — non-demand grouping traffic
1000 - 100 = 900

» The amount of sjc_wdc_demand traffic that A_interface can hold is 540 Mbps.
Total available capacity for the demand grouping * (§¢_wdc_demand/total demand grouping traffic)
900* (300/500) = 540

» The amount of 5ic_hst_demand traffic that A_interface can hold is 360 Mbps.
Total available capacity for the demand grouping * (5ic_hst_demand/total demand grouping traffic)
900* (200/500) = 360

« B_interface can hold 800 Mbps of §¢_wdc_demand traffic.
B_interface capacity — non-demand grouping traffic
1000 — 200 = 800

* C_interface can hold 800 Mbps of sic_hst_demand traffic.
C_interface capacity — non-demand grouping traffic
1000 — 200 = 800

» Thelimiting interface is A_interface because it imposes the strictest limitsin the demand grouping's
ability to deliver traffic. It supports only 360 Mbps of §jc_hst_demand traffic, whereas B_interface
supports 800 Mbps of gic_hst_demand traffic. Also, A_interface can support only 540 Mbps of
sic_wdc_demand traffic, whereas C_interface supports 800 Mbps of sijc_wdc_demand traffic.

* The Capacity Boundis900 Mbps. If the sum of the demandsin the demand grouping becomes 900 Mbps,
the utilization of A_interface (the limiting interface) will be 100%. This 900 Mbps is the total available
capacity for the demand grouping based on the limiting interface.

A_interface capacity — non-demand grouping traffic
1000 — 100 = 900
 The Capacity Violation is—400.
Total A_interface traffic permitted for the demand grouping — Capacity Bound
500 — 900 = —-400
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Figure 30: Example Demand Groupings Report

Reports

4 Demand Groupings
Demand Groupings (9}

Demands (95) MName Traffic Level Traffic Number of Demands Cost by Capacity Cost by Util
sjc to All Default 3650.60 6 5892516 18786095
sjc to All Peak 1472530 6 235547.56 369908.59
sicto Al Weekend 969555 6 149069.67 344901.80
Alltolax  Default 5924.67 5 137336.14 451218.90
Alltolax  Peak 9290.06 5 210953.77 35414469
Alltolax  Weekend 9453.31 5 21306140 450689.63
Alltochi  Default 710547 4 97903.69 27901297
Alltochi  Peak 1123234 4 144068.49 23675712 %
Alltochi  Weekend 8696.71 4 115934.92 26675057 §

Growth Plans

The Create Growth Plan tool lets you generate new plan files containing predictions of future traffic, based
on growth forecasts for the current plan. The predicted traffic growth can be generated in one of three ways.

* Per demand grouping using demand grouping traffic growth rates
* Per demand using demand traffic growth rates

« Per interface using interface traffic growth rates

Regardless of the method, the growth is compounded per period increment identified in the Create Growth
Plan tool.

A series of planfilesis created for each growth period, and each plan contains areport on the prediction
process used to generate it. Each newly created plan shows the effects of the traffic growth visually in the
plot using default traffic utilization colors, aswell as in the Traffic column in the Demands table. By
automatically running a simulation analysis on the new plans, you can incorporate worst-case performance
into planning decisions.

Demand Grouping Traffic Growth

Growth plans for network traffic, such as those produced either by trending analyses or by financial or sales
forecasts, are typically created for traffic aggregates. You can specify these aggregate growth forecasts or
trending estimates as demand grouping traffic growth information. The Create Growth Plans tool allocates
traffic to demands to match the aggregate traffic growth specified for each demand grouping. If two demand
groupings contain a common demand (for example, a grouping of demands sourced from one site, and a
grouping of demands destined for another site), this demand traffic is balanced between the requirement to
match each of the demand grouping traffic aggregates.

WAE Design supports two methods of creating growth plans based on demand groupings: oneis based on a
single period, while the other is for multi-period traffic forecasting.
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Single-Period Demand Grouping Traffic

Step 1

Step 2
Step 3

Step 4

The basic single-period method grows demands groupings based on the valuesidentified in the Growth Traffic
Total, Growth Traffic (%), and Growth Traffic Inc (increment) columns of the Demand Groupingstablein
the current plan. This approach is useful when all traffic in a given demand grouping is forecast to grow at
the same rate or when you want to create growth plans for only one growth period.

If Growth Traffic Total is specified, the base traffic is set to this value. Otherwise, the base traffic is set to
the sum of the current demand traffic in the demand grouping. The Create Growth Plans tool then appliesthe
Growth Traffic (%), followed by the Growth Traffic Inc.

Example: If the demands in the demand grouping have atotal of 15,000 Mbps of traffic, the Growth Traffic
(%) is 5, and the Growth Traffic Inc is 800, the resulting total demand traffic in the first period would be
16,550 Mbps, which is (15,000 *1.05) + 800. If you created growth plans for two period increments, the total
demand traffic in second increment would be 18,177.50 Mbps, which is (16,550 * 1.05) + 800.

If the Growth Traffic Total is specified as 20,000 Mbps, then the current demand grouping traffic total is
ignored, and the new demand grouping traffic total for the first period would be 21,800 Mbps, which is
(20,000*1.05) + 800.

You can populate these growth columns in the Demand Groupings table as follows:

* Choose Import > Demand Grouping Growth.
» Choose Edit > Traffic > Demand Groupings.

« By editing the Demand Groupings Properties dialog box as described in the following steps.

If setting the same growth for multiple demand groupings, select them from the Demand Groupings table.
Double-click a demand grouping, or right-click one and choose Properties.
Enter one or more values in the Growth area.

« Traffic Total—Specifies an exact traffic total in Mbps.

« Traffic (%)—Specifies the percent by which to grow current traffic in Mbps.

Example: If the Traffic Total is 30,000 and Traffic (%) is 5, then the growth plan grows the traffic to 31,500 Mbps.

« Traffic Increment—Specifies the amount of traffic to increment by in Mbps.

Example: If Traffic Total is 11,000 and Traffic Increment is 800, the growth plan grows the traffic to 11,800 Mbps.

Growth

Traffic Total:

Traffic (%&): 5

Traffic Increment: 800 ’-3
Click OK.
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Multi-Period Demand Grouping Traffic

The Demand Grouping Traffic table is away of specifying growth based on demand groupings for one or
more specified periods. Example use scenarios could be as follows.

« Traffic sourced and destined for CHI will increase by 10% next quarter
« VPN traffic between MIA and BOS will increase by 1000 Mbpsin the third quarter

* Transit traffic will reach 2 Gbps within ayear

Thistable has the flexihbility to specify the traffic total, traffic growth in specified increments (for example
10,000 Mbps), or traffic growth at a specified rate (percentage) per demand grouping.

The Demand Grouping Traffic table is created outside of WAE Design (for example, in a spreadsheet). You
can then use it, including all of its periods, when creating growth plans. When used with the Create Growth
Plans tool, the demand groupings in the current plan must match the names of those you are importing.

For information on creating this external table, seethe Cisco WAE Design I ntegration and Devel opment Guide

Demand Traffic Growth

This method grows demands based on the value identified in the Growth (%) column of the Demands table
in the current plan. This approach is useful when all traffic in the network, all traffic within a given traffic
level, or all traffic within a service class is forecast to grow at the same rate. When generating the plans, you
have the option of how many plansto create, and each plan will show growth at the same specified rate rel ative
to the previous plan.

Example: If traffic on ademand is 1000 Mbps, if the growth for that demand is defined as 10%, and if you
create two growth plans, the first will show 1100 Mbps and the second will show 1210 Mbps on that same
demand, representing 10% growth per period.

You can populate the Growth (%) column in the Demands table using either of these two methods.

* Select one or more demands, right-click one, and choose Properties. In the Traffic section, enter the
growth rate in the Growth % column.

* Import growth rates from a different plan file or tablefile. For instructions, see the Cisco WAE Design
Integration and Development Guide .

Interface Traffic Growth

This method grows measured traffic based on the Growth (%) column in the Interfaces table in the current
plan. It differsfrom demand-based growth methods because measured traffic, rather than demands (simul ated
traffic), isgrown. Thisisuseful for basic forecasting of the current network state, rather than worst-case failure
states, which require simulation. When generating the plans, you have the option of how many plansto create,
and each plan will show growth at the same specified rate relative to the previous plan.

You can also use this method in conjunction with Demand Deduction to create demands from the forecast
measurements.

Example: If traffic on an interface is 525 Mbps, if the growth for that interface is defined as 5%, and you
specify three growth plans, the first will show 551.25 Mbps, the second will show 578.81 Mbps, and the last
will show 607.75 on the same interface, representing 5% growth per period.

. Cisco WAE Design 7.4.0 User Guide



| Traffic Forecasting
Creating Growth Plans .

You can populate the Growth (%) column in the Interfaces table using either of these two methods.

 Choose Edit > Traffic > Measured Traffic. In the Growth (%) column of the Interfacestable, enter the
percent by which you want to grow the interface traffic for each applicable interface.

To set growth rates for multiple interfaces to the same value or to random values, select one or more
interfaces, right-click, and choose Set Value. You then have the option to set fixed values for all selected
interfaces or have WAE Design randomly set them within the range that you specify.

* Import growth rates from a different plan file or tablefile. For instructions, see the Cisco WAE Design
Integration and Development Guide .

Creating Growth Plans

Step 1 Choose Tools > Create Growth Plans.
Step 2 Specify one of the following growth methods:

» Demand Groupings—For information on how to set demand grouping growth based on fixed, incremental, or
percents, see Demand Grouping Traffic Growth, on page 100.

» Demand Growth (%) in current plan—For information on how to set this percent, see Demand Traffic Growth , on
page 102.

« Interface Growth (%) in current plan—For information on how to set this percent, see Interface Traffic Growth, on
page 102.

» Demand Grouping Traffic Table—Browse to or enter the name of the file containing the Demand Grouping Traffic
Table. For information on how to create these tables, see the Cisco WAE Design Integration and Devel opment Guide

Step 3 If creating growth plans based on demand groupings, demands, or interfaces, enter the number of plansto create and the
increment by which you want to create them.

* Period increment—Number of percentage increments per period. For example, if ademand is set to grow at 10%,
and the period increment is 2, the demand will grow by 21% in the first growth plan.

» Number of periods—Number of growth plan filesto create.

Plans are named using the period increment. For example, if you enter 4 as the increment and 2 as period, WAE Design
generates two growth plan files: one ending with _4 and one ending with _8.

Actions on Growth Plans...|

Perform actions on new growth plans

[] 1. Update LSP SetupBW on LSPs [All - |
¥] 2. Run simulation analysis

| | Perform actions on current plan

7
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Step 4 Click Actionson Growth Plansto perform these two tasks on the newly created growth plan files. To further specify
how to execute them, click their associated Options button. You can also choose to execute these tools on the current
plan.

 Upgrade L SP setup bandwidth on L SPs—For more information, see RSVP-TE Simulation, on page 135.

* Run simulation analysis—For more information, see Simulation Analysis, on page 79.

Mew plans named: euro_yearly_growth

Step 5 By default, WAE Design uses the current plan filename as the root name and adds the extensions generated by Step 3
for each growth plan. If you want the new plan filesto use a different root name, enter that namein the New plans named
field.

|| Open growth plans in GUI
W] save growth plans

C:/CARIDEN_HOMEVoice_Growth

300880

Step 6 To open these new plans upon exiting the dialog box, check Open growth plansin GUI.

Step 7 To automatically save these new plan files, check Save growth plans, and then enter or browse to the directory in which
you want to save the files.

Step 8 Click OK.
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IGP Simulation

This chapter describes options for simulating an IGP. WAE Design can simulate 1S-1S, OSPF, and EIGRP,
as well as supports multi-topology routing for 1S-1S and OSPF 1GPs.

All simulations use demands. For detailed information on demands, see Traffic Demand Modeling, on page
43

This section contains the following topics:

e OSPF and IS-IS, on page 105

* EIGRP, on page 107

* IGP Multipath Simulation, on page 107

 Multi-Topology Routing, on page 108

* |GP Metric Initializer , on page 109

* Viewing Shortest IGP, Latency, and TE Paths, on page 110
* Setting IGP Simulation, on page 112

OSPF and IS-IS

OSPF and |S-1S simulations are identical with the following exceptions.
» OSPF routing uses OSPF aress, if specified. By default all interfaces are assigned area zero.
* IS ISrouting uses |S-IS levels, if specified. By default, all interfaces are set to Level 2. Interfaces can
belong to Level 1, Level 2, or both. If both, then an alternate metric for Level 1 can aso be specified.
You can specify IGP Process ID to an IGP Protocol. To create, delete or edit IGP Process D, choose Edit >
| GP Process Protocols

Each interface can be associated with an IGP Process ID. Select one or more interfaces for which you want
to add IGP Process ID. Right click and choose Properties. Click Advanced tab and enter the IGP Process
ID.

OSPF Area Simulation

OSPF area membership can be specified per interface. The two interfaces on each circuit must belong to the
same area. Area names can be any string. Area zero, the backbone area, must be denoted by ““0’, “*0.0.0.0",
or an empty string. WAE Design simulates the OSPF area routing configuration in which the areas import

L SAsfrom the backbone. A demand from a source node to a destination node in a different areawill only be
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routed if it can reach the destination by passing through the source area, directly to area zero, and from there
directly to the destination area.

By default, all nodesin asingle AS are assumed to belong to asingle OSPF area. Nodes are assigned to areas,
asfollows.

« |f OSPF areas are not defined for interfaces, all nodes are assumed to be in the same area

« Each interface can be assigned to only one OSPF area. Note that each node can be assigned to one or
more areas.

« If anode has an interface in an OSPF area, the node is assigned to that area.

* An Area Border Router (ABR) is anode belonging to both area 0 and other OSPF areas.

IS-IS Multi-Level Simulation

By default, |S-ISinterfaces are assigned to Level 2, though you can assign them to Level 1 or to both Levels
1 and 2. (For instructions, see Setting |S-1S Multi-Level Simulation, on page 106.)

» The IGP metric defines the Level 1 metric for interfacesin Level 1, in Level 2, or in both Level 1 and 2
if these have equal metrics. However, you can change the Level 1 metric.

« If aninterfaceisin both Level 1 and Level 2 with uneven metrics, the |GP metric defines the Level 2
metric and the Level 1 metric defines the Level 1 metric.

ThelSISleve islisted inthe ISIS Level column of the Interfaces table, and the Level 1 metricis listed
in the Metric Level 1 1SIS column.
By default, all nodesin asingle AS are assumedto belongto asingle1S-1Slevel. Nodes are assigned to levels,
as follows.

« Each node can be assigned to one or more levels.

» Two Level 1 nodes are placed in different areasif any route between them (under normal operation)
passes through a Level 2 node.

* A nodeisassigned to asingle Level 2 areaif thereis at least one interface that is Level 2 or both Level
land Level 2.

« A nodeis assigned to one of potentially multiple Level 1 areasif any interfaceisLevel 1 or both Level
land Leve 2.

* An ABR isanode belonging to both the Level 2 area and another IS-1S area.

Setting IS-IS Multi-Level Simulation
Follow these stepsto set IGP metrics, IS-ISlevels, and Level 1 metrics.

Step 1 Choose one or more interfaces. Right-click one and choose Properties, or double-click an interface.

IGF Metric: 36
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Step 2 To set the IGP metric, enter itsvaluein the |GP Metric field or choose it from the drop-down list.
Step 3 To set SIS multi-level simulation, click the Advanced tab.

a) InthelGP area, set the |GP Process I D.

b) Select thelevel fromthe SIS Level drop-down list.

¢) InthelLevel 1 Metric field, enter the metric, and click OK.

EIGRP

The IGP Metric value for each interface is not used when EIGRP routing is selected. Instead, EIGRP uses
the following formulato derive total feasible distance (total cost) from a node to a destination subnet.

path metric to destination = (10,000/(bandwidth) + (delay) * 256

* The bandwidth is the minimum interface Capacity value along the path. Thisisin Mbps. For each
interface, if thereis no Capacity value, the Capacity Sim valueis used instead.

» Thedelay isthe sum of theinterface delaysin 10s of microseconds. Thisis calculated by taking the sum
of the EIGRP Delay values and dividing this sum by 10.

You can set thisdelay in the EIGRP Delay field of an interface's Properties dialog box. Here, the valueisin
microseconds.

If EIGRP Delay is not set, WAE Design uses 10 as the delay in the preceding cal cul ation, which means 10
"10s of microseconds.”

Exampledday: If there are 8 interfaces, each with an EIGRP Delay value of 15, thedelay used in the calculation
is(8x15)/10=120/10=12.

Demands show the EIGRP path metric of the path over which they flow in the Path Metric column.

IGP Multipath Simulation

By default, demands are split equally between all paths from aroute of equal distance to the destination, and
there isno ECMP limit.

You can specify a maximum number of ECMP paths. In this case, demands transiting through a router are
distributed among the available paths up to this maximum ECM P value. Paths are chosen by lowest next-hop
I P address, which isthe interface | P address for IGP or the destination |P address for L SPs. Paths with no IP
address are chosen last.
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—

Simulation | Protocols

IGP

Protacol |OSPF =

Max ECMF Faths 0

380896

(0 = no limit)

To configure ECMP, follow these steps:

Step 1 Choose Edit > Network Options or click the Network Optionsicon in the Visualization toolbar.

Step 2 Click the Protocols tab.

Step 3 In the Max ECMP Paths field, enter the maximum number of ECMPs. A 0 (zero) means thereis no limit.
Step 4 Click OK.

Multi-Topology Routing

WAE Design supports simulation of multi-topology routing. Interfaces can be assigned to one or more |GPs.
Demands and L SPs can be assigned to a specific IGP, and will only route through interfaces bel onging to that
IGP. This multi-topology simulation uses these rules.

* When an interface is common to more than one topology, all |GP properties of the interface (including
the metric) must be the same in both topol ogies.

» The IGPs must al be defined to be of the same type, for example OSPF or IS-IS. Thisishot arestriction
in practice unless either the OSPF topology or the IS-1S topology uses multiple areas.

» Demands and L SPs defined with a specific topology can only route over circuits belonging to that
topology. A circuit belongsto atopology if either one of its interfaces does.

» Demands and L SPs with no defined topology have no restrictions on routing. They are routed using the
default topology, to which all interfaces belong.

Editing Topologies

To create, rename, or delete topologies, choose Edit > Topologies.

To... Do This... Enter... Click...
Create a new topology Click New A topology name OK and
OK

Rename an existing topology | Select thetopology and click Rename | A different topology name | OK and
OK
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Adding Topologies to Objects .

To...

Do This... Enter...

Click...

Remove atopology

Select the topology and click Delete | —

OK

Follow these steps to associate interfaces, demands, or L SPs with topol ogies. Once you have associated the
topologies, you can view them by showing the Topology column.

Step 1 Select one or more interfaces, demands, or L SPs from their respective tables.
Step 2 Right-click one of the selected objects and choose Properties.
Step 3 Select the desired topology or topologies, as follows.

Interfaces

Demands and LSPs

a. Click the Advanced tab.
b. Inthe Topologies area, click the Edit button.

1. For each topology that you want on thisinterface, click
the F (false) to changeit to T (true).

2. Click OK.

c. Click OK.

b. Click OK.

a. Select the desired topology from the Topology
drop-down list. You can associate one topology to
each demand or LSP.

By selecting from asimilar Topology drop-down list, you can also add a topology to L SP meshes when creating them.

IGP Metric Initializer

The IGP Metric Initializer isaquick way of setting |GP metrics based on circuit latency values. WAE Design
calculates the metric by multiplying each circuit’'s Delay Sim value by the multiplier you specify. You aso
set aminimum value for the resulting |GP metric. WAE Design then uses the higher of the two values.

Multiplier 2

Minimum 1

Set Interface IGP metrics to max("Delay Sim" * Multiplier, Minimum)

380804

Example: If the circuit Delay Sim valueis 15, the multiplier value is 2, and the minimum valueis 1, the
resulting IGP metric is 30 (Delay Sim * Multiplier). However, if the minimum value were 50, the resulting

IGP metric would be 50.

Because WAE Design updates all metrics on all selected interfaces, you can modify interfaces individually
or in groups. For example, you might select all core routers in the Interface table and then simultaneously

calculate their IGP metrics.
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Step 1 Make your selections.

* Select one or more interfaces.
* Select one or more circuits. This updates |GP metrics for both associated interfaces.

* If you make no selections, IGP metrics are calculated for al interfaces.

Step 2 Choose Initializers> | GP Metric, or right-click an interface or circuit and choose I nitialize IGP Metric.
Step 3 Enter amultiplier and minimum value. Then click OK.

Viewing Shortest IGP, Latency, and TE Paths

The Shortest Paths table is dynamically generated to show routes that traffic would take between selected
nodes or between all nodes in selected sites. Columns include information about the total |GP metrics used
in the routes, as well as numerous latency columns. Because shortest paths are not objectsin the plan file,
there is no associated Properties dialog box. You can, however, right-click pathsto filter to interfaces or to
source and destination nodes to change their properties, as needed, to change the path.

« Shortest |GP paths are the shortest paths as calculated by |GP metric.
« Shortest latency paths are the shortest paths in an | GP network as calculated by the circuit latencies.

« Shortest TE paths are the shortest paths as calculated by the interface TE metric.

To view these shortest paths in the network plot, select them from the table (Figure 31: Shortest IGP,
Latency, and TE Paths, on page 111) using the following steps.

N

Note Filtering to the shortest IGP Path between two nodes when EIGRP is used does
not show the shortest EIGRP path. Rather, its shows the shortest path using the
traditional 1GP metrics for each interface.

Step 1 Select one or more nodes, or select one or more sites. If you select both, WAE Design uses the object type from which
you select the context menu. It does not use both simultaneously.
Step 2 Right-click one of the objects. For nodes, choose Filter to > Shortest Paths > <selection> . For sites, choose Filter to

intersite Shortest Paths > <selection> . The selection is any one of the following:
* Between selected nodes/sites (applicable only for multiple selections)
* With selected nodes/sites as source
* With selected nodes/sites as destination
* Through all selected nodes/sites
* Through any selected nodes/sites
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Step 3 The Shortest Pathstable is populated according to your selections: shortest IGP, shortest TE, or shortest latency. To view
apath in the plot, select it from thistable. The Type column identifies the path type.

What to do next
Figure 31: Shortest IGP, Latency, and TE Paths

Plotting Shortest Paths

From the Shortest Paths table, right-click one or more paths and choose Plot Shortest Paths. From here, you
can see each node in the shortest path, as well as the traffic utilization on interfaces between each node in the
path. Clicking Select Shortest Paths highlights the path in the network plot.
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Setting IGP Simulation

Step 1 Choose Edit > Network Options or click the Network Optionsicon in the Visualization toolbar.

*N
=]
s

| Simulation Protocols

IGF

Protocol

Step 2 Click the Protocols tab.

Janeny

Step 3 Choose the appropriate protocol from the IGP Protocol list.

Step 4 Click OK.
Step 5 Click the Simulation tab.

Step 6 Select an option for Redistribute Routes across | GP Processes. Choose from the following options:

* No IGP Redistribution
« Shortest Exit
* Shortest Path
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MPLS Simulation

This chapter describes how WAE Design simulates MPL S routing. All LSPs other than SR (segment routed)
LSPs arerouted like RSV P LSPs. For MPL S simulation information specific to these types of LSPs, see
RSVP-TE Simulation, on page 135 and Segment Routing Simulation, on page 179.

 LSPs are established under normal operation: that is, with failures not taken into account.

» Any L SPsthat are affected by the failures are rerouted. Depending on the L SP path settings, reroutes
might involve moving to a secondary path, dynamically rerouting the L SPs, or rerouting based on a
segment list.

» Demands are routed using the established L SPs using the specified | GP protocols given the specified
failure scenarios.

« LSP utilizations are calculated from the demand traffic using the specified traffic level.

This section contains the following topics:

* LSP Types, on page 113

« Creating and Visualizing L SPs and L SP Paths, on page 114
* Path Latency Calculations, on page 117

* Explicit LSP Paths Initializer, on page 117

« Routing Demands, on page 118

 Routing Inter-Area L SPs, on page 129

» Simulation Modes, on page 132

* LSP Establishment Order, on page 132

* Reports and Diagnostics, on page 133

LSP Types

* SR L SPs—Segment routing L SPs, which do not use RSV P for routing. You can create SR LSPs using
the WAE Design GUI. They areidentified with a Type property of SR. For moreinformation, see Segment
Routing Simulation, on page 179.

* RSVPLSPs—L SPsthat are established through RSV P. These are commonly known asMPLS TE tunnels.
WAE discoversRSVP L SPs, and you can a so create them using the WAE Design GUI. They areidentified
with a Type property of RSV P. For more information, see RSVP-TE Simulation, on page 135.

WAE Design does not model LDP tunnels as L SPs.
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Creating and Visualizing LSPs and LSP Paths

To simulate MPLS LSPsin the network, you must first set up the LSPs to be routed. In the WAE Design
GUI, enter LSPsinto the plan file in the following ways:

* By choosing Insert > L SPs > L SP, or by right-clicking in the plot and choosing New > L SPs> L SP.
This opens adialog box for entering properties for asingle LSP. One such property isthe Type, which
determines whether thisisan RSVP LSP or an SR LSP.

* By choosing Insert > L SPs > L SP Mesh, or by right-clicking in the plot and choosing New > L SPs >
L SP Mesh. This opens a dialog box for adding a mesh of L SPs between the selected nodes.

ﬁ R i

When selected, L SPs appear in the plot as a brown arrow. To view the details of LSP routes, as shown in
Figure 32: LSP Plot View of Three L SPs with the Same Source, on page 115, follow these steps.

Step 1 In the LSPstable, select one or more LSPs.

When you select LSPsin the LSPs table, their associated L1 circuit paths are highlighted in the network plot.
Step 2 Right-click and choose Plot L SPs.
Step 3 To move the plot horizontally or vertically, use the left/right arrows and up/down arrows.

Step 4 To select al LSPswithin the LSP plot view, click Select L SPs. To deselect all of these LSPs, click in an empty plot area.
Step 5 To visualize multilayer L1 paths when plotting L SPs, use the following drop-down options:

» L3—Displaysthe path in terms of interfaces.

e L1—Displaysthe path in terms of L1 links.
To better align the L1 links, WAE Design checksfor L3-L1 links. If they do not exist, WAE Design checksfor collocated
L3/L1 nodes within sites.

e L3+L1—Displaysthe L3 plot above and the L 1 plot below.

WAE Design does not perform alignment between L3 and L1 nodes. When you click an L3 interface, the associated
L1 links are highlighted automatically.

What to do next
You can plot one or more L SP paths in the same manner by selecting them from the L SP Paths table.

Tofilter to related information, such asrelated interfaces, source and destination nodes, or demands, right-click
one or more L SPs and choose the option.
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Figure 32: LSP Plot View of Three LSPs with the Same Source
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LSP Paths

L SPs can be assigned one or more LSP paths. Like LSPs, L SP paths have properties that vary depending on
whether the path isfor an RSVP LSP or SR LSP. If these properties are omitted, then they are inherited from
the LSP. If these properties are set in the L SP path, they override the L SP settings. For information on these
properties, see RSVP-TE Simulation, on page 135 and Segment Routing Simulation, on page 179.

After an LSP path is created, you can use an initializer to create explicitly routed paths. For information, see
Creating L SP Paths, on page 115 and Explicit LSP Paths Initializer, on page 117.
Path Options and Active Path

Each L SP path has a Path Option property. The LSPis routed using the first L SP path that can successfully
be established. L SP paths are established in increasing order of their path option, where path option 1 is

established first.
LSP Name: cri.lon_cr2.fra
Path Option: 2 2

Alternatively, you can choose which L SP path to use from the L SP Active Path drop-down list in the LSP
Property diaog box.

LSP Property

Active Path:

381068

Creating LSP Paths

Step 1 In the L SPstable, choose the L SP to which you are adding L SP paths.
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Create LSP Paths for the selected (1,/1056) LSPs

FPath Option: 2 -

Setup Bandwidth: (@ 0O Inher it from LSP
| Create associated named pathes: £1 &2

{£1 ks LSP Name, $2 ks Path Option)
W | Standby
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Step 2 Right-click in the plot choose New > L SPs > L SP Paths, or choose Insert > L SPs > L SP Paths.

Step 3 In the Path Option field, enter the order in which the LSP path is activated. Lower numbers have preference over higher
numbers.

Step 4 If thisisan RSV P L SP path, optionally set these properties. For information on these properties, see RSVP-TE Simulation,
on page 135.

a) If thisisastandby L SP path, check Standby, which ensures the paths are always active.

b) To set the bandwidth, specify the Setup Bandwidth for the L SP path, or specify that it should inherit the bandwidth
from the LSP.

c) To create associated named paths, check this option and complete the name using $1 for the L SP name and $2 for
the path option.

d) To associate the L SP path with affinities, click Edit. For example, you might want to associate a standby path with
an affinity that forcesit on adifferent path than the primary path. L SP paths can inherit the affinity from the LSP or
can be assigned a specific affinity. Click OK.

Step 5 Click OK.

Visualizing LSP Shortest Paths

To view the L SP shortest paths, use one of these methods. The sourceis marked with an“A” and the destination
is marked witha“Z".

« Using the View > L SPs submenus, you can choose to see the shortest actual paths, shortest latency paths,
or shortest TE paths each time that you choose an L SP.

* To view all shortest IGP paths, shortest TE paths, or shortest latency paths for selected L SPs, use the
context menu. Choose one or more L SPs, right-click, and choose Filter To > Shortest Paths (Figure
33: LSP Shortest IGP, Shortest TE, and Shortest Latency Paths, on page 117).
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Figure 33: LSP Shortest IGP, Shortest TE, and Shortest Latency Paths

Path Latency Calculations

WAE Design calculates shortest latency paths for L SPs and demands as follows:

* By default, WAE Design uses the shortest path from the source to the destination of the L SP or demand,
where the weight on each interface is the delay value for that interface.

« If the delay for any interfaceis zero (asit is by default), asmall (0.00001 ms) delay isused instead. This
means that if al the delays for the interfaces in the plan are zero, the path with the smallest number of
hopsis selected.

« If two paths have the same latency, paths with the smaller number of hops are preferred.

Explicit LSP Paths Initializer

The Explicit LSP Paths Initializer automates the process of explicitly routing existing L SP paths to follow
their currently simulated routes.

\}

Note Explicit LSP Paths Initializer supports RSVP only (in terms of ABR hop creation).
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» For RSVPLSPs, theinitializer convertsaset of dynamically routed L SPsto explicitly routed L SPsalong
their current paths.

Theinitializer creates named paths and named path hops for both primary and secondary paths. The
explicit paths are named <LSP Name> _<Path Option> . Orphaned named paths are deleted. (Named
paths are orphans if they are no longer used by any of the L SP paths.) For more information on RSVP
L SPs, see RSVP-TE Simulation, on page 135.

* For SR LSPs, the only use caseisif you want the initializer to create afinal segment list hop on the
destination node. For more information on SR L SPs, see Segment Routing Simulation, on page 179.

WAE Design writes areport identifying the number of selected L SP paths. To access thisinformation
|ater, choose Window > Reports

Create explicit LSPs that follow currently simulated routes
LSPs |Selected in table (10/1056) ~ |

All - -
Cancel

Tag: Acme (47/1056)
Taq: Edge (41/1056)

408317

Step 1 Choose Initializer s> Explicit L SP Paths, or right-click an LSP and choose Explicit Path Initializer.
Step 2 Choose whether to create explicit paths for all LSPs, selected L SPs, or tagged L SPs, and then click OK.

Routing Demands

Intra-Area LSPs

Intra-area L SPs are model ed as | GP shortcuts. That is, the source of the demand using the L SP can be anode
other than the ingress node into the IGP, and the destination node of the LSP can be anode other than the
egress node from the IGP. A demand through intra-area L SPs does not require the L SP to traverse the full
demand path.

Each intra-area L SP has a metric that helps determine which traffic is routed through the LSP. By defaullt,
autoroute L SPs have a metric equal to the shortest | GP distance from the source to the destination. However,
you can configure static metrics for these L SPs that override this default. Static metrics can aso be defined
relative the shortest | GP distance, but these relative metrics are not currently supported in WAE Design.

Forwarding adjacency L SPs always have ametric. If not specified, the default is 10. Forwarding adjacency
L SP metrics are injected into the | GP so that nodes other than the source node of the L SP are aware of the
path length through the forwarding adjacency L SP, and use it in their shortest path calculations.

To edit autoroute and forwarding adjacencies, choose one or more L SPs from the L SP table; double-click to
bring up the Properties dialog box and edit the values in the Routing area.

. Cisco WAE Design 7.4.0 User Guide



| MPLS Simulation

Inter-Area LSPs .

Inter-Area LSPs

Loadsharing

Because it is not possible to define metrics distances across | SP areas, there can be no well-defined metric
for inter-areaL SPs. Therefore, in WAE Design, ademand only routesthrough aninter-areal SPif the demand’s
endpoints are nodes matching the source and destination of the L SP, interfaces on these nodes, or external
ASeswhose ingress and egress points through the IGP are these nodes. This requirement is true regardless
of the network option settings.

To be routed, these demands must also match the privacy, tags, and class-based forwarding requirements.
Autoroute, forwarding adjacency properties, and L SP metrics are ignored. For information on privacy, see
Private L SPs, on page 126, for information on tags, see Plan Objects, on page 23, and for information on
class-based forwarding, see Class-Based Forwarding, on page 120.

Two or more L SPs with the same source and destination (and metrics, if these are defined) |oadshare traffic
between them. How the load is shared between the L SPs is determined by the L SP L oadshare property. By
default, L SPs have a L oadshare property of 1, and thus route traffic between them in equal proportions.
Changing the L oadshare value changes the distribution of L SP traffic and interface traffic in proportion to
these values.

Example: If two LSPs are parallel, and one has a L oadshare property of 2 and one has a L oadshare property
of 1, there will be a 2-to-1 ratio of traffic shared between them. The top half of Figure 34: Example of Two
Parallel LSPswith Equal Loadsharing, on page 120 shows an example of two parallel LSPsthat are routed
using strict explicit paths. Each has a L oadshare value of 1, which means the traffic is routed using a1:1
loadshare ratio so that each L SP carries 50% of the traffic. In contrast, the lower half shows the same parallel
LSPswith a2:1 ratio. That is, one LSP has a L oadshare value of 2, and one has a L oadshare property value
of 1. The LSP with a Loadshare value of 2 carries 67% of the traffic, while the other carries 33%.

Loadshare: 1

JE11

Each L SP has a path showing the percentage of traffic that crossesthe L SP as aresult of the Loadshare value
for that LSP. The format is <path option> :<loadshare percentage> %. Although loadshare applies only to
path option 1, the LSP itself might be routed along a different path.

381120

Note that this percentage may or may not be the same asthe L oadshare valuein the L SPstable. Thisisbecause
the Loadshare value is relative to the other Loadshare values for parallel LSPs. For this reason, if manually
editing the L oadshare property, we recommend that you consider the entire set of parallel LSPs. Note also
that because an L SP can be in multiple sets of parallel LSPs, the percentage on its path can differ.

To optimize these L oadshare values, use the L SP L oadshare Optimization tool. For information, see LSP
L oadshare Optimization, on page 316 .
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Figure 34: Example of Two Parallel LSPs with Equal Loadsharing

Two Parallel LSPs with Equal Loadshare LSPs

Ch' Name Source Destination Loadshare Traff Sim

,: ZW e crlsjc-to-crlwde-1 - crlsjc crlwdc 1.00 400.00
é ch crl.sjc-to-crlwde-2 crlsc crlwdc 1.00 400.00

i SRS g ¢ .
P Interfaces

& ma Node Interface Remote Node  Traff Sim
crl.okc to_crl.wdc crlwdc 400.00
crlsjc to_crl.chi crlchi 400.00
crl.chi to_crl.wdc crlwdc 400.00
crlsjc to_crl.okc crl.okc 800.00
Two Parallel LSPs with 2:1 Loadshare Ratio LSFs
chi Name Source Destination Loadshare Traff Sim

..
M " | |otsictoalwdel  alsic  alwde 200 53333
: DZ crlsjc-to-crlwde-2  crlsjc crlwdc 1.00 266.67
L

sic

A Interfaces

‘:_--, . L"" Node Interface Remote Node  Traff Sim
h;t, e " crl.oke  to_crlwde  crlwdc 266.67
crlsjc to_crl.chi crl.chi 533.33 &
crl.chi to_crl.wdc crlwdc 533.33 g
crlsjc to_crl.okc crl.okc 666.67 &

Class-Based Forwarding

Class-based forwarding (CBF) lets you manage differentiated service regquirements by restricting or allowing
demandsinto L SPs according to a set of user-defined mappings between demand service classes and L SPs.
For example, a demand with an Assured Forwarding service class could be mapped to an L SP saved for
carrying low-latency voice traffic, while a different L SP using that same demand could be used for only

best-effort services, such asfile transfers.

Class-Based Forwarding Simulations

Demands can be assigned a Service Class property. L SPs can be assigned a Class property. CBF is enabled
by creating a table that maps the demand service class to the L SP classes. The resulting table defines a set of

L SPs to which a demand with a specific service class has access.
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Figure 35: Example Service Class LSP Class Mapping Table

Service Class LSP Class Mapping

| Show All | | Select All |*| | Filter |*| 4/4 rows
Service Class  Priority  LSP Class
1 AF 1 LSPClass_AF
2 AF 2 L5PClass BE
3 AF 3 Drop .
4 BE 1 LSPClass_BE 2

« Each demand service class in the table is mapped to one or more L SP classes, or with a Drop value.

« If ademand’s service classisin the mapping table, the demand can only use L SPswith L SP classes that
match that service class.

If ademand service class is not in the mapping table, it can use any L SP,

Example: There are three demand service classes: AF, BE, and EX. The mapping table contains only AF and
BE (Figure 35: Example Service Class L SP Class Mapping Table, on page 121). Thismeansthat the demands
with EX service class can use any LSP in the plan file.

« If an LSP class does not appear in this mapping table, then any demand can use any L SP of that class.
« If multiple L SPs are sourced from one node, demands routed through that node can use any L SPto which
the demand'’s service class is mapped.

« If all available L SPs have L SP classes with equal priority, the traffic isload balanced between these
LSPs.

« If the LSPshave prioritized L SP classes (1, 2, 3, etc.), those with the highest priority (lowest number)
arerouted first.

Example: A demand with an AF service class must first use LSPswith an LSPClass AF because within the
AF serviceclass, thisistheonly Priority 1 LSP class. If no LSPswith LSPClass AF areavailable, the demand
triesto route across L SPswith an LSPClass BE class (Figure 35: Example Service Class L SP Class Mapping
Table, on page 121).

« If there are no available L SPs with matching L SP classes, the demand follows these rules.

« If the demand'’s service class is hot mapped to a Drop value, the demand forgoes using L SPs and
takes the shortest | GP path.

« If the demand’s service class is mapped to a Drop value, the demand is unrouted.

Example: If there are no available L SPs for the AF demand to route across, it will not route due to the Drop
value associated with it (Figure 35: Example Service Class L SP Class Mapping Table, on page 121). If the
BE demand cannot route across an L SP that has a class of LSPClass BE, it will route across the shortest IGP
path available.
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Example Simulations

In these examples, we want to route the assured-forwarding (AF) Europe-to-Japan traffic directly over the
more expensive, but lower latency, circuitsthrough Russia. We want to route the best-effort (BE) traffic along
the cheaper, but higher latency, circuits through the US.

Demands

Mame Source Destination Service Class

Lon-Tok-D1 crllon crl.iok AF
Lon-Tok-D2 crllon crliok BE

L5Ps

Mame Source Destination Class

LSP A  crllon crltok LSPClass_AF
LSP B crllon crliock LSPClass_BE

381084

In these example simulations, there are only two demands and two L SPs. Both demands and both L SPs go
from London to Tokyo.

* Lon-Tok-D1 demand uses an AF service class.
* Lon-Tok-D2 demand uses an BE service class.

e The LSPsarenamed LSP_A and LSP_B. Each LSPis explicitly routed to reach Tokyo via a different
path.

* LSP Aisassignedto LSPClass AF.
e LSP Bisassigned to LSPClass BE.

Figure 36: Example Reroute Around Failure Using | GP Path, on page 123 shows asimple one-to-one mapping
between a service class and an LSP class.

» The AF service classis mapped to LSPClass AF.
* The BE service classis mapped to LSPClass BE.

« If the circuit between London and Tokyo fails, the Lon-Tok-D1 demand reroutes using the shortest IGP
path. The reason is because there are no aternative L SPs available.
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Figure 36: Example Reroute Around Failure Using IGP Path

Lon-Tok-D1 Demand
Uses LSP_A

Mapping

Example Simulations .

AF
BE

Service Class Priority

LSP Class
1 LSPClass_AF
1 LSPClass_BE

Lon-Tok-D2 Demand
Uses LSP_B

Mascow

Moscaw

Lon-Tok-D1 Demand
Reroute Uses IGP Path

381088

Figure 37: Example Reroute Around Failure Using Alternative L SP Class, on page 123 shows that the AF
service classis mapped to both LSPClass AF and LSPClass BE. The Lon-Tok-D1 demand now reroutes
around a failure between London and Tokyo by using LSP_B. Thisis because the AF service class now has
aPriority 2 mapping to the LSPClass BE class, and the fact that LSP_B is assigned to this LSPClass BE

class.

Figure 37: Example Reroute Around Failure Using Alternative LSP Class

Mapping

Service Class Priority LSP Class
AF 1 LSPClass_AF
AF 2 LSPClass_BE
BE 1 LSPClass_BE

Lon-Tok-D1 Demand
Reroute Uses LSP_B

Moscow

Caro

381089

Figure 38: Example of Not Rerouting Based on Drop L SP Class, on page 124 showsthat the AF service class
is mapped to both LSPClass AF and a Drop value. The Lon-Tok-D1 demand now does not reroute around a
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failure between London and Tokyo. Thisis because demands using AF service class are mapped so that if an
LSPwith an LSPClass_AF classis not available, the traffic is dropped.

Figure 38: Example of Not Rerouting Based on Drop LSP Class

Mapping

Service Class Priority LSP Class
AF 1 LSPClass_AF
AF 2 Drop

BE 1 LSPClass_BE

Lon-Tok-D1 Demand
Moscow Does Not Reroute

51056

3810

Workflow for Creating Service Class and LSP Class Mappings

Step 1
Step 2

Step 3
Step 4
Step 5

The workflow for creating mappings between service classes and L SP classes is as follows (Figure 39:
Workflow Process for Creating Service Classto L SP Class Mappings, on page 125).

Create the service classes using the Manage QoS dial og box. For information, see Quality of Service Simulation, on page
239.

Assign demands to the service classes. To assign this property, use the Service Class menu in the demand’s Properties
dialog box. (Right-click one or more selected demands and choose Properties.)

Create the L SP classes using the Manage QoS dialog box. For information, see Creating L SP Classes, on page 125.
Assign LSPsto the L SP classes. For information, see Assigning L SP Classes to L SPs, on page 125.

As needed, assign a service class to one or more L SP classes using the Manage QoS dialog box. This creates a mapping
table between the demands with a given service class and L SPs with a given LSP class. Optionally, prioritize multiple
L SP classes within a service class. For information, see Creating Mappings Between Service Classes and L SP Classes,

on page 126.
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What to do next

Figure 39: Workflow Process for Creating Service Class to LSP Class Mappings

Create Demand
Service Classes

Assign Demand a
Service Class Property

Creating LSP Classes .

@ Create LSP Classes

Ser\ficecm; Service Class: E I Service Class LSP Class L
Service Classes ?@51 LSP Classes
Default
show All | |EX [ Showall | [Select Al
Name Name
1 AF 1 Default
2 BE 2 LSPClass_AF
3 Default 3 LSPClass_BE
4 EX

Map Service Class to LSP Class
and Prioritize LSP Classes for a
Given Service Class

Assign LSP an
LSP Class Property

Class: [Lspciass aF =] Service Class LSP Class Mapping

| Default
T I
LSPClass_BE

Show All | [Select All [*] [Filter [*] 4/4
LSP Class
1 LSPClass_AF

2 LSPClass_BE

Service Class Priority

381148

Creating LSP Classes

Step 1 Open the Manage QoS dialog box in one of two ways:
« Choose Edit > Manage QoS.

» Choose M anage QoS from the QoS drop-down menu in the Visualization toolbar.

Step 2 Click the L SP Class tab.

Step 3 In the LSP Classes area, click New.

Step 4 Enter the name of the LSP class, and click OK.
Step 5 Click OK in the Manage QoS dialog box.

Assigning LSP Classes to LSPs

Step 1
Step 2

Choose one or more L SPs.
Right-click one of the LSPs and choose Properties.
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Step 3 Choose the L SP class from the Class drop-down list and click OK.

Creating Mappings Between Service Classes and LSP Classes

Step 1 Open the Manage QoS dialog box in one of two ways:
* Choose Edit > Manage QoS.

 Choose M anage QoS from the QoS drop-down menu in the Visualization tool bar.
Step 2 Click the L SP Classtab.

Step 3 In the Service Class L SP Class Mapping area, click New.
Step 4 In the Service Class drop-down list, select the service class to which you are mapping L SP classes.

Service Class: |EX

Priority: 1
@ LSP Class: [Dgfault
faul
Brop De uu:.t.. -
I oK LSPClass_AF 2
. LSPClass_BE

Step 5 Enter apriority (number) for the LSP class. This determines the order in which the demand routes available L SPs. The
lower the number, the higher the priority.

Step 6 Click one of the following radio buttons:
« To map the selected service classto an LSP class, click L SP Class and select the class from the drop-down list.

* To set the mapping so the demand doesn’t reroute if LSPs are unavailable, click Drop. Drop should only be used
on the lowest priorities.

Step 7 Click OK, and then click OK again in the Manage QoS dialog box.

Private LSPs

WAE Design provides two ways to route sel ected traffic demands through specific L SPs. One way isto
dedicate the traffic for specific demands to a private LSP, which is a special L SP that carries those demands
only. Thistype of LSPmodelsan MPLS Layer 2 VPN, providing an exclusive route for the associated demands.
If the LSP goes down, all traffic associated with the L SP isinterrupted.

The other way to dedicate traffic to an LSP isto filter the demands that the L SP can carry. You can do this
by using the WAE Design tag feature to identify the desired demands, and then configuring the LSP with a
list of tagged values. Thistype of L SP makesit possible to route specific types of traffic over the LSP, and
the type of traffic is any arbitrary group that you define.
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To configure LSPs that simulate Layer 2 VPNS, use one of these two tools.

* Onetool creates dedicated demands for existing L SPs. The created demands will match the LSPsin
source and destination.

* Onetool creates private L SPsfrom existing demands. The created L SPswill match the existing demands
in source and destination.

The LSP Private property isset to T (true) in the LSPstable, and the Private LSP Node and Private LSP Name
properties in the Demands table are set.

Creating Private Demands for Existing LSPs

Step 1

Step 2
Step 3
Step 4
Step 5
Step 6
Step 7

L SPs must currently exist in the plan file.

LSPs: All ¥ |

Service Class: :Internet '

Set Demand Traffic to

@' LSP Setup BW
LSP traffic measurements

Zero

| Mark LSPs as private.

381081

If you are creating demands for only selected L SPs, select those L SPs from the LSP table. If they are tagged, you can
skip this step and specify the tag value in Step 3 instead. If you are creating demands for all LSPs, you can skip this step.

Choose Insert > L SPs> Demandsfor L SPs, or right-click in the plot and choose New > L SPs > Demands for L SPs.
Inthe LSPslist, choose All, Selected in table (Step 1), or Tag name .

Select the service class to which these L SPs belong.

Set the demand traffic to equal the L SP setup bandwidth, the L SP traffic measurements, or zero.

Check Mark L SPsasprivate.

Click OK. The newly created demands are highlighted in the Demands table.

Creating Private LSPs for Demands

Demands must currently exist in the plan file. See Traffic Demand Modeling, on page 43.
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Step 1

Step 2
Step 3
Step 4
Step 5
Step 6

Demands: ;All b

LSP Setup Bandwidth to

@ Demand traffic

Traffic Level: |morning v

Zero

381144

v | Mark LSPs as private.

If you are creating L SPs for only selected demands, select those demands from the Demands table. If they are tagged,
you can skip this step and specify the tag value in Step 3 instead.

ChooseInsert > L SPs> L SPsfor Demands, or right-click in the plot and choose New > L SPs> L SPsfor Demands.
In the Demands ist, choose All, Selected in table (Step 1), or Tag hame.

Set the bandwidth traffic to a specific traffic level or to zero.

Check Mark L SPsasprivate.

Click OK. The newly created L SPs are highlighted in the LSPs table.

Deleting Demands when Private LSPs are Deleted

Step 1
Step 2
Step 3

Step 4

You can choose to delete a demand when deleting a Private LSP. By default, when a private LSP is del eted,
the corresponding demand is not del eted.

Choose Edit > Network Options.
Click Advancedtab.
Under the Demands section, choose:

» Unrouted if the Private L SPs are unrouted
* Removed if the Private L SPs are removed

Click OK.

Configuring LSPs to Transport Specific Traffic Types

This section describes how to configure L SPsthat only route specific types of traffic. For example, you might
want to route traffic for avoice service class through an LSP with alow latency, and route traffic for an
Internet service class through another L SP with best-effort only. Such L SPsonly carry the specified demands,
but those demands might also be routed el sewhere.
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Step 1 In the Demands table, select and double-click the demands that you want to group.
a) Click the Tagstab.

If atag exists that you want to use, toggleits F (false) valueto T (true) to enable the tag for the selected demands. If
atag does not exist that you want to use, click New Tag.

Enter the name of the tag.
Click OK.

b) Click OK to save and exit the Properties dialog box.

Step 2 In the LSP table, select and double-click the L SPsthat are to transport demands that were tagged (Step 1).

a) Inthelnclude Any Demands Tags field, enter alist of demand tags and separate each entry with a semicolon.
b) Click OK.

Demand Mapping

| Only allow demands private to this LSP

Only allow demands containing these tags: video; voice

381124

Routing Inter-Area LSPs

In WAE Design, all nodesin asingle AS are assumed to belong to asingle IGP. If the plan file contains more
than one AS, al IGPs defined in these ASes are of the same type. For information on how nodes are assigned
to areas or levels, see Traffic Demand Modeling, on page 43.

Aninter-area LSP is an L SP whose source node and destination node have no areasin common. If available,
inter-area L SPs follow actual paths, regardless of whether doing so violates the required order of routing
through areas. For example, if following an actual path, an inter-area can enter and leave an OSPF area 0
more than once.

Other factors that determine how the inter-area L SPs are routed include whether the LSP typeis RSVP or
SR, and whether you have sel ected to require explicit hops at ABRs. (See Explicit Versus Dynamic Inter-Area
L SP Routing, on page 130.)

\)

Note Inter-areaFast Reroute L SPsand inter-areal GP shortcut L SPsare not supported. If the source and destination
nodes of a Fast Route LSP are in different areas, the LSP is not routed.

Order of Routing Through Areas

Regardless of the L SP type and whether explicit hops arerequired, inter-area L SPsroute through the backbone
areas, as follows, where “backbone” means area 0 for OSPF or the Level 2 areafor IS-IS.
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* If there are three or more areas, backbone areas must be between the source and destination nodes.
Typically, there are no more than three areas and therefore, the backbone area must be in the middle.
For example, an OSPF inter-area L SP would route from area 1 to area O (backbone) and then to area 2
(Figure 40: Example Inter-Area Routing Requiring Hops at ABRs, on page 131).

* If there are only two areas, there can only be one backbone area, and either the source or the destination
node must be in the backbone area.

Explicit Versus Dynamic Inter-Area LSP Routing

An OSPF ABR is anode that belongs to both area 0 and other OSPF areas. An 1S-1S ABR is anode that
belongs to both the Level 2 area and another 1S-1S level.

There are two modes of routing inter-area L SPs. One requires that explicit hops be set on ABR nodes. This
mode correctly simulates actual router behavior where ABR explicit hops are required. The other mode does
not require explicit hops at ABR nodes and can route an L SP fully dynamically across multiple areas. While
this mode does not simulate actual router behavior, it isuseful for planning inter-area L SP routes. For example,
you can use a fully dynamic simulation to find an appropriate path, which can then be converted into a
(routable) fully explicit path using other tools such as the Explicit L SP Pathsinitializer. These modes are
specified using the network option labeled “L SP routing requires ABR explicit hops.”

If this option is selected, inter-area L SPs are routed based on explicit hops set on the ABR nodes.

* Aninter-area RSVP L SP must contain a named path, and the named path must contain explicit hops at
ABRsfor each required area crossing.

* Aninter-area SR L SP must contain a segment list, and the segment list must contain explicit node hops
at ABRsfor each required area crossing.

If thisoption isnot selected, inter-area L SPsare routed dynamically and explicit hopsat ABRsare not required.
To leave one area and enter another, the inter-area L SP routes to the closest ABR in the current area that also
bordersthe areait is entering.

Example: Figure 40: Example Inter-Area Routing Requiring Hops at ABRs, on page 131 showstwo inter-area
L SPs selected, although only the L SP with explicit hops set on ABR nodes routes. The reason is because the
network option is set to require ABR hops when routing inter-area L SPs. Figure 41: Example Inter-Area
Routing Without Requiring ABRS, on page 131 shows that by deselecting this network option, the inter-area
L SP that does not have hops set at ABRS can dynamically route.
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Figure 40: Example Inter-Area Routing Requiring Hops at ABRs
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Simulation Modes

WAE Design lets you set global parameters that affect how L SPs are routed or rerouted. To access these
options, choose Edit > Network Optionsor click the Network Optionsicon in the Visualization toolbar.
Then click the Simulation tab.

G

-

By default, WAE Design simulatesthe state of the network onceit hasfully responded to afailure. Specifically,
thisisthe network state after L SPs have re-established new routes around the failure, and the IGP has fully
reconverged. Thisis called the IGP and LSP Reconvergence simulation mode.

Other simulation modes include Fast Reroute (FRR), Autobandwidth Convergence, and Autobandwidth
Convergence Including Failures. For information, see RSV P-TE Simulation, on page 135. For information on
the network option for rerouting of non-standby L1 circuit paths under failure, see Layer 1 Simulation, on
page 191.

The Optimization tools only work in IGP and L SP Reconvergence mode. If you try to run one whilein a
different convergence mode, you are prompted whether to continue, and if you do, the simulation changes to
|GP and L SP Reconvergence mode.

The status bar in the lower left of the GUI identifies which simulation modes you are currently using. Note
that unless specified otherwise, the documentation describes behavior in the IGP and L SP Reconvergence
mode.

LSP Establishment Order

WAE Design establishes L SPs in the order in which they appear in the plan. The routing of a specific LSP
might depend on previously established L SP routes. You can modify this order by changing arandom seed.
WAE Design then establishes L SPsin arandom order that is determined by this number. Although you cannot
predict the order based on the number, if you use the same number multiple times, WAE Design establishes
the LSPs in the same order each time. Varying the L SP establishment order |ets you check, for example,
whether certain orders result in higher utilizations.

LSF establishment order seed 17

AE113Y

Step 1 Choose Edit > Network Options or click the Network Optionsicon in the Visualization toolbar.
Step 2 Click the Simulation tab.
Step 3 In the LSPs area, enter a number in the L SP establishment order seed field. The default isO.

Step 4 Click OK.
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Reports and Diagnostics

LSP Path Reports

Step 1
Step 2
Step 3
Step 4

You can create reports on the L SP path routesthat the L SPis actually taking acrossboth L3 and L 1 topol ogies.
Each report identifies the compl ete path route, aswell as digjointnessinformation, including whether it contains
common nodes or common circuits. Additionally, the report contains all other columnsin an L SP Pathstable,
though they are initially hidden.

Select one or more L SP paths. If you do not select one, all LSP paths are used.

Choose Tools > Reports > L SP Path Routes.

Check one or both hop options, and click OK.

To export the report, right-click the Routes report name in the left Reports navigation pane, and choose Export Routes.

Simulation Diagnostics

To help troubleshoot RSVP LSP and L SP path simulations, WAE Design analyzes simulation routes and
providesreasonsfor certain types of routing behavior. The Simulation Diagnosticstool identifieswhy an LSP
is not routed, why an LSP is routed away from its actual path, and why an LSP is not following the shortest
TE path.

These routing diagnostics assume that all other L SPs, except for the one being tested, have been routed. That
is, WAE Design calculates whether an L SP can route on the actual path after all other routed L SPs have had
their bandwidth reserved.

Note that running areport overwrites the previous report of the same type. For example, an L SPs diagnostic
report would overwrite the previous L SPs report, but not the L SP Path diagnostic report.

Using Simulation Diagnostics to Troubleshoot

The following information is provided to help you troubleshoot L SP and L SP path issues.

Reason Description

Affinities The affinity settings prevent the LSP or L SP path from routing.

Available BW Thereisinsufficient bandwidth to route the L SP or LSP path.

Explicit Hops Theroute is determined by a named path that contains one or more explicit hops.

Hop Limit The hop limit istoo low.

Invalid Actua Path | The actual path isinvalid and cannot be interpreted as an L SP route.

No Actual Path The L SP does not have an actual path.
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Reason Description

No Attempt The LSP path is not routed because it is not a standby path and it is not the lowest
routable path option for the LSP.

No Destination Thereisno destination defined. The collected network might not contain the destination
node of the LSP.

Simulation Option | The simulation option for following actual pathsis not enabled.

TE not enabled There are interfaces that the LSP or L SP path traverses that are not TE enabled.

Topology The source and destination are disconnected.

Running LSP Simulation Diagnostics

Step 1 Choose one or more LSPs or L SP paths from their respective tables.
Step 2 Open the diagnostics information in one of two ways:

* Choose Tools > Diagnostics > L SP Simulation or L SP Path Simulation.

* Right-click the selection in the table and choose Simulation Diagnostics.
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RSVP-TE Simulation

This chapter describes how WAE Design simulates RSV P-TE routing. Unless otherwise noted, LSPs refer to
RSVP-TE L SPs. Note that WAE Design does not distinguish between LDP and RSVP-TE L SPs.

This section contains the following topics:

« Dynamic L SP Routing and CSPF, on page 135

* RSVP LSP Paths, on page 138

» Named Paths and Explicit LSP Routing , on page 140
« Actual Paths, on page 143

« Affinities, on page 144

» Simulation Modes, on page 148

» Advanced RSV P-TE LSP Simulations, on page 163

Dynamic LSP Routing and CSPF

If an LSP contains no L SP paths (also called MPLS TE tunnel paths), it is routed dynamically using CSPF.
The weights used for the CSPF cal culation are the TE metrics per interface. If the TE metric isnot configured
for an interface, the IGP metric is used.

If there are equal-cost routes, the following selection criteriaapply in this order:
 Bandwidth available—The route with the greatest reservable bandwidth is chosen.
 Hop count—The route with the fewest hopsis chosen.

» Random—If neither of the above criteria can be used, the route is randomly chosen.

CSPF properties are set in the LSP Properties dialog box and are viewable from the L SPs table.

CESFF

Satup bandwidth: v | Autobandwidth

Setp priceity: |7 v | Hold priority: |7

Hop limit: 2 TE Metric Disabibed E
b

* Setup Bandwidth—The amount of traffic the source node requests for this LSP in Mbps. The requested
bandwidth is available from the reservable bandwidth of each interface in the path.
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« Autobandwidth—Dynamically update the Setup BW Sim value when using the Autobandwidth
Convergence mode.

* Setup Priority—A priority for allocating reservable bandwidth. Thisisthe order in which the LSPs are
signaled. The lower the number, the higher the priority.

« Hold Priority—Priority that can preempt L SPs that are on the shortest path. Thisistypically set for a
particular service or traffic type. The lower the number, the higher the priority.

« Hop Limit—The maximum number of hops permitted in the LSP route. If no path is available with this
number of hops or fewer, the LSP is not routed.

» TE Metric Disabled—If checked, the LSP is routed using |GP metrics. If unchecked (default), the LSP
isrouted using TE metrics.

Interface MPLS Properties

Related MPLS properties are set in the MPL S tab of the interface or circuit Properties dialog box, and are
viewable in the Interfaces table.

T X

| Basic Advanced | MPLS | User | Tags

Selected Interfaces (1/32)

Reservable BW:
Reservable BW (%): 25
TE Metric: 10

Affinities: 0 Edit... 2

V| TE Enabled  [¥] FRR Enabled

8111

» TE Metric—Determines which path an L SP takes.

» TE Metric Sim—Derived column that shows the effective TE metric. If the TE Metric is empty, thisis
set to the IGP metric.

 TE Enabled—Identifies whether an L SP can be routed over the interface. If checked, the value is set to
T (True), and TE metricsare used in routing the L SP provided the LSP's TE Metric Disabled isunchecked
(False).

* Resv BW—Shows the amount of bandwidth that can be reserved by L SPs routed over the interface.

» Resv BW Percent—Shows the percentage of bandwidth that can be reserved by L SPs routed over the
interface.

* Resv BW Sim—Derived column.

* If aResv BW valueis entered, thisis copied to the Resv BW Sim column.
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* If Resv BW and Resv BW Percent are “na,” the Resv BW Sim is copied from the Capacity Sim
column.

* If Resv BW is“na,” but Resv BW Percent has avalue, the Resv BW Sim value is derived by this
formula:

Capacity Sim * (Resv BW Percent / 100)

If needed, you can change this behavior so that reserved bandwidth constraints are not used during
simulations, which could be useful for planning purposes. For information, see Ignoring Reservable
Bandwidths for Capacity Planning, on page 163.

« Affinities—Lists which affinities are set. For more information, see Affinities, on page 144.

« Loadshare—Valuefor redistributing either traffic across L SPs based on the ratio of this value with other
LSPsthat are paralel (have the same source and destination).

* FRR Enabled—Designated interface to be avoided by the FRR L SP. Only interfaces with this property
set are used by the FRR LSPsinitializer when creating FRR LSPs. This property does not affect FRR
L SPsthat are manually created. For more information, see Fast Reroute Simulations, on page 149.

To determine how much of theinterfacetraffic is contained in L SPs, show these columnsin the Interfaces
table. Thetotal of the two equals Traff Sim.

 Traff Sim LSP—The total amount of L SP traffic on the interface.
 Traff Sim Non L SP—The total amount of non-L SP traffic on the interface.

To determine which interfaces carry L SP traffic, sort the columns. To determine the demands associated
with one or more selected interfaces based on whether or not they have L SP traffic, right-click one and
choose Filter to Demands Through Interfaces. Then choose either In LSP or Not in L SP

Viewing LSP Reservations

To view the L SP reservations on the interfaces, choose L SP Reser vations from the Network Plot View in
the Visualization toolbar (Figure 42: L SP Reservations View, on page 137). Thewidth of the circuit displayed
in the network plot is set according to the Resv BW Sim column in the Interfacestable. The utilization colors
are based on the LSP Util column in the Interfacestable. The L SP Util isthe sum of all setup bandwidths for
al LSPsthrough the interface, as a percentage of the Resv BW Sim.

Figure 42: LSP Reservations View
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Interfaces |  Demands | ShortestPaths | Nodes | LSPs Sites

Show Al [Select All [ [Filter |v] 100/100 rows (0 selected) @]
Node Interface Resv BW Sim Remote Node  Traff Sim Capacity Sim LSP Resv 2

bii arllax to_cr2.hst 10000.00 cr2.hst 8579.39 10000.00 9836.27
2 erlsea to_crlsea 10000.00 crlsea 7090.98 10000.00 9274.01
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LSP Setup BW Initializer

Step 1
Step 2
Step 3
Step 4
Step 5

The LSP Setup BW Initializer cal culatesthe setup bandwidth for existing RSV P-TE L SPs. The setup bandwidth
is set to the maximum amount of demand traffic passing through the L SP for the traffic levels selected.

If using only onetraffic level, the best practiceisto use the Autobandwidth Convergence mode. For information,
see Advanced RSVP-TE L SP Simulations, on page 163.

Choose one ore more L SPs from the LSPs table.

Choose I nitializers > L SP Setup BW, or right-click one of the selected L SPs and choose L SP Setup BW I nitializer.
Choose which traffic level s to use for demand traffic.

Choose whether to set the load share values to be equal to the setup bandwidth.

Click OK.

RSVP LSP Paths

Like LSPs, L SP paths have CSPF properties, such as Setup Priority and Hop Limits. For a description of L SP
properties, see Dynamic L SP Routing and CSPF, on page 135.

If these properties are omitted, then they are inherited from the LSP. If these properties are set in the LSP
path, they override the L SP settings. Note, however, if operating in the Autobandwidth Convergence simulation
mode and if the L SP has Autobandwidth set to T (true), the L SP path Setup BW property (like the L SP Setup
BW) isignored, and the LSP’'s Setup BW Sim valueis calculated and used.

If an L SP path does not have an associated named path, it is routed dynamically. However, you can use named
pathsto fully or partialy describe a path from the L SP source to destination.

\}

Note This chapter refersto LSPs and L SP paths as dynamic , explicit , or loose explicit , depending on whether
their associated named paths have no defined hops, all hops defined, or only some hops defined.

Hot Standby

An LSP path can be defined asa“ hot” standby path. Standby paths are always established even if the associated
LSPisrouted using a path with a different path option. For RSV P L SPs, setup bandwidth, if any, is reserved
for them. These standby L SP paths are then immediately available should the currently routed path become
unavailable.
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| with the Same Route
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Example Response to Failures

Figure 43: Example RSV P L SP and Associated L SP Paths, on page 139 showsan RSVPLSP (crl.lon_cr2.fra)
that uses four LSP paths. The crl.lon_cr2.fraLSP has a primary and standby secondary path options (100
and 200), each with a setup bandwidth of 0. They are both established, using their defined named paths. Both
primary and secondary L SP paths have associated named paths, which appear in the Named Path column.
The other two paths do not have associated named paths, and so are dynamically routed.

Figure 43: Example RSVP LSP and Associated LSP Paths

| Interfaces [ Demands I Shortest Paths I Nodes LSPs LSP Paths Named Pathg
| Showall | [Select All [¥] [Filter [¥] 1/1 rows (0 selected)

1 crllon_cr2fra crllon crl.fra 125.00 100 crl.lon_cr2.fra_100

Name Source Destination Setup BW Active Path Named Paths

Interfaces | Demands | Nodes | LsPs | LSPPaths | sites | SRiGs | As

| Show All_| [Select All (¥ [Filter [¥] 4/4 rows (0 selected) _
LSP Path Name Setup BW Path Option  Standby
1 crlion_cr2fra  crllon_cr2.fra_100 0.00 100 T
2 crllon_cr2fra  crllon_cr2.fra_200 0.00 200 T
3 crllon_cr2fra na 300 F "
4 crllon_cr2.fra 0.00 400 F 5

This example L SP responds to failures as follows:

1
2.

If the primary path (crl.lon_cr2.fra_100) fails, the secondary path (crl.lon_cr2.fra 200) is used.

If both paths with associated name pathsfail, adynamic path is established with a reserved bandwidth of
125 Mbps, which it inherits from the LSP. This path is not set up initially becauseit is not a standby.

If al pathsfail, the path of last resort is a dynamic path with zero bandwidth. This ensures that thereis
aways an LSP up so that services relying on the L SP are always available.
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4. The simulation changesif the L SP Active Path has been set. For example, if crl.lon_cr2.fra 200 isthe
active path (that is, 200 appearsin the L SP's Active Path column), WAE Design usescrl.lon_cr2.fra 200
first, and then goes through the previous sequence.

Named Paths and Explicit LSP Routing

Named paths specify aroute though the network using an ordered list of adjacencies. The routeis defined by
named path hops, which can be nodes or interfaces, and each hop type specifies whether the route should be
strict, loose, or excluded. Named path hops can be nodes or interfaces. The hop type isidentified visually on
the plot, aswell aslisted in the Type column of the Named Path Hops table.

« Strict—The LSP must reach the named path hop directly from the previous one, with no intermediate
interfaces.

» Loose—The L SPisrouted to this hop from the previous hop using CSPF. Intermediate interfaces can
be used.

* Exclude—The node or interface is excluded from the L SP path. This hop type cannot be combined with
strict or loose hops in the same named path.

@ Strict

L) | Loose

p Exclude

The named paths and their hops are listed and sel ectable from the Named Paths and Named Path Hops tabl es.
The advantage of having separate tables is that you can have named paths that have missing or unresolved
hops. Also, the path name can be reserved even if it is not part of the WAE Design simulation.

Named Path Hops Example

Figure 44 Example Named Paths the crl.lon_cr2.fraLSP, on page 141 extends the earlier example (Figure
43: Example RSVP LSP and Associated L SP Paths, on page 139), showing two named paths for the
crl.lon_cr2.fraLSP. Thisshowsthat thefirst two L SP paths each have a named path. The naming convention
is<LSP_Name> <Path Option> , whichinthiscaseiscrl.lon cr2.fra 100 and crl.lon_cr2.fra 200.
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Figure 44: Example Named Paths the cr1.lon_cr2.fra LSP

Interfaces | LSPs | LSPPaths | Named Paths | |

[ Show All ] [Select All ‘F] [Filter "} 2/2 rows (0 selg
Name Source Active

1 crl.lon_cr2.fra_100 crllon T o

2 crllon_cr2.fra_200 crllon T F

The hops for each named path are defined in a separate table called Named Path Hops. Figure 45: Example
Named Path Hopsfor crl.lon_cr2.fra_100, on page 141 showsthe named path hopsfor thecrl.lon_cr2.fra 100
named path. The Steps column shows the hop order.

* Thefirst hop is an interface hop: astrict hop on the interface from crl.par to cr2.par.
* The second is a node hop, also strict, to cr2.par.
« Thethird hop is an interface hop: a strict hop on the interface from crl.frato cr2.fra

Hopsfor crl.lon_cr2.fra 200 are defined similarly.

Figure 45: Example Named Path Hops for cri.lon_cr2.fra_100

Interfaces | LSPs | LSPPaths | NamedPaths | Named Path Hops | Sitd
Show All | [ Select All |¥] [Filter |¥| 3/3 rows (0 selected)
Name Source Step Node Interface Type
1 crllon_cr2.fra_100 crl.lon 1 crl.par {to_cr2.par} strict
2 crllon_cr2.fra_100 crl.lon 2 cr2.par strict |,
3 crllon crd.fra 100 crl.lon 3 crl.fra {to cr2.fra} strict 2

Creating Named Paths and Their Hops

Named paths can be created in the WAE Design GUI in several ways.

@ Create associated named paths: $1 %2
($1 is LSP Name, $2 is Path Option)

* Check Create associated named pathswhen creating L SP paths. Using this option does not create hops.
» Use the Explicit LSP Paths Initializer. Using thisinitializer creates named paths with strict hops.
« Optimize L SP paths using the Explicit RSV P-TE L SP Optimization tool or RSVP-TE Optimizationtool.
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Editing Named Paths and Named Path Hops

Step 1

Step 2

Step 3

Step 4

Once the named paths are created, you can create, edit, or delete their named path hops. Note that discovered
named paths can contain unresolved hops, which are nodes and interfaces that are not in the plan file. For
information on resolving named paths, see Unresolved L SP Destinations and Hops, on page 176.

The recommended method of editing the named path hop type isto accessit directly from the Named Path
table as described in the following steps. Thisis the most efficient way of viewing the entire path. However,
if needed, you can double-click a named path hop in the Named Path Hops table, which takes you directly to
the named path hops Properties dialog box, which is described in Step 4.

In the Named Paths table, double-click a named path or right-click one and choose Properties.

Mame: cri.atl_crl.sjc_1

Source: gipa |at| v]
Mode: lcrl.atl *l i

v | Active g

Named path options:

* To change the name, enter it in the Name field.
« To change the source site or source nodes, choose them from the drop-down lists.

« To activate or deactivate, check Active.

Hop options:

« To add anew hop, choose an existing hop (if applicable) from the Hops list, and then click I nsert Before or Insert
After to determine where the new hop goes sequentially. Go to Step 4.

« To edit an existing hop, choose it from the Hops list and then click Edit. The Properties dialog box opens for named
path hops. Go to Step 4.

* To delete an existing hop, choose it from the Hops list, click Delete, and then OK. You heed not continue.
* To resolve nodes and interfaces that do not exist in the plan file, click Resolve. For information, see Resolving Plan

File to Objects, on page 177.

To continue creating or editing the named path hop, use the following options and then click OK

 As needed, choose the site, node, and interface. For node hops, do not choose an interface.

* Choose the named path hop type as Loose, Strict, or Exclude. See Named Paths and Explicit L SP Routing , on page
140 for a description of each.
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Actual Paths

In WAE Design, actual paths are the actual route that routed L SP paths are taking. They are read from the
live network, per LSP path. RSV P-TE routing is not always completely predictable because it depends on the
order in which LSPs are established and reserve their bandwidth on the network. WAE Design uses actual
pathsin L SP routing simulationsto match the current L SP routing state of anetwork as accurately aspossible.

When an LSP path is routed, the actual route is attempted first. If this routing fails due to CSPF constraints,
such as not enough reservable bandwidth or affinity restrictions, WAE Design reverts to the standard CSPF
routing algorithm.

Example: WAE Design routes all LSPsin its simulation according to the actual paths read from the network,
and the routings completely match the network. If acircuit fails, only the L SPsthrough this circuit are rerouted.
Because they cannot be established along their actual paths, standard CSPF is used. Theresult isa prediction
of incremental routing changes that would occur on the current network if such afailure were to occur.

It might be desirableto simulate a network without taking actual pathsinto account, for example, for long-term
planning. To achieve this, actual paths should simply be deleted. To delete an actual path, right-click an LSP
or LSP path and choose Delete Actual Paths.

An LSP or an L SP path might have a corresponding actual path. An LSP path with no actual path inheritsits
LSP actual path, if available.

Actua paths are represented as a series of interface hopsin the Actual Path Hops table. A hop isshownin
the network plot as a brown circle on the interface. To view an entire actual path of an LSP, choose View >
L SPs> Actual Paths; al hops are displayed when the L SP is selected.

Two columnsin the L SP table are useful to see the result of actual paths on L SP routing.

Column | Description

Actual | The simulation can only use actual pathsif they are resolved. If the network discovery was
incomplete, this might not be possible.

T =true; the simulation converted the actual path hopsinto a complete path from source to
destination of the LSP

 F =false; the simulation did not convert the actual path hops into a complete path

* na = not applicable; no actual path was available.
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Column | Description

Route * Actual = The LSP follows an actual path.
« Simulated = The L SP does not follow an actua path.

« Unrouted = Routing was not possible.

Deactivating Actual Paths for Simulations

Step 1
Step 2
Step 3

Step 4

WAE Design uses network statein its MPL S simulation, routing L SPs on actual paths where possible and
using L SP active path settings. For planning purposes, when stateis not relevant, you can change this behavior
to disregard actual paths.

LSPs

[¥] Use LSP actual paths, active paths |2

Choose Edit > Network Options or click the Network Optionsicon in the Visualization toolbar.
Click the Simulation tab.

To use or disregard actual paths and active pathsin MPLS simulation, check or uncheck Use L SP actual paths, active
paths.

Click OK.

Affinities

Affinities provide a mechanism for implementing L SP path diversity. By assigning affinities to physical
circuits and associating L SPs with affinities, you can implement avariety of routing policies. For example,
you can use affinities to restrict certain traffic to specific topological regions. Or you can force primary and
backup L SP paths onto different routes so they do not simultaneously fail.

WAE Design supports an unlimited number of 64-bit affinities, each of which is defined by a number and an
optional name. Named affinities are sometimes called administrative groups or link coloring .

The default plan files have 0-31 unnamed and unassigned affinities.
Workflow:

1. Creating and Editing Affinities, on page 145.

2. Assigning Affinitiesto Interfaces, on page 145.

3. Associating LSPs with Affinities, on page 146.
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Creating and Editing Affinities

Step 1 Choose Edit > Admin Groups.

Step 2 Modify an existing affinity number and name, or click New to add the number and name.
Affinity numbers must be unique. Affinity names are optional and must also be unique.

Step 3 Click OK.

Assigning Affinities to Interfaces

To use affinities, you must assign them to interfacesin away that encourages favorable routes and discourages
others. For example, continental paths might have one affinity and international paths have another.

[ asic | Advanced | MPLS | user [ Tags |
Selected Interfaces (4/100)
Edit affinities for 4 interfaces
- i | ShowAll | [SelectAll '¥] Filter
TE Metric: (Edit to change’ ' , =
Assigned Affinity Name
Affinities: 0 Edit...
T 0 Gold
T 1 Silver
| F 2 Bronze
Step 1 From the Interfaces table, choose one or more interfaces to which you are assigning the affinities.
Step 2 Double-click the selection or choose Edit > Properties.
Step 3 Click the MPL Stab.
a) Click the Affinities Edit button.
b) Inthe Include column, check the boxes for the affinities that you want to associate with the selected circuits. T =
true; associate the affinity with the circuit. F = false; do not associate the affinity.
c) Click OK.
Step 4 Click OK.

You can follow this procedure to assign affinities to interfaces through a circuit Properties dialog box. However, you

must choose and assign the affinity twice: once to each interface.
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Associating LSPs with Affinities

For affinitiesto influence L SP routing, you must associate L SPs with the affinities assigned to interfaces that
you want to include or excludein the routing process. If no affinity is specified, the L SP can be routed through
any path. Explicit routes can also have affinities for hops with a L oose relationship. (See Named Paths and
Explicit LSP Routing , on page 140.)

Inclusion and Exclusion Rules
* Include—Only use interfaces that include all affinities.
« Include Any—Use interfaces that include at |east one affinity.

» Exclude—Do not use interfaces with this affinity.

L SP paths inherit the L SP affinities. However, you can edit L SP path affinities to have priority over the LSP
affinities.

Figure 46: LSP Path Affinities

Affinities

Include: (Inherited)  Include Any: 1 Exclude: 2 | Edit..
Include: @) Inherit from LSP Use values from table below
Include Any: Inherit from LSP (@) Use values from table below
Exclude: Inherit from LSP (@ Use values from table below
[ Showall | [Selectall [« [Filter [v] 33/33 rows (1 selected)

Include Include ¢ Exclude Affini Name
F F 0 Gold

il F il Silver

F T 2 Bronze

408301

Example

This example (Figure 47: Example Affinities, on page 147) demonstrates how affinities affect the routing of
two L SPs with the same source and destination nodes.

» Theto_crl.nyc interface between wdc and nyc is assigned to both affinities 0 (Gold) and 1 (Silver). No
other interfaces are assigned affinities.

» LSP A isconfigured to exclude all interfaces assigned to affinity 0. Whileit cannot take the shortest path
using theto_crl.nyc interface, it can route around it.

» LSP B isnot associated with any affinities. Its LSP path is configured to include any interfaces assigned
to affinity 1 (Silver) and to exclude interfaces assigned to affinity 2 (Bronze). Because theto_crl.nyc
interface is assigned to both of these affinities, LSP B cannot route.
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Figure 47: Example Affinities
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Assigning LSPs to Affinities
Step 1 From the L SPs table, choose one or more L SPs to which you are associating the affinities.

Step 2 Double-click the selection or choose Edit > Properties.

Step 3 Click the Affinities tab.

Step 4 Choose the inclusion or exclusion rule for each affinity you are associating with the selected L SPs.
Step 5 Click OK.

Assigning LSP Paths to Affinities

Step 1 From the L SP Paths table, choose one or more L SP paths to which you are associating the affinities.

Step 2 Double-click the selection or choose Edit > Properties.

a) Click the Affinities Edit button. For each rule (Include, Include Any, Exclude), choose whether the L SP path should
inherit the L SP affinity rule or whether it should be based on rules defined in the table below these options.

b) If you chose to use the table, choose the rule for each affinity you are associating with the L SP path.
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c) Click OK.
Step 3 Click OK to save and edit.

Assigning Affinities When Creating LSP Meshes

You can associate affinities with L SPs when creating a new LSP mesh.

Step 1 Choose Insert > L SPs> L SP Mesh, or right-click in the plot and choose New > L SPs> L SP Mesh.

Step 2 Click the Affinities Edit button. Choose the inclusion or exclusion rule for each affinity you are associating with all
L SPsin the mesh, and click OK.

Step 3 Click OK to save and exit.

Simulation Modes

WAE Design lets you set several global parameters that affect how L SPs are routed or rerouted. To access
these options, either choose Edit > Networ k Optionsor click the Networ k Optionsiconin the Visualization
toolbar. Then click the Simulation tab.

[N

WAE Design supports four simulation modes for RSVP-TE LSPs:

* A Fast Reroute (FRR) mode using FRR L SPs, which is a common failure restoration mechanism used
by RSVP-TE LSPs. In alive network, FRR restoration typically occurs within milliseconds. See Fast
Reroute Simulations, on page 149.

« By default, WAE Design simulates the state of the network once it has fully responded to afailure.
Specifically, thisisthe network state after L SPs have re-established new routes around the failure, and
the IGP has fully reconverged. Thisis called the IGP and LSP Reconvergence simulation mode. The
Optimization tools only work in IGP and L SP Reconvergence mode.

« In the Autobandwidth Convergence mode, the network is simulated after the traffic (Traff Sim) has been
rerouted to other L SPs, but before the Setup BW Sim values have been reset. See Autobandwidth
Simulations, on page 159.

« In the Autobandwidth Convergence Including Failures mode, the network is simulated after the Setup
BW Sim values have been reset. See Autobandwidth Simulations, on page 159.

The status bar in the lower, | eft of the GUI identifies which simulation modes you are currently using. Unless
specified otherwise, the documentation describes behavior in the IGP and L SP Reconvergence mode.
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Fast Reroute Simulations

WAE Design simulates a Fast Reroute convergence mode using FRR LSPs. If afailure occursin the route of
aprotected RSVP-TE LSP, apresignaled FRR L SP (or bypass tunnel) forwards traffic locally around the
point of failure, typically from the nodejust before the failure to anode downstream. Thisrestoration mechanism
gives the source node (head-end) of the FRR L SP time to re-establish an aternate route around the failure.
This period is sometimes described as the 50 millisecond behavior of the network because FRR restoration
ideally becomes effective within approximately 50 milliseconds of afailure.

Routing of L SPsand demandsdiffer in FRR simulations compared to full convergence simulations, asfollows:

« The source node of the protected L SP does not reroute the traffic. If afailure occurs on anode or circuit
(link) within the L SP path, the following routing occurs:

« If an FRR L SP existsto protect afailed node or circuit, the protected L SP continues to be routed,
but its new path includes the FRR L SP route that redirects the traffic around the failure. Thistraffic
enters the FRR L SP’s source node just prior to the failure and rejoins the protected L SP path after
the failure at the FRR L SP's destination node.

* If the LSP is not protected by an FRR LSP, then the LSP traffic is not routed.

« Because there is no | GP reconvergence, demands through unrouted L SPs are unrouted. Additionally,
demands through failures outside of these L SPs are not routed.

FRR Fundamentals

This section summarizes key properties and terms, and how FRR LSPs are visualized in the network plot.
More detail s about these are further explained throughout the following sections. Note that FRR L SPs appear
in the same table as do regular LSPs and are identified in the Metric Type column as FRR.

Objects and Properties

Object |Type Property Description
LSP FRR LSP FRR Designated interface to be avoided by the FRR LSP.
Interface

FRR Type |Typeof FRR protection: Link or Node.

Autoroute FRR Enabled | Marks an LSP to be protected by FRR LSPs.
Forwarding Adjacency
Interface | na FRR Enabled | Marks an interface to be protected by FRR LSPs. This

property isrequired if an interface isto be used when
running the FRR LSPs initiaizer.

Terms

* Protected interface—An interface that is avoided when using FRR L SPs.

* Protected L SP—An LSP that would be rerouted through FRR LSPs in the event of failures. In WAE
Design, thisrequiresthe Fast Reroute simulation mode. To turn this mode on, accessthe Network Options
dialog box. For more information, see Running Fast Reroute Simulation, on page 158.
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* Protected SRLG—AnN SRLG that contains a protected interface.

Visualization

An unused FRR L SP path highlights in magenta when it is selected from the L SPs table. When routed, FRR
L SPs appear as a dashed magentaline.

Unused FRR LSP Path

bos
i e ——

bos
l// :
Fe @ "wdc =

Routed FRR LSP

FRR LSP Routing

The source and destination of an FRR L SP can be any pair of nodes, although in practice the source and
destination nodes are usually one hop (link protection) or two hops (node protection) apart. The source node
for the FRR L SP has a designated interface that is configured so that it is avoided during Fast Reroute
simulations. (Thisis the protected interface .)

Thisis configured using the FRR Interface property, which is set in the L SP Properties dialog box when
manually creating the FRR LSP, or it is automatically created when running the FRR LSPs initializer. The
initializer derivesit from interface FRR Enabled property.

Example: Thisfigure showsan FRR L SP sourced at §c, destined for nyc, and whose protected interface (FRR
Interface) isto_crl.okc. Therefore, the FRR LSP path routes towards chi and away from okc. If this FRR
Interface property wereto_crl.chi instead, the FRR L SP path would route sjc-okc-nyc, away from chi.
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Link and Node Protection .

chi
0 -—-
R
ﬁh::_r:- o
' okc e
LSPs

Source Destination Metric Type FRR Interface
crlsjc  crl.nyc FRR to_crl.okc =

Like other LSPs, FRR L SPs can use actual and named paths. Unlike other L SPs, they do not use setup
bandwidth when routing and they only use one L SP path.

Link and Node Protection

WAE Design supports both link (circuit) and node protection FRR LSPs. The type of protection showsin the
FRR Type column of the LSPs table.

LSPs
Metric Type  FRR Type
FRR Link
FRR Node

%
o
—

ol

« Link-protection L SPs—Protect an L SP from a circuit failure by routing an FRR LSP around the failed
circuit. The source node of the FRR L SPisthelocal node of thefailed circuit, and if configured correctly,
the destination of the FRR LSP is the remote node of the failed circuit. Figure 48: Example Full
Convergence Versus Fast Reroute with Link Protection, on page 152 shows an example of an LSP from
sic to nyc with afailure on the circuit between slc and hst. The top portion shows the Full Convergence
mode where the source node of the LSP is signaled to reroute the traffic. The lower portion shows that
alink-protection FRR LSP was set up for the slc-hst interface, and that the simulation is operating in
Fast Reroute mode. Here, slc reroutes the L SP traffic around the failed circuit.

 Node-protection L SPs—Protect an L SP from a node failure by routing an FRR L SP from the node one
hop prior to the failed node in the protected L SP path to the node one hop after the failed node. Figure
49: Example Full Convergence Versus Fast Reroute with Node Protection, on page 152 shows an example
of an LSP from gjc to nyc with afailure on the hst node. The top portion shows the Full Convergence
mode where the source node of the LSP is signaled to reroute the traffic. The lower portion shows that
anode-protection FRR LSP was set up to protect the hst node, and that the simulation is operating in
Fast Reroute mode. Here, the slc node reroutes the L SP traffic around the node failure.
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Figure 48: Example Full Convergence Versus Fast Reroute with Link Protection
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Figure 49: Example Full Convergence Versus Fast Reroute with Node Protection
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Figure 50: Example Fast Reroute without and with SRLG Protection, on page 153 In a network, if interfaces
are sourced from the same node (router) and are configured as an SRL G, an FRR L SP protecting one of these
interfaces can be configured to reroute around that interface. If possible, the FRR LSP avoidsall other interfaces
in the SRLG. In WAE Design, FRR L SPs can be configured to avoid all objects defined in the SRLG, not
just interfaces on the source node of the FRR L SP.
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Example: shows an example that uses the following setup:
* A protected L SP from cr2.hst to cr2.wdc.
* The protected interface isto_cr2.atl, and its source node is cr2.hst.
« An SRLG containing three circuits: cr2.hst_cr2.chi, cr2.hst_cr2.atl, and cr2.hst_cr2.mia.

* This SRLG has been configured on the cr2.hst node.
When the cr2.hst_cr2.atl circuit fails and there is no SRLG protection, circuits within the SRGL can be used

to reroute the LSP. When there is SRLG protection in place, the LSP is rerouted to avoid all circuits within
the SRLG.

Figure 50: Example Fast Reroute without and with SRLG Protection

Routing Around Failures
Assuming one or more failures occurred, the following decisions determine which FRR L SP to take.
Prerequisites:

 LSPs must be configured to be protected by FRR LSPs. For information on setting up FRR L SPs, see
Setting Up Fast Reroute Simulations, on page 154.

 Any interfaces along the FRR L SP path must be configured to be protected by FRR L SPs. For information
on protecting interfaces, see |dentifying L SPs for Protection, on page 154 or the FRR L SPs Initializer,
on page 155 (which automates the process of setting these).

Step 1 For each such interface on the L SP path, WAE Design checksfor an FRR L SP protecting that interface whose destination
is anode further down the path of the LSP.
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Step 2

Step 3

If more than one of these FRR L SPs exist, WAE Design chooses the one that is farthest down that path of the protected
L SP, thus simulating standard FRR behavior that prefers node protection over link protection.

If more than one eligible FRR L SP has the same destination farthest down the protected L SP path, the FRR L SP is chosen
arbitrarily among them.

If more failed circuits or nodes occur after this destination, further FRR L SPs are chosen in the same manner.

Setting Up Fast Reroute Simulations

Step 1
Step 2

Step 3

Step 4

Set appropriate properties on L SPs to mark them for protection. See Identifying L SPs for Protection, on page 154.

If protecting SRL Gs, associate anode with the SRLG in order to establish the protected interface within it. See ldentifying
SRLGs for Protection, on page 154.

If you are using the initializer to create FRR L SPs, identify which interfaces to protect. See FRR LSPs Initializer, on
page 155.

Create the FRR LSPs using the FRR L SPsiinitializer or manually. See FRR LSPs Initializer, on page 155 or Manually
Creating FRR L SPs, on page 157.

Identifying LSPs for Protection

To be marked for Fast Reroute protection, L SPs must have two properties set in the L SP Properties dialog
box.

* Routing type must be Autoroute or Forwarding Adjacency. The type appears as “autoroute” or “FA” in
the Metric Type column of the LSPs table.

» FRR Enabled must be checked. Thisappearsas T (true) in the FRR Enabled column of the LSPs table.
If thisis F (false), the LSPis not protected.

Identifying SRLGs for Protection

Step 1

To simulate arouter’s “ exclude protect” configuration, associate the source node of the protected circuit with
the SRLG. If that circuit fails, the FRR LSP reroutes around al circuits within that SRLG.

| Basic I Inventary SRLGs _ Lizer Tags ]
| Showall | |Selectall | [Filter ] 3/3 rows
Included SRLG
1| T Midwest_SRLG
2 ) F South_SRLG
3 AF North SRLG g

Right-click the source node of acircuit within an SRLG that you want to protect and choose Properties.
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Step 2 Click the SRL Gstah.
Step 3 Choose one or more SRL Gs with which you want to associate this node, and click OK.

FRR LSPs Initializer

The FRR LSPsinitializer automatically creates link-protection or node-protection FRR L SPs provided two
conditions are met:

» One or more L SPs have their FRR Enabled property set. (See Identifying L SPs for Protection, on page
154.)

 One or more interfaces on the path of these L SPs have their FRR Enabled property set. Thistellsthe
FRR LSPsinitializer how to create the FRR LSPs so that in the event of afailure, the interface would
be avoided when the LSP is being rerouted.

* Thisproperty is set in the MPLS tab of the interface Properties dialog box. The Interfaces table >
FRR Enabled column shows T (true) if the interface isincluded or F (false) if it is not.

» After FRR LSPs are created, the interface is listed in the LSPs table > FRR Interface column.

Interface Properties

lm[ Advanced T MPLS 'L user [ Interfaces
| Interface FRR Enabled
Selected Interfaces (2/32) o ebwae: [T
Reservable BWV: to_crlchi I
Reservable BW (%): 50
TE Metric: 10
Affinities: 0
/| TEEnabled  [¥| FRR Enabled
FRR LSPs Initializer Uses this Interface -

FRR Simulations Route Away from this Interface

Theinitializer createsthe FRR L SPs based on these FRR Enabled properties and based on whether you choose
to create link or node protection.

« Link protection—WAE Design creates FRR L SPsfor each pair of next-hop nodes (two connected nodes)
in the protected L SP path where the egress interface of the first hop has its FRR Enabled property set
(Figure 51: Example Link-Protection FRR L SPs Automatically Created, on page 156).

* Node protection—WAE Design creates FRR L SPs between each set of next next-hop nodes (three
connected nodes) in the protected L SP path where the egress interface by of the first hop hasits FRR
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B FRRLSPs itializer

Enabled property set (Figure 52: Example Node-Protection FRR LSPs Automatically Created, on page
157).

These new FRR LSPs are named FRR_<source> _<destination> _<postfix> , where postfix is optional and
set in theinitializer's dialog box.

Figure 51: Example Link-Protection FRR LSPs Automatically Created

Protected LSP

chi bos nyc
) | . ]—"_ 1w . - || j= . »f . ) L | Ta .
¥ ¥ b

Interface FRR Enabled ':
for Link Protection L

Link-Protection FRR LSPs Created

chi chi bos 582 chi bos e
. .

- — - -] |- - E—— - ——  § | | - — 0
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Figure 52: Example Node-Protection FRR LSPs Automatically Created

Running the FRR LSPs Initializer .
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Running the FRR LSPs Initializer

Step 1 Choose one or more nodes. If you do not choose any nodes, the initializer uses all nodesin the plan file.
[¥] Link Protection
¥] Mode Protection
Mame (FRR_source_destination_postfix)
Postfi:  Obi =
|| Delete current FRR LSPs =
Step 2 Choose Initializers> FRR L SPs.
Step 3 Choose whether to create FRR LSPs that protect links (circuits), nodes, or both.
Step 4 (Optional) Enter a postfix to add to the end of the names of the newly created FRR L SPs.
Step 5 Click OK.

Manually Creating FRR LSPs

381028

This section describes the required properties for an FRR LSP. It does not describe all the options available

when creating an LSP.
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Step 1 ChooseInsert > LSPs> L SP, or right-click in an empty area and choose New > L SPs> L SP. Alternatively, you can
choose an existing L SP to modify to be an FRR LSP. If so, right-click the L SP and choose Properties.

Source Destination

vl V] site: | oke

Mode: |crl.okc

MetInt Destination:

Site: |chi

Mode: |cr1.chi '|

38107G

Step 2 Choose the source site and node of the FRR LSP.

Step 3 Choose the destination site and node, or enter a Netlnt destination |P address. For information on NetInt destination 1P
addresses, see Unresolved L SP Destinations and Hops, on page 176.

Routing
| Fast Reroute -
Metric value: Load Share
Active Path: lot set i tor bos
R R’ _..--__d z .I I I & . L\l“q . »
FRR Interface: |to_cri.oke v |  Netint FRRInterface: N | |
to_crl.bos F v
to_cri.okc >
to_crl.sea Interface to Route |
Away from in |
FRR Routing
&g
[ S e ma——— ) ([
okc Z S
Step 4 In the Routing area, choose Fast Reroute asthe LSP type.

Step 5 Specify the interface that is to be avoided during routing by choosing it from the FRR Interface drop-down list or by
entering its |P address in the Netint FRR Interface field.

Step 6 Click OK.

Running Fast Reroute Simulation

FRR LSPs are routed only when simulating failuresin the Fast Reroute simulation mode. To enable the Fast
Reroute simulation mode, follow these steps.
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Autobandwidth Simulations .

Simulation Convergence Mode

Layer 3

'_Fast Reroute

408201

Step 1 Choose Edit > Network Options or click the Network Optionsicon in the Visualization toolbar.
Step 2 Click the Simulation tab.
Step 3 Choose Layer 3 Fast Reroute and click OK.

Autobandwidth Simulations

In a network, autobandwidth-enabled L SPs reset their setup bandwidth periodically based on the configured
autobandwidth timers, and establish new routesif necessary. In networkswith constrained bandwidth, changes
in LSP routes can make other L SPs unroutable, which can then affect the amount of traffic in each LSP, the

setup bandwidth settings, and the routes taken, without ever converging.

While WAE Design does not simulate thisinstability, it does simulate autobandwidth-enabled LSPs. In this
simulation mode, internally WAE Design first routes the autobandwidth-enabled L SPswith a setup bandwidth
of zero. Then, demands are routed to determine the simulated traffic (Traff Sim) through each LSP. Theresult
in the plan file and GUI is that the Traff Sim value is copied to the Setup BW Sim for each
autobandwidth-enabled L SP, and these L SPs are then routed using their new Setup BW Sim value. Note that
if some L SPs cannot be routed, the Traff Sim and Setup BW Sim values resulting from this process might
not match one another for all autobandwidth-enabled L SPs.

There are two autobandwidth simulation modes available. Before simulating failures or running Simulation
Analysis on autobandwidth-enabled L SPs, choose the appropriate mode depending on which state you need
to smulate.

* In the Autobandwidth Convergence mode, the network is simulated after the traffic (Traff Sim) has been
rerouted to other L SPs, but before the Setup BW Sim values have been reset. Thissimulatestheimmediate,
less optimal response to failures.

* In the Autobandwidth Convergence Including Failures mode, the network is simulated after the Setup
BW Sim values have been reset. This simulates the longer, more optimal response to failures.

Note

The Autobandwidth Convergence and Autobandwidth Convergence Including Failures simulation modes are
only available in plan files with asingle traffic level.

These autobandwidth simulations require that the L SPs have their Autobandwidth property setto T (True),
and that one of the two autobandwidth modes be selected from the Network Options dialog box.
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CSPF

Setup bandwidth: V| Autobandwidth

i

Simulation Convergence Mode
Layer 3

Autobandwidth convergence
Fast Rerou

Autobandwidth convergence (including failures)

Example Autobandwidth Convergence Without and with Failures
The network in this example has the following parameters:
* One demand from erl.chi to crl.wdc.
* Two LSPs: LSP-A from crl.chi to crl.wdc and LSP-B from cr2.chi to crl.wdc.
* Neither of these L SPs has a Setup BW.

« All circuits have a 10,000 Mbps capacity except for one (between cr2.chi and crl.wdc), which isonly
1000 Mbps.

Demands
Source  Destination Traffic Circuits

erlchi  crlwdc 5000.00 Node A NodeB  Capacity Sim
o1k . :“,Z criwde || €réchi crlwde 1000.00
e - erlchi  crlchi 10000.00
-M:;:j:::.zlm erlchi  cr2.chi 10000.00
. Sy alchi  cr2.chi 10000.00
. ' ““::;"3--: D ||erlchi crlwde 10000.00 |,
ert.ch A ' S @R achi arlwdc 1000000 |

* Figure 53: Example L SP Routing Using IGP and L SP Reconvergence and Using Autobandwidth
Convergence, on page 161 showsthat in the |GP and L SP Reconvergence mode, the Setup BW Sim value
for both LSPsisO.

. Cisco WAE Design 7.4.0 User Guide
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Example Autobandwidth Convergence Without and with Failures .

* In the Autobandwidth Convergence mode, the Setup BW Sim value for LSP-A is copied from its
Traff Sim value, which is 5000.

* There are no failures, and each L SP follows the same route in both convergence modes.

« Figure 54: Example Autobandwidth Convergence with Failures, on page 162 shows the Autobandwidth
Convergence mode when there is afailure.

* Failing the circuit between crl.chi and crl.wdc causes L SP-A to reroute through cr2.chi.

* The shortest path from erl.chi through crl.chi is now longer than the shortest path from erl.chi
through cr2.chi, and so the demand moves over to LSP-B. Thisis shown in the L SPs table where
the traffic (Traff Sim) of LSP-A ismoved to LSP-B.

* Becausethe smaller of thetwo circuitsis congested, L SP-A usesthelarger circuit, which hasenough
capacity to carry the traffic.

* LSP-B continues to route on the lower capacity circuit, thus causing congestion.

* The Setup BW Sim value is not updated for either L SP because the Autobandwidth Convergence
mode does not update setup bandwidth as aresult of traffic shifts due to failure.

* Figure 55: Example Autobandwidth Convergence Including Failures, on page 162 showsthe samefailure
in Autobandwidth Convergence Including Failures mode.

» The LSP-B Setup BW Sim is updated to the Traff Sim value, forcing it to take the larger circuit to
reach its destination. Note that the plot shows both the normal (solid) and failure (dashed) route for
L SP-B, indicating that it has rerouted under the failure, even though the failure did not interrupt its
path.

* The demand continues to route on L SP-B, but because the L SP has found a path with sufficient
capacity, there is no more congestion.

Figure 53: Example LSP Routing Using IGP and LSP Reconvergence and Using Autobandwidth Convergence

m LSPs
Bimulation Convergence Mode Name  Source Destination Setup BW | Setup BW Sim  Traff Sim | Autobandwidth
Layer 3 LSP-A  crlchi crlwdc na 0.00 5000.00|T
LSP-B cr2.chi crlwdc na 0.00 0.00|T
[IGP and LSP reconvergence
cri.chi A—< crl.wdc
erlchi = » I :A cr2.chi
LSPs
- JSimulation Convergence Mode Name  Source Destination Setup BW [Setup BW Sim  Traff Sim | Autobandwidth
LSP-A  crlchi crlwdc na 5000.00 5000.00|T
Layer 3
LSP-B cra.chi crlwdc na 0.00 0.00|T
[Auhobandwidih convergence §
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Figure 54: Example Autobandwidth Convergence with Failures
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Figure 55: Example Autobandwidth Convergence Including Failures
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Advanced RSVP-TE LSP Simulations .

Advanced RSVP-TE LSP Simulations

Ignoring Reservable Bandwidths for Capacity Planning

Step 1
Step 2

Example

When using WAE Design for capacity planning, it iscommon to increase the demand traffic to alevel expected
at afuture date. Various simulations are then performed, such asfailures and worst-case analysis, to determine
which circuits will likely experience over-utilization.

In MPLS networksusing RSVP-TE L SPs, a setup bandwidth is configured for each LSP. If the demand traffic
isincreased, L SP setup bandwidths are usually increased correspondingly (for example, by using the LSP
Setup Bandwidth initializer). When these L SP setup bandwidths become too large, some L SPs might not be
routable, thus rendering an improbable view of the future network. When this occurs, you have the option to
temporarily remove the reservable bandwidth constraints for a more realistic view into future capacity
requirements. Whilethisis not arouting method that actually existson routers, it isaconvenient WAE Design
simulation that can assist you when planning networks.

When you enable this routing mode, WAE Design routes L SPs in the order they appear in the plan file LSPs
table, as described in the following steps. Note that static order of the LSPstablein the plan filelikely differs
from the order of LSPsin the GUI, which changes frequently due to user interaction. For information on
tablesin plans files, see the Cisco WAE Design Integration and Devel opment Guide .

This operates only on L SPs that do not have autobandwidth enabled.

Route L SPs as usual. (For information, see Dynamic L SP Routing and CSPF, on page 135.)
If an LSP is not routable (call it “LSP-A”), try to route it with zero setup bandwidth.

* If LSP-A cannot be routed, leave it unrouted and try to route the next LSP in the LSPs table. If this L SP cannot be
routed, try to route the next LSP listed in the LSPstable in the plan file.

« If LSP-A can berouted, then there will be one or moreinterfaces on its route whose reservabl e bandwidth is exceeded.
Theseinterfaces are marked as having unlimited reservabl e bandwidth during the simulation of all subsequent L SPs,
thus alowing for the routing of LSP-A and other L SPs that would otherwise exceed the reservable bandwidth on
these interfaces. Note that actual Resv BW and Resv BW Sim valuesin the I nterfaces table do not change.

On completion of the simulation, a number of interfaces will have their reserved bandwidth greater than their configured
reservable bandwidth. The circuits containing these interfaces are candidates for capacity expansion.

In this example, there are four L SPs, each with a setup bandwidth (Setup BW) of 600 Mbps. All interfaces
have a reservable bandwidth (Resv BW) of 1000 Mbps.

*LSPs
e LSP-1, LSP-2, and LSP-3 go from LON to FRA.

* LSP-4 goes from LON to ROM.

* |GP metrics
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* |nterfaces between PAR and FRA, and interfaces between FRA and ROM have an | GP metric of

2.

* All other interfaces have an |GP metric of 1.

Figure 56: Comparison of Reservable Bandwidth Being Used vs Not Being Used, on page 164 showsthe L SP
Reservations view of this simple network in both simulations modes: the usual where reservable bandwidths
are observed and the capacity planning version wherein they areignored. In this latter mode, the two purple
circuitsindicate they are being over utilized and likely need their capacity increased. (For information on the

L SP Reservations view, see Viewing L SP Reservations, on page 137.)

Figure 56: Comparison of Reservable Bandwidth Being Used vs Not Being Used

L AMS LOM AMS
| eer—" — <8 - E— <0
. ' i L
,- PAR , i PAR H
| r— —————— " | re—— <0
. FRA " ' FRA
B - g = . | L 1 ! + [ nm- L 1 L I ER |

MAD ROM MAD ROM

Reservable Bandwidth Mode Capacity Planning Mode Where

Reservable Bandwidth Is Ignored

Figure 57: Simulated Routing Using Reservable Bandwidth Constraints, on page 165 demonstrates routing

simulations where reservabl e bandwidth constraints are applied, which is the default behavior.

 LSP-1 routes across LON-AMS-FRA, leaving circuits LON-AMS and AMS-FRA each with only 400

Mbps of available bandwidth.

* LSP-2 routes across LON-PAR-FRA, leaving circuits LON-PAR and PAR-FRA each with only 400
Mbps of available bandwidth.

« L SP-3 cannot be routed because there is not enough available bandwidth on LON-AMS or LON-PAR.

Its Setup BW Sim value in the LSPstable is set to “na’ and the Routed column is set to “ Unrouted.”

« L SP-4 cannot be routed, again because there is not enough available bandwidth. Its Setup BW Sim value

inthe LSPstableis set to “na’ and the Routed columnis set to “Unrouted.”
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Figure 57: Simulated Routing Using Reservable Bandwidth Constraints

U AMS L AMS U AMS L AMS
—“-l R o —— R B — J« B ﬂ PO E——
‘1‘ PAR l Epm ‘ ;: PAR PAR |
u - . I——‘Z ] ~-—w-z B 1:::‘2 | erem—m — ull |
[ FRAT y FRAS N FRAST FRA |
J | ] i E
J IR US| L | k
| seere——" —— | m - ) e —— | C - | | rer—— ——— ;
MAD ROM MAD ROM MAD ROM MAD
LSP-1 LSP-2 LSP-3 (Unrouted) LSP-4 (Unrouted)
Interfaces
Node Interface ResvBW  ResvBW Sim Remote Node
crllon  to_crlpar 1000.00 1000.00 crl.par
crlams to_crlfra 1000.00 1000.00 crl.fra
crlpar to_crl.fra 1000.00 1000.00 crl.fra
cllon  to_crlams 1000.00 1000.00 crl.ams
LSPs
Name  Source Destination Setup BW Setup BW Sim Routed
LSP-1 cllon  crlfra 600.00 600.00 Simulated
LSP-2 cllon crlfra 600.00 600.00 Simulated
~
LSP-3 crllon  crlfra 600.00 na Unrouted |2
LSP-4  crllon  crirom 600.00 na Unrouted )&

In Figure 58: Simulated Routing Without Using Reservable Bandwidth Constraints, on page 166, the use of
reservable bandwidth constraints has been disabled. The L SP routes are now as follows.

» Aswith the default behavior, LSP-1 routes across LON-AMS-FRA and L SP-2 routes across
LON-PAR-FRA.

« Onceit is determined that there is not enough reservable bandwidth for LSP-3 to route, it takes the
shortest path, LON-AMS-FRA. Thereservable bandwidth oninterfacesL ON-to-AMSand AM S-to-FRA
isignored for the remainder of this simulation. LSP-3's Setup BW Sim value in the LSPstableis set to
600.

 LSP-4 routes across LON-AMS-FRA-ROM because these reservable bandwidth constraints have been
removed and because it is the only route available. Even though LON-PAR-MAD-ROM is the shortest
path, there is not enough reservable bandwidth on LON-to-PAR or PAR-to-FRA. LSP-4's Setup BW
Simvaluein the LSPstableis set to 600.
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Figure 58: Simulated Routing Without Using Reservable Bandwidth Constraints
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If, however, L SP-4 were routed before L SP-3, then L SP-4 would route across its shortest path of
LON-PAR-MAD-ROM, and the LON-to-PAR interface would have its reservable bandwidth constraint
ignored. With this routing, L SP-3 would still route LON-AMS-FRA, and the interfaces LON-to-AMS and
AMS-to-FRA would still be set to remove their reservable bandwidth constraint.
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Enabling Capacity Planning Mode for LSPs

To ignore reservable bandwidth constraints in routing simulations, follow these steps.
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Step 1
Step 2
Step 3

P2MP LSPs

p2mpLsps ||

LA+E]

N

[¥] LSP capacity planning mode
Ingore interface reservable BW constraints if necessary to route LSPs

34

3an

Choose Edit > Network Options, or click the Networ k Optionsicon in the Visualization tool bar.

Click the Simulation tab.
Check L SP capacity planning mode, thus ignoring reservable bandwidth constraints, and click OK.

Point-to-multipoint (P2MP) LSPs offer an MPLS alternative to |P multicast for setting up multiple pathsto
multiplelocationsfrom asingle source. In live networks, the signal is sent once across the network and packets
arereplicated only at the relevant or designated branching MPL S nodes.

A P2MP LSP consists of two or more sub-L SPs that have the same source node. Most of WAE Design refers
to sub-LSPs as L SPs, and there is no distinction between the two.

To view the P2MP LSPs or their associated sub-L SPs, choose them from the P2MP L SPs and L SPs tables.

 To determineif an L SP belongsto a P2MP L SP, you can show the P2MP L SP column in the L SPstable.
You can also right-click an LSP and choose Filter to P2M P L SPs.

* To determine which L SPs belong to a P2MP L SP, you can visually see them by choosing the P2MP LSP
from the P2MP L SPs table. You can aso right-click a P2MP L SP and choose Filter to sub L SPs.

Figure 59: P2MP LSP with chi as the Source for Three Destinations
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Plotting P2ZMP LSPs

Step 1 In the P2MP L SPs table, choose one or more P2MP L SPs.
Step 2 Right-click and choose Plot P2M P L SPs.
Step 3 To move the plot horizontally or vertically, use the left/right arrows and up/down arrows.

Step 4 To choose all P2MP L SPs within the plot, click Select P2M P L SPs. To deselect al of these P2MP LSPs, click in an
empty plot area.

Step 5 To visualize multilayer L1 paths when plotting P2M P L SPs, use the following drop-down options:
» L3—Displaysthe path in terms of interfaces.

» L1—Displaysthe path in terms of L1 links.

To better align the L1 links, WAE Design checks for L3-L 1 links. If they do not exist, WAE Design checks for
collocated L3/L 1 nodes within sites.

e L3+L1—Displaysthe L3 plot above and the L1 plot below.

WAE Design does not perform alignment between L3 and L1 nodes. When you click an L3 interface, the associated
L1 links are highlighted automatically.

P2MP LSP Bandwidth

All sub-L SPswithin a given P2M P L SP share bandwidth and therefore, common circuits between these
sub-L SPs have the same bandwidth, rather than an aggregate. Common practiceisto set all sub-L SPswithin
aP2MP L SP to the same bandwidth. Otherwise, the bandwidth for the shared circuit isthe highest bandwidth
Set.

To see the reserved L SP bandwidth, show the LSP Resv column in the I nterfaces table. You can also view
the associated traffic by choosing L SP Reservationsin the Network Plot menu in the Visualization tool bar.
For more information, see Viewing L SP Reservations, on page 137.

Example: If A-C LSP and A-D L SP each have a bandwidth 400 Mbps, the A-B circuit has an aggregate
bandwidth of 800 Mbps (Figure 60: Bandwidth Behavior Without a P2MP L SP, on page 169). Howevey, if
A-C and A-D are sub-L SPswithin a P2MP L SP, the A-B circuit has a bandwidth of 400 Mbps (Figure 61:
Bandwidth Behavior with a P2MP L SP, on page 170).
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Figure 60: Bandwidth Behavior Without a P2MP LSP
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Figure 61: Bandwidth Behavior with a P2MP LSP
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P2MP LSP Demands

Demandsrouted through P2M P L SPs must have the same source asthe P2M P L SP; the demand then terminates
at each of the P2MP L SP destinations. No other demands can go through the P2MP L SP except for the one
created for it. If the P2MP L SP fails, its demand cannot be routed. (See Creating Demands for P2MP L SPs,
on page 175 for information on creating these demands.)

Demands must be private to the P2MP LSP. This privacy is automatically created when you insert a demand

for aP2MP LSP.

For complex P2MP L SP demands, filter to the demand, right-click the demand, and choose Plot Demand.
Figure 62: Example Demand Plot for P2MP LSP, on page 171 shows an example of a demand plot for the
P2MP L SP shown in Figure 59: P2MP L SP with chi as the Source for Three Destinations, on page 167 .
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Figure 62: Example Demand Plot for P2MP LSP
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Explicit P2ZMP LSP Path Initializer

The Explicit P2MP LSP Paths Initializer automates the process of creating explicitly routed sub-L SP paths,
asfollows:

« Convert a set of dynamically routed sub-L SPs to explicitly routed sub-L SPs along their current paths.

* Create digoint paths. Two PSMP L SP paths are digoint if they do not route over common objects. These
objects are configurable and can be circuits, nodes, sites, SRLGs, or L1 links.

* Create digoint paths between sub-L SPs that have the same destination and whose P2MP L SPs
belong to the same disjoint P2MP LSP group. Thisis useful for creating an alternate path if one of
the sub-L SP paths becomes unavailable.

Example: Figure 63: Example Digjoint Paths for P2MP L SPs, on page 172 shows two P2MP L SPs
(Region A and Region B) that are in the same digjoint group. Their sub-L SPs share two common
destinations: bosand atl. Upon choosing this option, the sub-L SPsin Region B arererouted to arrive
at the common destinations using different explicit paths.

* Create digoint primary and secondary paths for selected sub-L SPs.
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Figure 63: Example Disjoint Paths for P2MP LSPs
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Note Explicit P2MP LSP Paths Initializer supports Inter-Area functionality.

WAE Design creates named paths and named path hops for the sub-L SP paths. After running the initializer,
you can verify the named paths and their hops in the Named Paths and Named Path Hops tabl es.

« If you choose adisjoint option that creates secondary paths, the secondary named path followsthe shortest
aternate sub-L SP path that is disjoint from the primary path, according to rules that you specify.

* Orphaned named paths are del eted.

* Explicit paths are named <Sub-LSP Name> _<Path Option>.

Prerequisites:

* The plan file must aready contain the L SP paths.

« If creating digoint paths between P2MP L SPs in the same digjoint group, the P2MP L SPs must first be
added to the digjoint group in the P2MP L SP Properties dialog box. Here, you can also assign priorities
to P2MP L SPswithin these groups. Higher priority P2MP L SPs are assigned shorter routes based on the

TE metric. The higher the number, the lower the priority.

Step 1 From the P2MP L SPs table, choose the P2MP L SPsto initialize with explicit named paths. If you do not choose any

P2MP LSPs, all sub-L SP paths are used for creating the named paths.
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Step 2
Step 3

Creating P2MP LSPs and Sub-LSPs .

Choose I nitializers > Explicit P2M P L SP Paths, or right-click a P2MP LSP and choose Explicit Path I nitializer.
Specify how to create the explicitly routed named paths, and then click OK.

* To create named pathsfor al currently simulated primary or standby sub-L SP paths, click Follow currently simulated
routes.

Create fully explicit P2MP LSP paths for (1/2) selected P2ZMP LSPs

Route Selection

81116

@ Follow currently simulated routes

* To create digoint paths, choose whether to create them between disjoint PSMP L SPs that have sub-L SPs with the
same destination, or between disjoint primary and secondary sub-L SP paths.

Modify current routes to

Create disjoint paths between P2ZMP LSPs in Disjoint Groups
=" for sub-LSPs with matching destinations =

38111

| Create disjoint primary and secondary paths for sub-LSFs

» To modify the digjoint priorities that determine which objects are considered in paths, click Edit. Choose 1, 2, 3, or
Ignore, where the lower the number, the higher the priority. Click OK.

Example: If you give circuits apriority of 1, SRLGs a priority of 2, and ignore the other objects, when the digjoint paths
are created, WAE Design first creates paths with digjoint circuits. Then, if there are common SRLGs in those paths, it
creates paths so the SRLGs are digjoint. The remaining objects are not considered in the digoint path creating.

Disjoint owver: Circuits, SELGs Edit... |

N3 Edit Disjoint Priorities ]

Circuits ._l - SRLGs ;2 ':

Nodes _.lgm:re ¥| L1Links _'igrmre =

381084

Sites | lgnore - _.

Creating P2MP LSPs and Sub-LSPs

Rules and guidelines:
* All sub-L SPs within a given P2MP L SP must have the same source site and source node.

* Because sub-L SPs within a P2MP L SP share setup bandwidth, typically bandwidth is set to the same
vaue for each sub-LSP,
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Creating P2MP LSPs

Step 1

Step 2
Step 3

Create an empty P2MP LSP.

a) Chooselnsert > LSPs>P2MP L SP, or right-click in the plot and choose New > L SPs> P2MP L SP.

b) Enter aunique P2MP LSP name. If you do not enter a name, WAE Design creates one using the format
p2mp_lsp_<source node> .

¢) Choose the source site and node. This selection is the root for all sub-L SPs contained in this P2MP LSP,

d) (Optional) Enter or choose adisjoint group and disjoint priority for WAE Design to consider when using the Explicit
P2MP L SP Path Initializer.

Name: East_Region

Source

Site: | atl - |

MNode: |cr1.atl b |

Disjoint Group:  Voice e d

381141

Disjoint Priority:

If you have not done so, create sub-L SPs for the P2MP LSP.

Associate the sub-L SPsto the P2MP L SP. You can follow these steps individually, or you can choose multiple sub-L SPs

and edit them collectively.

a) Double-click the sub-LSPs from the LSP table.

b) Inthe Sub-LSP of P2MP LSPist (at the bottom), choose the P2MP L SP to which you want these L SPs to belong.
Then click OK.

Creating Sub-LSPs

Step 1
Step 2

Step 3
Step 4

Step 5

Choose Insert > L SPs> L SP, or right-click in the plot and choose New > L SPs> L SP.

Choose the site and node that will be the source of the P2MP LSP. All sub-LSPsin a P2MP LSP must have the same
source site and source node.

Choose the site and node that are the final destination for the sub-LSP.

Compl ete the remaining optional fields and tabs, as needed. Because sub-L SPs share bandwidth, typically the CSPF
Setup Bandwidth field is set to the same value for each sub-LSP in the P2MP L SP.

If you have already created the P2M P L SP to which this sub-L SP will belong, choose that P2M P L SP from the Sub-L SP
of P2MP LSPlist (at the bottom). Then click OK.

Creating a Mesh of Sub-LSPs

Step 1

For each node that will be the egress node of the P2MP L SP, create the same tag name.
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a) Inthe Nodestable, choose and then double-click all nodes that will be included in the P2MP LSP.
b) Click the Tagstab, then click New Tag.

c) Enter anamethat collectively identifies the sub-L SPs you are creating, and then click OK.

d) Click OK to save and exit.

Step 2 In the Nodes table, choose the node you will be designating as the source for the P2MP LSP.
Step 3 ChooseInsert > L SPs> L SP Mesh, or right-click in the plot and choose New > L SPs> L SP Mesh.
Step 4 Uncheck these check boxes:

* Same Destinations as Sour ces

» Also create L SPsfrom destination to source

Step 5 In the Source Nodes drop-down list, choose Selected in table (#/#). All sub-LSPsin a P2ZMP LSP must have the same
source node. A P2MP L SP cannot have multiple source nodes.

Step 6 In the Destination Nodes drop-down list, choose the newly created tag name.
Step 7 To set the bandwidth to be the same for all sub-LSPsin this mesh, enter that valuein the Fixed Value __ Mbpsfield.

To use the autobandwidth feature so that these L SPs have their Setup BW Sim value automatically cal culated and used
in autobandwidth simulations, click Autobandwidth.

Step 8 Complete the remaining optional fields as needed, and then click OK.

Creating Demands for P2MP LSPs
To simulate traffic routing through a P2MP L SP, create a demand for it.

Step 1 If you want to create demands for P2MP L SPs, choose one or more P2MP L SPs from the P2MP LSP table.

Step 2 Choose Insert > L SPs > Demandsfor P2M P L SPs, or right-click in the plot and choose New > L SPs > Demands for
P2MP L SPs.

a) Choose the P2MP L SPs through which you are routing traffic.
b) (Optional) Choose a service class for the newly created demand.
¢) Choose the desired bandwidth: Minimum sub-L SP Setup BW or Zero. Then click OK.

Deleting P2ZMP LSPs and Sub-LSPs

Deleting a P2MP LSP a'so deletes all sub-L SPswithinit. If you do not want all the sub-L SPs deleted,
disassociate them first.

Disassociating Sub-LSPs from Their P2MP LSPs

Step 1 In the L SPstable, choose one or more sub-L SPs.
Step 2 Double-click to open the Properties dialog box.
Step 3 In the Sub-L SP of P2MP LSP list, do one of the following:

 Choose the empty row to disassociate the sub-L SP and change it to an LSP.
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» Choose adifferent P2MP L SP to associate the sub-L SP with a different P2MP LSP.

Step 4 Click OK.

Deleting Sub-LSPs or P2MPs

Delete Sub-LSPs but Keep P2MP LSP Delete P2MP LSP and Associated Sub-LSPs
Right-click one or more sub-L SPsinthe L SPstable. | Right-click one or more P2MP L SPsin the P2MP LSP
Click Delete. teble.

Click Delete.

Click Yesto continue.
Click Yesto continue.

Unresolved LSP Destinations and Hops

RSVP-TE L SP configurations and state are read using network discovery from the source node of the LSP,
through SNMP, the Parse Configs tool, or other methods. These configurations might reference nodes or
interfaces that do not exist in the plan file, so they are referred to as being unresolved. For example, the LSP
destination node, read from the configuration on the source, might not be in the plan file. There are several
reasons for these differences:

* The plan file was modified to contain fewer nodes than are in the IGP.
* WAE cannot read all the nodes, or cannot obtain the | P addresses of al the nodes.

* The LSPs themselves are not configured correctly.

References that might not be resolved are as follows:
* Destination nodes of the LSPs.

 Hops in named paths configured on the source node.

 Hops in the actual paths read from the source node.

WAE tries to resolve as many of these references as possible. Tables and columns are updated as follows:

« If the L SP destinations are resolved, they are updated in the Destination column of the LSPstable. If
they are not resolved, the column remains empty. The original 1P addressremainsin the Netlnt Destination
column regardless of whether the destination is resolved or not.

« If the hops are resolved, they are updated in the Node and Interface columns in the Named Path Hops
and Actual Path Hopstables. If they are not resolved, the columns remain empty. The original |P address
remainsin the NetlntHop column regardless of whether the destination is resolved.

WAE Design does not make further attemptsto resolve these references unless you explicitly makethe request.
There are special casesin which this might be useful. For example, if additional nodes are added to a network
from a second network discovery procedure and if LSPsin the original network have unresolved references
to these nodes, it is useful to resolve the LSPs again.
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Resolving Plan File to Objects

If plan files have configurations that are not matched or refer to objects outside the modeled network, there
are several ways to resolve these differences:

* Resolve L SP destinations, hopsin named paths, hops in actual paths, or segment list hops by choosing
Initializers > Resolve Plan.

* Resolve hamed path hops in the named paths Properties dialog box.

* Resolve named path hops in the named path hops Properties dialog box.
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Segment Routing Simulation

By default, WAE Design creates and routes RSV P L SPs. However, you can create Segment Routing (SR)

L SPs by changing the L SP Type property to SR. These SR L SPs use autoroute, forwarding adjacencies, and
class-based forwarding, just like RSV P LSPs. Once the packet enters the tunnel, the different routing
mechanisms determine the path. An RSVP LSP isfirst established along a path, with each node on the path
accepting the reservation request and maintaining the reservation state. In contrast, SR L SPsrely on asegment
list that is created at the L SP's source node (head-end). This segment list, which is stored in the packet
(demand), directs the traffic over a series of configured node segments and interface segments. SR LSPs use
IP routing (and thus, potentially ECMP) between segments.

\}

Note WAE Design usestheterms SR LSPsthat use segment lists, which contain segment list hops. In Cisco routing
terminology, these terms are SR tunnels that use segment 1D (SD) lists, which contain SDs.

This section contains the following topics:

* SR LSP Segment Types, on page 179

* SR LSP Paths, on page 184

* SR L SP Routing, on page 185

* Inter-AS SR L SP Routing, on page 185

* Creating SR LSPs and Their L SP Paths, on page 187
* Creating Segment Lists, on page 188

» SR-TE Protection, on page 189

SR LSP Segment Types

The segment list of an SR L SP contains one or more segment list hops, which can be nodes, interfaces, SR
L SPs, or anycast groups.

To view asegment list, right-click an SR LSP and choose Filter to Segment Lists. You can then right-click
the segment list and choose Filter to Segment List Hops.
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Note The process of creating and optimizing segment lists and their segment list hops can be automated using the
SR-TE Optimization tool. For information, see SR-TE Optimization, on page 341. You can aso create SR

L SPsand their hops by optimizing bandwidth. For information, see SR-TE Bandwidth Optimization, on page
347.

Node Segment List Hops

When using node segment list hops, the SR L SP takes the shortest path to the specified node. Figure 64:
Example Node Segment List Hop, on page 180 shows an example SR L SP from cr2.kcy nodeto cr2.mianode

using one node segment list hop, which is cr2.okc. Because the IGP metrics are equal, the traffic is routed
using ECMP to reach okc.

Figure 64: Example Node Segment List Hop
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Interface Segment List Hops

On routers, interfaces can only be used in segment listsif the previous segment list hop isthe node containing
theinterface, or if theinterfaceis the egress of the source node. In WAE Design, there is no restriction that
an interface segment list hop be local. There is no requirement that the segment list contain a preceding
segment to the node containing the interface.

Figure 65: Example Interface Segment List Hop, on page 181 shows an example of an interface segment list
hop from cr2.chi to cr2.wdc. To ensure the path reaches cr2.chi (the node the packet must reach to use this
interface segment list hop), a node segment list hop is configured first to reach chi. This figure also shows
how a demand through an SR L SP reroutes when a node fails. The demand uses | GP to route around the
failure and back to the segment, if possible.
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Figure 65: Example Interface Segment List Hop
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LSP Segment List Hops

SR L SPscan use other SR L SPs as segment list hops, and in turn, these SR L SPs segment list hops can contain
other SR LSPs as segment list hops. Two rules apply:

 The LSP segment list hop must be an SR LSP, not RSVP LSP.

« An LSP segment list hop cannot reference another SR LSP that directly or indirectly referencesit. For
example, if the segment for SR LSP A contains SR LSP B asasegment list hop, SR L SP B cannot contain
SR LSP A as asegment list hop.

If aselected SR LSP contains an L SP segment list hop that contains yet another L SP segment list hop, only
thetop-level LSP segment list hop isidentified by the yellow diamond icon. The destination of an L SP segment
list hop is not identified. For example, Figure 66: Example LSP Segment List Hop, on page 182 shows that
LSP A (from erl.lax to erl.nyc) contains an LSP B segment list hop, whose source nodeis crl.lax. By
deselecting LSP A and then selecting LSP B, you seethat L SP B al so contains an L SP segment list hop, which
is LSP C whose source nodeis crl.atl.
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Figure 66: Example LSP Segment List Hop
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Anycast Group Segment List Hops

An SR LSP routes through the node in an anycast group segment list hop that has the shortest path to it. In
case of atie between multiple nodes in an anycast group, ECMP is applied. This mechanism lets you impose
routing restrictions in terms of potential intermediate segment destinations. It also lets the SR LSP choose
among the possible next hops (next segment list hops), potentialy reducing latency and improving load
balancing.

Figure 67: Example Anycast Group Segment List Hop, on page 183 shows an example of anycast group nodes
cr2.chi and crl.chi. In oneinstance, the | GP metrics to those nodes have equal | GP metrics, so the SR LSP
uses ECMP to route through both of them. When the IGP metric increases from cr2.lax to crl.chi, the SR

L SP routes only through cr2.chi because it has the shortest path. However, as Figure 68: Example Anycast
Group Rerouting Around Failure, on page 184 shows, if afailure prevents the shortest path from being used,
the SR L SP can still route through the anycast group using the next-highest cost path.
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Figure 67: Example Anycast Group Segment List Hop
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Figure 68: Example Anycast Group Rerouting Around Failure
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SR LSP Paths

)

SR L SPs can have multiple L SP paths, where each L SP path has its own segment list. There is no distinction
between standby and non-standby L SP paths for SR LSPs.

Note

If both the SR LSP and its SR L SP paths have segments, the segments on the L SP paths override those on
the SRLSP.

Figure 69: Example SR L SP Paths, on page 184 shows an SR L SP from kcy to miathat has a primary and a
secondary path. The primary path is configured with a chi node segment list hop and chi-to-wdc interface
segment list hop, and the secondary path is configured with a node segment list hop in okc. This can be seen
by selecting the LSP paths individually from the L SP Paths table.

Figure 69: Example SR LSP Paths
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SR LSP Routing

Assuming the common L SP mechanisms such as autoroute and forwarding adjacencies have determined that
ademand will enter an SR LSP, the LSP traffic is routed as follows. If the destination node or segment list
hops are not reachable, the SR LSP is not established.

)

Note The process of creating final segment list hops can be automated using the Traffic Demand Modeling, on
page 43 tool.

« If the SR LSP does not have a segment list, the demand is routed via | GP to the destination node.

If the SR L SP has a segment list, the demand is routed using the segment list hops within the segment
list in the sequential order in which they appear.

* If itisusing a node segment list hop, the demand takes the shortest path to that node.

If itisusing an interface segment list hop, the demand takes the shortest path of the source node of that
interface, and then routes to that interface’s destination node.

If it isusing an anycast group segment list hop, the demand routes through the node with the shortest
path. In case of atie between multiple nodes in an anycast group, the SR L SP uses ECMP to route.

« If you select both a hode and an anycast group containing that node when creating the segment list hop,
the node segment has precedence.

« If the SR L SP contains L SP paths, the demand is routed on the L SP path with the lowest path option for
which the demand can be routed from source to destination. Demands for SR L SP paths route in the
same manner as described above for SR LSPs.

« If the SR L SP contains multiple SR Candidate paths, the demand is routed on the L SP path with the
highest preference option for which the demand can be routed from source to destination. Demands for
SR L SP paths route in the same manner as described above for SR L SPs.

* If the demand cannot be routed on the segments defined in the SR LSP or its L SP paths (for example,
because of afailurein anode segment list hop), the demand is routed to the destination using the IGP
shortest path.

« If ahop (nodes, interfaces, L SPs, or anycast groups) contains a segment |D (SID), the segment list hop
inheritsthat SID.

Inter-AS SR LSP Routing

SR L SPs with source and destination nodes in different A Ses can route provided the following hop
configurations exist:

* Thereis anode segment list hop on the border of the AS that the LSP is exiting. This node is the exit
node.

* One of these hops exists:
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* A node segment list hop exists on thefirst node traversed in another AS. Thisnodeisthe entry node.
If there are multiple peering interfaces, their metrics determine which one the L SP uses.

* Aninterface segment list hop connects the exit node of one ASto an entry node in another AS.

Figure 70: Segment List Hops Define Exit and Entry Points Across AS, on page 186 shows an example
of each of the preceding configurations. Both networks show two A Ses, and both show a node segment
list hop on crl.nyc, which isthe node fromwhich the LSPisexiting AS 1. Thetop half showsthecrl.lon
node, the entry node to AS 2, as the next segment list hop. The lower half shows the crl.nyc-to-crl.lon
interface, which connects the exit nodein AS 1 to an entry node in AS 2, as the next segment list hop.

Without these conditions being met, SR L SPs cannot route across AS boundaries. For example, Figure
71: Inter-AS SR L SP Routing Requires Correct AS Exit and Entry Hops, on page 187 shows an SR LSP
with the proper node segment list hop set on crl.mia (exit node of AS 1), but it does not route because
the next segment list hop (crl.par) is not the first node in AS 2 that this LSP would traverse. By adding
anode segment list hop on crl.rom, the SR L SP can route across the A Ses.

Using demands with inter-AS SR L SPs requires that two conditions be met:

 The demand must be private to the SR L SP. For information on creating private L SPs, see MPLS
Simulation, on page 113.

» The demand must have the same source and destination as the SR LSP.

Figure 70: Segment List Hops Define Exit and Entry Points Across AS
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Creating SR LSPs and Their LSP Paths .

Figure 71: Inter-AS SR LSP Routing Requires Correct AS Exit and Entry Hops
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Creating SR LSPs and Their LSP Paths

SR L SPs and mesh SR L SPs are created the same way RSVP-TE L SPs are created. The differenceisthat you

must set the Type property to SR.

Type: I-ER ']

RSVP

The SR LSP has a color property which is a 32-bit numerical value.

Once created, the next step is to either create the segment list or create L SP paths and their segment lists.

Likewise, LSP paths are created in the same way as RSVP-TE L SP paths. Because you are creating them
from SR L SPs, you can edit the properties Path Option and Active. Set the property Protocol Origin to identify
the component or protocol that originates the SR L SP path. Choose from Local, PCE Initiated, and BGP

Initiated.

For information on creating L SPs and L SP paths, see MPL S Simulation, on page 113.
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Creating Segment Lists

You can create segment lists and destination segment lists hops automatically using the Explicit LSP Paths

initializer. Thisinitializer creates as few segment list node and interface hops as possible to route according
to the options selected. The destination node of the L SP is added as the final segment list hop unlessthe final
hop is a segment list interface hop that terminates on the destination node.

Step 1 Choose Insert > L SPs> Segment List, or right-click in the plot and choose New > L SPs > Segment List.
Step 2 Add the segment list hops in the order in which they are to be followed.

* To add a new segment list hop, select an existing hop (if applicable), and then click Insert Before or I nsert After
to determine where the new hop goes sequentially. Go to Step 2.

* To edit an existing segment list hop, select it from the list and then click Edit. Go to Step 2.

« To delete an existing segment list hop, select it fromthelist, click Delete, and then click OK. You need not continue.

Hop Specified by:
Step Node Interface Site: sic v
1 crasjc Node: [tr2.sj_c '
2 Cr2sjc to_cra.lax > Q) Interface: ['to_crz.lax v
3 crlhst LSP:
4 crlhst to_crl.atl
Anycast Group:
Insert Before 1 ' Insert After 0 Delete ] Edit... §
Step 3 To continue creating or editing a segment, use the following options and then click OK. As needed, choose the site, node,
interface, or anycast group.
Note Interface segment list hops must be the egress interface of a node segment list hop.

* If the node or source node (for interfaces and L SPs) is within a site, first choose the site.
« For node segment list hops, do not choose an interface.
« For interfaces and L SPs segment list hops, first choose the source node.

« For anycast group segment list hops, do not choose a site, node, or interface.

After the segment list is created, another way to manage segmentsis to double-click one from the Segment List Hops
table. From there you can change the site, node, and interface, but not the sequence.
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Creating Anycast Groups

Step 1 Choose Insert > Anycast Group, or right-click in the plot and choose New > Anycast Group.

Step 2 Enter a unique name to identify the anycast group.
Step 3 For each node you want to include in or exclude from the anycast group, check the T (true) or F (false) check box. Then
click OK.

SR-TE Protection

If the network contains a configurable topol ogy-independent loop-free alternate (TI-LFA), you can simulate
SR-TE tunnels before and after convergence.

)

Note To seethe simulation before convergence, you must be in Fast Reroute mode (choose Edit > Network
Options; in the Simulation Convergence Maode area, choose Fast Reroute). In IGP and L SP Reconvergence
mode, you can only see the after-convergence routes.

SR-TE Tunnel Simulation Before Convergence

For each SR tunnel in aplan file, and for each SID in the path, WAE Design determines the no-failure route.

Inanormal path state , WAE Design determines the no-failure route from segment list hop to segment list
hop. Between segment list hops, WAE Design follows the | GP shortest path to the next segment list hop. At
each interface along the path, if the connected circuit is down, WAE Design determines whether the next
segment list hop is an interface or a node, and whether the SR tunnel is routable.

« If SR FRR isenabled for the interface in the I nterfaces table, WAE Design configures the protect path
state:

» WAE Design derives the post-convergence path from the local node to the next SID hop with the
subject circuit removed from the topology.

» The next SID hop depends on the SID hop type. For an interface SID, the next hop is the remote
node of that interface. For anode SID, the next hop is that node.

» WAE Design follows the derived after-convergence path hop by hop until it reaches the next SID
hop. (If afailure occurs along the way, the SR FRR and the SR L SP do not route.)

» When WAE Design reaches the next SID hop, it returns to the normal path state and resumes
following the no-fail path to the SID hop.

« |f SR FRR is not enabled for the interface in the Interfaces table, the SR tunnel does not route.

SR-TE Tunnel Simulation After Convergence
WAE Design routes to each segment list hop through the |GP shortest path under al failure conditions.
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Note An SR LSP might be routable before convergence through a TI-LFA, but unroutable after convergence.

Constraints

« Inthe Interfaces table, if SR FRR Enabled is T (true) for a given interface, all SR L SPs with anode or
interface SID as the next hop are protected over that interface. If the SRR FRR Enabled is F (false), all
SR LSP SIDs are unprotected over that interface.

* Protected versus unprotected adjacency SIDs are not supported. (All adjacency SIDs are considered
protected.)

* WAE Design does not impose alimit on the TI-LFA path’s label stack depth.

* WAE Design does not explicitly derive P and Q nodes, but instead derives a protect path that aligns with
the after-convergence shortest path from the PLR to the next segment list hop.

« If any part of the TI-LFA path encounters afailure before reaching the next segment list hop, the TI-LFA
path fails and the SR L SP does not route.
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Layer 1 Simulation

Although WAE Design focuses on IPIMPLS Layer 3 (L 3) network views and traffic, you can also create and
view Layer 1 (L1) topologies for amore complete view of the network. Using the L3 and L 1 topologies
together, you can specify how L3 circuits route over L1 links. These Layer 3-to-Layer 1 associations let you
simulate individual L1 link and L1 node failures, or include L1 links and L1 node failuresin a Simulation
Analysisto determinethe effectson L3 traffic. Additionally, you caninclude L1 linksand L1 nodesin SRLGs.
With thisinteraction of layers, you can better design the network to meet performance requirements.

\}

Note Asidefrom this chapter, throughout this guide the term circuit means a circuit with L3 properties. In this
chapter, for purposes of clarity, L3 circuit and L1 circuit refer to objectsdefinedin the Circuitsand L1 Circuits
tables, respectively, whereas circuit refers to the actual network element.

This section contains the following topics:

e L1 and L3 Views, on page 191

« L1 Topology, on page 193

L1 Simulations, on page 195

* Relationships Between L1 and L3, on page 208
« Delay and Distance, on page 212

e L1 Failures, on page 214

* Inactive State, on page 219

L1 Simulation Analysis, on page 220

* Creating L1 Topology, on page 222

* Creating L1 and L3 Mappings, on page 230
* Visualizing the L1 Network, on page 235

L1 and L3 Views

Figure 72: Comparison of L1 and L3 Views, on page 192 shows an example L1 view in comparisontoan L3
view. Notice the different uses of circuits. In the L3 view, L3 circuits are relevant to IPPIMPL S routing and
show traffic. The L1 view showsthe physical topology with no traffic; if selected, it aso showsthe L1 circuit
paths taken across the L1 links. L3 isthe default view unless the plan file does not contain L3 nodes.

To more easily find relationships between L3 and L 1 objects, right-click the object and choose the appropriate
filter.
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Alternate Views

To alternate between L1 and L 3 views, use one of these methods:
* Click the L1/L3 toggle button in the top left of the Visualization toolbar.
* Choose View > Layer 1 View or View > Layer 3 View.

 Use keyboard shortcuts Ctrl-1 for L1 and Ctrl-3 for L3. (On aMac, use Alt-1 and Alt-3.)

Figure 72: Comparison of L1 and L3 Views
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Multi-Layer Views

To show relationships between the L1 and L 3 views, you can simultaneously view both of themin either view
(Figure 73: Multi-Layer (Combined Layer 1 and Layer 3) Views, on page 193). If you areinthe L1 view, L3
objects appear in the background. If you arein the L3 view, L1 objects appear in the background. Additionally,
the L3-L 1 links, which model the physical relationship between L3 nodesand L1 nodes, are visualized (Figure
74: L1-L3 Link Visualization, on page 193).

In the Plot Options dialog box, click the Layer 1 tab, and then choose options to determine whether to show
Layer 1 objectsin the Layer 3 view. For more information, see Editing L1 Plot Options, on page 236.

The ability to move, select, and edit properties for an object in the background is toggled on and off with
View > Preferences > Enable Selection of Background Objects.
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Figure 73: Multi-Layer (Combined Layer 1 and Layer 3) Views
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L1 Topology

An L1 topology consists of aunique set of objects (Table 12: L1 Objects, on page 194) that are distinct from
IP/IMPLS L3 topology and objects. However, two of the objects, L1 circuits and L3 circuits, represent the
same circuit.

« An L3 circuit contains L3 properties of the circuit.
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L1 Objects

Table 12: L1 Objects

Layer 1 Simulation |

* An L1 circuit contains L1 properties, specifically L1 routing, of the circuit.

You can create the objects and generate an L1 topology in WAE Design using these methods:

« Import an L1 topology from another plan file. This method creates the same L1 topology and the same
L1 link, L1 circuit, L1 port, and L3 mappings as in the source file. You can also copy an L1 topology
from aplan file. To import an L1 topology, choose File > Import > Layer 1.

« Construct an L1 topology based on al or part of an existing L3 topology in the same plan file. This
method creates an L 1 topology that mirrorsthe L3 one, and automatically generates the mappings between
theL1 and L3 objects. For moreinformation, see Creating L 1 Topology from L3 Topology, on page 222.

« Individually create the L1 ports, L1 nodes, L1 links, L1 circuits, L1 circuit paths, and L1 circuit path
hops. You can add both L1 nodes and L1 linksto SRLGs for simulation purposes. Thisistypically done
to represent ducts containing multiple fiber segments, where abreak in the duct could cause multiple L1
link failures, and thus potentially multiple L3 circuit failures for each of these L1 links. The end of this
chapter contains severa sections on manually creating L1 objects.

« Create the L1 topology directly in the tablesin the plan file, such as by editing the L1 tables (Edit >
Plan Tables as Database) or by creating the table in the plan file using a text editor.

L1 Object Description

L1 port ModelsL1 portsand islisted in the L1 Ports table. The source and destination for L1 circuitsare L1
ports. Each L1 port can belong to only one L1 circuit.
An L1 port can be associated with an L3 port.

L1 node Models L1 devicesand islisted in the L1 Nodes table. When selected, they become a darker shade of
blue.

L3-L1link Modelsthe physical relationship between an L3 node and an L1 node. If showing both L1 and L 3 objects,
these appear as light blue dotted lines. If selected, they are solid black lines.

L1 link Models the fiber segments connecting the L1 nodes. These are listed inthe L1 Links table and are

highlighted in blue when selected.

L1 circuits are routed over L1 links, which is how these L1 links can be associated with the IPPMPLS
topology in the L3 view.

L1 link waypoint

Models network devices (that are not L1 nodes) that reside in the L1 link path. Each waypoint has
coordinatesthat identify apoint onan L1 link. They are used for visualization purposes and for calculations
executed by the Latency and Distance initializer. They are not used in simulations. They appear as dots
onthe L1 link, and they become darker when selected.

L1 circuit

Modelsthe L1 properties of acircuit, such aswhich L1 ports are connected to it and the physical path
and distance. These are listed in the L1 Circuits table and are highlighted in green when selected.

Each L1 circuit can be associated with an L3 circuit directly or indirectly.
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L1 Waypoints .

L1 Object Description

L1 circuit path Models the paths available for the L1 circuits. These are listed in the L1 Circuit Paths table and are
highlighted in green when selected. The number on the highlighted path indi cates the Path Option number.

L1 circuit path hop ModelstheL1 nodeor L1 linksintheL1 circuit path. These arelisted inthe L1 Circuit Path Hops table.

Actual L1 circuit path hop | Discovered L1 circuit path hops.

L1 Waypoints

Sites

L1 links, L1 nodes, and L1 ports can be failed, set to an inactive state, and included in Simulation Analysis
to calculate aworst-casefailure analysis. Additionally, L1 linksand L 1 nodes can both beincluded in SRLGs,
which in turn can also be failed and included in Simulation Analysis. These capabilities let you assess the
effect of L1 outages on the IPPIMPL S network, thus improving your ability to design around and plan for
potential service disruptions.

Waypoints are only viewable in the geographic view, and by default, they are visible in the network plot.
Thereis an option to show or hide them in the Layer 1 tab of the Plot Options dialog box.

chi e e
m e — B

« The Order property represents the proximity to L1 node A, where 1 is the closest waypoint to the L1
node A and each subsequent number is farther away.

« Default Longitude and Latitude properties are based on the L1 link on which they are created, though
you can change them.

All sites are listed in the Sites table whether they contain L1 nodes, L3 nodes, or both. To determine how
many L1 nodes, if any, are in asite, show the L1 Node Count column. By default, sites containing only L1
nodes appear only in the L1 view, and sites containing only L3 nodes appear only in the L3 view. You can
change this default in the Plot Options dialog box. Empty sites appear in both views.

L1 Simulations

When reading the L1 tables, the derived Established and Routed properties indicate simulation capabilities.

« Established—Identifies whether an L1 circuit or L1 circuit path is routed when there are no failures.
Note that while an L1 circuit or L1 circuit path has Established equals F (false), it might be routable
under failures.

 Routed—Identifies whether and how an L1 circuit or L1 circuit path is routed:
* Unrouted

* Actual (if being routed through actual L1 circuit path hops)
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» Simulated (if being routed and not using actual L1 circuit path hops)

\)

Note You can configure the number of attempted routes for L1 circuit paths. Increasing the number of attempted
routes allows for more paths to be explored, thereby potentially reducing the number of unrouted L 1 circuits.
Thisincreases the overall computation time. To configure the number of route attempts, choose Edit >
Network Options and set the Number of Attemptsto Route L 1 Circuit Paths parameter.

Active L1 Path Selection

Because multiple L1 circuit paths can be routed for asingle L1 circuit, WAE Design uses the Active Path
Sim property to determine which L1 circuit path to use to set the derived properties for each L1 circuit, such
as Distance Sim and Delay Sim. The Active Path Sim property is copied from the user-specified Active Path
property if it has been set and if it isroutable.

Standby Paths and Path Options

The user-specified L1 circuit path’s Standby property sets the path to standby (T) or non-standby (F). The
user-configurable Path Option property isan integer that identifies the order in which the routing of L1 circuit
pathsis explored. The lower the value, the higher the priority to route the L1 circuit path.

If other L1 circuit paths must be explored, the standby L 1 circuit path with the lowest Path Option valueis
used provided it isroutable. If it is not routable, attempts are made for each Path Option with the next lowest
value (next highest priority). If none of the standby L1 circuit paths are routable, WAE Design then follows
the same procedure with non-standby L1 circuit paths, starting with the one with the highest priority Path
Option.

Note Non-standby L1 circuit pathsreroute under failure only you check the Networ k Options> L ayer 1rerouting
conver gence under failures check box. For more information, see Resiliency Under L1 Failures, on page
216.

L1 Circuit Path Routing Order

* WAE Design always triesto route L 1 circuit paths that have their Standby property setto T (true),
regardless of whether they are set as the active path. If they are routable, they are routed in the order of
this priority:

* Actual L1 circuit path hops have first priority. Note that while these are not discovered by WAE,
if they are discovered through another means, you can manually add them using the Actual tab of
the L1 circuit paths Properties dialog box or by adding an <ActualL 1CircuitPathHops> table to the
.txt planfile.

* L1 circuits paths with explicit central frequency IDs or central frequency |Ds defined through L1
circuit path hops are then routed. For information on central frequency 1Ds, see Central Frequency
ID Assignments, on page 204.
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* Thereafter, L1 circuit pathsthat do not have central frequency ID properties set explicitly or through
L1 circuit path hops are routed.

* After attempting to route standby L1 circuit paths, WAE Design determines whether and how to route
non-standby L 1 circuit paths (Standby property set to F).

» WAE Design determines if the non-standby L1 circuit path should route by checking the following
L1 circuit propertiesin this order.

If the L1 circuit Active Path property is set to this L1 circuit path, WAE Design triesto route the non-standby
L1 circuit path.

If the number of routed L1 circuit pathsis less than the associated L 1 circuit’s Min Routed Paths property,
WAE Design tries to route the non-standby L 1 circuit paths.

» Non-standby L1 circuit paths are routed based on their Path Option setting (lower numbers are routed
first). For each of these paths, the route order is based on the same criteriaas described above for standby
L1 circuit paths (actual L1 circuit path hops, then central frequency ID values, and then L1 circuit path
hops that do not have central frequency 1D values).

Within each of the above routing instances, WAE Design routesthe L 1 circuit path based on thefollowing
criteriaregardless of whether the L1 circuit path is standby or non-standby.

« Routes are based on the lowest Setup Priority value and then deterministically. For example, among L1
circuit paths with actual L1 circuit path hops, those with higher Setup Priority are routed first. See.

« L1 circuit paths that do not require automatic wavel ength assignments to route have higher priority than
those that do. For information on the Auto Spectrum Assignment property, see Central Frequency ID
Assignments, on page 204.

Viewing L1 Circuit Paths

To view the actual paths or simulated paths of L1 circuits, choose View > L 1 Circuits. Note that given the
priority of routing, if the actual L1 circuit path hops path isvalid, the actual and simulated paths are the same.
You can also choose to view the shortest latency path from this menu.

Rerouted simulated L 1 circuit paths show automatically when they are rerouted due to failures, regardless of
whether you are showing simulated paths.
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L1 Circuit Path Hops

\}

You can force an L1 circuit path to choose a different route by setting one or more node hops or link hops.

Node Hops Link Hops

* Strict—The L1 link must bein the path
in the specified order.

 Loose—The path must passthrough the node, but the node
does not have to be connected directly to the previous hop.

» Exclude—ThisL1link cannot beinthe
path.

« Strict—The node must be directly connected to the
previous node.

» Exclude—This node cannot be in the path.

Generally, node hops are used for simplicity, but link hops are useful for when you need to distinguish between
two parallel L1 links. To do this, set aloose hop on the L1 node preceding the link hop, and then set a strict
hop on the parallel L1 link over which you want to route this L1 circuit.

You can set L1 circuit path hopsin an L1 circuit path Properties dialog box. Because WAE Design aways
uses the shortest path, remember to set as many hops as needed to achieve the desired path, and put them in
the order of the desired path. The L1 Circuits Path Hops table identifies the path and the steps.

Note

Because L1 circuits paths are bidirectional, to smulate L 1 circuit path hops WAE Design automatically adds
theinitial L1 nodein the path as a strict hop.

Example: Figure 75: Shortest L1 Circuit Paths Versus Paths Determined by L1 Circuit Path Hops, on page
199 shows an example of a default shortest path being used, as well as an aternate circuit path created using
aloose nyc node hop. It also demonstrates that you could achieve the same path by setting only an exclude
link hop on wdc-bos.
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Figure 75: Shortest L1 Circuit Paths Versus Paths Determined by L1 Circuit Path Hops
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For More Information...

See...

Automate the process of setting up L1 circuit hops

Explicit L1 Circuit Paths Initializer, on page 199

Set L1 circuit hops per L1 node or L1 link

Creating Individual L1 Circuit Path Hops, on page 227

Explicit L1 Circuit Paths Initializer

The Explicit L1 Circuit Paths Initializer automates the process of creating explicitly routed L1 circuit paths.

Step 1 Choose one or more L1 circuit paths. If you select none, the default isto create L1 circuit path hops for all L1 circuit
paths.

Step 2 Choose I nitializers > Explicit L 1 Circuit Paths, or right-click an L1 circuit path and choose Explicit L1 Circuit Path
Initializer.

Step 3 Choose whether to use al L1 circuit paths, those selected in the table, or those with specific tags.

Step 4 Click OK.

L1 Circuit Route Reports

Step 1
Step 2

After closing the report, you can access it again by choosing Window > Reports.

Choose Tools > Reports > Layer 1 Circuit Routes.
Click OK.

You can create reports on L1 circuits based on the L1 circuit path identified as the Active Path Sim for each
L1 circuit. Additionally, the report contains all other columnsin an L1 Circuitstable, though they areinitially
hidden.

To export the report, right-click the Routes report name in the Reports navigation pane, and choose Export.
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L1 Link Metrics

When L1 circuit pathsare routed over L1 links, by default they are established along the shortest path between
the L1 nodes. This shortest path is defined as the path with the lowest metric, and the metric of an L1 circuit
path is defined as the sum of the L1 link metricsin the path. To move L1 circuit paths awvay from an L1 link,
raise the metric on that L1 link.

Because you can simultaneously edit multiple L1 link Metric properties, this method is useful for altering
numerous L 1 circuit paths at atime. For exact path specification per L1 circuit path, however, you must set
explicit L1 circuit path hops.

L1 Link

vl

8034

Metric: 3

If the two shortest L1 circuit paths have the same metric, WAE Design chooses one arbitrarily provided no
other properties impact the route.

Note that in contrast to an interface |GP metric, this L1 metric does not represent an actual configurable
guantity in the network.

Example: Figure 76: Example Effect of L1 Link Metric on Routing L1 Circuits, on page 200 shows an example
L1 circuit from §cto kcy. Whenthegc-dlcL1link hasametric of 2.7, the shortest L 1 circuit path is §c-slc-key.
By raising the §c-slc metric, the shortest L1 circuit path becomes gjc-sea-slc-kcey.

Figure 76: Example Effect of L1 Link Metric on Routing L1 Circuits
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L1 Link Metric Initializer

TheL1Link Metric Initializer setsL 1 metrics based on L1 link distances. WAE Design calcul ates the metric
by multiplying each L1 link’s Distance value by the multiplier you specify. You also set a minimum value
for the resulting metric. WAE Design then uses the higher of the two values.
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L1 Circuit Path Setup Priority .

Example: If the L1 Distance valueis 7, the multiplier valueis 3, and the minimum value is 1, the resulting
L1 metricis 21 (Distance * Multiplier). However, if the minimum value were 25, the resulting L1 metric
would be 25.

Set Layer 1 Link metric to max({"Distance" * Multiplier, Minimum)

Multiplier 3

Minimum 25

AB0SE0

Step 1 Make your selections.
* Choose one or more L1 links.

* If you make no selections, metrics are calculated for all L1 links.

Step 2 Choose I nitializers > Layer 1 Metric, or right-click an L1 link and choose I nitialize L1 Metric.
Step 3 Enter amultiplier and minimum value, and click OK.

L1 Circuit Path Setup Priority

The Setup Priority property identifies the order in which L1 circuits paths are routed when they share the
same L1 link. The lower the number, the higher the priority. Figure 78: Example Spectrum Blocking, on page
207 shows an example of rerouting L1 circuit paths based on Setup Priority.

L1 Circuit Path

Setup Priority: 7

380043

To set the Setup Priority, right-click one or more L1 circuit paths and choose Properties. This value appears
inthe L1 Circuit Paths table in the Setup Priority column.

L1 Circuit Wavelengths

The L1 circuit central frequency 1D (wavel ength) propertiesinclude those that identify transmission feasibility
and central frequency 1D assignments.

Using these properties, you can answer questions like:

e Can | add an L3 circuit that uses a specific L1 circuit?

« How will my network choose anew L1 circuit path under L1 failure?
» Can | modify an existing L1 circuit for an L3 circuit?

* How many available wavelengths are therein my L1 topology?

» What happensto the network when there are L 1 failures? Does optical restoration select anew L1 circuit
path, and if so, which path?
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Transmission Feasibility

In area network, the quality of an L1 circuit deteriorates as it passes through L1 links. Using feasibility
properties, WAE Design lets you simulate this weakening of L1 circuits to determine if they have degraded
to the point of being unroutable.

Feasibility Property Description
L1Link
Noise Identifies unidirectional propertiesfor L1 Links.
« NoiseAtoB (default isundefined): The noiseintroduced by L1 Link from
L1 NodeA toL1 NodeB indB.
» NoiseBtoA (default isundefined): The noiseintroduced by L1 Link from
L1 NodeBtoL1NodeA indB.
NoiseSigma Identifies unidirectional propertiesfor L1 Links.
» NoiseSigmaAtoB (default is undefined): The noise sigmaintroduced by
L1Link fromL1NodeA toL1 NodeB indB.
« NoiseSigmaBtoA (default is undefined): The noise sigmaintroduced by
L1Link fromL1NodeBtoL1NodeA indB.
L1 Circuit

Feasibility Metric Sim

Thisis copied from the Feasibility Metric Sim of the active L1 circuit path.

Feasible Transmission

I dentifies whether the L1 circuit can be transmitted. Thisis copied from the
Feasible Transmission of theactive L 1 circuit path. If all L1 circuit paths have
ahigher Feasibility Metric Sim than Feasibility Limit, thisvalue isF (false),
and the L1 circuit cannot route.

L1 Circuit Path

Feasibility Metric Sim

The simulated Feasibility Metric of the L1 Circuit Path in dB.

Feasibility Limit

| dentifies the acceptable quality of the L1 circuit path.

Feasibility Acceptance
Threshold

| dentifies the acceptance threshold used in calculating the L1 circuit path
feasibility metric. Lower thresholds increase the risk that the L1 circuit path
is not feasible in the network. The default is 3.

Feasible Transmission

I dentifies whether the L1 circuit path can be transmitted. If the L1 circuit
path’s Feasibility Limit is more than the sum of the Feasibility Metrics for
the L1 linksthat the L1 circuit path traverses, thisvalueisT (true) and the L1
circuit path can route.

Note This property does not apply if an L1 circuit uses actual L1 circuit
path hops.
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Routing Based on Feasibility Properties
Feasibility properties affect routing as follows:

« If thereis no Feasibility Limit, the shortest path is based on the L1 link Metric property, and Feasible
Transmission is set to “na”

* The shortest L1 circuit path is based on the L1 links that result in a L1 circuit path’'s Feasibility Metric
Sim value that islower than the L1 circuit path’s Feasibility Limit. The Feasible Transmission of the L1
circuit pathissetto T (true).

« If the L1 circuit path Feasibility Metric Sim is higher than the Feasibility Limit, it is not routed, and the
Feasible Transmission is set to F (false) except when actual L1 circuit path hops exist.

Example: Figure 77: Example Effects of L1 Link Feasibility on Routing L1 Circuit Paths, on page 203 shows
aseriesof changesto the Feasibility Limit onan L1 circuit path. The L1 Linkstable—which showsthe amount
of noise, in decibels—does not change in any of the following scenarios.

* Row 1 shows that the Feasibility Limit of the L1 circuit path is set to —10 dB. Because the simulated
feasibility metric (Feasibility Metric Sim) islower than the Feasibility Limit, the L1 circuit path follows
the shortest path, from sea to boi.

* Row 2 showsthat the Feasibility Limit of the L1 circuit path decreasesto —11.5 dB, and the path follows
alonger route (sea-slc-boi) to stay under the limit.

* Row 3 shows that the Feasibility Limit of the L1 circuit path decreases to —12 dB, thus making it
impossible for the path to route. The Feasibility Metric Sim changesto “na”

Figure 77: Example Effects of L1 Link Feasibility on Routing L1 Circuit Paths
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Show All Select All |~ | Filter = 1/1 rows (0 selected)
Feasibility Metric Sim Feasibility Limit Feasibility Acceptance Threshold
na -12.0000 3.00

Spectrum Modeling

L1 Circuits can be assigned spectrum of variable sizes.
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. Central Frequency ID Assignments

Each Spectrum Grid isidentified by Anchor Frequency, Central frequency granularity, and Central Frequency
ID Blocked list. The Freguency ID Lower Bound and Frequency 1D Upper Bound represent the lower and
upper bounds on available central frequency IDs.

Freguency 1D Lower Bound Anchor Frequency Frequency ID Upper Bound

«€ r
(Central Frequency ID, Spectral Width ID): (-8, 4) (12.8) Frequency
Configurable grid
granularity
A /
‘ . Spectal|__ | | i
Width {1
«< — >
w2 o 0 H 2 Sk Frequency .
(Central Frequency 1D, Spectral Width ID): (-2, 1) (3.2) §

To define the spectrum grids, choose Edit > Networ k Options. On the Edit Network Options dialog box,
click Advanced tab and update the values under Spectrum Grid section.

Central Frequency ID Assignments

Because multiple L1 Circuit Paths are transmitted in the same fiber, it is required that they each occupy a
different part of the spectrum asthey cross an L1 link. The portion of the spectrum that an L1 Circuit Path
occupiesisdetermined by its Central Frequency ID and Spectral Width ID. The Central Frequency ID identifies
the central frequency of the L1 circuit path in terms of its distance from the Anchor Frequency of the defined
grid. The Spectral Width 1D defines the size of the L1 Circuit Path around this central frequency. Thisis
expressed in integer increments corresponding to double the Central Frequency Granularity.

In WAE Design, the Central Frequency ID property identifiesthe L1 circuit path wavelength. To ssmulate
changes in the Central Frequency 1D values (regenerators) along an L1 circuit path, you can manually set
Central Freguency ID valuesfor each L1 circuit path hop.

 Each L1 circuit path traversing an L1 link must have a unique Central Frequency ID while on that L1
link. If more than one L1 circuit path has the same Central Frequency 1D asthey crossthe L1 link,
Spoectrum blocking occurs. That is, the L1 circuit path with the highest Setup Priority property (lowest
number) is routed, and the others are blocked.

To determinewhich L1 links are causing the spectrum blocking, right-click any L1 circuit path whose Spectrum
Blocking valueis T (True), and choose Filter to Spectrum Blocking L1 Links.

 Each L1 circuit path must use the same Central Frequency ID valueon all L1 linksthat it traverses unless
Central Frequency ID values are set onthe L1 circuit path hops. This requirement is called the spectrum
continuity constraint .

Feasibility Property Description

L1 Circuit
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Central Frequency ID Assignments .

Feasibility Property

Description

Central Frequency ID Sim

Simulated 1D of theinitial central frequency, which is copied from the Central
Frequency ID Sim of the active L1 circuit path.

Thisvalueissetto “na’ if no L1 circuit path can be routed.

Spectrum Blocking

True (T) meansthe L1 circuit cannot be routed because there is spectrum
blocking on all of itsL1 circuit paths.

Prefer Lower Frequency
IDs

Specifiesif the spectrum assignment algorithm prefers lower Frequency IDs.
The default is True (T).

L1 Circuit Path

Central Frequency ID

The ID of theinitia central frequency of the L1 Circuit Path..

« If thereis no Central Frequency ID value entered, the central frequency
ID value of the most recently used L1 circuit path hop is copied here.

« If thereareno L1 circuit path hops or if there are no Central Frequency I1D
assigned to L1 circuit path hops, thisvalueis set to “na.”

Spectral Width ID

The spectral width of the L1 Circuit Path in integer increments corresponding
to double the Central Frequency Granularity.

Thisvalueissetto 1if it isnot explicitly set.

Central Frequency ID Sim

Simulated ID of theinitial central frequency , which iscopied from one of these
valuesin this order of priority:

« Central Freguency ID Sim value of thefirst actual L1 circuit path hop.
* Central Frequency ID Sim value of thefirst L1 circuit path hop.
« Central Frequency ID vaue of the L1 circuit path.

If Auto Spectrum Assigment isinvoked, WAE Design changesthe Central
Frequency ID Sim in order to route the L1 circuit path.

Thisvalueisset to “na’ if the L1 circuit path cannot be routed.

Central Frequency Sim

The simulated initial central wavelength of the L1 Circuit Path.

Spectral Width

The spectral width of the L1 Circuit Path in GHz.

Spectrum Blocking

True (T) meansthis L1 circuit path cannot be routed either because it has the
same central frequency ID value as another L1 circuit path going over an L1
link.

Auto Spectrum Assigment

If spectrum blocking occurs and if Auto Spectrum Assigment is T (true), the
L1 circuit path tries to use another central frequency if it isavailable.

This property is useful for simulating optical restoration when thereare L1
failures.

L1 Circuit Path Hop
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Feasibility Property

Description

Central Freguency 1D

The user-specified wavelength of the L1 circuit hop.

The central frequency is used for al of the subsequent hops if no other change
is specified.

Thisvalueissetto “na’ if itisnot explicitly set.

Central Frequency ID Sim

Simulated wavel ength number, which is copied from one of these valuesin this
order of priority:

» The hop's Central Frequency ID value.

» The Central Frequency ID of thefirst preceding L1 circuit path hop that
has a Central Frequency ID value.

« The Central Frequency ID property of itsL1 circuit path.

When you manually create L 1 circuit path hops, WAE Design automatically
creates the first L1 circuit path hop to be thefirst L1 nodein the path. It
also copiesthe L1 circuit path’s Central Frequency ID Sim value to this
hop.

If Auto Spectrum Assignment is used, thisvalueis set to the Central
Frequency ID Sim value of the L1 circuit path.

Thisvalueisset to “na’ if no Central Frequency ID values have been
specified for this L1 circuit path hop or if the L1 circuit path cannot be
routed.

Routing Based on Central Frequency IDs

Central Freguency ID properties affect L1 circuit path routing as follows:

* If the Central Frequency ID is not set and cannot be derived, or if thereis no spectrum blocking, the L1

circuit path is routed.

« If there is spectrum blocking, WAE Design checks the Auto Spectrum Assignment property for each L1

circuit path.

« If F (false), the L1 circuit path is not routed.

« If T (true), WAE Design tries to route the L 1 circuit path on the first central frequency that is
continuously available on al L1 links over whichiit isrouted. If no such central frequency isfound,
the L1 circuit path is not routed.

* Spectral Width ID properties affect L1 Circuit path routing by defining how much spectrum must be
available around the Central Frequency.

Note that the Export Spectrum Utilization tool lets you create and export afile that identifies all of the L1
circuit Central Frequency ID Sim values being used on each L1 link. Choose File > Export > Spectrum

Utilization.

Example: Figure 78: Example Spectrum Blocking, on page 207 showstwo L 1 circuit paths attempting to route
over acommon L1 link (chi-nyc).
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* Path Option 1 uses sea-boi-chi-nyc.

* Path Option 2 uses sea-slc-hst-oke-chi-nyc.

Central Frequency ID Exclude List .

Both have a Central Frequency ID value of 7. Both have Auto Spectrum Assignment set to F (false). Path
Option 1 can route dueto itslower Setup Priority value. Path Option 2 cannot route due to Spectrum Blocking
being T (true). Notice that the Established column is F (false) and the Routed column is Unrouted.

Example: Figure 79: Example Auto Spectrum Assignment, on page 207 shows that Path Option 2 can route
after its Auto Spectrum Assignment property issetto T (true). Asaresult, its Central Frequency ID Sim
automatically changes to an unused Central Frequency |D value so that there is no spectrum blocking. The
Spectrum Blocking column changesto F (false), the Established to T (true), and the Routed to Simulated.
Thereason Path Option 1 can still route, even though its Auto Spectrum Assignment is still set to F, isbecause
it has alower Setup Priority value. Thus, WAE Design uses Central Frequency ID 7 for this path.

Figure 78: Example Spectrum Blocking

boi chi
A_l_ § — — _aa—B
23 e
& &
st oke
m & 7] & > m w
she widc

Path Option 2 Not Routed
Due to Lambda Blocking

L1 Circuit Paths

Path Option Routed

Established Lambda

1 Simulated T
2 Unrouted F

7
7

Lambda Sim Auto Lambda
7F
na F

Lambda Blocking Setup Priority
F
T

4
5

Figure 79: Example Auto Spectrum Assignment
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Central Freguency Exclude list indicates the list of frequency 1Ds that may not serve as Central Frequency
IDsfor L1 Circuit Paths. Central Frequency 1D Exclude lists may be set globally for the entire plan file or
locally for each L1 Link. Local settings override global settings.

To set aglobal exclude list choose Edit > Network Options. On the Edit Network Options dialog box, click
Advanced tab and select alist from the Central Frequency |D Exclude List dropdown.

Cisco WAE Design 7.4.0 User Guide .



Layer 1 Simulation |
. L1 Diversity Constraints

To add an excluded frequency list for an L1 link, right-click one or more L1 links and choose Properties. To
create anew exclude list, see Creating Central Frequency ID Exclude List, on page 229.

L1 Diversity Constraints

L1 Circuits can be configured to be digjoint from other L1 Circuits. This helpsin speedy recovery when
network failures occur.

WAE Design only supports mutual diversity between two L1 circuits. This means, each L1 circuit can only
have one diversity constraint defined. For example, L1 Circuit A and L1 Circuit B can be specified to be
diverse from each other. But WAE design does not support setting of L1 Circuit A to be diverse from L1
Circuit B and L1 Circuit B diverse from L1 Circuit C.

You can specify different levels of diversity. L1 Circuit Path can be set to be diverse in terms of L1 Links,
L1 Nodes, and SRLGs.

The diversity constraints apply to all L1 Circuit Paths of L1 Circuits. For example, if L1 Circuit A and L1
Circuit B are specified to be diverse from each other with each L1 Circuit having two L1 Circuit Paths, then
both L1 Circuit Paths of Circuit A will be diverse from both Circuit Paths of Circuit B.

\}

Note If afully digoint path isnot found, the L1 Circuit Path is not routed.

Relationships Between L1 and L3

Relationships between L1 and L3 objects can be created in multiple ways. Figure 80: Configurable L1 and
L 3 Relationships, on page 209 shows the relationships that can be directly configured.

* You can create L3-L 1 linksto model the physical relationship between L3 nodes and L 1 nodes as shown
in Figure 74: L1-L3 Link Visualization, on page 193.

* You can directly map L1 portsto L3 ports.

* You can directly map L1 circuitsto L3 circuits, or these associations can be formed indirectly. Once
associated with L1 circuits, L3 circuits inherit properties, such as Delay and Distance, from L1 circuits.
Additionally, these associations et you see the effect that failed and inactive L1 links, L1 nodes, and L1
ports have on the L3 network.

Thebasis of indirect L1-L 3 relationshipsisthe fact that every L1 circuit must have two L1 ports and that you
can optionally map these L1 portsto L3 ports.

» When L1 ports are mapped to L 3 portsthat are associated with L3 circuits, L1 circuits becomeindirectly
associated with those same L3 circuits.

 Similarly, when L1 ports are mapped to L3 ports that are associated with L3 port circuits, L1 circuits
become indirectly associated with those same L3 port circuits.

» Two L3 portsare implicitly connected (1) if they are connected to two interfaces on the same L3 circuit
and (2) if they are mapped to L1 ports that are connected to an L1 circuit.

Note that you can enhance the visualization of L1 and L 3 relationships by viewing both layers
simultaneously.
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Example Relations Between L1 Link and L3 Circuit .

Figure 80: Configurable L1 and L3 Relationships
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For More Information... See...

Directly map L1 circuitsto L3 circuits| Mapping an L1 Circuit to an L3 Circuit, on page 234

Directly map L1 portsto L3 ports Mapping an L1 Circuit to an L3 Port Circuit, on page 235

Create L3-L1links Creating L3-L1 Links Between Nodes, on page 230

View L1 and L3 layerssimultaneously | Multi-Layer Visualization, on page 236

Example Relations Between L1 Link and L3 Circuit

Thisexample demonstrates the dynamics between an L 1 link and L 3 circuits. Figure 81: Relationship Between
L1 Linksand L1 Circuits, on page 211 shows an L1 link named kcy-slc that isfiltered to its associated L1
circuits. Each L1 circuit path has one L1 circuit path (Ilabeled “1” on the path) where the end L1 nodes are
labeled A and B. Figure 82: Relationship Between L1 Circuits and L3 Circuits, on page 212 shows the
association of these L1 circuits with L3 circuits.

Cisco WAE Design 7.4.0 User Guide .

407030



Layer 1 Simulation |
. Example Relations Between L1 Link and L3 Circuit

This L1 Is Used By These L1 Circuits... | Which Are Mapped to These L3 Circuits
Link...
key-slc chi-sea crl.chi-cr2.sea

chi-gc cr2.chi-crl.gc

key-sic crl.gc-crlkecy
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Figure 81: Relationship Between L1 Links and L1 Circuits

Example Relations Between L1 Link and L3 Circuit .
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. Delay and Distance

Figure 82: Relationship Between L1 Circuits and L3 Circuits
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Delay and Distance

Both Delay and Distance are properties that can be set inthe L1 link and L1 circuit path Properties dialog
boxes. To automate the process of setting these, usethe L atency and Distance Initializer. For moreinformation
on simulated Delay and Distance, including the Latency and Distance Initializer, see Simulation, on page 69.

L1 Link

Distance: 1119.38

Delay: S.57

L1 Circuit Path

Delay: 25 Distance: 2000

ago9a4
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Delay and Distance .

Column Description

L1Links

Delay One-way transmission latency over the L1 link in milliseconds (ms).

Distance Distance of the L1 link in kilometers (km).

L1 Circuits

Delay Sim * (Derived) Thisvalued is copied from the L1 circuit path Delay Sim column of the

active path.

« If no L3 Delay is explicitly set for the L3 circuit, the Delay Sim column in the (L3)
Circuitstableis copied from the Delay Sim column of the mapped L1 circuit, which
is based on the L1 circuit path being used as the active path.

Distance Sim * (Derived) Thisvalued is copied from the L1 circuit path Distance Sim column of the

active path.

« If no L3 Distance is explicitly set for the L3 circuit, the Distance Sim column in the
(L3) Circuitstableis copied from the Distance Sim column of the mapped L 1 circuit,
which isbased on the L1 circuit path being used as the active path.

L1 Circuit

Paths

Delay One-way transmission latency over the L1 circuit path in milliseconds (ms).

Delay Sim (Derived) If the L1 circuit path Delay valueisentered, it is copied to the Delay Sim column.
Otherwise, thisis set to the sum of the delays of the L1 links over which this L1 circuit
path is routed.

Distance Distance of the L1 circuit path in kilometers (km).

Distance Sim | (Derived) If the L1 circuit path Distance value is entered, it is copied to the Distance Sim
column. Otherwise, thisis set to the sum of the distances of the L1 links over which this
L1 circuit path is routed.

Example: Figure 83: Example Effect of L1 Link Delay and Distance, on page 214 shows how L1 link Delay
and Distance properties affect L1 circuit path properties (and thus, L1 circuit properties), and how they can
potentially affect L3 circuit properties.

 One L1 circuit, which is mapped to an L3 circuit, hastwo L1 circuit paths.

 Because the active L1 circuit path (Path Option 2) has neither a Delay, nor a Distance set, its Delay Sim
and Distance Sim columns are derived by adding together the Distance and Delay values of the L1 links
over which it traverses. The combined Delay of these three L1 linksis 6.880 ms, and the combined
Distanceis 900 km. The L1 circuit inherits these in its Distance Sim and Delay Sim columns.

* Because the L 3 circuit mapped to the L1 circuit does not have a Delay or Distance property, its Delay
Sim and Distance Sim values are copied from the L1 circuit Delay Sim and Distance Sim columns.

 Notethat if the L1 circuit’s active path were to changeto 1 (Path Option 1), the L 1 circuit and its mapped
L3 circuit would have a Distance Sim of 1400 km and a Delay Sim of 10.880.
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Figure 83: Example Effect of L1 Link Delay and Distance
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L1 Failures

L1 links, L1 nodes, and L 1 ports can be set to failed states similarly to L3 circuits and nodesin the L3 topology.

\}

Note For detailed information about visual representations of failure, inactive, and non-operational states, see Plot
Legend for Design Layouts, on page 401. For information on how to fail objects and recover them from failures,
and how to set objects to active or inactive state, see Simulation, on page 69.
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L1 Failure Effects on L3

L3 circuits are rerouted due to L1 failuresif the L3 circuit is mapped to an L1 circuit that would traverse a
failed L1 node or L1 link under normal operations.

Example: Drawing upon the example L1 link, L1 circuits, and L3 circuits relationships shown in Figure 81:

Relationship Between L1 Linksand L 1 Circuits, on page 211 and Figure 82: Relationship Between L1 Circuits
and L 3 Circuits, on page 212Figure 84: Example Effect of Failingan L1 Link or L1 Node on L3 Circuits, on
page 215, shows the effects of failing the kcy-slc L1 link. It also shows the effect of an slc L1 nodefailure. If
an L1 node fails, the connected L1 links are non-operational. In this example, both the L1 link and L1 node

failure have the effect of making the same L3 circuits non-operational.

Example: Drawing upon the example in Figure 84: Example Effect of Failingan L1 Link or L1 Nodeon L3
Circuits, on page 215, Figure 85: Example Effect of Rerouting L1 Circuit Paths, on page 216 demonstrates
what occursif the kcy-gjc L1 circuit path isrerouted. The L1 circuit path takes a southern route, and the L3
circuit continues to route traffic. The L3 view continues to show active routing, and by selecting the mapped
L3 circuit, you can switch to the L 1 view to see both the original (solid green) and rerouted, rerouted L1 path
(dashed lined). Alternatively, you could see the impact of the L1 failure directly in the L3 view by showing
L1 objectsin the background (Figure 86: Multi-Layer View of Rerouting L1 Circuit Paths, on page 216). Note
that the L3 circuit Delay Sim value (in the Circuits table) might change due to the rerouting of the L1 circuit
path.

Figure 84: Example Effect of Failing an L1 Link or L1 Node on L3 Circuits
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Figure 85: Example Effect of Rerouting L1 Circuit Paths
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Resiliency Under L1 Failures

L1 circuit paths can be rerouted around failures using either standby (static) or non-standby (dynamic) L1
circuit paths. If no restrictions are specified with respect to path hops, this reroute takes the best path available

based on L1 link metrics.
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« Standby L 1 circuit paths are always established (available) to route. If there are multiple standby L1
circuit paths, WAE Design triesto route each avail able standby L 1 circuit path based on their Path Option
values (the lower the value, the higher the priority). In thisway you can simulate optical circuit protection,
such as might be configured for 1+1 protection (one primary and one backup path).

* The rerouting of non-standby L1 circuit paths under failure is determined by the “Layer 1 rerouting
convergence under failures’ check box.

v
-
v

Layer 1

v | Layer 1 rerouting convergence under failures

408288

If this check box is unchecked, non-standby L 1 circuit paths do not try to route when failures occur. L3
convergence can be set to different modes, and each one can be combined with this L1 convergence
mode. For example, when combined with setting the L3 simulation convergence mode to Fast Reroute,
deselecting this L1 network option is useful for determining the impact on traffic beforeL1 and L3
restoration has occurred.

If thisoption is selected, non-standby L 1 circuit pathsare dynamically available. That is, they areavailable
only if WAE Design tried to route all standby paths and if the number of routed standby pathsisless
thanthe L1 circuit’'sMin Routed Paths property. Thereafter, WA E Design triesto route each non-standby
L1 circuit path in the order of its Path Option value. This behavior models optical circuit restoration.
When combined with an L3 simulation convergence mode of 1P and L SP Convergence, you can model
the impact failures have on traffic after both L3 and L1 have reconverged.

Regardless of this L1 network option setting, standby L 1 circuit paths that are not affected by the failure
continue to route. For details on how L1 circuit paths are routed, see L1 Simulations, on page 195.

Example: This example assumes that the “Layer 1 rerouting convergence under failures’ check box is
checked. The L1C_chi-atl L1 circuit has three L1 circuit paths (Figure 87: Example of Dynamic
Non-Standby Path Routing Under Failure, on page 218).

* Path Option 1 is standby, and has no hops.
« Path Option 2 is standby, and has a strict kcy hop, and an exclude hst hop.
* Path Option 3 is non-standby and has no hops.

The non-standby Path Option 3 is not routed until both standby paths are unroutable due to failure.
Notice the Routed column changes for all three paths, indicating which paths are routable or
simulated. Also notice that the Established column remains consistent. Thisis because whether or
not an L1 circuit path is available for routing under normal operation has no bearing on whether it
isroutable under failure.

Inthisexample, if the“Layer 1 rerouting convergence under failures’ check box isunchecked, Path
Option 3 does not try to reroute (Figure 88: Example of Non-Standby Path Not Rerouting Under
Failure, on page 218).
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Figure 87: Example of Dynamic Non-Standby Path Routing Under Failure

aN
v

Layer 1

|| Layer 1 rerouting convergence under failures

L1 Circuit Paths

Layer 1 Simulation |

L1 Circuit Paths

Figure 88: Example of Non-Standby Path Not Rerouting Under Failure
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The number of L1 circuit paths that WAE Design triesto route is defined by the L1 circuit's Min Routed
Paths property. If the number of routed standby pathsislessthan the Min Routed Paths property, WAE Design
tries to route non-standby paths. This can be useful when modeling 1+1+R resilience schemes.
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Example: Figure 89: Example Resilience Scheme Using Minimum Routed Paths Property, on page 219 shows
an L1 circuit with Min Routed Paths set to 1. It has three L1 circuit paths; two are standby and one is
non-standby. When one standby L1 circuit path cannot be rerouted under failure, there is no attempt to route
the non-standby path. By changing the Min Routed Path to 2, the non-standby path is routed.

Figure 89: Example Resilience Scheme Using Minimum Routed Paths Property
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Inactive State

L1 links, L1 nodes, and L1 ports can be set to inactive states similarly to L3 circuits and nodesin the L3
topology. Setting an L1 link or L1 node to inactive reroutes L 1 circuit pathsusing that L1 link or L1 node. It
has no effect on the operational state of L3 circuits unlessthe L1 circuit path cannot be rerouted, in which
case the associated L 3 circuit becomes operationally down. Note that the L3 circuit Delay Sim value (in the
Circuits table) might change due to the rerouting of an L1 circuit path.

Example: Figure 90: Example Reroute of L1 Circuit when L1 Link or L1 NodeisInactive, on page 220 shows
arerouted hst-wdc L1 circuit path when an L1 link that it traversesis set to inactive. The same L1 circuit path
reroute occurs as aresult of the atl L1 node being set to inactive.
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Figure 90: Example Reroute of L1 Circuit when L1 Link or L1 Node is Inactive
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L1 Simulation Analysis

L1 linksand L1 nodes can be included in Simulation Analysis either as single objects or as part of SRLGs.
L1 ports can be included as single objects.

Worst-Case Simulations

When included in the Simulation Analysis, their impact on L3 worst-case traffic utilization is reflected in the
L3 Worst-Case Traffic view. Similarly, if an L1 link or L1 node is the cause of worst-case traffic utilization,
it isreflected in the WC Failure column in the Interfaces and Circuits tables.

The L1 Links table updates the following columns when you include L1 links or L1 nodesin the Simulation
Anaysis:

* WC Num L1 Circuit Paths—Number of L1 circuit paths that traverse this L1 link under worst-case L1
failure smulations.

» WC Util Sim—Number of L1 circuit paths that traverse this L1 link under worst-case L 1 failure

simulations as a percentage of the maximum number of L1 circuit paths that can traverse thisL1 link
without failures.

Number of L1 circuit paths that traverse this L1 link under worst-case L 1 failure simulations/ Max L1
Circuit Paths (property value)

The following columns are updated in the L1 Nodes table:
« Num L1 Circuit Paths—Number of L1 circuit paths with paths through the L1 node.
* WC Failures—Failures that cause the worst-case number of L1 circuit paths.

e WC Num L1 Circuit Paths— Number of L1 circuit paths that traverse this L1 node under worst-case L 1
failure simulations.

Failure Impact

The L1 Failure Impact view is available upon running a Simulation Analysison L1 links. The L1 links are
colored according to the maximum L3 interface traffic utilization level that would be caused should an L1
link fail. Similarly, L1 node border colors show the maximum L 3 interface traffic utilization level that would
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Failure Impact .

be caused should an L1 node fail. The color indicates the resulting L 3 utilization and severity of the L3
congestion.

Example: Inthe L1 Failure Impact view, if the chi-bos L1 link shows a utilization of 80-90% and its color
representation is orange, then if that chi-bos L1 link were to fail, one or more L 3 interfaces would react by
exceeding a80% utilization level.

Note

The network plot in the L1 Failure Impact view does not show utilizations unless L1 links or L1 nodes are
included in Simulation Analysis.

If you are showing only an L1 view, site borders show the maximum utilization level that would be caused
elsawhere in the network if L1 nodes within it fail or if intrasite L1 links within it fail. If you are showing a
multi-layer (L1 and L 3) view, site borders show the maximum utilization level that would be caused el sewhere
in the network if a contained L3 node, L3 circuit, L1 node, or L1 link fails.

Example: Figure 91: Example Site Bordersin Failure Impact View, on page 222 is an example of how the site
border of the sea site differs, depending on whether you are showing aLayer 3 view or aLayer 1 view. Notice
that Layer 1 shows the higher failure impact utilization. Thus, when showing a multi-layer view, the border
indicating the highest failure impact takes precedence.

The following columnsin the L1 Links table show the impact of failing L1 linksin Simulation Analysis:

* Failure Impact—Worst-case traffic utilization of L3 interfaces if thisL1 link were to fail. For example,
if thevalueis 70.13%, it meansthat if this L1 circuit failed, the resulting traffic utilization on one or
more L3 interfaces would exceed 70.13%.

* Failure Impact Interface—The L3 interface that will experience the highest utilization as aresult of the
L1 link going down.

Format = if{ Node]I nterface}
Example: if{ cr2.parfto_crl.fra}} meansif the L1 link goes down, it will have the greatest traffic impact
on the cr2.par to cril.frainterface.

The following columnsin the L1 Nodes table show the impact of failing L1 nodesin Simulation Analysis:

* Failure Impact—Worst-case traffic utilization of L3 interfacesif thisL1 node wereto fail. For example,
if thevalueis 70.13%, it meansthat if this L1 node failed, the resulting traffic utilization on one or more
L3 interfaces would exceed 70.13%.

* Failure Impact Interface—The L3 interface that will experience the highest utilization as aresult of the
L1 node going down.

Format = if{ Node]Interface}

Example: if{ crl.chito_cr2.mia}} meansif theL1 node goesdown, it will havethe greatest traffic impact
on the crl.chir to cr2.miainterface.
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Figure 91: Example Site Borders in Failure Impact View
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Worst-Case Failures

After running aSimulation Analysis, you can view the L 1 failure scenarios that caused the worst-case utilization
for an L3 interface. Right-click an L3 interface or L3 circuit and choose Fail to WC. A dialog box opens
from which you can choose afailure scenario to observe. Click OK; the network plot changes to show the
failure scenario. If you arein the L3 view and the worst-case failureis an L1 object, switch views to see the
fallureinthe L1 view.

For information on running Simulation Analysis, failing L 1 objectsto their worst-case utilization, and protecting
L1 objectsfrom inclusion in Simulation Analysis, see Simulation Analysis, on page 79.

Creating L1 Topology

Creating L1 Topology from L3 Topology

WAE Design providesatool that constructs acomplete L 1 topology using an existing L 3 topology asamodel.
You have an option to create the topology based on sites or L3 nodes. WAE Design then shows the same site
inthe L1 view and constructs the following L 1 topol ogy.

* Creates L1 nodes.
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Step 1

Step 2

Step 3

Creating L1 Nodes .

* Create L1 nodes from sites—WAE Design creates one L1 node within each selected site regardless
of the number of L3 nodeswithin that site. The L1 nodes are assigned the same name as their sites.
No L1 nodes are created for L3 nodes that are not residing in sites.

* Create L1 nodesfrom L3 nodes—WAE Design creates one L1 node for each L3 node selected. The
L1 nodes are assigned the same name as the L3 nodes. If the L3 node resides within a site, the L1
node is placed there as well.

* Creates L1 links between all L1 nodes whose corresponding L 3 nodes have connectivity between them.
L1 link metrics are set to 1.

e Createsan L1 circuit and L1 circuit path between each pair of L1 nodes connected by L1 links. TheL1
circuit Path Option valueis set to 1.

* Creates apair of L1 portsfor each L1 circuit.
* Creates alist of blocked Central Frequency IDs.

« Creates the mapping between L1 circuits and L3 circuits. For more information on these mappings, see
Relationships Between L1 and L 3, on page 208.

« Creates one standby L1 circuit path per each L1 circuit, and setsits Path Option to 1.

Follow these stepsto create an L 1 topology from an L3 topology. You can bein either an L1 or L3 view while
performing these steps.

If you want to create an L1 topology based on only specific L3 objects, select those sites or L3 nodes from the L3 view.
If you do not select sites or nodes, the topology is based on all sitesor all L3 nodes, depending on your selection in Step
3.

Creates Layer 1 topology based on existing Layer 3 topology
(11/11) Selected Sites  ~
(11/11) Selected Sit :
{33/33) Selected Nodes

Create Layer 1 Nodes from:

380307

Chooselnsert > Layer 1> L1 Topology from L3 Topology, or right-click the plot and choose New > Layer 1> L1
Topology from L3 Topology.

Select either sites or nodes, and click OK.

Creating L1 Nodes

Step 1
Step 2
Step 3

Step 4

Chooselnsert > Layer 1> L1 Node, or right-click the plot and choose New > Layer 1> L1 Node.

Enter aunique L1 node name.

Choose the site to which you want this L1 node to belong, or choose Noneif you do not want the L1 nodeto residein a
site.

(Optional) Choose the node type from the drop-down list.
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Step 5 (Optional) Enter adescription.
Step 6 (Optional) Click the I dentification tab to enter more descriptive information.
Step 7 Click OK.

Creating L1 Links

Each L1 link name and L1 node combination must be unique.

Step 1 Choose Insert > Layer 1> L1 Link, or right-click the plot and choose New > Layer 1> L1 Link.

Step 2 Enter an L1 link name and description. If the L1 link has the same source and destination as another L1 link, it must have
a unique name. Otherwise, it is not required.

Step 3 Required: Choose the two nodes you want to connect with this L1 link by first choosing the site and then choosing the
node.

Step 4 Optional selectionsinclude:

Field For Information...

Metric L1 Link Metrics, on page 200
Distance, Delay Delay and Distance, on page 212
Feasibility L1 Circuit Wavelengths, on page 201

Frequency 1D Blocked List | Central Frequency 1D Exclude List, on page 207

Protected, Active, Failed | Simulation, on page 69 and Simulation Analysis, on page
79

Step 5 Check SSON Enabled to specify that the L1 Link is SSON enabled.
Step 6 Click OK.

Creating L1 Circuits

You can manually create circuits by using the following method. Additionally, you can automatically creste
L1 circuits using their respective Properties dialog boxes.

Each L1 circuit name and L1 node combination must be unique.

Step 1 Chooselnsert > Layer 1> L1 Circuit, or right-click the plot and choose New > Layer 1 > L 1 Circuit.

Step 2 Enter an L1 circuit name.

Step 3 Choosethetwo L1 ports you want to connect with this L1 circuit by first choosing the sites (if applicable). the L1 nodes,
and then L1 ports.
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Step 4

Step 5
Step 6
Step 7

Plotting L1 Circuits .

Name: (L1Circuit* T
L1 Part & L1 Part
Site: chi v Site: bos v
L1 Nade: chi v L1 Nade: |bos v
L1 Part; |chi-bos v L1 Part; |bos-chi 7| :

Optional selections are as follows:

Field

For Information...

Disjoint Group, Digaint Priority

Explicit L1 Circuit Paths Initializer, on page 199

Bandwidth

Enter avalue for the bandwidth that the L1 circuit requires. Thisvalueis not used for
routing. It is copied to the BW Sim column in the L1 Circuits table. If no valueis
entered, the BW Sim column is set to the simulated capacity of the L3 circuit that is
mapped to thisL1 circuit. The total BW Sim for all L1 circuitsrouting over an L1
link is shown in the Circuit BW Sim column of the L1 Linkstable.

Active Path

Active L1 Path Selection, on page 196

Min Routed Paths

Minimum Routed Paths, on page 218

Check the Prefer Lower Frequency | Dsbased on your requirements.
Check SSON Enabled to specify that the L1 Circuit is SSON enabled.

Click OK.

Plotting L1 Circuits

Step 1
Step 2

Inthe L1 Circuits table, choose one or more L1 circuits.
Right-click and choose Plot L1 Circuits.

To move the plot horizontally or vertically, use the left/right arrows and up/down arrows.

To select all L1 circuits within the plot, click Select L1 Circuits. To deselect all of these L1 circuits, click in an empty

plot area.

Creating L1 Circuit Paths

Step 1

Choose one or more L1 circuits. If you do not choose any, L1 circuit paths are created for all of the L1 circuits.
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Step 2 Access an L1 circuit path in one of these ways:
* Choose Insert > Layer 1> L1 Circuit Paths.
* Right-click an L1 circuit in the L1 Circuitstable and choose Insert L 1 Circuit paths.

* Right-click the plot and choose New > Layer 1 > L 1 Circuit Paths.

Step 3 Select or enter a path option.
Step 4 If the L1 circuit path is a standby path, check Standby.
Step 5 Click OK.

Plotting L1 Circuit Paths

Step 1 Inthe L1 Circuit Paths table, choose one or more L1 circuit paths.
Step 2 Right-click and choose Plot L 1 Circuit Paths.

To move the plot horizontally or vertically, use the left/right arrows and up/down arrows.

To select al L1 circuit paths within the plot, click Select L1 Circuit Paths. To deselect al of these L1 circuit paths,
click in an empty plot area.

Editing L1 Circuit Paths

If editing L1 circuit paths, you can change the L1 circuit to which the L1 circuit path is mapped, including
the sites and L 1 nodes. Other options include:

Field For Information...

Path Options Standby Paths and Path Options, on page 196
Delay, Distance Delay and Distance, on page 212

Setup Priority L1 Circuit Path Setup Priority, on page 201

Central Frequency ID, Auto Spectrum | L1 Circuit Wavelengths, on page 201
Assignment

Feasibility Limit, Acceptance Threshold | L1 Circuit Wavelengths, on page 201

Standby Standby Paths and Path Options, on page 196, Resiliency Under
L1 Failures, on page 216

Hops Explicit L1 Circuit Paths Initializer, on page 199, Creating
Individual L1 Circuit Path Hops, on page 227
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Creating Individual L1 Circuit Path Hops

To manually create L 1 circuit path hops, the L1 nodes or L1 links must already exist. Alternatively, you can
use the Explicit L1 Circuit Paths Initializer, on page 199 to set explicit L1 circuit paths.

Step 1 Right-click an L1 circuit path in the L1 Circuits Paths table and choose Properties, or double-click an L1 circuit path.
Step 2 In the Starts From drop-down list, specify thefirst L1 node hop in the path as either A or B.
Step 3 If you are editing an existing hop, double-click it from the Hops list.

If you are creating a hop on this path for thefirst time, click Insert After in the Hops area.

If you are creating a hop on this path and other hops aready exist, select an existing hop and then click Insert Before or
Insert After, depending on the required order of the hops.

Step 4 Create or edit the node or link hop as follows:

L1 Circuit Node Hops L1 Circuit Link Hops
Inthe Node Hop area, select the siteand its | Click Link Hop.
L1 nodethat you want to set as the hop. Choose both endpoints (site and node) of the L1 link hop you are setting.
Choosethe type as loose, strict, or exclude. Choosethe L1 link name you are creating. Only those L1 links with the
9 L1 Hop endpoints you selected are listed.
Choose the type as strict or exclude.
Site: yc
@) L1 Link Hop
L1 MNode: \myc
e P le:teA. lea-
Loose % Site : hst - Site : kcy b
L1 Link Hop @ : :
Exclude % L1Nods : |hst - L1 Mode @ [key -
Click OK. ]
MName: | "'_
Tipe: (Stktx 2
Strict ]
Ewclude 2
Click OK.

Step 5 (Optional) Add a central frequency ID value for the L1 circuit path hop.

Step 6 Repeat Step 3 to Step 5 as needed for each hop in the path. Because WAE Design always chooses the shortest path, you
must enter enough hops to create an alternate, longer path.

Step 7 Click OK.

Step 8 Inthe L1 circuit path’s dialog box, verify that the list of finished hopsisin the order of the desired path, and then click
OK.
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Creating L1 Waypoints

To create waypoints, we recommend that you set the plot options to be able to view them first.

* To view L1 waypointsin the network plot, you must be in the geographic view and the Layer 1 option
to view them must be enabled in the Layer 1 tab of the Plot Options dialog box.

« To view waypoints within sites, the site must be viewed in a geographic layout or if using a schematic
site view, the site must contain another site. Thisis set in the Site Canvas field in the General Options
tab of the Plot Options dialog box.

The only method in which you can manually specify the Order valueisthrough the L 1 link context menu.
D

Note Onceyou enter the waypoint order value, you cannot edit it. To changeitsvalue,
you must delete and recreate it, or insert another waypoint that would then alter
the order value accordingly.

If no longitude and | atitude coordinates are specified, the waypoint isinserted in the middle between L1
node B and the waypoint closest to L1 node B. If no other waypoints exist on the link, the new waypoint
isinserted in the middle of the L1 link.

L1 Link Properties

Step 1
Step 2
Step 3

Step 4
Step 5

Right-click an L1 link and choose Properties, or double-click an L1 link.
Click the Waypoints tab.
If you are creating awaypoint for the first time, click Insert After.

If you are creating a waypoint on the L1 link and other waypoints already exist, select an existing waypoint and then
click Insert Before or Insert After, depending on the required order of the waypoints.

(Optional) Enter a description, longitude, and latitude.
Click OK.

L1 Link Context Menu

Step 1
Step 2
Step 3
Step 4

Right-click an L1 link and choose Insert L1 Link Waypoint.

Enter the number representing the order in which you want the waypoint to appear in proximity to L1 node A.
(Optional) Enter a description, longitude, and latitude.

Click OK.
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L1 Waypoint Context Menu

Step 1 Right-click an L1 waypoint and choose Insert L1 Link Waypoint > Before/After Selected Waypoint.
Step 2 (Optional) Enter adescription, longitude, and latitude.
Step 3 Click OK.

Duplicating L1 Objects
To duplicatean L1 link, L1 circuit, or L1 circuit path, right-click one and choose Duplicate.

« Duplicating an L1 circuit or L1 circuit path also duplicatesits L1 circuit path hops.

* When duplicating L1 circuits, you can optionally choose to create as many duplicated L1 circuits as
necessary. New L1 ports are created for each duplicated L1 circuit.

When duplicating an L3 circuit, you have the option to duplicate its associated L1 circuit if one exists
and create an automatic mapping to it. If you select no, the newly duplicated L3 circuit mapsto the
existing L1 circuit.

Creating Central Frequency ID Exclude List

Step 1 Chooselnsert > Layer 1> Central Frequency |D Exclude List, or right-click the plot and choose New > Layer 1 >
Central Frequency ID Exclude List.

Step 2 Enter a unique name for the central frequency ID excludellist.

Step 3 Select from thelist of frequency IDs using radio button. You can select multiple frequenciesto be blocked. Usethe Filter
button to narrow the frequency IDs from the list.

Step 4 (Optional) Enter the Frequency | D Lower Bound to specify the lower bound on available central frequency 1Ds.
Step 5 (Optional) Enter the Frequency | D Upper Bound to specify the upper bound on available central frequency IDs.
Step 6 Click OK.

Inserting L1 Diversity Constraint

Step 1 Choose Insert > Layer 1> L1 Diversity Constraints.
Step 2 Enter aunique name for the L1 Diversity Constraint in Name field.

Step 3 Inthe L1 Circuit A area, select the Site, L1 Node, L1 Port for L1 Port A and L1 Port B using the dropdown list.
A list of L1 Circuits for the specified combination is displayed in the Namefield. Select aL1 Circuit combination from
the dropdown list.

Step 4 Similarly, specify the L1 Port A and L1 Port B for L1 Circuit B and select from thelist of matching combinations available.
Step 5 Set the Constraints:

* L1 Node Diversity: Select thisto set the respective paths of the L1 Circuits to be diverse in terms of L1 Nodes.
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e L1 Link Diversity: Select thisto set the respective paths of the L1 Circuits to be diversein terms of L1 Links.
» SRL G Diversity: Select thisto set the respective paths of the L1 Circuits to be diverse in terms of SRLGs.

Note WAE Design allows you to select multiple levels of diversity at the sametime.

« Active: Set this property to Active for smulation to consider the L1 Diversity Constraint.

Step 6 Click OK.

Creating L1 and L3 Mappings

Creating L3-L1 Links Between Nodes

You can model the physical relationship between an L3 node and an L1 node to create an L3-L1 link, which
isan object listed inthe L3-L1 Links table. Creating these relationships can greatly expedite the process of
creating L1 circuits from L3 circuits. For information on how these are used in that process, see Mapping
Multiple L1 Circuitsto L3 Circuits, on page 231.

MHode L1 Mode
Site: ||:hi v| Site: chi -
Mode: ||:r1.|:hi v| L1 Mode: “ ‘}’

\}

Note For L3-L1linksto bevalidfor creating L1 circuits, there must apair of them. That is, there must be one entry
for each L3 end node of the L3 circuit. The L1 circuit that is created uses the L1 nodes to which those L3
nodes are mapped.

Example: ThisL3-L1 Links table shows an example of three L3-L 1 links:
L3 node crl.hst is connected to (linked to) the L1 node hst.

L3 node crl.okc is connected to the L1 node okc.

* L3 node cr2.wdc is connected to the L1 node wdc.

| L3-L1 Links

Mode L1 Node
crlhst hst

crlokc ok

crdwdc widC 4
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Step 1

Step 2
Step 3
Step 4

Mapping Multiple L1 Circuits to L3 Circuits .

Chooselnsert > Layer 1> L3-L1Link, or right-click in an empty areaand choose New > Layer 1 >L3-L1Link.
Note that preselecting an L3 node or L1 node has no effect on the sel ections opened in the dialog box.
Choose the L3 node and the site in which it is contained, if applicable.

Choose the L1 node and the site in which it is contained, if applicable.
Click OK.

Mapping Multiple L1 Circuits to L3 Circuits

Step 1

Step 2

The L1 Circuitsfor L3 Circuitstool creates L1 circuits based on L3 circuits and associates them with the L3
circuits using the following sequence of priorities. For each L1 circuit created, an associated L1 circuit path
isalso created. Nested objects are taken into account.

Select best L1 circuits using L3-L1 Links or site mermbership
) Require L3-L1 Links
@ Create L3-L1 Links

383005

) Do not require or create L3-L1 Links

« If the L3 circuit already has an associated L 1 circuit, oneis not created.

* WAE Design checksthe L3-L1 Linkstable for valid entries.
o If multiple pairs of L3-L1 links exist that could create the L1 circuit, one is randomly used.

e If novalid L3-L1link entry existsand if “Require L3-L1 Links’ isselected, no L1 circuit iscreated.

 If novalid L3-L1 link entry existsand if “Do not require or create L3-L1 Links’ is selected, for
each L3 circuit WAE Design checks for sites that contain both the L3 end node and at least one L1
node.

If multiple L1 nodes are collocated within the same sites as the L 3 nodes, one is randomly sel ected.

If this collocation is not found, WAE Design checksfor L1 nodeswithin the parent sites of the sites
containing the L3 end nodes. If none are found, an L1 circuit is not created.

« If “Create L3-L1 Links" isselected, theL3-L 1 links are created that map the respective L3 and L1 nodes.

If needed, you can make changesto the L1 circuit’s endpoints and the L3-L 1 links that are created by
editing their respective Properties dialog boxes.

Creating L1 circuitsin this manner automatically creates and assigns L 1 ports for the newly created L1
circuits.

In this process, you can optionally use L3-L1 links. If you are using them, verify you have the set of L3-L1 links you
need, and if not, create them. See Creating L3-L1 Links Between Nodes, on page 230.

If you want to create L1 circuits for only selected L3 circuits, first select those L3 circuits. Otherwise, L1 circuits are
created for as many L3 circuits as possible.
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Step 3 Right-click in an empty area and choose Layer 1> L1 Circuitsfor L3 Circuits, or chooseInsert >Layer 1>L1L1
Circuitsfor L3 Circuits.

Step 4 Choose €ither to require the use of existing L3-L1 links, to create them, or neither. Then click OK.

Examples

Figure 92: Topology and Existing L3-L1 Links, on page 232 shows a plan file containing six L3 circuits and
four L3-L1 links. All sites except sea contain one L3 node and one L1 node. The sea site containstwo L3
nodes and one L1 node. Refer to the diagram for details of the objects’ relationships and to see the objectsin
theL3-L1 Linkstable. There are no L1 circuits.

Figure 92: Topology and Existing L3-L1 Links
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If you click Require L3-L 1 Links, WAE Design creates three L1 circuits: one between hst and boi, and two
between sea and boi.
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@ Require L3-L1 Links

L1 Circuits
Name L1Node A L1lNodeB
L1Circuit[l] baoi hst
L1Circuitl2] bol sea @
L1Circuit(1] boi sea Z

If you click Do not torequireor create L3-L1 Links, WAE Design creates six L1 circuits: three using the
L3-L1 Links table and the remaining three by determining that the source and destination sites both contain

L3 and L1 nodes.

@) Do not require or create L3-L1 Links
L1 Circuits

Name L1Node A L1NodeB
L1Circuit[l] boi sea
L1Circuit[1] boi hst
L1Circuit[l] boi slc
L1Circuit{l] hst slc
L1Circuit[l] sea sl¢ o
L1Circuit[2] boi sea %

Using the same topology as in Figure 92: Topology and Existing L3-L 1 Links, on page 232 but with no
pre-existing L3-L1 links, if you click Create L 3-L 1 Links, WAE Design creates the same six L1 circuits as
if you had selected no options. However, it also creates five L3-L 1 links: one for each L3 node having an L3

circuit for which an L1 circuit was created.
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@ Create L3-L1 Links

Created L3-L1 Links Created L1 Circuits
L3-L1 Links L1 Circuits

Node L1 Node Name L1Node A L1NodeB

crlboi boi L1Circuit{l] Dboi sea

cr2.hst hst L1Circuit{l] boi hst

crlsea sea L1Circuit[l] boi slc

cr2sea  sea L1Circuit[l] hst slc

crlsic sle L1Circuit[l] sea slc ~
L1Circuit[2] boi sea %

Mapping an L1 Circuit to an L3 Circuit

Step 1 Right-click an L3 circuit in the Circuits table and choose Properties, or double-click an L3 circuit.
Step 2 Click the Advanced tab.
Step 3 Inthe L1 Circuit area, choose the applicable site, L1 nodes, and L1 ports for ports A and B.
L1 Circuit
L1 Port & L1 Port B
Site ! l{Nune} o | Site ¢ [{Nnne) x l
L1 Mode : |L1_r‘u:u:|e_|:hi - | L1 Mode |L1_r‘u:ude_mia % l
L1 Port: |L1_p|:|rt_|:hi—? - ] L1 Port: |L1_p|:|rt_mia—1 - | a

Step 4 Create and map anew L1 circuit to the L3 circuit, or map an existing one to the L3 circuit.

» Map existing L1 circuit—Click Select and then choose the L1 circuit from the drop-down list of all the available
circuits.

* Create L1 circuit—Click Create and enter a new name for the L1 circuit.
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Then click OK. Creating L1 circuits in this manner automatically creates and assigns L1 ports for the newly created L1
circuits.

Mapping an L1 Circuit to an L3 Port Circuit

Each port circuit can be indirectly associated with an L1 circuit via direct mappings of L1 portsto L3 ports.

Step 1 Right-click an L3 port circuit in the Port Circuits table and choose Properties, or double-click an L3 port circuit.

Step 2 Inthe L1 Circuit area, select the sites (if applicable), L1 nodes, and optionally L1 ports for both ends of the L1 circuit.
Note that if specifying L1 ports and mapping an L1 circuit, the pair must be already associated with an L1 circuit.

Step 3 Map an existing L1 circuit or create a new one, and then click OK.

» Tomap an existing L1 circuit, click Select and then choosethe L 1 circuit from the drop-down list of all the available
circuits. Note that thislist is populated only if the L1 ports selected are connected viaan L1 circuit.

« To create an L 1 circuit, click Create. Enter anew L1 circuit name or use the default name. After you click OK, you
can create L3-L 1 links. If you are creating an L1 circuit and if you did not choose L1 ports, L1 ports are created for
the new L1 circuit.

Mapping L1 Ports to L3 Ports

If an L3 port circuit exists whose L 3 ports are associated with L1 ports, that L3 port circuit is automatically
associated with the L1 circuit that also contains those same L1 ports.

Mapping L1 portsto L3 ports automatically associatesthe L1 circuit to the port circuit if aport circuit exists.

Step 1 Right-click a port in the Ports table and choose Properties, or double-click a port.
Step 2 Click the Layer 1 tab.

Step 3 If applicable, choose the L1 node’s site.

Step 4 Choose the L1 node and L1 port, and then click OK.

Visualizing the L1 Network

Many of the visualization tools available for the L3 view are also available for L1. These tools are described
in the Cisco WAE Network Visualization Guide .

* Assign Sitesto Nodes—Automatically create sites based on L1 node names and a set of parameters that
define which part of the node name to use.

« Arrange Sites and Nodes—A rrange sites and nodes using tools that offer a variety of alignment options
or arrange sites to specific geographic locations. You can aso show and hide sites, and change where
their site name is displayed in the plot.
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* Set Plot Backgrounds—Set the background for the network plot, including schematic view, outline of a
geographic background, and detailed geographic background.

« Create or Edit Layouts—Create multiple layouts for a single plan file, each containing its own set of
visual properties.

Editing L1 Plot Options

The Plot Options dialog box has a Layer 1 tab that lets you change how L1 links appear, whether to view
another layer in the background, and whether to show or hide sites from another layer. Because these are plot
options, they apply to the current layout and are saved on a per-layout basis when you save the plan file. You
can also save them as user defaults. For information on user and system defaults, see the Cisco WAE Network
Visualization Guide .

Step 1 Click the Plot Optionsicon in the top right of the Visualization toolbar, or choose Edit > Plot > Plot Options > Edit
Options.

Step 2 Click the Layer 1 tab.
Step 3 Edit Layer 1 fields as described in the following sections, and then click OK.

L1 Link Appearance
e L1Link Width—The L1 link width is only for visualization purposes and is not related to any property.

L1 Link Text—BY default, thereisno text on L1 links. Usethis option to display the link name, distance,
delay, or the number of L1 circuit paths using the link.

« Show L1 Link Waypoints—If checked, L1 waypoints are shown in the network plot.

* Visualize L1 Link Utilization—If checked, L1 link utilization is shown in the network plot.

Multi-Layer Visualization
Thefirst two background options let you show or hide Layer 1 in the Layer 3 view, and vice versa.

You can also set the degree of opacity of the background objects. The higher the value, the denser (darker)
the background objects appear.

N\

Note In the Visualization toolbar, thereis a Set to Foreground icon that brings selected objects to the foreground
and sends unsel ected obj ects to the background. This, too, has an opacity valuefor specifying the transparency
of background objects. This feature has precedence over the layer opacity set in the Plot Options dialog box.

By default, sites containing only L1 nodes are hidden in the L3 view, and sites containing only L3 nodes are
hidden in the L1 view. Use these selections to toggle whether to hide sites containing only L1 or L3 nodes.
If you are showing alayer in the background, you cannot hide per-layer sites within that view. You can show
and hide individua sites by right-clicking one and choosing L ayout > Hide/Show Site.
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Background Layer

V| Show Laver 1 in the Background of the L3 View
|| Show Layer 3 in the Background of the L1 Yiew

s
-

Opacity of Background Layer 30%

Hide L1 Sites in L3 Yiew

V| Hide L2 Sites in L1 Yiew

imisis
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Quality of Service Simulation

Quadlity of Service (QoS) isameans of ensuring high-quality performancefor critical applications. The concept
isthat because requirements of some users and services are more critical than others, some traffic requires
preferential treatment.

Using WAE Design QoS features, you can ensure that service levels are met without reactively expanding or
over-provisioning the network. QoS features are available for undifferentiated traffic, for service classesalone,
for interface queues alone, and for service classes that are mapped to queues.

« Undifferentiated traffic—Aggregate traffic on an interface.

* Service class—A user-defined classification of traffic that is not discovered by WAE. Examplesinclude
voice, video, and data. Service classes apply to the entire network unless you map them to specific queues.

* Queue—In live networks, traffic waitsin conceptual lines (queues) and then isforwarded over an interface
on a per-queue basis according to QoS parameters. Similarly in WAE Design, each queue has a set of
user-defined QoS parameters (interface queue properties) that specify how these queues are prioritized
and what percentage of traffic they carry. Aninterface contains zero or more queuesthat are discoverable
by WAE. You can also manually create and configure them. The traffic per queue is aso discovered.

This section contains the following topics:

* QOS Parameters, on page 239

» QoS Bound and QoS Violations, on page 241

« Viewing Queue and Service Class Information, on page 247

* Viewing QoS Bounds and QoS Violations, on page 247

* Creating Service Classes, on page 248

« Creating Queues, on page 249

 Assigning Queues to Interfaces, on page 250

» Mapping Service Classes to Queues, on page 250

* Creating or Editing Policy Groups for Interfaces, on page 250
* Creating or Editing Service Class Policies, on page 251

« Editing Interface Queues Properties (QoS Requirements), on page 252

QoS Parameters

In WAE Design, QoS requirements are defined by policies and interface queue properties (Figure 93: Policies
and Interface Queue Parameters, on page 241).
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Policy—Maximum percentage of traffic capacity that can be utilized by either a service class or by
undifferentiated traffic. There are two policies: one for normal operation and one for worst-case scenarios.
Policies set on service classes do not affect QoS requirements of any other service class. Nor would this
parameter have any effect on live network behavior.

In addition to setting policies for the network, you can refine the policy to agroup of interfaces (called an
interface policy group ). For example, you might need to model behavior for service classes offered only on
interfaces of a specific capacity, or you might need to observe service class traffic on only one area of the
network.

Interface queue properties—Configured parameters that would affect routing behavior in alive network. In
WAE Design, the interface queue properties are priority, weight, and police limit.

« The priority identifies the precedence of the queue. For example, traffic in apriority 1 queueis routed
before traffic in a priority 2 queue. Queues with the same priority evenly share the capacity based on
weighted-round robin (WRR) calculations. You can change this behavior using the weight and police
limit parameters. There are an unlimited number of priorities, though most networks only use no more
than three. By default, queues do not have priorities.

» The weight is the percentage of preference given to queues of an equal priority level, which enablesthe
network to fairly distribute the load among available resources. For example, if 10 Gbps were passing
through a 10GbE interface on two priority 1 queues, by default 5 Gbps would pass through each queue.
However, if you set the weight of one queue to 75% and the other to 25%, the distribution would be 7
Ghbps and 2.5 Gbps, respectively. By default, all queues have aweight of 100%.

« The palice limit is the maximum percentage of available capacity permitted through a queue of agiven
priority level, thereby preventing traffic from higher priority queuesfrom starving lower priority queues.
For example, if the interface is a 20GbE and a priority 1 queue has a police limit of 40%, then only 8
Ghbps of interface traffic can go through this queue. By default, all queues have a police limit of 100%.
To see examples of this starvation , refer to the examplesin Policies and QoS Bound Calculations, on
page 243, where you can see that lower priority queues received zero traffic due to priority settings.
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Figure 93: Policies and Interface Queue Parameters
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QoS Bound and QoS Violations

WAE Design uses the concepts of QoS bound and QoS violation as away of identifying whether QoS
parameters are being met or surpassed, thus better enabling you to plan for service requirements across the
network. Policies and queue properties determine the QoS bound calculation. In turn, this cal culation determines
whether thereis aviolation.

QoS Bound—Maximum interface capacity available without violating these QoS requirements. A separate
QoS bound is calculated for both policy and interface queue properties.

QoS Bound for... Calculation Based on...

Interface Queues Combination of interface queue properties, or in live networks, it isthe
capacity percentage that is discovered.

Service class Policy

Service class mapped to queues | The lower of these two calculationsis used:

* Palicy for service class

* Queue properties for queues
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QoS Bound for... Calculation Based on...

Undifferentiated traffic Policy

In the plot, the QoS bound on an interface is a combination of the color and white (Figure 94: QoS Bound
and Available Interface Capacity, on page 242). The interface capacity that is not available because it exceeds
the QoS bound isin gray. Columnsthat convey the QoS bound information are QoS Bound Meas, QoS Bound
Meas (%), QoS Bound Sim, and QoS Bound Sim (%).

Figure 94: QoS Bound and Available Interface Capacity
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QoS bound calculations are a set of decisions being made to determine how to rai se traffic on the queues until
that traffic cannot be raised any further. This capacity, or the reason the traffic cannot be raised further, is
defined both by the QoS parameters and the amount of traffic. For example, when traffic arrives at Queue X,
WAE Design fixes the traffic on all other queues and then determines how it can raise the traffic on Queue
X until some other traffic blocksiit.

For those queues that do not reach full capacity, unused queue capacity is made available for other queues.

QoS Violation—Total traffic minus the capacity permitted for the queue (QoS bound). A violation occurs if
the maximum QoS capacity allotted through policies and interface queue propertiesis exceeded. If the number
appearing in the QoS Violation column is positive, the allotted capacity has been surpassed. If the number is
negative, the allotted capacity has not been reached. In the plot, traffic exceeding the QoS bound appearsin
red and white stripes on the interface in violation (Figure 95: Example QoS Violation, on page 243).
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Figure 95: Example QoS Violation
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Policies and QoS Bound Calculations

If no other QoS parameters are set via the interface queue properties of priority, weight, and police limit, the
QoS bound is equivalent to the policy set.

Table 13: Example Policies and QoS Bound Calculations

Example Configuration QoS Bound QoS Violation (Positive # = Violation)

Interface capacity = 10,000 Mbps 6000 Mbps (60%) —1000 Mbps (—10%)

Undifferentiated traffic = 5000 Mbps Because this number is negative, there is no capacity violation
Normal operation policy = 60% g;g;g;i %4 QoS Bound and Available Interface Capacity, on
Interface capacity = 10,000 Mbps 6000 Mbps (60%) 2000 Mbps (20%)

Undifferentiated traffic = 8000 Mbps Because this number is positive, there is a capacity violation

Normal operation policy = 60% (Figure 95: Example QoS Violation, on page 243).

Interface capacity = 10,000 Mbps Voice = 9000 Mbps (90%) | Voice = —=3000 Mbps (30%)
Voice traffic = 6000 Mbps Video = 6000 Mbps (60%) | Video = —4000 Mbps (40%)
Video traffic = 2000 Mbps

Voice normal operation policy = 90%

Video normal operation policy = 60%
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Interface Queue Properties and QoS Bound Calculations

WAE Design simultaneously calculates QoS bound for each queue in the interface. In so doing, WAE Design
uses the interface queue parameters (priority, weight, and police limit) and the traffic measured or simulated
for all queuesin theinterface. Priority is aways considered first. If there are queues of equal priority, then
weight is applied next.

* Queueswith priority 1 share all availableinterface capacity. Their weight and police limitsfurther refine
how much each priority 1 queue can use (their QoS bound). Each priority 1 queue can borrow available
capacity from other priority 1 queues up to the limit of their QoS bound.

» The available capacity for priority 2 queuesisthetotal interface capacity less all capacity consumed by
priority 1 queues. The process then begins again for al priority 2 queues. Their weight and police limits
determine their QoS bound, and priority 2 queues can borrow capacity from each other up to the limits
set by the QoS bound.

« Thisprocess continuesfor each successive priority level. Traffic that isoutside any QoS bound isdropped
to the lowest priority of al traffic on the interface.

For discovered networks with measured traffic, if no WAE Design QoS parameters are set, the QoS bound
is based on whatever capacity percentages the live network has for each queue.
Priority
Provided policies are not set that further affect the QoS bound, a queue’s QoS bound is calculated as follows:
* Priority 1 QoS bound = 100% of the interface capacity.
* Priority 2 QoS bound = Total interface capacity — amount of traffic consumed by priority 1 queues.

« Priority 3 QoS bound = Total interface capacity — amount of traffic consumed by (priority 1 + priority
2 queues).

QoS bound for each succeeding priority follows this same pattern where the traffic consumed by all
higher priority queuesis subtracted from the total interface capacity.

Table 14: Examples of Priority QoS Bound Calculations

Example Configuration QoS Bound QoS Violation (Positive # | QoS Bound Calculations
= Violation)
Interface capacity = 20,000 Mbps EF = 20,000 Mbps | EF = -14,000 Mbps EF = Total interface capacity becauseitis

the only priority 1 queue

BE = 20,000 (interface capacity) — 6000
(consumed by higher priority queues)

EF traffic = 6000 Mbps; priority =1 | BE=14,000 Mbps | BE =—11,000 Mbps

BE traffic = 3000 Mbps; no priority
set

Interface capacity = 10,000 Mbps EF = 10,000 Mbps | EF = 4000 Mbps EF = Total interface capacity becauseit is

EF Traffic = 6000 Mbps; priority = 1 | BE = 4000 Mbps | BE = 1000 Mbps the only priority 1 queue

_ o BE = 10,000 (interface capacity) — 6000
BE Traffic = 5000 Mbps; priority = 2 (consumed by higher priority queues)
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Weight

weight [J|j

The weight identifies the forwarding precedence for queues of equal priority. If weights for queues of the
same priority do not add up to 100%, weights are converted proportionally so they do add up to 100%.

Table 15: Examples of Weight QoS Bound Calculations

Example Configuration QoS Bound QoS Violation (Positive # | QoS Bound Calculations
= Violation)

Interface capacity = 10,000 Mbps AF1=5000Mbps| AF1 =—-2000 Mbps AF1 = Half of capacity for priority 1
AF1 traffic = 3000 Mbps; priority = 1; | AF2=7000Mbps| AF2 = —1000 Mbps queues becase both queues have equal

S weights
weight = 100%
AF2 traffic = 6000 Mbps; priority = 1; AF2 = 5000 (half OT capacity) +2000
weight = 100% (unused AF1 capacity)
Interface capacity = 10,000 Mbps AF1=6000Mbps|AF1 =-1000 Mbps AF1 = 60% of capacity for all priority 1
AF1 = 5000 Mbps; priority = 1; weight = | AF2=5000 Mbps| AF2 = 1000 Mbps queues

60%

AF2 traffic = 6000 Mbps; priority = 1;
weight = 40%

AF2= 10,000 (interface capacity) — 5000
(consumed by AF1 queue)

Police Limits

Priority 1 queues have 100% of the interface traffic, and thus starve out the remaining queues. To prevent
thisqueue starvation, use police limitsto configure how much of the maximum percentage should be available
for agiven priority level.

Table 16: Examples of Police Limit QoS Bound Calculations

Example Configuration

QoS Bound

QoS Violation (Positive #
= Violation)

QoS Bound Calculations

Interface capacity = 10,000 Mbps

EF traffic = 1000 Mbps; priority = 1; police
limit = 50%

BE traffic = 2000 Mbps; priority = 2

EF = 5000 Mbps
BE = 9000 Mbps

EF = —4000 Mbps
BE = —7000 Mbps

EF = 50% of total interface capacity

BE = 10,000 (interface capacity) — 1000
(capacity consumed by EF)

Interface capacity = 10,000 Mbps

EF traffic = 1000 Mbps; priority = 1; police
limit = 5%

BE traffic = 2000 Mbps; priority = 2

F =500 Mbps
BE = 9500 Mbps

EF = 500 Mbps
BE =—7500 Mbps

EF = 5% of total interface capacity

BE = 10,000 (interface capacity) — 500
(capacity consumed by EF)

Cisco WAE Design 7.4.0 User Guide .




Quality of Service Simulation |
. Interface QoS Bound Calculations Using Multiple QoS Parameters

Example Configuration QoS Bound QoS Violation (Positive # | QoS Bound Calculations
= Violation)

Interface capacity = 10,000 Mbps EF = 2000 Mbps | EF = 1000 Mbps EF = 20% of total interface capacity
EF = 3000 Mbps; priority = 1; police limit | AF1=6000 Mbps | AF1 = —2000 Mbps AF1=75% of (10,000 [interface capacity]
= 0, — i

20% AF2= 4000 Mbps | AF2 = —1500 Mbps 2000 [capacity consumed by EF])
AF1 traffic = 4000 Mbps; priority = 2; AF2 =10,000 (interface capacity) — 2000
police limit = 75% (capacity consumed by EF) — 4000

(capacity consumed by AF1)

AF2 traffic = 2500 Mbps; priority = 2;
police limit 25%

Interface QoS Bound Calculations Using Multiple QoS Parameters

WAE Design calculates a QoS bound for interface queues based on all three parametersif they are all
configured: priority, weight, and police limits.

Table 17: Examples of Interface QoS Bound Calculations Using Multiple QoS Parameters

Example Configuration QoS Bound QoS Violation (Positive | QoS Bound Calculation

#=Violation)
Interface capacity = 10,000 Mbps | EF = 2000 Mbps | EF = 1000 Mbps EF = 20% of total interface capacity
EF = 3000 Mbps; priority = 1; police | AF1=6000 Mbps | AF1 = —2000 Mbps AF1 = Maximum of these two values.
o
limit = 20% AF2= 4000 Mbps | AF2 = —1500 Mbps « 75% of (10,000 [interface capacity] — 2000
AF1 traffic = 4000 Mbps; priority = [capacity consumed by EF])

2; weight = 75% . .
« 8000 (available capacity) — 2500 (AF2
AFR2 traffic = 2500 Mbps; priority = traffic)
2; weight = 25%
AF2 = Maximum of these two values.
* 25% of (10,000 [interface capacity] — 2000
[capacity consumed by EF])

+ 8000 (available capacity) — 4000 (AF1
traffic)

Service Class QoS Bound Calculations Using Multiple QoS Parameters

If service classes have policies and they are mapped to queues, WAE Design cal culates a QoS bound for both.
WAE Design then usesthe lowest value of the two so asto enforce restrictionsin the strictest possible manner.

Example:

Interface capacity = 10,000 Mbps

QoS bound for service class = 50%, or 5000 Mbps based on policy

QoS bound for EF queue = 7500 Mbps based on combined parameters of priority, weight, and police limit
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Viewing Queue and Service Class Information .

The QoS bound for this service classis 5000 Mbps because the policy QoS bound calculation is lower.

Viewing Queue and Service Class Information

Table 18: Queue and Service Class Information

To View Show or Select

Queue information Show the Interface Queue table. Select the queue from the QoS drop-down menu. Both the
plot and the Traff Meas and Traff Sim columns display traffic data specific to the queue
type selected.

Per-queuetrafficin the Interfacestable | Select the queue from the QoS drop-down menu. Both the plot and the Traff Meas and Traff
Sim columns display data specific to the queue type selected.

Per-service-class traffic Select the service class from the QoS drop-down menu. Both the plot and the Traff Meas
and Traff Sim columnsin the Interfaces table display data specific to the service class
selected.

Service class demands Show the Service Class column in the Demands table.

Viewing QoS Bounds and QoS Violations

AsFigure 94: QoS Bound and Available Interface Capacity, on page 242 and Figure 95: Example QoS Violation,
on page 243 demonstrate, the QoS bounds and QoS violations appear in the plot view. Table 19: QoS Bounds
and QoS Violations, on page 247 lists the available column options to display numeric values of the QoS

bound cal culations. For information on QoS values asthey relateto VPNs, see VPN Simulation, on page 279.

Table 19: QoS Bounds and QoS Violations

To View Show This Column in Interfaces, Circuits, or
Interface Queues Table

Measured Traffic

Maximum capacity before a QoS bound is violated under normal operations QoS Bound Meas

QoS bound as a percentage of total interface capacity QoS Bound Meas (%)

QoS violations under normal operations; if the number is positive, thereisa QoS Violation Meas
violation

QoS violation as a percent of the total interface capacity QoS Violation Meas (%)

Simulated Traffic

Maximum capacity before a QoS bound is violated under normal operations QoS Bound Sim

QoS bound as a percentage of total interface capacity QoS Bound Sim (%)
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To View

Show This Column in Interfaces, Circuits, or
Interface Queues Table

QoS violations under normal operations; if the number is positive, thereisa QoS Violation Sim
violation

QoS violation as a percent of the total interface capacity QoS Violation Sim (%)
Worst-Case Traffic

M aximum capacity before a QoS bound is violated under worst-case operations | WC QoS Bound

WC QoS bound as a percentage of total interface capacity WC QoS Bound (%)
QoS violations under worst-case operations; if the number is positive, thereisa | WC QoS Violation
violation

WC QoS violation as a percent of the total interface capacity WC QoS Violation (%)
Service class causing the worst-case utilization WC Service Class

Creating Service Classes

Step 1 Open the Manage QoS dialog box in one of two ways:
« Choose Edit > Manage QoS.

 Choose M anage QoS from the QoS drop-down menu in the toolbar.

Step 2 Click New. The New Service Class dial og box that opens contains queues if they have already been discovered or if they
have been manually created. Otherwise, the dialog box is empty. For instructions on how to create queues, see Creating

Queues, on page 249.
a) Enter aunique name.

b) (Optional) If queues exist and if you want to map this new service class to one or more queues, select them from the
list. If queues do not exist, but you want them, you must manually create the queues and then return to this dialog
box to select them. See Mapping Service Classes to Queues, on page 250.

c) Click OK.
Step 3 Click OK to save and exit.
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What to do next

Figure 96: Create Service Classes
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Creating Queues

Step 1

Step 2

Step 3
Step 4

Step 5

Step 6

WAE Design discovers queues. However, you can manually add them. Once discovered or created, queues
appear in the Interface Queues table.

By default, queues are assigned to all interfaces. If you want this new queue to be assigned to specific interfaces, you
must first select one or more interfaces.

Open the New Interface Queues Properties dialog box in one of two ways:

» Choose Insert > Interface Queues.

« Right click in the plot area choose New > | nter face Queues.

Enter the queue name.

(Optional) Enter the queue properties of priority, weight, and police limit. For information on how these queue properties
behave, see Interface Queue Properties and QoS Bound Cal culations, on page 244.

Click OK. The new queue appears as an option in the QoS drop-down menu in the toolbar, aswell asin the Manage QoS
dialog box.

(Optional) Map a service class to the queue. For instructions, see Mapping Service Classes to Queues, on page 250.
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Another way to create queuesisto edit the name of an existing one. For instructions, see Assigning Queuesto I nterfaces,
on page 250.

Assigning Queues to Interfaces

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

Step 7

The easiest way to assign queuesto interfacesisto select theinterface before creating the queue (see Creating
Queues, on page 249). However, you can follow these steps to reassign the queue to different interfaces.

From the Interface Queues table, select one or more queues.

Double-click; a Properties dialog box opens.

From the Node list, select the node associated with the interface.

From the Interface list, select the interface to which you are assigning the queue.
(Optional) Change the queue name or add a new one.

(Optional) Specify QoS requirements in the Priority, Weight, and Police Limit fields. By default, queues do not have a
priority and both their weight and police limits are 100%. For information on how these properties behave, see Interface
Queue Properties and QoS Bound Calculations, on page 244.

Click OK.

Mapping Service Classes to Queues

Step 1

Step 2
Step 3
Step 4
Step 5
Step 6

To map service classes to queues, those queues must first exist either because they were discovered by WAE
or because you manually added them.

Open the Manage QoS dialog box in one of two ways:
» Choose Edit > Manage QoS.

* Choose M anage QoS from the QoS drop-down menu in the toolbar.

From the Service Classes list, select one service class.

Click Edit.

In the Edit Service Class dialog box, select one or more queues. Click OK.
Repeat for each service class to which you are mapping queues.

Click OK to save and exit.

Creating or Editing Policy Groups for Interfaces

Creating apolicy group for interfaces lets you set policies for the group in the Manage QoS dialog box.
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Step 1
Step 2
Step 3
Step 4

Step 5
Step 6

Creating or Editing Service Class Policies .

Select one or more interfaces.

Double-click to open the Properties dialog box.

Click the Advanced tab.

In the QoS Policy Group field, you have three options:

« To add this interface to an existing policy group, select it from the drop-down list.
« To change the name of an existing policy, select it and then type over it.

» To add anew policy group, select the empty row in the drop-down list and then type the name of the new group.

Click OK.
To assign a service classto this policy group, choose M anage QoS from the QoS drop-down menu in the toolbar.

Creating or Editing Service Class Policies

Step 1

Step 2

Step 3

You can configure policies for undifferentiated traffic and for service classes.

Open the Manage QoS dialog box in one of two ways:
« Choose Edit > Manage QoS.

 Choose M anage QoS from the QoS drop-down menu in the toolbar.

In the Service Class Policies area, click New, or select aservice class row and click Edit.
a) If creating apolicy for undifferentiated traffic, select that option. If creating a policy for an existing service class,
select it from the Service Class drop-down list.

b) (Optional) To apply this service class mapping to agroup of interfaces, select from or enter the name in the Interface
Policy Group drop-down list. You can enter a name that does not exist and then create the policy group for a set of
interfaces. For further instructions, see Creating or Editing Policy Groups for Interfaces, on page 250.

¢) Inthe Normal Operation field, enter the percentage of bandwidth capacity that you do not want this interface (or
group of interfaces) to exceed for thistraffic or service class under normal conditions.

d) Inthe Worst-Case field, enter the percentage of bandwidth capacity that you do not want this interface (or group of
interfaces) to exceed for this traffic or service under worst-case operating conditions.
€) Click OK. These values now appear in the Manage QoS dialog box where you can edit them as needed.

Click OK to save and exit.
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What to do next
Figure 97: Manage QoS Dialog Box

Editing Interface Queues Properties (QoS Requirements)

The three parameters are priority, weight, and police limit.

Step 1 In the Interface Queues table, right-click one or more queues and choose Properties.
Step 2 In the Properties dialog box, change one or more fields to create the desired QoS requirement.
Step 3 Click OK.
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BGP Simulation

This chapter describes how WAE Design models multi-AS networks and simulates basic BGP routing. WAE
Design does not directly emulate BGP routing configurations, such aslocal prefsand MEDs. Rather, it provides
a high-level modeling of typical peering policies, such as standard customer, transit, and settlement-free
arrangements for service providers. This model lets you quickly and easily evaluate the effects of peering
locations and basic policy variations.

Additionally, you can extend these high-level models to significantly more complex policy-based routing
situations using external endpoints as demand sources and destinations. For information on demands and on
external endpoints, see Traffic Demand Modeling, on page 43 and Advanced Routing with External Endpoints,
on page 265.

This section contains the following topics:

« Internal and External AS Types, on page 253
* Inter-AS Routing , on page 254

» BGP Simulations, on page 259

* Trimming A Ses, on page 260

« Creating ASes, on page 261

* Associating Nodes with an AS, on page 262
* Editing AS Routing Policies, on page 262

* Assigning Names to ASNs, on page 263

Internal and External AS Types

To model amulti-AS network, each nodeis assigned an AS, and each AS is defined as either internal or
external . A typical multi-AS model in WAE Design consists of the following:

« A singleinternal AS representing the full topology of your network.
« Individual peering nodes of neighboring external ASes.

* Peering circuits connecting the internal AS to the nodes in the external ASes.
Generally, there are many external ASesin the plan file, but usually only one or afew internal ASes. All
nodesin an external AS are typically placed in the same site, although you can place them in any site. Figure

98: Example Multi-ASModel, on page 254 shows an example model with two internal ASesand four external
ASes.
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AS names and their types are defined in the AS Properties dialog box and listed in the AS table. Nodes are
assigned to ASes in the node Properties dialog box.

ASN: eurod
Hame:
Type internal
exdernal
w
o
AS: eurcd |5

Figure 98: Example Multi-AS Model
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Inter-AS Routing

Route Selection Between Internal ASes

Demands routed within asingle AS have a specified source node and destination node wheretraffic originates
and terminates. Demands routed between two connecting internal ASes are specified in the same manner:
with asource nodein the first AS and a destination node in the second.

WAE Design routes within an AS, to and from the border exit point, are determined by the IGP protocols.
The selection of border exit point is modeled by the Routing Policy, which is set to either Shortest Exit or
Respect MEDs. This property is set in the Edit AS Relationships dialog box, which is accessed through the
AS Properties dialog box.
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Routes Between External and Internal ASes .

N Edit AS Relationships SRS

Editing 1/4 AS Relationships

Routing Policy: |Respect MEDs *J
Shortest Exit

380824

« Shortest exit—The border exit node is selected, which is closest to the source node, within the | GP of
the source AS. If there is atie, the exit node with the lowest BGP ID is used.

 Respect MEDs—The border exit node is selected, which is closest to the destination node, within the
IGP of the destination AS. If thereis atie, the exit node with the lowest BGP ID is chosen.

Figure 99: Route Selection Based on Routing Policy, on page 255 shows these modeled as two internal ASes:
AS A and AS B. The same demand (A1 to B4) isrouted using each of the two different routing policies.

Figure 99: Route Selection Based on Routing Policy
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Routes Between External and Internal ASes

Table 20: Typical AS Routing Configurations, on page 255 lists typical routing configurations that can be

constructed by applying different combinations of Routing Policiesfor traffic in both directions between two
ASes.

* In apeer relationship, routing in both directions is Shortest Exit, which means each controlsits own
border exit points.

* For acustomer relationship, the customer determines the border exit points for traffic in both directions.

« For atransit relationship, the transit AS provides paid transit to the internal AS, so theinternal AS
determines all border exit points.

Table 20: Typical AS Routing Configurations

Type Policy to Policy from

Peer Shortest Exit | Shortest Exit

Customer | Respect Shortest Exit
MEDs
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Type Policy to Policy from

Transit | Shortest Exit | Respect
MEDs

Like traffic routed within an AS, traffic routed between ASes is represented by demands. However, for
demands from and/or to external ASes, the external ASis defined as the source or destination of the demand.
Optionally, the specific node in the external AS from which the traffic enters or exits theinternal ASisalso
specified.

Failover between nodes in the external AS can be modeled. For example, if the traffic is sourced from an
external AS and if the peering circuit from which traffic is entering the internal AS under normal operation
fals, the traffic can enter the internal AS from a different interface or peering node in the same external AS.
In the Demands table, the sources and destinations are represented as follows.

AS{<ASN>}:if{ node_namelinterface_name}
Example: AS{ 33287} :if{ crO1.newyork.ny|POS3/7/0/0}
For more detailed information on demand sources and destinations, see Traffic Demand Modeling .

The ASthat controls the routing chooses which peering node to use. If the internal AS controls the routing,
then because the topology of the internal AS isknown, you can simulate the routing to the peering node.
However, because WA E Design haslimited knowledge of the external AStopology, if theexternal AS controls
the routing, you cannot predict how traffic will be distributed among the exit points.

W3 Edit AS Relationships
AS Relationships
[ Show All ] [SelectAII v | [Filter v] 4/4 rows (1 selected)
From ASType  To AS Type Routing Policy Routing Control

1 External Internal RespectMEDs Internal
2 External Internal shortestExit External
3 Internal External RespectMEDs External -
4 Internal External ShortestExit Internal ,,

The ASthat controls the routing is determined by the AS type, direction of the demand, and the Routing
Policy property as described in Table 21: Determining the AS that Controls the Routing, on page 256.

Table 21: Determining the AS that Controls the Routing

Direction Routing Policy | AS with Routing Control
External ASto Internal AS (Ingress) | Respect Internal
MEDs

Shortest Exit | Externd
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Direction Routing Policy | AS with Routing Control
Internal ASto External AS (Egress) | Respect External
MEDs

Shortest Exit | Internal

Two ASes can bein one of four different routing relationships to one another, depending on which of the two
routing policiesis chosen in each direction (Table 22: Effects of Routing Policy and Routing Control , on

page 257).

« If traffic isrouted to an external AS when it has control and there is no knowledge of its topology, a set
of demands is created from the source in the internal AS (or from another external AS), each with a
destination set to one of the border nodes in the external AS. Thisway, any division of traffic between
the exit points can be model ed.

« If traffic isrouted to an external AS when an internal AS has control, a single demand is created from
the source to the ASiitself. WAE Design simulations determine the correct exit point for this single
demand based on the source.

« |f traffic isto be routed from an external AS when it has control, ademand is created from each nodein
the external ASto each nodein theinternal AS.

« If traffic is to be routed from an external AS when an internal AS has control, ademand is created to
each nodein theinternal AS using the external AS as the source. The demand originates from one or
multiple nodesin the external AS, depending on the topology and the metric cost to reach the destination
node. For example, a single demand from an external AS to a specific node could be sourced from two
different nodes in the external AS, each carrying 50% of the demand traffic.

Table 22: Effects of Routing Policy and Routing Control

Direction Routing Policy | AS with Routing Control | Demand Source or Destination Endpoint | Number of Demands
in Remote AS

External ASto Internal | Respect Internal Entire external AS Oneonly
AS (Ingress) MEDs

Shortest Exit | External Border nodes One for each node
Internal ASto External | Respect External Border nodes One for each node
AS (Egress) MEDs

Shortest Exit | Internal Entire external AS One only

External Meshes

An external mesh consists of two or more external ASeswith a Type property of External. Aninternal AS
typicaly restricts advertisement of BGP routes for some external ASes to other external ASes. For example,
destinations reachable through the transit network would not be advertised to a peer, or vice versa. In WAE
Design, these restrictions are represented by the absence of demands between the two external ASes.
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External Mesh: |Include
Include
Exclude

Each AS has a property called External Mesh, which WAE Design uses when inserting demand meshes into
aplan. Demands are created for external ASes only if one or both ASes have External Mesh set to Include.
If both ASes are set to Exclude, no demands are created for the external AS. For example, in Figure 100:
External Mesh Control, on page 258 the peer and transit ASes are both set to Exclude, so no demands are
created between those ASes. All other external AS demands are included in the demand mesh. Table 23:
External Mesh Settings for Common A S Relationships, on page 258 shows the External Mesh settings for
common AS relationships.

The External Mesh property is set in the AS Properties dialog box.

Table 23: External Mesh Settings for Common AS Relationships

Relationship | External Mesh Setting | Result

Peer Exclude Demands permitted to/from customers only
Customer | Include Demands permitted to/from all external ASes
Transit Exclude Demands permitted to/from customers only

For internal ASes, the External Mesh property isignored. More complex route adverti sement policies cannot
be represented by these simple External Mesh settings. In this case, demand mesh creation must be performed
in severa steps, possibly using a script and the dmd_mesh_creator CLI tool.

Figure 100: External Mesh Control
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BGP Simulations

Aswith all WAE Design simulations, AS routing uses demands. An IP simulation for a particular failure
scenario and traffic level performs these steps.

Step 1 Demands are routed using the established L SPs (if applicable) and using the specified BGP protocol s given the specified
failure scenarios.

Step 2 Interface utilizations are cal culated from the demand traffic using the specified traffic level.

WAE Design allows routes to be calculated between selected nodes even if no demands are present. In this case, only
thefirst step applies.

BGP demands do not failover between external ASes. That is, al traffic to or from an external AS behaves the same
under peering failuresto an external AS. You can change this default behavior using external endpoints to simulate
specific external AS nodes where traffic goesin and out of the network, as well as set priorities so that if onetraffic
source or destination goes down, the traffic can still be sourced from or delivered to another external AS node.

BGP Routing Details

BGP Multihop

WAE automatically constructs BGP pseudonodes where necessary when BGP multihops are detected.

WAE Design models the nodesin external ASesthat are directly connected, for example through eBGP, to
nodesininternal ASes. One exception isthat you can model BGP multihops by setting the node Type property
to psn (pseudonode), such as might occur at a peering exchange. This pseudonode can represent the switch
that connects a number of external AS nodesto the sameinternal AS node. In thisinstance, multiple external
AS nodes are connected by circuits to a BGP psn node, and this node is connected to a node in the internal
AS.

\}

Note In all cases, eBGP multipaths across parallel border circuitsis assumed.

BGP Load Balancing

BGP load balancing to an external AS uses eBGP multipaths or eBGP multihops. WAE Design models these
two eBGP load balancing designsin the same manner, though in the GUI they areidentified only as multipaths.
BGP multipath options are disabled by default.
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EBGP Multipath Incoming Disabled ]

IBGP Multipath 1Enabled =
Disabled
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To set BGP multipath options globally, follow these steps:

Step 1 Choose Edit > Network Options or click the Network Optionsicon in the Visualization toolbar.
Step 2 Click the Protocols tab.
Step 3 For each BGP multipath option that you want enabled, choose Enabled, and then click OK.

» EBGP Multipath—Turns on eBGP multipath within the internal ASes. Demand routings through theinternal ASto
an external AS are divided among external routes with equal-cost BGP exit routes.

« EBGP Multipath Incoming—Turns on eBGP multipath in all external ASes. Demand routings from external ASes
to aninternal AS are divided among external routes with equal-cost BGP exit routes.

 IBGP Multipath—Turns on iBGP multipath within the internal ASes. Demand routes through an internal ASto an
external AS are divided among internal paths to equal-cost BGP exit routes.

BGP Next Hop

In networks, there are two common configurationsfor the BGP next-hop | GP metric used in the path selection.
Oneisto set the next-hop self on the iBGP peers (next-hop self = on). The other isto configure IGP metrics
on eBGP interfaces, and to inject the interface prefix into the |GP database by setting the interface to be a
passive | GP interface (next-hop self = off).

WAE Design does not have an explicit next-hop self setting so it simulates paths as if next-hop self is off.
That is, the IGP metric of the egress peering interface isincluded in the |GP distance to the peering router
and is used in the iIBGP path selection. However, next-hop self to an external AS can effectively be simulated
by setting the metrics on all egress interfaces to that external ASto 0. (You can set the IGP metric in either
the Interfaces Properties or Circuit Properties dialog box accessed through the context menu.)

Trimming ASes

A plan file that uses BGP discovery typically has more external ASesin the plot than you are interested in
viewing or simulating. Some ASes might have very low traffic levels and others might have only one circuit
connecting into theinternal AS. You can trim these unwanted A Sesto simplify the network. Trimming removes
the ASfrom the plan file, but retainsthetraffic in and out of the ASfor simulation. That is, itsinterfacetraffic
is still included in the total traffic of connected nodes.
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Step 1

Step 2
Step 3

Step 4

Creating ASes .

Typicaly, plan files are trimmed before demands are created. However, you can optionally trim demandsin
aplanfile. If any demand is sourced from a trimmed external AS, the demand source is moved to the first
hop on the demand path in the remaining network. Likewise, if ademand has a destination that is a trimmed
external AS, the demand destination is moved to the last hop in the remaining network. If two or more demands
in the same service class are trimmed so that their resulting source and destination nodes are equal, these
demands are aggregated into one demand with their traffic summed. Demands split by ECMPs are converted
into multiple demands, each with traffic divided proportionally to the split ECMP.

Note that multicast demands are removed, and cannot be trimmed.

Select one or more ASes to trim from the AS table.

Trim (1/4) external AS's from the plan.

| Trim Demands

MName of trimmed demands: |Trimmed

1
a1
380838

For example, sort the ASes by traffic level and then select all ASesthat are below the level of interest. Alternatively,
filter the table for traffic using the less than operator (<) and the traffic level, and then select the filtered A Ses.

Right-click one of the selected ASes and choose Trim.
(Optional) Select the option to trim demands.

By default, the moved demands are named “ Trimmed,” though you can enter a different name.

Click Yes.

Creating ASes

Step 1
Step 2

Follow these steps to create an empty AS. After creating the AS, you still need to associate nodes with it and
create therel ationship between this AS and others. See Associating Nodeswith an AS, on page 262 and Editing
AS Routing Palicies, on page 262.

ChooseInsert > AS, or right-click in the empty plot and choose New > AS.
Configure the AS properties:

* ASN—AS number, which isatext string that can be a number or name.
* Name—AS name.

 Type—Internal ASes have afull topology. External ASes have a collapsed topology with just border nodes and a
virtual node.

 External Mesh—When creating a demand mesh, this option tells WAE Design whether to create external meshes.
When one or both ASes are set to Include, WAE Design creates a mesh between the external ASes (default). If both
are set to Exclude, no demands are created.

* IGP Protocol—Choose OSPF, I1SIS, or EIGRP from the dropdown.
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* Description—A text description of the AS.
Step 3 To change the routing policy, click Edit AS Relationships. (The default is Respect MEDSs.) For information on how

these options affect simulation, see Route Selection Between Internal ASes, on page 254.
Step 4 Click OK to create an empty AS.

Associating Nodes with an AS

Step 1 Choose one or more nodes, and double-click any one of them to open the node Properties dialog box.

Node Properties

MName: crl.ams
IP Address:
AS Properties Site: ams
ASM: eurod - AS! eurod
Mame:
Type: internal
External Mesh: |Include
Description: Our Europe network “:
Step 2 In the AS drop-down list, choose the AS to which you want to assign the nodes. Then click OK.

Editing AS Routing Policies
To create AS relationships, set the routing policy.

Step 1 Choose an AS from the AS table.
Step 2 Follow one of these methods to open the Edit AS Relationships dialog box:

 Choose Edit > AS Relationships.
* Right-click an AS and choose Edit AS Relationships.
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* Right-click an AS and choose Properties. Click Edit AS Relationships.

B3 Edit AS Relationships X
AS Relationships
[ showall | [Selectall [v] [Filter [¥| 4/4 rows (1 selected)
From AS From AS Type To AS To AS Type Routing Policy  Routing Control
1 eurc4 Internal euro_transit External ShortestExit Internal
Y curoronst Exteral —leuoé |imemal | RespecteDs
3 euro_transit External us_wan Int - = e Tat I
- = =l
4 us_wan Internal euro_transit Ext{ @ Edit AS Relationships al

Editing 1/4 AS Relationships
Routing Policy: |Respect MEDs ~
Shortest Exit
[ s

Step 3 Choose the AS pair that you want to configure. There is a separate line for each direction in the relationship so you can
configure them independently.

Step 4 Click Edit, set the Routing Policy to Respected M EDs (default) or Shortest Exit, and click OK.
Step 5 Click OK again.

380828

Assigning Names to ASNs

WAE Design can assign names to ASNs by looking them up in the SCARIDEN_HOME/etc/ASNs.txt file.
Thisfile contains alist of all assigned ASNs with their names and descriptions.

Step 1 Choose one or more ASes from the AS table. If no ASes are selected, names are assigned to all ASesin the plan.
Step 2 Choose I nitializers > Assign Namesto ASNSs, or right-click an AS and choose Assign Namesto ASNSs.

Step 3 To assign names only if the ASN does not have one, check Only those with blank Name fields.

Step 4 Click OK.
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Advanced Routing with External Endpoints

To model basic IGP routing, demands are sourced or destined for nodes within the topology. To model basic
inter-A S routing, the sources and destinations are neighboring external A Ses, or acombination of the external
AS and the peering node in that AS. However, more complex routing situations require the use of external
endpoints as the source or destination. External endpoints can contain multiple member nodes and A Ses, and
you can specify when traffic enters or exitsfrom each of them individually. Thisallowsyou to simulate routing
within and between A Ses where multiple traffic entry and exit points are used simultaneously. You can also
prioritize where the traffic fails over to other nodes and A Ses.

There are numerous use cases both for IGP and inter-A S routing:

« Simulate content caching failovers for in-network source of demands that are backed up by another
in-network source. If connectivity islost to the first, traffic is sourced from the second.

» Simulate edge routing with a single entry point into the network edge and a specific failover point.
Alternatively, you could model multiple entry points, depending on which is closest to the destination.

» Simulate complex BGP routing policies from atransit provider. For example, you can specify atransit
entry location and failover location per destination.

 Simulate failover between peering ASes; for example, from one single-connection transit provider to
another.

This section contains the following topics:

« Routing with External Endpoints, on page 265

* States, on page 269

* In-Network Routing Examples, on page 270

* Intra-AS Routing Examples, on page 273

« Creating External Endpoints and Their Members, on page 276

Routing with External Endpoints

An external endpoint isaWAE Design object that identifies specific entry (source) or exit (destination) points
for demands. These are identified in the External Endpoints table by a name and an optional tag.

Each external endpoint consists of one or more members that are defined as nodes, external ASes, or a
combination of an external AS and external node. By setting a demand’s source or destination to an external
endpoint, you can simulate traffic going from multiple sources to a single destination, from a single source
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to multiple destinations, or multiple sources going to multiple destinations. Because of this flexibility, they
are useful for specifying secondary entry and exit pointsin the event of failures.

External Endpoint Members

Each member is assigned properties that prioritize traffic entering and exiting that member, in what order to
fail over to another member, and how to distribute traffic for members of equal priority. These properties are
set when you create the member, and all members are listed in the External Endpoint Memberstable.

Member Endpoint: Node *|
Site: [chi *]
Mode: |cr2.chi = |
Priority (1,2,3...) : 1
Equal Priority Routing: IFix Traffic -
L)
Traffic Balance (%): 50 =
m

» Member Endpoint—Defines whether the member isanode, AS, or external node viaan AS.

* Priority—The sequential order in which external endpoint members are used in the simulations should
failures occur.

« Equal priority routing—If members have the same priority, this property identifies how the traffic is
distributed.

\}

Note Memberswithin an external endpoint that have the same priority must either al be Shortest Path or none of
them be Shortest Path.

* Shortest Path—Use the member that results in the use of shortest path between source and destination.

If amember isusing a shortest path, the Traffic Balance (%) column in the External Endpoint Memberstable
shows “na”

* Fix Traffic—Set the traffic across members of equal priority as defined in the Traffic Balance (%) field.

* Deduce Traffic—Behaves the same as Fix Traffic in that it sets traffic across members of equal priority
as defined in the Traffic Balance (%) field. However, upon running Demand Deduction, the Traffic
Balance (%) field is updated based on the measured traffic in the network. Note that Demand Deduction
only estimates the traffic balances for external endpoints with a priority that isin use in the current
no-failure simulation. Thus, Deduce Traffic is usually set to Priority 1.
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Routing Simulations

)

Note Although this section describes demands as being sourced from an external endpoint, the same methodol ogy
holds true if ademand’s destination is an external endpoint.

If ademand’s sourceis defined as an external endpoint, the foll owing sel ection of external endpoint members
ensues.

Priority (1,2,3...) : 1

50817

Step 1 Memberswith the highest priority (lowest number) are used asthe demand’s source. For example, if the external endpoint
has two members with a priority of 1, the demand is sourced from both members provided they are available.

If one or more of the members are not available, the traffic from the unavailable membersis evenly redistributed to the
other top priority members.

Step 2 If none of the top priority members are available to source the traffic but there are next-priority members available, Step
1 isrepeated for the next priority external endpoint members. Only if all members with the same priority fail does the
traffic get routed according to the next priority in the sequence.

Note that if afailure occurs that does not affect the external endpoint member’s ability to send or receive traffic, then
traffic is rerouted as usual without a need to use the additional members.

If an external endpoint member isan external AS, with or without a node specified, then the routing from or to that
member is determined by the BGP routing policy determined by the AS relationships. The distribution of traffic between
external endpoints with the same priority is the same as for node members.

Member Endpoint: External AS
AS: | euro_transit
Node: (unspecified) %

Traffic Distribution

Thetraffic distribution through these demandsis based on the Equal Priority Routing property, and if applicable,
the Traffic Balance (%) property used to define the external endpoint members.

Equal Priority Routing: |Shortest Path X

L s 1
Balance

Fix Traffic
| Deduce Traffic

018

a8
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If thereis only one member and it is defined as Shortest Path, the demand takes the shortest path as
defined by the IGP metrics.

Of the routable demands, if the Traffic Balance (%) values are all empty, the traffic isrouted and equally 1oad
balanced across the demands with the shortest | GP paths. Note in the case of multiple internal ASes, the
shortest IGP route is the shortest route in the first AS the demand enters.

If multiple members of the same priority are set to Shortest Path, the demand takes the path with the
shortest IGP path. If al interfaces between the source members and the destination have the same shortest
IGP paths, then the traffic is load balanced equally across them.

If one or more members of the same priority have their Equal Priority Routing property set to Fix Traffic
or Deduce Traffic, the demand traffic is split according to each member’s Traffic Balance (%) value.

« If the Traffic Balance percentages across sources with the same priority sum to lessthan 100%, the
overall demand traffic is decreased to that percentage.

« If an external endpoint member of the same priority fails, the traffic on the remaining members
increases in proportion, so that the same amount of traffic is still routed.

Example: Node A failed. Nodes B, C, and D each have a priority of 2 and are each a Fix Traffic type. Their
traffic balances are 20%, 20%, and 40%, respectively. The demand has 1000 Mbps of traffic.

Member Prionty Type Traffic Balance (%)

A 1 ShortestPath na
C 2 FixTraffic 20.00

B 2 FixTraffic 20.00
D 2 FixTraffic 40.00 |
E 3 ShortestPath na %‘

« Because Node A failed, the demand routes 200 Mbps traffic through node B, 200 Mbps through C, and

400 Mbps through D, totaling 800 Mbps (Figure 101: Example Effect of Failures When Using External
Endpoints, on page 269).

If Node D fails, the demand routes 400 M bps traffic through Node B and 400 through C. If Node B fails
too, the entire 800 Mbps is routed through C (Figure 101: Example Effect of Failures When Using
External Endpoints, on page 269).

If al three priority 2 membersfail, 1000 Mbpsis routed through node E, which isthe priority 3 member
(Figure 101: Example Effect of Failures When Using External Endpoints, on page 269).
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Figure 101: Example Effect of Failures When Using External Endpoints
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States

External endpoint members can be failed, set to an inactive state, and included in Simulation Analysisto
calculate aworst-case failure analysis. Additionally, they can be included in SRLGs, which in turn can also
be failed, set to inactive, and included in Simulation Analysis. Table 24: L1 Link Failure and Inactive States

, On page 270 shows the icons used for these states.
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If the external endpoint member that you fail or set to inactiveisan AS, entry through any of its nodesis not
possible. Thesameistrueif an SRLG isfailed or set to inactive and if it contains an external endpoint member
thatisan AS.

Table 24: L1 Link Failure and Inactive States

External Endpoint Member Description

If the external endpoint member isanode, thisicon appears under that
node in the plot. If the member is an external AS or an external AS
viaanode, thisicon appears under al nodesin the AS.

E —’i Failed external endpoint member.

) External endpoint member is not operational becauseitis
- contained in afailed SRLG.

3 E External endpoint member is not active.

S, External endpoint member is not operational becauseitis
- contained in an SRLG that is not active.

In-Network Routing Examples

Content from Multiple Data Centers

This example demonstrates servers that cache content for customers in Kansas City (crl.kcy). The primary
server islocated in San Jose (crl.gc), with backup serversin Mountain View (crl.mtv) and Palo Alto (crl.paa).
Each of the serversis amember of an external endpoint (Sjc_server) that is used as the source of the demand
to crl.key.

. Cisco WAE Design 7.4.0 User Guide



| Advanced Routing with External Endpoints

Content from Multiple Data Centers .

Figure 102:
Endpoint Member Priority Traffic Balance (%) Type
sjc_server crlsjc na ShortestPath
sjc_server crl.mtyv na ShortestPath
paa M .- sic_server  crl.paa 3 na ShortestPath
miv B -
. Route Available Through
i Priority 1 Member
Interfaces Demands Nod
| Show All_| (Select All (¥] [Filter [¥] 1/8 rows (1 selected)
Source Destination Traffic 2
1| EP{sjc_server} crlkcy Ej

» Member crl.gc hasapriority of 1, and it takes the shortest path.

* Member crl.mtv hasapriority of 2, and it takes the shortest path.

» Member crl.paahas apriority of 3, and it takes the shortest path.

Figure 103: Example Failover for Multiple Data Centers, on page 272 shows how the failure scenario works.

» When the priority 1 server node fails (crl.sic), content continues to be delivered using crl.mtv asthe

source.

« If crl.mtv also fails, crl.paa sources the traffic to crl.kcy.
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Figure 103: Example Failover for Multiple Data Centers
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paa B .
L4 et

I ==

External Source

If priority 1 member fails, traffic is
sourced from priority 2

If both priority 1 and priority 2
members fail, traffic is routed on
the priority 3 member

380798

One method of modeling an external demand source with multiple entry pointsis to construct an edge node,
connecting it to these entry points, and giving the interfaces equal metrics. Then source the demand from this

edge node.

Alternatively, you can construct these multiple entry points using a single external endpoint as the demand
source, thus reducing the complexity of the topology.

In thisexample, ademand has an external source with two entry pointsthat comeinto the network at Chicago.
External Source, on page 272 demonstratestwo waysto model this source. One uses additional topology (edge
node) to source the demand. The other uses a single external endpoint that has two members (crl.chi and
cr2.chi), both set to priority 1 with shortest path traffic.
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Figure 104: Example External Demand Source

chi x| chi x|

External Source

crl.chi cr2.chi Modeled as crl.chi .ghi
- o T erd Edge Node - -“ﬁ@%% -

poe - L 1"«
e

o @ External Source T @
' Modeled as
: : External Endpoint : :
al.chi Crgachi crigchi i
cr2sea Gole e o T 1P T T cribas . :—-A-%ﬁ% cribos
Member Priority  Traffic Balance (35) Type
crl.chi il na ShortestPath 5
oo
cr2.chi 1 na ShortestPath 2

Intra-AS Routing Examples

Failover to Nodes in External ASes

This example demonstrates a content provider (Acme) who sources most incoming Internet traffic through a
transit provider, and thistraffic isthen distributed to Acme's customers. Acme has identified specific policies
for each market using communities, and these policies determine, per location, which transit provider peering
pointsare used for primary routing and failover. The network is set up asfollows (Figure 105: Example Transit
Peer AS 2 San Diego Sends Traffic to Customersin an Internal AS, on page 274):

« The San Diego, Boise, Cheyenne, and Seattle nodes each belong to the same transit provider, AS 2.
* The remaining nodes belong to Acme'sinternal AS (AS 1), and these are Acme's customers.

* The San Diego node (prl.sdg) in AS 2 is sending traffic to three key customers located in Phoenix
(crl.pho), Salt Lake City (crl.dlc), and Denver (crl.dnv).

Cisco WAE Design 7.4.0 User Guide .



Advanced Routing with External Endpoints |
. Failover to Nodes in External ASes

Figure 105: Example Transit Peer AS 2 San Diego Sends Traffic to Customers in an Internal AS

[ as ]

ASN  Type External Mesh Node Count Peering Circuit Count

1y 1 internal  exclude 5 4
2.2 external exclude 4 4
AS 2 Seattle l"
‘:\v\‘ Bozeman
= [ hodes |
i < L .
‘\?\ ) Name Site AS
\\)\ i
AS 2 Boise M, e 1 erlsle Salt Lake City 1
- 1 AS 2 Cheyenne ”
: S 2 crlsjc San Jose 1
sat Loke Lo -
i 3 crl.pho Phoenix £ ¢
-.ZDenver
4 crldnv Denver 1
" 5 crl.boz Bozeman di
San Jose = =
6 prd.boi ASNZ2 Boise 2
, -"'-thoenix 7 pr3.sea ASN2 Seattle 2
AS 2 San DiegUA 8 pr2.chy ASNZ2 Cheyenne 2
9 prlsdg ASNZ2 San Diego 2
Demands |
Show All | [Select All [] [Filter [*] 3/3 rows (3 selected)
Source Destination Traffic ECMP Min %
1 iEP{9894?:4?58} crldnv 500.00 100.00
2 iEP{9894?:4758} crl.pho 500.00 100.00 =
- @
3 |EP{98947:4758}  crlslc 500.00 100.00 2

In WAE Design, Acme uses an external endpoint named after community 98947:4758. It containsthefollowing
members, all of which are in the same AS 2 transit provider:

* prl.sdg set to priority 1 with shortest path traffic
* pr2.chy set to priority 2 with shortest path traffic
» AS 2, which means the remaining nodes in the AS, set to priority 3 with shortest path traffic

AsFigure 105: Example Transit Peer AS 2 San Diego Sends Traffic to Customersin an Internal AS, on page
274 shows, multiple demands are created using this external endpoint (98947:4758) as the source, and each
sending traffic to a different customer destination. Figure 106: Example Failover Within the Same External
AS, on page 275 focuses on the traffic destined for Denver (crl.dnv), showing that thefailover scenario behaves
asfollows:

« If afailure prevents the peer prl.sdg node from sending traffic to crl.pho, afailover occursto pr2.chy
within that same peer to avoid a service disruption.

« If failures prevent prl.sdg or pr2.chy from sending traffic to crl.dnv, the remaining nodesin the AS
sourcethetraffic. Although thisis set to use the shortest path, because there are multiple paths, the traffic
isdistributed evenly.

The same result could have been achieved by setting the priority 1 to an interface going from San Jose to
prl.sdg and by setting the priority 2 to an interface going from Salt Lake City to pr2.chy.
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Figure 106: Example Failover Within the Same External AS

Failover from an External AS to Another .

If priority fails, priority 2 in the
same AS sources the traffic
A5 2 Seattle W, Member Priority Traffic Balance (%) Type
SN Bozerman prlsdg 1 na ShortestPath
B pr2.chy 2 na ShortestPath
'~ | AS{2) 3 na ShortestPath
AS 2 Bose W, - Tl
Ny AS 2 Cheyenne
Sakt Lake 9’ o -
- - ____*-ZDenver
e
Sanlose If neither priority 1, nor priority 2
S can source the traffic, then it is sourced
* 8 Phoenix from the remaining nodes in the AS
AS 2 San Diequ
AS 2 Seattle As
4 Bozeman
- ; - s n
Interfaces | Demands Shortest Paths |  Nodes | : E
_Show All | [Select All [*] [Filter [¥] 3/3 rows (1 selecte % 1
AS 2 Boise &
Source Destination Traffic ~ng‘ 1 AS 2 Cheyenne
1|EP{98947:4758)  crldnv 500.00 Sakt Lake Gy 8 - - W
o T
|} .
San Jose \
e
" @ Phoenix &
AS 2 San DmgoA o
o)

Failover from an External AS to Another

In this example, asmall ISP (AcmeNet) buys transit from two other service providers. AcmeNet peers with
AS 2in Phoenix and AS 3 in Denver. AcmeNet has a customer base in Phoenix (crl.pho). The customer has
apreferred access to the Internet through San Francisco (prl.sfo) in AS 2 (Figure 107: Example Transit Peer
ASN2 San Francisco Sends Traffic to Customersin an Internal AS, on page 276), and the secondary access
isthrough Denver (pr2.dnv) in AS 3 (Figure 108: Example Failover to aDifferent External AS, on page 276).
In WAE Design, AcmeNet simulates this network by creating an external endpoint (Internet) containing two

different external ASes as members.
* AS 2 ispriority 1 with shortest path
* AS 3ispriority 2 with shortest path

The demand is sourced from this external endpoint named Internet.
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Figure 107: Example Transit Peer ASN2 San Francisco Sends Traffic to Customers in an Internal AS

AS

ASN  Type External Mesh  Node Count  Peering Circuit Count
11 internal  exclude 4 3
212 external exclude 1 i
33 external exclude 1 1

Nodes Salt Lake
T e

Name Site 57 R&:w»u_;:il'-'l'-l"' 3 Q AS 3 Denver
1 crlpho Phoenix 1 \\ =
2 prlsfo ASNZ2 San Francisco 2 AS 2 San Francisco ; "
3 pr2.dnv ASN3 Denver 3 —

Phoeni;Z':': i

| Interfaces : Demands | Shortest Paths E Nodes | LS|
Show All | [Select All (¥ [Filter [*] 1/16 rows (1 selected)
Source Destination Traffic ECMP Min % é
1/EP(internet}  crlpho 43110 100.00|8

Figure 108: Example Failover to a Different External AS

Member Priority  Traffic Balance (%) Type

AS{2) 1 na ShortestPath
AS{3} 2 na ShortestPath Sait L ake
.---""-.-lﬁ.
CE e WS BN AS 3 Denver
A
AS 2 San Francisco > A,

U

ae0E

Creating External Endpoints and Their Members

The recommended method of creating external endpoint membersisto do so while creating the associated
external endpoint, as follows.
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Step 1

Step 2
Step 3

Step 4

Creating External Endpoints and Their Members .

Right-click in an empty areaand choose New > Demands > External Endpoint, or choosel nsert > Demands> External
Endpoint. The External Endpoint Properties dialog box opens.

To edit an existing external endpoint, double-click it from the External Endpoints table.

Enter a unique external endpoint name in the Name field.
To add a new member, click New.

To edit an existing member, select it from the Members table and click Edit.

An external endpoint member dialog box opens.

Member Endpoint: Node ']
Interface ;
External AS | chi T |
Mode: cr2.chi - |
Priority (1,2,3...) 1

Shortest Fath i
Fix Traffic
Deduce Traffic

Equal Priority Routing:

Traffic Balance {%):

| Protected

AB0B15

a)

€)

Specify the member type as Node, I nterface, or External AS.

» For nodes, choose the site and node name.

« For interfaces, choose the site, node, and interface. Using an interface lets you specify the exact interface on
which the demand traffic is going into or out of a node.

* For ASes, choose the AS name, and select either the “ unspecified” option or node name within the AS. The
“unspecified” option routes traffic evenly throughout the entire AS.

Enter a priority number to determine the sequence in which the member is used with other membersin this external
endpoint. Multiple members can have the same priority.

Select whether to use a shortest path route, or to direct a specified percentage of traffic across membersthat have the
same priority (Fix Traffic or Deduce Traffic).

If balancing traffic, enter the percentage of traffic this member should route.

If you set Deduce Traffic, thisvalue is updated by Demand Deduction provided there are no members with a higher
priority that are in use under normal (non-failure) operation.

Click OK.

Click OK in the External Endpoint Properties dialog box.
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VPN Simulation

The WAE Design virtual private network (VPN) model is arepresentation of avirtual subnetwork within the
plan file. Viewing and simulating VPN within WAE Design facilitates many network tasks and can answer
guestions, such as:

« Which VPNs are on my network? Where and how are they configured?
» Which VPNs are using congested interfaces?
» Which VPNswill experience congestion under any of agiven list of failure scenarios?

» Which failures scenarios cause the worst-case congestion or latency for aVPN?

There are many varieties of VPNSs. For example, there are Layer 2 (L2) VPNs and Layer 3 (L3) VPNSs, each
with different categories within it, and there are vendor-specific VPN implementations. Each VPN type has
its own specific configuration and terminology. The WAE Design VPN model supports a number of these
VPN types based on either route-target or full-mesh connectivity.

This section contains the following topics:

* VPN Model, on page 280

* VPNs, on page 281

* VPN Nodes, on page 283

* Layer 3 VPN Example, on page 284

« VPN Simulation Analysis, on page 287

* Creating VPN Nodes, on page 288

* Creating VPNs, on page 288

» Adding VPN Nodes to VPNs, on page 290

Cisco WAE Design 7.4.0 User Guide .



Il PN Model

VPN Simulation |

VPN Model

VPN Objects

Object Description Examples

VPNs A set of VPN nodesthat can exchange * Layer 2 VPN: The VPN represents an individual
data with each other. VPLS containing virtual switch interfaces (VSIs).

* Layer 3VPN: The VPN represents sets of VRFs
associated with a set of VPN nodes that forward
traffic between themselves. Often, this set of VRFs
signifies a single customer or service.

VPN Connection pointsin a VPN. They * Layer 2 VPN: The VPN node represents the VSIs
nodes exist on standard nodes, and each node configured on each router.
can contain multiple VPN nodes. A

VPN node can be in only one VPN. * Layer 3VPN: The VPN node represents the VRF

instances configured on each router.

VPN Topology and Connectivity

WAE Design VPN topology route connections are established through route targets (RTs) or through a full
mesh of VPN nodes. The Connectivity property is set in the VPN Properties dialog box.

Connectivity: ‘RT

[a}

Full Mesh |z

m

Knowing aV PN'’stopology and connectivity lets WAE Design cal culate which demands between VPN nodes
carry traffic for aparticular VPN, and thus which interfaces carry traffic for that VPN. In turn, WAE Design
can calculate the vulnerability of a VPN to certain failure and congestion scenarios.

A demand is associated with a VPN, meaning it carriestraffic for that VPN, if the following is true:
* The two VPN nodes are in the same VPN.
* The demand isin the same service class as the VPN.
* Only for VPNswith RT connectivity, the RT Export property of one VPN node must match the RT
Import property of another VPN node.

Once demands are associated with the VPN, this configuration simulates the associated access circuits
exchanging traffic as if they were on the same LAN.

Note that a demand associated with a VPN can additionally contain other traffic that is for that VPN.
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I |

Connectivity | Description

Full mesh | Full-mesh connectivity is a complete mesh of connections between VPN nodesin aVPN so
they can all communicate with one each other. This connectivity istypical inaVPLS, where
al VSlsidentify one another based on a common AGI.

Route Route targets model the more complex connectivity used in Layer 3 VPNS, such as
targets hub-and-spoke networks. Here, the V RFs exchange datawith one another based on the matching
of RT Export and RT Import properties set for each VPN node.

Having an import/export pair does not create bidirectional communication. Rather, traffic
flowsin the opposite direction of the routed advertisements. For example, if node A's RT
Import matches node B’s RT Export, traffic can flow from node A to B.

For traffic to flow from node B back to node A, node B must have an RT Import that matches
an RT Export of node A. This combination of matching imported and exported RTs defines
which VPN nodes can exchange data. The VPN name identifies the VPN itself.

VPN Node A VPN Node B

RT Import: @ :1; 100:100

RT Export: ( 1:1 }——"" |

31261

VPNs

Each VPN consists of a set of VPN nodes that can exchange data within it. VPNs have three key properties
that uniquely identify them and define how the traffic within them is routed:

* Name—Unique name of the VPN.

» Type—Type of VPN. You can choose from the defaults (VPWS, VPLS, or L3VPN), or you can enter a
string value to create a new one. Once entered, the new VPN type appears in the drop-down list and is
available for other VPNs and VPN nodes.

« Connectivity—Determines how WAE Design cal cul ates connectivity and associated demandsfor VPNSs:

* Full Mesh—Connectivity is between all nodesin the VPN. WAE Design ignores the RT Import
and RT Export properties of the VPN nodes.

» RT—Connectivity is based on the RT Import and RT Export properties of its VPN nodes.

VPNs Table

The VPNstable liststhe VPN properties, its associated service class, traffic, and the number of VPN nodes
within that VPN (Table 25: VPNs Table Columns for Normal Operation , on page 282). For information on
QoS measurements, see Quality of Service Simulation, on page 239. For information on the Worst-Case
columns not listed here, see Table 27: Simulation Analysis Columnsin the VPNs Table, on page 287.
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Note Because the traffic and QoS calculations are based on all interfaces within the VPN for the service class
specified for that VPN, the plot view might differ from the table. For example, the plot view could show
Internet traffic while a VPN carrying voice traffic is sel ected.

Table 25: VPNs Table Columns for Normal Operation

Columns Description

All traffic and QoS violations are based on traffic
carried on all interfaces used by the VPN for the
service class defined for that VVPN.

Service Class Service class associated with this VPN. All values within the table are associated
with this service class.

Num Nodes Number of VPN nodesin this VPN.

Util Meas The maximum measured utilization of all interfaces used by this VPN.

Util Sim The maximum simulated utilization of all interfaces used by this VPN.

Total Src Traff Meas Total amount of measured source traffic on this VPN.

Total Dest Traff Meas Total amount of measured destination traffic on this VPN.

QoS Violation Sim Maximum QoS violation under normal operations for all ssimulated traffic for all

interfaces used by this VPN. If the number is positive, thereis a violation.

QoS Violation Sim (%) QoS violation as a percent of the total smulated interface capacity.

QoS Violation Meas Maximum QoS violation under normal operations for all measured traffic for all
interfaces used by this VPN. If the number is positive, thereisaviolation.

QoS Violation Meas (%) QoS violation as a percent of the total measured interface capacity.
Latency Maximum latency of all demands used by this VPN.
Tags User-defined identifiers that makesit easy to group VPNSs.

VPNs are not selectable from the network plot; you can only select and filter to VPNs through tables. When
selected, all VPN nodes within the VPN are highlighted in the plot (Figure 109: VPN Nodes Within a VPN,
on page 284).

Identifying Interfaces Used by VPNs

To view which interfaces are associated with a VPN, right-click a VPN in the VPNs table and choose Filter
toInterfaces. Thisisuseful for viewing the VPN topology in the network plot. If you then choose all of these
filtered interfaces, you can see the VPN outlined in the network plot.
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To view which VPNs are associated with an interface, right-click an interface in the Interfaces table and
choose Filter to VPNSs. Thisisuseful for determining which VPNs are affected if acircuit fails or goes down
for maintenance.

Note  Utilization measurements might be different between the tables because the VPN table cal culates measurements
only for the service class associated with that VPN.

VPN Nodes

VPN nodes are defined by properties that determine which VPNs the nodes belong to and how the demands
are routed. The following are required properties:

» Node—Name of the node on which the VPN node resides. This node hame corresponds with onein the
Nodestable.

» Type—Thetype of VPN. You can choose from the defaults (VPWS, VPLS, or L3VPN), or you can enter
astring value to create a new one. Once entered, the new VPN type appears in the drop-down list and is
available for other VPN nodes and VPNSs.

* Name—Name of the VPN node.

* VPN—Name of the VPN in which this VPN node resides. The drop-down lists shows existing VPNs of
the same type set in the Type field. You can create a VPN node without setting its VPN, but without it,
the VPN nodeis not included in simulations as a member of any VPN.

To simulate RT connectivity, you must set the VPN Connectivity property to RT and then set the RT
Import and RT Export properties on the individual VPN nodes within it.

* RT Import and RT Export—The pairing of RT values identifies which VPN nodes connect with each
other. For more information, see VPN Topology and Connectivity, on page 280.

* (Optional) RD—Route distinguisher (RD) uniquely identifies routes within a VRF as belonging to one
VPN or another, thus enabling duplicate routes to be unique within a global routing table.

VPN Nodes Table

The VPN Nodes table lists the VPN node properties, as well as columns that identify the VPN nodes’
relationship within the VPN and its traffic (Table 26: VPN Nodes Table, on page 283).

Table 26: VPN Nodes Table

Columns Description

Total Connect | Number of VPN nodes that are connected to this VPN node as defined by the RT Import and RT Export pairings.
These may or may not be in the same VPN.

VPN Connect | Number of VPN nodes that are connected to this VPN node and are in the same VPN as defined by the VPN
column.
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Columns Description
Num VPN Number of nodesin the VPN that this VPN node belongs to as defined by the VPN column. Thisvalueis“na’
Nodes if the VPN node does not belong to a VPN.

Src Traff Meas | Total amount of measured traffic entering the VPN at this node (source traffic).

Dest Traff Meas | Total amount of measured traffic leaving the VPN at this node (destination traffic).

Tags User-defined identifier that makes it easy to group VPN nodes into asingle VPN. If you give aVPN node atag,
when you create a VPN later, you can identify its VPN nodes using tags.

VPN nodes are not selectable from the network plot; you can only select and filter to them through tables.

Once selected from the VPN Nodes or VPNs tables, the associated site and the nodes within that site appear
with agreen circle on it (Figure 109: VPN Nodes Within a VPN, on page 284).

Figure 109: VPN Nodes Within a VPN

Layer 3 VPN Example

This example illustrates a scenario where the Acme manufacturing company has three offices, but permits
the two branch (erl.par and erl.fra) offices to exchange data only with headquarters (erl.lon).
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Additionally, headquarters communicates with an SPV PN node (er1.bru) that isnot in the Acme VPN. Figure
110: Example RT Connectivity and Acme VPN Footprint, on page 286 shows the footprint of the Acme VPN
and the RTs set for all VPN nodesin this example.

* The VPN isnamed Acme, and it is set to a Connectivity of RT and a Type of L3VPN.
« In turn, each branch officeis set to the Acme VPN, with a Type of L3VPN.

« To exchange data with two other VPN nodesin the Acme VPN, headquarters (erl.lon) imports the
offices’ exported route targets of 2:1 (erl.par) and 3:1 (erl.fra).

* In turn, headquarters (erl.lon) exports aroute target of 1:1.

All three of these other VPN nodes import it (both offices and the SP VPN node).

Because the SP VPN node (erl.bru) is not in the Acme VPN, its communication with erl.lon is not within
the context of that VPN.

| Acme VPN

Acme VPN Nodes SP VPN Node
Name: Acme Type: L3VPN Type: L3VPN
Type: L3VEN Name: Acme_VRF Name: Management
Connectivity: :_RT | VPN: Acme VPN:

The VPN footprint in Figure 110: Example RT Connectivity and Acme VPN Footprint, on page 286 shows
that if the circuit between erl.fraand erl.bru became congested or failed, the VPN would be impacted.
However, afailure of the circuit between the two branch officeswould not impact it. Thisfailureisillustrated
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in Figure 111: Example Failure Between Branch Officesin the Acme VPN, on page 286, which shows that
none of the demands associated with the VPN are rerouted.

Figure 110: Example RT Connectivity and Acme VPN Footprint

RT Import: 2:1; 3:1; 100:100
Ams
RT Export: 1:1 — "B

=

RD: 71 RT Import: 1:1
_ RT Export:  100:100
|8 RD: 10:20

Headquarters - Lon

‘Ofﬁce Fra
T RT Import:  1:1
RT Export:  3:1

RD: 7:3 i
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o

o

381254
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For this example, Figure 112: VPN Nodes Filtered to Acme VPN, and Acme VPN Filtered to Demands, on

page 287 illustrates thefiltering of VPN nodesto itsassociated Acme VPN and thefiltering of the Acme VPN

toitsassociated demand traffic. It also showsthe cal culations of the Total Connect and VPN Connect columns
in the VPN Nodes table.

« The Total Connect for the VPN node residing on erl.lon, headquartersis highest because it exchanges
data with three other VPN nodes.

Each of the offices and the service provider VPN node have only 1 in the Total Connect column because
they each exchange data only with (have RT pairings with) headquarters.

» The VPN Connect for the VPN node residing on erl.lon, headquartersis highest because it exchanges
datawith and isin the same VPN as the two offices; all three VPN nodes share the same VPN name.
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VPN Simulation Analysis .

Each office has 1 in the VPN Connect column because it communi cates with only one VPN node in the same

VPN.

The service provider VPN node (erl.bru) has 0 VPN Connects because it does not reside in adefined VPN.
Figure 112: VPN Nodes Filtered to Acme VPN, and Acme VPN Filtered to Demands

VPN Simulation Analysis

When you run a Simulation Analysis, you have the option to record worst-case utilization and latency for
VPNsinthe VPNstable (Table 27: Simulation Analysis Columnsin the VPNs Table, on page 287). You can
then right-click a VPN to fail it to its worst-case utilization or to fail it to its worst-case latency.

[ Yools

Simulator

Simulation Analysis

|| calculate demand worst-case latency

| Calculate VPN worst-case utilizations and latency

J81262

Table 27: Simulation Analysis Columns in the VPNs Table

Columns

Description

All calculations are based on traffic carried on al
interfaces used by the VPN for the service class
defined for that VPN.

WC Util

Worst-case VPN utilization over al failure scenarios.

WC Failures

Failures causing the worst-case utilization of the VPN.
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Columns Description

WC Traffic Level Traffic level causing the utilization of the interface identified in the WC Util
column.

WC QoS Violation Highest worst-case QoS violation for al interfaces used by this VPN. A QoS
violation is equal to the worst-case traffic minus the worst-case capacity
permitted (worst-case QoS bound).

WC QoS Violation (%) Highest worst-case QoS violation for all interfacesin this VPN expressed asa
percentage of total capacity.

WC Latency Maximum VPN latency over failure scenarios considered.

WC Latency Failures Failures causing the worst-case VPN latency.

Creating VPN Nodes

Step 1
Step 2

Step 3
Step 4
Step 5

Step 6
Step 7

Step 8
Step 9

Right-click in an empty plot area and choose New > VPNs > VPN Node, or choose Insert > VPNs > VPN Node.

In the Site and Name fields, choose the site in which the VPN node will exist, and choose the node on which the VPN
node is being configured.

Choose a VPN type or enter astring value for a new one. The defaults are VPWS, VPLS, and L3VPN.
In the Name field, enter the name of the VPN node, which does not have to be unique.

From the VPN drop-down list, choose the VPN to which you are adding this VPN node. If you do not see the VPN that
you expect to see, verify that you correctly chose the type.

(Optional) Enter adescription that identifies the VPN node. For example, a customer name might be helpful.

If the Connectivity for the VPN is RT, enter the applicable route targetsin the RT Import and RT Export fields. All VPN
nodes with the same import RT as another VPN node’s export RT can receive traffic from that VPN node. Those VPN
nodes with the same export RT as another VPN node's import RT can send traffic to that VPN node.

(Optional) Enter aroute distinguisher in the RD field.
Click OK.

Creating VPNs

You can create VPNs from existing VPN nodes or you can create new VPNs and then later add VPN nodes
with them.

Creating VPNs from Existing VPN Nodes

When you create VPNs from existing VPN nodes, all VPN nodes are assigned to these newly created VPNs
and the existing V PNs become empty. Thisis because VPN nodes can belong to only one VPN at atime.
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Step 1
Step 2

Step 3
Step 4

Creating VPNs from Existing VPN Nodes .

Inserts VENs for (3/3) selected VPN Modes
| RegExp substitution of vaﬁj&; substitution of VPN Node ame. | |
VPN Node Name: (.+) RegEm substitution of VPN Node RD
VPN Name: g1 LEuiece g
Service Class:
Preview
Name RD Tags MNew VPN Name
1 éEast_Region-A ABC East  East_Region-A
2 East_Region-B East_Region-B =
3 West_Region-B ABC_West West_Region-B

If you are creating a VPN for specific nodes, choose VPN nodes from the VPN Nodes table.

Right-click in an empty plot areaand choose New > VPNs > VPNsfrom VPN Nodes, or chooseInsert > VPNs> VPNs
from VPN Nodes.

From the drop-down list, choose the method for creating the VPN: VPN node name, RD, or VPN node tag.

If applicable, enter the VPN node name or VPN node RD, and enter the VPN name. These two fields work together to
createand namethe VPN. Both fieldsuseregular expressions. The$inthe VPN Namefield identifieswhich parenthetical
expressioninthe VPN Node Nameor VPN Node RD field to use. For example, $2 means usethe second set of parenthesis
from which to create the VPN name.

« The default is aregular expression that matches the entire VPN node name and to create one VPN for each unique
VPN node name. That is, the default in VPN Node Name is (.+) and the default VPN Name is $1, which creates a
VPN with aname that isidentical to each VPN node (or al VPN nodes if none are selected).

If your convention is to use the same VRF name or the same service | D for every VPN node, this default works well. If,
however, the VPN name is encoded in the VRF name or service ID, use aregular expression to isolate the part of the
VPN node name that is to be used.

Example: By adding characters before or after the parenthesis, you can create aset of VPNsthat are similar to VPN node
names.

Selected VPN node names: AG-VPN-AMS and AG-VPN-FRA

VPN Node Name: AG-(.+)

VPN Name: $1

Resultsin two VPNs: VPN-AMS and VPN-FRA

Example:

Selected VPN node names: vif AKD_V001_Amsterdam, vif AKD_V001_Paris, and vif_AKD_V001 Frankfurt
VPN Node Name: (vrf)_(.+)_(V[0-9]+) _(.+)

VPN: $2
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Resultsin one VPN: AKD
« If you created a VPN from VPN node RDs (Step 3), WAE Design uses regular expressions for both the VPN Node
RD and VPN Namefields.
Example: Create a VPN named “7” from three existing VPN nodes with RDs of 7:1, 7:2, and 7:3.
VPN Node RD: (.+):(.+)
VPN:$1

« If you created aVPN from VPN node tags, WAE Design uses atag to create the new VPN. If aVVPN node has more
than one tag, only the first tag listed is used. (To create VPN node tags or to change the order of their appearance,
use the VPN Node Properties dialog box. Open it by double-clicking one or more VPN nodes.)

Step 5 To see alist of VPN nodes that will be included in the VPN and the VPN names being created, click Update Preview.
Step 6 Choose the service class for the VPN and click OK.

Creating New VPNs

Step 1 Right-click in an empty plot area and choose New > VPNs > VPN, or choose Insert > VPNs > VPN.

Step 2 Enter a unique name for the VPN.

Step 3 Choosethe VPN type: VPWS, VPLS, or L3VPN.

Step 4 Choose the service class for the VPN.

Step 5 Click OK.

Step 6 (Optional) Add VPN nodes to the newly created VPN.

Adding VPN Nodes to VPNs

Step 1
Step 2
Step 3

Right-click one or more VPN nodesin the VPN Nodes table and choose Proper ties.
In the drop-down list, choose the VPN to which you are adding the VPN nodes.
Click OK.
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Multicast Simulation

WAE Design supports source-specific multicast (SSM), which is amethod of delivering multicast packets to
receivers only from a specified source address that is requested by the receiver. By limiting the source, SSM

reduces resource requirements and improves security.
This section contains the following topics:

* SSM Parameters, on page 291

« Discovered Versus Simulated Multicast Flows, on page 291

» Multicast Demands, on page 294
* Creating Multicast Flows, on page 297

« Creating Demands for Multicast Flows, on page 299
* Toggling Multicast Flow Destinations to On and Off, on page 299

SSM Parameters

SSM is specified by an (S,G) parameter per multicast flow. The (S,G) pair islabeled using a dot-decimal
notation similar to IP addresses (for example, 1.1.1.1, 2.2.2.2). Each (S,G) pair is the name of a multicast
flow, and each flow islisted in the Multicast Flows table.

Discovered Versus Simulated Multicast Flows

How you work with multicast flows within WAE Design differs depending on whether the multicast flow
was discovered by WAE or whether you are smulating it (Table 28: Discovered Versus Simulated Multicast

Flows, on page 291).

Table 28: Discovered Versus Simulated Multicast Flows

Discovered Multicast Flow

Simulated Multicast Flow

Creation

WAE discovers multicast flows—(S,G) pairs)—and multicast
traffic isderived from the Multicast Flow Traffic table (accessed
from the Multicast Flows tab after choosing Edit > Traffic).

First, manually create the multicast flow, defining
both the source (S) and the destinations (G). Next,
create a demand that links the source to these
multicast destinations, alowing the routing to be
simulated through the network.
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Discovered Multicast Flow Simulated Multicast Flow

Hops Each discovered multicast flow includes multicast flow hops, | When you create ademand, it determines the path
which are node-interface combinations through which the to take.
multicast path flows. The Multicast Demand initializer uses
multicast flow hops to determine multicast sources and
destinations.

External hops| WAE discovers multicast flow hops on interfaces that are When you create a demand, it determines the path
external to the plan file. These are interfaces from a plan node | to take, but multicast external flow hops are not
to an external node, or from an external nodeto aplan node. |identified.

The Multicast Demand initializer uses multicast flow external
hops to determine multicast sources and destinations.

Destinations | WAE does not identify alist of multicast destinations for each | Specify destinations (nodes, interfaces, external
flow. The Multicast Demand initializer generates destinations | ASes, or externa endpoints) when you create
from the Multicast Flow Hops and Multicast Flow Externa multicast flows. When creating multicast demands,
Hops tables. specify these as multicast destinations.

Applicable » Multicast Flows * Multicast Flows

tables

* Multicast Flow Hops * Multicast Flow Destinations

» Multicast Flow External Hops « Demands

 Multicast Flow Traffic (accessed from the Multicast Flows
tab after choosing Edit > Traffic)

Plot displays * Selecting a multicast flow from the Multicast Flow table * Selecting multicast demands from the Demands
highlights a pink path on the plot (Figure 113: Multicast table highlights the multicast path in blue on
Flows, on page 293). the plot and labels the source as A and the
. . . destinations as Z.

* Selecting a multicast flow hop from the Multicast Flow
Hops table highlights a pink path on the plot (Figure 114: * Selecting multicast flow destinations from the
Multicast Flow Hops, on page 293). Multicast Flow Destinations table labels the

final destinationswith aZ inthe plot.
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Figure 113: Multicast Flows

Global Multicast Simulations .
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Global Multicast Simulations

Flow Hops

If aplan file contains multicast information, it includes the current hops taken by multicast flows. You can
specify that WAE Design multicast simulations should follow these flow hopsif possible. Thisisuseful, for
example, when calculating incremental routing changes on the current network state, such as those caused by
afailure. For planning purposes, when the current state is not relevant, you can change this behavior to

disregard the multicast flow hops.
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Multicast Simulation |

V] Use multicast flow hops |:

381160

WAE Design uses the network state in its multicast ssimulation. You can set simulations to take into account
multicast flow hops, as follows.

Step 1 Choose Edit > Network Options or click the Network Optionsicon in the Visualization toolbar.
Step 2 Click the Simulation tab.
Step 3 To use or disregard multicast flow hopsin simulation, check or uncheck Use multicast flow hops, and click OK.
Cisco Next Hop
For manually inserted demands, all SSM demand traffic for the (S,G) pair (multicast flow) goes through any
interface that is traversed by that demand.
Multicast
Multipath Selection [Gscaneﬂl-inp 'J
Dissbled | |2
However, you can set WAE Design to use Cisco next hops, which are calculated using ahash on Sand G for
amulticast flow (S,G). The hash calculation is different in |OS and |0S XR. The default behavior is that of
|OS. The IOS XR hash is used on al nodes whose OS field starts with |OS XR.
Step 1 Choose Edit > Network Options or click the Network Optionsicon in the Visualization toolbar.
Step 2 Click the Protocols tab.
Step 3 From the Multipath Selection drop-down list, choose CiscoNextHop, and click OK.

Multicast Demands

For discovered multicast flows, you can insert demands manually or use theinitializer.

For simulated multicast flows, create demands manually. For information on demandsin general, see Traffic
Demand Modeling, on page 43.

To find demands associated with amulticast flow, right-click either a multicast flow or multicast flow

destination, and choose Filter to Demands. Conversely, to find multicast flows associated with demands,
right-click a demand and choose Filter to > Multicast Flows.
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Initialized Multicast Demands

Theinitializer creates simulated multicast flows corresponding to the discovered multicast flows. The demand
traffic for all traffic levels existing is set to the traffic measured in the multicast flow. Following is how WAE
Design determines the source and destination.

» Source—WAE Design first looks for an external endpoint with the same source (S) name as the source
of the discovered multicast flow. If this source does not exist, WAE Design infers it from the multicast
flow hops that have traffic going out of them, but none coming in. The inferred source can be a node or
external endpoint.

* Destination—WAE Design first looks for multicast flow destinations with the same (S,G) name asthose
in the discovered multicast flow. If these multicast node destinations do not exist, WAE Design infers
them from the multicast flow hops that have traffic going into them, but none coming out. WAE Design
aso infers multicast external flow hops if traffic is leaving anode in adirection that is outside the plan.
These destinations are populated in the Multicast Flow Destinations table.

To run thisinitializer, choose | nitializer s> Multicast Demands.

Simulated Multicast Demands

For manually inserted demands, all SSM demand traffic for the (S,G) pair (multicast flow) goes through any
interface that istraversed by that demand. SSM demands are routed to take the shortest path from the destination
to the source, rather than from the source to the destination, as unicast demands do. By default, multicast
multipath is disabled. If two paths of equal cost exit from a node on the route back to the source, the path is
chosen based on:

* The remote interface with the highest |P addressiis used.

« If IP addresses are not available, the router name with the lowest lexicographical nameis used.
However, you can set WAE Design to use the Cisco next-hop multicast, multipath selection method. For
information, see Cisco Next Hop, on page 294.

The sources of these multicast demands can be nodes, interfaces, external ASes, or external endpoints. Using
interfaces lets you specify the exact interface on which demand traffic is entering. Using externa endpoints
letsyou model situations where the multicast source is outside of the nodesin the plan, and there is more than
one possible entry point of the traffic flow into and through the interfacesin the plan.

In this example, the selected demand has a node source of DEN, and a multicast destination containing two
nodes. CHI and OKC. The source node (S) is marked by A, and the destinationsin the receiver group (G) are
marked by Z.
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Source (A) = DEN

sJC

/ ,% Multicast destination (Z)
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includes CHI and OKC
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You can model asourcethat isoutside the plan using external endpoints. In this example, the demand’s source

isan external endpoint that contains SJIC and DEN as members. The multicast destination includes both CHI

and OKC.

Source SJC and DEN are
both members of an

external endpoint Dii

S

2

(=141

]

Viewing Multicast Flows

To highlight discovered multicast flows and multicast flow hopsin the plot, select them from their respective

tables. To view sources and destinations of multicast demands, select the demand from its table. The source
isidentified in the plot by A and the destinations are identified by Z.
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For complex multicast flows, filter to the demand, right-click the demand, and choose Plot Demand. Figure
115: Example Demand Plot of Multicast Flow, on page 297 shows an example of ademand plot for amulticast
flow.

Figure 115: Example Demand Plot of Multicast Flow

Selected Demand for Multicast Flow Demand Plot for Multicast Flow
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To View... Show This Table
Multicast flows, including both source and receiver names Multicast Flows

Discovered multicast flow hops, including (S,G) name, hop node, and hop | Multicast Flow Hops
interface

Discovered multicast flow external hops (destinations that areinferred as | Multicast Flow External Hops
external tothe plan), including (S,G) name, direction of the outbound interface

User-created multicast flow destinations, including (S,G) name and destination | Multicast Flow Destinations
node

Multicast demands Demands

Creating Multicast Flows

The recommended method of creating multicast flow destinations is to do so while creating the associated
multicast flows, as follows.
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Multicast Flow properties

Basic | User _| Tags ]

Multicast Destinations

Select All [*| | Filter |*| 0/0 rows (0 selected)
Destination
Select Destination [é]

Destination: cr2.chi

[Node ‘]
Site: | chi -
Node: Add Destination...
OK ] [ Cancel

Multicast Simulation |

Step 1 Choose Insert > Multicast Flow, or right-click the plot and choose New > Multicast Flow. A Multicast Flow dialog

box opens.

Step 2 In the Sfield, identify the source node by entering its dot-decimal name; for example, 2.3.2.3.

Step 3 In the G field, identify the collective name for all receiver nodes (destinations) by entering its dot-decimal name; for
example, 7.7.7.7.

Step 4 Add destinations to the receiver group.
a) Click Add Destination.

b) Inthe Typelist, select either anode, interface, external AS, or external endpoint.

¢) If you are adding a node to the receiver group, select both the site and node name of the destination point in the

multicast flow.

If you are adding an interface, select the site, the node, and the interface.

If you are adding an external AS, select the external AS name and node for the destination point.

If you are selecting an external endpoint, select its name.

d) Click OK. These values now appear in the Multicast Flow dialog box, where you can disable or enable them from
participating in the multicast flow.

Step 5 Repeat Step 4 for each destination in the multicast flow.
Step 6 Click OK to save and exit.

After creating the multicast flow, you need to create demands for the multicast flows.
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Creating Demands for Multicast Flows

Step 1
Step 2
Step 3

Step 4

Step 5

Choose Insert > Demands > Demand, or right-click the plot and choose New > Demands > Demand.
In the Name field, enter the name of the demand.
In the Source area, define the source (S) of the multicast flow.
a) Fromthe Type list, select the source as a node, interface, external AS, or external endpoint.
b) For node sources, select both the site and the node.
For interface sources, select the site, node, and the interface.

For external ASes, select both the external AS and the node within the plan file through which this external traffic
flows.

For external endpoints, select its name.

In the Destination area, define the receiver group (G) of the multicast flow.
a) From the Type list, choose M ulticast Destination.
b) From the Receiver list, choose the receiver that identifies the ssmulated multicast flow (S,G).

(Optional) Complete all other fields as needed, and then click OK.

Toggling Multicast Flow Destinations to On and Off

Step 1

Step 2
Step 3

In the Multicast Flowstable, double-click the multicast flow. A dialog box openswith alist of existing destinations. Each
destination hasa T next to it if it is currently part of the receiver group or an Fif it exists, but is not part of the receiver

group.

Included Destination
1 [OF if{crlams|to_cr2.ams} |,
> T crl.chi =

To enable or disable the multicast flow destination, click its associated T/F value.
Click OK to save and exit.
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Metric Optimization

The Metric Optimization, on page 302 tool optimizes metricsin the network core. It replaces the IGP metrics
of core interfacesin a network plan with new metrics chosen to maximize the throughput achievable by the
resultant routes, under a specified set of failure scenarios.

The Tactical Metric Optimization, on page 304 tool lets you quickly fix local congestion by doing as few
maodifications as possible on selected interfaces to push utilizations under a given level.

Note The core of the network must be connected, and all nodes must be contained in one AS. That is, there must
be a path between any two core nodes that passes only through other core nodesin the same AS, and not
through edge nodes. If thisis not the case, Metric Optimization signals an error.

This section contains the following topics:

* Core Versus Edge, on page 301

» Metric Optimization, on page 302

* Tactical Metric Optimization, on page 304
* Reports, on page 305

Core Versus Edge

WAE Design plan filesallow nodesto be defined as either core nodes or edge nodes. Note that these definitions
arenot related to any explicit router configurations. A similar classification of circuitsis determined implicitly
by the nodes they connect. If acircuit is attached to one or more edge nodes, it is defined as an edge circuit.
Otherwise, itisacorecircuit. Edge metrics and core metrics mean metrics of edge or core circuits, respectively.

This core and edge distinction helps define certain policies followed by WAE Design tools. In Metric
Optimization, these are as follows:

* Only core metrics are changed.
« The objective isto minimize utilization in the core. Utilization in the edge is not taken into account.

* The routes selected by the metrics are restricted by the tool so that any route between a source and a
destination will enter the core at most once, and leave the core at most once. That is, edge leakage of
routesis prevented.
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A consequence of these policiesisthat larger edge metrics in the plan file to be optimized might result in
better optimized core routes. With larger given edge metrics, the Metric Optimization tool has more flexibility
in how it can set the core metrics without |eakage of routes into the edge.

Metric Optimization

There are many trade-offs in metric optimization. The main trade-off is between performance under normal
operation versus performance under failure. Metrics can be selected to do well under the former whileignoring
the latter, or to try to balance performance between the two.

M etric optimization optimizes undifferentiated traffic, but does not optimize traffic per service class or per
interface queue. If there are policies set on the undifferentiated traffic, WAE Design tries to minimize both
the interface utilization and the policy violations.

Step 1 Choose Tools > Metric Optimization.

Step 2 Decide on the normal (non-resilient) optimization options to use. (See Table 29: Metric Optimization Options, on page
302 for field descriptions.)

Step 3 Decide on the failure (resilient) options to use. (See Table 29: Metric Optimization Options, on page 302 for field
descriptions.)

For planning purposes, the most benefit from metric optimization isthat it is able to optimize routing over alarge number
of failure scenarios. This capability controlsthat optimization, aswell as control s the trade-off between normal and failure
optimizations.

Step 4 Specify the remaining options to fine-tune the optimization, and then click OK.

What to do next

Table 29: Metric Optimization Options

Field Description

Normal (Non-Resilient) Options

Minimize maximum interface | This default is usually the primary objective, and concentrates on reducing the utilization of the
utilization interface with the highest utilization.

Minimize # of interfaceswith | Often asmall number of interfaces are bottlenecks in the network, and their utilizations cannot be
utilization > x % reduced through rerouting. However, it is still desirable to reduce the utilization of other,
under-utilized interfaces. This option triesto reduce all interface utilizations to below a specified
utilization level, or, if thisis not possible, to minimize the number of interfaces over thislevel.

Minimize average latency If after the optimizations flexibility is available in the choice of metrics, WAE Design uses this
flexibility to minimize the average latency of the routes across the network. Thisis not
user-configurable and is always on.

Enforce latency bounds If checked, the choice of paths for each demand is restricted, if possible, to those demands with
latency below the latency bound.
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Metric Optimization .

Field

Description

Failure (Resilient) Options

Minimize maximum interface
utilization

If checked, WAE Design selects metrics to minimize the maximum interface utilization over all
interfaces and all failure scenarios. If unchecked, only normal operation is optimized, and the
remainder of the failure section isignored.

Minimize # of interfaces with
utilization > x %

Thenumber of interfaceswith utilization (under any failure scenario) above a specified percentage
is minimized.

Enforce no-failure utilization
bound

If unchecked, maximum failure utilization is minimized with no consideration for utilization under
normal operation. It is often convenient to check this option and place a bound on the utilization
under normal operation, which Metric Optimization then satisfies, if possible.

Failures to consider

This option determines the failure scenari os over which optimization is performed. You can select
any combination of failures.

« All unprotected circuit, node, Layer 1 (L1) node, and L1 link failures

* All SRLG failures
This option does not consider port or port circuit failures. For information on protecting objects
from being included in this analysis, see Simulation Analysis.

To control the number of threads that WAE Design processes in parallel when examining failure
scenarios, set the Maximum number of threadsfield.

Other Options

Optimization Type

WAE Design can perform global or incremental metric optimizations.

* Incremental—Uses the current routes as a basis from which improvements can be made. The
target routes are not changed as radically as when using global optimizations, and therefore
the number of metric changes from the metric targetsis typically much smaller using the
incremental option.

* Global—Creates optimal routes from scratch, and targets the old metrics afterward. Because
WAE Design can choose routes globally, this option tends to perform better under some
circumstances, particularly when the target routes are poorly chosen. However, global
optimization typically takes longer than incremental optimization.

Set Metrics on Interfaces

By default, WAE Design sets or changes metrics on any of the core interfaces in the network to
achieve its optimization goals. Alternatively, as provided by this option, Metric Optimization
restricts metric changes to the following interfaces: all, core, selected in table, or tag name.

Traffic Level

The traffic level over which the optimization is performed.
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Field Description

Interfaces to Optimize By default, WAE Design optimizes all interfaces. You can restrict the optimized interfaces using
this option and choosing the Optimize utilization on interfacesvalue: al, core, selected in table,
or tag name.

For those interfaces that are not optimized, you can set the following:
* Ignore
« Minimize number of interfaceswith util > %

* Minimize number of interfaceswith util > current + %

Target to Current Metrics There are many sets of metrics that will result in equivalent sets of routes. (Doubling all metrics,
for example, does not change routes.) WA E Design sel ects between these sets of metrics by metric
targeting. Metrics can be selected to match as closely as possible the current metricsin the network.
This simplifies the changeover from one set of metrics to the next.

Targeting optimized metrics to the current metricsin the plan is performed by default. Various
targeting refinements are available as CLI options to specify upper and lower bounds on metric
selections.

Enforce Symmetric Metrics This option sets the two metrics on each interface of each circuit equal to one another. This
constraint can reduce optimization performance. However, it ensuresthat demandsfrom A (source)
to Z (destination) and from Z to A (in the core) take the same path, and so the chances of a session
between A and Z being interrupted by afailure is minimized.

Prevent Edge L eakage This default option restricts how WAE Design can change demand routes. |f a demand starts by
routing only through the core, or from the edge through the core to the edge, this option prevents
the routing from being changed so that it routes through the edge in the middle of its path. Thisis
usually adesired routing policy restriction.

Simulate after optimization Thisdefault option performsasimulation analysis after optimizing metrics. Thesimulation analysis
allows adetailed view, for example, of the utilizations under failure resulting from the new metric
settings.

New Plan for Result This default option creates a new plan as aresult of running Metric Optimization. Unless a name

is specified, WAE Design attaches the suffix -mopt to the plan filename. If not selected, WAE
Design changes the current plan file with the updated information.

Tactical Metric Optimization

The Tactical Metric Optimization tool (Tools > Tactical Metric Optimization) is areduced version of the
Metric Optimization tool that minimizes the number of changes and runs faster. The options for thistool are
a subset of those for the Metric Optimization tools.
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Reports

Reports .

Set Metrics on Interfaces: |Core T]

Minimize number of interfaces with utilization = 100 T

Interfaces to Optimize... l

Traffic level: Selected: morning -

[¥] Time Limit: 600 seconds
| Enforce latency bounds

r Enforce Symmetric Metrics

3B1067

[¥] New Plan for result:  euro_akd-mopt

Thetool triesto find the most optimal solution it can. In general, the longer it runs, the better the result. The
Time Limit option tells the tool to stop looking for better solutions after the specified amount of time, and
use the best solution it has found so far. If the option is not set, the tool continues to run until it runs out of
solutions to explore, which can take along time. If you need all available solutions to be explored, use the
Metric Optimization, on page 302 tool.

Metric Optimization writes a Metric-Opt report to the Design History area of the Reports window. To access
thisinformation later, choose Window > Reports.

Metric Optimization Report

Warnings

* Options—Summarizesthe options used to call Metric Optimization. Some of these options (for example,
the Output file and Report file) are only relevant when using the CLI tool.

* Number of demands—Total number of demands in the plan.

* Objectives—Summarizes the optimization objectivesin order of priority.

Warnings detected by Metric Optimization might lead to misleading or undesirable results.

* No Improvement in Optimization
No routing inprovenent found: nmetrics unchanged
Metric Optimization was unable to improve on the metrics in the network. If the incremental option was

specified and latency bounds were enforced, this could be because the target metrics violated latency bounds
in ways that incremental optimization could not fix.

* Optimization Exit Diagnostics
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Optim zation performance may be linmted by | ow edge netrics

During the optimization, some desirable routes could not be selected because the given edge metrics would
have caused edge |eakage.

* Optimization Constraints Violated

» <n> \{intra. inter\site core metrics exceed \crlf \{intra, inter\site-metric \{ upper, lower\-bound

One or more intrasite or intersite core metric bounds have been violated.

» Maximum normal utilization exceeds specified bound
The original plan had normal utilization above the specified bound, and Metric Optimization was unable to
reducethe normal utilization below thisbound. If this occurs, Metric Optimization triesto set normal utilization

aslow as possible. No worst-case optimization is performed because reducing utilization under the normal
scenario is the highest priority.

* <n> demands with non-zero bandwidth exceed latency bounds
Because enforcing latency bounds is the highest optimization priority, this situation should not occur unless
alatency bound is less than the shortest possible latency for a demand.

 <n> demands with zero bandwidth exceed latency bounds
Metric Optimization does not always enforce latency bounds for zero bandwidth demands. These warnings
can occasionally occur even if it is possible to find lower latency paths for the signaled demands.

* Unrouted Demands

* <n> unroutable demands under normal operation

There are <n> demands for which no route exists between source and destination, even under the No Failure
scenario.

* <n> unroutable demands under <m> circuit failure scenarios
There are <n> demands for which no route exists between source and destination under <m> circuit failure
scenarios. (Different demands might be unroutable under different circuit failures.)

* <n> unroutable demands under <m> SRL G failure scenarios
There are <n> demands for which no route exists between source and destination under <m> SRLG failure
scenarios. (Different demands might be unroutable under different SRLG failures.)

* <n> unroutable demands under <m> source/dest node failure scenarios
There are <n> demands whose source and/or destination nodesfail under <m> failure scenarios. These demands

clearly cannot be routed in these circumstances. (Different demands might be unroutable under different node
failures.)

* <n> unroutable demands under <m> non-source/dest node failure scenarios
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There are <n> demands for which no route exists between source and destination under <m> node failure
scenarios, where the nodes that fail are intermediate nodes in the path of the demands, and are not
source/destination nodes of the demands. (Different demands might be unrouted under different nodefailures.)

Routing Summary

Summary statistics are displayed of the routes in network, both before (in parentheses) and after the
optimization.

* Core/Edge Max Utilization—The maximum percentage utilization over any interfacein the core or edge
network. The normal utilization is under the normal (no-failure) scenario, and the worst-case utilization
is maximized over all failure scenarios in the failure set.

* Latency—Median and averagelatencies over al routed demands, both in milliseconds and as a percentage
of the latency of the smallest latency route possible.

The latency of each demand's routing is calculated as a percentage of the latency of the shortest possible
route, by latency, for that demand. Under the percentage column, the median and average of these percentages
are displayed.

* Num of routes away from shortest path—The number of routes (out of al the demands routed) that do
not follow the shortest path, by latency. This statistic is an indicator of how much the routes have been
affected by utilization minimization as the primary criterion for optimization.

Metrics

The metric targeting choice is shown, together with the number of metrics different from the target metrics.
Lists of interfaces for which metrics differ from the target metrics are displayed, together with both the target
metric and the optimized metric. The metrics are separated into those on intrasite and intersite interfaces.
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LSP Optimization

This section contains the following topics:

« LSP Digoint Path Optimization, on page 309
* L SP L oadshare Optimization, on page 316
* L SP Setup Bandwidth Optimization, on page 320

LSP Disjoint Path Optimization

LSPsand L SP paths are digjoint if they do not route over common objects, such as interfaces, nodes, or L1
links. The LSP Disjoint Path Optimization tool (Tools > L SP Optimization > L SP Digjoint Path Opt)
creates digoint L SP paths for RSVP LSPs and SR L SPs and optimizes these paths based on user-specified
constraints.

Note

N

LSP Digoint Path Optimization tool supports both Inter-Area and Inter-AS functionalitites.

One common use case for this optimization isthat disjoint L SPs can ensure services are highly resilient when
network failures occur. For example, thistool lets you route L SPs to have digjoint primary and secondary
paths that are optimized to use the lowest delay metric possible.

If it is not possible to achieve the optimization as defined by the routing selection, path requirements, and
constraints, the tool provides the best digjoint paths and optimization possible.

Upon completion, WAE Design tags the L SPs with DSIOpt and generates a new plan file with an -DSJopt
suffix. WAE Design also writes areport containing the results of the optimization.

Note

Whilethe optimizer appliesto both RSVP L SPsand SR L SPs, only one of thesetypes of L SPscan be optimized
at atime.

Disjoint Routing Selection

Only existing L SP paths are rerouted. New L SP paths are not created.
« Explicit hops are modified or created for RSVP LSPs.
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*» Segment list hops are modified or created for SR LSPs. Thefinal hop is either a node hop or interface
whose remote node is the destination of the LSP.

Segment lists are created only for LSP paths, and only L SP path segment lists are updated. If a segment list
is associated with an LSP (rather than an L SP path), that L SP segment list is removed.

Disjoint Routing Selection
Create disjoint primary and secondary paths for LSPs
Create disjoint paths between LSPs in Disjoint Groups
Q! Create disjoint primary paths for LSPs in Disjoint Groups | 2

Routing options include:

* Createdigoint primary and secondary pathsfor L SPs—For all L SPs, whether they arein adigoint group
or not, route all LSP paths so that they are digoint from all other paths belonging to that LSP. This
digointness extends beyond primary and secondary paths to include all other path options (for example,
tertiary).

* Create digoint paths between L SPsin disjoint groups—For all L SPsthat arein disjoint groups, route all
L SP paths so that they are digioint from all other paths belonging to L SPs in that digjoint group. This
digointness extends beyond primary and secondary pathsto include all other path options (for example,

tertiary).

Example: All LSPsin digoint group East are rerouted to be digjoint from each other. All LSPsin digoint
group Southeast are rerouted to be digjoint from each other. However, L SP paths in the East group are not
rerouted to be digoint from those in the Southeast group.

* Create digoint primary pathsfor L SPsin digjoint groups—For all L SPsthat arein digjoint groups, reroute
only their primary paths so that they are digjoint from each other.

Disjoint Path Requirements

Thedisjoint path requirementsidentify the priority for creating dig ointness across a path. Digointness priorities
1, 2, 3, and Ignore are available for circuits, SRLGs, nodes, sites, and L1 links. Thetool triesto create
digointness for all objects that have a priority set other than Ignore. If full disjointness cannot be achieved,
the tool prioritizes digointness based on these values.

Example: Circuits have apriority of 1, SRLGs have a priority of 2, and the other objects are ignored. If the
tool cannot achieve full digjointness across both circuits and SRLGs, it prioritizes the digointness of circuits
over SRLGs.

Disjoint Path Requirements

Priorities
Circuits: |1 - Nodes: *| L1 Links: I|I|;1|r‘u:|re v |
SALGs: |2 ~| sites: |Ignore ~ g
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Example

Example .

This example shows how disjoint routes can be created for primary and secondary RSV P L SP paths, and how
those routes differ, depending on the path requirements set.

The LSP has a primary and secondary L SP paths that use the same route from cr2.§cto cr2.wdc. The LSPis
not a member of adigoint group.

ki
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In both Figure 116: Primary and Secondary Paths Based on Digjoint Circuit Requirements, on page 312 and
Figure 117: Primary and Secondary Paths Based on Digjoint Circuit and L1 Link Requirements, on page 313,
the option is selected to create digoint primary and secondary paths for L SPs. However, they show different
secondary path routes.

* Figure 116: Primary and Secondary Paths Based on Digjoint Circuit Requirements, on page 312 shows
explicit interface hops set for the secondary L SP path that force it to take a different (northern) route
from cr2.g/cto cr2.wdc. Because the disjoint path requirement isonly circuits, the primary and secondary
paths route across different circuits, as indicated in the resulting report. However, they share a common
L1 link between slc and kcy.

* Figure 117: Primary and Secondary Paths Based on Digjoint Circuit and L1 Link Requirements, on page
313 is based on setting circuits as the first priority for digjoint requirement and L1 links as the second
priority. The result is adifferent set of explicit hops for the secondary L SP path, routing it through
southern digjoint circuits that are mapped to different L1 links. The resulting report shows there are no
longer any common L1 links.
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Figure 116: Primary and Secondary Paths Based on Disjoint Circuit Requirements

@) Create disjoint primary and secondary paths for LSPs
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Figure 117: Primary and Secondary Paths Based on Disjoint Circuit and L1 Link Requirements

Q) Create disjoint primary and secondary paths for LSPs
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Constraints .

0

LSP Name LSP Source Common Circuits Before Common Circuits After Common L1 Links Before Common L1 Links After
Isp_cr2.sjc  cr2ssjc 2

3

405319

0

» Minimize path metric—Paths are optimized to minimize the sum of the metrics along the path with
respect to delay, TE, or IGP metrics. All of these properties are configurable from an interface Properties
dialog box, and delays can also be set in a circuit Properties dialog box.

* Fix L SP Paths—Selected or tagged L SP paths are not rerouted. This constraint is useful when you have

previously optimized specific L SPs within the network and want to maintain their routes.

* Only update L SP Pathsthat violate requirements—Paths are modified only if they violate the requirements
specified in the area of the Digjoint Path Requirements, on page 310 dialog box.

Constraints

Minimize path meftric: |TE Mefric

Fix LSP Paths: { None

Only update LSP Paths that violate requirements

This example shows how disjoint routes can be optimized for two SR L SPs using the same source (§c) and
destination (kcy).
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* Both L SPs belong to the same disjoint group, and both L SPs have an L SP path.
* The circuit between gjc and kcy has significantly higher delay than the other circuits.
 The only disjoint path requirement selected is circuits.

* Figure 118: Example Routing of SR LSPs, on page 314 shows the following:

« Before using the L SP Digjoint Path Optimization tool, both L SP paths use the same route. There
are no segment list hops.

* By selecting the option to create digjoint paths between L SPs in the same disjoint group and using
the TE metric for the shortest path calculation, two digjoint L SP path routes are created. Both have
a segment list node hop on the destination node. One has an additional segment list node hop on
chi to force a different route.

* By selecting the same digjoint option and using the Delay metric for the shortest path calculation,
one LSP is moved away from the high-delay sjc-kcy circuit because traversing that circuit is not
the shortest latency path.

Figure 118: Example Routing of SR LSPs

| Q) Create disjoint paths between LSPs in Disjoint Groups
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Disjoint Report

The resulting report summarizes the number of L SPs and number of updated L SP paths. Depending on the
digoint option selected, the report summarizes the uniquely distinguishing attributes, such as L SP name and
digoint group name.

The Digoint Groups, L SP Disjointness, and Path Digjointness areas all list the number of common objects
(selected as digjoint path requirements) before and after the optimization, as well as digjointness violations
based on these requirements before and after the optimization. You can filter to related information from these
aress.
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Prerequisites

* The plan file must aready contain the primary L SP paths. If using the option to create disjoint primary
and secondary paths, it must also at least contain secondary L SP paths, though it can contain other path
options, such astertiary.

* If creating digoint paths between L SPs in the same digjoint group, the L SPs must first be added to the
digoint groups.

Creating Disjoint Groups

Step 1
Step 2
Step 3
Step 4

Step 5

Right-click one or more L SPs and choose Properties.

Click the Advanced tab.

Enter or select the disjoint group name.

If needed, assign priorities to L SPs within these groups. Higher priority LSPs are assigned shorter routes based on the
selected metric. The higher the number, the lower the priority.

Example: There are two L SPs in the same digjoint group, each with adifferent digoint priority. Run the LSP Disjoint
Path Optimization tool to create digoint paths for LSPsin the same disjoint group using TE metrics as a constraint. The
LSPwith adisjoint priority of 1 routes using the lowest TE metric, and the LSP with adigoint priority of 2 routes using
the second lowest TE metric.

Click OK.

Optimizing Disjoint Paths

Step 1

Step 2
Step 3
Step 4
Step 5
Step 6
Step 7

Skip this step if using tags. You can also skip this step if you want to run the tool on al SR LSPs and there are only SR
LSPtypes, and if you are not selecting L SP pathsto fix.

If you arefixing selected L SP paths or if you are running the optimization on selected SR L SPs, select them before
opening the dialog box.

« If you are selecting one or the other, do so from their respective L SP Paths or L SPs tables.

« If you are selecting both, make your selection in one table, and then press and hold the Alt key (Option key on a
Mac) while making selections in another table.

If the table contains both RSVP and SR L SPs, show the Type column to easily sort and find the LSP.

Choose Tools > L SP Optimization > L SP Digjoint Path Opt.

Select whether to optimize digjoint paths for all LSPs, selected LSPs, or tagged L SPs.

Select how to route the digjoint paths.

Select digoint path requirements and priorities.

Select the constraints.

Specify whether to create and add tags to all SR L SPs rerouted during optimization. You can edit the DSIOpt default.
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Step 8

Step 9

Specify whether to create a new plan with the results of the optimization. Unless a name is specified, WAE Design
attaches an -DSJopt suffix to the current plan filename. If not selected, WAE Design changes the current plan file with
the updated information.

Click OK.

LSP Loadshare Optimization

The L SP L oadshare Optimization tool automatesthe process of finding and setting the most favorableloadshare
ratios across parallel LSPs to balance traffic and avoid congestion. The optimizer only includes interfaces
that use parallel L SPsin the optimization. You can further limit parallel L SPinterfacesto only those on which
you want to drive down the maximum utilization.

Upon completion, WAE Design tags the L SPs with LSPLoadshare and generates a new plan file with an
-Lshare suffix. This plan file opens, showing the L SPstable that isfiltered to these rerouted (and newly
tagged) L SPs. Saving this plan file then simplifies the process of identifying which L SPsto reconfigurein
the network. Both the tags and the new plan filenames are editable.

Also upon completion areport is generated, identifying how many L SPs and interfaces were affected, the
number of bins used, the resulting maximum interface utilization, and if applicable, the number of interfaces
with utilization over the specified threshold.

Running the LSP Loadshare Optimization Tool

Step 1
Step 2

Step 3
Step 4

Step 5

Step 6
Step 7
Step 8
Step 9
Step 10

Open a plan file and choose one or more L SPs. If you do not choose any L SPs, the tool uses all LSPsin the plan file.

Choose Tools > L SP Optimization > L SP L oadshare Opt. (See Table 30: L SP L oadshare Optimization Options, on
page 317 for field descriptions.)

(Optional) Choose the L SPs on which you want to optimize the L oadshare value.
Choose the interfaces on which you want to drive down utilization:

« If you choose the default (All), the optimizer uses al interfacesin the plan file.

 Choose only those interfaces of interest on which to drive down the maximum utilization.

Choose which method of optimization to use:

* Minimize max interface util

* Minimize number of interfaceswith util > %

If distributing the traffic to bins, enter the total number of flow bins to use. (See the Bin Example, on page 320.)
(Optional) Choose which traffic level to optimize.

(Optional) Change the L SP tag name.

(Optional) Choose whether to create a new plan file based on the results, and change how to name it.

Click OK.

. Cisco WAE Design 7.4.0 User Guide



| LSP Optimization

Optimization Options .

Optimization Options
The LSP Loadshare options help balance traffic and avoid congestion.

Table 30: LSP Loadshare Optimization Options

Field

Description

Set loadshare on L SPs

Sets the loadshare setting between the selected parallel LSPs in the network. Parallel LSPs are
those with the same source and destination nodes. By default, the optimizer assumes you want to
optimize all LSPs. However, you can also choose a subset or certain selected L SPs to optimize
for load sharing purposes.

The optimizer does not set aloadshare value of 0 on LSPs.

Interfaces

Specifies whether to consider all interfaces or just a subset of these interfaces on which to drive
down the maximum utilization. You can choose them using tags or by choosing a subset of them
from the WAE Design tables.

Minimize max interface util

Minimizes the maximum interface utilization over all interfaces on the L SP routes. WAE Design
tries to minimize the number of |oadshare parameter changes required to do so.

Minimize number of interfaces
withutil > %

Minimizes the number of interfaces that have a utilization greater than the specified value. This
isalooser constraint than minimizing the maximum interface utilization. Therefore, WAE Design
has the opportunity to modify as few loadshare values as possible, thus reducing the amount of
reconfiguration required.

Number of flow bins

Routers typically cannot divide flows arbitrarily between parallel L SPs, but instead allocate them
to afixed number of “bins’ of approximately equal size. The bins are then divided between the
parallel LSPs. Thisoption letsyou specify thetotal number of bins, which in turns places aconstraint
on the traffic division.

Traffic Level Specifies the traffic level to usein the optimization. Thisis only required if more than one traffic
level is present.
Tag changed L SPs Specifies atag for any changed L SPs. By default, the optimizer tags upgraded circuits with the

label LSPLoadshare .

New plan for result

Specifies a name for the new plan file. By default, the optimizer appends the input plan file with
<plan file Lshare> .

Minimization Example

The base plan for this example, Acme_Network, contains two sets of parallel LSPs, each with a L oadshare
value of 1 and each using strict hops on named paths to reach its destination. All of these L SPs have a Traff
Sim of 3000 Mbps. The interfacesto which these L SPsfilter al have a Traff Sim value of 3000 M bps, except
for gc-to-okc, which has 6000 Mbps of simulated traffic (Figure 119: Example Acme Network Before LSP
L oadshare Optimization, on page 318).

« Using the Acme_Network plan file (Figure 119: Example Acme Network Before LSP L oadshare
Optimization, on page 318), if you minimize the maximum interface utilization across all L SPs, al four
L oadshare parameters change, and the maximum interface utilization is40% (Figure 120: Example Acme
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Network After Minimizing Maximum Interface Utilization, on page 319). The default plan filename and
default L SPtags are used, thus naming the new plan Acme_Network-L share and thetags as L SPL oadshare.

« Using the Acme_Network plan file (Figure 119: Example Acme Network Before LSP L oadshare
Optimization, on page 318), if you minimize the number of interfaces with utilization greater than 50%,
only two of the L oadshare values change (Figure 121: Example Acme Network After Minimizing Number
of Interfaces with Utilization 50%, on page 319). Notice in the figure how Loadshare values are rel ative
to the other Loadshare values for parallel LSPs, and not to all LSPsin the table. Also, only the affected
L SPs are tagged.

Figure 119: Example Acme Network Before LSP Loadshare Optimization

All LSPs

Interfaces LSPs

Node Interface Remote Node Traff Sim Util Sim | | Name Source Destination Loadshare Traff Sim Tags
crlsjc  to_chi crl.chi 3000.00 30.00| |sjc-wdc-1  sjc wdc 1.00 300000

crlsjc  to_okc crl.okc 6000.00 60.00| |sjc-wdc-2  sjc wdc 1.00 300000

crlsjc  to_hst crl.hst 3000.00 3000| |sjc-mia-2  sjc mia 1.00 300000

crl.chi towdc  crlwdc 3000.00 3000| |sjc-mia-1  sjc mia 1.00  3000.00

crl.okc to_wdc crlwdc 3000.00 30.00

crlhst  to_mia crl.mia 3000.00 30.00 3
crl.okc to_mia crl.mia 3000.00 30.00 2
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Figure 120: Example Acme Network After Minimizing Maximum Interface Utilization

Interfaces LSPs

Node Interface Remote Node Traff Sim Util Sim Name Source Destination Loadshare Traff Sim Tags

crlsic  to_chi crl.chi 4000.20  40.00 sic-wde-1  sjc wdc 66.67 400020 LSPLoadshare
crlsjc  to_okc  crlokc 3999.60  40.00 sic-wdc-2  sjc wdc 3333 1999.80 LSPLoadshare
crlsic  to hst crlhst 4000.20  40.00 sic-mia-2  sjc mia 66.67 400020 LSPLoadshare
crlchi  towdc  crlwdc 4000.20 4000 sic-mia-1  sjc mia 3333  1999.80 LSPLoadshare
crlokc towdc  crlwdc 1999.80 20,00 o
crlhst  to_mia crl.mia 4000.20 40.00 g
crl.okc to_mia crl.mia 1999.80 20.00 ]

Figure 121: Example Acme Network After Minimizing Number of Interfaces with Utilization 50%

Q@ Minimize number of interfaces with util > S0

Both LSPs

Interfaces LSPs

Node Interface Remote Node Traff Sim  Util Sim Name Source | Desfination Loadshare Traff Sim Tags

crlsjc to_chi crl.chi 3000.00 30.00 sjc-wdc-1 crlsje | crlawdc ( 1.00 3000.00

crlsjc to_okc crl.oke 499980 50.00 sjc-wdc-2 crlsjc | crlwdc 1.00 3000.00

crlsjc to_hst crl.hst 4000.20 40.00 sjc-mia-2 crlsjc | crlmia 4000.20 LSPLoadshare
crlchi  towdec crlwdc 3000.00 30.00 sjc-mia-1 crlsjc  crlmia 33.33 1999.80 LSPLoadshare
crloke towdc  crlwdc 3000.00 30.00 -
crlhst  to_mia crl.mia 4000.20 40,00 &8
crlokc to_mia crl.mia 1999.80 20.00 %
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In this example, a node uses a maximum of 32 bins, and the optimal traffic allocation is 45% of the traffic
through LSP A and 55% of the traffic through L SP B. The node that sources these two L SPs, however, cannot
do this exact split. The optimization divides the traffic into 32 bins, each with the same amount of traffic in
them. Thus, each bin has 3.125% of the traffic (100% of the traffic divided by 32). The optimization also
determines how the node should split the traffic. In this case, the split isto give 43.75% (which is 14 bins of
3.125% each) to LSP A and 56.25% (which is 18 bins of 3.125% each) to LSP B. Thus, it optimizes and
distributes 32 (14+18) bins of traffic. Thisisas close as possible to the optimal 45%/55% split using 32 bins.

LSP Setup Bandwidth Optimization

Workflow

As anetwork operator, you might need to periodically update L SPs as traffic changesin your network. You
might have some fixed rules around the maximum setup bandwidth for L SPs. Restrictions on the setup
bandwidth per L SP affect the number of LSPsin the network. As the setup bandwidth increases, the number
of LSPsthat you have to manage in your network is reduced. However, the risk that certain L SPs cannot be
routed also increases. As the setup bandwidth decreases, more alternative paths can be found, allowing for
better load balancing. This holds true both in the fail-free and under failures cases.

To address these L SP setup bandwidth requirements, WAE Design includes an L SP Setup BW Optimization
tool (Tools> RSVP L SP Optimization > L SP Setup BW Opt).

The LSP Setup BW Optimization tool lets you add or remove L SPs based on set bandwidth requirements that
you specify. You can select the L SPs that you want the optimizer to consider. The optimizer then separates
these LSPs into different groups. The optimizer defines an L SP group based on the fact that the L SPs within
the group share common source and destination nodes. You can also specify additional custom groupingsto
get afiner granularity on the setup bandwidth.

The optimizer lets you create L SPs by specifying:
 The number of LSPsto create for each L SP group.
 The maximum setup bandwidth per LSP. In this case, the minimum number of LSPsis created for each
group in order to meet this requirement.
Additionally, the optimizer lets you remove L SPs by specifying:

» The number of LSPsto remove for each group.

* The minimum setup bandwidth per LSP. In this case, the minimum number of LSPsis removed from
each group in order to meet this requirement.

You can then perform different operations on each group to test different design scenarios.

Note

The sum of the setup bandwidth of the L SPs per group is not modified by adding or removing LSPs. The
setup bandwidth is evenly redistributed among the L SPs within each L SP group.
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Step 1
Step 2

Step 3

Step 4

Step 5
Step 6

Summary Report .

Choose Tools > RSVP L SP Optimization > L SP Setup BW Opt.

Choose the L SPs you want the optimizer to consider. The default is to operate on all LSPs. If you want to consider just
certain LSPs, choose a subset of the L SPs or choose tags to specify certain LSPs.

Choose the manner in which LSPs are separated into L SP groups:

« Source/Destination Nodes—L SPs with a common source and destination belong in the same group.

« Source/Destination Nodes and existing SetupBWOpt::Group Entries—L SPs with acommon source and destination
and common SetupBWOpt::Group entries belong in the same group. This option is useful when you want to group
L SPs based on different service classes.

For each L SP group, provide your setup bandwidth requirements:

* Create x L SPs—Enter a positive integer. The optimizer creates a certain number of L SPs per group; for example,
1

* Create the minimum number of L SPs so that Setup BW <= x Mbps—Specify the minimum number of L SPsto meet
your setup bandwidth rule. For example, the bandwidth rule could be 10000 M bps.

» Remove x L SPs—Enter apositive integer. The optimizer removes a certain number of L SPs per group; for example,
1

« Remove the minimum number of L SPs so that Setup BW <= x M bps—Specify the removal of the minimum number
of LSPsto meet your setup bandwidth rule; for example, 270000 Mbps.

(Optional) Override the defaults for how L SPs are tagged (SetupBWOPpt) or for how new optimized plan files are saved.
Click OK.

Summary Report

After running the L SP setup bandwidth optimization, the report summarizes the total number of:
» LSPsyou selected.

 LSP groups identified.
* LSPs created.
 LSPs removed.

LSP Groups Report

In the Reports window, click L SP Groups to view details on how the optimizer operated on L SPs:

» Group—Name of the L SP group as specified by SetupBWOpt::Group. If this group is not specified, the
Group column is empty.

* L SP Source—Source node of the L SP group.
* L SP Destination—Destination node of the L SP group.
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* Total Setup BW—Sum of the setup bandwidth values of the L SPs within the L SP group.

* LSP Number Before—Number of L SPs within the L SP group before running the optimization.

» LSP Number After—Number of L SPswithin the L SP group after the optimization.

 LSP Setup BW Before—Average setup bandwidth within the L SP group before the optimization.
* L SP Setup BW After—Setup bandwidth within the L SP group after the optimization.
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CHAPTER 20

RSVP-TE Optimization

The RSVP-TE Optimization tool (Tools > RSVP L SP Optimization > RSVP-TE Opt) creates explicitly
routed L SP paths to optimize route properties such as distance, TE metrics, utilization, and digointness. The
routing decisions are centralized within the tool, in contrast to traditional RSV P-TE routing, in which routing
decisions are distributed across the head-end routers in the network. Although it has fewer parameters, this
tool isfaster and has a more predictabl e run-time than the Explicit L SP Optimization tool and is the
recommended method for explicit RSVP-TE L SP path optimization.

The primary optimization goal isto minimize path distance (which can be based on interface TE metrics,
delay, or user-defined value), while not exceeding a bandwidth bound defined for each interface so asto avoid
congestion. Unlike RSV P-TE, L SPs are routed even if they cannot avoid exceeding bandwidth bounds for
certain interfaces, though these bound violations are minimized. Additionally, you can use this tool for
reoptimizing and reconfiguring RSV P-TE L SPs after events, such as network failures and subsequent route
reconvergence.

You can specify different treatment for different L SPs: whether the L SPs should be rerouted to shorten the
path distance, only as necessary to reduce congestion, or not optimized at all. These three LSP groups are
called Opt, Fit, and Fix. Using these input parameters alows for avariety of use cases, such as:

« Global optimization—Minimize the path length of al L SPs subject to specified interface bandwidth
constraints.

» New L SP optimization—Minimize the path length of newly created L SPs without exceeding bandwidth
bounds specified for the interfaces. Existing L SPs are kept on their current paths, being moved only if
necessary to prevent new L SPs from violating bandwidth bound constraints.

» Tactical congestion mitigation—Change the routing of as few L SPs as possible to bring bandwidth on
al interfaces bel ow the specified bandwidth bound.

Upon completion, WAE Design generates a new plan file with a suffix, which by default is RSYPTEOpt .
Thissuffix isconfigurablein the“New planfor result” field. Assuch, thetool isbeneficial for offline planning
and configuration of an explicitly routed RSVP-TE network. It is aso useful for providing routing decisions
for a centralized, reactive network control application, such as can be implemented on the WAE platform.

This optimized plan file opens showing the L SPs tabl e filtered to the rerouted L SPs. Saving this plan file then
simplifies the process of identifying which LSPs to reconfigure in the network.

Note

RSV P-TE Optimization tool supports both Inter-Area and Inter-AS functionalitites.
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This section contains the following topics:

 Optimization Input, on page 324

* Optimization Output, on page 328
» Examples, on page 329

» Workflow, on page 333

Optimization Input

The RSV P-TE Optimization tool usesthe LSP and interface input properties listed in Table 31: RSVPTEOpt
Input Parameters, on page 324 to execute its optimization cal culations. These properties, which are specified
in user columnsin the L SPs and Interfaces tables, can be created in one of two ways:

» Use thetool to automatically create (initialize) the propertiesif they do not exist. The selections made
inthe Specify L SP Groups, L SP Parameters, and I nterface Parameters areas popul ate the input properties.

Example: If you choose L SPsto optimize, to fit, and to fix, the tool creates the RSV PTEOpt::Group
column in the L SPs table and sets this property to the appropriate values for each LSP (Opt, Fit, Fix). If
the property already exists, it is updated with the new valueif it has changed.

Example: If you select to set the interface bandwidth bound based on the Resv BW property, the tool
creates the RSVPTEOpt::BWBound column in the Interfaces table and for each interface, copies the
Resv BW valuetoit. If the property aready exists, it is updated with the new bandwidth bound value if
it has changed.

* Before running the tool, manually create the input properties as user columnsin the LSPsand Interfaces
tables. When running the tool, you must then select the “Use Existing RSV PTEOpt::<property _name>"
option. Thisisuseful if you want to configure specific values rather than using existing properties and
values. For information on creating user-defined columns, see User Interface, on page 5 or the Cisco
WAE Design Integration and Development Guide .

N

Note Because the resulting plan file can potentially reset properties that can be used
asinput to optimizations, it isabest practice to run the optimization only on plan
filesor LSPsthat have not yet been optimized. For example, by default WAE
Design resets the L SP Setup BW property to 0 after optimizing LSPs, and this
same property could be used as input to other optimizations.

Table 31: RSVPTEOpt Input Parameters

Table Input Property Description and Values Used to Create the Input Property

LSPs RSVPTEOpt::Group L SP optimization group.

Theinput property is derived based on your entries in the Specify L SP Groups area unless you
select to use the existing RSV PTEOpt::Group property. Values are Opt, Fit, or Fix. If thevalue
is not defined, it is set to Ignore.

RSVPTEOpt::BWReq | The bandwidth required by each L SP that is being optimized.

Theinput property is derived from the Setup BW, Traff Meas, or Traff Sim L SP properties
unless you specify to use the existing RSV PTEOpt::BWReq value.
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Table Input Property Description and Values Used to Create the Input Property

Interfaces | RSVPTEOpt::BWBound | Sum total of L SP bandwidth routed over the interface should not exceed this value.

Theinput property isderived from the Resv BW, Capacity, or Capacity Siminterface properties
unless you specify to use the existing RSVPTEOpt::BWBound value.

RSVPTEOpt::Metric Metric value used in the shortest path calculations.

Theinput property is derived from either the TE Metric or Delay property of the interface
unless you specify to use the existing RSV PTEOpt::Metric value.

Selecting LSP Groups

To determine how and whether L SPs are optimized, select them from the Specify LSP Groups area. If an LSP
isin multiple groups, the first group in which it residesis how the LSP is treated.

» Opt—Explicitly route or reroute these L SPsto minimizetheir path length, while respecting the bandwidth
bounds specified for the interfaces. The RSVP-TE Opt tool changes the L SP path as much as needed to
find the optimal route. First, it tries to set the LSP to its shortest path, which is defined by the interface
Metric parameter. The LSP is moved away from the shortest path only if needed due to congestion.

Setting all LSPsto this option is useful when trying to achieve global optimization on all LSPs.

* Fit—Reroute these L SPs only as necessary to respect specified bandwidth bounds on the interfaces,
while accommadating the Opt group. If thereis currently no explicit route or if the route is incomplete,
treat like Opt LSPs.

Thisoption is useful when attempting tactical congestion mitigation, where it is desirable to move as
few L SPs as possible to remove existing congestion.

A combination of Opt and Fit or a combination of Opt and Fix is useful for targeting the optimization
of new LSPs.

* Fix—Do not reroute these L SPs, but consider them in the optimization calcul ations.

Specify LSP Groups

(@ Set RSYPTECPL: :Group with selections

Opt:  |Selected in table (70/160)

Fit:  |Tag: test (23/160)

Fic: |l

Ignore: Remaining LSPs
! Use existing REVPTEOpt: :Group enfries E

L SPsthat are not selected areignored, and as such, maintain their original configuration and are not considered
in the optimization calculations. This can be useful if you have network regions that do not interfere with
optimizations. Note, though, that if measured interface traffic is used in the optimizations, traffic contributions
from the ignored L SPs to this measured traffic might affect the results.
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Because you can set each of the “ Set RSVPTEOpt::Group” selections to None, All, only selected, or tagged
L SPs, you can section off specific L SPs for one optimization treatment or another.

Example: Tag new L SPs and set them to be optimized (Opt L SPs). Select and set existing LSPsto Fit LSPs
to optimize their paths only as necessary to accommodate bandwidth bound constraints.

Setting Optimization Parameters

Optimization calculations are based on two sets of parameters that define how much bandwidth the L SPs
require, how much bandwidth the interfaces have availablefor these L SPs, and which metric to use for shortest
path. See Table 31: RSVPTEOpt Input Parameters, on page 324 for selection options.

LSP Parameters

Required BW Setq:p BW v

Interface Parameters

B8W Bound |Resy BW v
Metric TE Metric A
Delay
{Use existing RSVPTEOpt: :Metric

406031

* LSP Required BW—Specify how to determine the bandwidth required for the primary L SP paths.

* Interface parameters:

* BW Bound—Specify how much bandwidth the interfaces have available to carry L SPs. WAE
Design tries to route L SPs without surpassing this bound, but exceeds it if necessary.

* Metric—Specify which metric to use for shortest path calculations. Figure 122: Example Shortest
Path Optimization, on page 327 shows a sample L SP path that is optimized once based on the TE
Metric and once based on the Delay.

. Cisco WAE Design 7.4.0 User Guide



| RSVP-TE Optimization
Setting Disjoint Groups .

Figure 122: Example Shortest Path Optimization
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Setting Disjoint Groups

In the Advanced tab, you can create digoint paths or use existing disjoint paths as follows. Note that two L SP
pathsare digoint if they do not route over common objects. These objects are configurable and can be circuits,
nodes, sites, SRLGs, or L1 links.

 No digoint routing—Do not create digjoint secondary paths and do not enforce any disjointness on
primary peths.

« Create disjoint secondary pathsfor L SPs—Create secondary L SP pathsthat are disjoint from the primary
L SP paths.

Additionally, specify whether to include secondary paths in the optimization. If set to Zero, their
bandwidths are set to 0 and are not included. Otherwise, their required bandwidths are set to be the same
asthe primary paths, and they are included in the optimization.

* Create digoint paths between LSPs in Disjoint Groups—Create disjoint paths between LSPsthat arein
digoint groups.
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Disjoint Routing
) Mo disjoint routing

@) Create disjoint secondary paths for LSPs

Secondary path BW [Zero ']

Create disjoint paths betwesn LSPs in Disjoint Groups

Disjoint over: Circuits, SELGS... | Edit... E

Setting Avoidance Constraints

Avoid Objects section in the Advanced tab lets you to select Nodes, Interfaces, L1 Links, L1 Nodes, SRLGs
to be avoided when optimizing L SPs.

» Nodes - LSPs are created to route away from the Nodes selected. Default is None.

* Interfaces - L SPs are created to route away from the Interfaces selected. Default is None.
e L1 Links- LSPsare created to route away from the L1 Links selected. Default is None.

» L1 Nodes - L SPs are created to route away from the L1 Nodes selected. Default is None.
» SRLGs - LSPs are created to route away from the SRLGs selected. Default is None.

Setting Post-Optimization Parameters

The Post Optimization options identify how to reset the Setup BW for modified L SPs:
* Reseat Setup BW to 0.

* Reset Setup BW to be the same as the resulting RSV PTEOpt::BWReq value.
* Keep the Setup BW the same.

Optimization Output

Properties Created

In addition to creating the input parameters, as described in Optimization Input, on page 324, thetool generates
the propertieslisted in Table 32: RSVPTEOpt Parameters Used as Optimization Input, on page 329. These
properties provide further insight into the optimizations.
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Table 32: RSVPTEOpt Parameters Used as Optimization Input

Table Property Description

LSPs RSVPTEOpt::Action I dentifies whether the L SP's path was updated (optimized).
RSV PTEOpt::PathMetric Sum of interface metrics on the L SP path.
RSV PTEOpt:: ShortestPath I dentifies whether the LSP is now taking the shortest path.

RSV PTEOpt:: ShortestPathMetric | Sum of interface metrics on the shortest L SP path.

Interfaces | RSV PTEOpt::BWTotal Sum of the bandwidth required for all L SPs routed on the interface.

RSV PTEOpt::BWBoundExceeded | I dentifies whether the bandwidth bound of theinterface was exceeded.

Optimized LSPs Reconfigured
The optimized L SPs are reconfigured with the following parameters:
* Metric Type—Autoroute
* Metric and Hop Limit—na

* Setup BW—O0, the same value as the resulting RSV PTEOpt::BWReg, or unchanged, depending on how
you configured the Post Optimization option in the Advanced tab

* Primary paths Standby—T (true)

* Status—Active

* FRR Enabled—T (true)

* LSP entry in the Actual Pathstableisremoved

Reports
WAE Design writes a report containing the results of the optimization. To access thisinformation, choose
Window > Reports.
The report summarizes the results of the optimization, such as how many L SPs there are total compared to
how many were optimized, as well as how they were optimized. It also summarizes how digoint priorities
were handled and the number of paths that exceed the interface's bandwidth bound.

Examples

Optimizing New LSPs Example

Figure 123: Non-Optimized L SP Routes, on page 330 shows three LSPs: LSP_A is configured with 4000
Mbps of Setup BW, LSP_B with 5000 Mbps of Setup BW, and LSP_C, which represents anewly added L SP,
with 6000 Mbps of Setup BW. Each interface has a Resv BW value of 10,000 Mbps. Without optimization,
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this newly added LSP_C is using three hops to reach crl.bos because thisis the only path with sufficient

bandwidth.
Figure 123: Non-Optimized LSP Routes
Interfaces LSPs

Node Interface Resv BW Sim Remote Node Name  Source Destination Setup BW

crlchi to_crlnyc 10000.00 crlnyc LSP_A crlchi crlbos 4000.00

crlnyc to_crl.chi 10000.00 crl.chi LSP_B crlchi crlbos 5000.00

crlwsh to_crlbos 10000.00 ¢crlbos LSP_C crlchi crlbos 6000.00

crlbos to_crlwsh 10000.00 crlwwsh

crl.chi to_crlwsh 10000.00 crlwsh

crlwsh to_crl.chi 10000.00 crl.chi

crlnyc to_crlwsh 10000.00 crlwsh

crlwsh to_crl.nyc 10000.00 crl.nyc

crlnyc to_crlbos 10000.00 crlbos

crlbos to_crlnyc 10000.00 crl.nyc

LSP_A LSP_B Newly Added LSP_C

crehi A—m- crlnye alchi A_qu- crlnye sin e = aun
| | |
Il [ ' /
H S i M & m | 42

e e am— | wsh e - B T - i wh me————T 2 ibes |2
criwsh Z cribos orl.wsh 3= Z crl.bos crlwsh | Z cribos §

Figure 124: Example: No Optimization Improvements When Setting New LSP_C to Opt and All Other LSPs
to Fix, on page 331 shows the results of prioritizing the optimization of the new L SP by setting it to Opt, and
setting the other two LSPsto route “asis’ by setting them to the Fix LSP group. The LSP Required BW
parameter is Setup BW, and the interface BW Bound is Resv BW. While a primary path with explicit hops
iscreated for LSP_C, all LSPsremain on the same route. This demonstrates that LSP_C cannot go on a
two-hop path without exceeding bandwidth and it cannot alter this behavior by shifting the other two LSPs
around because they are set to Fix. The interface bandwidth bound, however, is not exceeded, which is shown
in the RSV PTEOpt::BWBoundExceeded column in the Interfaces table. The L SPs table shows that only
LSP_C was updated in the RSVPTEOpt::Action column, and that neither LSP_B, nor LSP_C are on their
shortest path. Notice also in the L SPs table that the Setup BW values are reset to 0, which is the default
behavior, and that the RSV PTEOpt:: Group shows how each L SP was considered during the optimization (Fix
or Opt).

Figure 125: Example: Improved Global Optimization When Setting All LSPs to Opt, on page 331 shows the
results of an alternative optimization where all three L SPs are set to Opt. The resulting plan file shows both
LSP B and LSP_C were optimized to route on shortest paths without exceeding bandwidth bounds.
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Figure 124: Example: No Optimization Improvements When Setting New LSP_C to Opt and All Other LSPs to Fix

Specify LSP Groups

Q) Set RSYPTEOpt: :Group with selections

LSPs

opt: [Selected in table (1/3)
Name Setup BW RSVPTEOpt:Group RSVPTEOpti:Action RSVPTEOpt:ShortestPath
Fit:  [None LSP_A 0.00 Fix na T
Fic [al LsPB 0.00 Fix na F
Ignore: Remaining LSPs Lsp.C 0.00 Opt Update F
Interfaces
Use existing RSYPTEOpt: :Group entries
Node Interface  RSVPTEOpt:BWBound RSVPTEOpt:BWBoundExceeded
LSP Parameters crlehi to_crlnyc  10000.0 F
Recuired BW [Se == crlwsh  to_crlbos 10000.0 F
e op crlchi  to_crlwsh 100000 F
Interface Parameters crlnyc  to_crlwsh 100000 F
crlwsh  to_crlnyc  10000.0 F
BW Bound [Reservable BW calnyc  to_crlbos 10000.0 F
Fix LSP_A Fix LSP_B OptLSP_C
crichi ) - I R W crlnye cri.chi R m—— - Ly Cobe Y | eme——— NG
' |
|
~ 1 ) M 4
|
Lo ! “ ¢ A4 P
lwsh W1 Z ribos criwsh -_cj_Z Pt B =R e ——— Z cribos é
Figure 125: Example: Improved Global Optimization When Setting All LSPs to Opt
Q) Set RSVYPTEOpt: :Group with selections
Opt: [AII
Fitt  [None
Fix: [None
OptLSP_A Opt LSP_B OptLSP_C
atchi ﬁ—m- crinyc Tl Am.- T CRETY | e —————
I 7 | ¢ z :
_ | | |
e R I e —— Z o1bos | | criwsh w1 Z aibos | | criwsh we —m—rz aibos %

Tactical Mitigation Example

Figure 126: Unroutable L SP Due to I nsufficient Bandwidth, on page 332 shows three non-optimized L SPs:
LSP_A and LSP_B have 4000 Mbps and 5000 Mbps of Setup BW, respectively. They route the same asin
Figure 123: Non-Optimized L SP Routes, on page 330. LSP_C has 12,000 Mbps of Setup BW, leavingit unable
to route because all interfaces have a Resv BW of 10,000 Mbps.
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Figure 126: Unroutable LSP Due to Insufficient Bandwidth

cr1.chiA»'_.—; 1 el e

alwsh M . . T Z crlbos
LSPs

Name Source Destination  Setup BW
1 LSP_A crl.chi crlbos 4000.00
2 LSPB crl.chi crlbos 5000.00 L
3/LSP C crlchi crlbos 12000.00 &

Figure 127: Example: Congestion Occurs When Settings L SPsto Fix, on page 333 shows an optimization run
to set this high-Setup BW LSP_C to Opt and keep the other L SPs set to Fix. This resultsin congestion and

leaves three interfaces exceeding their bandwidth bound.

Analternativeis shownin Figure 128: Example: Tactical Congestion Mitigation Using Fit L SPs, on page 333,
where congestion isreduced by running the optimization to set LSP_C to Opt, while setting the other to L SPs
to Fit. Thislets WAE Design adjust the routes of the other L SPs to achieve the best optimization possible
(lowest shortest-path metric with the least congestion). While both LSP_B and LSP_C route on two hops
now, two interfaces still exceed their bandwidth bound, though the amount of congestion is significantly less.
Note that the same result would be achieved if all three L SPs had been set to Opt.
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Figure 127: Example: Congestion Occurs When Settings LSPs to Fix
Specify LSP Groups
Q) SetRSYPTEOpt: :Group with selections
opt:  [Selected in table (1/3)
Fit: None
Foc (Al Interfaces 14l )
lonore:;Remaliing L3S Node  Interface  RSVPTEOpt:BWBound| RSVPTEOpt:BWBoundExceeded RSVPTEOpPt:BWTotal
Use existing RSVPTEOpt: :Group entries
crlnyc  to_crlbos 10000.09 T 16000.00
LSP Parameters crl.chi to_crlwsh 10000.09 T 12000.00
Required BW [Setup BW crlwsh  to_crlnyc 10000.00\T 12000.00
|
crl.chi to_crlnyc 10000.00 F 9000.00
Ineriace Rarametecs crlwsh  to_crLbos 10000.00 F 5000.00
B Bound [Reservahle BwW crlnyc  to_crlwsh 10000.00 F 5000.00
Fix LSP_A Fix LSP_B OptLSP_C
erlchi ﬁ_m- erLnye alchi —EB_- arlnye LAl | ee— Tl.wm iy
| |
H < ; H / i &
|
5 k- 4 ‘ -
g 24 z 4 2
‘ | e—— | ! : i 3 . s : A — s |
arlwsh W I thn; rlwsh e - EE— mz albos | |olwsh meeC 1 Zcums §
Figure 128: Example: Tactical Congestion Mitigation Using Fit LSPs
Interfaces
Specify LSP Groups
Node Interface  RSVPTEOpt:BWBound | RSYPTEOpt:BWBoundExceeded RSVPTEOpt:BWTotal
Q) Set RSYPTEOpt::Group with selections
crlwsh to_crlbos 10000.00| T 12000.00
Opt: Selected in table (1/3) 7
crlchi to_crlwsh 10000.00\T 12000.00
it lal crlchi to_crLnyc 10000.00 F 9000.00
Fix: None crlnyc to_crlbos 10000.00 F 9000.00
Fit LSP_A Fit LSP_B Opt LSP_C
mh'ﬁ'_m"- alnyc C’“*‘A'—M" e RN | e m—— — T
|
1 § i H > A p 1
V . I b
alwsh W T Z a1bos | | qrwsh mesc—— S — 4‘! aibos | | crtwsh -»—EB3_<Z erlbos §
Step 1 If thisis thefirst time using the tool and if you want to use your own preconfigured RSV PTEOpt properties, you must

manually edit the LSPs and Interfaces tables to create them.

* LSP RSVPTEOpt::Group—Place L SPs into the Opt, Fit, or Fix groups. Any remaining L SPs are placed in the
Ignore group.

« LSP RSVPTEOpt::RequiredBW—Define an exact amount for the sum total of L SP bandwidth that is using the
interface.
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Step 2

Step 3
Step 4
Step 5
Step 6

Step 7
Step 8
Step 9
Step 10
Step 11
Step 12
Step 13

Step 14
Step 15

RSVP-TE Optimization |

« Interface RSV PTEOpt::BWBound—Define an exact amount of bandwidth that the interface can hold.
* Interface RSVPTEOpt::Metric—Define an exact amount to use in shortest path cal culations.

If creating digoint paths between LSPs in the same digjoint group, the L SPs must first be added to the disjoint groups
inthe L SP Propertiesdialog box. Here, you can also assign prioritiesto L SPswithin these groups. Higher priority LSPs
are assigned shorter routes based on the metric being used for shortest path cal culations. The higher the number, the
lower the priority.

Disjoint Group: GBD >

Disjoint Priority: 1

ag10ez

If using tagged L SPs, create those tags. For information on how to create tags, see Plan Objects, on page 23.
If running the optimization based on selections, select those L SPs.
Choose Tools > RSVP L SP Optimization > RSVP-TE Opt.

In the Specify LSP Groups area, make selections for optimizing L SPs based on Opt, Fit, or Fix LSP groups, or based
on those defined in the RSVPTEOpt::Group property.

In the Required BW field, set bandwidth requirements for the primary L SP paths.
In the BW Bound field, set how much bandwidth the interfaces can carry.

In the Metric field, specify on which property to base the shortest path.

(Optional) Specify the name of the resulting plan file.

Click the Advanced tab.

| dentify whether to create disjoint LSP paths and if so, how you want them defined.

Specify any objects you want to avoid (like Nodes, Interfaces, L1 Links, L1 Nodes, and SRLGS) during optimization
in the Avoid Objects section.

Specify whether to reset the L SP bandwidth after the optimization, and if so, how so.
Click OK.
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Explicit and Tactical RSVP-TE LSP Optimization

The Explicit RSVP-TE L SP Optimization tool minimizes congestion by optimizing the placement of primary
and secondary paths for selected RSV P LSPs. By default, WAE Design minimizes the utilization across
primary paths under normal operation and creates digjoint secondary paths so that a single failure cannot
disrupt both paths simultaneously.

Thedefault isto optimize utilization on all interfaces using all RSV P L SPs on those interfaces. Another default
isto remove CSPF constraints, such as affinities and hop limits. For example, WAE Design sets the setup
bandwidth to 0, thus providing the greatest flexibility when setting these explicit paths.

Upon completion, WAE Design tags the RSV P L SPs with expopt and generates a new plan file with an -eopt
suffix. Thisplan file opens, showing the L SPstable that isfiltered to these rerouted (and newly tagged) RSV P
L SPs. Saving this plan file then simplifies the process of identifying which RSV P L SPs to reconfigure in the
network.

WAE Design also writes areport containing the results of the optimization. To access this information later,
choose Window > Reports.

This section contains the following topics:

* Running the RSVP-TE L SP Optimization Tool, on page 335
* Tactical Explicit RSV P-TE LSP Optimization, on page 340

Running the RSVP-TE LSP Optimization Tool

Step 1

Step 2
Step 3

Step 4

Choose Tools> RSVP L SP Optimization > Explicit Opt. (See Table 33: Explicit RSV P-TE L SP Optimization Options
, on page 336 for field descriptions.)

Specify objectives for primary, secondary, and tertiary paths.
Identify which interfaces to optimize.

Thedefault isto optimize RSVP L SP paths on all selected interfaces, and by default, all interfaces are considered sel ected.
You can, however, optimize alimited number of interfaces or specify a set of RSV P LSPs by preselecting them or by
using tags.

Click OK.
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What to do next

Table 33: Explicit RSVP-TE LSP Optimization Options

Field

Description

Primary Path Options

Primary paths

Define whether to reroute primary RSVP L SP paths:
* Optimized—Create optimized explicit primary paths based on the objectives selected.
« Keep—Route RSV P L SPs aong the existing primary paths.

Primary paths are optimized using the following three objectives in order of priority. The
first two objectives move RSV P L SPs away from their shortest latency path in an attempt
to reduce the utilizations of the most highly utilized interfaces in the network.

1. Minimize # of interfaces with
utilization > x %

Specify a percentage and minimize the number of selected interfaces with utilizations over that
percentage under normal operation (default).

2. Minimize maximum interface
utilization

Route primary paths so that the maximum interface utilization over al selected interfacesis
minimized under normal operation.

3. Balance across equal latency
paths

Balance utilizations over lower utilized interfaces. For example, use this option to balance
utilizations on parallel interfaces between two nodes if the two interfaces have the same latency.

« Utilization threshol d—Keep the number of interfaces with utilization greater than thisvalue
as low as possible without significantly increasing the latencies of the primary paths.

« Latency tolerance—Permit this percentage of additional latency.

Enforce latency bounds

Enforce latency bounds that can be specified for some or all demandsin the planfile. If checked,
this option takes precedence over all of the preceding objectives.

Secondary Path Options
Secondary paths Define whether and how to route secondary paths.
» Optimized—Create optimized explicit secondary paths based on the objectives selected.
» Dynamic—Route secondary paths dynamically. No explicit hopswill be created for the path.
« None—No secondary paths are created; existing paths are removed.
For optimized secondary paths, the objectives are used in order of priority listed.
Hot Standby Set the secondary path to be a hot standby, which meansit is established at the same time as the

primary peth, rather than after the primary path fails.
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Field

Description

1. Maximize primary/secondary
path disjointness with respect to

Define primary and secondary paths for each RSVP L SP that are digjoint with respect to circuit,
SRLG, node, and Layer 1 (L1) link failures, depending on what is selected.

« Circuits—No circuit is used by both the primary and secondary paths (default = 1).

* SRLGs—No SRLG is used by both the primary and secondary paths (default = 2).

* Nodes—No node is used by both the primary and secondary paths (default = 3).

* L1 Nodes—No L1 node is used by both the primary and secondary paths (default = 3).
e L1 Links—No L1 link is used by both the primary and secondary paths (default = 3).

« Traffic digointness only—A path is acceptable even if it uses similar circuits, SRLGs, or
nodes as other paths provided there is no traffic routed over the RSV P LSP when failures
occur.

You can specify the degree of digjointness of primary and secondary paths. The lower the
number, the higher the disjointness priority. For example, if it isimportant that the paths are
node digoint and the SRL G digjointness are less important, you could change the setting to
circuits 1, nodes 2, and SRLGs 3.

Note that the network topology sometimes makes it impossible to fulfill al the selected
digointness requirements. In this case, paths are selected that are maximally disjoint. That
is, they are digjoint for as many circuits, SRLGs, nodes, L1 nodes, and L1 links as possible.

2. Minimize # of interfaces with
utilization> __ %—

Options 2 and 3 both operate on the sel ected failure scenarios (circuits, SRL Gs, nodes, L1 nodes,
and L1 links) listed in the “Failures to consider” options listed under 3. These choices are the
failure scenarios over which the simulation is performed at the end of the optimization. Note that
this selection of failure scenariosis distinct from the failure scenarios sel ected for the digjointness
objective 1.

Use option 2 to minimize the number of interfaces with utilizations over the specified percentage
across al selected failure scenarios.

3. Minimize maximum interface
utilization

Use option 3 to minimize the maximum interface utilization over al interfaces and over all selected
failure scenarios.

Tertiary Path Options

Tertiary paths Define whether to create tertiary paths:
» Dynamic—Create dynamic tertiary paths.
* None—No tertiary paths are created.
Hot Standby Set thetertiary path to be a hot standby path, which meansit is brought up with the primary path,
rather than after the primary path fails.
Other Options

Optimized Interfaces

Identify which interfaces to optimize: all interfaces, those selected prior to opening the dialog
box, or those with specific tags.
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Field Description

Using RSVP LSPs Specify which L SPs are candidates for rerouting. The default is al the LSPs currently routed on
the selected interfaces.

Tag changed LSPs Create and add tags to all L SPs rerouted during optimization. Using tags makes it easier to find
the L SPsthat need to be reconfigured in the actual network according to the optimization results.
By default, newly optimized RSV P L SPs are tagged as expopt .

New plan for result This default option creates anew plan with the results of the optimization. Unless anameis
specified, WAE Design attaches an -eopt suffix to the current plan filename. If unchecked, WAE
Design changes the current plan file with the updated information.

Details button See Setting Optimization Details, on page 338.

Setting Optimization Details

Step 1 Choose Tools> RSVP L SP Optimization > Explicit Opt. (See Table 33: Explicit RSV P-TE L SP Optimization Options
, on page 336 for field descriptions.)

Step 2 Click the Details button to identify less frequently used parameters, such astraffic levels and how to treat non-optimized
interfaces.

» Non-optimized interfaces—You can specify whether to ignore non-optimized interfaces or set the acceptable level
of utilization for them.

If setting an acceptable utilization level and if both options are selected, WAE Design uses the higher of the two.
These settings are calculated on a per-interface basis.

 Acceptable utilization of optimized interfaces:  %—Thisvalueis the same as the utilization threshold set
in the Primary Path area (Minimize# of interfaceswith utilization > %, where the default is 80). To change
this value, you must change it in the Primary Path area.

If using the Tactical Explicit RSVP-TE L SP Optimization tool, thisfield is equivalent to, and thus only
changeable in, the Acceptable Utilization % field.

e Current utilization + ___ % —Current utilization of non-optimized interfaces plus the added percentage.

Mon-optimized interfaces

@ Acceptable utilization is maximum of:

] Acceptable utilization of optimized interfaces: 80%
W]  current utilization + 0 %

Ignore

Example: There are two non-optimized interfaces: crl.chi_crl.miahas a utilization of 60% and cr2.5jc_cr2.okc hasa
utilization of 78%.

The acceptabl e utilization settings for non-optimized interfaces are:
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* The primary path utilization threshold is 80%.
* The current utilization has 5% added to it.

.‘: Explicit LSP Optimization Settings

Primary Paths

Mon-optimized interfaces 1. [¥] Minimize # of interfaces with utilization > 80 %

@ Acceptable utilization is maximum of:

[¥]  Acceptable utilization of optimized interfaces: 80%

[¥] current utilization + 5 %

‘ .‘: Tactical Explicit LSP Optimization Settings ‘

Acceptable interface utilization: 80 Yo

381050

Result: The maximum utilization for each interface isindividually calculated. The acceptable level of utilization for
crl.chi_crl.miais 80%, and the acceptable level of utilization for cr2.5c_cr2.okc is 83% (78 + 5).

* LSP Configuration > Create fully explicit named paths for—BY default, WAE Design creates named paths across
the RSVP L SPs that were selected if areroute is required to achieve the optimization objectives. For example, if a
selected dynamically routed RSV P L SP has an acceptable route, WAE Design does not create a named path for it.

To change this default, click All selected L SPs. WAE Design then creates and routes fully explicit named paths for
all selected RSVP LSPs.

LSP Configuration

Create fully explicit named paths for
All selected LSPs
@ Rerouted LSPs only

11046

el
)

« LSP Configuration > In addition—BYy default, WAE Design sets the Setup BW to zero, providing the greatest
flexibility when creating explicit routes. Aswell, all affinities and hop limits are removed, and the setup and hold
priorities are set to 7. These changes apply only to the RSV P LSPs with newly created or changed explicit named
paths.

You can turn off these defaults, and you can also set them individually after the optimization is performed using the
L SP Paths Properties dialog box. (In the LSP Paths table, right-click an RSV P L SP path and choose Properties.)
If these defaults are turned off, the original parameters are preserved.

In addition:
] Set Setup BW to zero

etz

Remove affinities

1

Remaove Hop Limit
Set Setup Priority, Hold Priority to 7

=

< E <
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« Traffic Level—Choose thetraffic level you want used in the utilization cal cul ations and optimizations. For information
on traffic levels, see Traffic Demand Modeling .

« Rerouting Preference—BY default, preferences on which RSV P L SPs to reroute are not based on traffic volume.
You can select high-traffic or low-traffic options to sequentially give priority to RSV P L SPs with higher and lower
traffic.

Step 3 Click OK to close the Details dialog box.
Step 4 Click OK.

Tactical Explicit RSVP-TE LSP Optimization

The Tactical Explicit RSVP-TE L SP Optimization tool is areduced version of the Explicit RSVP-TE LSP
Optimization tool. Thistool optimizes only primary paths using the minimum number of path changesrequired
to bring utilizations below an acceptable level. It is useful when you need to reduce congestion in a specific
area of the network with alimited number of RSV P L SP reconfigurations.

If you need to target specific interfaces or RSV P L SPs to confine the optimization to problem areas, select
those interfaces or RSVP LSPsfirst. Then choose Tools > RSVP L PS Optimization > Tactical Explicit
Opt.
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Segment Routing Optimization

The SR-TE Optimization, on page 341 tool creates or updates segment lists to minimize the sum total of
user-specified metrics for selected SR L SPs, including inter-AS L SPs, using the fewest number of segment
list hops as possible. The tool sets the routes based on traffic engineering criteria and optimizes a sequence
of node or adjacency hops for the SR LSP paths to follow.

The SR-TE Bandwidth Optimization, on page 347 tool letsyou reduce thetraffic utilization of selected interfaces
to below a specified threshold. Thisability to mitigate congestion is useful when planning for increased traffic
and when determining if service-level agreements can be met in the event of congestion. Additionally, you
can use thistool for reoptimizing bandwidth after events, such as network failures and subsequent route
reconvergence.

This section contains the following topics:

* SR-TE Optimization, on page 341
» SR-TE Bandwidth Optimization, on page 347
» Compressing Segment Lists, on page 354

SR-TE Optimization

You can use the SR-TE Optimization tool to design, capacity plan, and manually configure networks to meet
the following objectives:

N\

Note SR-TE Optimization tool supports both Inter-Areaand Inter-AS functionalities.

* TE Metric or Delay Minimization—Minimize distance between hops with respect to metrics other than
IGP metrics. These can be either TE metrics configured on interfaces (which can be set proportional to
circuit latency) or latencies (delays) for each circuit. An example application is a differentiated service
inwhich latency-sensitive network traffic is routed on shortest latency paths, while the bulk of the traffic
routes over cost-optimized paths.

« Avoidance—Create or optimize segment lists so they avoid routing through specified objects (nodes,
interfaces, L1 links, L1 nodes, or SRLGs). An example application is routing pairs of L SPs, each over
adifferent plane in adual-plane network. The sametraffic is routed over both L SPs simultaneously, thus
improving availability.
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While there is an option to specify a maximum number of hops, doing so might not achieve the lowest
possible latency. In this case, the best achievable solution is provided.

You can additionally avoid unnecessary L SP churn by specifying boundaries (bounds) on the path length
and margins within which the shortest path must be optimized.

A\

Note Unlessqualified with“TE" or “IGP" the term metric in this chapter appliesto
|GP metric, TE metric, or delay.

Optimizing SR-TE LSPs

Choose Tools > SR L SP Optimization > SR-TE Opt. Then identify which SR LSPsto optimize: all SR
L SPs, those selected before opening the dialog box, or those with specific tags. The default isto optimize all
selected SR LSPs, and by default, all SR LSPs are considered selected.

« Parameters for optimizing explicit L SP paths are specified in the Bound, Margin, and Constraints areas
of the dialog box. If you do not specify a bound, margin, or constraint, WAE Design generates the best
possible SR LSP routes for the given path metric.

* A segment list is created or updated for all SR L SP paths that can be optimized using the minimum
number of segment list hops possible.

* If an LSP has a directly associated segment list, the segment list is del eted.
* If an LSP has no L SP paths, an L SP path with a path option of 1 is created.

« If an LSP has no segment list, but it has L SP paths, a segment list is created for the active path if it
existsand if not, for the lowest path option (where lowest means the smallest value).

« If an L SP hasassociated L SP paths and a segment list associated with either the active path or lowest
path option, the segment list hopsin the segment list are updated.

Example: Figure 129: Example SR L SP Optimization, on page 343 shows an SR L SP that normally
routes from AMS-FRA-PAR based on IGP metrics. It has no LSP paths. All circuits have a Delay
Sim value of 50 except for the AMS-FRA circuit, which has a Delay Sim value of 60. Optimizing
this SR LSP based on delay resultsin rerouting the SR L SP over the shortest achievable delay path,
creating an L SP path with a path option of 1, and creating a segment list node hop on the cr.lon
node.

 Thefinal hop is either a node hop or interface whose remote node is the destination of the LSP.

« If itisnot possibleto achieve thelowest possible path without exceeding the specified maximum number
of segment list hops, WAE Design providesthe best achievable sol ution within thisrestriction of maximum
permissible hops.

« If itis not possible to avoid all specified nodes for an SR LSP, that SR L SP is not updated.

« If an existing segment list would be better optimized by removing all segment list hops, those hops are
removed, though the segment list remains.

« If apreviously optimized SR L SP does not need further optimization, it isnot changed and its previously
set SROpt tag is removed.
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« If the source and destination nodes are in different IGP areas, WAE Design creates an explicit hop on
the most optimal ABR for each IGP area that the SR LSP traverses.

Figure 129: Example SR LSP Optimization
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Optimizing the Path Metric

The Minimize Path Metric selection defines whether to optimize SR L SPs based on interface IGP metrics,
interface TE metrics, or circuit delays. This minimization is for the sum of the metrics along the path. Note
that for inter-AS SR L SPs, these metrics are calculated end-to-end for the LSP, not per AS. These properties
are configurable from an interface Properties dialog box, and delays can also be set in a circuit Properties
dialog box.
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Minimize Path Metric [TE Metric v
IGP Metric
TEMetric [
Delay 2

Bound and Margin

Bounds and margins identify which pathsto optimize, aswell aswhen to stop optimizing a given path. If you
enter avaluefor more than onerestriction, WAE Design usesthe strictest limitation as the optimization target.
If there is no bound or margin specified, WAE Design optimizes L SP paths to the best possible solution
(lowest total metrics for the LSP path).

Bound: Maximum Acceptable Path Length

The Fixed Bound entry letsyou set the maximum path metric that is acceptable. WAE Design triesto optimize
L SP paths with metrics that exceed this bound. If a solution adhering to this bound cannot be found, the best
possible solution is provided and bound violations are listed in the report. L SP pathsthat are less than or equal
to this bound are not optimized.

Example: If you select to optimize L SP paths based on TE metrics, the value entered is 50, and the sum of
TE metrics on the LSP path is 51, that L SP path is optimized.

Enter anumber based on the selected path metric. A TE metric is a property values whose total sum for the
L SP path cannot be exceeded. The delay is also a property value, but it isin milliseconds (ms). If you enter
“50" and you have selected delay as the metric to optimize, this represents 50 ms as the maximum acceptable
delay for the LSP path.

Margin: Maximum Acceptable Metric Above Shortest Path

The Margin entries let you identify the acceptabl e deviation above the shortest achievable path metric. Any
existing L SP path with a metric that isless than or equal to the shortest path metric plus the margin is not
optimized.

* Fixed—The amount by which ametric must be surpassed before it is optimized.

Example: If an SR LSP route has a delay of 110 (asin Figure 129: Example SR L SP Optimization, on
page 343), afixed margin set to 10, and the shortest achievable delay path is 100, the current SRLSPis
within the margin and will not be updated (Figure 130: Example SR L SPs Optimized with Margins, on
page 345). If the fixed margin is set to 9, the SR LSP would be optimized.

100 (shortest path) + 10 (fixed margin) = 110, so al paths greater than 110 are optimized
* Percentage—The amount by which ametric must be surpassed, expressed as a percentage of the shortest
path, before it is optimized.

Example: If an existing SR LSP route has a TE metric of 210, a percentage margin set to 10%, and the
shortest achievable TE metric path is 200, the current SR L SP is within the margin and will not be
updated. If the current SR L SP had a metric of 225, it would be optimized.
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200 (shortest path) x .10 (percentage margin) = 20, so all paths greater than 220 must be optimized

Example: If an SR LSP route has adelay of 110 (asin Figure 129: Example SR L SP Optimization, on
page 343), afixed bound is set to 120, afixed margin is set to 15, a percentage margin is set to 5%, and
the shortest achievable delay path is 100, the strictest of these restrictions takes precedence, and the SR

LSPisoptimized (Figure 130: Example SR L SPs Optimized with Margins, on page 345).

Fixed Bound = 120
100 (shortest path) + 15 (fixed margin) = 115

100 (shortest path) x .05 (percentage margin) = 5, so al paths greater than 105 are optimized because it

isthe strictest margin
Figure 130: Example SR LSPs Optimized with Margins
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Constraints

The constraints let you specify restrictions for the optimizations.

» Maximum Segment List Hops—The maximum number of segment list hops that any given segment list
can contain after optimization. If no value is specified, WAE Design creates as many hops as needed to

optimizethe SR LSP.
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 Avoid—Do not permit optimized segment lists to route through the selected or tagged objects (nodes,
interfaces, L1 links, L1 nodes, or SRLGs). Thisconstraint isuseful when modeling dual-plane topologies

that route digjoint L SPs.

Example: Figure 131: Example of Avoiding Tagged Nodes During SR-TE Optimization, on page 346
shows an SR L SP from crl.chi to crl.miathat isrouted based onits shortest IGP route. It also showsthe

optimized SR L SP path if it were to avoid crl.okc based on its tag.

* Restrict segment nodesto core nodes—Segment list node hops must be core nodes (nodes that have their
Function property set to “core”), and the local node of segment list interface hops must be a core node.
An SR LSP could still route using edge nodes if they are not used as hops.

Figure 131: Example of Avoiding Tagged Nodes During SR-TE Optimization

Before Optimization

F

arci

A

S5
crl.ok

crinyc

=l
==

MNodes

\:Tag: acme_region (1/5) '}

crl.okc Properties

Basic | Inventory | sRiGs | user

Tags

| Show all
Included
1@

Tags

| [Selectall [*] [Filter [¥] 1/1 rows

After Optimization While
Avoiding Tagged Nodes

crinyc
Jo .

Using SR Tags and Creating New Plan Files

These options identify how optimized SR L SPs are tagged, and whether to create new plan files with the

results:

* Tag updated L SPs with—Create and add tagsto all SR L SPs rerouted during optimization. Using tags
makes it easier to find the changed SR L SPs that are deployed to the network or to find those SR L SPs
that need to be reconfigured in the actual network according to the optimization results. By default, newly
optimized L SPs are tagged as SROpt .

» New plan for result—This default option creates a new plan with the results of the optimization. Unless
anameis specified, WAE Design attaches an -SRopt suffix to the current plan filename. If not selected,
WAE Design changes the current plan file with the updated information. Saving this plan file then
simplifies the process of identifying which L SPsto reconfigure in the network.

. Cisco WAE Design 7.4.0 User Guide




| Segment Routing Optimization
Optimization Report .

Optimization Report

Upon completion, WAE Design writesareport containing the results of the optimization, aswell asverifications
that the results met the criteriafor avoiding nodes and meeting the specified bounds. To accessthisinformation
later, choose Window > Reports.

SR-TE Bandwidth Optimization

Table 34: Feature History

Feature Release Information Description
SR-TE Bandwidth Optimization | Cisco WAE Release 7.4.0 * The SR-TE Bandwidth
Enhancements Optimization Tool can now be

used to specify utilization
threshold valuesfor individual
interfaces. A new field called
Utilization Threshold Tables
fileallowsyouto upload a.txt
file containing threshold
values for specific interfaces
in the form of atable. SR-TE
Bandwidth Optimization Tool
uses these details to reduce
utilization on the link to the
specified threshold value.

Users can now know if they
have enough capacity in their
network for congestion to be
mitigated under different
failure scenarios. The SR-TE
Bandwidth Optimization Tool
in WAE Design is enhanced
to include Congestion
proximity constraint. This
constraint specifies that the
new SR LSP
source/destination nodes may
differ from the demand
source/destination nodes and
the Source/Destination nodes
closer to congestion pointsare
selected.

The goal when reducing traffic isto reroute as few demands as possible. Thisis achieved by creating private
SR L SPs for demands. The SR-TE BW Optimization tool also creates L SP paths and segment lists for these
L SP paths with the fewest node or interface segment list hops possible, with a maximum of three hops. The
final hop is either a node hop or interface whose remote node is the destination of the LSP.
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Thetool operates on a set of constraints that determine which paths are selected, whether demands and L SPs
can be rerouted, and whether demand latency bounds can be surpassed. If the traffic cannot be reduced to
below the threshold given these constraints, private SR L SPs are still created to route demands to reduce
congestion as much as possible. If interface utilization surpasses the threshold prior to the optimization, it
does not go higher. Utilization of non-congested interfaces might increase, though these will not surpass the
threshold.

Thetool reroutes existing SR LSPs only if they are private to a demand.

\)

Note SR-TE Bandwidth Optimization tool supports Inter-Area functionality.

Operating Modes

You can run the SR-TE BW Optimization tool in two modes:

« Analysis—Performs multiple optimizations, one for each failure scenario within the specified failure
set. The results of these optimizations are aggregated in areport.

* Operation—Performs an optimization using a specified set of constraints.

An output plan fileis produced with the optimization results. Only asingle state of the network is considered.
For example, if no objectsarefailed in theinput plan file, the optimization is performed for normal operation.
If acircuit isfailed in the input plan file, the optimization is performed considering this particular failure
scenario.

Interface Utilization Thresholds

You can specify utilization threshold of an interface using the SR-TE Bandwidth Optimization tool. If the
utilization for an interfaceislarger than thisthreshold value, then that interface is considered to be congested,
and the tool reduces traffic on the link.

* Global Utilization Threshold—Use thisfield to specify the global threshold value which appliesto all
interfaces on the network.

« Utilization Threshold Tables file—Use this option to upload Utilization Threshold Tables file which is
a.txt file. Thisfile contains the threshold value for a specific interface.

Thefile contains atable called <InterfaceThresholds> which has the threshold values defined and
separated using tabs. The table has three columns namely Node, Interface, and Threshold.

A sampletable is shown below:

<InterfaceThreshol ds>
Node Interface Threshol d
crl.nyc to_cr2.wdc 70

This above sample table specifiesthat utilization on interface to_cr2.wdc from crl.nyc must belessthan
70 percent.

Use the Browse button to upload the Utilization Threshold Tablesfile.

Uploading thisfile is optional. But when the interface threshold is specified using thisfile, the tool aims
to reduce the utilization on this link to the specified threshold.
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Constraints

Both the analysis and operation modes use the same dialog box for specifying bandwidth constraints:

* Path Selection—When choosing demand routes, the SR-TE BW Optimization tool uses one of two
criteria:

» Maximize Available BW—Paths are optimized to achieve the highest available bandwidth on
interfaces (Capacity Sim - Traff Sim).

» Minimize Metric—Paths are optimized to minimize the sum of the metrics along the path with
respect to delay, TE, or IGP metrics. All of these properties are configurable from an interface
Properties dialog box, and delays can also be set in a circuit Properties dialog box.

» Create I nterface Segment Hops—If checked, the tool considersinterface hops when trying to drive
down utilization.

* LSPs:

* Create new L SPs—If checked, new private SR L SPs with optimized routing can be created. If
unchecked, new L SPs are not created.

* Midpoint Optimization Mode—Choose:

« Disabled: Default mode indicating that the new SR L SP source/destination nodes must
match demand source/destination nodes.

» Demand endpoint proximity: Specifies that the new SR L SP source/destination nodes
may differ from the demand source/destination nodes. Source/Destination nodes closer
to demand endpoints are selected.

« Congestion proximity: Specifies that the new SR L SP source/destination nodes may
differ from the demand source/destination nodes. Source/Destination nodes closer to
congestion points are selected.

» Exclude End Nodes—Nodes selected are not considered as source/destinations nodes for SR

L SPs. Default is None. The nodes selected here are ignored if Midpoint Optimization Mode
is set to Disabled.

* Rerouting L SPs
* Fix LSPs—Controls whether or not L SP routes can be modified. This constraint is useful if
you want to reroute existing L SPs to mitigate congestion.
* Rerouting Demands:
» Traffic Steering Mode—If Individual Demands is selected, each demand is individually carried by

aprivate LSP. If Autorouteis selected, multiple demands can be carried by anon-private Autoroute
LSP

» Maximum Demand Split—Use this option to split demandsinto smaller demands. If 'n' isthe value
entered, the demands are split into 'n+1' smaller demands. The default valueis 0.

» Fix Demands—Sel ected or tagged demands are not rerouted. This constraint is useful, for example,

when you have previously optimized specific L SPs within the network and want to maintain the
route of one or more existing demands.
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* Enforcelatency bounds—If checked, demands cannot surpasstheir configured latency bound. (This
property is set in ademand's Properties dialog box.) If the latency of rerouted demands exceeds the
configured bound, the tool does not reroute demands on congested interfaces.

Bandwidth Optimization Report

Examples

Upon completion of a basic optimization, the SR-TE BW Optimization tool generates a summary report to
identify key changes due to the optimization. The tool tags the L SPs with SRBWbpt and generates anew plan
file with an -SRBWbpt suffix. This plan file opens, showing the L SPs table that is filtered to these rerouted
(and newly tagged) L SPs. Saving this plan file then simplifies the process of identifying which LSPs to
reconfigure in the network. Both the tags and the new plan filenames are editable.

After running the bandwidth optimization, the optimizer creates a summary report of the:
» Number of interfaces that exceeded the utilization both before and after the optimization.
» Maximum utilization both before and after the optimization.
* Number of demands that were rerouted.
* Number of LSPs that were created and rerouted.
* Average segment list length.

» Number of latency bound violations both before and after the optimization.

Figure 132: Network Before Optimization, on page 351 shows a network before bandwidth optimization. It
has no L SPs, and there is congestion between San Jose (5ic) and Los Angeles (lax), aswell as between Los
Angeles (lax) and Houston (hst). Sorting the Util Sim column shows the top five highest utilizations with two
of them higher than 90%. Notice that the demand from sjc to hst routes directly over these highly used
interfaces.
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Figure 132: Network Before Optimization
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To optimize the maximum available bandwidth to be bel ow 90% and to enforce latency bounds, the following
parameters are set:

« Congestion threshold = 90%.

* Base the rerouted paths on maximizing available bandwidth.

« Enforce latency bounds.

The result of this optimization is that no interfaces have utilization over 90%, and the interfaces with the

highest utilization are different interfaces than prior to the optimization. Figure 133: Network After Reducing
Utilization to Below 90%, on page 352 shows this redistribution of traffic acrossthe network. The only demand
rerouted was the one between sjc and hst, which you can compare to Figure 132: Network Before Optimization,
on page 351.
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Figure 133: Network After Reducing Utilization to Below 90%
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Figure 134: Optimized Network Under Failure, on page 353 showsthis same network, but with afailed circuit
between Seattle (sea) and Chicago (chi). There are three interfaces with over 100% utilization. Here, the
SR-TE BW Optimization tool was rerun using the same parameters as above except the congestion threshold
was set to 100. Although congestion cannot be completely mitigated, the tool minimizes congestion as much
asit can, leaving only one interface congested (over 100% utilized).
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Figure 134: Optimized Network Under Failure

o T— Before Optimization

= 136.26
e 12935

113.98
: 87.53
A a | 86.20

— 8y ] 85.39
' o L 83.93

- ma 80.04

sza. A/ chi S o Ihos Util S;m After Optlmlzatlon
¥ 7S - !
/ e & 12935
| |‘ | 99.23
' £ by ? 98.46
sic MF u r u Tl T« wdc

23 96.96
1t H ad | 96.53
hx.'\ . ] ;\"“-‘_ [l 90,21
‘| 5] 88.57
hst
B mia 87.53
Number of Rerouted Demands 4
Before After
Number of congested interfaces: 3 1
Maximum interface utilization: 136.26% 129.35% 2

Optimize Bandwidth

Step 1

Step 2
Step 3
Step 4
Step 5

Skip this step if you are using tags. You can also skip this step if you want to run the tool on al interfaces, and if you are
not selecting demands to fix.

If you are fixing selected demands or running the optimization on selected interfaces, select them before opening the
dialog box.

« If you are selecting one or the other, do so from their respective Demands or Interfaces tables.

« If you are selecting both, make your selection in one table, and then press and hold the Alt key (Option key on a
Mac) while making selections in another table.

Choose Tools > SR L SP Optimization > SR-TE BW Opt > Operation.

Select whether to optimize bandwidth for al interfaces, selected interfaces, or tagged interfaces.

Specify constraints. See Constraints, on page 345.

Specify whether to create and add tags to all SR L SPs rerouted during optimization. You can edit the SRBWopt default.
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Step 6

Step 7

Specify whether to create a new plan with the results of the optimization. Unless a nameis specified, WAE Design
attaches an -SRBWbpt suffix to the current plan filename. If unchecked, WAE Design changes the current plan file with
the updated information.

Click OK.

Analyzing Congestion Under Different Failure Sets

Step 1

Step 2
Step 3

Step 4

Step 5

You can perform multiple optimizations, onefor each failure scenario within aspecified failure set. Theresults
of these optimizations are aggregated in areport. This way, you can evaluate the ability of the optimizer to
mitigate congestion under different failure scenarios.

Choose Tools > SR L SP Optimization > SR-TE BW Opt > Analysis. By default, the analysistool presents you with
the Basic bandwidth optimization options.

Click the Failure Set tab.
Select failure sets that you want the optimizer to consider (circuits, nodes, sites, and so on).

Entries appear dimmed if they are not available in your design plan.
(Optional) Specify the maximum number of threads.
By default, the optimizer triesto set this value to the optimal number of threads based on the available cores.

Click OK.

This runs a simulation analysis and creates the optimization report.

Compressing Segment Lists

Step 1
Step 2

Step 3
Step 4

Some routers might not support long segment lists; however, long segment lists might be required to achieve
the desired route.

The Compress Segment Liststool takes L SPsasinput and creates new segment liststhat adhereto amaximum
length. Any segment liststhat exceed the maximum length are replaced by new L SPs, L SP paths, and segment
lists. A newly created LSP is set as the final segment list hop of the previous L SP; this process repeats until

theinitial L SP reachesits destination. Thetool also creates new L SPswhen the route crosses an AS boundary.

Choose Tools > SR L SP Optimization > Compress Segment Lists.

Choose which segment lists to compress: all (the default), those selected before opening the dialog box, or those with
specific tags.
In the Maximum Segment List Length field, enter avalue of at least 3 hops. The default limit is 9 hops.

Check the Remove Orphaned Segment Lists check box if you want to remove segment lists that are not used by other
L SP paths or SR FRRs as aresult of the optimization.
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Step 5 In the Tag updated L SPswith field, enter atag to add to all segment lists that are compressed during optimization.
Using tags makes it easier to find the segment lists that need to be compressed in the actual network according to the
optimization results. By default, newly compressed segment lists are tagged as S.Opt .

Step 6 Check or uncheck the New plan for result check box. If checked, WAE Design generates anew plan file with the results
of the optimization and appends the suffix S_Opt to the new plan filename. (You can change the filename.) If unchecked,
WAE Design changes the current plan file with the updated information.

Step 7 Click OK.
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Capacity Planning Optimization

Asdemand grows on your network you need away to addressthe additional traffic and congestion. To dleviate
congestion, you can:

 Upgrade existing circuits by adding more capacity to them
» Augment these circuits with associated port circuits
» Add parallel circuitsto existing circuits

« Specify new adjacencies between nodes that were not initially connected

To perform these planning optimization investigations, WAE Design includes a capacity planning optimization
tool. The goal of a capacity planning optimization isto minimize the addition of any required capacity to be
installed on the network. The capacity planning optimizer operates on both Layer 1 and Layer 3 network
elements, aswell as acrossfailure sets, so you can use acombination of elementsin alayered fashion to reach
an acceptabl e solution to meet maximum utilization requirements.

Figure 135: Design Before Optimization, on page 357 shows an example of a network design before
optimization, where extrademands were placed on the network. Asaresult, you can see congested interfaces
in purple.

Figure 135: Design Before Optimization
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This section contains the following topics:

» Workflow, on page 358
* Reports, on page 360

« Layer 3 Optimization Options, on page 361
« Layer 1 Optimization Options, on page 363
 Advanced Optimization Options, on page 364

Workflow

Step 1 Choose Tools > Capacity Planning Optimization

Capacity Planning Optimization |

You can set optimization parametersto relieve network congestion and augment capacity. You start by defining
amaximum utilization threshold for a specified set of interfaces and then layering additional options that
operate on Layer 3, Layer 1, and across failure sets.

)

Note Some of the optimizer options are mutually exclusive; for example, if you tell the optimizer to create port
circuits, it cannot create parallel circuits at the same time. Other options are complementary; for example,
you can specify the creation of paralléel circuits and new adjacencies together.

Layer 3 Layer 1 Advanced

Maximurn Interface Utilization %o

Capacity

Capacity Increment | 2438

| Mbjs

[ Use Capacity of Exisiting LAG Members

Upgrade Existing Circuits
Upgrade Circuits | All

(@) Create Port Circuits (LAGS)
() Create Parallel Circuits
Create New Adjacencdes

Restrict New Adjacencies between Nodes | (Mo tags defined)

Maximum Number of New Adjacencies |

Set IGP Metric of New Interfaces to

@ Shortest IGP Metric minus Decrement | 1

O Fixed Metric

Tag Upgraded Circuits with: |Capadty0pt::Upgraded

Tag New Objects with: |Capacity0pt: New

Mew plan for resultt  |LBO_demo-CapPlanOpt

Cancel

Step 2 In the Layer 3 tab, define the maximum utilization threshold that you want to use for all interfaces in the network.
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Step 3

Step 4
Step 5
Step 6

Step 7

Workflow .

Decide on the Layer 3 optimization options to use. (Options are described in Table 35: Layer 3 Optimization Options,
on page 362.)

* Specify the capacity parameters to use when upgrading circuits, creating port circuits, or creating parallel circuits.

Note You can specify both the capacity increment and the existing capacity of LAG circuits in tandem.
* Specify circuit upgrade parameters.
You can upgrade all existing circuits or asubset of these circuits. If you want to allow the upgrade of just certain circuits,

indicate those circuits to be modified. Thisisuseful if you want to limit your upgrades to a certain geographical location
in the network.

To create new port circuits or parallel circuits, choose one of the following options:

* Create new port circuits (LAGS). In this case, the optimizer augments the existing circuits with associated port
circuits (LAGSs) with additional port circuits. The optimizer converts non-LAG circuitsto LAGs.

* Create new parallel circuits. In this case, the optimizer creates new circuits that are parallel to existing circuits.

« Create new adjacencies.
By default, the optimizer does not create new adjacencies. If you specify aset of candidate nodesfor it to use, the optimizer
proposes new adjacencies. The optimizer restricts a new adjacency between the specified candidate nodes. For example,

you might require that only core nodes be directly connected. In this case, specify only core nodes as your candidate
nodes. Additionally, you can impose alimit on the maximum number of new adjacencies that the optimizer creates.

To create new adjacencies:

* Choose al the nodes in the table or just a subset of the nodes that you want to optimize.

« Specify the Maximum Number of New Adjacencies threshold.

Note You can apply the IGP metric to new adjacencies, but not to parallel circuits.

« Specify the IGP metric type for new interfaces, which can be either:

Decrement (default): The metric of new interfacesis equal to the shortest path minus the value specified in the metric
option.

Fixed: The metric of new interfacesis equal to the value specified in the Fixed Metric field.

(Optional) Onthe Layer 1tab, check CreateL 1 Circuits. Seefor the Layer 1 optionsand Table 36: Layer 1 Optimization
Options, on page 363 see Creating Layer 1 Circuits, on page 364 for more information.

(Optional) On the Advanced tab, choose options to provide additional capacity planning and describe the cost for the
various elementsin your design.

(Optional) On the Layer 3 tab, override the defaults for how circuits are tagged or for how new optimized plan files are
named.

Click OK to create the capacity planning optimization reports.

WAE Design routesthe traffic and looks at the utilization threshold you specified, and any other optimization parameters
you specified. After running an optimization, you can look at the summary report to see what the optimizer did to remove
congestion. The key metric to look at isthe Total Capacity Added (Mb/s).

Figure 136: Design After Optimization, on page 360 shows the design after optimization using the parameters specified
in Step 1. In this case, the optimizer proposes to set up two new adjacencies:
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. Reports

* One between Seattle (sea) and Houston (hst)
* One between Atlanta (alt) and Boston (bos)

Figure 136: Design After Optimization
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Reports

The Reports window provides a summary report and a capacity upgrades table.

Summary Report Example

After running the optimization, the summary reports provide useful metrics at a glance. Using the previous
design as an example with the default utilization threshold of 100%, the decrement interface metric type, and
unbounded adjacencies, this report provides details on the:

* Total capacity added as aresult of the optimization (in this example, 34832 Mb/s)
* Number of new adjacencies (in this example, 2)

» Number of upgraded circuits (in this example, 4)

* Number of new circuits (in this example, 2)

* Number of new ports (in this example, 36)

» Number of new port circuits (in this example, 28)

« Number of new L1 ports (in this example, 20)

* Number of new L1 circuits (in this example, 10)
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* Number of new L1 circuit paths (in this example, 10)

Figure 137: After Optimization Summary Report Example

Capacity Upgrades Report Example .

Reports CAPACITY PLANNING OPTIMIZATION

» L1 Circuit Path Explicit Routing
Explicit LSP Path Routing
~ Capacity Planning Optimization
Summary
Capacity Upgrades (5)

Upgraded

£ candidate Nodes

metr e

Hew Object tag

ts to upgrade : 50

22

: decrement

1 100%
1 2488

: unbounded

: none

1 4

: CapacicyOpc::New
: CapacityOpt::Upgraded

Farallel H

Create L1 ta : true
Create Ex © Primary L1 Circuit Paths: false
Create Secondary L1 Circuit Paths : false

Number of
Homber of
Humber of
Nomber of
Humber of
Number of
Humber of
Humber of

Total Capacity hdded (Mb/as)

Hew L1

1 34832

1 36

120

Capacity Upgrades Report Example

Click Capacity Upgrades for details on how the optimizer upgraded circuits. Using the previous optimized
design as an exampl e and using the default utilization threshol d of 100%, the decrement interface metric type,
and unbounded adjacencies, this report provides details on the six circuit upgrades that it suggests to meet

your optimization parameters.

Figure 138: After Optimization Capacity Upgrades Report Example
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In this example, out of the six upgrades listed, there were two new port circuits created for each upgraded

circuit.

Layer 3 Optimization Options

You have several Layer 3 options for capacity planning. These parameterstell the optimizer what your
preferencesarein termsof utilization thresholds, capacity increments, and whether to upgrade existing circuits,

create new adjacencies between nodes, create port circuits, or create parallel circuits.
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Table 35: Layer 3 Optimization Options

Capacity Planning Optimization |

Option

Description

Maximum Interface Utilization

Defines the congestion threshold for al interfaces in the network. By default, the capacity
planning optimizer sets the threshold at 100% congestion. However, for future planning
purposes, you might want to set the utilization to alower number, such as 90%.

Capacity Increment

Defines the bandwidth increment value (that is, the allowed capacity increment). You can
think of this value as the capacity of the ports. The default is 100000 Mby/s.

Use Capacity of Existing LAG
Members

Augments capacity based on the capacity already defined in the existing LAG Members
instead of using the Capacity Increment.

Upgrade Circuits Upgrades all circuits, or just a subset of circuits or those circuits with certain tags to reduce
congestion. By default, the optimizer assumes that you want to upgrade all circuits.
To indicate that you want to use a subset of these circuits, you can choose them using tags
or by choosing a subset of them from the WAE Design tables.

Create Port Circuits (LAGS) Creates port circuits to reduce congestion. If anon-lag circuit is upgraded, the optimizer

creates a port circuit with theinitial capacity (existing L1 circuits are reassigned to this port
circuit) and new port circuits are created.

Create Pardllél Circuits

Creates parallel circuits to reduce congestion. If you tell the optimizer to create parallel
circuits, you cannot also tell it to create port circuits and vice versa.

Restrict New Adjacencies between
Nodes

By default, the optimizer does not create new adjacencies. If you specify a set of candidate
nodes for it to use, the optimizer proposes new adjacencies. The optimizer restricts a new
adjacency between the specified candidate nodes. For example, you might require that only
core nodes be directly connected. In this case, specify only core nodes as your candidate
nodes.

Maximum Number of New
Adjacencies

Specifies the maximum number of adjacenciesto create between candidate nodes. By defaullt,
this is an unbounded number.

Set IGP Metric of New Interfaces to
Shortest IGP Metric minus

Setsthe |GP metric of the interfaces corresponding to new adjacenciesto be the shortest IGP
metric minus the decrement of 1. Thisis how the IGP metric of such interfacesis set by

Decrement default. The IGP metric of new interfaces due to parallél circuit upgradesis the same as the
metric of the parallel interfaces.

Fixed Metric Defines afixed IGP metric to use when creating new interfaces. Enter a positive integer asa
valuein thisfield.

Tag Upgraded Circuits with Definestags any upgraded circuits. By default, the optimizer tags upgraded circuits with the
label CapacityOpt::Upgraded .

Tag New Objects with Definestagsfor any new objectsthe optimizer creates. By default, the optimizer tags upgraded

circuits with the label CapacityOpt::New .

New plan for result

Specifies a name for the new plan file. By default, the optimizer appends the input plan
filename with -CapPlanOpt .
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Parallel Circuits Design Example

Figure 139: Adding Parallel Circuitsto Increase Capacity, on page 363 shows the first design in this chapter
with parallel circuits added to increase capacity. In this case, the optimizer proposes five sets of parallel
circuits:

* One between Houston (hst) and Los Angeles (lax)

* One between Los Angeles (lax) and San Jose (§¢)

* One between San Jose (§ic) and Seattle (seq)

 One between Boston (bos) and New York City (nyc)

* One between Atlanta (atl) and Washington, D.C. (wdc)

Because the utilization threshold was set to 100%, utilizations over 90% (shown in red) are acceptable solutions.

Figure 139: Adding Parallel Circuits to Increase Capacity
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Layer 1 Optimization Options
The Layer 1 optionstell the optimizer to create new L1 circuits.

Table 36: Layer 1 Optimization Options

Option Description

Match Explicit Routes of Parallel | AssignsL1 circuit path hopsto new primary L1 circuit paths to match the explicitly specified
Primary L1 Circuit Path routes of existing parallel L1 circuits. By default, paths are dynamically routed.

Create non-standby Secondary L1 | Creates secondary L1 circuit paths to simulate optical restoration capabilities.
Circuit Path

Feasibility Limit Ignores new L3 adjacencies with no possible route in the L1 topology that is lower than the
specified feasibility limit. The default is unbounded.
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Option

Description

Acceptance Threshold If thetotal feasibility metric onthe L1 linksonthe L1 circuit path exceedsthefeasibility limit,

WAE Design rejects the path. The metric on the L1 link is not entirely fixed; it might contain
some noise. You can specify how much noise to take into account when testing the path metric
against the metric limit.

When WAE Design proposes new L1 circuit paths between two L1 nodes, it's important that
thefeasibility metric limit isnot violated. Therefore, you can specify what acceptance threshold
to use when considering new L1 circuit paths. Each L1 circuit path has its own feasibility
threshold.

Creating Layer 1 Circuits

Step 1
Step 2
Step 3

Step 4

Step 5

Step 6

If you know exactly where you want to place L1 circuits, you can use explicit routing. To simulate optical
restoration capabilities, you can create secondary L1 circuit paths.

In the Capacity Planning Optimization tool, click the Layer 1 tab.
Check Create L1 Circuits.

(Optional) Specify whether you want to use explicit routing, create secondary L1 circuit paths, or both. See Table 36:
Layer 1 Optimization Options, on page 363 for the Layer 1 options.

(Optional) In the Feasibility Limit field, enter a positive number.

The optimizer takes into account the feasibility limit of each Layer 1 circuit path; that is, how far it can travel and what
impairments it can suffer.

Because of the feasibility limit, the optimizer might, for example, recommend adding five 10-GB circuitsinstead of a
single 100-GB circuit.

(Optional) In the Acceptance Threshold field, enter a positive number. Lower thresholds increase the risk that the L1
circuit path is not feasible in the network. The default is 3.

Click OK.

Advanced Optimization Options

Step 1
Step 2

Use the advanced options to:
* Choose whether to optimize for capacity or cost.

* Define what failure scenarios to consider.

In the Capacity Planning Optimization tool, click the Advanced tab.
Click one of the following radio buttons:

 Minimize Capacity—(Default) Minimizes the capacity that is added to your network.
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» Minimize Cost—Runs the optimization with the objective of reducing the overall cost when adding new capacity.
Click Insert to manually enter a cost unit for capacity, L3 and L1 ports, and the feasibility limit. Alternately, click
Import to import cost values from afile.

When you run an optimization, the tool generates areport on the overall cost—including the cost of the added ports—and
recommends the most cost-efficient solution.

Step 3 In the Failure Sets area, choose options that you want the optimizer to consider (circuits, nodes, sites, and so on). Entries
appear dimmed if they are not available in your design plan.

Step 4 (Optional) Specify the maximum number of threads. By default, the optimizer triesto set thisvalue to the optimal number
of threads based on the available cores.

Step 5 Click OK.

Thisaction createsthe capacity planning optimization report showing the results of the increased capacity. The optimizer
takes into account whether it makes sense to upgrade existing circuits or set up new adjacencies, and considers capacity
increments, cost options, and feasibility limits.

Cisco WAE Design 7.4.0 User Guide .



Capacity Planning Optimization |
. Advanced Optimization Options

. Cisco WAE Design 7.4.0 User Guide



CHAPTER 24

L1 Circuit Path Optimization

One common use case for L1 circuit path optimization isthat digoint L1 circuit paths can ensure services are
highly resilient when network failures occur. For example, thistool lets you route L1 circuit paths to have
digoint primary and secondary paths that are optimized to use the lowest delay possible.

L1 circuit paths are digoint if they do not route over common objects. Thisis useful, for example, when
planning L1 circuit paths, particularly when multiple L1 circuit paths connect the same pair of L1 nodes.
Using digjointness on these L1 circuit paths can help improve availability.

If any L1 circuit path isunrouted, no L1 circuit path hops are created for it. If the simulated central frequency
ID of an L1 circuit path is different than the user-specified central frequency ID on the path, theinitializer
sets the central frequency ID value of the L1 circuit path to the simulated central frequency ID. You can
choose to retain existing L1 circuit path hops.

If it is not possible to achieve the optimization as defined by the routing selection, path requirements, and
constraints, the tool provides the best digjoint paths and optimization possible.

This section contains the following topics:

« Running the L1 Circuit Path Optimization Tool, on page 367
* Reports, on page 368

Running the L1 Circuit Path Optimization Tool

Step 1
Step 2

Step 3

Choose Tools > L1 Circuit Path Optimization.

From the L1 Circuit Paths drop-down list, choose which L1 circuit paths to optimize: all, those selected in the table, or
those with specific tags. The default isto optimize all selected L1 circuit paths, and by default, all L1 circuit paths are
considered selected.

From the Minimize Path Metric drop-down list, choose whether to optimize L1 circuit paths with respect to the:
o L1link metric
 Delay of the L1 link
* Distance of the L1 link

* Hop count

This minimization is for the sum of the metrics along the L1 circuit path.
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Step 4

Step 5

Step 6

Step 7

Step 8

Step 9

L1 Circuit Path Optimization |

Choose one of the following digoint path constraints:

» None—Do not create digoint paths and do not enforce any digointness.

* Create digioint paths between L1 circuitsin disjoint groups—For all L1 circuitsthat arein digoint groups, route all
L1 circuit paths so that they are disoint from all other paths belonging L1 circuitsin that disoint group. This
disiointness extends beyond primary and secondary paths to include all other path options (for example, tertiary).

* Createdigioint primary and secondary pathsfor L1 circuits—For all L1 circuits, whether they arein adigoint group
or not, route all L1 circuit paths so that they are digjoint from all other paths belonging to that L1 circuit. This
digointness extends beyond primary and secondary paths to include all other path options.

Note If digoint path constraints are selected, L1 Diversity Constraintsinvolving the selected L1 Circuits are set to
be inactive in the output plan.

If you chose to create digjoint paths, click Edit and specify priorities for the type of digointness. Then, click OK inthe
Edit Disjoint Priorities dialog box.

(Optional) To retain existing L1 circuit path hops and consider them in the optimization, check Respect existing L1
Circuit Path Hops. To remove existing L1 circuit path hops and actual L1 circuit path hops, |eave the check box
unchecked.

For example, if you check this check box and aloose node hop is specified for an L1 circuit path, the created fully explicit
path must contain a strict hop to the node.

Inthe Tag Updated L 1 Circuit Pathswith field, enter atag to add to all paths rerouted during optimization. Using tags
makesit easier to find the L 1 circuit paths that need to be reconfigured in the actual network according to the optimization
results. By default, newly optimized L1 circuit paths are tagged as L10Opt .

Check or uncheck the New plan for result check box. If checked, WAE Design generates anew plan filewith the results
of the optimization and appends the suffix L1Opt to the new plan filename. (You can change the filename.) If unchecked,
WAE Design changes the current plan file with the updated information.

Click OK.

Reports

Upon completion, WAE Design writes a report containing the results of the optimization. (To accessthis
information later, choose Window > Reports.)

The Digjoint Groups and Path Digjointness reports list the number of common objects (selected as digjoint
path requirements) before and after the optimization, as well as disjointness violations based on these
requirements before and after the optimization.

Example

LAYER 1 CIRCU T PATH OPTI M ZER

Opti ons

Plan File
Qutput File :
Exi sting L1 circuit hops . renove

. Cisco WAE Design 7.4.0 User Guide



| L1 Circuit Path Optimization

Example .

Routi ng sel ection . Current
Disjoint priorities

(L1 Link, L1 Node, Site, SRLG : 1,ignore,ignore,ignore
L1 Gircuit Paths
Nunber of L1 Circuit Paths sel ected . 20
Nunber of Disjoint G oups D2
Di sjoint Groups with conmmon
L1 Links 0
L1 Nodes 2
Sites 2
SRLGs 0

(See Path Disjointness Report for details)
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Changeover

WAE Design lets you model the topology, routings, and utilizations of a currently operational network. It
aso alows exploration of modifications to that network. For example, interface metrics can be modified or
explicit LSP routings changed to obtain a new routing configuration.

The Changeover tool provides a step-by-step sequence of routing configuration changes to move a network
safely from an initial configuration to a prespecified final configuration. WAE Design selects the order of
these changes so that thereis aslittle as possible congestion in the network during intermediate configurations,
and so that this congestion lasts for as few intermediate steps as possible.

Only certain configuration changes are allowed between the initial and final plan:
« Changes to interface metrics
* Changes to L SP configurations

* Changes of circuits and node from the active to the inactive state, and vice versa

Anindividual step in the changeover sequence consists of one of the following:
* A single metric change on a specific interface
« L SP configuration changes on all LSPs sourced from a specific node

« The activation or inactivation of a specific circuit or node

This section contains the following topics:

« Running the Changeover Tool, on page 371
* Reports, on page 372

Running the Changeover Tool

Step 1
Step 2
Step 3
Step 4

Open both the initial and final network plansin WAE Design, and choose the desired plan to view.

Choose Tools > Changeover .

Decide on the changeover options to use. (See Table 37: Changeover Options, on page 372 for field descriptions.)
Click OK.
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What to do next

Table 37: Changeover Options

Field Description

Initial Plan Name of the initial plan, selected from open plan files.

Final Plan Name of the final plan, selected from open plan files.

Traffic Level Changeover monitors maximum interface utilization levelsfor all stepsin the sequence. The

utilizations are calculated using thistraffic level.

Acceptable Utilization The percentage of maximum acceptable utilization of any interface at any step during the
changeover sequence. Changeover triesto keep utilizations below this level, although it is not
always possible. Often the utilization spikes upward during the last few steps of the sequence, if,
for example, new ECMP paths must be put in place. WAE Design tries to keep the number of
high-utilization steps to a minimum.

Group Interface Metric Steps | Changeover Tool allowsyou to group Interface Metric changes together into steps. You can choose
from the following options:

» None - Each Interface Metric change is treated as a single step.
o Parallel - Paralel Interfaces are grouped into a single step.

* Source Node - Interfaces sourced from the same node are grouped into a single step if there
is no impact on maximum utilization.

Group L SP steps by source node | Specify whether to group the L SP steps by source node.

Reports

Changeover creates areport that contains Summary, Steps, and Utilizations sections.

» To access thisinformation later, choose Window > Reports.

« To export the steps taken to change over to anew plan file, right-click Stepsin the Reports window, and
choose Export Tables.

* To export the utilization values to atable, right-click Utilizations in the Reports window, and choose
Export Tables.

Summary

The Summary section contains alist of the options used to run the changeover. It also contains a summary of
the differences between theinitial and final plans, the number of stepstaken, and the number of stepsresulting
in intermediate configurations with utilizations in excess of the acceptable utilization.
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Steps

The Steps section contains the following columns, some of which you might need to show because they are
hidden:

* Step—Steps of the changeover sequence.
* Action—Action taken at the step.

» MetricChange—An interface metric is changed.

» CapacityChange—An interface capacity is changed.

* TunnelsFromRouter—L SPs from a specified router are to be reconfigured.
* ActivateNode—A node (router) is activated.

» DeactivateNode—A node (router) is deactivated.

* Activatel nterface—An interface is activated.

 Deactivatel nterface—An interface is deactivated.

* Node
« If Action is MetricChange, the node containing the interface of the metric to change.
« If TunnelsFromRouter, the node at which the L SPs are to be reconfigured.
* If ActivateNode or DeactivateNode, the relevant node.

« If Activatelnterface or Deactivatel nterface, the node containing the relevant interface.

* RemoteNode—If Action is MetricChange, the remote node containing the interface of the metric to
change.

« Circuit—If Action is MetricChange, the circuit for the metric change.

¢ Interface

« If Action is MetricChange, the interface name.
« If TunnelsFromRouter, ActivateNode, or DeactivateNode, thisis na (not applicable).

« |[f Activatel nterface or Deactivatel nterface, the relevant interface name.

» MaxUtil—The maximum interface utilization at this step.
« UtilL ocation—The interface on which the maximum utilization occurs.
 ChangeTo—If Action is MetricChange, the original metric. Otherwise, thisis set to “na”

» ChangeFrom—If Action is MetricChange, the metric to be configured at this step. Otherwise, thisis set
to“na”
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Utilizations

The Utilizations section contains all utilizationsfor al interfacesin the network, for each step in the changeover
sequence.
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Patch Files

A patch fileis a compact way to represent differences between plan files. These differences or patches can
be applied to other plan files or deployed to the network.

You can create, apply, view, and send patches by choosing Tools > Patches.

A common WAE Design use case is to create a plan file for deployment. One potential workflow for doing
thisisthe following:

1. Openaplanfilefrom a WAE Automation server. (File > Open from > WAE Automation Server.)
2. Duplicate the plan file by saving it as a different name.
Make L SP modifications as needed in the duplicated plan file.

3

4. Open both plan files, and create a patch file. (Tools > Patches > Create.)

5. Perform adry run to test the patch before deploying it. (Tools > Patches > Send, Dry Run option.)
6

Deploy the patch file to the network. (Tools > Patches > Send.)

This section contains the following topics:

* Opening a Remote Plan File, on page 375
* Creating Patch Files, on page 377

* Applying Patch Files, on page 378

« Viewing Patch Files, on page 378

* Sending Patch Files, on page 378

Opening a Remote Plan File

From the WAE Design GUI, you can open plan files residing on WAE Archive, WAE Automation Server,
WAE Modeling Daemon, and Design Archive to make modifications before deploying L SPs.

Prerequisites:
* You must know the username and password of the server, or its authentication must be disabled.

« The server must be configured for the type of deployment you are using.
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Table 38: Opening a Remote Plan File

Patch Files |

To...

Do This...

open afile from WAE Archive

Choose File > Open from > WAE Archive.

Identify the remote server. Enter or choose the
hostname or | P address of the server. Specify how
to connect to the server by entering or choosing
the port number and network.

To automatically populate the Network field with
the list of available networks, click Refresh List
of Networks.

If authentication is enabled, enter the same
username and password. If authentication is
disabled, the username and password fields must
be empty.

Choose the latest plan or select a plan from the
archive.

Click OK.

open afile from WAE Automation Server

Choose File > Open from > WAE Automation
Server.

| dentify the remote server. Enter or choose the
hostname or | P address of the server. Specify how
to connect to the server by entering or choosing
the port number and network.

If authentication is enabled, enter the same
username and password. If authentication is
disabled, the username and password fields must
be empty.

Click OK.

open afile from WAE Modeling Daemon

Choose File > Open from > WAE Modeling
Daemon.

| dentify the remote server. Enter or choose the
hostname or | P address of the server. Specify how
to connect to the server by entering or choosing
the port number.

If authentication is enabled, enter the same
username and password. If authentication is
disabled, the username and password fields must
be empty.

Click OK.
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Creating Patch Files .

)

Note Opening afile from Design Archive feature is not supported in Cisco WAE Design.

Creating Patch Files

Step 1
Step 2

Step 3

The patch created identifies how to get from the plan file identified in the From Plan field to the plan file
identified in the To Plan field. These patch files only include differencesin new, modified, and deleted objects
that are supported by the WAE YANG model.

Fram Plan
® PlanFile: | Edge-AK ¥

() GetPlan from WAE | Location...

To Plan

Plan File: |E|:|gE-EF‘ |

Patch

Mame: I Edoe-AK-Edge-EP.plp |

Location: | |-'|."'.n'in|:||:|'a'-.'s-x86_64 | Browse...

Gorcel

Examples:
« If From Plan Edge-AK contains 33 L SPs and To Plan Edge-EP contains 23 L SPs, the patch file identifies
which 10 LSPs to delete from plan Edge-AK to create plan Edge-EP.

« If From Plan Edge-AK contains 10 L SPs and To Plan Edge-EP contains 15 L SPs, the patch file identifies
which 5 LSPsto add to plan Edge-AK to create plan Edge-EP.

« If both plan files contain the same LSP, but in From Plan Edge-AK the L SP has a SetupBW property
equal to 100, whereasin the To Plan Edge-EP it does not, the patch file identifies the need to modify the
SetupBW property of this LSP in plan Edge-AK so that it matches plan Edge-EP.

Open the two plan files that you are using for the patch file creation.

From the plan file used as the To Plan, which is the plan file you want to achieve using the patch file, choose Tools >
Patches > Create.

In the From Plan field, choose one of the following options:

* Plan File—Choose the plan file from which you are determining required changes to achieve the plan file identified
in the To Plan field.

* Get Plan from WAE—Obtain the plan file from WAE with a specified location.
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. Applying Patch Files

Step 4 The default patch filename combines the From and To plan filenames. If needed, change the filename. It must have a
.plp extension. Unless you want the patch file to be overwritten, the patch filename must be unique to its location.
Step 5 Enter or browse to the location where you want the resulting patch file to reside.

Step 6 Click OK.

Applying Patch Files

You can apply patch filesto plan files.

Step 1 Open the plan file to which you want to apply the patch.
Step 2 Choose Tools > Patches > Apply.

Step 3 Enter or browse to the location where the patch file resides.
Step 4 Enter a unique name for the plan file you want to create as aresult of this applied patch.
Step 5 Specify whether you want to stop or continue in case of error.

Step 6 To verify the patch file's contents before applying it, click View Patch. (After viewing the patch, click Close.)
Step 7 Click OK.

Viewing Patch Files

Viewing patch files lets you ensure they meet your needs before applying or deploying them.

Step 1 Choose Tools > Patches > View.
Step 2 Browse to and choose the patch file, and then click Open.
Step 3 View the patch and then click one of the following:

* Send Patch—To deploy the patch asis.

« Edit Patch—To edit the patch before sending it. A dialog box opens, displaying the contents of the patch as XML
text. You can save or discard the patch text edits. The tool warns you if you try to saveinvalid XML syntax. You
can right-click in the patch text dialog and choose Undo to undo changes. Other standard text editing (cut, copy,
paste, and so on) is also supported.

* Close—To close the dialog box without deploying the patch.

Sending Patch Files

When sending apatch file, it isapplied to the specified network, and rel ated deployment actions are triggered.
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Step 1
Step 2
Step 3

Step 4

Step 5
Step 6
Step 7

Saving

Step 1

Step 2
Step 3

Step 4

Saving and Clearing Settings .

Choose Tools > Patches > Send.

Browse to or enter the full path to the patch file.

| dentify the remote server:

a) Enter or choose the hostname or |P address of the server.

b) Specify how to connect to the server by entering or choosing the port number and network.

To automatically populate the Network field with the list of available networks, click Refresh List of Networks.

c) If authentication is enabled, enter the same username and password. If authentication is disabled, the username and
password fields must be empty.

(Optional) Check Dry Run.

Best practiceisto perform adry run to verify the patch file can be successfully applied. If you choose this option, a status
popup shows whether the deployment of this patch would be successful, unsuccessful, or only partially successful. To
save the status of the dry run, click Save Status.

Tip If you check Dry Run or set the Test Option to Test Only, and the patch dry run succeeds, you can deploy the
patch easily. Click Send Patch in the status popup; you then return to the Send Patch dialog box with the patch
presel ected.

Dry run successful

Show Details

| Save Status | | Send Patch | | Close

Specify what to do in case of an error: roll back, stop, or continue.
Click View Patch to ensure the patch meet your needs before deploying it. (After viewing the patch, click Close.)
Click OK.

and Clearing Settings

To save all settingsfor use the next time you open the Send Patch dialog box, check Save Settings. This saves all settings
whether the fields are empty or not.

To save the authentication password, check Save Password.

To clear al current user-specified settings from the fields, click Clear Settings. Note that this does not clear the default
port value, although any manual entries are cleared.

To delete all user-specific settings so the next time you open the Send Patch dialog box all fields are empty (except for
the default port value), follow these steps:

a) Click Clear Settings.

b) Ensurethat Save Settingsis checked.

¢) Click OK to exit.
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d) At the prompt to continue, click Yes.
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Reports

WAE Design letsyou generate reports that compare | PPMPL Stopol ogy and configuration information, demand
routings, L SP routings, or traffic between two plan files. You can use these reports to:

« Plan for upgrades—Compare plan files before and after topology and configuration changes are made
to acurrent network. For example, you could compare the original plan file to a proposed new planin
which circuits or nodes are added or upgraded.

* Mitigate congestion—Compare plans before and after making configuration changesto mitigate congestion
due to afailure or planned maintenance, such as metric changes or L SP additions and reroutings.

* Validate simulations—Compare the simulated traffic under failure in one plan to the measured traffic
after afailure has occurred in another plan to validate the accuracy of the smulation.

« Audit plans—Review any changes between two plan files.

« |dentify demand and L SP reroutes—Compare plans to determine which demands or L SPs experienced
routing changes, for example as the result of an interface metric change or capacity upgrades.

Upon comparing plan files, areport of the results opens automatically. You can access this report later by
choosing Window > Reports.

For More Information... See...
Reports on L SP path routes MPLS Simulation, on page 113
Reportson L1 circuit routes Layer 1 Simulation, on page 191

Reports on demand groupings and demand grouping costs | Traffic Forecasting, on page 91
Cost Modeling, on page 391

Reports on infrastructure costs Cost Modeling, on page 391

This section contains the following topics:

 Plan Comparison Reports, on page 382
« Traffic Comparison Reports, on page 389
* Viewing or Exporting Reports, on page 390
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Plan Comparison Reports

Comparison reports let you compare objects between two plan files to determine:
» Which objects are present in one plan, but not in the other.

» Which objects are present in both plans and which, if any, have different properties.

Plan 1: us_netwk

Plan 2: [us_wan_Ll =

Report

IF/MPLS topology and configuration
) Demand routings
) LSP routings

1@ Complete plan comparison

For each object

'@ Only show properties with differences

) Show all properties compared

381186

You can run four types of plan comparison reports:

* IPIMPL S topology and configuration—Objects describing the topology (such as nodes, circuits, and
interfaces), configured objects (such asL SPsand L SP paths), and related properties (such as | GP metrics
and capacity).

» Demand routings—Demand paths and the properties that indicate routing changes, such as Path Length
and Max Latency. For acomplete list of compared properties, see Table 39: Plans Comparison Report:
IP/IMPLS Topology and Configuration , on page 383.

« L SProutings—Properties of L SPsthat indicate routing changes, such as TE Path Metric and Active Path
Sim. For acomplete list of compared properties, see Table 40: Plans Comparison Report: Demand
Routings, on page 386.

» Complete plan comparison—Al|l tablesin the table schema are compared, except for internal simulation
caching tables. For acomplete list of these tables, refer to the SCARIDEN_HOME/docs/table_schema
file.

Report Columns

Each WAE Design table has key columns that uniquely identify objects. For example, the key columnsin the
Interfaces table are the Node and Interface columns, which represent the name of the node containing the
interface and the name of the interfaceitself. In a Plan Comparison report, an object in one plan isidentified
with an object in another plan only if the key columns of the two objects match. That is, key columns determine
if an object is present in both plans or in only one of the plans.
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The Plan Comparison report displays three other types of columns. Table 39: Plans Comparison Report:
IP/MPLS Topology and Configuration, on page 383, Table 40: Plans Comparison Report: Demand Routings
, On page 386, and Table 41: Plans Comparison Report: L SP Routings, on page 387 list the propertiesreported
upon and their associated column type.

« Information only (Info)—There are no comparisons made. Information is reported for the plan file from
which you are running the report (Plan 1).

« Differences (Diff)—Specific properties are compared for each object that has matching key columns
across the two plan files. Objects are then identified as belonging in either Plan 1 only (file from which
you are running the report), in Plan 2 only (plan file to which you are comparing), or in both Plan 1 and
Plan 2. If the object existsin both plan files, but has different properties, a Diff column shows T (true)
if there are any differences or F (false) if there are none.

Differences are based on the current state of the open plan files. For example, if acircuit hasfailed, the
demand routings change to route around the failure.

» Summary Differences (Summ Diff)—These are not columns within WAE Design tables. They are T/F
(true or false) values, depending on some differences in the table objects that are not represented in the
table columns. For example, if acommon L SP path is configured differently between plans, thisdifference
is represented in a summary difference column in the L SP section. If demand routings differ, thisis
represented in a summary difference column in the Demands section.

A

Note For easy reference, the following tableslist columnsin the order of type first:
Key, Info, Diff, and Summ Diff. Properties within each column type are
alphabetical.

Table 39: Plans Comparison Report: IP/MPLS Topology and Configuration

Compared Table | Compared Columns Comparison Column Type | Summary Difference Description

Interfaces Name Key
Node Key
Remote Node Info
Affinities Diff
Area Diff
Capacity Diff
Circuit Diff
Description Diff
FRR Protect Diff
IGP Metric Diff
IP Address Diff

Cisco WAE Design 7.4.0 User Guide .



. Report Columns
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Compared Table

Compared Columns

Comparison Column Type

Summary Difference Description

PC Min BW Diff
PC Min Links Diff
Resv BW Diff
TE Metric Diff
Circuits InterfaceA Key
InterfaceB Key
NodeA Key
NodeB Key
Name Info
Active Diff
Capacity Diff
Delay Diff
Nodes Name Key
Active Diff
AS Diff
BGPID Diff
ECMP Max Diff
IP Address Diff
IP Manage Diff
Model Diff
0s Diff
Vendor Diff
LSPs Node Key
Source Key
Active Diff
Destination Diff
Exclude Diff
FRR Link Protect Diff
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Compared Table

Compared Columns

Comparison Column Type

Summary Difference Description

Hold Pri Diff
Hop Limit Diff
Include Diff
Include Any Diff
Load Share Diff
Metric Diff
Metric Type Diff
Setup BW Diff
Setup Pri Diff

Unresolved Destination

Diff

L SPs Path Diff Summ Diff T (true) if there are any differencesin the L SP Paths table for
this LSP. If two L SPs have differencesin their named path
hops or L SP paths, these differences are propagated to this
column.

L SP Paths Node Key

Path Option Key

Source Key

Exclude Diff

Hold Pri Diff

Hop Limit Diff

Include Diff

Include Any Diff

Path Name Diff

Setup BW Diff

Setup Pri Diff

Standby Diff

Named Path Diff Summ Diff T (true) if there are any differences in the Named Paths table
for this LSP path.

Named Paths Active Key
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Compared Table | Compared Columns Comparison Column Type | Summary Difference Description
Name Key
Source Key
Named Path Hops Diff | Summ Diff T (true) if there are any differences in the Named Path Hops
table for this named L SP path.
Named Path Name Key
Hops
Source Key
Step Key
Interface Diff
IP Address Diff
Node Diff
Type Diff
Unresolved Hop Diff

Table 40: Plans Comparison Report: Demand Routings

Compared Compared Comparison Column Type | Summary Difference Description
Table Columns
Demands Destination Key

Name Key

Service Class Key

Source Key

Destination Site | Info

Source Site Info

Active Diff

ECMP Min % Diff

Max Latency Diff

Path Metric Diff

Path Diff Summ Diff T (true) if there are any differencesin routing of the demand.
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Table 41: Plans Comparison Report: LSP Routings

Report Sections .

Compared Compared Columns | Comparison Column Type | Summary Difference Description
Table
LSPs Name Key
Source Key
Active Path Sim | Diff
Destination Diff
Routed Diff
Shortest TE Path | Diff
TE Path Metric Diff
Actua Path Diff | Summ Diff T (true) if there are any differences in routing of the actual LSP
path.
Simulated Path Diff | Summ Diff T (true) if there are any differences in routing of the LSP.

Report Sections

The Summary section shows the number of objectsin each plan file, the number of objectsin both plan files,
and the number of objectswith property differences (Figure 140: Example Plan Comparison Report Summary,

on page 388).

Example: Nodes A, B, and C arein Plan 1, and B, C, and D arein Plan 2. Nodes B and C have matching key
columns. The B nodes have identical properties, but the C nodes have different 1P addresses. Therefore, in
the Summary section, the In Both Plans column shows 2, and the Different Properties column shows 1.

Anindividual sectionisgenerated for each object that appearsin only one plan fileand if there are differences
between the properties, a section is generated showing these differences. Thus, there is the potential of

generating one to three sections per compared table: one for objects appearing only in Plan 1, one for objects
appearing only in Plan 2, and one listing objects existing in both plan files, a ong with their differences noted
withaT (true) or F (false).
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Figure 140: Example Plan Comparison Report Summary

Reports Plan Comparison Report
4 Campare Plans
Summary
Interfaces Diffs (14) PMan 1 us_wan_L1-2
LSPs Diffs (1056) Pan 2 us_wan_L1

Demands Plan 2 Only (8)
Demand Traffic Plan 2 Only {6)
Demand Traffic Diffs (83)
Interface Traffic Plan 1 Only (1)

Report Type Complete Plan Files
Show All properties

Interface Traftic Diffs (33) Plan 1| Plan 2 | Plan 1| Plan 2 | In Both Plans | In Both Plans,

Plot Layout Elements Plan 1 Only (11) Only | Oy | Different Properties
| interfaces | wo| 0| of o 100 14
IL‘SPS [ 1056 1056 I 0 I 0 1056 1056
:' Demands 8 os| o 6 89 0
[ Demand Traffic &9 a5 I ] ] a9 a9
.JmJerfuI:e Traffic . 100 b I 1 : 0 I 9 9%
_. Plet Layout Eleirl'lrenl:s:r 57 46 11 0 46 0

SRd19

Other than Summary, the report sections and columns (properties) that appear depend on the options selected
when generating the report.

« If you select to show only properties with differences, only those columns with differences in properties
appear inthereport. If only onevalueisdifferent, all objectsarelisted (not just the one with the different

property).

« If you select to show all properties compared, all compared properties appear in the report whether there
are differences between the two plan files or not.

Creating Plan File Comparison Reports

Step 1 Open the two plan files you want to compare.

Step 2 In either of these two plan files, choose Tools > Reports > Compare Plans.
Step 3 Choose the plan file to which you are comparing the open plan.

Step 4 Choose the type of comparisons you want to generate:

 IPIMPL S topology and configuration
« Demand routings
* LSP routings

» Complete plan files

Step 5 Choose whether to show only properties with differences or whether to show all properties compared.
Step 6 Click OK.
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Traffic Comparison Reports

Traffic Comparison reports compare traffic values within a single plan or between two plan files. You can
comparetraffic on one object at atime (nodes, interfaces, circuits, demands, L SPs, multicast flows, and flows).
Each object hasadifferent set of comparisons from which to choose. For example, interface traffic and capacity
can be compared, and L SP traffic and setup bandwidth can be compared. Another example would be to
compare the simulated interface traffic in aplan file before afailure to the measured interface traffic of aplan
filein which afailure occurred. Such a comparison lets you determine which interfaces show the greatest
differences.

For each plan file compared, the current traffic level and either the selected service class or queue are used.
They can be different in each plan.

The Summary section shows a high-level summary of what is being compared. Additionally, a section of the
difference on the selected object and traffic columns is generated and named accordingly.

Plan 1 Uus_wan
Plan 2 us_wan_L1

Compare Interfaces

Plan 1 Plan 2

Traffic Type | TraffSim TraffSim
Traffic Level | Default Default

Qos Undifferentiated | Undifferentiated
Total Traffic | 108830 Mbps 58286 Mbps

381188

Flan 1 has 30544.1 Mbps more traffic in total than Flan 2

Creating Traffic Comparison Reports

Step 1 If comparing traffic from the open plan file to another, open the other plan file.
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Step 2
Step 3

Step 4
Step 5
Step 6
Step 7
Step 8

Reports |

Compare Traffic on |Interfaces

Flan 1

Current Plan: eurcd_net

Column: ITraFF Sim

Plan 2

Select Flan: Ieurm_hru

e |

Column: [TraFF Sim

z)

KR

In each plan file, choose the travel levels and choose either the service class or queue traffic to compare.
Choose Tools > Reports > Compare Traffic. Thisplan fileisidentified as Plan 1 in the Compare Traffic dialog box

that opens.

Choose the object type on which to compare traffic (interfaces, circuits, nodes, and so on).
Choose the traffic column in the current plan that you want to compare (Plan 1).

The default Plan 2 is the current plan file. To change this, choose a different plan file for Plan 2.
Choose the traffic column being compared for Plan 2.

Click OK.

Viewing or Exporting Reports

Upon generating areport, it opens automatically. From there you can select the various sections of the report

from the left navigation pane.

To view areport after having closed it, choose Window > Reports. All reports generated on that plan file
appear and are sel ectable from one report window.

If you want to save these reports for later use, you must save the plan file. However, running the report again
overwrites the report. To preserve the information, you can export the data by report section. Right-click any
of the sections in the left navigation pane and choose Export Tables.

Reports

4 Compare Traffic
Summary
Interfaces Diffs (46)

Compare Plans
Infrastructure Cost
Simulation Analysis

Delete
Export Tables

i

1 »

381
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Cost Modeling

WAE Design provides basic cost modeling of network plans. Costs are specified for nodes and circuits, and
these can be used to approximate infrastructure costs for the network or parts of the network. This allowsfor
quick assessments of the costs of various upgrade alternatives, as well as for greenfield build-outs.

The specified circuit costs can also be used to estimate demand and demand grouping costs. Thisis the cost
of routing traffic between particular locations or sets of locationsin the network, taking into account the
amount and cost of the circuit infrastructure used. This can be used to assessthe cost of a customer, aparticular
service, or any other defined traffic source on the network.

This section contains the following topics:

« Infrastructure Costs, on page 391
» Demand and Demand Grouping Costs, on page 398

Infrastructure Costs

An Infrastructure Cost report can help you approximate the total monetary cost of a network design based on
estimated costs assigned to nodes and circuits. These costs are calculated from initial costs and per-period
costs, where per-period costs are amortized based on the specified number of periods and interest rates. The
report gives an infrastructure cost based on sums of all node and circuit costs, as follows:

* Total initial cost—Sum of all initial costs for each object type.
« Total cost per period—Sum of all per-period costsfor each object type before the amortization is applied.
« Total cost—Total initial cost + total cost per period after being amortized to a net present value.

« Total infrastructure cost—Sum of the total node and total circuit costs.
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Number 41 69

Total initial cost 211,603 | 73,148

Total cost per period 4,779 | 13,722

Number of periods 2 2
Interest rate (%) 3.75 3.75
Total cost 220,649 | 99,122

Total Infrastructure Cost 319,771

3E0E51

Cost Basis

Costs are based on any combination of Cost Initial and Cost Per Period properties that are assigned to nodes
and circuits. A typical use caseisto set nodeswith aninitial cost to identify the initial capital investment and
to set circuit costs per period to analyze the operational cost of leasing circuits over time.

« Cost Initial—Static, one-time cost to which amortization and interest rates are not applied.

* Cost Per Period—Ongoing costs that are amortized based on the number of periods identified and on
the interest rate specified when generating the Infrastructure Cost report.

You can set these properties manually. For circuits, you can also use the Cost Circuit Initializer, on page 393
to set the costs automatically based on circuit distance and capacity.

Thetotal cost for each node and each circuit appearsin its respective Cost Initial or Cost Per Period column
in the Nodes table and Circuits table. The sum total of the node and circuit costs appearsin the output of the
Infrastructure Cost report and is used in its calculations.

An easy way to see totals—as well as average, minimum, and maximum costs—without running the report
istoright-click the Cost Initial or Cost Per Period column heading.

Cost Per Penig~—* 5=

Hide this Column

124

o Show/Hide Columns
Adjust Width to Fit

1241 Save Columns settings

S00(

1244 76148 (Sum)

500( 1522.96 (Avg)

1244 0 [er:} | o

S SO00 (Max) =

L 7 =

Setting Cost Properties

You can set these properties manually, as follows.
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Cost (initial): 5000
Cost (per period): f‘-
Step 1 Choose one or more nodes or one or more circuits. Right-click one of these objects and choose Properties, or double-click

one of these objects.
Step 2 Click the appropriate tab:

» Nodes—Click the I nventory tab.
* Circuits—Click the Advanced tab.

Step 3 Enter valuesin the Cost (initial) field, Cost (per period) field, or both, and click OK.

Cost Circuit Initializer

The Cost Circuit initializer offers an automated way of setting circuit costs. For example, it letsyou set redlistic
per-period circuit costs based on distance, capacity, or both.

Thetotal cost for each circuit isthe sum of the fixed cost plusthe variable cost, where the variable cost isthe
result of multiplying the per-unit cost times the units selected (distance or capacity).

Set costs on (69/69) selected circuits
| Set initial cost
@) Set per period cost

Fixed ——>| Fixed cost: 200.00
——»| Cost varies by:
] unit distance

Variable —
|+ Unit capacity

aa0a4

—3| Per-unit cost: 10.25

To accessthisinitializer, choose I nitializers > Circuit Cost. Options are as follows:

* Set cost—Set initia or per-period cost. The options that follow are applied to the choice selected here.
Becauseinitial and per-period costs are different values that do not overwrite each other, you can set one
and then run theinitializer again to set the other.

* Fixed cost—A static cost that is most often used when setting initial costs.

* Variable cost—A cost based on a circuit’s distance, capacity, or both. Whichever unit is selected (one
or both), the value is multiplied by the “Per-unit cost” value.

* Per-unit cost—Per-unit monetary cost.
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 Unit distance—Distance Sim value of the circuit.

Example: If only “Unit Distance” is selected, if the Distance Sim is 700, and if the “Per-unit cost” is 0.50,
the variable value for this circuit is 700 x 0.50 = 350.00.

* Unit capacity—Capacity Sim value of the circuit.
Example: If only “Unit Capacity” is selected, if the Capacity Sim is 400, and if the “ Per-unit cost” is 0.25,
the variable value for this circuit is 400 x 0.25 = 100.00.

Example: This example sets a per-period cost for a circuit that has a fixed cost of 250, a per-unit cost of 2,

circuit distance of 850, and a capacity of 1000. Including all of these optionsin the calculation, the cost of
thiscircuit is:

Fixed + (Per-unit Cost x Distance Sim x Capacity Sim)
250 + (2 x 850 x 1000) = 250 + 1,700,250 = 1,700,250

Set costs on (1/69) selected circuits
") Set initial cost
(@) Set per period cost

Fixed cost: 250.00
Cost varies by:

v" Unit distance

v’ Unit capacity
Per-unit cost: 2.00

Capacity Sim  Distance Sim  Cost Per Period
1000.00 850.00 1700250.00 Z’

Infrastructure Cost Report

To create an infrastructure cost report, follow these steps.
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Step 1

Step 2
Step 3
Step 4

Step 5

Step 6

Example Infrastructure Cost Workflow .

Modes: |All

Amaortization

Mumber of periods: 2

Interest rate (%):  3.75

Circuits: [HII

Amaortization

Mumber of periods: 2

Interest rate (%):  3.75

3a0850

For any node or circuits you want included in the report, set their initial or per-period costs. For more information, see
Setting Cost Properties, on page 392.

If creating areport for selected nodes or circuits, select them before opening the report dialog box.
Choose Tools > Reports > Cost Analysis.

Nodes:

a) Select whether to include all nodes, selected nodes, or specifically tagged nodes.

b) If you are calculating per-period costs, set the number of periods and the interest rate.

Using tagsis a convenient way to determine costs for a specific region of the network or for specific customers.

Circuits:
a) Select whether toinclude all circuits, selected circuits, or specifically tagged circuits.
b) If you are calculating per-period costs, set the number of periods and the interest rate.

Click OK.

Example Infrastructure Cost Workflow

Step 1

Thisexample showsthe generation of an Infrastructure Cost report based on aspecific set of nodesand circuits,
both tagged as the East Region. It setsinitial costs on the nodes and per-period costs on the circuits based on
their distance. Thereport isfor 4 periods, and the interest rate is 5%.

Set initial node costs in the node Properties dialog box.
a) Filter to the nodes containing the East Region tag.

b) Inthisexample, there are 20 nodeswith thistag. Set the 10 core nodesto an initial cost of 2000 each and the 10 edge
nodesto an initial cost of 1000 each.
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The Nodes table lists these costs in the Cost Initial column. Right-click this column heading to see the total Cost
Initial for all of these nodes (here, 30,000). Because we are only interested in initial node costs, thisisthe same value
that the Infrastructure Cost report shows for total initial node cost.

Node Properties

Cost (initial): 2000
Cost (initial}: 1000
Cost (per period): 0
Cost (per period): 0 :r;
Step 2 Run the Latency and Distanceinitializer to set Distance Sim values on thecircuits (I nitializer s> L atency and Distance).

Set costs on (32/30) selected circuits
Set initial cost
(@ Set per period cost

Fixed cost: 0.00
Cost varies by:

[¥] Unit distance

] unit capacity

A00E4T

Per-unit cost: 2.00

Step 3 Set per-period circuit costs using the Circuit Cost initializer on circuits tagged with East Region.
a) Filter to the circuits containing the East Region tag, and select these circuits.
b) Run the Circuit Cost initializer (I nitializers > Circuit Cost). For this example, there are no fixed costs, a per-unit
cost of 2, and the initializer is only using Distance Sim.

The Circuits table lists these costs in the Cost Per Period column. Right-click this column heading to see the total
Cost Per Period for all of these circuits. Here, it is 35,063.46, and thisis the number that is amortized in the
Infrastructure Cost report based on 4 periods with a 5% interest rate.
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Example Infrastructure Cost Workflow .

MNodes: | Tag: East Region (20/33) o

Amortization

Mumber of periods: 1

Interest rate (%): O

Circuits: ITag: East Region (32/50) x

Amortization

Mumber of periods: 4

Interest rate (%%): 5

380848

Step 4 Now that costs are set up for the region, generate the Infrastructure Cost report.
a) Choose Tools > Reports> Cost Analysis.
b) Select the East Region nodes and circuits.
¢) Because there are no per-period costs for nodes, no further node options are set.

Set the circuits “Number of periods’ to 4, and the “Interest rate (%)” to 5.

What to do next
The resulting report performs these calculations:
» Sums thetotal initial costs for al nodes tagged with East Region to determine the total node cost.

» Sumsthe per-period costsfor al circuitstagged with East Region to determinethetotal per-period circuit
cost.

» Amortizes the per-period circuit costs across 4 periods using a 5% interest rate to determine the total
circuit cost.

» Adds the total node cost to the total circuit cost to determine the total infrastructure cost.
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Hodes | Circuits
Number 20 32
Total initial cost 30,000 ]
Total cost per period 0| 35,063
Humber of periods na 4
Interest rate (%) na 5
Total cost 30,000 | 124,333

Total Infrastructure Cost 154,333 5

Demand and Demand Grouping Costs

Example

Two estimates of the monetary costs of demands are automatically derived when you set per-period costs for
circuits, as follows. These appear as the following column headings in the Demands table:

* Cost by Capacity—Total of the Cost Per Period for the circuits using the demand as routed, scaled by
proportion of demand traffic to the total interface capacity.
It is divided by two to share the circuit cost between the costs of traffic in two directions.
(Sum Cost Per Period of All Circuits Using the Demand) x (Demand Utilization on the Interface/ 2)
Where demand utilization on the interface = (Interface Utilization / Capacity)
« Cost by Util—Total of the Cost Per Period for the circuits using the demand asrouted, scaled by proportion
of demand traffic to the total traffic through the circuit.
(Sum Cost Per Period of All Circuits Using the Demand) x (Demand Utilization on the Interface) / (Sum of
the Ultilizations on the Two Interfaces)
Where demand utilization on the interface = (Interface Utilization / Capacity)
If there is only one demand through the circuit, the full cost of that circuit is allocated to that demand.

Demand grouping costs are cal culated when you run the Demand Grouping report (Tools> Reports> Demand
Groupings). The Cost by Capacity and Cost by Util are the sum total of the costs of the demands within the
demand grouping.

This example shows four nodes connected by three circuits.
« Each circuit has 10,000 Mbps capacity.
« Each circuit has a Cost Per Period of 100.

* There are two demands:
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Example .

dnv-mia has 2000 Mbps of traffic.
mia-dnv has 5000 Mbps of traffic.

* These two demands are in one demand grouping named Acme_region.

driv chi

Bl [ =g, [ " jsgel ]~ -

nyc mia

Circuits

Mode A MNodeB CapacitySim Capacity Cost Per Period

dnv chi 10000.00 10000.00 100.00
chi nyc 10000.00 10000.00 100.00
nyc mia 10000.00 10000.00 100.00

| Demands |

Source Destinatio Traffic

Cost by Capacity Cost by Util

4 Demand Groupings

Demand Groupings (1)

mia dnv 5000.00 75.00 214379 o
dnv mia 2000.00 30.00 85.71 LU:
Reports

Dema
1 Name

Acme_Region 7000....

Traffic Number of Demands Cost by Capacity Cost by Util
2 105.00 300.00

aa0Ead

The Cost by Capacity calculation is asfollows:
* dnv-mia demand: (100 + 100 + 100) x ((2000/10,000)/2) = 30

« mia-dnv demand: (100 + 100 + 100) x ((5000/10,000)/2) = 75

» Acme_region demand grouping: 30 + 75 = 105

The Cost by Util calculation is as follows:
* dnv-mia demand: (100 + 100 + 100) x 2000/(2000 + 5000) = 85.71

» mia-dnv demand: (100 + 100 + 100) x 5000/(2000 + 5000) = 214.29

» Acme_region demand grouping: 85.71 + 214.29 = 300
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CHAPTER 29

Plot Legend for Design Layouts

Thislegend isfor Design layouts used in the WAE Design GUI.

\}

Note All traffic isdisplayed in Mbps. In the network plot, the traffic utilization colors represent outbound traffic.
L3 means Layer 3, and L1 means Layer 1.

Legend Description

Interfaces and Circuits Interfaces and Circuits, on page 402

Circuit Colors, on page 402

Circuit Active, Failed, and Operational States, on page 404

Nodes L3 Nodes, on page 406

Sites Sites, on page 407

Demands and Routings Demands, on page 409

Demand Segment Lists, on page 409

External Endpoint Members | External Endpoint Members, on page 410

LSPs L SP Paths, on page 411

L SP Named Paths, on page 412

LSP Actua Paths, on page 412

Segment-Routed L SP Paths, on page 413

L1 Objects L1 Links, on page 414

L1 Circuit Paths, on page 415

L1 Circuit Path Hops, on page 416

L1 Nodes, L1 Ports, and L1 Waypoints, on page 416
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. Interfaces and Circuits

This section contains the following topics:

« Interfaces and Circuits, on page 402

* L3 Nodes, on page 406

« Sites, on page 407

« Demands, on page 409

* External Endpoint Members, on page 410
* LSPs, on page 411

* L1 Objects, on page 414

Interfaces and Circuits

Table 42: Interface and Circuit Visualization

Graphic Description

3 L Circuits are rectangles divided in half by a vertical black line. Each half shows an interface. Tick marks
i 'IIIIJ; show 25%, 50%, 75% utilization levels.

a C Width of circuit shows capacity. Width increases a fixed amount for every 4x increase in capacity.
T
a C Full-length interface style, which is the defaullt.

se3 chi  Shortened interface style, showing the sameinformation asafull-length view, just in shorter representations
W oo o« [J e Fthat are repeated at each end of the circuit.
oot
0 A'? ?I n this example, al chi interfaces are shortened at both ends of the circuit.
583 chi ' Col lapsed interface view, showing the presence of interfaces as up/down arrowsinside the site. The arrow
= color shows the highest utilization of any of the collapsed interfaces (in this example, blue for seaand
: yellow for chi).

‘ In this example, al chi interfaces are collapsed at both ends of the circuit.

Circuit Colors

Table 43: Interface and Circuit Colors

Graphic Description

The traffic utilization colors are customizable.
For information, see the Cisco WAE Network
Visualization Guide .

. Cisco WAE Design 7.4.0 User Guide



| Plot Legend for Design Layouts

Circuit Colors .

Graphic

Description

Blue indicates a selected interface or circuit.

Outbound traffic utilization is depicted by colors. Default colorsarelight blue, light
green, yellow, orange, red, and purple, and | eft to right, each color represents
increased utilization.

» Measured Traffic and Simulated Traffic views—The color shows the percent
of traffic utilized for the available interface capacity.

* Worst-Case Traffic view—The color represents the worst-case utilization on
each interface. Thisis the highest utilization that a particular interface
experiences over al the failure scenarios considered when running asimulation
analysis.

* Failure Impact viewv—The color representsthe failure impact of acircuit. This
is defined as the highest utilization experienced by any interfaceif that circuit
wereto fail.

* L SP Reservation viewv—The color represents the total setup bandwidth that is
reserved by L SPs through the interface.

chi

Mg

If parallel circuits are grouped for visual display, each side of the circuit showsits
congtituent interfaces. Here, there are two circuits (two interfaces on each side)
grouped by site. If the circuits are between sites, the utilization includes the
utilization of nested interfaces, if applicable.

* The color fill on each side shows the average utilization of the grouped
interfaces, which is weighted against the sum of the grouped capacities. For
example, the average utilization for the interfaces from chi to miais between
30% and 50% and is shown in green.

* Each interface within a grouped circuit has athin colored border showing the
utilization of that interface. For example, one interface going from miato chi
isbordered by yellow and another by blue, each showing thetraffic utilization
for the bordered interface.

_E -m:‘ﬁ

White indicates 0% utilization.
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Plot Legend for Design Layouts |

Description

Interfaces are light gray for the following reasons:
» Measured Traffic view

* The interface has no traffic measurement.

« Thisamount of interface capacity is not available due to a QoS bound.

» Simulated Traffic view—This amount of interface capacity is not available
due to a QoS bound.

* Worst-Case Traffic view—No simulation analysis was performed.
* Failure Impact view
» No simulation analysis was performed.

« Failing the circuit would not increase the traffic utilization on any other
circuit.

« Circuit is operationally down.

M F
R | ||

QoS policy violations are indicated by red and white bars. Thisis displayed when
utilization exceeds the QoS bound, which is set through policy or interface queue
properties.

K—2

Shortest | GP path between two selected nodes or sites.

5 chi
ﬁw 1«

Shortest latency path between two selected nodes or sites.

Shortest TE path between two selected nodes or sites.

Circuit Active, Failed, and Operational States

Table 44: Circuit Active, Failed, and Operational States

Graphic

Description

X

Failed circuit.
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Circuit Active, Failed, and Operational States .

Graphic Description
&2 The circuit is not operational because of one of the following reasons:
5
oS * A node connected to the circuit failed.

* A sitefailed that contains a node connected to the circuit.

« ThecircuitisaLAG (port channel) that does not meet its operational requirements (minimum
number of available ports or minimum capacity, whichever is surpassed first) due to failure
of some of its ports or port circuits.

» Mapped L1 circuit cannot be routed because it traversesafailed L1 port, L1 node, or L1 link.

« An SRL G failed that contains the circuit or contains one of the above objectsthat are required
for circuit operation.

=——ps ThecircuitisaLAG, and one or more ports or port circuitsin the LAG failed. The red strikeout

line isthe percent of unavailable capacity due to the failure. In the Worst-Case Traffic view, the
red strikeout line is the percent of unavailable capacity under the worst-case failure.
If you right-click thefailed port or port circuit and choose Recover, the red strikeout line disappears.
If you right-click again and choose Fail, the red strikeout line returns.
The circuit isinactive.

a2 The circuit is not operational because of one of the following reasons:

>

&3 « A node connected to the circuit isinactive.

« Aninactive site contains a node connected to the circuit.

« Thecircuit isaLAG that does not meet its operational requirements (minimum number of
available ports or minimum capacity, whichever is surpassed first) due to some of its ports or
port circuits being inactive.

« A mapped L1 circuit cannot be routed because it traverses an inactive L1 port, L1 node, or
L1 link.

* An SRLG isinactive, and the SRLG contains the circuit or contains one of the above objects
that is required for circuit operation.

ThecircuitisaLAG and one or more portsor port circuitsinthe LAG isinactive. The gray strikeout
e —

lineisthe percent of unavailable capacity due to the inactive ports or port circuits.
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. L3 Nodes

L3 Nodes

Table 45: Layer 3 Node Visualization

Graphic

Description

A node is shown as a blue rectangle with a border. Solid blue indicates the node is selected.

A green border surrounds the node when:
» Simulated Traffic View—The node is the source or destination of simulated traffic that is greater than O.
» Measured Traffic View—The node is the source or destination of measured traffic that is greater than O.

* L SP Reservation View—The node is the source or destination of L SPs with nonzero bandwidth reservations.

A white border surrounds the node when:
» Simulated Traffic View—The node is not the source or destination of simulated traffic.
» Measured Traffic View—The node has ingress and egress traffic of 0 (zero).

» LSP Reservation View—The node is the source or destination of L SPswith 0 (zero) bandwidth reservations.

A gray border surrounds the node when:

» Measured Traffic View—The node has no ingress or egress traffic.
» Worst-Case Traffic View—Nodes always have gray borders.

* Failure Impact View—The node is not included in the failures considered, or failing the node would not increase the
traffic utilization on any circuit.

In the Failure Impact view, the node border color represents the failure impact of anode. Thisis defined as the highest
utilization experienced by any circuit if that node wereto fail.

Up/down triangles show that some interfaces from the hode have been collapsed.

Failed node.

Node is not operational becauseit is contained in afailed site or in afailed SRLG.

Nodeis not active.

Node is not operational becauseit is contained in asite or an SRLG that is not active.

One or more selected VPN nodes exist on the node.
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Sites

Site utilization colors and symbols are based on intrasite objects. Note that intrasite objectsinclude child sites
and the objects contained within them.

Table 46: Site Visualization

Graphic | Description

. A siteis shown as a blue square with a border. Solid blue indicates the site is selected.

o Layer 3view

» Measured Traffic and Simulated Traffic views—The border color is the maximum traffic utilization color of all
intrasite interfaces within the site.

 Worst-Case Traffic view—The border color isthe highest utilization that the interfaces within it experience over
all the failure sets selected for Simulation Analysis.

« Failure Impact view—The border color is the maximum utilization level that would be caused elsewhere in the
network should an L3 node or L3 circuit contained within it fail.

* Layer 1 Failure Impact view—The border color is the maximum utilization level that would be caused elsewhere in
the network should an L1 node or L1 link contained within it fail.

* Multi-Layer Failure Impact View—The border color isthe maximum utilization level that would be caused elsewhere
in the network should any L1 or L3 intrasite object fail.

&  Layer 3 view—A white border surrounds the site if all intrasite interfaces have zero utilization.

 Layer 1 view—The sites always have white borders except in Failure Impact view.

) A gray border surrounds the site when:
e Layer 3view
» Measured Traffic view—There is no measured traffic on intrasite interfaces.

» Worst-Case and Failure Impact views—No simulation analysis was performed.

* Failure Impact viewv—Failing an intrasite L3 node or L3 circuit would not increase the traffic utilization on any
L3 circuit.

e Layer 1 Failure Impact view—Failing an intrasite L1 node or L1 link would not increase the traffic utilization on any
L3 circuit.

< Multi-layer Failure Impact view—Failing an L1 or L 3 intrasite object would not increase the traffic utilization on any
L3 circuit.

@ The small box indicates that one or more intrasite objectsis selected. In amulti-layer view, thisincludes both L1 and L3
intrasite objects.
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Graphic | Description

= * Layer 3 view—Up/down triangles show that one or more egress interfaces from within the site have been collapsed.
 Layer 1 view—Not applicable.

X The site failed.

ar One or more intrasite objects failed. In amulti-layer view, thisincludes both L1 and L3 intrasite objects.

5. e Layer 3view

 One or more L3 nodes or L3 circuits contained within the site are not operational because they are contained in
afailed SRLG.

» One or more L3 nodes or L3 circuits within the site are associated with afailed L1 port, L1 node, or L1 link.

 Layer 1 view—One or more L1 nodes or L1 links contained within the site are not operational because they are
contained in afailed SRLG.

« Multi-layer view—Qne or more intrasite objects are not operational because they are contained in afailed SRLG.

x The site isinactive.

X One or moreintrasite objects are inactive. In amulti-layer view, thisincludes both L1 and L3 intrasite objects.

) * Layer 3view

* One or more L3 nodes or L3 circuits contained within the site are not operational because they are contained in
an SRLG that is not active.

« One or more L3 nodes or L3 circuits within the site are associated with an inactive L 1 port, L1 node, or L1 link.

 Layer 1 view—One or more L1 nodes or L1 links contained within the site are not operational because they are
contained in an SRLG that is not active.

« Multi-layer view—QOne or more intrasite objects are not operational because they are contained in an SRLG that is
not active.

E « Layer 3 view—One or more selected VPN L3 nodes exist on nodes within the site.
 Layer 1 view—Not applicable.
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Demands

Table 47: Demand Visualization

Graphic Description

5 i |“A” and“Z” mark the source and destination site/node of a demand. Blue arrows show demands routed
i“ E through an interface on acircuit.

p—— Percentages show the proportion of a split demand (for example from ECMP) through an interface.
-5n%t
g chi | Reroute of ademand under afailure.
ﬁ — -
e

ﬁ i Demand is routed through an LSP.

Demand is rerouted through a Fast Reroute (FRR) LSP.

—

i Shortest IGP path of a demand.
A—17

5 chi | Shortest latency path of ademand.
R
A B Multicast flow and multicast flow hops.
- e l4

Demand Segment Lists

Table 48: Demand Segment List Visualization

Graphic Description

© Site containing a node segment in a demand’s segment list.
1

—

@, Node segment in ademand’s segment list.
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Plot Legend for Design Layouts |

Graphic Description

| - Interface segment in a demand’s segment list.

© Site containing the source of an LSP segment list hop in a demand’'s segment list.

e Source node of an LSP segment list hop in a demand's segment list.
[ {:} |

b Site containing one or more nodes bel onging to an anycast group segment in ademand’s segment list.
alch Node belonging to an anycast group in a demand’'s segment list.

External Endpoint Members

Table 49: External Endpoint Visualization

Graphic

Description

a

An yellow triangle indicates that the external endpoint member
selected.

If the external endpoint member is anode, thisicon appears
under that node in the plot. If the member isan external AS
or an external ASviaanode, thisicon appears under all nodes
inthe AS.

>

Failed external endpoint member.

5 External endpoint member is not operational becauseit is contained
inafaled SRLG.
3 E External endpoint member is not active.
i External endpoint member is not operational because it is contained

inan SRLG that is not active.
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LSPs

Table 50: LSP Visualization

N |

Graphic Description
5 ' “A” and “Z" mark the source and destination site/node of an L SP. Brown arrows show how L SP traffic
ie-“ﬁ . isrouted.
5 chi Rerouting of LSP traffic when a failure occurs in Convergence mode.
T =
T e 7

T

FRR L SP path that would be taken if afailure required its use.

. e

FRR LSPthat is currently rerouting L SP traffic around afailurein FRR mode.

K—2

Shortest IGP path of an LSP.

g chi
j —

Shortest latency path of an LSP.

Shortest TE path of an LSP.

LSP Paths

Table 51: LSP Path Visualization

Graphic Description

5 [ “A” and “Z" mark the source and destination site/node of an L SP path. The brown arrow indicates the L SP
ﬁ-m- path is active (carrying traffic). The number in the gray rectangle (here 1) is the path option.

5 A lighter brown arrow indicates the L SP path is not active and is not carrying traffic. The yellow rectangle
ﬁ-_z__w + 4 indicates a standby path. The number in ayellow rectangle (here 2) is the path option.
¥ . |
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Graphic

Description

——

The percent value is the loadshare percentage that this L SP path is carrying for the selected LSP. In this
example, the L SP loadshare percentage is 75%.

LSP Named Paths

Table 52: LSP Named Path Visualization

. g

Graphic Description
g chi “A” marks the source of anamed path. The brown diamond on an interface denotes it as a named path hop.
ﬁ 1" 1« A black dot in the center denotes a strict hop.
chi A brown diamond on a site denotes that the site contains anode or interface that is a named path hop. No

black dot in the center denotes aloose hop. The siteis shown as containing aloose hop unless all hops
within the site are set to strict or exclude.

A brown diamond on anode denotesit as anamed path hop. No black dot in the center denotes aloose hop.

erl.chi-
chi “A” marks the source of anamed path. A red circle with awhite X on an interface denotesit as a named
e path hop that is set to exclude .
-C-'n...__. :
chi A red circle with awhite X on a site denotes that the site contains a named path hop on a node or interface

and that it is set to exclude .

erl.chi-

a ]
[ o

&,
i

A red circle with awhite X on a node denotes it as a named path hop that is set to exclude .

LSP Actual Paths

Table 53: LSP Actual Path Visualization

Graphic Description
cEd chi A dark brown circle on an interface denotes an L SP actual path hop on the interface.
m-_ N
L 5 |
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Graphic Description
= chi A dark brown circle on a site denotes an actual path hop on anode or interface within the site.
|| J« I
o s A dark brown circle on a node denotes an actual path hop on the node.
I

Segment-Routed LSP Paths

Table 54: SR LSP Path Visualization

Graphic |Description
R An interface segment in a segment-routed (SR) LSP.
< A site containing a node segment or an interface segment.
@ A node segment in an SR LSP.
© Site containing the source of an L SP segment list hop in an SR LSP's segment list.
g Source node of an LSP segment list hop in an SR LSP’'s segment list.
Ea {:} ]
<> A site containing one or more nodes belonging to an anycast group.
Node belonging to an anycast group.
atl.crl
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L1 Objects

L1 Links

Table 55: Layer 1 Link Visualization

Graphic Description

Unselected L1 link.

Inthe L1 Failure Impact view, indicates that failing the L 1 link would not increase the traffic
utilization on any L3 circuit.

Selected L1 link.

Inthe L1 Failure Impact view, the color represents the failure impact of an L1 link. Thisis defined
asthe highest utilization experienced by any L3 interface if that L1 link wereto fail.

L1link failed.

L1 link is not operational because of one of the following reasons:
* An L1 node failed that is connected to the L1 link.

* A sitefailed that containsthe L1 link.
* An SRLG failed that contains the L1 link.
* An SRLG failed that contains an L1 node connected to the L1 link.

L1link isinactive.

L1 link isinactive because of one of the following reasons:
X * An L1 node that is connected to the L1 link isinactive.
* Aninactive SRLG containsthe L1 link.

Multi-layer view—A blue dotted line indicates an L3-L 1 link.

cr2.chi bios
&3 = @
o o Multi-layer view—A solid, thin gray lineindicates a selected L3-L1 link.
i — . E
|
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L1 Circuit Paths

Table 56: Layer 1 Circuit Path Visualization

Graphic Description

: : Simulated L1 circuit path from L1 node “A” to L1 node “B” highlightsin green when any of the
Active Sim Path following are selected:

A— | - ﬁ * L1 circuit or L1 circuit path

« Circuit or associated interface mapped to L1 circuit

* Port circuit mapped to L1 circuit

Sim Path The simulated active path appears in a darker green than simulated paths that are not active.

c
A L____ BN ] ﬁ
Path options are numerically identified within arectangular label. Standby paths have ayellow
Standby Path background, and non-standby paths have a gray background. In this example, path option 2 isa

standby path, and path option 3 is a non-standby path.
K - . ﬁ

402437

MNon-Standby Path

A I - ﬁ
5 E Actual L1 circuit path.
ﬁ 1

Shortest latency of an L1 circuit path.

Rerouted L1 circuit path that isin use.

ig ﬁ Unrouted L1 circuit path.
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L1 Circuit Path Hops

Table 57: L1 Circuit Path Hop Visualization

Graphic Description

L1link isastrict L1 circuit path hop.

Site contains an L1 node that isa strict L1 circuit path hop.

L1 nodeisastrict L1 circuit path hop.

Site containsan L1 node that isaloose L1 circuit path hop.

{}ﬁé}_g

L1 nodeisaloose L1 circuit path hop.

L1 link isan excluded L1 circuit path hop.

Site containsan L1 node that is excluded asan L1 circuit path hop.

©

a L1 nodeis excluded asan L1 circuit path hop.

L1 Nodes, L1 Ports, and L1 Waypoints

Table 58: Layer 1 Node, L1 Port, and L1 Waypoint Visualization

Graphic | Description

An L1 node is shown as a blue rectangle without borders.
LM

— A selected L1 node is adarker shade of blue.

- L1 Failure Impact view—The color represents the failure impact of an L1 node. Thisis defined as the highest utilization
g | experienced by any L3 interfaceif that L1 node wereto fail.
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L1 Nodes, L1 Ports, and L1 Waypoints .

Graphic | Description

i Indicates that failing the L1 node would not increase the traffic utilization on any L3 circuit.
R L1 nodefailed.

st L1 port failed.

[ ¢

L1 nodeis not operational becauseit is contained in afailed site or SRLG.

=

L1 nodeisinactive.

hist

L1 port isinactive.

L1 nodeis not operational because an SRLG containing it isinactive.

L1 link waypoint.

Selected L1 link waypoint.
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