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C H A P T E R 13

Convert Network Configurations

Note The terms "Unidirectional Path Switched Ring" and "UPSR" may appear in Cisco literature. These terms 
do not refer to using Cisco ONS 15xxx products in a unidirectional path switched ring configuration. 
Rather, these terms, as well as "Path Protected Mesh Network" and "PPMN," refer generally to Cisco's 
path protection feature, which may be used in any topological network configuration. Cisco does not 
recommend using its path protection feature in any particular topological network configuration.

This chapter explains how to convert from one SONET topology to another in an ONS 15454 network. 
For initial network turn up, see Chapter 5, “Turn Up Network.”

Before You Begin
This section lists the chapter procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).

1. NTP-A154 Convert a Point-to-Point to a Linear ADM, page 13-2—Complete as needed.

2. NTP-A155 Convert a Point-to-Point or a Linear ADM to a Two-Fiber BLSR, page 13-4—Complete 
as needed.

3. NTP-A156 Convert a Point-to-Point or Linear ADM to a Path Protection Configuration, page 
13-7—Complete as needed.

4. NTP-A210 Convert a Path Protection Configuration to a Two-Fiber BLSR, page 13-8—Complete as 
needed.

5. NTP-A211 Convert a Two-Fiber BLSR to a Four-Fiber BLSR, page 13-10—Complete as needed. 

6. NTP-A159 Modify a BLSR, page 13-11—Complete as needed.
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NTP-A154 Convert a Point-to-Point to a Linear ADM
NTP-A154 Convert a Point-to-Point to a Linear ADM

Note Optical transmit and receive levels should be in their acceptable range as shown in the specifications 
section for each card in Table 2-3 on page 2-25.

Note In a point-to-point configuration, two OC-N cards are connected to two OC-N cards on a second node. 
Any multispeed slots (Slots 1 to 4 and 14 to 17) or high-speed slots (Slots 5 to 6 and 12 to 13) can be 
used if connections between nodes are consistent. For example, Slot 5 on the first point-to-point node 
connects to Slot 5 on the second point-to-point node for the working path, and Slot 6 connects to Slot 6 
for the protect path. The working OC-N ports have data communications channel (DCC) terminations, 
and the OC-N cards are in a 1+1 protection group.

Step 1 Log into a point-to-point node. See the “DLP-A60 Log into CTC” task on page 3-23 for instructions. If 
you are already logged in, go to Step 2.

Step 2 Complete the “DLP-A298 Check the Network for Alarms and Conditions” task on page 13-3 for 
instructions.

Step 3 Log into the node that will be added to the point-to-point configuration. 

Step 4 Complete the “NTP-A24 Verify Card Installation” procedure on page 4-2 to ensure that the new node 
has two OC-N cards with the same rate as the point-to-point nodes.

Step 5 Complete the “NTP-A35 Verify Node Turn Up” procedure on page 5-2 for the new node.

Step 6 Physically connect the fibers between the point-to-point node and the new node. 

Step 7 On the new node, create a 1+1 protection group for the OC-N cards that will connect to the point-to-point 
node. See the “DLP-A73 Create a 1+1 Protection Group” task on page 4-29 for instructions.

Step 8 Complete the “DLP-A253 Provision SONET DCC Terminations” task on page 5-5 for the working 
OC-N cards in the new node that will connect to the linear ADM network. Make sure to set the Port State 
in the Create SDCC Termination dialog box to IS. 

Note DCC failure alarms appear until you create DCC terminations in the point-to-point node during 
Step 9.

Step 9 Display the point-to-point node that will connect to the new node in CTC node view.

Step 10 Ensure that the point-to-point node has OC-N cards installed that can connect to the new node. 

Step 11 Create a 1+1 protection group for the OC-N cards that will connect to the new node. See the “DLP-A73 
Create a 1+1 Protection Group” task on page 4-29 for instructions. 

Purpose This procedure upgrades a point-to-point configuration (two nodes) to a 
linear add/drop multiplexer (ADM) configuration (3 or more nodes).

Tools/Equipment None

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite

Security Level Provisioning or higher
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NTP-A154 Convert a Point-to-Point to a Linear ADM
Step 12 Create DCC terminations on the working OC-N card that will connect to the new node. See the 
“DLP-A253 Provision SONET DCC Terminations” task on page 5-5. In the Create SDCC Termination 
dialog box, set the port state to IS. 

Step 13 Display the new node in node view.

Step 14 Complete the “NTP-A28 Set Up Timing” task on page 4-21 for the new node. If the new node is using 
line timing, make the working OC-N card the timing source. 

Step 15 Display the network view to verify that the newly created linear ADM configuration is correct. Two 
green span lines should appear between each linear node.

Step 16 Click the Alarms tab. Verify that no unexpected alarms are displayed.

Step 17 Repeat the procedure to add an additional node to the linear ADM.

Stop. You have completed this procedure.

DLP-A298 Check the Network for Alarms and Conditions

Step 1 From the View menu, choose Go to Network View. Verify that all affected spans on the network map 
are green.

Step 2 Verify that the affected spans do not have active switches on the network map. Span ring switches are 
graphically displayed on the span with the letters “L” for lockout ring, “F” for Force ring, “M” for 
Manual ring, and “E” for Exercise ring. 

Step 3 A second verification method can be performed from the Conditions tab. Click Retrieve Conditions and 
verify that no switches are active. Make sure the Filter button is not selected.

Step 4 Click the Alarms tab. Verify that no critical or major alarms are present, nor any facility alarms, such as 
LOS, LOF, AIS-L, AIS-P, SF, and SD. Make sure the Filter button is not selected.

If trouble is indicated (for example, a major alarm exists), resolve the problem before proceeding. See 
Chapter 7, “Manage Alarms,” or, if necessary, refer to the Cisco ONS 15454 Troubleshooting Guide.

Step 5 Return to your originating procedure (NTP).

Purpose This task verifies that no alarms or conditions exist on the network.

Tools/Equipment None

Prerequisite Procedures DLP-A60 Log into CTC, page 3-23

Required/As Needed As needed

Onsite/Remote Remote

Security Level Retrieve or higher
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NTP-A155 Convert a Point-to-Point or a Linear ADM to a 
Two-Fiber BLSR

Caution This procedure is service affecting.

Note Optical transmit and receive levels should be in their acceptable range as shown in the specifications 
section for each card in the Cisco ONS 15454 Reference Manual.

Step 1 Log into one of the nodes that you want to convert from a point-to-point or ADM to a BLSR. See the 
“DLP-A60 Log into CTC” task on page 3-23 for instructions. If you are already logged in, go to Step 2.

Step 2 Complete the “DLP-A298 Check the Network for Alarms and Conditions” task on page 13-3 for 
instructions.

Step 3 Right-click a span adjacent to the node you are logged into.

Step 4 From the shortcut menu, click Circuits. The Circuits on Span window appears.

Step 5 Verify that the total number of active STS circuits does not exceed 50 percent of the span bandwidth. In 
the Circuits column there is a block titled “Unused.” This number should exceed 50 percent of the span 
bandwidth.

Note If the span is an OC-48, no more than 24 STSs can be provisioned on the span. If the span is an 
OC-192, no more than 96 STSs can be provisioned on the span. If the span is an OC-12, no more 
than 6 STSs can be provisioned on the span.

Caution If the first half of the capacity is exceeded, this procedure cannot be completed. Bandwidth must be 50 
percent unassigned to convert to BLSR. Refer to local procedures for relocating circuits if these 
requirements are not met.

Step 6 Repeat Steps 3 through 5 for each node in the point-to-point or linear ADM that you will convert to 
BLSR. If all nodes comply with Step 5, proceed to Step 7.

Step 7 Complete the “DLP-A189 Verify that a 1+1 Working Slot is Active” task on page 13-6 for every 1+1 
protection group that supports a span in the point-to-point or linear ADM network. 

Step 8 Complete the “DLP-A155 Delete a Protection Group” task on page 10-18 at each node that supports the 
point-to-point or linear ADM span.

Purpose This procedure upgrades a point-to-point configuration (two nodes) or a 
linear ADM configuration (3 or more nodes) to a two-fiber bidirectional 
line switched ring (BLSR).

Tools/Equipment None

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite

Security Level Provisioning or higher
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Step 9 Complete the “DLP-A214 Change the Service State for a Port” task on page 5-6 to put the protect ports 
out of service at each node that supports the point-to-point or linear ADM span.

Step 10 (Linear ADM only) Physically remove the protect fibers from all nodes in the linear ADM; for example, 
the fiber running from Node 2/Slot 13 to Node 3/Slot 13 (as shown in Figure 13-1) can be removed .

Figure 13-1 Linear ADM to BLSR Conversion

Step 11 Create the ring by connecting the protect fiber from one end node to the protect port on the other end 
node. For example, the fiber between Node 1/Slot 5 and Node 2/Slot 5 (as shown in Figure 13-1) can be 
rerouted to connect Node 1/Slot 5 to Node 3/Slot 13.

Note If you need to physically remove any OC-N cards, do so now. In this example, cards in 
Node 2/Slots 5 and 13 can be removed. See the “NTP-A116 Remove and Replace a Card” 
procedure on page 2-21.

Step 12 From the network view, click the Circuits tabs and complete the “DLP-A139 Export CTC Data” task on 
page 7-4 to save the circuit data to a file on your hard drive.

Step 13 Complete the “DLP-A253 Provision SONET DCC Terminations” task on page 5-5 at the end nodes; 
provision the slot in each node that is not already in the SDCC Terminations list (in the Figure 13-1 
example, Port 1 of Node 1/Slot 5 and Port 1 of Node 3/Slot 13).

Step 14 For circuits provisioned on an STS that is now part of the protection bandwidth (STSs 7 to 12 for an 
OC-12 BLSR, STSs 25 to 48 for an OC-48 BLSR, and STSs 97 to 192 for an OC-192 BLSR), delete and 
recreate each circuit:

Note Deleting circuits is service affecting.

a. Complete the “NTP-A152 Delete Circuits” procedure on page 9-16 for one circuit.

b. Create the circuit on STSs 1 to 6 for an OC-12 BLSR, 1 to 24 for an OC-48 BLSR, or 1 to 96 for an 
OC-192 BLSR on the fiber that served as the protect fiber in the linear ADM. See the “NTP-A189 
Create a Manually Routed Optical Circuit” procedure on page 6-47 for instructions. 
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c. Repeat Steps a and b for each circuit residing on a BLSR protect STS.

Step 15 Complete the “NTP-A126 Create a BLSR” task on page 5-18 to put the nodes into a BLSR.

Stop. You have completed this procedure.

DLP-A189 Verify that a 1+1 Working Slot is Active

Step 1 In the node view, click the Maintenance > Protection tabs.

Step 2 In the Selected Group pane, verify that the working slot/port is shown as Working/Active. If so, this task 
is complete.

Step 3 If the working slot says Working/Standby, perform a Manual switch on the working slot:

a. In the Selected Group pane, choose the Protect/Active slot.

a. In the Switch Commands field, choose Manual.

b. Click Yes in the confirmation dialog box.

Step 4 Verify that the working slot is carrying traffic (Working/Active). 

Note If the slot is not active, look for conditions or alarms that might be preventing the card from 
carrying working traffic. Refer to the Cisco ONS 15454 Troubleshooting Guide.

Step 5 When the working slot is carrying traffic, clear the Manual switch:

a. In the Switch Commands field, choose Clear.

b. Click Yes in the confirmation dialog box.

Step 6 Verify that the working slot does not revert to Standby, which might indicate a problem on the working 
span.

Step 7 Return to your originating procedure (NTP).

Purpose This task verifies that a working slot in a 1+1 protection scheme is active 
(and that the protect slot is in standby).

Tools/Equipment None

Prerequisite Procedures DLP-A60 Log into CTC, page 3-23

Required/As Needed As needed

Onsite/Remote Both

Security Level Maintenance or higher
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NTP-A156 Convert a Point-to-Point or Linear ADM to a Path 
Protection Configuration

Caution This procedure is service affecting. All circuits are deleted and reprovisioned.

Step 1 Log into a node on the point-to-point or linear ADM. See the “DLP-A60 Log into CTC” task on 
page 3-23. If you are already logged in, continue with Step 2.

Step 2 Complete the “DLP-A298 Check the Network for Alarms and Conditions” task on page 13-3 for 
instructions.

Step 3 Complete the “DLP-A189 Verify that a 1+1 Working Slot is Active” task on page 13-6 for each node.

Step 4 Complete the “DLP-A155 Delete a Protection Group” task on page 10-18 for each 1+1 protection group 
that supports the point-to-point or linear ADM span.

Step 5 Complete the “DLP-A253 Provision SONET DCC Terminations” task on page 5-5 at the protect cards 
in all nodes.

Step 6 Complete the “NTP-A152 Delete Circuits” procedure on page 9-16 and the “NTP-A188 Create an 
Automatically Routed Optical Circuit” procedure on page 6-43 to delete and recreate the circuits one at 
a time.

Note Deleting circuits is service affecting.

Stop. You have completed this procedure.

Purpose This procedure upgrades a point-to-point system to a path protection 
configuration.

Tools/Equipment None

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite

Security Level Provisioning or higher
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NTP-A210 Convert a Path Protection Configuration to a 
Two-Fiber BLSR

Caution This procedure is service affecting. All circuits on the ring are deleted and reprovisioned.

Caution Read through this procedure completely before beginning the conversion.

Note Prior to beginning this procedure, you should have a unique ring ID number to identify the new BLSR 
and a unique node ID number for each node on the ring.

Note Prior to beginning this procedure, optical transmit and receive levels should be in their acceptable range 
as shown in the specifications section for each card in the Cisco ONS 15454 Reference Manual.

Step 1 Log into an ONS 15454 on the network where you will begin the ring conversion. See the “DLP-A60 
Log into CTC” task on page 3-23. If you are already logged in, continue with Step 2.

Step 2 Complete the “DLP-A298 Check the Network for Alarms and Conditions” task on page 13-3 for 
instructions.

Step 3 Click View > Go to Network View.

Step 4 Right-click a span adjacent to the node you are logged into.

Step 5 From the shortcut menu, click Circuits. The Circuits on Span window appears.

Step 6 Verify that the total number of active STS circuits does not exceed 50 percent of the span bandwidth. In 
the Circuits column there is a block titled “Unused.” This number should exceed 50 percent of the span 
bandwidth.

Note If the span is an OC-48, no more than 24 STSs can be provisioned on the span. If the span is an 
OC-192, no more than 96 STSs can be provisioned on the span. If the span is an OC-12, no more 
than 6 STSs can be provisioned on the span.

Purpose This procedure converts a path protection configuration to a two-fiber 
BLSR.

Tools/Equipment None

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Both

Security Level Provisioning or higher
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Caution If the first half of the capacity is exceeded, this procedure cannot be completed. Bandwidth must be 50 
percent unassigned to convert to BLSR. Refer to local procedures for relocating circuits if these 
requirements are not met.

Step 7 Repeat Steps 1 through 6 for each node in the path protection configuration that you will convert to 
BLSR. If all nodes comply with 
Step 6, proceed to Step 8.

Step 8 Save all circuit information:

a. In network view, click the Provisioning > Circuits tabs.

b. Record the circuit information using one of the following tasks:

– From the File menu, click Print to print the circuits table.

– From the File menu, click Export and choose the data format: HTML, CSV (comma separated 
values), or TSV (tab separated values). Click OK and save the file in a temporary directory.

See the “NTP-A195 Document Existing Provisioning” procedure on page 7-2 for more 
information.

Step 9 Delete the circuits:

Note This method uses the network view. To delete circuits one at a time from each node, see the 
“NTP-A152 Delete Circuits” procedure on page 9-16.

a. From network view, click the Circuits tab. All circuits on the ring appear. 

b. With the Shift key pressed, click each circuit in the display. Each line in the display turns dark blue 
as it is selected. 

c. After all circuits have been selected, click Delete. Allow several minutes for processing; the actual 
length of time depends on the number of circuits in the network.

Step 10 Complete the “NTP-A126 Create a BLSR” procedure on page 5-18 to create the BLSR.

Step 11 Complete the “NTP-A175 Two-Fiber BLSR Acceptance Test” procedure on page 5-20.

Step 12 To recreate the circuits, see Chapter 6, “Create Circuits and VT Tunnels” and choose the applicable 
procedure for the circuit type you want to enter.

Stop. You have completed this procedure.
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NTP-A211 Convert a Two-Fiber BLSR to a Four-Fiber BLSR

Note Two-fiber OC-48 or OC-192 BLSRs can be converted to four-fiber BLSRs. To convert, you install two 
additional OC-48 or OC-192 cards at each two-fiber BLSR node, then log into CTC and convert the 
BLSR from two-fiber to four-fiber. The fibers that were divided into working and protect bandwidths for 
the two-fiber BLSR are now fully allocated for working BLSR traffic. A span upgrade can be performed 
prior to the two-fiber to four-fiber BLSR conversion.

Note Optical transmit and receive levels should be in their acceptable range as shown in the specifications 
section for each card in the Cisco ONS 15454 Reference Manual.

Step 1 Complete the “DLP-A60 Log into CTC” task on page 3-23 to log into one of the two-fiber nodes that 
you want to convert. 

Step 2 Check the BLSR for outstanding alarms and conditions. See the “DLP-A298 Check the Network for 
Alarms and Conditions” task on page 13-3 for instructions.

Step 3 Install two OC-48 or OC-192 cards at each BLSR node. You must install the same OC-N card rate as the 
two-fiber BLSR. See Chapter 2, “Install Cards and Fiber-Optic Cable,” for installation procedures.

Step 4 Connect the fiber to the new cards. Use the same east-west connection scheme that was used to create 
the two-fiber connections.

Step 5 Complete the “DLP-A214 Change the Service State for a Port” procedure on page 5-6 to enable (put in 
service) the ports for each new OC-N card.

Step 6 Test the new fiber connections using procedures standard for your site. 

Step 7 Convert the BLSR:

a. Display the network view and click the Provisioning > BLSR tabs.

b. Choose the two-fiber BLSR you want to convert then click the Upgrade to 4 Fiber button.

c. In the Upgrade BLSR dialog box, set the amount of time that will pass before the traffic reverts to 
the original working path after the condition that caused the switch has been resolved. The default 
is 5 minutes. 

d. Click Next.

e. Assign the east and west protection ports:

• West Protect—Select the west BLSR port that will connect to the west protect fiber from the 
pull-down menu.

Purpose This procedure upgrades a two-fiber BLSR to a four-fiber BLSR. The 
conversion will be easier if the same east and west configuration is used 
on all nodes being upgraded.

Tools/Equipment None

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite

Security Level Provisioning or higher
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• East Protect—Select the east BLSR port that will connect to the east protect fiber from the 
drop-down menu.

f. Click Finish.

Step 8 Click the Alarms tab. Make sure the Filter button is not selected. Verify that no critical or major alarms 
are present, nor any facility alarms, such as LOS, LOF, AIS-L, SF, and SD. If an alarm is present, resolve 
the problem before proceeding to the next step. Refer to the Cisco ONS 15454 Troubleshooting Guide 
for more information about alarms.

Step 9 Complete the “NTP-A176 Four-Fiber BLSR Acceptance Test” procedure on page 5-26.

Stop. You have completed this procedure.

NTP-A159 Modify a BLSR

Step 1 Log into a node in the BLSR you want to modify. See the “DLP-A60 Log into CTC” task on page 3-23 
for instructions. If you are already logged in, continue with Step 2.

Step 2 Check the BLSR for outstanding alarms and conditions. See the “DLP-A298 Check the Network for 
Alarms and Conditions” task on page 13-3 for instructions.

Note Some or all of the following alarms display during BLSR setup: E-W MISMATCH, RING 
MISMATCH, APSCIMP, APSDFLTK, and BLSROSYNC. The alarms clear after you configure 
all the nodes in the BLSR. For definitions of these alarms, see the Cisco ONS 15454 
Troubleshooting Guide.

Step 3 To change the BLSR ring ID or the ring or span reversion times, complete the following steps. If you 
want to change a node ID, go to Step 4.

a. In network view, click the Provisioning > BLSR tabs.

b. Click the BLSR you want to modify and click Edit.

c. In the BLSR window, change any of the following:

– Ring ID—If needed, change the BLSR ring ID (a number between 0 and 9999). Do not choose 
a number that is already assigned to another BLSR.

– Reversion time—If needed, change the amount of time that will pass before the traffic reverts 
to the original working path after a ring switch. 

– Span Reversion—(Four-fiber BLSRs only) If needed, change the amount of time that will pass 
before the traffic reverts to the original working path after a span switch.

Purpose Use this procedure to change a BLSR ring ID, node ID, or ring and span 
reversion times.

Tools/Equipment None

Prerequisite Procedures NTP-A126 Create a BLSR, page 5-18

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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d. Click Apply. 

If you changed the ring ID, the BLSR window closes automatically. If you only changed a reversion time, 
close the window by choosing Close from the File menu.

Step 4 To change a BLSR node ID, complete the following steps; otherwise, proceed to Step 5.

a. On the network map, double-click the node with the node ID you want to change.

b. Click the Provisioning > BLSR tabs.

c. Choose a Node ID number. Do not choose a number already assigned to another node in the same 
BLSR.

d. Click Apply.

Step 5 In network view, verify the following:

• A green span line appears between all BLSR nodes.

• All E-W MISMATCH, RING MISMATCH, APSCIMP, DFLTK, BLSROSYNC and Node ID 
Mismatch alarms are cleared.

Note For definitions of these alarms, see the Cisco ONS 15454 Troubleshooting Guide.

Stop. You have completed this procedure.

DLP-A301 Initiate a BLSR Manual Ring Switch

Caution Traffic is not protected during a manual ring protection switch.

Step 1 Display the network view. 

Step 2 Click the Provisioning > BLSR tabs.

Step 3 Choose the BLSR and click Edit. 

Tip To move an icon to a new location, for example, to see BLSR channel (port) information more clearly, 
click an icon and drag and drop it in a new location.

Step 4 Right-click any BLSR node channel (port) and choose Set West Protection Operation (if you chose a 
west channel) or Set East Protection Operation (if you chose an east channel).

Purpose Use this task to perform a BLSR Manual ring switch.

Tools/Equipment None

Prerequisite Procedures DLP-A60 Log into CTC, page 3-23

Required/As Needed As needed

Onsite/Remote Onsite

Security Level Provisioning or higher
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Note For two-fiber BLSRs, the squares on the node icons represent the BLSR working and protect 
channels. You can right-click either channel. For four-fiber BLSRs, the squares represent ports. 
Right-click either working port.

Step 5 In the Set West Protection Operation dialog box or the Set East Protection Operation dialog box, choose 
MANUAL RING from the drop-down menu. Click OK.

Step 6 Click Yes in the two Confirm BLSR Operation dialog boxes.

Step 7 Verify that the channel (port) displays the letter “M” for Manual ring. Also verify that the span lines 
between the nodes where the Manual switch was invoked turn purple, and that the span lines between all 
other nodes turn green on the network view map. This confirms the Manual switch.

Step 8 From the File menu, choose Close.

Step 9 Return to your originating procedure (NTP).

DLP-A241 Clear a BLSR Manual Ring Switch

Caution Traffic is not protected during a Manual ring switch.

Step 1 Display the network view. 

Step 2 Click the Provisioning > BLSR tabs.

Step 3 Choose the BLSR and click Edit. 

Tip To move an icon to a new location, for example, to see BLSR channel (port) information more clearly, 
click an icon on the Edit BLSR network graphic and while pressing Ctrl, drag the icon to a new location.

Step 4 Right-click the BLSR node channel (port) where the Manual ring switch was applied and choose 
Set West Protection Operation or Set East Protection Operation, as applicable. 

Step 5 In the dialog box, choose CLEAR from the drop-down menu. Click OK.

Step 6 Click Yes on the Confirm BLSR Operation dialog box. The letter “M” is removed from the channel (port) 
and the span turns green on the network view map.

Step 7 From the File menu, choose Close.

Step 8 Return to your originating procedure (NTP).

Purpose Use this task to clear a Manual ring switch.

Tools/Equipment None

Prerequisite Procedures DLP-A60 Log into CTC, page 3-23

Required/As Needed As needed

Onsite/Remote Onsite

Security Level Provisioning or higher
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