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C H A P T E R 1
Get Started with Cisco Optical Network Planner

• Cisco Optical Network Planner Overview, on page 1
• Supported Platforms, on page 2
• Supported Topologies , on page 2
• Supported Protection Schemes , on page 3
• Supported Services, on page 4
• Supported DWDM Channel Interfaces, on page 5
• Supported Fiber Types, on page 5
• Register New User, on page 5
• Log in to Cisco ONP Web Interface, on page 6
• Cisco ONP Home Page, on page 6
• Change Password , on page 6
• Reset Your Password, on page 7
• Sign Out from Cisco ONP, on page 7
• Cisco Secure Development Lifecycle Compliance, on page 8

Cisco Optical Network Planner Overview
Cisco Optical Network Planner (Cisco ONP) is a tool to model and test Optical Transport Networks (OTN)
and Dense Wavelength Division Multiplexing (DWDM) optical networks by using a graphical environment.
The primary purpose of Cisco ONP is to design and validate networks of NCS 1004, NCS 2000, and NCS
4000 series. Using the Cisco ONP tool, you create multiple instances of a network, modify different parameters
at each instance, and compare. Cisco ONP generates a rack view of all the sites that are deployed in the
network, shows the differences between the instances, and provides a complete Bill of Materials (BoM) for
the network.

Cisco ONP models the network, generates the BoM, and provides detailed information about the network,
such as Cabling report, Optical report, and Traffic matrix.

This chapter describes the features of Cisco ONP, protection scenarios, topology and service support, CSDL
(Cisco Secure Development Lifecycle) compliance, and the setting up of the graphical display.

For more information about Cisco ONP, see the data sheet.

Cisco Optical Network Planner Configuration Guide, Release 4.2
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Supported Platforms
Cisco ONP supports the following platforms:

Table 1: Supported Platforms and Releases

Recommended and Supported ReleasesPlatforms

7.0.1NCS 1004

11.0.0, 11.1.0, 12.1.0, 12.2.0NCS 2000

6.5.28NCS 4000

Supported Topologies
Cisco ONP supports the following network topologies:

• Linear—In a linear topology, the nodes are arranged in a line and are connected to two other adjacent
nodes. However, the first and last nodes are not connected.

• Mesh—In a mesh topology, each node is connected to one or more nodes. This configuration provides
maximum redundancy to the network.

• Ring—In a ring topology, each node is connected to exactly two other nodes, forming a circular
configuration. It requires at least three nodes to form a ring.

Cisco Optical Network Planner Configuration Guide, Release 4.2
2

Get Started with Cisco Optical Network Planner
Supported Platforms



Supported Protection Schemes
Table 2: Feature History

Feature DescriptionRelease InformationFeature Name

The following protection schemes
are supported:

• 1+R: For each service, Cisco
ONP automatically finds one
working path. You can define
the restoration path.

• 1+1+R: For each service,
Cisco ONP finds one working
path, and one protected path.
You can define the restoration
path.

• 1+1+R+R: For each service,
Cisco ONP finds one working
path and one protected path.
You can define the restoration
paths.

Cisco ONP Release 4.1Protection Types Supported

Cisco ONP supports the following protection schemes:

Figure 1: Protection Schemes

• Unprotected—In unprotected mode, the tool routes the service on the shortest path.

• 1+1—Two client signals are transmitted to separate line cards or transponder cards instead of using
Y-cable to split one client signal into two line cards or transponder cards. In client 1+1 protection, the
failure and switchover are controlled by the client system. The following figure shows 1+1 protection.

Cisco Optical Network Planner Configuration Guide, Release 4.2
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Figure 2: 1+1 Protection

• 1+R—Supported on SSON network. For each service, Cisco ONP automatically finds one working path.
You can define the restoration path.

• 1+1+R—Supported on SSON network. For each service, Cisco ONP finds one working path, and one
protected path. You can define the restoration path.

• 1+1+R+R—Supported on SSON network. For each service, Cisco ONP finds one working path and one
protected path. You can define the restoration paths.

• S+NS—Supported on non-SSON network. Cisco ONP uses the shortest path for the working service,
and the next shortest path for protection. The paths are span-disjointed but not node disjointed.

• Unprotected Disjoint—Supported on non-SSON network. Cisco ONP provides two cards following
two completely disjoint paths in the network to reach their destination.

Supported Services
Cisco ONP supports the following OTN demands:

• ODU-1,ODU-2,ODU-3,ODU-4

• GE – Gigabit Ethernet

• 10GE – 10-Gigabit Ethernet

• 100GE –100-Gigabit Ethernet

• STS-3

• STS-12

• STS-48

• STS-192

• VC-4-4

Cisco Optical Network Planner Configuration Guide, Release 4.2
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• VC-4-16

• VC-4-64

• STM-64

Supported DWDM Channel Interfaces
See Supported Cards and Pluggables, on page 149 and Supported Optical Sources, on page 161 for the DWDM
channel interfaces supported by Cisco ONP.

Supported Fiber Types
Cisco ONP supports the following fiber types:

• G652-SMF

• G652-SMF-28E

• TWR

• MC

• TWPlus

• TWMinus

• TWClassic

• FL

• LS

• TL

• G652-SMF

• ELEAF

• True Wave

Register New User
Use this task to register yourself as a user.

Step 1 In the browser URL field, enter the IP address or hostname of the Cisco ONP instance.
Step 2 Click Sign Up in the Login page.
Step 3 Enter the Username, Email, and Password, and click Submit.

ClickGenerate if you want a system-generated password. Copy and paste the system-generated password in the Password
field.

Cisco Optical Network Planner Configuration Guide, Release 4.2
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Step 4 Click Ok in the Success dialog box.

Log in to Cisco ONP Web Interface
Use this task to log into the Cisco ONP web interface.

Step 1 In the browser URL field, enter the IP address or hostname of the Cisco ONP instance.

If you are a new user, sign up. See Register New User, on page 5, for more information.

If Google Chrome browser blocks your access to Cisco ONP due to self-signed certificate security, type
thisisunsafe to proceed to the login page.

Note

Step 2 Enter the username and password in the Username and Password text boxes.
Step 3 Click Login.

Cisco ONP Home Page
After your login, Cisco ONP displays its home page. The home page comprises the following elements:

• Menu bar―Includes various menus such as File, Network, Export, Import, Manage, Logs, Job Monitor,
Control Panel, and Help. See Menu Bar, on page 137.

• Last Login―Shows the last date and time when the user logged in to the Cisco ONP tool.

• Last Login IP―Shows the IP address of the client through which the user logged into the Cisco ONP
tool previously.

• User name―Shows the name of the user, who has currently logged in to the Cisco ONP tool, for example:
ADMIN.

• Reports tabs―Shows various reports under each tab. Report availability depends on whether a network
is analyzed or not. Reports are also available in site properties after analyzing the network.

• Network tree―Displays the network name, and network elements, such as Sites, Fibers,Waves orMedia
Channels, SRLGs, and Subnet. See Network Tree, on page 143.

Change Password
The procedure to change your existing password is:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Cisco Optical Network Planner Configuration Guide, Release 4.2
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Step 1 Click the login icon in the top-right corner of the home page.
Step 2 Click Change Password to change the existing password.
Step 3 In the Change Password dialog box, enter the Old Password, New Password, Repeat New Password.
Step 4 Click Update.

Reset Your Password
The following procedure shows how to reset the password.

Step 1 In the browser URL field, enter the IP address or hostname of the Cisco ONP instance.
Step 2 Click Forgot Password ? in the Cisco ONP login page. The Forgot Password page appears.
Step 3 Enter the registered email ID in the Forgot Password page.
Step 4 Click Continue.

A verification code is generated and sent to the registered email ID.

Step 5 Enter the verification code, new password and confirm password.
Step 6 Click Continue.

Sign Out from Cisco ONP
The procedure to sign out of Cisco ONP is:

Step 1 Click the login icon in the top-right corner of the home page.
Step 2 Click Sign Out to log out of the Cisco ONP tool.

Cisco Optical Network Planner Configuration Guide, Release 4.2
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Cisco Secure Development Lifecycle Compliance
Table 3: Feature History

Feature DescriptionRelease InformationFeature Name

The following CSDL compliance
enhancements are supported:

• Displays the last login IP
address of the client.

• Allows you to set a passphrase
for encryption of credentials
during the installation of LNI
application and database.

Cisco ONP Release 4.1CSDL Compliance Enhancements

The following Cisco Secure Development Lifecycle (CSDL) compliancies are implemented:

• Check for the existence of new passphrases against a dictionary.

• Display of the last login date and time of the user in the user interface of the Cisco ONP tool.

• Display of the last login IP: The IP address of the client through which the user logged into the server,
previously.

• Warning the users through pop-up messages about the impending passphrase expiration.

• Option to allow an admin user or any user with CONFIGURATION_MANAGEMENT permission to
set the lifetime of a passphrase and the grace period to change the passphrase through the system
configuration tab.

• Prompt for user to change the passphrase through the passphrase change dialog box, when the admin
user logs in for the first time.

• Option to allow the user to set a passphrase with a minimum of eight characters and a maximum of 127
characters as the length.

• The passphrase must include at least one lowercase alphabet, one uppercase alphabet, one number, and
one special character.

• Option to allow the user to set a passphrase or key for encryption of credentials during the installation
of Live Network Import (LNI) application. If not specified Cisco ONP uses the default key.

• Option to allow the user to set a passphrase with a minimum of eight characters and a maximum of 64
characters as the length, during the installation of Cisco ONP and LNI database.

• LNI application provides the details of all the ports used. See Ports Used in LNI, on page 29.

• Option to allow the user to generate a password using Generate Password option.

• Display of the strength of the password set by the user.

Cisco Optical Network Planner Configuration Guide, Release 4.2
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C H A P T E R 2
Manage Users and Roles

• User Roles in Cisco ONP, on page 9
• Grant Access to a New User, on page 10
• Remove Access to a User, on page 11
• Delete a User, on page 11
• Create a New User Group, on page 11
• Assign a User to a User Group, on page 12
• Set Password Expiration for Individual User, on page 13
• Set Password Expiration for All Users, on page 13
• Lock and Unlock an Individual User Account, on page 14
• Expire the Password Set by an Individual User, on page 14
• Create a New Role, on page 14
• Assign a Role to a User Group, on page 15
• Manage Password Through Dictionary, on page 15
• Retrieve System Logs , on page 16

User Roles in Cisco ONP
Initially, the administrator performs access control management tasks, like activating users after user sign-up,
creating user groups, roles, and assigning roles and users to user groups. The admin or user with admin access
grants access to the newly created user by activating the user. After the admin grants access, the new user will
be notified by email (sent to the email address registered while signing up). It is only then that the new user
is able to log in. By default, the following user roles are available in Cisco ONP.

1. Admin: The Admin user can create new user groups and assign user to user groups. Users are categorized
into groups. There are certain predefined user groups in Cisco ONP. You cannot edit or delete these user
groups. Admin can assign a group with a particular role. The role describes the actions that a particular
user group can perform.

2. Designer: The Designer user can design a network. There are two ways to design a network.

• Manual Design

• Import Design

The designer user can create a network topology of any type (linear, ring, mesh) with Traffic, OLA,
ROADM, and Passthrough sites, and assign the fibers with suitable spans between those sites. The designer

Cisco Optical Network Planner Configuration Guide, Release 4.2
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can only design the network and cannot analyze the network. The designer can view the reports, when
any user shares the analyzed network.

3. Planner: The Planner user can design and analyze a network. After the Sites, Fiber spans, and Service
demands are created, analyze the network to determine the network performance. Cisco ONP automatically
optimizes the design and summarizes the optical transmission performance. In the analyzed state, all
reports are available and updated. In the analyzed state, no aspect of the network design can be changed.

4. Reader: The Reader user can view users, user groups, roles, and permission. The Reader can also view
the network topology, layout, connections, and BOM. By default, a user is assigned in the
READ_ONLY_GROUP with a READER_ROLE.

You can also create new roles. See Create a New Role, on page 14.

Under Control Panel > Roles and Control Panel > Permissions, you can view the permissions applicable
for each role and the actions that can be performed for each permission.

Grant Access to a New User
All users with Admin role receive an email notification about new user registration.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 You can change the state of a user from INACTIVE to ACTIVE by using either of two ways:

a. From the State field, click INACTIVE in the respective user row.

b. Select the user row and click Update.

• In the Update User dialog box, select the Group and State from the respective drop-down lists.

• Click Save.

Step 3 Click OK in the Success dialog box.

• After the Admin grants access, the new user gets notified by email (sent to the email address registered
while signing up). It is only then that the new user will be able to log in.

• The admin assigns a newly created user with a Role and Group that determines what actions the user
can perform.

Note

Cisco Optical Network Planner Configuration Guide, Release 4.2
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Remove Access to a User
Use this task to remove Cisco ONP access to a user.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control panel.

The Access Control Management page appears.

Step 2 You can change the state of a user from ACTIVE to INACTIVE by using either of two ways:

a. From the State field, click ACTIVE in the respective user row.

b. Select the user row and click Update.

• In the Update User dialog box, select the Group and State from the respective drop-down lists.

• Click Save.

Step 3 Click OK in the Success dialog box.

Delete a User
Use this task to delete a user.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control panel.

The Access Control Management page appears.

Step 2 Select the user to be deleted under the USERS tab and click Delete.
Step 3 Click Yes in the Warning dialog box.

The message User deleted successfully appears. You can delete another user only after this message appears.

Create a New User Group
Use this task to create a new user group.

Cisco Optical Network Planner Configuration Guide, Release 4.2
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Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USER GROUPS tab.
Step 3 Click Create.
Step 4 In the Create Group dialog box, enter the Group Name.
Step 5 Choose the appropriate role from the Role drop-down list. The available default roles are:

• ADMIN

• PLANNER

• DESIGNER

• READER

The Role drop-down list may also have user-defined roles that are listed under it.

Step 6 Click Save to save the created user group.
Step 7 Click OK in the Success dialog box.

Assign a User to a User Group
Use this task to assign a user to a user group.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control panel.

The Access Control Management page appears.

Step 2 Under the USERS tab, select the user who is to be assigned to the new group.
Step 3 Click Update.
Step 4 In the Update User dialog box, perform the following:

• Select the appropriate group from the Group drop-down list.

• Select Active or Inactive from the State drop-down list, to activate or inactivate the user in the group, respectively.

• Click Save.

Step 5 Click OK in the Success dialog box.

Cisco Optical Network Planner Configuration Guide, Release 4.2
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a. A user can belong to only one group.

b. Only one role can be assigned to any group.

c. All the users of a group have the same role as that of the group.

d. By default, a new user is assigned to the Read_Only_Group.

Note

Set Password Expiration for Individual User
Use this task to set the expiration of the password set by the user.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 with Admin or Configuration_Management permission.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Select the user under the USERS tab.
Step 3 Click Update.
Step 4 In the Update User dialog box, click the PASSWORD EXPIRY tab.
Step 5 Enter values for the Lifetime, Warning and Grace fields.
Step 6 Click Save.

The password expiry settings like lifetime, warning and grace time, take effect after the existing password
is changed by the user.

Note

Step 7 Click OK in the Success dialog box.

Set Password Expiration for All Users
Use this task to set the expiration of the password for all users.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 with Admin or Configuration_Management permission.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the System Configuration tab.
Step 3 Enter values for the Lifetime, Warning and Grace fields.

Cisco Optical Network Planner Configuration Guide, Release 4.2
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Step 4 Click Update.

The password expiry settings like lifetime, warning and grace time, take effect after the existing password
is changed by the user.

Note

Lock and Unlock an Individual User Account
Use this task to lock or unlock an individual user account.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USERS tab.
Step 3 Select the user whose account you want to lock or unlock.
Step 4 Click Lock to lock the user account, or click Unlock to unlock the locked user account.

The user of a locked account must contact the admin to unlock the user account.Note

Expire the Password Set by an Individual User
Use the following task to expire the password set by an individual user.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USERS tab.
Step 3 Select the user whose password you want to expire.
Step 4 Click Expire.

Create a New Role
Use the following task to create a new role.

Cisco Optical Network Planner Configuration Guide, Release 4.2
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Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the ROLES tab.
Step 3 Click Create.
Step 4 In the Create Role dialog box, enter the Role Name and select the Permissions for the role.

You can select more than one permission.Note

Step 5 Click Save.
Step 6 Click OK in the Success dialog box.

Assign a Role to a User Group
Use the following task to assign a new role to a user group.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the USER GROUPS tab.
Step 3 Select the user group whose role is to be updated.
Step 4 Click Update.
Step 5 In the Update Group dialog box, select the desired role from the Role drop-down list, and click Save.

Step 6 Click OK in the Success dialog box.

Manage Password Through Dictionary
If a password exists in the predefined list of passwords under the Content column, the dictionary rejects the
new password set by the user. You must have Admin or Configuration_Management permission to view and
modify the dictionary.

By default, theRejection Mode toggle button is disabled. Enable theRejection Mode toggle button to verify
the password against dictionary. This password verification check against the dictionary happens during any
one of the following events:

• New user sign-up
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• Password change

• Password reset using forgot password option

The following is the procedure to verify, whether the new password set by the user exists in the list of predefined
passwords:

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with Admin role.

Step 1 Click Control Panel.

The Access Control Management page appears.

Step 2 Click the DICTIONARY tab.
Step 3 Enter the password in the Enter Passphrase text box.
Step 4 (Optional) Enter the limit (maximum number of matching passphrases) in the Enter Limit text box.
Step 5 Click Search.

The matching passphrases get displayed.

If you have entered the limit, a number of search results matching the limit gets displayed. Otherwise, all
matching passphrases get displayed.

Note

Retrieve System Logs
The System Logs page shows at logs the events that are initiated during a specific time interval. See Logs ,
on page 140.

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as an admin or a user with User Management and Network
Management permission.

Step 1 Click Logs.
Step 2 Click Select Start Date, and choose the start date. Similarly, click Select End Date, and choose the end date.
Step 3 Click FILTER to retrieve the logs.

The following icons are available in the System Logs page:

DescriptionIcons

Exports the system logs to an Excel sheetExport as CSV

Exports the system logs as a zip fileExport Archive

Imports the zip fileImport Archive

Refreshes the system logs pageRefresh
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DescriptionIcons

Deletes the existing logsClear Logs
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C H A P T E R 3
Design and Analyze Networks

• Design a Network Using Cisco ONP, on page 19
• Create Optical Subnet for Non-SSON Networks, on page 34
• Create Optical Subnet for SSON Networks, on page 35
• Convert Non-SSON Network to SSON Network, on page 36
• Share a Network, on page 37
• Analyze the Network, on page 38
• Upgrade the Analyzed Network, on page 40
• Upgrade LNI Network, on page 41
• Upgrade the Software Release of a Network , on page 45
• Plan Mode, on page 47
• Import Optical Sources, on page 52
• Download Optical Sources, on page 52
• Delete Optical Sources, on page 53
• Layout Template , on page 53
• Layout Visualization, on page 57
• Regenerate BoM Automatically, on page 64
• Add new Pluggables, Alarm Cables and 100G Client Bandwidth Licenses to BoM, on page 64
• Export IPC Report, on page 65
• Design Networks with SVO Card, on page 66
• Associate OLA or DGE Sites with SVO Cards, on page 67
• Upload NETCONF XML Files on SVO Web Interface, on page 67
• Export NETCONF XML Files for Individual Sites, on page 68

Design a Network Using Cisco ONP
You can design a network in one of the following ways:

• Manual Design―Create a network design using a design palette.

• Import Design―Import a network design from an Excel sheet, Live Network Import or from an existing
network from CTP, or another instance of Cisco ONP.
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Manually Design a Network Using Cisco ONP
Table 4: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to perform
the following:

• Supports NCS 4K-1K-2K
multi-platforms

• Visualizes new layout for Txp
and SVO for NCS 2000 node

• Supports different OTN
service types with protection

• Edits layout for NCS 4000 and
NCS 1004 nodes

Cisco ONP Release 4.1Multi-Layer Platform (MLP)
Greenfield Design with NCS
4k-1k-2k

You can create any of the following network designs:

• Spectrum Switched Optical Network (SSON) that uses flexible spectrum allocation, where the required
minimum spectral resources are allocated adaptively based on traffic demand and network conditions

• Non-SSON network that allocates single spectrum (fixed spectrum) irrespective of the traffic demand
and network conditions

Perform the following steps to create a network in the Cisco ONP:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > New.

The Create New Network dialog box appears.

Step 2 If you want to create an SSON network, check the SSON Network check box, else leave the SSON Network check
box unchecked.

Step 3 Choose the System Release for NCS 2K from the drop-down list.

You cannot change the system releases that are available for NCS 4K and NCS 1K.

Step 4 Click Create.

You can view a map and the design palette. For more information, see Design Palette, on page 144.

Step 5 Click the Drawing Tool icon (pencil and ruler crossed).
Step 6 Add sites to the map using the drawing tool.

a) Zoom into the map to the desired level. Click any of the site icons (ROADM, OLA or Traffic(4K-1K-2K)), and
drag it to the sites on the map. Drag or click the map where a site has to be placed, when the cursor changes to the
site icon.
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SRLG is not supported in the SSON networks

Cisco ONP automatically calculates the distance based on the x and y coordinates on the map. Before
you create the design, zoom in the map to the maximum for an accurate distance, because the distance
is used to calculate signal degradation.

Note

b) Click the Fiber icon and drag it to connect from one site to another site. Continue this for all sites.

Step 7 Create services between the sites.

Cisco ONP provides only OTN service.

a) Click the Drawing Tool icon and select OTN Service (Green in color).
b) Add the service between the existing Traffic sites on the map.

Step 8 Create media channels (for SSON), or waves (for non-SSON) between the sites.
a) Click the Drawing Tool icon, and select Media channel (purple in color), or Waves (red in color).
b) Add the media channel, or waves between the existing sites on the map.

In the left pane, you can view a network tree panel with a default network name. The network elements added are
displayed in the tree panel.

Step 9 Choose File > Save As.
Step 10 Enter a network name in the Give a Network Name dialog box.
Step 11 Click Save.

Create Shared Risk Link Group
You can use the Shared Risk Link Group (SRLG) feature for routing protected services. You can create SRLGs
through the Excel import file SRLG tab or through the Cisco ONP GUI using the following procedure:

SRLG is supported only for the non-SSON network including the traffic nodes.Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the network tree panel in the left.
Step 2 Expand Fibers.
Step 3 Check the check box next to each fiber in the same SRLG.
Step 4 After all fibers are checked, right-click, and select Create SRLG.

SRLG is created with a unique name. You can rename the SRLG.
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Import Network Using Excel Sheet
Use this task to import a network into Cisco ONP, using an Excel sheet.

By default, the system release of the Excel imported network is 11.0.Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Download Import Template to download the Excel sheet template.

The template has the following mandatory tabs, and the respective fields to be filled in the Excel sheet.

DescriptionTabs

Label (name of the network), Platform (NCS2000)Network

Site Label, Type, X coordinates, Y coordinates, Pre Equip
Degree, Grooming Site, CLLI code, and Site Address

Sites

Span label, A (Source site name), Z (Destination site name),
Kms (Distance), Loss, A_Edge, Z_Edge, AZ_Loss,
ZA_Loss, AZ_Kms, and ZA_Kms.

Spans

Demand Label, A (Source), Z (Destination), Y (Tertiary
Source), B (Tertiary Destination), Type of Demand,
Quantity, and Protection.

Note: Y and B can be used with Unprotected Disjoint
Service.

Demands

Channel label, A, Z, Wavelength, Protection, and TypeChannels

SRLG Label and Spans.SRLG

Step 2 Fill the network details in the template file or edit the current network file, and save the file.
Step 3 Choose Import > Excel.
Step 4 Browse, select the saved file, and click Import.

Cisco Transport Planner Network Import Support
You can import the networks that are created and analyzed from Cisco Transport Planner (CTP) to Cisco
ONP, to avoid recreating the networks that are already created in CTP. The CTP network files are in .mpz
format. You can, release upgrade, the imported networks.
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• Network must be in design-analyzed or upgrade-analyzed mode.

• You cannot import networks which are earlier than Release11.0.

Note

Supported Hardware

• Optical source files and transponders

See Supported Optical Sources, on page 161, and Supported Cards and Pluggables, on page 149.

• Contentionless, colorless, and colored point-to-point demands

• Flex network

• Gain Equalizer

The Gain Equalizer node changes as a ROADM node when you unlock the site
after the release upgrade.

Note

• ROADM-SMR-9 and SMR-20

• All flex supported amplifiers, controller cards, and chassis types

Import MPZ Design File
Use this task to import .mpz file from CTP to Cisco ONP.

Importing of mpz networks with P-Ring and A2A demands is not supported. Hence, we recommend you to
delete these demands in CTP, reanalyze the networks in CTP and import the mpz into Cisco ONP.

Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with network creation permission.

Import the required optical source files and layout template using Manage > Optical Source and Manage >
Optical Source options. For more information, refer Manage Alien and Import Layout Template for NCS
2000 Network in to Cisco ONP Database.

Delete the parameters that are not supported by Cisco ONP from the .mpz file and then import the .mpz file
to Cisco ONP.

Step 1 Choose Import > MPZ.

The Import File (.mpz) dialog box appears.

Step 2 Browse to the .mpz file stored in your local system.
Step 3 Click Import.
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The .mpz file gets imported to Cisco ONP.

If you view a blank screen when you click waves in the network tree, refresh the browser.Note

Step 4 Choose Network > Upgrade or Network > Release Upgrade to make any changes on the imported network.

• You cannot go back to design mode on the imported mpz network.

• The wave label of imported mpz network in Cisco ONP is the service name present in the CTP properties
window.

Note

Export the CPZ File
Cisco ONP stores the network design file as .cpz file in its database. You can export the design file into your
local system.

• The .cpz file of a network in the design mode includes design file, layout template, and optical source
details.

• The .cpz file of a network in the analyze mode includes a design file, analyze file, ANS file, per side
ANS file, BOM, error messages, trace files, layout template, mpz, and report.

• For the network in upgraded mode, you can export only the last child in the parent child hierarchy.

• You can export only one network at a time.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network that you want to export, from the list of networks.

The network opens.

If you view a blank screen when you open a network, refresh the browser, or log in to Cisco ONP again.Note

Step 3 Choose Export > CPZ.

The Export .cpz file dialog box appears.

Step 4 Rename the file if required.
Step 5 Click Export.
Step 6 Save the file in your local system.

Cisco Optical Network Planner Configuration Guide, Release 4.2
24

Design and Analyze Networks
Export the CPZ File



Import CPZ File
You can import the cpz network design files that are exported from another Cisco ONP instance.

You can import only the networks that are exported from the current release.Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Import > CPZ.

The Import .cpz file dialog box appears.

Step 2 Click Choose file, and select a cpz network design file that you want to import into Cisco ONP, from your local system.
Step 3 Click Import.

If the names of the optical source and layout template files available in the Cisco ONP database and the imported network
file are the same, you are prompted to confirm whether you want to overwrite the existing file.

The error message "Network already exists in the system with another user. New network will be
created" is just an information. You do not need to perform any action. Cisco ONP automatically imports
as a new network specific to the user. There is no impact on the already existing network.

Note

Step 4 Check the Overwrite Network check box, if you want to overwrite the existing file.

If you leave the check box unchecked, Cisco ONP saves the imported network as a new network.

Step 5 Choose the optical source files and layout template that you want to replace.

If you do not choose the optical source or the layout template file, the files will not be imported.

Step 6 Click Confirm.

The imported network is saved in the Cisco ONP database.
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Live Network Import
Table 5: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to import
a live deployed network having
NCS 1004, NCS 2000, and NCS
4000 nodes into Cisco ONP, using
the LNI (Live Network Import)
import template. This feature also
allows you to view network
topology, BOM, and layout report.

Cisco ONP Release 4.1Live Network Import

The Live Network Import (LNI) feature allows you to perform a live import of network having NCS 1004,
NCS 2000, and NCS 4000 nodes into Cisco ONP. You must have Network Management role to perform the
LNI operation. After importing you can visualize the complete deployed network details in Cisco ONP. Map
shows the network topology, and you can view the node, fiber, OTN service, and media channel properties
in the Network Tree, and the Entity Editor.

Perform Live Network Import
Use this task to perform live import of a network:

Before you begin

• Perform LNI only when the network is in a stable or running state. Do not perform LNI during the
maintenance period for software upgrade.

• Configure all the mandatory parameters on the circuit.

• Make sure that the following Cisco IOS XR Software Maintenance Updates (SMUs) are loaded on the
NCS 4000 devices on top of Cisco IOS XR Release 6.5.28:

• ncs4k-6.5.28.CSCvu93045.tar

• ncs4k-sysadmin-6.5.28.CSCvt67465.tar

• ncs4k-6.5.28.CSCvv79518.tar

• Make sure that there is a provision for opening three TL1 sessions per NCS 2000 device for Live data
collection. NCS 2000 devices should not be overloaded with too many TL1 sessions.

• Make sure that the fibers are configured with the same channel numbers (Spectral Density, ex: 91.0/82.0)
on both source and destination ends.

• Check the card label set for the following NCS 2000 cards and update it if they are not aligned.

Card LabelPID

AD-16-FSNCS2K-16-AD-CCOFS

SMR20-FS-CVNCS2K-20-SMRFS
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Card LabelPID

SMR20-FSNCS2K-20-SMRFS-L

SMR9-17-FSNCS2K-9-SMR17FS

SMR9-24-FSNCS2K-9-SMR24FS

SMR9-34-FSNCS2K-9-SMR34FS

SMR9-34-FSNCS2K-9-SMR34FS-L

OPT-RAMP-COP15454-M-RAMAN-COP=

OPT-RAMP-CTP15454-M-RAMAN-CTP=

OPT-EDFA-35NCS2K-OPT-EDFA-35

• You must install Microsoft Excel in the Client Machine from where the browser is launched to open
Cisco ONP application.

• Log in to Cisco ONP Web Interface, on page 6

.

Step 1 Choose Export > Download LNI Import Template, and download the template which is in the form of an Excel
sheet.

Step 2 Fill the template with the details of all the nodes belonging to the network to be imported and save the file.

The following fields are mandatory:

• Node IP

• User Name

• Password

• Connectivity Type―TL1 for NCS 2000 nodes and NETCONF for NCS 1004 and NCS 4000 nodes

• Connectivity port―830 for NCS 4000 and NCS 2000 nodes

Enter a value in the range of 60–180 in the Connectivity Timeout field or leave the field empty.Note

Step 3 Choose Import > Live Import.
Step 4 Browse and choose the saved file.
Step 5 If you want to clean the existing LNI database of the nodes and perform a fresh import, check the Fresh Import

(Cleanup LNI Database) check box.

We recommend fresh import of the live network.Note

Leave this check box unchecked, if you want to import the details of only few of the nodes which had issues during
the previous import.

LNI import is not user-specific. When you perform a fresh import, Cisco ONP overwrites all the LNI data
that are imported by the other users.

Note
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Step 6 Click Import.
Step 7 In the Device Onboarding dialog box, click OK.

If you try to import a network of unsupported version, the device collection does not happen, and an error
message "device collection failed" appears. See Supported Hardware and Software for LNI, on page 31.

Note

Step 8 Click Job Monitor, and click Check Progress for the IMPORT_LIVE_NETWORK task, to view the status of the
LNI operation in the LNI Progress dialog box. Click Refresh to see the updated status.

After LNI is completed, the job is removed from the Job Monitor page.

Step 9 Click Logs to view the list of events that are related to the LNI operation, as logs.
Step 10 After the completion of the LNI operation, choose File > Open.

The format of the LNI imported network filename is LNI_<Date>_<Time>.

Step 11 Click the imported network name to view the network under the Map tab and its corresponding network tree in the left
panel.

The aggregated node including NCS 1004, NCS 2000, and NCS 4000 is indicated in purple color, and the aggregated
node including NCS1004 and NCS 2000 is indicated in orange color in the network tree. You can view the tag Imported
from Network in the top-right corner.
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• Even If some errors occur during the LNI operation, the LNI operation is not canceled. In such case,
when you open the imported network, a warning message is displayed.

• You can view the errors under the Elements > Messages tab.

• Device collection failure is listed under critical messages.

• The reason for failure is listed under noncritical messages.

• If both NCS and Non-NCS PIDS are present in the inventory, Cisco ONP enables the Enable NCS
option. You can edit this option during upgrade after unlocking the site, if necessary.

• Service path for the restored circuits is displayed as follows in the Cisco ONP UI:

• Primary Path: Working path before restoration

• Secondary path: Protected path

• Restoration path: Current work path after restoration

If the circuit is not in the restored state, the restoration path is not shown.Note

• SSON circuits carrying protected OTN services are merged as Client 1+1 protected Media Channel.
Due to this, you may see difference in total number of SSON circuits between the imported network
in Cisco ONP and the actual network.

• If LNI is not installed properly, you may encounter the errors such as LNI failure or LNI not able to
purge the data. In such cases, we recommend starting and stopping the LNI services in the server
where Cisco ONP and LNI are installed using the following commands:

• Stop the LNI services.
root:~/$ONP_HOME# cd LNI

root:~/$ONP_HOME/LNI# bash ciscolniinstaller.sh -o stop -t update -m offlinemode

• Start the LNI services.
root:~/$ONP_HOME/LNI# bash ciscolniinstaller.sh -o start -t update -m offlinemode

Note

Wait for a minimum of five minutes after starting the services, for the LNI services to resume before
triggering a new live network import. You can

Note

Step 12 Click the BOM tab to view the BOM details of the network.

The PIDs of prototype cards are shown as "NA" in the BOM details of the LNI network.Note

You can export the CPZ, import the CPZ, and share the imported network. You can check the properties of the network
using the Entity Editor.

Ports Used in LNI
LNI application uses the following ports. If any port is shut down due to any failure, then the service is restarted
by the Docker system.
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UsageServicePort

Registration and discovery service, which holds the information about
all microservice applications

Eureka Service8761

Receives all the incoming requests, and then delegates the requests to
internal microservices like LNI Broker

API Gateway8088

Collects metrics and operation data from the devicesCollector Service8086

Responsible for device onboarding processDevice Manager8082

Provides inventory dataInventory Service8083

South bound interface plug-ins for TL1 protocol-basedNCS 2000 devicesTL1 plug-in
Service

9975

Adapter module to transform NCS 2000 device response from collector
to Cisco ONP NCMS schema-based POJO

NCS 2K Inventory
Adapter Service

8898

Adapter module to transform NCS 4000 device response from collector
to Cisco ONP NCMS schema-based POJO

NCS 4K Inventory
Adapter Service

8899

Adapter module to transform NCS 1004 device response from collector
to Cisco ONP NCMS schema-based POJO

NCS 1K Inventory
Adapter Service

8900

South bound interface plug-ins for NETCONF based 1K/4K devicesNETCONF plug-in
Service

9976

Provides interfaces for Cisco ONP BE service to trigger live network
import

LNI Broker Service8102

Provides network topology dataTopology Service8085

Provides network circuit dataCircuit Service8090

Common adapter for Topology and Circuit servicesNETCONF
Adapter Service

8024

Aggregates inventory, topology, and circuit details under NCMS
schema-based networks

Model Aggregator
Service

8091

Common adapter for Topology and Circuit ServiceTL1 Adapter
Service

8092

Data visualization and exploration tool that is used for log and time-series
analytics, applicationmonitoring, and operational intelligence use cases

The default Edge browser onWindowsOS is not supported
for viewing the Kibana logs. Cisco recommends using
Firefox or Chrome browser for viewing the Kibana logs.

Note

Kibana5601

Keeps track of status of the Kafka cluster nodes, and also keeps track
of Kafka topics, partitions publish-subscribe messaging system that
enables inter service communication

Zookeeper2181
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UsageServicePort

Publish-subscribe messaging system that enables inter-service
communication

Kafka9092

Database to persist services dataMongo27017

Supported Hardware and Software for LNI
The following table describes the software versions and hardware requirements of the network imported
through LNI.

Table 6:

ValuesProperty

Network

SSONNetwork Type

ETSIPlatform

NCS 2000: R11.1, and R11.1.1.2

NCS 1004: XR 7.0.1

NCS 4000: XR 6.5.2.8

System Release

Site/Node

4K-1K-2K: ADD/DROP, 1K-2K;Regen,
2K:ROADM/OLA

Site Type

SMR-20, SMR-9-17FS, SMR-9-34FS, SMR-9-24FSROADM

RAMAN-CTP, RAMAN-COP, EDFA35-24,
EDFA35-35

Amplifier

DEG-5/UPG-4Degree Mesh Type

4K: NCS4016, 2K:NCS2006, 1K:NCS1004Chassis Type

4K-DC, 1K-DC, 2K-DC40Power Supply

ECU-SECU

TNCS-2, TNCS-2OController Card

82Channel Rule

NCS1K4-1.2T-K9=, NCS4K-4H-OPW-QC2Line Cards

ON and OFFEvolved Mesh

2K: Separated shelves, 4K: Single shelfNode Protection
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ValuesProperty

MPO-16LC UnitMpo16Lc

MPO16TO2MPO8CableMpo16ToMpo08

YesCascaded SMR

YesEnable NCS

NoUse Payg

Yes, NoConnection Verification

MF-6RU, MF6-10RU, or MF-1RUMF Unit

Line, Multidegree, TerminalStructure

4, 8, 12Scalable upto degree

YesPower redundancy

IPv4IP Address

Fiber

AutoOSC Frame Type

YesDCN Extension

YesENE/GNE

YesLength

YesLoss

KMMeasurement Unit

NoLength based Loss

YesRaman Amplified

G652-SMF-28EFiber Type

YesConnector Loss A

YesConnector Loss B

YesCross OSC and Parallel OSC

Media Channel

NCS1004_SP_16QAM_16QAM_300G_27%SDFEC_60GBdTraffic Type

Unprotected, and 1+RProtection

Actual PathPath
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ValuesProperty

Regen siteRegen

NoMulticarrier

YesContentionless

Restored, UnrestoredCircuit State

Service

100GE, 10GE, STM-64Service Type

1+1, Unprotected, 1+R, 1+1+R, 1+1+R+RProtection

Actual PathPath

OTU4Client Type (1K)

BHInterface Type (1K)

200G, 300GTrunk Mode (1K)

60 and 69 GBdBaud Rate (1K)

ONS-QSFP28-LR4=,
QSFP-100G-SR4-S=,ONS-QSFP-4X10-MLR=

Client Pluggable

Limitations of LNI
The LNI feature has the following limitations:

• You cannot perform multiple LNI at the same time.

• Scheduled LNI is not supported.

• LNI does not support the following:

• Non-SSON Network import

• Non-Contentionless configuration import

• Circuit import with NCS 2000 Transponder or Muxponder cards

• Chassis position in layout may not be accurate in the live imported network.

Workaround: NCS 2000, NCS 1004, and NCS 4000 chassis are placed in separate racks for a better
view of the layout. You can edit the same after network upgrade and analysis.

• If X, Y coordinates are not configured in the devices, nodes are overlapped in the Cisco ONP map.

Workaround: Configure X, Y coordinates before importing the network for a better view of the topology
in Cisco ONP map; otherwise, you can drag and drop the nodes in the Cisco ONP map and adjust the
node position after importing.
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• Scalable up to degree parameter is not imported from the real device. Cisco ONP chooses the maximum
scalable up to degree based on the number of line sides and contentionless sides present on the node.

Workaround: You can unlock node after upgrading and change the scalable up to degree. After unlocking
the site, use layout template to rearrange the layout.

• Cisco ONP imports the proto-PID, if any, present in inventory, and show as N/A PID in the Cisco ONP
BOM.

• Duplicate media channel label is not supported. If there are multiple media channels with same label
present in the network, only one media channel is imported and the rest of them are discarded.

• Fiber name, source, and destination names may not match between the first and the second import. Source
and destination site names may interchange for bidirectional fibers.

• If the regenerated demand is in restored state, the restored path is shown as working or protected path,
and the service protection is shown as 1+R in Cisco ONP. The restoration details will not be available.

• Service protection type is shown as 1+1+R or 1+1+R+R only if restoration path is available. Otherwise,
service protection type will be shown as 1+1.

• Preprovisioned cards are not listed in the Cisco ONP BOM, and they are populated after successful
upgrade and analysis of the LNI network. Make sure that the cards are equipped to retrieve the PID
details.

• Fibers may not be associated with correct optical subnet if the fibers are not configured with the same
channel number at both source and destination ends. Due to this amplifier output power may not be
within valid range. Hence, you either correct channel number at both source and destination nodes and
re-import the network, or associate the fiber with correct optical subnet after network upgrade in Cisco
ONP.

Create Optical Subnet for Non-SSON Networks
An optical subnet is a collection of spans with certain associated properties. When you create a new network,
Cisco ONP automatically creates an optical subnet that is associated to the network. At least one optical subnet
must exist for each network.

Check theCurrent Subnet check box in the properties window, to make the subnet you created as the current
subnet. You cannot uncheck the Current Subnet check box.

Note

The following procedure creates an optical subnet for Non-SSON networks:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click Subnet in the network tree panel.
Step 2 Right-click Optical Subnet.
Step 3 Click Create Optical Subnet.
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The Create Optical Subnet dialog box appears.

Step 4 From theCband Rules drop-down list, choose the C-band design rules for the new optical subnet that you want to create.
Step 5 Click Save.

A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

You can select new Cband rules from the Cband Rules drop-down list in the properties window.Note

You can add a fiber to a subnet from the Fiber links drop-down list in the properties window.

You can also add a fiber to a subnet from the network tree panel. To add a fiber to a particular subnet in the
network tree panel, perform the following steps:

• Right-click the required optical subnet and select Edit Fibers.

An Info dialog box appears displaying "Do you want to continue?.

• Click OK.

The UI freezes. You can only select a fiber from the map.

• Select the required fiber and click the Done button appearing near the zoom icon.

The fiber now appears in the Fiber links field. When you select the optical subnet, its corresponding
fiber is highlighted in the map.

When a fiber is added to one of the subnets, it will be automatically removed from the other subnets. Only
one subnet rule will be associated with one fiber.

Note

Create Optical Subnet for SSON Networks
The following procedure creates an optical subnet for SSON networks:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click Subnet in the network tree panel.
Step 2 Right-click Optical Subnet.
Step 3 Click Create Optical Subnet.

The Create Optical Subnet dialog box appears.

Step 4 From the Spectral Density drop-down list, choose the spectral density for the new optical subnet that you want to create.
The Name, CBand Rules, and Maximum Number of Channels the you seenin the Create Optical Subnet dialog box,
are set based on the spectral density that you have selected.

Step 5 Click Save.
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A new optical subnet with the design properties you selected is created and placed in the network tree panel under
OpticalSubnet.

You can select a new spectral density from the Spectral Density drop-down list in the properties window.Note

You can add a fiber to a subnet from the Fiber links drop-down list in the properties window.

You can also add a fiber to a subnet from the network tree panel. To add a fiber to a particular subnet in the
network tree panel, perform the following steps:

• Right-click the required optical subnet and select Edit Fibers.

An Info dialog box appears displaying "Do you want to continue?.

• Click OK.

The UI freezes. You can only select a fiber from the map.

• Select the required fiber and click the Done button appearing near the zoom icon.

The fiber now appears in the Fiber links field. When you select the optical subnet, its corresponding
fiber is highlighted in the map.

When a fiber is added to one of the subnets, it will be automatically removed from the other subnets. Only
one subnet rule will be associated with one fiber.

Note

Convert Non-SSON Network to SSON Network
The following procedure converts non-SSON networks to SSON networks:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a non-SSON network that you want to convert to SSON.

The network opens. Ensure that the network is in Design Mode.

Step 3 Choose Network > SSON Convert.
Step 4 Click Ok.

The error message, "Network cannot be converted to SSON due to following errors : [Network contains waves with
invalid traffic types: [100G-SD-FEC, 200G-SD-FEC]]" appears.

Step 5 Choose Network > Entity Editor > Services.
Step 6 Expand Waves and navigate to trail, and click a trail.
Step 7 Choose any NCS 1004optical source from the Src Card Type drop-down list.
Step 8 Click Update.
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Step 9 Choose File > Save.
Step 10 Choose Network > SSON Convert.

• Select SSON optical source from the Traffic Type drop-down list in the properties window.

• You cannot convert a non-SSON network with Traffic Sites to SSON.

• To convert a non-SSON network to SSON network in Analyze mode, upgrade or release upgrade the analyzed
network. In theUpgrademode, orRelease Upgrademode network, unlock all the channels, and force NCS 1004
optical source.

Share a Network
Use these steps to share a network with one or more users or user groups:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Select a network from the list of networks.

The map of the selected network opens.

Step 3 Choose File > Share.
Step 4 Select one or more users or user groups from the Share Network dialog box.
Step 5 Click Share.

You can share the network with selected users or user groups in read-only mode.

Access a Shared Network
Use these steps to access a network shared by another user:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open Shared Network.

The Select Network To Open dialog box appears with a list of networks that are shared by other users.

Step 2 Click a network name from the list.

The shared network opens in read-only mode.
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Step 3 Choose File > Save As.
Step 4 Enter the name in the Give a network name dialog box, and click Save.

A copy of the shared network is saved.

You can work on this copy of network, depending on the privileges of your user role. For example, if your
user role is Designer, you can change the design of the saved copy of the shared network, but you cannot
analyze the shared network.

Note

Step 5 (Optional) Share the updated network with other users.

Unshare a Network
Use these steps to unshare a network with one or more users or user groups:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a network from the list of networks.

The network opens.

Step 3 Choose File > Share.
Step 4 In the Share Network dialog box, remove the name of one or more users or user groups from the list.
Step 5 Click Share.

The shared network is no longer available to the users or user groups that are removed.

Analyze the Network
The Analyze tool allows you to analyze the network after design completion.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a network that you want to analyze, from the list of networks.

The network opens.
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Step 3 Choose Network > Analyze.

The Cisco ONP analysis progress indicator indicates the analysis status.

If there is any failure in the analysis stage, a dialog box appears with the message, “Analysis Failed.”

Step 4 Choose the Elements > Messages tab to see the list of error details in the analyzed network..

By default, it shows only the key messages when the Critical Only toggle button is enabled. If you want to view the
entire network message, disable the Critical Only toggle button.

Note

Step 5 If you find an error message under the Messages tab, resolve the error and analyze the network again. Repeat this step
until all errors are resolved.

The error message "Unexpected Situation 999" may occur when the optical simulation becomes inconsistent
due to incorrect values of properties entered or modified while designing the network. Call Cisco TAC to
know the exact cause of the error and modify the suggested property value for the successful analysis of the
network.

Note

Bottom-Up Flow
Bottom-up support enables step-by-step creation of a network. Adding all the services and waves on day 0
itself is not mandatory to analyze the network and view reports. Bottom-up flow enables you to build a network
over a period.

Day 0: Create a network with only the topology added. Add all sites and add fibers between them. Analyze
the network and view the reports without adding any services or waves.

Day 1: Add waves between the sites that are added on Day 0 and newly added sites and fibers. Analyze the
network and view the reports.

Day 2: Add services and tag waves that are created on Day 1 and newly added sites and fibers. Analyze the
network and view the reports.

After you have created the topology with sites and fibers added, you can add either a service or a wave. You
need not follow any specific order.

Bottom-up flow is applicable only for Non-SSON networks. In order to achieve this, you must set A2A mode
as A2A_fast in network properties. You can also set the A2A channel type as contentionless, colorless, and
colored.

Note

Idle Timeout in the Analyze Mode
If you keep the browser idle for more than 15 minutes, you are logged out of Cisco ONP. The default timeout
is set to 15 minutes. The System Admin can disable this feature by changing the enabled option in the
configuration file on the server to false. You can change the default time of 15 minutes by editing the duration
option in the configuration file.
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During a long network analyze cycle, you get logged out due to idle timeout, and the network analysis runs
in the background. When you log back, the same network opens in one of the following states:

• If the analysis is still on, the analysis progress bar is shown, and you cannot perform any other action.

• If the analysis is complete, the network opens in the Analyze mode.

• If the analysis has failed, the network opens in the design mode, and you can view the reason for failure
on the Elements > Messages page.

The session time out does not redirect you to the login page always; so, reload or enter the URL again.

Upgrade the Analyzed Network
Cisco ONP allows you to upgrade an existing network that is in analyzed mode. You can modify certain
properties of a network element in the network while retaining the existing network layout and design in the
locked state. Upgrade is supported for both SSON and non-SSON networks.

Use these steps to upgrade your network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the analyzed network that you want to upgrade.

The network opens.

Step 3 Choose Network > Upgrade.
Step 4 Click Yes in the Warning dialog box.

The message “Network Upgraded Successfully” appears. The network goes into upgrade mode and network elements
such as sites, fiber, waves (for non-SSON), and media channel (for SSON) are locked.

Step 5 Right-click the network element that you plan to modify from the network tree panel, and click Unlock. You can unlock
individual element and one at a time for multiple elements until the lower level in the network tree hierarchy.

For example, you can hierarchically unlock at the node level, side level, side add/drop card level, and side amplifiers
level.

Step 6 You can make the following modifications according to your requirement:
a) Edit the properties of network elements.
b) Delete the network elements from the network.
c) Add a new site, wave, services, demands, optical subnet, or fiber into the network map.

The newly added elements are automatically displayed in the network tree panel, and by default, remain unlocked.

You can insert a node in the upgrade mode only for the unlocked fiber. Therefore unlock the fibers that are
connected to the node and add nodes to the network.

Note
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Step 7 Choose File > Save.
Step 8 Choose Network > Analyze.

After the analysis is completed, the newly added elements are locked, and the optical reports and installation parameters
of the upgraded network are updated.

When you add services or fibers while upgrading a network that has where layout template is applied, the template gets
updated with the newly added service or fiber. You can export this template, make changes and reapply it to another
network.

Step 9 Choose Network > Design to further upgrade the newly upgraded network design.

When you upgrade a network every time, Cisco ONP saves the new version of the network as a child network, and
maintains the parent and child relationship.

Upgrade LNI Network
Table 7: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to upgrade
andmodify the imported LNI (Live
Network Import) network as
required. You can also correct LNI
errors, reanalyze the network, and
view the updated parameters such
as BOM, layout, connections, and
optical results.

Cisco ONP Release 4.1Upgrade LNI Network

The Upgrade feature can be used to correct LNI errors, modify the network, reanalyze the network and view
updated BOM, Layout, Connections, and Optical Results.

Use these steps to upgrade the LNI network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a network imported through LNI that you want to upgrade.

The network opens.

Step 3 Choose Network > Upgrade.
Step 4 Click Yes .
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The message “Network Upgraded Successfully” appears. After upgrading the network, the network goes into upgrade
mode, and network elements such as Sites, Fiber, OTN Services and Media Channels are locked.

You can modify certain properties of the network element, while retaining the existing network layout and design
locked.

Step 5 Right-click the network element that you plan to modify from the network tree panel, and click Unlock. You can
unlock individual element and multiple elements until the lower level in the network tree hierarchy.

For example, you can unlock node level, side level, side add/drop card level, and side amplifiers level.

Step 6 You can make the following modifications according to your requirement:
a) Edit the properties of network elements.
b) Delete the network elements from the network.
c) Add a new site, wave, services, demands, optical subnet, or fiber into the network map.

The newly added elements are automatically displayed in the network tree panel, and by default, remain unlocked.

• Unlocking media channel has few constraints. See Media Channel Unlocking Scenarios, on page 43.

• Cisco ONP automatically sets the scalable up to degree value based on certain design rules, as this
value is not present in the network that is imported through LNI. Hence, we recommend you to check
and update the actual scalable up to degree value, if necessary.

Note

Step 7 Choose File > Save.

When you upgrade a network every time, Cisco ONP saves the new version of the network as a child network, and
maintains the parent and child relationship.

Step 8 Choose Network > Analyze.

Analysis is successful only if a consistent and valid network is imported from LNI.Note

Step 9 If the analysis fails, go to Elements > Messages tab and check for the failure reason.
Step 10 If any validation error is thrown from any component, resolve the issue by manually changing the network or by

reimporting the LNI networks after correcting some configuration on the live network. See Possible Error Scenarios
and the Workarounds, on page 44.

Step 11 Re-Analyze the network.
Step 12 ClickLayout tab and edit the layout manually to adjust chassis or card position for NCS 4000 and NCS 1004 platforms.

See
Step 13 Click the BOM tab, and the Results tab to view the BOM and optical results.
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a. If the LNI inventory has any unconnected cards, that will be removed from the CONP reports after
upgrading and analyzing the LNI network.

b. The following PIDs are added in the Cisco ONP BOM after upgrading and analyzing the LNI network.
These PIDs are not part of the LNI network BOM.

• Pre-provisioned PIDs

• Release software PIDs

• Optical cables―Cables used for Internal Patch-cord Connection (IPC) is not imported in LNI as
this data cannot be retrieved from device

• Attenuators

• SMR port license PIDs―Only SMR card PID is imported as part of LNI. If licensed PID is
retrieved, corresponding port licenses are added after upgrading and analyzing the LNI network,
based on the number of ports used

• USB cables―Added if pre-provisioned passive cards present

• Blank cards―Blank cards are not imported. They are added in Cisco ONP after upgrading and
analyzing the LNI network

Note

Media Channel Unlocking Scenarios
The following table explains the various media channel conditions and the unlocking possibilities.

Table 8:

Unlocking PossibilitiesConditions

Cisco ONP throws an error indicating that there are
OTN services associated with the media channel. You
can neither update nor delete the channel. To unlock
and delete themedia channel, unlock associated OTN
services first and then unlock the media channel.

Channel has OTN services going over it. For 4K-2K,
the service is directly mapped to the channel, and for
4K-1K-2K, the service is mapped via OTU4 trail.

Cisco ONP allows you to unlock the channel but does
not automatically clear the properties of the channel
or its child entities such as Trail and Section,
irrespective of whether the properties or user-defined
or auto-assigned. Also, the channel is not unlocked
automatically, if it has any associated OTU4.

After unlocking the channel, you can delete the
channel, but cannot update the properties of the
channel or its child entities. (When the properties of
the media channel or its child entities are
auto-assigned, only wavelength is cleared and set to
Auto, and all other properties are not cleared.)

Channel does not have OTN services going over it.
For example, in case of 4K-1K-2K, the media channel
carries empty OTU4s.
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Unlocking PossibilitiesConditions

Cisco ONP allows you to unlock the channel and
automatically clears auto-assigned properties. After
unlocking you can perform the following:

• Update various properties of the channel and its
child entities.

• Delete the channel.

Channel has neither OTN services nor OTU4(s) going
over it. In case of 4K-1K-2K networks, Media
Channel does not carry even empty OTUs.

Possible Error Scenarios and the Workarounds
Following table describes the workarounds for the errors that are shown under the Elements > Messages tab.

Table 9: Error Scenarios and the Workarounds

WorkaroundsError Message

Check the username and password of the device,
which is given in LNI input Excel and retry LNI
import with valid device credentials.

Device Authentication failure

Check for any connectivity issue in the setup, fix it
and retry LNI import.

Device collection failed or Device not reachable.

Unlock C-Band amplifiers for side A inside Site4 in
the Network tree and force the valid output power. If
not sure, set it to Auto and analyze. Cisco ONP
chooses the best value based on the configuration.

In Site4.A, output power setting is not supported by
the amplifier.

For protected OTN service or SSON service, a
minimum of two contentionless sides must be present
on the source and destination sites. Check and add
contentionless sides on the target service source and
destination site and analyze.

Cannot Route demand! Did not find any valid
Omnidirectional Side.

Only 100GE, 10GE, and STM-64 service rates are
supported. If any other service rate is present in the
network, unlock the specific service, change it to one
of the supported service types and update the ODU
time slot accordingly and analyze.

• Demand OTU3 has unrecognized type [OTU3]

• ServiceGroup does not support the demandType
OTU3 for OTU3

100GE service type must have ODU time slot in the
range of 1–80. If any other value is set, update the
correct value or leave it blank so that Cisco ONP can
set it to the correct value.

Primary OTN Demand [100GE_Flex] has invalid
Timeslot ranges. Allowed ranges are [1-80]

Unlock the site and reanalyze.Cannot complete mesh connections at Site3.

No action required. This is an information message
to the user.

No OTN demand found for NCS4K trunk port -
NCS4016-B - OTU40/8/0/1.
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WorkaroundsError Message

Unlock the corresponding fiber couple and update the
correct connector loss value to be greater than zero.
The typical value is 0.2.

Fiber between Node1.A and Node2.B has an invalid
value in connector loss value

Unlock the corresponding fiber couple and update the
correct Tot SOL Loss w/o Connectors. The value
should be greater than zero.

Fiber between Nod1.C and Node2.C has an invalid
value in Tot SOL Loss w/o Connectors.

Remove Raman forcing on the fiber, or check and
force the path for any service so that it goes through
Raman enabled span.

Span Fiber-2 is forced as Raman but no traffic is
present.

Force RAMAN-CTP or COP on the Fiber-2
connecting node interface or remove RAMAN forcing
on the Fiber-2

Couple Fiber-2 has Raman enabled on the duct but
corresponding Raman Forcing is missing.

No specific action is required for noncritical messages. These are just information messages to the user.Note

Upgrade the Software Release of a Network
Table 10: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to choose
the NCS 2000 system release to the
desired release (11.1.0, 12.0.1, or
12.1.0), while performing the
release upgrade of CTP network,
Cisco ONP network, network
imported through Excel, and LNI
network.

Cisco ONP Release 4.1Release Upgrade

You can upgrade the software version of a network that is imported from CTP, the network created in Cisco
ONP, LNI Network, and Excel imported network to any desired release. Release upgrade is supported for
both SSON and non-SSON networks having NCS 2000 nodes with ROADM,OLA, Traffic, or the Passthrough
functionality.

Release upgrade is supported starting with NCS 2000 Release 11.1.0.

NCS 2000 supports SVO from the Release 12.1.0.Note

The following table lists the releases to which the existing system release can be upgraded, for each type of
network..
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Upgrade ReleaseNetwork

• From 11.0.0 to 11.1.0, 12.1.0, and 12.2.0

• From 11.1.0 to 12.1.0., and 12.2.0

CTP network (.mpz)

• From 11.0.0 to 11.1.0, 12.1.0, and 12.2.0

• From 11.1.0 to 12.1.0., and 12.2.0

• From 12.1.0 to 12.2.0

Cisco ONP network

From 11.0.0 to 11.1.0, 12.1.0, and 12.2.0Excel imported network

11.1.0 to 12.0.1 and 12.1.0

11.1.0 to 12.1.0 and 12.2.0

You cannot directly release upgrade an
LNI network. Perform the following:

Note

• Upgrade the LNI network. see
Upgrade LNI Network, on page
41)

• Analyze the network. (see Analyze
the Network, on page 38

• Release upgrade the analyzed LNI
network.

LNI network

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network in which you want to perform system release upgrade.

The network opens.

Step 3 Choose Network > Release Upgrade.
Step 4 Choose the System Release of NCS 2000, to which you want to upgrade, from the drop-down list.
Step 5 Click Submit.

The upgraded network is saved as a child network.

The network elements are locked in the network tree after the release upgrade. You can unlock and modify the elements.

Cisco Optical Network Planner Configuration Guide, Release 4.2
46

Design and Analyze Networks
Upgrade the Software Release of a Network



If the PMD coefficient does not get updated with the expected value, update the fiber type first, followed by
the PMD value when you edit the fiber properties.

Note

Plan Mode
Table 11: Feature History

Feature DescriptionRelease InformationFeature Name

This feature extends the current
implementation ofWhat-if analysis
for the OTN Services that are
connecting the aggregated nodes.
The failure report includes the
number of failed services, restored
services, and unrestored services.
This feature is supported for SSON
(4K-1K-2K and 1K-2K) and
non-SSON (4K-2K) networks.

Cisco ONP Release 4.1What-if Analysis for OTN Services

Plan mode enables you to perform what-if analysis on the existing network resources, such as failing and
restoring the fiber, OTN services, and site. This mode is applicable only for PLANNER and ADMIN roles.
This mode simulates the actual network behavior during failure and determines whether a service can be
rerouted; however, this mode does not suggest how to turn-up new wave lengths, insert new nodes, cards, or
ports, and so on.

The network can enter the Plan mode only from the Analyze mode. The what-if analysis can be done on the
NCS 2000 aggregated node (ROADM, OLA, Passthrough), Traffic node (1K-2K, 4K-2K and 4K-1K-2K),
the node created in Cisco ONP, CTP imported (mpz), and LNI imported networks.

Enter the Plan Mode
The following procedure shows how to enter the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with admin or planner role.

Step 1 Open the network in Analyze mode.
Step 2 Choose Network > Enter Plan Mode.

Switching to Plan Mode progress bar appears. The message, Entered Plan Mode successfully appears in the Success
dialog box.
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Exit the Plan Mode
The following procedure shows how to exit the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface, on page 6 as a user with admin or planner role.

Step 1 Open the network in the Analyze mode.
Step 2 Choose Network > Exit Plan Mode.

Fail a Fiber
The following procedure shows how to fail a fiber or a list of fibers in the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Expand the Fibers option in the network tree panel.
Step 2 Right-click the fiber, and click Fail. You can choose multiple fibers to fail by checking the check boxes next to the fibers.

All media channels or waves, OTN services, and demands that pass through the failed fiber fail. You can see the failed
media channels from the Map option or from the network tree.

• You can also fail a fiber or undo a fiber failure from Map.

• You can view the unrestored channel details in the failure report and the reason for restoration failure
under Elements > Messages tab.

• Failed channels are indicated with a red cross symbol, impacted fibers are marked with yellow cross
symbol, and the restored channels with a green tick symbol.

Note

Undo Fiber Failure
The following procedure shows how to undo fiber failure in the Plan mode:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree panel, click Fiber.
Step 2 Right-click the failed fiber, and click Undo Fail.
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Create a Failure Set
You can click any set of fibers or sites, right-click , and fail them. The failed fibers or sites are marked with
a red cross mark beside them. You can also choose multiple fibers or sites.

• Cisco ONP saves the user created failure sets.

• You can save multiple failure sets under a given failure group.

The following procedure shows how to create a failure set:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Right-click the Failure Groups option in the network tree panel.
Step 2 Click Add Failure Group.

A Failure group gets created.

Step 3 Choose the Fibers or Sites to fail by checking the check boxes next to the them.
Step 4 Right-click the chosen Fibers or Sites and click Fail.
Step 5 Select the network name, and right-click.
Step 6 Click Add Failure Set.
Step 7 Select the Failure Group to which the failed fibers or sites must be added.

The Failure Set gets created under the Failure Group. The failed fibers or sites are added to the created Failure Set.

If networks have dark fibers (which does not carry any traffic), that path is not considered for restoration.Note

Fail a Site
The following procedure shows how to fail a site or a list of sites in the Plan mode.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Expand the Sites option in the network tree panel.
Step 2 Right-click the site, and click Fail. You can choose multiple sites to fail by checking the check boxes next to the sites.

You can also fail a site from the network map view.

Undo Site Failure
The following procedure shows how to undo the site failure in the Plan mode:
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Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree panel, click Site.
Step 2 Right-click the failed site, and click Undo Fail.

You can also undo the site failure from the network map view.

Failure Report
The failure report shows the following parameters:

DescriptionReport

Shows the failed fibers in the network.Failed Fibers

Shows the failed sites in the network.Failed Sites

Shows the fibers that are impacted due to the site failure.Impacted Fibers

Shows the total number of media channels in the network.Total Channels

Shows the total number of media channels that are passing through the failed ducts
or sites in the network.

Failed Channels

Shows the total number of media channels that are restored from the failure state.Restored Channels

Shows the total number of media channels that are not restored from the failure
state due to the unavailability of alternate paths.

Unrestored Channels

Shows the fibers that have utilized greater than or equal to 80% of the bandwidth.
You can modify the threshold by updating the value in the Feature.Properties file.

• Fiber: Shows the fibers that are listed under fiber hot zones.

• Utilization Before (%): Shows the percentage of bandwidth that is utilized
before the channel restoration.

• Utilization After (%): Shows the percentage of bandwidth that is utilized
after the channel restoration.

Fiber HotZones

Shows the total number of services going through the fiber that was failed.Total Services

Shows the number of failed services going through the fiber that was failed.Failed Services

Shows the number of restored services going through the fiber that was restored.Restored Services

Shows the number of unrestored services going through the fiber that was restored.Unrestored Services

:
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Export Failure Report
The following procedure shows how to export the failure report.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Choose Export > Failure Report to export the failure report as an Excel sheet.

You can save the Excel sheet.

Export Failure Report from Map
The following procedure shows how to export the failure report from the map:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click Failure Report under Map.
Step 2 Click Export to export the failure report as an Excel sheet. You can save the Excel sheet.

Restore Failed Channels
The following procedure shows how to restore the failed fibers:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Network > Enter Plan Mode.
Step 2 Click Restore.

The message, "Restoration is in progress" appears.

Step 3 Click Failure Report to view the number of media channels that are restored or unrestored.

Restored channels are indicated with a green color tick mark in the network tree and map.

All media channels or waves, and demands that pass through the restored fiber also get restored. The Path
Computation Element (PCE) supports the restoration of the OTN services based on the optical feasibility
and OTN constraints.

Note
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Import Optical Sources
Optical Source Wavelength is a way to connect a DWDM interface from any external element to a third-party
optical network.

Use this procedure to import an optical source:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears. The default optical sources available in the server are:

• OpticalSources_NCS2K_400GXP-LC_NCS4K-4H-OPW-QC2

• NCS1004_OpticalSources_V3

• ONS-CFP2D-400G-C-OpticalSources-V2.mxd

• QDD-400G-ZRP-S-OpticalSources-V2.mxd

By default, all existing optical source files are loaded in the server.Note

Step 2 Click Add.

The Import Optical Source (.mxd) dialog box appears.

Step 3 Click Choose File and browse to the .mxd file stored in your local system, and click Import.

After the optical source is imported, a list of related interfaces appears.

Step 4 Choose the interfaces to import by checking the check box next to them. The selected interfaces get added to Type
drop-down list in the properties window of the network tree.

When you create waves, you can use the interfaces in the Type drop-down list.

Download Optical Sources
Use this procedure to download an optical source:

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

Step 2 Choose an optical source to download.
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Delete Optical Sources
Use this procedure to delete an optical source:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Manage > Optical Source.

The Manage Optical Source dialog box appears.

Step 2 Choose an optical source to delete.
Step 3 Click Delete to delete the selected optical sources.

Layout Template
Layout templates are reusable templates that are used to design layout configurations for a network. When
you have a network with fixed layout rules applicable for multiple nodes, you can use these templates to
accurately set up the layout for those nodes. These templates save you time, effort, and they minimize errors.

Layout template is not supported for a mix of TXP and Real card label of transponders.Note

Export Layout Template
Table 12: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to export
the layout template for an
individual site or for all the sites.
The layout template export is
possible only if the network is
analyzed in CiscoONPRelease 4.1.
The export of layout template is
supported on 4K, 4K-1K-2K, and
2K nodes.

Cisco ONP Release 4.1Layout Template Enhancement

Use the following procedure to export the layout template of a specific site or all sites:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.
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Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network whose network layout template you want to export.

The network opens.

Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout tab.
Step 5 Click the Hierarchy tab.
Step 6 Click the name of a site for which you want to download the layout template.
Step 7 Hover the mouse pointer over the Export icon and click Layout Template for Current site or All Sites.

The Export Layout Template dialog box appears.

Step 8 Click Export.

• We recommend that you export the layout template only in the analyze mode. Exporting layout templates
in the upgrade and release upgrade modes may be inaccurate.

• You can export the layout template for node of the type 4000 and 1000, but the exported layout template
will contain only the layout of NCS 2000 nodes. To export the layout template for the node type
NCS4K-1K-2K and NCS1K-2K, perform the following:

• Right click the site name under the Hierarchy tab, and click Export.

• Click OK to export the layout template in text format.

• The NCS 2000 layout template is in XML format.

Note

Import Layout Template for NCS 2000 Network in to Cisco ONP Database
Use the following procedure to import a template into the Cisco ONP database:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Manage > Layout Templates.
Step 2 Click Add in the Manage Layout Template dialog box.
Step 3 Click Choose Files and select a template from your local system.
Step 4 Click Import.
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The template is imported to the Cisco ONP database.

Download Layout Template for NCS 2000 Network
Use the following procedure to download a template from the Cisco ONP database:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Manage > Layout Templates.
Step 2 In the Manage Layout Template dialog box, choose the template that you want to download.

You can also choose multiple templates.

Step 3 Click Download.

Save the template into your local system.

Delete Layout Template for NCS 2000 Network
Use the following procedure to delete a NCS 2000 Network template from the Cisco ONP database:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose Manage > Layout Templates.
Step 2 In the Manage Layout Template dialog box, choose the template that you want to download.

You can also choose multiple templates.

Step 3 Click Delete to delete the template from the Cisco ONP database.

Apply NCS 2000 Layout Template into a Site
Use this task to apply the NCS 2000 Layout template into a site. The site can be NCS4K-2K, NCS1K-2K-4K,
or NCS1K-2K, but the template will be applied only to the NCS 2000 section of that site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.
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The Select Network To Open dialog box appears.

Step 2 Click the network where you want to apply the layout template into an NCS 2000 site.

The network opens.

Step 3 Choose Network > Entity Editor.
Step 4 In the Entity Editor window, expand Sites and choose the site.
Step 5 In the right pane, choose the required template from the Layout Template drop-down list.

Make sure that the other properties under Layout section such as Chassis Type, Power Supply, Controller
Card, Node Protection, Redundant Controller Card, and MF-Unit are

set to Auto. Otherwise the Layout Template drop-down list remains disabled.

Note

Import NCS 1000 and NCS 4000 Layout Template into NCS1K-2K and
NCS4K-1K-2K Sites

Use this task to import NCS 1000 and NCS 4000 layout templates that were exported, into 4K-2K and
NCS4K-1K-2K Sites.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network that has the site to which you want to apply the layout template.

The network opens.

Step 3 Click the Layout tab.
Step 4 Add the required NCS 4000 and/or NCS 1000 chassis, cards, and pluggables to the required slot of the added chassis.

See Edit the Layout Manually, on page 58

Step 5 Click the Hierarchy tab.
Step 6 Click Edit to enter the edit mode.
Step 7 Right click the name of a site on which you want to import the layout template, and click Import.
Step 8 Choose the layout template that you want to import into the site and click OK

The layout template gets applied to the site.

When you modify an exported template, ensure to rename the modified template before reapplying it to a
site in the upgrade mode so that the changes in the template reflect in the layout view.

Note
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Layout Visualization
Table 13: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to view and
adjust the position of NCS 4016
and NCS 1004 chassis and cards in
the layout. This feature is supported
only on 4K-1K-2K and 1K-2K
aggregated nodes and not supported
on stand-alone NCS 2000 node.

Cisco ONP Release 4.1Layout Visualization and Edit

This feature allows you to visualize the layout of a network, designed using Cisco ONP. You can view the
arrangement of racks, chassis inside the racks and cards inserted in the chassis. When you click a particular
Rack or Chassis or Card in the Hierarchy panel, the corresponding Rack or Chassis or Card gets highlighted
in the Layout image. You can zoom in and zoom out the Layout image.

View Network Layout
The procedure to view the network layout is as follows:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 From the File menu, click Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout tab.
Step 5 In the Hierarchy panel on the left side, click the site.

The OLA sites are highlighted in green color, ROADM sites in blue color and Aggregated nodes in purple
color.

Passthrough sites are not listed under layout.

Note

Step 6 Click any rack under a site to visualize the rack view of the network under Layout tab.
Step 7 Click any chassis under a rack to visualize the chassis view of the network.
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When you click the Aggregated node under Hierarchy panel, NCS 1004, NCS 2000 and NCS 4000 series
chassis are placed in separate racks.

You can click the screenshot icon to take screenshot of all racks layout of the selected site.

Note

Edit the Layout Manually
The Manual layout edit feature is used to adjust the position of NCS 4016 and NCS 1004 chassis and cards
in the layout.

The procedure to edit the layout manually is as follows:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.

Choose the network where 4K-1K-2K and 1K-2K aggregated nodes are added. This feature is not supported on NCS
2000 node.

Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout tab.
Step 5 Click Edit to enter the Edit mode.
Step 6 Select the Chassis (4K-1K-2K and 1K-2K) or Card from a particular rack.
Step 7 Drag and drop the selected Chassis or Card from a particular rack to the empty slot in the same or different Chassis or

Rack.
Step 8 To add pluggables to a particular card, perform the following steps:

Make sure to add the required cards.Note

a) Select the Rack.

The cards available in the Rack are displayed.

b) Select the card to which you want to add pluggables.

The ports available in the card are displayed.

c) Select the pluggable for each port.

The following pluggables are displayed:
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Supported PluggablesCard

• ONS-QSFP8-LR4=

• QSFP-110G-SR4-S=

• ONS-QSFP-4*10-MLR=

NCS4K-4H-OPW-QC2

• ONS-QSFP8-LR4=

• QSFP-100G-SR4-S=

• ONS-QSFP-4*10-MLR=

NCS4K-4H-OPW-LO

• ONS-QSFP8-LR4=

• QSFP-100G-SR4=

• ONS-QSFP28-LR4-S=

• QSFP-100G-CWDM4-S=

• QSFP-100G-SM-SR=

NCS1K4-1.2T-K9=

d) Click the Tick icon.

Step 9 Click Done to save the changes in the Layout.

View the Layout Details Using Tooltip
You can hover over the Racks or Chassis or cards in the Rack and view the details using Tooltip. Click See
More Details to view the details of port no. type, pluggables and rates.

Copy the Configurations of a Particular Node to Another Node
The configuration can be copied from one node to another node only for the manual 4K-1K layout movement.

The procedure to copy the configurations of a particular node to another node of a different site is as follows:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note
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Step 4 Click the Layout tab.
Step 5 Select the Rack, Chassis, or Card of a particular site.
Step 6 Select the site to where you want to copy the configurations to, from the Copy To drop-down list.
Step 7 Click New Rack to add a new rack. The configuration gets copied to the new rack.
Step 8 Click Done to save the changes in the Layout.

You can also cut, copy, and delete Racks, Chassis, and Cards in the Chassis from the Layout.Note

Export Port Usage of LNI Network
Table 14: Feature History

Feature DescriptionRelease InformationFeature Name

This feature provides the
connection trace of a service across
various interfaces in a network.
This feature allows you to export
the following:

• Consolidated port usage report
based on network in addition
to the internal port details
which you can view by
hovering the mouse pointer
over the tooltip

• Port usage report based on
sites

• Port usage report only for LNI
imported networks

Cisco ONP Release 4.1Multi-Layer Connections Phase 1

Use the following procedure to export the port usage details of an LNI network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the LNI network whose port usage you want to export.

The network opens.

Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note
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Step 4 Click the Layout tab.
Step 5 Click the Hierarchy tab.
Step 6 Click the name of a site for which you want to download the port usage.
Step 7 Mouse hover the Export icon and click Port Usage for Current site or All Sites.

The Export Port dialog box appears.

Step 8 Click Continue.

The port usage details are exported in the Excel sheet format.

• If you modify any services in the NCS 4000 node after upgrading the LNI network , the changes will
not get updated in the port usage details.

• The demand labels seen against the trunk ports of NCS4K-DWDM line card in the port mapping report
are not logically related to the NCS 4000 trunk ports, but are related to NCS 1004 client ports.

Note

Define Multilayer Connections for SSON Network
Table 15: Feature History

Feature DescriptionRelease InformationFeature Name

You can define Multilayer
Connections (MLC) such as cards
and pluggables for NCS 4K-1K-2K
and NCS 1K-2K aggregated nodes
in an SSON network.

This new tab in the Layout page
helps to view end-to-end MLC
trace for OTN service starting from
NCS4K IN until NCS2K
Add/Drop for LNI network. Also,
it helps to define new traces for the
newly added service and maintain
the network design and
deployment.

Cisco ONP Release 4.2NCS4K-1K-2K Multilayer
Connection Trace

Use this procedure to define the Multilayer Connections (MLC) such as cards and pluggables for 4K-1K-2K
and 1K-2K aggregated nodes in an SSON network.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.
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Step 2 Click a network in which you want to define the multilayer connections.

Make sure that the network is in analyzed mode and 4K, 1K, and cards are defined in the network.

The network opens.

Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout tab.
Step 5 In the left pane, click the MLC tab.

You can also navigate to the MLC page by right-clicking the service name in the network tree and clicking View in
MLC

You can view a table describing the following properties of the service, in the right pane:

Table 16: MLC Details

DescriptionProperties

Name of the serviceName

Name of the group to which the service belongs toGroup Name

Traffic typeType

Source siteSrc Site

Details of Rack/Slot/Card/Port in the input side of the NCS
4000 chassis in the source site

Src NCS4K In

Details of Rack/Slot/Card/Port in the output side of the
NCS 4000 chassis in the source site

Src NCS4K Out

Details of Rack/Slot/Card/Port in the output side of the
NCS 1004 chassis in the source site

Src NCS1K In

Details of Rack/Slot/Card/Port in the output side of the
NCS 1004 chassis in the source site

Src NCS1K Out

Add/Drop multiplexer and demultiplexer connected to the
NCS 2000 chassis in the source site

Src NCS2K AddDrop

Media channel between the source and destination sitesSrc NCS2K MPO

Details of Rack/Slot/Card/Port in the input side of the NCS
4000 chassis in the destination site

Dst NCS4K In

Details of Rack/Slot/Card/Port in the output side of the
NCS 4000 chassis in the destination site

Dst NCS4K Out

Details of Rack/Slot/Card/Port in the input side of the NCS
1004 chassis in the destination site

Dst NCS1K In
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DescriptionProperties

Details of Rack/Slot/Card/Port in the output side of the
NCS 1004 chassis in the destination site

Dst NCS1K Out

Add/drop multiplexer and demultiplexer that is connected
to the NCS 2000 chassis in the destination site

Dst NCS2K AddDrop

MPO cable connecting the NCS 2000 chassis in the
destination site

Dst NCS2K MPO

Media channel between the source and destination sitedMedia Channel

More notes, if anyNotes

Indicates whether the service connections are user-created
or imported through LNI.

Trace Origin

The details of source and destination NCS2KAddDrop andNCS2KMPO are not displayed for the networks
that are created in Cisco ONP Release 4.1 and migrated to Cisco ONP Release 4.2.

Note

Step 6 Click the service name to switch to the layout view.

You will view the layout and the service details in the right pane.

Step 7 Select the rack, shelf, card, and ports from the drop-down lists for NCS4K In, NCS4K Out, NCS 1K In, and NCS 1K
out, for both Source and Destination sites.

The details of the NCS 2000 chassis are auto-populated.

For LNI imported network all the details are auto-populated. If you add any new service, you can change
the details of the new service as per your requirement.

Note

Step 8 Click the Tick icon to save the changes you have done.

You can click the refresh icon to delete the changes you made after saving.

The updated details are included in the BOM.

Step 9 (Optional) To export the MLC details perform the following steps:
a) Click the Table icon to switch to the table view.
b) Choose Export > MLC Tracesto export all the details available in the MLC table.
c) Choose Export > LMP/TTI Connections to export the details of Link Management Protocol (LMP) connections

which are the connections between NCS 1004 and NCS 2000 cards, and Trail Trace Identifier (TTI) connections
which are the connections between NCS 4000 and NCS 1004 cards.

All these connections get added to the BOM.

Step 10 (Optional) Click the Filter icon to filter the services displayed in the left pane, based on the following:.

The following filter options are available:

• Source Site

• Destination Site
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• Type of the traffic

• Trace Origin

• LNI―Imported through Import Live Network option

• User Created―Created through Cisco ONP UI

• Trace Status

• Completed―User has defined all MLC details.

• Partial―User has defined only partial MLC details.

• Empty―User has not defined any MLC details.

Step 11 (Optional) Click the three vertical dots and select the following as required:

• Enable Multi Select―You can select up to the card level for different OTN.

• Expand All―Expands the services tree.

• Collapse All―Collapses the expanded services tree.

• Show Trace Status―Shows the trace status icon next to the service name.

Step 12 (Optional) Click the three horizontal dots across the service trace and select the following as required:

• Delete Trace―Deletes the respective trace.

• Locate in Map―Shows the service in the map view.

User can enable the same port number on the primary and secondary NCS4K IN nodes for Client 1+1 and
other protection scheme.

Note

Regenerate BoM Automatically
You can view the new Chassis or Card added to the existing layout under the BOM tab. You can also view
the regenerated BoM after manual editing of the layout.

Add new Pluggables, Alarm Cables and 100G Client Bandwidth
Licenses to BoM

You can add new pluggables, alarm cables and 100G bandwidth licenses of NCS 1004 and NCS 4000 platforms
to the existing BoM.

The procedure to add new pluggables, alarm cables and 100G client bandwidth licenses to the existing BoM
is as follows.
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Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.
The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the BOM tab.
Step 5 Click Add.

The New window opens.

Step 6 Enter the Cisco part number of the pluggable or alarm cable or 100G bandwidth license in the Cisco Part Number field.
Step 7 Choose the Quantity of pluggables or alarm cables or 100G bandwidth licenses to be added.
Step 8 Click Add.

The new pluggables or alarm cables or 100G bandwidth licenses are added to the BoM list.

Export IPC Report
You can export the connections of a current site or all sites to an Excel sheet using the following procedure:

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 From the File menu, click Open.

The Select Network To Open dialog box appears.

Step 2 Click the network to open from the list of available networks.
Step 3 Choose Network > Analyze.

Network must be successfully analyzed to proceed further.Note

Step 4 Click the Layout tab.
Step 5 z
Step 6 Click the IPC tab.

You can view the patches that are listed in the left pane. Click each patch to view the details such as position, card, and
port of the source and destination sites.

Step 7 Hover over the Export icon, and click Current site or All Sites option.

The Export IPC dialog box appears.
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Step 8 Click Continue to export the connections of the current site or all sites.

Design Networks with SVO Card
An SVO card along with the application software provides functionality-based licenses for alarm correlation,
performance monitoring, connection verification, and Optical Time Domain Reflectometry (OTDR). You can
design a network with ROADM and TRAFFIC nodes that are equipped with SVO cards.

Features

• The SVO card is a two-slot card.

• The SVO card acts as the primary card for all the networks after Release12.1.0.

• To achieve high availability, you can have two SVO cards equipped in one node.

• You can use two 10G SFP+ pluggables to connect two SVO cards present in a node.

• You cannot have two SVO cards in the same chassis, to achieve high availability in the network.

• When designing the network, you can connect a Cisco ASR 920 Switch to the SVO cards.

• The SVO can be used as a card or as a UCS-based solution.

SVO Licenses

SVO cards require either Base License or SVO Full License (High Availability, Connection Verification,
Flex Spectrum). If you do not select SVO Full License, by default, SVO Base License and High Availability
are enabled.

The different types of SVO licenses are

• Cisco NMS: This includes features such as High Availability, Connection Verification, Flex spectrum,
and OTDR.

• Third-Party NMS: This includes features such as NBI (North Bound Interface), Alarm Correlation,
Performance Monitoring, and Circuit Provisioning.

Chassis Licensing

• Every chassis added to the network must have license after Release 12.1.0. For the release upgraded
network, a new chassis license is added after it is analyzed in Cisco ONP Release 4.0 or higher.

• There are many variants of the chassis license, such as 1-chassis, 5-chassis, 10-chassis, 20-chassis,
50-chassis, and so on. The variants of chassis license are added based on cost optimization.

• A license is required for every chassis that is added to the network after the first chassis.

• Chassis License Flush Out: You can flush out the existing chassis license and purchase a new chassis
license. If you hold the existing chassis license, the license remains active even if the site is unlocked.

• Chassis License Flush Out is supported only in the network upgrade mode.

• You can use the existing license with new changes in chassis, if you do not use the Chassis License Flush
Out option.
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Associate OLA or DGE Sites with SVO Cards
The following procedure shows how to associate OLA sites with the SVO cards:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree panel, right-click any ROADM site.
Step 2 Click Edit SVO Associations.
Step 3 Select the OLA sites on the map to toggle the SVO connections. ClickDone at the top-right corner to confirm the selection.

You can open widgets in the map and select top section to view the association.

You can also right-click any ROADM site from the Map and click Edit SVO Associations. For the sites
that are of DGE type, the Edit SVO Associations option is not displayed.

The tool associates the OLA and DGE sites that are not associated by you, with the SVO card during the
network analysis.

Note

Upload NETCONF XML Files on SVO Web Interface
The following procedure shows how to upload the NETCONF XML files on the SVO web interface:

Step 1 In the browser URL field, enter the IP address of the SVO line card.

The login page appears.

Step 2 Enter the username and password.
Step 3 Click Login.
Step 4 Click the hamburger icon at the top-left of the page, and select Node Configuration.
Step 5 Click the Node Setup tab.
Step 6 Click Select files .
Step 7 Browse to the NETCONF XML files exported from the Cisco ONP GUI and upload them.

If the passive unit ID in the NETCONF file exceeds the range 1–126, SVO displays an error message. Validate the XML
file and reimport.

If the value of FEC mode already provisioned in the 200G-CK-C line card does not match with the value
available in the NETCONF XML file, SVO displays an error message. We recommend that you remove the
provisioned FEC settings for this card and reimport the XML file.

Note
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Export NETCONF XML Files for Individual Sites
The following procedure shows how to export NETCONFXML files for individual sites from the Cisco ONP
GUI.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

The network must be in Analyze mode.

Step 1 In the network tree panel, enable the Stage button.
Step 2 Check the individual site check box.

You can select only one site at a time and download the NETCONF XML file for that site by enabling the Stage button.

Step 3 Right-click the site.
Step 4 Click Generate NetConf XML.

The message, "Success. Netconf exported successfully" appears.

Cisco Optical Network Planner Configuration Guide, Release 4.2
68

Design and Analyze Networks
Export NETCONF XML Files for Individual Sites



C H A P T E R 4
Modify Network Properties

• Modify Network Properties, on page 69
• Modify Site Properties, on page 71
• Modify Fiber Properties , on page 82
• Modify Fiber Couple Properties, on page 86
• Modify Service Properties, on page 87
• Services Aggregation, on page 90
• Modify Wave Properties, on page 94
• Modify Media Channel Properties, on page 94
• Modify Trail Properties, on page 96
• Modify Section Properties, on page 98
• Modify Side Properties, on page 99
• Modify C-Band Amplifier Properties, on page 100
• Modify Add/Drop Multiplexer Properties, on page 108
• Modify Client Properties, on page 108
• Sort the Network Elements, on page 110
• Regeneration Support, on page 110
• Multidegree ROADM, on page 111

Modify Network Properties
Use this task to modify the properties of the network.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, click the network name.

You can view the basic properties of the network at the bottom of the network tree.

Step 2 Modify the following network properties as required.

DescriptionProperty

Modify the network name as required.Name
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DescriptionProperty

Check the Quick Analysis check box to quickly analyze the network by using a less
accurate algorithm.

The quick analysis option does not optimize the DCU and amplifier placement algorithm,
hence resulting in an approximate BoM.

To receive an accurate BoM, uncheck the Quick Analysis check box.

Quick Analysis

Cisco ONP supports 100G and 200G transceivers as DWDM interfaces.

This option is applicable only for automatically created waves, when OTN services are
present.

• 100G—The entire network chooses the 100G wavelength for transmission.

• 200G—The entire network chooses the 200G wavelength for transmission.

If you enable both 100G and 200G options, by default, the entire network chooses the
200G wavelength for transmission. If 200G wavelength is not optically feasible, then it
selects 100G automatically for transmission.

DWDM Interfaces

Enter the customer name.Customer Name

Choose ANSI (North American standard) or ETSI (European Telecommunications
Standards Institute) from the drop-down list. ANSI networks do not allow you to define
SDH (ETSI) service demands. ETSI networks do not allow you to define SONET (ANSI)
service demands.

Platform

Displays the unit of measurement of span length. By default, it is kilometer (km), and
you cannot edit it.

Measurement Unit

Choose the A2A (Any to Any) mode. The available options are:

• A2A_None

• A2A_FAST

A2A Mode

The power output value is based on the chosen A2A mode.A2A Power Output

The demand type is based on the chosen A2A mode.A2A Demand Type

Choose the type of channel. You can choose multiple types. The available options are:

• Contentionless―This property enables an N-degree ROADMnode to accommodate
N wavelengths of the same frequency from a single add or drop device.

• Colorless―The colorless property enables tuning of channel wavelengths without
changing the optical interface of the port.

• Colored―The Colored property dedicates a separate port for each wavelength.

A2A Channel
TypeContentionless

Indicates whether the network is an SSON network.SSON
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DescriptionProperty

Check this check box to enable the Pay As You Grow feature on the client cards.

The PAYG feature enables you to implement a cost-effective solution when the wavelength
requirements are comparatively less than themaximum capacity of the network. A standard
card is configured to work onmaximum supported wavelengths, whereas a PAYG license
comprises license restricted cards and a base license. So, instead of purchasing a standard
card, you can purchase a PAYG license.

Use client Payg

System Release

Displays the system release of the NCS 4000 node in the network.NCS 4K

Displays the system release of the NCS 2000 node in the network.NCS 2K

Displays the system release of the NCS 1004 node in the network.NCS 1K (Available only on
the SSON network)

Displays the system release of the NCS 2000 node in the network, before the Release
upgrade.

Previous NCS 2K (Available
only on the Release upgraded
network)

(Display only.) By default, the Naming Convention Enabled option is enabled by default
for the networks that are created in Cisco ONP, and you cannot edit it. By default, the
sides are named from T, S, R, Q, P, O, N, M, L, K, J, I, H, G, F, E, and index, depending
upon the used Scalable Upto parameter.

• You can import a mpz network without naming convention enabled, but the Cascaded
SMR option remains disabled.

• You cannot edit the label name of the side.

Naming Convention Enabled

Choose the type of network management solution. The available options are:

• SVO―Chooses SVO card

• UCS―Chooses SVO application that is hosted on a server.

• Auto―Chooses SVO card as default, for SVO solution.

SVO

Step 3 Click Update.
Step 4 Tomodify the advanced properties of the service, click Show Advanced Properties or chooseNetwork >Entity Editor.
Step 5 In the Entity Editor window, click the Site tab.
Step 6 Click the network, and modify the properties in the right pane.
Step 7 Click Update.

Modify Site Properties
Use this task to modify the properties of the site.
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Before you begin

Table 17: Feature History

Feature DescriptionRelease InformationFeature Name

You can enable the Colored
Add/Drop property. This feature
supports the use of contentionless
and colored demands that are
connected to the same port of an
SMR card. With the Shared SMR
Port enabled, you can create and
validate the contentionless and
colored configuration on a
16-degree SMR-20 node.

Cisco ONP Release 4.2Shared SMR Port

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Sites, and click a site.

You can view the basic properties of the site at the bottom of the network tree.

Step 2 Modify the following site properties as required.

DescriptionProperty

General

Enter the site name, either alphanumeric or numeric.Name

Choose the type of site. For example, ROADM, OLA, Pass-through, or a Traffic site.

• You can add a passthrough site as a place holder. You cannot add services or waves to
this site and therefore cannot generate the report. Later, you can convert the passthrough
site to a ROADM, OLA, or the Traffic site in the design mode.

• OLA is an optical line amplifier site that is used only for amplification. You cannot
add service or waves on this site.

• You cannot add a Traffic site of the type 4K-2K into an SSON network.

Type

The default value is FLEX NG-DWDM for all nodes. This field is non-editable.Node Type

Choose the configuration from the drop-down list. This option is available only for the
Traffic site. The available options are:

• Large CO - NCS 4016

• Small Site - NCS 4016

• Small Site - NCS 4009

Equipment Configuration
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Choose the traffic type. The available options are:

• 4K_1K_2K (for SSON)

• 1K_2K (for SSON)

• 4K_2K (non- SSON)

Traffic Type (only for
Traffic site)

Indicates whether the network is an SSON network.SSON

Layout

Choose the type of chassis. Chassis type is supported for all the sites except passthrough.

The available options are:

• M6 Chassis

• M15 Chassis

• Auto

M15 is the default option when you choose Auto.

Chassis Type

Choose the type of Power Supply. The available options are Auto, AC Power, and DC Power.

The default option is DC Power.

Power Supply

C Band

Displays the structure of the site: Multi degree and Terminal for ROADM and Traffic sites,
and Line for OLA and Passthrough sites. This field is non-editable.

Structure

Displays the site functionality. This field is non-editable. Following is the functionality
available for each type of sites:

• Optical Cross Connect (OXC) for ROADM and traffic site

• Auto for OLA site, Cisco ONP downgrades OLA site to passthrough if OLA is not
required.

• Passthrough for passthrough site

Functionality

This parameter determines the maximum number of degrees, ducts, or line sides that can be
supported by the site. The available options are 2, 4, 8, 12, and 16. The default option is 4.
The network is scalable up to 16 degrees for ROADM and Traffic sites. Choose 2 to have
a LINE ROADM site.

For OLA and passthrough, the value is 2 and is noneditable.

Scalable up to Degree
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DescriptionProperty

Choose the type of site.

The available options are:

• Auto

When you choose Auto, the default option is SMR-20.Note

• SMR-20

• SMR-9

The Site type is Line for the OLA site.

Site Type

Step 3 Click Update.
Step 4 To modify advanced properties of the site, click Show Advanced Properties, or choose Network > Entity Editor.
Step 5 In the Entity Editor window, expand Sites under the network tree, choose the site, and modify the following properties

that are displayed in the right pane. For more information on entity editor, see Entity Editor, on page 146.

DescriptionProperties

General

Enter a string holding the CLLI code.CLLI Code

Enter the site address.Site Address

By default, this option is unchecked. When you enable this feature on the
network, it is automatically enabled on the associated sites of the network.

Evolved Mesh

Displays the status of the network. It shows whether the network isUp orDown.Status

Displays the weight of all the units of the site, in pounds.Weight Lbs

Choose the Node Protection. The available options are:

• Same shelf

• Separated shelves

Node Protection

Displays the fan-out module. The default option is MF-MPO-16LC.

TheMPO-16 to 16-LC fan-out module is a double slot module with oneMPO-16
connector (COM) and eight LC duplex connectors. The MPO-16 connector is
compatible with the SMR20 FS EXP and 16-AD-CCO FS units.

Mpo16Lc

Choose the required Mpo16 to Mpo8 converter. The available options are:

• MPO16ToMPO8Cable

• MF-2MPO_ADP

Mpo16ToMpo8

Enable this option to add Layer-2 contentionless sides.Cascaded SMR
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DescriptionProperties

By default, this check-box remains checked for newly created network. You
cannot edit it.

Flex Spectrum

When you enable this option, it indicates that OTN traffic can be groomed at
this site.

Grooming Site

Check this check box to use the ONS-MPO-MPOLC-10 breakout cable to
interconnect the client ports of the MR-MXP card with the
NCS2K-MF-MPO-20LC passive module.

MR-MXP BreakOut Cable

Check this check box to use the NCS2K-MF-8X10G-FO passive module only
for 10G on the client-side of the NCS2K-400G-XP card. By default, this passive
module is enabled.

8X10G-FO

Bill of Material

This feature enables NCS features on all sites in the network.Enable NCS

The Pay As You Grow (PAYG) functionality significantly reduces the initial
setup cost and enables the purchase of another wavelength capacity on a need
basis.

PAYG enables port-based cost or licensing for SMR-9 and SMR-20 cards.

Use PAYG

Enable this check box to:

• Validate the correct optical interconnection between the optical cards inside
a Flex ROADM.

• Measure the insertion loss of the external passive path.

• Validate the quality of the connections to the patch panel.

• Check if the insertion loss is within expected value.

The following cards support connection verification:

• SMR20 FS CV

• MF-DEG-5-CV

• MF-MPO-16LC-CV

• MF-UPG-4-CV

Connection Verification

By default, this check-box remains checked for newly created network. You
cannot edit it. This option enables displaying of new SMR-20 PID in the BOM
page.

You can enable this option when you unlock an mpz network where SMR-20
is selected, during upgrade or release upgrade.

New FS-SMR PID

Layout
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DescriptionProperties

Choose the type of chassis. The available options are:

• M6, and M15 Chassis for OLA

• M6 Chassis for ROADM and Traffic

• M15 Chassis for ROADM and Traffic

• Auto for all nodes

Chassis type is not supported for the passthrough site.Note

Chassis Type

Choose the type of Power Supply. The available options are based on the chassis
type:

• Auto for all type of chassis

• AC Power, DC power for M15 and M2 chassis

• AC Power, DC Power, AC2 Power, DC40 Power, and DC20 Power for
M6 chassis

Power Supply

Choose the type of the controller card.

For NCS 2000 site, the default controller card is TNCS-2. The available options
are based on the chassis type chosen. By default, controller cards that are
supported by M15 chassis are listed. The available options are:

• Auto

• TNC/TSC, TNC-E/TSC-E, TNCS, TNCS-0, TNCS-2, and TNCS-20 for
M2 chassis

• TNC/TSC, TNC-E/TSC-E, TNCS, TNCS-0, TNCS-2, and TNCS-20 for
M6 chassis

• TNCS, TNCS-0 TNCS-2, TNCS-20 for M15 chassis

Controller Card

Choose whether to use a redundant controller card.Redundant Controller Card

Cisco Optical Network Planner Configuration Guide, Release 4.2
76

Modify Network Properties
Modify Site Properties



DescriptionProperties

Choose the required layout template.

After the chosen layout template is applied, all layout properties
will be reset and disabled.

Note

After design analysis, if the applied layout template is not
considered for card placement in the layout, check for the error
message (noncritical) under the Elements > Messages tab. If you
see a template-related error which indicates that there is a mismatch
between the cards that are defined in template and the cards that
are created on the site, perform the following:

Note

• Export the template from the Layout page, and modify it as
required.

• Import the modified template using the Manage > Layout
Template option.

• Switch to Design mode and apply the template to the site
using the Entity Editor.

• Reanalyze the network to get the correct layout populated.

Layout Template

Choose the type of cables to be used for the AC power supply. Cables are listed
based on the country type and the Chassis type selected.

UTS AC Power Cables

Choose the redundant power scheme from the drop-down list to configure the
number of working and protected power units for the chassis.

For NCS 2000 site, the options available are based on the chassis type. ForM15
chassis, the options available are 1+0, 1+1, 2+0, 2+1, 3+0, 3+1, 2+2, 3+1 is the
default redundancy power scheme for M15 DC chassis and 2+2 is the default
redundancy power scheme for M15 AC chassis. For example, if you choose
3+1 redundant power scheme, there are 3 working power units and 1 protected
power unit.

For M6 chassis, the options available are Auto, Yes, and No.

Redundant Power Scheme

This option is available only for the OLA site. By default, this check box remains
checked. This option indicates that MF-2LC-ADP can be shared with EDRA
amplifiers and not with RAMAN amplifiers irrespective of the default selection.

Raman Adapter Share
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DescriptionProperties

Choose the External Connection Unit (ECU) type from the drop-down list. The
options available are based on the chassis type. By default, the ECU applicable
for M15 is listed.

• ECU—Has 12 USB 2.0 ports and supports IEEE1588v2 PTP, time-of-day
(ToD), and pulse-per-second (PPS) inputs.

• ECU-S—Similar to ECU except that it has eight USB 2.0 ports and two
USB 3.0 ports.

• ECU60-S—Variant of ECU-S introduced for the NCS 2006when the shelf
is powered at –60VDC nominal input voltage.

ECU-S and ECU60-S are supported only for M6 chassis.

ECU Type

Choose the mechanical frame for the passive optical modules from the
drop-down list. The options available are Auto, MF-6RU/MF-10RU, and
MF-1RU.

• The NCS2K-MF-1RU has four slots for the passive optical modules.

• TheNCS2K-MF-6RU supports up to 14 single-slot passive optical modules
such as any combination of NCS2K-MF-DEG-5, CS2K-MF-UPG-4, or
Connection Verification (CV) units.

• The NCS2K-MF10-6RU supports up to 10 double-slot passive optical
modules such as NCS2K-MF-MPO-16LC=.

MF Unit

If you check this check-box, ROADM and transponder cards are placed in
different chassis.

Chassis Disaggregation

Map

It represents the longitudinal location of the site. Longitude can be positive or
negative (-180 to 180). Negative is west of Greenwich, and positive is eastward.

X Coordinate

It represents the latitudinal location of the site. Latitude can be positive or
negative (- 90–90), north and south of the Equator.

Y Coordinate

Check this check box to lock the site position on the map.Position Lock

C Band
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Check this check box to connect Contentionless unit 16-AD-CCOFS andColored
unit MD-48-ODD/Even to the sameMPO port of SMR-20. When Shared SMR
port is enabled, MD-48-ODD/EVEN unit connects to the specific side of
SMR-20 through MPO-8LC and UPG-4 instead of directly connecting to
SMR-20 through MPO-16LC.

Shared SMR port becomes disabled, ifNote

• Degree Mesh Type property is PPMESH8-5AD

• Or, Site Type property is SMR-9 and Scalable Upto Degree
property is 8

Shared SMR Port

Choose the mesh type for Flex NG-DWDM site. The available options are:

• DEG-5/UPG-4

• PPMESH8-5AD

DEG-5/UPG-4 is the default value.

Degree Mesh Type

Displays the type of the site. For example, OLT.Site Type

Displays the platform.L0 Platform

Displays the type of degree. For example, BRK-8.Degree Type

This parameter determines the number of degrees to be considered for the site
hardware placement on day 0.

The values can be None, Auto, 4, 8, 12 or 16. The default option is None. If
you choose None, only the sides that are present in the Cisco ONP GUI are
shown. The values in the drop-down list are populated based on the value of
scalable up to degree parameter.

Pre Equip Degree

SVO

Allows you to flush out the existing chassis license and purchase new chassis
license.

Chassis License Flush Out

You can choose one of the following options from the drop-down list. When
you choose Auto, ONS_SC+-10G_SR is the default option.

• Auto

• ONS-SC +- 10G-SR

• ONS-SC +-10G-LR

The SVO pluggables are not applicable for UCS-based SVO
network design.

Note

SVO Pluggables

Cisco NMS
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DescriptionProperties

Enable this check box to add High Availability (Feature and License),
Connection Verification license, Flex Spectrum license, and OTDR license
packaged in it.

SVO Full License

Enable this check box to add the High Availability feature to the license package.High Availability

Enable this check box to add the Connection Verification feature to the license
package.

Connection Verification License

Enable this check box to add the Flex Spectrum feature to the license package.
For SSON networks, Flex Spectrum license is enabled by default.

Flex Spectrum License

Enable this check box to add the OTDR feature to the license package.OTDR License

3rd party NMS

Enable this check box to add NBI (North Bound Interface), Alarm Correlation,
Performance Monitoring, and Circuit Provisioning features to the license
package.

3rd party Full License

Enable this check box to add the NBI feature to the license package.NBI

Enable this check box to add the Alarm Correlation feature to the license
package.

Alarm Correlation

Enable this check box to add the Performance Monitoring feature to the license
package.

Performance Monitoring

Enable this check box to add the Circuit Provisioning feature to the license
package.

Circuit Provisioning

Step 6 Click Update.

Add Contentionless Side to a Site
Contentionless functionality on a site refers to the contentionless add or drop ability of an N-degree ROADM
node to accommodate N wavelengths of the same frequency from a single add or drop device. For a ROADM
to be contentionless, the number of drop units must be equal to ROADM degrees.

Use the following procedure to add contentionless sides to a ROADM or traffic site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click the network in which you want to add contentionless sides to a site.
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The network opens.

Step 3 Choose Network > Entity Editor.
Step 4 Click the site to which you want to add contentionless sides.
Step 5 Click the Add Contentionless Side icon.
Step 6 Enter the appropriate value in the Enter number of contentionless sides field.

The number of contentionless sides that can be added to a site depends on the type of site, the Scalable Upto Degree
property. The following table explains the same.

Table 18: Contentionless Sides for Layer-1 SMR

Number of Contentionless SidesScalable Upto DegreeSite Type

164SMR-20

128SMR-20

812SMR-20

416SMR-20

8LineSMR-20

8TerminalSMR-20

54SMR-9

18SMR-9

Step 7 To add layer-2 SMR-20 contentionless sides, perform the following steps:
a) Check the Evolved Mesh check box.
b) Choose Site Type as SMR-20 or Auto.
c) Check the Cascaded SMR check box.
d) Choose Degree Mesh Type as DEG-5/UPG-4.
e) Click Update.

You can add 20 more contentionless sides on each site for layer-2 SMR.

Step 8 Click OK.

Modify Number of Contentionless Side Ports for a Site
Use this task to modify the number of contentionless ports for a side in a ROADM site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.
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Step 2 Click the network in which you want to modify the number of contentionless ports for a side in a ROADM site.

The network opens.

Step 3 Choose Network > Entity Editor.
Step 4 Expand a ROADM site and select a contentionless side.

You can view the properties of the side in the right panel.

Step 5 From the Contentionless Ports drop-down list, choose the required number of ports.

Click Update.

Modify Fiber Properties
Use this task to modify the properties of fiber.

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 In the network tree, expand Fiber, and click a fiber.

You can view the basic properties of the fiber at the bottom of the network tree.

Step 2 Modify the following fiber properties as required.

DescriptionProperty

General

By default, the name of the fiber is based on the number of fibers between the source and
destination sites. You can edit the name.

Name

Displays the source site name. This field is noneditable.Source

Displays the destination site name. This field is noneditable.Destination

Indicates whether standard single fiber is used to transmit the data in both directions.Bidirectional
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Select the fiber type. Cisco ONP supports the following fibers, and the default fiber type
is G652-SMF.

• G652-SMF-28E

• TWR

• MC

• TWPlus

• TWMinus

• TWClassic

• FL

• TL

• G652-SMF

• ELEAF

• True wave

Fiber Type

Displays the span length of the fiber connecting a source and destination site. If necessary,
change the span length manually.

• The Cisco ONP tool automatically updates the fiber length based on the actual
geographical map. If you change the fiber length, then the Cisco ONP tool updates
the same in the network tree and the map accordingly for the first time. Later, the
fiber length does not change, when you drag and drop the sites in the map.

• In the network tree pane, expand Fiber and select the fiber couple, A-Z and Z-A.
The properties pane displays the fiber couple name, source side, destination side, its
span length, loss, and, Polarization Mode Dispersion (PMD) value.

• You can enter the different span length and loss values for the individual fibers in a
fiber couple.

Length

Displays the status of the network, whether the network is being deployed or not. If the
network is not deployed, it shows the status as UNDISCOVERED.

Network status

Displays the status of the fiber in a business perspective view. If fiber is not deployed, it
shows the status as FUTURE. This field is noneditable.

Business status

Choose the measurement unit (Km or Miles) for the fiber span. You can set the
measurement unit only for the duct, but not for the fiber pair (couple) or fiber.

Measurement Units

Enter the aging loss value for the fiber.Aging Loss [dB]

Check this check box to enable the default use of data connection network (DCN) extension
on each span in the project. This setting implies that the optical service channel (OSC)
channel is not used to connect the two nodes.

DCN Extension
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Choose the OSC frame type. The options available are:

• Auto

• OC3 Frame

• GE Frame

• FE Frame

The default option is Auto. When set in Auto, Cisco ONP uses FE Frame as the preferred
frame type.

OSC FrameType

Enter the number to fiber aging factor.Aging Factor

Physical

The fiber loss value is automatically calculated based on length and loss coefficient, when
you check this option.

Length-Based Loss

Enter the start of life fiber loss value for each span, excluding the connector concentrated
loss.

Tot SOL Loss w/o
connectors

Factors

Enter the value of the SOL fiber loss per kilometer used to calculate the loss of each span
in the network.

Loss[dB]

Raman Amplification

Enable Raman Amplification on the ducts.

When you enable Raman amplification, the side property Enable C+L Band
S/C is automatically disabled.

Note

Raman Amplified

Step 3 Click Update.
Step 4 To modify advanced properties of the fibers, click Show Advanced Properties, or choose Network > Entity Editor.
Step 5 Click the FIBER tab in the Entity Editor window.
Step 6 Choose the fiber and modify the following properties in the right pane.

DescriptionProperty

General

Enter the aging loss value.Aging loss

Enable the default use of data connection network (DCN) extension on each span in the
network.

DCN Extension

Choose the OSC frame type. The options available are Auto, OC3 Frame, Gigabit Ethernet
Frame, and Fast Ethernet Frame. The default option is Auto. When set in Auto, Cisco ONP
uses Fast Ethernet Frame as the preferred frame type.

OSC Frame Type
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Enter the number to factor fiber aging. This factor is multiplied by the SOL total span loss
without connectors.

Aging Factor

Physical

Connector Loss at Source Site [dB]Connector Loss A

Connector Loss at Destination Site [dB]Connector Loss B

Factors

Loss is calculated based on the loss coefficient.Loss Coefficient
[dB/km]

Displays the secondary order dispersion for C-band.QD C-Band

Displays the secondary order dispersion for L-band.CD C-Band

Displays the random dispersion value.RD Factor

Extended

Displays the effective mode area [µm^2]Effective Mode Area

Displays the Stimulated Raman Scattering tilt coefficient on the band.SRS tilt coefficient

Displays the Rayleigh Scattering capture coefficient.DRBS coefficient

Nonlinear index of refraction [1e-16 cm^2/W]N2

Length of individual fibers for sigmaDSP [Km]LFBR

Totals

(The properties under Totals are noneditable)

Displays the Polarization Mode Dispersion (PMD) value.PMD

Displays the total loss EOL calculation.Loss EOL

Displays the total loss SOL calculation.Loss SOL

Displays the total chromatic dispersion for the C-band.CD C-Band

Displays the secondary order dispersion for C-band.QD C-Band

Displays the random dispersion value.RD

Step 7 Click Update.
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Modify Fiber Couple Properties
Use this task to modify properties of the fiber couple.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Fiber, and drill down up to a fiber couple and click the fiber couple.

You can view the basic properties of the fiber couple at the bottom of the network tree.

Step 2 Modify the following fiber couple properties as required.

DescriptionProperty

General

By default, fiber couple is named based on the fiber name followed by COUPLE-AZ or
COUPLE-ZA. The sides that are connected by the fiber couple are indicated inside
brackets. The name is noneditable.

Name

Displays the source side name. This field is noneditable.Source Side

Displays the destination side name. This field is noneditable.Destination Side

Automatically displays the span length of the fiber connecting a source and destination
side. Change the span length manually, if necessary.

You can enter the different span length and loss values for the individual fibers in a fiber
couple.

Length

Physical

Enter the start of life fiber loss value for each span, excluding the connector concentrated
loss.

Tot SOLLoss w/o connectors

Factors

Enter the value of the SOL fiber loss per kilometer used to calculate the loss of each span
in the network.

Loss coefficient [dB]

Totals

Displays the total loss SOL calculation.Loss SOL

Displays the total loss EOL calculation.Loss EOL

Step 3 Click Update.
Step 4 To modify advanced properties of the fiber couple, click Show Advanced Properties, or choose Network > Entity

Editor.
Step 5 Click the FIBER tab in the Entity Editor window.
Step 6 Choose the fiber and drill down to the fiber couple, and modify the following properties in the right pane.
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DescriptionProperty

Physical

Connector Loss at Source Site [dB]Connector Loss A

Connector Loss at Destination Site [dB]Connector Loss B

Factors

Displays the PMD coefficient.PMD coefficient

Totals

(The properties under Totals are noneditable)

Displays the PMD value.PMD

Displays the total loss EOL calculation.Loss EOL

Displays the total loss SOL calculation.Loss SOL

Displays the total chromatic dispersion for the C-band.CD C-Band

Displays the secondary order dispersion for C-band.QD C-Band

Displays the random dispersion value.RD

Step 7 Click Update.

Modify Service Properties
Use this task to modify the properties of the service.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Services and click a service.

You can view the basic properties of the service at the bottom of the network tree.

Step 2 Modify the following service properties as required.

DescriptionProperty

General

By default, the service name is based on the source and destination sites and the number of services between
them. You can edit the name.

For example, if there are two services between site 1 and site 2, the names of the services are Site-1-Site-2-1
and Site-1-Site-2-2, respectively.

Name
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DescriptionProperty

Choose the types of service.Type

Choose the protection type from the drop-down list. Options available are:

• Unprotected

• 1+1

• Disjoint

• S+NS

• 1+R

• 1+1+R

• 1+1+R+R

For more information on protection types, see Supported Protection Schemes , on page 3.

Protection

Displays the source site name.Source

Displays the destination site name.Destination

Step 3 Click Update.
Step 4 To modify advanced properties of the service, click Show Advanced Properties or choose Network > Entity Editor.
Step 5 In the Entity Editor window, click the Service tab.
Step 6 Choose the service under the network tree, and modify the following properties in the right pane.

DescriptionProperty

General

From the drop-down list, select the possible site as a tertiary source.Tertiary Source

From the drop-down list, select the possible site as a tertiary destination.

Tertiary source and tertiary destination are enabled only when you select the protection
scheme as Unprotected Disjoint.

You can select either tertiary destination or both tertiary source and tertiary destination.

• If you select only the tertiary destination, the demand is created between the
source and destination and between the source and tertiary destination. These
do not have common fibers in the path, which are disjoint.

• If you select both tertiary source and tertiary destination, two unprotected
demands are created between the source to destination, and tertiary source to
tertiary destination. The demands are disjoint to each other.

Tertiary Destination

Primary Path Forcing

Cisco ONP automatically selects the shortest path as working path and also allows
you to force the path manually.

Path
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DescriptionProperty

Primary path fiber is forcing path for working trail.Fiber

Displays the platform of the regeneration siteRegeneration Platform

Choose the regeneration site.Regen Sites

Click Edit to choose the wavelength. The default option is Auto.Wavelength

Enter the ODU timeslot value.ODU Timeslot

Displays the selected Wavelength.Section Wavelength(s)

Choose the type of source channel. The available options are:

• Auto—This is the default option. Auto option is the contentionless demand.

• Contentionless

• Colorless

• Colored

Src Channel Type

Choose the type of destination channel.Dst Channel Type

Secondary Path Forcing (Available only for (1+1)

Secondary path is the protected path when the primary path fails. This path is the
second best path after the primary path.

Path

Secondary path fiber is for protected service, forcing path for the protected trail.Fiber

Displays the platform of the regeneration siteRegeneration Platform

Choose the regeneration site.Regen Sites

Click Edit to choose the wavelength. The default option is Auto.Wavelength

Enter the ODU timeslot value.ODU Timeslot

Displays the selected Wavelength.Section Wavelength(s)

Choose the type of source channel.Src Channel Type

Choose the type of destination channel.Dst Channel Type

Restoration 1 Path Forcing (Available for 1+R, 1+1+R, 1+1+R+R)

Cisco ONP automatically selects the first restoration path.Path

Choose the first restoration path fibers.Fiber

Restoration 2 Path Forcing (Available for 1+1+R+R)

Cisco ONP automatically selects the second restoration path.Path
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DescriptionProperty

Choose the second restoration path fibers.Fiber

• Ensure that you force both primary and secondary path fiber or channel for protected service. Also
ensure that the wave type is same for both primary and secondary paths.While doing path forcing, make
sure that you perform an end-to-end path forcing from the source to the destination. Analysis fails if
the partial path is forced.

• Force the wave path for the wave, which is tagged to the service.

• In case of protection type: 1+1+R+R, 1+1+R, and 1+R, you can force a path in restoration path1 or
restoration path2 Fiber that is forced in primary or secondary path Fiber.

Note

Step 7 Click Update.

Services Aggregation
Table 19: Feature History

Feature DescriptionRelease InformationFeature Name

Services aggregation feature allows
two or more services to share the
same trunk port or channel. By
default, the services are added to
the DefaultGroup. You can also
export the aggregation reports.

Cisco ONP Release 4.1Services Aggregation

Services aggregation indicates whether two or more services can share the same trunk port or channel. The
aggregation is defined based on the properties of the Service Group. When you add services to the Traffic
site (of the type 1K-2K-4K) in an SSON network, aDefaultGroup is created under the Services in the network
tree. The services that you add, are associated to the DefaultGroup.

Create a New Service Group
Use this task to create a new service group:

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Click a network, where you want to create a new service group.

The network opens.
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Step 3 Right-click Services under the network tree and choose Create Service Group.

A new service group gets created under the Services.

Modify Service Group Properties
Use this task to modify the properties of service group.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Services and click a service group.

You can view the basic properties of the service at the bottom of the network tree.

Step 2 Modify the following service properties as required.

DescriptionProperty

General

By default, Cisco ONP provides a servive group name. For example, Group-1. You can edit
the name.

For example, if there are two services between site 1 and site 2, the name of the services are
Site-1-Site-2-1 and Site-1-Site-2-2, respectively.

Name

Choose the demand type. For default group all demand types are available, and you cannot edit
them.

Demand Types

Indicates whether the service group is a default group or a user created group.Default Group

NCS 4 K

Indicates whether the services belonging to this group must have an exclusive Line Card (LC)
or not.

For example, when you check this check box, neither the Client LC nor the Trunk LC of the
services belonging to this group can be shared by services belonging to any other groups.

Exclusive LC Usage
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DescriptionProperty

Indicates whether this group allows aggregation of only symmetric services. Services are
symmetric if they have same protection scheme. Following are the various protection schemes:

• Unprotected

• 1+R

• 1+1

• 1+1+R

• 1+1+R+R

For Example, all “1+1” services are symmetrical.

If you check this check box, this service group allows aggregation of only symmetrical services.

For example, “Unprotected” can be aggregated only with “Unprotected”, “1+R” only with
“1+R”, “1+1” only with “1+1”, and so on.

If this check box is unchecked, this service group allows aggregation of symmetrical and
unsymmetrical services together.

For example, “Unprotected” can be aggregated with either “Unprotected”, “1+R”, “1+1”
“1+1+R” or “1+1+R+R”.

See Aggregation Rules, on page 92.

Symmetric
Aggregation

NCS 1 K

Same as NCS 4 K.Exclusive LC Usage

Same as NCS 4 K.Symmetric
Aggregation

Step 3 Click Update.

Aggregation Rules
Following are the rules for any two services (symmetrical or nonsymmetrical) to be aggregated:

• The services must have the same Source and Destination.

• The services must have same paths for the same path types.

For example:

• For symmetric aggregation between two “1+1” services, the working path of the first service must
match with the working path of the second service and the protection path of the first service must
match with the protection path of the second service.

• For non-symmetric aggregation between “1+1” and “1+1+R” services, the working path of the first
service must match with the working path of the second service and the protection path of the first
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service must match with the protection path of the second service. The restoration path of second
service can be anything.

• The services must be configured to use same wavelength for same path types.

• If the wavelength is set to “auto”, it is flexible to be aggregated with other “auto" wavelength or a fixed
wavelength.

• The services must be configured to use same trunk mode for same path types.

• The services must be configured to use same regeneration sites for same path types.

Demand Type is not used as a constraint for aggregation (except for trunk capacity availability).Note

Associate a Service to the Newly Created Group
By default, the services are associated to the DefaultGroup. But you can change the group.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, click the service that you want to associate to a group.

You can view the basic properties of the network at the bottom of the network tree.

Step 2 Choose the group from the Service Group drop-down list.
Step 3 Click Update.

For an LNI imported network, by default, all the services are present in the Default group. Only when you
upgrade the LNI imported network for the first time, you can move the services to other newly created Service
Groups without having to unlock them. On subsequent upgrades, you must unlock the services to facilitate
the movement between Service Groups. Also, the Service Groups are in locked state in the upgrade mode,
unless a complete Network-level unlock has been performed.

Note

What to do next

Export Aggregation Reports
Use this task to export the service aggregation reports:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.
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The Select Network To Open dialog box appears.

Step 2 Click an analyzed network.

The network opens.

Step 3 Choose Export > Service Aggregation.
Step 4 Save the aggregation report in the form of an Excel sheet to your local system.

Modify Wave Properties
Use the following task to modify the properties of the wave.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Waves, and click a wave.

You can view the basic properties of the wave at the bottom of the network tree.

Step 2 Modify the following wave properties as required.
Step 3 Click Update.

Modify Media Channel Properties
Use the following task to modify properties of the media channel.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Media Channels, and click a media channel.

You can view the basic properties of the media channel at the bottom of the network tree.

Alternatively, you can chooseNetwork >Entity Editor > Services, expandMedia Channels, and click a media channel
to view the properties.

Step 2 Modify the following properties as required.

DescriptionProperty

General
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DescriptionProperty

By default, the media channel is named based on the source and destination sites and the number of
media channels between them. You can edit the name.

For example, if there are twomedia channels between site 1 and site 2, they are named as Site-1-Site-2-1
and Site-1-Site-2-2, respectively.

Label

Displays the source site name.Source Site

Displays the destination site name.Destination
Site

Choose the traffic type from the drop-down list. The available options are:

• Optical Source

• 100GE

• 10GE LAN PHY

• 40GE LAN PHY

• Fiber Channel 10G

• Fiber Channel 16G

• Fiber Channel 8G

• OC-192/STM-64

• OTU2

• OTU2e

• OTU4

• Pluggable Card

Traffic Type

Choose the protection type.

• Unprotected

• Client 1+1

For more information on protection types, see Supported Protection Schemes , on page 3.

For Client 1+1, ensure that the sites have contentionless sides for the analysis to be successful. By
default, Cisco ONP finds both span and node disjoint path for Client1+1 protected waves, but allows
you to force span and node disjoint path.

Protection
Type

Check this check box to change a present wave to a forecast wave.Forecast

Check this check box to enable encryption.Encryption

Step 3 Click Update.
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Modify Trail Properties
Use this task to modify the properties of the trail.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Waves, or Media Channels, drill down up to trail and click a trail.

The basic properties of the trail are displayed at the bottom of the network tree.

Step 2 Modify the following trail properties as required.

DescriptionProperty

General

Displays the name of the trail. You can edit the name.Label

Select a fiber from the drop-down list.Path of Wave

Select the regeneration site.Regen Sites

Displays the source site name.Source Site

Displays the destination site name.Destination Site

Click Edit to choose the wavelength. The default option is Auto.Wavelength

ClickEdit to choose the central wavelength. The default option is Auto.Central
Wavelength

Indicates whether the transmission is a multicarrier transmission.Multicarrier

Choose the trunk mode from the drop-down list.Trunk Mode

Step 3 To modify the advanced properties of the trail, click Show Advanced Properties or choose Network > Entity Editor.
Step 4 In the Entity Editor window, click the Service tab.
Step 5 ExpandWaves, orMedia Channels, under the network tree, drill down to the trail, click the trail, and modify the following

properties that are displayed in the right pane.

DescriptionProperty

General

Displays the forward optical signal to noise ratio.OSNR Forward [dB]

Displays the reverse optical signal to noise ratio.OSNR Reverse [dB]

Indicates whether colorless functionality is enabled on the trail.Colorless

Indicates whether omni-directional functionality is enabled on the trail.Omni-directional
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DescriptionProperty

Indicates whether contentionless functionality is enabled on the trail.Contentionless

Displays the value of the penalties that are caused by the different filter types (OADM, and
ROADM).

Filtering Penality

OTN

Displays the first Optical Data Unit.First ODU

Displays the last Optical Data Unit.Last ODU

Displays the SRLGs associated with the trail.SRLGs

Displays the number of OTN hops.OTN Hops

Displays the number of OTN services on the trail.Quantity

Source

Choose the card used in the source site. See Supported Cards and Pluggables, on page 149 and
Supported Optical Sources, on page 161 for more information on the list of supported cards.

Src Card Type

Choose the pluggable from the drop-down list. The pluggables suitable for the chosen card type
are displayed.

See Supported Cards and Pluggables, on page 149 for more information on the list of supported
pluggables.

The pluggable FR-1(QSFP-100G-FR-S) is supported on the client ports of the 400G-XP LC
starting from NCS 2000 Release 11.1.0.

Src Client Interface

Choose the type of source channel. The available options are:

• Auto

• Contentionless

• Colorless

• Colored

Src Channel Type

Choose the trunk type from the drop-down list.Src Trunk Type

Choose the contentionless side from the drop-down list.Src Contentionless
Side

Destination

The destination card type is auto populated based on the source card type chosen.Dst Card Type

Choose the pluggable from the drop-down list. The pluggables suitable for the chosen card type
are displayed.

Dst Client Interface

Choose the trunk type from the drop-down list.Dst Trunk Type
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DescriptionProperty

Choose the type of the destination channel. The available options are:

• Auto

• Contentionless

• Colorless

• Colored

Dst Channel Type

Choose the contentionless side from the drop-down list.Dst Contentionless
Side

Step 6 Click Update.

Modify Section Properties
Use this task to modify properties of the section.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, expand Waves, drill down up to section and click a section.

You can view the basic properties of the section at the bottom of the network tree.

Step 2 Modify the section properties as required.

Section and trail have the same properties. Refer Modify Trail Properties, on page 96 for the descriptions of the properties.

Step 3 Click Update.
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Modify Side Properties
Table 20: Feature History

Feature DescriptionRelease InformationFeature Name

Cisco ONP supports the passive
module, NCS2K-MF-CL-SC (C
and L-band combiner and splitter),
starting from the NCS 2000 system
release 12.2 for SSON and
non-SSON networks. This feature
enables combining C and L band
wavelengths.

Cisco ONP Release 4.2Support for NCS2K-MF-CL-SC (C
and L-band combiner and splitter)

Use this task to modify the properties of a side in a site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, Choose Sites > Site > Site domain > Side.
Step 2 To modify the side properties, perform the following steps:

a) Click Show Advanced Properties.
b) In the right pane of Entity Editor window, modify the following properties of the side.

You cannot edit the properties of the Pass through site side.Note

DescriptionProperty

General

Displays the label of the side.Label

Displays the type of the side. The available options are:

• Line

• Contentionless

Type

Enter the number of colorless ports.Colorless Ports (Displayed for Line side)

Choose the number of contentionless ports.Contentionless Ports (Displayed for Contentionless side)
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DescriptionProperty

Cisco ONP supports the passive module,
NCS2K-MF-CL-SC (C and L-band combiner and splitter),
starting from the NCS 2000 system release 12.2 for SSON
and non-SSON networks. Check this check box to enable
the NCS2K-MF-CL-SC card. This card is supported for
ROADM, OLA, and traffic nodes, but not on the
passthrough node.

When you enable this option on a side:Note

• It is automatically enabled on the side
that is connected to the selected side
through a fiber.

• The fiber property Raman Amplified is
automatically disabled, and the
opposite way.

• This card introduces a certain amount
of attenuation and insertion loss that is
reflected in the ANS parameters.

The NCS2K-MF-CL-SC module does not
appear in the layout.

Enable C+L Band S/C (Displayed for Line side type)

c) Click Update.

Modify C-Band Amplifier Properties
Table 21: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to edit the
crosstalk values of the Raman COP
amplifier in the SSON network,
starting from NCS 2000 Release
11.1.

Cisco ONP Release 4.1Manual Editing of Raman COP
values
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Table 22: Feature History

Feature DescriptionRelease InformationFeature Name

The Inline Amplifier option allows
you to enable an inline amplifier in
the network. You can simulate the
optical feasibility of the network
with and without an inline
amplifier. Based on the colorless or
colored add/drop type selected and
the QSFP-DD pluggable status, a
default inline amplifier is enabled
for the network.

Cisco ONP Release 4.2Inline Amplifier

Use this task to modify the properties of a c-band amplifier in a site.

Make sure that SMR card is forced on the site before you update the c-band amplifier properties.Note

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 In the network tree, choose Sites > Site > Site domain > Side > C-Band.
Step 2 To modify the amplifier properties, perform the following steps:

a) Click C-Band Amplifier.

You can view the properties of the C-Band Amplifier at the bottom of the network tree. For more information, see
Supported Amplifiers, on page 165.

b) Modify the following properties of the amplifier:

You can also modify the properties by choosing the C-Band Amplifier under Network > Entity Editor.

DescriptionOptions

General

The default value is Auto. You can enter a value.Raman COP Tilt

The default value is Auto. You can enter a value.Pre Tilt

The default value is Auto. You can enter a value.Raman Tilt

The default value is Auto. You can enter a value.Booster Tilt
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DescriptionOptions

Inline Amplifier
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DescriptionOptions

Choose whether inline amplifier can be forced. The
available options are:

• Yes―EDFA17 or EDFA35 amplifier is chosen as
the default amplifier when you choose colored
add/drop module MD-64-C or colorless add/drop
MF-6AD-CFS, respectively. See Modify Add/Drop
Multiplexer Properties, on page 108.

• No―No amplifier can be forced.

• Auto

• EDFA17 amplifier is chosen as the default
amplifier when any one of the demands
aggregated in MD-64-C has low launch power
optical resource or QSFP-DD pluggable is
forced.

• EDFA35 amplifier is chosen as the default
amplifier when any one of the demands
aggregated in MF-6AD-CFS has low launch
power optical resource or QSFP-DD pluggable
is forced.

When you configure
MF-6AD-CFS+EDFA35 in an SSON or

Note

non-SSON network, the optical results show
system error for the demands of the same or
different types. This error affects the what-if
analysis. Hence we recommend choosing
the appropriate channel and client
attenuators so that the inline amplifier works
at the proper gain range.

You can view the amplifier added in the IPC, BOM, and
Layout tabs, after the successful analysis.

Note • When you add a QDD demand while
upgrading a network where the Inline
Amplifier property is set as no, the
inline amplifier can be included in the
network only if you unlock the side and
set the Inline amplifier property asAuto
or Yes.

• Default colorless configuration does
not require inline amplifier.

• When there are no demands passing
through the colored or colorless
Add/Drop device, the forced Inline
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DescriptionOptions

amplifier is not placed.

From Fiber

Choose a preamplifier from the drop-down list. The
default value is Auto. To enable this field for ROADM
and Traffic nodes, you must choose SMR-9 or SMR-20
from the Site Type drop-down list under the Site
properties.

If you choose SMR-9, the available options are:

• SMR9-FS-EDFA17-PRE

• SMR9-FS-EDFA24-PRE

• SMR9-FS-EDFA24-PRE

If you choose SMR-20, the available options are:

• SMR20-FS-EDFA17-PRE

• SMR20-FS-EDFA24-PRE

For the OLA site, the available options are:

• EDFA35-35-PRE

• EDFA35-24-PRE

• OPT -EDFA-17

• OPT -EDFA-24

Pre Amp

The default value is Auto. You can enter a value.Output Power

This field is enabled only when you choose a preamplifier.
Choose an attenuator from the drop-down list. The
available options are:

• ATT-LC-2

• ATT-LC-3

• ATT-LC-5

• ATT-LC-7

• ATT-LC-10

• ATT-LC-12

• ATT-LC-15

• ATT-LC-18

Attenuator In
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DescriptionOptions

This field is enabled only when you choose a preamplifier.
Choose an attenuator from the drop-down list. The
available options are:

• ATT-LC-2

• ATT-LC-3

• ATT-LC-5

• ATT-LC-7

• ATT-LC-10

• ATT-LC-12

• ATT-LC-15

• ATT-LC-18

Attenuator Out

To Fiber

The default value is Auto. To enable this field for
ROADM and Traffic nodes, you must choose SMR-9 or
SMR-20 from the Site Type drop-down list under the
Site properties.

If you choose SMR-20, the default booster is
20SMR-FS-BST.

If you choose SMR-9, default booster is
SMR9-FS-EDFA-BST.

For the OLA node, the available options are:

• EDFA35-35-BST

• EDFA35-24-BST

• OPT -EDFA-17

• OPT -EDFA-24

Booster

The default value is Auto. You can enter a value.Output Power
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DescriptionOptions

This field is enabled only when you choose a booster.
Choose an attenuator from the drop-down list. The
available options are:

• ATT-LC-2

• ATT-LC-3

• ATT-LC-5

• ATT-LC-7

• ATT-LC-10

• ATT-LC-12

• ATT-LC-15

• ATT-LC-18

Attenuator In

This field is enabled only when you choose a booster.
Choose an attenuator from the drop-down list. The
available options are:

• ATT-LC-2

• ATT-LC-3

• ATT-LC-5

• ATT-LC-7

• ATT-LC-10

• ATT-LC-12

• ATT-LC-15

• ATT-LC-18

Attenuator Out

Raman Amplification

Cisco Optical Network Planner Configuration Guide, Release 4.2
106

Modify Network Properties
Modify C-Band Amplifier Properties



DescriptionOptions

Choose the Raman amplifier from the drop-down list.

To force the RAMAN amplifier, you must
enableRAMAN amplified on the fiber, else
the Raman Amp is disabled, and network
analysis fails.

Note

The available options for ROADM and Traffic sites are:

• RAMAN-CTP

• RAMAN-COP-CTP

Raman Amp can be forced only between two nodes.

The available options for the OLA site are:

• EDRA1-26

• EDRA1-35

• EDRA2-26

• EDRA2-35

• RAMAN-CTP

Raman Amp

Enter a value.Raman CTP Gain

Enter a value. This field is enabled only when you choose
RAMAN-COP-CTP.

Raman COP Gain

By default, this option is disabled. Enable it to edit the
crosstalk values of the Raman COP amplifier.

Static data is supported from Release 11.1
for SSON network.

Note

Static Data

Edit the value of average linear crosstalk.Linear XT Avg

Edit the value average linear crosstalk sigma.Linear XT Six

Edit the value of average nonlinear crosstalk.NonLinear XT Avg

Edit the value of average nonlinear crosstalk sigma.NonLinear XT Sig

Raman crosstalk values are present in the ANS file under logoparameters section.Note

c) Click Update.
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Modify Add/Drop Multiplexer Properties
Table 23: Feature History

Feature DescriptionRelease InformationFeature Name

You can create and validate network designs by choosing colored
and colorless add/drop multiplexers and demultiplexers, and
interlever under C-Band > Add/Drop. The following options
are supported in this release:

Cisco ONP Release
4.2

Modify Properties of
Add/Drop
Multiplexer and
Demultiplexer

Network SupportedOptionsType of Add/Drop

• SSON

• Non-SSON

• Direct SMR

• MF-6AD-CFS

Colorless

• SSON

• Non-SSON

• MD-64-C

• MD-48-ODD

• MD-48-EVEN

• MD-48-ODD+
MD-48-EVEN

Colored

• Non-SSON• MpoCable

• MD-48-CM

Interlever

Use this task to modify the properties of the add/drop multiplexer in a site.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 In the network tree, Choose Sites > Site > Site domain > Side > C-Band.
Step 2 To modify the Add/Drop multiplexer card properties, perform the following steps:

a) Click Add/Drop.
You can view the properties of the add/drop multiplexer at the bottom of the network tree.

b) Modify the following properties of the add/drop multiplexer:
c) Click Update.

Modify Client Properties
Use this task to modify the properties of a client-side attenuator in a site.
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Before you begin

Table 24: Feature History

Feature DescriptionRelease InformationFeature Name

You can set up channel attenuators
for QSFP-DD demands. You can
choose different channel attenuators
based on the specific configuration
and check for the optical feasibility
of the channel.

Cisco ONP Release 4.2Channel Attenuators

Log in to Cisco ONP Web Interface, on page 6

Step 1 In the network tree, choose Sites > Site > Site domain > Side > Clients > Channel-Attenuators.
Step 2 In the right pane of the Entity Editor window, modify the following properties of the client-side attenuator.

DescriptionOptions

General

This column displays the selected wavelength.Wavelength

Choose an RX-Attenuator from the drop-down list. The
default option is Auto.

Youmust select a wavelength to edit this field.Note

RX-Attenuator

Choose a TX-Attenuator from the drop-down list. The
default option is Auto.

Youmust select a wavelength to edit this field.Note

TX-Attenuator

Click Edit to select a Flex Grid or Fixed Grid wavelength.

Select Fixed Grid (64-Chs) for SSON
network with NCS1K-MD-64-C card.

Note

NCS1K-MD-64-C card has First Channel
limitation for Colored sites. First Channel
(196.1 THz) in Fixed Grid (64-Chs)
wavelength supports only Terminal Add/Drop
sites and not ROADM sites.

Note

New Wavelength - Auto

Step 3 Click Update.

Cisco Optical Network Planner Configuration Guide, Release 4.2
109

Modify Network Properties
Modify Client Properties



Sort the Network Elements
You can sort the sites, services, fibers, waves, and SRLG in ascending or descending order. This feature is
helpful for huge networks, to find out the required site, fiber, waves, or SRLG names quickly. Right-click the
network element, for example Sites and choose Ascending or Descending. You can sort based on alphabets,
numbers, or alphanumeric.

Regeneration Support
In optical networks, as the fiber length increases, a loss in the signal ratio and power could occur due to
attenuation and dispersion. You require a regenerator to recreate the weak and distorted optical signals through
reamplification, regeneration, and retiming processes. The regenerators remove noise and distortion, convert
the optical signal to electrical signal, and then convert the signals back to optical signals (OEO conversion).
Cisco ONP supports creation of regeneration sites in the network.

A regenerator site can only be a ROADM site.Note

Create a Regeneration Site
Table 25: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to assign
different wavelengths for different
sections of the Regen sites.

Cisco ONP Release 4.1Wavelength Forcing at the Section
Level

Use the following procedure to create a regeneration site in the network.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Choose File > Open.

The Select Network To Open dialog box appears.

Step 2 Select a network from the list of networks. This opens the selected network’s map.

You can also add a regeneration site when you are designing a new network or upgrading a network.

Step 3 In the network tree, expand Waves, select a wave and drill down to its trail.

If the network is an SSON network , you see Media Channels instead of waves. Expand Media Channels
, and drill down to its trail.

Note

Step 4 Click the trail.
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You can view the properties of the trail at the bottom of the network tree.

Step 5 From the Regen Sites drop-down list, select a regeneration site.

If you select a fiber from the Path of Wave drop-down list, you cannot select any regeneration site to force
a path. Similarly, if you select a regeneration site, you cannot force a path for the wave. However, if you
want to force a fiber, select the fiber from the Path of Wave drop-down list available under the section
properties.

Note

Step 6 (Optional) Select the wavelength of each section in the properties for non-SSON network.

For the SSON network, you can select the wavelength only at the trial level.Note

Step 7 Click Update.

A new section is added along with the existing section under the trail, whenever a regeneration site is created. Regeneration
can be performed using any two cards back-to-back or with a dedicated regenerator card.

Step 8 Click Analyze to analyze the network.

After analysis, if you click trail or section in the network tree, the map highlights the trail in orange color, and the section
in green color.

You can assign different wavelengths for different sections. The Central Wavelength is denoted as a *,
when different wavelengths are assigned for different sections.

Note

Multidegree ROADM
In multidegree ROADM, sites have two or more sides and face two or more fibers spans. You can select the
degree of a node from the Cisco ONP GUI. The values are 2, 4, 8, 12, and 16 for Evolved Mesh (EV) ON
and OFF scenarios. The default value is 4. Degrees 5, 9, and 13 are not supported. EV flag is editable.

Prerequisites for Cascaded SMR

• The Structure field under C Band in the Entity Editor must be Multidegree.

• The Site Type field under C Band in the Entity Editor must be SMR-20.

• The Evolved Mesh check box under General in the Entity Editor must be checked.

• The Degree Mesh Type field under C Band in the Entity Editor must be Auto or DEG-5/UPG-4.

• The Mpo16TOMpo8 field under General in the Entity Editor must be MPO16To2MPO8 cable.

• By default, the Cascaded SMR check box is unchecked, but you can edit in the design mode as a site
property. Check the Cascaded SMR check box for contentionless side creation. L2 SMR is supported
for both SSON and Non-SSON networks.

• You can edit theCascaded SMR check box whenEvolved Mesh is ON and the SMR-20 card is selected.
You can create Layer 2 SMR sides only after you check the Cascaded SMR check box.

• You can create contentionless sides manually and force the contentionless ports. The default value is 16
for the contentionless ports. The range of values is 0–16.
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Limitations

• Supports only contentionless add/drop demands.

• Supports Layer-2 SMR for SMR-20 card only.
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C H A P T E R 5
Configure a Network

This chapter describes the various ways of configuring the network designed through Cisco ONP.

• Configure a Network for Contentionless Functionality, on page 113
• Configure a Network for Colorless Functionality, on page 113
• Configure a Network for Colored Functionality, on page 114
• Configure a Network with Mixed Add/Drop Multiplexers and Demultiplexers, on page 115

Configure a Network for Contentionless Functionality
Use the following procedure to configure the contentionless functionality in a network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 19 .
Step 2 Add contentionless sides to the required sites. See Add Contentionless Side to a Site, on page 80.
Step 3 Set the channel type for the demands:

a) In the Entity Editor window, click the Services tab.
b) Click the service connecting the site and set the Src Channel Type property as Auto or Contentionless. Similarly,

click the trail under the wave (for non-SSON) or Media Channel (for SSON) and set the Src Channel Type property
as Auto or Contentionless.

Contentionless is the default option when you select Auto.Note

c) Click Update.

Step 4 Analyze the network by choosing Network > Analyze.

Configure a Network for Colorless Functionality
Use the following procedure to configure the colorless functionality in a network:
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Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 19 .
Step 2 Set the channel type for the demands:

a) In the Entity Editor window, click the Services tab.
b) Click the service connecting the site and set the Src Channel Type property as Colorless. Similarly, click the trail

under the wave (for non-SSON) or Media Channel (for SSON) and set the Src Channel Type property as Colorless.
c) Under the Site > Side properties, choose the Line type side from which you want to create the colorless demand, and

enter the number of Colorless Ports.

The number of colorless ports forMF-6AD-CFS depends on the Scalable Upto Degree property. The following table
explains the same.

Table 26: Colorless Ports for SSON and Non-SSON Networks

Maximum Number of Colorless
Ports for Non-SSON

Maximum Number of Colorless
Ports for SSON

Scalable Upto
Degree

Site Type

72724SMR-20

72728SMR-20

242412SMR-20

242416SMR-20

9696LineSMR-20

96120TerminalSMR-20

554SMR-9

d) Click Update.

Step 3 Under the C-Band properties, choose MF-6AD-CFS or Direct SMR as the Colorless Add/Drop.
Step 4 Click Update..
Step 5 Analyze the network by choosing Network > Analyze.

You can see the colorless Add/Drop unit getting added in the layout and BOM.

Configure a Network for Colored Functionality
Use the following procedure to configure the colored functionality in a network:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.
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Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 19 .
Step 2 Set the channel type for the demands:

a) In the Entity Editor window, click the Services tab.
b) Click the service connecting the site and set the Src Channel Type property as Colored. Similarly, click the trail

under the wave (for non-SSON) or media channel (for SSON) and set the Src Channel Type property as Colored.
c) Click Update.

Step 3 For SSON network, perform the following:
a) Under the C-Band properties, choose MD-64-C as the Colored Add/Drop.

MD-64-C is supported from NCS 2000 Release 12.x.Note

b) Click Update..

For non-SSON network, by default, MD-48-ODD or MD-48-EVEN is added as the Colored Add/Drop when Share
SMR Port is not enabled.

If you choose MD-48-EVEN or MD-48-ODD, make sure to select an even wavelength for the Wavelength
property under Trail.

Note

Step 4 When Share SMR Port port is enabled, you can select the Colored Add/Drop by using the following steps:
a) Under the C-Band properties, choose MD-48-ODD, MD-48-EVEN, or MD-48-ODD+MD-48-EVEN as the Colored

Add/Drop.

The above mentioned Add/Drop units are supported from NCS 2000 Release 11.x.Note

b) Click Update.

Step 5 Analyze the network by choosing Network > Analyze.

You can see the colored Add/Drop unit getting added in the layout and BOM.

Configure a Network with Mixed Add/Drop Multiplexers and
Demultiplexers

Use the following procedure to configure mixed wavelengths in a network:
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Table 27: Feature History

Feature DescriptionRelease InformationFeature Name

You can configure different
functionalities in the network created
in Cisco ONP. Mixed wavelengths
such as colorless and contentionless,
colored and contentionless, can be
added/dropped on the same side or
direction. The following mixed
configurations are supported:

• Colored
(MD-48-ODD/MD-48-EVEN)
and Contentionless
(16-AD-CCOFS)without shared
SMR port

• Colored and Contentionless
(MD-64-C and 16-AD-CCOFS)

• Colored (MD-64-C) and
Colorless (Direct SMR)

• Colored (MD-48) and
Contentionless (16-AD-CCOFS)
with Shared SMR Port

• Colorless and
MD-48-ODD/MD-48-EVEN

• Colorless and 16-AD-CCOFS

Cisco ONP Release 4.2Support for Mixed Add/Drop
Configuration

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Create a network design. See Design a Network Using Cisco ONP, on page 19 .
Step 2 Set the properties of the network under the Entity Editor for different combinations of the functionalities, as described

in the following table:
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Table 28: Supported Mixed Configurations

Properties to be SetPossible Mixed ConfigurationsSupported
Network Type

• Add required number of contentionless sides.

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colored for
one wave. Set the Src Channel Type and
Dst Channel Type to beContentionless for
the second wave created on the same site.
Both wavelengthsmust add/drop in the same
side or direction.

• By default, MD-48-ODD orMD_48-EVEN
is added as the Colored Add/Drop in the
BOM and layout, when you set theChannel
Type as Colored and when Shared SMR
Port is disabled.

By default, 16-AD-CCOFS is added in the
BOM and layout, when you set theChannel
Type as Contentionless.

Colored (MD-48-ODD/MD-48-EVEN) and
Contentionless (16-AD-CCOFS) without shared
SMR port

Non-SSON

• Add required number of contentionless sides.

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colored for
one media channel. Set the Src Channel
Type and Dst Channel Type to be
Contentionless for the secondmedia channel
created on the same site. Both channels must
add/drop in the same side or direction.

• Colored Add/Drop―MD-64-C under the
side.

Colored and Contentionless (MD-64-C and
16-AD-CCOFS)

SSON

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colored for
one media channel. Set the Src Channel
Type andDst Channel Type to beColorless
for the second media channel created on the
same site. Both channels must add/drop in
the same side or direction.

• Enter the number of Colorless Ports under
the Line Side properties.

• Colored Add/Drop―MD-64-C

Colorless Add/Drop―Direct SMR

Colored (MD-64-C) and Colorless (Direct SMR)SSON
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Properties to be SetPossible Mixed ConfigurationsSupported
Network Type

• Add required number of contentionless sides.

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colored for
one wave. Set the Src Channel Type and
Dst Channel Type to beContentionless for
the second wave created on the same site.
Both wavelengthsmust add/drop in the same
side or direction.

• Check the Shared SMR Port check box,
under the Site properties.

• Colored Add/Drop―MD-48-ODD,
MD-48-EVEN, or MD-48-ODD and
MD-48-EVEN

If you choose MD-48-EVEN, make sure to
select an even wavelength for the
Wavelength property under Trail.

Colored (MD-48) and Contentionless
(16-AD-CCOFS) with Shared SMR Port

Non-SSON

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colorless for
the wave.

• Enter the number of Colorless Ports under
the Line Side properties.

• By default, MD-48-ODD/MD-48-EVEN is
added as colored Add/Drop in the BOM and
layout, when any colored demand is added
in the non-SSON network.

Colorless and MD-48-ODD/MD-48-EVENNon-SSON

• Add required number of contentionless sides.

• Channel Type―Set the Src Channel Type
and Dst Channel Type to be Colorless for
the wave or media channel.

• Channel Type―Colorless for onewave and
Contentionless for another wave created on
the same site. Both wavelengths must
add/drop in the same side or direction.

Colorless and Contentionless (16-AD-CCOFS)SSON

MF-6AD-CFS colorless configuration cannot be mixed with any other configurations.Note

The following is the list of mixed configurations that are not supported by Cisco ONP.
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Table 29: Unsupported Mixed Configurations

Mixed ConfigurationsNetwork Type

Colored (MD-64-C) and Colorless (MF-6AD-CFS)SSON

Contentionless and Colorless (MF-6AD-CFS)SSON

Colored (MD-64-C), Contentionless, and Colorless
(MF-6AD-CFS)

SSON

Colored (MD-64-C) and Layer-2 ContentionlessSSON

Contentionless and Colorless (MF-6AD-CFS)Non-SSON

Colored (MD-48) and Colorless (MF-6AD-CFS)Non-SSON

Colorless (Direct SMR) and Colorless (MF-6AD-CFS)Non-SSON

Colored, Contentionless, and Colorless (MF-6AD-CFS)Non-SSON

Cisco Optical Network Planner Configuration Guide, Release 4.2
119

Configure a Network
Configure a Network with Mixed Add/Drop Multiplexers and Demultiplexers



Cisco Optical Network Planner Configuration Guide, Release 4.2
120

Configure a Network
Configure a Network with Mixed Add/Drop Multiplexers and Demultiplexers



C H A P T E R 6
View Network Reports

• Network Reports, on page 121

Network Reports
Cisco ONP provides network reports, which are listed under the report availability tabs. Reports are available
depending on whether a network is analyzed, or not. Reports are also available in site properties after analyzing
the network.

Cisco ONP provides the following reports:

• Dashboard

• Elements

• Map

• BOM

• Layout

• Results

The Cisco ONP home page has multiple tabs to access the reports of the analyzed network. You can also view
the reports for specific site, fiber, or wave properties by clicking the respective report in the Network Tree
pane.

View Reports in the Dashboard Tab
The Dashboard tab provides the total count of sites, fibers, SRLGs, services, waves/media channels, and
messages that exist in the network.

The Dashboard report shows incorrect count of 100G and 200G waves for transponder cards. You can view
the details in the Optical report and Traffic report.

Note
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View Reports in the Elements Tab
The Elements tab provides detailed reports of the network elements and messages.

DescriptionReport

Shows the site information, which consists of the name of the sites, type and
their X and Y coordinate values.

Sites

Shows the information about the fiber length between the source and the
destination for corresponding sites.

Fibers

Shows the service type, source and destination sites for particular service,
quantity, protection type, and status.

For each service, the report shows the primary path, secondary path, and their
status.

Services

The Waves report shows the number of waves available in the network and
the wave utilization. Click each wave to view the following details:

• Wave—Consists of a wave UID and its source and destination sites.

• Wave Details—Provides details of wave OSNR, channel path, OTN
services associated to wave and excluded channels.

• Channels—Port details of the source and destination cards, wavelength
that is used, and its utilization demands.

• Optical Results—Provides details of optical parameters such as OSNR,
SOL, EOL, Power margin, CD, and PMD.

Waves

Lists the names of created SRLGs and their fiber details. Click Export at the
bottom to export the report in .xlsx format.

SRLGs

Shows messages that are related to errors occurred while analyzing the
network. By default, only critical messages for the analyzed network are
listed here. You can disable the Critical Only toggle button to view all
messages.

Messages

Click the Pop-up icon to view the reports in a larger, resizable window.Note

Cisco Optical Network Planner Configuration Guide, Release 4.2
122

View Network Reports
View Reports in the Elements Tab



View Details of the BOM Report
Table 30: Feature History

Feature DescriptionRelease InformationFeature Name

The following new licensed PIDs
for the SMR-20 card are displayed
on the BOM page so that you can
view the price details and consider
ordering.

• NCS2K-FSSMR-2LIC=

• E-NCS2K-1P-LIC=

• E-NCS2K-5P-LIC=

• E-NCS2K-10P-LIC=

Cisco ONP Release 4.2Support for New PIDs for SMR-20
Card

Table 31: Feature History

Feature DescriptionRelease InformationFeature Name

This feature allows you to perform
the following:

• Compare the BOMs of two or
more LNI imported networks.

• Upgrade brownfield network.

• Upgrade the Cisco ONP
network with traffic sites.

Cisco ONP Release 4.1MLP Brownfield with Diff BOM

The BOM report consists of individual site price lists and the total BOM of the network. Click each site to
view BOM of OTN and DWDM separately.

You can compare the BOM of the existing network with other networks using the Compare with: Other
Networks option.

You can export the BOM details in the form of a spreadsheet, by clicking Export and saving it to your local
system.

We recommend that you export the BOM report only in the analyze mode. Exporting the reports in the upgrade
and release upgrade modes may be inaccurate.

You can also compare the BOM of LNI imported networks.Note
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From Release 4.2, Cisco ONP supports the listing of new licensed PIDs for the SMR-20 card. The PIDs are
chosen based on the demand. This is applicable only for the newly designed and upgraded networks.

• NCS2K-FSSMR-2-LIC=―20-port FS-SMR licensed to enable two ports

• E-NCS2K-1P-LIC=―Software license to enable one port on licensed 20-port FS-SMR

• E-NCS2K-5P-LIC=―Software license to enable five ports on licensed 20-port FS-SMR

• E-NCS2K-10P-LIC=―Software license to enable ten ports on licensed 20-port FS-SMR

Note

View Details of Layout and Internal Connections
To get the details of layout and internal connections, perform the following steps:

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the Layout tab on the Cisco ONP home page.
Step 2 Type the site name in the search box.

The site layout is displayed with its racks and cards. Hover the mouse pointer over the transponder card to view the details
of slot, PID of the card, and ports. Expand the Ports to view details, such as wavelength and trunk mode. Similarly, hover
the mouse pointer over chassis to know the total power consumption.

SVO supports up to 50 UIDs, beyond which, the site layout displays incorrect UID for the chassis.

Step 3 Click the ‘Orange Colored Double Arrow’ symbol on the top of search box to view Internal Connections. You can view
the patch details of every site.

Step 4 Click Export as png to export the layout as an image file.

Export Internal Connections
Cisco ONP allows you to export internal fiber connection in two ways, either at Site-level or Network-level.
To export the details, right-click the internal fiber connection or site, and click Export.

Compare the Installation Parameters of Two Networks
Table 32: Feature History

Feature DescriptionRelease InformationFeature Name

This feature improves the user
experience while comparing the
installation parameters and optical
reports of two networks.

Cisco ONP Release 4.1UI Revamp of Optical Reports
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Use this task to compare the installation parameters of two networks.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the Results tab on the Cisco ONP home page.
Step 2 Click Installation Parameters.
Step 3 Click Other Networks.
Step 4 From the list of networks, choose the network to compare with.

You can find a new parameter called diffBy.

You can click Clear to stop the comparison of two networks.Note

Compare the Optical Report of Two Networks
Use this task to compare the optical report of two networks.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.

Step 1 Click the Results tab on the Cisco ONP home page.
Step 2 Click Optical Report.
Step 3 Click Other Networks.
Step 4 From the list of networks, choose the network to compare with.

You can find two values in the optical parameters such as Protection, SOL, EOL, SE, P/F, Source, Src Colorless, Src
Contentionless, Destination, Dst Colorless, Dst Contentionless, Wavelength, Src Tx Type, Dst Tx type, Span, Suggested
Regen Locations, BER Target, SOL OSNR, EOL OSNR, SOL OSNR margin, EOL OSNR margin, SOL RX, EOL RX,
SOL Power Margin, EOL Power Margin, SOL Overload, EOL Overload, Residual CD, CD robustness, Single-Channel
NLE Status, Multi-Channel NLE Status, Min GB, Filtering Penalty, PMD, RX Atten, TX Atten, Encryption, SNLE
Components, MNLE Components, OSNR Penalties and POWER Penalties.

You can click Clear to stop the comparison of two networks.Note

View Optical Results
Use this task to view the details of optical reports, installation parameters, traffic reports, and cabling reports.

Before you begin

Log in to Cisco ONP Web Interface, on page 6.
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Step 1 Click the Results tab on the Cisco ONP home page.
By default, the Optical Report tab appears. Each row in the tab shows the performance of one optical path:

Optical Parameter

Displays the ID number of the wave and aggregated waves. ID is automatically generated
based on the site name.

Name

Displays the protection type of the wave.Protection

Displays an icon indicating the results summary of the analysis that is run with Start of
Life (SOL) fiber loss values:

• Green indicates success.

• Yellow indicates success with a marginal failure risk.

• Orange indicates that the channel has a higher risk of failure.

• Red indicates failure.

SOL

Displays an icon indicating the results summary of the analysis that is run with End of Life
(EOL) fiber loss values. The indicator shows the optical performance for the path at the
end of the fiber life:

• Green indicates success.

• Yellow indicates success with a marginal failure risk.

• Orange indicates that the channel has a higher risk of failure.

• Red indicates failure.

EOL

Indicates a system-related error that may impact the analysis of the design. If the indicator
is red, review the messages that are reported at the end of the analysis or determine which
units or sites have a problem.

SE

Displays the present or forecast services indication.P/F

Displays the name of the source site and side; for example, Site 1-E.Source

Displays whether the colorless functionality is enabled on source ports.Src Colorless

Displays whether the contentionless functionality is enabled on source ports.Src Contentionless

Displays the name of the destination site and side; for example, Site 1-E.Destination

Displays whether the colorless functionality is enabled on destination ports.Dst Colorless

Displays whether the contentionless functionality is enabled on destination ports.Dst Contentionless

Displays the wavelength of the optical channel.Wavelength

Displays the type of DWDM unit or pluggable port module that is used at the source of
the specific Optical Channel (OCH) trail. The class of the DWDM unit is also displayed.

Src Tx Type

Displays the type of DWDM unit or pluggable port module that is used at the destination
of the specific OCH Trail. The class of the DWDM unit is also displayed.

Dst Tx type
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Optical Parameter

Displays the total span length (source to destination) for this path in kilometers.Span

Displays the regeneration locations.Suggested Regen Locations

Displays the bit error rate (BER) target for this channel, based on the capability of the
channel’s optical interface. It is 1.0E-15 for the interfaces using forward error correction
(FEC) and 1.0E-12 for interfaces without FEC.

BER Target

Displays the start of life average Optical Signal to Noise Ratio (OSNR) value at the receiver.SOL OSNR

Displays the end of life average OSNR value at the receiver.EOL OSNR

Displays the SOL OSNR margin calculation. It is the difference between the OSNR value
at certain power of the working point of the receiver client and the working area boundary.

SOL OSNR margin

Displays the EOL OSNR margin calculation, which is the difference between the OSNR
value at a certain power of the working point of the receiver client and the working area
boundary.

EOL OSNR margin

Displays the SOL average power that is received at the destination site in dBm.SOL RX

Displays the EOL average power that is received at the destination site in dBm.EOL RX

Displays the SOL power budget margin at the receiver in decibels. It is defined as the
offset between the receiver working point and the BER curve with margin. A positive
value indicates that there are no power problems.

SOL Power Margin

Displays the EOL power budget margin at the receiver in decibels. It is defined as the
offset between the receiver working point and the BER curve with margin. A positive
value indicates that there are no power problems.

EOL Power Margin

Displays the SOL overload margin at the receiver in decibels. A positive value indicates
that there are no overload problems.

SOL Overload

Displays the EOL overload margin at the receiver in decibels. A positive value indicates
that there are no overload problems.

EOL Overload

Displays the chromatic dispersion (CD) margin of the demand.Residual CD

Displays the robustness to chromatic dispersion of the receiver.CD robustness

Displays the status of alarms if any nonlinear effect (NLE) is present in the demand.Single-Channel NLE Status

Provides the status of the nonlinear effect (NLE) on a particular channel or demand due
to other channels or demands.

Multi-Channel NLE Status

Displays the minimum Guard Band (GB) requirement between channels on the 40G
CP-DQPSKMXP and 40GCP-DQPSKMEMXP cards, and other transponders in a mixed
any-to-any connectivity.

Min GB

Displays the value of the penalties that are caused by different filter types (OADM,
ROADM, and arrayed waveguide grating (AWG)).

Filtering Penalty

Displays the calculated total Polarization Mode dispersion (PMD) for each circuit. If the
overall PMD for the link overcomes the maximum that is allowed, the PMD value is
displayed in a red-colored font. Themaximum allowed value depends on the client interface.
For these special cases, the network must be manually resolved by contacting a Cisco TAC
team.

PMD
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Optical Parameter

Displays the attenuation at the input of the receiver.RX Atten

Displays the attenuation at the output of the receiver.TX Atten

Displays the encryption type of the channel. Possible values are N/A, Yes, No.Encryption

Step 2 Click Export Report to export the optical reports details in an Excel sheet.

We recommend that you export the optical report only in the analyze mode. Exporting the reports in the upgrade and
release upgrade modes may be inaccurate.

Step 3 Click the Installation Parameters tab.

The Installation Parameters report shows the values to be set (provisioned) at the installation time on each site in the
network.

You can view the installation parameters for ANS (automatic node setup), and ANP (automatic node provisioning), for
each side of the Network Element (NE) in all the sites:

Step 4 Click the ANS tab to view the following parameters:

Table 33: ANS Parameters

DescriptionParameter

Displays the name of the siteName

Displays the line sideSide

Displays the rack, shelf number, and slot position of the card where the patch cord originates.Position

Displays the name of the card.Unit

Displays the port number where the patch cord originates.Port

Displays the port ID.Port ID

Displays the name of the port.Port Label

Displays the name of the parameter to be set, such as RX Power Low.Parameter

Displays the name of the value to be set for the parameter.Value

Displays the measurement unit for the related installation parameter value, such as dBm.Measurement
Unit

Indicates with a Yes or Nowhich parameters must bemanually set using the Cisco Transport Controller
(CTC) interface.

Manual Set

Step 5 Click the ANP tab to view the following parameters:
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Table 34: ANP Parameters

DescriptionParameter

Displays the name of the site.Name

Displays the unit (slot number) of the passive units in the shelf.Unit ID

Displays the shelf identifier.Shelf ID

Displays the rack number.Rack Number

Identifies the rack position in the shelf.Rack Position

Identifies the slot position in the shelf for the card.Slot Position

Displays the card type.Equipment
Type

Displays the details of the card type.Description

Step 6 Click the Traffic Report tab.

You can view the aggregated demand channel data in the form of the following traffic reports:

Table 35: Traffic Reports

DescriptionTraffic Report

Categorizes each demand type. Each demand is further
categorized into service, trails, and sections.

Demand

Displays the sections under every service.Section

Displays the site name for the optical channel source.Src Site

Displays the rack, shelf ID, and slot identifiers for the source
of the optical channel.

Src Position

Displays the unit name for the optical channel source.Src Card

Displays the site name for the optical channel destination.Dst Site

Displays the rack, shelf ID, and slot identifiers for the
destination of the optical channel.

Dst Position

Displays the unit name for the optical channel destination.Dst Card

Displays the client service type of the demand; for example,
OC-48.

Client Service Type

Displays the protection type of the demandProtection Type

Displays whether the demand is encrypted or not, values
are NA, Yes, No.

Encryption
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DescriptionTraffic Report

Displays the wavelength value of the optical channel, and
the serial number of the wavelength in the wavelength band.

Wavelength

Displays the latency time for the current circuit. This value
includes all the latency components for the circuit, including
fiber and DWDM units on the path.

Max Latency

Step 7 Click the Cabling Report tab.

You can view the patch cord connections related to multi-shelf management. This report is available for the networks
starting from NCS 2000 system Release 12.1.0.

Table 36: Cabling

DescriptionCabling Report

Displays the name of the site.Name

Displays the source unit.Src Unit Type

Displays the rack, shelf, and slot position of the card from
which the patch cord originates.

Src Position

Displays the source unit ID.Src ID

Displays the name of the port.Src Port Label

Displays the type of cable.Cable Type

Displays the source unit.Dst Unit Type

Displays the rack, shelf, and slot position of the card from
which the patch cord terminated.

Dst Position

Displays the destination unit ID.Dst ID

Displays the name of the port.Dst Port Label

Displays whether the connection relates to a present or
forecast circuit.

W/P
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Confidential Banner
Table 37: Feature History

Feature DescriptionRelease InformationFeature Name

This feature indicates the
confidentiality of the reports or
results generated by Cisco ONP for
a network. The CONFIDENTIAL
banner is placed in all the exported
reports. It is placed in the first row
and first cell of the Excel sheet,
followed by a blank row and the
contents of the exported report.

Cisco ONP Release 4.1Confidential Banner

Table 38: Feature History

Feature DescriptionRelease InformationFeature Name

The Confidential Banner string can
be customized as required. An
admin user can modify the banner
string when the
confidentialBanner.enabled field
is set to true in the
feature.properties file.

Cisco ONP Release 4.2Customizable Confidential Banner

The CONFIDENTIAL banner is to be present in all the exported reports. It is placed in the first row, first
cell of the Excel sheet (.xslx), followed by a blank row and the contents of the exported report.

The exported reports include:

• Sites

• Fibers

• Services

• Waves

• Traffic

• Failure (Plan and Restore)

• BOM

• Media Channel

• SRLG

• Messages

• Optical Result

• Failure Group
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• Cabling Report

• Service Aggregation

• IPC (Individual and All sites)

• The CONFIDENTIAL banner is present in all the sheets, if multiple sheets are present in the xlsx file.

• The CONFIDENTIAL banner is updated, only when you export the reports in .xlsx format.

• The server admin can customize the banner string CONFIDENTIAL in the confidentialBanner.content
field as required. The admin must set the confidentialBanner.enabled field to true in the feature.properties
file to enable banner change. By default, the confidentialBanner.enabled value is set to false.

Note
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C H A P T E R 7
Backup and Restore Cisco ONP Database

• Backup Database, on page 133
• Restore Database Using Script, on page 135

Backup Database
Based on the database backup configuration on the server, as set by the system admins, you can take the
backup of the complete database on a daily, weekly, or monthly basis. Only system admins can access the
backup folders and restore them. Backup archive is stored on highly durable NFS share. The following backup
archives are available:

• Archives for the last 7 days

• Weekly archives for the last 4 weeks

• Monthly archives for the last 6 months

You can change the duration for monthly archives.Note

Setup Backup

Before you begin

• Ensure that highly durable 2 TB NFS storage is available to store database archives.

• Ensure that the storage is accessible from the Cisco ONP environment. Set up rules that are defined by
the Cisco ONP network and appropriate ACL (Access Control List) to permit or deny access to the
storage.

Step 1 Log into the Cisco ONP server, where you have installed Cisco ONP by using the tar archive.
Step 2 Create a folder for backup. Ideally it should be mounted on a reliable object storage (like NFS).
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Step 3 Copy restore_mongo.sh from /ONP/images/.

Perform Manual Backup
Perform the following steps for the backup operation:

Step 1 Browse to the location, where the backup_mongo.sh script is stored.
Step 2 Execute the backup_mongo.sh script using the following command:

Example:
user@server:~/cnp_backups$ bash backup_mongo.sh

The backup file gets stored in the daily backup folder (backup.daily) with the current time stamp.

Schedule a Backup

Schedule a Backup Using Script
Use this task to schedule the backup operation using script:

Step 1 Log in to the Cisco ONP server.
Step 2 Execute the rotation.sh script using the following command:

user@server:~/cnp_backups$ bash rotation.sh

This command creates necessary folder structure.

Step 3 Execute the setup_backup.sh script using the following command:

Example:

The backup file gets stored in the daily backup folder (backup.daily) with the current time stamp.

Step 4 Enter the path in the user prompt to store the file.
Backup files are stored in your required file path as following:
/user-defined path/backups/backup.daily

Schedule a Backup
Use this task to schedule the backup operation using Crontab:

Step 1 Log in to the Cisco ONP server.
Step 2 Configure the Crontab job using the following command.

user@server~/cnp_backups$ sudo crontab -e
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Step 3 Modify the Crontab.sh script to schedule the backup.

Example:

The following example shows the scheduling of the backup operation, at 3 a.m daily.
0 3 * * * /home/ciscocnp/cnp_backups/backup_mongo.sh

Syntax to Schedule the Backup Using Crontab
Use the following syntax to schedule backup in Crontab:
m h dom mon dow

Where:

• m—Minutes (0–59)

• h—Hours (1–23)

• dom—Day of the month

• mon—Month of the year

• dow—Day of the week

To define the time, you can provide concrete values for minute (m), hour (h), day of the month (dom), month
(mon), and day of the week (dow), or use the wildcard, '*' in these fields (for 'any').

The backup jobs start based on the cron's system daemon's notion of time and time zones.Note

Restore Database Using Script
You can restore the database using script, which is available at the following location:

Images/DB_backup/restore_mongo.sh

Execute the following command:
$ sudo bash restore_mongo.sh DB backup archive file path.

For example:
$ sudo bash restore_mongo.sh /backups/backup.daily/2019-05-05-23-58.archive

The database backup is created and a confirmation prompt appears asking to delete the database (y/n).

Enter y to delete the database.

Enter n to not delete the database.

Enter No to not delete the database and apply only missing data(s) from backup file.
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A P P E N D I X A
Cisco ONP UI Reference

• Menu Bar, on page 137
• Network Tree, on page 143
• Design Palette, on page 144
• Entity Editor, on page 146

Menu Bar
The following table describes the options available in the Cisco ONP GUI menu bar.

DescriptionOptions

Includes the common file options such as New, Open, Open Shared, Save, Save As, Share,
and Delete

File

Includes Entity Editor, Analyze, and SSON ConvertNetwork

Includes options to export reports of CPZ, sites, fibers, SRLGs, services, waves, media
channels, optical results, service aggregation, BOM, and messages. Export enables you to
download excel and LNI templates

Export

Imports different types of files (CPZ, Excel, LNI, andMPZ) and designs a network in CONPImport

Manages Layout Templates and Optical SourcesManage

Displays logs events that are initiated during a specific period, such as user login, user logout,
password change, and LNI - start, failed, and completed

Logs

Checks and manages tasks running in the backgroundJob Monitor

Manages users, user groups, user roles, permissions, system configuration, and dictionaryControl Panel

Displays the Cisco ONP versionHelp

Shows last date and time when the user logged in to Cisco ONP, and last login with IP detailsLast Login

Shows name of the user who has currently logged in to Cisco ONPUsername

Cisco Optical Network Planner Configuration Guide, Release 4.2
137



File
The File menu includes common file options such as New, Open, and Delete.

DescriptionOptions

Creates a new network. You can check the SSON Network check box and select System
Release for NCS 2K to create an SSON network.

New

Opens a saved network. The network name in blue-colored font indicates that the network is
in the Design mode, and the network name in green-colored font indicates that the network
is in the Analyze mode.

If you view a blank screen when you open a network, refresh the browser, or log
in to Cisco ONP again.

Note

Open

Opens a shared network.Open Shared

Saves a network.Save

Saves the network with a new name.Save As

Shares a network or networks.Share

Deletes a network or networks.Delete

Network
The Network menu includes options such as Entity Editor, Analyze, and SSON Convert in the design mode.
It includes options such as Entity Editor, Design, Upgrade, and Enter Plan Mode in the Analyze mode.

DescriptionOptions

Use this option to edit various properties of an element in the networkEntity Editor

Analyzes the network after completing the designAnalyze

Converts a Non-SSON network to an SSON networkSSON Convert

Switches fromAnalyze mode to Design, Upgrade, or Release Upgrade modeDesign

Upgrades an existing network that is in the Analyze modeUpgrade

Upgrades the NCS 2K System Release of a networkRelease
Upgrade

Switches to the Plan modeEnter Plan
Mode

Exits the plan modeExit Plan Mode

Restores failed fibers and nodesRestore
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Export
The Export menu includes options to export reports of Sites, Fibers, Services, SRLG, Waves, Messages, and
BOM.

DescriptionOptions

Export the .cpz design file of a network into your local system.CPZ

Exports site details such as x and y coordinates, grooming site flag, CLLI
code, site address, site type, and site name.

Sites

Exports fiber details such as length, loss to fiber, source and destination site,
source and destination edge.

Fibers

Exports service details such as name, type, path, quantity, and protection.Services

Exports details about created SRLGs.SRLGs

Exports wave details such as Label, Source and Destination sites, Card Type,
Wavelength, Utilization, Source port, Destination port, Demands, OTNHops,
OSNR, OSNRMarginEOL, StatusEOL, Excluded Channels, and Path of
Wave.

Waves (Available for
non-SSON network)

Exports media channel details such as Media Channel Label, Media Carrier
Label, Source and Destination sites, Card Type, Wavelength, Utilization,
Source port, Destination port, Demands, OTN Hops, OSNR,
OSNRMarginEOL, StatusEOL, Excluded Channels, and Path of Media
channel.

Media Channels (Available
for SSON network)

Shows the complete log of the analysis, including critical errors.Messages

Download sample Excel file that can be used as a reference for creating
networks using the Import Excel feature.

Excel Template

Download sample LNI file that can be used as a reference for creating networks
using the Import feature.

LNI Template

Exports details about pricing and quantity of the network equipmentBOMs

This option is available only in the plan mode. You can add failed fibers to a
failure group.

Failure Groups

This option is available only in the plan mode. It shows the failed fibers, total
channels, failed channels, restored channels, and fiber hotzones.

Failure Report

Exports details such as protection type, SOL, EOL, source, and destinationOptical Result

Import
The Import menu imports an Excel file, a CPZ file, or an MPZ file.
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DescriptionOptions

Imports the .cpz network design files that are exported from another Cisco ONP instanceCPZ

Imports an Excel file containing all the design parametersExcel

Imports a live deployed network by retrieving configurations of the nodes, provided in the LNI
input Excel sheet

Live

Imports the .mpz network design files from CTP to Cisco ONP, to avoid recreating the networks
that are already created in CTP

MPZ

Manage
You can manage layout templates and optical sources.

DescriptionOptions

Imports reusable templates to design layout configurations for a networkLayout
Templates

Imports an optical source from your local systemOptical Sources

Logs
The System Logs option allows an admin user, or user with USER MANAGEMENT, and NETWORK
MANAGEMENT permissions to view at logs the events that are initiated during a specific time interval.
Examples of events are user login, user logout, password change, Live Network Import (LNI)-start, failed,
completed and analysis-start, and failed.

The SYSTEM LOGS page includes the following fields:

DescriptionField

Provides the date and time of the specific eventTime Stamp

Shows the type of event, which includes user login, user logout, password change, and so
on

Event Type

Describes the event, which includes user login success, user logout success, and so onDescription

Shows the user who has initiated specific eventsUsername

Shows the IP address of the device from where the event is initiatedEvent Source

Events that are captured in the System Logs are:

DescriptionEvent

New user sign-up for Cisco ONPSIGNUP

User log in to Cisco ONPLOGIN
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DescriptionEvent

User state change from Active to Inactive and the converseUSER STATE CHANGE

User role change, such as admin to planner, and so onUSER ROLE CHANGE

User log out from Cisco ONPLOGOUT

Deletion of a particular userUSER DELETION

User enters invalid login credentialsUNAUTHORIZED

Successful initiation of Live Network ImportLNI_START

Successful completion of live import of a networkLNI_COMPLETE

Cancellation of Live Network ImportLNI_CANCEL

Imported Live network data is successfully purgedLNI_PURGE

Analysis of LNI network started successfullyANALYZE_LNI_START

Analysis of LNI network completed successfullyANALYZE_LNI_END

Populating of L0 DesignData initiatedLNI_POPULATE_DESIGN_DATA

Starting of the network analysisANALYZE START

Completion of the network analysisANALYZE END

Cancellation of the network analysisANALYZE CANCEL

Entering the Upgrade modeUPGRADE NETWORK

Entering the Plan modePLAN_INIT

Exiting the Plan modePLAN_END

Checking for alternate paths to restore failed media channels or wavesPLAN_REROUTE

Restoration of failed media channels or waves in progressPLAN_PROGRESS

Upgrading the system release of the network is in progress.RELEASE_UPGRADE_NETWORK

Job Monitor
The Job Monitor menu checks and manages tasks running in the background.

You can access this menu if you have ADMIN, NETWORK_MANAGEMENT, or NETWORK_PLANNING
role.

The JOB MONITOR page has the following options:

DescriptionOptions

Refreshes the display information.Refresh
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DescriptionOptions

Applies one or more of the following filter options:

Task Type: Filters the display information based on the task type.

Select Start Date: Filters the display information based on the start date of the task.

Select End Date: Filters the display information based on the end date of the task.

Username: Filters the display information based on the username.

Filter

The date on which the task is started by the user.Created Date

Name of the network on which the task is running.Network
Name

The type of background task: Valid values are ANALYZE and EPNM_IMPORT.Task Type

The current state of the task.Messages

Enables you to cancel or stop an ongoing background task:

• The Admin can cancel any of the running background tasks. Other valid users can
cancel only their own tasks.

• If you want to cancel your ongoing network analysis, you can open Cisco ONP at the
browser in incognito mode, or contact the Admin.

• After a task is cancelled, it gets removed from the job monitor. You can check the status
of a cancelled task from System logs page. Click Logs to open the System logs page.

Cancel

Enables you to view the status of the LNI operation.Check
Progress

Control Panel
Apart from designing, analyzing, and creating BOM for a network, a user with admin rights can activate,
manage, and delete users and their roles.

To navigate to the control panel page, click Control Panel.

The admin or any user with USER_MANAGEMENT role can lock, unlock an individual user account, and
manually expire the individual user password. For more information, see Manage Users and Roles, on page
9.

Help
This menu provides information about the Cisco ONP version.

DescriptionField

Provides the Cisco ONP version.About
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Network Tree
The left pane of the Cisco ONP home page comprises a network tree. The network tree includes various
network elements. When you click each element, the respective property is displayed under the network tree.
You can edit the properties. For more information on editing the network properties, see Modify Network
Properties, on page 69.

Table 39: Network Tree Elements

DescriptionNetwork Tree Elements

Displays the name of the network.Network name

Customer premise equipment that is located in a rack
within a building.

Sites

Optical fiber connecting two sites.Fiber

A fiber couple consists of two different fibers
(clockwise and counterclockwise), one for
transmission and another for reception.

Fiber Couple

Service is the circuit through which traffic flows
between nodes.

When you add services to the Traffic site (of the type
1K-2K-4K) in an SSON network, a DefaultGroup is
created under the Services in the network tree. You
can also create a new service group.

Services

The wave or Media channel represents a DWDM
channel. In a wave hierarchy, for each wave, there is
a trail. When you expand a trail, there is a section
under each trail. The trail is an optical path or a
network section joining two traffic nodes. It can have
more than one section depending on whether the trail
has a regenerator site. For more information on
regeneration, see Regeneration Support, on page 110.

Waves or Medial Channel

Shared Risk Link Group (SRLG) is useful for routing
the protected services. If there are Fiber 1 and Fiber
2 in the network, they are assumed to be diverse and
are used as alternates for protection purposes. If Fiber
1 and Fiber 2 are in an SRLG, they are not true
alternates, and they share the same risk of failure.
Therefore, if Fiber1 fails, Fiber 2 also fails, and Fiber
2 cannot be used as a protected path.

SRLG

Cisco Optical Network Planner Configuration Guide, Release 4.2
143

Cisco ONP UI Reference
Network Tree



DescriptionNetwork Tree Elements

An optical subnet is a collection of spans with certain
associated properties.When you create a new network,
Cisco ONP automatically creates an optical subnet
that is associated to the network. At least one optical
subnet must exist for each network.

Optical subnet

Visible only in the Analyze mode.Stage button

Use the Search box on top of the network tree to search for any specific site, fiber, or wave in the network
tree panel. Click the Refresh icon to refresh your search.

Design Palette
Table 40: Feature History

Feature DescriptionRelease
Information

Feature Name

The new intuitive map display allows you to virtually rearrange
networks for a clutter-free view without impacting the original design.
This display simplifies adding new nodes to complex networks. Save
the last modified network in the new view to retain the latest
rearrangement. The new icons in the Design Palette that enable the
intuitive display are:

• Switch to Intuitive Arrangement/Switch to Coordinates
Arrangement—Toggles the map between the intuitive and
original displays.

• Rearrange nodes—Overrides node coordinates and rearranges
the map in a presentable manner.

Cisco ONP
Release 5.2

Intuitive Map
Display

At the right of the Cisco ONP home page, there is the design palette. You can use this design palette to create
a network design. It consists of the following six icons:

DescriptionIcons

Click this icon to magnify the map.Zoom In

Click this icon to minimize the map.Zoom Out

Click this icon to reset the map to its original size.Reset Zoom
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DescriptionIcons

The Drawing Tool consists of the following icons:

• Traffic Site: Select this icon, and click the working area to create traffic sites
in the network.

• ROADM Site: Select this icon, and click the working area to create ROADM
sites.

• OLA Site: Select this icon, and click the working area to create OLA sites.

• Passthrough Site: Select this icon, and click the working area to create
passthrough sites.

• Link: Click this icon, and drag and drop between sites to create a fiber link.

• OTN Service: Click this icon to create OTN service between sites.

• DWDM channel: Click this icon to add a wave or medial channel between sites.

• Select: The Select icon looks similar to the cursor tool. Click this icon to select
a node, link service, and so on.

Drawing Tool

Use this icon to view or hide layers such as fiber link, service, text, and channel. The
following are the four toggle icons:

• Toggle Fiber: Click this icon to view or hide fiber link details from the network.

• Toggle Service: Click this icon to view or hide service details from the network.

• Toggle Wave: Click this icon to view or hide the channel or wave details from
the network.

• Toggle Text: Click this icon to view or hide the text from the network.

• Toggle SVO associations: Click this icon to remove or add SVO associations.

• Expand/Collapse All Demands: Click this icon to expand the waves or media
channels so that you can view them clearly. Click this icon again to collapse the
waves and media channels to their original shape and position.

The eye symbol in the icon indicates that you are currently viewing the respective
details.

Layers Window

The icon below the Drawing Tool is the Zoom Tool. You can change the display
of the working area by using this function. Click the arrow to view two sliders.

• Map Fade: Move the Map Fade slider from right to left to fade the map from
the background.

• Zoom In/Out: To magnify the map, move the Zoom in or out slider from left
to right.

Zoom Tool
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DescriptionIcons

Click the Zoom Elements icon to view four sliders.

• Media Channel Width: Move this slider from left to right to increase the channel
width.

• Path Spread: Move this slider from left to right to increase the space between
the paths.

• Fiber Width: Move this slider from left to right to increase the fiber width.

• Service Width: Move this slider from left to right to increase the service width.

Zoom Elements

This icon shows the failed media channels in the map. Failed ones are marked with
a red cross mark.

Show Failed
(available only in plan
mode)

This icon shows the total number of impacted media channels, demands, or services
that are working or failed in the entire network.

Traffic Monitor
(available only in plan
mode)

Entity Editor
The Entity Editor allows you to edit various properties of an element in the network. Choose Network >
Entity Editor to open the Entity Editor window. The following table explains the operations that you can
perform in the Entity Editor window.

DescriptionOptions

Includes check boxes to filter the network elements
displayed under each tab:

• For the SITE tab, you can choose whether to
display OTN (only traffic node), DWDM
(ROADM,OLA, or pass-through) node, or both.

• For the FIBER tab, you can choose the fiber
connecting a particular source and destination
sites.

• For the SERVICE tab, you can choose to display
either services, waves, or both.

Left pane filter

Displays all properties of the selected network
element. You can modify the properties as required.

Right pane properties

Searches for a particular network element.Search

Refreshes the network elements that are listed under
each tab.

Refresh
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DescriptionOptions

Expands or collapses the network elements available
in the network tree under each tab.

Expand/Collapse

Use this option to make a similar selection. For
example, select a ROADM site, and click the Select
Similar icon. All ROADM sites get selected.

You can change a property in all the selected sites at
one time.

Allows you to identify and compare the property
difference. For example, if a property is different
among the selected sites, that property is dimmed.
You can select an option that is applied to all the
selections.

Select Similar

Deselects all selections that you make under the
network tree.

Un-Select All

Deletes the selected network elements.Delete

Contentionless functionality on a site refers to the
contentionless add/drop ability of an N-degree
ROADMnode to accommodate Nwavelengths of the
same frequency from a single add/drop device. For a
ROADM to be contentionless, the number of drop
units have to be equal to ROADM degrees.

• Click the ROADM site to which you want to add
contentionless sides.

• Click the Add Contentionless Side icon.

• Enter the appropriate value in theEnter number
of contentionless sides field.

• Click OK.

After adding the contentionless side, you can edit the
contentionless port property of the side at the right
pane. You can select any of the values ranging from
1 to16. The default value is 16.

Add Contentionless Sides (available only under the
SITE tab)
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DescriptionOptions

Use this option to clone a service or wave that is
connected between two sites.

• Select a wave and click Copy.

• Enter the quantity in theClone Service/DWDM
Channel dialog box, and click OK.

The label of the new wave has –1 appended to the
label of the cloned wave. For example,
Site-2-Site3-1-1 is the label of the new wave that is
created by cloning the wave Site-2-Site3-1. You can
rename the label.

You can also clone a service in a similar way.

Copy (available only under the SERVICE tab)
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A P P E N D I X B
Supported Cards and Pluggables

• Supported Transponder Cards and Pluggables, on page 149

Supported Transponder Cards and Pluggables
Table 41: Feature History

Feature DescriptionRelease InformationFeature Name

QSFP-100G-FR-S= pluggable is
supported on the QSFP ports of the
400G-XPLC transponder cardwith
100GE data rate.

Cisco ONP Release 4.1Pluggable Support

Cisco ONP supports the following transponders and pluggable:

Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_200G

NoYes (only
for
100GE)

• SR-1(CPAK-100G-SR10)

• SR-1(CPAK-100G-SR4)

• LR-1(CPAK-100G-LR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

SD-FEC_20• 100GE

• OTU4

200G-CK-LC
+ MR-MXP
(200G MXP
mode)

Auto,
TRK_100G

YesYes• SR-1(CPAK-100G-SR10)

• SR-1(CPAK-100G-SR4

• LR-1(CPAK-100G-LR4)

SD-FEC_20100GE200G-CK-LC
+ MR-MXP
(100G TXP
mode)

Auto,
TRK_100G

YesYes• SR-1(CPAK-100G-SR10)

• SR-1(CPAK-100G-SR4

• LR-1(CPAK-100G-LR4)

SD-EFEC100GE200G-CK-LC
+ MR-MXP
(100G TXP
mode)
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_100G

YesYes• SR-1(CPAK-100G-SR10)

• SR-1(CPAK-100G-SR4

• LR-1(CPAK-100G-LR4)

SD-FEC100GE200G-CK-LC
+ MR-MXP
(100G TXP
mode)

Auto,
TRK_100G

YesYes• LR-1(ONS-QSFP-4*10G-MLR)

• LR-1(QSFP-4*10G-MLR)

• SR-1(QSFP-40G-SR4)

• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

SD-FEC_20• 10GE

• 10GE
LAN
PHY

• OC192

• OTU2

200G-CK-LC
+ MR-MXP
(100G MXP
mode)

Auto,
TRK_100G

YesYes• LR-1(ONS-QSFP-4*10G-MLR)

• LR-1(QSFP-4*10G-MLR)

• SR-1(QSFP-40G-SR4)

• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

SD-EFEC• 10GE

• 10GE
LAN
PHY

• OC192

• OTU2

200G-CK-LC
+ MR-MXP
(100G MXP
mode)

Auto,
TRK_100G

YesYes• LR-1(ONS-QSFP-4*10G-MLR)

• LR-1(QSFP-4*10G-MLR)

• SR-1(QSFP-40G-SR4)

• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

SD-FEC• 10GE
LAN
PHY

• 10GE

• OC192

• OTU2

200G-CK-LC
+ MR-MXP
(100G MXP
mode)
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_100G

YesYes• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• LR-1(QSFP-40G-LR4)

• DWDM(ONS-SC+-10GEPxx.x)

• SR-1(QSFP-40G-SR4)

• SR-1(QSFP-40G-SR-BD)

SD-FEC_20• 10GE

• 10GE
LAN
PHY

• 40GE

200G-CK-LC
+ MR-MXP
(100G MXP
mode 2*10G
2*40G
MODE)

Auto,
TRK_100G

YesYes• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• SR-1(QSFP-40G-SR4)

• LR-1(QSFP-40G-LR4)

• SR-1(QSFP-40G-SR-BD)

SD-EFEC• 10GE

• 40GE

200G -
CK-LC +
MR - MXP
(100G MXP
mode 2*10G
2*40G
MODE)

Auto,
TRK_100G

YesYes• SR-1(ONS-SC+10G-SR)

• LR-1(ONS-SC+10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• SR-1(QSFP-40G-SR4)

• LR-1(QSFP-40G-LR4)

• SR-1(QSFP-40G-SR-BD)

SD-FEC• 10GE

• 40GE

200G -
CK-LC +
MR -MXP
(100G MXP
mode 2*10G
2*40G
MODE)

Auto,
TRK_100G

NoYes for
OTU2e

• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR (ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

SD-
FEC_20

• 10GE

• OC192

• OTU2

• OTU2e

200G -
CK-LC
+10x10G
-LC
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_100G

NoYes for
OTU2e

• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER (ONS-SC+-10G-ER)

• ZR (ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

SD-EFEC• 10GE

• OC192

• OTU2

• OTU2e

200G -
CK-LC
+10x10G
-LC

Auto,
TRK_100G

NoYes for
OTU2e

• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

SD-FEC• 10GE

• OC192

• OTU2

• OTU2e

200G-CK-LC
+ 10x10G
-LC

Auto,
TRK_200G

NoYes for
100GE
and
OTU2

• SR-1(CPAK-100G-SR10)

• SR-1(CPAK-100G-SR4)

• LR-1(CPAK-100G-LR4)

• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

SD-
FEC_20

• 100GE

• 10GE

• OC192

• OTU2

200G -
CK-LC +
MR-MXP
(200G Mxp
100G+10*10G
Mode)
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_200G

YesYes• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• SR-1(QSFP-40G-SR4)

• LR-1(QSFP-40G-LR4)

• SR-1(QSFP-40G-SR-BD)

SD-
FEC_20

• 10GE

• 10GE
LAN
PHY

• 40GE

200G-CK-LC
+ MR-MXP
+ MR-MXP
(200G Mxp
4*40G +
4*10G
Mode)

Auto,
TRK_200G

YesYes• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

• LR-1(ONS-QSFP-4*10G-MLR)

• ZR(ONS-SC+-10G-ZR)

SD-
FEC_20

• 10GE

• OC192

• OTU2

200G-CK-LC
+ 10x10G
-LC +
MR-MXP

Auto,
TRK_200G

YesYes• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

• LR-1(ONS-QSFP-4*10G-MLR)

• ZR(ONS-SC+-10G-ZR)

SD-FEC_20• 10GE

• OC192

• OTU2

200G-CK-LC
+ MR-MXP
+ MR-MXP
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

Auto,
TRK_100G

NoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

EFEC,
SD-FEC_20

• 10GE

• OC192

100GS -
CK-LC +
10x10G-LC

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

FEC• 10GE

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G - LC-C
+
10x10G-LC

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER (ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

EFEC• 10GE

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G - LC-C
+
10x10G-LC
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER (ONS-SC+-10G-ER)

• ZR (ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

HG-FEC• 10GE

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G - LC-C
+
10x10G-LC

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

FEC• 10GE

• 10GE
LAN
PHY

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G - CK-
LC-C +
10x10G-LC
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

EFEC• 10GE

• 10GE
LAN
PHY

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G
-CK-LC-C +
10x10G-LC

AutoNoNo• SR-1(ONS-SC+-10G-SR)

• LR-1(ONS-SC+-10G-LR)

• DWDM(ONS-SC+-10G-C)

• DWDM(ONS-SC+-10GEPxx.x)

• ER(ONS-SC+-10G-ER)

• ZR(ONS-SC+-10G-ZR)

• DWDM(ONS-SC+-10G-xx.x)

HG-FEC• 10GE

• 10GE
LAN
PHY

• OC192

• Fiber
Channel
10G

• Fiber
Channel
8G

• OTU2

• OTU2e

100G -
CK-LC-C +
10x10G-LC
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

TRK_100G,
TRK_200G

YesYes• SR-1(QSFP-100G-SR4-S)

• LR-1(QSFP-100G-LR4-S)

• LR-1(QSFP-28-LR4)

• SR-1(QSFP-100G-SM-SR)

• SR-1(QSFP-40/100G-SRBD)

• LR-1(ONS-QSFP-4*10G-MLR)

• LR-1(QSFP-4*10G-LR)

• SR-1(QSFP-40G-SR4)

• ER(ONS-QSFP-4*10G-MER)

• LR-1(QSFP-40G-LR4)

SR-1(QSFP-40G-SR-BD

• LR-1(ONS-QC16GFC-LW)

• LR-1(ONS-QC16GFC-SW)

• LR-1(ONS-QSFP28-LR4)

• FR-1 (QSFP-100G-FR-S)
(only for 100GE)

SD-FEC_25-
NO_DE

• 100GE

• 10GE
LAN
PHY

• 10GE

• 40GE

• Fiber
Channel
10G

• Fiber
Channel
16G

• Fiber
Channel
8G

• OC192
/STM64

• OTU2

• OTU2e

• OTU4

400G-XP-LC
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

TRK_100G,
TRK_200G

YesYes• SR-1(QSFP-100G-SR4-S)

• LR-1(QSFP-100G-LR4-S)

• LR-1(QSFP-28-LR4)

• SR-1(QSFP-100G-SM-SR)

• SR-1
(QSFP-40/100G-SRBD)

• LR-1(ONS-QSFP-4*10G-MLR)

• LR-1(QSFP-4*10G-LR)

• SR-1(QSFP-40G-SR4)

• ER(ONS-QSFP-4*10G-MER)

• LR-1(QSFP-40G-LR4)

• SR-1(QSFP-40G-SR-BD

• LR-1(ONS-QC16GFC-LW)

• LR-1(ONS-QC16GFC-SW)

• LR-1(ONS-QSFP28-LR4)

• FR-1 (QSFP-100G-FR-S)
(only for 100GE)

SD-FEC_15
-NO_DE

• 100GE

• 10GE
LAN
PHY

• 10GE

• 40GE

• Fiber
Channel
10G

• Fiber
Channel
16G

• Fiber
Channel
8G

• OC192
/STM64

• OTU2

• OTU2e

• OTU4

400G-XP-LC

AutoNoNoSR-1(CPAK-100G-SR10)FEC• 100GE

• OTU4

100G-LC-C

AutoNoNoSR-1(CPAK-100G-SR10)EFEC• 100GE

• OTU4

100G-LC-C

AutoNoNoSR-1(CPAK-100G-SR10)HGFEC• 100GE

• OTU4

100G-LC-C

AutoNoNo• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

FEC• 100GE

• 40GE

• OTU4

100G -
CK-LC-C
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Trunk
Mode

Encryption
Non-SSON

Encryption
SSON

Pluggables SupportedFEC modeTraffic TypeTransponder/
Muxponder

AutoNoNo• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

EFEC• 100GE

• 40GE

• OTU4

100G -
CK-LC-C

AutoNoNo• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

HGFEC• 100GE

• 40GE

• OTU4

100G -
CK-LC-C

Auto,
TRK_100G

NoYesSR-1(CPAK-100G-SR10)FEC100GE100GS -
CK-LC

Auto,
TRK_100G

NoYEsLR-1(CPAK-100G-LR4)EFEC100GE100GS -
CK-LC

Auto,
TRK_100G

NoYesSR-1(CPAK-100G-SR10)SD-FEC_20100GE100GS -
CK-LC

Auto,
TRK_100G

NoYes (for
100GE)

• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

FEC• 100GE

• OTU4

200G -
CK-LC
(100G Mode
only)

Auto,
TRK_100G

NoYes (for
100GE)

• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

EFEC• 100GE

• OTU4

200G -
CK-LC
(100G Mode
only)

Auto,
TRK_100G

NoYes (for
100GE)

• SR-1(CPAK-100G-SR4)

• SR-1(CPAK-100G-SR10)

• LR-1(CPAK-100G-LR4)

SD-FEC_20• 100GE

• OTU4

200G-CK-LC
(100G Mode
only)
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A P P E N D I X C
Supported Optical Sources

• Supported Optical Sources, on page 161

Supported Optical Sources
Table 42: Feature History

Feature DescriptionRelease InformationFeature Name

Optical Sources enable you to simulate the optical
feasibility of the network with the 400G and other
interfaces that are not natively modeled in Cisco ONP.
The following Optical Sources are introduced in this
release:

• ONS-CFP2D-400G-C-OpticalSources-V 2.mxd

• QDD-400G-ZRP-S-OpticalSources-V2.mxd

Cisco ONP Release 4.2New Optical Source and
Pluggable Support

Cisco ONP supports the following optical sources:

• OpticalSources_NCS2K_400GXP-LC_NCS4K-4H-OPW-QC2 DWDM Line Card

• 400GXP_100G_25%_DE

• 400GXP_200G_15%_DE

• 100G-SD-FEC

• 400GXP_100G_15%_DE

• 200G-SD-FEC

• 400GXP_100G_15%

• 400GXP_200G_15%

• 400GXP_200G_25%DE

• NCS1004_OpticalSources_V3

• NCS1004_QPSK_SP_16QAM_200G_27%SDFEC_60GBd
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• NCS1004_SP_16QAM_300G_27%SDFEC_69GBd

• NCS1004_QPSK_200G_27%SDFEC_69GBd

• NCS1004_16QAM_32QAM_400G_27%SDFEC_62GBd

• NCS1004_16QAM_400G_27%SDFEC_69GBd

• NCS1004_SP_16QAM_16QAM_300G_27%SDFEC_60GBd

• NCS1004_32QAM_500G_27%SDFEC_69GBd

• QDD and CFP2-DCO variants

• ONS-CFP2D-400G-C-OpticalSources-V2.mxd
1

• CFP2_200OR_TXP_FOIC2_OFEC_15_DE_ON_4Q_1S_BR63_1

• CFP2_300OR_TXP_FOIC3_OFEC_15_DE_ON_8Q_1S_BR63_1

• CFP2_400OR_TXP_FOIC4_OFEC_15_DE_ON_16Q_1S_BR63_1

• ONS-CFP2D-400G-C-OpticalSources-V2.mxd
2

• CFP2_300ZR+_MXP_GAUI8_OFEC_15_DE_ON_8Q_0S_BR60_1

• CFP2_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_8Q_1E_BR40_1

• CFP2_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_16Q_1E_BR30_1

• CFP2_400ZR_TXP_GAUI8_CFEC_15_DE_ON_16Q_0S_BR59_8

• CFP2_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_4Q_0S_BR60_1

• CFP2_100ZR+_TXP_GAUI2_OFEC_15_DE_ON_4Q_1S_BR30_1

• CFP2_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_4Q_1S_BR60_1

• CFP2_400ZR+_TXP_GAUI8_OFEC_15_DE_ON_16Q_1E_BR60_1

• CFP2_300ZR+_MXP_GAUI8_OFEC_15_DE_ON_8Q_1E_BR60_1

• CFP2_400ZR+_TXP_GAUI8_OFEC_15_DE_ON_16Q_0S_BR60_1

• CFP2_100OR_TXP_FOIC1_OFEC_15_DE_ON_4Q_1S_BR31_6

• CFP2_200OR_TXP_FOIC2_OFEC_15_DE_ON_8Q_1S_BR42_1

• CFP2_200OR_TXP_FOIC2_OFEC_15_DE_ON_16Q_1E_BR31_6

• QDD-400G-ZRP-S-OpticalSources-V2.mxd
2

• QDD_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_4Q_1S_BR60_1

• QDD_400ZR_TXP_GAUI8_CFEC_15_DE_ON_16Q_0S_BR59_8

• QDD_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_4Q_0S_BR60_1

• QDD_400ZR+_TXP_GAUI8_OFEC_15_DE_ON_16Q_1E_BR60_1

1 The optical source interfaces are supported for SSON networks.
2 The optical source interfaces are supported for SSON and non-SSON networks.
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• QDD_400ZR+_TXP_GAUI8_OFEC_15_DE_ON_16Q_0S_BR60_1

• QDD_300ZR+_MXP_GAUI8_OFEC_15_DE_ON_8Q_1E_BR60_1

• QDD_400ZR+_TXP_GAUI8_OFEC_15_DE_ON_16Q_0E_BR60_1

• QDD_300ZR+_MXP_GAUI8_OFEC_15_DE_ON_8Q_0E_BR60_1

• QDD_100ZR+_TXP_GAUI2_OFEC_15_DE_ON_4Q_1S_BR30_1

• QDD_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_16Q_1E_BR30_1

• QDD_300ZR+_MXP_GAUI8_OFEC_15_DE_ON_8Q_0S_BR60_1

• QDD_200ZR+_MXP_GAUI2_OFEC_15_DE_ON_8Q_1E_BR40_1

NCS 1004 is supported as an optical source.Note

The following optical source files are not supported in NCS 2000 Release 11.0:

• NCS1004_16QAM_32QAM_400G_27%SDFEC_62GBd

• NCS1004_QPSK_SP_16QAM_200G_27%SDFEC_60GB

Hence, we recommend you to upgrade the system release of the network to Release 11.1, or force the optical
source files that are supported for the Release 11.0.

Note
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A P P E N D I X D
Supported Amplifiers

• Supported Amplifiers, on page 165

Supported Amplifiers
Cisco ONP supports the following amplifiers:

Table 43: Cisco ONP Supported NCS 2000 Amplifiers

DescriptionAmplifier

Raman Amp C-Band15454-M-RAMAN-CTP

Raman Amp C-Band15454-M-RAMAN-COP

Erbium Doped Fiber Amplifier (EDFA) that can function in dual gain with
maximum gain of 35 dB

EDFA 35 for OLA node

21dBm EDFA + Bst 26dB Span - C-BandNCS2K-EDRA2-26C

21dBm EDFA 26dB Span - C-BandNCS2K-EDRA1-26C

21dBm EDFA + Bst 35dB Span - C-BandNCS2K-EDRA2-35C

21dBm EDFA35dB Span - C-BandNCS2K-EDRA1-35C

• RAMAN-CTP is supported on all nodes.

• EDRAs are supported on the OLA node.

• For ROADM and Traffic nodes, the booster amplifier and preamplifier are in-built. The booster is
20SMR-FS-BST.

Note
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A P P E N D I X E
Troubleshoot

• Troubleshooting Tasks, on page 167

Troubleshooting Tasks
The following table describes the common error messages that are related to Cisco ONP configuration and
the workarounds:

Table 44: Troubleshooting Tasks for Cisco ONP Configuration

WorkaroundProbable Reason for the ErrorWarning Message or Error

Check and add the required number
of contentionless sides on the target
service or wave source and
destination sites.

Required contentionless sides are
not created on add/drop sites. For
protected service or wave, minimum
two contentionless sides are
required on the add/drop sites.

Cannot Route demand. Did not
find any valid omnidirectional
side.

For linear topology, change the
demand protection to unprotected.

For ring topology, ensure that at
least two nodes and fiber-disjoint
paths are available and the forced
wavelength is unconfined in the
end-to-end path.

Force the required number of
colorless ports.

Disjoint path is not available for
protected demand.

Or

Forced wavelength may be already
used for other demand in the same
path.

Or

The number of colorless demands
created is more than the colorless
ports forced on the interfaces.

Error: No valid path from
<source> to <destination>

For linear topology, change the
demand protection to unprotected.

For ring topology, ensure that at
least two nodes and fiber-disjoint
paths are available and the forced
wavelength is unconfined in the
end-to-end path.

Disjoint path is not available for
protected demand.

Or

Forced wavelength may be already
used for other demands in the same
path.

Error: Traffic subnet constraints
prevent routing of section.
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WorkaroundProbable Reason for the ErrorWarning Message or Error

If the Cascaded SMR flag is
enabled, create only contentionless
demands on those nodes. Else,
reduce the number of contentionless
sides, colorless ports, or colored
demands that are created, to get
successful network analysis.

The number of contentionless sides,
colorless ports that are forced, and
colored demand exceed SMR-20
port capacity.

Or

The Cascaded SMR flag is enabled,
and colored or colorless demand is
created.

Error: The sum of CoDem and
Non-CoDem colorless ports and
ports that are used for
Omnidirectional and Contentional
sides cannot exceed 20 when the
TYPE is SMR-20.

Change the fiber type to the one that
is supported by Cisco ONP.

The fiber connecting these sides is
not supported by Cisco ONP.

Couple between<source>.<side>
and <destination>.<side> is of
invalid type.

Connect the fiber to the nodes in the
ring network.

Any of the sites are connected to the
fiber in the Ring/Linear network.

Unconnected nodes or sites are
present in the network.

Force the correct path on the
Wave/Media Channel.

Wrong path has been forced on the
wave or media channel.

Unfeasible forcing

Clear the contents of mongodb_cnp
folder before running the restore
command: rm -rf
/var/lib/mongodb_cnp/*cannot

Restore database script attempts to
write data in the mongo database,
but the data with the same index is
already present.

E11000 duplicate key error
collection: CnpDB.dbchangelog
index: _id_ dup key: { :
ObjectId('') }

Unlock the mentioned entity or
unlock the complete site.

There is an issue with setting up
connection in the lock mode.

Cannot complete mesh
connection.

Check the path and choose the
correct primary path and secondary
path fibers.

Or

Remove all the fibers that are forced
to set the Path of Wave property as
Auto.

Invalid path has been forced.Path constraints prevent routing.

Force the wavelength as per optical
subnet rule or change the optical
subnet rule.

Forced Wavelength is not part of
the Optical subnet rule.

Traffic subnet constraints prevent
routing.

Set the property MF Unit to Auto
and then force the template.

Template is applied when properties
such as ECU, MF Unit are forced.

MF Unit value MF1-RU is not
supported in RPT, so resetting the
value to default for <site name>.
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WorkaroundProbable Reason for the ErrorWarning Message or Error

Modify the Interlever forcing on the
line side to MD-48-CM.

In non-SSON traffic, the ROADM
site with the properties (DEG-8,
SMR-9, number of contentionless
sites is equal to 1) has 96 colored
waves.

The Interlever Type is property
set to Auto or MpoCable.

Please force MD-48-CM as
Interlever Type for {0}.

Delete the extra contentionless
sides.

During upgrade or Release upgrade,
colorless port is forced on SMR-9,
and more than one contentionless
side is added in the imported MPZ
network.

The sum of forced CoDem and
Non-CoDem colorless ports and
colored demands can't be greater
than 9 for type SMR-9.

Check the restoration path. It must
not have any dark fiber.

Plan mode restoration fails because
the presence of dark fiber in the
restoration path makes it difficult to
find it.

No Route Found.

Correct the wave such that the
wavelength is supported by the
optical subnet C-band rule.

Two fibers are occupied by a wave
with the same wavelength.

The fiber belongs to a subnet where
the wavelength is not supported. For
example, a wave with an even
wavelength is forced through a fiber
belonging to the C40 channel or
C48 channel subnet rules.

Wavelength Forced {0} in this
{1} is already in use / not as per
current optical subnet channel
rule.

Before you convert the site type to
traffic, modify the optical source
wave to be feasible.

ROADM sites having waves with
optical source other than 100,
200SDFEC are converted to traffic
sites.

tm.unsupported_client_pluggable.msg
=Incompatible Client Interface
forcing.

Refresh the browser and try again.Slow internet connectivity, or idle
session.

Error Message

Upload proper .MPZ file.The MPZ file that you are trying to
upload does not have a valid file
extension.

Please provide a valid .mpz
network file.

Close MPZ file in the CTP tool
before uploading it to Cisco ONP .

MPZ file remains open in the CTP
tool.

Failed to import mpz file, please
make sure the MPZ file is not in
use and retry.

Restart the Mongo database
container or reinstall the Build.

Failed to connect to Mongo DB on
opening Control Panel tab.

Cannot connect to
Server;(Password).
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WorkaroundProbable Reason for the ErrorWarning Message or Error

Fix the syntax and reapply the
template.

The applied layout template file has
syntax error such as extra SPACE,
TAB, missing symbols such as <,
>.

Null pointer exception

Refresh the browser or log in again
to Cisco ONP.

Intermediate network disconnection.Object not found in cache.

Log in again to Cisco ONP.Idle time-outSession does not exist.

Force another wavelength that is
next to the currently forced one.

Forced wavelength is not a feasible
central wavelength based on the
configuration.

Forced/Locked wavelength is not
feasible for spectrum to be
allocated for the demand/MCH
<Site-1-Site-3-1>. Insufficient
spectrum around the forced central
wavelength.

Make sure that the alternate path has
waves associated with the fiber and
has sufficient bandwidth available.

Insufficient spectral width due to
the following reasons:

• The alternate path has no
waves (dark fiber).

• Optical parameters are not
feasible.

• Wavelength dos not have
sufficient bandwidth.

Route could not be
found/Alternate path not
found/<Optically not feasible>.

Change Evolved Mesh to Off,
reduce Scalable upto degree to 8,
change Site Type to SMR-20, or
Remove contentionless or colorless
forcing.

Check if it is 8 degrees, SMR-9
node with Evolved Mesh ON and
contentionless and colorless/colored
mixed add/drop configuration.

Error: Could not find any valid
flex configuration for the traffic
matrix defined at <Site-1.A> This
could be because of configuration
limitations, invalid forcings, or
equipment restrictions.

• Enable Quick analysis.

• After successful analysis,
check the optical report and
look for the waves that require
regeneration.

• Split the long haul demand
between the intermediate short
distance nodes that are
equivalent to regen site.

• Disable Quick analysis and
analyze.

Check if Quick analysis under
Network property is disabled.

Single hop path Site-1~Site-3
needs regeneration but has no
regenerator hosting sites.
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